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GEM Collection ™ 

& 
GEM DesktopTM Insider's Guide 

Special Offer 

GEM Collection FOR ONLY $99.95! 

The GEM Collection combines the functionality of GEM Paint ™ and 
GEM Write TM. You can develop logos and illustrations with GEM Paint. 
You can use GEM Write to produce your memos and reports. Both 
applications work with the popular GEM Desktop and give you the 
ability to create attractive artwork which you can include in your text 
documents. GEM Collection will be available in June to registered 
GEM Desktop and GEM DrawTM users for only $99.95. If you want your 
picture and the thousand words, GEM Collection is the product for you. 

The GEM Desktop Insider's Guide is a detailed reference manual 
designed for the advanced GEM Desktop user. It contains over 100 
pages of text and illustrations and is available for $14.95. If you want 
to become more familiar with the GEM Desktop, this is the book for 
you. 

The GEM Desktop Insider's Guide and the GEM Collection may be 
ordered by phone with your VISA, MasterCard, or American Express 
card. Just call 800-443-4200 to place your order. Be sure to have 
your card number ready. 

This offer is valid through August 31, 1985. 

Digital Research and its logo are registered trademarks of Digital Research Inc. GEM 
Collection, GEM Desktop, GEM Draw, GEM Paint, and GEM Write are trademarks of 
Digital Research Inc. 
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Dear GEM DeslctopTM Customer: 

Please make note of a special offer we have included in the front 
pages of your GEM Desktop manual. In June you can obtain our new 
product, GEM Collection TM, which gives you the ability to create 
appealing artwork and combine it with text, for only $99.95. You can 
also obtain the GEM Desktop Insider's Guide, a detailed GEM Desktop 
reference manual, for $14.95. For details, see the page labeled "GEM 
Collection & GEM Desktop Insider's Guide Special Offer" located just 
inside the front cover of this manual. 

We'd like to encourage you to fill out the enclosed registration card 
and return it to us in the mail. In this way you'll be sure to receive 
information about new features, GEM Desktop updates, and future 
GEMTM applications. 

We're sure you'll find the GEM Desktop easy to learn and use, and that 
it will increase your productivity. In addition to using GEM 
applications with the GEM Desktop, you can use existing applications 
like Wordstar®, Lotus™ 1-2-3™, and dBASETM III. 

For information on how to order other GEM applications, call our toll­
free number: 800-443-4200. 
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Thank you for your interest in the GEM Desktop. 

Sincerely, 

Digital Research, Inc. 

Copyright © 1985. All rights reserved. Digital Research and its logo are registered 
trademarks of Digital Research Inc. GEM, GEM Col/ection, and GEM Desktop are 
trademarks of Digital Research Inc. We Make Computers Work is a service mark of 
Digital Research Inc. dBASE is a trademark of Ashton-Tate. Lotus and 1-2-3 are 
trademarks of Lotus Development Corp. WordStar is a registered trademark of 
MicroPro International. 

3/85 



[!ill DIGITAL 
RESEARCH® 
We make computers work.'" 

NOTICE TO USER 

From time to time changes are made in the filenames and in the files 
actually included on the distribution disk. This manual should not be 
construed as a representation or warranty that such files or facilities 
exist on the distribution disk or as part of the materials and programs 
distributed. Most distribution disks include a "README.DOC" file. This 
file explains variations from the manual which do constitute 
modification of the manual and items included therewith. Be sure to 
read this file before using the software. 



Notes on the GEM Desktop ™ 

Additional Microsoft ™ Mouse 

In addition to the Microsoft Mouse described in "Preparing Your 
System" (Section 2 of "Getting Started with the GEM Desktop"), you 
can also use a Microsoft Mouse that plugs into one of your computer's 
serial communication ports. 

The first mouse, which plugs into its own interface board, is known as 
the Bus Version of the Microsoft Mouse. The mouse that plugs into 
the serial port is known as the Serial Version. The GEMPREP program 
lets you install the GEM Desktop to work with either kind of mouse. 

Restarting the GEM Desktop from DOS 

If you quit the GEM Deskt0p and then want to restart it, you must first 
type the fo"lIowing command at the DOS prompt (C> or A»: 

CD\ 

This command returns you to the DOS "root directory." 

You can then type GEM to start the GEM Desktop. 

If the GEM Desktop is on floppy disks, make sure you insert the GEM ... 
STARTUP disk into drive A before you type GEM. 

GEMSETUP: Floppy Disk System and Hard Disk System 

The GEMSETUP program is contained on GEM Device Driver Disk # 1. 
If you are running the GEM Desktop from a hard disk, you can still run 
GEMSETUP from a floppy disk drive. Insert GEM Device Driver Disk #1 
into a floppy disk drive, open that drive's floppy disk icon, and then 
open the GEMSETUP.APP application icon. 

If you indicate in GEMSETUP's initial dialog that you are installing for a 
hard disk system, you must still give both "Drive letters" (Hard Disk 
and Floppy Disk) in the dialog that appears next. 
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After typing the Hard Disk Drive letter, you can move the text cursor <I> 
to the space for the Floppy Disk Drive letter by pressing the Tab key. 

End of Release Note 

Copyright © 1985. All rights reserved. Digital Research and its logo are registered 
trademarks of Digital Research Inc. GEM and GEM Desktop are trademarks of Digital 
Research Inc. We Make Computers Work is a service mark of Digital Research Inc. 
Microsoft is a registered trademark of Microsoft Corporation. 
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COPYRIGHT 

Copyright © 1985 Digital Research Inc. All rights reserved. No part of 
this publication may be reproduced, transmitted, transcribed, stored in 
a retrieval system, or translated into any language or computer 
language, in any form or by any means, electronic, mechanical, 
magnetic, optical, chemical, manual, or otherwise, without the prior 
written permission of Digital Research Inc., 60 Garden Court, P.O. Box 
DRI, Monterey, California 93942. 

DISCLAIMER 
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and facilities exist on the distribution disk or as part of the materials 
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do constitute modification of the manual and the items included 
therewith. Be sure to read this file before using the software. 
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Foreword 

INTRODUCTION 

Welcome to the GEM Desktop TMI 

The GEM Desktop from Digital Research® uses specially designed 
Graphics Environment Manager™ software to turn your computer 
screen into an electronic desktop. The GEM Desktop offers a way to 
see and organize work that appeals to both beginning and experienced 
computer users. 

WHO CAN USE THE GEM DESKTOP? 

The GEM Desktop is suited equally for business and home use. 

In the workplace, the GEM Desktop can help you organize the mass of 
information that flows through a typical office. 

At home, the GEM Desktop is an ideal starting point for a family that 
plans to make a computer an integral part of the household. 

If you have been using a computer for a while and have already 
acquired several application programs, you can use them with the GEM 
Desktop. If you are just starting out, you can use application 
programs specially designed for the GEM Desktop. 

WHAT IS DOS? 

"DOS" stands for Disk Operating System. To carry out its tasks, the 
GEM Desktop uses DOS and the underlying GEM™ software. 
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In this guide, DOS refers to any of the following operating systems: 

• PC DOS, version 2.0 or higher 
• MS™-DOS, version 2.0 or higher 
• ConcurreneM DOS, version 3.3 or higher, in DOS mode 

TEXT CONVENTIONS 

This manual employs several conventions involving capitalization. 

On the GEM Desktop and in the text, icon names (like GEMRUN.BAT) 
are capitalized. When naming an icon, you do not need to capitalize; 
the GEM Desktop automatically converts letters to capitals regardless 
of how YOlJ' enter them at the keyboard. 

In the text GEM Desktop messages appear in colored type. Examples 
of responses that you type appear in boldface colored type. The 
names of the GEM Desktop menu commands appear in boldface black 
type. 

Most of the illustrations are pictures of actual GEM Desktop screens 
which were made while the product was in development. For this 
reason, they might differ slightly from what you see on your screen. 

CONTENTS OF THIS MANUAL 

This manual consists of three parts. Part 1, "Getting Started with the 
GEM Desktop,'1 discusses basic topics, your graphics card and mouse, 
and how to set up your system with GEMPREP. It teaches you basic 
GEM Desktop techniques through a tutorial and gives you some tips 
on advanced techniques. 

Part 2, 'IGEM Setup Guide," shows you how to run GEMSETUP, the 
program that tells your GEM software what hardware devices and type 
fonts you want to use. 

Part 3, 'IGEM Output Guide," shows you how to reproduce the charts, 
graphs, and free-form graphic designs you create with your GEM 
applications on a screen, printer, or plotter. 
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Important Note: The table of contents, page numbers, tables, figures, 
and index all use 2-letter codes to help you locate information more 
easily. These codes refer to the three "parts" of the GEM Desktop 
manual as follows: 

GS = Part 1: Getting Started with the GEM Desktop 
SG = Part 2: GEM Setup Guide 
OG = Part 3: GEM Output Guide 

For example, if you see page number GS 3-25, that refers to page 
3-25 in Part 1, "Getting Started with the GEM Desktop." 
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SECTION 1 

Basic Concepts 

INTRODUCTION 

The GEM Desktop combines recognizable symbols and simple menus. 
The symbols represent the familiar features of your office or home 
work space. The menus contain all the commands you'll need. 
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Figure GS 1-1. Traditional Desktop and GEM Desktop 
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Getting Started I ntrod uction 

You organize your work and prepare text and graphics all on the 
electronic GEM Desktop, using the following components: 

• GEM Desktop work area and menu bar 

• icons 
• windows 

The basic GEM Desktop concepts are described briefly in the following 
paragraphs. You'll become more familiar with them as you work 
through the GEM Desktop tutorial (Section 3). 

GEM DESKTOP 

The GEM Desktop is where you organize your work and start your 
application programs. The GEM Desktop has a rectangular work area 
with a menu bar running across the top. 
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GEM Desktop Getting Started 

menu bar window work area 

icons icons 

Figure GS 1-2. GEM Desktop with Icons and Window 

WORK AREA 

The work area is where the GEM Desktop icons and windows appear. 
Like a combination desk and file cabinet, it is both a work surface and 
the place where you organize the pieces of your work. 
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Getting Started Menu Bar 

MENU BAR 

Menus are lists of commands you use to instruct the GEM Desktop to 
take certain actions. Because you use menus, you don't have to 
memorize or type commands. 

The GEM Desktop "drop-down" menus are brief and simple because 
many actions--such as copying or deleting data--take place directly 
on the GEM Desktop work area. 

ICONS 

An icon is a picture of an object. GEM Desktop icons include folders, 
floppy disks, and even a trash can. 

By using icons to represent the materials you work with, the GEM 
Desktop gives you the feeling that you're working with familiar 
materials, not electronic abstractions. 

WINDOWS 

A window shows you what is inside a disk or folder. A window can 
contain folders, documents, and applications. 

like the GEM Desktop work area, a window is a work space. You can 
manipulate the window work space in many ways, including moving it 
on the GEM Desktop and changing its size. 
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Keyboard Keys Getting Started 

KEYBOARD KEYS 

On many keyboards, several keys use symbols on their keycaps to 
indica:te their functions. Figure GS 1-3 identifies the keys and the 
names used in this text. 

Tab Backspace Enter 

Shift Shift 

Figure GS 1-3. Keycap Definitions 

End of Section 1 
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SECTION 2 

Preparing Your System 

INTRODUCTION 

Before you use the GEM Desktop, you must use a program called 
GEMPREP. GEMPREP prepares your hard disk or floppy disks to do the 
following: 

• start the GEM Desktop 
• display GEM graphics on your computer screen 
• use the mouse 

Before you use GEMPREP, read all of this section. 

GEM DISKS 

The GEM Desktop comes with several disks, including the following: 

• GEM SYSTEM MASTER DISK 
• GEM DESKTOP MASTER DISK 
• GEM DEVICE DRIVER DISK # 1 
• GEM DEVICE DRIVER DISK #2 

Note: Before you prepare your system, be sure to make backup copies 
of these disks. To make backup copies, use the DOS DISKCOPY utility 
described in your DOS user's guide. 
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Graphics Card and Mouse Getting Started 

GRAPHICS CARD AND MOUSE 

To use GEM Desktop graphics on your computer screen, yo,u need two 
pieces of hardware: a graphics card and a mouse. 

The GEM Desktop that you received assumes that you already have a 
graphics card and mouse. If you do not have the assumed graphics 
card or mouse, GEMPREP lets you modify your software to match the 
equipment in your system. 

If your system matches the assumed system, you must still run 
GEMPREP to prepare your hard disk or floppy disks. 

USING GEM PREP 

GEMPREP uses three methods to get and give information: 

• query - a question requiring a Ves or No answer 
• instruction - a brief message that tells you to do something 
• menu - a numbered list from which you make a selection 

A query always ends with a prompt of 

YIN 
or 

(YIN)? 
Type V for Ves or N for No. 

A typical instruction is one that tells you to change disks in your 
floppy disk drive. Most instructions end by telling you to do the 
following: 

Strike a key when ready • . . 
Some instructions tell you specifically to press the Enter key. 
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Getting Started Using GEMPREP 

In some instances, the fly IN" or "Strike a key when ready ... " prompt 
might take a couple of seconds to appear. Wait until it does before 
you respond. 

Figure GS 2-1 shows a menu. In your version of GEMPREP, 

<graphics card name> 
is replaced by the name of a graphics card. 

Which graphics card do you have? 

1 <graphics card name> 
2 <graphics card name> 
3 <graphics card name> 
4 <graphics card name> 

Type the number of the graphics card you have. 

Figure GS 2-1. GEMPREP Menu 

To select from a menu, type a number. Note that the menu numbering 
begins with 1. 

STOPPING GEMPREP 

To stop GEMPREP once it has started, press Ctrl (Control) and C at the 
same time. DOS displays the following query: 

Terminate batch job?Y/N_ 
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Stopping GEMPREP Getting Started 

When you type V (Ves), the operating system's A> or C> prompt 
reappears. 

Note: You cannot stop GEMPREP while it is waiting for a response to 
a V IN prompt. To stop GEMPREP, Type V or N first, then 
immediately type Ctrl-C. 

STARTING GEM PREP 

To start GEMPREP, take the following steps: 

1. Start your computer. 
2. Insert the GEM SYSTEM MASTER DISK into drive A. 
3. Type the following command: 

A>GEMPREP 

The words "ECHO OFF" appear briefly on the screen, followed by 
GEMPREP's first message: 

Welcome to GEMPREP! 

Do you want to put the GEM Desktop on a hard disk? 

YIN 

If you type V, GEM PREP places the GEM Desktop on your hard disk. If 
you type N, GEMPREP places the GEM Desktop on noppy disks. 

GEMPREP's queries, instructions, and menus will lead you from this 
point to the conclusion of the- program. The remainder of this section 
describes some of the highlights of GEMPREP. 
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Getting Started Direct to the GEM Desktop? 

DIRECT TO THE GEM DESKTOP? 

For both hard disk and floppy disk systems, GEMPREP gives you the 
following option: 

Do you want to go directly to the GEM Desktop 
each time you start your system? 

YIN 

If you choose to do so, you can always return to DOS from the GEM 
Desktop by choosing the Quit command from the File Menu. 

If you prefer to start each session in DOS, type N. To start the GEM 
Desktop from the DOS prompt, change to the directory where 
GEM.BAT is located and type the following command: 

A>GEM 

ASSUMED GRAPHICS CARD AND MOUSE 

The GEM Desktop you received is already prepared for a particular 
graphics card and mouse. One of GEMPREP's queries identifies the 
graphics card, mouse, and mouse communication port and asks if they 
match your system. 

If you reply that they do, GEM PREP continues preparing your hard disk 
or floppy disks. 
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Assumed Graphics Card and Mouse Getting Started 

If you reply that they do not, GEMPREP displays a series of menus (like 
the one in Figure GS 2-1) to let you identify your graphics card and 
mouse. 

GEMPREP assumes your mouse is connected to communication port 
1/1. If you are not sure which port is which, you can do either of the 
following: 

• You can ask your computer dealer or a systems specialist . 

• You can say the mouse is connected to port 1/1. If the mouse does 
not work when you start the GEM Desktop, restart your system, and 
run GEMPREP again. This time, say the mouse is connected to port 
1/2. 

When you run GEM PREP the second time, disregard any DOS error 
messages concerning directories. 

COPYING DATA 

GEMPREP copies data from the GEM SYSTEM MASTER DISK and GEM 
DESKTOP MASTER DISK to your hard disk or floppy disks. As it copies 
the data, GEMPREP reports its progress to you. Figure GS 2-2 shows 
how your screen might appear as GEMPREP copies data. The lines in 
boldface type are GEMPREP's progress report. 
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Remove the DOS disk from drive A. 
Insert the GEM SYSTEM MASTER DISK into drive A. 
Strike a key when ready • • • 

1 File(s) copied 
1 Filefs) copied 

A:EXAMPLE.SYS 
A:ASSIGN.SYS 

2 File(s) copied 

Figure GS 2-2. Copying Data 

GEM PREP AND A FLOPPY DISK SYSTEM 

When you use GEMPREP to put the GEM Desktop on floppy disks, 
there are a couple of extra steps you need to take. 

First, check the directory of your DOS disk. (Use your backup copy of 
the DOS disk, not the original.) To do this, take the following steps: 

1. Insert your DOS disk into your computer's A drive, and turn on the 
computer. 

2. When the DOS prompt appears, type the following command: 

A>DIR 
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3. look for the following in the DOS disk's directory: 

COMMAND. COM 
FORMAT. COM 
DISKCOPY.COM 
PRINT. COM 

Getting Started 

All of these must be on the DOS disk for you to be able to use the 
GEM Desktop fully. 

Second, you need two floppy disks on which GEMPREP can put the 
GEM Desktop. You can use new disks or disks containing data you no 
longer need. GEM PREP instructs you to give these disks the following 
names: 

• GEM STARTUP 
• GEM DESKTOP 

GEMPREP copies data from the GEM SYSTEM MASTER DISK and GEM 
DESKTOP MASTER DISK to these two disks. When GEMPREP 
terminates, store the two master disks for possible future use. You 
will use the GEM STARTUP and GEM DESKTOP disks as work disks for 
all GEM Desktop sessions. 

Note: The GEM DESKTOP MASTER DISK and the GEM DESKTOP work 
disk have very similar names. It is very important that you remember 
the difference between the names of these· two disks and follow 
GEMPREP's instructions carefully. 
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IF YOU HAVE A MICROSOFT® MOUSE 

If you have a Microsoft Mouse, you must take two additional steps to 
prepare your system. 

First, insert the Microsoft Mouse disk into your computer's drive A. If 
you are running the GEM Desktop from a hard disk, type the following 
command: 

A>COPY MOUSE.COM C:/V 
If you are running the GEM Desktop from floppy disks, insert the GEM 
STARTUP disk into drive B, and type the following command: 

A>COPY MOUSE.COM B:/V 
The second step is required only if you are running the GEM Desktop 
from a hard disk and if you have the kind of Microsoft Mouse that 
plugs into its own special interface board inside your computer. If so, 
turn off your computer, and take the following steps: 

1. Remove the Microsoft Mouse interface board from your computer. 

2. Look at the bottom center of the board, in the position indicated in 
Figure GS 2-3. You will find four sets of double gold-colored pins 
labeled 2, 3, 4, and 5. 

3. Look for a black and gold box-like object (called a "jumper") on one 
of the pins, probably on pin 5. Remove the jumper. 

4. Place the jumper on pin 3. If the jumper is already on pin 3, you 
don't need to move it. 

5. Put the interface board back into your computer. 

Your system is now fully prepared for use with the Microsoft Mouse. 
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Figure GS 2-3. Microsoft Mouse Interface Board 
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AFTER GEM PREP 

When you finish GEMPREP, you are ready to begin using the GEM 
Desktop. To learn the basic techniques of the GEM Desktop, run the 
GEM Desktop tutorial, which is described in Section 3. 

Section 3 also describes how you start the GEM Desktop from a floppy 
disk or a hard disk. 

As soon as you are working on the GEM Desktop, you can add a 
printer, plotter, or other hardware device to your system. To do so, 
run GEMSETUP, which is described in Part 2, "GEM Setup Guide." 

End of Section 2 
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SECTION 3 

GEM Desktop Tutorial 

INTRODUCTION 

This tutorial provides a basic understanding of GEM Desktop concepts, 
techniques, and terminology, including the following: 

• using the mouse 
• selecting and opening icons 
• choosing commands from menus 
• manipulating directories and windows 
• creating folders 
• copying data 

WHAT YOU NEED 

To run the tutorial, you need the following: 

• your microcomputer prepared to display graphics 

Section 2 tells you how to prepare your system to display GEM 
Desktop graphics. 

• mouse 
• GEM Desktop, ready to run from a hard disk or floppy disk 
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TUTORIAL 

This tutorial takes you step by step through several exercises that 
introduce you to the GEM Desktop. 

The first step tells you how to start the GEM Desktop from a floppy 
disk. The step after that tells you how to start the GEM Desktop from 
a hard disk. 

All set? let's begin! 

Starting the GEM Desktop from a Floppy Disk 

If you told GEMPREP that you want to go straight to the GEM Desktop 
each time you start your system, insert the GEM STARTUP disk into 
drive A, and turn on your computer. You see a series of messages on 
the screen, followed by the screen illustrated in Figure GS 3-1. 
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Figure GS 3-1. Insert GEM DESKTOP Disk Dialog 
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Remove the GEM STARTUP disk, and set it aside until your next GEM 
Desktop work session. Insert the GEM DESKTOP disk into drive A, and 
press the Enter key. In a few moments, the GEM Desktop (Figure GS 
3-2) appears. 

To start the GEM Desktop from the DOS prompt, insert the GEM 
STARTUP disk into drive ,A, and type the following command: 

A>GEM 

In a few moments you see the instruction to insert the GEM DESKTOP 
disk. 

Starting the GEM Desktop from a Hard Disk 

First, turn on your computer. Most computers need anywhere from a 
few seconds to a couple of minutes to warm up. 

If you told GEMPREP that you want to go straight to the GEM Desktop 
each time you start your system, you see a series of messages on the 
screen, followed by the GEM Desktop. Figure GS 3-2 shows what the 
GEM Desktop looks like when you first see it. 

To start the GEM Desktop from the DOS prompt, type the following 
command: 

C>GEM 

In a few moments the GEM Desktop appears. 

Initial GEM Desktop 

The GEM Desktop that first appears on your screen consists of a 
desktop work area and a menu bar. Icons for floppy disks, a hard disk, 
and trash can appear in the work area. The trash can is where you 
discard unwanted data. 
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menu bar Desktop work area disk icons 

mouse pointer trash can 

Figure GS 3-2. Initial GEM Desktop 

If, during GEMPREP, you put the GEM Desktop on your hard disk, your 
intitial GEM Desktop shows one hard disk icon and one floppy disk 
icon. If you put the GEM Desktop on floppy disks, your initial GEM 
Desktop shows two floppy disk icons and no hard disk icons. To add 
or remove a disk icon, see "Installing and Removing a Disk Drive" in 
Section 4. 

Moving the Mouse; Mouse Button Techniques 

The mouse pOinter (see Figure GS 3-2) moves when you move the 
mouse. Practice moving the mouse. The pointer's movement echoes 
the mouse's movement, although you can't move the pOinter entirely 
off the screen. 
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Now practice using the mouse button. Do your practicing in an open 
part of the GEM Desktop work area. (Nothing happens when you click 
in the work area. Right now you're just practicing mouse button 
techniques.) 

If your mouse has more than one button, always use the button on the 
left. 

Press and release the mouse button once. This is called "clicking." 
Click the mouse button several times. 

Now click the mouse button twice. Do it quickly, without pausing 
between clicks. This is called "double-clicking." 

Practice clicking and double-Clicking until you're ready to continue. 

Selecting an Icon 

When you select an icon, you indicate to the GEM Desktop that this is 
the icon you want to work with. 

Move the pointer so that it touches the floppy disk icon labeled "A". 
Click the mouse button. 

The GEM Desktop highlights the icon (reverses its colors) to indicate 
that the icon has been selected. Figure GS 3-3 shows the selected 
drive A floppy disk icon. 

Figure GS 3-3. Selected Icon 
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Now move the pointer to the trash can, and click again. Note how the 
GEM Desktop de-selects the drive A floppy disk icon when you select 
the trash can. 

{You can select more than one icon. We'll get to that later.} 

Move the pointer to an open space on the GEM Desktop, and click. 
The GEM Desktop de-selects the trash can. Now there are no 
selected icons. 

Practice selecting and de-selecting icons until you are ready to 
continue. 

Moving GEM Desktop Icons 

You can move GEM Desktop icons {disks and the trash can} to 
different positions on the GEM Desktop. 

Move the pointer to the trash can icon. Press the mouse button, but 
do not release it. {If the trash can was not already selected, the GEM 
Desktop now selects it.} 

Continue to hold down the mouse button, and move the mouse. A 
shadowy outline resembling an upside-down T moves with the pointer. 
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Figure GS 3-4. Moving the Trash Can 

The technique of holding down the mouse button while moving the 
mouse is called "dragging." 

Drag the outline to an open area of the GEM Desktop, and release the 
mouse button. The trash can moves to the pointer's position. 

Practice moving all of the desktop icons. When you're finished, move 
them back to their original positions, so that they'll be in the same 
places as those in the tutorial's figures. 

Click the mouse in an empty space on the GEM Desktop to de-select 
the last icon you moved. 

Displaying Drop-Down Menus 

Move the pointer up to the menu bar at the top of the GEM Desktop. 
Place the pOinter on the word "File". The File Menu appears below the 
menu b~r. 
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available command unavailable command 

Figure GS 3-5. File Menu 

Each text line in the menu is a command. The bright commands are 
available; the dimmed commands are unavailable. 

You can choose an available command. For example, you can choose 
Quit if you want to leave the GEM DesKtop and return to DOS. 

You can't choose a dimmed command, because right now it isn't 
meaningful to the GEM DesKtop. For example, you can't choose Open 
if you haven't first selected an icon. 

Now move the pointer along the menu bar from "File" to "View". The 
File Menu disappears, and the View Menu appears. 

Practice moving the pointer sideways along the menu bar. Note how 
the GEM Desktop's "drop-down" menus appear automatically when the 
pointer touches their titles in the menu bar. 

Now clicK the mouse anywhere on the GEM DesKtop outside the 
currently displayed menu. The menu disappears. 

If you're running this tutorial from a floppy disK, select the drive A 
floppy disK icon. If you're running this tutorial from a hard disK, select 
the hard disK icon. 
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Display the File Menu again. Note how selecting the icon made the 
Open, Show Info ... , and Format... commands change from unavailable 
to available, and the To Output command change from available to 
unavailable. 

Choosing a Command 

You choose a command from a menu by clicking on it. 

Move the pOinter through the File Menu. Note how the GEM Desktop 
highlights available commands as the pointer touches them. 

tk~ »} r G J de p v h v 

LJo~)'e 
LJn~)'e jjj.~ido~,< 

FormOltOQO 
Tu Output 
~uit 

Figure 3-6. Highlighted Command 

Move the pOinter to the Show Info... command. When the GEM 
Desktop highlights the command, click the mouse button. 

A GEM Desktop message (called a "dialog") appears. The DISK 
INFORMATION dialog contains information about ,your floppy or hard 
disk. When you're ready to continue, click in the rectangle labeled OK. 
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Opening a Disk Icon 

Let's find out what's on the floppy disk or hard disk. 

The disk icon should still be selected. If it isn't, select it now. 

Display the File Menu. Move the pointer through the menu, and click 
the mouse button on Open. 

A window appears on the GEM Desktop. The window contains a 
"directory," a group of icons that shows you what is on the disk. The 
directory in Figure GS 3-7 contains icons for folders and applications. 

folder icon 

close box application icon title bar full box 

size box 

Figure GS 3-7. Directory 
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The title bar of the window in Figure GS 3-7 contains the drive 
identifier A:\. If you're running the GEM Desktop from a hard disk, the 
drive identifier is C:\. 

Sizing a Window 

You can change the size of a window for any of the following reasons: 

• to reduce the amount of room the window takes up on the GEM 
Desktop 

• to see desktop icons that are hidden by the window 

• to change how much of the directory is visible in the window 

Move the pointer to the size box, located in the extreme lower right 
corner of the window's border (see Figure GS 3-7). Press and hold 
down the mouse button. A shadowy outline appears at the tip of the 
pointer. This outline gives you a preview of the window's size. A 
second shadowy outline, inside the first, gives you a preview of the 
size of the window's work area. 
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Figure GS 3-8. Sizing a Window 

Drag the shadowy outlines toward the center of the window. When 
the outlines are in the pOSitions indicated in Figure GS 3-8, release the 
mouse button. The GEM Desktop redraws the window to the smaller 
size. 
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Moving a Window 

You can move the window by dragging its title bar. Place the pointer 
on the title bar, and drag down and to the right. A rectangular outline 
moves with the pointer. 

Figure GS 3-9. Moving a Window 

Release the mouse button. The window disappears from its old 
location and reappears at its new one. 

Practice moving the window. Note that you can't move the window up 
into the menu bar or off the left side of the GEM Desktop. You can, 
however, move the window over the disk icons and the trash can. 

When you're ready to go on, leave the disk icons visible; you'll be 
using them again later. 
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Opening a Folder 

If you're running this tutorial from a floppy disk, the window contains 
two folders, GEMDESK and GEMSYS. If you're running this tutorial 
from a hard disk, the window contains the same two folders, plus two 
others, GEMBOOT and GEMAPPS. 

To see what is inside the GEMSYS folder, select the icon, and choose 
Open from the File Menu. 

A new directory appears in the window, containing document and 
application icons. Figure GS 3-10 shows the new directory for a 
floppy disk. (The hard disk directory should look much the same.) 

up-arrow 

left-arrow scroll bar 
slider right-arrow 

Figure GS 3-10. New Directory 
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Scrolling a Directory 

You're looking at only part of the directory. You can see the other 
icons by scrolling the directory. 

Use the scrolling points indicated in Figure GS 3-10. 

Click on the right-arrow. The directory moves, revealing the next 
column of icons to the right. 

Click on the right-arrow again, and watch the horizontal slider. The 
slider shifts to the right, indicating that you're moving toward the right 
side of the directory. 

Keep clicking on the arrow until the slider is all the way to the right. 
Note that each click moves you one column toward the right side of 
the directory. 

Now drag the slider all the way back to the left. 

This time, click on the scroll bar to the right of the slider. The 
directory moves, revealing the next three columns of icons to the 
right. The slider moves a greater distance to the right than it did 
when you clicked on the arrow. 

Here are the general rules for horizontal scrolling: 

• You click on the arrows and scroll bar; you drag the slider. 

• The left- and right-arrows always move the directory one column of 
icons at a time. 

• The scroll bar always moves the directory by as many columns of 
icons as are visible in the window (in this case, three). 

• The slider lets you move quickly from one end of a directory to the 
other, or to any point in between. 

• If there are no more columns of icons to the left and right in the 
directory, the left- and right-arrows have no effect, and the slider 
entirely fills the scroll bar. (Figure GS 3-7 shows a window whose 
entire directory is visible.) 
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The rules for vertical scrolling are similar. If there are no more rows 
of icons above and below in the directory, the up- and down-arrows 
have no effect, and the vertical slider entirely fills the vertical scroll 
bar. 

Practice clicking on the left- and right-arrows and the horizontal scroll 
bar. Practice dragging the slider. 

When you're finished scrolling, make sure the horizontal slider is all 
the way to the left. 

Now make the window larger, so that it contains two rows of icons, 
with six icons in the top row. Use the size box again. Practice until 
the window is the right size. 

Using the Full Box 

To enlarge the window instantly to fill the GEM Desktop work area, 
click on the full box, which is in the upper right corner of the 
window's border (see Figure GS 3-7). 

Click on the full box again. The window returns to its former size and 
location. 

Practice using the full box. When you're ready to continue, leave the 
window in its full size. 
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Sorting a Directory and Changing Directory Type 

Display the View Menu. The check marks next to Show as Icons and 
Sort by Name indicate that the directory contains icons, and that the 
icons are arranged alphabetically by name. OUTPUT is an example of 
an icon's name. 

Move the pointer though the menu, and choose Sort by Type by 
clicking on it. The icons rearrange themselves in the window so that 
all icons with the same type (EXE is an example of a type) are grouped 
together. 

Display the View Menu again. The check marks are now next to Show 
as Icons and Sort by Type. 

Choose Show as Text from the menu. The GEM Desktop replaces 
each icon with a line of text that gives the icon's name, its size in 
bytes, and the date and time of its creation or last modification. 
Figure GS 3-11 shows a text directory sorted by type. 
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types 
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Figure GS 3-11. Text Directory Sorted by Type 

Display the View Menu again, and choose Sort by Name. The lines of 
text rearrange themselves alphabetically by name. 

To select from a text directory, click anywhere on the text line. 
Practice selecting in the text directory. To de-select a text line, click 
in an open part of the window. 
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When you feel comfortable with text directories, display the View 
Menu, and choose Show as Icons. The directory should now be as it 
was when you began. 

Before continuing, click on the full box to make the window smaller 
again. 

Creating a Folder 

A folder is a place for storing and organizing data. You can place any 
number of folders in a directory, and you can even place folders inside 
other folders. 

To create a folder in your current directory, display the File Menu, and 
choose the New Folder ... command. 

The GEM Desktop displays the NEW FOLDER dialog. 
keyboard to type the following name: 

FOLDER.TMP 

Use your 

Type the name just as shown. Type the period, and don't type any 
spaces. If you make a typing error, use the Backspace key to erase 
the error, and retype. 

When you finish typing the name, click on OK. The GEM Desktop 
places a folder called FOLDER.TMP at the beginning of your directory. 

Note: The .TMP is optional. It is included here to demonstrate text 
entry in a dialog. 

Selecting a Group of Icons 

The new folder in your directory is empty. Let's put something in it. 

You'll start by selecting a group of three icons. Move the pointer to 
the icon next to the FOLDER.TMP icon. Starting just to the left of this 
icon (see Figure GS 3-12), press the mouse button, and drag to the 
right. A rectangle follows the pointer. 

When the rectangle touches three icons, release the mouse button. 
The GEM Desktop selects all three icons. 
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start here 

Figure GS 3-12. Dragging a Rectangle to Select a Group of Icons 

The rectangle in Figure GS 3-12 is large enough; it does not have to 
surround the icons entirely. If you ,accidentally select more than three 
icons, de-select the group by clicking in an open space in the window, 
and try again. 

Copying Data 

To copy the icons you just selected to the folder, place the pointer on 
one of the icons in the group. Press the mouse button, and drag the 
upside-down T outlines of the icons to the folder. When the pointer is 
directly over the folder, the GEM Desktop highlights the folder. 
Release the mouse button. 
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The GEM Desktop displays the COpy FOLDERS / ITEMS dialog. Click 
on OK or press the Enter key. As the GEM Desktop copies your data 
into the folder, the dialog counts down the number of items. When 
the last item has been copied, the dialog disappears. 

To open the FOLDER.TMP icon in a single step, try double-clicking. 
Move the pointer to the folder, and click the mouse button twice. 

The window's title bar and directory change to show that you are now 
inside the folder. 

Note: In dialogs, the boxes with labels like OK and Cancel are called 
"exit buttons." One of them usually has a heavy border. Pressing the 
Enter key has the same effect as clicking on the exit button with the 
heavy border. 

Opening Another Window 

Each time you open a disk icon, you produce a new window on the 
GEM Desktop. In this step you'll open the same disk icon you opened 
earlier under "Opening a Disk Icon." 

Move the pointer to the drive A floppy disk icon or the hard disk icon. 
Double-click to open the icon. A new window appears on the GEM 
Desktop. The new window's initial size is smaller than the first 
window's initial size. 

Open the GEMDESK icon in the new window by selecting the icon and 
choosing Open from the File Menu. 

Figure GS 3-13 shows the two windows on the GEM Desktop. If 
necessary, move the new window so that it is not entirely inside the 
old one. 
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Figure GS 3-13. Two Windows 

The new window is different from the old window in the following 
ways: 

• The new window is on top of the old window. 

• The new window's title bar is highlighted. 

• The new window is the only one whose full box, size box, and 
scrolling points are visible. 

GS 3-23 



Tutorial Getting Started 

These facts tell you that the new window is the "active window." 
There can only be one actjve window at a time. The active window is 
the only one you can size or move; it is also the only window whose 
icons you can select or whose directory you can scroll. 

To make a window active, click anywhere inside it. Practice activating 
the old window and then the new window. When you're finished 
practicing, leave the old window active. 

Closing Directories and Windows; Deleting Data 

Now you'll begin to clear the two windows off the GEM Desktop. 

You'll start by closing the directory in the active window. To close a 
directory, you can either click on the window's close box, or you can 
choose Close from the File Menu. This time use the close box. 

The close box is located in the window's upper left corner. See Figure 
GS 3-7. Place the pOinter on the active window's close box, and click. 
The GEM Desktop closes the current directory, and the following 
things happen: 

• The previous directory, which contains the FOLDER.TMP icon, 
appears in the window . 

• The window's title bar changes to reflect the change in directories. 
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The GEM Desktop should now look like the one in Figure GS 3-14. 
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Figure GS 3-14. Previous Directory 

Before you go further, delete the FOLDER.TMP icon. You don't need it 
any more, and it's taking up space in your directory. 

Drag the folder icon to the trash can. When the GEM Desktop 
highlights the trash can, release the mouse button. 

Before deleting the folder, the GEM Desktop displays the DELETE 
FOLDERS / ITEMS dialog. Click on OK. As the GEM Desktop deletes 
the data, the dialog counts down the number of items (3) and folders 
(1 ). 

When FOLDER.TMP has been deleted, the dialog disappears, and the 
GEM Desktop redraws the directory without the folder icon. 
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To close this window in a single step, display the File Menu, and click 
the mouse button when the pointer is on Close Window. The window 
disappears back into the disk icon from which it came. 

There is now only one window on the GEM Desktop. See Figure GS 
3-15. This window becomes the active window. 

Figure GS 3-15. GEM Desktop with One Window Closed 

To close the remaining window in a single step, again display the File 
Menu, and click the mouse button when the pointer is on Close 
Window. The la$t window disappears back into the disk icon from 
which it came. 

The GEM Desktop should now be exactly as it was when you started 
the tutorial. 
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Putting a GEM Application on Floppy Disks 

To run a GEM application from floppy disks, you must make a backup 
copy of the application disk. To do so, follow these steps: 

1. Insert a new disk (or a disk containing data that you no longer 
need) into drive B. 

2. Select the drive B floppy disk icon. 

3. Display the File Menu and choose the Format ... command. 

4. Insert your application disk into drive A. 

5. Drag the drive A floppy disk icon to the drive B floppy disk icon. 
Click on OK in the COpy FOLDERS / ITEMS dialog. 

6. Insert your GEM DESKTOP disk into drive A. Open the drive A 
floppy disk icon by double-clicking or by choosing Open from the 
File Menu. 

7. Drag the GEMSYS folder from the A:\ window to the drive B floppy 
disk icon. Click on OK in the COpy FOLDERS / ITEMS dialog. 

8. Drag the COMMAND.COM icon from the A:\ window to the drive B 
floppy disk icon. Click on OK in the COpy FOLDERS / ITEMS dialog. 

Your application work disk is now ready to use. 

To start the application, insert the disk into drive A and open the drive 
A floppy disk icon. The initial directory contains two folders, GEMSYS 
and GEMAPPS. 

Open the GEMAPPS folder. You'll find the application icon inside. 

Putting a GEM Application on a Hard Disk 

To run a GEM application from a hard disk, you must copy the 
application data to your hard disk. To do so, follow these steps: 

1. Open your hard disk icon. The initial directory contains a folder 
called GEMAPPS. 

2. Insert your application disk into drive A and open the drive A 
floppy disk icon. Its initial directory also contains a folder called 
GEMAPPS. 
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3. Open the GEMAPPS folder in the A:\ window. 

4. Select all the icons in the A:\ directory and drag them to the 
GEMAPPS folder in the hard disk (C:\) window. Click on OK in the 
COpy FOLDERS / ITEMS dialog. 

Your hard disk is now ready to run a GEM application. 

To start the application, open the hard disk icon and then open the 
GEMAPPS folder. You'll find the application icon inside. 

What's Next? 

The GEM Desktop tutorial has provided you with the basic techniques 
you'll need for working on the GEM Desktop. Section 4 tells you about 
some advanced GEM Desktop techniques. 

If you want to return to DOS, display the File Menu, and choose Quit. 

If you want to take a break, you can return to DOS and then turn off 
your computer's power. If you are using floppy disks, store them in a 
safe place. 

End of Section 3 
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SECTION 4 

More About GEM Desktop 

INTRODUCTION 

This section provides additional information on the GEM Desktop. It 
begins with descriptions of the commands in the Options Menu: 

• Install Disk Drive .. . 
• Install Application .. . 
• Set Preferences ... 
• Save Desktop 
• Enter DOS Commands ... 

INSTALLING AND REMOVING A DISK DRIVE 

If you add a disk drive to your computer system, you can add (install) 
a disk drive icon on the GEM Desktop. Similarly, if you remove a disk 
drive from your system, you can remove its icon from the GEM 
Desktop. 

To install a disk drive, follow these steps: 

1. Select any disk icon currently on the GEM Desktop. 

2. Display the Options Menu and choose the Install Disk Drive ... 
command. The GEM Desktop displays the INSTALL DISK DRIVE 
dialog. 

3. Type a drive identifier letter and icon label in the text fields. 
Because the icon label identifies the disk drive (not the contents of 
the disk currently in the drive), a general label like FLOPPY DISK is 
preferable. 
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4. To place a floppy disk icon on the GEM Desktop, click on the 
button labeled "Floppy"; for a hard disk icon, click on the button 
labeled "Hard". 

5. Click on the Install button. 

To remove a disk icon from the GEM Desktop, follow these steps: 

1. Select the icon. 

2. Display the Options Menu and choose the Install Disk Drive ... 
command. 

3. Click on the Remove button in the INSTALL DISK DRIVE dialog. 

Note: There must always be at least one disk icon on the GEM 
Desktop; you can't remove them all. 

INSTALLING AN APPLICATION 

When you install an application, you do the following: 

• You select a specially designed application icon . 

• You make it possible to start the application by opening a document 
you created with the application. 

To install an application, take the following steps: 

1. Select the application's icon. This icon must have the type APP, 
BAT, COM, or EXE. DRAW.APP is an example of an application 
icon's name and type. 

2. Choose Install Application ... from the Options Menu, and complete 
the INSTALL APPLICATION dialog. 

3. Move the cursor to the Document Type field. If the application 
automatically assigns a type to its documents, enter that type here. 
For example, GEM PainrM produces documents that have the type 
IMG. The application's manual should identify the assigned type. 
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If the application does not automatically assign a type, enter one of 
your own choosing. Make sure that you always give this type to 
any documents you create with this application. 

4. Move the cursor to the Application Type field. If you are installing 
a GEM application, click on GEM. If you are installing a DOS 
application, click on DOS. 

If you are installing a DOS application that lets you name a 
document or supply other information when you start the 
application, click on "DOS-takes parameters". The application's 
manual should tell you if the application accepts parameters. 

5. Move the cursor to the buttons labeled "Icon Type". These buttons 
let you choose the application icon that appears on the GEM 
Desktop. 

Click on the button that describes the application. If the other 
selection buttons do not accurately describe the application, click 
on Generic. 

Saving an Application Installation 

When you install an application, the installation remains in effect for 
the rest of the current session. To make the installation permanent, 
choose Save Desktop from the Options Menu. Save Desktop is 
described later in this section, under "Saving the Desktop." 

SETTING PREFERENCES 

If you prefer that the GEM Desktop delete or copy data without 
displaying the DELETE FOLDERS / ITEMS or COpy FOLDERS / ITEMS 
dialogs, display the Options Menu, and choose the Set Preferences ... 
command. When the SET PREFERENCES dialog appears, set "Confirm 
Deletes" or "Confirm Copies" to No. 

This dialog also lets you determine how fast you have to press the 
mouse button when you double-click. 
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SAVING THE DESKTOP 

The Save Desktop command saves the following aspects of the GEM 
Desktop environment: 

• current settings in the SET PREFERENCES dialog 
• current directory type and directory sorting 
• current placement of desktop icons 
• current size and location of windows 
• installation of any applications in the current session 

When you choose Save Desktop, you determine how the GEM Desktop 
appears and functions at the beginning of future GEM Desktop 
sessions. You can change any of the saved aspects during a session, 
but unless you save the GEM Desktop again, the changes only last 
until the end of that session. 

Note: If you are running the GEM Desktop from floppy disks, the GEM 
DESKTOP disk must be in drive A when you choose the Save Desktop 
command. 

ENTERING DOS COMMANDS 

When you choose Enter DOS Commands ... and click on the OK button 
in the resulting dialog, you leave the GEM Desktop and go to the DOS 
prompt. (If you are running the GEM Desktop from floppy disks, insert 
your DOS disk into drive A when you see the message asking for the 
COMMAND.COM disk.) 

At the DOS prompt you can enter commands like TYPE, PRINT, or 
FORMAT. You can also use DOS commands to start applications, 
change DOS directories, or change the default disk drive assignment. 

To return to the GEM Desktop from any DOS directory or disk drive, 
type EXIT at the DOS prompt. 
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Note: While you are entering DOS commands, the GEM software is 
still loaded into your computer's memory. For this reason, do not try 
to return to the GEM Desktop by typing GEM at the DOS prompt. 

USING THE KEYBOARD TO MOVE THE POINTER 

You can use your computer's up-, down-, left-, and right-arrow keys 
to move the pointer on the GEM Desktop. (If the arrow keys do not 
move the pointer, press the Ctrl or Num Lock key.) 

If you hold down an arrow key, the pointer moves continuously and 
fairly rapidly across the GEM Desktop. If you hold down the Shift key 
at the same time, the pointer moves more slowly. 

The following techniques are the keyboard equivalents of GEM Desktop 
mouse button techniques: 

• To click, press and immediately release the Home key. 

• To double-click, press and immediately release the Home key twice 
in rapid succession. 

• To drag, take the following steps: 

1. Press and release the Shift and Home keys simultaneously. This 
has the same effect as pressing the mouse button. 

2. Use the arrow keys to move the pointer. 

3. Press the Home key. This has the same effect as releasing the 
mouse button. 

ENTERING AND EDITING TEXT IN DIALOGS 

Several dialogs contain "editable text fields," which are places where 
you can type text. The text cursor (I) shows where your typed 
characters will appear. 
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To move the cursor to an editable field text, click the mouse anywhere 
in the field or use one of the keystrokes described in Table GS 4-1. 

Table GS 4-1 shows the key or key combinations you use to move the 
text cursor and delete characters in an editable text field. 

Table GS 4-1. Text Editing Keys 

Key(s) You Press Effect 

left-arrow 

right-arrow 

Tab or down-arrow 

Moves the text cursor one character to 
the left without deleting characters. 

Holding down the key moves the cursor 
continuously until it reaches the 
beginning of the field. 

Moves the text cursor one character to 
the right without deleting characters. 

Holding down the key moves the cursor 
continuously until it reaches the end of 
the text. 

Moves the cursor to the next editable 
field. 

Shift/Tab or up-arrow Moves the cursor to the previous 
editable field. 

Delete 
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Table GS 4-1. (continued) 

Key(s) You Press 

Backspace 

Escape 

Effect 

Deletes the character to the left of the 
cursor and moves the trailing text one 
space to the left. 

Holding down the key deletes 
continuously until the cursor reaches the 
beginning of the field. 

Moves the text cursor to the beginning 
of the current field and erases all 
characters in the field. 

Some editable text fields contain periods, slashes (I), or other special 
characters. Typing the character causes the text cursor to jump to the 
first space following the character. You saw this in the tutorial when 
you created the folder called FOLDER.TMP. 

SHIFT-CLICKING TO SELECT GROUPS 

You can select icons that are not next to each other by Shift-clicking 
as follows: 

1. Select the first icon by clicking on it. 

2. Press and hold down the Shift key on your keyboard. 

3. Click on the rest of the icons you want to select. The GEM 
Desktop highlights each icon as you click on it. 

4. Release the Shift key. 
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The corresponding keyboard technique for Shift-clicking is as follows: 

1. Press the Home key to select the first icon. 

2. Use the arrow keys to move the pointer to another icon. 

3. Press the Shift and Home keys simultaneously to select the icon. 

4. Without moving the pointer, press the Home key again. (If you 
don't, the GEM Desktop thinks you're dragging the icons. Of 
course, if you only want to select two icons and then drag them, 
that's OK.) 

5. Repeat steps 2-4 for any additional icons. 

RENAMING A DOCUMENT 

To rename a document, select the document icon, and choose Show 
Info... from the File Menu. 

The GEM Desktop displays the ITEM INFORMATION dialog. Type the 
new name in the Name field. 

ASSIGNING DATE AND TIME TO YOUR DATA 

The GEM Desktop includes a clock that assigns a date and time to all 
your new folders, documents, and applications. 

To see the clock, display the Desk Menu, and choose the Clock 
command. 

The clock has two modes: time mode and alarm mode. When you see 
a clock symbol, the clock is in time mode; when you see a bell 
symbol, the clock is in alarm mode. The clock must be in time mode 
for you to read or set the time. To change from one mode to the 
other, click on the symbol. 

GS 4-8 



Getting Started Assigning Date and Time to Your Data 

To set the time, move the pointer to the hour or minutes and click. 
When the GEM Desktop highlights the numbers, use the keyboard's 
standard number keys (not the numeric keypad) to type the correct 
number. Use 12-hour clock settings. 

Always type two digits. For single-digit settings, type a zero before 
the number--08, for example. When you type the second digit, the 
GEM D~sktop instantly changes the setting. 

To change from AM to PM (or from PM to AM), click on the "am" or 
"pm" following the time. 

To be sure of assigning a correct date and time, reset the clock at the 
beginning of each GEM Desktop session. 

If you do not want to reset the clock so frequently, you can purchase 
a battery-powered system clock that keeps running when your 
computer's power is turned off. 

End of Section 4 
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Foreword 

Welcome to Graphics Environment Manager (GEM) software from 
Digital Research! Applications based on this software, such as the 
GEM Desktop and GEM DrawTM, can run on a variety of computers with 
a large selection of graphics devices and type fonts. 

You use GEMSETUP to tell your GEM software which of the following 
you have in your system: 

• hardware devices 
• type fonts 
• communications ports 

WHEN DO I NEED TO RUN GEMSETUP? 

You must run GEMSETUP to do the following: 

• add or change a device connected to your system, such as a printer 
or graphics card 

• reconnect a device to another communications port (a plug in the 
back of your computer) 

You should run GEMSETUP when you remove a device from your 
system. When you remove a device, you no longer need its "device 
driver." A device driver is a program your computer uses to translate 
information into a format it can display on your screen, or reproduce 
with a printer or plotter. Device drivers use valuable disk and memory 
space. When you no longer need a device driver, you should run 
GEMSETUP to eliminate it. 

Finally, you can use GEMSETUP whenever you want to change the type 
fonts for the characters your screen, printer, or plotter produces. 
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HOW SHOULD I USE THIS GUIDE? 

This guide is both a step-by-step explanation of how to set up your 
GEM ~ystem, and a reference to GEMSETUP commands. 

To fil1d out how to start GEMSETUP and learn about its components, 
see S~ction 1. 

To create your own system setup, see Section 2. 

To modify the list of available choices, see Section 3. 

To see a summary of GEMSETUP menu commands, see Section 4. 

This guide assumes you can use the following: 

• menu bar 
• windows 
• dialog boxes 

• mo~se 
It alsQ assumes you have two disk drives in your system: either two 
floppy disk drives, or a hard disk drive and a floppy disk drive. 
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SECTION 1 

What is GEMSETUP? 

This section tells you how to start GEMSETUP and acquaints you with 
its icon, windows, and menu bar. 

STARTING GEMSETUP 

To start GEMSETUP from the GEM Desktop, open the icon labeled 
GEMSETUP.APP. You can either double-click on the icon, or select the 
icon and choose the Open command from the File Menu. 

Figure SG 1-1 shows the dialog box that appears when you start 
GEMSETUP. 
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i 
I 

i 

Figure SG 1-1. System Drive Identification Dialog 

Click on FLOPPY DISK if your system has only floppy disk drives. 

Click on HARD DISK if your GEM system is on a hard disk. 

Note: Choose FLOPPY DISK if you have a hard disk but start your 
system from a floppy disk. 

When you click on HARD DISK, a dialog box appears that asks you for 
the letter identifier of two disk drives. 
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Figure SG 1-2. Drive Identification Dialog 

Specify the letter identifier of the hard disk where your GEM system 
resides and the letter identifier of the floppy disk drive from which 
GEMSETUP reads the new setup information. For example, the hard 
disk may be drive C and the floppy disk may be drive A. Follow these 
instructions to give GEMSETUP the drive identifiers: 

1. Type the letter C. 

2. Click on the Floppy Disk entry location and type the letter A. 

3. Click on OK to communicate this drive information to GEMSETUP. 

Click on Cancel to return to the GEM Desktop. 
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Once GEMSETUP knows where your GEM system resides, it displays 
the main GEMSETUP screen, shown in Figure SG 1-3. 

Mouse 
Mouse Ports 
Plotters 
Plotter Fonts 
Plotter Ports 
Printers 
Printer Fonts 
Printer Ports 
Metaf i les 
Metafile Fonts 
Tablets 
Tablet Ports 

-----------------------------------------------------

------------_._----_._---------------------------------

Texas Instruments Professional MONOCHROME MODE 
Corona Data Systems PC MONOCHROME MODE __________ _ 

--_._----_._-_._--------------------------------------

--_._----_._-_._------------------------------------------
------------_._----_._--------_._------------------------

Figure SG 1-3. Initial GEMSETUP Screen 

GEMSETUP WINDOWS 

The initial GEMSETUP screen has three windows entitled Categories, 
Chosen, and Available. Table SG 1-1 describes these windows. 
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Table SG 1-1. GEMSETUP Windows 

Window Title Description 

Categories 

Chosen 

Available 

GEMSETUP MENU BAR 

Displays the categories of hardware 
devices, type fonts, and communication 
ports you can use with GEM software. 
When you first start GEMSETUP, the 
Graphics Cards category is highlighted. 
This means it's the "current" category. 
When you select a category, GEMSETUP 
highlights it. 

Lists the items already selected from the 
current category. 

Lists the items you can select from the 
current category. When you select a 
category in the Categories window, 
GEMSETUP lists all the items in the 
Available window that you can add to 
your system's setup. For example, if 
Graphics Cards is the current category, 
then the Available window lists all the 
different graphics cards you can choose. 

The GEMSETUP menu bar has four menus labeled Desk, File, Edit, and 
Special. They are described in Table SG 1-2. 
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Table SG 1-2. GEMSETUP Menu Bar 

Menu Title What Menu Contains 

Desk 

File 

Edit 

Special 

Commands to see information about 
GEMSETUP and start your desk 
accessories. 

Commands to save the new setup or 
exit GEMSETUP. 

Commands to see the summary of what 
will go into the new setup, learn 
information about the choices, and clear 
either one or all choices. 

Commands to add, modify, or delete 
items that appear in the Available 
window. 

Section 4, "Menu Commands," lists and explains the commands you 
see in the menus. 

End of Section 1 
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SECTION 2 

Creating Your Setup 

This section gives you a quick overview of GEMSETUP, then shows 
you how to add graplJics devices and type fonts you might have to 
your system setup, how to delete them, and finally how to save and 
use the new setup. 

A QUICK LOOK AT GEMSETUP 

A typical session with GEMSETUP involves the following: 

1. Getting Information About Your Setup 

a. Choose Show Summary from the Edit Menu to see what is in 
your current setup. Note: You only need to use GEMSETUP if 
your system setup differs from what appears in the summary 
when you first start GEMSETUP. 

b. Choose Show Info ... from the Edit Menu to learn more about an 
available item. 

2. Adding a New Device or Type Font 

a. Select a category (for example, Printers). 

b. Click on an available item, such as IBM®/Epson® Graphics Printers 
HI RES, and drag it up to the Chosen window. 

3. Saving the New Setup 

a. Choose Save Summary from the File Menu to create the new 
setup. 

b. Insert the correct disks as GEMSETUP creates your new setup. 
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4. Activating Your New Setup 

a. Choose Quit from the File Menu to return to the GEM Desktop. 

b. Restart your computer. 

The following sections give you more details on these four steps. 

GETTING INFORMATION ABOUT YOUR SETUP 

This section describes two ways to get information about your setup 
using the Edit Menu commands: 

• Use the Show Summary command to see what will go into your 
new setup the next time you update your system disk . 

• Use the Show Info... command to see an available choice's 
description. 

Seeing the Summary 

To see the summary, do the foillowing: 

1. Choose Show Summary from the Edit Menu. Figure SG 2-1 shows 
the Summary window. 

When you first start GEMSETUP, the summary contains only the 
items from your current setup. 

2. To return to the main GEMSETUP screen, click on the close box in 
the upper left corner of the Summary window. 

Note: You can choose Save Summary or Quit from the File Menu 
while the summary is on display. If you are satisfied with the 
summary of choices, you can save your new setup without returning 
to the main GEMSETUP screen by choosing Save Summary. Or, you 
can abandon the changes you have made by choosing Quit and then 
restarting GEMSETUP. 
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Communication Port 11 _____________________________________________ _ 
IBM/Epson Graphics Printers HI RES ________________________________ _ 
EPSOM Hi Res Helvetica 14 _________________________________________ _ 
Printer Parallel Port U2 __________________________________________ _ 
GSX File __________________________________________________________ _ 
Communication Port 12 _____________________________________________ _ 

f--------------------------------------------------------------------------

Figure SG 2-1. Summary Window 

Getting Information on an Item 

To learn more about an available item, you can display its description 
as follows: 

1. Click on a category name, such as Printers. 

2. Click on the Available window to activate it. (You can't show 
information on an item in the Chosen window; you also can't show 
information on a category.) 

3. Click on an item in the Available window, such as IBM/Epson 
Graphics Printers HI RES. 
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4. Choose Show Info ... from the Edit Menu. Figure SG 2-2 shows the 
dialog box which tells you: 

• name of the device driver or type font program 
• name written on its disk's label 
• short description of it 
• detailed description of it 

5. To close the dialog box and return to the main GEMSETUP screen, 
click on OK or press the Enter key. 

Filenawa: ~PSMONHH.8YS 
J)i.sll lLahe~: em'i nW,)ICJ': i)HI\)mll[)R~m 

J)esex' lion: 

Iler.a Is: 
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Figure SG 2-2. Show Info ... Dialog 
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ADDING A NEW DEVICE OR FONT TO YOUR SETUP 

Once you know what's in the summary and you're sure you're adding 
the correct device driver or type font to your system, you are ready to 
add it to the summary. 

To select an item do the following: 

1. Click on the Categories window and click, on a category. (The 
Chosen window displays any items already in the summary for this 
category.) 

2. Click on the Available window and click on the item you wish to 
add to the new setup. 

3. Drag the item up to the Chosen window. When you release the 
mouse button, the choice usually replaces the previous selection. 
Note: You can select only one item from each hardware device 
category, that is, one printer, one mouse, or one monitor, etc. But, 
you may select more than one type font for a device. Therefore, 
when you choose a device, it replaces the previous selection; when 
you choose a font, it's added to the list. 

4. Choose Show Summary from the Edit Menu to verify that the 
items you have chosen are ready to go into the new setup. 

DELETING A DEVICE OR FONT FROM YOUR SETUP 

You can remove either one or all choices from the setup summary 
using the Clear Choice and the Clear Summary commands from the 
Edit Menu. 
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Clearing a Choice 

To clear a choice from the summary, do the following: 

1. Click on the Categories window and click on a category. 

2. Click on the Chosen window and click on the item you wish to 
exclude from the new setup. 

3. Choose Clear Choice from the Edit Menu. GEMSETUP erases the 
selection from the Chosen window and the summary. 

4. Check the summary again to verify that it is no longer on the list. 

Note: Clear Choice differs from Remove Item from the Special Menu. 
Clear Choice erases the selected item from the Chosen window and 
the summary. Remove Item erases the selected item from the 
Available window permanently. 

Clearing the Summary 

To clear all the selected items from the summary, do the following: 

1. Choose Show Summary from the Edit Menu. 

2. Choose Clear Summary from the Edit Menu. Figure SG 2-3 shows 
the Clear Summary dialog box. 

3. To clear the summary and return to the main GEMSETUP screen, 
click on OK. 

To return to the main GEMSETUP screen without clearing the 
summary, click on Cancel or press the Enter key. 
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WARNING? 

Click on OK to erase ALL entries in the 
Summary. NOTE: The SUMmary shows you what 
will he included in the ASSIGN.SYS file 
next time you choose to save it. 

Figure SG 2-3. Clear Summary Dialog 

Note: Choosing Clear Summary does not affect your current setup 
but does clear the summary. Remember that the summary shows you 
exactly what will go into your new setup the next time you update 
your system disk. If you save an empty summary, you will not be able 
to use your GEM system the next time you start your computer. (See 
"Correcting Mistakes" below). 
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SAVING THE NEW SETUP 

Once you are satisfied with the summary, you are ready to save it. 
When you choose Save Summary from the File Menu, GEMSETUP 
displays the dialog shown in Figure SG 2-4. If you click on OK, 
GEMSETUP prompts you for the correct disks to insert as it creates 
your new setup. 

You must have the appropriate software on driver disks. If you do not 
have the device driver or type font programs you have requested, you 
see a dialog box requesting that you provide the software or cancel 
the save procedure. 

Note: Follow the directions exactly! The new setup overwrites and 
destroys the old setup_ You might not be able to start your system 
next time if you save an incorrect setup. (See "Correcting Mistakes" 
below.) 
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-------------------------------------------------------------------

WARMING! 

Click on OK to create a new setup. 
NOTE: The new setup overwrites and 
destroys the old setup. 

Figure SG 2-4. Save Summary Dialog 

ACTIVATING THE NEW SETUP 

If you just added a new device or font to your setup, you cannot use 
it until the next time you start your system. 

To activate your new setup, choose Quit from the File Menu, return to 
your operating system's prompt and restart your computer. 

Note: Quit does not save your new setup. You must use the Save 
Summary command from the File Menu to save your new setup. If 
you choose Quit before you choose Save Summary, you abandon your 
changes. 
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CORRECTING MISTAKES 

If you add the wrong type font or device type to your system, you can 
usually restart GEMSETUP and create another setup. However, if you 
add the wrong graphics card or mouse, you will have to use the 
GEMPREP program as described in Part 1, "Getting Started with the 
GEM Desktop," Section 2, "Preparing Your System." 

End of Section 2 
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SECTION 3 

Customizing the Choices 

Although your GEM system comes with a large variety of graphics 
devices and type fonts you can choose from, the list of available items 
may not be just right for you. You may feel that the descriptions are 
not informative enough. Or, perhaps you have acquired a new type 
font that did not come with your GEM system. The GEM system is not 
limited to the graphics devices and type fonts that we make available 
to you in GEMSETUP. 

This section shows you how to customize the GEMSETUP list of 
available items. 

A QUICK LOOK AT CUSTOMIZING 

GEMSETUP keeps all the information about each of the available items 
in a document on your system disk called GEMSETUP.TXT. Each time 
you pick a category, GEMSETUP reads this document and lists the 
appropriate items in the Available window. GEMSETUP also looks in 
this document each time you choose Show Info... to display the 
selected item's description. 

You use the Special Menu commands to: 

• add a new item to the Available window 

• change the information about a current item 

• remove an item from the Available window 

• update the text file that contains all the information about the 
available items 

SG 3-1 



A Quick Look at Customizing GEM Setup Guide 

Note: If you want to add a new choice to the Available window, you 
must have the device driver or type font program. Even if you add a 
new entry to the list of choices with the Update Text File command, 
you cannot update your system using the Save Summary command 
from the File Menu if you do not have the appropriate device driver 
software on the driver disk. (See "Saving the New Setup" in Section 
2.) 

ADDING NEW ITEMS 

To add a new item to the Available window, do the following: 

1. Click on the Categories window and click on a category. 

2. Click on the Available window to make it active. 

3. Choose Add New Item from the Special Menu. You see the Add / 
Change Item dialog box shown in Figure SG 3-1. 

4. Click on each text field, and enter the new item's description, as 
follows: 

Filename: 

Disk Label: 

Description: 
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Type the name of its disk. GEMSETUP prompts 
you for this disk when you choose Save 
Summary from the File Menu. 

Enter a short description. This text line appears 
in the Available, Chosen, and Summary windows. 
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Patch Bytes: 

Details: 

Adding New Items 

If this device driver needs to know which 
communication port you are using, click on Port 
and type the number of the port in the back of 
your computer. See your hardware specification 
manual for the identification number of the port. 

If this device driver needs to know which mouse 
you are using, click on Type and enter the 
identification of your mouse. The mouse 
number corresponds to where it is listed in the 
Available window: no mouse is 0, PC Mouse is 
" and so on. If you are adding a new mouse, 
use the next available number. 

Type a short description of this device driver's 
or font's purpose. This is for your information; 
it's like a scratch pad where you keep notes to 
yourself. 

4. To return to the main GEMSETUP screen without creating a new 
entry, click on Cancel. 

To create a new entry for the Available window, click on OK or 
press the Enter key.-

5. Choose Update Tex·t File from the Special Menu to revise the 
document that contains the information about the available items. 
Once you update the text document, the new item is available to 
choose. 

6. Choose Show Info ... from the Edit Menu to verify your entry. 
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Filename: 
Disk Lahe 1: 

EPSMONHB .1 
GEM DEVICE-DRIVER DISK 12 _____________ _ 

Description: IBM/Epson Graphics Printers HI RES ______________ _ 
Patch Bytes: Port: __ Type: __ 

Details: 
This driver is for the IBM Graphics printer, the Epson FX 80/100 and ___ _ 
the Epson MX 80/100. The printers are driven in the 120 x 144 dots per __ 
inch mode. _____________________________________________________________ _ 

Figure SG 3-1. Add / Change Item Dialog 

CHANGING CURRENT ITEMS 

To modify an item's description, do the following: 

1. Click on the Categories window and click on a category. 

2. Click on the Available window and click on an available item. 

3. Choose Change Item from the Special Menu. Figure SG 3-1 
shows the Add / Change Item dialog box. 
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4. Modify the item's description. Refer to the descriptions above. 
Use caution when you change the patch bytes because your 
system needs the correct port and mouse identification where 
applicable. 

5. To close the Add / Change Item dialog box and return to the main 
GEMSETUP screen without modifying the item's description, click 
on Cancel. 

To mark the item for modification, click on OK or press the Enter 
key. 

6. Choose Update Text File from the Special Menu to modify this 
device driver's description in the text document. 

7. Choose Show Info ... from the Edit Menu to verify the changes you 
just made. 

REMOVING OLD ITEMS 

To remove an item from the Available window, do the following: 

1. Click on the Categories window and click on a category. 

2. Click on the Available window and click on an available item. 

3. Choose Remove Item from the Special Menu. GEMSETUP marks 
the item for deletion from the Available window. 

Note: Remove Item differs from Clear Choice from the Edit Menu. 
Remove Item erases the selected item from the Available window 
permanently. Clear Choice erases the selected item from the 
Chosen window and the summary. 

SG 3-5 



Removing Old Items GEM Setup Guide 

4. Choose Update Text File from the Special Menu to erase this 
item's description from the text document. 

Note: Never erase an item's device driver from the driver disk. You 
might want to restore the item later. 

End of Section 3 
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SECTION 4 

Menu Commands 

This section describes the commands in the Desk, File, Edit, and 
Special menus. 

Show SUMMary Add Hew IteM 
Show Info... Change iteM 
Clear Choice ReMove IteM 
Clear SUMMary Update Text File 

Figure SG 4-1. GEMSETUP Menus 

DESK MENU 

The Desk Menu is divided into two sections by a dashed line. The top 
section always has the GEMSETUP Info ... command which gives you a 
dialog that introduces you to GEMSETUP. The bottom section, 
however, varies depending on what desk accessories you have 
available on your system. 
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FILE MENU 

You use the File Menu commands to save a new setup or exit 
GEMSETUP. 

Table SG 4-1 describes the File Menu commands. 

Table SG 4-1. File Menu 

Command Description 

Save Summary 

Quit 

SG 4-2 

Creates a new setup on the floppy disk 
in the default drive, overwriting the old 
setup. 

Stops GEMSETUP and returns you to the 
GEM Desktop. 
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EDIT MENU 

You use the Edit Menu commands to see the summary of what will go 
into the new setup, get information about the choices, and clear either 
one or all choices from the summary. 

Table SG 4-2 describes the Edit Menu commands. 

Table SG 4-2. Edit Menu 

Command Description 

Show Summary 

Show Info ... 

Clear Choice 

Clear Summary 

Lists the items that will go into the new 
setup the next time you choose Save 
Summary from the File Menu. The list 
includes all hardware devices and type 
fonts not deleted from the current setup, 
plus all assignments added during this 
session of GEMSETUP. 

Displays the description of a selected 
item from the Available window. 

Deletes a selected entry from the 
Chosen window and summary. 

Deletes all entries from the summary. 
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SPECIAL MENU 

You use the Special Menu commands to modify the list of available 
items in the current category. 

Table SG 4-3 describes the Special Menu commands. 

Table SG 4-3. Special Menu 

Command Description 

Add New Item 

Change Item 

Remove Item 

Update Text File 

SG 4-4 

Makes another item available in the 
selected category. 

Marks the 
Available 

selected item 
window for a 

modification. 

from the 
description 

Marks the selected item for permanent 
deletion from the Available window. 

Revises the document that contains 
information describing the available 
choices. This command adds the data 
collected in Add New Item, modifies the 
entries indicated in Change Item, and 
erases the items marked for deletion in 
Remove Item. You do not actually make 
any permanent revision to the 
GEMSETUP.TXT document until you 
choose this command. 

End of Section 4 
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Foreword 

This guide explains how to reproduce the charts, graphs, and free­
form graphic designs you create with GEM applications like GEM 
DrawTM and GEM Paint. 

WHEN DO I RUN OUTPUT? 

You use OUTPUT to send pictures to your: 

• screen 
• printer 
• plotter 

HOW SHOULD I USE THIS BOOK? 

This guide is both a step-by-step explanation of how to reproduce 
pictures, and a reference to OUTPUT commands. 

To start OUTPUT and become acquainted with its components, see 
Section 1. 

To learn to use OUTPUT, see Section 2. 

To see a summary of OUTPUT menu commands, see Section 3. 

This guide assumes you can use: 

• mouse 
• menu bar and menus 
• windows 
• dialog boxes 
• ITEM SELECTOR 

iii 



SECTION 1 

What is OUTPUT? 

This section tells you how to start OUTPUT and acquaints you with its 
window and menu bar. 

BEFORE YOU START 

You can select the pictures you wish to reproduce before you start 
OUTPUT. Click on the appropriate names in a directory window, then 
follow the instructions for starting OUTPUT below. 

You can pre-select either the individual names of the graphs, charts, 
or designs you plan to send to your output device, or the name of an 
"output list" (defined on page OG 1-3). Then, when you start OUTPUT, 
the names of the pictures you wish to reproduce will be ready to send 
to your output device immediately. 

Section 2, "Using Output," explains how you can also select the names 
after you have started OUTPUT. You can learn how to select 
individual picture names under "Adding a Name" in Section 2; you can 
learn how to select an output list name under "Opening an Output 
List," also in Section 2. 
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STARTING OUTPUT 

To start OUTPUT from the GEM Desktop or a GEM application, choose 
To Output from the File Menu. 

Figure OG 1-1 shows an untitled output list. 

Figure OG 1-1. Untitled Output List 
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OUTPUT LIST 

If you did not pre-select picture names, OUTPUT displays an empty 
output list on your screen. You arrange the names of the tables, 
charts, graphs, and pictures that you wish to reproduce on your output 
device in the output list. Like a roll of film that has 36 exposures, the 
output list can accommodate up to 36 names. It remains "untitled" 
until you save it and give it a name. 

If you did pre-select picture names, OUTPUT displays their names in 
an untitled output list. The names appear in the output list in the 
order they appear in the directory, not in the order you selected them. 
You can change the order of the names in the directory with 
commands from the GEM Desktop View Menu, or you can change the 
order of the names in the output list. (See "Moving a Name" in 
Section 2.) 

Note: OUTPUT permits you to pre-select up to 128 characters, 
including the directory path names, backslashes (\), and periods (.) 
contained in the names. So, if you pre-select many names, you might 
not see all the names you expect in the initial output list. 

If you pre-select an output list name, OUTPUT displays the names 
contained in that list and writes the output list's title in the title bar. 

When you choose To Output from one of the GEM applications, such 
as GEM Draw, OUTPUT assumes you have pre-selected the current 
picture in that application. For example, say you are working in GEM 
Draw on a picture named BARGRAPH. When you are ready to send it 
to your printer, you choose To Output from the GEM Draw File Menu. 
OUTPUT automatically displays BARGRAPH in the output list when it 
starts. 
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OUTPUT MENU BAR 

OUTPUT's menu bar has four menus labeled Desk, File, Edit, and 
Options. They are described in Table OG 1-1. 

Table OG 1-1. OUTPUT Menu Bar 

Menu Title What Menu Contains 

Desk 

File 

Edit 

Options 

Commands to see information about 
OUTPUT and start your desk accessories. 

Commands to open and close existing 
output lists, create and save new output 
lists, plus get and save options for your 
output devices. 

Commands to arrange the names in the 
output list. 

Commands to select options for your 
output devices and make the current 
options the default settings. 

Section 3, "Menu Commands," lists and explains the commands you 
see in the menus. 

End of Section 1 
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SECTION 2 

Using OUTPUT 

This section gives you a quick overview of the OUTPUT procedures. It 
also gives step-by-step instructions on how to create and save the 
output list, set options for your output devices, and reproduce the 
pictures named in the output list on your screen, printer, or plotter. 

A QUICK LOOK AT OUTPUT 

There are 4 steps to producing output: 

1. Arrange the picture names sequentially in the output list. 

2. Choose Save As ... from the File Menu if you desire to save the 
output list for later use. 

3. Check the assigned options for your screen, printer, and plotter 
and, if necessary, change them using the Option Menu commands. 

4. Choose Start Output ... from the File Menu when you are ready to 
reproduce the pictures named in the output list. OUTPUT asks if 
you want to send them to the screen, printer, or plotter. 

The following sections give you more details about these four steps. 
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CREATING AN OUTPUT LIST 

You must put the names of the charts, graphs, or designs you wish to 
reproduce into an output list before you can send them to an output 
device. There are two ways to create a new output list as follows: 

• Start OUTPUT. 
• Choose the New command from OUTPUT's File Menu. 

Starting OUTPUT 

If you have not pre-selected any picture or output list names~ start 
OUTPUT. OUTPUT displays an empty, untitled output list. If you want 
to add picture names to it, see "Adding a Name" below. 

Choosing the New Command 

If an output list is currently on display and you want to clear the 
screen and display an empty, untitled list, choose New from the File 
Menu. 

The New command causes one of two things to happen depending on 
whether the current output list is new or old: 

• If you have not made any changes to an old list, OUTPUT clears the 
output list without saving it and displays an empty, untitled list. 

• If the current list is new or if you have made changes to a pre­
existing list, OUTPUT displays a dialog box that reminds you to save 
the list. 

To clear the list without saving it, click on Continue. 

To return to the output list without clearing it, click on Cancel or press 
the Enter key. After you save it, choose New to create a new output 
list. 
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ARRANGING OUTPUT LIST NAMES 

This section explains how to add, duplicate, move, or delete names in 
an output list. 

Adding a Name 

To add a name to an output list do the following: 

1. Choose Add Name ... from the Edit Menu. OUTPUT displays the 
ITEM SELECTOR dialog box. 

2. Click on the desired name in the directory window or type the 
name in the Selection line. 

Note: All the documents you enter in the output list must be in 
the same directory. 

3. To add the name to the output list, click on OK or press the Enter 
key. 

To return to the output list without adding a new name, click on 
Cancel. 

To change the directory path on your current disk, do the following: 

1. Click on the directory window's close box. If need be, do it again, 
until the window contains a list of folder names (they're preceded 
by diamonds and have no type following the period). 

2. To change to the new directory path, click on the folder name you 
want. OUTPUT displays a list of document names from that folder 
with the type specified on the Directory line. 

To change to a directory path on another disk, do the following: 

1. Click anywhere on the Directory line. 

2. Press the Escape (Esc) key to erase the entire path name. 

3. Type the desired disk drive identifier, followed by an asterisk 
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(called a IIw ildcard" character), a period, and the document type you 
want. The correct form is A:\*.GEM. 

4. Click in the directory window to see the list of folders on the new 
disk. 

If you already know the name of the folder you want, you can specify 
it in the Directory line. In that case you would type A:\DRAW\*.GEM. 

Note: The directory window is not automatically updated when you 
specify a new directory path. You must click in the window to update 
it. 

OUTPUT provides the following shortcuts with the ITEM SELECTOR: 

• If you only want to put a single document on the output list, you 
can double-click on the document name in the directory window. 
This has the same effect as clicking on the name and then clicking 
on OK . 

• If you want to put @ the documents from the current directory 
window on the output list (up to a maximum of 36), leave the 
Selection line blank and click on OK. 

After you have added all the names you desire, you can save the list 
for future use (see "Saving an Output List" below), or choose Start 
Output... from the File Menu. 
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Duplicating a Name 

To reproduce a picture more than once, duplicate its name in the 
output list as follows: 

1. Click on the names you want to duplicate. OUTPUT highlights each 
name when you select it. 

You can select multiple names two ways. If the names are not 
next to each other, use the Shift-click mouse technique. If the 
names are next to each other, you can drag to select them as you 
did in the tutorial on page GS 3-20. Drag selecting is also called 
the "rubber-rectangle" method. 

2. Choose Duplicate Name from the Edit Menu. OUTPUT adds the 
selected names under the original names. 

Note: If you try to choose more names to duplicate than the output 
list has spaces for, OUTPUT dims the Duplicate Name command so 
you cannot choose it. 

Moving a Name 

To move a name to another location in the list, select the name and 
drag it to the desired location. When you release the mouse button, 
OUTPUT rearranges the list. You can move only one name at a time. 

Deleting a Name 

To delete a name from the output list, do the following: 

1. Click on the name you want to delete. You can delete multiple 
names using the Shift-click and rubber-rectangle mouse 
techniques. 

2. Choose Delete Name from the Edit Menu. OUTPUT erases the 
name you selected from the list. 
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Selecting Text Document Names 

Although OUTPUT is specially designed to sefid pictures to output 
devices, it can also send text documents to either a screen or printer. 
It does, however, have certain limitations. 

When you output a text document, OUTPUT does not use page breaks. 
Instead, it sends the document to your output device in a continual 
stream. Therefore, when you display the document on your screen, for 
example, you must use the Ctrl-S and Ctrl-Q keystrokes to control the 
scrolling. Press the Control key and the letter S simultaneously to 
stop the scrolling; press the Control key and Q to restart it. 

Note: When you print a text document on your printer, be sure to use 
continuous-form paper. 

SAVING AN OUTPUT LIST 

Once you have all the entries you want in the output list, you can save 
the list and give it a name. Later you can open it, modify its contents 
(if you wish), and reproduce the pictures named in it. 

To save a new output list, or save a list under a different name, do the 
following: 

1. Choose Save As ... from the File Menu. Figure OG 2-2 shows the 
SAVE LIST dialog box. Note: OUTPUT displays a similar dialog box 
when you choose the Save Options ... command. 

2. Type the name you wish to give the output list. OUTPUT adds .LlS 
to the list's name to indicate it is an output list and stores the new 
list in the directory. 
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SAVE LIST 

Path: B::\ 

Save as: PIECHART"LI~ 

Figure OG 2-1. SAVE LIST Dialog 

To save an output list with its previous name, choose Save from the 
File Menu. OUTPUT stores it on the disk in its original directory path. 

In either save procedure, your current output list remains on your 
screen so you can continue working with it. 

If you have just saved an output list and are ready to create another 
one, choose New from the File Menu. OUTPUT clears the current 
output list and displays an empty, untitled list you can add names to. 
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CHANGING OUTPUT DEVICE OPTIONS 

Once you have created and saved an output list, you can send the 
pictures named in it directly to your output device. However, before 
you do, you might want to check or change the way your screen, 
printer, or plotter reproduces your pictures. 

OUTPUT provides a variety of settings for each of your output devices. 
For example, you can set the print justification for reproducing pictures 
on your printer or plotter. The justification settings enable you to put 
a picture in different positions on the page. 

OUTPUT supplies a set of default options for each device. You can 
select different options, changing the current settings. You can also 
save the new settings for later use. You can even change the default 
settings. 

Note: You cannot turn off an option setting. Each option must be 
set. 

One way to know if you need to change the output device options is 
by trial and error. For example, you won't know if you need to change 
the justification until you see how your picture looks after you output 
it. 

This section explains your output devi,ce options. 
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Screen Options 

Figure OG 2-2 shows the SCREEN OPTIONS dialog box that OUTPUT 
displays when you choose Screen ... from the Options Menu. 

Figure OG 2-2. SCREEN OPTIONS Dialog 
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Click on the desired settings as follows: 

Wait for: 

Cycle: 

Click on Key if you want OUTPUT to wait for you to 
strike a key before it reproduces the next picture in 
the output list. Otherwise, click on the desired 
number of seconds: 2, 5, 10, or 20. 

If you use the Key option, OUTPUT reproduces the 
next picture when you press any key or the mouse 
button. If you press the up-arrow key, OUTPUT 
reproduces the previous picture in the output list. 
You can press the Esc key to stop sending the 
pictures and return to the current output list. 

Click on Yes if you want OUTPUT to repeat the 
cycle; click on No if you want it to reproduce the 
pictures listed in the output list only once. 

If you select Yes, OUTPUT continues to send the 
pictures listed in the output list over and over again 
until you press the Esc key. 

To set the screen options, click on OK or press the Enter key. 

To return to the output list without setting the screen options, click on 
Cancel. 
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Printer or Plotter Options 

Figure OG 2-3 shows the PRINTER OPTIONS dialog box that OUTPUT 
displays when you choose Printer ... from the Options Menu. 

Note: The plotter options are identical to the printer options. 

PRIMTER opnmlS 

Scale: ~(~f~~ll IFull Scalel 

Justification 

Horizontal: I Left I ~ I Right I 

Uertical: ~ ~ IBotto~ 

Figure OG 2-3. PRINTER OPTIONS Dialog 
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Click on the desired settings as follows: 

Scale: 

Horizontal: 

Vertical: 

Click on Best Fit if you want OUTPUT to do its best 
to fit the picture on one page of paper; click on Full 
Scale if you want it to break the page at the end of 
the paper and continue the output on the next page 
using Full Scale. Best Fit shrinks or stretches the 
picture to fill the page. Full Scale preserves the 
aspect ratio of the picture without distorting it; that 
is, it draws to the specifications you indicated in the 
application where you created the picture. 

For example, say you designed a table in Landscape 
layout that fits horizontally on legal-sized paper, 
8-1/2" x 14" as in Figure OG 2-4. But you want to 
print it on 8-1/2" x 1111 paper. Select Best Fit and 
let OUTPUT scale it down proportionally to fit on 
the smaller page. 

Align your picture horizontally with the Left, Center, 
or Right setting. The whole picture shifts or centers 
itself to adjust the left and right margins of the 
page. (See Figure OG 2-4). 

Align your picture vertically with the Top, Center, or 
Bottom setting. The whole picture shifts or centers 
itself to adjust the top and bottom margins of the 
page. 

To set the options, click on OK or press the Enter key. 

To return to the output list without setting the options, click on 
Cancel. 

OG 2-12 



Output Guide 

--------- 11" ---------+-, : 

r--------------------
SAMPLE STACKED BAR GRAPH 

Landscape Layout 
~~ndOryAxI. 

OL-__ £WllL~~WWLW~~llL----; 

~-----~--~~~:~~--~---~ 

Landscape layout, 
center justified 
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: .... ,------ 8V2" ------,: 

SAMPLE'STACKED BAR GRAPH 

Se<:ondaryAxis 
140 

Portrait Layout 

________ ~m~ :s _____ _ 

Portrait layout, 
right justified 

11" 

Figure OG 2-4. Layout and Justification 
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SAVING OUTPUT DEVICE OPTIONS 

You can save the current option settings for your output devices with 
the Save Options ... command. You can restore those settings with 
the Get Options... command next time you want to use them. 

Save Options... creates a document containing options for all the 
output devices connected to your system. Get Options... reads that 
document and resets the current options to match those in the saved 
option document. 

This is handy if you have special option settings you want to use only 
occasionally. Save them using a unique name, then restore them at 
the appropriate time. Meanwhile, you can use the default s'ettings. 

Note: These commands do not change OUTPUT's default options 
(those OUTPUT starts up with). If you want to change OUTPUT's initial 
options, you must use Make Default from the Options Menu as 
explained in "Setting Output Device Default Options" later in this 
section. 

To save the current options for later use, do the following: 

1. Choose Save Options ... from the File Menu. Figure OG 2-1 shows 
the SAVE LIST dialog box, which is similar to the SAVE OPTIONS 
dialog box. 

2. Type the name you wish to give the option document. Output 
adds .OPT to the name to indicate it is an option document and 
stores it in the directory that contains OUTPUT. 

3. To save the new option document, click on OK or press the Enter 
key. 

To return to the output list without saving a new option document, 
click on Cancel. 
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GETTING OUTPUT DEVICE OPTIONS 

When you want to use a set of options saved in the above procedure, 
do the following: 

1. Choose Get Options ... from the File Menu. OUTPUT displays the 
ITEM SELECTOR with the names of the option documents 
(document names that end in .OPT) in the directory that contains 
OUTPUT. 

2. Click on the desired option document's name in the directory 
window or type the name followed by .OPT in the Selection line. 

3. To reset the current options for all output devices to those in the 
selected option document, click on OK or press the Enter key. 

To return to the output list without resetting the options, click on 
Cancel. 

Note: See "Adding a Name" above or your GEM application 
documentation for more information about how to use the ITEM 
SELECTOR. 

You can choose Get Options... again and specify DEFAULT.OPT to 
restore OUTPUT's default options after you are finished with the 
special options. 
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SETTING OUTPUT DEVICE DEFAULT OPTIONS 

When you first start OUTPUT, it indicates certain option settings. 
These are the "default settings." You can change OUTPUT's initial 
option settings to the settings you most frequently use with Make 
Default from the Options Menu. Use the following procedure: 

1. Set the desired option settings using the Options Menu commands. 

2. Choose Make Default from the Options Menu. OUTPUT updates 
DEFAUl T.OPT, which it uses to set the initial options for all of your 
system's output devices each time you start OUTPUT. 

STARTING THE OUTPUT 

After you create your output list and set the options for your output 
device, you are ready to reproduce the pictures named in the list. 

If the current list is not the one you want to output, you must first 
open the output list you wish to send to your output device. 
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Opening an Output List 

To open an output list, do the following: 

1. Choose Open ... from the File Menu. OUTPUT displays the ITEM 
SELECTOR with the names of the output lists (document names 
that end in .lIS) in your default disk's directory. 

2. Click on the desired output list's name in the directory window or 
type the name followed by .lIS in the Selection entry area. 

If you do not see the name you want in the directory window, even 
by scrolling it, you can specify a different disk and directory path. 
Be sure to type \*.lIS after the directory name to indicate that you 
want to see all the output list names in that directory. 

Note: See "Adding a Name" above or your GEM application 
documentation for more information about the use of the ITEM 
SELECTOR. 

Choosing Start Output ... 

If the current output list is the one you want, and the options are set 
correctly for your output device, you are ready to go. 

Choose Start Output... from the File Menu to display the START 
OUTPUT dialog box shown in Figure OG 2-5. 
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START OUTPUT 

Device: 

Number of copies: 011 

[<=Lor] ~_~LJ 
-=;=~~",!J 

=-~~~~---~-~~-~. -~~-~-~--~~ 

I I 

Figure OG 2-5. START OUTPUT Dialog 

To send the pictures named in the output list to your output device, 
do the following: 

1. Click on the output device you wish to use. 

2. Type the number of copies you want to reproduce, if it differs from 
the current number. 

3. To start the output, click on OK or press the Enter key. 

To return to the output list without reproducing the pictures named 
in it, click on Cancel. 
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Note: To stop sending pictures to the output device, press the Esc 
key. OUTPUT stops only after it finishes sending the current picture to 
the output device. 

If you have just reproduced the pictures named in an output list and 
want to reproduce the pictures listed in another one, you need to 
close the current output list and open the next one you wish to 
reproduce. Then choose Start Output... from the File Menu again. 

CLOSING AN OUTPUT LIST 

To close the current output list and clear it from the screen, choose 
Close from the File Menu. 

If you did not save the current output list before choosing Close, 
OUTPUT does one of the following: 

• If the current list is new or if you have made changes to a pre­
existing list, OUTPUT displays the SAVE LIST dialog box and asks 
you to supply a name, as if you had chosen Save As... from the File 
Menu . 

• If you have not made changes to a pre-existing output list, OUTPUT 
saves it under its previous name, as if you had chosen Save from 
the File Menu. 

QUITTING OUTPUT 

When you are finished with a session of OUTPUT and wish to return to 
the GEM Desktop or a GEM application, choose Quit from the File 
Menu. 

End of Section 2 
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SECTION 3 

Menu Commands 

This section describes the commands in the Desk, File, Edit, and 
Options Menus. 

Calculator 
Clock 

DESK MENU 

New 
Open •.• 
Close 
Save 
Save As ••• 

Get Options ••. 
Save Options ..• 

Start Dutput •.• 
Quit 

Duplicate Name 
Delete Name 

Figure OG 3-1. OUTPUT Menus 

Screen •.• 
Printer .•• 
Plotter •.. 

Make Default 

The Desk Menu is divided into two sections by a dashed line. The top 
section always shows the Output Info ... command which gives you a 
dialog introducing you to OUTPUT. The bottom section, however, 
varies depending on what desk accessories you have available on your 
system. You can choose any desk accessory that's listed. 

OG 3-1 



File Menu Output Guide 

FILE MENU 

You use the File Menu commands to open and close existing output 
lists, create and save new output lists, plus get and save options for 
your output devices. 

Table OG 3-1 describes the File Menu commands. 

Table OG 3-1. File Menu 

Command Description 

New 

Open ... 

Close 

Save 

Save As ... 

OG 3-2 

Clears the current output list without 
saving it and displays an empty, untitled 
list ready for you to add names to. 

Displays the output list you specify on 
your screen. 

Closes the current output list, removing it 
from your screen. 

Saves the current output list under its 
previous name, leaving it on your screen. 

Saves the current output list, but under a 
different name you specify. OUTPUT 
automatically adds .LlS to an output list's 
name. Always use the Save As ... command 
to save a new list. 



Output Guide 

Command 

Get Options ... 

Save Options ... 

Start Output ... 

Quit 

File Menu 

Table OG 3-1. (continued) 

Description 

Resets the current options for all output 
devices to match those in the option 
document that you select (document 
names that end in .OPT). You create an 
option document using the Save Options ... 
command. 

To restore the default options during a 
session of OUTPUT, choose the Get 
Options... command and select the 
DEFAUL T.OPT document. 

Saves the current options for all devices in 
an option document. OUTPUT 
automatically adds OPT to an option 
document's name. You can restore these 
options using the Get Options ... 
command. 

Sends the pictures named in the current 
output list to the specified output device. 

Stops OUTPUT and returns you to either 
the GEM Desktop or a GEM application. 
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Edit Menu Output Guide 

EDIT MENU 

You use the Edit Menu commands to arrange names in the output list. 

Table OG 3-2 describes the Edit Menu commands. 

Table OG 3-2. Edit Menu 

Command Description 

Add Name ... 

Duplicate Name 

Delete Name 

OPTIONS MENU 

Adds a name to the output list. 

Repeats selected name(s) in the output list. 

Removes selected name(s) from the output 
list. 

You use the Options Menu commands to select options for your 
output devices and make the current options the default settings. 
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Output Guide Options Menu 

Table 3-3 describes the Options Menu commands. 

Table OG 3-3. Options Menu 

Command Description 

Screen .. . 

Printer .. . 

Plotter .. . 

Make Default 

Sets options for your screen. 

Sets options for your printer. 

Sets options for your plotter. 

Makes the current options OUTPUT's initial 
settings for your screen, printer, and 
plotter. The Make Default command 
updates DEFAUl T.OPT, which OUTPUT uses 
to set the initial options for all of your 
system's output devices each time you 
sta~ it. You can also choose Get 
Options... and specify DEFAUl T.OPT to 
restore the default option settings during a 
session of OUTPUT. 

End of Section 3 
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Index 

A 

Activating 
new setup, SG 2-9 
windows, GS 3-24 

Active window, GS 3-24, 
GS 3-26 

Adding 
name to output list, OG 2-3 
new device/font, SG 2-5 
new item, SG 3-1, SG 3-2, 

SG 4-4 
Add Name ... command, OG 2-3, 

OG 3-4 
Add New Item command, SG 4-4 
APP (type), GS 4-2 
Application disk 

backup copy, GS 3-27 
Application icons, GS 3-11 
Applications 

assigning date and time, 
GS 4-8 

installing, GS 4-2 
saving installation, GS 4-3, 

GS 4-4 
selecting directory icon, 

GS 4-2 
starting, GS 3-27, GS 4-2 
types, GS 4-2 

Aspect ratio, OG 2-12 

Available commands, GS 3-9 
Available window, SG 1-4, 

SG 1-5 

B 

Backing up application disk, 
GS 3-27 

Backspace key 
editing text in dialogs, 

GS 3-20, GS 4-7 
Backup copies, GS 2-1 
BAT (type), GS 4-2 
Best Fit, OG 2-12 
Boldface colored type, v 
Boldface type, v 

c 

Capitalization, iv 
Categories window, SG 1-4, 

SG 1-5 
Change Item command, SG 4-4 
Changing 

information about an item, 
SG 3-4 

output device options, OG 2-8 
Choosing commands, GS 3-10 

Index-1 



Chosen window, SG 5-4 
Clear Choice command, SG 2-6, 

SG 3-5, SG 4-3 
Clear Summary command, 

SG 2-6, SG 2-7, SG 4-3 
Clearing 

all choices from summary, 
SG 2-6 

one choice from summary, 
SG 2-5 

output list, OG 2-2, OG 3-2 
Clicking, GS 3-6 

keyboard equivalent, GS 4-5 
to choose commands, GS 3-10 
to select icons, GS 3-6 

Clock, GS 4-8 
alarm mode, GS 4-8 
assigning date and time, 

GS 4-8 
bell symbol, GS 4-8 
changing mode, GS 4-8 
clock symbol, GS 4-8 
setting the time, GS 4-9 
time mode, GS 4-8 

Clock command, GS 4-8 
Close box, GS 3-24 
Close command, OG 3-2 
Close Window command, 

GS 3-26 
Closing 

directories, GS 3-24 
output list, OG 2-19 
windows, GS 3-26 

COM (type), GS 4-2 
COMMAND.COM disk, GS 4-4 
COMMAND.COM icon, GS 3-27 

Index-2 

Commands, GS 3-9 
affected by icon selection, 

GS 3-10 
available, GS 3-9 
choosing, GS 3-10 
highlighting, GS 3-10 
unavailable, GS 3 ..... 9 

Communication port, GS 2-5 
COpy FOLDERS llTEMS dialog, 

GS 3-22, GS 3-27, 
GS 3-28, GS 4-3 

Copying data, GS 3-21 
Correcting mistakes, SG 2-10 
Creating 

folders, GS 3-20 
output list, OG 2-2 

Ctrl (Control) key, GS 2-3, 
GS 4-5 

Current output list, OG 2-2 
Current settings with OUTPUT, 

OG 2-8 
Customizing list of available 

items, SG 3-1 

o 

Data 
copying, GS 3-21 
deleting, GS 3-25 

De-selecting 
icon groups, GS 3-21 
icons, GS 3-7 

DEFAUL T.OPT, OG 2-19, OG 3-3 
Default settings with OUTPUT, 

OG 2-8, OG 2-14, OG 2-15 



DELETE FOLDERS / ITEMS 
dialog, GS 3-25, GS 4-3 

Delete key 
editing text in dialogs, GS 4-6 

Delete Name command, OG 3-4 
Deleting 

data, GS 3-25 
device/font, SG 2-5 
icons, GS 3-25 
name in output list, OG 2-5 

Desk accessories, SG 1-6, 
SG 4-1 

Desk Menu, GS 4-8, SG 1-6, 
SG 4-1 

Desk Menu 
with GEMSETUP, SG 4-1 
with OUTPUT, OG 1-4, OG 3-1 

Desktop icons, GS 3-7 
moving, GS 3-7 
saving placement of, GS 4-4 

Desktop work area, GS 3-4 
Device driver, SG iii, SG 3-2 
Device options with OUTPUT, 

OG 2-8 
Dialog box, SG 2-4 
Dialogs, GS 3-10 

entering/editing text, GS 4-5 
Directories, GS 3-11 

closing, GS 3-24 
scrolling, GS 3-16 
sorting, GS 3-18 
type, GS 3-18 

Directory icons, GS 3-11 
Directory sorting, GS 3-18 

saving, GS 4-4 

Directory type, GS 3-18 
saving, GS 4-4 

DISKCOPV, GS 2-1 
Disk drive icons 

drive identifier, GS 4-1 
icon label, GS 4-1 
installing, GS 3-5, GS 4-1 
on initial GEM Desktop, GS 3-5 
removing, GS 3-5, GS 4-2 

Disk icons 
opening, GS 3-11 

DISK INFORMATION dialog, 
GS 3-10 

Disk Operating System, iii 
Displaying a menu, GS 3-8 
Distorting pictures, OG 2-12 
Document icons, GS 3-15 
Documents 

assigning date and time, 
GS 4-8 

renaming, GS 4-8 
DOS, iii 

returning to, GS 3-28 
DOS applications, GS 4-3 

taking parameters, GS 4-3 
DOS commands, GS 4-4 
Double-clicking, GS 3-6 

keyboard equivalent, GS 4-5 
setting required speed, GS 4-3 
to open icons, GS 3-22 

Down-arrow key 
moving text cursor, GS 4-6 

Dragging, GS 3-8 
keyboard equivalent, GS 4-5 
to select a group of icons, 

GS 3-20 

Index-3 



Drive identifier, GS 3-12 
Duplicate Name command, 

OG 2-5, OG 3-4 
Duplicating name in output list, 

OG 2-5 

E 

Edit Menu, SG 1-6, SG 4-3 
Edit Menu, 

with GEMSETUP, SG 4-1, 
SG 4-3 

with OUTPUT, OG 1-4, 
OG 3-4 

Editable text fields, GS 4-5 
Empty output list, OG 1":3, 

OG 2-2 
Enter DOS Commands ... 

command, GS 4-4 
Enter key, GS 2-2 

to exit dialogs, GS 3-22 
Entering DOS commands, 

GS 4-4 
Esc (Escape) key, OG 2-3, 

OG 2-10 
editing text in dialogs, GS 4-7 

EXE (type), GS 4-2 
Exit buttons, GS 3-22 
EXIT command, GS 4-4 
Exiting GEMSETUP, SG 4-2 

F 

File Menu, GS 3-8, SG 1-5, 
SG 4-2 

Index-4 

File Menu 
with GEMSETUP, SG 4-1, 

SG 4-2 
with OUTPUT, OG 1-4, 

OG 3-2 
Floppy disk icon, GS 3-4 

installing, GS 4-2 
Folder icons, GS 3-11 

opening, GS 3-15 
Folders, GS 3-20 

assigning date and time, 
GS 4-8 

creating, GS 3-20 
FORMAT (DOS command), 

GS 4-4 
Format ... command, GS 3-27 
Full box, GS 3-17, GS 3-23 
Full Scale, OG 2-12 

G 

GEM applications, GS 3-27, 
GS 4-3 

on floppy disks, GS 3-27 
on hard disk, GS 3-27 

GEM DESKTOP disk, GS 2-8, 
GS 3-4, GS 3-27, GS 4-4 

GEM DESKTOP MASTER DISK, 
GS 2-1 

GEM DEVICE DRIVER DISK # 1, 
GS 2-1 

GEM DEVICE DRIVER DISK #2, 
GS 2-1 

GEM Paint, GS 4-2 



GEM STARTUP disk, GS 2-8, 
GS 3-2 

GEM SYSTEM MASTER DISK, 
GS 2-1 

GEMAPPS folder, GS 3-15, 
GS 3-27, GS 3-28 

GEMBOOT folder, GS 3-15 
GEMDESK folder, GS 3-15, 

GS 3-22 
GEMPREP, GS 2-1, GS 3-2, 

GS 3-4, GS 3-5 
GEMSETUP 

starting, SG 1-1 
typical session, SG 2-1 

GEMSETUP.APP, SG 1-1 
GEMSETUP.TXT, SG 3-1, SG 4-4 
GEMSYS folder, GS 3-15, 

GS 3-27 
Generic application icon, GS 4-3 
Get Options ... command, OG 3-3 
Getting information about your 

setup, SG 2-2 
Getting options with OUTPUT, 

OG 2-15 
Graphics card, GS 2-2, GS 2-5 

H 

Hard disk icon, GS 3-4 
installing, GS 4-2 

Icon names, iv, GS 3-18 
Icon type, GS 3-18 

Icons, GS 3-4 
clicking to select, GS 3-6 
de-selecting, GS 3-7 
de-selecting groups, GS 3-21 
deleting, GS 3-25 
double-clicking. to open, 

GS 3-22 
highlighting, GS 3-6 
moving (desktop only), GS 3-7 
name, GS 3-18 
selecting, GS 3-6 
selecting groups, GS 3-20 
type, GS 3-18 

Incorrect setup, SG 2-8 
Initial GEM Desktop, GS 3-4 
Initial OUTPUT Screen, OG 1-2 
Install Application ... command, 

GS 4-2 
INSTALL APPLICATION dialog, 

GS 4-2 
Application Type field, GS 4-3 
Document Type field, GS 4-2 
Icon Type field, GS 4-3 

Install Disk Drive ... command, 
GS 4-1, GS 4-2 

INSTALL DISK DRIVE dialog, 
GS 4-1, GS 4-2 

Install button, GS 4-2 
Remove button, GS 4-2 

Installing disk drive icons, 
GS 3-5, GS 4-1 

Instruction, GS 2-2 
ITEM INFORMATION dialog, 

GS 4-8 
ITEM SELECTOR, OG 2-3 
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J 

Justification, OG 2-12 

K 

L 

Landscape layout, OG 2-12, 
OG 2-13 

Layout, OG 2-13 
Left-arrow key 

moving text cursor, GS 4-6 

M 

Make Default command, OG 3-5 
Menu bar, GS 3-4, GS 3-8, 

SG 1-5 
moving the pointer along, 

GS 3-9 
Menus, GS 2-2 

displaying, GS 3-8 
making disappear, GS 3-9 

Mouse, GS 2-2, GS 2-5 
Mouse button, GS 3-5 

button on left, GS 3-6 
techniques, GS 3-6 

Mouse number, SG 3-3 

Index-6 

Mouse pointer, GS 3-5 
See also pointer 

Moving 
desktop icons, GS 3-7 
name in output list, OG 2-5 
windows, GS 3-14 

Multiple windows, GS 3-22 

N 

New command, OG 2-2, OG 3-2 
NEW FOLDER dialog, GS 3-20 
New Folder ... command, GS 3-20 
New setup 

using, SG 2-9 
Num Lock key, GS 4-5 

o 

Open command, GS 3-11 
Open ... command, OG 3-2 
Opening 

disk icon, GS 3-11 
folder, GS 3-15 
output list, OG 2-17 

Options Menu, GS 4-1 
Options Menu 

with OUTPUT, OG 1-4, OG 3-4 
OUTPUT 

plotter options, OG 2-11 
printer options, OG 2-11 
quitting, OG 2-19 
repeating, OG 2-10 



screen options, OG 2-9 
selecting multiple names, 

OG 2-5 
starting,OG 1-2, OG 2-16 
stopping, OG 2-19 

Output device options 
changing, OG 2-8 

Output list, OG 1-3 

p 

adding name, OG 2-3 
clearing, OG 2-2 
closing, OG 2-19 
creating, OG 2-2 
deleting name, OG 2-5 
duplicating name, OG 2-5 
moving name, OG 2-5 
opening, OG 2-17 
saving, OG 2-6 

Periods 
in editable text fields, GS 3-20, 

GS 4-7 
Picture alignment, OG 2-12 
Pictures 

distorting, OG 2-12 
Plotter ... command, OG 3-5 
Plotter options with OUTPUT, 

OG 2-11 
Pointer, GS 3-5 

moving with keyboard, GS 4-5 
Portrait layout, OG 2-13 
Preparing your system, GS 2-:- 1 
Pre-selecting output list name, 

OG 1-1 

Pre-selecting picture names, 
OG 1-1 

PRINT (DOS command), GS 4-4 
Printer ... command, OG 3-5 
Printer options with OUTPUT, 

OG 2-11 
Prompt, GS 2-2, GS 2-4 
Proportional fit, OG 2-12 

Q 

Query, GS 2-2 
Quit, SG 2-2, SG 2-9, SG 4-2 
Quit command, GS 3-28, OG 3-3 
Quitting OUTPUT, OG 2-19 

R 

Remove Item command, SG 3-5, 
SG 4-4 

Removing disk drive icons, 
GS 3-5, GS 4-2 

Removing item, SG 3-1, SG 3-5 
Repeating output, OG 2-10 
Returning to DOS, GS 3-28 
Right-arrow key 

5 

moving text cursor, GS 4-6 
scrolling, GS 3-16 

Save As ... command, OG 3-2 
Save command, OG 3-2 
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Save Desktop command, GS 4-3, 
GS 4-4 

Save Options ... command, 
OG 3-3 

Save Summary command, 
SG 2-2, SG 2-9, SG 4-2 

Saving 
application installation, GS 4-3 
current option settings 

with OUTPUT, OG 2-14 
new setup, SG 2-8, SG 4-2 
output list, OG 2-6 

Screen ... command, OG 3-5 
Screen options with OUTPUT, 

OG 2-9 
Scroll bar, GS 3-16 
Scrolling directories, GS 3-16 

general rules, GS 3-16, 
GS 3-17 

Scrolling points, GS 3-16, 
GS 3-23 

right-arrow, GS 3-16 
scroll bar, GS 3-16 
slider, GS 3-16 

Selecting 
group of icons, GS 3-20, 

GS 4-7 
icon, GS 3-6 
multiple names with 

OUTPUT, OG 2-5 
Set Preferences ... command, 

GS 4-3 
Setting the time, GS 4-9 
Shift-clicking, GS 4-7 

keyboard equivalent, GS 4-8 

Index-8 

Shift/Tab keys 
moving text cursor, GS 4-6 

Show as Icons command, 
GS 3-18, GS 3-20 

Show as Text command, 
GS 3-18 

Show Info ... command, GS 3-10, 
GS 4-8 

with GEMSETUP, SG 2-2, 
SG 2-4, SG 4-3 

Show Summary command, 
SG 4-3 

Size box, GS 3-12, GS 3-23 
Sizing windows, GS 3-12 
Slashes (I) 

in editable text fields, GS 4-7 
Slider, GS 3-16 
Sort by Name command, 

GS 3-18, GS 3-19 
Sort by Type command, GS 3-18 
Sorting directories, GS 3-18 
Special characters 

in editable text fields, GS 3-20, 
GS 4-7 

Special Menu, SG 1-5, SG 3-1, 
SG 4-4 

Start Output ... command, OG 3-3 
Starting 

application, GS 4-2 
GEMPREP, GS 2-4 
GEMSETUP, SG 1-1 
OUTPUT, OG 1-2, 

OG 2-16 
Starting the GEM Desktop 

from DOS, GS 3-4 
from floppy disk, GS 3-2 
from hard disk, GS 3-4 



Stopping 
GEMPREP, GS 2-3 
OUTPUT, OG 2-19 

Summary, SG 2-2 
Summary window, SG 2-3 
System clock, GS 4-9 

T 

Tab key 
moving text cursor, GS 4-6 

Text 
entering/editing in dialogs, 

GS 4-5 
Text cursor, GS 4-5 

moving, GS 4-6 
Text directories, GS 3-18 

selecting from, GS 3-19 
Title bar, GS 3-12, GS 3-14, 

OG 1-3 
dragging to move window, 

GS 3-14 
drive identifier, GS 3-12 
highlighted, GS 3-23 

To Output command, OG 1-3 
Trash can, GS 3-25 
Trash can icon, GS 3-4 
TYPE (DOS command), GS 4-4 

u 

Up-arrow key 
moving text cursor, GS 4-6 

Update Text File command, 
SG 4-4 

v 

View Menu, GS 3-9, GS 3-18 
check mark, GS 3-18 

w 

Windows, GS 3-11, SG 1-4 
activating, GS 3-24 
active, GS 3-24 

x 

y 

close box, GS 3-24 
closing, GS 3-26 
full box, GS 3-17 
initial sizes, GS 3-22 
moving, GS 3-14 
multiple, GS 3-22 
saving size and location, 

GS 4-4 
size box, GS 3-12 
sizing, GS 3-12 

Unavailable commands, GS 3-9 
Untitled output list, OG 1-3, 

OG 2-2 Z 
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DIGITAL RESEARCH -INC. 
END USER PROGRAM LICENSE AGREEMENT 

YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND 
CONDITIONS BEFORE OPENING THE DISKETTE PACKAGE. OPENING THE 
DISKETTE PACKAGE INDICATES YOUR ACCEPTANCE OF THESE TERMS 
AND CONDITIONS. IF YOU DO NOT AGREE WITH THEM, YOU SHOULD 
PROMPTLY RETURN THE PACKAGE UNOPENED AND YOUR MONEY WILL 
BE REFUNDED. 

Title to the media on which the program is recorded and to the 
documentation in support thereof is transferred to you, but title to the 
program is retained by DRI or AUTHOR. You assume responsibility for 
the selection of the program to achieve your intended results, and for 
the installation, use, and results obtained from the program. 

1. DEFINITIONS - In this License Agreement, the terms: 

1. DRI means DIGITAL RESEARCH INC., 60 Garden Court, P.O. Box DRI, 
Monterey California 93942, owner of the copyright in, or authorized 
licensor of, the program. 

2. Machine means the single microcomputer on which you use the 
program. Multiple CPU systems require additional licenses. 

3. AUTHOR means any third party author and owner of the copyright 
in this program. 

4. Run-time Library means the set of copyrighted DRI language 
subroutines provided with each language compiler, a portion of 
which must be linked to and become part of your program for that 
program to run -on the computer. 



2. LICENSE 

You may: 

1. Use the program on a single machine; 

2. Copy the program into any machine-readable or printed form for 
backup or modification purposes only in support of such use. 
(Certain programs, however, may include mechanisms to limit or 
inhibit copying. They are marked "copy-protected.") Copying of 
documentation and other printed materials is prohibited; 

3. Modify the program and/or merge it into another program for your 
use on the single machine (Any portion of this program merged 
into another program will continue to be subject to the terms and 
conditions of this Agreement); and 

4. Transfer the program and license to another party if you notify DRI 
of the name and address of the other party and the other party 
agrees to a) accept the terms and conditions of this Agreement, 
~n~ h\ n~\I tho thon "11r'r'ont tr'!:ln~for' foo If ''''11 tr'!:ln~for' tho 
U.IY """/ .,uy ",I'U "',."' •• '""u •• " .... "'lUI',,",''''' ."''''_ II J"""' "' ....... ".". "'I''''' 

program, you must at the same time either transfer all copies, 
including the original, whether in printed or machine-readable form 
to the same party or destroy any copies not transferred; this 
includes all modifications and portions of the program contained or 
merged into other programs. 

You must reproduce and include the copyright notice on any copy, 
modification, or portion merged into another program. 

You may not use, copy, modify, or otherwise transfer the program, or 
any copy, modification, or merged portion, in whole or in part, except 
as expressly provided for in this Agreement. 

If you transfer possession of any copy~ modification, or merged portion 
of the program to another party, your license is automatically 
terminated. 
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3. TERM 

The license is effective until terminated. You may terminate it at any 
other time by destroying the program together with all copies, 
modifications, and merged portions ·in any form. It will also terminate 
upon conditions set forth elsewhere in this Agreement or if you fail to 
comply with any term or condition of this Agreement. You agree upon 
such termination to destroy the program together with all copies, 
modifications, and merged portions in any form. 

4.. COMPOSITE PROGRAMS 

. As an exception to Paragraph 2, you are granted the right to include 
portions of the DRI Run-time Library in your developed programs, 
called Composite Programs, and to use, distribute, and license such 
Composite Programs to third parties without payment of any further 
license fee. You shall, however, include in such Composite Program, 
and on the exterior label of every diskette, a copyright notice in this 
form: "Portions of this program, (C) 1985 Digital Research Inc." In 
cases where such Composite Program is contained in Read-Only­
Memory (ROM) chips, a copyright notice in the form listed above must 
be displayed on the exterior of the chip and internally in the chip (in 
ASCII literal form). As an express condition to the use of the Run­
time Library, you agree to indemnify and hold DRI harmless from all 
claims by you and third parties arising out of the use of Composite 
Programs. 

5. LIMITED WARRANTY AND DISCLAIMER OF WARRANTY 

DRI warrants the media on which the program is furnished to be free 
from defects in materials and workmanship under normal use for 
ninety (90) days from the date of delivery to you as evidenced by a 
copy of your receipt. 
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DRI warrants that each program which is designated by DRI as 
warranted in its program specifications, supplied with the program, will 
conform to such specifications provided that the program is properly 
used on a machine for which it was designed. If you believe that 
there is a defect in a warranted program such that it does not meet 
its specifications, you must notify DRI within the warranty period and 
in the manner set forth in the program specifications. 

ALL OTHER PROGRAMS ARE PROVIDED "AS IS" AND NEITHER DRI, ITS 
DISTRIBUTORS OR DEALERS, NOR AUTHOR MAKE ANY WARRANTY OF 
ANY KIND, EITHER EXPRESS OR IMPLIED. THE ENTIRE RISK AS TO THE 
QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. 
SHOULD THE PROGRAM PROVE DEFECTIVE, YOU (AND NOT DRI OR 
AUTHOR) ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, 
REPAIR, OR CORRECTION. 

Neither DRI, its Distributors or Dealers, nor AUTHOR warrant that the 
functions contained in any program will meet your requirements or 
that the operation of the program will be uninterrupted or error free or 
that program defects will be corrected. 

THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. 

SOME STATES DO NOT ALLOW THE EXCLUSION OF IMPLIED 
WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. 
THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS AND YOU MAY 
ALSO HAVE OTHER RIGHTS WHICH VARY BY STATE OR JURISDICTION. 
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6. LIMITATIONS OF REMEDIES 

DRI's entire liability and your exclusive remedy shall be as follows: 

1. With respect to defective media during the warranty period: 

- DRI will replace media not meeting DRI's "Limited Warranty" if 
returned to DRI or a DRI authorized representative with a copy 
of your receipt. 

In the alternative, if DRI or such DRI authorized representative is 
unable to deliver replacement media free of defects in materials 
and workmanship, you may terminate this Agreement by 
returning the program and your money will be refunded. 

2. With respect to warranted programs, in all situations involving 
performance or nonperformance during the warranty period, your 
remedy is (a) the correction or bypass by DRI of program defects, 
or (b) if, after repeated efforts, DRI is unable to make the program 
operate as warranted, you shall be entitled to a refund of the 
money paid or to recover actual damages to the limits set forth 
below. 

3. For any other claim concerning performance or nonperformance by 
DRI pursuant to, or in any other way related to, the warranted 
programs under this Agreement, you shall be entitled to recover 
actual damages to the limits set forth below. 

4. IN NO EVENT WILL DRI, IT DISTRIBUTORS OR DEALERS, OR AUTHOR 
BE LIABLE FOR ANY LOST PROFITS, LOST SAVINGS, OR OTHER 
INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE 
USE OR INABILITY TO USE ANY PROGRAM OR OTHERWISE, EVEN IF 
DRI, ITS DISTRIBUTORS OR DEALERS, OR AUTHOR, HAS BEEN 
ADIVSED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY 
CLAIM BY ANY OTHER PARTY. 

5. SOME STATES AND JURISDICTIONS DO NOT ALLOW THE 
LIMITATION OR EXCLUSION OF LIABILITY FOR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATIONS OR 
EXCLUSION MAY NOT APPLY TO YOU. 
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6. The liability of DRI or its Distributors or Dealers to you for actual 
damages for any cause whatsoever, and regardless of the form of 
action, shall be limited to the greater of five thousand dollars 
($5,000.00) or the money paid for the program that caused the 
damages or that is the subject matter of, or is directly related to, 
the cause of action. 

7. SUPPORT SERVICE 

Support Service from DR!, if any, will be described in program 
specifications or in the statement of service, supplied with the 
program, if there are no program specifications. 

8. GENERAL 

You may not sublicense, rent, or lease this program. Any attempt to 
sublicense, rent, or lease or, except as expressly provided for in this 
Agreement, to transfer any of the rights, duties, or obligations 
hereunder is void. 

This Agreement will be construed under the Uniform Commercial Code 
of the State of California. 
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Warranty Support: 
Warranty Support is available to provide limited assistance with your product once you have tried to 
resolve the issue with the dealer from whom you obtained your product. Your dealer should always be 
your first choice for product assistance because that is the person who knows you and your product. The 
dealer also has priority access to technical information from Digital Research®. If your dealer cannot 
help, you may call Warranty Support at (408) 646-6464 for the following information: 

• responses to a limited number of common questions 
• information on replacement of a defective product 
• determination of whether a problem that you are having is a known problem 
• technical information on extensions of product capabilities or documentation 

Digital Research and its logo are registered trademarks of Digital Research Inc. 

DIGITAL RESEARCH® REGISTRATION CARD 
Please read the program license agreement before breaking the seal on the diskette package. If you do 
not agree to the licensing contract, you may return the package to your distributor/dealer for refund as 
long as the diskette package seal remains unbroken. Upon receipt of this registration card by Digital 
Research, you will become a registered user. Benefits to registered users may include the Digital 
Research News and notices of updates and enhancements to Digital Research software. 

I have read the Digital Research End User Program License Agreement and agree to abide by the terms 
contained in it. 

PLEASE PRINT 

YourNrune ________________________________________________________________ __ 

Comp~yName---------------------------------------------------------------

Street Address _____________________________________________________________ _ 

City ____________________________________ State _______ Zip _______ _ 

Country __________________ Postal Code ___________________ _ 

Phone Number ( ___ ) _________________________________________ _ 

Serial Number ___ _ __ -'-_ Date Obtained __________________ _ 

Product __________________________________ Version Number _____ _ 

Signature ___________________________________________________ _ 

Where Obtained: ______ Retail Store ____ Mail Order ____ M~ufacturer Rep. 

Computer Brand ________________________________________ _ 

Primary Use ____ -'Personal ______ nBusiness ______ LEducation 

How did you learn of this product? 

_____ Store Display 

____ Personal Recommendation 

_____ Magazine Article 

______ Magazine Advertisement 

____ Sales Person 

___ ~Other 

Other Digital Research Products Owned ______________________________________ _ 

Digital Research and its logo are registered trademarks of Digital Research Inc. 
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Reader Comment Card 
We welcome your comments and suggestions. They help us provide you with bettE 
product documentation. 

Date 

1. What sections of this manual are especially helpful? 

2. What suggestions do you have for improving this manual? What informatio 
is missing or incomplete? Where are examples needed? 

3. Did you find errors in this manual? (Specify section and page number.) 

GEM DesktopTM 
Second Edition: April 1985 
5054-2332-001 

COMMENTS AND SUGGESTIONS BECOME THE PROPERlY OF DIGITAL RESEARCH. 
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Drop-down menus give you a wide selection 
of commands at your fingertips, without 
cluttering up the screen. 

Use icons to perform a wide variety of 
commands. Pick up and open file folders. 
Switch disk drives. Or do calculations with 
the GEM Desktop built-in calculator. 

Copy or move information simply by 
moving icons (such as file folders) from one 
window to another. Or delete information 
si mply by dragging the appropriate file 
to the waste basket icon. 

505 -2332-001 

GEM DesktopTM software lets you control your camputer the most natural way 
possible - simply by pointing with a cursor ana presSing a button. Your 
computer's screen is arranged just like a desktop; with pictures of objects 
you 'll recognize at a glance. File folders. Disk drives. A calculator. What's more, 
GEM Desktop works with virtually every PC DOS appl ication, including 
WordStar,<lI> Lotus 1-2-3~ and Symphony.TM 
Just move a pointer on your screen to manipulate GEM Desktop drop-down 
menus, icons, and windows. Use a mouse, a graphics tablet, or, if you prefer, 
use your computer's arrow keys. Most importantly, GEM Desktop makes 
using your IBM PC easy! 

System Requirements: 

Use scroll bars to view the off-screen contents 
of any wi ndolV, and easi ly. 

Open any of your applications (such as 
spreadsheets, word processors, data bases, 
etc.) directly from GEM De ktop.Just point 
and push.a button. 

ColI/puters: IBM PC Family and IOOr., compatibles. 
Grapbics Requirements: Mu t have IBM Color Graphics Adaptor, IBM Enhanced Color Graphics 
Adaptor, Hercules Graphics Card, or compatibles. 
Pointers: Mouse Systems PC Mouse~ Microsoft Mouse~ SUlil)llagraphi cs" 12" Tablet, 
or compatibles. 
MinilllulIl Mem01y:256K RAM for PC DOS 2.X, 320K for PC DOS 3.X. 

GEM, GEM Desklop. Graphic EnviromncllI Manager, Ihe GEM IORG. tl i gi~11 Research. and Ihe tligiml Research lo!,'O are 
wddemarksor regislered Imdcmarksortligiml Research tnc. IBM is a regisll'red Imdemark orlmemalional Business 
Machines Corp. Hercules GmphiCS Card is a Imdemark or flercules ComplllerTedlllology. Mouse SI~lems and PC Mouse 
are Imdemarks or Mouse Sysll'ms Corp. Microsoft Mouse is a trademark or Microsoft CorporJlion. WordS"r is a reRislcred 

PRODUCT NAME 
IMPLEMENTATION 
VERSION NUMBER 
SERIAL NUMBER 

, 

GEM"'" Desktop 
PC DOS 
1.0 
5054 - 0000-004181 

---~./ 
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