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Roadmap for Section 2.5.

Lab experiments investigating:

® Process Execution

® Object Manager & Handles
O Interrupt Handling

® Memory Pools Labs

©® System Threads

® System Processes
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Process Info with Task Manager

® Processes tab: List of ® Applications tab: List of top
processes level visible windows
£l Windows Task Manager 2 Windows Task Manager |[_ | E‘ i‘
File Options View Help File Options View Windows Help
——————— Applications | Processes || Performance | Metworking
Applications | Processes | Performance || Metworking
Task Status
Microsoft PowerPoint - [dep353.ppt] Running
IITIEQE Mame PID CPU CPU Tin :,’,M MindManager - [Troubleshooting Process &M...  Running
CPUSTRES.EXE :00: B command Prompt - robocopy fz Vwedimgsre ... Running
tagkmgr = 2040 03 NEAE) B Calendar - Microsoft Outiook Runining
Acrobat.exe 308 01 0:00: B Command Prompt Running
POWERPNT.EXE 3638 o0 0:05: (L) Inbox - Microsoft Outlook Running
notepad.exe w76 00 0:004 %{f‘“‘ - Merosoft Qutiook —
eminder Running
calc.exe 3440 00 Q000 B dep353.ppt Runring
cmd .exe 3396 00 Q00
CLUTLOOK.EXE 3003 o 0:04:! « . ”/
planner .exe 2992 00 001z / Runnlng means
IEXPLORE.EXE 2563 o 0:09: A 11 I
e oty waiting for window
MNetint.exe 2196 Right-clickén a | messages
TFMFS.exe 1943 :

H End Task Switch Ti Mew Task...
pinger .exe 1oz | window and select [ Ewtosk [ swtchto J[ tewTask... | ‘
vmnat.exe 1704

: GO tO pI’OCESS" CPU Usage: 2% Commit Charge: 197M [ 11




% Process Details with Process
Explorer

® “Super Task Manager”

® Shows full image path, command line, environment variables,
parent process, security access token, open handles, loaded DLLs
& mapped files

*: Process Explorer - Sysinternals: www.sysinternals.com

File View Process Handle Options Search Help
H @ &R A dh
Process PID CPU Description Owner Session Ha#
Elgystem Idle Process 0 0 <access denied> 0 0
O System 4 0 NT AUTHORITY... 0 455
Csmss.exe 396 0 Windows NT Session Manager NT AUTHQORITY... 0 21
Blcsrss.exe 452 0 Client Server Runtime Process NT AUTHORITY... 0 510
i winlogon_ exe 0 Windows NT Logon Application NT AUTHORITY. 0
o explorer.exe 312 0 Windows Explorer DSOLOMONds... O 679
Bl ouTLOOK EXE 1312 0 Microsoft Outlook DSOLOMON\ds... O 435
B cmd exe 1980 0 Windows Command Processor DSOLOMONds... 0 48
£ hh.exe 1316 0 Microsoft® HTML Help Executable DSOLOMON\ds... 0 180
_Q procexp.exe 2932 0 Sysinternals Process Explorer DSOLOMONds... O b7 «
3 >
Handle Type - Access Name A5
0x634 Desktop 0x000F0TFF \Default
OxAC Desktop 0x000FOTFF YwWinlogon
0xB4 Desktop 0x000F01 FF \Disconnect
0xB8 Desktop 0x000F01 FF \Default
0x14 Directory 0x000F000F \Windows
0x28 Directory 0x0002000F \BaseNamedObjects
0x8 Directory 0x00000003 \KnownDlls
0x188 Event 0x00100000 \BaseNamedQObjects\WinSta0_DesktopSwitch
Ox1A0 Event 0x001F0003 \BaseNamedQObjects\ThemesStartEvent
0x1B0 Event 0x001F0003 \BaseNamedObjects\WFP_IDLE_TRIGGER ¥
< >
winlogon.exe pid: 476 Refresh Rate: Paused




2 The Process Explorer tool

Run Process Explorer & maximize window
Run Task Manager — click on Processes tab

Arrange windows so you can see both

> W

Notice process tree vs flat list in Task Manager

® |f parent has exited, process is left justified

Sort on first column (“Process”) and note tree view disappears
6. Sort Process column 2 more times and tree view returns

® Can also Click on View->Show Process Tree or press CTRL+T to
bring it back

/. Notice description and company name columns
8. Hover mouse over image name to see full path

9. Right click on a process and choose “Google”



Image Information

® Double click on Explorer.exe to  [REEEESIEES
bring up process properties N

Image File

Microzaoft PowerPaint

O I m ag e tab : E Microsoft Carparation

Wergion: 1000042050000

® Description, company name, A
. | C:\Program Files\Microzoft OfficetOffice] (\POWERPNT . EXE
version (from .EXE) - |

® Fullim ag e path EE?%EE‘:ZT?Wi.C!EESP”.'?'.ff.i'?f?”*'.-.'.f.“?‘ﬂ..E_'."*FE'WE.HF“T-E?SE.":
® Command line used to start o
process s oo
® Current directory Slaled  SOB05PM 1/8/2003
® Parent process | e
® User name
® Start time



Viewing the Process Tree

1. Look at process hierarchy with TLIST /T

® Start a Windows command prompt, then run

Notepad from command prompt, then look at TLIST
/T output

® Exit the command prompt and notice “orphan”
process with TLIST /T

2. Task Manager:

® Applications tab: find the process that owns a
window (right mouse click on window title)

® Process tab: add a few additional columns: Virtual
Memory size, Handle count, Thread count

® Windows: add I/O counters; right click on a process &
notice “end process tree” option



Viewing the Base HALSs

® Windows 2000/XP/2003 HALs (see \windows\driver cache\i386\driver.cab)

Hal.dll Standard PC (uniprocessor)
Halacpi.dll ACPI PC (uniprocessor)
Halapic.dll APIC PC (uniprocessor)
Halaacpi.dll APIC ACPI PC (uniprocessor)
Halmps.dll Standard PC (multiprocessor)
Halmacpi.dll ACPI PC (multiprocessor)
Win2000 only:

Halborg.dll Silicon Graphics (multiprocessor)
WinXP only:

Halsp.dll Compaq SystemPro (multiprocessor)

® Additional NT4 HALs (see Knowledge Base article 156358)

Halast.dll AST Manhattan SMP

Halcbus.dll Corollary C-bus Architecture

Halmca.dll IBM PS/2 or other Micro Channel-based PC
halmpsm.dll Micro Channel Multi Processor PC
Halncr.dll NCR System 3000 Model 3360/3450/3550
Haloli.dll Olivetti LSX5030/40

Halwyse7.dll Wyse Series 7000i Model 740MP/760MP

Hal486c¢.dll Standard PC with C-Step i486



Determining Which HAL You're

Running
® Selected at installation time

® See \windows\repair\setup.log to find out which one

® Can select manually at boot time with /[HAL= in

boot.Ini
Windows distribution Boot Partition:
CD-ROM:\i386 \windows\System32

NTOSKRNL.EXE,
NTKRNLPA.EXE,
NTKRNLMP.EXE,
NTKRPAMP.EXE

| NTOSKRNL.EXE
Windows Setup NTKRNLPA.EXE

HAL.DLL
HALACPI.DLL
...etc.

HAL.DLL

(see \windows\repair\setup.loQ)
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Determine the HAL

® Can also see by viewing the “device drivers” for the
Computer

Go to Control Panel->System — Hardware_tab

Driver File Details d b
O CI ICk O n ) DeVI Ce M a'n ag e r” \@i Adwvanced Configuration and Power Interface [BCF)
— FC
® Click on “Computer” e s

C:A\WIMMNT S peterm32hhal. dll

® Right click/Properties on “driver” fop/PC  [Eiinmasamnescro

_(o| x|
ﬂ Frovider: Microsoft Corporation
E-S5 Computer o Fils versior: 5.00.2121.1
P Advanced Configuration and Power Interface (ACPT) POC ;I
| S | Copyright:  Copyright [C] Microsoft Corp. 1981-1999

Screen snapshot from:

Control Panel | System | Hardware |
Device Manager | Computer properties |
Driver Details
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% Examining NTOSKRNL & HAL
Image Dependencies

*Tool: Dependency Walker (Depends.Exe in Resource Kit & Platform SDK)
*Allows viewing of image->DLL relationships, imports, and exports

® NTOSKRNL.EXE
® Executive and Kernel

© HAL.DLL

® Hardware Abstraction
Layer - interface to
hardware platform

® BOOTVID.DLL
® Boot video driver
® Added in Win2000
® KDCOM.DLL

® Kernel debugger
communication code

" Dependency Walker - [ntozkrnl] _|Of x|

B File Edit Miew MWindow Help

=18] x|

b ) R = = = T

Far Help, press F1

Ela HTOSKRML.E=E Ordinal ™ Hint | Function o
SR} HALDLLS @ M 0 [0%0000)  ExAcquireFastMute -
¢ hem | NTOSKRMLESE (|[E M/A 1 [0:0001] ExReleaseFasttutex
=] BOOTVID.OLL & N 2 [0:0002]  ExTrTodcquireFasttutes =

"] NTOSKRNLEXE | 4] | H
Al HALDLL Ordinal ~ | Hirt | Function -
[e] 1 [0=0001] O [0<0000) ExfcquireFasthutes b
[e] 2 [0=0002] 1 [0x0001) ExReleaseFasthutes
[el 3 [0=0003] 2 [0x0002] ExTryTobdcquireFastdutes  |=

1| | ]2 b

| Module - Time Stamp Size Attributes b achine Subsystem -

] BOOTVID.DLL [ 08413798 2002 10976 | AC Inbel w86 Mative

] HALDLL 03/13/98 &00a B1.536 | AC Intel »86 HMative b

q NTOSKRMHLEXE [ 08/13/98 8:00a( 1,287 580 | AC Intel 86 Mative x

4 3
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Installed Device Drivers

® Separate loadable modules (drivername.SYS)
® Linked like .EXEs
® Typically linked against NTOSKRNL.EXE and HAL.DLL

® Only one version of each driver binary for both uniprocessor (UP) and multiprocessor
(MP) systems...

® ... but drivers call routines in the kernel that behave differently for UP vs. MP Versions
® Defined in registry

® Same area as Windows services (t.b.d.) - differentiated by Type value
® Several types:

® “ordinary”, file system, NDIS miniport, SCSI miniport (linked against port drivers), bus
drivers

® More information in 1/O subsystem section
® To view loaded drivers, run drivers.exe

® Also see list at end of output from pstat.exe — includes addresses of each driver
® To view installed drivers:

® System properties->Hardware Tab->Device Manager

® Msinfo32->Software Environment->System Drivers
14



Peering Into Undocumented
Interfaces

® Exported symbols
® Functions and global variables Microsoft wants visible outside the
Image (e.g. used by device drivers)
® About 1500 symbols exported

® Ways to list:
® Dependency Walker (File->Save As)
® Visual C++ “link /dump /exports ntoskrnl.exe”

® Global symbols
® Over 9000 global symbols in XP/Server 2003 (Windows NT 4.0 was

4700)
® Many variables contain values related to performance and memory
policies
® Ways to list:
® Visual C++: “dumpbin /symbols /all ntoskrnl.exe” (names only)

® Kernel debugger: “x nt!*”
® Module name of NTOSKRNL is “NT” 15




Image Subsystem Type

® Look at subsystem startup information in registry

® Using EXETYPE, look at subsystem types for:

® \windows\system32\notepad.exe, cmd.exe,
CSrss.exe

16



Viewing Open Handles

® Process Explorer (GUI version) or handle (character
cell version) from www.sysinternals.com

® Uses a device driver to walk handle table, so doesn’t need
Global Flag set

Process Explorer - Sysinternals: wwww.sysinternals.com

File Wiew Process Handle Options Search Help
| =@ = * | ¢k
Process | P_. / | Description | Owner | Priority | Handles
"] System Idle Pr... 0 <access denied> 1} 1]
T System 4 NT AUTHORITYSYSTEM 8 257
Tlexplorer.exe 292 YWindows Explorer DSOLOMOM\dsolomon 8 hb7
Iﬁ SMSs.exe 380 Windows NT Session ... NT AUTHORITY\SYSTEM 11 22
1 csrss.exe 440 Client Server Runtime ... NT AUTHORITY\SYSTEM 13 366
;’ wvdtask exe 464 DSOLOMOMNAdsolomon B 30
4 netsrv.exe 500 DSOLOMOM\dsolomon 8 37
i winlogon.exe 528 Windows NT Logon Ap... NT AUTHORITYA\SYSTEM 13 h43 3
2& TS —— ran AT AT AT LA O SO T n ann s
Handle |T / Access | Name 2
Ox30 Desktop 0x000FO1FF  A\Default
0x18 Directory 0x000F000F  \Windows
0x38 Directory 0x0002000F ‘\BaseNamedObjects
oxC Directory 0x00000003 ‘\KnownDlls
0x164 Ewvent 0x001F0003 ‘\BaseNamedObjectsiuserenv: User Prof._.
0x274 Ewvent 0x001F0003 ‘\BaseNamedObjectsiShellReadyEvent
0x334 Ewvent 000100000 ‘\BaseMNamedObjects\crypt32LogoffEvent
0x35C  Ewvent 0x001F0003 ‘\BaseMNamedObjects\HPlugEjectEvent
0x394 Ewent 0x00100002 ‘\BaseNamedObjects\mixercallback 3
explorer.exe pid: 292 Refresh Rate: Paused




Experiment with Handle-tool

Handle View

®  Suggestion: sort by type or path column
® Objects of type “File” and “Key” are most interesting for general troubleshooting
® By default, shows named objects

® Click on Options->Show Unnamed Objects

Solve file locked errors

® Use the search feature to determine what process is holding a file or directory
open

® Can even close an open files (be careful!)

Understand resources used by an application

® Files

® Registry keys

Detect handle leaks using refresh difference highlighting

® Can also view the state of synchronization objects (mutexes, semaphores,
events)

18



Maximum Number of Handles

1. Run Process Explorer, and click View and then
System Information. Open a command prompt.

2. Run the testlimit -h

e When Testlimit fails to open a new handle, it will
display the total number of handles it was able to
create.

e |f the number is less than approximately 16 million, you
are probably running out of paged pool before hitting
the theoretical per-process handle limit.

3. Kkill the testlimit process by closing the command-
prompt window; thus closing all the open handles.

19



% Viewing Open Handles with
» Kernel Debugger

@ If looking at a dump, use 'handle in Kernel

Debugger (see help for options)
Ikd>handle O f 9e8 file

processor number 0
Searching for Process with Cid == 9e8
Searching for handles of type file

PROCESS 82ce72d0 Sessionld: O Cid: 09e8 Peb: 7ffdfO00 ParentCid: O6ec

DirBase: 06602000 ObjectTable: e1lc879¢c8 HandleCount: 430.
Image: POWERPNT.EXE

0280: Object: 82c5e230 GrantedAccess: 00120089

Object: 82c5e230 Type: (82fdde70) File
ObjectHeader: 82c5e218

HandleCount: 1 PointerCount: 1

Directory Object: 00000000 Name:
\slides\ntint\new\4-systemarchitecture.ppt {HarddiskVolumel}

20



® Run NotMyFault and select
“Leak Pool”

(available from
http://www.sysinternals.com
[files/notmyfault.zip)

O Allocates paged pool buffers
and doesn’t free them

@ Stops leaking when you
select “Stop Leaking”

File Options Wiew Help

Bpplications I Process

—CPU Usage ——

ec  Performance |

—CPU Usage Histary

—Takals —Physical Memory (1)
Handles 6801 Total 65076
Threads 423 Aveailable 4104
Processes 36 Syskem Cache 23752

—iCommit: Charge (k) —Kernel Memory (K)
Takal 132268 Tatal S0624
Lirnit 149344 Paged 44500
Peak, 131868 MNonpaged 524

Processes ' 36 CPU Usage: 6% Merm Usage: 132263K | 149344k 4

21



Determining the Maximum Pool
Sizes

® Three options:

1.

Poolmon (in Support Tools and Device
Driver Kit)

.Kernel Debugger 'Poolused command

.Driver Verifier (in Windows 2000 and later)

22



Mapping a System Thread to a

Device Driver

1. Generate network file access activity, for
example:
“dir \computername\c$ /s”

e System process should be consuming CPU
time

Open System process process properties
Go to Threads tab
Sort by CPU time and find thread(s) running

L

Determine what driver these are In

23



ldentifying System Threads In the
System Process

® To really understand what’s going on, must find
which driver a thread “belongs to”

® With standard user-mode tools:

1. PerfMon: monitor %Processor time for each thread in
System process & determine which thread(s) are
running

2. Pviewer: get “Start address” (address of thread
function) of running thread(s)

3. Pstat: find which driver thread start address falls in

» Look for what driver starts near the thread start address

24



Solitaire as a Service

® Create a service to run Sol.exe

Sc create dumbservice binpath= c:\windows\system32\sol.exe
©® Start the service

©® Use the GUI, or type “sc start dumbservice”, or “net start..”

® Quickly run Process Explorer and look at handle table
for sol.exe

® Notice name of Windowstation object

® Open services.msc,; mark service “Allow Service to
Interact with Desktop”

® Start the service again and in Process Explorer, look at
handle table for sol.exe

® Notice name of Windowstation object

25



Listing Installed Services

® Not always a 1-to-1 mapping

® Some service processes contain more than one service

® Conserves virtual memory, reduces boot time

® This is up to the developer of the service

® Service properties displayed through Control Panel
(services.msc) show name of .EXE

® But not which process the services is running in

DHCP Client Properties {Local Computer) ed

General |Ln:ug EInI Flecwer_l,ll Dependenciesl

Service name: Dhep

Dizplay name:

Frescnption: b anage ik, configuration by registenng and updz
Fath to executable:
: CES EXE

26



Viewing Service Detalls Inside
Service Processes

® Tlist /S (Debugging Tools) or Tasklist /svc (XP/2003) list
Internal name of services inside service processes

® Process Explorer shows more: external display nhame

and description

nce a
% Semvices registered in this process:

| Service Display Name *
[AudioSrv _ Windows Audio |
|BITS Background Intelligent Transfe
|Browser Computer Browser

CryptSvc Cryptographic Services

|Dhep DHCP Client

fdmser\rer Logical Disk Manager

|ERSwvc Error Reporting Service L3
[ 4
Manages audio devices for Windows-based programs. If thiz zervice is
stopped, audio devices and effects will not function propery. | this
zervice iz dizabled, any services that explicitly depend on it will Fail to

shart

27



Viewing Services Running Inside
Processes

1. Open acommand prompt

2. Type “tasklist /svc”

3. Find the Svchost.exe process with the most services
Inside it

4. In Process Explorer, double click on that Svchost.exe
process

9. Click on Services tab

6. Notice extra details about each service displayed by
Process Explorer

28



Service Configuration &
Control Tools

® To view & control services:

® Control Panel->Administrative Tools->Services

4, Services |0 x|
J dckion  View J = =) | | | @ |J boE Il mr

Tree I Mame £ | Descripkion | Skatus | Startup Twpe | Log On As | -
W .ﬁ.lerter Motifies selected users and computers of. .. Manual LocalSystem |

Application Management:

%Clipﬁunk

Pravides software installation services ...

Supports ClipBoak Yiewer, which allows ..

Skarted

Manual
Manual

LocalSwstem

LocalSwstem

%CDWH Event Syskem Provides automatic distribution of event...  Started Manual LocalSwstem
%Cnmputer Browser Maintains an up-to-date lisk of computer...  Started Aukomatic LocalSwstem
%DHCF‘ Clienk Manages network, configuration by regis...  Started Aukomatic LocalSwstem
%Distrihuted Link Tracking Client Sends notifications of files mowving bekwe, ., Started #ukomatic Local3ystem
%Distrihuted Transackion Coordinator  Coordinates transactions that are distrib, .. Manual Local5ystem

1 | | LI %DNS lient Resolves and caches Domain Mame Sysk.,.  Started #ukomatic Local3ystem ll

® No option to add/remove — done at install/uninstall time
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