Cisco Router Handbook

Warning! This document has been designed to be viewed with a frames-capable browser. Please obtain a frames-capable browser such as Netscape Navigator or Microsoft Internet Explorer before attempting to view this document.

Or, if you would prefer to view this document without frames, click onno frames.


HTMLHelp File Created Using:

Web2HTMLHelp 		Free To Download From:
http://www.web2htmlhelp.co.uk

Also Available:
HTMLHelp ePublisher
HTMLHelp eDocument Creation Made Easy

Free To Download From:
http://www.htmlhelp-epublisher.co.uk

[ Back ]


Cisco Router Handbook - Beta Version

 Chapter: 1 | 2 | 3 | 4 | 5 | 6
Sackett
$70.00 0-07-058098-7

Chapter One

Cisco IOS Software

We have all heard the saying "It’s what’s inside that counts" at some point in our lives. In the world of networking Cisco’s Internetwork Operating Systems (IOS) has taken that saying to heart. The very core of Cisco Systems phenomenal success is the breadth of services provided by the Cisco IOS software.

No two networks are exactly alike. There are connectivity requirements that differ between healthcare and manufacturing, entertainment and shipping, finance and telecommunications. Each of which has different security issues. Each requires the ability to scale with reliability and manageability. The Cisco IOS software has proven to meet these criteria and to build on new requirements due to its flexibility in meeting the rapid changing network requirements of all businesses.

  1. Benefits

    2. Cisco IOS software provides a foundation for meeting all the current and future networking requirements found in today’s complex services driven business environments. Businesses rely heavily on generating income from their network infrastructure. Cisco IOS software has the broadest set of networking features primarily based on international standards allowing Cisco products to interoperate with disparate media and devices across an enterprise network. Most importantly, Cisco IOS software enables corporations to deliver mission-critical applications seamlessly between various computing and networking systems.

    1. Scalability

      2. The network infrastructure for every corporation must be flexible to meet all the current and future internetworking requirements. Cisco IOS software uses some proprietary but also adheres to international standards for congestion avoidance using scalable routing protocols. These routing protocols allow a network using Cisco IOS to overcome network protocol limitations and deficiencies inherent in the protocols architectures. Additional features in scaling an efficient use of bandwidth and resources is the ability of the IOS software is detailed packet filtering for reducing "chatty" protocol traffic as well as reducing network broadcasts through timers and helper addresses. All these features and more are available with the goal to reduce network traffic overhead thereby maintaining an efficient yet effective network infrastructure.

    2. Adaptiveness

      3. Network outages occur frequently in corporate networks. However, many times these outages are not effecting the flow of business do to the reliability and adaptiveness of the policy-based IOS software routing features. Using routing protocols, each Cisco router can dynamically decide on the best route for delivering packets through the network around outages thereby providing reliable delivery of information. The prioritization of packets and services enables Cisco routers to adapt to bandwidth constraints due to outages or high bandwidth utilization. IOS software load balances traffic throughput over various network connections preserving bandwidth and maintaining network performance.

      The concept of virtual LANs has become a reality for many corporate networks. Cisco routers have the ability to participate in these virtual LANs using emulated LAN functions for physical LAN extensions and ATM LAN Emulation (LANE) services. These are just two of the many newer networking technologies incorporated into the IOS software feature set enabling networks to implement newer technologies without the added expense of new hardware.

    3. Access support

The Cisco IOS software access support encompasses remote access and protocol translation services. These services provide connectivity to:

    • Terminals
    • Modems
    • Computers
    • Printers
    • Workstations

There are various network configurations for connecting these network resources over LANs and WANs. LAN terminal service support is:

    • TCP/IP support for Telnet and rlogin connections to IP hosts.
    • TN3270 connections to IBM hosts.
    • LAT connections to DEC hosts.

Over WANs Cisco IOS, software supports four flavors of server operations. These are:

    • Connectivity over a dial-up connection supporting AppleTalk Remote Access (ARA), Serial Line Internet Protocol (SLIP), compressed SLIP (CSLIP), Point-to-Point Protocol (PPP), and Xremote (Network Computing Device’s (NCD) X Window System terminal protocol.
    • Asynchronous terminal connectivity to a LAN or WAN using network and terminal emulation software supporting Telnet, rlogin, DEC’s Local Area Transport (LAT) protocol, and IBM TN3270 terminal protocol.
    • Conversion of a virtual terminal protocol into another protocol. LAT-TCP or TCP-LAT communication between a terminal and a host computer over the network.
    • Support for full Internet Protocol (IP), Novell Internet Packet Exchange (IPX), and AppleTalk routing over dial-up asynchronous connections.
      1. Performance Optimization

Optimizing networks requires network equipment to dynamically make decisions on routing packets cost effectively over the network. Cisco IOS software has two features that can greatly enhance bandwidth management, recovery and routing in the network. These two features are dial-on-demand access (DDA) and dial-on-demand routing (DDR).

DDA is useful in several scenarios. These are:

    • Dial backup
    • Dynamic bandwidth

In many instances connectivity to a location fails because of a modem, DSU/CSU failure or the main telecommunications line to the office is disrupted in some way. A good network design has a backup solution for this type of outage. Using DDA a router can sense the line outage and perform a dial backup connection over a switched serial, ISDN, T1, or frame relay. In this manner, the office maintains connectivity to the WAN with minimal downtime. The DDA function monitors the primary line for activation and can cut back to the primary connection automatically if so desired.

DDA features the ability to determine a low and high bandwidth watermark on the permanent lines. This feature allows the addition of temporary bandwidth to another location to meet throughput and performance criteria. The IOS monitors the permanent line for high bandwidth utilization. If the bandwidth reaches the defined threshold DDA is enabled to add extra bandwidth to the remote location of the permanent line. IOS continues to monitor the bandwidth for utilization to fall under the threshold for a period of time. Once low water mark is reached, IOS disconnects the DDA line. Using DDA in this fashion enables the IOS to maintain performance criteria between the two locations.

DDR allows Cisco routers to create temporary WAN connections based on interesting packets. IP, Novell IPX, X.25, Frame Relay and SMDS destination addresses may be specified under DDR as interesting packets. Once the router interprets the packet and determines it is and interesting packet it performs the dial up connection to the destination network specified in the packet that corresponds to the DDR configuration. In this way, connectivity to remote locations are provided on a temporary basis thereby saving network connectivity costs.

      1. Management

        2. Cisco IOS software supports the two versions of Simple Network Management Protocol (SNMP) for IP based network management systems, Common Management Interface Protocol (CMIP)/Common Management Interface Service (CMIS) for OSI based network management systems and IBM Network Management Vector Transport (NMVT) for SNA based network management systems. These management protocols are pertinent to the type of network supported by the Cisco router. The IOS itself has the ability for an operator to perform configuration management services, monitoring and diagnostics services using the IOS command interface.

        Cisco Systems has a suite of network management tools under the name of CiscoWorks. CiscoWorks is a set of network management tools that work with Cisco IOS for change, configuration, accounting, performance and fault management disciplines.

      2. Security

Cisco IOS software supports many different types of security capabilities. Some of these, such as, filtering, are not usually thought of as a security feature. Filtering, for example, was actually the first means of creating the now infamous firewall techniques for corporate connectivity the Internet prior to actual commercial offerings. Secondly, filtering can be used to partition networks and prohibit access to high security server networks. The IOS has the ability to encrypt passwords, authenticate dial-in access, require permissions on changing configurations and provides accounting and logging to identify unauthorized access.

The IOS supports standard authentication packages for access to the router. These are RADIUS and TACACS+. Each security package requires unique user identification for access to the router. These security packages offer multilevel access to IOS command interface functions.

    1. Packaging

      2. The ordering of Cisco IOS software has been streamlined into feature sets. Prior to IOS Version 11.2 the IOS software was built based on the router requirements. A second enhancement to the delivery of IOS software is the use of feature packs. Feature packs allow you to order the IOS software images and a Windows 95 utility to load the image on the router.

      1. Feature Sets

Each feature set contains a standard offering. However, options are provided to enable the IOS software to meet more specific needs. Each hardware platform has a feature set. For the most part, all the routers share the same feature sets. The sets are broken down into three categories. These are:

    • Basic: The basic feature set for the platform.
    • Plus: The basic feature set plus added features depending on the platform.
    • Encryption: 40-bit (Plus 40) or 56-bit (Plus 56) data encryption feature sets with the basic or plus feature set.

The list of features and feature sets and the platforms supporting them are found in Appendix A.

      1. Feature Packs

IOS Release 11.2 introduces software feature packs. Feature packs offer a means for receiving all materials including software images, loading utilities and manuals on CD-ROMs. Each feature pack contains two CD-ROMs. The software CD-ROM contains:

    • IOS software images
    • AS5200 modem software images
    • Windows 95 software installer program

A second CD-ROM is included providing the Cisco IOS software documentation reference library. The remaining documentation provided by the feature pack includes an instruction manual for using the Windows 95 software installer program, release notes for the IOS release included on the software CD-ROM and the software license.

    1. Features Supported

      2. All the features found in the matrices of Appendix A are applicable to each router and access server platform. These features cross a wide range of services and functions to take into account old, current and future network configurations.

      1. Protocols

Cisco IOS supports a wide array of networking protocols. Of these protocols, Transmission Control Protocol/Internet Protocol (TCP/IP) is by far the most widely used.

TCP/IP

Cisco IOS software supports TCP/IP features:

    • IP access lists
    • IP Security Option (IPSO)
    • IP accounting
    • Simple Network Management Protocol (SNMP)
    • Serial Line Interface Protocol (SLIP)
    • Address Resolution Protocol (ARP)
    • Reverse Address Resolution Protocol (RARP)
    • Domain Name System (DNS) support
    • Internet Common Message Protocol (ICMP)
    • Internet Group Management Protocol (IGMP)
    • User Datagram Protocol (UDP)
    • Telnet
    • TN3270
    • Trivial File Transfer Protocol (FTP)

Release 10 and 10.3 of IOS introduced new features to already existing standards that have given Cisco routers the ability to provide higher level of security, greater availability, and increase network scalability. Among these features are:

    • Hot Standby Router Protocol (HSRP) and Multigroup HSRP
    • Next Hop Resolution Protocol (NHRP)
    • Department of Defense Intelligence Information System Network Security for Information Exchange (DNSIX) extended IPSO
    • Type of Service (TOS) queuing
    • Cisco Discovery Protocol (CDP)
    • Border Gateway Protocol (BGP) Communities

With the introduction of release 11 and 11.1 the Cisco IOS software enhances router functionality in the areas of security, performance, and routing services. The major enhancements for these releases are:

    • Route Authentication with Message Digest 5 (MD5) encryption algorithm
    • IP Access Control List (ACL) Violation Logging
    • Policy based routing
    • Weighted fair queuing
    • NHRP on IPX
    • Fast Install for Static Routers
    • Fast Switched GRE
    • RIPV2

Release 11.2 implements more routing protocol enhancements, IP address translation features and access control list usability. The major features introduced are:

    • On Demand Routing (ODR) for stub routers
    • OSPF On Demand Circuit (RFC1793)
    • OSPF Not-So-Stubby-Area (NSSA)
    • BGP4 enhancements
    • Soft Configuration
    • Multipath
    • Prefix filtering with inbound route maps
    • Network Address Translation (NAT)
    • Named IP access control list
    • Integrated routing and bridging (IRB)

ISO CLNS

The Open Systems Interconnection (OSI) reference model implements the International Organization for Standardization (ISO) Connectionless Network Service (CLNS) as the network layer protocol. Cisco IOS fully supports the forwarding and routing of ISO CLNS. The ISO standards and Cisco implemented features supported by Cisco IOS are:

    • ISO 9542 End System-to-Intermediate System (ESIS) routing protocol
    • ISO 8473 Connectionless Network Protocol (CLNP)
    • ISO 8348/Ad2 Network Service Access Points (NSAP)
    • ISO 10589 Intermediate System-to-Intermediate System (IS-IS) routing protocol
    • DDR for OSI/CLNS
    • Connection-Mode Network Service (CMNS) for X.25 using NSAP

DECnet Phase IV and Phase V

Cisco routers have supported DECnet for sometime. IOS software has full functional support of local- and wide-area DECnet Phase IV and Phase V routing on all media types. Currently, Cisco IOS supports these enhanced DECnet features:

    • DECnet dial-on-demand (DDR)
    • Dynamic DECnet Route Advertisements
    • DECnet Host Name to Address Mapping
    • Target Address Resolution Protocol (TARP) support over SONET

Novell IPX

Since IOS release 10.0, Cisco IOS provides complete IPX support. Beginning with release 10.3, IOS enhancements for Novell have centered on performance, management, security and usability. These enhancements are:

    • Novell Link State Protoc0l (NLSP)
    • IPXWAN 2.0
    • IPX Floating Static Routes
    • SPX spoofing
    • Enhanced IGRP to NLSP Route Redistribution
    • Input Access Lists
    • Per-Host Load Balancing
    • NLSP Route Aggregation
    • Raw FDDI IPX encapsulation
    • IPS Header Compression
    • Display SAP by name
    • IPX ACL Violation logging
    • Plain English IPX Access Lists

AppleTalk Phase 1 and Phase 2

AppleTalk has been a long standing supported protocol on Cisco IOS software. Extended and non-extended networks under AppleTalk Phase 2 are supported. Cisco IOS routes AppleTalk packets over all media types. The AppleTalk features implemented by Cisco IOS are:

    • MacIP
    • IPTalk
    • SNMP over AppleTalk
    • Routing Table Maintenance Protocol (RTMP)
    • AppleTalk Update-Based Routing Protocol (AURP)
    • AppleTalk over Enhanced IGRP
    • Inter-Enterprise Routing
    • AppleTalk Name Binding Protocol (NBP) Filtering
    • AppleTalk Floating Static Routes
    • Simple Multicast Routing Protocol (SMRP)
    • AppleTalk load-balancing
    • SMRP fast switching

Banyan VINES

Banyan’s Virtual Integrated Network Service (VINES) is supported on all media types with Cisco IOS software. The VINES routing protocol itself automaticallydetermines a metric for delivering routing updates. This metric is based on the delay set for the interface. Cisco IOS enhances this metric by allowing you to customize the value for the metric. Other enhancements and features supported on Banyan VINES using Cisco IOS are:

    • Address resolution in response to address requests and broadcast propagation
    • MAC level echo support to Ethernet, IEEE 802.2, Token ring and FDDI
    • Name to address mapping for VINES host names
    • Access list filtering of packets to or from specific networks
    • Routing Table Protocol (RTP)
    • Sequenced Routing Update Protocol (SRTP)
    • VINES DDR
    • Floating static routes

Xerox Network System (XNS)

XNS is the foundation for Novell IPX protocol. As such, Cisco IOS supports a XNS routing protocol subset of the XNS protocol stack. XNS is supported on Ethernet, FDDI, Token Ring, point-to-point serial lines using HDLC, Link Access Procedure Balanced (LAPB), X.25 Frame relay and SMDS networks.

Apollo Domain

Apollo workstations use the Apollo Domain routing protocol. Cisco IOS supports packet forward and routing of this protocol on Ethernet FDDI, HDLC and X.25 encapsulation.

HP Probe

HP Probe is a protocol used by HP devices that provides machine name resolution to the physical IEEE 802.3 address. Cisco routers acting as HP Probe Proxy servers on IEEE802.3 LANs allows the router to resolve the machine name to IEEE 802.3 address eliminating the need for a separate server on each IEEE802.3 LAN saving corporate resources.

Multiring

Cisco IOS supports the framing of Layer 3 protocol packets in Source Route Bridging packets using the Multiring protocol. Multiring is primarily used for Token ring networks.

      1. Management

        2. Cisco IOS software supports the three network management schemas: SNMP, CMIP/CMIS and IBM NMVT. These network management schemas use by network management applications executing on workstations, minicomputers or mainframes. For the most part, they use a client/server type of architecture between the router and the management system.

        IOS release 11.2 introduced the ability to manage Cisco routers using HyperText Transfer Protocol (HTTP) from Web browsers. HTTP utilizes HyperText Markup Language (HTML) for navigating web pages from a browser. Cisco routers at release 11.2 or higher have the capability of presenting a home page to a web browser. The default home page allows you to IOS command line interface commands using Web-like hot links. This home page is modifiable to meet the needs of any router or organization.

        Specific to the Cisco 7200 series router is a logical representation of the router hardware configuration using HTTP. With this enhancement, the operator, using a pointing device such as a mouse, points to the logical view of a router interface and clicks on it to display the status or modify the interfaces configuration.

        Building on the ease of operation using Web-based interfaces, Cisco has implemented a Web-based application on the Cisco access product line called ClickStart. The ClickStart interface, beginning in release 11.0, presents at installation an initial setup form guiding the operator through router configuration. Once the router is configured and connected to the network it is manageable from any central location. ClickStart is available on the Cisco 700, 1000 and 1600 access routers

      2. Multimedia and QoS

        3. The advent of higher bandwidth and technologies enabling the integration of audio, video and data on the same network medium have given rise to the need for supporting multimedia applications with guaranteed service. Cisco IOS release 11.2 meets the quality of service (QoS) requirement of multimedia applications Resource Reservation Protocol (RSVP), Random Early Detection (RED) and Generic Traffic Shaping.

        RSVP is an IETF standard that enables applications to dynamically reserve network resources (i.e., bandwidth) from end-to-end. Video or audio feeds over the network can now co-exist with bursty data traffic without the needs for parallel networks. Each router or networking device used on the path between the two end resources requiring RSVP participate in delivering the QoS demanded by the multimedia application.

        Network congestion is monitored and managed through the implementation of Random Early detection (RED). During peak traffic loads, transmission volume can lead to network congestion. RED works in concert with RSVP to maintain end-to-end QoS during these peak loads by selectively dropping traffic at the source using TCP slowstart characteristics. Thus, the source stations feeding into the network slow down their feed until the network metrics defined for the low-water mark against RED are met.

        Generic traffic shaping works in a similar fashion to RED. However, generic traffic shaping, also called interface independent traffic shaping, reduces the flow of outbound traffic to the network backbone. This takes effect when a router connecting to a network backbone composed of Frame Relay, SMDS or Ethernet, receives Layer 2 type congestion packets from down stream network transport devices. Generic traffic shaping throttles back the outbound traffic entering the backbone network at the source of entry.

      3. Secure Data Transmission

        4. Security, privacy and confidentiality over public or untrusted IP networks are paramount for using Virtual Private Networks (VPN). Cisco IOS release 11.2 reduces the exposure by enabling the ability to provide router authentication and network–layer encryption. Router authentication enables two routers to exchange a two-way Digital Signature Standard (DSS) public keys before transmitting encrypted traffic over VPNs using generic routing encapsulation (GRE). The exchange is performed once to authenticate the routers by comparing the hash signature of the keys.

        Network-layer encryption uses Diffie-Hellman keys for security. These keys form a Data Encryption Standard (DES) 40- or 56-bit session key. The keys are configurable and set a "crypto-map" that use extended IP access lists to define network, subnet, host and/or protocol pairs requiring encryption between routers.

      4. Support for IBM networking environments

Cisco has been the leader in providing SNA and NetBIOS support over IP networks. Cisco IOS has several means for transporting IBM type traffic, specifically SNA, over router backbone networks. The basis for the transport is encapsulation. Cisco IOS has five different encapsulation techniques and supports full APPN functionality in its native form. The five-encapsulation techniques are:

    • Remote Source Route Bridging (RSRB)
    • Serial Tunneling (STUN)
    • Data Link Switching Plus (DLSw+)
    • Frame Relay RFC 1490
    • Native Client Interface Architecture (NCIA)

Along with the five-encapsulation techniques, Cisco IOS supports SDLC –to-LLC2 (SDLLC) conversion. This allows SNA devices suing IBM SDLC protocol to attach serially to the router, as if the router were functioning as an IBM front-end processor. SDLLC converts the SDLC frame into a LLC2 frame for transmission using RSRB or DLSw+ to the mainframe.

IBM configuration and connectivity are also enhanced using Cisco IOS as TN3270 Server and as a Downstream Physical Unit (DSPU). TN3270 is an IETF RC standard that allows non- –SNA devices to act as IBM 3270 terminals. Routers using Cisco IOS can act as a TN3270 Server for these devices and present their representation to the mainframe as IBM 3270 terminals attached to IBM 3174 Control Units. The DSPU feature allows a Cisco router to have up to 255 logical SNA physical units attached to it and representing all of them as a single IBM SNA physical unit.

Direct connectivity to the mainframe from a Cisco router is using a Channel Interface Processor (CIP). The CIP can connect the Cisco 7x00 router series to the mainframe using ESCON or block multiplexing channel connectivity. The CIP provides for SNA, TCP/IP services for connecting to the mainframe.

Two management enhancements for supporting IBM SNA over Cisco routers enable SNA network management and performance. Cisco IOS now supports IBM NMVT command set for sending alerts to the mainframe network management system (i.e., NetView) when SNA devices defined to the router have outages or errors. The IOS also has a Response Time Reporter (RTR) feature allowing operators to analyze SNA response time problems on each leg of the path to the mainframe form the end user device. This is extremely important to determine bottlenecks in the Cisco router network affecting SNA response time problems.

      1. IP Routing Protocols

Cisco IOS supports a variety of routing protocols. Two of these are Cisco developed and therefore considered proprietary. All other routing protocols are international standards. The two Cisco routing protocols are Interior Gateway Protocol (IGRP) and Enhanced (IGRP).

IGRP supports IP and ISO CLNS networks. IGRP has its roots in distance vector transport routing schemas with enhancements for determining the best route based on bandwidth along the route. In this decision process, IGRP assumes that the route with the least amount of hops and the higher bandwidth should be the preferred route. However, it does not take into account bandwidth utilization and can therefore itself overload a route and cause congestion. Enhanced IGRP utilizes the Diffusing Update Algorithm (DUAL) along with its roots in link state routing protocols to determine the best path between two points. Enhanced IGRP merges the best of distance vector and link state routing algorithms to provide greater route decision making control. Enhanced IGRP has support for routing IP, AppleTalk and IPX natively.

The following list provides the remaining open standard routing protocols available for use on Cisco routers:

    • Routing Information Protocol (RIP)
    • RIP2
    • Exterior Gateway Protocol (EGP)
    • Border Gateway Protocol (BGP)
    • BGP4
    • Protocol Independent Multicast (PIM)
    • Intermediate System – Intermediate System (IS-IS)
    • Next Hop Routing Protocol (NHRP)
      1. Bridging

Independent Local Area Networks (LANs) have traditionally been bridged together to expand their size and reach. There are two bridging techniques that all others are based on: Transparent and Source Route. Transparent bridging is also known as a learning bridge. This type of bridge is the type typically found bridging Ethernet LANs. Cisco IOS supports the following Transparent bridging features:

    • IEEE 802.1(d) Spanning-Tree Protocol
    • IEEE 802.10 virtual LANs
    • DEC spanning tree
    • Bridging over X.25 and Frame Relay networks
    • Remote bridging over synchronous serial lines

Source Route bridging provides the path between session partners within the frame itself. Transparent bridging has been coupled with Source Route bridging to allow both techniques to be operable on the same interface. This bridging technique is known as Source Route Transparent (SRT) bridging. Another type of bridging that enables the passing of LAN frames from an Ethernet to a Token Ring LAN is called Source Route/Translational Bridging (SR/TLB). This bridging technique, for example, enables SNA devices on an Ethernet to communicate with the mainframe off a Token ring LAN.

      1. Packet Switching

Packet switching has its foundation in X.25 networks. Today, the most wide spread use of packet switching is considered to be frame relay. Cisco provides packet switching for frame relay, SMDS, and X.25 for corporate network support. The most comprehensive of these is frame relay. Cisco IOS supports the following functions and enhancements to frame relay networking:

    • Virtual interface
    • TCP/IP header compression
    • Broadcast queue
    • Frame Relay switching
    • RFC 1490-multiprotocol encapsulation
    • RFC 1293-Frame Relay Inverse ARP for IP, IPX, AppleTalk, and DECnet
    • Discard eligible (DE) or tagged traffic bit support
    • LMI, ANSI Annex D, and CCITT Annex A support
    • Dial backup
    • Frame Relay over ISDN
    • Autoinstall over Frame Relay
    • RFC1490 - Transparent bridging
    • Frame Relay dial backup per DLCI
    • Fast Switched Frame Relay bridging
    • DLCI Prioritization
    • Frame Relay Switched Virtual Circuit (SVC) support
    • Dynamic modification of network topologies with any-to-any connectivity
    • Dynamic network bandwidth allocation or bandwidth-on-demand
    • Backup for PVC backbones.
    • Resources allocated only when the connection is required to transfer data in private networks.
    • Traffic shaping over Frame Relay
    • Rate enforcement on a per VC basis
    • Per VC backward explicit congestion notification (BECN) support
    • VC level priority/custom/weighted-fair queuing (PQ/CQ/WFQ) support
      1. NetFlow Switching

        2. Details of session flows through the router network used to be an elusive quest for the network management team. Cisco IOS NetFlow Switching provides "call detail recording" of traffic through the network on both the network and transport layers. This allows Cisco IOS to manage traffic on a per-user, per application basis. It does this using a connection-oriented model of the end-to-end flows, applying relevant services to the flow of data. What makes NetFlow even more attainable it is accomplished in software without added hardware features on the Cisco 7500 and 7000 series routers using Route Switch Processor (RSP) or Versatile Interface Processor (VIP) boards.

      2. ATM

Cisco IOS is fully compliant with all the ATM standards. Cisco itself is very active in establishing the ATM standards and as such has a complete feature set. Cisco IOS supports all the ATM standards including the following:

    • ATM Point-to-Multipoint Signaling
    • ATM Interim Local Management Interface (ILMI)
    • RFC 1577-Classical IP and ARP over ATM
    • SVC Idle Disconnect
    • Bridged ELANs
    • LANE (LAN Emulation) MIBs
    • SSRP (Simple Server Redundancy Protocol) for LANE
    • HSRP for LANE
    • DECnet routing support for LANE
    • UNI 3.1 signaling
    • Rate queues for SVCs per subinterface
    • AToM MIB
      1. Dial-on-demand Routing

As mentioned earlier, Cisco support dial-on-demand services that enhances the availability and performance of internetworks. Dial-on-demand routing (DDR) uses switched circuit connections through public telephone networks. Using these switched circuits allows Cisco routers to provide reliable backup and bandwidth optimization between locations. The features supported by Cisco DDR include:

    • POTS via an external modem
    • SW56 via an external CSU
    • ISDN (BRI and PRI) via integrated ISDN interfaces or external terminal adapters
    • Dial backup
    • Supplementary bandwidth
    • Bandwidth-on-demand
    • Snapshot routing
    • Multiprotocol routing and transparent bridging over switched circuits
    • ISDN fast switching
    • Asynchronous ISDN access
      1. Access Server

Cisco routers that function primarily as devices for remote users to access the network are referred to as access servers. These access servers support all the features of dial-on-demand with enhancements to support terminal types, connection protocols, security, management, and virtual private networks over the Internet. Access servers provide the following services and features:

    • Asynchronous terminal services - includes X.25 packet assembler/disassembler (PAD), TN3270, Telnet, and rlogin.
    • Remote node access over a telephone network using Point-to-Point Protocol (PPP, IPCP, and IPXCP), Xremote, SLIP, and compressed SLIP (CSLIP), AppleTalk Remote Access (ARA) protocol versions 1 and 2 and MacIP
    • Multichassis Multilink PPP (MMP) – an aggregate methodology for sharing B channels transparently across multiple routers or access servers
    • Asynchronous routing - IP, IPX, and AppleTalk routing
    • TN3270 enhancements
    • PPP/SLIP on protocol translator virtual terminals
    • TACACS+
    • TACACS+ single connection
    • TACACS+ SENDAUTH function
    • ATCP for PPP
    • Asynchronous mobility – connects users to private networks through public networks, e.g., Internet.
    • Asynchronous callback – router recognizes a callback request and initiates the callback to the caller
    • Asynchronous master interfaces – template of standard interface configuration for multiple asynchronous interfaces on the access server
    • ARAP and IPX on virtual asynchronous interfaces
    • Local IP Pooling – pool of reusable IP addresses assigned arbitrarily to asynchronous interfaces
    • Remote node NetBEUI – uses PPP Network Control Protocol (NCP) for NetBEUI over PPP called NetBIOS Frames Control Protocol (NBFCP)
    • Modem auto-configuring – auto-discovery and auto-identification of attached modems allowing for automatic modem configuration
    • NASI (Novell Asynchronous Services Interface)
    • RFC 1413 Ident
    • RADIUS (Remote Authentication Dial-In User Service)
    • Virtual Private Dial-up Network (VPDN)
    • Dialer profiles
    • Combinet Packet Protocol (CPP)
    • Half bridge/half router for CPP and PPP
      1. LAN Extension

Cisco central site routers, like the 7x00 series, can extend their LAN connectivity over a WAN link using Cisco IOS LAN Extension. The central site router configures LAN Extension services to a multilayer switch at the remote site in a hub-and-spoke configuration. This connection provides a logical extension of the central sites LAN to the remote.

LAN extension is a practical use of Cisco’s CiscoFusion architecture. CiscoFusion describes the combined use of Layer 2 switching or bridging with Layer 3 switching or routing. This combination provides transparent connectivity under LAN extension supporting IP, IPX, AppleTalk, DECnet, VINES and XNS protocols. Since LAN extension supports functions of Layer 2 and 3, MAC address filtering and protocol filtering and priority queuing are accomplished over the WAN links for efficient use of bandwidth.

Backward Forward


Sackett
$70.00 0-07-058098-7

Chapter Two

Cisco Router Hardware

The Cisco router product line has three flavors. Cisco routers are available as modular, fixed or combination configurations. Along with full router configuration Cisco offers router platforms on personal computer (PC) card format. Additionally, Cisco combines routers and small hubs into one device suitable for small office installations. Key to a successful implementation of Cisco routers in a networking environment is proper placement and configuration of the router. Each Cisco router offering is suited for a specific function. These functions are depicted in Figure 2.1 as core, distribution and access. These functional characteristics make up Cisco’s router internetwork architecture.

  1. Cisco Router Network Architecture

    2. Early on in the development of internetworks, an architecture emerged. This architecture for deploying routers was documented into an architecture which Cisco employs and preaches to its customer base. The architecture relies on the ability of the processor in the router and its need for processing routes, filters and physical connections. The architecture places the larger Cisco 7x00 series and 12000 series routers at the center or core of the network. The 4x00 series routers are at the net layer of the network architecture called the distribution layer. Finally, the 25xx, 100x, 7x0 and 200 series routers constitute the access layer of the architecture. While these assignments to the three different layers of the architecture make sense it does not mean that 7x00 series routers can not be used as a distribution or access router. Likewise, in some cases the 4500 and 4700 series router platforms may be used as a core or access router. However, the smaller fixed and combination routers are most suited for the access layer and will not perform the physical or logical requirements of the core or distribution routers.

    1. Core

      2. The routers that comprise the core layer of the architecture are often referred to as the backbone routers. These routers connect to other core routers providing multiple paths over the backbone between destinations. These routers carry the bulk of WAN traffic between the distribution routers. Core routers are usually configured with several high speed interfaces as shown in Figure 2.2. However, the introduction of ATM and interface cards providing up to OC-12 speeds (622Mbps), core routers may only require two physical interfaces. However, as the section on ATM configuration will reveal, multiple subinterfaces are allowed on each physical interface. The need for the core router to manage many high speed interfaces is still a requirement even with only two physical ATM interfaces.

      The use of Packet over SONET is another alternative to proving a high-spped core using Cisco routers. In large WANs and MANs it is common to have the backbone built on SONET rings with OC-3, OC-12 and OC-48 connections. Packet over SONET allows for the transmission of IP direct over the SONET network without the use of ATM. This provides a great incentive to corporations that have yet to embrace ATM but have a need for high speed and bandwidth over their backbone. Using Packet over SONET as the backbone transport requires an investment in only routers versus ATM which requires investments in routers and switches.

    2. Distribution

      3. The distribution router functions as the main conduit for a location back to the core. As an example, in Figure 2.3, the distribution router acts as a core router for a campus environment but as a distribution router for a building. Or the distribution router may act solely as a distribution router for a region or campus managing only the transmission of data between the core and the access layers.

    3. Access

    The outer layer of the architecture is the access layer. It is at this layer that end users gain access to the network resources connected by the routers. A typical example for using access routers is in large buildings or campuses. As depicted in Figure 2.4, access routers connect workgroups and/or floor segments within a building to the distribution router. Access routers also provide remote dial-up connectivity for temporary connections.

  2. Online Insertion and Removal (OIR)

    3. Many networks require 24x7 up time. Powering down a router to replace or add new interface cards causes an outage to all the LAN segments and WAN connections. Cisco IOS along with the hardware has implemented a technique to avoid unnecessary downtime called Online Insertion and Removal (OIR).

    1. Supported Platforms

      2. OIR is specific to the high-end router platforms. The Cisco 7000, 7200, 7500 and 12000 series routers all support the OIR feature. The OIR feature works with all interface processor boards allowing the router power and non-affected interface cards to remain online and functional.

    2. OIR Process

      3. Removal of an interface processor board is accomplished at anytime. A new interface processor board is installed in the now available slot and the route processor will recognize that a new board has been installed. If the newly installed board is a higher density or replacement board with equivalent interfaces (i.e., Ethernet), the processor board recognizes that the boards are similar in function and automatically configures the interfaces as to reflect the previous board’s configuration. In this way, OIR reduces operator intervention thereby eliminating configuration input errors on the new interface processor board.

    3. Exceptions to using OIR

    OIR is specific to interface processors for all interface types. OIR does not support the dynamic replacement of a route processor, route switch processor, or a network engine processor. Replacing these boards requires that the router be powered off. However, if you are using the 7507 or 7513 series routers and have taken advantage of the High System Availability (HSA) feature with Route Switch Processors 2 or 4 (RSP2 or RSP4) removes this restriction. HSA enables these router platforms to operate with two RSP boards. By default the RSP installed in the first RSP slot is the system master and the second RSP slot is the system slave. Using HSA it is now possible to remove an RSP for upgrading or for replacement without disrupting the power to the router or interrupting processing the interface processors.

  3. Cisco 12000 Series

The 12000 series router platform is built in support of providing gigabit (Gb) speeds across WAN and MAN backbones. The Cisco 12000 series is targeted at scaling Internet and enterprise backbones at speeds up to 2.4 Gbps. This is the aggregate bandwidth of an OC-48 SONET connection. The Cisco 12000 series is optimized for IP only networks and thereby provides a high-speed backbone infrastructure for IP based networks. The ability to handle OC-3 through OC-48 SONET connections enables network engineers to expand the backbone switching capacity with a range from 5 to 60 Gbps. Since the 12000 eries is built for providing core backbone it is designed for maximum uptime and minimal disruption. These features are found in the its architeture for:

    • Redundant switch fabric design
    • Line card redundancy
    • Dual Gigabit Route Processors
    • Online software configuration

The speeds of the Cisco 12000 series routers is possible from the synchronized circuitry of two cards. The Clock and scheduler card (CSC) and the Switch Fabric Card (SFC). Both the CSC and SFC provide an OC-12 switching bandwidth between the line cards for the system. Each type of card has a switching capacity of 15 Gbps.

A minimum of one CSC is required in the router. The CSC performs the following functions for the router:

    • System Clock - clicking sent to all line cards, GRP and SFCs. It synchronizes data transfer between the various components of the system. In redundant mode the CSC clocks are synchronized for fail over.
    • Schedule - The scheduler function handles requests form the line cards and schedules when the line card can have access to the switch fabric.

The Switch Fabric Card provides the following functionality for the router:

    • Contains only switching fabric.
    • Carries traffic between line cards and GRP.
    • Receives scheduling and clocking form the CSC.

The chassis configuration of the Cisco 12000 router comes with an upper cage and lower cage. The upper cage is used mostly for the line cards to connect to the network in addition to the Gigabit Route Processor (GRP) card. The lower cage supplements the ability for the 12000 series router to perform switching by having extra slots for the SFC installs. For more information on the specific cage configurations of the 12000 series router consult the section specific to the model.

The 12000 series comes in three models. These are the 12004, 12008 and 12012.

      1. Cisco 12004 Series

        2. The Cisco 12004 series is the smallest of the 12000 line. It provides a total of four interface slots and two slots for Gigabit Router Processors. The 12004 supports all the available interfaces of the 12000 series. The 12004 is usually used in IP SONET backbone networks with minimal connectivity requirements. Typically the 12004 is used for OC-3 and OC-12 interface connections. The 12004 has an IP datagram switching capacity of 5 Gbps. In a single CSC configuration the 12004 supports OC-12 data rates and a 1.25 Gbps switching capacity. Using redundant CSCs in the two center slots of the upper cage and three SFCs in the lower cage the 12004 can support OC-48 data rates with a switching capacity of 5 Gbps. In a redundant GRP configuration the 12004 has two line card slots available for network connectivity.

      2. Cisco 12008 Series (picture h7689.gif 7691.gif 7690.gif)

        3. The Cisco 12008 can switch IP data grams in the range of 10-40 Gbps. Minimal configuration requirement for the Cisco 12008 are the presence of a single GRP and a single Clock and scheduler card (CSC). As shown in Figure 2.5 the CSC must be placed in either of the two center slots in the upper cage of the 12008. A second CSC may be placed in the open CSC slot for redundancy. The GRP may be placed in any of the remaining slots. A second GRP may be installed for redundancy in any of the remaining slots. Using redundant GRPs leaves 6 available slots for line card connectivity to the network. The lower cage houses the three optional slots for used by SFCs.

        Installation of a second CSC does not increase the switching capacity but provides redundancy. The addition of the three SFCs enables the router to move from an OC-12 with a switching capacity of 10 Gbps to support of an OC-48 data rate with switching capacity to 40 Gbps with full redundancy should either CSC fail or a single SFC fail.

      3. Cisco 12012 Series (h11017 h10476)

        4. The Cisco 12012 has the capacity to switch IP datagrams anywhere from 15 to 60 Gbps. The increase in interface density of the 12012 is created by expanding the lower cage. The lower cage of the 12012 contains five keyed slots for placing the CSC in slots 0 or 1 and the SFCs in slots 2-4. The GRP is still installed in the upper cage. In a redundant GRP configuration there are 10 open line card slots for network connections. The single CSC configuration supports OC-12 data rate and a capacity of 15 Gbps switching. A redundant CSC configuration with three SFCs installed enable the 12012 to support OC-48 data rates and a switching capacity of 60 Gbps.

      4. Usage

The 12000 series is placed at the very core of the network. Since it is optimized for IP traffic it must be designed that IP traffic only flows through these routers. For example, in a network that is based on IP and SNA the SNA data must be transported using RSRB or DLSw+ with TCP or FST encapsulation techniques. In this manner, the high speed backbone can be used for connecting remote locations to the main data centers. Likewise, using Voice over IP the router or PBX must encapsulate the voice data into IP prior to delivering it to the 12000 series backbone routers. Based on this type of usage the 12000 series is ideal for:

    • Internet service providers (ISPs)
    • Carriers providing Internet services and utilities
    • Competitive access providers (CAPs)
    • Enterprise wide-area network (WAN) backbones
    • Metropolitan-area network (MAN) backbones
      1. Switch Processors (h10547 h10548

        2. The Cisco 12000 Gigabit Route Processor is based on the IDT R5000 Reduced Instruction St Computer (RISC) CPU. This processor has an external bus clock speed of 100MHz and an internal clock speed of 200 MHz. All the models of the Cisco 12000 series routers use the same GRP card. The GRP may be installed in any slot of the 12012 except for the far right slot. This is reserved for the alarm card. Normal practice is to install the first GRP in the far left slot. On the 12008 the GRP may be installed in any availabel slot of the upper cage except for the two center slots. These are reserved for the Clock and Scheduler Cards.

      2. Memory

        3. Each GRP comes with a base of 64 MB of dynamic random-access memory (DRAM) which is upgradeable to 256MB of parity-protected extended data output (EDO) DRAM. The DRAM is provided in two dual in-line memory module (DIMM) format running at 60 nanoseconds (ns). The GRP uses the DRAM for storing systems software (Cisco IOS), configuration files, and line card routing tables. The Cisco IOS runs from DRAM. Table 2.x lists the DRAM socket locations and DRAM configuariotns for upgrading from 64 MB to 256MB.

        Total DRAM | DRAM Socket | Number of DIMMs
64 MB | U39 (bank 1) | 1 (64 MB DIMM)
128 MB | U39 (bank 1) and U42 (bank 2) | 2 (64 MB DIMM)
128 MB | U39 (bank 1) | 1 (128 MB DIMM)
256 MB | U39 (bank 1) and U42 (bank 2) | 2 (128 MB DIMM)

        Table 2.x: DRAM update configurations.

        In addition to DRAM the GRP also includes Static RAM (SRAM) and Non-volatile RAM (NVRAM). The SRAM provides 512KB of secondary CPU cache memory functions. The SRAM can not be configured by the user nor can it be upgraded in the field. The SRAM is primarily a staging area for routing table updates to and from the line cards. The NVRAM stores router configurations, system cache information and read only memory (ROM) monitor variables in 512 KB. Information stored in NVRAM is available even after the router loses power. SRAM and DRAM lose the information stored within them. Like SRAM the NVRAM can not be configured by the user nor can it be upgraded.

        The GRP also utilizes flash memory. There is 8 MB of single inline memory modules (SIMM) on the GRP for storing Cisco IOS software images as well as saving router configurations and other type of end user files. Additionally, the only board flash memory can be coupled with the ability to use 20 MB PCMCIA flash memory cards that install on two slots on the GRP with a total capacity of 40 MB. Each card can be used for storing Cisco IOS software images and other files required by the router for operation.

        For operational support the GRP enables remote access to the Cisco 12000 router through either an auxiliary dial-up port in an IEEE 802.3 10/100 Mbps Ethernet port for Telnet connections. In addition the GRP has an RS-232 console port connection for direct serial connectivity form a PC to the router.

        The GRP can be installed in any of the slots available in the upper cage of the Cisco 12000 series routers. The exception to this is the Cisco 12012 where the GRP can not be installed in the far right slot. This slot is reserved for the alarm card.

      3. Line Cards

Each line card is comprised of several functions equivalent on each card. The line card uses for burst buffers to prevent packet dropping when there is an instantaneous increase in back-to-back small packets queued for transmission. Burst buffers increase throughput and maintain an even packet burst for packets arriving on Layer 3 switch processing.

Each line card contains two silicon queuing engines one for receive and one for transmit. The receiving engine moves packets form burst buffers to the switch fabric. The transmit moves the packets from the switch fabric to the transmit interface. The silicon engines also manages the movement of IP packets in buffer memory. Buffer memory defaults to 32 MB split evenly between receive and transmit buffers. The amount of buffer memory in use is configurable up to 64 MB for receive and 64 MB for transmit.

An application-specific integrated circuit (ASIC) is used for supporting the high-speed process required to perform layer 2 switching. To assist in the decision making an IDT R5000 200 MHz RISC processor is on the line card to make forwarding decisions based on the Cisco Express Forwarding table and the Layer 2 and Layer 3 information in the packet. The GRP is constantly updating the table based on information gathered from the routing table.

The line card also contains a switch fabric interface. This is the same 1.25 Gbps full-duplex data path used by the GRP. When a packet is on the proper queue the switch fabric requests the CSC for scheduling the transfer of the packet across the switching fabric.

There is also a maintenance bus module on the line card that provides the master Mbus module of the GRP with requested information. The type of information reported in temperature, and voltage. In addition the Mbus on the line card stores the serial number, hardware revision level and other pertinent information about the card in EEPROM.

In addition each line card maintains the Cisco Express Forwarding (CEF) table. The table is built on routing table information provided by the GRP and is used to make forwarding decisions.

There are six available line cards for connecting the 12000 series router to the network. These are:

    • Quad OC-3c/STM-1c Packet-Over-SONET (POS) (h10781.gif)
    • Quad OC-3 ATM Line Card
    • OC-12c/STM-4c Packet-Over-SONET (POS)
    • OC-12c/STM-4c Asynchronous Transfer Mode (ATM)
    • OC-48c/STM 16 Optical IP Interface Card
    • Channelized OC-12 Line Card

The Quad OC-3c/STM-1c Packet-Over-SONET (POS) is shown in Figure 2.6

. The card has four ports for interfacing directly to the SONET providers equipment. The Quad OC-3c/STM-1c Packet-Over-SONET (POS) line card must be ordered for either single mode or multimode SC fiber connection. Each mode supports full-duplex transmission. The card uses for 128 KB burst buffers to prevent packet dropping when there is an instantaneous increase in back-to-back small packets queued for transmission.

The Quad OC-3 ATM Line Card shown in Figure 2.7 (h10781) performs ATM segmentation and Reassembly functions for ATM connectivity. Segmentation is the process of converting packets to ATM cells. Reassembly is the process of converting ATM cells to packets. The Quad OC-3 ATM Line Card can handle up to 4000 simultaneous reassemblies of an average packet size of 280 bytes. To perform this ability the Segmentation and Reassembly is performed on ASIC. The ASICs also allow each of the four ports on the Quad OC-3 ATM Line Card to support 2000 active virtual circuits. The card must be ordered as either single mode or multimode fiber connection. The Quad OC-3 ATM Line Card supports a burst buffer of 4 MB.

The OC-12c/STM-4c Packet-Over-SONET (POS) illustrated in Figure 2.8 (h10782.gif) has a one duplex SC single- or multimode fiber connection. The port supports OC-12c at 622 Mbps data rate. The OC-12c/STM-4c Packet-Over-SONET (POS) has a burst buffer of 512 KB.

The OC-48c/STM 16 Optical IP Interface Card shown in Figure 2.9 (15424.gif) a single duplex SC or FC single mode fiber connection. The top port is the transmit (TX) connection and the bottom port is the receive (RX) connection. The interface supports a full 2.5 Gbps optimized for transporting packet over SONET (POS). The burst buffer on the OC-48c/STM-16 Optical Interface Card is 512 KB with a default buffer memory of 32 MB for receive and 32 MB for transmit. Cisco IOS software Release 11.2(14)GS1 and line card microcode Version 1.14 is required for complete support of all features. The typical maximum distance the line card can sustain is 1.2miles or 2 kilometers.

The Channelized OC-12 Line Card shown in Figure 2.10 (11704.gif) supports only single mode full-duplex SC connections at 622 Mbps. Its burst buffer size is 512 KB. The forwarding processor on the Channelized OC-12 Line Card is an IDT R5000 RISC processor rated a 250 MHz.

      1. Software Support

The Cisco IOS software for the Cisco 12000 series routers is optimized for transporting IP traffic. The first release of Cisco IOS supporting the Cisco 12000 series platform is the 11.2 release. The Cisco IOS Release 11.2 supports the following IP IOS functions:

    • Routing Protocols

Interior: RIP, OSPF, IS-IS, ISO/CLNP, EIGRP, EGP

Exterior: BGP
    • Routed Protocols

TCP/IP, UDP/IP
    • BGP4 Support

Route Reflections

MED (Multi-Exit Discriminators)

Communities

DPA (Destination Preference Attribute)

Flat/Weighted Route Dampening

Confederations

Next Hop-Self

GP Multipath

Static Routing (IGP)

    • Management

SNMP, Telnet, MIB II
    1. Cisco 7500 Series

      2. The Cisco 7500 series router is the high-end routing platform for supporting corporate enterprise wide networks as well as a keystone for the Internet backbone itself. The port capacity and available interface types enable the 7500 to serve all layers of Cisco’s routing architecture. The speed with which the 7500 series processes packets between the various interfaces is the use of high-speed bus architectures.. The architecture is called the Cisco Extended Bus (CyBus). The CyBus supports any combination of interface processors on the 7500 series platform. The CyBus ahs an aggregate throughput of 1.067Gbps. The 7500 series encompasses three models: Cisco 7505, Cisco 7507 and the high-end of the platform is Cisco 7513. Each model has a specific location for the RSP boards. The 7500 series platform supports fifteen different feature sets. These feature sets along with other characteristics of the 7500 series platform are found in Appendix B.

      1. Cisco 7505 Series

        2. The 7505 series is the smallest platform of the 7500 line. It supports four interface processors and one RSP board. Figure 2.11 depicts the platform format for the 7505. The 7505 comes with a single CyBus for attaching the interface boards to the RSP. The 7505 series supports RSP1 and RSP4. The single power supply offered on this platform makes the 7505 series a choice for locations with low availability requirements but with high throughput requirements and the need for varied interface support.

      2. Cisco 7507 Series

        3. The Cisco 7507 series router platform from Cisco expands the interface combination possibilities by providing five slots for interface processors as shown in Figure 2.12. The 7507 series provides a higher reliability through the use of a second power supply and dual RSP boards. The redundant configuration for the 7507 series enables it to reliably serve as a core or distribution router. The 7507 series uses either an RSP2 or RSP4. The RSPs used in a dual RSP configuration (HSA) should however be the same RSP platform. Added to the higher availability architecture of the 7507 is the use of a dual CyBus architecture. This architecture not only enables recovery should a bus fail, the architecture allows both buses to be used simultaneously allowing higher throughput than on the 7505 series.

      3. Cisco 7513 Series

        4. The Cisco 7513 is the high capacity 7500 series router platform from Cisco. This series provides two RSP slots for HSA and eleven interface processor slots, ash shown in Figure 2.13, to support any combination of network interface requirements. The 7513 series also supports the dual CyBus architecture and allows for two power supplies. Both RSP2 and RSP4 processors are supported on the platform. The 7513’s high capacity for interfaces makes it a useful platform for multiple LAN segment interfaces in a large environment along with using the interface combination possibilities to serve as a core, distribution or access router.

      4. Usage

        5. The 7500 series is quite versatile and provides the functionality of core, distribution and access layers. Figure 2.14 illustrates the various functions and configurations found in a typical network infrastructure. The 7505 is used as a low availability access router servicing a casual end user site supporting multiple LAN interfaces. A site of this nature is usually autonomous with processing done locally for the majority of the time.

        The 7507 series servicing the remotes performs the functions of the distribution and access layers. The 7507 features are useful in access locations where there are many different types of interface requirements, many LAN segments and supports high volume of data from the site to the WAN. As a WAN distribution router, the 7507 connects many of the remote access locations without going to the core routers. The 7513, as indicated earlier, is suitable for all the three layers of the router networking architecture. In Figure 2.14, the 7513 is illustrated as a core routing platform. In this example topology, the 7513 connects the core routers using an ATM backbone, the distribution routers with frame relay. Also note that the 7513 may feed other locations within its own building using FDDI and Ethernet.

      5. System Processors

        6. The Route Switch Processor (RSP) platform used on the 7500 series router is a combination of the router processor (RP) and switch processor (SP) originally used on the Cisco 7000 series router platform. Combining the functionality of the RP and SP into one board enables the RSP to switch and process packets faster and allows each platform to gain an extra slot for an interface processor. There are three types of RSP platforms. The base platform of each RSP type comes with 32MB of DRAM and 8MB of Flash SIMM memory. The 7500 series uses the Flash SIMM for storing and loading the Cisco IOS BOOT images necessary for the RSP to activate prior to executing any other functions. The DRAM is upgradeable from 32- to 64- to 128MB of DRAM with Flash memory upgrades using PCMCIA cards in up to two slots totaling 40MB. Each RSP comes with 128KB of Non-Volatile RAM (NVRAM) to store the IOS system running and startup configuration files.

        RSP1

        The RSP1 is the default RSP on the 7505 series router. It is only available on the 7505 router. The RSP1 stores the Cisco IOS image in Flash memory on the RSP or on up to two Intel Series 2+ Flash memory PCMCIA cards. The RSP1 has an external clock speed (bus speed) of 50MHz and internal clock speed (CPU speed) of 100 MHz.

        RSP2

        The RSP2 is the base RSP board supplied for the 7507 and 7513 series routers. The RSP2 operates at an external clock speed (bus speed) of to 50MHz and an internal clock speed (CPU speed) of 100 MHz. The RSP2 platform of the RSP system processors supports the High System Availability (HSA) features. Using two RSP2 system processors, the 7507 and 7513 provide for RSP failure recovery as the slave takes over for the master if the master should experience an outage. The default for identifying the system master is the RSP2 occupying slot2 on the 7507 and slot6 on the 7513 router. The order is configurable but it is highly recommended that the defaults be taken when using HSA. A caveat to using HSA is Cisco IOS Release 11.1(5) or higher and ROM monitor version 11.1(2) or higher. Each RSP2 must have the same version of ROM monitor installed for HSA to function properly.

        RSP4

        The RSP4 platform of the RSP system processors is available for the three 7500 series platforms. Its external clocking speed (bus speed) is 100 MHz and supports an internal clocking speed (CPU speed) of 200 MHz. The RSP4 uses DIMM chip sets for DRM memory. As such, the RSP4 DRAM configuration is 32-, 64-, 128- or 256MB. AN enhancement to the RSP4 over the RSP1 and RSP2 is the use of static RAM (SRAM) for packet buffering and a secondary cache memory for CPU functions. The RSP4 supports any type of PCMCIA flash memory card for flash memory. PCMCIA card formats come in three types. PCMCIA Type 1 and 2 and usable in slot 0 and slot 1. Type 3 PCMCIA flash memory cards are only supported in slot 1 of the PCMCIA slots for the RSP4. Like the RSP2, the nRSP4 supports HAS. Support for HAS on the RSP4 is dependent to the level of Cisco IOS and ROM monitor. HAS is fully supported on the RSP4 using Cisco IOS release 11.1(8)CA1 and ROM monitor version 11.1(8)CA1 and higher.

      6. Memory

Memory on the RSP and any interface processor is paramount to efficiently running the routers. The more the better. It does not hurt to order the highest amount of memory available for any platform as an inexpensive insurance policy against poor design or "memory leaks" from the IOS or microcode software. That aside, the 7500 series platform comes with DRAM memory size recommendations based on the number of IP routes in a network. Cisco categorizes network sizes into the following:

    • Small networks – less than 2,000 IP routes
    • Medium networks – between 2,000 and 10,000 IP routes
    • Large networks – greater than 10,000 IP routes

The for the RSP1, RSP2 and RSP4 system processors on each on the 7505, 7507 and 7513 router platform the DRAM memory requirements are recommended to be:

    • Small networks – 32MB
    • Medium networks – 32MB
    • Large networks – 64MB

Cisco highly recommends that even if some networks are much smaller than the 2,000 IP routes a minimum of 32MB of DRAM is beneficial for router performance.

The Flash memory PCMCIA cards available for insertion into slot 0 and slot 1 of the RSP boards are available in different memory sizes. The default card comes with 8MB of memory and has a default IOS software image stored. If a spare is ordered or purchased it must first be formatted before use. PCMCIA cards used on RP boards from a 7000 series router must be reformatted for use on the 7500 series router due to a difference in formatting of memory on the different system processors.

    1. 7200 Series

      2. The Cisco 7200 series router is a change in the routing platform architecture for Cisco. The architecture of the interface slots is based on the technology conceived with the Versatile Interface Processor 2 (VIP2) boards from the 7x00 series. Instead of using slots the 7200 series uses port adapters. Figure 2.15 illustrates the adapter layout for the 7200 series router.

      The 7200 series platform is available in two formats. The 7204 supports up to four port adapters while the 7206 supports up to six port adapters. Each platform requires a network processing engine (NPE) and an Input/Output (I/O) Controller processor. The I/O Controller has two slots for PCMCIA flash memory cards and can be optionally configured with a Fast Ethernet interface using an MII connector. Each port adapter supports the OIR function allowing non-interruption of port upgrades or replacements. As found in the 7x00 series the replacement of like-adapters are automatically configured up on insertion.

      The 7200 series uses a peripheral component interconnect (PCI) bus architecture in support of the various network interfaces available using the port adapters. This bus architecture is built on two primary PCI buses and a secondary PCI bus providing a high-speed mid-plane rate of 600Mbps. A second power supply is available for added redundancy enhancing high availability.

      1. Usage

        2. The 7200 is positioned as a low volume core router or medium distribution router. Network Layer 3 switching support directly supported by the 7200 series makes it an excellent candidate as a distribution router for a large office complex or as a access router for many LAN segments with in the office complex as Figure 2.16 illustrates.

      2. Network Processing Engine

        3. Maintenance and execution of system management functions are supported by the network processing engine (NPE) on the 7200 series platform. The NPE works with the I/O Controller to monitor environmentals and share in system memory management. There are two versions of the NPE. The NPE-100 maintains an internal clock speed of 100MHz and an external clock speed of 50Mhz. The higher performance NPE-150 uses an internal clock speed of 150MHz and an external clock speed of 75Mhz. In addition the NPE-150 includes 1MB of packet SRAM for storing packets used in fast switching. The NPE requires Cisco IOS software verison 11.1(5) or later for the 7206 and 11.1(6) or later for the 7204.

      3. Memory

      Memory requirements on the 7200 series are dependent on the varied adapter configurations possible with each platform. Appendix C details the memory configuration requirements for the 7200 series platforms. The NPE come standard with 32MB of DRAM. This memory is incremental in 8-, 16- or 32MB SIMMs totaling 128MB. Both the NPE-100 and NPE-150 have a unified cache memory of 512KB as a secondary cache for the Orion R4700 RISC processor.

      The I/O Controller for the 7200 series provides NVRAM for the storage of system configurations and logging environmental monitor results. The two PCMCIA slots found on the I/O Controller support the Intel Series 2+ Flash Memory PCMCIA formats. These PCMCIA cards have 8-, 16- or 20MB of flash memory on board. The total available for the two slots combined is 40MB.

    2. 7000 Series

      3. The Cisco 7000 series was the original "big" router platform introduced. It was the replacement for the Cisco AGS and AGS+ router platforms. The 7000 platform itself has since been replaced by the 7500 platforms. The Cisco 7000 comes in two platforms as Figure 2.17 depicts. These are the 7000 and the 7010 series. The 7000 has a total of seven slots. Five of these slots are used for interface processors and two for system processors. The 7010 series is smaller and offers a total of five slots. Three of the slots on the 7010 are used of interface processors and the remaining two slots provide support for system processors.

      OIR was originally introduced with this platform along with a backplane called the Cisco extended bus (CxBus). The CxBus architecture provided a data bus throughput of 533Mbps on the 7000 series. The 7000 series supports up to two power supplies to enhance availability. However, the series itself does not support the high system availability feature found on the 7500 series platforms.

      1. Usage

        2. The 7000 platforms were initially developed primarily as a core router. However, the need for higher port densities and faster processing have moved the 7000 series out of the core and into the role of a small to medium distribution. As shown in Figure 2.18, the 7000 or 7010 is used as a distribution router servicing a minimal amount of access locations.

      2. System Processors

On introduction of the 7000 platform Cisco used a Motorola 68040 CPU clocked at 25Mhz.. While this was considered fast for the time it has since been antiquated. The CPU is found on the Router Processor (RP) board. The RP is installed in slot 6 of the 7000 series and slot 4 of the 7010 series. In concert with the RP, the 7000 platform utilized three models of a Switch Processor (SP). These are the Switch Processor (SP) Silicon Switch Processor (SSP) and Silicon Switch Processor–2MB (SSP-2MB). The SP offloaded the responsibility of managing the CxBus from the CPU on the RP board. Thus, allowing the RP to efficiently manage system functions. Further enhancements using a Silicon Switch Engine (SSE) on the SP allowed the SP to examine incoming packet data link and network link header information making an intelligent decision on whether the packet should be bridged or routed and forward the packet to the corresponding interface. The speed of the decision process was enabled by using a silicon-switching cache which kept track of packet information through the router. The SSE is encoded in the SP hardware and in this configuration is called a Silicon Switch Processor (SSP). The SSP performs switching decisions independently of the RP thereby increasing the throughput and efficiency of system resources. The base SSP includes an extra 512KB of memory for handling switching decisions while the SSP-2MB provides an extra 2MB of memory. On the 7000 series the SP, SSP or SSP-2MB is installed in slot 5 and on the 7010 series the SP, SSP or SSP-2MB is installed in slot 3. The configuration for this installation is shown in Figure 2.19.

Extending the life of the 7000 platform was made possible by the introduction of the Route Switch Processor 7000 (RSP7000) and the 7000 Chassis Interface (7000CI) processors. These two boards together give the 7000 platform the enhancements and ability to use the IOS software made for the 7500 router platform. The IOS software must be at IOS version 10.3(9), 11.0(6) 11.1(1) or later to support the RSP7000 processor and the 7000CI processor. The RSP7000 increases the performance of the 7000 platform by using a MIPS Reduced Instruction Set Code (RISC) CPU at 100MHz and a bus speed clocking (external clock) of 50Mhz. Use of the RSP7000 on the 7000 and 7010 series routers enables these platforms to use the Versatile Interface Processor (VIP) technology supported under the 7500 IOS software platform. The 7000CI monitors chassis specific functions relieving the RSP7000 from the following duties:

    • Report backplane and arbiter type
    • Monitor power supply status
    • Monitor fan/blower status
    • Monitor temperature sensors on the RSP7000
    • Provide router power up/down control
    • Provide power supply power-down control

The RSP7000 is installed in slot 5 of the 7000 series and slot 4 of the 7010 series. The 7000CI is installed in slot 6 of the 7000 series and slot3 of the 7010 series. Figure 2.20 diagrams the installation of the RSP7000 and 7000CI on both the 7000 and 7010 series routers.

      1. Memory

While both the RP and RSP7000 use the Intel Series 2+ Flash Memory cards, they must be reformatted if used between the two processors. The RP supports one slot for flash memory and the RSP7000 supports two flash memory slots. The RP flash memory PCMCIA card is either 8MB or 16MB. The RSP7000 is available in either 8-, 16- or 20MB formats with a total of 40MB of flash memory.

The RP processor comes standard with 16MB of RAM and is upgradeable to 64MB. The RSP7000 comes standard with 32MB of RAM with expansion to a total of 128MB. Appendix D highlights the various DRAM requirements along with the feature sets available for the 7000 series routers.

    1. Cisco 7x00 Series Interface Processors

      2. The strength of the Cisco router product line is the ability to support the many different LAN/WAN physical interface standards available. The Cisco 7x00 family of routers has a very versatile offering supporting these standards without restricting the combinations possible by mixing and matching the interface processor boards on the chassis. The Cisco 7x00 router platform can actively support any combination of Ethernet, Fast Ethernet, Gigabit Ethernet, Token Ring, FDDI, serial, channelized T3, Multichannel E1/T1, IBM mainframe channel attachment, ATM, Packet OC-3, ISDN, and HSSI interfaces. These interfaces are provided on interface processors that connect physical networks to the high-speed bus of the Cisco 7x00 router. The interface processors are specific to the 7000 and 7500 router platforms. The 7200 router platform uses port adapters which are akin to the port adapters of the Versatile Interface Processor (VIP) available on the 7000 and 7500 router platforms. The VIP and the port adapters supported are discussed in the following section.

      The interface processors are modular circuit boards measuring 11 x 14 inches with network interface connectors. The interface processors all support OIR and are loaded with mircocode images bundled with the Cisco IOS software. The exception to this bundling of microcode is the CIP which is unbundled as of IOS version 11.1(7) and higher. For the most part, each interface processor is self contained on a single motherboard. However, some interface processors require a companion board attached to the motherboard. For example, the AIP board uses a physical layer interface module (PLIM) which is installed at the factory based on the AIP order.

      1. ATM Interface Processor (AIP)

The AIP board supports fiber optic connectivity and coaxial connectivity in support of Asynchronous Transfer Mode (ATM) networking environments. The board also supports single mode and multimode fiber-optic connections. Figure 2.21 illustrates the AIP board with a fiber-optic PLIM. The following lists the media types supported by the AIP board:

    • Transparent Asynchronous Transmitter/Receiver Interface (TAXI) multimode fiber-optic
    • Synchronous Optical Network (SONET) multimode fiber-optic
    • SONET single-mode fiber-optic
    • E3 coaxial
    • DS3 coaxial

The AIP board can now support up to OC-12 SONET connectivity for high bandwidth and throughput requirements. Each of the media type supported requires a specific cable connection. Appendix E lists all the cable specifications for all the router platforms and their interfaces.

      1. Channel Interface Processor 2 (CIP2)

The Cisco Channel Interface Processor 2 (CIP2) is the second generation of IBM mainframe channel connectivity boards offered in support of connecting router networks directly to the mainframe. The CIP2 is a direct competitor to IBM’s 3172 Interconnect Controller and the IBM 2216 channel attached router. The CIP2 has memory and processing advantages over the first generation CIP. The CIP2 supports both IBM’s parallel bus-and-tag channel and ESCON fiber channel architectures. The CIP2 ships with a default of 32 MB of memory with memory configuration of 64- and 128-MB allocations.

The CIP2 is compatible with the Cisco 7000 series router using Cisco IOS release 10.2(13) or later, 10.3(12) or later, 11.0(10) or later and all versions at 11.1(5) or later. The 7500 series router requires the Cisco IOS release level be at 10.3(13) or later, 11.0(10) or later, and all versions at 11.1(5) or later.

The CIP2 microcode is unbundled from the IOS software as of release 11.1(7) and must be ordered separately from the IOS when installing a CIP2. The microcode supports the following mainframe connectivity features:

    • TCP/IP Datagram
    • TCP/IP Offload
    • CIP Systems Network Architecture (CSNA) connectivity using External Communications Adapter (XCA) communications to VTAM
    • TN3270 Server
    • Native Client Interchange Architecture (NCIA) Server
    • Advanced Peer to Peer Network (APPN)

The CIP2 supports different combinations of channel connectivity to the mainframe. These combinations are configured at the factory and must be ordered appropriately. Figure 2.22 diagrams a CIP2 board with a single parallel channel and single ESCON interface configuration. The valid combinations for the CIP2 interfaces are:

    • Single parallel channel
    • Dual parallel channel
    • Single ESCON channel
    • Dual ESCON channel
    • Single ESCON channel and single parallel channel

When ordering a CIP2 board it is advisable to determine the number of TCP/IP and SNA connections planned for use by the CIP2. The number of connections directly related to CIP2 performance and memory requirements. While Cisco has memory recommendations and formulas to calculate memory requirements it is advisable to order the CIP2 with the maximum amount of memory, 128 MB, to allow for growth and performance without compromising availability and reliability. Appendix E details the CIP2 memory formulas and minimum requirements.

      1. Channelized T3 Interface Processor (CT3IP)

        2. The CT3IP is based on the VIP2 interface processor architecture. It is a fixed-configuration, meaning that it is not reconfigurable after ordering or installation. The CT3IP supports four T1 connections and a single DS-3 connection as shown in Figure 2.23. The T1 connections use a DB-15 connector and the DS-3 uses a transmit (TX) and receive (RX) female BNC connection pair. The DS-3 connection provides up to 28 T1 channels with each channel viewed as a serial interface to the system. Each channel may then be configured individually. The CT3IP board is supported on the Cisco 7500 series and Cisco 7000 series with the RSP7000 and 7000CI boards only.

      2. Ethernet Interface Processor (EIP)

        3. The EIP supports 10 Mbps Ethernet LAN connectivity. There are three variations of the EIP board supporting either two, four or six 10 Mbps Ethernet 802.3 interface ports. Figure 2.24 diagrams a six port EIP board. Attachment of the EIP interfaces may require a transceiver that converts to 802.3 and attachment user interface (AUI) cable to RJ-45 cable connectivity to a LAN hub or switch.

      3. Fast Ethernet Interface Processor (FEIP) and FEIP2

        4. The interface processor forms support fast Ethernet connectivity at 100 Mbps. The media supported is twisted-pair or fiber-optic cable. The format of the board uses the port adapter architecture found with VIP2 boards, but, the FEIP and FEIP2 port adapters are not interchangeable for use on the VIP2 board or Cisco 7200 series routers. Figure 2.25 illustrates the FEIP and FEIP2 boards. Note that the main difference on the boards is the inclusion f a CPU on the FEIP2. The CPU on the FEIP2 offloads the RSP of switching, filtering and other previously RSP based functions thereby increasing performance on the FEIP2 and the RSP in general.

        Both the FEIP and FEIP2 have configurations that support one or two port adapters. Each port adapter supports a RJ-45 and MII connector. The MII connector in concert with a transceiver supports fiber-optic connectivity. Only one of the interfaces may be active on each port adapter. The RJ-45 supports Category 5 UTP 100BaseTX connectivity. The FEIP supports full- and half-duplex operations on all interfaces in any combination. The FEIP2 only allows half-duplex operations on the 100BaseTX RJ-45 connection. The FEIP2 may operate both 100BaseFX interfaces using either half-duple or full-duplex modes. However, in a configuration where both MII interfaces attach 100BaseFX LANs, only one interface may operate in full-duplex mode. In addition to the use of a CPU on the motherboard, the FEIP2 includes 1 MB of SRAM and 8 MB of DRAM.

        The Cisco 7000 series supports the FEIP using 100BaseTX with Cisco IOS release 10.3(5) or later. The Cisco 7500 series supports FEIP 100BaseTX using Cisco IOS software release 10.3(6) or later. Support for 100BaseFX connectivity on the Cisco 7000 and 7500 series using Cisco IOS Release 10.3(13) or later, 11.0(10) or later and Release 11.1(5) or later.

        The FEIP2 board and interface support for 100BaseTX and 100BaseFX connections is found in Cisco IOS Release 11.1(10)CA or later for both the Cisco 7000 and 7500 series routers.

      4. FDDI Interface Processor (FIP)

The FIP enables the Cisco 7000 and 7500 router platform to support single mode and multimode FDDI connections at 100 Mbps. Figure 2.26 diagrams the four FIP board configurations. These configurations support:

    • Multimode to multimode with optical bypass
    • Multimode to single-mode
    • Single-mode to multimode
    • Single-mode to single-mode with optical bypass
      1. Fast Serial Interface Processor (FSIP)

        2. The FSIP, as shown in Figure 2.27, uses dual-port port adapters. Each port adapter supports two serial interfaces. Each interface can support up to 6.132 Mbps. The 6.132 Mbps bandwidth is the total allowed for the entire FSIP board. If one or more ports totals a bandwidth of 6.132 Mbps, the remaining ports are not available for use.

        The FSIP supports two configurations. A four interface serial port adapter and an eight interface serial port adapter. The first ports are numbered 0 – 3 and the second are numbered 4 – 7.

      2. High Speed Serial Interface(HSSI) Interface Processor (HIP)

        3. The HIP is capable of supporting up to 52 Mbps bandwidth. The HIP, diagrammed in Figure 2.28, enables data rates up to 45 Mbps (DS-3) or 34 Mbps (E3) for connecting ATM, SMDS, Frame Relay or private lines. The HIP uses a special cable and must be ordered from Cisco for supporting this high speed configuration.

      3. Multichannel Interface Processor (MIP)

The MIP, shown in Figure 2.29, is a multichannel multiplexer allowing the router to emulate an Nx64 or Nx56 backbone multiplexer on a 1.536 Mbps (T1) or 2.048 Mbps (E1) line. The MIP supports seven different types of configurations:

    • One E1/PRI port at 75-ohm unbalanced
    • Two E1/PRI ports at 75-ohm unbalanced
    • One E1/PRI port at 120-ohm balanced
    • Two E1/PRI ports at 120-ohm balanced
    • One channelized E1 75-ohm unbalanced or 120-ohm balanced
    • One T1/PRI port
    • Two T1/PRI ports

These configuration allow the MIP to provide varied answers to connectivity requirements. The dual port MIP can act as a dial-on-demand ISDN PRI for high volume locations or be configured through software enabling one port to act as an ISDN PRI line while the other operates as a multichannel multiplexer feeding remote locations.

      1. Packet OC-3 Interface Processor (POSIP)

The POSIP board, shown in Figure 2.30, complies with RFC 1619, "PPP over SONET/SDH" and RFC 1662, "PPP in HDLC-like Framing". Using these standards, the POSIP encapsulates packet data using Point-to-Point Protocol (PPP) which is then mapped into an STS-3c/STM-1 frame reducing the transport overhead by approximately fifty percent as compared to using ATM adaptation Layer 5 (AAL5) and line card control (LCC) Subnetwork Access Protocol (SNAP) encapsulations over SONET OC-3 media.

The POSIP interface supports one 155 Mbps port using either single-mode or multimode optical-fiber on Cisco 7000 and 7500 series routers. The Cisco 7000 must have the RSP7000 system processor installed to support the POSIP board. The POSIP has support for the following features:

    • SONET/SDH compliant interface; SONET/STS-3c and SDH/STM-1 framing and signaling overhead
    • Full-duplex operation at OC-3 155 Mbps
    • Intermediate reach optical interface with single-mode fiber
    • Optical interface with multimode fiber
    • OIR

The POSIP board connects the OC-3 optical-fiber network to the CxBus on the 7000 series or the CyBus on the 7500 series routers. The POSIP installs on any available interface processor slot. The POSIP board may be configured with 16 or 32 MB of DRAM and 1 or 2 MB of SRAM. The memory requirements may be upgraded at a later date.

      1. Service Provider MIP (SMIP)

Internet Service Providers require speed in delivering packets between the end user community and the Internet. The SMIP functions similarly to the MIP. However, the SMIP does not support multiprotocol routing. Using Cisco IOS Release 10.2(6) or later is requried to support the following SMIP functions:

    • IP routing with PPP or High-Level Data Link Control (HDLC)
    • ISDN PRI connectivity

The SMIP, shown in Figure 2.31, supports three different types of configurations. These are:

    • Two T1 ports
    • Two E1 ports with 75-ohm
    • Two E1 ports with 120-ohm

Note that the SMIP is only optioned with two ports. One port may be used to channelize Nx64 or Nx56 supporting 24 channels on a T1 or 30 channels on an E1. Each channel is configured as its own serial interface. The second port may be used as an ISDN PRI port for ISDN BRI dial connections to the router.

      1. Standard Serial Interface Processor (SSIP)

        2. The SSIP is only optioned with eight high-speed serial ports. The total aggregate bandwidth supported by the SSIP is 8 Mbps. The dual-port port adapters used on the SSIP are compatible with the FSIP. They are not interchangeable with the VIP2 or 7200 series port adapters. Each port diagrammed in Figure 2.32, when using Cisco IOS Release 10.3(6) or later, supports up to T1 or E1 speeds when using IP routing encapsulated in PPP or HDLC. If multiprotocol routing is required the serial port uses PPP or HDLC encapsulation with speeds at 64 Kbps or less.

      2. Token-Ring Interface Processor (TRIP)

        3. The TRIP connects the Cisco CxBus or CyBus to a token ring network at 4 or 16 Mbps. Each port is connected to a token ring multistation access unit (MAU) suing a DB-9 connector. The TRIP is configurable with either two or four token ring ports. Figure 2.33 illustrates the TRIP board.

      3. Versatile Interface Processor 2 (VIP2)

The VIP2, shown in Figure 2.34, is a new generation interface processor board with a high speed RISC MIPS 4700 processor with an internal speed of 100 MHz and a system bus interface speed of 50 MHz. This CPU enables the VIP2 to process all functions on the VIP2 rather than requesting functions from the RSP system processor. This function is available with Cisco IOS Release 11.1(472) or later, enabling the VIP2 to run the Cisco IOS kernel directly on its own CPU. The 7000 and 7010 series routers must have the RSP7000 and 7000CI system boards installed in order to use the VIP2 features.

The VIP2 is comprised of a motherboard and up to two port adapters or service adapters. Any combination of port or service adapters may be installed on the VIP2 in support of LAN and WAN interfaces and services. Appendix E details the VIP2 models of VIP2 required in support of various port adapter and service adapter configurations.

    1. Cisco 7x00 Series Port and Service Adapters

The port and service adapters for the 7x00 series routers are compatible between the VIP2 and the 7200 series router. The 7000 and 7010 series routers must have the RSP7000 and 7000CI system boards installed prior to using the VIP2 board supporting the port adapter and service adapters. The following media and interface types are supported on the entire 7x00 series product line:

    • ATM
    • 100VG-AnyLAN
    • Ethernet 10BaseT
    • 10BaseFL
    • Fast Ethernet 100BaseTX
    • 100BaseFX
    • Token Ring
    • Fiber Distributed Data Interface (FDDI)
    • High-Speed Serial Interface (HSSI)
    • Synchronous serial media
    • Channelized T1/ISDN PRI

The Cisco 7200 series supports all of the above media and interface types along with support for ATM-Circuit Emulation Services (ATM-CES) and ISDN PRI and BRI connections.

      1. ATM OC-3

        2. The ATM OC-3 comes in two models as shown in Figure 2.35. The port adapter uses a single-port SC duplex connector to the OC-3c ATM network. It is supported on the full 7x00 series line when used with Cisco IOS Release 11.1(9)CA. The fiber run from the router to the switch may be up to 15 km in length.

      2. ATM-Circuit Emulation Services (ATM-CES)

        3. The ATM-CES is supported only on the 7200 series routers. It supports four T1 CES interfaces and a single ATM trunk for servicing data, voice and video traffic over an ATM WAN using Cisco IOS Release 11.1(11)CA or later. As shown in Figure 2.36, the ATM-CES can support either structured Nx64 Kbps or unstructured 1.544 Mbps circuits. The ATM-CES is optioned with either an OC-3 (155 Mbps) single-mode intermediate reach ATM trunk interface or a DS-3 (45 Mbps) ATM trunk interface.

      3. 100VG-AnyLAN

        4. The 100VG-AnyLAN standard was developed and published by Hewlett-Packard (HP). Its intention is to provide voice, video and data transport over 100 Mbps using Ethernet. The 100VG-AnyLAN port adapter uses a single interface port supporting the IEEE 802.12 specification of running 802.3 Ethernet packets at 100 Mbps over Category 3 or Category 5 UTP cable with RJ-45 terminations. The 100VG-AnyLAN port adapter operates at 120 Mbps using the 5B/6B coding scheme to provide the 100 Mbps data rate at half-duplex. Figure 2.37 depicts the 100VG-AnyLAN port adapter.

      4. ISDN Basic Rate Interface (BRI)

        5. The ISDN BRI port adapter is available only on the 7200 series router. Using an NT1 device, the 7200 ISDNBRI port adapter connects using either one or both of the two B channels (64 Kbps) in full-duplex mode observing an aggregate rate of 128 Kbps. The single D channel on the BRI is also available at a full-duplex data rate of 16 Kbps. Figure 2.38 illustrates the two models available for the 7200 series router. The port adapters are available in either 4 or 8 ISDN BRI ports. The 4 port ISDN BRI port adapter connect switch a U interface while the 8 ISDN BRI port adapter uses an S/T interface to the NT1 device.

      5. Channelized T1/E1 ISDN PRI

        6. The channelized port adapters from Cisco support T1 (1.544 Mbps) and E1 (2.048 Mbps) line speeds with the ability to connect using ISDN PRI standards. Each port adapter is available with one or two interfaces. The channelized E1/ISDN PRI port adapter is available with unbalanced 75-ohm or balanced 120-ohm connections. Figure 2.39 illustrates the channelized T1/E1 ISDN PRI port adapter.

      6. Ethernet 10BaseT

        7. The IEEE 802.3 Ethernet 10BaseT standard is supported using wither four or eight interfaces. Each interface runs at wire speed of 10 Mbps thereby providing an aggregate bandwidth of 40 Mbps for the four port and 80 Mbps for the eight port. The Ethernet 10BaseT port adapter, depicted in Figure 2.40, is available on the entire Cisco 7x00 router platform.

      7. Ethernet 10BaseFL

        8. Support for 10 Mbps Ethernet over fiber-optic media is provided by using the 10BaseFL port adapter. The port adapter has up to five interfaces using the IEEE 802.3 Ethernet 10BaseFL standard running at 10 Mbps each in half-duplex mode with an aggregate bandwidth rate of 50 Mbps. The interfaces, as shown in Figure 2.41, uses a pair of multimode S/T receptacles one for receive (RX) and one for transmit (TX) both at wire speed. The Ethernet 10BaseFL is supported across the Cisco 7x00 router platform.

      8. Fast Ethernet

        9. The Cisco Fast Ethernet port adapters support full- and half-duplex operation at 100 Mbps. This port adapter is available on all the Cisco 7x00 router platforms and comes in two models.

        In support of twisted pair media, the Fast Ethernet port adapter provides a single 100BaseTX port for connection to Category 5 UTP media using an RJ-45 connection. The 100BaseTX port adapter, shown in Figure 2.42, may also connect to Category 3, 4, and 5 UTP or STP for 100BaseT4 media using the MII interface. Additionally the 100BaseTX Fast Ethernet model may connect to multimode fiber for 100BaseFX media using the MII interface through external transceivers.

        Connectivity to fiber-optic media is also available using the 100BaseFX Fast Ethernet port adapter. The 100BaseFX port adapter, shown in Figure 2.43, connects to fiber-optic media in one of two ways. The 100BaseFX may use SC fiber-optic connectors or use external transceivers to multimode fiber through the MII interface. Additionally, the 100BaseFX Fast Ethernet port adapter allows connectivity to 100BaseT4 networks through the MII interface over Category 3, 4, and 5 UTP or STP media.

      9. Synchronous Serial

The synchronous serial port adapter comes with four interfaces. Each interface must be alike and supports the following electric standards:

    • EIA/TIA-232
    • EIA/TIA-449
    • EIA-530 X.21
    • V.35

The interfaces support either DCE or DTE terminations depending on the type of cable connected to the interface. The synchronous serial port adapter depicted in Figure 2.44 is available on the Cisco 7500, 7000 and 7200 series routers.

      1. Single Port Molex 200-pin receptacle

        2. The Molex 200-pin receptacle supports a wide variety of synchronous serial interfaces. Each Molex receptacle interface provides up to eight synchronous serial interfaces using a special cable designed for supporting the desired electrical interface specification. The Molex runs full-duplex mode supporting either 1.544 Mbps (T1) or 2.048 Mbps (E1) speeds for V.35 and X.21 interfaces. Support for EIA/TIA-232 interfaces allows up to eight ports operating full-duplex mode at 64 Kbps. Figure 2.45 illustrates the 200-pin Molex receptacle. These port adapters are available on the 7x00 family of routers.

      2. Synchronous Serial E1-G.703/G.704

        3. The E1-G.703/G.704 serial interface is an International Telecommunication Union Telecommunication (ITU-T) standard for serial line speeds of 2.048 Mbps on E1 lease lines. The port adapter supports up to four synchronous serial interfaces framed and unframed service. The interfaces are ordered with eight unbalanced 75-ohm or balanced 120-ohm. Figure 2.46 diagrams the Synchronous Serial E1-G.703/G.704 port adapter.

      3. Token Ring

        4. The Token Ring port adapter provides up to four IEEE 802.5 token ring interfaces at either 4 or 16 Mbps. The port adapter is available on the 7x00 family of routers and comes in two models. A half-duplex and full-duplex model. The full-duplex model realizes an aggregate speed of 32 Mbps. Figure 2.47 illustrates the token ring port adapter.

      4. FDDI

        5. The FDDI port adapter comes in two flavors: half-duplex and full-duplex. Each of these flavors is available with two multimode or single-mode interfaces at a maximum bandwidth of 100 Mbps per port. Each port adapter supports the optical bypass switching capability. Figure 2.48 diagrams the single and multimode FDDI port adapters. The full-duplex option enables the FDDI port adapter to realize and aggregate speed of 200 Mbps per port. The FDDI port adapters are available for all the Cisco 7x00 family of routers.

      5. HSSI

        6. HSSI port adapters are configurable with either one or two HSSI interfaces. Each interface uses the EIA/TIA 612/613 high speed standard to provide T3 (45 Mbps), E3 (34 Mbps) and SONET STS-1 (51.82 Mbps) data rates. Figure 2.49 illustrates the HSSI port adapter which is available on all Cisco 7x00 routers.

      6. Compression Service Adapter

Bandwidth for many installation is a valuable asset. Compressing data prior to transmission enables routers to transmit fore information than would be allowed without compression. The Compression Service adapters off-load compression and decompression functions from the host processor for inbound and outbound traffic over channelized E1/ISDN PRI, channelized T1/ISDN PRI, BRI ISDN and synchronous serial port adapters. Figure 2.50 diagrams the two models for the compression service adapters.

The first model has 786 KB of memory enabling it to handle compression/decompression for up to 64 WAN links. The second model is configured with 3 MB of memory in support of 256 WAN links. Both models of the compression service adapter are available on the entire Cisco 7x00 family of routers.

    1. 4000 Series

The Cisco 4x00 router platform is based on the use of network processor modules (NPM). Using the NPMs a 4x00 router can combine many different types of interface connections in support of various networking requirements. The 4x00 series router platform is available in three models. Each model looks identical as depicted in Figure 2.51, with different interface support and processing power. The models 4000-M, 4500-M and 4700-M can mix and match the NPMs using the three available slots. The low-end 4000-M model supports the following NPMs:

    • Ethernet
    • Token Ring
    • FDDI
    • Serial
    • ISDN BRI
    • Channelized E1/T1 ISDN PRI

The higher-end 4500-M and 4700-M routers support the following network interfaces in any combination using the three available slots:

    • Ethernet
    • Token Ring
    • FDDI
    • HSSI
    • High-density serial
    • ISDN BRI
    • Channelized E1/T1 ISDN PRI
    • ATM OC-3c
    • ATM DS-3
    • ATM E3

The NPMs available for each router platform come in various port configurations. Though some have multiple ports the 4000 series platform supports full wire speed on each port. Each NPM has the following port configurations:

    • 1-, 2-, or 6-port Ethernet
    • 1-port Fast Ethernet
    • 1 or 2-port Token Ring
    • 1-port multimode FDDI (both single [SAS] and dual attachment station [DAS])
    • 1-port single-mode FDDI (DAS)
    • 2 or 4-port synchronous serial
    • 2-port high-speed serial and 16-port low-speed serial
    • 4 or 8-port ISDN BRI
    • 1-port channelized T1/ISDN PRI
    • 1-port channelized E1/ISDN PRI (balanced or unbalanced)
    • 4-port serial G.703 and G.704 (balanced or unbalanced)
    • 1-port HSSI
    • 1-port ATM (single-mode or multimode) OC-3c
    • 1-port ATM DS-3
    • 1-port ATM E3

Due to the processing of the high-speed NPMs there is a maximum of two high-speed interface available on the Cisco 4500-M and Cisco 4700-M platforms. This means only two of the following NPMs may be installed and operable using the Fast Ethernet, FDDI, ATM-OC3 or DS-3 NPMs. The exception to this is that there can only be one ATM-OC3 NPM configured and operable on the 4500-M or 4700-M routers. Therefore combinations with the ATM-OC3 NPM are either one Fast Ethernet, one FDDI, one ATM-DS3 or E3, and one HSSI. The 4500 or 4700 routers can however be configured with two Fast Ethernet, two FDDI, two HSSI, or one Fast Ethernet and one FDDI, or one Fast Ethernet and one HSSI, or one FDDI and one HSSI. In these types of configuration the remaining slot may be used by the other NPMs as noted. For complete detail of NPM configurations and combinations see Appendix F.

      1. Usage

        2. The 4000 series routers were initially developed as access routers in the Cisco routing architecture. However, as depicted in Figure 2.52, the 4700-M router using the high-speed NPMs may perform the duties of a distribution router as well as an access router.

      2. Processors

        3. The processor vary on each platform. The 4000-M series uses a Motorola 40-MHz 68030 processor while the 4500-M and the 4700-M uses and IDT Orion RISC processor. The Cisco 4500-M router uses a 100 MHz IDT Orion RISC processor while the high end 4700-M platform uses a 133 MHz IDT Orion RISC processor.

      3. Memory

Each 4000 series router comes standard with 128 KB of NVRAM which is used to store and recall the router configuration. Main memory on the router is used for executing the Cisco IOS and process routing tables. Shared memory is used to move packets between interfaces and flash memory is used to store router configurations and Cisco IOS code. Since the 4000 series is actually designed for the access layer of the Cisco routing architecture it comes with low base memory.

The 4000-M platform comes with a base of 4 MB of Flash memory expandable to either 8 MB or 16 MB. Main memory on the 4000-M starts with 8 MB and may be expanded to 16 or 32 MB of memory. Shared memory on the 4000-M in earlier models were shipped with 1 MB of shared memory. The newer models are shipped with 4 MB of shared memory. If the 4000-M being used is an earlier model the shared memory must be upgraded to a minimum of 4 MB to support FDDI or have more the five physical or virtual interfaces defined. Shared memory is expandable to 16MB.

The Flash memory support on the 4500-M platform is the same as that found on the 4000-M router. Main memory comes standard at 16 MB and with an upgrade to 32 MB of main memory. The 4500-M router comes standard with 4 MB of shared memory with the option to expand to 8 or 16 MB.

The 4700-M platform also comes standard with 4 MB of flash memory with upgrades to either 8 or 16 MB. Being the high end of the 4000 series platform the 4700-M comes standard with 16 MB of main memory with expansion to either 32 or 64MB of memory to handle large routing tables. Shared memory on the 4700-M is the same as that found on the 4500-M router.

    1. 3600 Series

The 3600 series routers is one of the newer modular platforms form Cisco. This router comes in two models the 3640 and the 3620. The 3600 series provides for increased dial-up port density with newer WAN technologies like ATM. One special feature available on the 3600 series is the ability for the operator console and auxiliary console to connect to a local or remote PC at 115.2 Kbps and support for Xmodem or Ymodem protocol for loading the router IOS software directly through these ports versus having to have a network connection.

The 3640 has more port capacity than the 3620 as shown in Figure 2.53. The 3640 is available with four network module slots while the 3620 has two network module slots available. The module slots are used to connect external media to the bus backplane of the router with network module interface cards that mix LAN and WAN media types along with asynchronous and synchronous serial connections and support for ISDN PRI and BRI interfaces.

In support of ISDN PRI connectivity the 3640 installed with a mixed media module and three 2-port ISDN PRIN network module interface can connect up to 138 T1 or 180 (E1) B channels. This enables the 3640 as a cost effective solutions for corporate telecommuting. Using three 8-port ISDN BRI network interface modules the Cisco 3640 connects up to 48 B channels with local LAN and WAN routing capability.

The port density on the network interface cards enables the 3640 to support up to 24 asynchronous or synchronous serial interfaces for multiple 56 Kbps connections. The 3600 series routers support the following network interfaces:

    • 1 and 4 port Ethernet network modules
    • 1 port Fast Ethernet network module
    • 1 port Ethernet and 1 port Token Ring network module
    • 4 and 8 port Asynchronous/Synchronous network module
    • 4 port serial network module
    • ISDN BRI (ST and U interfaces)
    • Channelized T1/ISDN PRI (with and without CSU)
    • Channelized E1/ISDN PRI (balanced and unbalanced)

The 3600 series of Cisco routers require Cisco IOS software Release 11.1(7)AA and later or Release 11.2(5)P and later.

The network modules are the cards that slide into the slots of the 3600 series routers as shown in Figure 2.54. The network modules themselves provide various interfaces for connecting external networks to the router bus backplane. Of these network modules one of the more versatile is the mixed-media network module.

The mixed-media network module supports up to two fixed LAN interfaces and two user installable WAN interfaces. The LAN interfaces are a part of the network module itself and cannot be removed. The LAN interface support as illustrated in Figure 2.55 is one of the following:

    • 1 Ethernet port
    • 2 Ethernet ports
    • 1 Ethernet and 1 token ring port

The Ethernet connections support both 10BaseT and AUI interfaces at 10 Mbps. The Token Ring port is either 4 or 16 Mbps using either STP or UTP wiring. The WAN expansion slots on the mixed-media network module supports the following WAN interface cards:

    • 1-port ISDN BRI WAN interface card
    • 1-port ISDN BRI with NT1 WAN interface card
    • 1-port serial WAN interface card
    • 1-port 4-wire 56 Kbps DSU/CSU WAN interface card

Each of the WAN network interface cards are shown in Figure 2.56. The Cisco 1600 series routers also supports the Cisco 3600 ISDN BRI, ISDN with NT1 and serial interface cards. The 3600 series router requires Cisco IOS Release 11.2(4)XA, 11.2(5)P or later to properly operate the WAN interface cards ISDN BRI, ISDN with NT1, 1-port 4-wire 56 Kbps DSU/CSU interface cards.

The network modules supporting channelized T1/E1 and ISDN PRI lines are available with a built-in CSU with one or two ports. Figure 2.57 illustrates the various channelized T1/ISDN-PRI and E1/ISDN-PRI network modules available for the 3600 series routers. Using a T1/ISDN-PRI CSU the network module connects directly to the providers network connection. Without the internal CSU the T1/ISDN PRI network module connects to an external CSU which then connects to the provides network connection. The T1 module channelizes the T1 up to 24 virtual channels per T1 port. The E1/ISDN PRI network module provides one or two E1 ports at 2.048 Mbps second in full duplex transmission. They are configured as either balanced or unbalanced and provide up to 30 virtual channels per E1 port. If the T1/E! modules are configured for using ISDN PRI they are not compatible with the 4 or 8-port ISDN BRI modules. However, when used as a "multiplexer" the ISDN BRI modules are compatible.

The ISDN BRI network modules have four different models. The use of 4 or 8 ISDN BRI ports along with S/T or on board NT1 service for each port define the four different model types as shown in Figure 2.58. The ISDN BRI network modules use local SRAM for buffer descriptor, input queues and configuration storage to increase performance. The performance of the ISND BRI 8-port model is 5,760 packet-per-second (pps) running full-duplex continuous data of 144 Kbps using 50-byte packets. The aggregate full duplex rate of the 8-port ISDN BTI network module is 2.3 Mbps. The ISDN BRI network modules include features to query the network module, SNMP traps for monitoring the network module, manageability with Ciscoworks or CiscoView and support for the ISDN MIB standard.

For more traditional low-speed network connections the 4 and 8-port Asynchronous/Synchronous network modules are available. Figure 2.59 illustrates the two module formats. These network modules support 128 Kbps synchronous connections or 115.2 Kbps asynchronous connections per port. The ports use the DB-60 interface standard for connecting to the router.

In support of Ethernet the 3600 series network modules are available with 1 and 4-port Ethernet connections. As shown in Figure 2.60, the 1-port Ethernet network module comes with one AUI DB-15 and one 10BaseT RJ-45 interface connections. Only one of these ports may be active at any time for this network module. The 4-port Ethernet adds to the 1-port Ethernet network module format three 10BaseT RJ-45 connections on the left side of the network module. The restriction of either the AUI or RJ-45 port be active on the right side of the 4-port Ethernet module still holds true. Cisco IOS Release level 11.2(4)XA and 11.2(5)P or later are required for operation.

The advancement of Ethernet has dictated that the network modules keeping with the new Ethernet standards. Currently, the 3600 series routers support a 1-port Fast Ethernet network module using an RJ-45 connector or a 40-pin media-independent interface (MII).. Again, there is a restriction that only one of these interfaces may be active at any given time. The RJ-45 connects two pair Category 5 UTP wiring using the 100BaseTX standard. Using the MII an external transceiver is required to connect to a multimode optical fiber using 100BaseFX standard or it can use the 100BaseT4 standard over four-pair of Category3, 4 or 5 UTP or STP wiring. Figure 2.61 diagrams the 1-port Fast Ethernet network module for the 3600 series router which requires Cisco IOS Release 11.2(6)P or higher for operation.

The Cisco 3640 supports a maximum of two 1-port Fast Ethernet network modules with no other network modules installed. If using the 1-port Fast Ethernet with a 4-port Ethernet network module the 3640 router may be configured for a maximum of 1 Fast Ethernet and two 4-port Ethernet network modules along with other network modules.

Using the high-density DB-60 interface standard the 4-port serial network module can support various data rates. If only port 0 is use then the interface can realize a data rate of 8 Mbps. Using ports 0 and 2 the data rate is halved to 4 Mbps per port and using all four ports the data rate is halved again to maximum of 2 Mbps per port.

      1. Usage

        2. The 3600 series routers are designed for the access layer of the Cisco router architecture. As shown in Figure 2.62, the 3640 is ideal for use by ISPs to have many points-of-presence (POPs) or for telecommuting to a corporate environment. The 3620 provides for small office connectivity and local LAN and WAN connections using mixed media network modules.

      2. Processors and Memory

The two models of the Cisco 3600 series use different processors. The Cisco 3640: uses the 100-MHz IDT R4700 RISC processor and the Cisco 3620 uses the 80-MHz IDT R4600 RISC processor. The 3600 series uses a single DRAM pool which is partitioned main and shared memory areas. This partitioning of DRAM makes memory calculation difficult when configuring the 3600 router platforms. Appendix F identifies some guidelines on how to configure the proper amount of DRAM for the 3600 routers. The 3600 series also uses flash memory. Both the DRAM and flash using the SIMM chips for memory allowing field upgrades and replacements. The standard flash memory is 4 MB. However, the flash memory can be upgraded to a maximum of 48 MB for both the 3620 and 3640 routers. Each routers comes with a base of 16 MB of DRAM which is expandable on the 3620 to 64 MB and on the 3640 to 128 MB. In addition to on board flash memory the 3600 series has PCMCIA two slots available in support of 4MB to 128 MB of flash using two 64 MB PCMCIA flash cards.

    1. 2600 Series

The Cisco 2600 series router platform extends the modular format of the 3600 series into the smaller remote branch office. The modularity of the 2600 series enables these small offices to deploy voice/fax/video along with data in a single versatile network appliance. The Cisco 2600 shares many of the same network module interfaces with the 3600 and 1600 router platforms. The 2600 series supports one network module slot, two WAN Interface Card slots and a new interface slot dubbed Advanced Integration Module (AIM). Cisco maximizes uptime on the 2600series through the use of an external Redundant Power Supply (RPS) and Cisco IOS dial-on demand routing features for the restoration of both data an voice connections automatically should the primary link failure occur.

The 2600 series comes in two flavors: a single Ethernet (2610) or a dual Ethernet interface (2611). The WAN interface card slots support:

    • Serial
    • ISDN BRI
    • Built in CSU/DSU functions

The network modules add needed support for:

    • Multiservcie voice/data/fax integration
    • Deparmental dial concentraion
    • High-density serial concentration

The AIM slot supports added features for optimization through hardware assisted data compression and encryption.

An auxiliary port with the ability for use as a 115 Kbps Dial ON Demand Routing interface for WAN back-up connectivity is standard on both the 2610 and 2611 models. Figure 2.63 shows the rear panel of the 2600 models.

The Cisco 2600 shares many of the data network modules with the 3600 series routers. These shared data network modules are:

  • 16-port high density async network module - NM-16A
  • 32-port high density async network module - NM-32A
  • 4-port low speed (128 Kbps max) async/sync serial network module1-NM-4A/S1
  • 8-port low speed (128 Kbps max) async/sync serial network module - NM-8A/S

The following Voice/fax network modules and interface cards are shared with the 3600 series router:

  • One-slot Voice/Fax Network Module - NM-1V
  • Two-slot Voice/Fax Network Module - NM-2V
  • Two-port FXS Voice /Fax Interface Card - VIC-2FXS
  • Two-port FXO Voice /Fax Interface Card - VIC-2FXO
  • Two-port E/M Voice /Fax Interface Card - VIC-2E/M

The 2600 series also shares WAN Interface Cards (WICs) with the 1600 and 3600 series routers. These cards are the:

  • One-port serial WAN Interface Card - WIC-1T
  • One-port 4-wire 56 Kbps DSU/CSU - WIC-1DSU-56K4
  • One-port ISDN BRI - WIC-1B-S/T
  • One-port ISDN BRI with NT1 -WIC-1B-U

WICs unique to the 2600 series support the following configuration:

  • 2-Port Serial WAN Interface Card for Cisco 26002 - WIC-2T2
  • 2-Port Async/Sync Serial WAN Interface Card for Cisco 26002 - WIC-2A/S2
      1. Usage

        2. Based on its size and purpose we can see that the 2600 series falls into the access layer of the Cisco layered network topology. Multiservices have become quite desirable for reducing communications network infrastructure cost while at the same time enhancing application functionality. Using the QoS features built into the Cisco IOS software small branch offices and participate is voice-enabled desktop applications and desktop video.

        Using the modular features the 2600 can serve as a dial services concentrator for remote office and remote user access by supporting up to 36 high-speed asynchronous ports using PPP, SLIP, ARA and Xremote protocols. As shown in Figure 2.64, this enables casual connection for these remote locations to the corporate WAN through the WAN interface cards available on the two 2600 models.

        The various WAN modules and WAN Interface Card slot options enable the 2600 series routers to be a serial device concentrator. Through the power of the Cisco IOS and optional support of upto 12 synchronous serial interfaces the 2600 protects legacy sysetm investment for SDLC, bisynch and asynch devices. Ideally, this ability in combination with the Ethernet LAN interfaces and integrated CSU/DSU and ISDN BRI WAN interface cards allows a network designer to provide a solution for connecting retail, financial and sales branch offices.

      2. Processor

        3. The 2600 series router has a Motorola MPC860 40 MHz CPU with a 20 MHz internal bus clock.

      3. Memory

The system memory (DRAM) comes in two DIMM slots. The default memory size is 16MB with expansion to a total of 64 MB. Flash memory is incorporated on the processor board using a single SIMM slot supporting a default of 4 MB with expansion to 16 MB. The DRAM on the 2600 uses pooled DRAM memory. The DRAM is partitioned between processor and packet memory areas. The default 16 MB of DRAM is partitioned into 12 MB for processor and 4 MB for packet memory.

Cisco IOS Release 11.3(2)XA and 11.3(3)T and higher. The Cisco IOS may be loaded into the router using the LAN interface and TFTP or using the auxiliary or console port using Ymodem or Xmodem protocols. This is valuable for remote dial-up restoration of a damaged IOS or for updating the stored configuration file.

    1. 2500 Series

The 2500 series router platform from Cisco provides specific access layer functions for small offices or small business. The 2500 series comes in many different solution formats. These are:

    • Single LAN routers
    • Mission-Specific routers
    • Router/hub combinations
    • Dual LAN routers
    • Modular routers

Additionally, the 2500 series comes in an access server offering for supporting remote dial-up access to enterprise networks The Cisco access servers are not discussed in this text. The console and auxiliary ports on the 2500 series use RJ-45 connectors. Any 2500 series model ordered comes with a cable kit to connect an RJ-45-to-RJ-45 using a roll-over console cable, an RJ-45-to-DB-25 male DCE adapter, an RJ-45-to-DB-25 female DTE adapter, and an RJ-45-to-DB-9 female DTE adapter for connecting PCs or modems to the these ports. The low-speed serial asynch-/synchronous ports on all the models support asynchronous connections up to 115.2 Kbps and synchronous connections up to 2 Mbps.

The single LAN routers come in eight models. Each model has a different combination of non-upgradeable or non-field modifiable interfaces. The 2501 shown in Figure 2.65 provides a single Ethernet 10 Mbps port and two synchronous serial interfaces. The Ethernet uses a DB-9 AUI port which may require an external transceiver to connect to an RJ-45 LAN hub interface. The two serial ports use DB-60 connectors and all data rates up to 2 Mbps.

The 2502 router pictured in Figure 2.65 has a token-ring LAN interface instead of an Ethernet AUI port. The token-ring interface uses DB-9 connection which may require a converter to an RJ-45 connector for connecting to a LAN hub. The token –ring interface is configurable as 4 or 16 Mbps data rates.

The addition of a single ISDN BRI port on the is shown on the 2503 and 2504 routers in Figure 2.65. Note that the 2503/2504 is the same as the 2501/2502 with the exception of the ISDN BRI ports. The ISDN BRI ports have an internal ISDN Terminal Adapter. These ports must connect to an ISDN NT1 device for switched ISDN connectivity.

Support for low-speed asynch-/synchronous serial lines is provided by the 2520/2521 platforms pictured in Figure 2.66. There are two low-speed connections with asynchronous data rates up to 115.2 Kbps and synchronous data rates up to 128 Kbps. Additionally, the LAN ports for Ethernet and Token-ring are also provided with an RJ-45 connection interface. Only one LAN interface is allowed to be configured and operative at any one time.

The 2520/2521 also provides a single ISDN BRI port. The 2520 Ethernet AUI or 10BaseT RJ-45/UTP adapter supports 10 Mbps and the 2521 token-ring DB-9 or RJ-45/UTP adapter supports 4 or 16 Mbps data rates.

The last two models, pictured in Figure 2.67, in the single LAN category of the 2500 series routers provides for up to eight low-speed asynch-/synchronous and two high-speed communications interfaces, a single ISDN BRI and a single LAN interface. The 2522 provides for Ethernet at 10 Mbps using an AUI or a 10BaseT RJ-45 connection. The 2523 model supports the 4 or 16 Mbps token-ring speeds using either the DB-9 or RJ-45 UTP ports.

Mission specific entry level routers in the 2500 series come in twelve unique offerings. The mission specific router models are configured with less memory than the single LAN models and execute IOS software images specifically designed for the CFRAD (CF), LAN FRAD (LF) and ISDN requirements. The special IOS images disable/enable unused ports through software. These mission specific routers give the single LAN router platforms the ability to act as frame relay access devices for connecting the location to frame relay networks without having to connect through a separate frame relay access piece of equipment. The CF models allow the router to also act as a frame relay switch for delivering information through frame relay networks. These models are however upgradeable to full functionality through full function IOS software and added memory.

The mission-specific routers are the exact models of the single LAN routers however, through the software have limited functionality. The 2501CF/2502CF routers have their respective LAN ports disabled by the IOS software and only allows configuration of the two high speed serial interfaces. The 2501LF/2502LF have their LAN ports enabled along with the ability to send LAN traffic through frame relay networks directly.

The 2503I/2504I provide for Ethernet and Token-Ring LAN connectivity respectively through ISDN BRI connections. The high speed serial connections available on the router are software disabled.

The 2520CF, 2521CF, 2522CF and 2523CF routers all have their ISDN BRI ports disabled and their respective LAN interfaces also disabled. The low- and high-speed ports are enabled and functional.

The 2520LF, 2521LF, 2522LF and 2523LF have all their LAN and WAN ports enabled however their ISDN BRI ports are disabled by the software.

For locations where a single device to support both routing and LAN connectivity for workgroups and small offices the Cisco 2500 series router/hub combinations is available in six different formats. Each format supports only one LAN segment but has multiple ports available for connecting workstations or servers. The integrated hubs on these router platforms save the small business or small office equipment and software costs while providing a full LAN/WAN solution.

The 2505, 2507, 2516 and 2518 router/hub offerings, diagrammed in Figures 2.68 and 2.69, provide a single segment Ethernet LAN environment.

Caption; The 2505/2507 models of the Cisco 2500 series router.

The 2505 supports up to eight Ethernet connections, the 2507 supports sixteen, the 2516 supports fourteen and the 2518 supports twenty-three Ethernet LAN connections to the hub. The router card of the 2518 connects to port 24 of the Ethernet hub allowing the 2518 to route LAN traffic over the WAN. The AUI port on the 2518 allows the 2518 to connect to an external Ethernet hub expanding the reach of the LAN segment. Both the 2516 and the 2518 have the ability to expand to five hubs using Lanoptics hub expansion units. Each platform has two high-speed serial interfaces. Only the 2505/2507 do not provide for an ISDN BRI interfaces.

The 2517 and 2519 support toke-ring LAN segments. The 2517 model allows for eleven token-ring LAN connections to the hub while the 2519 supports up to twenty-three token-ring LAN segments to the hub. The hub interfaces can either be 4 or 16 Mbps but all the ports must be using the same data rate. The 2519 contains a token-ring ring-in/ring-out ports for cascading token-ring hub equipment thereby increasing the size of the token-ring segment. Additionally, the ring ports 1-12 may be defined as a separate token-ring segment from ports 13-24. Both the 2517 and 2519 have router cards with token-ring RJ-45 connectors. The router cards attach to port 12 of the 2517 and port 24 of the 2519 routers. This enables the routers to transport LAN traffic over a WAN. The 2517 allows a single port on the 11 available ports to connect to another hub using an RJ-45 cross-over cable expanding the token-ring segment. On the 2519 the ring-in/ring-out ports allow for the expansion of the segment. An expansion unit is found on the top of the 2517 and 2519 to expand the hub to five hubs using Lanoptics supplied hubs. Both of these models have a single ISDN BRI port for switched backup use or bandwidth on demand use in conjunction with two high speed serial ports.

Small offices requiring more than one LAN are supported by the dual LAN router models. These are available in three different models. Figure 2.70 depicts the three dual LAN routers. All three models do not have ISDN BRI ports available. The 2513 supports one Ethernet 10 Mbps LAN segment and one toke-ring 4 or 16 Mbps LAN segments with two high-speed serial interfaces. The 2514 supports two Ethernet 10 Mbps LAN segments using AUI ports and the 2515 supports two Token-ring LAN segments at 4 or 16 Mbps using DB-9 connectors.

The modular routers in the 2500 series give the network engineer the ability to change and adapt the 2500 series routers unlike the previous models mentioned. There are two types of modular 2500 series routers. The two modular router models shown in Figure 2.71 differentiate themselves by the LAN support

. The 2524 connects Ethernet LANs while the 2525 provides Token Ring connections. Both allow up to three WAN modules configuring up to two synchronous serrial and one ISDN. The modules are available in the following configurations:

    • 2-wire, switched, 56-kbps DSU/CSU
    • 4-wire, 56/64-kbps DSU/CSU
    • Fractional T1/T1 DSU/CSU
    • Five-in-one synchronous serial
    • ISDN BRI
    • ISDN with integrated NT1 device

The three available slots shown in Figure 2.71 on the 2524 and 2525 are used for the WAN interfaces. The WAN slot on the right of the unit is keyed to allow only the ISDN BRI interface cards be installed. Likewise, the ISDN BRI cannot be installed in the first two WAN slots starting on the left of the router. The 2-wire, Switched 56 Kbps DSU/CSU WAN module allows for 56 Kbps dial up connections through the plain old telephone service (POTS) using an RJ-11 connection. The module connects directly form the RJ-11 port on the module to the RJ-11 port on the wall for connecting to the public telephone network.

The 4-wire 56/64 Kbps DSU/CSU WAN Module, Figure 2.71, for the 2524 and 2525 router provides dedicated leased line synchronous serial connections up to 64 Kbps using and RJ-48S connector directly to the wall plate connecting the line to the communications network.

The fractional T1/T1 DSU/CSU WAN module, shown in Figure 2.71, uses an RJ-48C connector to the network. This module supporting a 1.544 Mbps line provides either Nx56 or Nx64 channels up to a total of 24 individual channels at each speed. Each channel is defined as if it were its own unique interface.

The ISDN modules pictured in Figure 2.72 provide ISDN BRI connectivity using RJ-45 S/T connections. The ISDN BRI supports two B channels and one D channel. The two B channels together allow for a switched connection of 128 Kbps. The ISDN BRI module contains its own Terminal adapter and must be connected to an external NT1 device. The second ISDN BRI module has an integrated NT1 device and connects directly to the ISDN BRI port installed by the network provider.

The five in one synchronous serial WAN module shown in Figure 2.73 enables the one interface to support the following electrical interface standards using the appropriate cables:

    • EIA/TIA-232
    • EIA/TIA-449
    • V.35
    • X.21
    • EIA-530

The router side of the cable used has a DB-60 connector. The opposite end is headed with the appropriate interface required as specified by the line connection requirements.

      1. Usage

        2. The 2500 series has many different uses and in some ways can provide both distributed an access layer functions. For example, in Figure 2.73 a 2525 is used to connect a location to a frame relay network with a 56 Kbps switched dial backup line to another 2525 at a different location. Meanwhile a 2519 at a third sight connects a token ring LAN to a corporate center using a 256 Kbps line to a multiplexer attached to a 2424 with a Fractional T1 WAN module servicing all three remote sights and connecting them to a core router in the larger corporate backbone.

      2. Processor and Memory

All the 2500 series router platforms use the Motorola 20 MHz 68030 processor. Each system comes with a minimum of 8 MB of flash memory. The minimum system memory provided with the routers is 4 MB of DRAM partitioned between shared and primary DRAM memory. The total amount of DRAM available on the 2500 series graduates from 4 to 8 to 16 MB. All configurations of DRAM are partitioned into 2 MB of shared memory. The remaining DRAM is used for primary DRAM resulting in 2, 6 and 14 MB of primary DRAM respectively. For completeness consult Appendix G on 2500 series router memory requirements and IOS software feature support.

    1. 1600 Series

      2. For small offices or offices with occasional connectivity requirements Cisco offers the 1600 series router platform. The 1600 series had four models. The 1601, 1602, 1603 and 1604. All the models come equipped with one Ethernet 10 Mbps port, a built-in WAN port and one WAN interface card expansion slot for added bandwidth and flexibility. The WAN ports support ISDN BRI, asynchronous serial up to 115.2 Kbps, synchronous serial connections up to 2.048 Mbps.

      The 1601 has a built-in serial WAN port for leased line connection rates up to 2.048 Mbps. The 1602 uses the built-in WAN port for a 56 Kbps 4-wire CSU/DSU interface thereby eliminating an external CSU/DSU device. The 1603 has a built in ISDN BRI S/T port with a Terminal Adapter requiring connectivity to an external NT1 device. The 1604 removes the external NT1 connection for the built in ISDN BRI port by including the NT1 device internally. IN addition, the n1604 includes an ISDN-S port which allows the router to connect to an ISDN telephone or fax on the second B channel of the same ISDN line. Figure 2.75 illustrates the front of all the 1600 routers and the rear views of the four individual offerings. The expansion slot of the 1603 and 1604 is not available for a second ISDN port. However, the 1601 and 1602 can mix and match all the available WAN module for the expansion slot.

      There are three WAN interface expansion modules available with the 1600 series routers. Figure 2.76 diagrams their interface plates. The serial WAN interface expansion module provides EIA/TIA-232, V.35, X.21, EIA/TIA-499, and EIA-530 standard interfaces with support for 115.2 Kbps asynchronous and up to 2.048 Mbps synchronous connections. The proper cable must be installed to support the various interface requirements for successful operation. The ISDN BRI S/T supports two B channels and one D Channel for data only. The ISDN BRI U with a built in NT1 allows connectivity to the a switched ISDN network without the use of an external NT1 device.

      1. Usage

        2. The 1600 series routers are an ideal low cost solution for small remote sales offices or telecommuters with need for high-speed connectivity or casual connectivity to a single Ethernet LAN segment with IP/IPX or AppleTalk communication requirements. The 1600 series is the quintessential access layer router as shown in Figure 2.77.

      2. Processor and Memory

      The 1600 series uses the Motorola 68360 33 MHz processor. Each unit comes with a base of 4 MB of flash which is expandable to 12 MB. Flash expansion can go from 4 to 6MB or 4 to 8 MB or 4 to 12 MB. The DRAM comes with a bas e of 2 MB of memory expandable to a maximum of 18 MB.

    2. 700M Family of Access Routers

The Cisco 700M family is an ISDN multiprotocol access router. The 700M family supports ISDN basic rate interface (BRI) of 56, 64 or 128 Kbps remote access connections. The Cisco 700M family of access routers comes in two series: the 760 and 770. The 760 series has one Ethernet 10Mbps LAN interface and an ISDN BRI port. The 770 series includes a built in 4-port 10 Mbps Ethernet hub, ISDN BRI along with a call connect/disconnect switch on the format of the router to allow the user to manually connect or disconnect the ISDN BRI data linen connection.

The 760/770 series is broken further down into four models. Their features and functions are:

    • 761M/771M (h5906/ h8503)

Shown in Figure 2.78, these models require an external Network Termination 1 (NT1) device for connectivity. It is based on the Intel 25 MHz 386 processor and comes with 1.5MB expandable to 2 MB over DRAM. The on-board NVRAM is 16 KB with a 1 MB flash memory. It can support up ton 1500 users and is available worldwide.
    • 762M/772M (h5905/h8504)

Shown in Figure 2.79, these models include an internal Network Termination 1 (NT1) device for connectivity. Additionally, these models have a second BRI port for external ISDN device connectivity or a second ISDN BRI line. It is based on the Intel 25 MHz 386 processor and comes with 1.5MB expandable to 2 MB over DRAM. The on-board NVRAM is 16 KB with a 1 MB flash memory. It can support up ton 1500 users and is available in North America only.
    • 765M/775M (h5789/h8502)

Shown in Figure 2.80, these models require an external Network Termination 1 (NT1) device for connectivity. It also includes two analog POTS RJ-11 ports for attaching phones, fax machines and modems to share the ISDN BRI simultaneously with data. This model also supports provider supplemental services over ISDN such as: call waiting, cancel call-waiting, call retrieve, call hold, 3-way call conferencing, and call transfer. It is based on the Intel 386 processor and comes with 1.5MB expandable to 2 MB over DRAM. The on-board NVRAM is 16 KB with a 1 MB flash memory. It can support up to 1500 users and is available worldwide.
    • 766M/776M (h5788/h7861)

Shown in Figure 2.81, these models include an internal Network Termination 1 (NT1) device for connectivity. Additionally, these models have a second BRI port for external ISDN device connectivity or a second ISDN BRI line. It also includes two analog POTS RJ-11 ports for attaching phones, fax machines and modems to share the ISDN BRI simultaneously with data. This model also supports provider supplemental services over ISDN such as: call waiting, cancel call-waiting, call retrieve, call hold, 3-way call conferencing, and call transfer. It is based on the Intel 386 processor and comes with 1.5MB expandable to 2 MB over DRAM. The on-board NVRAM is 16 KB with a 1 MB flash memory. It can support up ton 1500 users and is available North America only.

The 700M family can act as the DHCP server for the LAN attached devices assigning the remote locations IP addresses to the attached workstations. The 700M family can also have its IP or IPX addresses assigned from the provider or central site network connection using Multilink Point-to-Point Protocol (MPPP). The ISDN BRI connection can dial-on demand dynamically when it senses "interesting" traffic as defined by the remote location network administrator. This feature is useful when one ISDN BRI B channel connects to one location and traffic is generated for a second location. The second B channel can be activated for the life of the interesting traffic and then terminated. Also useful is setting FTP traffic as interesting to the router when transferring large file to another location by bringing up the second B channel to increase bandwidth.

In typical configurations there are many LAN workstation requiring access to another remote location. In many instances the 700M is used as a connection to the Internet. Internet service providers (ISPs) typically provide only one Internet address for the location. The 700M uses a many-into-one feature called Port and Address Translation (PAT) to over come this single address restriction. PAT is also used as a firewall function allowing to protect unknown resources from accessing the remote locaiton and privileging internal devices to access the Internet. The access can include web browsing, e-mail or file transfer to devices on the remote LAN network.

As described the 700M family is an access router. It's typical use is for occasional connectivity requirements from a remote location to another location. The location may be another remote office, the Internet or a central office location.

Backward Forward


Sackett

Chapter Three

Cisco Router Network Design

The hierarchical structure of the Cisco router network design model is based on the type of services provided at each layer. The notion of using layers creates a modular architecture enabling growth and flexibility for new technologies at each layer. The Cisco hierarchical design model consists of three layers. Figure 3.1 diagrams the Cisco hierarchical design model.

The core layer provides the high-speed backbone for moving data between the other layers. This layer is geared towards the delivery of packets and not packet inspection or manipulation.

The distribution layer provided policy-based networking between the core and access layer. The distribution layer provides boundaries to the network topology and provides several services. These services are:

  • Address or area aggregation
  • Departmental or workgroup access
  • Broadcast/multicast domain definition
  • Virtual LAN (VLAN) routing
  • Any media transitions that need to occur
  • Security

The access layer is the edge of the network. Being on the edge the access layer is the entry point to the network for the end user community. Devices participating in the access layer may perform the following functions:

  • Shared bandwidth
  • Switched bandwidth
  • MAC layer filtering
  • Microsegmentation

It is important to remember that the Cisco hierarchical design model addresses functional services of a network. The different layers described may be found in routers or switches. Each device may partake in the functions of more than one layer. Separation of functional layers is not mandatory however; maintaining a hierarchical design fosters a network optimized for performance and management.

    1. The Network Infrastructure Life-Cycle

      2. Every corporation has a network infrastructure in place as the framework supporting the business processes. Just as applications and systems have life cycles so does a network infrastructure. This section highlights a network infrastructure life-cycle that may be used as a general guideline for designing and implementing Cisco based networks.

      1. Executive Corporate Vision

        2. Corporate organizational restructuring through regional consolidation or through business group integration will certainly have an effect on the network infrastructure. Aligning the corporate vision with the business directives builds the foundation for the network infrastructure.

      2. Gather Network Infrastructure Information

        3. This involves research and discovery of the current network WAN topology as well as corporate and branch office LAN topologies. A full understanding of end-to-end network configuration is required. Additionally, bandwidth allocations and usage costs must be determined to provide the complete picture.

      3. Determine current network requirements

        4. Communication protocols, client/server architectures, e-mail, distributed processing, Inter— and Intranet, voice and video, each has its own unique characteristics and can place demands on the network. These demands have to be recognized and understood for planning an enterprise wide solution. The result from this study is a network profile for each business process and the network itself.

      4. Assess current network operational processes

        5. Network operational processes involve not just daily trouble shooting but the other disciplines of network management: Inventory, Change, Configuration, Fault, Security, Capacity/Performance, and Accounting. Documenting the processes in place today will assist in evaluating the current baseline of service provided and identify areas that may need re-engineering to meet the changing business requirements.

      5. Research plans for new applications

        6. The effect of new applications on network characteristics must be discovered prior to business groups moving into development, testing and production. Desktop video conferencing and voice communications along with data traffic requires up front knowledge to re-engineer a network. Business group surveys and interviews along with each group's strategic plan will provide input to creating a requirements matrix.

      6. Identify networking technologies

        7. The selection of the appropriate technologies and how they can be of use in meeting current and future networking requirements relies on vendor offerings and their support structure. Paramount to this success is the partnership with and management of the vendors through an agreed on working relationship.

      7. Define a flexible strategic/tactical plan

        8. The strategic plan in today’s fast pace changing technology environment requires flexibility. A successful strategic plan requires business continuity through tactical choices. The strategic plan must demonstrate networking needs in relation to business processes both current and future.

      8. Develop Implementation Plan

        9. This is the most visible of all the previous objectives. The planning and research performed prior can be for naught if the implementation does not protect current business processes from unscheduled outages. This must meet current business requirements and demands while migrating the network infrastructure to the strategic/tactical design. The perception to the business community must be business as usual.

      9. Management and Review

      The effectiveness of the new infrastructure is achieved through management and review. Reports highlighting the network health measured against expected service levels based on the strategic/tactical plan and design reflect the ability of the network to meet business objectives. The tools and analysis used here provide the basis for future network infrastructures.

    2. Design Criteria (Design Internet Basics)

      3. In planning for your network design there are many criteria to consider. These criteria are based on the current network design and performance requirements as measured against the business direction compared to internetworking design trends. The trends of internetworking design affect the four distinct components of an enterprise internetwork. These components are:

      Local Area Networks - These are networks within a single location that connect local end users to the services provided by the entire enterprise network.

      Campus networks - These are networks within a small geographic area interconnecting the buildings that make up the corporate or business entity for the area.

      Wide-area networks (WAN) - These networks span large geographic areas and interconnect campus networks.

      Remote networks - These types of networks connect branch offices, mobile users or telecommuters to a campus or the Internet.

      Figure 3.2 illustrates today's typical enterprise-wide corporate network topology.

      1. The Current LAN/Campus Trend

        2. LANs and Campus networks are grouped together for the simple reason that they share many of the same networking issues and requirements. Depending on technologies used a LAN may be focused within a building or span buildings. The spanning of a LAN makes up the campus network. Figure 3.3 diagrams a LAN/Campus network topology.

        Campus networks are a hybrid of LANs and WANs. From LAN/WAN technologies campus networks use Ethernet, Token Ring, Fiber Distributed Data Interface (FDDI) Fast Ethernet, Gigabit Ethernet and Asynchronous Transfer Mode (ATM).

        Two LAN technologies that serve to optimize bandwidth and increase flexibility for LAN design are Layer 2 and Layer 3 switching. In short, Layer 2 switching occurs at the data link layer of the OSI Reference Model and Layer 3 switching occurs at the Network layer of the OSI reference Model. Both switching algorithms increase performance by providing higher bandwidth to attached workgroups, local servers and workstations. The switches replace LAN hubs and concentrators in the wiring closets of the building.

        The ability to switch end user traffic between ports on the device has enabled the concept of Virtual LANs (VLANs). Defining VLANs on the physical LAN enables logical groupings of end user segments or workstations. This enables traffic specific to this VLAN grouping to remain on this virtual LAN rather than use bandwidth on LAN segments that are not interested in the grouped traffic. For example, the Finance VLAN traffic does not affect the Engineering VLAN traffic. Table 3.x lists the important technologies affecting LAN and Campus network design.

        Routing technologies | Routing has long been the basis for creating internetworks. For use in a LAN/Campus environment, routing can be combined with Layer 3 switching. Layer 3 switching may also replace the entire function of a router.
LAN switching technologies |
Ethernet switching | Ethernet switching is Layer 2 switching. Layer 2 switching can enable improved performance through dedicated Ethernet segments for each connection.
Token Ring switching | Token Ring switching is also Layer 2 switching. Switching token-ring segments offers the same functionality as Ethernet switching. Token Ring switching operates as either a transparent bridge or a source-route bridge.
ATM switching technologies | ATM switching offers high-speed switching technology that integrates voice, video, and data. Its operation is similar to LAN switching technologies for data operations.
      2. Wide Area Network Design Trends

        3. Routers are typically the connection points to WANs. Being at this juncture, the routers have become an important decision point for the delivery of traffic. With the advent of switching the routers are slowly moving away from being the WAN device. The WAN services are now being handled by switches with three types of switching technologies. These are circuit, packet and cell switching.

        Circuits switching provides dedicated bandwidth while packet switched enabled efficient use of bandwidth with flexibility to service multiple requirements. Cell switching combines the best of both circuit and packet switched networks. ATM is the leading cell-switched technology used in the WAN today.

        Because the WAN links end up servicing all traffic from one location to another, it is important that the bandwidth and performance be optimized. The optimization is due in part to the explosive growth of remote site connectivity, enhanced application architectures such as, client/server and intranets, and the recent development of consolidating servers to a centralized location to ease administration and management. These factors have reversed the rules for traffic profiles form that of 80% LAN and 20 % WAN to 80 % WAN and 20% LAN. This flip-flop of traffic characteristics has increased the requirement for WAN traffic optimization, path redundancy, dial backup and Quality of Service (QoS) to ensure application service levels over the WAN. The technologies available today that enable effective and efficient use of WANs are summarized in Table 3.x. Coming on the horizon are such technologies as: Digital Subscriber Line (DSL), Low-Earth Orbit (LEO) satellites, and advanced wireless technologies.

        WAN Technology | Typical Uses
Analog modem | Analog modems are typically used for temporary dial-up connections or for backup of another type of link. The bandwidth is typically 9.6bps - 56 Kbps.
Leased line | Leased lines have been the traditional technology for implementing WANs. These are links "leased" from communications services companies for exclusive use by your corporation.
Integrated Services Digital Network (ISDN) | ISDN is a dial-up solution for temporary access to the WAN but adds the advantage of supporting voice/video/fax on the same physical connection. As a WAN technology, ISDN is typically used for dial-backup support at 56, 64 or 128 Kbps bandwidth.
Frame Relay | Frame Relay is a distance insensitive telco charge thereby making it very cost effective. It is used in both private and carrier-provided networks and most recently is being used to carry voice/video/fax/data.
Switched Multimegabit Data Service (SMDS) | SMDS provides high-speed, high-performance connections across public data networks. It can also be deployed in Metropolitan Area Networks (MANs). It is typically run at 45 Mbps bandwidth.
X.25 | X.25 can provide a reliable WAN circuit however does not provide the high bandwidth requirements as a backbone technology.
WAN ATM | WAN ATM is used as the high bandwidth backbone for supporting multiservice requirements. The ATM architecture supports multiple QoS classes for differing application requirements delay and loss.
Packet over SONET (POS) | POS is an oncoming technology that transports IP packets encapsulated in SONET or SDH frames. POS meets the high bandwidth capabilities of ATM and through vendor implementations supports QoS.
      3. Remote Network Trends

        4. Branch offices, telecommuters and mobile users constitute remote networks. Some of these may use dial-up solutions with ISDN or analog modems. Others may require dedicated lines allowing access to the WAN 24 hours a day 7 days a week (24x7). A study of the users business requirements will dictate the type of connection for these remote locations. Using ISDN and vendor functionality, a remote location can be serviced with 128 Kbps bandwidth to the WAN only when traffic is destined out of the remote location. Analysis of the ISDN dial-up cost based on up time to the WAN, as compared to the cost of a dedicated line to the WAN, must be determined for each location. This analysis will provide a break-even point on temporary versus dedicated WAN connectivity. Any of the various technologies discussed for the WAN may be well suited for remote network connectivity.

      4. Application availability versus cost effectiveness

It is the job of the network to connect end users with their applications. If the network is not available then the end users are not working and the company loses money. Application availability is driven by the importance of the application to the business. This factor is then compared against the cost of providing application availability using:

  • Redundant lines for alternate paths
  • Dial-back up connectivity
  • Redundant devices with redundant power supplies for connecting the end users
  • On-site or remote technical support
  • Network management reach into the network for troubleshooting
  • Disaster recovery connectivity of remote locations to the disaster recovery center

Designing an internetwork therefore has the main objective of providing availability and service balanced with acceptable costs for providing the service. The costs are generally dominated by three elements of supporting a network infrastructure. These are:

  • The number and location of hosts, servers, terminals and other devices accessing the network; the traffic generated by these devices and the service levels required to meet the business needs.
  • The reliability of the network infrastructure and traffic throughput that inherently affect availability and performance thereby placing constraints on meeting the service levels required.
  • The ability of the network equipment to interoperate, the topology of the network, the capacity of the LAN and WAN media and the service required by the packets all affect the cost and availability factor.

The ultimate goal is to minimize the cost of these elements while at the same time delivering higher availability. The total-cost of ownership (TCO) however is dependent on understanding the application profiles.

      1. Application profile

Each application that drives a business network has a profile. Some profiles are based on corporate department requirements and others may be a directive for the entire company. A full understanding o the underlying architecture of the application and its use of the network is required for creating an application profile. Three basic components drive a network profile. Figure 3.4 illustrates these graphically. These are:

  • Response time
  • Throughput
  • Reliability

Response time is a perceived result by the end user and a measured function of the network engineer. From a user standpoint, it is the reduced "think-time" of interactive applications that man dates acceptable response time. However, a network design that improves response time is relative to what the end user has perceived as normal response time. A network engineer will break down the components that make up the response time into the following components: host-time and network time. The difference between the two are that host time is application processing, be this disk access to retrieve data or analysis of data. Network time is the transit time as measured from leaving the host to the network interface of the end user device. Host time is then again computed on the workstation. Typically, host time on a workstation is based on presentation to the end user. Online interactive applications require low response times. These applications are usually referred to as time sensitive applications.

Applications that rely on the delivery of large amounts of data are termed throughput-intensive applications. Typically, these applications perform file transfers. They require efficient throughput however, many of these applications also depend on the delivery of the data within a time window. This is where they can adversely affect interactive application response times due to their throughput.

Reliability is often referred to as up time. Applications requiring a high reliability inherently require high accessibility and availability. This intern requires hardware and topology redundancy, not only on the network side but also on the application host or server side. The importance of the function served by the application is weighed by the cost of downtime incurred by the business. The higher the cost-of-downtime the higher the requirement for reliability.

Creating an application becomes paramount in understanding the needs of a network design. Application profiles are assessed through exercising some or all of the following methods:

  • Profile the user community - Determine corporate versus departmental internetworking requirements by separating common applications from specific applications for each community. If possible, develop the application flow from the end user to the host/server for each common and specific application. Using network management tools gather network traffic profiles to parallel the user community.
  • Interviews, focus groups and surveys - Using these methods insight into current perceptions and planned requirements are discovered. This process is key to developing the current baseline of the network in addition to coalescing information about planned requirements shared by independent departments. Data gathered here in combination with the community profiles is used for developing the new network design.
  • Design Testing - This is the proof-of-concept stage for the resulting design. Using simulated testing methods or real-time lab environments the design is measured against the requirements for response-time, throughput and reliability.
      1. Cost Efficiency

The network is now an asset to all corporations. As such, investment into the network must be viewed as a total-cost-of-ownership (TCO). These costs are not only equipment investment but also include:

Total cost of equipment - this includes not only hardware but software, installation costs, maintenance costs and upgrade costs.

Cost of performance - is the variable against which you measure the improved network performance and reliability against the increase of business conducted. The ratio between the two determines the effectiveness of the investment.

Installation cost - the physical cabling infrastructure to support the new design becomes a large one-time investment cost. Implement a physical cabling infrastructure that meets current and future networking technologies and requirements.

Growth costs - Reduce growth costs by implementing technologies today that can meet the direction of technologies tomorrow.

Administrative and Support - Limit the complexity of the internetwork design. The more complicated the higher the cost for training, administration, management and maintenance.

Cost of downtime - Analyze the cost of limited, reduced or inaccessible application hosts, servers and databases. A high down time cost may require a redundant design.

Opportunity costs - Network design proposals should provide a minimum of two designs with a list of pros and cons to each design. Opportunity costs are the costs that may be realized by not choosing a design option. These costs are measured more in a negative way; not moving to a new technology may result in competitive disadvantage, higher productivity costs and poor performance.

Investment protection - The current network infrastructure is often salvaged due to the large investment in cabling, network equipment, hosts and servers. However, For most networks investment costs are recovered within three years. Understand the cycle of cost recovery at your corporation. Apply this understanding to the design as a corporate advantage in the design proposal.

Keep in mind that the objective of any network design is the delicate balance of meeting business and application requirements while minimizing the cost to meet the objective.

    1. Network Devices and Capabilities

      2. The phenomenal growth of internetworks has predicated the move from bridges to routers and now switches. There are four basic devices used in building an internetwork. Understanding the functions of each is important in determining the network design. These four devices are: Hubs, bridges, routers and switches.

      Hubs are often called concentrators and made possible centralized LAN topologies. All the LAN devices are connected to the hub. The hub essentially regenerates the signal received form one port to another acting as a repeater. These devices operate at the physical layer (Layer 1) of the OSI Reference Model.

      Bridges connect autonomous LAN segments together as a single network and operate at the data link layer (Layer 2) of the OSI Reference Model. These devices use the Media Access Control (MAC) address of the end station for making a decision forwarding the packet. Bridges are protocol independent.

      Routers performing a routing function operate at the network layer (Layer 3) of the OSI Reference Model. These devices connect different networks and separate broadcast domains. Routers are protocol dependent.

      Switches were first advanced multiport bridges with the ability to separate collision domains. Layer 2 switches enhancing performance and functionality through virtual LANs have replaced hubs. The second incarnation of switches, enable them to perform Layer 3 routing decisions thereby performing the function of a router.

      1. Bridging and Routing

        2. Bridging for this discussion is concerned with transparent bridging. This is opposed to Source-Route Bridging (SRB) which is closer to routing than bridging. Bridging occurs at the MAC sublayer of IEEE 802.3/802.5 standard applied to the data link layer of the OSI Reference Model. Routing takes place at the Network layer of the OSI Reference Model. Bridging views the network as a single logical network with one hop to reach the destination. Routing enables multiple hops to and between multiple networks. This leads to four distinct differences between the routing and bridging:

        Data-link packet header does not contain the same information fields as network layer packets.

        Bridges do not use handshaking protocols to establish connections. Network layer devices utilize handshaking protocols.

        Bridges do not reorder packets from the same source while network layer protocols expect reordering due to fragmentation.

        Bridges use MAC addresses for end node identification. Network layer devices such as routers, use a network layer address associated with the wire connecting to which the device is attached.

        While there are these differences between bridging and routing there are times where bridging may be required or preferred over routing and vice-a-versa.

        Advantageous of bridging over routing:

        Transparent bridges are self-learning therefore require minimal, if any, configuration. Routing requires definitions for each interface for the assignment of a network address. These network addresses must be unique with in the network.

        Bridging has less overhead for handling packets than does routing.

        Bridging is protocol independent while routing is protocol dependent.

        Bridging will forward all LAN protocols. Routing only uses network layer information and therefore can only route packets.

        In contrast routing has the following advantageous over bridging:

        Routing allows the best path to be chosen between source and destination. Bridging is limited to a specific path.

        Routing is a result of keeping updated complete network topology information in routing tables on every routing node. Bridging maintains a table of devices found off its interfaces. This causes bridges to learn the network slower than routing thereby enabling routing to provide a higher level of service.

        Routing uses network layer addressing which enables a routing device to group the addresses into areas or domains creating a hierarchical address structure. This leads to an unlimited amount of supported end nodes. Bridging devices maintain data link layer MAC addresses, therefore they can not be grouped, and hence results in a limited number of supported end nodes.

        Routing devices will block broadcast storms from being propagated to all interfaces. Bridging spans the physical LAN segment to multiple segments and therefore forward a broadcast to all attached LAN segments.

        Routing devices will fragment large packets to the smallest packet size for the selected route and then reassemble the packet to the original size for delivery to the end device. Bridges drop packets that are too large to send on the LAN segment without notification to the sending device.

        Routing devices will notify transmitting end stations to slow down (congestion feedback) the transmission of data when the network itself becomes congested. Bridging devices do not possess that capability.

        The general rule of thumb in deciding to route or bridge is to bridge only when needed. Route when ever possible.

      2. Switching

        3. The process of witching is the movement of packets from the receiving interface to a destination interface. Layer 2 switching uses the MAC address found with in the frame. Layer 3 switching uses the network address found within the frame.

        Layer 2 switching is essentially transparent bridging. A table is kept within the switching device for mapping the MAC address to the associated interface. The table is built by examining the source MAC address of each frame as it enters the interface. The switching function occurs when the destination MAC address is examined and compared against the switching table. If a match is found the frame is sent out the corresponding interface. A frame that contains a destination MAC address not found in the switching table is broadcast out all interfaces on the switching device. The returned frame will allow the switching device to learn the interface and therefore place the MAC address in the switching table. MAC addresses are predetermined by the manufacturers of the network interface cards (NICs). These cards have unique manufacturer codes assigned by the IEEE with a unique identifier assigned by the manufacturer. This method virtually insures unique MAC addresses. These manufacturer addresses are often referred to as burned-in-addresses (BIA) or Universally Administered Addresses (UAA). Some vendors however, allow the UAA to be overridden with a Locally Administered Address (LAA). Layer 2 switched networks are inherently considered a flat network.

        In contrast, Layer 3 switching is essentially the function of a router. Layer 3 switching devices build a table similar to the Layer 2 switching table. Except in the case of the Layer 3 switching table the entries are mapping network-layer addresses to interfaces. Since the network-layer addresses are based on, assigning a logical connection to the physical network a hierarchical topology is created with Layer 3 switching. As packets enter an interface on a Layer 3 switch, the source network-layer address is stored in a table that cross-references the network-layer address with the interface. Layer 3 switches carry with them the function of separating broadcast domains and network topology tables for determining optimal paths.

        Combining Layer 2 and Layer 3 switching, as shown in Figure 3.5, within a single device reduces the burden on a router to route the packet from one location to another. Switching therefore increases throughput due to the decisions being done in silicon, reduces CPU overhead on the router, and eliminates hops between the source and destination device.(newidb2-2)

      3. Backbone Considerations

The network backbone is the core of the three layer hierarchical model. Many factors affect the performance of the backbone. These factors are:

  • Path optimization
  • Traffic prioritization
  • Load balancing
  • Alternate paths
  • Switched access
  • Encapsulation (Tunneling)

Path optimization is generally a function of a router that occurs using the routing table created by the network layer protocols. Cisco routers support all of the widely implemented IP routing protocols. These include: Open Shortest Path First (OSPF), RIP, IGRP, EIGRP, Border Gateway Protocol (BGP), Exterior Gateway Protocol (EGP), and HELLO. Each of these routing protocols calculates the optimal path from the information provided within the routing tables. The calculation is based on metrics such as, bandwidth, delay, load, and hops. When changes occur in the network, the routing tables are updated throughout all the routers within the network. The process of all the routers updating their tables and recalculating the optimal paths is called convergence. With each new generation of IP routing protocols, the convergence time is reduced. Currently the IP routing calls with the smallest convergence times are Cisco proprietary routing protocols IGRP and EIGRP.

Traffic prioritization is a form of policy-based routing that prioritizes the network traffic. This allows time sensitive and mission critical traffic to take precedence over throughput-sensitive type traffic. Cisco routers employ three types of traffic prioritization. These are priority queuing, custom queuing and weighted-fair queuing.

Priority queuing is the simplest form of traffic prioritization. It is designed primary for low speed links. The traffic under priority queuing is classified based on criteria among which are protocol and subprotocol types. The criteria profile is then assigned to a one of four output queuing. These queues are high, medium, normal and low. In IP based networks, the IP type-of-service (TOS) feature and Cisco IOS software ability to prioritize IBM logical unit traffic, enable priority queuing for intraprotocol prioritization.

Custom queuing answers a fairness problem that arises with priority queuing. With priority queuing, low priority queues may receive minimal service, if any service. Custom queuing takes the addresses this problem by reserving bandwidth for a particular type of traffic. Cisco custom queuing therefore allows the prioritization of multiprotocol traffic over a single link. For example, the greater the reserved bandwidth for a particular protocol, the more service received. This provides a minimal level of service to all over a shared media. The exception to this is under utilization of the reserved bandwidth. If traffic is not consuming the reserved bandwidth percentage then the remaining percentage of reserved bandwidth will be shared by the other protocols. Custom queuing may use up to 16 queues. The queues are serviced sequentially until the configured byte count has been sent or the queue is empty.

Weighted fair queuing uses an algorithm similar to time-division multiplexing. Each session over an interface is placed into a queue and allocated a slice of time for transmitting over the shared media. The process occurs in a round robin fashion. Allowing each session to default to the same weighting parameters ensure that each session will receive a fair share of the bandwidth. This use of weighting protects time-sensitive traffic by ensuring available bandwidth and therefore consistent response times during heavy traffic loads. The weighted fair algorithm identifies the data streams over an interface dynamically. Because the algorithm is based on separating the data streams into logical queues, it cannot discern the requirements of different conversations that may occur over the session. This is an important point when considering queuing methods for protecting IBM SNA traffic. Weighted fair queuing becomes a disadvantage for SNA traffic when the SNA traffic is encapsulated in DLSw+ or RSRB.

The differences between the three queuing methods are dependent on the needs of the network. However, for administrative point of view weighted fair queuing is far easier due to it being a dynamically built queue versus priority and custom queuing which both required the definitions of access lists, pre-allocated bandwidth and predefined priorities.

Load balancing for IP traffic occurs with two to four paths to the destination network. It is not necessary for these paths to be of equal cost. The load balancing of IP traffic may occur on a per-packet basis and or a per-destination basis. Bridged traffic over multiple serial links becomes balanced by employing a Cisco IOS software feature called circuit groups. This feature logically groups the multiple links as a single link.

Redundancy is a major design criterion for mission critical processes. The use of alternate paths not only requires alternate links but requires terminating these links in different routers. Alternate paths are only valuable when single point of failure is avoided.

Recovery of dedicated leased connections is mandatory for ensuring availability and service. This function is often termed switch access or switched connection however, it does not relate to the Layer 2 or Layer 3 switching function. Switched access calls for the instantaneous recovery of WAN connectivity due to an outage on the dedicated leased line. It is also used to supplement bandwidth requirements using a Cisco IOS software feature called bandwidth-on-demand (BOD) which uses Dial-on-demand routing (DDR). Using DDR along with the dedicated leased WAN connection, a remote location can send large mounts of traffic in a smaller time frame.

Encapsulation techniques are used for transporting non-routable protocols. IBM's SDLC or SNA is a non-routable protocol. They are also used when the design calls for a single protocol backbone. These techniques are also referred to as tunneling.

      1. Distributed Services

Within the router network, services may be distributed for maximizing bandwidth utilization, routing domains and policy networking. The Cisco IOS software supports these distributed services through:

  • Effective backbone bandwidth management
  • Area and service filtering
  • Policy-based distribution
  • Gateway services
  • Route redistribution
  • Media translation

Preserving valuable backbone bandwidth is accomplished using the following features of Cisco IOS software:

  • Adjusting priority output queue lengths so overflows are minimized.
  • Adjust routing metrics such as bandwidth and delay to facilitate control over path selection.
  • Terminate local polling, acknowledgement and discovery frames at the router using proxy services to minimize high volume small-packet traffic over the WAN.

Traffic filtering provides policy-based access control into the backbone form the distribution layer. The access control is based on area or service. Typically, we see the use of service access controls as a means for limiting an application service to a particular segment on the router. Traffic filtering is based on Cisco IOS software access control lists. These access control lists can affect inbound and outbound traffic of a specific interface or interfaces. On both inbound and outbound the traffic may be permitted or denied.

Policy-based networking is a set of rules that determine the end-to-end distribution of traffic to the backbone. Policies may be defined to affect a specific department, protocol, or corporate policy for bandwidth management. The CiscoAssure initiative is a policy-based direction that enables the various network equipment to work together to ensure end-to-end policies.

Gateway functions of the router enable different versions of the same networking protocol to internetwork. An example of this is connecting a DECnet Phase V network with a DECnet Phase IV network. These DECnet versions have implemented different addressing schemes. Cisco IOS within the router performs as an address translation gateway (ATG) for transporting the traffic between the two networks. Another example is AppleTalk translational routing between different versions of AppleTalk.

Route Redistribution enables multiple IP routing protocols to interoperate through the redistribution of routing tables between the two IP routing protocols within the same router.

There are times in corporate networks that communications between different media is a requirement. This is seen more and more with the expansion of networks and newer technologies. For the most part media translation occurs between Ethernet frames and token-ring frames. The translation is not a one for one since an Ethernet frame does not use many of the fields used in a token-ring frame. An additional translation that is observed is that form IBM SDLC to Logical Link Control 2 (LLC2) frames. This enables serial attached IBM SDLC connections to access LAN attached devices.

      1. Local Services

At the local access layer of the three layer model features provided by the Cisco IOS within the router, provide added management and control over access to the distribution layer. These features are:

  • Value-added Network Addressing
  • Network Segmentation
  • Broadcast and Multicast Capabilities
  • Naming, Proxy, and Local Cache Capabilities
  • Media Access Security
  • Router Discovery

The discovery of servers and other services may sometimes cause broadcasts within the local area network. A feature on Cisco IOS software directs these requests to specific network-layer addresses. This feature is called helper addressing. Using this feature limits the broadcast to only segments of the helper addresses defined for that service. This is best used when protocols such as Novell IPX or DHCP typically search the entire network for a server using broadcast messages. Helper addresses thereby preserve bandwidth on segments that do not connect the server requested.

Network congestion is typically a result of a poorly designed network. Congestion is manageable by segmenting networks into smaller more manageable pieces. Using multiple IP subnets, DECnet areas and AppleTalk zones further segments the network so that traffic belonging to the segment remains on the segments. Virtual LANs further enhance this concept by spanning the segmentation between network equipment.

While routers control data link (MAC address) broadcasts they allow network layer (Layer 3) broadcasts. Layer 3 broadcasts are often used for locating servers, and services required by the host. The advent of video broadcasts has proliferated the use of multicast packets over a network. Cisco IOS does its best in reducing broadcast packets over IP networks through directed broadcasts to specific networks rather than the entire network. In addition, the Cisco IOS will employ a spanning-tree technique when flooded broadcasts are recognized minimizing excessive traffic but enabling the delivery of the broadcast to all networks. IP multicast traffic moves form a single source to multiple destinations. IP multicast is supported by a router running Cisco IOS with the Internet Group Management protocol (IGMP) implemented. Using IGMP the router can serve as a multicast distribution point delivering packets to only segments that are members of the multicast group and ensuring loop-free paths eliminating duplicate multicast packets.

The Cisco IOS software contains many features for further reducing bandwidth utilization using naming, proxy and local cache functions. The function drastically reduces discovery, polling and searching characteristics of many of the popular protocols from the backbone. The following is a list of the features available with Cisco IOS that limits these types of traffic from the backbone:

Name services - NetBIOS, DNS, and AppleTalk Name Binding Protocol

Proxy services - NetBIOS, SNA XID/Test, polling, IP ARP, Novell ARP, AppleTalk NBP

Local Caching - SRB RIF, IP ARP, DECnet, Novell IPX

    1. Selecting Routing Protocol

Routing protocols are the transport of IP based networks. Examples of routing protocols are:

Routing Information Protocol (RIP)

Routing Information Protocol 2 (RIP2)

Interior Gateway Routing Protocol (IGRP)

Enhanced Interior Gateway Routing Protocol (EIGRP)

Open Shortest Path First (OSPF)

Intermediate System - Intermediate System (IS-IS)

In selecting a routing protocol for the network, the characteristics of the application protocols and services must be taken into consideration. Network designs enabling a single routing protocol are best for network performance, maintenance and troubleshooting. There are six characteristics of a network to consider when selecting a routing protocol. These are:

  • Network Topology
  • Addressing and Route Summarization
  • Route Selection
  • Convergence
  • Network Scalability
  • Security
      1. Network Topology

        2. Routing protocols view the network topology in two ways. These are flat or hierarchical. The physical network topology is the connections of all the routers within the network. Flat routing topologies use network addressing to segregate the physical network into smaller interconnected flat networks. Examples of routing protocols that use a non-hierarchical flat logical topology are RIP, RIP2, IGRP and EIGRP.

        OSPF and IS-IS routing networks are hierarchical in design. As shown in Figure 3.6, hierarchical routing networks assign routers to a routing area or domain. The common area is considered the top of the hierarchy off which the other routing areas communicate through. Hierarchy routing topologies assign routers to areas. These areas are the routing network addresses used for delivering data from one subnet to another. The areas are a logical grouping of contiguous networks and hosts. Each router maintains a topology map of its own area but not of the whole network.

      2. Addressing and Route Summarization

        3. Some of the IP routing protocols have the ability to automatically summarize the routing information. Using summarization, the route table updates that flow between routers is greatly reduced thereby saving bandwidth, router memory and router CPU utilization. As shown in 3.7 a network of 1000 subnets must have a 1000 routes. Each of the routers within the network must therefore maintain a 1000 route table. If we assume that the network is using a Class B addressing scheme with a subnet mask of 255.255.255.0, summarization reduces the number of routes within each router to 253. There are three routes in each of the routers describing the path to the other subnets on the other routers and 250 routes describing the subnets connected to each router.

      3. Route Selection

        4. In networks where high availability and redundancy are a requirement, the route selection algorithm of the routing protocol becomes an important factor in maintaining acceptable availability. Each of the routing protocols uses some type of metric to determine the best path between the source and the destination of a packet. The available metrics are combined to produce a "weight" or "cost" on the efficiency of the route.

        Depending on the routing protocol in use multiple paths of equal cost may provide load balancing between the source and destination thereby spreading the load across the network. some protocols like EIGRP can use unequal cost paths to load balance. This ability to load balance further improves the management of network bandwidth.

        Load balancing over multiple paths is performed on a per-packet or per-destination basis. Per--packet distributes the load across the possible paths in proportion to the routing metrics of the paths. For equal cost paths this results in a round-robin distribution. There is however, the potential of a per-packet load balancing technique that the packets are received out of order. Per-destination load balancing distributes the packets based on the destination over the multiple paths to the destination. For instance, as shown in Figure 3.8, packets destined for subnets attached to router R2 from router R1 use a round-robin technique based on the destination. Packets destined for subnet 1 flow over link 20, while packets destined for subnet 2 flow over link 21 versus the per packet basis of alternating the packets for subnet 1 and subnet 2 over the two links.

      4. The concept of convergence

        5. Convergence is the time it takes a router to recognize a network topology change, calculate the change within its own table and then distribute the table to adjacent routers. The adjacent routers then perform the same functions. The total time it takes for the routers to begin using the new calculated route is called the convergence time. The time for convergence is critical for time-sensitive traffic. If a router takes too long to detect, recalculate and then distribute the new route, the time-sensitive traffic may experience poor performance or the end nodes of the connection may then drop.

        In general, the concern with convergence is no the addition of new links or subnet s in the network. The concern is the failure of connectivity to the network. Routers recognize physical connection losses rapidly. The issue for long convergence time is the failure to detect poor connections within a reasonable amount of time. Poor connections such as line errors, high collision rates and others, require some customization on the router for detecting these types of problems faster.

      5. Network Scalability

        6. The ability of routing protocols to scale to a growing network is not so much a weakness of the protocol but the critical resources of the router hardware. Routers require memory, CPU and adequate bandwidth to properly service the network.

        Routing tables and network topology are stored in router memory. Using a route summarization technique as described earlier reduces the memory requirement. In addition, routing protocols that use areas or domains in a hierarchical topology requires the network design to use small areas rather than large areas to help in reducing the memory consumption.

        Calculation of the routes is a CPU intensive process. Through route summarization and the use of link-state routing protocols the CPU utilization is greatly reduced since the number of routes needing re-computing is reduced.

        Bandwidth on the connections to each router becomes a factor in not only scaling the network but in convergence time. Routing protocols learn of neighbor routers for the purpose of receiving and sending routing table updates. The type of routing protocol in use will determine its affect on the bandwidth.

        Distance-vector routing protocols such as RIP and IGRP send their routing tables at regular intervals. The distance-vector routing protocol waits for the time interval before sending its update even when a network change has occurred. In stable networks this type of updating mechanism wastes bandwidth, however, protects the bandwidth from an excessive routing update load when a change has occurred. However, due to the periodic update mechanism, distance vector protocols tend to have a slow convergence time.

        Link-state IP routing protocols such as OSPF and IS-IS address bandwidth wastefulness of distance-vector routing protocols and slow time to converge. However, due to the complexity of providing this enhancement link-state protocols are CPU intensive, require higher memory utilization and bandwidth during convergence. During network stability, link-state protocols use minimal network bandwidth. After start-up and initial convergence, updates are sent to neighbors only when the network topology changes. During a recognized topology change, the router will flood its neighbors with the updates. This may cause excessive load on the bandwidth, CPU and memory of each router. However, convergence time is lower than that of distance-vector protocol.

        Cisco's proprietary routing protocol EIGRP is an advanced version of distance-vector protocols with properties of link-state protocols. From distance-vector protocols, EIGRP has taken many of the metrics for route calculation. The advantageous of link-state protocols are used for sending routing updates only when changes occur. While EIGRP preserves CPU, memory and bandwidth during a stable network environment, it does have high CPU, memory and bandwidth requirements during convergence.

        The convergence ability of the routing protocols and their affect on CPU, memory and bandwidth has resulted in guidelines form Cisco on the number of neighbors that can be effectively supported. Table 3.x lists the suggested neighbors for each protocol.

        Routing Protocol | Neighbors per Router
Distance vector (RIP, IGRP) | 50
Link state (OSPF, IS-IS) | 30
Advanced distance vector (EIGRP) | 30
      6. Security

Routing protocols can be used to provide a minimal level of security. Some of the security functions available on routing protocols are:

  • Filtering route advertisements
  • Authentication

Using filtering, routing protocols can prohibit the advertisements of routes to neighbors thereby protecting certain parts of the network. Some of the routing protocols authenticate their neighbor prior to engaging in routing table updates. Though this is protocol specific and generally a weak form of security, it does protect unwanted connectivity from other networks using the same routing protocol.

Backward Forward


Sackett

Chapter Four

IP Routing Protocol Design

Routing is the process of moving packets from one network to another. The routing decision takes place at the source network device. That is a router. The decision is made based on metrics used for a particular routing protocol. Routing protocols may use some or all of the following metrics in determining the best route to a destination network:

  • Path length
  • Reliability
  • Delay
  • Bandwidth
  • Load
  • Communication cost

Path length is measure in either a cost or a hop count. In link-state routing protocols, the cost is the sum of the costs associated with each link in the path. Distance-vector routing protocols assign a hop count to the path length, which measures the number of routers a packet traverses between the source and destination.

Reliability is typically the bit-error rate of a link connecting this router to a source or destination resource. For most of the routing protocols, the reliability of a link is assigned by the network engineer. Since it is arbitrary it can be used to influence and create paths that are favorable over other paths.

The delay metric is an overall measurement of the time it takes for a packet to move through all the internetworked devices, links and queues of each router. In addition, network congestion and the overall distance traveled between the source and destination are taken into consideration in evaluating the delay metric value. Because the delay value takes into account many different variables, it is an influential metric on the optimal path calculation.

Using bandwidth as a metric in optimal path calculations may be misleading. Though bandwidth of a bandwidth of 1.54 Mbps is greater than 56 Kbps, it may not be optimal due to the current utilization of the link or the load on the device on the receiving end of the link.

The load is a metric that assigns a value to a network resource based on the resources overall utilization. This value is a composite of CPU utilization, packets processed per second, and disassembly/reassembly of packets among other things. The monitoring of the device resources itself is an intensive process.

In some cases, communication lines are charged based on usage versus a flat monthly fee for public networks. For example, ISDN lines are charged based on usage time and potential the amount of data transmitted during that time. In these instances, communication cost becomes an important factor in determining the optimal route.

In designing a routing protocol based network the routing algorithm should have the following characteristics built into the design:

Optimality - using some or all of the metrics available for a routing protocol in order to calculate the optimal route. Different routing protocols may apply one metric as having a higher weight to the optimal route calculation than another has. An understanding of this behavior is important in choosing the routing protocol.

Simplicity - While routing protocols themselves may be complicated their implementation and operational support must be simplistic. Router overhead and efficient use of router resources is important in maintaining a stable and reliable network.

Robustness - Choose a routing algorithm that meets the requirements of the network design. In some cases, for instance small networks, a simplistic distance-vector routing protocol is sufficient. In large networks that require a hierarchical design requires the ability of the routing protocol to scale to the size of the network without itself becoming a hindrance on the network.

Rapid Convergence - The convergence time to recalculate and then use a new optimal path between a source and destination resource is paramount in meeting availability and service level requirements of a network.

Flexibility - The algorithms employed by the selected routing protocol must be flexible and adapt to the changing dynamics of network resources and the network as a whole.

    1. RIP, RIP2 and IGRP Network Design

      2. RIP, RIP2 and IGRP are distance-vector based routing protocols. Distance-based vector routing protocols base the optimal route on the number of hops (i.e., devices) a packet must pass through to reach a destination. Routing Information Protocol (RIP) was the first routing protocol algorithm for distributing, calculating and managing available routes within a network. Interior Gateway Routing Protocol (IGRP) is a Cisco proprietary routing protocol algorithm using enhanced optimal route calculation. IGRP calculates optimal routes based on bandwidth, delay, reliability and load. RIP2 is the second generation of RIP. RIP2 supports the Internet Protocol Version 6 specification for 128-bit addressing, variable-length subnet masks (VLSM) and route summarization.

      1. Topology

        2. Distance-vector routing protocols use a flat network topology as shown in Figure 4.1. Since these protocols are distance-vector based routing algorithms it is beneficial to minimize the number of hops between two destinations. This requires careful planning of the core, distribution and access topology layers in planning the hierarchical service model. For most cases, when deploying distance-vector based routing protocols the service functions of the core, distribution and access layers typically co-mingle within a single router.

      2. Addressing and Summarization

        3. In RIP and IGRP networks the IP 16-bit addressing scheme of IP version 4 is supported. RIP2 supports both the IP version 4 16-bit and IP version 6 128-bit addressing scheme. Additionally, RIP and IGRP support on fixed subnet masks for a network. Every subnet address used in the RIP or IGRP network must use the same subnet masking. RIP2 using VLSM and the 128-bit addressing scheme allows for varied subnet masks of the router interface. This is because the RIP2 routing packet includes the subnet mask of the source and destination IP address. Because RIP2 supports VLSM the routing tables use are summarized. This reduces the memory requirements on the router by keeping the routing table to a minimum. RIP and IGRP do not summarize since every entry represents a unique network or subnet.

      3. Route Selection and Convergence

        4. Both RIP and RIP2 base the optimal route selection on the number of hops. IGPR enhances this by incorporating bandwidth, delay, reliability and load. Figure 4.2 illustrates the route selection difference between RIP, RIP2 and IGRP. RIP and IGRP use the first route within their routing tables as the optimal route for a destination network or subnet. RIP does not load balance so multiple entries within the table for a destination network only become available if the optimal route is recalculated as less favorable. IGRP will load balance packets over equal-cost paths to s destination network or subnet. This load balancing occurs in a round-robin fashion. Both RIP and IGRP build their tables and then transmit the entire routing table to adjacent routers. Each router in turn recalculates its table based on the information received from the sending router. Once this is completed the router forwards its new table to adjacent routers. Both RIP and IGRP periodically send their routing tables to adjacent routers. RIP defaults to a 30 second interval for sending the routing table to adjacent routers. IGRP defaults to a 90 seconds interval for sending the routing table to adjacent routers. Both RIP and IGRP will recalculate routing entries once recognizing a link outage or timeout to an adjacent router. However, the recalculated routing table is not forwarded to adjacent routers until the update interval has been reached. The periodic updating of neighbor routers for topology changes causes excessive convergence time for the network to learn new optimal routes.

        RIP2 however, addresses the periodic update problem by sending only the updated route entry at the time of the recalculation. While this sounds much like a link-state protocol update RIP2 still sends the entire table on a periodic basis. The ability of RIP2 to send an update at the time it is recalculated reduces the convergence time. RIP2 sends the entire routing table on a periodic basis just as RIP and IGRP. However, the table is smaller due to the use of VLSM and route summarization. RIP2 will load balance packets to a destination network or subnet over equal-cost paths.

      4. Network Scalability

      The time for convergence of RIP, IGRP and RIP2 networks is the single inhibitor to scaling these protocols to large networks. Convergence is not just a time factor but also a CPU and memory issue on each router. These protocols recalculate the entire table during convergence versus just the affected route. Therefore, convergence becomes a CPU intensive process thereby reducing the ability of a router to provide service levels during convergence. Since these protocols send the entire table in a periodic timeframe they consume bandwidth causing bandwidth constraints in an ongoing basis.

    2. EIGRP Network Design

      3. Enhanced Interior Gateway Protocol (EIGRP) is a proprietary routing protocol of Cisco Systems. EIGRP merges the best of distance-vector protocol characteristic with advantages of link-state protocol characteristics. In addition, EIGRP uses Diffusing Update Algorithm (DUAL) for fast convergence and further reduction of possible routing loops with in the network. An advantage to using EIGRP over other routing protocols is its ability to support not only IP but also Novell NetWare IPX, and AppleTalk, thus simplifying network design and troubleshooting.

      1. Topology

        2. EIGRP uses a non-hierarchical flat networking topology. EIGRP automatically summarizes subnet router for networks directly connected to the router using the network number as the boundary. It has been found that the automatic summarization is sufficient for most IP networks.

      2. Addressing and Summarization

        3. EIGRP supports variable-length subnet masking (VLSM). Defining an address space for use by an EIGRP is a primary step in developing the routing architecture. EIGRP support for VLSM is made possible by including the subnet mask assigned to the router interface in the EIGRP routing messages. VLSM is essentially the subnetting of a subnet (sub-subnet). Using an appropriate addressing scheme, the size of the routing tables and convergence time can drastically be reduced through route summarization. EIGRP automatically summarizes the routes at network number boundaries. Figure 4.3 diagrams the use of route summarization. However, the network engineer can configure route summarization at the interface level using any bit-boundary of the address to further summarize the routing entries. The metric used in route summarization is the best route found for the routes used to determine the summarized route.

      3. Route Selection

        4. EIGRP uses the same metrics as IGRP. These values are bandwidth, delay, reliability and load. The metric placed on a route using EIGRP defaults to the using the minimum bandwidth of each hop plus a media-specific delay for each hop. The value for the metrics used in EIGRP are determined s follows:

        Bandwidth - EIGRP uses the default value for each interface to the value specified by the bandwidth interface command.

        Delay - The inherent delay associated with an interface. The delay metric can also be defined on an interface using the delay interface command.

        Reliability - A dynamically computed value averaged over five seconds. The reliability metric changes with each new weighted average.

        Load - A dynamically computed weighted average over five seconds. The load metric changes with each new weighted average.

      4. Convergence

        5. EIGRP employs Diffusing Update Algorithm (DUAL) for calculating route computations. DUAL uses distance vector algorithms to determine loop-free efficient paths selecting the best path for insertion into the routing table. DUAL however, also determines the second best optimal route for each entry termed a feasible successor. The feasible successor entry is used when the primary route becomes unavailable. Figure 4.4 illustrates the use of the feasible successor. Using this methodology of successor routes avoids a recalculation and therefore minimizes convergence time. Along with primary routes, EIGRP distributes the feasible successor entries to the neighboring routers.

      5. Scalability

        6. Scalability is a function of memory, CPU and bandwidth efficiencies. EIGRP is architected in optimizing these resources. Through route summarization, the routes advertised by neighbors are stored with minimal memory required. This enables an EIGRP network to expand without routing issues. Since EIGRP uses DUAL only routes that are affected by a change are recomputed and since EIGRP is based on using the same metrics as IGRP the computation CPU requirements are minimal. Because EIGPR only sends updates due to topology changes bandwidth is preserved. Steady-state bandwidth utilization of EIGRP is minimal due to the use of EIGRP's HELLO protocol for maintaining adjacencies between neighbors.

      6. Security

      Since EIGRP is a Cisco IOS proprietary routing protocol it is available only on Cisco routers. Additionally, route filters and authentication can be specified to further limit accidental or malicious routing disruptions from unknown routers connecting to the network.

    3. OSPF Network Design

      4. Open Shortest Path First (OSPF) is a standards based link-state routing protocol defined by the Internet Engineering Task Force (IETF) OSPF workgroup and published in Request for Comment (RFC) 1247. OSPF is based on autonomous system (AS). OSPF defines an AS as a group of routers exchanging routing information using link-state protocol. OSPF is based on using a hierarchical networking topology. Defining the hierarchy requires planning to define boundaries that denote an OSPF area and address assignment.

      1. Topology

        2. OSPF defines its hierarchy based on areas. Figure 4.5 illustrates the OSPF hierarchy and various areas used to build and connect the OSPF network. An area is a common grouping of routers and their interfaces. OSPF has one single common area through which all other areas communicate. Due to the use of the OSPF algorithm and its demand on router resources it is necessary to keep the number of routers at 50 or below per OSPF area. Areas with unreliable links will therefore require many recalculations and are best suited to operate within small areas.

        The OSPF algorithm using a flooding technique for notifying neighbors of topology changes. The greater number of neighbors the more CPU intensive the topology change since the new route must be recalculated and forwarded to all attached neighbors. Cisco studies have resulted in a recommendation of no more than 60 neighbors per OSPF router.

        The OSPF link-state algorithm calculates a change for each specified area defined on the router. Area routers are usually also area border routers (ABR). That is they maintain and support OSPF routing tables for two OSPF areas. In general, there is a minimum of two areas for an ABR: The backbone area and one non-backbone area. The recommendation for OSPF is to limit the number of supported areas in a router to three. This will minimizes resources utilization for the calculation and distribution of link-state updates.

        OSPF uses a designated router as the keeper of all the OSPF routes within a local-area network. This reduces routing updates over a LAN thereby preserving LAN media bandwidth. OSPF routers attached to the same LAN as the designated router request a route only if their own table does not have an entry for the destination resource. A backup designated router is also used for availability and redundancy. The recommendation is to have a designated and backup designated router supporting only one LAN. In addition, the designated and backup designated router should be the least CPU intensive router on the LAN.

        The OSPF backbone must be designed for stability and redundancy. A link failure that partitions the backbone will result in application outages, which leads to poor availability. The size of the backbone should follow that recommended areas to be no more than 50 routers.

        Routers within the OSPF backbone must be contiguous. This follows the concept of the hierarchy and maintains the traffic for backbone updates within the backbone area routers. However, OSPF offers the use of a virtual link for connecting two non-contiguous routers through a non-native area router. Using a virtual link, a partitioned backbone can be circumvented until the link failure causing the outage is corrected. Finally, reserve the media used for the OSPF backbone for routers to avoid instability and unrelated routing protocol traffic.

        As with backbone areas each OSPF area must be contiguous. Not only contiguous in design but also contiguous in the network address space. Using a contiguous address space makes route summarization possible. The routers of an area connecting the area to the OSPF backbone area are termed area border routers (ABR). For availability, it is deemed appropriate to have more than one ABR connecting the area to the backbone area.

        Designing large-scale OSPF networks requires a review of the physical connectivity map between routers and the density of resources. Designing the network into geographic areas may be beneficial for simplifying implementation and operations but may not be beneficial for availability or performance. In general, smaller OSPF areas generate better performance and higher levels of availability than large OSPF areas.

      2. Addressing and Summarization

Maximizing the address space in OSPF networks assists in reducing resource utilization and maximizes route summarization. A hierarchical addressing scheme is the most effective means of designing an OSPF network. OSPF supports VLSM that lends itself to a hierarchical network address space specification. Using VLSM, route summarization is maximized at the backbone and ABR routers. Guidelines in defining an OSPF network for optimized route summarization are:

  • Define the network address scheme in subnet ranges for use in each contiguous area.
  • Use VLSM addressing to maximize address space.
  • Define the network address space for future growth to allow the splitting of an area.
  • Design the network with the intention of adding new OSPF routers in the future.

Route summarization increases the stability of an OSPF network. Using route summarization keeps route changes within an area. Route summarization must be explicitly specified when working with OSPF networks on Cisco routers. The specification of router summarization requires the following information:

  • Determine route information needed by the backbone about each area
  • Determine route information needed by an area for the backbone and other areas

OSPF route summarization occurs in area border routers. Using VLSM, bit-boundary summarization is possible on network or subnet addresses within the area. Since, OSPF route summarization is explicit the network design must incorporate summarization definitions for each OSPF area border router.

OSPF areas offer four types of routing information. These are:

Default - A default route of all packets for which the destination IP network or subnet is not explicitly found in the routing tables.

Intra-area routes - These are routes for network or subnets within a given area.

Interarea routes - This information provides areas with explicit network or subnet routers for networks or subnets within the OSPF autonomous system but not within the area.

External routes - These are routes learned from the exchange of routing information between autonomous systems. This results in routes that are external to the OSPF autonomous system.

OSPF route information provides information on three types of OSPF areas. These are non-stub areas, stub areas and stub areas without summaries. Stub areas are OSPF areas that connect only to one other area and therefore are considered a stub off the hierarchy. A non-stub area is an OSPF area that provides connectivity to more than one OSPF area.

Non-stub area characteristics are:

  • Store default routes, static routes, intra-area routes interarea routes and external routes.
  • OSPF interarea connectivity.
  • Uses autonomous system border routers.
  • Virtual links require non-stub areas.
  • Most resource-intensive type of area.

Stub area characteristics are:

  • Build default, intra-area, and interarea routes.
  • Most useful in areas containing one ABR
  • May contain multiple area border routers to same area
  • Virtual links cannot connect through stub areas
  • Cannot use autonomous system border routers.

Stub areas without summaries contain:

  • Default and intra-area routers
  • Recommended for single router connections to the backbone.

Table 4.x lists the OSPF area types against the routing information supported.

 | Routing Information type
Area Type | Default | Intra-area | Interarea | External
Nonstub | Yes | Yes | Yes | Yes
Stub | Yes | Yes | Yes | No
Stub without summaries | Yes | Yes | No | No
      1. Route Selection

        2. OSPF defaults route selection to the bandwidth metric. Under OSPF the bandwidth metric is determined by the type of media being used. The bandwidth metric for a link is the inverse of the bandwidth supported by the media used for the link. The bandwidth metric has been calibrated based on a metric of 1 for FDDI media. Figure 4.6 depicts an OSPF network and the applied bandwidth metric. The total metric for a given route is the sum of all the bandwidth metric values of all the links used for the route. Media that supports bandwidth greater than FDDI 100 Mbps default to the FDDI metric value of 1. In a configuration where media types connecting the router are faster than FDDI a manual cost greater than 1 must be applied to the FDDI link in order to favor the higher speed media type.

        OSPF route summarization uses the metric of the best route found within the summarized routes as a metric value for the summarized entry.

        OSPF external routes are defined as being either a type 1 or type 2 route. The metric for a type 1 external route is the sum of the internal OSPF metric and the external route metric. Type 2 external routes use only the metric of the external route. Type 1 external route metrics are more favorable in providing a truer metric for connecting to the external resource.

        For single ABR OSPF areas, all traffic leaving the area flows through the single ABR. This is done by having the ABR exchange a default route with the other routers of the area. In multiple ABR OSPF areas, the traffic can leave either through the ABR closest to the source of the traffic or the ABR nearer to the destination of the traffic. In this case, the ABRs exchange summarized routes with the other routers of the area.

        High availability network design requires redundant paths and routers. Redundancy is useful when employing equal-cost paths to take advantage of load balancing. Cisco routers will load-balance over a maximum of four equal-cost paths between a source and destination using either per-destination or per-packet load balancing when using OSPF. The default of per-destination is based on connectivity bandwidth at 56 Kbps or greater.

      2. Convergence

        3. Since OSPF is a link-state based routing protocol, it adapts quickly to network topology changes. OSPF detects topology changes based on interface status or the failure to receive a response to an OSPF HELLO packet of an attached neighbor within a given amount of time. OSPF has a default timer of 40 seconds in broadcast networks (i.e., LANs) and two minutes in non-broadcast networks (i.e., WANs).

        The routes are recalculated by the router recognizing the failed link and sends a link-state packet to all the routers within the area. Each router then recalculates all the routes within its routing table.

      3. Scalability

        4. The addressing scheme, number of areas and number of links within the OSPF network all affect the scalability of an OSPF network. Routers use memory for storing all the link states for each area a router belongs. The more areas attached to a router the larger the table. Scaling OSPF therefore depends on the effective use of route summarization and stub areas to reduce memory requirements. The larger the link-state database the more CPU cycles required during recalculation of the shortest path first algorithm. Minimizing the size of a OSPF area and the number of links within the area along with route summarization enables OSPF to scale to large networks. OSPF only sends small HELLO packets and link-state updates when a topology change occurs or at start-up. This is a great benefit for preserving bandwidth utilization as compared to distance-vector routing protocols such as RIP or IGRP.

      4. Security

OPSF can use an authentication field to verify that a router connecting as a neighbor is indeed a router that belongs within the network. OSPF routers by their very nature do not allow the filtering of routes since all OSPF routers must have the same routing information within an area. Using authentication, an OSPF router can verify that it should exchange topology information with a new router that has joined the network. In this way, not only does OSPF provide some protection from unwanted access, it assists in keeping a stable network.

Backward Forward


Sackett

Chapter Five

Frame Relay Network Design

Frame relay is based on a packet-switched data network. The differential of frame relay to previous packet-switched networks like X.25 is that frame relay switches a frame versus a packet. Frame relay has considerable low overhead and its speed through the network is in part to not insuring delivery of data. Frame relay as a WAN network solution grew due to the low cost for acceptable performance as compared to leased-line WAN solutions. An optimal frame relay network design is based on the following:

  • Balancing the cost savings of using a public network with the business performance requirements.
  • A scalable WAN design founded in a manageable environment.
  • Utilizes a hierarchical design.

Main concerns for implementing a frame relay design is the ability of the design to scale to not only topology growth but to traffic growth. Components for creating a scalable frame relay network designs are:

  • The adherence to the three-layer router model of core, distribution and access layers.
  • Overall hierarchical design
  • Implementing various mesh topology design
  • Addressing protocol broadcast issues
  • Addressing performance concerns

Meeting these guidelines results in providing a scalable, high-availability and low cost frame relay network design.

    1. Hierarchical Design of Frame Relay Internetworks

      2. Frame relay design is based on permanent virtual connections (PVCs). A PVC is identified using a Data Connection Link Identifier (DLCI) number. Multiple PVCs are possible over a single physical communication link. Using this ability, a single link can communicate with multiple locations. This function is shown in Figure 5.1 where router R1 using two PVCs communicates with two other routers over the public frame relay network. A PVC can be assigned a bandwidth. The total bandwidth of all defined PVCs can equal the actual bandwidth of the physical communication link. In a sense, frame relay acts as a time-division multiplexer (TDM) over a public network.

      Due to the nature of frame relay services through PVCs, hierarchical designs are more logical than physical in definition. Each PVC may be guaranteed a bandwidth parameters called committed information rate (CIR) and excessive burst limits (Be). The CIR is an agreement with the frame relay provider for a minimum throughput for the PVC. The excessive burst limit is an agreement with the frame relay provider for the available for use by the PVC over and above the PVC bandwidth to the maximum available on the physical link. These two variables greatly influence the cost and therefore the design of the frame relay network.

      1. Scalability

        2. Scalability is achieved in frame relay network design through the implementation of a hierarchy. Using a hierarchy enables incremental growth. The hierarchical approach however, must follow the three layer routing model in order for meeting high-availability, acceptable performance and low-cost requirements. These requirements can be met through careful planning of actual performance requirements at remote locations, degree of high-availability service, and minimizing the complexity of the hierarchy.

      2. Management

        3. Managing a hierarchical network is minimized through the partitioning of the network into smaller elements. By simplifying the network into manageable modules, troubleshooting is eased. The partitioning also provides protection against broadcast storms and routing loops. A hierarchical design inherently provides a flexible network topology allowing the inclusion of other technologies into the network design. This leads to a hybrid approach for the overall network infrastructure. While hybrid network design may enable greater service, it does make network management a bit more complex. Finally, router management in hierarchical frame relay networks is reduced due to fewer network connections based on the hierarchy.

      3. Performance

      Hierarchical network design lends itself to protecting networks form broadcast and multicast traffic issues. Regional hierarchy with smaller areas enables the frame relay network to maintain overall network performance requirements. Limiting the number of routers within an area or layer minimizes the chances of traffic bottlenecks due to broadcast traffic.

    2. Frame Relay Network Topology

The network topology design chosen for implementing frame relay networks is dependent on many variables. Among these are the types of protocols supported and the actual traffic characteristics and patterns generated by applications using the network. It is recommended that an optimal frame relay network design support anywhere form a maximum of 10 to 50 PVCs per physical interface. Consider the following factors in determining the number of PVCs to support:

  • Broadcast intensive protocols constrain the number of PVCs. Segregating the protocols into their own PVC for better management requires more PVCs in multiprotocol networks.
  • Broadcast updates due to routing protocols may consume bandwidth. The number, type and frequency of the routing protocol updates will dictate the number of PVCs required to meet service levels.
  • The available bandwidth of the physical frame relay connection as measured against the amount of broadcast traffic may dictate higher-bandwidth PVCs with higher CIRs and excess burst limits. However, because each PVC has more bandwidth the number of PVCs is reduced.
  • Static routes can either eliminate or reduce the amount of broadcasts thereby enabling more PVCs per physical connection.
  • Large networks tend to create large routing protocol updates. Large updates and frequencies require higher bandwidth thereby reducing the number of available PVCs per physical link.

The topology of a frame relay network is comprised of different design formats. Each format has its advantageous and disadvantageous. The network requirements along with the considerations outlined above on the number of PVCs required in a design need to be addressed in using the various topology layouts.

      1. Star

        2. A frame relay star topology is depicted in Figure 5.2. The configuration is referred to as a star due to the single connection by all remote sites to a central location. Star topologies minimize the number of PVCs and result in a low cost design. However, due to its design bandwidth at the central site becomes an issue since it becomes limited due to the number of remote locations connecting over the physical connection. Likewise, high-availability through alternate paths and rerouting of data from the remote locations is non-existent since there is only one path from the remote location to the rest of the network. An advantage to a star topology is ease of management. However, the disadvantageous of the core or hub router as a single point of failure, performance impact to the backbone due to the single core router connection, and the inability of a star topology to scale make it a poor choice for basing a foundation for the network design.

      2. Fully Meshed

A fully meshed frame relay network provides a very high degree of availability. As shown in Figure 5.4 a fully meshed network uses PVCs connecting all frame relay points on the network. Disadvantageous to using a fully meshed network is the number of PVCs required. A PVC is required for logically connecting to each router on the network. A fully meshed topology requires [n(n-1)]/2 PVCs where n is the number of routers being connected to the frame relay network. For example, a fully meshed network of five routers requires [5(5-1)]/2 which equals 10 PVCs.

Although frame relay networks are non-broadcast multiaccess (NBMA) networks a router sends a broadcast over each active PVC. This replication process leads to excessive CPU and bandwidth requirements for jut routing updates, spanning tree updates and SAP updates.

In small frame relay networks, a fully meshed topology is a reasonable design. The issues that make a fully meshed network for large networks a poor design are:

  • A large number of PVCs
  • CPU and bandwidth overhead due to packet and broadcast replication
  • Management complexity
      1. Partially Meshed

Merging the ease of design and management using a star topology with the high availability feature provided by a fully meshed topology results in a requirements balanced partially meshed topology. Seen in Figure 5.5 a partially meshed topology is two star topologies being supported by the remote locations. Partially meshed topologies are ideal for regional implementation. The advantageous to partially meshed networks are:

  • High-availability
  • Relatively low-cost as compared to fully meshed
  • Minimum number of PVCs required
  • Acceptable performance at a reasonable cost

Data must flow through one of the core routers for communication between locations of a partially meshed topology without a direct PVC.

      1. Fully Meshed Hierarchical

        2. Applying the fully meshed topology to an overall hierarchy for the three layers of the routing layer model results in a design that scales and localizes traffic due to the creation of manageable segments. The modularity of the design enables the network as a whole to scale well. As shown in Figure 5.6 the hierarchy is based on the strategic connections made across the routing layer model.

        Though again this topology provides high redundancy and modularity, it continues to have the packet/broadcast replication problem. The balance of service to cost is also lost due to the extra number of routers, physical links and PVCs required.

      2. Hybrid Meshed Hierarchical

Managing the balance between core backbone performance and maintaining a low-cost network design results in a hybrid hierarchical frame relay network. A hybrid hierarchical network, as depicted in Figure 5.7, uses private leased lines for creating a fully meshed backbone and partially or fully meshed frame relay networks for connection to the regional network.

In Figure 5.7, we see the use of an ATM core backbone feeding a leased line distribution network. The distribution layer then provides network connectivity using a partially meshed topology. This topology high-availability, great bandwidth for the backbone, network segmentation and simplified router configuration management.

    1. Broadcast Traffic Issues

      2. Broadcasts are typically used for routing protocols to update network devices on selecting the best path between two destination on the network. Many routing protocols update their neighbors or peers on a periodic basis. Routers replicate a broadcast on to every active PVC defined on the router for transmission to he partner node at the other end of the PVC. Figure 5.8 illustrates this point.

      In managing the broadcasts of routing protocols, it is important to understand the time requirement for topology changes. In stable networks, the timers that manage the broadcast updates for individual routing protocols may be extended which helps router and bandwidth overhead in supporting the routing protocol updates. Another alternative is to include in the design efficient routing protocols such as EIGRP, for reducing the routing protocol broadcast updates over the frame relay network. Managing the replication of broadcasts and packets is of paramount concern. Fully meshed networks actually increase the overall cost of a network and increase the overall load on the network. Table 5.1 lists the relative traffic levels as they relate to broadcast traffic generated by routing protocols.

      Network Protocol | Routing Protocol | Relative Broadcast Traffic Level
AppleTalk | Routing Table Maintenance Protocol (RTMP) Enhanced Interior Gateway Routing Protocol (EIGRP) | High Low
Novell Internetwork Packet Exchange (IPX) | Routing Information Protocol (RIP) service Advertisement Protocol (SAP) Enhanced Interior Gateway Routing Protocol (EIGRP) | High High Low
Internet Protocol (IP) | Routing Information Protocol (RIP) Interior Gateway Protocol (IGRP) Open Shortest Path First (OSPF) Intermediate System-Intermediate System (IS-IS) Enhanced Interior Gateway Protocol (EIGRP) Border Gateway Protocol (BGP) Exterior Gateway Protocol (EGP) | High High Low Low Low None None
DECnet Phase IV | DECnet Routing | High
DECnet Phase V | IS-IS | Low
International Organization for Standardization (ISO) Connectionless Network Service (CLNS) | IS-IS ISO-IGRP | Low High
Xerox Network Systems (XNS) | RIP | High
Banyan Virtual Integrated Network Service (VINES) | Routing Table Protocol (RTP) Sequenced RTP | High Low
    2. Performance Considerations

There are several factors affecting performance of frame relay networks. We have already discussed the affect of broadcasts on the network. Broadcasts are the primary concern for designing the bandwidth and number of PVCs necessary to designing a viable frame relay network. During the planning stage of developing the frame relay network design the following must be considered:

  • Maximum rate requirements
  • Committed Information Rate
  • Management of multiprotocol traffic
      1. Determining Maximum rate

        2. The frame relay provider uses several metrics to determine the billing of the frame relay connections. Therefore, it is important to fully understand the bandwidth and number of PVCs required to meet business service levels. The metrics used for determining the frame relay network configuration are:

        Committed burst (Bc) - the number of bits committed to accept and transmit at the CIR

        Excess burst (Be) - the number of bits to attempt to transmit after reaching the Bc value

        Committed Information Rate (CIR) - the maximum permitted traffic level for each PVC

        Maximum data rate (MaxR) - calculated value measured in bits per second (Bc + Be)/Bc * CIR

        Determination of the CIR, Bc and Be is predicated on the actual speed of the physical line. The maximum values can not extend past the maximum speed of the link. In addition, the application profiles will influence the metrics based on the type of service, transport mechanisms and usage of each application using the PVCs.

      2. Committed Information Rate (CIR)

        3. The CIR is the guaranteed bandwidth the frame relay service provides for each PVC on the physical link. For example, a CIR of 19.2 Kbps on a 128 Kbps physical link commits the frame relay network to provide 19.2 Kbps throughput for the PVC between source and destination. CIR is the metric most influencing the ability to meet the service levels for the applications. Failure to properly calculate the appropriate CIR level results in poor performance and failure to meet service levels.

        Under estimating the CIR results in discard eligible (DE) frames. The DE bit value is set to on by a frame relay switch when the bandwidth used on the PVC begins to exceed the CIR. Frame relay switches inspect the DE bit value within the frame. If the DE bit is on, the frame may be discarded based on the switches resource constraints, network congestion and available bandwidth.

      3. FECN/BECN Congestion Protocol

        4. Frame relay institutes a congestion protocol to protect network resources from over utilization. This protocol is termed FECN/BECN. Forward Explicit Congestion Notification (FECN) is a frame relay message used to notify a receiving device that there is a congestion problem. Backward Explicit Congestion Notification (BECN) is a frame relay message used to notify a sending device that there is a congestion problem. These messages enable the network devices to throttle the traffic onto the network. Cisco routers support the use of FECN and BECN.

      4. Virtual subinterface and Multiprotocol Management

Support for multiple protocols over frame relay connections requires some thought on traffic management. Cisco IOS enables the use of subinterfaces on physical interfaces. This ability, diagrammed in Figure 5.9, to create virtual interfaces enables a network designer to use all the tuning, reporting and management functions of the Cisco IOS interface commands for each individual PVC. Using this feature of virtual interfaces also creates unique buffers on the output queues for each PVC versus n output buffer queue for the entire physical connection. The result is better performance and management using virtual subinterfaces.

    1. SNA Support

      2. Cisco IOS supports the transport of IBM Systems Network Architecture (SNA) protocols over frame relay using the RFC 1490/FRF.3 specification. The specification describes the encapsulation technique for transporting the SNA protocols. Cisco has applied their own algorithms for supporting enhanced features such as local acknowledgement, dynamic rerouting, SNA prioritization and PVC prioritization.

      1. Boundary Network Node (BNN)

        2. Cisco routers implementing RFC 1490/FRF.3 can connect LAN attached or SDLC attached SNA resources directly to the an IBM front end processor without the use of a data center based router or any other intermediate frame relay device. The IBM front-end processor must be using Network Control Program (NCP) V7.1 or higher Boundary Network Node (BNN) functions. Using a Cisco router at the remote location enables these SNA devices to maintain their current configuration while realizing the design benefits of a frame relay network. Figure 5.10 illustrates an SNA BNN connection to a mainframe front-end processor using Cisco routers at the remote location.

        Locations having multiple SNA physical units (PUs) requiring connectivity may use a single PVC. This is accomplished by implementing a Service Access Point (SAP) multiplexing feature. Each SNA PU is assigned a unique SAP address, which enables the Cisco router to support multiple SNA PUs over the single PVC.

      2. Boundary Access Node (BAN)

RFC1490/FRF.3 enhances frame relay connectivity directly to the FEP by including the IEEE 802.5 MAC header in every frame. This specification is called Boundary Access Node (BAN). Using BAN an unlimited number of SNA, devices are supported over a single frame relay PVC. BAN eliminates the need to use SAP addresses for multiplexing the SNA connections over a single frame relay PVC. Additionally, BAN supports duplicate DLCI-MAC address mappings on the front-end processors for load balancing and redundancy. Support for BAN on the IBM front-end processor requires NCP V7.3 or higher and the Cisco IOS must be using IOS 11.1 or greater. Figure 5.11 illustrates the use of BAN connectivity.

The differences between BNN and BAN are:

  • BAN does not greatly benefit reduced router configuration over BNN for single SNA PU connectivity
  • For LAN attached SNA PUs, BNN requires a router configuration change as opposed to the dynamic use of MAC addresses employed by BAN.
  • BNN is more efficient for SDLC attached devices than BAN. At locations that have both SDLC attached and LAN attached SNA PUs a combination of BNN and BAN is beneficial.
  • BAN may require an NCP upgrade to V7.3.
  • Only BAN supports load balancing and dynamic redundancy.
      1. FRAS Host support

Cisco IOS supports the RFC 1490/FRF.3 node function at the data center router using the Frame relay access support (FRAS) host function. As shown in Figure 5.12, instead of the frame relay PVC terminating at an IBM front end processor a Cisco router is used. The Cisco IOS SNA connectivity features for connecting to the mainframe using either SDLC, LAN or channel-attachment with a Channel interface processor (CIP) or channel port adapter (CPA) are then employed for completing the SNA connection.

Backward Forward


Sackett
$70.00 0-07-058098-7 		Backward

Chapter Six

ATM Internetworking Design

Asynchronous Transfer Mode (ATM) is the first networking architecture developed specifically for supporting multiple services. ATM networks are capable of supporting audio (voice), video and data simultaneously. ATM is currently architected to support up to 2.5 Gbps bandwidth. Data networks immediately get a performance enhancement when moving to ATM due to the increased bandwidth over a WAN. Voice networks realize a cost savings due in part to sharing the same network with data and through voice compression, silence compression, repetitive pattern suppression, and dynamic bandwidth allocation. The ATM fixed-size 53-byte cell enables ATM to support the isochronicitiy of a time-division multiplexed (TDM) private network with the efficiencies of public switched data networks (PDSN).

Most network designers are first challenged by the integration of ATM with the data network. Data network integration requires legacy network protocols to traverse a cell-based switched network. ATM can accomplish this in several ways. The first of these is LAN emulation.

  1. LAN emulation (LANE)

    2. ATM employs a standards based specification for enabling the installed base of legacy LANs and the legacy network protocols used on these LANs to communicate over an ATM network. This standard is known as LAN emulation (LANE). LANE uses the Media Access Control (MAC) sublayer of the OSI data link control Layer 2. Using MAC encapsulation techniques enables ATM to address the majority of Layer 2 and Layer 3 networking protocols. ATM LANE logically extends the appearance of a LAN thereby providing legacy protocols with equivalent performance characteristics as are found in traditional LAN environments. Figure 6.1 illustrates a typical ATM topology with LANE support.

    LANE can use ATM emulated LANs (ELANs).. Using ELANs, a LAN in one location is logically connected to a LAN in another location. This allows a network designer to extend a LAN over an ATM WAN avoiding the need for routing packets between the two locations. LANE services can be employed by ATM attached serves or workstations, edge devices such as switches, and routers when routing between ELANs is required. ATM LANE uses four components to establish end-to-end connectivity for legacy protocols and devices. These are LAN Emulation Client, LAN emulation configuration server (LECS), LAN emulation server (LES), and Broadcast and Unknown Server (BUS).

    1. LAN Emulation Client (LEC)

Any end system that connects using ATM require a LAN emulation Client (LEC). The LEC performs the emulation necessary in support of the legacy LAN. The functions of the LEC are:

  • Data forwarding
  • Address resolution
  • Registering MAC addresses with the LANE server
  • Communication with other LECs using ATM virtual channel connections (VCCs).

End systems that support the LEC functions are:

  • ATM-attached workstations
  • ATM-attached servers
  • ATM LAN switches (Cisco Catalyst family)
  • ATM attached routers (Cisco 12000, 7500, 7000, 4700, 4500 and 4000 series)
      1. LAN Emulation Configuration Server (LECS)

The ELAN database is maintained by the LAN emulation configuration server (LECS). In addition, the LECS builds and maintains an ATM address database of LAN Emulation Servers (LES). The LECS maps an ELAN name to a LES ATM address. The LECS performs the following LANE functions:

  • Accepts queries from a LEC
  • Responds to LEC query with an ATM address of the LES for the ELAN/VLAN
  • Serves multiple emulated LANs
  • Manually defined and maintained

The LECS assigns individual clients to a ELAN by directing them to the LES that corresponds to the ELAN.

      1. LAN Emulation Server (LES)

        2. LECs are controlled from a central control point called a LAN Emulation Server (LES). LECs communicate with the LES using a Control Direct Virtual Channel Connection (VCC). The Control Direct VCC is used for forwarding registration and control information. The LES uses a Control Distribute VCC, a point-to-multipoint VCC, enabling the LES to forward control information to all the LECs. The LES services the LAN Emulation Address Resolution Protocol (LE_ARP) request which it uses to build an maintain a list of LAN destination MAC addresses.

      2. Broadcast Unknown Server (BUS)

        3. ATM is based on the notion that the network is point-to-point. Therefore, there is no inherent support for broadcast or any-to-any services. LANE provides this type of support over ATM by centralizing broadcast and multicast functions on a Broadcast And Unknown Server (BUS). Each LEC communicates with the BUS using a Multicast Send VCC. The BUS communicates with all LECs using point-multipoint VCC known as the Multicast Forward VCC. A BUS reassembles received cells on each Multicast Send VCC in sequence to create the complete frame. Once a frame is complete is then sent to all the LECs on a Multicast Forward VCC. This ensures the proper sequence of data between LECs.

      3. LANE Design Considerations

The following are guidelines for designing LANE services on Cisco routers:

  • The AIP has a bi-directional limit of 60 thousand packets per second (pps).
  • The ATM interface on a Cisco router has the capability of supporting up to 255 subinterfaces.
  • Only one active LECS can support all the ELANs. Other LECS operate in backup mode.
  • Each ELAN has one LES/BUS pair and one or more LECs.
  • LES and BUS must be defined on the same subinterface of the router AIP.
  • Only one LES/BUS pair per ELAN is permitted.
  • Only one active LES/BUS pair per subinterface is allowed.
  • LANE Phase 1 standard does not provide for LES/BUS redundancy.
  • The LECS can reside on a different router than the LES/BUS pair.
  • VCCs are supported over switched virtual circuits (SVCs) or permanent virtual circuits (PVCs).
  • A subinterface supports only one LEC.
  • Protocols such as , AppleTalk, IP and IPX are routable over a LEC if they are defined on the AIP subinterface.
  • AN ELAN should be in only one subnet for IP.
      1. Network Support

The LANE support in Cisco IOS enables legacy LAN protocols to utilize ATM as the transport mechanism for inter-LAN communications. The following features highlight the Cisco IOS support for LANE:

  • Support for Ethernet-emulated LANs only. There is currently no token-ring LAN emulation support.
  • Support for routing between ELANs using IP, IPX or AppleTalk.
  • Support for bridging between ELANs
  • Support for bridging between ELANs and LANs
  • LANE server redundancy support through simple server redundancy protocol (SSRP)
  • IP gateway redundancy support using hot standby routing protocol (HSRP)
  • DECnet, Banyan VINES, and XNS routed protocols
      1. Addressing

        2. LANE requires MAC addressing for every client. LANE clients defined on the same interface or subinterface automatically have the same MAC address. This MAC address is used as the end system identifier (ESI) value of the ATM address. Though the MAC address is duplicated the resulting ATM address representing each LANE client is unique. All ATM addresses must be unique for proper ATM operations. Each LANE services component has an ATM address unique form all other ATM addresses.

      2. LANE ATM Addresses

LANE uses the NSAP ATM address syntax however it is not a Layer 3 network address. The address format used by LANE is :

  • A 13-byte prefix that includes the following fields defined by the ATM Forum:
  • AFI (Authority and Format Identifier) field (1 byte)
  • DCC (Data Country Code) or ICD (International Code Designator) field (2 bytes)
  • DFI field (Domain Specific Part Format Identifier) (1 byte)
  • Administrative Authority field (3 bytes)
  • Reserved field (2 bytes)
  • Routing Domain field (2 bytes)
  • Area field (2 bytes)
  • A 6-byte end-system identifier (ESI)
  • A 1-byte selector field
      1. Cisco's Method of Automatically Assigning ATM Addresses

The Cisco IOS supports an automated function of defining ATM and MAC addresses. Theses addresses are used in the LECS database. The automation process uses a pool of eight MAC address that are assigned to each router ATM interface. The Cisco IOS applies the addresses to the LANE components using the following methodology:

  • All LANE components on the router use the same prefix value. The prefix value identifies a switch and must be defined within the switch.
  • The first address in the MAC address pool becomes the ESI field value for every LANE client on the interface.
  • The second address in the MAC address pool becomes the ESI field value for every LANE server on the interface.
  • The third address in the MAC address pool becomes the ESI field value for the LANE broadcast-and-unknown server on the interface.
  • The fourth address in the MAC address pool becomes the ESI field value for the LANE configuration server on the interface.
  • The selector field for the LANE configuration server is set to a 0 value. All other components use the subinterface number of interface to which they are defined as the selector field.

The requirement that the LANE components be defined on different subinterfaces of an ATM interface results in a unique ATM address due to the use of the selector field value being set to the subinterface number.

      1. Using ATM Address Templates

        2. ATM address definitions is greatly simplified through the use of address templates. However, these templates are not supported for the E.164 ATM address format. The address templates used for LANE ATM addressing can use either an asterisk (*) or an ellipsis (…) character. An asterisk is used for matching any single character. An ellipsis is used for matching leading or trailing characters. Table 6.1 lists the address template value determination.

        Unspecified Digits In

        Resulting Value Is

        Prefix (first 13 bytes)

        Obtained from ATM switch via Interim Local Management Interface (ILMI)

        ESI (next 6 bytes)

        Filled using the first MAC address of the MAC address pool plus

        0-LANE client

        1-LANE server

        2-LANE broadcast-and-unknown server

        3-LANE Configuration server

        Selector field (last 1 byte)

        Subinterface number, in the range 0 through 255.

        The ATM address templates can be either a prefix, or ESI template. When using a prefix template, the first 13 bytes match the defined prefix for the switch but uses wildcards for the ESI and selector fields. An ESI template matches the ESI field but uses wildcards for the prefix and selector fields.

      2. Rules for Assigning Components to Interfaces and Subinterfaces

The LANE components can be assigned to the primary ATM interface as well as the subinterfaces. The following are gudielines for applying LANE components on a Cisco router ATM interface.

  • The LECS always runs on the primary interface.
  • Assignment a component to the primary interface falls through to assigning that component on the 0 subinterface.
  • The LES and LEC of the same emulated LAN can be configured on the same subinterface in a router.
  • LECs of two different emulated LANs must be defined on a different subinterface in a router.
  • LESs of two different emulated LANs must be defined on a different subinterface in a router.
      1. Redundancy in LANE environments

The ATM LANE V 1.0 specification does not provide for redundancy of the LANE components. High avialbility is always a goal for network designers and the single point of failure in the LANE specification requires a technique for redundancy. Cisco IOS supports LANE redundancy through the implmenentation of Simple Server Replicatoin Protocol (SSRP).

SSRP supports redundancy for LECS and LES/BUS services. LECS redundancy is provided by configuring multiple LECS address in the ATM switches. Each defined LECS is defined with a rank. The rank is the index (number of the entry in the LECS address table) of the LECS address in the table. At iitialization the LECS requests the LECS address table form the ATM swixth. The requesting LECs onreceipt of the LECS addres table tries to connect to all the LECSs with a lower rank. In this way the LECS learns of its role in the redundancy hierarchy. A LECS that connects with a LECS whose rank is higher places itself in a backup mode. The LECS that connects to all other LECS and does not find a ranking higher than its own assumes the responsibility of the primary LECS. In this hierarchy, as shown in Figure 6.2, the failure of a primary LECS does not result in a LANE failure. Rather , the second highest ranking LECS assumes the primary LECS role. Loss of the VCC between the primary and highest ranking secondary signals the highest secondary ranking LECS that it is now the primary LECS.

In theory any number of LECS can be designed using SSRP. However, Cisco recommends that no more than three LECS be designed into SSRP. The recommendation is based on adding a degree of complexity to the network design which can lead to an increase in the time it takes for resolving problems.

LES/BUS redundancy using SSRP is similar in that it uses a primary-secondary hierarchy however, the primary LES/BUS pair is assigned by the primary LECS. The LECS determines the primary LES/BUS pair by determining the LES/BUS pair having the highest priority with an open VCC to the primary LECS. The LES/BUS pair priority is assigned during configuration into the LECS database.

The following guidelines are highly recommended for desinging the LECS redundancy scheme and ensuring a properly running SSRP configuration:

  • Each LECS must maintain the same ELAN database.
  • Configure the LECS addresses in the LECS address table in the same order on each ATM switch in the network.
  • Do not define two LECSs on the same ATM switch when using the Well Known Address. Only one of the LECS will register the Well Known Address with the switch which may led to initialization problems.

A second type of redundancy mechanism used in LANE is specific to ELANS using IP protocol. The Host Standby Router Protocol (HSRP) enables two routers to share a common virtual IP address using a virtual MAC address assigned to the resulting virtual interface. This enables two routers to respond as the single IP gateway address for IP end stations. Figure 6.3 illustrates the use of HSRP with LANE. The primary and secondary router interface is determined by definition of HSRP on interface or subinterface. HSRP exchanges definition information between the two routers to determine which interface is the primary gateway address. The secondary then sends HELLO messages to the primary to determine its viability. When the secondary does not receive a HELLO message from the primary HSRP router it assumes the primary role.

    1. Data Exchange Interface (DXI)

      2. ATM networks connect to serial attached routers by implementing the ATM data exchange interface (DXI) specification. The DXI specification enables ATM user-network interface (UNI) connectivity between a Cisco router with only a serial interface to the ATM network. This is accomplished using an ATM Data Service Unit (ADSU). As shown in Figure 6.4, router R1 connects to the ADSU using a High Speed Serial Interface (HSSI) connection. The ADSU recevies data from the router in the ATM DXI format. The ADSU then converts the data into ATM cells and forwards them to the ATM network. The ADSU performs the opposite function for data going to the router.

      1. Supported Modes

While there are three modes of ATM DXI the Cisco IOS supports only mode 1a. The three modes are:

  • Mode 1a-Supports AAL5 only, a 9232 octet maximum, a 16-bit FCS, up to 1023 virtual circuits.
  • Mode 1b-Supports AAL3/4 and AAL5, a 9224 octet maximum, a 16-bit FCS. AAL5 support up to 1023 virtual circuits. AAL3/4 is supported on one virtual circuit.
  • Mode 2-Supports AAL3/4 and AAL5 with 16,777,215 virtual circuits, a 65535 octet maximum, and 32-bit FCS.
      1. DXI Addressing

The DXI addressing using a value which is equivalent to a frame relay data link connection identifier. In DXI this field is called a DFA. The ADSU maps the DFA to the appropriate ATM Virtual Path Identifier (VPI) and Virtual Connection Identifier (VCI). Figure 6.5 illustrates the bytes and position mapping of the DXI DFA address to the ATM cell VPI and VCI values.

    1. Classical IP

      2. Cisco routers are configurable as both an IP client and IP server in support of Classical IP. Classical IP enables the routers to view the ATM network as a Logical IP Subnet (LIS). Configuring the routers as an ATM ARP server enables classical IP networks to communicate over an ATM network. The benefit to this is a simplified configuration. Classical IP support using an ATM ARP server alleviates the need to define the IP network address and ATM address of each end device connecting through the router in the router configuration.

      ATM uses PVCs and SVCs. The ATM ARP server feature of Classical IP is specific to using SVCs. Using the ATM ARP server feature each end device only configures its own ATM address and the address of the ATM ARP server. Since RFC 1577 allows for only one ATM ARP server address there is no redundancy available for Classical IP. As shown in Figure 6.6, the ATM ARP server address can point to a Cisco router. IP clients using Classical IP make a connection to the ATM ARP server address defined in their configuration. The server then sends an ATM Inverse ARP (InARP) request to the client. The client responds with its IP network address and ATM address. The ATM ARP server places these addresses in its cache. The cache is used to resolve ATM ARP requests from IP clients. The IP client established a connection to the IP-ATM address provided in the ATM ARP server reply.

    2. Multiprotocol over ATM (MPOA)

MPOA provides a single solution for transporting all protocols through an ATM network. MPOA V1.0 in concert with LANE User-to-Network Interface (UNI) V2.0 allows routers and other ATM networking devices to fully exploit VLANs, QoS and high-availability. These network enhancements enable designers to add services while relieving traffic congestion and flexibility to the network. The key benefits to MPOA are:

    • Inter-VLAN "cut-through" which maximizes bandwidth and network segmentation.
    • Robust Layer 3 QoS features to support packetized traffic such as video or voice, while ensuring data service levels.
    • Software only upgrade which minimizes the cost and simplifies implementation.

The MPOA specification is built on four components. These components are:

    • MPOA Client (MPC)
    • MPOA Server (MPS)
    • Next Hop Resolution Protocol (NHRP)
    • LAN Emulation (LANE)

Both MPC and MPS functions are supported on Cisco routers. MPOA uses a direct virtual channel connection (VCC) between the ingress (inbound) and egress (outbound) edge or host device. Direct VCCs are also termed shortcut VCCs. The direct VCC enables the forwarding of Layer-3 packets, normally routed through intermediate routers, between source and destination host thereby increasing performance and reducing latency.

Figure 6.7, illustrates the use of MCP, MPS, and NHRP for establishing a direct VCC between two edge devices servicing two end stations.

      1. Multiprotocol Client (MPC)

Typically, the Multiprotocol client (MPC) will reside on an ATM edge device such as a Cisco Catalyst family of switches. However, a Cisco router can perform the functions of an MPC or MPS. An MPC provides the following functions:

    • Ingress/egress cache management
    • ATM data-plane and control-plane VCC management
    • MPOA frame processing
    • MPOA protocol and flow detection
    • Identifies packets sent to an MPOA-capable router
    • Attempts to establish a direct VCC with the egress MPC.
      1. Multiprotocol Server (MPS)

The Multiprotocol server (MPS) provides the forwarding information used by the MPCs. The MPS maintains the information by using Next Hop Resolution Protocol (NHRP). MPS interacts with the NHRP module running in the router. MPS interacts with NHRP in the following manner:

    1. The MPS converts the MPOA resolution request to a NHRP request. The MPS then sends the NHRP request to either the next hop MPS or the Next Hop server (NHS) based on the results form the next hop information search through the MPS tables. MPS ensures that the correct encapsulation is used depending on the next hop server type.
    2. If the next hop is determined to be on a LANE cloud the NHS sends resolution requests to the MPS. Likewise, the NHS sends resolution requests when the destination of the packet is unknown. The MPS may also request the NHS to terminate the request or discard the packet.
    3. If the replies terminate in the router or the next hop interface uses LANE, resolution replies are sent from the NHS to the MPS.
    4. Upon receiving resolution replies from the NHS the MPS sends a MPOA resolution reply to the MPC.

MPS uses a network ID. The default nework ID for all MPSs is 1. Using different network IDs allows the network designer to segregate traffic. This enables the designer to permit direct VCCs between groups of LECs and deny direct VCCs between others. The network ID of an MPS and NHRP on the same router must be the same in order for reqeusts, replies and shortcuts across the MPS and NHRP.

      1. MPOA Guidelines

The following is a list of guidelines for designing MPOA:

    • An ELAN identifier must be defined for each ELAN.
    • An MPC/MPS can serve as a single LEC or multiple LECs.
    • A LEC can associate with any MPC/MPS.
    • A LEC can attach to only one MPC and one MPS at a time.
    • A LEC must break its attachment to the current MPC or MPS before attaching another MPC or MPS.
    • A primary ATM interface can have multiple MPCs or MPSs defined with different control ATM addresses.
    • Multiple MPCs or MPSs can be attached to the same interface.
    • The interface attached to the MPC or MPS must be reachable through the ATM network by all LECs that bind to it.
    1. Bandwidth support on routers

ATM is supported on the Cisco 7500 and 7000 series routers using the ATM Interface Processor (AIP). In designing the ATM internetwork in support of LANE the total ATM bandwidth support for the entire router should not exceed 200 Mbps in full duplex mode. This results in the following possible hardware configurations:

  • Two Transparent Asynchronous Transmitter/Receiver Interface (TAXI) connections.
  • One OC-3 Synchronous Optical Network (SONET) and one E3 connections.
  • One OC-3 SONET and one low-use OC-3 SONET connections
  • Five E3 connections
    1. Configurable Traffic Parameters

The AIP provides the ability to shape various traffic. The AIP supports up to eight rate queues. Each queue is programmed for a different peak rate. The ATM virtual circuits can be assigned to one of the eight rate queues. A virtual circuit can have an average rate and a burst size defined. The AIP supports the following configurable traffic rate parameters:

    • Forward peak cell rate
    • Backward peak cell rate
    • Forward sustainable cell rate
    • Backward sustainable cell rate
    • Forward maximum burst
    • Backward maximum burst
Backward


George Sackett
$80.00 0-07-058098-7

Cisco Router Handbook


Teleport Pro Messages

http://www.netscape.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.microsoft.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/computing/computing-home.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/betabooks/stores.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/betabooks/betabooks-home.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/pbg-home.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.mcgraw-hill.com/corporate/news_info/copyrttm.htm: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/contact.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/custservice.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/authors.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/international.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/new-book-alert.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/search.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/sitemap.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.pbg.mcgraw-hill.com/whatsnew.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.mcgraw-hill.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.mcgraw-hill.com/corporate/news_info/privacy.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.