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Introduction

Discover the world of Office 2003 programming and development.
Microsoft has put many of its best cutting-edge tools into this power-
house package. And you can also add .NET technology to Office 2003 quite
easily, taking your programming to the next level. There’s lots to explore.

This book shows you — the Office user, programmer, or developer — how
best to exploit, expand, administer, and write code for Office 2003, the
world’s most popular application suite. And it certainly is popular: Experts
estimate that Office has over 90 percent of the market share. [ think [ know
why (and the answer isn’t what Microsoft-haters claim).

P've Seen It All

I've seen all the software. Over two decades — first as editor of COMPUTE!
magazine and since then as a full-time computer-book author — I've worked
with review copies of most major software. I work daily with computers and
have used most all the major applications.

Word processors? I've used SuperScript, XYWrite, WordStar, WordPerfect,
Word, and more. I've also put in time with other products that are today
little more than memories: dBase, early spreadsheet applications like
VisiCalc, and so on.

In its day, WordPerfect was the word processor of choice, and I happily used
it for years (the last half of the 80’s), but when Microsoft Word appeared in
1989, I switched to it pretty fast. Right away, actually. | switched because

[ thought that Word was a better word processor than the competition.
That’s not because of any special ties | have to the Windows operating
system or because | work for Microsoft. (They’re not even giving me free
software anymore when [ write a book.) I'm mad at them because I have to
buy all this software, truth be told. But truth should be told, and Microsoft
does put out very good software. Microsoft-haters are wrong, in my opinion.

Today Word enjoys almost 100 percent market share in the word processing
application market. Why? Because it’s just plain the best word processor
you can buy.
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Moving beyond UBA

Whatever your politics, most of us living in the real world of practical com-
puting use, manage, or program for Microsoft Office. And that’s what this
book is all about: how to take your current knowledge of Office to the next
level. You'll find tips, solutions, code examples, clear explanations, migration
paths, and lots of other useful information that you can apply to your every-
day personal and business computing.

While writing this book, I've tried hard to give you information that is practi-
cal, makes sense, and helps you do the jobs you have to do.

Moving beyond VBA

This book has another, secondary goal: to help you migrate from VBA
(the traditional Office programming language) to VB.NET, the next genera-
tion programming technology that offers you considerable additional muscle.

You'll find plenty of examples illustrating how to add .NET programming to
your Office 2003 projects and how to tap into the various tools that the .NET
editor (Visual Studio, the IDE) offers us programmers. Ignore .NET at your
peril.

Connectivity, Internet programming, scalability, interoperability, stability,
and more — VB.NET brings many qualities to the Office programmer’s
toolkit. VB.NET is the future of Office programming, and this book prepares
you to make the move. You'll find code examples written in both VBA and
VB.NET, showing you how to move to this important language and apply it to
Office 2003 solutions. You need to know how to do things that VBA simply
cannot handle by itself.

You can add .NET’s power to your Office programming very easily — I show
you how throughout this book.

But good old VBA isn’t neglected. A mini-book is devoted to it (Book II,
“Understanding Office Programming”), and much of this whole book’s pro-
gramming is written in it. VBA remains the “official” Office language in Office
2003. And we all have lots of VBA code that we’ve written over the years,
either in VBA itself or its brother language, Visual Basic (versions 6, 5, 4, 3, 2,
and 1).

Nonetheless, there are certain hints — suggestions of obsolescence —
coming out of Redmond. For example: “There are no language enhancements
to VBA 6.0 itself in the Microsoft Office System.” In other words, VBA was not
improved in Office 2003. (That’s always a bad sign.) Further, Microsoft has
announced that it will continue to support VBA in the future. Cue the “Jaws”
movie music.
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UBA code is legacy code!

Microsoft says that “if VBA is ever retired” (cellos: dunn-dit-dunn-dit-dunn-
dit, as the shark approaches), it will provide utilities or other assistance to
help us move our code from VBA to .NET. Here’s a statement from a white
paper on the MSDN site. Be afraid, VBA programmers, be very afraid:

VBA 6.0 is not going away in the next release of the Microsoft Office System,
and Microsoft will provide a migration strategy if VBA is ever retired. There is
quite a bit of legacy code that is written in VBA 6.0. In many cases, there may
be no reason for existing code to be rewritten. However, the significant advan-

tages and capabilities the .NET Framework offers may cause you to rethink
whether to leave some solutions as they are. There are no language
enhancements to VBA 6.0 itself in the Microsoft Office System.

Here they’re starting to refer to our beloved VBA programming as “legacy
code.” You know what legacy means: done for. So how should we react?
Should we say:

“We, the programmer soldiers, salute you! Bring it on!”
or
“Do me baby one more time.”

The choice is yours.

Recognizing UBA’s excellence

VBA is to classical procedure-oriented programming as Bach’s incomparable
works are to Baroque music. They represent the finest example, the summa-
tion, of an epoch.

VBA is probably the most efficient and mature procedure-oriented language
available today. And although VBA includes some object-oriented features,
they seem a bit uncomfortable within the VBA structure — they feel more
like workarounds and patches than integral elements.

By contrast, VB.NET was designed from the ground up to be object-oriented
and to be an effective way to write distributed programs — programs that are
divided into segments that execute on different machines.

Also, the .NET IDE offers a very powerful suite of programming tools. It’s
simply more capable and sophisticated than the VBA editor in Office 2003
applications. Given a choice, any serious Office 2003 developer — or indeed
pretty much any programmer doing most kinds of Windows or Internet
programming — likely prefers the Visual Studio programming environment.
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Moving beyond UBA

Using the framework

Also, the .NET language itself, the .NET framework, is huge and contains
effective, specialized, and generally powerful classes to accomplish what-
ever you might need to do. (Database, Internet, security, and nearly any
other kind of programming are supported with advanced tools and versatile
objects.) For example, NET lets you add classic Windows forms to Office
solutions. These windows are superior to the UserForms available via VBA.
And the VB.NET debugging facilities are among the most thoughtfully organ-
ized and robust available. .NET includes extensive XML and namespace
support; ADO.NET — an advanced, highly scalable, database management
technology — and ASP.NET (ditto for highly scalable Internet programming).
The list goes on and on.

This book is not about .NET, but I do provide considerable information for
Office programmers who want to find out how to add .NET to their Office
solutions and in the process, see how to migrate from VBA to .NET.

The VB.NET language is not merely a revision of VBA or VB 6. Instead, it was
rewritten from the ground up to be a brand-new, fully OOP language. Do real-
ize, though, that if your programming projects are relatively small or you
don’t program as part of a programming team, OOP is often simply more
trouble than it’s worth. Fortunately, you can ignore OOP when writing code
in .NET if you wish. You can just use familiar, tried-and-true, VBA-style
procedure-oriented programming techniques if you wish. And you still get
the double bonus of tapping into the powerful .NET framework of prewritten
functions and also the use of the splendid .NET programming editor.

Understanding managed code

VB.NET — like the other VS.NET languages — runs under the supervision

of the common language runtime (CLR), thereby earning Microsoft’s new
phrase: managed code. Such code is validated (checked to see that it doesn’t
violate memory restrictions and other illegal behaviors). It also offers code-
based security features unavailable to unmanaged (non-.NET languages)
code. However, compared with older languages — particularly the VBA built
into Office applications — .NET requires that you deal with a bit of a learning
curve, particularly when adapting to the .NET programming styles, language
elements, and security settings. Also, after you come to grips with the essen-
tials of OOP, communication between .NET and Office objects or VBA is gen-
erally quite smooth although there are a few data type discrepancies that
now and then must be dealt with.
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About This Book

My main job in this book is to show you the best way to create solutions for
Office 2003 applications. You see how to master the various techniques that
collectively put you on the path to true Office programming expertise.

If a task requires hands-on programming, I show you step-by-step how to
write that programming. In other cases, I tell you when there’s a simpler,
better way to accomplish a job. Otherwise, you could spend days hand-
programming something that’s already been built — something you can
create by clicking a simple menu option, adding a prebuilt component, firing
up a wizard, using a template, or tapping into an object library.

This book is designed for Office programmers and developers or for people
who want to become one. Most new computers ship with Office, and it is
used in nearly every business today. What these businesses have in common
is an ongoing effort to improve their efficiency. In many cases, developing or
automating Office applications is one of the most effective ways to increase
workplace productivity. Many workers know what they wish they could do,
and this book shows you how to help them do it.

Office 2003 Application Development All-in-One Desk Reference For Dummies
covers all the new features in Office 2003 and demonstrates how developers
can best exploit them. Many of these features are designed to improve work-
flow, boost productivity, and facilitate better communication between
employees — just the sort of goals that Office developers themselves work
to achieve. For example, InfoPath simplifies interaction with all kinds of data
sources: everything from unformatted lists to legacy databases. SharePoint
assists developers in building an automated collaborative environment.

Underlying many of the improvements in Office 2003 is XML and related
technologies such as Web Services. This book explains precisely how to take
advantage of XML'’s promise with simple, no-nonsense, real-world examples.
Readers will understand exactly how to leverage their current work and com-
munication patterns using the new and powerful data sharing techniques
available in Office 2003.

Businesses understand the importance of remaining competitive. This book
shows developers how to make the most of Office’s tools and technologies.
All the innovations in Office 2003 are fully explained, employing the famous
For Dummies approach: clear explanations, step-by-step examples, and lots
of practical advice.
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Who Should Read This Book

No significant Office topic is ignored. I explain traditional but significant fea-
tures such as Visual Basic for Applications (which are too often ignored in
other books on Office). And I cover all the latest developments such as
Smart Documents, Access 2003 Developer Extensions, programming task
panes, managing Smart Tags, the new security features, and much more.

Anyone interested in building intelligent business applications will find the
solutions they’re looking for in this book. And the example code is practical:
Not only do I show you how the code works, but as often as possible, I try to
provide code that you can use in your own programs. You find out, for exam-
ple, how to write a text search utility that searches across folders and direc-
tories for a specific word or phrase. What’s the benefit? This search utility is
far faster than the Windows search utility found on the Start menu.

Who Should Read This Book

This book is written for a broad audience: programmers, developers, office
managers, IT staff, and even individual users of the Office 2003 suite of appli-
cations. In other words, the book has value for everyone who wants to be
more efficient when using Office 2003.

The book shows how to exploit the Office applications by learning how to
develop solutions to common business problems. The reader will under-
stand how to solve those problems by using the many utilities, features,
hidden shortcuts, wizards, add-ins, and other tools in the Office suite.

The book is also for would-be developers who want to get involved in cus-
tomizing or automating the applications but just don’t know how to get
started. Whether you want to get Access to communicate with Outlook or
are interested in building a sophisticated inter-office scheduling system,
you’ll find what you need in this book. The book is filled with useful macros
and plenty of practical, real-world programming examples including

4 Automating e-mail routing
4 Administering the task pane from within an application

4+ Writing your own add-ins

4+ Building a distributed business system using Web Services

Making do in a shaky economy

No matter what they tell us from the bully pulpit, we know how shaky the
economy is, don’t we? The primary trend in nearly all industries today is
toward making do with less: fewer workers, less time to complete tasks, and
stretching resources as much as possible. This trend demands improved
productivity.
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Some offices respond by letting part of the staff go and heaping additional
work on the remaining employees or by outsourcing or offshoring. In many
cases, a more successful long-term tactic is to retain a high-quality, loyal
staff but to improve the general efficiency of that staff. Microsoft Office 2003
is loaded with tools to improve productivity if you know how to exploit
them. Office 2003 Application Development All-in-One Desk Reference

For Dummies is the handbook that takes the reader from idea to finished
business solution.

I hope that all my work these past years exploring programming and working
with Office will benefit you, showing you the many useful shortcuts and guid-
ing you over the rough spots. I won’t pull any punches: I confess if it took me
several hours wrestling with code to accomplish something. But after I've
put in the time getting it to work, I can almost always show you how to do it
in a few minutes. (I never got one new technology, Visual Studio Tools for
Office, to work, but I confess that, too.)

Plain, clear English

Also, unlike some other books about Office 2003 programming (which must
remain nameless), this book is written in plain, clear English. Novices will
find many sophisticated tasks made easy: The book is filled with step-by-
step examples that even beginners can follow even if they’ve never written a
line of programming or designed a single computer application. And if you're
an experienced programmer, better still. You'll find out how to accomplish
sophisticated tasks quickly. You also discover how to harness the machinery
built into Office 2003. And you also discover how to leverage your current
skills to prepare for the future of Office programming: moving beyond VBA
to VB.NET.

How to Use This Book

This book obviously can’t cover every feature in Office 2003, VBA, and espe-
cially VB.NET. Instead, as you try the many step-by-step examples in this
book, you’ll become familiar with the most useful features of Office develop-
ment and programming and discover many shortcuts and time-saving tricks
(some that can take years to discover on your own). Believe me, some of
them have taken me years to stumble upon.

Whether you want to turn a Word document into a Web site or create
impressive Office 2003 solutions in Windows, this book tells you how to
build what you want to build. Here are just a few of the goals that you can
achieve with this book:
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4+ Explore and program with new Office 2003 features such as Document
Workspaces, shared attachments, OneNote, XML, and others. Some tech-
nologies explored in this book are not covered in other Office program-
ming titles, including encryption programming and the new Visual Studio
Tools for Office.

+

Build professional-looking, effective programs.

4+ See how to connect the various Office 2003 applications and data stores
into a seamless, distributed, and secure business solution (and how to
be smart enough to know when to use wizards to help).

4+ Make the transition from Microsoft’s traditional VBA Office language to
the powerful new .NET technologies for database and other kinds of
programming.

4+ Understand how to best use the many features built into VB.NET.

<+

Kill bugs using powerful debugging tools.

4 Get the most out of the Office and .NET security features, including how
to automate strong programmatic encryption.

Many people think that programming is impossibly difficult and that distrib-
uted (inter-application) programming is even more difficult. It doesn’t have
to be.

In fact, many common programming jobs have already been written for you in
Office object libraries or the VB.NET framework, so you don’t have to do the
programming at all. If you're smart, you don’t reinvent the wheel. Sometimes,

all you need to know is where in VBA to find a particular component, wizard,
template, or other prebuilt solution. Then drop it into your application. This

book is your guide to building efficient Office 2003 applications, utilities, and
large-scale solutions.

This book tells you whether a particular wheel has already been invented. It
also shows you how to save time by using or modifying existing components
or Help code to fit your needs instead of building new solutions from scratch.
But if you're doing something totally original (congratulations!), this book
also gives you step-by-step recipes for tackling many common tasks from the
ground up.

Foolish Assumptions

In writing this book, I had to make a few assumptions about you, dear reader.
[ assume that you know how to use Office (except for the brand-new features
in Office 2003) and understand the basics of programming in general.
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I also assume that you don’t know much, if anything, about VB.NET program-
ming as it applies to Office. Perhaps most importantly, [ assume that you don’t
want lots of theory or extraneous details. You just want to get programming
jobs done, not sit around listening to airy-fairy theory about polymorphism
and such. When a job can be done in VBA, [ show you how. When you need
to reach out to the more powerful .NET framework, I show you that, too.
Whatever it takes, the job gets done.

How This Book Is Organized

The overall goal of Office 2003 Application Development All-in-One Desk
Reference For Dummies is to provide an enjoyable and understandable guide
for the Visual Basic programmer. This book will be accessible to developers
and programmers with little or no .NET programming experience.

The book is divided into eight mini-books, with several chapters in each
book. Just because the book is organized doesn’t mean that you have to be.
You don’t have to read the book in sequential order from Chapter 1 to the
end, just as you don’t have to read a cookbook in sequential order.

For example, if you need to add today’s most powerful encryption technology
to your office solution programmatically, | suggest you read the last chapter
first (Book VIII, Chapter 8).

If you want to brush up on VBA, Book Il is for you. You're not expected to
know what’s in Book I to get results in Book II. Similarly, within each chapter,
you can often scan the headings and jump right to the section covering the
task that you want to accomplish. There is no need to read each chapter
from start to finish. I've been careful to make all the examples as self-
contained as possible. And each of them works, too. They’ve been thor-
oughly tested.

All of the source code for all the examples in this book is downloadable from
this book’s Web site at www.dummies.com/go/office2003dev.

The following sections give you a brief description of the book’s eight main
parts.

Book I: Office 2003 Essentials

This first mini-book introduces Office 2003 — explaining its purposes, what’s
new in this edition, and Office’s fundamental nature. You see how common
tasks are accomplished, and you discover the elements of Office program-
ming. You are introduced to the main new features in Office 2003 such as
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OneNote, XML, task panes, the major overhaul of Outlook, and so on. Topics
in this mini-book include managing menus and toolbars, how to find program-
ming help online, understanding macro security, introduction to document
workspaces, and joining the XML revolution.

Book 11: Understanding Office Programming

Book II covers the primary elements of VBA. It’s a refresher course for pro-
grammers to need to brush up on classic Visual Basic programming, and a
full-on programming course for people new to programming VBA, the classic
language built into Office applications. All the essentials are covered, from
simple concepts such as data types to advanced subjects like various secu-
rity measures that you can take to protect databases. This mini-book covers
how to move Office documents and other elements to the Internet. You also
see how to exploit the famous Visual Basic debugging tools.

Book 111: Maximizing Word

Book IIl focuses on the world’s greatest word processor. You see how to
work with the Word object model to tap into the power of this huge dedi-
cated language. You explore enums, ranges, selections, and the dialog
object, among other topics. Then on to power editing — ways to maximize
Word’s editing features. Many (perhaps most) Office workers don’t take
advantage of Word’s many powerful editing capabilities. You also see how to
maneuver efficiently, use Smart Documents, import data, and manage mail
merge.

You explore how XML and Word now work together synergistically to facili-
tate communication between any and all platforms, operating systems, data
stores, applications, and whatever else might want to communicate with
Word. You see how Word does a serviceable job for smaller Internet jobs,
such as displaying your pictures or blogging your feelings for all to see. You
find out how to transform DOC files into Web pages. This book concludes
with power macro programming: how to contact and manipulate other Office
applications from within Word, how to access and modify the behavior of
Word’s built-in features such as FileSave, and a set of what I consider the
best Word macros available.

Book IV: Making the Most of Excel

This mini-book focuses on many aspects of programming Excel, beginning
with an exploration of the Excel object hierarchy including all the expected
classes, plus collection objects, ranges, charts, pivot tables, shapes, and so
on. Concrete examples illustrate how you can get down deep into Excel
and make it really glide across the ice like a champion skater. You also see
how to respond programmatically to Excel events, automate data and XML
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importation, create datasets, and programmatically build pivot tables. You
see how to manage goal seeking, scenarios, and summary reports and also
explore problems with the Solver. You contact other Office applications from
within Excel, employ UserForms, add macros to worksheet controls, automate
formatting, add controls programmatically, trap keypresses, send workbooks
via e-mail, and tell the differences between the activate and select methods.
Whew! If I've left out anything you're interested in, send me an e-mail, and I'll
include it in the next printing.

Book U: Advanced Access

There are dozens of books on Access 2003, but few I've found make a con-
scious attempt to integrate Access with the other Office applications.
Access, poor darling, has always stood alone. It’s always been the strange
stepchild — the one that doesn’t quite get into the act or the one off in the
shadows in the family pictures. Access differs in many ways from the other
Office 2003 applications, from its lack of direct keyboard modification to the
peculiarities of its object model. Throughout this book, I've often found
myself writing “. . . but of course, Access does this differently. Here’s how to
get Access to accomplish this task.”

So I've done my best to always include Access in any important discussion
all through the entire book. In this mini-book, though, I focus directly on
Access. You see how to sort out the various database technologies and
ODBC and how to move beyond VBA and DAO to ADO. You wrestle with the
concurrency problem and benefit from various RAD efficiencies. Cutting-
edge technologies are explored, including loading an Access database into
.NET; data views; the XML Designer and XML dataset; loading XML into
Access; using the new Access 2003 Developer Extensions; exploring the
Package Wizard and Custom Startup Wizard; learning about the Property
Scanner add-in; Smart Tags in Access; connecting to Access via automation;
automating the Access runtime; using the new sandbox mode; and other
topics that might interest you.

Book VI: Exploiting Outlook

No Office 2003 application has been as overhauled as Outlook. In this mini-
book, you explore the new pane and other topics such as filters, spam block-
ing, encryption, special folders, and double calendars. As a programmer, you
want to read the sections that show you how to exploit the Outlook object
model, deal with namespaces, use MAPI objects, trap events, handle Contacts,
send data between Outlook and Word or Access, create new folders, modify
collections, search tasks, and manage the Outlook Calendar. Also covered
are topics such as effective automatic routing (during your vacation), man-
aging multiple accounts, using send/receive Groups, blocking virii, working
with profiles, sharing schedules, planning meetings, searching e-mail, and
ergonomics for your users.
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Book VII: InterOffice: Working as a Team

This mini-book takes a closer look at ways to integrate workers and applica-
tions to improve overall workplace efficiency. I start with OneNote, the cool
new utility and notes organizer that some people cannot live without. You
also see how to work well with others. It’s not always easy to avoid stepping
on people’s toes when several people try to edit the same document or plan
the same project. You see how to best use Office 2003 to manage shared
Contacts, handle document collaboration, set up a meeting workspace and
permissions, use the new Information Rights Management, change work-
space options, protect documents in Word, specify editing and formatting
restrictions, create custom views, and deal with the version problem using
Word’s new versions feature. You also explore topics such as building Web
pages, adjusting properties, viewing code, writing scripts, doing scripting in
Excel, debugging script, using forms, and sharing information efficiently.
InfoPath offers a variety of useful collaborative tools. You discover designing
with InfoPath, viewing data hierarchies, generating InfoPath forms from XML,
and building InfoPath forms from databases.

You also see how Smart Tags can be added to your Office 2003 projects to
assist users in filling out forms, getting context-sensitive help, and other ben-
efits. You see how to create, program, and test Smart Tags. You move on to
the containers of Smart Tags — Smart Documents — and read about feeding
data to Web sites, managing security issues, simplifying deployment, work-
ing with the elements of Smart Documents, using XML, attaching schemas,
attaching the XML Expansion Pack, coding, and modifying a template.

Project 2003 isn’t ignored. You explore creating and editing projects, dealing
with dependencies, understanding Gantt charts, and employing Outlook fea-
tures in your projects. Then you move on to SharePoint, beginning with the
reasons why you might choose it over other collaboration technologies. You
see how to install, specify permissions, use the Task Pane, manage SharePoint
scalability, integrate SharePoint with office 2003 applications, and a bit about
the ASP.NET connection.

Book VIII: Power Techniques: Advanced
Office Automation, UBA, and .NET

If you're looking for real heavy-duty programmer info and industrial-strength
development, many of those topics are gathered together in this mini-book.
But don’t be misled: Some seriously advanced topics are covered in other
mini-books as well. It’s just that I chose this last mini-book to focus on some
of the more cutting-edge or sophisticated techniques.
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This mini-book starts off with a discussion of the drawbacks of OOP pro-
gramming and also a comparison of the qualities of VBA versus VB.NET
(when you should choose one over the other). You also see code that
introduces a cool .NET feature called streaming. You then create your own
add-in — one of several techniques whereby you add the power of .NET to
your Office 2003 programming.

Chapter 2 is all about XML and associated technologies such as XSD, XML
data types, schemas, and XML programming. You wallow in objects in
Chapter 3: discovering techniques for using objects in VBA, understanding
.NET data types, making declarations and using events in VBA, and managing
collections and arrays of objects. Then you move on in the next chapter

to some advanced Internet programming topics, including working with

Web Services and how XML and Office work with this interesting Internet
technology:.

Chapter 5 is a dive into .NET — something every serious programmer must
master sooner or later. Sure, it’s a learning curve at first; Visual Basic will
never be the same again, after VB.NET. But believe me, what you spend in
time mastering .NET, you gain in considerable additional programming capa-
bility. You see how to use software services, Internet initiatives, .NET data-
base technologies, and general programming practices. This chapter is for
those readers who understand that the migration from VBA to .NET is essen-
tial (unless they’re near retirement and don’t have to worry about the future
of their career).

Chapter 6 continues this migration topic by focusing on Visual Studio Tools
for Office. It sounds like just the ticket. (Visual Studio is the set of utilities,
editors, and languages that collectively contain .NET.) It might sound like the
ticket, but at this point, it’s maybe a little too unfinished to be of much real
use to programmers. It has a little two-page wizard that merely sets up a
template that you can use to build an Excel or Word document, using some
code-behind features: that is, programming in .NET that can be used when a
user opens these documents (thereby also running Excel or Word).

Read Chapter 6 to see the struggles I faced trying to get VSTO to work.
Maybe it has been improved by the time you read this book, or maybe the
days I spent trying and failing to get it working correctly were a result of
temporary confusion on my part. Whatever. I got it mostly working — right
up to the final step. So perhaps you’ll succeed where I failed. (Some on the
VSTO newsgroup seem to have it working.) One other point, though: Even if
it works, there are other ways to do what VSTO does. Thus, unless I'm miss-
ing something, I actually don’t understand VSTO'’s raison d’étre. I might not
have conquered VSTO, but I do know French.
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Chapters 7 and 8 move you into an area of computing that is of increasing
interest to all of us who program or simply use computers — security.
Chapter 7 walks you through the various ways you can tighten Office 2003
security. You read about IRM, virus protection, file- and folder-based sys-
tems, macro security, signing, and hashing.

Chapter 8 is my personal favorite because to me, encryption is one of the
most compelling aspects of programming. There’s something intriguing
about the contest of intellects on either side — those cooking up new
attacks versus those thinking up new defenses. And the computer brings
an entirely new dimension to this ancient spy-versus-spy game.

For example, computers can try millions of passwords in less than an hour.
This speed wasn’t possible before computerization. It’s called a brute force
attack. This attack is countered by brute force encryption systems, as you’ll
see in Chapter 8. When you finish this chapter, you’ll be able to employ
today’s strongest encryption systems in your own programming. It’s quite a
bit of power for just a little extra work.

You also discover how to harness the DES system, used today by most banks
and other commercial institutions to secure their data and the messages
that they send over the Internet. But you also see how to add public key
encryption (RSA) to your programming. RSA is today’s most powerful
encryption system, used by the military and others to transmit shorter
pieces of data, such as passwords and keys. RSA isn’t generally used for
actual messages (because they’re too lengthy), and although it’s fantastically
secure, it’s really too slow to practically encrypt large amounts of data.

But combine the two technologies, and you’ll have today’s most powerful
encryption system at your disposal. Use RSA to exchange passwords or

keys and then use fast DES to exchange messages.

This chapter also shows you how to avoid storing your messages on a hard
drive (where, even if “deleted,” they can be recovered by widely available
utilities). Instead, you see how to employ .NET streaming technologies to
keep your information floating in the air like smoke — then disappearing
without a trace into the encryption. These memorystreams and crypto-
streams have lovely, poetic names, but they embody important, potent
technology . . . technology that you’ll want to understand.

Conventions Used in This Book

This book is filled with step-by-step lists that serve as recipes to help you
cook up finished Office 2003 solutions. Each step starts off with a boldface
sentence or two telling you what you should do. Directly after the bold step,
you might see a sentence or two, not in boldface, telling you what happens
as a result of the bold action — a menu opens, a dialog box pops up, a
wizard appears, you win the lottery, whatever.
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A primary convention used in this book is that I've tried to make the step-by-
step examples as general as possible but at the same time make them spe-
cific, too. Sounds impossible, and it wasn’t easy. The idea is to give you a
specific example that you can follow while also giving you a series of steps
that you can apply directly to your own projects. In other words, [ want to
illustrate a technique but in a way that employs real-world, useful code.

In some of the examples, particularly when exploring Access 2003, I use the
Northwind sample database that comes with Office 2003. With Access run-
ning, choose Help=>Sample Databases and then select Northwind Sample
Database. If it’s not there in the Help menu, go to the Windows Control Panel,
choose Add/Remove Programs, find and click Microsoft Office, click the
Change button, and follow the instructions to install the Northwind sample
database. You'll need it, even for some programming involving other Office
2003 applications as well.

Also, note that a special symbol shows you how to navigate menus. For
example, when you see “Choose FileoNewr>Project,” you should click the
File menu, click the New submenu, and finally click the Project option.

When I display programming code, you see it in a typeface that looks like
this:

Dim pfont As Font
pfont = New Font("Times New Roman", 12)

If  mention some programming code within a regular paragraph of text, [ use
a special typeface, like this: Dim pfont As Font.

If I ask you to type something in, it shows up in bold, like this.

Find All the Code Online

Every line of code that you see in this book is available for downloading
from this book’s companion Web site at dummies.com/go/office2003dev.
Take advantage of this handy electronic version of the code by downloading
it from the Web site so that you can then just copy and paste source code
instead of typing it by hand. This will save you lots of time and help you
avoid those pesky typos.
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The Searchable UBA/VB.NET Dictionary

Also, over the years I've compiled a book-length Rosetta stone dictionary

of traditional VBA programming commands alongside their VB.NET equiva-
lents. VBA programmers can look in this Dictionary of VB.NET online for a
VBA function that they already know (such as InStr) to see how that same
job is done the VB.NET way. Even readers who are not familiar with tradi-
tional VBA will also find this searchable Appendix of use. If you want to
quickly find out, for example, how to change a property of Forml from within
Form2, search the dictionary and you get your answer. Find this dictionary
at the following Web site:

http://www.dummies.com/extras/vb_net_all_in_one_fd/

What You Need to Get Started

To use this book to the fullest, you need only one thing: a copy of Office

2003 — preferably the Professional or Enterprise versions — to take full
advantage of all the topics covered in this book. However, this book does not
require the high-end Enterprise version or even the Professional version.
The book covers what I consider the most significant topics in whatever ver-
sion you use.

Although throughout this book (and particularly Book VIII), I cover OOP in
depth, it does help to understand a few basic terms upfront. VBA program-
mers have not traditionally written classes. They use procedure-based pro-
gramming techniques, which is usually quite sufficient for many Office
programming jobs. But time marches on, and fashions arrive and fade. The
current fashion in programming is OOP, and you have to come to grips with
it. Here are some essential OOP concepts:

4 A class module is a container for OOP source code that you write in the
VBA editor. And after you define a class in your source code, when you
execute that source code (by pressing F5 or otherwise running the
code), an object comes into being. (The object is instantiated; an instance
of the object comes alive.) So class is to object as recipe is to cookie:
The class is the blueprint, the latter is the resulting thing.

4+ An object is an entity that comes into existence when you run your proj-
ect by pressing F5 or otherwise triggering the code to execute. The
object’s characteristics and behaviors are based on the description of
that object you provided in the class. For example, a UserForm becomes
an object when you press F5 and thereby execute your program.
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4+ Classes (and the objects that result from them) are primarily composed
of two types of code: properties (the object’s characteristics, like its
BackColor) and methods (the object’s behaviors, like its Show method
that makes it visible to the user). Properties are similar to traditional
variables, and methods are similar to traditional functions (or Sub pro-
cedures). Collectively, an object’s methods and properties are called
members. There’s another member, events, but let’s not go too far, too
fast.

Icons Used in This Book

\\3

Notice the eye-catching little icons in the margins of this book. They’re next
to certain paragraphs to emphasize that special information appears. Here
are the icons and their meanings:

The Tip icon points you to shortcuts and insights that save you time and
trouble.

A Warning icon aims to steer you away from dangerous situations.

A Technical Stuff icon highlights nerdy technical discussions that you can
skip if you want to. I'm not too fond of unnecessary technical stuff, so this
icon is used rarely.
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Chapter 1: Getting
with the Program

In This Chapter

v Exploring what you’ll find in this book

+* Managing menus and toolbars

1 Creating your first Office program (it’s easier than you think)
v Customizing the keyboard

v Getting programming help online

0 ver the years, Office has evolved. As the result of hundreds of focus
groups, ergonomic studies, user feedback, and hard-won experience,
the Office design teams have come up with a highly effective suite of
applications.

One of Office’s strong points over the years has been its considerable depth.
You can find literally thousands of features within the Office applications,
yet the surface that you interact with can be as smooth and simple as you
wish. You can even hide the toolbars and menu bars.

Put another way, Office applications are highly customizable. Throughout
this book, you discover ways to manage and exploit Office 2003 to take it
to a new level of efficiency. You see how to write programs that make your
work easier as well as how to build utilities that facilitate communication
between Office applications and automate other common business tasks.
I also show you hundreds of other useful techniques and tools.

Most new computers ship with Office, which is also used in nearly every
business today. What these businesses have in common is an ongoing effort
to improve their efficiency. And in many cases, developing or automating
Office applications is one of the most effective ways to increase workplace
productivity. Many workers know what they wish they could do — and this
book shows them how to do it.

Office 2003 Application Development All-in-One Desk Reference For Dummies

covers all the new features in Office 2003 and demonstrates how developers
can best exploit them. Many of these features are designed to improve work-
flow and facilitate better communication between workers — just the sort of
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goals that Office developers want to achieve. You'll find everything you need
to know to make Office 2003 an effective, valuable, and customized workplace
engine.

For example, InfoPath simplifies interaction with all kinds of data sources:
everything from unformatted lists to legacy databases. SharePoint assists
developers in building an automated collaborative environment. And
eXtensible Markup Language (XML) as well as related technologies, such as
Web Services, underlies many of the improvements in Office 2003. Among
many other topics, this book explains precisely how to take advantage of
XML'’s promise with simple, no-nonsense examples. You’ll understand exactly
how to leverage your current work and communication patterns by using the
new and powerful data sharing techniques available in Office 2003.

No significant Office topic is ignored here. Read on to discover how to use
classic but important features such as Visual Basic for Applications (VBA).
And I cover all the latest developments such as Smart Documents, Access
2003 Developer Extensions, and the new security features. Anyone interested
in building intelligent business applications will find the solutions they're
looking for here.

Modifying the User Interface

This chapter starts things off with an introduction to some relatively easy
modifications that you can make to Office 2003 applications. (No point jump-
ing immediately into the deep end of heavy-duty programming; there’s time
enough for all that in subsequent chapters.) And although these modifica-
tions are on the simpler side, some of the techniques that I describe in this
chapter are powerful, new, or both.

I show you various ways of manipulating the user interface, the surface that
you work on when using Office applications. If you're already an Office guru,
you might want to skim this chapter to search for techniques you don’t yet
know. Less-experienced readers are likely to find many ideas in this chapter
that are of immediate practical use, such as hiding a new Help feature or
modifying and editing menus.

You will find a bit of programming in this chapter, too, but it’s not very
advanced, and you’re not even expected to understand it at this point. You
can just benefit from the exercise, and you might find the results (such as
quickly turning toolbars on and off) a valuable addition to your bag of tricks.

Turning off mini help

Begin by seeing how to get rid of that new little Office 2003 Help field. It
seems as if Microsoft introduced a new, cute Help feature. Remember the
little paper clip fellow (Clippit) that started annoying many people a few
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years back? Most people find the animated Office Assistant rather bother-
some, not to mention unprofessional looking. At least it’s easy enough to
turn off that annoying paper clip by just deselecting Office Assistant on the
Help menu.

Now to get rid of that new Help field, located by default at the upper-right
corner of Office applications such as Word and Access, as you can see in
Figure 1-1.
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What I don’t like about this feature is that anyone can see your last Help
request, which could be embarrassing. Personally, [ don’t want people
seeing the kind of help that I last requested. It lets them know what I didn’t
know. Your last question stays up there for all to see, even after you’'ve
closed the Help pane. And even though there’s no obvious way to make this
little feature go away, [ know the easy secret.

Before I lead you through this example, note something important about the
Customize dialog box. When it’s open, Office 2003 applications freeze and
wait to see whether you’re modifying something. All the menus and toolbars
are loosened, so you can drag and drop items from the dialog box onto tool-
bars or remove items by dragging them off toolbars and dropping them into
the document workspace.
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Here are the steps for removing the Help field:

1. Choose Tools->Customize.
2. Click the Toolbars tab of the Customize dialog box.
3. Right-click the little Help field.
You see a check box with a check mark in it.
4. Remove the check and then close the Customize dialog box.
The discomforting little critter won’t ever advertise your personal short-

comings again.

If you want this feature back, just repeat these steps, but mark the check box
to select it.

\\3
Making this change in Word won’t get rid of the Help field in other Office
2003 applications; you have to turn it off in each application.

Modifying menus

Menus can be adjusted to suit your needs. You can move the menu bar itself
the same way that you move toolbars: Just drag the dotted line on the left or
top of the menu bar and drop the menu elsewhere on the screen. To switch
between long and short menus (short menus display only the most frequently
used options), choose Tools=>Customize=>Options, and then select the Always
Show Full Menus check box.

To modify a menu’s location on the menu bar, follow these steps:

1. Choose Tools~>Customize.

2. While the Customize dialog box is open, you're free to drag around
the menu headings on the menu bar, reorganizing them any way
you wish.

If you want to remove a menu heading entirely, drag it away from the
menu bar and drop it somewhere in the document.

Editing menus

The contents of menus can be modified, too. To modify the order of items
within a menu, follow these steps:

1. Choose Tools=>Customize.

2. In the Customize dialog box, click the Commands tab.

3. Click the Rearrange Commands button.

The Rearrange Commands dialog box opens, as shown in Figure 1-2.
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4. Select a command you want to rearrange; then click the Move Up or

Click the Modify Selection button in Figure 1-2 to rename menu items, change

their icon, and otherwise manipulate them to suit yourself, as shown in
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Creating your own menus

You can even create a new menu of your personal favorite features. Just
follow these steps:

1. Choose Tools>Customize and then click the Commands tab.
2. Click New Menu in the Categories list.

3. Drag the new menu icon from the Customize dialog box and drop it
on the menu bar.

4. Right-click the new menu to name it whatever you want.

To add commands to your new menu, click the Rearrange Commands
button. Then locate the name of your new menu in the Choose a Menu
or Toolbar to Rearrange list.

5. Click the Add button and select which features you want to include on
your new custom menu.

Customizing shortcut menus

Shortcut menus, also called context menus, are those little menus that
appear when you right-click something. In Office 2003, you can customize
these menus in Access, Word, or PowerPoint.

Although thousands of shortcut menus exist, never fear. Here’s how to add a
new command to a shortcut menu in Access. Follow these steps to add the
Help command to the default database background shortcut menu:

1. Open a database window in Access; then right-click the window to
open the default context menu, as shown in Figure 1-4.
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Modifying the User Interface

2. Choose Tools=>Customize.
3. Click the Toolbars tab.
4. Select the Shortcut Menus check box.

A special shortcut toolbar appears, as you can see in Figure 1-5.

A special shortcut menu toolbar appears.
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5. From this special toolbar, choose Database->Background, as shown in

Figure 1-6.

6. Click the Commands tab of the Customize dialog box.

7. Choose the category that contains the command you want to add to

the shortcut menu.

8. Drag the command from the Commands list to the shortcut menu

(position it where you want it to appear).

9. Drop the command (release the mouse button) into the shortcut

menu, as shown in Figure 1-7.
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In this example, I add the Help feature to the shortcut menu that pops

out when I right-click the background of a database, as shown in
Figure 1-8.
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You can edit context menus in many of the same ways you edit ordinary
menus — rename, rearrange, add icons, and so on. However, you can’t add
or delete an entire context menu.

Personalizing Toolbars

\\J

You can manipulate toolbars, tailoring them to suit yourself, much the same
way you customize menus. In fact, a toolbar is simply another kind of menu.
Although toolbars are more graphic and they are always open, they're just
another way for you to trigger behaviors in Office 2003 applications. Some
people prefer menus; others consider toolbars more convenient. (You say
toe-may-toe, and | say toe-mah-toe.) As usual in Office, how you work is largely
up to you, as long as you know how to modify the applications. After all, it’s
your work surface, so you should be able to decide where things go and how
best to manage it, just as you arrange your desk to suit yourself.

In addition to adding built-in commands (such as File=>Open), to menus
and toolbars, you can also add macros. A macro is simply a short program,
designed to work within and improve the efficiency of the application that
hosts it. (See Book I, Chapter 2.) Writing macros allows you to really take
control of the elements of an Office application and do with it what you will.
You can also add special hyperlinks, such as a link to a worksheet or work-
book in Excel or to a Web page.

Adding hyperlinks

As with menus, you modify toolbars via the Customize dialog box. Just add a
custom button, change its image (if you like), and name it. You can even turn
the button into a hyperlink. Follow these steps to see how to add a hyperlink
to CNN News to the standard Excel toolbar.
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First add the custom button:

. Choose Tools=>Customize.

Click the Commands tab in the Customize dialog box.

Click Macros in the Categories list.

SN W N~

. Drag a custom button from the Commands list and drop it on the
a\\J Standard Excel toolbar.

You don’t have to detach the Standard toolbar as it’s shown in Figure 1-9.
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Don’t worry about the smiley face default icon; you can always change this
icon by right-clicking it and choosing another graphic. In fact, try that now
(with the Custom dialog box still open from the preceding step list).

1. Right-click the smiley face and choose Change Button Image.

You get a palette of images to choose from.

2. Select the microphone image to remind you that this is CNN, which is
broadcast.

Smiley is gone, replaced with the microphone image.
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Now rename the custom buttom:

1. Right-click the new button and click the Rename option from the
context menu.

2. Rename it from Custom Button to CNN.
Finally, make the button hot (into a link):

1. Right-click the button once again and this time choose Assign
Hyperlink, and then Open, from the context menu.

The Assign Hyperlink: Open dialog box opens, as shown in Figure 1-10.

Assign Hyperlink: Open 2%
f Linik to: Text to display:
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bOOkS, Web Document Files , E b E."’.’— s
sites, and g e _
sSo on. E-mail Address o m
\J - . . . o
) Note in Figure 1-10 that you can link to various destinations: specific
cells or ranges in an Excel workbook; files; e-mail addresses; or new
documents, workbooks, Word files, or Notepad TXT files.
2. Type http://www.cnn.com into the Address field (refer to Figure 1-10).
3. Click OK.
The dialog box closes.
4. Click the Close button on the Customize dialog box.
Now try your new hyperlink. Click the microphone icon on the Standard
toolbar, and you should see CNN appear, with all the latest shocks, scandals,
and scary celebrity agony.
P Follow essentially the same steps to add links to menus instead of toolbars.

Hyperlinks can also be inserted into Excel workbooks (just right-click a cell
and choose Hyperlink from the context menu), Word documents (right-click
the document), and so on.
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Access, however, is, as usual, the odd stepchild and does things its own, dif-
ferent way. You add hyperlinks to reports, forms, and so on in Access. (It just
creates a Label control containing the link.) However, the links don’t work
in Access itself. You must output the report to Excel, HTML, Word, or some
other host before the links can actually do their job. As you’ll see throughout
this book, Access often trods a different path than other Office applications.
It appears to exist in a parallel, although similar, universe.

Vaporizing interface elements programmatically

Throughout this book, you’ll find all kinds of programming techniques that
you can use to exploit and unify Office 2003 applications. Although you’ve
not yet explored the vast VBA language built into most Office applications,
create a useful little macro right now while I'm talking about toolbars. You
don’t have to understand what’s happening in the programming at this
point: Monkey-see, monkey-do is just fine at this stage.

Many games and programs have a key you can press that removes all the
extraneous, distracting menus, help windows, gauges, and other things

from the screen. This frees you up to simply see the essentials. It’s similar to
choosing View=>Full Screen in Word: All the rulers, scroll bars, menus, and
toolbars vanish, and you see the immortal words of the document’s writer
(you) unadulterated by debris. However, note a couple of problems with Full
Screen mode in Word: You lose the scroll bars, and an annoying little bar
appears right in the document, which allows you to restore the view to
Normal mode.

Here [ show you how to write a macro to improve on Word'’s clean-screen
mode. In this macro, [ preserve the scroll bar, and you won’t need that
annoying back-to-Normal-mode bar. Instead, you just use the shortcut key
combination Alt+V to toggle Full Screen mode on and off. Simple, clean,
and — for those of us who like to type on a blank piece of “paper” without
distracting icons all over the edges — a real pleasure to use.

Programming a macro to hide a toolbar

Here’s how to write a macro to hide one or more menus and toolbars so that
you can selectively clear the screen any way you choose or toggle between
sets of toolbars/menus for different purposes.

Many people have the primary menu (File, Edit, View, and so on), and the
Standard and Formatting toolbars visible at all times while using Word.

But you use them only now and then. Most of the time, you're just typing.
Wouldn't it be nice to have a clean screen in which to type? Figures 1-11 and
1-12 show before and after examples.
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Here’s how to make distracting menus and toolbars disappear, or reappear,
every time you press the Alt+V key combination (V for vanish).

1. In Word, choose Tools->Macro-=>Macros.

2. Type Alt+V in the Name field in the Macros dialog box.

You're later going to assign this macro to the Alt+V key combination, so
it’s useful to name the macro after these keys. It helps you remember.

3. Click the Create button in the Macros dialog box.

A powerful editor opens, about which you can find more in Book Il and
other places in this book.

Your insertion cursor (the blinking, vertical line) is now located within
your AltV macro.

4. Type in the following VBA commands so that the A1tV macro (a Sub,
technically) looks like Listing 1-1.

Listing 1-1: AltV Macro

Sub ATtV()

" ATtV Macro
' Macro created 11/25/2003 by Richard

If CommandBars("Standard").Visible = True Then

CommandBars("Standard").Visible = False
CommandBars("Formatting").Visible = False

Else

CommandBars("Standard").Visible = True
CommandBars("Formatting").Visible = True

End If

End Sub

5. Close the Visual Basic editor by clicking the small X icon in the upper-
right corner.

When reviewing the code, you can ignore the lines that begin with single
quote marks. They’re simply comments that the programmer (or in this case,
VBA itself) inserted as hints or notes to the programmer. VBA ignores such
lines when executing a macro.
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You can also ignore these programming commands, but for the curious, the
above code translates into English like this: If the Standard toolbar is show-
ing, make it and the Formatting toolbar invisible or else make them both visi-
ble. And that’s just what you want. Pressing Alt+V toggles their visibility, just
the way you toggle a light switch on and off.

Usinq macros to remove menus

If you want to hide the main menu, too, you have to do things a bit differ-
ently. Menus are not part of a Menus collection but are in the CommandBars
collection. (Collections are, simply put, arrays of objects. Like arrays, collec-
tions can be manipulated programmatically in loops.) What’s more, you
can’t specify the primary menu (the one with File, Edit, View, and so on) by
name but instead must refer to it as the ActiveMenuBar. Finally, you can’t
use the Visible = False approach that works with toolbars. Instead, you
must use Enabled = False. There’s no rhyme or reason for these differ-
ences: It’s just one of the challenges faced by programmers every day.
Consistency is attempted in computer languages like VBA but is never fully
achieved. Anyway, here’s the code that you should add to the above macro
to toggle the visibility of the main menu. Insert the bold lines in the places
indicated.

If CommandBars("Standard").Visible = True Then
CommandBars("Standard").Visible = False

CommandBars("Formatting").Visible False
CommandBars.ActiveMenuBar.Enabled False

Else

CommandBars("Standard").Visible = True
CommandBars("Formatting").Visible True
CommandBars.ActiveMenuBar.Enabled True

End If

Modify this code to add any additional command bars — beyond Standard
and Formatting — that you use in Word.

Assigning the macro to hide menus and toolbars

After you program the macro to hide toolbars and menus (see the preceding
sections), all that remains is to assign this macro to the Alt+V key combina-
tion. Follow these steps:
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1. Choose Tools=Customize.

2. Click the Keyboard button at the bottom of the Customize dialog box.

3. Choose Macros in the Categories list.

A new list named Macros appears, with all your macros displayed,
including the new one you just wrote, ATtV.

&=

dialog box.

Choose AltV in the Macros list.
Click in the Press New Shortcut key field in the Customize Keyboard

The insertion cursor begins blinking in this field, ready for you to press
the key combination that will launch the A1tV macro.

0. Press Alt+V.

You are informed that Alt+V is unassigned unless you’ve already
assigned it to something previously, in which case you must decide
whether to override the previous assignment or choose a new key

combination.

7. Click the Assign button of the Customize Keyboard dialog box.

8. Click the Close button of the Customize dialog box.

Let Office do the programming

If you're unsure what commands to use when
programming in VBA, you can always try a
shortcut: Let Office do the programming for you.
Here's how. Choose Tools=>Macro=>Record
New Macro. The Record New Macro dialog
box opens. Click the OK button to begin
the recording process. Then do something —
type, click the mouse, choose menu options,
whatever — while the recorder runs and writes
programming for everything you're doing.
When you've finished, click the blue square in
the Macro Recorder toolbar to stop the record-
ing. Now press Alt+F11 (in Word) to display the
VB editor and the programming that was gen-
erated for you by the recorder. You can now
edit this code, copy and paste it into other
macraos, or just learn from it. For example, if you

choose Filec>Save while the recorder is run-
ning, you'll find the following code in the VB
editor later:

Sub Macro6()

' Macro6 Macro

' Macro recorded 11/25/2003 by
Richard
ActiveDocument.Save

End Sub

The currently visible Word document is the
ActiveDocument object. You can append a
period after this object’s name to perform vari-
ous tasks that can be accomplished with the
ActiveDocument.
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Now for the fun. Press Alt+V in Word’s Normal document view. The toolbars
disappear. Press Alt+V again, and they reappear, just as you’d hoped. You
can take this technique as far as you want, showing or hiding pretty much
whatever you want, whenever, however . . .well, you get the idea. More about
VBA in chapters to come.

If you want to go the whole way and create a macro to toggle Full Screen
mode, use the following code. (Use this instead of the code in the previous
sections, not in addition to.)

ActiveWindow.View.FullScreen = Not ActiveWindow.View.FullScreen

Customizing the Keyboard

\\J

Just as you have essentially total freedom to manipulate Office 2003 menus
and toolbars, you can also reassign keys to suit your needs. Key combina-
tions can be assigned to trigger all the features in the applications as well as
macros and other targets. These combinations are hot keys or shortcut keys.
However, when you open menus via built-in keyboard shortcuts featuring
the Alt key (such as Alt+F to open the File menu), this behavior is also called
shortcut keys or keyboard shortcuts. Never mind. Whenever you want, you can
change the classic key assignments to whatever you want.

To see the shortcut keys assigned to toolbar buttons when you pause your
mouse cursor over a button, choose Tools=>Customize and then click the
Options tab. Mark the Show ScreenTips on Toolbars and the Show Shortcut
Keys in ScreenTips check boxes to select them. Making these changes
affects the behavior of all the other Office 2003 applications. (Note: Excel
displays only the Show ScreenTips on Toolbars check box, so you can’t
make this change from Excel.)

Restoring Classic Key Behaviors

When you first start using Office 2003 Word, you might notice that several
traditional keyboard behaviors have been rather strangely altered. For exam-
ple, the Delete key has for decades been used to delete a selected block of
text. Now, when you select (drag) some text (so it reverses color, to white on
black), pressing the Delete key merely displays a little (and for most of us
who are capable typists, highly annoying) question: Delete block? No (Yes).
Repeatedly pressing the Delete key has no effect. You must also press Y to
actually perform the job that pressing the Delete key used to accomplish.
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Similarly, keys that maneuvered you through a document have been reas-
signed. You used to get to the start of a line of text by pressing the Home key.
Now you must press Home+<«. You used to be able to press Ctrl+Home to
get to the beginning of the document; now this displays the Find and Replace
dialog box, with the Go To tab selected.

If you're finding these strange behaviors, you won’t be able to remap these
keys by using the usual approach (choosing Tools=>Customize and then
clicking the Keyboard button). The Delete key is set to Edite>Clear, which is
what it’s supposed to say. It just behaves oddly.

Here is the solution: For reasons unknown, when Word is installed, it some-
times switches on the Navigation Keys for WordPerfect Users option. To fix
this and restore your familiar Word behaviors, choose Tools=>Options and
then click the General tab. Deselect the Navigation Keys for WordPerfect
Users option.

Getting Online Help

Microsoft provides extensive online help for developers and programmers,
and its Office information is no exception.

Your portal to Office 2003 help online is http://office.microsoft.com.
(You'll find a link to this site in the Office applications’ Help menu.) At this
location. you find a list of the individual Office applications and utilities.
(See the left side of Figure 1-13.)

Click the Access link, for example, and you’ll be told that in Office 2003,
you need to upgrade to Jet 4.0 if you want Access to be able to offer all its
features yet at the same time block unsafe expressions that could cause
virus-like damage.

Another useful online resource is MSDN, the Microsoft Developer Network.
Here at http://msdn.microsoft.com, you can find advanced tutorials, a
search engine, white papers, downloads, free software trials, and other often
useful items. MSDN is also a subscription service that sends out early versions
of Microsoft products, CDs full of various kinds of programmer-oriented tools,
and so on. However, you don’t have to be a subscriber to take advantage of
the wealth of information online.

If you're looking for answers to specific questions, try joining one of the
newsgroups dedicated to the various Office applications. Try this address:
http://support.microsoft.com/newsgroups/default.aspx. Then drill
down until you find the application, topic, and messages of interest to you.
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Chapter 2: Programming Lite:
Making the Most of Macros

In This Chapter

+* Knowing what you can and can’t record

1 Assigning macros to toolbars and keyboard shortcuts
v+ Viewing standard macros

v Using the Auto macros

v+ Understanding macro security

perhaps you've created macros (little programs) in an application such
as Word. (Nobody knows how macros got their name: Macro means
large, but macros are small. Whatever.)

Macros can be real timesavers, automating tasks that you perform frequently.
Macros are available for every other major Microsoft application. Even Visual
Basic .NET and the Visual Studio .NET editors now have macro capabilities.

Discovering the Pluses of Macros

You can automate and customize your applications in many ways: assigning
layout configurations to function keys, adding new shortcut keys, building
custom add-ins, creating your own wizards, modifying toolbars, and even
extending the existing menus with your own utilities.

However, for those of us who love to program, macros (also known as VBA
subs or procedures) are among the most enjoyable ways to modify how appli-
cations behave — easy, little utilities that can be quite simple to create but
are also sometimes surprisingly useful.

The most obvious reason to use a macro is to accomplish instantly what
might take you a fair amount of time to do. For example, if you find yourself
doing something repeatedly, such as having to fill out your address, create a
macro to do the job for you.
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Discovering the Pluses of Macros

The ABCs of BASIC and C

BASIC (Beginner’s All-Purpose Symbolic Instruc-
tion Code) has been around for a long time (think
mid-1960s). An early programming language, it's
the most popular, straightforward, and efficient
computer language ever invented. Prior to 1995,
most Office applications had their own, unique
version of BASIC: WordBasic, AccessBasic, and
so on. That was unfortunate, but now these spe-
cial languages have all been replaced by VBA.

It's a great relief that Microsoft had the wisdom
to use BASIC as the macro language rather
than the alternative (the crypto-mathematical,
pseudo-scientific C language and its many deriv-
atives). Had C been chosen — and doubtless

there were some programmers advocating it—
few people would bother to write macros.

Nonetheless, over the years, some aspects of
C have leaked into BASIC, most notably the
academic theory of object-oriented program-
ming (OOP). VBA is somewhat less straightfor-
ward, intuitive, and plain-English than previous
versions of BASIC such as WordBasic, which
VBA replaced. That's because 00P has moved
into VBA in various ways, adding some com-
plexities while offering some benefits as well.
But VBA will never be fully object-oriented. For
that, you must move to Visual Basic .NET.

\\J

Macros can be composed of a simple series of application commands, such
as creating a new Access database with certain parameters. Or macros can

be quite complex, involving .NET libraries and other low-level (sophisticated

programming) activities. You can read how to create complex macros in

Books Il and VIII.

In essence, a macro is a computer program. No, it’s not as large or complex
as a typical utility (such as a spell checker), but it’s a program nonetheless.
You tell the macro how to do something for you. Then, forever after, it car-
ries out your instructions flawlessly.

Although macros are just one way to write a computer program, they’re
widely used because they're efficient — both easy to create and useful. Most
commercial applications contain an embedded programming language: the
macro language. In Microsoft applications, that language is Visual Basic for

Applications (VBA).

Macros run within their applications; they can’t run if the host application
isn’t also running. However, you can build small programs by using Visual
Basic 6, VB .NET, or other languages outside of Office applications while
you’re working in any application or even just on the desktop or in Explorer.
And with a third-part utility that [ use all the time, you can even imitate the
way macros are usually launched. These outside programs can be launched
with shortcut key combinations, such as W+Tab to launch Word.
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In other words, regardless of whether any applications are running, you can Book |
launch a program, substitute text, open a document, send e-mail, go to an Chapter 2
Internet site, open a folder or Windows peripheral (such as printers, disk
drives, and so on), and even launch scripts that you write to do such things
as switching screen resolutions with a single keypress. (Script languages are
similar to regular computer languages such as BASIC, but they usually lack
the ability to directly modify or delete files on the hard drives, or other poten-
tially malicious, virus-like actions.) This Windows-wide, keyboard shortcut-
capable macro utility is available from ActiveWords (www.activewords.com),
which offers a free 60-day trial and two versions. (The more expensive

one includes the scripting feature among other enhancements.) I find this
utility indispensable.
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Recording Macros

Whenever you find yourself doing some small task repeatedly, that task is a
candidate for a macro. For example, I often need to see how many words are
in a document I'm writing in Word. [ could take the long route through the
menu system: Filec>Propertiest>Statistics. Or I could record this activity into
a macro and then simply add that macro to a toolbar, so I could see the word
count with a single click. Or I could assign that macro to a keyboard shortcut
such as Alt+W. Either way, macros make frequent tasks a snap.

Try an example. You can read in Chapter 1 how to write a macro directly —
to program it — in the Visual Basic editor. You can also record macros,
which is the simplest (but most limited) way of creating a new macro.
(However, you can’t record a macro in Access. You can write them, but you
can’t record them.)

Recording a simple Word macro

Assume that you're running a little eBay business, selling Samoan straw
dolls. Every time you write a letter to a customer, you have to type We're
hoping you enjoy your new MuNaa Doll! Remember, though, never put it in the
microwave.

This tedious, repetitive task is a perfect candidate for a macro. What’s the
point of typing those sentences over and over, day after day? The following
steps show you how to create a macro to automate the process.

1. In Word, choose Tools=>Macro=>Record New Macro.

The Record Macro dialog box appears, as shown in Figure 2-1.
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Record Macro 1%
.\_‘CT:;:;‘EHE!
-\;ﬂ\:ﬂl'\aflt o
Figure 2-1: Toctacs =
Begln Store macro in:
recording a Al Documents (Normal,dot) v
Word macro | 2essiption:
. Macro recorded 11/27/2003 by Richard
from this
dlalog box. |W]
2. In the Macro Name text box, type Closing as the name for your new
macro.
3. Decide how you want the user to activate the macro: mouse or
keyboard.
You can also opt to assign your new macro to a toolbar, but that requires
that you move your hands from the keyboard and reach for the mouse.
(Bad.) It also requires that the toolbar be visible at the time. (Double
bad.) In my view, creating a keyboard shortcut is often preferable. So,
click the Keyboard icon of the Record Macro dialog box.
The Customize Keyboard dialog box opens, as shown in Figure 2-2.
Customize Keyboard %]
Specify & command
Commands:
ﬁumd.kﬁﬁm,w
Spedify keyboard sequence
Current keys: Press new shortout key:
Alt+C
Figure 2-2:
ASS|gn your Currently assgned to: [unassigned] :
new macro Save r?hanges n: Mormal, dot ¥
Description
to a key
combination
here.

4. Click the Press New Shortcut Key field to put the blinking insertion
cursor there; then press Alt+C (or whatever other combination you
want to use).
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5. Click the Assign button and then click the Close button.

The Record Macro toolbar appears on the upper left of your document,
with a blue square (End Recording) and a red circle (Pause).

6. Type in the following text, which is what you want to automatically
insert whenever this macro is run.

We're hoping you enjoy your new MuNaa Doll! Remember, though, never
put it in the microwave.

7. Click the blue square on the Record Macro toolbar.

The toolbar disappears, and your macro is finalized.
Now whenever you press Alt+C, the text is typed in for you.

Although the macro recorder can detect mouse clicks on such things as
menu items (it sees this as simply the same as a keyboard menu selection
via Alt+keypress), some mouse behaviors can’t be correctly interpreted
(such as dragging to draw a line). So, if possible, use the keyboard when
recording a macro, especially in Excel and PowerPoint.

If a dialog box appears while you're recording a macro, note the settings dis-

played in the dialog box. Every setting will be recorded by the macro, even if
you’re merely trying to adjust one of the settings. For example, if you decide

to switch to boldface, you can open the Font dialog box by choosing Format=
Font during recording. However, all the following information (everything this
dialog box is capable of modifying) is inserted into your macro:

With Selection.Font

.Name = "Times New Roman"
.Size = 10
.Bold = True

.Italic = True

.UnderTine = wdUnderTineNone
.UnderlineColor = wdColorAutomatic
.StrikeThrough = False
.DoubleStrikeThrough = False
.Qutline = False

.Emboss = False
.Shadow = False
.Hidden = False

.SmallCaps = False
.Al1Caps = False

.Color = wdColorAutomatic
.Engrave = False
.Superscript = False
.Subscript = False
.Spacing = 0.3

Book |
Chapter 2
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Recording Macros

.Scaling = 100

.Position = 0

.Kerning = 0

.Animation =
End With

wdAnimationNone

This is fine if forcing all these parameters is your intention. However, if you
just meant to make the text you've selected boldface, you’d be better off
avoiding the dialog box altogether when recording the macro. Try using

Ctrl+B instead.

Understanding the UBA behind recorded macros

If you want to view or modify the macro you just recorded, press Alt+F11 to
open the VB editor and scroll until you find the macro named Sub Closing.

It should look like this:
Sub Closing()

Closing Macro

' Macro recorded 11/27/2003 by Richard

Selection.TypeText Text:="We're hoping you enjoy your new

MuNaa DolTl!
microwave."

End Sub

Remember, though, never put it in the

A short overview of objects

To understand .NET, Office applications’ object
models, the XML object model, and other con-
temporary programming, you need to know
about a few key qualities of objects.

You can divide computing into two broad cate-
gories: information and processing (manipulat-
ing the information). Similarly, objects are made
up of two broad categories: properties and
methods. Properties are similar to information;
properties describe an object’s characteristics,
like the format of an XML attribute (format=
ounces, for example). Methods are similar to
processing. A method is a behavior or job that
an object knows how to perform, like make a
copy of yourself. Another way to look at this

distinction is that properties are similar to what
a programmer thinks of as traditional variables,
but methods are similar to traditional functions.
Collectively, an object’s methods and properties
are known as its members.

These distinctions between object, properties,
and methods are hardly new to computer pro-
gramming, much less an invention of 0OP or
XML. Instead, they are built into reality and can
be found in the simplest childhood grammar:
“Black storm go boom!” is more than a two-
year-old's poetic description of thunder. It
reveals the fundamental nature of object/
member relationships: Black (property), storm
(object), go boom (method).
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The Selection object is not well-named. to indicate that it’s a selection. Unfortunately,
Selection, in computer terms, typically means this is not what is commonly meant by selec-
that you've dragged your mouse across textor  tionin VBA. A Selection object is merely a
held down the Shift key while using the arrow  fancy way of saying the current insertion
keys to highlight some text. The selected text cursor position (although it can also confus-
reverses to white letters on a black background  ingly mean a true, classic selection of text).

The Selection object

\\3

The lines Sub and End Sub surround all macros, and mean start here and end
here, respectively. The commands and information between those two lines
tell VBA what to do when the macro is executed. Lines that start with apos-
trophes are comments and are ignored during execution.

You can delete this macro Sub if you wish, but be sure to delete everything,
including the End Sub. Or you can modify the message by typing something
else as the text. In other words, you can directly modify the macro program-
ming in the VB editor.

What does the programming mean? It’s written in BASIC (see the sidebar,
“The ABCs of BASIC and C”). But because of the influence of OOP, instead of
simply writing Insert "This Text", as would be the case in WordBasic,
you must refer to a selection object and its TypeText method: Selection.
TypeText. Then you have to provide a Text object. (Some would call it a

property.)

Today’s programmers face the job of transitioning from classical computer
programming (typified by VBA) to the current trend of object-oriented pro-
gramming, as exemplified by VB.NET. Throughout this book, I illustrate
migration paths that you take to ease this transition if you're used to tradi-
tional Office programming techniques but now need to move beyond them
to VB.NET. If you aren’t yet familiar with the fundamental concepts of OOP
(objects and their properties, methods, and events), don’t be concerned.
You'll pick up the jargon as you go along.

Briefly, and somewhat simplified, an object can be practically anything (a vis-
ible button, single word of text, range of words, calendar utility, and so on).
An object’s properties are its qualities (such as its color, size or length, posi-
tion on the screen, and so on). An object’s methods are things that it can do,
such as a calendar object’s ability to calculate the number of days between
two dates. Events are things that can happen to an object, such as the user
clicking the object to trigger it or select it, and so on.

Book |
Chapter 2
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Using Special Macros in Access

The point is that with OOP-inflected BASIC, your programming becomes
more verbose than traditional BASIC programming as well as less clear, less
descriptive, and less easy to read and modify. The punctuation also becomes
awkward and strange (such as the : = used instead of the more sensible =).
And, c’'mon: You're simply inserting text here. Why not just use the obvious
programming (WordBasic’s version), like this?

Insert "We're hoping you enjoy your new MuNaa Doll! Remember,
though, never put it in the microwave."

The answer is that a generation of programmers has graduated from schools
that teach only the OOP way, so that’s what they tend to prefer.

Using Special Macros in Access

Although Access includes VBA, it has a separate (albeit rather awkward)
macro facility as well. However, for reasons of backward-compatibility
(surely it’s not nostalgia for ungainliness), Access retains its old macro pro-
gramming system as well as VBA. Also, Access contains a utility that can
translate legacy Access macros into VBA macros.

I don’t spend much time exploring Access macros, but you should know that
you can’t record a macro in Access. In fact, if you open the Tools=>Macro menu
in Access, all you see are three options: the VB editor, Run Macro, and Convert
Form’s Macros to Visual Basic. Form’s Macros are Access’s old-style macros:
You select various actions from a list box; when translated into VBA, these
actions become methods of the DoCmd object. In all the other Office 2003
applications, macros are what I've been describing in this chapter, namely
VBA Subs (also called procedures). However, Access (always the maverick)
requires you to explicitly request (via Toolse>Macro) that a particular Access-
style “macro” be translated into VBA.

Creating an Access macro

To create a legacy Access macro, go to the primary database window, click
the Macros option in the left pane, and then click the New button. The spe-
cial Macro window appears, as shown in Figure 2-3, from which you choose
actions from a drop-down list:
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Figure 2-3:
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Access
macros.
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Never fear, however. As you'll see in Book Il and elsewhere, you can create
whatever you need via VBA in Access perfectly well, just without the free-
dom to use a recorder to assist you.

Converting Access-style macros to UBA

If you do have legacy Access macros that you want to convert to VBA — so
you can edit them along with your other, newer Access macros — follow
these steps:

1. Click the Macros option in the Objects pane of the database window.

Your macros are listed.

2. Click the name of the macro you want to convert.

3. Choose Filer>Save As.
The Save As dialog box opens.
Choose Module in the lower text box.
Click OK.

6. Choose Convert in the Convert Macro dialog box.

o=

Working with Auto Macros

Word, Excel, PowerPoint, and Outlook each permit you to use a special type
of macro. If you use special names when naming a macro, the macro is han-
dled in a special way by VBA. These special macro names begin with Auto

Book |
Chapter 2
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50 Working with Auto Macros

and other special, reserved names. Office applications recognize that such
macros must be executed in response to events that happen while the appli-
cation is executing. In fact, in OOP, these macros would actually be called
events.

The most useful Auto macros are

4+ AutoExec: This executes when you first start the application running
(or also if you load a global template in Word).

4+ AutoNew: This executes each time you create a new document, work-
book, or presentation.

4+ AutoOpen: This executes any time you open an existing document,
workbook, or presentation.

4+ AutoClose: This executes every time you close a document, workbook,
or presentation.

4+ AutoExit: This executes when you shut down the application (or also if
you unload a global template in Word).

Auto macros are useful if you need to do some housekeeping before an
application runs or a document loads (such as loading in the last two
documents you worked on, or calculating the latest sales tax). Other
housekeeping — such as saving a special backup file — might need to be
done during document or application shutdown.

Word includes several specialized Auto events, but you will probably need
to use only AutoOpen and AutoClose (put these in a Normal module),
Document_0Open, Document_Close, and Document_New.

Excel also offers a variety of Auto macros — New Sheet, Sheet Activate, and
so on — but the spelling is a bit different. (AutoOpen becomes Auto_0Open,
for example). Press Alt+F11 to get to the Excel VBA editor and then look in
the Project Explorer for Name.Personal . x1s. Double-click this entry and
choose Modules, Modulel. You're now in Modulel of your Personal Macro
Workbook. Choose Insert=>Procedure. You see the Add Procedure dialog
box. Type Auto_Open in the Name field. Click OK.

Access does permit a limited Auto event facility, but you cannot use VBA. You
must use that early macro legacy technology that Access (alone among Office
applications) includes. Search Access help for AutoExec to find instructions.
Outlook uses this format:

Private Sub Application_Startup()
End Sub
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PowerPoint wants you to put any Auto macros in a class module. Beyond Book |
that, you must trigger the macros from a code in a different location. I don’t Chapter 2
have time or space or patience to outline the unnecessarily convoluted
process to execute PowerPoint events, but if you must do it, search
PowerPoint Help for Application Events.

If the user holds down the Shift key, Auto macros are blocked and will not
execute. Also, you might have a macro that creates new documents, which
would, therefore, trigger the Document_New macro. If you want to block the
Document_New event from triggering in your programming, use this code:

A\
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WordBasic.DisableAutoMacros

Dealing with Macro Security Issues:
What You Need to Know

The struggle to achieve computer security is doomed. It’s impossible to
completely secure a computer, just like it’s impossible to build a car that
can’t crash, you cannot completely secure a computer. (You could secure
a computer or car by encasing them in cement and then burying them in a
salt mine, but then they’d no longer do their jobs.)

Of course, you know that your computer can delete files: Just right-click a
filename in Window Explorer, and then choose Delete from the shortcut
menu. However, if a file can be deleted, a virus can potentially delete it, too.
Or reformat an entire hard drive, or use your computer to launch blizzards
of span, and so on.

All you can do is minimize the risks; you can’t eliminate them. Similarly,
macros are executable programs, albeit small programs. And therefore, they
can be used for good, or ill.

Administrators (and if you work on a personal computer at home, you should
be the administrator) are people who are permitted to do everything to
modify how Windows behaves. They can hide files from other users, change
passwords, adjust security settings, and make many other modifications.

Administrators can specify how macros behave, as well as any other exe-
cutable code located in documents, presentations, templates, workbooks,
and most objects attached to these various elements via linking or other
techniques. (Remember that objects are famous for including not merely
data, but also executable code — known as methods — that can act upon
that data.)
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Dealing with Macro Security Issues: What You Need to Know

Windows has various kinds of built-in security. In XP, an administrator can
assign levels of “trust” to various different users. (For example, some are not
allowed to delete files, for example). In addition, the .NET languages have
built-in security features. Office 2003 applications contain their own kinds of
security. As you see, there are layers upon layers of security measures.

By far, the most effective security that you can personally achieve is to take
these relatively simple steps:

4+ Make frequent backups. This prevents a file-deleting virus attack from
doing much harm.

4+ Install a firewall like Zone Alarm. This blocks (so invaders from the
Internet will be blocked, and spyware can’t send secret messages out
from your machine).

4 Set your macro security level to High.

4+ Simply refuse to install software from unknown sources. This includes
opening e-mail attachments.

Microsoft recommends the following additional safety measures: “run up-to-
date antivirus software on your computer; clear the Trust All Installed Add-ins
and Templates check box (described below); use digital signatures; maintain
a list of trusted publishers.” To me, these are fine precautions if you want to
take them, but personally I've never found much use for anti-virus software
because it interferes with some software installation processes (even though
you trust the source); it exacts a speed penalty; it’s a hassle to continually
update it with the latest versions; and if you take the steps I suggest at the
start of this tip, it’s not necessary.

When your macro security settings are set to High, macros created by you
are trusted, as are other sources of executables (runnable programs) that
you can specify. However, nothing prevents a virus author from posing as
you. Somewhere in the computer, a macro’s author is identified — and iden-
tity theft is not impossible; indeed it’s rather common.

VeriSign (www.verisign.com)— and other sources such as Microsoft’s own
Authenticode technology — attempts to ensure security by verifying the
origin of software via digital signatures. A digital signature usually does two
things

4+ Certification: They certify that the sender of a message or the author of
a piece of code (like a macro) is who he says he is.

In this sense, digital signatures are like a driver’s license.
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4+ Verification: The other job they perform is to verify that the message or
code has not been modified after the author signed it.

In other words, you can rely on the message to be accurate, or the code
to be benign.

Technically, an electronic signature is usually generated by hashing a public
key, which is, itself, encrypted using an associated private key. The terms hash
and public/private key pairs are explained in detail in Book VIII, Chapter 8§, if
this topic is of interest to you and you want to try programming using these
technologies.

Digital signatures are better than nothing, but viruses can imitate signatures,
just as people can put on police uniforms as a disguise. Likewise, they might
get caught relatively quickly but not before they’ve done some damage.

You can also self-certify your own macros. Choose Start=>All Programs from
the Windows toolbar, and then choose Microsoft Office=>Microsoft Office
Toolse>Digital Certificate for VBA Projects. In the dialog box that opens, type
in whatever name you want to use for your personal certification. Note that
this is a pretty weak certification process. (Not that any of them are com-
pletely secure.) This self-certification is kind of like issuing yourself a home-
made driver’s license — it’s not likely to impress the sheriff. It works on your
computer, but if your programming is run on a different machine, a warning
message appears. Commercial certificate issuing companies can revoke their
certificates, if necessary, and can trace signatures back to their origin. Neither
of these capabilities are available when you self-certify.

If you want to digitally sign your own macros for use on other computers,
choose Toolsw>Digital Signature in the VBA editor. (You have to sign up with
VeriSign or another vendor before this will work. Prices vary depending on
the size of your business and other factors. Contact VeriSign sales for details
at 866-893-6565.)

Adjusting macro settings

To see your current Office 2003 macro security settings, choose Tools=>
Macro=>Security. You see the Security dialog box, where you can adjust the
levels of macro security. By default, security is set to High, as shown in
Figure 2-4.

The macro security settings (Toolst>Macrow>Security) work as follows:

Low

Anything goes! Live dangerously, hellzapoppin’! Every macro or eXtensible
Stylesheet Language (XSL) script file can do whatever it will. This is crazy
and dangerous. Nobody should use this setting.
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Figure 2-4:
Set macro
security
here.

Security 2

{Security Level || Trusted Publshers

() Very High. Only macros instaled in trusted locations wil be alowed
to run. All other signed and unsigned maoros are dissbled.

‘53) High. Only signed macros from trusted sources will be alowed to
run. Unsigned macros are automaticaly disabled,

() Medium, You can choose whether or not to run potentially unsafe
macos.

() Low [not recommended}. You are not protected from potentially
unsafe macros. Use this setting only if you have virus scanning
software irstalled, or you have chedeed the safety of 8l documents
you open.

(e

Medium

For unsigned macros, the user is shown a dialog box requesting permission
to run this macro. Signed macros are first examined to see the quality of the
digital signature.

4+ A signature from a trusted source and by a trusted digital signature com-
pany (such as VeriSign) executes automatically.

4+ A valid source but by an unrecognized author displays the permission
dialog box.

4+ An invalid signature causes the macro to be disabled and the user to be
warned.

4+ A ssignature that can’t be verified or certificate (validation method) that
has expired displays a dialog box and requests user permission to
execute.

High
This setting is similar to Medium except that
4 No dialog box is shown for unsigned macros.

4 Network administrators can lock the list of trusted sources so that users
can’t accidentally add new (but nasty) trusted sources.

4+ In all additional situations, macros are summarily disabled, along with
dialog boxes displaying warnings.

Although I'm the administrator on my personal machine, this is the setting
[ use.



Figure 2-5:
Here's how
to disable all
macros
entirely.
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Very High

New in Office 2003, this most conservative setting disables all Smart Tag
DLLs, COM add-ins, and any macros not from trusted locations. DLLs are
dynamic link libraries (collections of executable code, loaded as needed by
applications: hence, the term dynamic). COM add-ins are similar to macros,
but they are sometimes larger, utility-size programs and are written and exe-
cute outside of documents or worksheets. Add-ins can also be used to glob-
ally change the behavior — or add functionality — to several Office 2003
applications simultaneously and automatically. What’s more, add-ins execute
more quickly than the typical macro.

You build an add-in for yourself using .NET (see Book VIII, Chapter 1). To pre-
vent any macros from running on a particular computer, choose Tools=>
Macro=>Security, click the Trusted Sources tab, and deselect the Trust All
Installed Add-ins and Templates check box, as shown in Figure 2-5:

Security B[]

security Level || Trusted Pubishers|

Izsued To Issued By Expk... | Friendly Name
| Google, Inc. VeriSign Com...  10/10...  <None>

[Cltrust al installed add-ns and templates
mrus! access to Wisual Basic Project

|
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Different Office 2003 applications display different options in the Security
settings. And, always the odd stepsister of the Office system, Access 2003
doesn’t offer the Very High option, although all other Office 2003 applica-
tions do.

Triggering trouble

No matter what settings you choose for the macro security feature in
Office 2003, other sources of potential damage lurk. In early versions, VBA
was VBScript, which was a language without such potentially dangerous
capabilities as file deletion. However, VBA does have FileSystemObject.
DeleteFileand FileSystemObject.DeleteFolder commands. What’s
more, Word documents and Excel workbooks can execute code from within
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.NET assemblies. This execution ignores any security settings within the
dialog box shown in Figure 2-4: .NET security is managed by the .NET frame-
work itself.

You can avoid .NET assembly code execution from within Office 2003 appli-
cations by removing any _AssemblylLocation0 or _AssemblyNameQ proper-
ties from a document (or template) or workbook’s list of custom document
properties. To do so, choose Filem>Properties~>Custom.

Alternatively, you can handle the problem from within .NET itself by deleting
a .NET assembly’s associated code group from the computer or by modifying
code group properties by using the Code Access Security Policy Tool or the
Microsoft .NET Framework Configuration tool. For information on this tactic,
see the Microsoft .NET Framework Developer’s Guide that comes with Visual
Studio .NET. These are rather drastic steps, however.

Office 2003 includes a new capability to scan XML files to see whether any
references to XSL exist, which can contain executable scripts. If the macro
security level is set to High or Very High, all scripts are disabled. With the
security at Medium, the user is prompted to decide whether to permit the
script to execute. Set macro security to Low, of course, and Office allows
any scripts to execute and also invites angry ex-cons to your house for
Thanksgiving dinner.

Setting security for your needs

Here’s how to achieve whatever level of security you want:

4+ To prevent all executables from running: Disable the Trust All Installed
Add-ins and Templates option and set the macro security level to Very
High.

4+ To prevent all executables from running, other than those from a
trusted location: Enable the Trust All Installed Add-ins and Templates
option and set the macro security level to Very High.

4+ To allow trusted signed executables to run automatically: Set the
macro security level to Medium or High.

4+ To prevent unsigned executables from running: Set the macro security
level to High.

4+ To display a prompt to users to see whether they want to allow an
untrusted executable to run: Set the macro security level to High.

4+ To display a prompt to users to see whether they want to allow any
executable to run: Set the macro security level to Medium.

4+ To allow all executables to run with no prompt: Set the macro security
level to Low.
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Administrators can set these levels for an entire office by using these vari-
ous approaches:

4 Custom Maintenance Wizard
4+ Office Profile Wizard

4 Custom Installation Wizard
4 Group Policy snap-in

A snap-in is a utility that can be added to a Microsoft Management
Console (MMCO).

The Office 2003 Editions Resource Kit Tools can be downloaded from

http://www.microsoft.com/downloads/details.aspx?familyid=
4bb7cb10-a6e5-4334-8925-3bcf308cfbaf&displaylang=en

This resource kit is a set of utilities and information. It includes the Custom
Maintenance Wizard (and the CMW File Viewer), Office Profile Wizard, Custom
Installation Wizard, Policy Template files, customizable alerts, HTML Help
Workshop, international information, Office Converter Pack, Office informa-
tion, Outlook Administrator Pack, Package Definition Files, MST File Viewer,
and OPS File Viewer.

The Group Policy allows administrators to specify and govern how network
resources, applications, and the operating system itself will behave. The
administrator can configure security settings for domains, computers, and
individual users by manipulating the MMC. To open the MMC, choose Starte>
Run. In the Open field, type mmec. Click OK to launch the console. To get fur-
ther information on using snap-ins, choose Action=>Help in the MMC.

Book |
Chapter 2

S0IOR) JO
Jsojn ay) Bunjely
:a)1 Builwwesfory



58  Bookl: Office 2003 Essentials



Chapter 3: What's New in 2003?

In This Chapter

1 Seeing an overview of task panes

v Introducing Document Workspaces
v Discovering OneNote
v Joining the XML revolution

1~ Discovering the redesigned Outlook

M any users and developers are upgrading from previous versions of
Office to Office 2003. Perhaps you’ve been using Office XP or even

Office 2000, and you’re wondering what the primary new features are in
Office 2003 and how they can be used to your advantage. If so, this chapter’s
for you.

On the user interface level, Smart Tags and task panes are more in evidence
in Office 2003, and Outlook has undergone quite major changes. However,
many Office applications should seem pretty much as you remember them.
A quick look at the surface of Office 2003 will seem rather familiar, but you'll
soon discover significant changes under the hood, where we programmers
spend most of our time.

For example, Office 2003 emphasizes interoffice communications in two
major ways: communication between office workers, and communication
between Office applications.

In fact, Microsoft is no longer calling the Office applications a suite. Instead,
it’s now the Microsoft Office System. This new terminology suggests that you
should consider Office a kind of special network, with lots of improvements
designed to assist the flow of data among workers. No longer are Office
applications merely isolated, individual applications running on separate,
self-contained computers. Instead, there is a great push to integrate the
system into a client-server network. After all, how many company docu-
ments are generated by one person working alone?

Throughout this book, you'll find lots of examples showing how to exploit
Office’s new collaborative features. In this chapter, [ take you on a brief
introductory tour of some of the major new tools and utilities in Office 2003.
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Opening Task Panes

Opening Task Panes

Figure 3-1:
Alt+click a
word for a
list of ency-
clopedia
articles.

In various Office 2003 applications, you see a pane (a zone within a window)
open up, usually on the right side, as shown in Figure 3-1. These panes have
never been used as extensively as they now are in Office 2003, although
they’ve been around for several years. For example, in many XP applications,
the Help system opens a pane on the right side of the application.

In Office 2003, task panes are frequently used to provide context-sensitive
links, templates, help, and various other kinds of information. These panes
pop up in various ways: if the user clicks certain words, loads an XML-based
document, works on a shared document, opens a new document, chooses
ViewroTask Pane, and several other actions.

For example, if you need to do research, be sure to check out the new
Research task pane. Just hold down the Alt key while clicking a word in a
document, and the Encarta encyclopedia pops open in the Research pane,
as shown in Figure 3-1.
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In addition, you can open the All Reference Books list box to see various the-
sauri, translation services, and other research sites.
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To see research for an entire phrase, highlight it before Alt+clicking it.

Security: Adjusting Permissions and Protections

Figure 3-2:
Specify here
how widely
this docu-
ment can be
distributed
or viewed.

All the new collaborative features of Office 2003 are welcome, but sometimes
too much collaboration isn’t a good thing. For example, the accounting
department gets to look at everyone’s salary, but fights would undoubtedly
break out around the water cooler if the whole office could see just who'’s
being slighted and who'’s rolling in cash.

Each Office application now has a Permission item on its File menu, as
shown in Figure 3-2. And you’ll also find various other options, such as the
Protection option on the Excel Tools menu or the Protect Document option
on the Word Tools menu.
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4 \Documents and Set, .. \Top 20 Stories This Wisek.cov

Exit

One new security aspect is Information Rights Management (IRM). With this,
you can decide to mark documents so they can’t be forwarded, copied, or
printed. Of course, forbidding copying or printing can be a rather weak secu-
rity feature, given that (although the PrintScreen key is disabled) third-party
utilities can still copy a document as a graphic that can then be merrily for-
warded, copied, or printed.
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SharePoint Everywhere

You can also specify an expiration date on a document as well as lock docu-
ments (or parts of documents) from modification. If an organization prefers
not to use IRM, it can use the Passport system (Microsoft’s authentication

system, permitting quick and easy log on/password entry and verification).

SharePoint Everywhere

a\\S

To streamline and improve workflow, Office 2003 is designed to work suc-
cessfully with SharePoint. With SharePoint, anyone in an office, or indeed an
entire distributed company, can easily collaborate with others to produce
documents, diagrams, presentations, or whatever other computer-based
task is required.

To this end, a core SharePoint portal hosts newsgroup-like discussions, links,
database features such as disconnected recordsets drawn from the corpo-
rate database, files of all types, annotated multimedia content, and so on.
Making all this more effective is that you're not called upon to use special
utilities to communicate, with all the inconvenience and copying and pasting
that implies. You don’t need to open an Internet browser to e-mail a para-
graph from a Word document to a colleague. You can hold a chat discussion
or show someone part of a Word document right from within Word itself,

via the Shared Workspace task pane. You can invite others into a Shared
Workspace session by using the instant messaging feature of Microsoft
Office Live Communications Server 2003.

To use Office 2003’s collaboration features, you need to install on your
server either Windows Server 2003 (which includes SharePoint and costs
around $1,000 for five clients) or the SharePoint Portal Server 2003, which
costs $3,999 and $71 per user. Client computers can simply install Office
2003 itself.

Sharing with Document Workspaces

A Document Workspace site is a SharePoint Services site devoted to allowing
colleagues to collaborate efficiently on a document (or set of related docu-
ments). It’s similar to the idea behind other project management utilities
that permit people to check out documents and then update the common
copy of those documents in the shared library.

You can use the Shared Workspace task pane to launch a Document
Workspace in Office 2003 Word, Excel, PowerPoint, or Visio. After you
choose Tools>Shared Workspace in one of these applications, the Shared
Workspace Task pane appears, as shown in Figure 3-3.



Figure 3-3:
Here's a
way to
create a
new Shared
Workspace.
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Introducing One Note

If vou are a reporter or someone else who takes a lot of notes, you’ll
doubtless be impressed by Microsoft OneNote 2003 —a new, slick note-taking
program. It offers an interesting interface, integrating a variety of note bits
and pieces into a single, sasilv searched. location. You can create outlines.
simple test notes, formatted text, graphics, pasted items from Web pages, or
drawings.

Alas, like some other satellite utilities such as Visio and FrontPage, the
Office 2003 suite does not include OneNote (even the high-dollar Enterprise
version doesn’t have it). With current rebates, you can find it at the time of
this writing for around 380,

]
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In other words, use Document Workspace to facilitate intelligent merging
and solve version-control problems when documents are worked on by
groups. You know, how do you know which version contains everyone’s
latest modifications? Use SharePoint to handle this version problem for you
by permitting designated users read-only access to a document that you
(feel the power) can freely edit. Or you could choose to let everyone in your
group see the changes that you’re making in real-time if you wish.

Cool factor: Perhaps the most interesting aspect of this feature is that it
mimics a group of workers standing around a table, simultaneously modify-
ing a document. To prevent version collisions when two people try to edit
the same word, when anyone makes a change, everyone else’s mouse pointer
disappears. The final version of the document is then saved to the SharePoint
server after the collaborators have agreed on the changes. Explore these
concepts in more depth in Book VII, Chapter 8.
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Introducing OneNote

Introducing OneNote
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If you're a reporter, office worker, or anyone who takes a lot of notes, you’ll
doubtless be impressed by the new, slick note-taking program, Microsoft
OneNote 2003. Featuring an interesting interface, it can integrate a variety of
note bits and pieces into a single, easily searched, location. You can create
outlines, simple test notes, formatted text, graphics, pasted items from Web
pages, or drawings. OneNote can even include handwritten notes, diagrams,
and audio snippets (synchronized to your other notes), providing you with
very convenient ways to organize and retrieve disparate kinds of information.

OneNote offers many of the other formatting features of Word, but it’s specif-
ically designed for quick organization and easy retrieval, including sections,
tabs, running heads, specifying which notes are particularly important (by
using note flags: icons such as stars, question marks, and check boxes), and
other visual aids to help put notes in order systematically. You don’t even
have to remember to explicitly save a note: After you create a note, it’s auto-
matically saved for you. Also, cutting and pasting can be avoided because
you can e-mail and otherwise access the Internet directly from within
OneNote itself.

Think of OneNote as an electronic briefcase full of miscellaneous items:
diagrams, handwritten notes, audiotape snippets, and so on. You want to
accomplish two primary objectives with this collection of items. First, you
want to be able to organize them efficiently. Second, at some point, you're
likely to want to combine some of them into an actual document to show
others. Both of these needs are thoughtfully and effectively met as a result
of all Microsoft’s efforts to make the product anticipate your researching,
searching, and document-generating needs and behaviors.

Alas, like some other satellite utilities such as Visio and FrontPage, the Office
2003 suite does not include OneNote. (Even the high-dollar Enterprise ver-
sion doesn’t have it.) With current rebates, you can buy OneNote at the time
of this writing for around $80.

XML under Everything

As with most Microsoft products — such as Visual Studio — Office 2003
rests on eXtensible Markup Language (XML). XML is a daughter language of
HyperText Markup Language (HTML), which is a communication scheme
becoming increasingly popular as a way to send messages over the Internet
(among other uses).
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Markup languages

XML shares HTML's inability to compute. They
are fundamentally markup languages: that is,
they're used to describe how things look or
how information should be arranged but are not
themselves capable of processing information.
Information processing is the definition of com-
puting; however, by themselves, languages such

as HTML and XML can’t even add 2 + 2. (A
derivative language, XSL or XML transforms,
however, can include executable script. Other
derivative languages can perform various doc-
ument editing functions. XML itself, though, is
by definition merely structured data with no
processing capability.)

XML'’s primary benefit for Office 2003 users is that it offers yet one more way
to avoid having to use the Clipboard for copying and pasting information —
or worse, copying data by hand. XML permits you to automate the process
of transferring data between applications or between a data store (a data-
base, or perhaps another place where data is stored, like a list) and an
application.

Using InfoPath with Word

New in Office 2003, InfoPath offers you a way to create templates that take
data from a database and change it into forms that can be added to your cor-
porate database. InfoPath — unlike the rest of Office — stores data directly
as XML. InfoPath can be used by itself, but it’s especially valuable as a tool
to connect front-end users to back-end data stores. You can build forms
where users enter, view, or modify data, and the data store — and perhaps

a set of proprietary, legacy user-input interfaces — remain invisible to the
user. InfoPath can be a significant part of any Office 2003 data-related system.
And, of course, XML is now also available to all Office 2003 applications, if
not as directly as it is to InfoPath.

For example, after translating a table in a Word document into an XML file,
it’s then relatively easy to automatically flow that data into an Access data-
base (or indeed, any other kind of database). XML deconstructs data into
the famous self-describing format and then reconstructs it according to the
rules of the target.

To put it another way: When you choose Filer>Save As and then select Save
As Type XML document, the process of translating a spreadsheet, database
table, or Word document separates the formatting from the raw data. The

formatting is preserved. An italicized word, for example, gets a tag pair like
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these — <italic>identifying</italic> — that is indeed italic. However, if

the data is sent to a target application where italics are not available as part
of the presentation, the italic tags are ignored. In other words, formatting is

not lost, but it can be recast if the recipient application prefers to display

it — or otherwise manipulate it — a different way.

Here’s how it all looks. Suppose you enter a recipe into a Word table and then
send that table to a co-worker or store it in a database. The Word table is
translated first into XML format, with each element delimited (surrounded)
by tags describing the raw data inside those tags:

<?xml version="1.0"7>

<recipes>
<{recipe>
<name>Paste</name>
<cook>Mrs. Sprud</cook>
{date>2/12/03</date>
{size format="ounces">14</size>
<recipe>

<ingredients>
<dry>flour</dry>
<wet>water</wet>
</ingredients>
</recipes>

Using InfoPath with Excel

Here’s an example showing how InfoPath can be used with Excel. Data that
you type into an Excel spreadsheet doesn’t always remain in the classic Excel
format. Instead, like everywhere else in Office 2003, the data can become XML.
The advantage here is that the time-honored and terribly inefficient process
of printing out a hardcopy of an Excel spreadsheet and then having someone
type that data into a database or report is no longer necessary. The connec-
tion between Excel and the database becomes possible via XML’s universal
data format.

Another time factor, too, is improved by XML. Because Excel data can

now appear immediately in various structures, formats, applications, and
reports, people all over the organization can see various views of data right
away. They don’t have to wait until it’s retyped or otherwise massaged

into a different format via some cumbersome process. XML offers instant
communication.
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Figure 3-4 shows a sample Excel spreadsheet that [ saved in an XML spread- Book |
sheet format: Chapter 3
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To save data in XML in Excel, choose File>Save As and then change the
Save As Type selection at the bottom of the Save As dialog box to XML
Spreadsheet (*.xml). When you look at this file (it’s in plain, unformatted
text, as XML usually is), it describes the data in the classic <tag></end tag>
format and includes considerable redundancy (for clarity when this data is
translated into the target format). In Listing 3-1 is part of the XML file gener-
ated from the spreadsheet in Figure 3-4:

Listing 3-1: XML Generated by the Spreadsheet Data Shown in Figure 3-4

</Row>
<Row ss:StylelD="s41">

<Cell ss:StylelD="s42"><Data ss:Type="String">Mortgage or rent</Data></Cell>
<Cell ss:StylelID="s43"><Data ss:Type="Number">1000</Data></Cell>

<{Cell ss:StylelD="s43"><Data ss:Type="Number">1000</Data></Cell>

<Cell ss:StylelD="s44" ss:Formula="=RC[-2]-RC[-1]"><Data

ss:Type="Number">0</Data></Cell>
<Cell ss:StylelID="s39"/>
<Cell ss:MergeAcross="1" ss:MergeDown="1" ss:StylelD="m18355140"><Data
ss:Type="String">Actual Monthly Income</Data></Cell>
</Row>
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{Row ss:StylelD="s41">
<Cell ss:StylelD="s42"><Data ss:Type="String">Second mortgage or
rent</Data></Cell>
<Cell ss:StylelD="s43"><Data ss:Type="Number">0</Data></Cell>
<Cell ss:StylelD="s43"><Data ss:Type="Number">0</Data></Cell>
<Cell ss:StylelD="s44" ss:Formula="=RC[-2]-RC[-11"><Data
ss:Type="Number">0</Data></Cell>
<Cell ss:StylelD="s39"/>
</Row>
<Row ss:StylelD="s41">
<Cell ss:StylelD="s42"><Data ss:Type="String">Phone</Data></Cell>
<Cell ss:StylelD="s43"><Data ss:Type="Number">54</Data></Cell>
<Cell ss:StylelD="s43"><Data ss:Type="Number">100</Data></Cell>
<Cell ss:StylelD="s44" ss:Formula="=RC[-2]-RC[-1]"><Data ss:Type="Number">-
46</Data></Cell>
<Cell ss:StylelID="s39"/>
<Cell ss:StylelD="s45"><Data ss:Type="String">Income 1</Data></Cell>
<Cell ss:StylelD="s43"><Data ss:Type="Number">4000</Data></Cell>
</Row>

Excel also has a feature that translates and saves spreadsheets in an XML
data format that’s more like a traditional database table than the XML
spreadsheet format above with its cell identifiers and other spreadsheet-
specific tags.

Checking Out Outlook’s New Features

Outlook has been considerably improved. It’s a hotbed of collaborative fea-
tures, as you would expect. For one thing, you can now look at two calendars
at the same time. This is the sort of thing that people do in their offices all
the time, reconciling their personal day planner or PDA with their wall calen-
dar, for example, or comparing their schedule with a co-worker’s.

Several years ago the Microsoft Office team must have sat down and said:
“What do people do in offices a lot that we’re not offering in Office?” The
result is the many collaboration features supported by the SharePoint engine
as well as many individual touches like Outlook’s dual calendars.

In Outlook and Visio, you can send files as shared attachments, and a
Document Workspace site can be automatically created for you, named after
the attached document. You specify the SharePoint site where your new site
is to reside. This action makes you the default Document Workspace admin-
istrator, and the recipients of your e-mail attachment (who are members

of the contributor site group) become members of this new Document
Workspace.
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Among the many other new team-centric features in Outlook, when you
attach a document to an e-mail, you see a pane open with many options, as
shown in Figure 3-5. One notable new option is the suggestion that you might
not want to e-mail the attachment in the traditional way but instead use the
Shared Attachment feature. If you choose this option, the document is
placed into a shared workspace rather than sent to individual client
computers.
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Chapter 1: The Basics of Office
Development with VUBA

In This Chapter

v Using the IDE

v Introducing the Object Browser

+ Understanding objects and collections

+» Employing events

In this chapter, you orient yourself to the Visual Basic for Applications
(VBA) editor, also known as the Visual Basic editor or IDE (Integrated
Design Environment or Integrated Development Environment).

Although the VBA editor isn’t the powerhouse development environment
available in the Visual Studio IDE, the VBA editor is nonetheless full of useful
tools, a mature and effective Help system, and other features that help move
your programs from idea to finished product. This chapter also explores the
Object Browser utility and examines objects themselves (their uses, collec-
tions, and events).

Discovering the IDE

To get started with the grand tour of the editor, press Alt+F11 and behold
the Visual Basic editor, as shown in Figure 1-1.

For now, you can close the Properties window, the Project Explorer pane,
and any other windows that are visible, except the normal (Normal.dot)
macros window, as shown in Figure 1-1.

Here you get to do some real programming. You can use VBA to create
macros, but it’s also a very powerful language in its own right. The common
use of the term macro suggests a limited series of commands, similar to those
of the old AccessBasic language, but don’t be misled: VBA is full of commands
and capabilities. Indeed, its capabilities exceed those needed for many macro
tasks, but Microsoft figured why not just go whole hog and give us everything
we could possibly ever want?
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Figure 1-1:
This editor
sits on top
of the VBA
engine,
providing
you with
high-level
tools.
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End Sub

Public 3ub ChangeFcnz()

In fact, both VBA and VB.NET (VBA's likely successor as the Office applica-
tion development language) give you access to many thousands of program-
ming commands, and most of them have multiple variations: You can use
each command in various ways. Remembering all the commands and their
variations would be impossible for most of us, so in this chapter, I show you
how to find help quickly when programming in BASIC.

Navigating the Complex UBA Vocabulary

Over the years, BASIC source code has grown far more complex. Visual Basic
(VB) Version 1 in 1991 had a vocabulary of approximately 350 words. When
VB made its first, tentative moves toward object-oriented programming
(OOP) in version 4, the vocabulary began to balloon. Now, in VBA and
VB.NET, the lid has blown off: You can program with thousands of objects,
and each of them can have dozens of members (methods, properties, and
events). Each of these members can include yet more diction (various argu-
ments). The total vocabulary now available to the VBA programmer is many
thousands of words. For example, when you use VBA in Word, you're not
only accessing all the VBA commands but also the thousands of Word
objects and all their properties and methods.

How are you going to remember all these commands and their grammar?
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Using AutoListMembers and parameter info

Fortunately, you don’t have to remember all the properties and methods
(known as the object’s members). Always at your service is the Help feature,
which continues to improve with each new version of Visual Basic.

Also, Microsoft has IntelliSense features — AutolListMembers and parame-
ter info — that pop up while you're writing your source code, listing all the
members. And then after you choose a member, all that member’s parame-
ters are listed, too. This list displays the number, names, and data types of
both required and optional parameters used by a function, template, or
attribute.

Displaying a reminder

Whenever possible in this book, the examples will kill two birds with one
stone. They illustrate a technique, but they’re also useful in their own

right. (You discover how to do something actually worth doing rather

than its underlying theory.) In this example, [ show you how to use the
AutolistMembers feature and also see how to display reminder or comment
messages to users in the title bar of Office applications. This is less obtru-
sive than a message box as a way of communicating with users: They don’t
have to close the message box before continuing with their work.

For some of the code examples in this book, you need to make sure that the
Office Object Library is available (is referenced) by the VBA editor. Press
Alt+F11 to open the Word VBA editor and choose Toolsw>References. Ensure
that the check box next to Microsoft Office 11.0 Object Library is marked.

Now follow these steps:

1. Run Word and press Alt+F11.
The Visual Basic editor opens.
2. In the editor, choose Insert>Procedure.
The Add Procedure dialog box opens.
3. Type ChangeTitle as the name for your new procedure.
4. Click OK.

The dialog box closes, and a new, empty Sub procedure appears, waiting
for you to insert some programming.

Public Sub ChangeTitle()

End Sub
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Figure 1-2:
Here's one
kind of
automatic
Help list that
VBA
displays.

You want to add Remember to Save! to the title bar at the top of the cur-
rent Word document(s). Most Office applications have an object that
represents them. Not surprisingly, it’s the AppTication object. Like
most objects, it has lots of properties and methods, including a Caption
property that affects what you see on the title bar. To see one kind of
AutolistMembers feature, type this line just below the PubTic Sub
line:

Dim App As

As soon as you finish typing the word As, a list of objects appears, as
shown in Figure 1-2.

4 Normal - NewMacros (Code) S

[(Genera =] [chargetite

e

5. Type the following lines, ending with a period after the word app.,

like this:
Public Sub ChangeTitle()

Dim app As Application
Set app = Application

app.
Don’t worry about the strange Dim and Set redundancy. I explain those
commands shortly in the upcoming section, “Instantiation woes.”

As soon as you type the period following app, the AutoListMembers
window opens, showing you all the properties and methods available
to the Word Application object, as shown in Figure 1-3.



Figure 1-3:
An object’s
members
are all listed
here for you
to choose
from.

Figure 1-4:
This small
argument
list Help
feature is
AutoQuick
Info.
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Fublic 3Sub ChangeTitle()

Dim app As Application

Set app = Epplication

app.
28 CapsLock -
25 [Caption !
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% CheckGrammar
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6. Scroll down in the list with the down-arrow key until you highlight
the Caption property; then press Enter.

The Caption property is inserted into your source code, and the list
disappears.

N

Finish the line by assigning your text message to the Caption
property, as in the following:

app.Caption = "Remember to Save!"

8. Just below the line you entered in Step 7, type MsgBox and press the
spacebar.

As soon as you press the spacebar, a list of the arguments available
to the MsgBox (message box) command is displayed. This handy
AutoQuickInfo feature, as shown in Figure 1-4, reminds you of the
required arguments, the optional arguments shown in brackets, and
the order of the arguments.

HsgBox |
WsgBox(Prompr, [Buttons As VhMsgBoxStle = vbOROnl], [Tite], [HelpFig], [Contexl]) As VhMsgBorResult
End Sub

9. Complete your little macro procedure by assigning text to the mes-
sage box prompt.
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Your entire macro should look like this:
Public Sub ChangeTitle()

Dim app As Application
Set app = Application

app.Caption = "Remember to Save!"
MsgBox ("Done.")
End Sub

10. With your blinking insertion cursor somewhere inside the new
ChangeTitle procedure in the VBA editor, press F5 to execute and
test the macro.

When you look at Word'’s title bar now, you should see the name of the
currently opened document, followed by the message Remember to
Save!

Using the Object Browser

Some people like to use the VBA Object Browser utility instead of (or in addi-
tion to) the IntelliSense features. Press F2 to see the Object Browser, as shown
in Figure 1-5.

4y Object Browser B[E)[%]
<Al Libraries= =] 4l Belw g
Seare Resulls
Libirary Clags | Member |

Classas Warmbars of Tlocument

Figure 1-5:
Find the
class
names and
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of objects
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browser.
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& ClosePrintPrevew
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Click the various classes in the left pane to see the members of the objects
that interest you. Figure 1-5 illustrates the Document Close event that I dis-
cuss at the end of this chapter. Of course, you do run into the old paradox
from time to time: How do you look up a word in the dictionary if you don’t
know how to spell it? You might have a tough time finding what you’re look-
ing for in Help, the Object Browser, or the IntelliSense features. I don’t know
of any solution to this problem other than memorizing the necessary names
for important, but strangely named, classes.

Understanding Objects

What, you might well ask, is an object? Simply, objects are items like message Chapter 1
boxes, but lots of other things are called objects, too, as you'll soon see.

Truth be told, everything in today’s programming languages is an object — g
even a lowly integer is an object in VB.NET. < Sw
= D

=0 2

If everything is an object, is there any meaning to the concept object? Does z.g @
the term object have any value in categorizing things? Good questions, 2 35
friend. But you're getting ahead of yourself. 2 g
[x]

(-]

To try to get a sense of what an object is, first ask this question: How does
an object differ from a traditional variable? An object is more powerful and
sophisticated; some objects are like self-contained mini-programs (quite
mini). A variable contains a value: a single piece of data. An object, on the
other hand, usually contains several pieces of data, sometimes arranged in

a hierarchy. Some of an object’s data are known as its properties, such as a
document’s typeface style, called its FontName property. Another piece of
data, its FontColor property, specifies a graphic that is displayed within the
button.

In addition to its data, an object also usually includes programming: that is,
things it knows how to do with its data (or data passed to it), such as a Word
document object’s Add method, which adds a new Word document to the
current collection of open documents. An object’s programming is known as
its methods.

All the currently open documents in a Word application are, collectively,
considered an object (technically a collection, but with all the features of an
object, such as methods and properties). And, each document within the
documents collection is itself an object. So you can have objects nested
within other objects. (For more on collections, see the sidebar, “Objects
versus collections.”)
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Objects versus collections

Take a look at this little Word macro to under- is often just a simple array, with index numbers
stand the relationship between objects and so you can access each member of the col-
collections: lection, such as FontNames(2). Then you

Sub ShowFonts () use the InsertAfter methoq of the Range

Documents . Add object to type the variable s into the newly
created blank document, followed by two car-
riage returns. (vbCr imitates what happens
when the user presses Enter.) Finally, you use
the For Each command to step through the
entire FontNames collection, typing in the
name of each font name. Try typing this macro
into the VBA editor, and then pressing F5 with
your blinking insertion cursor inside the macro
text to run it.

s = "You have these " &
FontNames.Count & " fonts
you can use:"

ActiveDocument.Range.
InsertAfter s & vbCr & vbCr

For Each afont In FontNames

ActiveDocument.Range. Most applications have collections that can
InsertAfter afont & ", " provide you with useful information that might
Next afont be important during program execution. Here's
an example that tells you how many tables are

End Sub in an Access database:

Here you use the Add method of the Sub infoAccess()
Documents collection to create a new blank

document. It's the same behavior as if the With Application.CurrentData
user had chosen Filec>Newr>Blank Document, s = "This database has " &
but here, you're accomplishing that job .A11Tables.Count & "
programmatically. tables.”
Then you compose a text string (s) incorporat- . Mgz s
ing the Count property of the FontNames col- End With
lection. It tells you how many typefaces are

End Sub

available to you. They're in an array. A collection

Finally, objects can (but don’t necessarily) have events, which are places

for a programmer to define how the object behaves in the event that some
outside action happens to that object, such as an Excel workbook object’s
BeforeClose event. In this case, when a user attempts to close a workbook,
your macro can respond to that event by putting up a message box that reads
Would you like to back up your work? The workbook’s BeforeClose
event can contain optional programming that you insert into the event to
display the message box.
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To summarize: An object can have properties (qualities), methods (abilities),
and events (responses). Together, this entire group of features is known as
the object’s members.

Also note that an object can (but doesn’t necessarily) include a visible user
interface. For example, a Button object has a visible user interface, but a
Timer component does not. Some objects just do math calculations or
search for a particular name in a database, but other objects display the
results of that calculation or that search to the user or invite the user to
modify the object’s data.

However, don’t get the idea that objects are limited to components like

buttons or text boxes. True, all components are objects, but not all objects c::::;:l1
are components. Some objects that you program with are located inside
applications — like the workbook object in Excel and other objects that you =
create within your programs for your own purposes. = ;
S=o
Objects can be used in two main ways when programming in VBA. First, you = % é
can take advantage of the many objects available in the Office 2003 applica- §-§ e,
tions. This is useful. Second, you can create your own objects for program- - 1:”_ =
ming purposes in VBA. Generally speaking, this is not useful. It’s overkill 3

unless you’re creating a large, complex project or programming in a group
(where such features as OOP’s encapsulation assist in helping people avoid
stepping on each other’s code).

Should You Go Fully O0P?

Some programmers believe that all Visual Basic programs — indeed all com-
puter programs — should be written with OOP. I'm not one of them. I feel
that objects are most useful with large, complex programs, or when you're
writing a program with other programmers as a group effort. Some people
also advocate OOP for all programs because they claim that you can easily
reuse objects in future programs.

It is true that programming with objects forces you to follow some strict
rules that can help avoid problems commonly encountered when group-
programming, working with complex applications, or reusing code. However,
smaller, simpler applications generally don’t benefit from most OOP tech-
niques, and macros (of course) individually need not be made into classes
to be useful — that would be dreadful overkill.
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For macros and small utilities — the primary use of VBA — OOP imposes

a superstructure more sophisticated and heavy-handed than is called for.
What’s more, VBA still employs outdated programming techniques for
instantiation, property procedures, and so on. Unless you have a compelling
reason to employ OOP, you're better off with classic structured (procedure-
oriented) programming in VBA.

If you've never been exposed to OOP, you might find the following para-
graphs helpful. I show you some of what OOP can do for you, should you
need to use it.

Encapsulation

Perhaps the primary benefit of OOP is encapsulation, which means that an
object doesn’t permit outside programming to directly manipulate its data.
(In programming terms, this means that none of the encapsulated object’s
variables should be declared Pub1ic. They’re all Private or declared with
some other self-application-only scope.)

Any properties that you want to permit outsiders (source code that uses the
object) to read (query) or set (change) can be exposed to those outsiders in
a special way: by using property procedures. The outside code must contact
these procedures, and then the procedures in turn deal directly with the
object’s data. It’s rather like having someone answer the phone for you — to
run interference in case you don’t want to accept the call. The outside code
doesn’t get to manipulate an object’s actual data directly. This allows you
(the programmer) to validate that incoming behaviors, properties, or other
data are proper and won'’t cause problems for your encapsulated objects.

To illustrate the idea of encapsulation, first create an object (a class). It has
a Private (encapsulated) string variable. It can’t, therefore, be changed, or
even accessed for viewing by outsiders (any code outside the class itself,
such as a macro that activates the class). For comparison, the object also
includes a Pub1ic variable that outsiders can modify. Follow these steps to
create the object:

1. In the Word VBA editor, choose Insert~>Class Module.
A new window appears, with a default initialize method (Sub).

You can view this Sub by opening the drop-down list in the upper-left
corner of the Class code window and choosing Class. This Sub Class_
Initialization method is carried out every time the class is instanti-
ated (brought into being) by being accessed from code inside a macro.
Initialization is similar to the traditional Visual Basic Form_Load event:
the place a programmer usually writes any code that has to execute
before the user interacts with the form (such as loading in some data).
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You can ignore this Sub by writing no programming inside it if you don’t
need to do any housekeeping during initialization. (There’s also a termi-
nate method for handling any necessary tasks when the object is about
to be destroyed.)

lillustrate how a class in VBA works, though, by displaying some
messages.

. By default, your new class is named Class1l. Move your insertion

cursor up to the top of the Classl editor window and type in the fol-
lowing private variable:

Private m_OutsideMessage As String

This Private property can’t be accessed directly from code outside the
class itself.

. Now just below that, type in the Property procedure:

Public Property Let TheMessage(ByVal s As String)
If Len(s) > 10 Then 'validate
MsgBox ("ERROR. LIMIT 10 characters.™")
Else
Let m_OutsideMessage = s
End If
End Property

This property is Pub1ic, so it can be accessed from outside the class,
but the string passed from the outside is validated. In this case, if it’s
greater than ten characters, the outside code is warned. If it passes
the test, you assign the outsider’s string to the private property
m_OutsideMessage. It’s traditional to prepend an m or m_ to private
property names, as I did here.

. Inside the Initialize method, type this:

Private Sub Class_Initialize()
s = "Initializing..."
MsgBox (s)

End Sub

The purpose of this method is just to indicate when the initialization
takes place by displaying a message.

. Finally, type this to create a method that the outside code can access.

Public Sub QurClass()
MsgBox (m_OutsideMessage)

End Sub
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Just asa Public Property is a property of an object, a PubTic Sub
is a method of an object. This method displays the Private property
m_OutsideMessage, showing that the user’s string was correctly
assigned. The entire class should look like Figure 1-6.

& Normal - Classt (Code) 5]
[Class =| |mitialize

b

Private m CursideMessage As String

Public Propsrty Let TheMessage (ByVal = As Scring)
If Len(s} » 10 Then 'wvalidate
MagBox (MERROR. LINIT 10 characters.’)
Else
Let m_CutzideMessage = =
End If
End Property

Private Sub Claas3_Initialize()

2 = "Initializing..."
—— MegBox (=]
Flg_ur_e 1-6: P
Thls IS the Public Sub Ourcl 1]

L c A urClass

VBA class
edltor H=gBox (m_OutsideMessage)
window. Erid S -

=4l O

To test your new macro, go to the Normal New Macros window (where most
of your ordinary Word macros are). If it’s not visible, press Ctrl+R to see the
Project Explorer (see Figure 1-6), choose Normal=>Modules, and then double-
click New Macros. Now type in this new macro to test your class, as follows:

Sub TestClass()

Dim o As Classl 'create object variable
Set o = New Classl 'assign object variable

0.TheMessage = "Hi, Bobbi!"
0.0urClass

End Sub

The first two lines of code within this Sub instantiate the object (that you
just created as C1ass1). Then, using the object variable 0f fice, you send a
message to the object’s TheMessage property. Finally, you request that the
object’s OurClass method be exectued.
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Instantiation woes

You must first instantiate the object before you can access its public mem-
bers. The approach shown in the previous section — using Dim and then

Set and then New commands — is not only cumbersome, but it’s technically
indefensible. It simply makes little sense and is highly redundant. Fortunately,
VB.NET has simplified the process of instantiating objects, and presumably
VBA will eventually adopt the superior approach. But for now. . . .

The code works like this: After you create your object variable o, you
then assign the object variable to point to your C1ass1. Then you set the
message property with o. TheMessage and display the message with the

0.0urClass method. Book Il
Chapter 1
Press F5 to run the TestClass macro to see how it instantiates, and then —
employs, the class. &
Sw

: , £33
Class modules in VBA never have a user interface. (You choose Insert= s25
UserForm to add user interfaces to your VBA programming.) When you want §'§ 2
a class to do some computing that doesn’t require a user interface, choose a > e o
class module. -
(-]

Using Events

The Word Document object includes a variety of events, as do the primary
objects in Excel, Access, and other applications. Events are behaviors, like
methods, but they’re not hard-wired into an object. Instead, outside pro-
grammers can write code that goes inside an event that executes when the
event itself is triggered. For example, many objects have a C11ck event that
triggers whenever a user clicks the mouse on the object.

In this example, you display a reminder to anyone who closes the current
document that a copy of the document needs to be sent to a co-worker.
Follow these steps:

1. Run Word.

2. Open a document file.

3. Press Alt+F11.

The VBA editor opens.
4. Press Ctrl+R.

The Project Explorer opens, showing all macros, references and other
items associated with the currently running application.
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5. Locate the name of your currently open document in the Project
Explorer window.

6. Locate and then double-click ThisDocument under the currently open
document title (in boldface, Project (Document name)), as shown in
Figure 1-7.

— | project - Project %
Figure 1-7: 235l P
H s = 5' normal (Normal)
ClICk Th1 S =] 3 Microsoft Word Objects
Document ] Tristocument
=I5 Forms
under the H teatarat
B8 userForm2
currently L e Modics
¥} AttachTemplate
ope_n 22 MewMacros
Project <] 3 Class Moduies
&) dass1
(document), - 3 Project (Bk0201)
not under - Miuoi_a_.‘i d Objects
Normal 41 References
+ &% Project (P_TOAUX)
As soon as you double-click, you see a code window for the
ThisDocument object, as shown in Figure 1-8.
(21570676 BKOZ01_AR m - ThisDocument (Code) S]]
I[Iacumcm ﬂ Close :J
Private Jub Document Close() c:?:?-e q
iopan I
M=gBox ("Rememioer to send this IllFSyﬁc
Flgure 1-8: End Sub xmtézﬁxlm
Use the two
drop-down
lists at the
top of this
code
window to
choose
Document
from the left
list, and
Close from
the right list. ~|
== qlm| 4P|

The list box on the right in Figure 1-8 contains the available events that
are built into the document object. You chose the C10se event.
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7. Type the following into the Close event:

MsgBox ("Remember to send this file to Suzanne when it's finished.")
8. Now return to Word and close the current document.

Your message is displayed before the Word document closes.
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Chapter 2: Managing Data

In This Chapter

v+~ Using variables and arrays
v+~ Handling operators and expressions

v+ Understanding scope

f you're an experienced BASIC programmer, you can skip this chapter
because it’s too elementary for you. In fact, the next few chapters cover
the fundamentals of VBA programming, which you perhaps already know.

However, if you're coming to BASIC (Visual Basic for Applications, the ver-
sion of BASIC used in Office) from a different language, you’ll want to at least
read the parts that explain the variable types available, the various opera-
tors, and how BASIC handles scope (a variable’s range, or duration, of
influence).

Understanding Variables

I start from the beginning by explaining what variables do in computer pro-
gramming. You create variables for the same reason that you might have a
manila envelope on your desk with VISA written on it. Each month, when
you get your new bill, you replace last month’s bill with the latest bill. In
other words, the envelope always contains your current Visa charge card
balance.

The amount that you owe varies from month to month — hence the term
variable. If someone asks about your current balance, you could just hand
her the envelope. In other words, the envelope named VISA contains the
current data about your credit card account. In a computer program, you
can use variables the same way: the variable’s name takes the place of the
number that it contains. For example

MsgBox 214.15

displays the number 214.15. The same number would be displayed if you
instead assigned that number to a variable (like currentbill) and then
used the variable’s name in the code rather than the literal number, like this:

currentbill = 214.15
MsgBox currentbill
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This code also displays the number 214.15. After you create a variable in a
running program, the computer’s memory contains the variable’s name
along with its current contents (called the variable’s value), which is the
information that this variable holds. Later, the program might change the
contents of the variable so a new value would be held by that variable. The
value in a variable can vary, which is where it gets its name. A constant is
similar, but as its name suggests, its value does not vary:

Const ReagansWife = "Nancy"
The distinction isn’t really too significant, and constants are used much. In
fact, if you were writing a program involving Ms. Spears, I'd strongly advise

that you use a variable in that case:

BritneysHusband = "?"

Creating Variables

You can create a variable by assigning data to it, as in the earlier example:
currentbill = 214.15

This is an implicit declaration because you haven’t specified a variable type:
You let BASIC worry about the type of variable that you're creating. BASIC is
smart enough to know that if you use quotation marks around your data, it’s
a text variable (a string), as in

MyName = "Richard"

Or, in the case of the Visa-bill example, you're assigning a fractional number,
so BASIC knows that 214.15 should be a floating-point numeric variable.

BASIC is also smart enough to know how to perform implicit conversions in
many situations — that is, it can change a variable’s type from, say, numeric
to string. An implicit conversion happened in the example earlier in this
chapter. The MsgBox function displays string variables — not numeric vari-
ables. However, BASIC created a floating-point variable when you assigned it
the fractional number 214.15:

currentbill = 214.15

Then, when you later use that variable with the MsgBox function, BASIC auto-
matically translates it into a string variable:

MsgBox currentbill
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Any time you use implicit declaration, BASIC simultaneously creates the vari-
able’s name (the label you want to give it, such as currentbil1), assigns
your data to that variable, and then assigns it an indeterminate type called
the variant type, which is capable of changing into various kinds of data
types as needed. The Variant type has been removed from VB.NET
(because of the rounding problems and other kinds of errors it can introduce
when the context in which it’s used is ambiguous) and will likely disappear
from Office programming as well in the future. The rounding error problem
occurs when a variant changes to a less precise data type. For example, a
double precision floating point data type can be quite precise because it per-
mits such a small fractional portion — so many digits to the right of the deci-
mal point, like this: 1.79769313486232. However, were that converted to a

. .. . . Book II
single precision data type, rounding would occur because the single only per- Chapter 2
mits this many decimal places: 1.402823. If a high degree of accuracy were
required — such as during laser surgery — rounding off decimal places
could be catastrophic. §
=
P Also, note that your program’s users never see variables’ names. You use é
those variable names when writing your program, so it’s helpful to give your =
variables names that mean something to you. Most programmers give vari- g

ables names that help them to understand the meaning of the contents
of those variables. A variable named X is less helpful than one named
MyVisaBi11l when you later read, test, or modify your program.

You can use any name you want when creating a variable except the name of
a word that itself VBA uses, like Print or Show or End. VBA tells you if you
make this error; it won’t allow you to assign a value to one of these reserved
words.

Explicit Uariable Declaration and Data Types

Some languages don’t permit implicit declaration or conversion. You can
also force VBA to refuse to execute a program or macro if a variable isn’t
explicitly declared by typing Option Explicit at the top of your code window.

One reason for insisting on explicit declaration is that sometimes errors can
be caused by BASIC’s attempts to figure out what variable type you intend.
Also, when variables are explicitly declared, BASIC can catch a particular
type of programming error: namely, a typo where you incorrectly typed in
the variable name (curretbill instead of currentbilT1, for example).
Without Option Explicit turned on, your program would execute with no
error messages when you used curretbill — and that could easily cause a
mysterious and hard-to-track-down bug.
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Never send a rocket to Tempe

Here's why NASA engineers must be explicit
when declaring or converting variable types. A
floating-point data type (which might hold a
value such as 12.335) should not be permit-
ted to automatically (that is, implicitly via
BASIC's best guess) convert to an Integer
data type because the conversion would
strip off the .335 fractional portion of the
number. Integers have no decimal point, and
BASIC converts decimals to integers by trun-
cating the fraction. Of course, stripping off
that . 335 is insignificant in many kinds of

programming — for example, when calculating
calories in a diet program. But when you're cal-
culating a rocket’s trajectory, every fraction
must be accounted for. You might send the
moon shot to Tempe, Arizona instead of its
intended target.

What about the other way around? Is automatic
conversion of an integer into a floating-point
type permitted? Yes, because that type of con-
version is safe; it merely increases the preci-
sion of the number.

With Option Explicit in force, it’s not enough to simply assign a datum
(some value) to a variable; you must formally declare the variable name and

also declare its type as well:

Dim MyName As String
MyName = "Richard"

Also, implicit conversion isn’t allowed in some languages. If you want to
display a numeric variable in a text box or message box, you must formally
and explicitly transform (also called casting, or coercing) the variable from
a numeric to a text variable type. Here’s an example. When converting one

type into another type — such as changing a floating-point numeric type into
a String type — you specifically do that transforming in your source code:

Sub Vars()

Dim currentbill As Single 'this is a floating point data type
currentbill = 214.15

Dim bill1String As String
bil11String = CStr(currentbill)
MsgBox bill1String

End Sub

In this example, two variables are explicitly declared, and their types are
defined. Then the CStr (convert to string) function is used to transform the
floating-point numeric type variable currentbil1 into a string so that it can
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be assigned to the string variable bi11String. Of the various ways to shorten
this code, [ wanted to show you the full monty so you could see the various
steps. It can be shortened by doing the conversion directly before passing
the data to the message box, like this:

Sub Vars()

Dim currentbill As Single
currentbill = 214.15

MsgBox CStr(currentbill)

End Sub Book Il

Chapter 2
VBA lets you declare variables as one of the following data types: Boolean,
Byte, Integer, Long, Currency, Single (afloating point data type with less
precision — fewer digits to the right of the decimal point — than the Double
floating point type), Double, Date, String (for variable-length strings),
String * length (for fixed-length strings), Object, or Variant. The details
and specifications for each of these types are described in Table 2-5, later in
this chapter.

ejeq huibeuepy

Whether you turn on the Option Explicit feature is your decision. If
you’re working for NASA, calculating orbital velocities, you’d better turn

it on and force yourself to be explicit. You don’t want a moon shot heading
off-course. If you're just writing a little geography quiz program for Junior,
however, [ wouldn’t worry too much about explicit declaration.

Using Operators and Expressions

Variables can interact with each other. Here’s one example:

Donkeys 15
Monkeys 3
TotalAnimals = Donkeys + Monkeys

In other words, you can use the variable names as if they were the same as
the contents of the variables. If you write Monkeys = 3, you assign the value
3 to the word Monkeys. You can thereafter use Monkeys just as you would
use the number 3:

TotalAnimals = Donkeys + Monkeys
The preceding line is the same as the following:

TotalAnimals = Donkeys + 3
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Using Operators and Expressions

When you combine variables on the same programming line and make them
interact, you're using an expression. Here’s how it works: If someone tells
you that she has a coupon for $1 off a $15 Mozart CD, you immediately think
$14. In the same way, VBA reduces the several items linked into an expres-
sion into its simplest form.

A numeric expression means anything that represents or results in a single
number. Strictly speaking, the numeric expression evaluates into a single
number (or true or false, which is another way of saying 1 or 0, the

binary numbers).

When an intelligent entity hears an expression, the entity collapses that
expression into its simplest form. In plain English, if you type 15 - 1 into
one of your programs, Visual Basic reduces that group of symbols — that
expression — to a single number: 14. Visual Basic simply evaluates what
you've written and uses it in the program as the essence of what you are
trying to say.

We humans always reduce things, too. Sometimes we call it intuition;, some-
times we call it putting two and two together. But we routinely reduce compli-
cated expressions or ideas to their simpler forms, their essence.

5 * 3 is a numeric expression, and as far as BASIC is concerned, 5 * 3 is just
another way of expressing 15 (a single number). 5 * 3 collapses into 15 inside
the program and is essentially that single number.

You can combine many kinds of numeric entities into expressions. Any com-
bination of any of the following entities is acceptable in a numeric expression:
4 A numeric variable.
4 A numeric variable in an array.
4+ A function that returns a number.
4+ Aliteral number. (12 is a literal number, as opposed to a variable.)

Print Sqr(12) 'Titeral number
Print Sqr(N) 'Variable

4 A numeric constant, like Const Pi = 3.14159265358979.

4+ Any combination of literal and variable numbers.
Print X + 14
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Any combination of the preceding examples that can evaluate to a single
numeric value is an expression. An expression is made up of two or more of
the preceding items connected by one or more operators. For example, the
plus symbol in 2 + 2 is an operator. Altogether, there are 23 different opera-
tors. (I get to operators shortly in the following section.)

Testing True or False

An expression can be evaluated by Visual Basic as either 0 (False) or not 0
(True). See how this works:

BobsAge = 33
BettysAge = 27
If BobsAge > BettysAge Then Print "He's Older"

BobsAge > BettysAge is an expression making the assertion that BobsAge
is greater than BettysAge. The greater-than (>) symbol is one of several rela-
tional operators. Visual Basic looks at the variables BobsAge and BettysAge
and at the relational operator (see Table 2-1) that combines them into

the expression. VB then determines whether the expression is True. The
If...Then structure bases its actions on the truth or falsity of the expression.

Table 2-1 Relational Comparison Operators
Operator Means This

< Less than

<= Less than or equal to

> Greater than

>= Greater than or equal to

<> Not equal

= Equal

Is Do two object variables refer to the same object?
Like Pattern matching* (see upcoming example)

*The Like pattern-matching operator works like this:

Sub LikeTest()

X = "Farina"

If X Like "F*a" Then MsgBox "Yes, like!"
End Sub

Book Il
Chapter 2
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The patterns are case-sensitive, so "f*a" in the above L1ike example would
fail: that is, would not be true and the message box would not display. Here
are the Like patterns that you can use:

4 ?: Any single character. ("BETTYboohoo" Like "B?T*")

4 *:Zero or more characters.

4+ ik Any single digit (0-9). ("a2a" Like "affa")

4 [charlist]: Any single character in charlist. ("F" Like "[A-Z1")
4+ [lcharlist]: Any single character notin charlist. ("F" Like "[!A-

Z]1") (This returns False.)

Note: You can use the relational operators with text as well. When used with
literal text (or text variables), the operators refer to the alphabetization qual-
ities of the text, with Andy being “less than” Anne.

The relational operators make comparisons, and the result of that compari-
son is always True or False.

Usmq arlthmetlc opemtors

Just like relational operators make comparisons based on such criteria as
less than and greater than, the arithmetic operators (as shown in Table 2-2)
describe mathematical relationships, such as multiplication.

Table 2-2 Arithmetic Operators

Operator ~ Means This

" Exponentiation (the number multiplied by itself: 5 A 2 is 25, and 5 A 3 is 125).
- Negation (negative numbers, such as —25).

* Multiplication.

/ Division.

\ Integer division (division with no remainder, no fraction, no floating-point

decimal point: 8\ 6 is 1. Integer division is easier, and the computer performs
it faster than regular division).

Mod Modulo arithmetic.
+ Addition.
- Subtraction.

& String concatenation.
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Dividing the Mod way

The modulo (Mod) operator gives you any
remainder after a division but not the results of
the division itself. This operation is useful when
you want to know whether some number
divides evenly into another number. That way,
you could do things at intervals. If you wanted
to print the page number in bold on every
fifth page, for example, you could enter the
following:

If PageNumber Mod 5 = 0 Then
FontBold = True

Else
FontBold

End If

0

If this program were to check each page
number in turn, the results of the expression at
the beginning would look something like this:

15 Mod 5 resultsin 0.
16 Mod 5resultsin 1.
17 Mod 5 resultsin 2.
20 Mod 5 resultsin 0 again.

Combining Variant variables

Variant variables can be combined in a way that is similar to how tradi-
tional text variables are concatenated:

A = "This":B = "That":MsgBox (A & B)

results in ThisThat.

When adding numbers, use the + operator. When adding (concatenating)

text, use the & operator:

MsgBox (A & B)

When you use variants (recall that unless you specify otherwise, VBA
defaults to the Variant data type):

X =5:a = "This"
MsgBox (x & a)

results in 5This.

Book I
Chapter 2

ejeq huibeuepy



98

Using Operators and Expressions

Variants are in an indeterminate state, like Schrédinger’s Cat, until they are
used. For example, if you add two Integer variable types, you get an over-
flow error if the result is larger than 32767, which is the biggest number that
a variable of Integer type can hold:

Dim x As Integer, y As Integer

x = 32760
y =22

X =X +y
MsgBox x

results in Overflow Error.

The TypeName command can tell you what subtype a variant currently is.
Notice in the following code how the variant variable x changes from an
Integer type into a Long type to accommodate the addition that results in
a number greater than an integer can hold:

Sub Vars()

x = 32760

MsgBox TypeName(x)
y =22

X =X +y

MsgBox x

MsgBox (TypeName(x))

End Sub

results in Integer, 32782, Long.

Using logical operators

Logical operators (as shown in Table 2-3) are rather specialized and not too
often used in most programming. They compare two entities, resulting in
True or False. For example, you can use the logical operator And to see
whether two conditions are true, like this:

X =12: Y = 22
If X > 0 And Y > 0 Then MsgBox "true"

This evaluates to True, and the message is displayed because both
expressions — X is greater than zero and Y is greater than 0 — are true.
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Table 2-3 Logical Operators

Operator Means This

Not Logical negation

And And

Or Inclusive Or

XOR Either but not both

Eqv Equivalent

Imp Implication —firstitem False or second item True

In practice, you'll likely need to use only Not, And, XOR, and Or from among
the logical operators. These four operators work pretty much the way they

do in English:

If5+2=40r 6+ 6 =12 Then MsgBox "One of them is true."

Understanding XOR

For years, a number of respected journals pub-
lished articles on computer encryption that
suggested using the binary operation XOR.
XOR remains widely used in computer-based
encryption because XOR has the pleasant fea-
ture that it toggles things. XOR a character
once, and itis changed into another character;
XOR this new character, and it is restored back
to the original.

XOR does this to bits:
0XOR0=0
0XOR1=1
1X0R0=1
1X0R1=0

In computers, the letters of the alphabet are
already in the ASCII code (or the double-byte
Unicode). Each letter has a numeric equivalent;
in ASCII code, capital A is 65, B is 66, and so on.
That's already one level of substitution. Now,
when you XOR capital A with something, you

get another number. But XOR it with what? The
thing that you use to make substitutions unique
is a key. This obviously helps “mess up” the
original because using a different key will pro-
duce different patterns in the resulting
encrypted document.

For example, if you XOR the characters RM
against the key it, you get the symbols ;9.

If you then XOR the encrypted text (;9), you
restore the original text: RM.

In effect, XOR is a black box that you can feed
an original into and get a garbled result. Then
feed that garbled resultinto XOR a second time,
and you get back the original text. Sounds like
a perfect way to encrypt and then decrypt a
message, right?

You can go both ways with this same little box.
For this reason, XOR was widely used as the
basis for computer encryption. It has fallen out
of favor, however, because this type of encryp-
tion is too easily cracked.

Book Il
Chapter 2

ejeq huibeuepy



100 Using Operators and Expressions

Because one of these expressions is True, the message box will be dis-
played. Remember that with the Or operator, only one or the other needs
to be True.

If5+2=4And 6 + 6 = 12 Then MsgBox "Both of them are
true."

As before, only one expression is true. This makes the And operator evaluate
to False, so nothing is displayed. Both expressions (the first and the second)
must be True for the message box to be displayed.

Use the XOR operator to change an individual bit within a number without
affecting the other bits. XOR has been used for some crude, easily solved
encryption schemes. There was a time when people actually thought XOR
was a useful computer encryption tool.

Operator precedence

When you use more than one operator in an expression, you have to be
aware that operators follow an order of precedence. In other words, some
operators are executed before others, without regard to their physical posi-
tion in a line of code. In simple terms, you sometimes need to specify which
operator should be evaluated first in an expression.

For instance, multiplication might need to be carried out before addition. To
illustrate the importance of operator precedence, try this example:

MsgBox (10 + 5 * 3)

Does this mean to first add 10 + 5 (getting 15) and then multiply that by 3 for
a final result of 45? (Thank you for playing, Contestant Number 1.) Or does it
mean to multiply 5 * 3 (getting 15) and then add 10 for a final result of 25?
(Contestant Number 2 wins the vacation to Hawaii.) You see the ambiguity
here. Expressions are not necessarily evaluated by the computer from left to
right. Left-to-right evaluation in this example results in 45, which is incorrect.

To make sure that you get the results you intend when using more than one
operator, the simplest approach is to just use parentheses to enclose those
items you want evaluated first. For example, if you intend to add 10 and 5
and then multiply that result by 3, write the expression like this:

MsgBox (10 + 5) * 3

By enclosing the addition operation in parentheses, you tell VBA that you
want the enclosed items to be considered a single value and to be evaluated
before anything else happens.
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In complicated expressions, you can even nest parentheses to make clear
which items are to be calculated in which order, like this:

MsgBox 3 * ((9 + 1) + 5)

This expression adds 9 and 1 (getting 10), which is then added to 5 (getting
15), which is multiplied by 3 (getting, finally, 45). If you work with numbers a
great deal, you might want to memorize the following table. However, most
people just use parentheses and forget about this precedence order.

Table 2-4 shows the order in which VB will evaluate an expression, from first
evaluated to last:

Table 2-4 Arithmetic Operators in Order of Precedence

Operator Means This

A Exponents. (6 A 2 is 36. The number is multiplied by itself x number of times.)

- Negation (negative numbers like —33).

*/ Multiplication and division.

\ Integer division (division with no remainder, no fraction, no floating-point
decimal point. 8\ 6is 1).

Mod Modulo arithmetic (any remainder after division; 23 Mod 12 is 11. See the
sidebar, “Dividing the Mod way").

+/- Addition/subtraction.

Expressions combined into larger expressions

Expressions themselves are acceptable elements of expressions. In other
words, you can put expressions together, building a larger entity that itself is
an expression, like this:

Sub Vars()

Z = "Tom"

R = Right(Z, 2) 'Pick off "om," the two characters on the right side
L="om"

N=23

M =4

0o=25

P=56

If N+M+o0+P =18 And Z = "Tom" Or R = L Then MsgBox "Yes."

End Sub

Book |
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This expression, complicated as it is with various operators and interior
expressions, evaluates in the end to True, so the message box is displayed.
Also notice that no matter how complex an expression becomes, it always
ends up evaluating in only two possible ways: true or false.

Expressions with literals, constants, and variables

You can include literals as well as variables in an expression. In the follow-
ing, Z is a variable, but "Tom" is a literal in the preceding example. M is a vari-
able, and 4 is a literal. You can mix and match. You could also create the
preceding example with some literal numbers mixed, as well as a constant
or two, in

const Nance = "Morphing"

If 3+M+5+ P =18 And Z$ = "Tom" And Nance = "Morphing"
Then MsgBox "Yes."

Expressions and functions

Expressions can include functions, in addition to all the other elements
described earlier that are legally included in expressions. In this example,
the Val function tests the number at the start of the variable A. Finding
True, the string variable A doesn’t match 55.

A = "44 Rue Madeline"

If Val(A) <> 55 Then MsgBox "The text variable doesn't start
with the digits 55."

Variables versus Constants

Although a variable’s name remains the same while a program runs, the con-
tents of the variable can vary, which is how a variable differs from a constant.
Constants are not changed while a program runs; they are a known quantity,
like the number of donuts in a dozen or months in a year:

Const MONTHSINYEAR = 12

Variables, um, vary:

MyVisaBil1AtThisPoint 1200.44
but a month later . ..

MyVisaBiT1AtThisPoint = 1530.78
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Arrays — Cluster Variables

In practice, a few programmers love constants, but most others avoid them.
If you read some people’s programs, you can see they are making their pro-
grams more readable — more English-like — by including several constants:

BackColor = vbBlue

The preceding line is preferred by many people over the following line:

BackColor = RGB(170, 170, 170)

VBA includes many constants built into the language. With built-in constants,
you can just use them in your programming. You don’t have to declare them,;
they’re just there. To see what constants are built in, press F2 to get the
Object Browser and select All Libraries in the top drop-down list. Then in the
Classes list, look for words that end in constant, such as ColorConstants or

KeyCodeConstants, as shown in Figure 2-1.
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Arrays — Cluster Variables

Arrays, unlike constants, are universally regarded as extremely useful. Arrays
are variables that have been gathered together into a structure, so you can
manipulate the data by using loops.

An array is a group of variables that all have the same variable name and are
distinguished only by an index number. This way, you can refer to each item
in the array by referring to its index number, thereby manipulating the items
serially and mathematically.
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This approach might look like a small savings of effort, but imagine that your
program will probably have to use a set of variables in many situations. And
eventually, you'll have to save them to disk. If you had to refer to each item
by name, you couldn’t go quickly through the group, like this, to add sales
tax to each item:

For i =1 To 12
ArrayName(i) = ArrayName(i) * 1.06
Next I

If you don’t understand how loops work, like the For. . .Next loop here,
they’re explained in Book II, Chapter 3.

Variable Types

The terms variable types and data types are interchangeable. However, 'm
now pulling back and looking at a larger, more abstract set of variable cate-
gories. All numeric variables can be thought of as one category and strings
(text) as a separate category. Finally, objects form a third major type. Just
remember that within the numeric and object types, there are many subcate-
gories, but the text type has only one version: the string.

Text and Numeric are the two basic kinds of variables; they’re defined as
follows:

4+ Text variables (often called string variables): Can be used in captions,
text boxes, and so on. Text variables are made up of the symbols — the
characters in text. They can’t be divided or used to calculate the amount
of linoleum that you would need to redo your kitchen floor. Text is for
communication, not calculation. Text is merely a group of graphic
symbols; for example, the word Europe can’t be divided by the word
spaceship.

4+ Numeric variables: Are used to calculate things; they are numbers
rather than symbols. The digits 1 and 2 stamped on top of a carton of
eggs are text, but the actual number of eggs in that carton is numeric.

How do you change a text variable into a numeric variable and vice versa?
The Str and Val commands mediate between the two kinds of numbers. Str
translates a true number into digits (text characters) that can be displayed.
Val does the opposite; it turns a text digit like 5 into a real number that you
could multiply. However, VBA doesn’t require that you use Str or Val much
because VBA uses implicit type conversion automatically. Just remember
that those commands will cure the problem if you ever get a Type Mismatch
error message.
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Although only one kind of text variable is available, you can pick from sev-
eral types of numeric variables because there are several ways of expressing
numbers in a computer. The term variable type is also sometimes expressed
as data types.

Object variables

A new, third major variable type has been introduced to VBA. You can use
variables to point to objects, including forms and controls (which are
objects). (Point to is a common usage among programmers, meaning techni-
cally that the variable contains the memory address where the value of a
variable resides.) This provides you with efficient ways to access, manage,
and create copies of forms and controls and also to get your feet wet pro-
gramming with some object-oriented programming (OOP) features, such as
classes. Several metaphysical-sounding commands support object variables
in VBA: Is, Set, New, Null, Empty, Nothing, and Me. They mostly disappear
from BASIC when you move to Visual Basic .NET, so I won’t waste your time
exploring them in this book. You're unlikely to use them in your VBA, either.
And Help is always only an F1 keypress away if you think you might want to
look at them.

As a reminder of how object variables are used, here’s an example from
some code in Book II, Chapter 1:

Sub TestClass()

Dim o As Classl 'create object variable
Set o = New Classl 'assign object variable

0.TheMessage = "Hi, Bobbi!"
0.0urClass

End Sub

The value of numeric types

Computers calculate in different ways with different numeric variable types.
They can do arithmetic faster with integers than with floating-point types
because integers have no decimal point and thus no bothersome fractions
manipulate.

Why? The simplest explanation is found in the fact that elementary school
teachers have to spend much more time teaching division than teaching
multiplication. These operations — addition, subtraction, multiplication,

and division — are not symmetrical. Multiplication is pretty easy to get after
you understand the idea of addition. (Anyone who has written a list for Santa
or made a stack of cookies understands addition. Subtraction, too, is clear
enough — especially when your older brother steals some cookies from the
stack.)
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But division is in a class by itself. Division can cause something to go below
unity, below one, into the problematic world of fractions. Suddenly, two
simple digits like 3 and 1 can expand into a list of digits bigger than the uni-
verse, like .3333333333333333333, the infinitely long answer to dividing 1 by 3.

And then there are those remainders — you know, those unsettling things
left over after the arithmetic is supposedly finished.

Computers have exactly the same problems working with division; there’s
more to consider and more to manipulate. Just like us, the computer calcu-
lates more slowly when using floating point variables. If you want to speed
up your programs, allow the computer to use integers instead. If you don’t
need the precision fractions offer — and most of the time you don’t — use

an Integer.

In Table 2-5 is a list of the numeric variable types that you can use in VBA,
along with their symbols, the range of numbers they can hold, and the
amount of space each requires in the computer to store a number of that

type:
Table 2-5 Variable Types
Name Symbol  Range Storage Required
Boolean None TrueorFalse 2 bytes
Byte None 0to 255 1 byte
Integer % —32,768 to 32,767 2 bytes
Long Integer & —2,147,483,648 t0 2,147,483,647 4 bytes
(or Long)
SingTe (single-precision ! —3.402823E38 to —1.401298E-45 4 bytes
floating point) (negative numbers); and
1.401298E-45 to 3.402823E38
(positive numbers)
Doub1e (double-precision # 1.79769313486232E308 to 8 bytes
floating point) —4.94065645841247E-324
(negative numbers); and
4.94065645841247E-324 to
1.79769313486232E308
(positive numbers)
Currency (scaled @ —922,337,203,685,477.5808 to 8 bytes
integer) 922,337,203,685,477.5807
Decimal None +/-19,228,162,514,264,337,593 543, 14 bytes

950,335 if no decimal point; +/—
7.9228162514264337593543950335
with 28 places to the right of the
decimal. The decimal type is
removed in VB.NET.




Scope: The Range of Influence 107

Name Symbol  Range Storage Required
Date None January 1, 100 to 8 bytes
December 31, 9999
Object None AnyObject 4 bytes
Text (string) (a $ 1to roughly 2 billion The length plus
string of variable length) 10 bytes
Text ("string") $ 1 to roughly 2 billion (roughly Length of string;
(a string of fixed-length) 65,400 for Windows 3.1) the length of the
text
Variant (when None Any number 16 bytes; can be as
holding a number) largeasa Double Book Il
Variant (when None 1to roughly 2 billion The length of the Chapter 2
holding text) (roughly 65,400 for Windows 3.1) text plus 22 bytes
User-defined Variable None The size of the defined contents Whatever is =
(use the Type command) (You, the programmer, establish required by the )
the range.) contents ]
s
«
P Some programmers type DefInt A-Z at the very top (in the general declara- g
Q

tions section above any Subs) of each form and module. This forces all unde-
clared variables to default to the integer rather than variant type. This used
to offer a more significant gain in program execution speed than it does now,
but there is still some improvement. The A-Z means every variable name
starting with any letter between A and Z: in other words, all variables.

Scope: The Range of Influence

So far the variables in the examples in this chapter have been located inside
procedures (between Sub and End Sub). When you declare a variable inside
a procedure, the variable works only within that procedure. While the pro-
gram executes the procedure or event, the variable comes to life and does
its thing but then dies and disappears as soon as the End Sub line is exe-
cuted. Variables that live only within a single procedure are local variables.

Local variables have two qualities that you should understand:

4 Limited scope: No programming outside their own procedure can inter-
act with them, either to read their value or to change their value. Their
scope is limited to their own procedure. (I discuss the concept of scope
at greater length in the next section.)

4+ Disappearing value: When VBA finishes executing the procedure in
which they reside, the local variable’s value (whatever data it holds)
evaporates. If that procedure is executed a second time, whatever value
the local variable once contained is simply no longer there.
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Preserving the values of local variables

In some programming situations, you want a  In this example, the variable x retains its value
local variable's value to be preserved. In those  until the program is shut down. Another way of
cases, use the Static command, like this: putting it is this: When you use the Static
command to declare a local variable, the value

St it n>§( ) of that variable is preserved for the lifetime of
Static x e ] .
End Sub your application. If you don't use Static, a

local variable exists only for the lifetime of the
procedure within which it sits.

What do you think would happen if you click somewhere in the RunThis
macro (to put the blinking insertion cursor there) and then press F5 to
execute it?

Sub RunThis()
First

X =x+3
MsgBox x

End Sub

Sub First()
x =12

X =x+5
MsgBox x
End Sub

Here’s what happens when you execute RunThis. The first command that
the computer encounters is First, which refers to the macro of the same
name. By using the command First, the First macro is executed, which
first defines the value of x as 12, and then 12 + 5 or 17. A message box then
pops up displaying 17, which is the value of the variable x.

Then the line x = x + 3 executes, and a message box displays 3. The vari-
able x inside the RunThis macro is not the same variable as the x inside the
First macro.

But what if you want both of these procedures to be able to access and manip-
ulate the same variable? To do this, move your insertion cursor to the very
top of the code window — above any procedures. When you do this (press
the up arrow until you move the cursor to the top, or click your mouse at
the top), you'll notice that the two list boxes at the top of the code window
now read (General) and (Declarations), as you can see in Figure 2-2.



Figure 2-2:
Declare a
variable in
the General
Declarations
zone if

you want

it usable
anywhere —
in all the
procedures
—in this
module.
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% Normal - NewMacros (Code) EEE)|
| |iGeneral) ; (Declarations) j |

Dim X -
[ 3

Sub RunThis()

X=X + 3
MagBox X
End Sub

Sub Firstc()
X =12
X=X +5
MagBox X
End Sub

X 0

Having created a module-wide variable by declaring it outside any particular
procedure (using Dim X to declare the variable X), try executing the RunThis
procedure again. Now, the variable x is the same variable in both procedures,
so the second message box displays 20 this time.

When a variable has module-wide scope like this x, it’s available to all the
procedures in that module. It’s not available, however, to the procedures in
any other modules or forms in the project. Instead of Dim, you can use the
declaration Private. Private has that same effect as Dim but is a bit more
descriptive because it makes it clear that the variable is private to its own
module rather than public to all modules in the project. Also, Dim is more
frequently used within procedures.

What if you want to make a variable available to all the procedures in all
your modules and forms? (In other words, you want to create a variable with
project-wide scope.) To do this, declare the variable with the Pub11ic com-
mand rather than Dim. What’s more, you have to put the declaration into a
module, like the one named NewMacros that I use for the programming exam-
ples in this chapter.

A module is similar to a form, but it doesn’t have a user interface. Forms dis-
play buttons, text boxes, or other user-interaction objects. Forms are covered
in Book II, Chapter 4.
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Modules are never made visible to the user. Modules also contain no events.
A module is just a code window — a location where you put your program-
ming and also put public declarations that then become project-wide in
scope). A public Sub or Function in a module is available to the entire
program, too.

Form-wide, module-wide, and project-wide variables are preserved for the
lifetime of your application. They never lose their value, as does a local vari-
able declared with the Dim command.

It’s considered good programming practice to try to avoid using Pub11i ¢ vari-
ables when possible. Variables with that much scope can make your program-
ming harder to debug. Looking at the status of variables is one of the primary
ways to find out where a problem is located in a program. If you use a local
variable, a problem with that variable will be confined to its procedure. That
really narrows your search for a bug. You have more code to search if there’s
a bug involving a form-wide variable, but at least this kind of variable limits
the problem to a single form rather than the entire program.

You might have noticed that procedures themselves also have scope. All pro-
cedures are default to public scope, except for event procedures that default
to private. (You find them within forms, which I discuss in Book II, Chapter 4.)
To make your procedures private to their module, insert the Private
command:

Private Sub RunThis()

Scope Blowout

Classic BASIC, of which VBA is an example, limits itself to the four primary
scoping declarations discussed in this chapter: Dim, Private, Public, and
Static. (There’s also a ReDim, but it’s arcane.)

However, when you get into OOP languages — such as Visual Basic .NET —
scoping becomes more complex. It can be much more complex. Quite a bit of
time and effort is spent on scoping rules and techniques in OOP. Among the
OOP scoping commands are Protected, Friend, and Shared. You even find
combination scoping, which is using two scope declarations at the same time,
such as Protected Friend, ReadOnly Public,and WriteOnly Friend.
So far there’s no Prison Pen-pal Friend declaration, but give it time.
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The fundamental purpose of OOP is to promote encapsulation, which is a
security measure that attempts to hide data and code in an effort to reduce
confusion and bugs. For more on this, see Book II, Chapter 1.

You can ignore this OOP explosion of scoping behaviors and commands as
long as you limit your programming to VBA. OOP is often overkill for individ-
ual programmers or small projects anyway. However, throughout this book,
VB.NET is covered along with VBA, so you find out what Friend (and lots of
other terms) means when used to declare scope.
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Chapter 3: Looping and Branching

In This Chapter

+ Handing repetition
1 Making decisions with If...Then

v Branching with Select...Case

Fis chapter is for people who are new to programming. However, if
you're new just to Visual Basic (VB), you might want to skim through
it to get a feel for how VB handles looping and branching, which are two of
the most important techniques in programming.

Looping means repeating a task until a condition is met; branching means
choosing between carrying out a set of different tasks, based on a condition.

Going 'Round and 'Round in Loops

Often a job requires repetition until a result is achieved: Polish your boots
until they shine, or add spoonfuls of sugar one at a time until the lemonade
tastes good. This kind of repetitious behavior is handled with looping in a
computer program.

Repetition is often needed in computer programs, and the most common
loop structure is For. . .Next.

Using a For...Next loop

Between the For and the Next are program lines, which are instructions that
get carried out repeatedly. The number of times that the computer executes
the loop is defined by the two numbers listed right after the For:

Sub Iterate()

For I =1 To 4
A=A+1

Next 1

MsgBox A

End Sub
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In this example, the loop’s counter variable is named I. (There’s a tradition
to use thename I in For...Next loops.) But the important thing to under-
stand is that the counter variable is incremented (raised by 1) each time the
program gets to the Next command.

The Next command does three things.

4 Adds 1 to the variable I.

4 Checks whether [ has reached the limit set in the For statement (4 in
this example) and makes sure the limit has not been exceeded.

4+ Then Next loops — that is, it sends the program back up — to the For
statement to repeat the code one more time. The lines of programming
code within the loop are executed each time the loop cycles.

The answer displayed by the message box in the previous example is 10.
Try single-stepping through the execution of this loop (press F8 repeatedly),
pausing your mouse cursor over the counter variable I and also over the
variable A each time you go through the loop. You'll see that the first time
through I is 1. (Look at For I = 1 To 4;the counter starts with 1.) The
variable A is empty, but as soon as its line of code is executed, it contains
the value of I plus whatever was in A. The second time through the loop, A
first has a 1 in it, but the value of I is 2, so A then contains 3. The third time
through the loop, 3 is added to 3, resulting in 6. Finally, the last time through
the loop, I has a value of 4, which when added to 6, becomes 10. The pro-
gram then exits the loop and displays the MsgBox.

Using the Step command with For...Next

Step is an optional command that works with For...Next. Step can be
attached at the end of the For line to allow you to skip numbers — in other
words, to “step” past them. When the Step command is used with
For...Next, Step alters the way the loop counts.

By default, a loop counts by 1:

Sub Iterate()

Dim a As String

For i =1 To 12

a=ag&is&""
Next i
MsgBox a

End Sub



Going 'Round and 'Round in Loops 115

Andresultsinl 2 3 4 56 7 8 9 10 11 12.

However, when you use a Step command, you change how a For...Next
loop counts. For example, use Step 2 to count every other number:

Sub Iterate()

Dim a As String

For i =1 To 12 Step 2
a=ag&i&""
Next i

MsgBox a
End Sub

Andresultsinl 3 5 7 9 11.

If the mood strikes you, you can even “step” every 73rd number (Step 73),
count backward (For T = 10 to 1 Step -1), or count by fractions
(Step .25).

Nesting For...Next loops

For...Next loops can be nested, one inside the other. At first, this sort of

structure seems confusing (and it often remains confusing): The inner loop
interacts with the exterior loop in ways that are instantly clear to only the

mathematically gifted, although a couple of beers also helps.

Essentially, the inner loop does its thing the number of times specified by its
own counter variable, multiplied by the counter variable of the outer loop.
Got it? It’s like the moon. It’s revolves around the Earth, but both are simulta-
neously revolving around the sun. So the moon’s path resembles a corkscrew.
To make matters worse, the entire solar system is revolving around the
galaxy, but let’s not get into that.

When working with nested loops, simply keep substituting counter numbers
(and maybe moving code from one loop to the other) until things work the
way you want. One meaning of hacking to a programmer is similar to what
carving is to a sculptor: messing around until the desired result emerges. In
this example, I want to display two sets of numbers: 1 2 3and 1 2 3. After
a frosty, cool one, I finally figured how to do it. The outer loop (1) should
loop twice, and the inner loop (J) should loop three times. And the value

of J should be used each time to display the numbers that [ want. Here’s

the code:
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Sub Nested()

Dim a As String
cr = vbCrLf ' move down one line

For T =1 To 2
For J =1 To 3
a=ad&" " &J&cr
Next J
Next 1

MsgBox a
End Sub

Any numeric expression can be used with For. . .Next. However, the range
that you're counting must be possible. For example, the following is not
possible:

For i = -10 To -20 Step 2
MsgBox "Toop"; i
Next

This loop does nothing. It can’t. You're asking it to count downward, but
your Step command is positive. As any intelligent entity would when con-
fronted with a senseless request, Visual Basic does nothing with these
instructions. It ignores you. You have to make the Step negative with -2
before something will happen.

Early exits from loops

If you want to exit the loop before the counter finishes, use the Exit For
command. The Exit For command is rarely used, but here’s an example of
when you’d want to use it. Suppose you're filling an array that should only
hold 500, and you don’t want to overflow it. You avoid this by making a pro-
vision for an early exit from the loop if necessary. If the Exit For is carried
out, execution moves to the line of code following the Next command.

If n > 500 Then Exit For

You can use Exit Do (for Do loops), Exit Function, Exit Property, and
Exit Sub commands as well.

Working with Do...Loops

Sometimes you might prefer the Do. . .While loop structure to For. . .Next;
in fact, some programmers favor it over For...Next because it can be a bit
more flexible. Do. . .Loop structures can be handy in special looping situa-
tions. Read on.
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Choosing Do While over For...Next loops

In its most common use, Do. . .While employs a comparison operator at

the start of the loop to test something (is it = or =>, and so on). If the com-
parison succeeds, the statements in the loop are executed at least once.
However, the first time the comparison fails, the loop is skipped, and execu-
tion continues on the line following the Loop command. The Loop command
signals the end of the Do While structure, just as the Next command signals
the end of the For...Next loop structure.

Sub Iterate()

Dim a As String
cr = vbCrLf ' move down one line

Do While y < 11
y = + 1
a =ad&y&cr
Loop
MsgBox a
End Sub

Remember that you must do something in the code within the loop that
changes the comparison value. Otherwise, you create an endless loop. Also
note that if Y in the example above already holds a value of 11 or more when
the program reaches this loop, the loop will never execute. The exit test will
fail the very first time the loop is encountered, and none of the code within
the loop will execute at all.

Using Do Until loops

A version of Do Whileis Do Until.It’s just another way of expressing the
same idea, but you might find it a little clearer. Do While loops as long as
the comparison is True, but Do Unti1 loops until the comparison is False:

Do Until y = 11
'Some behaviors
Loop

Using Loop While and Loop Until

If you want to put the loop exit test at the end of the loop structure, here are
two additional ways to construct a Do loop:

Do
'Some behaviors
Loop While Y < 11
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This works the same way as the earlier Do While example. The difference is
that when you put the test at the end, the loop always executes at least
once, no matter what value is in the variable Y when you enter the loop.

Do
'Some behaviors
Loop Until Y = 11

Which of these four structures should you use? Use Do While or Do Until
if you don’t want the loop to execute even once if the exit test fails at the
start. As for the difference between the While and Unti]1 styles, it’s often a
matter of which one seems to you to be more readable, or which one works
better with the exit test. Many times, it’s merely a semantic distinction: the
difference between Do the dishes while any are still dirty versus Do the dishes
until all are clean.

Exploring While...Wend: A simple loop

Finally, at your disposal is the WhiTe...Wend structure, although it’s little-
used. It’s simple but relatively inflexible:

While X < 7
'Some behaviors
Wend

As you can see, this looping technique is comparatively simple. While...Wend
has no Exit command (like the Exit Do command). While...Wend is lim-
ited to an exit test at the start of the loop, and it does not permit you to use
the alternative command Until.

For...Each: Looping in Object Collections

The job of moving through a collection of objects is made easy for program-
mers because the collection itself knows how many objects it contains. With
collections, you can use the For Each structure.

For example, to see a list of the text fonts available on a given computer in
VBA, you can create this macro:

Sub ShowFonts()

For Each F In FontNames
Debug.Print F & ", "

Next F

End Sub
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The results are displayed in the Immediate window.

To do the same thing VB.NET, you use the System.Drawing.FontFamily
object, like this:

Dim F As System.Drawing.FontFamily
For Each F In System.Drawing.FontFamily.Families

Console.WritelLine(F.Name)
Next

For Each is a quick and clean way to loop because you don’t have to spec-
ify a literal number or some other exit test.

Creating a Very Useful File Search Utility

A\

The macro you create in this next example is one of my favorites because it
executes so much faster than the built-in Windows text search utility. If you
write 800-page books as I sometimes do, you now and then find yourself near
the end, writing Chapter 28, and thinking, “Didn’t [ mention object collections
in one of the early chapters?”

Until [ wrote the following macro, I had to rely on the search engine in
Windows: the one you launch with Starte>Search, or by right-clicking in
Windows Explorer and choosing Search from the context menu. Windows
includes an indexing feature that works in the background during idle time,
attempting to create lists to speed up the search process. Nonetheless, these
Window searches are really quite slow if you're looking through dozens of
DOC files for a particular word or phrase such as object collections.

Type in the following macro and then add it to a toolbar in Word. (Right-
click the toolbar, click the Commands tab, click Macros in the left list of
the Customize dialog box, locate the SearchText macro in the right list box
and drag it onto the toolbar.) Or create a shortcut key combination for the
macro. (Choose Tools>Customize and click the Keyboard key.)

This example code also illustrates the For Each structure, so that’s the
excuse I'm using to include this high-speed search utility in this chapter.

The first time in a given session that you use this macro to search, it is about
as slow as the Windows search utility. But thereafter, the documents being
searched are cached in RAM, and the search is extremely fast. Try searching
the same folder for two different phrases. You'll see that the search for the
second phrase is lightning fast.
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Press Alt+F11 to open the Word’s VBA editor, and choose Toolsc>References.
Ensure that the Microsoft Office 11.0 Object Library check box is marked.
Then type Listing 2-1 into the Normal macros editor, where you put all the
macros you want to make available to all Word documents.

Listing 2-1: Search Macro

Sub SearchText()

"after the first search of a given path, this is faster than
the built-in Windows search.

"and, unlike the Windows Explorer search, this one can be
hard wired for a project's folder.

cr = vbCrLf
quot = Chr(34) 'quotes

Dim 1 As FileSearch
Set 1 = Application.FileSearch

s = InputBox("Please enter the search string...", "Enter the
text you're looking for.")

With 1
.NewSearch
.LookIn = "C:\book OFFICE 2003"
.SearchSubFolders = True
.FileName = "*.doc"
.MatchTextExactly = True

.TextOrProperty = s
nFound = .Execute(msoSortBylLastModified)

If nFound > 0 Then
For Each F In .FoundFiles
UserForml.ListBoxl.AddItem F
Next
End If

End With
UserForml.Caption = nFound & " hits for " & quot &
1.TextOrProperty & quot & " found in" & T1.LookIn

UserfForml.Show

End Sub
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In this macro, you first create a variable to move down one line (cr) and
another to display quotation marks.

Then you define a FiTeSearch object variable and use Set to assign this

application’s FileSearch object to that variable. You ask the user for the
text that should be searched for. You can also ask the user at this time to

specify which folder or drive to search, but I prefer to hardwire it into the
code with this line in the macro:

.LookIn = "C:\book OFFICE 2003"

For several months while working on a book, I generally search in the same
folder, so it’s quicker to just define that folder right in the code. This way

[ don’t have to answer the LookIn question each time I use the search utility.
It’s easy enough to press Alt+F11 and type a new . LookIn filepath as need be.

Similarly, you can ask the user to enter the file specification (the . FileName
property of the FileSearch object), but I like to hardwire . doc into the
macro code.

Using the Wi th structure so you don’t have to keep repeating the object
variable name 1, you then specify the various properties and use the
FileSearch object’s Execute method to iterate (loop) through each
(For Each)item in the .FoundFiles collection built by the Execute
method. These items are dumped into a ListBox on a UserForm.

This line does quite a bit of work:

If .Execute(msoSortByLastModified) > 0 Then

The Execute method returns the number of files found, so if it is zero, you
don’t use the For Each loop. Also, the msoSortBylLastModified argument
is one of several you can choose from to specify how the filenames are
ordered in the collection of hits that the Execute method finds during its
search. msoSortBylLastModified orders them by (you guessed it) their
date of modification. To get a list sorted alphabetically, use
msoSortByFileName.

At the end of the macro, some statistics are displayed on the UserForm’s
title bar, and the UserForm is shown to the user so he can click one of the
documents listed to view the document in Word.

The .NewSearch property is used because the other search properties are
remembered between searches and reused during a given session. In other
words, without specifying . NewSearch, filepaths, text to search for, and

so on are retained and become the defaults. Also, the text you search for
includes a search of the documents’ properties (the name of the document’s
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title, its author, and so on). | haven’t found a way to leave out the document
properties during a search and just look through the text. This
.TextOrProperty seems the only option here.

Add the UserForm to this project now by choosing Insert>UserForm in the
VBA editor. Drop a ListBox from the Toolbox onto the UserForm. Double-
click the ListBox to get to its C11ck event and type in this code:

Private Sub ListBox1_Click()
n = ListBoxl.Value

Documents.Open FileName:=n, ConfirmConversions:= _
True, ReadOnly:=False, AddToRecentFiles:=False,

PasswordDocument:="", _
PasswordTemplate:="", Revert:=False,
WritePasswordDocument:="", _
WritePasswordTemplate:="", Format:=wdOpenFormatAuto,
XMLTransform:=""
End
End Sub

When the user clicks a document name in this list box, Word’s documents
object’s Open method is triggered, displaying the document so the user can
read it.

You can include another property of the FileSearch object to allow users
to specify a filter for the search based on the time the files were saved. If
you don’t include the . LastModified property in your code, it defaults
to any date (msolLastModifiedAnyTime). However, you can select from
these alternative time stamps: msolLastModifiedLastMonth,
msolLastModifiedlLastWeek, msoLastModifiedThisMonth,
msolLastModifiedThisWeek, msolLastModifiedToday, and
msolLastModifiedYesterday.

Making Decisions via Branching

Making decisions is central to any intelligent behavior. As a result, the
If...Then structure is one of the most important features in any computer
language — indeed, in any kind of language.
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If...Then is the most common way that decisions are made. After the deci-
sion is made, actions are taken that respond to the decision. A program is
said to branch at this point because the path it was following splits into more
than one trail. The branch that the program chooses is decided here at the
If...Then junction. For each of the branches, you write code appropriate
to that path.

Many times a day, we do our own personal branching, using a similar struc-
ture: If you're hungry, you eat. If it’s nice weather, you don’t wear a jacket. If
the car windows are fogged up, you wipe them off. This constant cycle of
testing conditions and then making decisions based on those conditions is
what makes our behavior intelligent and adaptive.

Understanding If...Then

This same kind of testing is what makes computer behavior intelligent, too.
You put If...Then structures into a program so it reacts appropriately to
various kinds of user input, as well as such additional events as incoming
data from a disk file, the passage of time, or other conditions.

Here’s a simple example of how If...Then is used:

Sub Branching()
Response = InputBox("How many calories did you take in today?")

If Response > 2200 Then
m = "Keep that up and you'll have to buy new pants. Your bad self."
Else
m = "Good self-control on your part."
End If

MsgBox m

End Sub

The line of code starting with I f tests whether something is True. If so, the
code on the line or lines following the If are carried out. If the test fails
(the test condition is false), your program skips the line(s) of code until it
getstoan Else, E1self,or End If command. Then the program resumes
execution. Put another way, the If test determines whether some lines of
code will be executed.

Notice that if you're making a simple decision (either/or) with only two
branches, you can use the E1se command. In the above example, if the
user’s response is that he ate more than 2,200 calories, the first message is
displayed. Or, if the opposite happened, the message following the E1se
command is displayed.
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What if you want to branch into more than only two paths? Easy! You can
use the E1self command:

If X = "Bob" Then
MsgBox "Hello Bob"
ElseIf X = "Billy" Then
MsgBox "Hello Billy"
Elself X = "Ashley" Then
MsgBox "Hello Ashley"
End If

In a way, using E1selIf is like using several If...Thens in a row. But for situ-
ations in which you want to test multiple conditions, the better solution is to
use the Select Case command, as you'll soon see.

As with loops, it’s traditional to provide a visual cue by indenting all lines of
code that will be carried out inside the If...Then structure. Also, there is a
simple, one-line version of I f...Then that you can use if your test is simple
enough (True/False) and short enough that you can just put it all on a
single line. In that case, you do not use an End If.(The If...Then struc-
ture is assumed to be completed by the end of the line of code.) The com-
puter knows that this is a single-line If...Then because some additional
code follows the Then command. In a multiline If. . .Then structure, the
Then command is the last word on the line. Here’s an example of the single-
line structure:

Sub Branching()

Password = "sue"

Reply = InputBox("What is the password?")

If Reply <> Password Then MsgBox ("Access Denied"): End
MsgBox "Password verified as correct. Please continue."

End Sub

Notice the colon that appears at the end of the If...Then line in the pre-
ceding example code. It’s used to combine separate programming state-
ments (logical lines of code) on the same physical line. This is a rarely used
technique, but you should be aware of it. It’s handy for single-line If...Then
code, as this example illustrates. You want to do two things should the pass-
word fail the test:

4+ Show a message box.

4+ End the program.
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Normally, the End command would have to be on a line of its own in the
code. When you use the colon, VBA reads the code that follows it as a sepa-
rate logical line of code. Recall that you can use the space-underscore char-
acters to break a single, long, logical line of code into two physical lines.
(Logical here means what VB acts on, and physical means what you see
onscreen.) Using a colon is the opposite of the space-underscore. A colon
allows you to place two logical lines on the same physical line. (You can
even cram more than two logical lines on one physical line:
X=X+1:A=B:N="Hi.", for example.)

Remember that the condition you test with If is an expression, so it can
involve variables, literals, constants, and any other valid combination of
components that can make up an expression. For instance, you can use a
function in an expression:

If InputBox("Enter your age, but it's optional"™) <> "" Then
MsgBox "Thank you for responding"

End If

The InputBox function is executed, and its result is tested to see whether it
does not equal (<>) an empty string (" "), which would mean that the user
failed to type anything into the InputBox.

A Function, like a Sub, is a procedure. However, a Function usually returns
avalue, and a Sub (usually) does not. In practice, over the years, the distinc-
tion between Sub (no return value) and Function (returns a value) has
broken down, and now these procedures are fairly interchangeable. Generally,
code that you execute with programming commands, such as MsgBox or
InputBox, are called functions although they reside in the language’s code
library and you, yourself, do not write these functions. You merely call them
(use them) in your programming.

Multiple choice: The Select Case command

If...Then is great for simple, common testing and branching. But if you're
testing for more than two branches, If...Then becomes clumsy. Fortunately,
here’s the alternative decision-making structure in VBA that specializes in
multiple-branching. Select Case should be used when there are several
possible outcomes and several tests.

The main distinction between If...Then and Select Case goes something
like this:

If CarStatus = burning, Then get out of the car.
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But the Select Case structure tests many and various situations:

Select Case CarStatus
Case Steaming
Let radiator cool down.
Case Wobbling
Check tires.
Case Skidding
Steer into skid.
Case Burning
Leave the car.
End Select

Select Case works from a list of possible answers. Your program can
respond to each of these answers differently. There can be one, or many,
lines of code within each case:

Response = InputBox("What's your favorite color?")

Select Case LCase(Response)
Case "blue"
MsgBox "We have three varieties of blue"
Case "red"
MsgBox "We have six varieties of red"
Case "green"
MsgBox "We have one variety of green"
Case Else
MsgBox "We don't have " & Response & ", sorry."
End Select

This example illustrates that you can use any expression (variable, literal,
function, compound expression, or other kind of expression) in the Select
Case line. In this example, I use the L Case command to reduce whatever the
user typed to all lowercase letters. Then VB goes down the list of cases and
executes any lines in which the original expression on the first line matches
one of the Case lines. Note that the final case is special: The optional Case
E1se command means that if there were no matches, execute the following
code.

Using the Is command with Select Case

You can use the special Is command with each case to use comparison tests
on each case:
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X = InputBox("Your weight, please?")

Select Case X
Case Is < 200
"(put one or more commands here)
MsgBox "Good for you"
Case Is < 300
"(put one or more commands here)
MsgBox "Not too bad."
End Select

In the above example, if the number is lower than 200, the first block of code
lines executes; then execution jumps to the line of programming following
End Select. If the number is lower than 300, the second block of code exe-
cutes (any code between Case Is < 300 and End Select). Note that as
soon as one of the cases triggers a match, no further cases are even checked
for a match. The Case structure is merely exited.

Using the To command with Case Select

If you want to check a range of values, use the To command. It can be a
numeric range (Case 4 To 12) or an alphabetic range (based on the first
letter of the string being tested):

Reply = LCase(InputBox("Type in your Tast name."))

Select Case Reply
Case "a" To "m"

MsgBox "Please go to the left Tine."
Case "n" To "z"

MsgBox "Please go to the right Tine."
End Select

You can also combine several items in a Case, separating them by commas:

Case "a" To "1", "gene", NameOfUser

This is an or type of test: that is, take action if

4+ The answer begins with a letter between a and 1.
or

4+ It’s gene.
or

4 It matches the value in the variable NameOfUser.
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Chapter 4: Managing Files and
UserForms

In This Chapter

v+ Understanding saving and loading
v Displaying a user interface
v+ Working with dialogs

v Using Windows controls

Fis chapter continues the introduction to VBA, covering several topics
of interest to anyone who doesn’t know how to build a user interface.
Specifically, here I cover UserForms, dialogs, and Windows controls. And
because hard drive storage is also important, I start with a little background
on loading and saving disk files.

Communicating with the Hard Drive

s

To preserve data, you need to load and save disk files. The syntax to do this
differs between various Office applications, with Access, as always, being
the odd man out.

Each Office application has its own type of file because the documents used
within the applications have different internal structures representing their
different purposes. Excel opens a workbook object (an XLS file), so it uses
the Open method of the Workbooks object. Word opens a document, so it
uses the Open method of the Documents object. And Access, of course, does
things a little differently.

Loading files in Word and Excel

Here’s how you open a file in Word, adding it to the collection of currently
open documents:

Documents.Open "c:\test.doc"
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Here’s how to load a file in Excel:
Workbooks.Open "c:\test.x1s"

You can also specify a slew of optional conditions when opening document
or workbook files, such as the one that makes the file read-only, like this:

Documents.Open FileName:="C:\MyFiles\MyDoc.doc", ReadOnly:=True
Here’s the full syntax for the Open command:

Workbooks.Open(FileName, ConfirmConversions, ReadOnly,
AddToRecentFiles, PasswordDocument,
PasswordTemplate, Revert, WritePasswordDocument,
WritePasswordTemplate, UserFormat, Encoding,
Visible, OpenConflictDocument, OpenAndRepair
DocumentDirection, NoEncodingDialog)

If you want to open all recent files (those listed at the bottom of the File
menu), use this code:

Sub OpenRecentFiles()
Dim rFile As RecentFile
For Each rFile In RecentFiles
rFile.Open
Next rFile
End Sub

Loading files in Access

Access, of course, does things differently. You import ordinary text files by
using archaic Open commands that hearken back to the early days of BASIC.
Here’s an example that opens a file in sequential-input mode, and then reads
and displays the contents. Follow these steps:

1. Open a database in Access. If you don’t have a file on your root C:\
directory named test.txt, create one in Notepad.

2. Choose Windowr>the database name.
The main database window opens.

3. Click Modules in the left pane of the main window, as shown in
Figure 4-1.
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4. Click the New button in the main database window (refer to
Figure 4-1).

The Visual Basic editor opens, as shown in Figure 4-2.
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5. Type this macro into the editor:

Sub opentext()
Open "c:\test.txt" For Input As #1

If LOF(1) > 0 Then
Do Until EOF(1)
Line Input #1, s

a =a4&s

Loop

End If

Close
Close #1

MsgBox a

End Sub

6. Click somewhere in this macro so your blinking insertion cursor
shows within the code.

7. Press F5 to execute the macro.

The test.txt file is opened, and a message box displays its contents.
You can use this technique to load data from some legacy databases.

You use the Open command for both loading and saving files in Access. This
example opens the file in binary mode (which sometimes results in smaller
file sizes) for writing operations only:

Open "c:\test.txt" For Binary Access Write As #1

Many variations on the Open command exist. See Access’s VBA Help for a
description of all the permutations.

Saving files

In most Office applications (Access excluded), you can simply use the Save
method of the document, workbook, or other object to store the information
on the hard drive. (See the preceding section for how to save a file in Access.)

For example, in Word, you can use this code to save the current document
(the one you’re looking at in the Word window) if it has been in any way
modified since the last time it was saved:
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Sub savedoc()
If ActiveDocument.Saved = False Then ActiveDocument.Save

End Sub

To save all opened documents, use the Documents collection’s Save method,
like this:

Sub saveAlldocs()
Documents.Save NoPrompt:=True

Book Il
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Creating User Interfaces

In Visual Basic programming, the UserForm is a container that you use to
arrange the visual elements of a user interface. When the program later exe-
cutes, the UserForm appears to the user as a window, with whatever appro-
priate controls (buttons, text boxes, scrollbars, and so on) are necessary for
the user to interact with the application.

Suno1as
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The UserForm as a container

For a programmer, though, the UserForm is also a container for program-
ming code that supports the behaviors of the controls and brings them to
life. For example, if you put a button control on a UserForm and label that
button C1ick Me to see BBC!, you can put underlying code for that
button that responds when the user clicks the button by connecting to the
Internet and showing the BBC news page.

Try an example; follow these steps to take the user to the BBC news page.

1. Press Alt+F11 in Word.
The VBA editor is displayed.
2. Choose Insert->UserForm from the VBE menus.

A new UserForm, along with a Toolbox containing controls, appears, as
shown in Figure 4-3.
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Figure 4-3:
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3. Drag a CommandButton from the Toolbox (as shown in Figure 4-3) and
drop it on the UserForm.

A new CommandButton appears on the UserForm.
4. Click the button.

An insertion cursor appears, cluing you that you can edit the default
caption.

5. Type Click Me to see BBC as the new caption of the button.
6. Click outside the button on the UserForm.
7. Double-click the button.

A new code window opens, displaying the C11ick event of the button.
Into this event (a Sub procedure, just like a macro), you can type what-
ever programming you want to execute when the user clicks this button.

8. Type this code to open the user’s browser and to display the BBC site:
Private Sub CommandButtonl Click()

ActiveDocument.FolTowHyperTink _
Address:="http://news.bbc.co.uk", NewWindow:=True

End Sub

9. With the blinking insertion cursor inside this procedure, press F5 to
test your user interface.

The UserForm appears as a window, just as the user would see it, as
shown in Figure 4-4.
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Figure 4-4:
Your pro-
gramming
UserForm
has been
transformed
into a
window.

UserForms &

10. Click the button.

The BBC news page appears in your browser.

Displaying a UserForm from a macro

After you create a UserForm, you want to be able to display it to users. You
can display UserForms from within macros by using the UserForm object’s
Show method. Follow these steps:

1.

In the VBA editor, choose Viewr>Project Explorer.

The VBA Project Explorer window pane opens.

Click the + symbol next to the Modules node to expand it.
The node opens, displaying all the modules in this document.
Double-click the New Macros entry under Modules.

The main macro editor window opens.

Move down to the bottom of the macro window and type in this new
macro:

Sub savedoc()
UserForml.

End Sub

As soon as you type the period following UserForml, IntelliSense takes
over and displays a list of all the members of a UserForm.

Locate Show in the members list and click it to make your line of code
read

UserForml.Show
Press F5 to execute this macro.

Your UserForm is displayed.
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Using an object variable

A more formal approach to displaying and managing UserForms involves cre-
ating an object variable, which [ name My Form here, in a macro or applica-
tion, like this:

Dim MyForm as New UserForml

Thereafter, you can use the object variable to assign values to the form’s
properties and the properties of controls on the form. Here’s a macro that
manipulates a form and its contents:

Sub ShowForm()

Dim MyForm As New UserForml
MyForm.TextBox1l.Text = "Welcome"
MyForm.Caption = "Florida"
MyForm.Show

End Sub

You can also retrieve values from a form by using the object variable:

S = MyForm.TextBoxl.Text

Hiding and destroying an object variable
When you’re done with the form, use its Hide method to make it invisible:

MyForm.Hide
If you don’t need it any more, destroy the object variable and its object:

Set MyForm = Nothing

Engaging the User with Dialogs

A set of standard Windows dialogs are available to you in several Office 2003
applications: printing, file access, color adjustments, and so on. Here is an
example that displays the standard Open dialog box:

Sub ShowDia()
Dialogs(wdDialogFileOpen).Show
End Sub
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In addition to the standard Windows dialog boxes, dozens of application-
specific dialogs are also available, such as Word’s Date and Time dialog box
(as shown in Figure 4-5), which you display with the following:

Dialogs(wdDialogInsertDateTime).Show

4 Normal - NewMacros {Code) =& ]
|(Gcm:lall _ﬂ |shuwdia ﬂ |
Debug.Frint b zl
N be=h+6
Figure 4-5:
End Sub
You can =
manipulate Sub showdial()
dozens of Dislogs |
| . ltemil = wdDialoginsenCaption )
built-in End 515 waDisloginsenCaplionMumbering
dialOg boxes @ wdDizloginserCrossReference
& wdDizloginserdDatabase
program- = wdDisloginzeriDateTime [ i =i
maticall = wilialoginserField =
Y- =i= 4| | & wdDialoginserlFile v L[J
= _1_r - e |
N To see a list of all the dialog boxes available and their arguments, search the

Excel or Word Help system for Built-in Dialog Box Argument Lists. (Outlook
and PowerPoint don’t offer this capability.) Or just type in Dialogs( (with a
left parenthesis), as shown in Figure 4-5, and the VBA IntelliSense feature
opens with a list of all the dialogs.

Access, of course, doesn’t directly support a simple UserFormat for display-
ing dialogs, although you can use this technique. However, to get it to work,
you need to figure out which code library (Tools=>References in the Access
VBA code window) contains the standard Windows dialogs; then select its
check box:

Sub ShowDia()
Dim dl1gOpen As FileDialog

Set dlgOpen = Application.FileDialog( _
FileDialogType:=msoFileDialogOpen)

With d1g0pen
AlTowMultiSelect = True
.Show

End With

End Sub

Book Il

[x]
=
o
=
=
(-]
=
s

Suno1as
pue s3ji4 buibeuepy



73 8 Understanding Controls

You can employ a variety of techniques with the dialog boxes. For instance,
if you want to simply show a dialog box to the user but prevent the user
from taking action, use the Display method. The Open button in this next
dialog box will be disabled:

Sub ShowDia()

Dialogs(wdDialogFileOpen).Display
End Sub

A value is returned by the Show and Display methods, telling you whether
the user clicked the Close, OK, or Cancel buttons:

Sub ShowDia()
If Dialogs(wdDialogFileOpen).Show = -1 Then

'user clicked 0K
End If

End Sub

A returned value of 0 means that the user clicked the Cancel button, and a
returned value of -2 means that the user clicked the Close button.

Understanding Controls

\\J

You can of course construct custom dialog boxes to display to the user.

A simple approach is to use the msgbox and inputbox functions. More
complex and satisfactory is to create a UserForm and interact with the user
with it.

To see a control’s properties, right-click the control on the UserForm and
then choose Properties from the context menu. The Properties window
opens, as shown in Figure 4-6.

To see how to employ the various controls in the UserForm Toolbox, follow
these steps:

1. Press Alt+F11 in Word.
The VBA editor is displayed.
2. Choose Insert->UserForm from the VBA editor menu.

A new UserForm appears, along with a Toolbox that contains controls.
A close-up of the Toolbox is shown in Figure 4-7.
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Excel’s Toolbox has an additional control named RefEdit that displays the
address of a range of cells on one or more worksheets.

Figure 4-6 shows the default controls on the Toolbox, but you can add

dozens more to the Toolbox. Some controls might be installed on your com-
puter from other Microsoft products. You can also get controls from third-
party sources, and there’s even a set available from within Office that’s not
considered as frequently used as the default set.
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Figure 4-8:
A slew

of other
controls is
available to
add to your
Toolbox.

To see the list of controls that you can add to the Toolbox, right-click the
Toolbox and choose Additional Controls. You'll see the list of controls, as
shown in Figure 4-8. You can read more about these in Chapter 5, Book II.
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Read on to explore the purpose and behavior of each of the default controls.

The Label control

A Label is generally used to inform the user of the meaning of something
visible on a window. For example, if you have a TextBox, you could describe
its purpose to the user by positioning a Label that reads P1ease enter
your address here just above the TextBox.

Here are some common uses for a Label:

4 Print information on a UserForm.

4 Add captions or other descriptive text to controls that have no Caption
property of their own, such as Scrol1Bars.

4 Apprise the user of changing conditions while your program runs: that
is, a file is being loaded, records are being sorted, and so on.

A Label normally has no border (the default) and appears to be printed on
a UserForm. Labels are usually not changed while a program runs, although
they can be. Often the Caption (the label’s displayed text) and its other

properties are adjusted while you design your program using the Properties
window.
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The most important element of a Label is its Caption property, which is
where you put your descriptive text. Remember that the main purpose of a
Label is to label something on your UserForm. TextBox controls are also
designed to handle text, but they also accept input from the user and have
much greater overhead.

A Label wraps its text at its right edge. (It breaks lines at a space character.)
You can take advantage of this fact to add multiline notations on UserForms.
First, create a Labe]l that’s a few lines high and then type some words sepa-
rated by spaces into its Caption property. When you reach the edge of the
LabeT, the words move to the next line. A Label is limited to 1,024 charac-
ters, and its TextATign, AutoSize, and WordWrap properties determine how
text is displayed within the label.

The TextBox control

The TextBox control and the CommandButton are probably the most fre-
quently used of all the controls. The VB TextBox control is a simple
(although surprisingly functional) word processor.

The TextBox control responds to all the usual editing keys: Delete, Insert,
Backspace, PgUp, and PgDn. It can also automatically word wrap: that is,
detect when the user has typed to the right side of the text box and then
move the word down to the next line without breaking it in two.

You can add Scrol1Bars (via that property of the TextBox). By manipulat-
ing the SelText and related properties during runtime, you can create cut,
copy, and paste features. By using the KeyDown event, you can capture char-
acters while the user types them, thus adding special, additional features
triggered by the Ctrl, Alt, or function keys.

A TextBox is like Notepad — elementary, but useful. For example, you can
use text boxes for data entry or any situation where the user needs a con-
venient way to type something into your program. If you want to limit the
number of characters the user is permitted to enter into a TextBox, use the
MaxlLength property. It can be set in the Properties window or while the pro-
gram is running. When not 0 (the default), a TextBox will refuse to accept —
will not print onscreen or add to the Text property — any more characters
typed by the user. You can also use text boxes to display information, such
as a disk file that the user will want to view or edit.

When using TextBox, you can’t add a selective boldface or italics feature,
however, or include varying typefaces or font sizes. These properties are set
for the entire TextBox, so you can’t mix and match them in the text inside
the box.
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However, a more advanced TextBox control is available — the RichText
Box — and you might find it in the list of additional controls you can see by
right-clicking the Toolbox. This control does permit formatting, such as ital-
ics, boldface, various type faces and type sizes, bulleted lists, and even
color. You can import and export RTF files, thereby retaining the formatting.
(Most word processors recognize the RTF codes.)

The TextBox Multiline property is rather an annoyance, to the regret of
millions of BASIC programmers (and a waste of man-centuries of time), ever
since Visual Basic version 1 Multiline has defaulted to False. The practi-
cal effect of this bizarre decision on the part of the designers is that you
almost always have to change the property to True whenever you add a
TextBox to a UserForm. That’s because text boxes are almost always more
functional with more than one line (and, consequently, with word-wrap
activated).

If you add a horizontal Scrol1Bar with the scroll bar’s property, all text will
be on a single line. This single line can contain up to 255 characters. Any
additional characters that the user attempts to type in or that your program
attempts to add to the Text property will be ignored. It’s therefore usually
practical to use only a vertical Scrol1Bar, both horizontal and vertical bars,
or none. A lone horizontal bar is restrictive.

There is no default limit (beyond the user’s available memory) to the size
of the text within a TextBox. A TextBox Text property (Textl.Text, for
instance) behaves just like a text variable.

You can use the KeyDown event of a TextBox to intercept characters as
they’re typed in, which allows you to control user input — refusing to accept
letters, for example, if the user is supposed to be entering a phone number.

You can also add shortcut commands with this technique, such as Ctrl+Q for
Quit. To add a cut, copy, and paste feature, see the SelText property in the
earlier section, “The TextBox control.”

Windows uses the Tab key as a way of moving between the items — the
controls — in a window. Pressing Tab cycles you through the various
OptionButtons, CommandButtons, or whatever controls are on a UserForm
(see “Tablndex” in Help). In a TextBox (unless it’s the only control on the
UserForm that can respond to tabbing), the user can’t use the Tab key to
move the cursor over as would be possible in most word processors (and
typewriters). Pressing Ctrl+l, however, will tab in a TextBox.
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The CombobBox control

ComboBoxes are similar to ListBoxes; however, a ListBox simply provides
a list of options the user can choose from, whereas a ComboBox offers that
list and also lets the user type in additional items.

Use ComboBoxes to offer the user choices but accept alternatives. For exam-
ple, if your program dials the telephone and is an electronic substitute for a
Rolodex, you can keep track of the six most-frequently dialed people.

When the program starts, it shows a ListBox with these people’s names so
the user can just click one and then press Enter to select the one that’s high-
lighted. Pressing arrow keys moves the user up and down through the list.
And — the main feature — there’s a place for the user to simply type in a
person who is not listed in the top six.

Your macro or program detects the user’s selections, which trigger the text
box’s C11ck event. Your program also knows when the user starts typing:
That act triggers the box’s Change event.

Your program can add or remove items from a ComboBox:
ComboBox1.AddItem "New York"

Or to add an item, use this:

ComboBox1.AddItem N

Or to remove the fourth item from a ComboBox, use this:

ComboBox1.Removeltem 3

The items in a List or ComboBox start with a zero-th item, so the fourth item
is removed by requesting number 3.

Computer language designers still cling to the confusing habit of starting a
count from zero (in some cases, not all).

The ListBox control

A ListBox is the same as a ComboBox except that the user can’t type any-
thing into a ListBox. He can click only one or more of the listed items,
thereby selecting that item or set of items.
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When using ListBoxes, remember these points:

4+ Provide the user with a list of hardwired choices reflecting your judg-
ment about appropriate options.

For example, if you want the user to select between light, medium, and
dark blue for the BackColor of a UserForm, put only those names in a
ListBox. The user must follow your aesthetic rules because those are
the only options that you offered.

4+ Provide the user with the only possible choices.

Only a limited number of font style settings are available, so your
ListBox would contain only those options.

4+ Make a ListBox more accommodating to the user.

Add a TextBox or other controls to the UserForm as adjuncts to a
ListBox, offering the user more flexible control than a lone ListBox
would normally offer. Let the user, for instance, select from CheckBoxes
or OptionButtons to AddItems to your ListBox.

ListBoxes can be made more efficient in some situations by adjusting their
MultiSelect, ColumnCount, and TopIndex properties. MultiSelect per-
mits the user to select more than a single item at a time; Columns displays
more than a single vertical list of items; and TopIndex allows your program
to scroll the list, independent of the user.

The Text property of a ListBox always contains the currently selected item
(available as a text [string] variable). X = Listl.Text would allow your
program to examine and react to the selected item in the box. The Text
property of a ComboBox, however, can contain something the user might
have typed in — some text that’s not part of the box proper.

The user can select an item from a ListBox by clicking it or by typing in its
first letter. This triggers a C11ick event without using the mouse.

The CheckBox control

Check boxes allow the user to select from among several options, and more
than one of these options can be simultaneously selected. The OptionButton
is a similar, related control, but only one of them can be selected at a time.

The Value property of a CheckBox determines whether a given box is
unchecked, checked, or grayed out (meaning that it can’t be selected by
the user at this particular time; it’s inactive and unavailable as an option).
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The user can trigger a CheckBox by clicking anywhere within the frame of a
CheckBox (on the box image, on the caption, or even outside the caption if
the frame is larger). The box that has the focus is indicated visually while
the program runs by a dotted-line box around the caption. In other words, if
a particular CheckBox (among all the controls on a window) has the focus, it
will have a faint, gray line around it.

The OptionButton control

OptionButtons are similar to CheckBoxes, but OptionButtons allow the
user to select one choice from a group of mutually exclusive choices. That is,
selecting one button automatically deselects all the other buttons in the
group. Only one OptionButton in a group can be selected at a given time.

This control is frequently referred to as a radio button group because it oper-
ates the way the buttons do on an old car radio (think Rambler or DeSoto,
not Escort or Passat). Time-warp back (or ask your dad) about how you liter-
ally had to press a button to make the currently selected button pop out. In
control terms, when you click a radio button, the currently selected button
is deselected. In other words, only one radio button in a group can be
selected at a time.

CheckBoxes are used in groups too, but any number of CheckBoxes can be
selected (active) at a given time.

You could use a group of OptionButtons if you want to offer the user a
choice of possible BackCoTlors for a UserForm. Because there can be only
one background color on a UserForm at a time, the choices are mutually
exclusive. For example, if the button for Green were previously in effect and
the user selects Magenta, Green should pop out and become inactive.

OptionButtons can be placed directly on a UserForm or grouped within a
Frame control. If you want to create a group of OptionButtons that will
cause each other to pop out when a new one is selected, they must all be on
the same UserForm or within the same Frame. You can create more than one
group of OptionButtons on a single UserForm by placing each group within
a Frame, which acts as a container.

To place an OptionButton within a Frame, for example, first put a Frame
control on a UserForm; then drag and drop the OptionButton icon from the
VB Toolbox.

The group of OptionButtons that you place into a Frame all move together
if you drag the Frame around. And, more importantly, the OptionButtons
are now part of a team, and pressing one will automatically pop out any of
the others.
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The ToggleButton control

A ToggleButton is essentially a CheckBox in a fancy costume. It has two
states, on and off, and the user can tell when it’s on because it looks as if it’s
depressed into the UserForm. Like OptionButtons, ToggleButtons can be
grouped inside Frames.

The Frame control

Frames have something in common with UserForms: They are dual-purpose
entities that can assist you in organizing your program both visually and
structurally. Frames subdivide a UserForm into logical zones (to visually
clue the user about the relatedness of variously framed sets of controls).

A Frame can draw a visible line around a group of controls. This alerts the
user that these controls, like a set of OptionButtons, are working together
toward some purpose — such as selecting a graphic, or a record in a data-
base. More importantly, a Frame can group controls drawn on top of it. This
grouping has two effects.

One, while you are designing your program, you can drag the Frame around
on the UserForm, and any other controls contained within the Frame will
follow it as a unit. They have been contained within the Frame. This simpli-
fies design and maintains the positional relationship between the grouped
controls.

To group controls, you must first add the Frame to the UserForm. Then
drag and drop the other controls from the Toolbox — or elsewhere on the
UserForm — into the Frame.

VBA also allows you to surround a group of controls by dragging the mouse
around them (or by clicking them while holding down the Shift key). Then
they can be dragged in concert.

The second effect that frames have is that all OptionButtons contained
within a particular Frame or PictureBox are considered a unit. If the user
clicks one of these buttons, any other button in the unit that was selected
will be deselected. For more on this, see the section, “The OptionButton
control,” earlier in this chapter.

A Frame sinks its Caption into the Frame border, to the left side. If this
design style appeals to you, the Frame offers it.
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The CommandButton control

Just like the C11ck event is the most popular event in Visual Basic, so the
CommandButton is perhaps the most frequently used control. It provides
visually intuitive, direct access: The user sees the caption and simply clicks
the command button to get something done. The animation offers good,
strong feedback; there’s a real sense that something has happened, unlike
some other VBA selection methods.

Use CommandButtons any time the user needs to make something happen in
the program. Accompany them with pictures (by setting their Picture prop-
erty). Use Label controls to explain the button’s purpose to the user.

The TabStrip and MultiPage controls

The TabStrip can be a useful control because it organizes information in a
way similar to a card file of 3 x 5 cards, with divider tabs to indicate logical
categories. In other words, it’s similar to some of the dialog boxes and prop-
erty windows displayed in various Windows applications.

Display large amounts of data

Use a TabStrip when you want to display a considerable amount of informa-
tion to the user and need to organize that information into categories.

The TabStrip control offers the user a more visually intuitive and easier to
use format than the traditional menu approach to changing an application’s
options or preferences.

MultiPage does basically what a TabStrip does except it’s easier for the
programmer to work with.

When an event fires in a MultiPage or TabStrip control, you see a different
syntax than you find in other controls. An index is passed as an argument to
the event, so that you (the programmer) can figure out which page or tab on
the control was clicked (or otherwise triggered an event). For example

Private Sub TabStripl_Click(ByVal Index As Long)

End Sub

Designing a MultiPage control

It’s not difficult to design a MultiPage. Just drag it so that it fills the
UserForm. (This looks best, and users expect to see a tab-style page as a
single entity — not as a part of a larger window.) Then from the Toolbar,
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drag and drop whatever controls you want on page one. Click the Page?2 tab
and add controls to it. If you want additional pages, right-click the Page? tab
and choose New Page. You can also choose Move from this same right-click
context menu to rearrange the pages.

The ScrollBar control

A Scroll1Bar is an analog control, like the volume knob on a stereo. The
position of an analog control offers a visual analogy corresponding to, and
illustrating, the status of the thing it adjusts.

Such controls can be turned all the way up or all the way down or can be
moved gradually between the extremes. Scrol1Bars are, therefore, appro-
priate for allowing the user to adjust things that have a range of possible
states, such as background color. This range of states should also be con-
tiguous, like how the colors of a rainbow blend into each other across the
spectrum.

And, of course, the classic use for Scrol1Bars is to help the user move data
up and down in a window (or sideways).

You can reverse the direction of a Scrol1Bar. Normally, Max is at the far
right of a horizontal bar and at the bottom of a vertical bar. However, if you
set the Max property to a number lower than the Min property, the Max flips
and becomes the far left of a horizontal bar and the top of a vertical bar.

A Scroll1Bars property of the TextBox control adds an internal scrollbar to
that control.

The SpinButton control

This simple control increments and decrements numbers when the user
clicks it. You can use it to manipulate the values displayed in other controls,
such as changing the date displayed in a label. To get an idea how it works,
add a SpinButton and a Label to a UserForm; then double-click the
SpinButton to get to its Change event. Type this into the event, press F5,
and click the SpinButton to observe the activity:

Private Sub SpinButtonl_Change()
Labell.Caption = SpinButtonl.Value

End Sub

Adjust the Min and Max properties to suit your needs.



Figure 4-9:
Clipping
mode
versus
stretch
mode.

Understanding Controls '49

The Image control

The Image control holds graphics, displaying BMP, GIF, JPG, ICO, and WMF
graphics files. Graphics placed in an Image control can be freely resized.
You can stretch or shrink the graphics to suit your needs by adjusting the
PictureSizeMode property. Zooming, stretching, and clipping — to pre-
serve the original resolution — are all available techniques.

Figure 4-9 illustrates the clipping mode in the image (top) and the stretch mode
(bottom). Set the PictureSizeMode property to fmPictureSizeModeStretch
if you want the entire graphic to display no matter how you resize the Image
control that contains it.

UserForm1 %]

\\3

UserForms can also display graphics, via their Picture property.
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Chapter 5: Moving to the Internet

In This Chapter

v Developing Web Pages
1 Using Web controls

v+ Understanding database security levels

In this chapter, I show you how to use Office 2003 to build Web pages.
You also discover how to manage Internet security features, use Web
controls, and create a direct connection between a database and an Internet
Web page by using the data-access page feature in Access.

Taking Office 2003 to the Web

Office 2003, like most other major applications, has provisions for the
Internet, both in terms of input and output. The input “features” include
hyperlinks embedded in documents that, when clicked, result in that annoy-
ing (to me, anyway) surprise when the Internet Explorer browser suddenly
takes over a window, or a pane, within an application or utility. Press the
wrong keys or click a hyperlink by accident, and suddenly Word or Windows
Search utility transforms into a kind of faux browser. Even Windows Explorer
also participates in this sudden and — I think unwelcome — transformation.
When I want to surf the Internet, [ prefer to do it in the full browser and not
some partial browser that invades another program.

As for output — displaying your information in Web pages for the world to
see — Office 2003 applications include some special controls, wizards, and
other features to help you do just that. For example, the Microsoft Office
Web Components are controls you can use to display charts, spreadsheets,
and database contents on the Internet. And you’ll likely be amazed at how
the Access data-access page helps you easily and quickly create connec-
tions between databases and Web pages. That used to be quite a tough job.

Moving Office to the Web

Although the four Internet-related controls in the preceding steps are the
most visible Internet-related elements in Office 2003, additional features in
Office also contribute to the job of publishing on the Web. Many Office 2003
applications use the Web (or an intranet site) to assist in various kinds of
collaboration and user communication.
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One simple Web publishing feature is available in Word and Excel. Choose
File>Save as Web Page from Excel or Word, and an HTML version of your
spreadsheet or document is stored. These versions can be directly displayed
in Web pages. An HTML file is — for all practical purposes — simply a Web

page. Loaded into a browser, it becomes a Web page.

If you open the .mht (a single-page version of HTML) file in a browser, it

looks like Figure 5-1.
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You can also use the Save As Web Page dialog box to save your document as

an ordinary HTML page or even as XML.

When you use the Save As Web Page feature, any elements in your document
that must be translated for browser viewing are described. For instance,

when | saved this Word page, | was told that

4+ Decorative border styles will appear as single-line borders.

4 Pictures and objects with text wrapping will become left- or right-aligned.



Loading Additional Controls ’53

However, these saved documents are not interactive. They're static, like
snapshots. To permit the user to interact with your Office 2003 applications’
data, you can use the special controls that you added to your toolbox earlier
in this chapter.

Loading Additional Controls

Figure 5-2:
Add new
controls to
the Toolbox
with this
dialog box.

When you add a UserForm to a VBA project in an Office application, a
Toolbox also appears. This Toolbox contains a set of controls you can drag
and drop onto the UserForm to build the user interface. However, this isn’t
the entire story; there are more controls you can employ for special pur-
poses. To load additional controls to display Office applications’ information
on the Internet, follow these steps:

1. In Excel, press Alt+F11.
The VBA editor window opens.

2. In the editor, choose Insert>UserForm.

A new UserForm — and the Toolbox with its controls — appears. For
more on UserForms, see Chapter 4, Book II.

3. Right-click the Toolbox and choose Additional Controls from the con-
text menu.

The Additional Controls dialog box appears, as shown in Figure 5-2.
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4. Scroll down until you find the following controls in the dialog box:
* Microsoft Office Chart 11.0

e Microsoft Office Data Source Control 11.0
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Figure 5-3:
These
added
controls
help you
display data
onthe
Internet.

S

e Microsoft Office PivotTable 11.0
e Microsoft Office Spreadsheet 11.0

To see what these controls are used for, see the section, “Using the Web
Controls,” later in this chapter.

If you don’t see these controls listed in the dialog box, close the dialog
box and download them from the Microsoft Web site at

www.microsoft.com/downloads/details.aspx?familyid=
7287252C-402E-4F72-97A5-E0FD290D4B76&displaylang=en

You might see versions 10.0 of these controls or other versions. Mark
the check box next to the most recent versions. Another name for Office
2003 is Office 11, so generally you’ll look for Office 11 components when
adding features.

Click the check box next to each control name in Step 4.
Click OK.

The Additional Controls dialog box closes, and you see that four new
icons have been added to your Toolbox, as shown in Figure 5-3.

Toolbox

’TAahI

Controls I

F « 2 <
2| [

The new control icons

Using the Web Controls

Here’s a summary of the four Office 2003 Web Controls that I show you how
to load earlier in this chapter:

4+ ChartSpace: The ChartSpace control lets you display graphs and

charts from a worksheet or pivot table (Access and Excel) or a database
table (Access). You can display more than one graph or chart at a time.
(This control is a container, which is probably why it’s called a space.)
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PivotTable: The PivotTable control allows users to interact with a
worksheet or database table. Options include filtering, outlining, and
sorting. Pivot tables are reports that can be quickly switched to show
various views on a set of data. You can find much more on pivot tables
in Book IV, Chapter 4, “Data Diving with PivotTables.”

Spreadsheet: The Spreadsheet control displays a basic version of a
worksheet but does allow users to manipulate functions and recalculate.

DataSource: The DataSource control is not displayed to the user but
does help the programmer create a connection between a data source
and the Web page or controls on that page.

You can also drop these controls into spreadsheets or UserForms for
Windows programming, rather than Internet purposes.

Publishing an Excel Spreadsheet

You can Web-publish a single Excel spreadsheet or pivot table but not an
entire workbook. Obviously, publishing this kind of data might be especially
useful as a way to share information with co-workers, even those on the
road. To see how to display an interactive spreadsheet in a Web page, follow
these steps:

\\3

1.

Run Excel and choose Filec>New.

The New Workbook pane opens. (If it doesn’t open, choose Viewr>
Task Pane.)

Click the Templates on Office Online link.

Choose an Excel template, such as the Buy vs. Lease Car Calculator
template (listed under the Finance and Accounting link, then the
Personal Finance link).

Click the Download button to bring it into your version of Excel.

If you want to see how this entire sheet would look in a Web page,
choose File>Web Page Preview.

Drag your mouse to select the range of cells you want to publish, as
shown in Figure 5-4.

Choose Filer>Save As Web Page.

Click the Selection radio button to publish only the range, as shown in
Figure 5-5.
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To publish
onlya
selected
range,
click the
Selection

radio button.

8. Click the Add Interactivity check box.

This determines that the spreadsheet isn’t read-only when displayed in
the Web page, permitting users to actually use the spreadsheet.

9. Click the Publish button.
The Publish as Web Page dialog box opens, as shown in Figure 5-6.



Figure 5-6:
Make any
changes
you wish
to the
published
sheet here.
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10. Ensure that the Add InteractivityActivity With check box is checked.

11. Specify a filepath for your Web page.
12. Select the Open Published Web Page in Browser check box.

13. Click the Publish button.

After some behind-the-scenes grinding away, the Web page file (.mht) is
stored on your hard drive, and Internet Explorer opens with the spread-
sheet range displayed, as shown in Figure 5-7. This spreadsheet range is
a Web page, and it is dynamic. Users can type in data, formulae, and per-

form calculations.

Type some data into this Web page and then choose Viewr=>Source in

Internet Explorer to see the underlying HTML code that was generated to
create your Web page. Here’s one interesting part of the code, where the

Excel spreadsheet object is defined:

<object
id="Buy vs_26422_Spreadsheet"

classid="CLSID:0002E559-0000-0000-C000-000000000046">
<param name=DisplayTitleBar value=false>

<param name=ViewableRange value="$A$1:$B$20">

<param name=Autofit value=true>

<param name=DataType value=XMLData>

In the preceding code block, note the c1assid. That’s a unique number

(or so you hope) that identifies the Microsoft Office Spreadsheet Web

Component version 11. Version 10 has this similar but unique ID number:

0002E551-0000-0000-C000-000000000046
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Figure 5-7:
Post a
functional
spreadsheet
range as a
Web page.
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(See more about the version differences in the earlier section, “Loading
Additional Controls.”)

Securing a Spreadsheet: Protecting Cells

\\3

You might want to display some cells in a spreadsheet that are protected:
namely, that the user is not permitted to modify. In the following example
(using the Buy vs. Lease Car template), you want to freeze the Refundable
Security Deposit cell at 0 (zero) and not allow users to make any changes
toit.

To see how to publish a selectively disabled spreadsheet, follow these steps:

1. In Excel, open the spreadsheet template from the preceding example.
2. Type 0 (zero) into one of the cells.
Your goal now is to disable this cell so that the user can’t adjust it.

3. Drag your mouse to select the cell (with the 0) that you want to dis-
able. (It may appear selected after you complete Step 2, but it isn’t.
You must drag to see the context menu in Step 5.)
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Right-click the selected cell.
Choose Format Cells from the context menu that appears.

The Format Cells dialog box opens, as shown in Figure 5-8.

Format Cells 2]
Nurnber | Aligreent Faork Border | Patterns | Protection
iocked!
[ Hidden
— Locking cells or hiding formeas has no effect unless the
worksh_cct is protected, To probect the worksheet, choose
Figure 5'8: t}_:?tttz;gsc:\rmtlrlgll'lets&:gu, and then choose Protect
Use this
dialog box
to protect
(disable) a
cell or range
of cells. ==
6. Click the Protection tab in the dialog box.
7. Click the Locked check box to add a check mark.
8. Click OK.
The dialog box closes.
9. Choose Tools=>Protection=>Protect Sheet.
In the Protect Sheet dialog box that opens, you can choose various
levels of protection.
10. Leave the default settings as they are and click OK. These defaults
allow the user to select, but not edit, the locked cell.
QNG The dialog box closes.
V.
s Don’t choose the Password option in the Protect Sheet dialog box — if
you do, the cells can’t be used in a Web page.
11. Select the range of cells you want to publish — perhaps a dozen cells
surrounding the protected one — so you can test the protection feature.
12. Choose Filer>Save As Web Page.
13. Enable the Selection radio button to publish only the range.
14. Click the Add Interactivity check box.

Now all the cells in the spreadsheet (other than the protected one) can
be modified by the user when displayed in the Web page.
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Figure 5-9:
Not so fast,
dude. This
cellis read-
only, so
forget about
changing it.

15. Click the Publish button.
The Publish as Web Page dialog box opens.

16. Ensure that the Add Interactivity With check box is checked.

17. Specify a filepath for your Web page.

18. Click the Open Published Web Page in Browser check box.

19. Click the Publish button.

Now try to make changes to that 0 in the protected cell. Doesn’t happen.
Instead, a message box informs you that this cell is read-only, so your efforts

to modify it are doomed, as shown in Figure 5-9.
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Publishing Access Data

Access doesn’t work the way that Excel does; no

already an HTML document — and thus, already

Although data-access pages are used to create Web pages, you can also
employ them within the Access application itself in Windows. And, either
within a browser or Access, a user can edit and add or delete records as well

as sort and filter the data.

File>Publish as Web page
feature exists. Instead, you use the special data-access page, which is
published, in a sense. You
can permit users to interact with data — or indeed to use the Web controls
(Chart, PivotTable, or Spreadsheet) — within a data-access page.
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Figure 5-10:
Click the
Pages
object to
begin
building a
data access
page.
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Publishing Access Data

Data access pages can be created several ways:

4+ Convert an existing Web page or Access report (or table, form, or
custom view).

4 Start from scratch.

4 Use a wizard in Access.

Whichever method you choose, you’ll avoid the maddening tedium and
downright waste of human time writing HTML by hand to accomplish the job
of building an interactive, database-connected Web page. Programmers used
to write this stuff by hand; fortunately, wizards and other automated features
make a Web programmer’s life far more pleasant these days.

Creating a data access page

To see how to create a data access page from an opened database, follow
these steps:

1. In Windows Explorer, open the Northwind sample database
(Northwind.mdb) in Access.

Northwind can be found at C: \Program files\Microsoft 0ffice\
0fficell\Samples. Choose Help|Sample Databases, then select
Northwind Sample Database. If it’s not there, go to Windows’s Control
Panel, choose Add/Remove Programs, then find and click Microsoft
Office, click the Change button, and follow the instructions to install the
Northwind sample database.

2. Start creating a data-access page by choosing Pages (in the left pane of
the database window, as shown in Figure 5-10).
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Figure 5-11:
Choose
here which
data access
page
approach

to take.

3. Click the New button on the database window toolbar.

The New Data Access Page dialog box opens, as shown in Figure 5-11.

Mew Data Access Page B[]

Design View
Existing web pags
Page Vizard
AutoPage: Columnar

This wizard sukomaticaly
creabes 3 columnar data
ACCEss page.

Choose the table or query where Employaes] Py

the object's data comes From:

s

=

Click the AutoPage: Columnar option.

5. In the drop-down list at the bottom of the dialog box, choose the
EmpTloyees table as your data source (refer to Figure 5-11).

6. Click OK.

The dialog box closes, and your new data-access page appears, as
shown in Figure 5-12.

Notice in Figure 5-12 that a set of database manipulation icons are available
in a strip along the bottom. These include the usual first, previous, next, and
last record navigation buttons, as well as new record, delete record, sorting
and filtering buttons. The user has quite a bit of freedom to manipulate and
view this table from the database.

Deploying a data-access page

To save the data-access page (so you can drop it into a Web site via
FrontPage or other Web site-building tools), just click the data-access page’s
toolbar to select it. Choose Filem>Save, and you’ll see a Save dialog box
where you can specify where the . htm (HTML) file will be stored.

After the file is saved, you see a warning dialog box telling you that you've
saved the file to an absolute filepath (a hard-wired address on your hard
drive) as opposed to the more desirable network Universal Naming
Convention (UNC) path. If you intend for others on your intranet to use this
file, you should indeed correct the address. However, if you're deploying the
file to a server for Internet Web site purposes, you undoubtedly know how
and where to store the file — just store it in the same directory along with
your other Web pages.
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¥ Employees == %]
Last Name Davali 2
First Name [Mancy
Title: Sales Representative
Title Of Courtesy  |Ms.
Birth Date 08-Dec-1268
Hire Date 01-May-1952
Address: A07 - 20th Ave. E
C|ty [Seattle
Region: [twia,
Postal Code |9a1z2
Country: UsA,
Figure 512 | Home Phone {205) 555-6857
A finished |
Extension: 5467
data access
page, Photo: ErnpiD1,bmp
showing the Notes: [Education includes a BA in psychology from Colorade State
- University. She also completed "The Art of the Cold Call."
TIrSt record Mancy is a ;ember of Toastmasters International
in the
Employees Reports To 2
table. 4 Employees 1 of 9 MR Hp a2 T (7] =1
After the file is saved, it can be displayed in a browser, just like a Web page
because it is in fact (hmmm) a Web page. In Windows Explorer, double-click
the employees.htm file (or whatever name you saved the file). If you
(or your machine’s administrator) applied some permissions security meas-
ures to this location, you'll see a message like the one displayed in Figure 5-13.
Figure 5-13:
Security
measures Microsoft Internet Explorer =]
can prevent A Th_e database has bean placed in a state by user Admin’ on machine 'DELL' that prevents it from
a database . being opened or locked.
from being
accessed
from a Web

browser.
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However, precisely this same security warning can be displayed erroneously.
The message should also state
This file or database may currently be in use by another application or
process.
If you haven’t shut down Access and it’s still displaying the data-access file,
shut Access down now. Then try double-clicking the employees.htm file in
Windows Explorer again.
This time you should see it appear in Internet Explorer, as shown in
Figure 5-14. You've made a connection between your Access database
and a Web browser; users can manipulate this database from the Internet.
&] Employees - Microsoft Internet Explorer i %
Eile Edit View Favorites Tool =~ Address | €] poysesihim v | £ &0 ) Bac =
ks 5] 12t @]amet B]Amen &) advo gleec EJonn WPebay £]Et @&l Modd gl 2
Google~ v| Gsearchwes - @ocachsic +p 8 g P2
bl
Title: Sales Bepresencative
Title Of Courtesy ns.
Birth Date 08-Dec-1968
Hire Date 01-May-1992
Address: 507 - 20th hve. E.
Clt}’ Seattle
Region: Lz
Postal Code o812z
Country: msa
Home Phone {206) 555-9857
Figure 5-14: Extension: 5467
Make a Photo: EwpID1. Dby
Connect|0n Notes: Education includes a BL in psychology from
Colorado State Uni sity. Jhe l=o
bEtween cgmpi:ted "?‘h: A::VEE ;he ColdEC:Li."’
yourAccess Hancy is & werpber of Toastmasters
database Reports To 2
and a Web 4 Employess 1 of 9 oMb R 4R T [
browser.
< | ¥

Experiment a bit with the database records by trying some of the manipula-
tion and maneuvering tools on the toolstrip at the bottom of the Web page.
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Also, to give yourself a thrilling yet frightening treat, right-click the back-
ground of the Web browser and choose View Source from the context menu.
You now see the enormous amount of HTML that’s been created for you. This
is why I said earlier that creating database-connected Web pages (indeed
pretty much any kind of a Web page) used to be HTML hell. Imagine having
to write this stuff by hand, as people used to do.

Also notice that buried in the HTML code is a Data Access control as well
as the various parameters that it uses, including the Northwind sample data-
base, the Jet database engine, and various security settings. Here is the por-
tion of the HTML that defines the control:

<OBJECT 1d=MSODSC tabIndex=-1 L

classid=CLSID:0002E553-0000-0000-C000-000000000046> SIEITE

<PARAM NAME="XMLData" VALUE="<xml xmlns:a=&quot;urn:schemas-
microsoft-com:office:access&quot;>&#13;8&4#10;
<a:DataSourceControl>&#13;&#10; <a:0WCVersion>10.0.0.5605
</a:0WCVersion>&#13;&4#10;
<a:ConnectionString>Provider=Microsoft.Jet.0LEDB.4.0;User
ID=Admin;Data Source=C:\Program Files\Microsoft
0ffice\OFFICEI1\SAMPLES\Northwind.mdb;Mode=Share Deny
None;Extended Properties=&amp;quot;&amp;quot;;Persist
Security Info=False;Jet OLEDB:System
database=&amp;quot;&amp;quot;;Jet OLEDB:Registry
Path=&amp;quot;&amp;quot;;Jet OLEDB:Database
Password=&amp;quot;&amp;quot;;Jet OLEDB:Engine Type=0;Jet
OLEDB:Database Locking Mode=1;Jet OLEDB:Global Partial
Bulk Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet
OLEDB:New Database Password=&amp;quot;&amp;quot;;Jet
OLEDB:Create System Database=False;Jet OLEDB:Encrypt
Database=False;Jet OLEDB:Don't Copy Locale on
Compact=False;Jet OLEDB:Compact Without Replica
Repair=False;Jet
OLEDB:SFP=False</a:ConnectionString>&#13;&#10;

Jaulajuj ay) o0}
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Security: Locks on Top of Locks

Always an interesting topic (to some of us anyway), security takes many
forms in today’s computers. Layers upon layers of technology exist these
days, all trying to save us from intruders, probes, spies, and virii of various
kinds. Security initiatives today have become rather overdone. Like doors
you see in New York City apartments, there are locks upon locks, sliders,
chains, multiple bolts . . . as if quantity were quality.

Of course, if you take a few, easy common-sense precautions, you have noth-
ing much to fear. If you simply back up your documents frequently, refuse to
open e-mail attachments or execute programs from unknown sources, and
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use a firewall when connected to the Internet, you're in little real danger
from anything that the big, bad hackers and whackers can do to your
machine.

Nonetheless, it’s annoying to get spied on or have to reinstall your applica-
tions after a virus attack. Most careful people never experience a virus attack
in their personal computers at home, but the danger in lost productivity in
office situations is clear. And the more connectivity (the more people online
at an office intranet for example), the more likely that someone in the office
will be dumb enough to try to open an e-mail attachment named BIGFUN. EXE
or something and infect the whole place.

With .NET, and the general thrust to make security a priority, security initia-
tives are flowing freely into every level of computation. This isn’t merely a
Microsoft phenomenon — almost everyone selling anything related to com-
puting has security on the mind (and in the advertising). It’s almost enough
to make one bemused.

Securing databases

If you create a direct connection between a database and an Internet Web
page by using the data-access page feature in Access, any visitor to this page
can alter or delete records. Think about it. You've exposed your quivering
hard drive to the depredations of the world’s bad guys.

In the earlier section, “Securing a Spreadsheet: Protecting Cells,” [ show you
how to post an Excel spreadsheet to the Internet and selectively specify
some or all cells as read- only, thus preventing users from making any
changes to it.

Likewise, you can protect databases in a variety of ways — everything from
encrypting the data so users can’t see what they shouldn’t see to employing
user-permissions (Toolsw>Security=>User and Group Permissions) or pass-
words so that only authorized people get to look at the data — and perhaps
only a subset of those people are given full permissions so they are able to
actually modify the data.

An easy way to manage user-level security settings is to select the main data-
base window and then choose Toolsw>Security=>User-level Security Wizard.

If you assign a password to a database file, only people whom you tell the
secret password are able to open it. After they’re in, though, they’re com-
pletely in and can do whatever they want (unless you've separately specified
user-level security permissions), so passwords by themselves are sometimes
an all-or-nothing approach. You can password-protect only .mdb database
files (see the upcoming section, “Protecting your code,” for the scoop
on.mdb’s cousin, .mbe.) Follow these steps:
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1. Choose Filec>Open in Access.
The Open dialog box opens.

Here’s a weird Ul feature. The Open button on the lower right of this
dialog box has a drop-down feature. A little arrow on it. This is the first
time I've ever seen a drop-down button — but you never know. Somebody
thought this unique approach was clever or something. Baffles me.

2. Click an .mdb file in the Open dialog box to select it.

3. Click the down-arrow icon on the Open button, as shown in Figure 5-15.
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Dediton e rasic
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e s

Py Dazumenks || ) berohision
| Uisan Stude Frojects

w8 |5
My Computer ||5
«) ERw
. ) Fhe et s = fom -
My Mebwork, s =
Flaces | Fhs ol Moot Offos Access (™ ade; *mds;“unds; ™ ok v | Open

Open Bead-Only
Open Exclusive
Dpen Excusive Read-Only

4. Choose Open Exclusive in the drop-down button list.
5. Choose Tools>Security=>Set Database Password.
6. Type in whatever password you want to use.

This password is case-sensitive.

You can remove passwords by choosing Tools=>Securitym>Unset Database
Password.

Protecting data-access pages

In Book VIII, Chapter 7, I cover various Office 2003 security features in depth.
For now, be aware that you can protect a data-access page by opening it in
design view. (Choose Viewr>Design View with the data-access page selected.)
Right-click the section bar in the group that you want to make read-only.
Then, from the context menu, choose GroupLevel Properties. The GroupLevel
Properties dialog box appears, as shown in Figure 5-16.
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Figure 5-16:
Protect
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data access
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dialog box.
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GroupHeader . ...y True
Recorddamigationsection , , . Troe
RecardSelector ... o0u False

In the GroupLevel Properties dialog box, enable whatever kinds of protection
you want to enforce: forbid additions, deletions, editing, or any combination
of these permissions.

Protecting your code

Another aspect of security is protecting the programming that you do from
others. Perhaps you’ve come up with an excellent solution that you want to
hide from prying eyes. Or perhaps you just want to hide the code so others
won’t mess around with it and introduce bugs.

You can save an .mdb file in a different format (.mde; the e is for encrypted).
Similarly, you can also transform . adp files into . ade files.

When saved as an . mde file, all your VBA modules are compiled (turned into
machine language executables), and your readable source code (what you
see when programming in the VBA editor) is removed. As a result, people can
execute — but not read (or modify) — your VBA programming. This kind of
security is pretty efficient. You don’t have to subdivide your users into vari-
ous levels of permissions, or manage passwords, and so on. You're just giving
out the executable and not letting anyone into the source code that generates
the executable. Users of .mde files can’t use design view to import, export, or
modify forms, reports, source code, or modules. Nor can they add, remove,
or modify references to databases or code libraries. They can’t even open the
Object Browser. (Data access pages, tables, queries, and macros can, how-
ever, still be imported from, or exported to, databases that are not saved in
the .mde format.)

Say you've written some VBA code in Access, and you don’t want others
viewing your macros or programs. Here’s how to transform an unprotected
Access database into an .mde database:
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1. Open your .mdb or .adp file and ensure that no one else on the net-
work is currently viewing it.

2. Choose Tools>Database Utilities>Make MDE File.

If Access finds that you’re trying to save an Access 2000 database in the
.mde format, it informs you that the database must first be converted
into an Access 2003 version. To do so, click the Main database window
to select it, and then choose Tools=>Database Utilitiesz>Convert Database.

The Save dialog box opens.

3. Specify where you want the new database saved; then click Save.

The new .mde or . ade file is saved.

Your original .mdb or . adp file still remains on the hard drive. It’s not deleted
because you might want to modify it later, so you should keep your original in
a secure place. Note that you can’t revert an .mde or .ade database back
into an .mdb or . adp version. Also be aware that you’ll run into versioning
problems if people have been modifying data in an .mde or .ade version,
and then you want to make some changes to, say, a macro. You can'’t easily
reconcile the versions.
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Chapter 6: Debugging

In This Chapter

v+~ Handling typos
v~ Trapping errors within code
v Locating logic errors

v Using step-throughs, watches, and other debugging techniques

B ugs — errors in a computer program — are inevitable. You can be enor-
mously painstaking, tidy, and thoughtful, but if your program is more
than 50 lines long, errors are likely to occur. If it’s longer than 100 lines, errors
are virtually certain.

Macros are short enough that you might create five or six of them without a
bug, but odds are that you won’t. One reason, though, that short programs
like macros are easier to write bug-free (aside from the obvious point that
there’s simply less code to err in) is that much of the job of debugging long
programs is the work you must invest finding and fixing the very worst bugs
(logic bugs). You'll spend a lot of time just figuring out where the little crit-
ters are. Locating bugs in large programs is usually much more difficult than
actually fixing them. Most macros, though, are small enough that you already
know where the bug is: It’s right there in the few lines of code that you're
staring at.

However, if you write programs in VB.NET (as I describe in several chapters
in Book VIII), you’ll have more code to look through. To debug longer pro-
grams, you want to avail yourself of several of the tools like watches, as |
describe here, that help you track down exactly which line contains the bug.

Roll up your sleeves and see what tools the VBA and .NET editors offer for
those who need to track bugs down and kill them dead. Because VBA pro-
grammers stand astride two different languages — classic Visual Basic rep-
resented by VBA, and the future of BASIC, VB.NET — this chapter covers the
error-trapping techniques available in both languages. If you're not ready to
transition to .NET just yet, simply ignore the comments applicable to that
language.
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Errors in computer programming fall into three primary categories:

4+ Typographical errors (includes syntax errors)
4+ Runtime errors

4+ Logic errors

[ deal with each in turn, starting with typos, which are the easiest. Logic
errors are the toughest.

Fortunately for us programmers, Visual Basic (VB) editors provide a powerful
suite of tools to help you track down and eliminate bugs. Basic programmers
have been the envy of the programming community for years. However, with
the arrival of Visual Studio .NET, all supported languages (namely C and its
derived daughter languages) now share the same editor (Integrated Design
Environment; IDE) and, therefore, the other languages have finally caught up.

Typos in Commands and Variables

Typos are the easiest errors to locate and correct. For example, Visual Basic
knows at once if you mistakenly type Prjnt instead of Print. If it doesn’t
recognize the word, it detects that kind of error and alerts you. When you
give VB an impossible command like Prjnt, VB realizes that it can’t do any-
thing with that line of code because that word just isn’t in the language’s
vocabulary.

VB also lets you know if you have a typo in a variable name. Typing an
Option Explicit in the top of the code window forces you to explicitly
declare all variables. This has the effect of preventing a particular kind of
typo: If you misspell the name of a variable, an error message will warn
you that the variable has not been declared. This alerts you that you’'ve
made a typo.

Command Name Errors as Typos

Perhaps you didn’t mistype something but instead mistakenly thought that
VB knew a command that it doesn’t know. For example, type in the command
Pass the Salt:

Sub Whaaa()
Pass the Salt

End Sub
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As soon as you press Enter after typing Salt, you have an error. VB expects
to see a command at the start of that line, and Pass is not part of the list of
commands that VB understands. To help you find your error, that line of
code turns red (in the VB editor) or is underlined (in the .NET editor). (In
.NET, VB also displays its best guess as to the nature of the problem in its
Task List window, although the suggestions can be a bit vague.)

If you press F5 to run the Pass the Salt code, VB displays a message box
informing you of compile or build errors. You can ask for Help in the VBA
error message box, but it, too, is a bit vague, reporting in this case that the
problem might be punctuation, a misnamed procedure, misspelling, and
several other possibilities.

Book Il
Chapter 6
Understanding Syntax Errors
o
Related to typographical errors are syntax errors. Computer languages can 2,
be snippy little schoolmarms when it comes to correct punctuation. And lan- é
guages don’t tolerate it when you leave out required arguments or put them 3

in the wrong order.

VB expects correct punctuation. This line — UserForml..BackColor =
B1ue — will trigger a syntax error because there’s no double-period punctua-
tion in VB’s Little Book of Correct Punctuation.

Another kind of error is when you don’t provide the right type of informa-
tion, or enough information, for VB to carry out a command:

CommandButtonl.Top

The information in this statement is incomplete. You've given only the name
of a control (CommandButtonl) and one of its properties (Top), but you
haven’t provided the information that tells the Top method which location
you want it to move to. That’s as incomplete a statement as an English sen-
tence like Mary’s Hair.

A third variety of easily detected (and easily fixed) error is an inconsistency
of some kind between parts of your program. For example, if you have a pro-
cedure that expects an argument, like the following:

Sub MultiBeep(numbeeps)
For counter = 1 To numbeeps
Beep
Next counter
End Sub
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and you try to call it but give no argument:
MultiBeep

VBA catches the error right away, displaying this message: Argument Not
Optional. (.NET displays this somewhat more complete message: No argu-
ment specified for non-optional parameter "numbeeps™)

P If you have the AutoListMembers option selected in Toolsw>Options=>Editor
(or in .NET: Tools=>Options=>Text Editor=>All Languages), VB displays the
argument list for any procedure that you're trying to call. This happens as
soon as you type the left parenthesis following the procedure’s name. Of
course, if you don’t type any left parenthesis, this doesn’t happen.

Handling Runtime Errors

Some errors occur only during runtime. Your code is valid code with no
typos or syntax errors, but something unexpected happens when the pro-
gram is running. This is often a problem related to contacting a peripheral,
such as a hard drive. For example, if the user has no diskette in Drive A:,
and your program executes this code:

Documents.Open "a:\test.doc" 'VBA
or the .NET version:
Open(5, "A:\Test.doc", OpenMode.Input) '.NET

VBA puts up an error message telling you that the file can’t be found.
VB.NET is somewhat more technical in its error message: An unhandled
exception of type 'System I0.IOException' occurred and so on.

VBA’s error message lets you choose between four buttons: Continue, End,
Debug, and Help. .NET’s buttons are Break, Continue, Ignore, and Help.

You need to prevent, or at least gracefully handle, runtime errors. It’s no
good having a smoothly running program that suddenly halts if the user has,
say, forgotten to put a disk into Drive A: or failed to close the drive door.

How Runtime Errors Occur

Runtime errors include various kinds of unexpected situations that can
come up when the program is running. While you’re writing the program,
there are a number of things you can’t know in advance about the user’s
system. For example, how large is the disk drive? Is it already so full that
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when your program tries to save a file, there won’t be enough room? Are you
creating an array so large that it exceeds the computer’s available memory?
[s the printer turned off, but the user tries to print anyway?

Whenever your program is attempting to interact with an entity outside the
program — the user’s input, disk drives, Clipboard, RAM — you need to take
precautions by using the On Error (VBA) or Try...End Try (.NET) struc-
tures. These structures enable your program to deal effectively with the
unexpected while it runs.

Unfortunately, your program can’t correct many runtime errors. For

\\J
instance, you can only let the user know that his or her disk drive is nearly BEeEl]
full. The user will have to remedy this kind of problem; you can’t fix it with Ch:nter 6
your code. v
; g
Using On Error or Try...End Try g
(=]
If a runtime error can occur, you should use the On Error or Try commands E

to trap the error. If you don’t use these error-trapping commands, Visual
Basic will provide an error message to the user (which might be very confus-
ing to the user), and VB might have to shut down your VB program as well.
This scares the wits out of new users. They sometimes think they’ve broken
the computer. Here’s a comparison of the traditional (VBA) On Error error-
trapping technique and the more advanced Try technique (.NET).

Using On Error (VBA)

.NET permits you to use the classic On Error technique: You don’t have to
revise this aspect of your older programs. However, for new programs that

you write in VB.NET, you might want to consider the possibility that a supe-
rior error-trapping and handling approach exists. It’s called structured error
handling, which implies that your familiar, classic VBA error handling is . . .
well . . . unstructured.

However, if you try to write some traditional VBA like If Err Then, you’ll
be informed that VB.NET doesn’t permit the ErrObject to be treated as
Boolean (True/False). But where there’s a will, there’s a way. You can test
the Err object’s number property. If you want to test the Err object within
an If...Then structure, use this VB.NET code:

x = CInt(textboxl.Text)
If err.Number <> 0 Then
textboxl.Text = "You must enter a number..."

End If
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Figure 6-1:
Be friendly
to users
with custom
error-
trapping
and error
messages
that are
descriptive.

Consider first the classic VBA On Error syntax. Because there is no
Drive Z:,the following input causes an error:

Sub Mungo()
Open "Z:\MYFILE" For Output As #1
Print #1, x
Close #1

End Sub

When this macro runs, a Path Not Found message will appear. Many users
will be baffled; some will undoubtedly go into a deep depression. Only expe-
rienced programmers or users will understand what Path Not Found means.
However, if you modify the macro to insert an error handling structure, you
can provide a more helpful message of your own and also make the program
continue to run rather than shut down:

Sub SavelIt()
On Error Resume Next
Open "Z:\MYFILE" For Output As #1

If Err Then

MsgBox (Error(Err)) & ". There was a problem with the disk
drive. Perhaps there is no Drive Z on your system?”

Close

Exit Sub

End If

Print #1, X
Close #1

End Sub

When this disk access fails, the user sees the helpful, custom error message
shown in Figure 6-1 instead of VBA’s cryptic, scary Path Not Found default
message.

Microsoft Word

Path not found. There was a problem with the disk drive. Perhaps there is no Drive Z on your system?
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Notice in the above code that you put an On Error Resume Next command
at the start of a procedure where you suspect that a runtime error might
occur (such as contacting a peripheral like the disk drive). This command
tells VB to not shut down the program if an error occurs. Rather, it should
resume execution of the next line of code following the error.

You then place the line that starts handling the error (If Err Then) just fol-
lowing the possible error (Open Z:). This code is sometimes called an error
handler or an error trap. The point is that you are saying this: If the Err vari-
able contains some value other than 0, there is an error. Consequently, you
must do something about that error in your code between the If Err and
the End If, asIdid in the preceding example. The Error(Err) command
feeds the error code (Err) to the Error function — and you get back a text
description of the error.

The UB.NET version: Structured trapping

If you're writing a .NET program, consider using the new Try...Catch...
Finally structure rather than VBA's On Error:

Sub TryError()

Try

Microsoft.VisualBasic.FileOpen(5, "A:\Test.Txt",
OpenMode. Input)

Catch er As Exception
MessageBox.Show(er.ToString)
Finally

End Try

End Sub

Code between the Try and End Try commands is watched for errors. You
can use the generic Exception (which will catch any error) or merely trap a
specific exception such as the following:

Catch er As DivideByZeroException

The term exception is used in C-like languages (and now in VB.NET) to mean
error. It sounds better, more PC, and certainly less embarrassing to tell the
boss, “l have a couple of exceptions in my program” rather than “I have a
couple of errors.”

Book Il
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[ use er in this example, but you can use any valid variable name for the
error. Or you can leave that variable out entirely and just use Catch, like

this:
Try
Microsoft.VisualBasic.FileOpen(5, "A:\Test.Txt", OpenMode.Input)
Catch
MessageBox.Show("problem")
Finally
End Try

When Catch executes

If an error occurs during execution of the source code in the Try section,
the following Catch section is then executed. You must include at least one
Catch section, but there can be many such sections if you need them to test
and figure out which particular error occurred. A series of Catch sections is
similar to the Case sections in Select Case structures. The Catch sections
are tested in order, and only one Catch block (or none) is executed for any
particular error.

You can use a When clause to further specify which kind of error you want to
trap, like this:

Dim Y as Integer
Try

Y=Y/0

Catch When y =0
MessageBox.Show("Y = 0")

End Try

Or you can specify a particular kind of exception, thereby narrowing the
number of errors that will trigger this Catch section’s execution:

Catch er As ArithmeticException
MessageBox.Show("Math error.")

Catch When y = 0
MessageBox.Show("Y = 0")

End Try

To see a list of the specific exceptions, use VB.NET’s menu Debuge>Windows=>
Exceptions and then expand the Common Language Runtime exceptions. You
might have to do a bit of hunting. For instance, the FileNotFound error is
located two expansions down in the hierarchy: Common Language Runtimer>
SystemException>IOException. So you have to expand all three nodes (click
the + next to each) in order to finally find FileNotFoundException.
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Also notice in the Exceptions window that you can cause the program to
ignore any of the exceptions. (Select the Continue radio button in the
Exceptions window.) This is the equivalent of On Error Resume Next in
older versions of BASIC such as VBA or VB 6.

Here is a list of common errors that you can trap in VB.NET. The following
errors are in the System namespace:

AppDomainUnloadedException, ApplicationException,
ArgumentException, ArgumentNullException,
ArgumentOutOfRangeException, ArithmeticException,
ArrayTypeMismatchException, BadImageFormatException,
Can'tUnloadAppDomainException, ContextMarshalException,
DivideByZeroException, DIT1NotFoundException,
DuplicateWaitObjectException, EntryPointNotFoundException,
Exception, ExecutionEngineException, FieldAccessException,
FormatException, IndexOutOfRangeException, InvalidCastException,
InvalidOperationException, InvalidProgrambxception,
MemberAccessException, MethodAccessException,
MissingFieldException, MissingMemberException,
MissingMethodException,MulticastNotSupportedException,
NotFiniteNumberException, NotImplementedException,
NotSupportedException, NullReferenceException,
OutOfMemoryException, OverflowException,
PlatformNotSupportedException, RankException,
ServicedComponentException, StackOverflowException,
SystemException, TypelnitializationException, TypelLoadException,
TypeUnloadedException, UnauthorizedAccessException,
UnhandledExceptionEventArgs, UnhandledExceptionEventHandler,
UriFormatException, WeakReferencekException.

The following errors are in the SystemI0 category:

DirectoryNotFoundException, End0fStreamException,
FileNotFoundException, InternalBufferOverflowException,
[0Exception, PathToolLongException.

You can list as many Catch phrases as you want and respond individually to
them. You can respond by notifying the user as in the previous example or
merely by quietly fixing the error in your source code following the Catch.
You can also provide a brief error message with the following:

e.Message
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Or, as in the previous example, use the following fully qualified error message:
e.ToString
Here’s the full Try...Catch...Finally structure’s syntax:

Try
tryStatements

[Catch [exception [As typell [When expression]
catchStatements

[Exit Try]

Catch [exception [As typell [When expression]
catchStatements

[Exit Tryl

Catch [exception [As typell [When expression]
catchStatements]

[Exit Try]

[Finally
finallyStatements]

End Try

Recall that following the Try block, you list one or more Catch statements.
A Catch statement can include a variable name and an As clause defining
the type of exception or the general all errors, As Exception (er As
Exception). For example, here’s how to trap all exceptions:

Try
Microsoft.VisualBasic.FileOpen(5, "A:\Test.Txt", OpenMode.Input)

Catch e As Exception
'Respond to any kind of error.

Finally

End Try
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And here is how to respond to the specific File Not Found error:

Try
Microsoft.VisualBasic.FileOpen(5, "A:\Test.Txt", OpenMode.Input)
Catch FileNotFoundE As FileNotFoundException

'"Respond to this particular error here, perhaps a messagebox to alert the
user.

Finally

End Try

An optional Exit Try statement causes program flow to leap out of the Try
structure and to continue execution with whatever follows the End Try
statement.

Using Finally

The Finally statement should contain any code that you want executed
after error processing has been completed. Any code in the Finally state-
ment is always executed, no matter what happens (unlike source code fol-
lowing the End Try line, which might or might not execute, depending on
how things go within the Try structure). Therefore, the most common use
for the Finally section is to free up resources that were acquired within the
Try block. For example, if you were to acquire a Mutex lock within your Try
block, you would want to release that lock when you were done with it,
regardless of whether the Try block exited with a successful completion or
an exception (error). It’s typical to find this kind of code within the Finally
block:

objMainKey.Close()
objFileRead.Close()
objFilename.Close()

Use this approach when you want to close, for instance, an object reference
to a key in the Registry, or to close file references that were opened during
the Try section (block) of code.

Mutex means mutual exclusion object. A Mutex object can help direct traffic
when more than one thread attempts to access a file or other resource.
When a thread makes a connection to the shared resource, it locks the
Mutex. It’s unlocked when the connection is no longer needed. Then other
threads are free to make their connections in the same lock/unlock fashion.

Book |
Chapter 6

buibbngag



182 Tracking Down Logic Errors
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Here’s how source code that you put within the Finally section differs from
source code you put following the End Try line.

If there is an error, here is the order in which code execution takes place:

1. Try section.
2. Catch section. (The Catch section that traps this error.)

3. Finally section.
If no error occurs, here is the execution order:

1. Try section

2. Finally section

3. Source code following the End Try line
Even if a Catch section has an Exit Sub command, the Finally section
nevertheless will still be executed. Remember that Finally is always exe-

cuted. However, the Exit Sub does get executed just after the Finally
block.

Tracking Down Logic Errors

The third major category of programming bugs — logic errors — is usually
the most difficult of all to find and fix.

Some can be so sinister, so well concealed, that you think you will be driven
mad trying to find the source of the problem within your code. BASIC pro-
gramming editors devote most of their debugging features and resources to
assisting you in locating logic errors.

Alogic error occurs even though you made no typos, followed all the rules
of syntax, and otherwise satisfied Visual Basic so that your commands can
be carried out. You and VB think everything is shipshape. However, when
you run the program, things go wrong: Say, the entire screen turns black, or
every time the user enters $10, your program changes it to $1,000.

BASIC’s set of debugging tools help you track down the problem. The key
to fixing logic errors is finding out where in your program the problem is
located. Which line of code (or multiple lines interacting) causes the
problem?
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Some computer languages have an elaborate debugging apparatus, sometimes
even including the use of two computer monitors: One shows the program
as the user sees it; the other shows the lines of programming that match the
running program. Using two computers is a good approach because when
you’re debugging logic errors, usually your main job is to figure out where
the code is that’s causing the problem.

It’s not that you don’t notice the symptoms: Every time the user enters a
number, the results are way, way off. You know that somewhere your pro-
gram is mangling the numbers — but until you X-ray the program, you often
can’t find out where the problem is located.

The watchful voyeur technique

Many logic errors are best tracked down by watching the contents of a vari-
able (or variables). Something is going wrong somewhere, and you want

to keep an eye on a variable to find out just where its value changes and
goes bad.

Some of VB’s best debugging tools help you keep an eye on the status of
your variables. Type in a simple VBA macro, like this:

Sub Adder()
Dim a As Double, b As Double

a = 112
b=a/2
b=Db+6

End Sub

Now press F8 once to take your first step into the macro. After you press

F8 to take that first step, make the watch window visible: Choose Debugr>
Add Watch (VBA) or Debugr>Windows and select the Locals, Watch, and
Immediate windows (NET). Open the Immediate and Locals windows in VBA
from the View menu.

Each time that you press F8 to execute the next line of code (called single-
stepping, or step into), the program again goes into break mode (paused in
its execution).

The .NET Watch and Locals windows share the same space, and you can
switch between them by clicking the tabs on the bottom of their shared
window.

Book Il
Chapter 6

buibbngag



18 4 Tracking Down Logic Errors

In VBA's Add Watch dialog box, type b in the Expression field and then click
OK to close the dialog box. This tells VBA to display the contents of variable
b while the program is executing, while you’re stepping through it, or while
in break mode.

Press F8 several times to step through the code lines and keep an eye on the
value in variable b, as shown in Figure 6-2.

[ Microsoft Visual Basic - Normal [hreak] [BE]=|
EEIIe Edit View Insert Format Debug Run Tools Add-lns Window

End If

Princ #1, X
Cloze #1

End Sub

Sub Adder (]

Dim a hs Double, b As Double

a = 112

h=a/2

bh=h+86
Figure 6-2:
The Watch
window .
displays a /)
variable’s x
value while T \ TType. Contet -
you're a5 b a6 Daudole Mewhiacros Adder
debugging. :ﬂ

In the .NET Locals window, you see the contents of all variables that have
been declared within the currently executing procedure.

Also take a look at the Immediate window. In this window, you can directly
query or modify variables, or expressions. To find out the value in variable b,
for instance, just type the following into the Immediate window and then
press Enter:

?b
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The answer — whatever value b currently holds while you're in break
mode — will be printed in the Immediate window. (The ? command is short-
hand for the Print command.)

If you want to experiment and actually change the value in a variable during
break mode, delete the number in the Value column in the .NET Locals or
Watch windows, and then type in your new value. You can also launch and
test procedures (events, Subs, or Functions) by typing their names and
pressing Enter. VB.NET will execute the procedure and then halt again. This
is a good way to feed variables to a suspect procedure and watch it (and it
alone) absorb those variables to see if things are going awry within that
procedure.

Using Debug.Write or Debug. Print

Some .NET programmers like to insert Debug.Print (or Console.Writein
.NET) commands at different locations within their code. (I don’t because

[ find that approach rather clumsy compared to setting watches or break-
points. For one thing, with these printing/writing statements, you have to
spell out the location and variable name yourself in the printed message.)
This also has the effect of displaying the contents of the variable b in the
Output window. But in this case, you're causing the values in the variables
that you choose to show to be displayed via code within your program. Try
inserting some Debug.Write (MylVariableName) lines here and there in a
VB.NET program, and then run the program and watch the results appear in
the Output window.

Actually, you can type any executable commands that can be expressed on a
single line into the Immediate window to watch their effects. Notice that this
is all done while the VB program is halted during a run. You can test condi-
tions from within the living program while it’s in break (pause) mode. You
can get into break mode several ways:

4+ Insert a Stop command into your code.

4+ Set a breakpoint (which I discuss later in the section, “Setting
Breakpoints”) in the code.

4+ Single-step (press F8).

+

Choose Break from the Run menu (or the toolbar).

4 Press Ctrl+Break.
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The Add Watch Technique

The Locals window in .NET is fine for local variables, but what about form-
wide or project-wide variables? Although they show up in the VBA Watch
window, they don’t in the Locals window.

To watch one of these other kinds of variables in .NET, put your program in
break mode, right-click the variable you're interested in, and choose Add
Watch from the context menu. You can alternatively select and then drag a
variable from the code window, dropping it into the Watch window. Also,
while you’re in break mode, you can simply pause your mouse pointer over
a variable to see its contents in a small box.

When you add a watch, VB keeps an eye on whatever expression(s) you've
asked it to watch. You can watch a single variable, an expression, a property,
or a procedure call. The Watch window shows the current status of any
watched expressions.

In VBA but not .NET, the Watch window permits some highly useful debugging
techniques, like conditionally halting the program (throwing it into break
mode so you can examine variable values, see where the break occurred, and
examine surrounding conditions). You can break when a condition becomes
true (such as the variable I holding a value, say, larger than 44 [ > 44) and
other tests. This ability to break conditionally is, in VB.NET, part of the break-
point debugging feature, which I discuss in the next section.

Setting Breakpoints

Sometimes you have a strong suspicion about which line, macro, form, or
module contains the error you're hunting for. Instead of single-stepping
through the entire code, you want to press F5 to execute the program at
normal speed but then stop when execution enters the dubious form or pro-
cedure. After halting the program in a suspect region, you can start pressing
F8 to single-step through each line.

Breakpoints can be one of the most useful debugging aids. You can certainly
press Ctrl+Break and stop a running program in its tracks. But what if it’s
moving too fast to stop just where you want to look and check on things?
What if it’s alphabetizing a large list, for example, and you can’t see what’s
happening? What if you want to specify a condition (n = 1445, for example)
that triggers a break?
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You can specify one or more breakpoints in your program. While running,
the program will stop at a breakpoint just as if you had pressed Ctrl+Break
(or if you've made the breakpoint conditional — it will break when that con-
dition occurs).

When the IDE enters break mode, the code window pops up, showing you
where the break occurred so that you can see or change the code, or single-
step, or look at the Watch window or other debug windows to see the values
in variables.

You set a breakpoint by clicking the gray margin to the left of the line in the
code window where you want the break. A red dot appears in the gray

margin. The red dot alerts you that a line of code is a breakpoint. Execution c::otI:aIrIG
will halt on this line (or perhaps not if the breakpoint is conditional), and VB v
enters break mode. Click the red dot a second time to turn it off.
S
Setting conditional breakpoints in UBA £
Try creating a conditional breakpoint in VBA. For this example, you can use <.
<«

the code you created in the previous section. Say that you want to halt exe-
cution when the variable counter is greater than 1,000. Follow these steps to
make this code break execution when this condition occurs:

1. Click the gray margin to the left of the line that you want to break on
(the For line, for example, as shown in Figure 6-3).

% Normal - NewMacros (Code) 1
|(Generill ;i iMuNi ﬂ
End Sub El
— Sub Muled()
Figure 6-3: ?}
H 1 MEXT COUNCEr
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margin — Procedure; [Mult = Help |
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H H :ELI_l Project:  narmal
signaling

H “Watch Type
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A red dot appears where you clicked, and also the line of code is high-
lighted where the breakpoint is set.

2. Right-click the breakpoint line.

3. From the context menu that appears, choose Add Watch.
The Add Watch dialog box opens.

4. Type counter > 1000 into the Expression field.
This is your condition that will trigger the break.

5. Select the Break When Value Is True radio button.
This means break when the expression becomes true.

6. Click OK.

The dialog box closes, and the breakpoint is now conditional on the
value of the counter variable increasing above 1,000.

7. Choose Viewr>Watch to open the Watch window and then press F5 to
execute the procedure. Press F5 twice if necessary.

The loop executes and then halts when the variable reaches 1001. The
Value column in the Watch window turns from False to True.

Another use for breakpoints is when you suspect that the program is not
running some lines of code. Sometimes a logic error is caused because you
think that a subroutine, a function, or an event is getting executed, but the
program never reaches that procedure. Whatever condition is supposed to
activate that area of the program never occurs.

To find out whether (as you suspect) a particular event is never executing,
set a breakpoint on the first line of code within that procedure. Then, when
you run your program — and the breakpoint never halts execution — you
have proven that this procedure is never called.

Sometimes you set several breakpoints in your code that you later want to
delete because you've fixed the bug. If you've set a lot of breakpoints, the
Clear All Breakpoints (Ctrl+Shift+F9) feature allows you to get rid of all of
them at once without having to hunt them all down and toggle each one off
individually by locating them and then clicking their red dot.

Setting conditional breakpoints in .NET

[ use an example earlier in this chapter in which $10 grew to $1,000 for no
good reason. If something like this happens to you, you’d obviously want
to find out where that happened in your code. You could add breakpoints
to stop the program when $10 grows larger than, say, $200 (that’s your
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condition). Then, while the program is running and $10 is transformed into
$1,000 — your logic error — VB halts the program and shows you exactly
where this problem is located.

Type this code into the VB.NET editor:

Private Sub Buttonl_Click(ByVal sender As System.Object,
ByVal e As System.EventArgs) Handles Buttonl.Click

Static moneyvariable = 55
moneyvariable = moneyvariable + 44

Book Il
End Sub Chapter 6
To set a conditional breakpoint, go to the line in this procedure where
moneyvariable is increased by 44. Click in the gray area to the left of that =
line of code. The red dot appears, and the line is changed to a red color as 2,
well. Right-click the red part of the line (not the red dot) and choose é
BreakPoint Properties from the content menu that pops out. 5

Click the Condition button in the BreakPoint Properties dialog box. In the
BreakPoint Condition dialog box that appears, type your condition that will
trigger the break: that is, moneyvariable > 200, when this variable goes
above 200.

Press F5 and keep clicking Buttonl five times. Then your variable will have
exceeded the conditional value, and the editor will enter break mode. You
can specify any kind of condition by using the Is True, Has Changed, or Hit
Count options in the BreakPoint Properties dialog box.

Alternative Debugging Strategies

You likely noticed several other tools on the Debug menu. Although they’re
not as widely useful as breakpoints, single-stepping, or watches, when you
need these lesser tools, you'll be glad that they’re available. Here’s a brief
survey of the minor debuggers.

Step Over

Step Over is the same as single-stepping (pressing F8) except that if you're
about to single-step into a procedure, Step Over ignores the procedure. No
procedure calls will be carried out. All other commands will be executed. If

you’re single-stepping (pressing F8 repeatedly) and you come upon a proce-
dure that you know isn’t the location of the bug, press Shift+F10 on that line
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to step over the entire procedure, ignoring it entirely. This option gets you
past areas in your program that you know are free of bugs and would take a
lot of single-stepping to get through.

Keyboard shortcut: In VBA, press Shift+F8. In .NET, press Shift+10.

Step Out

You must be in break mode for the Step Out feature to work. It executes
the remaining lines of the procedure that you're currently in, but it stops
on the next line in the program (following the current procedure). Use this
to quickly get past a procedure that you don’t want to single-step through.

Keyboard shortcut: Press Ctrl+Shift+F8.

Run to Cursor

To use the Run to Cursor option, click somewhere in your code other than
the line on which VB currently stopped. (You're moving the insertion cursor
to a different line of code.) VB remembers both the original line and the new
line where the insertion cursor now resides. Choose the Run to Cursor
option, and the code between the original and new locations is executed
quickly. This is a useful trick when you come upon, for example, a really
large For...Next loop. You want to get past this loop quickly rather than
waste all the time it would take to complete the loop by pressing F8 over
and over. Just click a program line past the loop and then use the Run to
Cursor feature. VB executes the loop at normal execution speed and then
halts at the code following the loop. You can now resume stepping from
there.

Keyboard shortcut: In VBA, press Ctrl+F8. In .NET, press Ctrl+10.

Set Next Statement

You must be in break mode to use this. With the Set Next Statement fea-
ture, you can move anywhere in the current procedure and restart execution
from there. (It’s the inverse of the Run To Cursor feature described above.)
While the program is in break mode, go to the new location where you want
to start execution from, and then click the new line of code where you want
to resume execution. Now, pressing F8 will single-step from that new location
forward in the program. This is how you skip over a line or lines of code. Say
that you know that things are fine for several lines, but you suspect other
lines further down. Move down by using Set Next Statement and start
single-stepping again.

Keyboard shortcut: In VBA, press Ctrl+F9. In .NET, press Ctrl+Shift+10.
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Show Next Statement

If you’'ve been moving around in your program’s code, looking in various
events, you might have forgotten where in the program the next single-step
will take place. Pressing F8 would show you quickly enough, but you might
want to get back there without actually executing the next line. Show Next
Statement moves you in the code window to the next line in the program
that will be executed, but doesn’t execute it. This way, you can look at the
code before proceeding.

Keyboard shortcut: None.

Call Stack

The Call Stack feature is on the View menu in VBA, and the Debug=>
Windows menu in .NET. Call Stack provides a list of still-active procedures
if the running VB program went into break mode while within a procedure
that had been called (invoked) by another procedure. Procedures can be
nested: That is, one can call on the services of another, which, in turn, calls
yet another. The Call Stack option shows you the name of the procedure
that called the current procedure. And if that calling procedure was itself
called by yet another procedure, Call Stack shows you the complete his-
tory of what is calling what.

Keyboard shortcut: None.
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Chapter 1: The Word Object Model

In This Chapter

+~ Beginning with the Application object

v+ Programming with Document objects
v Accessing enumerations

+ Understanding ranges and selections
v+~ Using bookmarks

+~ Handling events

Tle terms object model or class hierarchy refer to the system of categoriza-
tion that is used to try to organize a set of classes into some meaningful
arrangement. For example, the Application object is the largest object in
Office applications. It contains many other objects, such as ranges, selections,
toolbars, and so on.

In practical terms, the outermost (or largest container) object is often simply
left out of coding; it’s understood, so it’s only optional. Lesser objects, such
as a document, paragraph, or selection are contained within each other, like
nested Russian eggs. These lesser objects must be named in your code
(although Document is sometimes omitted).

In this chapter, you wrestle with the dodgy concepts of objects and object
variables, and also see how some useful objects can be used to search and
otherwise manipulate Word documents.

Understanding Objects

Objects are slippery things. Born of and nurtured by academic theoreticians,
the idea of object-oriented programming (OOP) has spread throughout the
computer world. Whether you consider this a good thing is beside the point;
OOP is as pervasive among today’s programmers as alchemy was in the
Middle Ages. If you call yourself a programmer, you must deal with objects.
You don’t have to create them in your programming: Classes can be entirely
left out in favor of simpler, shorter procedure-based programming techniques.
VBA, VB 6, and all earlier versions of Visual Basic are only incidentally
object-oriented.
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However, if you wish to make use of the features built-into applications — and
you certainly do — you must at least learn the fundamentals of OOP in order
to employ the members of the classes (objects) that are exposed (you're
allowed to use them) by Office 2003 applications. These members are proper-
ties and methods. Properties are generally qualities (similar to traditional
variables); methods are just other names for what have always been called
procedures. But you do need to learn the lingo and the syntax with which you
instantiate an object and then access its members. You might never need to
write your own classes when programming for Office 2003, but you’ll cer-
tainly need to use the classes built into the Office suite of applications.

Objects are so widely used because professors mostly love the concept of
OOP and have taught a generation of programmers to use them. In addition,
when writing very large programs in groups (such as the people at Microsoft
who collectively cobbled Excel together), OOP offers security/clerical bene-
fits that traditional procedure-oriented programming does not.

However, objects do suffer from two undeniable weaknesses. The first is that
they are not logical. How do you keep everything straight when everything is
an object (as is true in the .NET languages)? In .NET, even an integer variable
is an object. What good is the term object? What can it mean if it means every-
thing? How much information do you convey if you describe everything with
the word thing?

The second weakness is the fact that OOP nomenclature has little stability.
The same object can be a collection, an object, and a property. For example,
Document is an object in the Word object hierarchy, but it’s simultaneously a
collection of the current documents (Documents). The Document object has
properties, yet it is also itself a property (of the Application object). This
situation is more than simply amusing: It’s as if biological classification had
been designed by a bunch of drunk monks . . . as if a toad were classified as
both land animal and fish. In a sense, this is vaguely accurate about toads —
they are kind of intermediate — but how useful is a taxonomic system that
can'’t effectively categorize any animal with any useful specificity?

Nonetheless, you're obligated to wrestle with the hierarchies and structures
that OOP promotes, and programming in Office 2003 requires that you learn
to work with objects and their members. You do want to be able to display
dialogs, use the built-in search utility, and other features that are contained
within the Office applications’ class libraries.

As George Orwell said of communists, some are more equal than others.
Some objects are more important than others. In Word, for instance, the
Application object is the big one in hierarchical terms but is generally of
little importance to programmers (unless you need to programmatically
manipulate options, windows, views, and such).
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The Application object is the object from which all other objects derive.
However, you need not use it explicitly when programming the Document
object in Word. (When contacting Word from outside applications, you do
need to use an object variable referencing the Application object.)

In Word document programming, you can leave the Application object out
of your code because derived objects such as the Document object are under-
stood to be part of the application. Just as you don’t have to say America’s
California, there’s no other possibility.

\\J

Dissecting the Document

Much Word programming involves the Document object, the ActiveDocument
object (the document with the focus — the one that you've been working with
most recently) and the Documents collection (all currently open documents).
You can be as granular as necessary because the Document object decon-
structs into the components of a piece of writing: for example, a Paragraphs
collection containing a Sentences collection containing a Words collection
containing a Characters collection. Or so you would imagine. Read on.

You can retrieve the first paragraph in the first document by using this code:

Book I

Sub Gran() Chapter 1

n = Documents(1l).Paragraphs(1)
MsgBox (n)

End Sub

This displays the first paragraph in the first document. However, you can’t
get the first word in that paragraph this way (as you logically would think):

1apojA 193lqQ
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n = Documents(1l).Paragraphs(1l).words(1)

Oops! (Get it, OOPs?) An error message appears: method or data member
not found. With OOP, things aren’t always what you might expect. The Words
collection is a property of the Document object and not the Paragraphs
object. Instead, use this, which searches in the ActiveDocument object of
Document:

n = ActiveDocument.Words(5)
or

n = Documents(2).Words(5)
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Note that the Words object is a property of various other objects, including
the Document, ActiveDocument, and Range objects. Yet, to surprise us yet
again, the Characters collection is a property of the Words collection and
not the document:

n = Documents(2).Words(5).Characters(2)

So, you just never know. Patterns do exist, but they are unpredictable and
vary from one application’s object model to the next.

To keep your head from rolling off your shoulders when in OOP World, you
must rely heavily on the IntelliSense (lists that pop out while you're writing
code such as statement completion and AutoListMembers) in programming
editors, Help, MSDN online, books that describe the object model, and per-
haps to a lesser extent, the Object Browser.

Objects themselves aren’t the problem. It’s the inconsistencies and the
randomness by which they are organized and manipulated in computer
languages.

I can’t think of an alternative to objects and the members that describe their
capabilities and qualities. Indeed, what’s best about working with objects is
that you have the ability to manipulate essentially everything in an applica-
tion. You can programmatically do pretty much anything a user can do with
menus and toolbars and quite a bit that users can’t do (such as directly
redefining ordinary keys, like the accent grave key — as you’ll see how to

do at the end of Book III.) You'll also see why it’s quite a useful adjustment
to make to Word.

But the people — committees actually, as you might expect — who are design-
ing the system are so terribly inconsistent. I'd use the word blithe to describe
the general approach to classification.

So my advice is to approach objects deductively rather than inductively. Don’t
try to sit there like a philosopher and say, well, logically, the Words collection
must be a property of the Paragraph object. Be deductive and try experiment-
ing (and use Help features) until you get the answer in the real world. Logical
assumptions don’t get you too far with today’s object taxonomies. The clas-
sification scheme is far from orderly, and the committees who design these
schemes include some people who look exactly like Gyro Gearloose.

Object variables

If you want to create or open a document, it’s necessary in VBA to take the
time to generate an object variable and then instantiate an object and assign
it to that variable, like this:
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Dim mydoc As Word.Document
Set mydoc = Documents.Add()

That creates a new document, giving it a default filename (Document]1, for
example). To specify your own filename (like, say, t . doc), use this:

Dim mydoc As Document

Documents.Add.SaveAs ("C:\t.doc")
Set mydoc = Documents("C:\t.doc")

The following statement opens an existing file:

Set mydoc = Documents.Open("C:\t.doc")

Editing text
You can do the usual things with document elements: add, delete, or modify
(words, paragraphs, headers, or whatever).

To make these changes, use either the Range or SeTection objects. You can
have multiple Range objects but only one Selection object at any given
time. Also, with a Selection, you must first select (highlight) before you
can manipulate. A Range can merely be directly described in the code.

There is always a Selection object in a document’s text. (If nothing is high-
lighted, the blinking insertion cursor — representing the insertion point — is
the Selection object.)

Here’s an example. In a Word document, type this is selected, and then drag
your mouse across those three words to highlight (select) them. Now switch
to the VBA editor and type this in:

Sub SelectionInfo()

s = "The selection contains " & Selection.Characters.Count & " characters."
MsgBox s

Selection.InsertDateTime

End Sub

Press F5 to run the macro. You're told that there are 16 characters in the

selected text, and then the InsertDateTime method replaces the selection
with today’s date.
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Significant selection properties

As you might expect, various properties of the Selection object can tell
you information about what’s selected — or indeed, modify the selection.
(The Range object shares many of these same properties.)

The End and Start properties

The End and Start properties tell you the character position, within the
document’s Characters collection, of the selection. For example, if your
document starts like this:

One two three four five
And you select the word two, the Start property is 4, and the End property
is 7. You can use these properties to set (change) the selection start and end

points — moving the highlight.

The Font and ParagraphFormat properties

The Font and ParagraphFormat properties get or set objects describing the
formatting. The Range object returns a range identical to the selection. You
can go the other way with the ActiveDocument.Range.Select method.
Notice that when you get a range from a selection, it’s a property; but when
you go the other way and get a selection from a range, it’s a method. I tell
you, there’s no logic.

The StoryType property

An object called (who knows why?) Story represents the various kinds of text.
You can use the StoryType property to get a built-in constant (also called an
enumeration) telling what kind of Story is selected: ordinary document text
=wdMainTextStory, wdCommentsStory is a comment, wdFootnotesStory
for footnotes, and so on. The StorylLength property tells you how many
characters long the story is (that contains your selection).

Enumerations do not directly report (in English) the answer you're after.
Instead, you get a code — a number — and you have to look up the constant
list to see what the number represents:

MsgBox Selection.StoryType

If this displays 1, what does it mean? Which of the constants is represented
by 1? If you look up StoryType in Help, it doesn’t give you the list of codes.
Instead, you must search Help for constants, where you’ll find the Word
Enumerated Constants entry — and that includes a WdStoryType entry,
shown in Figure 1-1.



Figure 1-1:
Here's
where you
can find the
many lists of
enumerated
constants in
Word Help.
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After you look up the constants, you discover that 1 means MainText story.
However, you can use the built-in constant names in expressions, like this:
I[f Selection.StoryType = wdFootnotesStory Then

The Style property

The Style property can get or set the style, which can either be one of the
styles in the Styles drop-down list in the Formatting toolbar or one defined in
the constant style’s enumeration. But don’t bother looking in the list of enu-
merations shown in Figure 1-1 for wdStyTes or anything like that. You won’t
find it there. What do you imagine is the name they gave this enumeration?
Boo! Surprise! It turns out to be wdbuiltinStyles! Who could have guessed?

There are 103 built-in styles, ranging from wdStyleBlockQuotation to
wdSty1eT0C9. If you want to change the style of a selection to, say, the
third-level headline, use the following statement:

Selection.Style = wdStyleHeading3
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Queerly, the numeric codes for all the style constants are negative! For exam-
ple,wdStyleBodyTextFirstIndent is -78. Fortunately, when you query

the style, you get back a string variable (not a code) telling you the name

of the style:

n = Selection.Style

Please don’t try to find patterns in these behaviors. Believe me, there aren’t
any useful rules here. Things can go any which way. Just, (I repeat), lean
on Help and the various IntelliSense features, along with reference books.

The Text property
The Text property returns or sets the text:

s = Selection.Text
MsgBox s

The Words property

The Words property returns a collection of the words in the current selection.
So, to make the third word in the selection boldface and 8 point (small), you
can use this code:

Sub SelectionInfo()

With Selection.Words(3)
.Font.Size = 8
.Bold = True

End With

End Sub

In some versions of BASIC, you find the property FontSize, but in others,
you find (as here) the Size property of the Font object. (The Font object is
also a property of the Selection object, but that’s another tale.)

Significant selection methods

When providing arguments to methods, you can use either the peculiar
colon-equals (: =) punctuation or the traditional parentheses. Beware that
the colon-equals approach has not survived in future versions of BASIC.
The following two lines of code do the same thing:

Selection.Expand Unit:=wdParagraph
Selection.Expand (wdParagraph)

The following methods are of the Selection object, but many are also meth-
ods of the Range object. Selection.copy copies the selection to the Clip-
board. The Cut and Delete methods are similar, but Cut puts a copy in the
Clipboard (like pressing Shift+Del). Paste pastes.
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Starting at 1 or 0?

Although nearly all other collections in VBA
(Paragraphs, Characters, and so on)
begin counting with the number 1, the Range
object counts from 0 (zero). There's no reason
for this discontinuity: Every list, group, array, or
collection should begin counting with 1. That's
the way our numeric system has worked for
thousands of years, and there’s no reason to
start counting from zero in computer lan-
guages. We don't say, for example, “I've been
to Greece five times, but the very zeroth time |
went was the most fun.” We quite reasonably
say, “The firsttime | went. ...” Why some com-
puter language designers decided to count

from 0in some cases and from 1in other cases
remains one of those sad mysteries in the
annals of human folly. And don’t assume that
you can ever know which of the two modes —
start with 0 or start with 1 — applies in any par-
ticular case. Some collections, list box controls,
arrays, and other groups in programming begin
with 0 and some with 1. You just have to wres-
tle with this problem until sanity eventually
gains the upper hand with computer language
designers. Eventually, they'll realize how many
man-centuries of debugging they've caused by
authoring this confusion.

You can increase the size of the selection with the End0f or Expand meth-
ods. The InsertAfter and InsertBefore methods insert a string where

described. The InsertBreak method takes the following arguments, among

others: wdPageBreak (default), wdSectionBreak, and wdLineBreak.

InsertParagraph replaces the selection, but InsertParagraphAfter
and InsertParagraphBefore donot. SetRange(Start, End) specifies
the starting and ending character positions. Shrink reduces the selection

to the next smaller unit of text (following this pattern: entire document, sec-
tion, paragraph, sentence, word, insertion point). For example, if you select

a paragraph, only a sentence remains selected after using Shrink.

Creating ranges

You can create a range directly by specifying its starting position and length:

Sub Ranges()

Dim myrange As Word.Range

Set myrange = ActiveDocument.Range(0, 25)

myrange.Bold = True

End Sub

In this example, you ask VBA to create a range from the Oth to the 24th

character.
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Recall that you can create as many different ranges within a document as you
need. Also, a whole slew of Word objects have a Range property that you can
use to create a new range. The range that you get is the same unit of the
object. (A Paragraph object returns, for example, a paragraph-long range.)
Here are the objects with a range property: Bookmark, Ce11, Comment,
Endnote, Footnote, FormField, Frame, HeaderFooter, Hyperlink, Index,
InTineShape, List, Paragraph, Revision, Row, Section, Selection,
Subdocument, Table, TableOfAuthorities, TableOfContents, and
TableOfFigures.

Here’s an example that uses the Range property of the Paragraph object.
Your goal here is to change the size and color of the first character in

each paragraph in the active document. In addition, you change the charac-
ter to the engraved style. You first define two object variables: one for

the Paragraph object and one for the Range object. Then you specify

the following for every paragraph (in turn) throughout this document’s
Paragraphs collection: If the paragraph has at least one sentence in it,
create a range that spans merely the first character in the paragraph’s
range’s Characters collection. Then, change that little range (that first
character).

Sub Ranges()

Dim p As Word.Paragraph
Dim r As Word.Range

For Each p In ActiveDocument.Paragraphs
If p.Range.Sentences.Count > 0 Then
Set r = p.Range.Characters(l) 'point to first letter
r.Font.Size = 12
r.Font.Engrave = True
r.Font.Color = wdColorBlue
End If
Next p

End Sub

Bookmarking

Similar to the Range and Selection objects, the Bookmark object has a start
and end position. It can also be as large as the entire document or merely
the size of the insertion point (zero characters). Bookmarks, though, are
kind of like ghost documents within the regular document. They can be used
as place markers showing where addresses from a database — or perhaps
boilerplate text — are to be inserted in a letter. Also, bookmarks can them-
selves contain text that, depending on conditions, is inserted into the main
document.
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Bookmarks are normally invisible but can be made visible by setting the View
object’s ShowBookmarks property to True (or by choosing Tools=>Options=>
View). Here’s an example that inserts one of two messages at the end of a
letter to a customer, depending on whether the customer’s account is paid
up. In a Word document, choose Insert>Bookmark and then name your new
bookmark AreTheyPaidUp. Then switch to the VBA editor and type the
macro in Listing 3-1.

Listing 3-1: Bookmark Insertion Macro
Sub BookIt()

Dim Rangel As Word.Range
Set Rangel = ActiveDocument.Bookmarks("AreTheyPaidUp").Range

With Rangel

If paidup = True Then

.InsertAfter vbCrLf & "Thank You for your business!" & vbCrLf
Else

.InsertAfter vbCrLf & "Where's the cash??!!" & vbCrLf

End If

.Select

End With

ActiveDocument.Bookmarks.Add "AreTheyPaidUp", Selection.Range

End Sub

When executed, this macro accepts a parameter named paidup (probably
from a database) that describes whether the customer owes any money. A
Range object is then created and set to point to the bookmark. Then you use
the InsertAfter method to append your message to any text that might
already exist in the bookmark. (In this case, there’s none, but boilerplate
text might well exist in a typical business or professional document.)

Surrounding the text with & vbCrLf, which is a constant representing press-
ing Enter, has the effect of making your text a separate paragraph. Finally, you
use the Bookmarks collection’s Add method to replace the existing bookmark
with your new one. When you use the same name as an existing bookmark, the
original bookmark’s text (if any) is retained, but your new text is inserted.
Unfortunately, bookmarks are deleted from a document if you use a range’s
Text property to replace the contents of the bookmark. Likewise, if you hadn’t
used the Select method to create a new selection, the bookmark in the above
example would have been destroyed.
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Search and Replace

Automating Word can sometimes require that you employ the Find and
Replacement objects. This is another way to insert boilerplate text or to
change a letter’s contents based on information coming in from a database
or other source. You could even display an InputBox to ask the letter writer
to choose whether he wants to send the polite, neutral, or really exasperated
version of the same letter. (The exasperated version searches for, and then
deletes, all use of the phrases thank you and please.)

One quick way to program in VBA is to first record a macro and then see
what VBA code was automatically created for you. You can modify that code
as necessary, but at least you’re not starting from scratch.

Follow these steps:

1. In Word, open a document that you don’t mind messing up.
2. Choose Tools->Macro->Record New Macro.

The Record New Macro dialog box opens.
3. Click OK to close the dialog box.

The macro recording toolbar appears.
4. Choose Edit->Replace.

The Find and Replace dialog box opens.
5. In the Find What field, type the; in the Replace With field, type xxxx.
6. Click the Replace All button.

All instances of the word the are replaced with xxxx’s.
7. Close the dialog box.
8. Click the Stop button on the Macro toolbar.

The macro recording stops, and the toolbar disappears.
9. Press Alt+F11.

You see the VBA editor.
10. Locate your new macro. It should look like this:

§ ub Macro8()

' Macro8 Macro
' Macro recorded 12/19/2003 by Richard
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The Find Object’s Properties

Selection.Find.ClearFormatting
Selection.Find.Replacement.ClearFormatting
With Selection.Find

.Text =

uthevv

.RepTacement.Text = "xxxx"
.Forward = True
Wrap = wdFindContinue

.Format

False

.MatchCase = False
.MatchWholeWord = False
.MatchWildcards = False
.MatchSoundsLike = False
.MatchAlTWordForms = False

End With

Selection.Find.Execute Replace:=wdReplaceAll

End Sub

You can adjust any of the SeTection or Find objects’ properties to modify
how your search and replace behaves.

The Find Object’s Properties

The significant properties of both the Find and Replacement objects
include Font, ParagraphFormat, Style, and Text. The important proper-
ties of the Find object (by itself) are Forward, Found, MatchCase, and

MatchWholeWord.

The Execute method of the Find object has several optional arguments that
are duplicates of some of the Find object’s own properties. You can either
specify these options as properties or arguments, as you wish. For example,

the statement

myrange.Find.Execute Forward:=True

is equivalent to
With myrange.Find
.Forward = True

.Execute
End With

or

myrange.Find.Forward

True
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The CTearAlT1Formatting method of the Find object eliminates any previ-
ously specified formatting rules. This way, you won’t cause that frequently
confusing result of finding no hits in a document that you know contains
plenty of hits. Then, you notice that the italic or HeadTlinel Style format-
ting criteria are specified because your last search required them.

Trapping Events

Of the three members of any object model — properties, methods, and
events — it’s events that are generally less often discussed. Nonetheless,
you frequently need to provide a programmatic response to something that
happens to an object (such as the user clicking a button, or an incoming
message arriving).

The document object offers six events: New, Open, Close, Sync,
XMLAfterInsert, and XMLBeforeDelete. You can provide programming
for these events in the ThisDocument object. Press Alt+F11 to open the
VBA editor, and then right-click ThisDocument under the Normal node.
Choose View Code from the context menu and select Document in the
top-left, drop-down list box of the Code window. By default, the Document__
New event is displayed, but you can select the document’s other events by
opening the drop-down list in the upper-right of the Code window.

For example, you put any code you want to execute when a new document is
created inside the New event, like this:

Private Sub Document_New()
MsgBox "Welcome!"

End Sub

An alternative approach to using ThisDocument events is to trap
events by giving your macros special names (such as FileSave). In this
case, any time the user chooses Filem>Save from the Word File menu,
your macro code is executed. Read about this technique in Book III,
Chapter 5.

To respond to Word’s App1ication or mail merge object’s events, you must
add a class module to your project to contain the event. Then create the
event in the class module, like this:
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PubTic WithEvents o As Word.Application
Private Sub o_Quit()

MsgBox "bye"
End Sub

You can find out the syntax and any arguments required by the various events
by searching for application in VBA Help, choosing Application Object, and
then clicking the Events link at the top of the Help page. (The Quit event has
no arguments.)

Before your event trapping works, you must also initialize the object. A good
place to do that is in the ThisDocument Open event:

Dim X As New Classl "this assumes your class module is named Classl

Private Sub Document_Open()
Set X.o = Word.Application 'point object variable to app
End Sub

For an example of how to do this in Excel (Word works the same way), see
the Book IV, Chapter 2.
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Chapter 2: Power Editing

In This Chapter

v+ Maximizing Word’s editing features

v Viewing and maneuvering the smart way
v Introducing Smart Documents

v+ Understanding fields

v Importing data

v Using Mail Merge

M any — perhaps most — Office workers don’t take advantage of Word’s
many powerful editing features. Before exploring some VBA and pro-
gramming techniques, this chapter first offers some useful (albeit underused)
techniques that can improve productivity for nearly any kind of Office worker.
You'll see how to do some power editing, maneuver efficiently, and use Smart
Documents. Fields, data importing, and mail merge are also covered.

Selecting Text Quickly

Selecting text is a common job in Word, but few people realize the many
shortcut ways to do this. For example, double-click any word to select it.

To select an entire line, click the left margin. Double-click the left margin to
select the entire paragraph. Drag in the left margin to select a group of lines.
Triple-click the left margin to select the entire document (or press Ctrl+A).
Quadruple click the left margin to send a Word document to the Space
Station. (Let me know how this last one works out.)

To select a chunk of text of any size, do the same thing you do to select a
contiguous group in a list box or a group of filenames in Windows Explorer.
That is, click at the start of the text block and hold Shift while clicking the
end of the block. Or click the start of the block, press F8, and then drag (or
click the end point). To select all text formatted the same way, right-click the
text and choose Select Text with Similar Formatting from the context menu.
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Making Snappy Retorts . . . er, Repeats

Memorize the F4 key; it can be a real timesaver. If you have to do something
repeatedly (such as formatting, typing in a phrase, or many other tasks), you
don’t have to repeat all the steps in the task. For example, maybe you want
to change the style of all the headlines in a document, reducing them from the
Headingl style to Heading2. Instead of selecting each headline, dropping the
style list in the Formatting toolbar, scrolling until you find Heading2, and
then clicking it in the list — yipes — just take those steps for the first head-
line in the document. Thereafter, merely click each headline and press F4.
The style is correctly applied to each headline.

Going Backward with Undo

Always remember your Undo friend: Press Ctrl+Z to undo a mistake. If you
delete some text and then wish you hadn’t, the Undo feature restores the
text. Sweet. Likewise, Undo is a lifesaver when you make foolish formatting
mistakes. The downside: If you made your mistake several steps previously,
of course, you could repeat Ctrl+Z until the problem is fixed, but this also
undoes in-between things you probably don’t want undone as well. Undo,
unfortunately, undoes every action between the error up to and including
your latest action.

To see a list of your actions — and I mean everything you’ve done since you
opened the document! — locate the Undo icon on the Standard toolbar and
then click the down arrow on the Undo icon. (Undo looks like a left-curved
arrow.) Your most recent six behaviors are listed, but you can scroll down
this list as far as necessary to find the problem. Then you click the error.
Remember, though, that all previous actions will also be undone. It’s up

to you.

If the Undo button isn’t visible, right-click the Standard toolbar and choose
Customize from the context menu. In the Customize dialog box, click the
Commands tab, click Edit, and drag the Undo icon and drop it on the Standard
toolbar.

Note Undo’s brother, the Redo feature (Ctrl+Y). Its toolbar button also
includes a drop-down list with all the actions that you most recently undid.
This is your lifesaver if you undo 143 actions and then regret having to
repeat the 142 tasks that you correctly accomplished.
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Figure 2-1:
Click in the
outline in the
left pane to
move there
in the main
document.

When editing a document, you sometimes want to see the forest, not the trees.
You want to move around quickly, just locating a particular zone or type of
style. Here are a couple of tips for how to view and search your document
differently.

Viewing a document

Speed up your work by choosing different views in Office 2003. A change of
view can help you see a document’s outline, or maybe you want to see how
two pages next to each other look. You can still rely on the stalwart Document
Map, but you have some new choices, too.

Document Map

Use Document Map to collapse a document into a kind of outline format,
based on the headings you’ve used in the document. One great thing about
this view is that you still get to see the original document. This is handy when
you want to make sure you have headings in a logical progression or when you
want to jump to a certain heading in the document. Choose View=>Document
Map to see this outline version, as shown in Figure 2-1. See a similar view in
the upcoming “Thumbnail view” section.

%] BIO302. doc - Microsoft Word S| %]
™~

-

Tips about Selecting
Snappy Repeats
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Figure 2-2:
Click any-
where in the
thumbnails
to move to
that location
in your
document.

Reading Layout view

New in Office 2003 is Reading Layout view. When you select this option
from the View menu, you see two pages at a time, as if you had opened a
book. This view makes it somewhat easier to scan larger amounts of text
at a glance.

Thumbnail view

Also new in Office 2003 is a view of small versions of the pages in a docu-
ment. When you choose Viewro Thumbnails, click anywhere within these
sample pages to immediately go to that place in the main document. You
see a scrollable set of thumbnail shots of your document’s pages, as shown
in Figure 2-2.

Searching within a document

Use these Office tools to help you quickly navigate a document, finding spe-
cific items such as page numbers, comments, bookmarks, and more.

7o
Note that there is also a Redo feature (Ctrl+Y), and its toolbar button also >
includes a dropdown list with all the actions yvou most recently undid. This is
your lifesaver if you undo 143 actions, then regret having to repeat the 142
tasks that you correctly accomplished.

Quick Maneuvering

When editing a document you sometimes want 1o see the forest, not the trees.
You want to move around quickly. just locating a particular zone, or type of
style. Here are a couple of tips.

The Go To dialog box (Editf/Go to) allows you to specify many kinds of
elements in a document {comment, line, page, and so on), as shown in Figure
2-1:

Figure 2-1: Use this dialog box to quickly locate a particular element in a
docment,

To see small versions of the pages in a document, then click anywhere within
these sample pages to immediately go there in the main document, choose
View/Thumbnails. You see a scrollable set of thumbnail shots of your 3
document’s pages, as shown in Figure 2-2;

Figure 2-2: Click anywhere in the thumbnails to move to that location in your
document.
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Figure 2-3:
Use this
dialog box
to quickly
locate a
particular
elementin a
document.
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Go To

Use the Go To tab of the Find and Replace dialog box (choose Edit=>Go To)
to search for many kinds of elements in a document (comment, line, page,
and so on), as shown in Figure 2-3. Go To’s cousin — Find — works much the
same way but with a little more precision. Pressing Ctrl+F brings up the Find
tab of the same dialog box, from which you can search for a word, word frag-
ment, special characters or formatting, and so on.

Find and Replace B3]%]
Bnd || Replace | G0To
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Section
Line Erker + and —to move relabive to the current
Bookmeark. location, Example: +4 will move Forward four
Comment: iterns.,
Footnote
Endnote st = r

l Previous | | et | L Close ] |

Bookmarks are convenient for marking somewhere you want to return to, like
the stopping point of the day’s work. When you insert bookmarks through-
out your document, you can use them to quickly locate and move to certain
points in a document. To insert a bookmark, choose Insert->Bookmark to open
the Bookmark dialog box, enter a name for the bookmark, and then click Add.
To go to a bookmark, press Ctrl+G (which takes you to the Go To tab of the
Find and Replace dialog box), click Bookmark (under Go To What), find the
bookmark (under Enter Bookmark Name), and then click the Go To button.
(Speed hint: Just double-click the bookmark’s name in the dialog box.)

Browsing with Select Browse Object

On the bottom of the horizontal scrollbar (in the lower right of your docu-
ment), you'll see some symbols — icons that most people ignore. The central
icon is a small ball, as illustrated in Figure 2-4.

Go Back

Press Shift+F5 to use Go Back to cycle among the most recently edited loca-
tions in a document. This feature is most handy when you reopen a docu-
ment and want to find where you last worked. You can also make use of the
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Figure 2-4:
Click this
Select
Browse
Objecticon
to see a set
of targets
you want to
see in your
document.

GoBack method of the AppTlication object. To open the most recently
edited document and then move the insertion cursor to the most recently
edited location in that document, create this macro:

RecentFiles(1).0pen
Application.GoBack

If you name this macro autoexec, this behavior automatically loads the
most recent document, at the most recent edit, every time you start Word:

Sub autoexec()

RecentFiles(1).0pen
Application.GoBack

End Sub

Any instructions you write in a macro named autoexec are automatically
executed every time you run the Word application.

Browse by heading
Browse by edits | Browse by graphic

GoTo Find Browse by table

— | i
{a} [I'j [m Cd D——— Browse

by page
Browse by field Browse by |
comment T
Browse by endnote

Browse by footnote Browse by section

=,
i1l
0= | Ba

Introducing Smart Documents

Although the new Smart Documents technology in Office 2003 (Word and
Excel, specifically) certainly qualify to be included in a chapter about power
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editing, I cover this technology in depth in Book VII, Chapter 6. Still, a little
preview here is useful.

To a user, on the surface, Smart Documents behave somewhat like wizards but
without the step-by-step pages of instructions. Smart Documents are based
on XML and offer you, the developer, a programmable solution to a variety
of common Office tasks. You can semi-automate processes, like creating pro-
posals, business plans, reports, and other kinds of documents that have
predictable form and/or content. You can hand someone a Smart Document,
and he can use the task pane (that you've built) to get help, lists of options,
and other assistance in writing, editing, and publishing the document.

Smart Documents are built on XML, so you might suspect that there’s an
Internet connection here. Good guess, Office 2003 developer. Technically —
and thankfully, someday all this will be kept under the hood — a Smart
Document is built by using managed code that’s Internet-connected with
either a primary interop assembly or a COM interface. I only mention this
because some readers like brief clouds of sophisticated-sounding nonsense.
Unfortunately, at this time, Smart Documents are technically demanding
because creating them is not yet smart (that is, not filled with useless buzz-
words or pointless propeller-head verbiage). The main problem is that there’s
no wizard to guide you through the process of creating Smart Documents.
One day soon there will be such a wizard, but not yet.

As you might suspect, the task pane is context-sensitive, so when a user
maneuvers through a Smart Document, the commentary and other assistance
offered by the pane changes. Exactly what kind of commentary appears in
the task pane is up to you, the programmer. You can insert lists, calculation
fields, all kinds of controls (such as list boxes), hyperlinks, and various other
kinds of assistance.

Here are some ideas about what you could do with Smart Documents:

4+ Facilitate import and export of data in a fashion similar to Mail Merge
but with more flexibility (regarding the location, type, destination, and
source of the data).

4+ Take a single document and automate the process of transforming it into
several versions, each appropriate for a different target (a database, a
published report, an outline, and so on).

4+ Programmatically build new Word documents more flexibly than previ-
ously, drawing on more diverse sources for the content.

4+ Semi-automate various librarian functions (answering questions like,
Who has the latest version? Whose comments can be ignored? and so on).

4+ Increase document security and validation automation.
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Although creating Smart Documents is a mildly interesting new feature, it’s far
from ironed out. You have to manage quite a few details manually (ever try
writing XML by hand?), and the opportunity for version conflicts (between
different Smart Documents), deployment problems, and other new technology
glitches is great. Smart Document creation cries out for a wizard, but there
currently isn’t one. As you can see in Book VII, Chapter 6, creating Smart
Documents currently is not for the faint of heart.

Programming with Fields

A\

Of the various ways to automate document creation and modification, fields
are among the most venerable. The three types of fields are

4+ Result fields: These tell Word what text you want inserted.

4+ Marker fields: Rather simple, these resemble bookmarks, indicating a
location in the document (so that Word can later return to this location
and do something: for example, add a term to an index). Bookmarks, in
fact, are themselves a field. A difference between fields and bookmarks
is that you can delete fields in your text with the Delete or Backspace
keys. However, to delete a bookmark, you must open the Bookmark dialog
box (choose Insert>Bookmark), select the bookmark from a list, and
click the Delete button.

4+ Action fields: These do something by themselves, such as launch a
macro, but don’t themselves add new text to the document. A hyperlink
is considered an action field, for example.

In some ways, a field is similar to a variable in programming. Based on condi-
tions or context, a field can be automatically changed without user or pro-
grammer intervention. For example, a field containing a date can change to
always display the current date.

Fields can import data from files, from elsewhere in a document, or from
data about the document (its word count, for example).

To see fields within a document, select the field (or the entire document if you
wish), and then toggle field view by pressing Shift+F9. If you have a date field
in your document, it will change from 1/30/2003 to {DATE \@ “M/d/yyyy }.
Fields are enclosed in braces.

Inserting fields

The simple way to insert a new field into a document is to choose Insert=>
Field. Memorable, isn’t it? The Field dialog box appears, as shown in Figure 2-5.



Figure 2-5:
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The Field dialog box includes a MacroButton option, as shown in Figure 2-5.
And when you select that option, you can scroll through the macro name
list and find all your macros, plus dozens of menu items (most everything
available on a menu) such as Hanginglndent and WindowNewWindow. Most
of these menu items are named after the menu on which they reside. Thus,
if the Word Count feature is on the Tools menu, the name of this item is
ToolsWordCount.

Here are some helpful field tips:

4+ If you want Word to always update the fields before printing documents,
choose Tools=>Options, click the Print tab, and then select Update

Fields.

4+ If you prefer to type fields directly into your documents, type the field’s
name, select it, and press Ctrl+F9.

4+ To update all the fields in a selection, press F9.

4+ To prevent a field or fields from being updated, select the fields, and
then press Ctrl+F11. To reverse this process — to permit the fields to
be updated — choose Ctrl+Shift+F11.

4+ To move from one field to the next, press F11. To move in reverse, press

Shift+F11.

4+ When you right-click a field, you can accomplish three things with this
field from the context menu: update it, edit it, or toggle between results
and the code.
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Using the Fields collection

You can programmatically manage fields by using the Fields collection. In
this example, the number of pages in the document is inserted:

Sub fieldwork()

Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
Type:=wdFieldNumPages)

End Sub

To update all the fields in a selection:

Selection.Fields.Update

Using the Ref field

The Ref field is interesting. It allows you to both refer to a bookmark else-
where in the document as well as insert that bookmark’s text at the field
location. To see how this works, select a block of text somewhere in your
document and choose Insert=>Bookmark. When the Bookmark dialog box
opens, name this bookmark ThisText. Click somewhere else in the document
where you want this text inserted, and then choose Insert=>Field. The Field
dialog box opens, as shown in Figure 2-6.

Select the Ref field in the Field dialog box, select name of your bookmark
(ThisText), and click OK to close the dialog box. The bookmarked block of
text is reproduced at the current location (of the field) in your document.
Now go to the bookmark, make a change to the text, and move back to the
field Ref copy. Click your mouse in the field, and poof! The entire block of
text goes gray, indicating that it’s a field. Press F9 to update the field. The
change that you made to the bookmark text is now made in the updated field.

Advanced field tricks

If you feel that you’ll use fields extensively in your documents, it’s worth using
Word Help to investigate various advanced tricks that you can do with fields.
For example, you can customize your field’s appearance in various ways,
choose differently formatted numbers, create fields that calculate results from
literals or variables (like a spreadsheet does), format date and time, and so
on. You can even nest fields inside each other: This way, one field’s changes
or conditions can optionally update the nested field, or you can base the out-
come of an IF field, for example, on the status of a nested field.
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Importing Data

You can bring data into a document automatically, using much the same style

of programming that works when programming .NET or older versions of
Visual Basic.

You can open the sample Access Northwind database and then insert a
comma-delimited (data separated by commas, such as this, this, and this)
list of all the customers’ names into the current document. Sometimes indi-
vidual data are delimited (separated) by commas or other special symbols.
To perform this task, follow these steps:

1.

Press Alt+F11.

The Word VBA editor opens.

Press F7.

The code window opens where you can write macros.

You must first import a library of DAO (Data Access Objects) code, so
choose Tools>References.

The References dialog box opens.

Scroll down in the dialog box until you locate Microsoft 3.0 DAO Object
Library, or versions 3.51 or 3.6.

Click the latest DAO library version to select it.
Click OK to close the dialog box.
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To open the Northwind database and bring in the customer name
records, type this code into the VBA code window:

Sub datawork()

Dim d As Document
Set d = ActiveDocument

Dim db As DAO.Database

Dim r As Recordset

Set db = OpenDatabase(Name:="C:\Program Files\Microsoft
O0ffice\Officell\Samples\Northwind.mdb")

Set r

db.OpenRecordset(Name:="Customers")

For i = 0 To r.RecordCount - 1
d.Content.InsertAfter Text:=r.Fields(2).Value & ", "
r.MoveNext

Next i

r.Close
db.Close

End Sub
7. Click somewhere within the above macro; then press F5 to execute it.

You see a list of 91 names inserted into your current document, ending
with the name Zbyszek Piestrzeniewicz, which is pronounced Ziggy
Stardust.

P If your version of Northwind.mdb isn’t in the path used in this code,
you’ll get an error #3044 message (not a valid path). Use the Start=>Search
feature to locate Northwind.mdb on your hard drive. If it’s nowhere to be
found, rerun your Office 2003 setup CD and choose to install the sample
databases.

In this example, you first create a document object and point it to the current
active document; then you create database and recordset variables. (I talk
more about recordsets and their sucessor, datasets, in Book V when I discuss
Access.) The database variable is pointed to the sample database (which
also opens the database), and the recordset is pointed to the Customers
table in that database.

You can view the structure (tables, fields, views, stored procedures) of a
database by opening the database in Access or by using the new and useful
Server Explorer in the .NET IDE, as shown in Figure 2-7.
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The fields within the Northwind Customers table include customer ID, con-
tact, and other fields. But I'm interested in the CompanyName field (which
happens to be field 2, as you can see in Figure 2-7). So the example code
loops through the entire table by using the MoveNext method of the record-
set object. Notice that you must start your loop with 0 and end it with
RecordCount-1 because recordset fields begin counting their lists with 0,
and that throws everything off by 1, so you have to compensate in your code.

Each time through the loop, the Content.InsertAfter method is used to
add text to the document. (This text is the Value property of the Fields
collection.) A comma and a space are added to the text in the document.
Finally, the two objects are destroyed with the C1ose method.

You can employ the various bookmarks, fields, paragraphs, and other collec-
tions and objects available in the Word object model to insert your data
coming in from a database (or other source) wherever appropriate in your
text. See Book III, Chapter 1 for additional information on the Word object
model.
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Mass Mailings with Mail Merge

Word’s Mail Merge is a specialized combination of some of the techniques
featured in this chapter: bringing data in from outside Word, and automating
the process of inserting text into ranges, fields, or bookmarks. However,
because merging names and addresses into a document for mass mailings is
such a venerable and essential word processing task, a wizard exists to make
the job fairly painless. The wizard sits in Word, but you can also get to it via
Outlook. I show you both pathways.

Word’s Mail Merge is a classic technique: From a data source, you insert
unique information (such as addresses) into form letters. It’s a cheap, easy
way to customize anything from mass ad mailings to the Christmas letter
that you send to all your friends.

You first create a form letter, specifying where you want custom content
inserted (merge fields). Then create a data source (a database table, a table
in a Word document, a spreadsheet, or your Outlook Contact list.)

You use the Mail Merge Wizard to step you through the necessary tasks,

and your form letter can actually take five different forms: a traditional form

letter, e-mail, envelopes, labels, or directories (catalogs) — a single document
containing all the merged data, including a repetition of any additional static
text you want associated with the data.

To create a mail merge, follow these steps:
1. Create a Word document, saving this document to your hard drive

with the name MassMail.doc.

Fill your holiday letter full of news about little Billy and Betty, their many
accomplishments, and an update on Uncle Bob and his dog Sam.

2. Choose Tools=>Letters and Mailings->Mail Merge.
The Mail Merge Wizard appears, as shown in Figure 2-8.

3. Select Letters in the first step of the wizard, as shown in Figure 2-8.

=

Click the Click Next to continue link on the bottom of the task pane.

5. On the second step of the wizard, select Start from Existing Document.

A file browser opens in the task pane, asking you to identify the existing
document.

6. Select Use the Current Document.
7. Click Next.
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8. Select Type a New List in the Select Recipients option button group.
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10. Click the Close button.

The Mail Merge Recipients dialog box opens, as shown in Figure 2-10.

Mail Merge Recipients @
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11. Click OK.
The dialog box closes.
12. Click Next.

The task pane tells you to personalize the letter by adding address
blocks, greetings, and so on.

13. Click above the main body of the letter, where you want to write
Dear XXXXX.

14. Click the Greeting Line link in the task pane.

The Greeting Line dialog box opens, as shown in Figure 2-11.

— (Gresling Line &)
Figure 2-11: || Gectingine format: : :

. Dear s | |, Randal w| s ]
H eres Greeting ine far invald reciplent names: =
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create a P
greetlng Dear Mr, Randall, |
merge field. [cmat ]

15. When you're satisfied with the default greeting style, click OK.

The dialog box closes.
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16. Click above the greeting line in your letter, in the location where you
want the address field to appear.

17. Click the Address Block link in the task pane.
The Insert Address Block dialog box opens, showing you the default style.
18. Click OK.

The dialog box closes. At this point, your document includes two merge
fields, and looks something like this (although details of your Christmas
mass mailing will undoubtedly differ slightly from those written by
Karyn here):

<{<AddressBlock>>

<KGreetinglLine>>

Thank you for everything!!
Uncle Billy is getting better every week!! And Tittle Billy still Toves

his bike!
Love,
Karyn ("Fluffy") Primstance-Mesuremaseur

19. Click Next in the task pane.

You see a preview of your form letter, with the merge fields filled in from
the first record of data.

20. Click Next in the task pane.

The task pane tells you how to either print your mass mailing or edit the
individual letters (making them even more deeply personal).

Book I
Chapter 2

To start a mass mailing process from within Outlook (where perhaps you
keep addresses of many of your Contacts), click the Contacts button in the
left pane of the Outlook window and choose Tools=>Mail Merge. When you
finish making any selections in that dialog box that open and then click OK|
Word opens with the merge document loaded. You then choose Tools=
Letters and Mailings=>Mail Merge in Word, but you begin with the wizard’s
Step 3, as described in the earlier steps.

Bunip3 samog



228  Book III: Maximizing Word



Chapter 3: Using XML in Word

In This Chapter

v+ Discovering WordML
v Using XML
v Using programmatic XML

v Selecting options
v+~ Using the special Word XML editor

In this chapter, you see how XML and Word now work together, synergisti-
cally, to facilitate communication between any and all platforms, operating
systems, data stores, applications, and whatever else might want to commu-
nicate with Word. In a word, XML is today’s lingua franca.

Lingua means tongue. Franca is a corrupted version of Italian that was once
spoken on the Mediterranean coast. It was the language of the Franks blended
into Italian. But the phrase lingua franca has come to stand for whatever
means of communication can be used to make interaction possible between
people who speak different languages.

Introducing Word XML

eXtensible Markup Language (XML) and associated technologies have
become de rigueur in contemporary computing. Book VIII, Chapter 2 goes
into the topic of XML in relation to all Office 2003 applications, but it’s useful
here to introduce the features of XML in Word specifically. Likewise, in the
books on particular Office 2003 applications — Excel, Outlook, and Access
most notably — you’ll find explanations of how XML works in the context of
each specific application.

Microsoft — although located in Seattle, home office of grunge — is no
slacker. Do you imagine that Microsoft would sit idly by while others created
versions of XML and not have a go at it, too? Actually, many flavors of XML
float around in Microsoft operating systems and applications. And the one
of interest here is WordML, which is the schema for Word 2003.
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Making do with what you've got

Although XML files are bulky because they’re
wildly redundant, this just doesn't matter.
Developers and programmers have undergone
a paradigm shift in the past decade. In the early
days (1985 and before), programmers had to be
careful to conserve computer memory because
it was expensive and quite limited. As a result,
programming used every little corner of a RAM
chip. This lead to such unhappy consequences
as employing the number 0 as the firstitemin a
list. (Arrays, lists, and collections sometimes
still have a zeroth index, leading to lots of
unnecessary programming bugs.) Y2K fears

were also caused by programmers trying to
conserve memory, storing dates using only two
digits: 88instead of 7988.

Times change, and yet they don't. Hey, when
paper was expensive, monks in the Middle
Ages wrote on every scrap, sometimes writing
on top of earlier manuscripts (which is how we
lost some invaluable classics, like a treatise by
Archimedes destroyed when a monk thought
the parchment was more valuable than the
genius’s thoughts.) Of course, on the plus side,
monks preserved quite a lot of classical knowl-
edge, as well.
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Excel (with its grids of orderly data) and Access (with its tables of organized
data) seem ideally suited to XML. It’s easy to see how an XML document’s

tidy structure can accommodate a database table or spreadsheet. But what
about Word? Aren’t Word documents fundamentally unstructured? Well, yes

and no. Of course, there are sentences and paragraphs, but they’re not really

that predictable. Too, Word can include tables, numbered lists, and other
comparatively more structured data. But don’t worry; Microsoft has figured
out a way to preserve Word’s hidden structures (formatting, document sta-
tistics, and so on). That’s WordML'’s job: to provide a schema to store a sys-
tematic XML version of a Word document, complete with all the necessary
tag pairs that preserve all the underlying structures of a document.

You can save documents in XML (WordML) format in all versions of Word
2003, but the other XML features are found only in Office 2003 Professional

(or the confusingly named Enterprise Professional version) and the standalone

version of Word 2003.

XML — daughter of HTML and mother of countless child languages — differs

from HTML in some fundamental ways. For one, XML is highly extensible.
Anyone can invent any elements or attributes they want. XML also describes
data (preserving the structure of the information it contains). HTML isn’t
designed to be customized by users, and it describes appearance, such as
boldface or the location and size of a headline.

Although an XML file itself is highly redundant — often containing many
repetitious tags and duplicated data — using XML in the workplace can
paradoxically reduce another, more important redundancy.




XML in Word 23 ’

Take this (intentionally long) example: A salesman writes down an order and
faxes it to the office. There it’s retyped into the home office computer, and
another form is filled out by someone in the fulfillment department. Then
some tags and mailing labels are typed in the warehouse, and the billing
department retypes the details into an invoice while another worker retypes
the order into the inventory management software — and on and on. Not only
does all this repetition introduce obvious productivity losses, but it also
greatly increases the opportunity for typographical errors. If the salesman
had entered the order into his notebook and saved it as an XML file right
from the start, software could take over the job of radiating the order into
its various different forms in the various departments that handle the order.

Put another way, XML data is polymorphic and can easily be expressed,
stored, and printed in a variety of formats — from invoices to mailing labels —
without human intervention. This kind of system is a primary way that your
local friendly SprawlMart differs from the corner mom-and-pop grocery.

Try an experiment. Create a blank Word document and type in Hello, Snarky.

Saving this information in a simple TXT format takes up only 14 bytes, 1 for

each character. Saving it as a WordML file requires 3,442 bytes, and saving it

as a DOC file takes up 24,064 bytes. As you can see, storing all the extra infor-

mation about formatting, author, styles, when it was last saved, line pitch,

and whatnot requires quite a bit of space more than the simple characters

themselves. Book Ill
Chapter 3

Although XML wallows in redundancy, the paradigm shift in computer pro-

gramming is this: Computer memory is now so cheap that different program-

ming styles are possible, such as XML's complete refusal to engage in any

reduction of redundancy. When you can store a person’s entire lifetime of

e-mail messages on a CD that costs less than a penny, why not use redundant

data storage methods if there’s an advantage to be gained? And indeed there

is: Computers don’t make mistakes (although human data-entry or source

code can make computers seem to err). The less that data is handled by

humans (retyping it, for example), the safer that data is.

paop ut JAIX Buisn
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For more on XML, try XML All-in-One Desk Reference For Dummies by
Richard Wagner and Richard Mansfield (Wiley).

XML in Word

XML, being extensible, invites people to create their own versions, so you've
got different XML languages (schemas, or sets of rules and tags) for the baker,
the butcher, and the candlestick maker. What’s more, two different bakeries
might each use their own proprietary XML. However, XML theorists were quite
aware of the Tower of Babel problem. After all, XML was designed in part to
solve the tremendous difficulties resulting from incompatible data storage
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schemes. So, most importantly, XML is stored as ordinary text — letters
making words that people can actually read. If you can read and write your
language, you can also read and write XML (not that you'll usually want to,
but you can if you must).

Here are some of the things you can do with XML in Word:

4+ Mix XML into ordinary Word documents or save documents (convert
them) in XML format.

4+ Validate Word XML files to ensure that the XML is well-formed (meaning
that it makes sense, that all its tags appear in pairs, and that it otherwise
follows the rules of XML documents).

4+ Import or export XML data when communicating with other XML-capable
applications.

WordML is primarily a set of custom tags defining the elements of a Word
document (and there are hundreds of potential elements). Before WordML,
you couldn’t make much sense of a DOC file if you loaded it into Notepad or
otherwise tried to view it as text. Note: It’s not text; it’s a binary file. WordML,
however, is a fully documented set of tags that you can actually read and (if
you wish) manipulate programmatically.

For example, if you open a new document in Word (Filec>New), you see a task
pane open up with XML document as one of the options. Click the XML docu-
ment link in the task pane. An XML Structure task pane opens. Type hello,
select it, and then make it italic and underline it. Now choose File=>Save and
click the Save button in the Save As dialog box. You can choose to optionally
save only the data (no schema), or if you've attached a separate schema,
Word saves that information along with the data.

You then use Windows Explorer to locate the file that you just saved. (Look for
an . xml extension.) Right-click the filename, and choose Open with Notepad
from the context menu. In the mass of information, you should be able to
locate your hello twice in the document, but the one you want is down near
the bottom:

Werd><wrPro<w:i/><w:u w:val="single"/><{/w:rPr><w:t>hello/w:t></w:ir>

Note the <w:1i/> tag (for italics) and the <w:u w:val="single"/> tag (u for
underlining with the additional attribute, single underlining). Rumor has it
that there are more than 3,000 different tags in WordML, which is more than
[ can explore here. Whenever possible, smart programmers let utilities and
applications convert data and documents into HTML or XML. But do be
aware that every Word feature is supported by an XML tag.



Figure 3-1:
The XML
data view
window,
with the
XML
Document
task pane at
the ready.

XML in Word 2 33

Here’s the most basic XML document that Word can read — that Word can
translate from XML into the native DOC format. (This is not the simplest
form of XML file that Word can save, which is much more complex, as you
can see in the preceding hello example.)

<?xml version='1.0"7?>
<w:wordDocument xmIns:w="http://schemas.microsoft.com/
office/word/2003/wordml'>

<w:body>
<w:p><w:r><w:t>Hello, World.</w:t></w:r></w:p>
</w:body>

</w:wordDocument>

If you type this into Notepad (or use Save As Plain Text from within Word)
and then save this file with an . xm1 extension, you can use File=>Open in
Word to load it into Word. When you do this and you're asked whether you
want to convert it from an XML file, click OK. You see the XML neatly format-
ted, as shown in Figure 3-1.

] sml - Microsoft Word ==
=
2| LR locupeat LXK
4 wordDocument ¥ data views
This 3L decument fas multdne data
“ body v, Befre meking chengss tthe
document, dhocss e dale v
[#2T)to apply.
& ol

Lrowse...

(ee{
(«t{Hello, World J&*)
JED)
FD

All visible content in a Word document is contained within the <body> tag
pair. The <p> is for paragraph, <r> for run (a run of text is a string of charac-
ters that all share the same formatting), and <t> is for text.

If you open a WordML file with a schema that you’ve attached (referenced)
and Word cannot find the eXtensible Stylesheet Language Transformation
(XSLT; schema file) in the Schema Library when opening this file, Word applies
its default XSLT.
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Deeper into WordML

You can, of course, automate the process of using XML by writing program-
ming to manipulate it. One typical kind of XML programming involves trans-
lating traditional objects or data structures into XML and then back into their
original formats (or indeed into other formats). You see here how that’s done.

The Word XML Content Development Kit

Go to this address and download the Microsoft Word XML Content Develop-
ment Kit (CDK) Beta 2. It assists you with your Word XML programming by
providing sample code illustrating XML in Word 2003 and documentation
about using XML in your own programming.

http://msdn.microsoft.com/1ibrary/default.asp?url=/downloads/1ist/office2k3.asp

After installing this software development kit (SDK), choose Start=>All
Programs=>Microsoft Office 2003 Beta Documentation. Follow the pop-out
menu items through Microsoft Word XML CDK, and click MSXML Reference.
You'll see the Help window, as shown in Figure 3-2.
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Programmatic XML

[ talk more about manipulating XML data by using shocking-sounding tech-
niques like SAX and DOM in my book XML All-in-One Desk Reference For
Dummies (Wiley), but do note that communication is one of the advantages
of using XML with Word and other applications. You can communicate
between Office 2003 applications — and indeed with other entities such as
.NET-created applications and utilities, or even between platforms — by
using XML in your programming.

As an example, create a VBA program that builds a little XML file with two
objects. (Pieces of data surrounded by schema tags can be called objects, but
then, what can’t?) First the program instantiates two objects; then it loads
an XML string into each. (Read more about Word objects in Chapter 1 of this
mini-book.)

Adding a reference

Open VBA in Word. In the Visual Basic editor, choose Tools=>References.
References attach outside code libraries to your projects; in this case, you
want the XML library. Scroll in the References dialog box until you locate
Microsoft XML, v 5.0 (or a later version). Select its check box to select it and
then click OK to close the dialog box.

Now type in this macro:

Sub XMLwerk()

Dim d As New DOMDocument50

Dim dl1 As New DOMDocument50

d.loadXML "<FirstName>Nitsy</FirstName>"
dl.loadXML "<LastName>Aha</LastName>"

Debug.Print d.XML, dl1.XML
End Sub

When you press F5 to execute this macro, you'll see your XML objects printed
in the Immediate window (View>Immediate Window). This is what you see:

<FirstName>Nitsy</FirstName>
<LastName>Aha</LastName>

You have programmatically created an XML document, added a couple of ele-
ments to it, and then printed the contents of both of those elements. In other
words, you've manipulated an XML schema and its data programmatically.
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Choosing XML Options in Word

When you’re working with WordML, you might want to specify some behav-
iors regarding how XML will be validated, displayed, saved, and loaded. To
do this, choose Tools=>Templates and Add-Ins. When the dialog box opens,
click the XML Schema tab and then click the XML Options button. The XML
Options dialog box opens, as shown in Figure 3-3, with the following choices:

4+ Save Data Only: The Save Data Only option filters what data Word saves.
Only data related to an attached schema will be saved; none of the other
document information (such as author, date of origin, number of words,
macros, and so on) is saved. This is a slimmer, less Word-specific version
of saving the full XML data. If you don’t choose this option (it’s also avail-
able in the XML task pane), Word saves everything specified in the default
WordML schema, including formatting, embedded graphics, and other
such details.

4+ Apply Custom Transform: If you select Apply Custom Transform, Word
runs the data through whatever XSLT transformation you request. Find
more on transforms in Book VIII, Chapter 6.

4+ Validate Document against Attached Schemas: Selecting the Validate
Document against Attached Schemas option causes Word to check the
accuracy of the XML. In other words, it asks, Does it conform to the
schema? Any errors are displayed in the XML Structure task pane.

4+ Hide Schema Violations in This Document: This option causes Word to
eliminate the graphics (lines) in the document that alert you to any vio-
lations of the schema.

4+ Ignore Mixed Content: This option is used when you want to save DOT
files (templates), and you expect users to enter data into your XML struc-
tures. Formatting that they enter along with their text causes no problems.

4+ Allow Saving as XML Even if Not Valid: This option permits XML to be
saved even if it can’t be validated via an attached schema. Use this to
save your work even though you’ve not completely filled in the entire
document (and it’s thus invalid technically).

4+ Hide Namespace Alias in XML Structure Task Pane: This option causes
Word to omit an attached schema’s namespace alias (or even the entire
namespace if no alias has been provided) after each element name.
(Namespace is another clerical term used to specify a particular library
of code. Read more about aliases in the following section.) Seeing the
namespace repeated like this can be cumbersome, redundant, and unnec-
essary in the diagram displayed in the narrow task pane. You usually want
a cleaner view — like the one in Figure 3-4 — especially if more than one
schema is attached to your file.

4+ Show Advanced XML Error Messages: This option causes Word to dis-
play extra information about schema violations.
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4+ Show Placeholder Text for All Empty Elements: This option takes effect
if you've turned off the display of XML tags in the document (by dese-
lecting the Show XML Tags in the Document option on the task pane).
Word displays instead a placeholder when it finds an empty element.
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Working with XML in Word’s Special Editor

Try a couple of exercises to familiarize yourself with how XML documents
can be manipulated by using the special XML editor window and its associ-
ated task pane. (See any of the task panes by choosing Viewr>Task Pane.
Then click the small, inverted triangle symbol next to the X in the top-right
corner to drop a list of available task panes.)

First, create a schema to use for practice. Type this simple schema (Listing
3-1) into Notepad (to avoid any extra formatting, and so on) and then save it
as PartyTime.xsd.

Creating a practice schema

Remember that a schema is an XML structure into which data can be inserted.
The particular schema in this example helps you plan a party by including
fields for the names of all your friends as well as a Personality section describ-
ing their strengths and drawbacks as people.

Listing 3-1: Practice XML Schema

<?xml version="1.0" ?>
<{xs:schema id=" PartyTime'
xmins:xs="http://www.w3.0rg/2001/XMLSchema’
>
<{xs:element name=' MyFriends' >
<{xs:complexType>
<{xs:choice maxOccurs=" unbounded' >

{xs:element name=' NameAndComments' >
{xs:complexType>
{xs:sequence>
<{xs:element name=" Name' minOccurs=" 1" maxOccurs=" 1" >
<xs:complexType>
{xs:sequence>
<{xs:element name="' Firstname' type=' Xxs:string'
minOccurs=" 1" maxOccurs=" 1" />
<{xs:element name=" Lastname' type=' xs:string’
minOccurs=" 1" maxOccurs=" 1" />
{/xs:sequence>
<{/xs:complexType>
<{/xs:element>

{xs:element name=' Personality' type=' xs:string'
minOccurs=" 0" maxOccurs=" 1" />

<{/xs:sequence>
<{/xs:complexType>
{/xs:element>
{/xs:choice>
{/xs:complexType>
{/xs:element>
<{/xs:schema>
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Now follow these steps to store your new schema:

1.

s W N

Choose File>New in Word and then choose XML Document from the
task pane.

Click the Templates and Add-Ins link in the task pane.

Click the Add Schema button in the dialog box.

Browse your hard drive and choose PartyTime.xsd.

Type this in for the URL: http://www.w3.0rg/2001/XMLSchema.
You have to put one in, so just use this.

Type Party for the alias.

It’s nice to use aliases, or else you'll see the schema displayed with the
entire cumbersome namespace. And sometimes you’ll go hog-wild and
use several schemas at once, each with its own cryptic namespace.
Aliases make it easier to remember what each schema does.

Close the dialog box.

Your new schema is displayed in the task pane as MyFriends{Party}.
Party is the namespace alias.

You now have your empty shell into which you can pour data. This schema
is also automatically added to the library of schemas maintained by Word
(and it can be later used with other documents).

Using the XML Structure Task Pane

Word’s XML Structure task pane offers several advantages to the busy XML
document creator. With it you can

+

IR SRR

See the entire structure of the attached schema(s), including child ele-
ments nestled within outer elements.

See the structure displayed hierarchically.
Edit the XML data by adding and removing elements.
Show or hide tags within Document view.

Get error messages if you abuse the schema’s structure (removing an
End tag, for example).

Building your XML document

Now build an actual XML document by adding some data. In the Element list at
the bottom of the task pane, you see the top-level element (the outermost ele-
ment, or the one within which all other elements are nested). It’s MyFriends.
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Figure 3-5:
Your first
XML tag
pair ready
for editing in
Document
view.

Click it in the list to add to your document, and you see NamesAndComments,
which is the second outermost pair of tags in this Russian dolls eggs-within-
eggs structure of nested items.

You now see the outer element tag pair in your document, as shown in
Figure 3-5.

(‘“ MyFriends El] MyFriends ";]

Pt

At this point, though, you’ve been a bad puppy and made a mess . . . temporar-
ily. Notice the little question mark in the top of the task pane. Hover your
mouse pointer over that ? to see Word telling you that you’ve violated one

of the rules of your schema. That’s right: This must contain other elements.
In other words, just your outermost tag pair by itself does not a valid docu-
ment make, according to your schema. And, should you be a really bad dog
and try to save this as an XML file, you’ll be told that you can’t because it’s
in violation of the rules. You can save it as a DOC file but not as an XML file.

Word also alerts you to the violation with the vertical, saw-toothed purple
line in Document view. Right-click that, and you get the same violation report
at the top of the context menu. Anyway, you know what to do: Add more ele-
ments to correct the violation.

Notice in the lower box in the task pane that a new element (the second
outermost) is now displayed: NameAndComments, which you should click.

It’s inserted where it should be between the outer MyFriends tags. Click
Firstname in the task pane box. Notice that the box is now empty because
no further nested tags are within the Name pair. However, there are two other
pairs of tags: LastName and Personality. To see them in the box, press the
right-arrow key. Now you see Firstname and Lastname. Click Lastname.

At this point, the two, innermost tag pairs become strange. They turn pink!

And they also no longer display tag pairs but have been collapsed into a single
pink icon, with ( ) closed parentheses. This is to save some space in the dia-
gram. It’s still the same old open-tag/close-tag pair in the underlying XML, but



Figure 3-6:
Your
complete
Party XML
document,
displayed

in two
diagrams.

Working with XML in Word'’s Special Editor 2 4 ]

for your viewing pleasure, tags that can hold data automatically turn pink and
collapse. You can force other (no-data) tags to collapse, too, if you wish. Click
to the left of a tag and then press Tab. That tag-pair collapses, and any tags
that it encloses (child elements as they’re called) also collapse. Ctrl+Z reverses
the collapse.

At this point, you might want to cursor around within the document and use
the Enter key and others to format the diagram in the usual XML way, putting
child elements on their own lines, indenting to show nesting, or whatever else
rings your bell. The underlying XML is unaffected by these merely visual
rearrangements.

To add the final data element, Personality, click between the Name and
NameAndComments closing tags. You see Name and Personality listed in the
task pane box. (You can add as many Name elements as you wish; that’s why
it’s available.) However, just click the Personality element to add it to the
diagram. Personality has no child elements. At this point, your document
should look something like Figure 3-6.
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Type in a first name, last name, and a brief description of the personality in
the appropriate places between the parentheses and the tags. Then choose
Filec>Save As and save the document as Party.xml. This time, Word doesn’t
object to your wish to save the file.
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Extending the variety of uses to which a single XML data document can be
put is not difficult in Word. You can manipulate the data or schema itself via
SAX and DOM techniques, and you can convert XML into various formats via
transforms. These and other topics are covered in various sections through-
out this book, and specifically in Book VIII, Chapter 6.



Chapter 4: The Internet Connection

In This Chapter

v Creating Web pages in Word
v Understanding Web file types
v Changing Web options

v Using the Web Tools toolbar
v+~ Using Web page controls

v Scripting Word Web pages

v Testing Web pages

v+ Understanding ASP

Can your Word documents be stored as Web pages and then viewed on
the Internet? Indeed, they can. As you see in this chapter, you won’t
want to use Word as the front end for a big enterprise database-driven
invoicing system. But for smaller jobs, such as displaying your pictures or
blogging your feelings for all to see, Word does a serviceable job. And if
you've already created documents that you want to display to the world,
nothing could be easier than changing DOC files into Web pages.

Creating Web Pages in Word

Few areas of contemporary computing have been untouched by the impact
of the Internet, which is currently estimated to comprise 92-million giga-
bytes of data (and exploding). Office 2003 applications are no exception.

If you're creating a complex, huge Web site, use a dedicated Web page
designer application. FrontPage, for example, includes helpful tools to make
working with multifaceted sites easier than using Word. And if you want true
power — including tools for creating dynamic, scalable Web pages — go for
Visual Studio .NET.

However, if you're comfortable working in Word — you’re familiar with its
formatting features, tables, and so on — you can design perfectly fine Web
pages in Word. Just do what you normally do to create and design a docu-
ment, and what you see is what you will get on the Internet.
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When you save a Word document as a Web page, you can then load that
page into Internet Explorer and be pleased with what you see. Word does the
tough job of translating the document into a Web page; all the HTML code is
hidden from you. Yet, with the exception of a few items (headers, footers,
and newspaper-style columns, which HTML doesn’t support), the page
should look pretty much as you designed it.

And if you need to build some interactivity built into your Web page, VBScript
and JScript are available in Word as well. But don’t be misled: Word-designed
Web pages are largely for display and not serious interactivity. You can build
nice advertisements, informative tutorials, and so on. But because Word is a
document-processing system, it simply doesn’t offer the tools necessary to
build a database-driven, heavy-duty, or complex interactive Web site. For that,
do consider using Visual Studio .NET instead.

Saving as a Web Page: The Three Kinds of Files

When you choose Filem>Save as Web Page, you're given a choice between
three file types:

4 Ordinary, plain HTML: Word calls this type filtered because all Word
codes are stripped out and only HTML is left. Choose this if you plan to
edit the page further in some other Web page editor that could trip on
some of the proprietary Word formatting.

4+ Web Page: This includes both HTML and the codes that Word uses to
construct the page’s formatting in the Word editor. This choice creates a
larger file, obviously, but it allows you to continue working on the page
in Word.

4+ Single File Web page (Mime, MHTML with an .mht extension): This
format incorporates any necessary support pages (such as a graphics
file) into a single file. If you don’t choose this option, any support files
are kept in a separate, dependency folder from the main HTML file.

Adjusting the Web Options Settings

You can make more specific adjustments for your Web pages in Word by
choosing Tools=>Options and then clicking the Web Options button of the
General tab. Here, as shown in Figure 4-1, you can select specific target
browsers, which is useful if you're creating pages for an office intranet and
you know that your company is still using an old version of Internet Explorer
or even Netscape.
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The Portable Network Graphics (PNG) and Vector Markup Language (VML)
graphics formats are relatively new but do outperform the standard formats
such as JPG. PNG is a beefed-up version of GIF, with support for 48-bit true-
color or 16-bit grayscale and improved compression. VML uses equations to
describe shape and fills, resulting in highly scalable drawings with very little
bandwidth hit. (The drawings are described mathematically rather than
transmitted as graphics files.) Of course, the results are essentially cartoon-
ish, clip-art quality — not photographic.

Because cascading style sheets (CSSes) are pretty much universally under-
stood now, you probably leave that option selected. Use the Files tab to
refine how you want your Word Web pages saved, and the Pictures tab speci-
fies the monitor resolution you want to target. Adjusting the pixels per inch
(ppi) allows you to adjust the loading time of graphics-intensive Web pages
(by, for example, speeding things up at the expense of some image quality by
setting the ppi to 72). Leave this one alone for most applications. The Fonts
tab allows you to specify different default fonts.

Building a Web Page in Word

You can take two approaches to creating a Web page in Word: Start with an
ordinary Word document and then save it as a Web page, or begin with a
blank Web page from Word’s File>"New menu. I suggest that you take the
second approach because Word knows from the beginning that you intend
this document to end up on the Internet, so it offers you some additional
help (some menu features specific to HTML, for example).

To create a new Web page, follow these steps:

1. Choose File>New.

The New Document task pane pops out.
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Figure 4-2:
Your mouse
cursoris
followed by
some extra
lines when
you're in the
Web page
design
window.

. Click the Web page link in the task pane.

A new document opens, looking pretty normal (but don’t be fooled).
Take a look at the mouse pointer, for example. It’s got some extra lines
following it around the screen; it’s a different icon than the usual I-beam
shape, as shown in Figure 4-2.

—
"

. Create your Web page by typing in some text and maybe adding some

pictures (choose Insert=>Picture).

. For a good scare, choose View=>HTML Source.

The Microsoft Script Editor opens, holding your code. You can type in
VBScript (or JScript) if you wish, using this editor. You also see the
bloated HTML code that is necessary to display your few words and
graphics in a Web page, as shown in Figure 4-3.

. Close the Script Editor.

No point in spooking yourself by seeing what unfortunate Web program-
mers had to contend with a few years ago. You'll reopen this editor at
the end of this chapter to fiddle around a bit with scripting, which isn’t
the same thing as writing HTML. Scripts are Visual Basic (or Java), some-
what pared down to remove file-access and other behaviors that could
be used for bad purposes by hackers.

. Choose Filec>Save As.

The Save As dialog box opens.

. In the Save as Type list box on the bottom of the dialog box, choose

Web Page.

The file is saved. If you inserted graphics, a subfolder is created to hold
them.
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8. In Windows Explorer, locate the HTM file that you just saved, and E %
double-click its filename to open it. s %
Your browser (probably Internet Explorer) opens, and your Web page is
displayed, as shown in Figure 4-4.
® If you're creating a Web page, you’ll probably enter a test-modify/code-retest

cycle until you get things working as you want. It’s simpler to view and test
the Web page by using the Filec>Web Page Preview feature than to save the
file each time through the cycle and then activate it via Windows Explorer, as
you did in Step 8 in the preceding example.
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Using the Web Tools Toolbar

With the various buttons on the Web Tools toolbar, you can easily add a vari-
ety of useful controls, such as check boxes, option (radio) buttons, list boxes,
text boxes, submit buttons, passwords — even movies and sound. Just click

in your document where you want the control, and then click its icon on the
toolbar.

Right-click any toolbar in Word and then mark the Web Tools check box in
the drop-down list of toolbars. You see the Web Tools toolbar, as shown in

Figure 4-5.
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You can also use this toolbar to add special effects, such as scrolling text
(great, if you like annoying people) and background texture (okay if used in
moderation).

Adding scrolling text

I ask that you avoid using scrolling text. (Shudder.) It’s usually second only to
animations and pop-ups as the most annoying features of vulgar Web sites.
Used mostly for ads, scrolling text makes it hard to read the other elements
on the Web page. But if you must (cough . .. if the boss insists), add it from
the Scrolling Text dialog box, as shown in Figure 4-6.

Scrolling Text %]
Behavior: | Serol »| Backgreund color: | 7] auto vI
Direction: |Left | Loop: Tnfinke vl
—Spead

1
Show Fast

Type the scroling text here:
HEY!| LOOE AT MEINN

Preview

HEY!I LOOK AT

5] o |

Open this dialog box by clicking the rightmost icon on the Web Tools toolbar.

Adding background texture

Background textures do add quality to your Web pages. From the Fill Effects
dialog box (choose Format=>Background=Fill Effects), you can add gradi-
ents, textures, or graphics to the background of your Web page. (Another
option, patterns, I'd avoid. They’re not only distracting; they’re also cheesy.)
A gradient adds interest to the Web page shown in Figure 4-7. Gradients, if
not too extreme, add a nice metallic look. The one in Figure 4-7 goes from
white to gray, but [ recommend avoiding the default white-to-black gradient
because it’s too strong.

The textures available in this dialog box are also useful, but again, as with
gradients, use a light touch and ensure that the background doesn’t interfere
with the foreground text and graphics, as it does in Figure 4-8.
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Scripting in Word Web Pages

While viewing your Word Web page, press Alt+Shift+F11. There it is! A VBA-
style editor, complete with a Toolbox for adding controls, debugging facili-
ties, a properties window for adjusting controls’ qualities, and a project
window to show you the various documents and other files in the current
project (which in this case is a Web site).

Although Word created the HTML that describes your Web page, strangely
enough, you'll find lots of little, squiggly red underlines in the code. These
are indications of various errors in the HTML code, but just ignore them. The
editor’s parser is evidently more uptight about HTML violations and illegal
nesting than Internet Explorer is. And lucky for you, you don’t have to worry
about this stuff, anyway:.

You can drag and drop controls from the Toolbox into the code, but do try to
add them in the right places (not within attribute lists of other elements, not
in the header, and so on). In fact, it’s easier to add controls from the Web
Tools toolbar. (See the earlier section, “Using the Web Tools Toolbar.”)
Remember that you're working in a design view (not this code view), and
you can let Word worry about inserting the controls’ code where it should
be inserted. However, the Toolbox in the Scripting Editor does have a few
controls not available on the Web Tools toolbar. Book I

Chapter 4
Scripting is inserted into an HTML page between <SCRIPT> tag pairs
</SCRIPT>. Also, the script code is clumsily enclosed within the HTML tag
pair for comment: <! - -

-->

uonvauuoY)
Jauayu| ay|

Normally in programming, a commented zone within code is ignored and not
executed. In HTML, though, this merely prevents browsers that cannot execute
script from instead displaying the source code to users (many of whom would
be baffled by seeing it).

Scripting is similar to programming any other language, but note a few
differences:

4+ HTML pages are read from top to bottom by a browser, so you usually
insert your script code in the HEAD section of a Web page.

This way, it’s decoded by the browser and is ready to respond to any
action that later takes place in the lower BODY section of the page.

4 You can put your code within Sub or Function procedures, and that
code executes only when the procedure is called (by other code in
the page).
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Or, if you put code outside a procedure, that code is executed only one
time — when the page first loads. So, you put your initialization code
outside procedures in the HEAD section, which is the equivalent of using
VB’s Form_Load event.

To see how all this works, create a new Web Page (FileoNew=>Web Page) and
then press Alt+Shift+F11 to open the editor. In the HEAD section (just above
the </head> tag), type this function:

<script Tanguage="VBScript">

<h--

Function SubmitIt()

n = Msgbox ("Thank you for your order!")
End Function

-->
{/script>
</head>

You can name the function whatever you want. It’s an event that will respond
whenever a Submit button (a button-style control in HTML) is clicked by the
user.

Whenever you want to insert script, you can get the template of the code by
right-clicking the background of the code window and then choosing Insert
Script from the context menu.

In the code view in the Editor, click in the BODY section of your HTML code
and then double-click the Submit button on the Toolbox. This code is
inserted for you:

<INPUT type="submit" value="Submit" ID=Submitl>

That’s enough to display a Submit button in a browser, but you need to add
an additional attribute to this element to make it trigger your function when-
ever the user clicks this button:

<INPUT type="submit" value="Submit" ID=Submitl onclick="SubtmitIt()">

By adding an onc11ick attribute, you're telling the browser to execute the
named procedure — SubmitIt in this case — whenever the user clicks the
button. This is one way to interact with the user.

If you copy code from a word processor, the code will contain extra format-
ting codes when you paste it into a code editor such as the Script Editor or
Visual Studio. It will look something like this:

<p class=Code>&1t; INPUT type=&quot;submit&quot;
value=&quot;Submit&quot;ID=Submitl&gt; </p>
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Understanding ASP

One of the best ways to interact with users —
and to provide dynamic content in Web pages,
such as database interactivity — is ASP and
not ordinary scripting. Active Server Pages
(ASPs) refers to a technology in which you can
write scripting such as VBScript (or using
ASP.NET, you can use the full VB.NET language)
to respond to and interact with Web site visi-
tors in a more efficient way than with ordinary
scripting. The key is that security problems are
solved because no script is ever sent to the
user's browser. Instead, all executables (scripts
or programming code) run on the server — only
HTML is sent to the user.

When a Web page is loaded into a browser
(when a user visits a Web site), the user’s
browser handles the typical HTML codes — for
example, <H1>, which causes the browser to
display text as a large headline. (<H1> means
Heading #1, the biggest one.)

However, if a Web page contains ASP pro-
gramming, something happens before the page
is sent to the user. Any code in the page found
between the special ASP percent symbol
codes <% and %> is interpreted on the server
where the Web site sits. The page is interpreted
before that Web page is sent to the user's
browser. The server translates the program-
ming code into plain ordinary HTML, so there’s
no security issue — it flows directly into the
user's browser.

What use is ASP in a real-world situation?
Without ASP, Web pages can be mere exercises

in publishing— not all that much more useful or
advanced than the traditional advertisement. If
you own a bookstore, you can print a flyer or
take out an ad in a paper. You can do the same
kind of thing with your Web site — list titles and
display covers. Because users block scripts,
your page is not interactive.

But by adding ASP to your Web pages, you
enable users. They can, for example, tap into
your databases directly (read-only, of course,
unless you specify otherwise). With ASP, you
could let a visitor to your bookstore’s site see
the latest discounts, see all the books you offer
by searching your database, compare prices
interactively, and even place orders. In other
words, users can do dynamic things that used
to require both a phone call to your office and a
person in your office to provide assistance.
Think of it this way: The ASP technology — to
a great extent — lets users be their own cus-
tomer service department.

When a user clicks a button or otherwise inter-
acts with the page, a message is sent back to
the server for a response. Executables execute
on the server, and another HTML page is com-
posed and sent back to the user. In this way,
users can interact with your site without facing
any danger of virus attacks. Thus, if you want
to create Web pages that seriously, dynami-
cally interact with users, abandon the features
available in Word or other Office 2003 applica-
tions and start using Visual Studio .NET to build
your Web site.

To strip off all the unwanted codes, first paste the copied programming into

Notepad. Then copy it from Notepad (select it and then press Ctrl+C) and
paste it into the editor. It will then look like this, as it should:

KINPUT type="submit" value="Submit" ID=Submitl>
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Testing your Web page

Now test your Web page. Go to the design view of your Web page (the Word
document view) and click the Refresh button if necessary. You should see
your Submit button. Choose Filex>Web Page Preview. Click the Submit button
in the browser, and you should see your message box. (If you don’t see it,
proofread your code to ensure that your onc1ick attribute includes the cor-
rectly spelled name of the function.)

In VBScript, you can avoid having to add an event trap to a Submit button.
VBScript allows you to simply create a function with the ID of the object
(submitl in this example) separated by an underline ( _ ) from the name of
the event you're handling (onc11ick in this example). So you could option-
ally omit the oncTick="SubmitIt()" attribute and just name your function
like this: Function Submitl_OnCTlick().If you name the Function like
that, it will be executed when the user clicks the Submit1 button.

Understanding scripting’s drawbacks

Alas, scripting has been responsible for some virii — or blamed for it,
anyway — so some people turn off scripting in their browsers. Then no
script can execute. A more elegant and universally effective approach is
available via Active Server Pages (ASP).



Chapter 5: Advanced Word Macros

In This Chapter

v Deciding what deserves to be automated

1 Accessing other Office applications from within Word
+* Modifying Word’s built-in features

1+~ Specialized formatting

1+ Advanced automation

+ The best Word macros of all time

Wth VBA, you can use a macro to automate anything that you do
repeatedly. Macros are a highly useful way to shift the burden of repet-

itive tasks from you to the machine. And don’t forget that you can turn on
the macro recorder and then follow the usual steps to accomplish your task
(for the last time). When you're finished, just turn off the recorder, assign
your macro to a shortcut key combination, and happily ever after just press
a couple of keys to accomplish what you used to do slavishly by hand.

In this chapter, you see how to contact and manipulate other Office applica-
tions from within Word, access and modify the behavior of Word’s built-in
features such as FileSave, and are treated to what I consider the best Word
macros available (at least for a writer).

Writing Macros 101

Perhaps the best way to master Office applications’ macro programming is
to record a macro and then look at the code that’s automatically produced.
(Choose Tools>Macro>Record New Macro.) In fact, if you ever get con-
fused and need to see how a menu item or some other feature can be coded
into VBA — the macro language — just record the behaviors, press Alt+F11
to open the macro code editor, and look at the code.

Additionally, macros can also do some things that are not available in
normal Word. That is, they can do things that don’t appear in any toolbar or
menu. For example, you can contact other applications and send messages
back and forth between Word and the outside application. To see how to
send some data to an Excel worksheet, type the Sub in Listing 5-1 in the
macro editor.
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Listing 5-1: Sending Interapplication Data via a Macro
Sub ContactExcel()

Dim ExcelSheet As Object
Set ExcelSheet = CreateObject("Excel.Sheet")

With ExcelSheet.Application
.Cells(l, 1) = "Hello, Excel! This is Word speaking!."
.ActiveWorkbook.SaveAs "c:\ExcelTest.x1s"
.Quit

End With

Set ExcelSheet = Nothing

End Sub

To execute the macro, press F5 while your blinking insertion cursor is inside
this Sub in the code window. Although nothing seems to happen, use Windows
Explorer to double-click the new file (ExcelTest.x1s) on your C drive. When
you do, the file loads in Excel, proving that Word started Excel running
(CreateObject), sent your data to one of the cells in the current worksheet,
saved the workbook that contained this worksheet, and then closed Excel —
all with a few lines of code.

If you prefer to see Excel running, just the.Visible = True property in the
above code.

With ExcelSheet.Application
.Visible = True
.Cells(l, 1) = "Hello, Excel! This is Word speaking!"
.ActiveWorkbook.SaveAs "c:\ExcelTest.x1s"

End With

If you want users to be able to see the names of your macros and execute
them, create them as a Sub in the Macros dialog box (Tools>Macror>Macros).
If you don’t want a macro to appear in the dialog box, create it as a Function.

Interception: Modifying Built-In Word Features

Another great use for macros is their ability to intercept Word’s built-in menu
or toolbar features and make them behave differently. For example, to over-
ride the Filem>Save option through a macro — replacing the usual actions with
your own preferences — just name the macro after the menu+item, such as
Sub FileSave(). Now whenever someone chooses Filem>Save (or activates it
otherwise, such as via a shortcut key combination), your macro — not the
built-in Save action — will execute.
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Here’s a useful example. Perhaps you want to always save your documents
in two different locations on your hard drive as a safety measure. After all,
unless you're directly hit by a meteor, it isn’t inevitable that two different
locations on your hard drive will simultaneously fail. (Of course, they could,
which is why you also back up your work to CDs or some other offline stor-
age.) But saving your current document to two locations in your computer
(or perhaps a separate, second disk drive) is a good precaution.

Suppose that whenever you choose File=>Save, you want to save the document
in the normal way, but you also want to save a copy of the document to a direc-
tory called C:\archives. First, record a macro that copies the File>Save As
action. Listing 5-2 shows you the format for SaveAs, which is what you want
when saving two copies because SaveAs is necessary if you're changing the
filepath for the Save. Then press Alt+F11 to see your new macro in the editor.

Listing 5-2: Double-Saving a Document

Sub doublesave()

' doublesave Macro
' Macro recorded 12/31/2003 by Richard

ActiveDocument.SaveAs FileName:= "bk0305 new.doc",

FileFormat:=wdFormatDocument, _

LockComments:=False, Password:=""
AddToRecentFiles:=True, WritePassword _

:="", ReadOnlyRecommended:=False,
EmbedTrueTypeFonts:=False, _

SaveNativePictureFormat:=False, SaveFormsData:=False,
SaveAsAOCELetter:= _

False

End Sub

Fair enough. But now you want to also save the backup copy as well. When
you use SaveAs, the current directory is switched to the new target of the

SaveAs. However, you don’t want this to happen. You want to preserve the
current directory. The way to do this is to first store the current directory:

Path = Selection.Document.FulTlName 'save current path

Then build a new filepath for the backup:

bakpath = "c:\archives\" & Selection.Document.Name 'create backup path

Now you can employ these paths to first SaveAs to the archive folder and

then SaveAs to the original folder (which has the effect of restoring the origi-
nal current directory). The complete macro is in Listing 5-3.
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Listing 5-3: The Complete Double-Save Backup Macro
Sub FileSave()

' doublesave: archive and original, for backup

Path = Selection.Document.FullName 'save current path
bakpath = "c:\archives\" & Selection.Document.Name 'create

backup path

ActiveDocument.SaveAs FileName:=bakpath,
FileFormat:=wdFormatDocument, _

LockComments:=False, Password:="",
AddToRecentFiles:=True, WritePassword _

:="", ReadOnlyRecommended:=False,
EmbedTrueTypeFonts:=False, _

SaveNativePictureFormat:=False, SaveFormsData:=False,

SaveAsAOCELetter:= _
False

ActiveDocument.SaveAs FileName:=Path,
FileFormat:=wdFormatDocument, _

LockComments:=False, Password:=
AddToRecentFiles:=True, WritePassword _

:="", ReadOnlyRecommended:=False,
EmbedTrueTypeFonts:=False, _

SaveNativePictureFormat:=False, SaveFormsData:=False,

SaveAsAOCELetter:= _
False

WordBasic.PrintStatusBar "This document, and a backup,
were saved, honey."

End Sub

Finally, as a courtesy to myself, I display a subtle, yet heartwarming, mes-
sage on the status bar.

QNING/ If you get an error when running this macro, your security settings are likely
to blame. The path specified might be read-only or something. As usual,
when you're tripped up by security, consult your administrator. If you're the
administrator, consult your own bad self.

Using Macros for Specialized Formatting

You should also consider employing macros to combine multistep jobs like
specialized formatting. For example, one book publisher’s editors do not like
the phrase do not. They want you to replace it with don’t, on the theory that
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this usage is more friendly, less academic, and less bossy. | suppose they’re
right. They go further: They want you to replace cannot with can’t, will not
with won'’t, and for instance with for example. So, the intelligent person
records these various search and replace actions into a single macro. Then,
each chapter can be instantly scanned and fixed in one single step by run-
ning the macro. In Listing 5-4, you can see what part of this macro looks like.

Listing 5-4: Replacement Formatting in Word
Sub firstFormat()

" firstFormat Macro
' Macro recorded 12/2/2002 by Richard Mansfield

Selection.Find.ClearFormatting
Selection.Find.Replacement.ClearFormatting
With Selection.Find
.Text = "cannot"
.Replacement.Text = "can't"
.Forward = True
.Wrap = wdFindContinue
.Format = False
.MatchCase = False
.MatchWholeWord = False
.MatchWildcards = False
.MatchSoundsLike = False
.MatchAlTlWordForms = False
End With
Selection.Find.Execute Replace:=wdReplaceAll
With Selection.Find
.Text = "will not"
.Replacement.Text = "won't"
.Forward = True
.Wrap = wdFindContinue
.Format = False
.MatchCase = False
.MatchWholeWord False
.MatchWildcards False
.MatchSoundsLike = False
.MatchAllWordForms = False
End With

Macros should also be used when you want to combine formatting jobs that
cannot be accomplished via a single Search and Replace dialog box. For
example, you cannot simultaneously format both a paragraph and a font:
These require two separate dialog boxes. However, you can accomplish this
kind of thing with macros. Also, you're likely to find various jobs easier when
you assign macros to keyboard shortcuts. Anyone who frequently writes or
edits documents will understand.
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For example, | frequently have to apply four headline styles while I'm writing
a book. I could drop the list box of styles on the Standard toolbar and scroll
through that list to find the appropriate headline style. I could, but I'd be nuts.
It’s far easier to create this macro (see the following steps):

Sub ATtH(O)
Selection.Style = ActiveDocument.Styles("Heading 1")
End Sub

Now assign this macro to the Alt+H key combination:

1. Choose Toolsc>Customizec>Keyboard.
2. In the Customize Keyboard dialog box, click Macros in the category list.

3. Find the appropriate macro in the list on the right and click it to select
it (in this case, the macro named A1tH).

4. Click in the Press New Shortcut Key text box and press whatever key
combination you want.

[ suggest Alt+H, for headline. Then I follow this same approach to rede-
fine Alt+J (Headline Style 2) and Alt+K (Headline Style 3).

If your new shortcut is already assigned to a different (perhaps Word
default) shortcut, such as Ctrl+O (the Open standard), you see a message
to that effect. You can usually override the default, but some presets are
sacrosanct, like File>Open (Ctrl+O). For more limitations on what keys
you can (yea!) and can’t (argg) reassign, see the later section, “Redefining
ordinary keys.” And for the scoop on how to override Word’s overrides
(woohoo!), see the later section, “Switching windows and deleting words.”

5. Click the Assign button.
The shortcut that you enter hops to the Current Key field.

6. Click the Close button to exit the Customize Keyboard dialog box and
then click the Close button of the Customize dialog box.

Thereafter, any time [ want a Level 1 (main) heading, I just press Alt+H any-
where on the line where the headline sits, and it’s instantly formatted.

Naming shortcut keys

Follow these simple rules when assigning keyboard shortcuts.
4+ Name the macro after the shortcut (A1tH, A1tJd, A1tK, A1tL, for example).

This way, you can always tell which keyboard shortcut triggers the macro.

You can also look up this information by choosing Tools=>Customizer>
Keyboard and then clicking the name of the macro to see the macro’s
shortcut combination.
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4+ Name the macro after its purpose.

Some people prefer to give their macros names that are descriptive of
the macro’s job: LevelOneHeadlineSty1e, for example. This approach
doesn’t interest me because I find it quite easy to read the programming
code in a macro to find out what it does. However, you could always add
a descriptive comment to the code by preceding the line with a single
quote character: '

4 Group related macros together.

For example, in my macros, A1tH, A1tJ, A1tK, and A1tL apply the four
heading styles from largest to smallest, respectively.

4+ When possible, use mnemonic first characters.

For example, use A1tH for headline style, A1tN for normal style, and so on.

Storing macros

For the most part, you can store your macros in the Normal.dot (NewMacros)
file, which is the template that’s always loaded with any document you open,
no matter what other templates might also be used. When you first record a
macro, it’s automatically stored in Normal.dot by default, as you can see in
Figure 5-1.

Record Macro %]
Macro name:

Macros

Assign macro to

é :.. Tocbars @ Keyboard

Stare macra ind

Al Documents {Mormal,dot) w |
Description:

Macro recoeded 12/31/2003 by Richard

[ coat )

You can choose to store this macro only in the current document by select-
ing the Store Macro In drop-down list as shown in Figure 5-1. In that case, the
macro is usable only when this document is the active one: that is, not in
any other document. You can also store a macro in a template so that it
works only in documents that use that template. Select this option from the
Store Macro In drop-down list, too. Finally, you can store macros in add-ins,
but I've never tried that.
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Add-ins can, however, be useful in their own right, without using any macro
code in them. In Book VIII, Chapter 1, you can read all about add-ins and see
how to create them. One major advantage of creating an add-in is that you
thereby bring VB.NET’s powerful programming capabilities to your Office proj-
ects. Add-ins use compiled native code and also run in-process, thus avoiding
the slight speed penalty exacted when either of these conditions are not met.
Also, as the example in Book VIII, Chapter 1 illustrates, a single COM add-in
can automatically load within multiple Office applications (either at applica-
tion startup or on demand, depending on your specification).

Automating Macro Execution

To have Word automatically execute a macro at specified times, give the
macro the following names:
4+ AutoExec: Runs each time you start Word
4+ AutoNew: Runs each time you create a new document
4+ AutoClose: Runs when you close a document
4+ AutoExit: Runs each time you shut down Word itself (not just a document)
4+ AutoOpen: Runs whenever you open a template (or any document based

on a template) containing a macro with this name

To use one of these special macros, just name the macro using one of the
words in the list above. For example, to display the word count each time
you close a document, name your macro AutoClose, like this:

Sub AutoClose()

Dim dlg As Object: Set dlg = WordBasic.DialogRecord.Documentstatistics(False)
WordBasic.Curvalues.Documentstatistics dlg

MsgBox "Words: " & dlg.Words

End Sub

The Best Word Macros of All Time

Well, perhaps I exaggerate, but the following macros are those that I've found
most useful. | have been a busy beaver in the past two decades, using a word
processor (on average) 5 hours a day for 20 years. I've used Word since it
first became available, switching from Word Perfect (which was serviceable
but less powerful and less well-thought-out).
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We don’t need no stinkin’ f key

| had an extra computer keyboard in my study.
(When you buy a new computer, you some-
times get a keyboard even if you don’t want it.)
A lady was visiting me and asked whether she
could buy it because she needed a new one. |
asked her: “Do you use the letter fvery often?
Could you work around it?” She replied: “Is it

bad?” I told her, “The keyboard works just fine,
but it doesn't print the letter £ She considered
this for a moment and then said that yes, she
needed the £. | told her that | was just joking and
gave her the keyboard . . . but | don't think she
ever really forgave me for my funny little prank.

My favorites list is, of course, skewed toward what’s most useful for a writer
because that’s what I do. But [ suspect some of these macros are universally
worth using.

You can find other nifty macros earlier in this chapter, like DoubTeSave (see
Listing 5-2) and FirstFormat (see Listing 5-4). There are also some good
macros sprinkled here and there throughout this book. If you have any per-
sonal favorite macros — for any Office 2003 application — I'd be interested
in seeing them. Please send them to richardm52@hotmail.com.

Redefining ordinary keys

You can easily assign key combinations such as Alt+H to macros. See the ear-
lier section, “Using Macros for Specialized Formatting.” However, you aren’t
allowed to redefine ordinary character keys, such as r or z. And you some-
times want to do just that.

Frivolity aside, you really do need all the normal keyboard characters except
for three: the accent grave (*; the one just under the Esc key) and [ ], the two
square brackets. Only a few nationalities need an accent grave diacritical
mark, and unless you're a typist for a mathematics professor, you don’t
much need brackets either. If you find you ever do need them (ahem, I just
did to write this paragraph), you can always type them into Notepad and
then copy and paste them into the Word document. A bit cumbersome, true,
but rare. And by freeing up these keys, you can assign them to macros you
use every time you use Word. They’re the best because they’re not even key
combinations — you just press a single key, and the macro executes.

The next section illustrates how to assign macros to these keys.
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Switching windows and deleting words

I often have two documents open at once — one containing notes and research,
and the other in which I'm actually writing. I like to be able to switch quickly
between them. [ assign the accent grave key to this important job.

You can always use Word’s Window menu to switch, but one of the most signif-
icant benefits of redefining keys is that you don’t have to take your hands from
the keyboard and reach for the mouse, or go through a series of shortcut key
maneuvers to access the menu system. Here’s the macro that switches to the
next open document. If you want to use it, too, just type this into the macro
editor, naming it NextWindow:

Sub NextWindow()
WordBasic.NextWindow
End Sub

If you want to ensure that the windows are always full-screen, add this line
just above the End Sub:

Application.WindowState = wdWindowStateMaximize

[ assign both bracket keys to a macro that deletes the word currently closest
to the blinking insertion cursor. | use both because I so frequently have to
quickly delete words, and using both bracket keys makes it almost impossible
to press the wrong key. Repeatedly pressing this key sucks up whole strings
of words quite rapidly, as if it were a vacuum. To me, it’s an indispensable
macro, and here it is:

Sub killword()
WordBasic.DeleteWord

End Sub

Now I don’t need to select a word before deleting it, repeatedly press the
Backspace or Delete key, or resort to any mouse/keypress interactions. I just
press one of the bracket keys, and the word to the right of the insertion
cursor vaporizes immediately.

Not out of the woods yet. Remember that you have to reassign keys: the
accent grave key to point to the NextWindow macro, and the bracket keys to
point to the ki1Tword macro.

This next Sub does the trick. Type this (Listing 5-5) into the macro editor.
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Listing 5-5: Key Reassignment Macro

Sub Assignkey()

'219 is keycode for left bracket

'221 is keycode for right bracket

'96 is keycode for Circumflex (lowercase)

"run this macro to assign "killword" macro to the brackets
"just delete the assignment (in Tools@-->Customize@-->
Keyboard) to 'restore the bracket keys

WordBasic.ToolsCustomizeKeyboard Category:=1,
Name:="killword", KeyCode:=219, Add:=

WordBasic.ToolsCustomizeKeyboard Category:=1,
Name:="killword", KeyCode:=221, Add:=

WordBasic.ToolsCustomizeKeyboard Category:=1,
Name:="NextWindow", KeyCode:=96, Add:=

"OR TO UNDO THIS CHANGE
'"WordBasic.ToolsCustomizeKeyboard Category:=1,
Name:="killword", KeyCode:=219, Remove:=1
"WordBasic.ToolsCustomizeKeyboard Category:=1,
Name:="killword", KeyCode:=221, Remove:=1
End Sub

By going inside the engine room underneath Word and grabbing hold of the
tube that routes keystrokes, you can assign a macro to a keycode (representing
the tube through which the electricity flows when a particular key is pressed).
By using the Add: =1 command, you tell Word to flip this switch and route this
keystroke to your macro instead of simply printing the character onscreen.
This is the same process that Word itself uses when you define a custom key
combination, except here you're doing it on a low level — bypassing Word'’s
refusal to permit some redefinitions in its Customize Keyboard dialog box.

If you are one of the few who rarely use the f key (see the sidebar, “We don’t
need no stinkin’ f key”) and wish to redirect it (or any other key) to a macro,
you can find the codes by searching VBA Help for Character Set.

Assigning normal style

[ assign Alt+N (for normal) to the normal style macro so that when I copy
and paste text into my documents, [ can quickly make it conform to the cur-
rent document’s primary body text format. Here’s the macro:

Sub ATEN()
Selection.Style = ActiveDocument.Styles("Normal")

End Sub
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Assigning an anti-table macro

The following macro is quite useful. It eliminates table formatting and leaves
the text behind.

Text pasted into a document from a Web page is formatted often by Word as
a table. You usually don’t want this. For example, when I make a motel reser-
vation at one of the better establishments (or any kind of establishment, for
that matter, although I no longer stay in actual dives), I select the whole Web
page containing all the reservation information. Then I copy and paste that
into a Word document.

Alas, all kinds of havoc results: The various sections of the Web page are
now separated by dozens of blank lines, boxes, frames, and what-not. [ don’t
need all that mess, especially because what should print out as a one-page
document requires five pieces of paper to accommodate all the pseudo tables.
Just put your insertion cursor anywhere inside this fake tabled data and
then run this macro. [ keep it on my custom toolbar, triggered by a button I
named Untable.

Sometimes these table formats are nested, so you might have to run the
macro more than once to get rid of all the lines and stuff:

Sub Untable()
On Error Resume Next

Selection.Rows.ConvertToText
Separator:=wdSeparateByCommas, NestedTables:= _
True
Selection.MoveDown Unit:=wdlLine, Count:=1

If Err Then MsgBox "No table was detected, dude."

End Sub

Toggling revisions

When working with another person on a document (an editor in my case),
it’s useful to turn on the revision marks feature so that the other person
can quickly see the changes you made. This feature is particularly difficult
to locate and select via the Word menu system or the Reviewing toolbar.
(Microsoft calls this Track Changes instead of revision marks, so no wonder
I have problems locating it, even when searching Help. You’d think it would
be on the View, Edit, or Format menus, but it’s on the Tools menu, instead.)
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[ add a macro — RevTog — to my custom toolbar that toggles revision marks
on and off. Sometimes you make changes to a document that you don’t want
highlighted for others to see (either because they’re cumbersome and unneces-
sary, or because they’re deeply embarrassing). I find I need to toggle revision
marks off and on rather frequently. Here’s the macro:

Sub RevTog()

Dim DR As Object: Set DR = WordBasic.DialogRecord.ToolsRevisions(False)
WordBasic.Curvalues.ToolsRevisions DR

If DR.MarkRevisions = 0 Then
WordBasic.PrintStatusBar "Revision Marks ON."
WordBasic.ToolsRevisions MarkRevisions:=1

Else

WordBasic.PrintStatusBar "Revision Marks OFF."
WordBasic.ToolsRevisions MarkRevisions:=0

End If

End Sub

Add a macro to a toolbar by right-clicking the toolbar, choosing Customize
from the context menu, and then clicking Macros in the left list box. From

the right list box in this dialog box, drag the name of the macro to the toolbar
and drop it. Right-click the new button to rename the button. By default, the
entire path of the macro is included in the button’s name, such as Normal .
NewMacros.Untable. You don’t want all that cluttering up your toolbars.

Accepting all changes

When you’re looking at a document all messed up with revision marks — or
should I say, Track Changes marks — you sometimes want to just get rid of
them all and see the final, clean version. You can use Accept All Changes to
do this, and it’s another button on my custom toolbar:

Sub AcceptAll()
WordBasic.AcceptAllChangesInDoc
End Sub

Using WordCount

[ often need to know how many words I've written in a document. I don’t want
the entire document properties stats — paragraphs, characters, author’s
name, fishing tips, and everything else — just the word count. This macro
does it:

Sub wordcount()

"update the statistics
WordBasic.FileSummaryInfo Update:=1
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Dim dlg As Object: Set dlg =
WordBasic.DialogRecord.Documentstatistics(False)
WordBasic.Curvalues.Documentstatistics dlg

WordBasic.PrintStatusBar " "+
dlg.Words + " words in this document"
End Sub
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Chapter 1: The Excel Object Model

In This Chapter

v+ Understanding the Excel object hierarchy

1+ Using worksheets and workbooks

v Working with cells

v+ Understanding Excel collection objects
1 Accessing the Application object

1+~ Using ranges

v+ Naming ranges

v Creating charts

Fis chapter begins the focus on Excel. You see how objects are organ-
ized in Excel and then work with the various members of important
objects such as worksheets, workbooks, and cells. You also see how to
manipulate ranges and charts.

Understanding the Excel Object Model

Excel’s uses in an Office context include financial planning, modeling, and
building charts. In some cases, it’s even used as a kind of database (a reposi-
tory of ordered information). But the trick that spreadsheets are famous for
is recalculation: A cell can contain text, a numeric value, or a formula (such
as the sum of all the values in a column). For example, if salesman Bob
Racrette reports $2,000 worth of extra orders this month, you can change
the value in the appropriate worksheet cell; if this cell is one of those gov-
erned by a SUM formula, the cell containing the total immediately changes
to reflect Bob’s success. Likewise, any Excel chart that gets its data from
these changed cells will also be updated.

Like the Word object model (and most other application’s models), Excel
begins with the Application object at the top. (Read more about the Word
object model in Book IIl, Chapter 1.) Within the App1ication object resides
the Workbook object and a Workbooks collection.
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The Application and Workbook objects have many members in common,
but when you work with the AppTication object’s members, you're usually
accessing the current workbook (the one that has the focus). A workbook’s
members are specific to that particular workbook.

Within the workbook is the Worksheet object, referring to a particular work-
sheet. Note that the Workbook object has a Sheets collection containing a
set of Worksheet or Chart objects.

Going further down is the Range object, and you’ll use this one frequently.
To read or write to any cells, rows, columns, or other elements within Excel,
you usually first create a Range object. Compare this with Word, in which
you work primarily with Range or Selection objects to manipulate text. In
Excel, you define a Range object so that you can read, manage, or edit its
contents.

The Excel Range object specifies a section of a worksheet, or it can also
specify several sections at once. A range can be a single cell, a block of cells
within a single worksheet, or even a set of blocks of cells in two or more
worksheets.

There is an Excel Selection object, but I caution you against using it.
Generally, use Range instead because the selection that the user creates will
be lost if you activate a Selection in code: It is replaced by the selection
that the code made. Also, the Range object is more flexible: You can have
multiple ranges at a given time but only one selection. To see how to convert
a SelectiontoaRange, see the upcoming section, “Transforming a selec-
tion into a range.”

How to Use Excel UBA

To experiment with the Excel VBA example code, follow these steps:

1. Start Excel.
2. Press Alt+F11.

You see the Visual Basic editor, which is probably empty — no place to
write code yet.

3. Choose View=>Project Explorer.

You see a list of the worksheets and workbooks that are currently avail-
able in this instance of Excel.

4. Double-click the default workbook’s name, which is ThisWorkbook
(unless you’ve changed it), as shown in Figure 1-1.



Figure 1-1:
Double-click
a workbook
name to
make your
VBA macros
available to
the entire
workbook.

Adding a Workbook 2 73

Project - ¥BAProject

7
EETE 4
=-B% vBAProject (Book1)

=] 3 Microsoft Excel Objects
#f] shesti (Sheet1)
B shestz (Sheet?)

A code window opens where in which you can type in procedures, like
the Sub in the next section.

Adding a Workbook

When you start Excel, the Application object is automatically created. You
don’t need to use the Application object in your VBA code because it’s
understood. For example, you don’t need to prepend Excel.Application
to code that closes the current workbook’s Workbooks.Close. You can just
directly reference the Workbooks collection or any individual workbook or
other element without using the Application object.

The following code adds a new worksheet and then displays the names of all
the worksheets in the current (with focus) workbook:

Sub ShowSheets()

Set s = Sheets.Add(Type:=x1Worksheet)
For i = 1 To Sheets.Count

s.Cells(1l, i).Value = Sheets(i).Name
Next i

End Sub

With your blinking insertion cursor somewhere in this code, press F5 to exe-
cute the code. Press Alt+11 to return to the Excel workbook view. You'll see a
new worksheet added to your workbook, with the names of all the worksheets
listed in the first row. Note that the newly added sheet is not in the right order,
though. Suppose you want Sheet4 to appear after Sheet3. As with most any-
thing in Excel, you can automate the task programmatically. In this case, add
the following bold line to this procedure that moves the new worksheet:

Book IV
Chapter 1
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Sub ShowSheets()
Set s = Sheets.Add(Type:=x1Worksheet)
Worksheets(1l).Move After:=Worksheets("Sheet3")

For i = 1 To Sheets.Count
s.Cells(1l, i).Value = Sheets(i).Name
Next i

End Sub

Notice that the worksheets here are referenced in two ways. The first refer-
ence specifies a worksheet by its index number in the Worksheets collection:
Worksheets(1).Move.

The alternative way to reference a worksheet is illustrated by the second
reference. In this case, you specify a worksheet by using its name:
After:=Worksheets("Sheet3"). Note that this After:= specification
works only if there is a worksheet named Sheet3.

Now when you execute the code, the sheets are in the order that you want
them. As usual, you'll find a variety of approaches that you can take. For exam-
ple, a copy method works the same way but adds a new sheet to the existing
collection instead of merely moving one. If you prefer, you can replace the
after argument with a before argument. Or, you can leave these out, and a
new workbook is created with the moved or copied sheet. Finally, if you don’t
know how many sheets might be in the workbook — and you want the new
sheet appended to the end of the collection — use After:=(Sheets.Count).

Referring to Me

In Visual Basic .NET, you can specify an object itself with the Me command.
For example, Me .BackColor = Color.AliceBlue turns the form (in which
this code resides) a cunning, light blue. The object in which the code resides
isn’t necessarily the active object (the cell with the focus, with the black
insertion frame, for example). Perhaps you have a macro that needs to refer-
ence an object in the same workbook where the macro resides. For example,
you might want to display a DialogSheet from the workbook. You cannot
always be sure that this workbook has the focus. The workbook might not
be the currently active workbook. To ensure that a macro references its own
workbook, use the ThisWorkbook property, like this:

ThisWorkbook.DialogSheets(2).Show

There is no equivalent ThisWorkSheet property.
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Accessing the active cell

The smallest unit that you can manipulate is the cell. You can read or edit
the currently active cell by using several equivalent code phrases (each
of the following points to the same cell):

ActiveCell

ActiveWindow.ActiveCell
Application.ActiveCell
Application.ActiveWindow.ActiveCell

As usual, the AppTication object is optional in code unless you want to
start a whole new instance of Excel running. Here’s how to read the contents
of the currently active (with focus) cell in Sheet2:

Sub accessCell()

Worksheets("Sheet2").Activate
MsgBox ActiveCell.Value

End Sub

Notice that something other than a worksheet might currently have the
focus, so you use the activate method to set the focus on a particular
worksheet — in this case, the one named Sheet2.

Creating a New Instance of Excel

The following code uses the App1ication object because no current
Application object exists; for example, you're not running Excel but are
instead executing this code from within Word. Or perhaps you want a second
instance of Excel to run concurrently with the instance in which you execute
this code. In other words, if you run the following VBA from within Excel
itself, you spawn a new, second Excel instance:

Book IV
Sub BringTolife() Chapter 1

On Error Resume Next
Dim e As Excel.Application

Set e = New Excel.Application
e.Visible = True

I13poIN
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e.Workbooks.Add
e.Worksheets("Sheetl").Cells(4, 4).Value = 256

If Err Then MsgBox Error$
End Sub
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Execute this, and you see a new Excel instance with a worksheet containing
256 in cell 4,4.

Note that when you instantiate Excel in this fashion (programmatically), no
workbook or worksheets are automatically added to the instance. That is,
you have an empty Excel instance, and thus your programming must explic-
itly create a workbook by using the Add method of the Application object’s
Workbooks collection. Also notice that you must specify whether a new
instance of Excel created this way is visible. Similarly, if you programmati-
cally create a new Workbook, it remains hidden until you set its Visible
property to True.

As you might have noticed, when starting Excel yourself nonprogrammatically
(from the Start menu for example), Excel does provide you with a default
workbook, and it contains three worksheets. You can programmatically rede-
fine the number of default worksheets by using the SheetsInNewWorkbook
property of the Application object.

Using the Application Object

In Word is an Options object that you can use to manipulate various options
(Tools=>Options). In Excel, however, you use the Application object to
adjust options, like this:

Application.Calculation = x1CalculationManual
Application.CalculateBeforeSave = True

Recall that you can often leave out the AppTication object name when
referencing other objects such as ActiveCel1. However, when accessing
application properties, you must use Application. For example, this code
will fail to adjust the Calculation option:

Calculation = xI1CalculationManual

Other options that are adjusted via the Application object can be found in
this list of the AppTication object’s 174 properties. Some of these are other
objects (such as ActiveWindow), and others are options (CanPTaySound):

ActiveCell, ActiveChart, ActivePrinter, ActiveSheet, ActiveWindow,
ActiveWorkbook, AddIns, AlertBeforeOverwriting, AltStartupPath,
AnswerWizard, Application, ArbitraryXMLSupportAvailable,
AskToUpdatelinks, Assistant, AutoCorrect,
AutoFormatAsYouTypeReplaceHyperlinks, AutomationSecurity,
AutoPercentEntry, AutoRecover,Build, CalculateBeforeSave,
Calculation,CalculationInterruptKey,CalculationState,
CalculationVersion, Caller, CanPTaySounds, CanRecordSounds,
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Caption, Cell1DragAndDrop, Cells, Charts, ClipboardFormats, Columns,
COMAddIns, CommandBars, CommandUnderlines, ConstrainNumeric
ControlCharacters, CopyObjectsWithCells, Creator, Cursor,
CursorMovement, CustomListCount, CutCopyMode, DataEntryMode
DDEAppReturnCode, DecimalSeparator, DefaultFilePath,
DefaultSaveFormat, DefaultSheetDirection, DefaultWebOptions,
Dialogs,DisplayAlerts,DisplayClipboardWindow,
DisplayCommentIndicator,DisplayDocumentActionTaskPane,
DisplayExcel4Menus, DisplayFormulaBar,DisplayFullScreen,
DisplayFunctionToolTips, DisplayInsertOptions,
DisplayNotelIndicator,DisplayPasteOptions,DisplayRecentFiles,
DisplayScrollBars,DisplayStatusBar, EditDirectlyInCell,
EnableAnimations, EnableAutoComplete, EnableCancelKey,
EnableEvents, EnableSound, ErrorCheckingOptions,
Excel4IntIMacroSheets, Excel4MacroSheets, ExtendList,
Featurelnstall, FileConverters, FileDialog, FileFind, FileSearch,
FindFormat, FixedDecimal, FixedDecimalPlaces,
GenerateGetPivotData, Height, Hinstance, Hwnd,
IgnoreRemoteRequests, Interactive, International, Iteration,
LanguageSettings, Left, LibraryPath, MailSession, MailSystem,
MapPaperSize,MathCoprocessorAvailable, MaxChange, MaxIterations,
MemoryFree, MouseAvailable, MoveAfterReturn,
MoveAfterReturnDirection, Name, Names, NetworkTemplatesPath,
NewWorkbook, ODBCErrors, ODBCTimeout, OLEDBErrors, OnWindow
OperatingSystem, OrganizationName, Parent, Path, PathSeparator,
PivotTableSelection, PreviousSelections, ProductCode,
PromptForSummaryInfo, Range, Ready, RecentFiles, RecordRelative,
ReferenceStyle, RegisteredFunctions, ReplaceFormat, Rol1Zoom,
Rows, RTD, ScreenUpdating, Selection, Sheets, SheetsInNewWorkbook,
ShowChartTipNames, ShowChartTipValues, ShowStartupDialog,
ShowToolTips, ShowWindowsInTaskbar, SmartTagRecognizers, Speech,
Spelling0Options, StandardFont, StandardFontSize, StartupPath,
StatusBar, TemplatesPath, ThisCell, ThisWorkbook,
ThousandsSeparator, Top, TransitionMenuKey,
TransitionMenuKeyAction, TransitionNavigKeys, UsableHeight, Book IV
UsableWidth, UsedObjects, UserControl, UserLibraryPath, UserName, Chapter 1
UseSystemSeparators, Value, VBE, Version, Visible, Watches, Width,
Windows, WindowsForPens, WindowState, Workbooks,
WorksheetFunction, Worksheets.

Working with Ranges

You can specify ranges either absolutely (specifying a particular cell or group
of cells) or relative to the active cell (the one currently with the focus). Here’s
an absolute range, which is also being given a name:

[opoIy
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Sub SetRange()
Names.Add Name:="Vac", RefersTo:="=sheetl!$A$3"
Range("Vac").Value = "This"

End Sub

When you put a dollar sign ($) in front of the row and column references, the
range becomes absolute: No matter what cell is currently active (selected),
this code puts the word This in cell A3. Also note that an exclamation point
(1) is used to separate the name of the sheet from the cell reference.

However, if you remove the dollar signs, the range specification becomes rel-
ative to the active cell. If the active cell is Al, only then will $A$3 mean cell
A3 in the above code. If instead the active cell is A2, like this, in what cell do
you suppose the message will appear?

Here’s an example that illustrates how to specify a relative reference:
Sub SetRange()
Names.Add Name:="Vacl", RefersTo:="=Sheetl!" & "D3"
Range("Vacl").Value = "This"

End Sub

You can also mix and match columns and rows (one can be absolute, the
other relative). Here are the possible combinations:

+ $B$2: Absolute column and absolute row

4+ BS$2: Relative column and absolute row

4+ $B2: Absolute column and relative row

4 B2: Relative column and relative row

The A1 style reference

One referencing system used in Excel is the A! style, meaning that columns
are labeled A- 1V, and that the rows range from 1-65536. Mercifully, Excel
doesn’t start with row 0 (zero).

You can specify ranges and blocks of cells in the following fashion:

4+ The cell at column B and row 12 is B12.
4+ The range of cells from column A and rows 11-30 is A11:A30.
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4+ The range of cells from row 16 and columns C-G is C16:G16.
4+ All cells in row 6 is 6:6.

4+ All cells in rows 2-4 is 2:4.

4 All cells in column B is B:B.

4 All cells in columns A-B is A:B.

4 The range of cells in columns A-C and rows 9-20 is A9:C20.

A 3-D reference specifies cells across more than one sheet. For example, to
get a total of all the values stored in cell R23 on sheets 4, 5, 6, and 7, you
write it this way:

=SUM(Sheet4:Sheet7!R23)

The R1C1 style reference

The RICI style reference is an optional way of specifying cells that avoids
using letters to represent columns: R1C1 uses numbers instead. This can be
useful if you need to compute mathematically some row or column positions.
(You can’t do math on the letters A, B, and so on; you must use numbers.)
In this system, R stands for row, and C stands for (you guessed it) column. It
works like this:

4 Ris an absolute reference to the current row.

4+ R[-3]C is arelative reference to the cell three rows up in the same column.

4+ R[-1] is a relative reference to the entire row immediately above the
active cell.

4+ R[4]C[2] is a relative reference to the cell four rows down and two
columns to the right.

4+ R2C5 is an absolute reference to the cell in the second row in the fifth
column.

Note that Excel itself often uses this style of reference when you record a
macro. For example, if you click a cell and type in a value while recording,
you get this mix of both the Al style and the R1C1 style:

Range("F9").Select
ActiveCell.FormulaR1Cl = "22"

Using the Offset method

You can also reference a range relative to the current cell by using the
0ffset method. In this example, the word Norma appears six cells over and
four down from the current cell:

Book IV
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ActiveCell.0ffset(4, 6).Value = "Norma"
ActiveCell.0ffset(4, 6).Font.Underline = x1Single

This notation might be a bit easier to visualize than the R1C1 style of relative
addressing.

Using the Names collection

The Names collection of a workbook can contain as many named ranges as
you wish, and you can thereafter refer to a named range by its name rather
than its cell addresses, as you can see in the preceding example.

You can also assign temporary names, but if they’re not added to the Names
collection, they won’t be saved when you shut down Excel:

Dim r As Range

Set r = Range("B3")

r.Name = "Total"
Range("Total").Value = 124

Accessing special ranges

In addition to the ActiveCell and Range objects, you can use other Excel
VBA members to specify useful ranges in your code. For example, you might
want to programmatically add some more rows or columns to a sheet but
need to know where the outermost used cell is.

The SpecialCells method

The SpecialCells method of the Range object can come in handy. Suppose
that you want to go to the end of used cells in a sheet (the cell in the farthest
column, and down in the farthest-used row). This code does that:

Worksheets("Sheet2").Activate
ActiveSheet.Cells.SpecialCells(x1CellTypelLastCell).Activate
ActiveCell.Value = "Boo"

The format is

.SpecialCells(Type, Value)
The Type can be any of the following built-in constants:

4+ x1CellTypeAllFormatConditions
4+ x1CellTypeAllValidation

4+ x1CellTypeBlanks

4+ x1Cell1TypeComments

4+ x1CellTypeConstants
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x1CellTypeFormulas
x1CellTypelLastCell
x1Cel1TypeSameFormatConditions

x1Cell1TypeSameValidation

AR IR IR IR

x1Cell1TypeVisible

Using SpecialCelTls is a way of filtering. It allows you to get only particular
kinds of cells from a range. The Value argument is optional. You can use it to
specify that you want only particular types of cells. Value is used only with two
of the preceding constants: x1Cel1TypeConstants or x1Cel1TypeFormulas.
You can use Value types either alone (such as x1TextValues by itself to get
only text cells) or combine several Value constants to broaden the results.
These are the Value constants that you can use: x1Errors, x1Logical,
xINumbers, or x1TextValues.

The UsedRange property

The UsedRange property of the Worksheet object returns the smallest
rectangular region that can be drawn that includes all the used cells in the
worksheet. For example, this could be useful if you want to color these cells
to highlight them. This code applies a light gray pattern to the range of used
cells in a sheet:

Worksheets("Sheetl").Activate
ActiveSheet.UsedRange.Interior.Pattern = xIPatternGrayl6

To find a list of the built-in constants, such as x1PatternCrissCross,
x1Logical, and x1BorderWeight, search the VB editor’s Help (while in the
editor, press F1) and search for Microsoft Excel Constants.

The CurrentRegion property

The CurrentRegion property gives you the current region (all the cells that
are in use: bounded by the white, unused cells). It works like a fill tool in a
graphics program, searching from the current cell in all four directions until
it finds blank rows and columns. Then it defines the region.

The blocks of data in Figure 1-2 are (as is often the case) framed by empty
rows and columns. To specify a range for one of these blocks of data, you
can use the CurrentRegion property, like this:

Sub dorange()

Worksheets("Sheetl").Activate
ActiveCell.CurrentRegion.Select

End Sub

Book IV
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If you want to access that range by using an object variable, this code does it:

Sub dorange()

Dim r As Range

Set r = ActiveCell.CurrentRegion
r.Interior.Pattern = x1PatternLightDown

End Sub
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Transforming a selection into a range

Recall that generally you work with ranges in your programming. But now
and then, you need to interact with users, who make selections. The follow-
ing code shows you how to query the user about the current selection and
then translate the Selection object into a Range object before you change
its format in the code. This preserves the selection, which would be lost if
you accessed it directly, programmatically:

PubTic Sub SelectionToRange()

Dim r As Range

Set r = ActiveWindow.RangeSelection

s = MsgBox("Do you want this range highlighted?", vbYesNo)
If s = vbYes Then

r.Interior.Pattern = x1PatternLightVertical

End If

End Sub
Here’s code that returns the address of the current selection:

MsgBox ActiveWindow.RangeSelection.Address

Adding a formula

The following transforms the current selection into a range to specify that a
SUM formula should be added to cell Al, displaying the total of the values in
the user’s selection:

PubTlic Sub AddFormulaRange()

ActiveSheet.Cells(1l, 1).Formula = "=Sum(" &
ActiveWindow.RangeSelection.Address & ")

End Sub

Using the WorksheetFunction

Alternatively, you might need only to get the result programmatically. That
is, you don’t want it displayed on the sheet to the user. To do that, you can
use the WorksheetFunction method, like this:

Public Sub ShowSum()

Set r = Worksheets("Sheetl").Range("G4:G6")
n = WorksheetFunction.Sum(r)

MsgBox n

End Sub

Book IV
Chapter 1

I13poIN
10alqQ [29x3 3y}



28 4 Creating a Chart

Creating a Chart

Figure 1-4:
Adding
charts to
an Excel
workbook
is easy.

It’s easy to create charts of data in Excel. Type these numbers into cells
G4-G10 in Sheet 1: 45, 66, 33, 33, 44, 55, 66. Then type in and execute this
simple macro:

Public Sub ShowChart()

Dim ch As New Excel.Chart

Set ch = Charts.Add

ch.SetSourceData Source:=Worksheets("Sheetl").Range("g4:g10")
ch.ChartType = x13DArea

ch.Activate

End Sub

You see the chart displayed in Figure 1-4.

\\J

Dozens of varieties of charts are available in Excel. Search the VB editor Help
(not Excel Help) for Microsoft Excel Constants, locate XLChartType, and click
it to open the list, as shown in Figure 1-5.
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Chapter 2: Handling Excel Events

In This Chapter

v+ Programming events in workbooks and worksheets
1 Managing chart events

v Dealing with Application events

v+ Adding a class module

Euents occur when programmers write code to respond to things that
happen to an application. For example, when you write an application,
you cannot know when (or even whether) the user will ever click one of
your buttons. In an object’s event procedures, you can write code to specify
what happens when an event occurs: like when the program starts, when
the user clicks a particular button, after a PivotTab]le report is updated,
when the selection changes, and so on. All these (and many more actions)
are events.

Generally speaking, events trigger (or fire) because the user does something
to interact with your program. But events can also trigger when other objects
interact with them. For example, the SheetChange event will fire whether
the user changes a cell in that worksheet or whether some code in a macro
(for instance) makes the change.

By default, the Application object’s EnableEvents propertyis True,
allowing events to trigger; however, if you want to prevent events from firing
for some reason, you can turn it off like this:

Application.EnableEvents = False

In this chapter, you explore how to provide source code that executes when
events trigger in workbooks, worksheets, charts, or other objects. Events
are a way that a programmer responds to user interaction with their pro-
grams, although sometimes other code also interacts and triggers events.
(Events are sometimes said to fire when triggered, just like a gun.)
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Programming an Excel Event

To see a list of the events available in the Workbook object, follow these
steps:

\\J

Figure 2-1:
Find the
events

for the
Workbook
object here.

1.

Press Alt+F11 in Excel.

The Visual Basic editor appears.

Choose Viewr>Project Explorer in the VB editor.

Project Explorer appears.

Double-click This Workbook in Project Explorer.
The editor window for this workbook is displayed.

From the drop-down list in the upper left of the workbook’s editor,
choose Workbook.

The Workbook_0Open event (a Sub procedure, like a macro) appears with
its basic structure typed in for you.

VBA chooses what it thinks is the most frequently used event to type in
by default. For a Button object, for instance, it’s obviously the C11ick
event that you most likely want to use. If you wish, you can simply erase
the default event procedure that VBA types in for you. Or you can just
leave it empty, with no code in it. Nothing will happen when an empty
event fires because there’s no source code to execute.

Open the drop-down list in the upper right.

You see a list of all the events that can be programmed for a workbook,
as shown in Figure 2-1.

&) Book! - ThisWorkbook (Code) i |S|=]
[workboak =] [open | |
Private 3ub Workbook Open() ;:::::;"“E!CDGH hady |
Betoramlmpart
End Sub Deactivate
MewSheel
Fivod Table CpenCornection
SheelActivate
ShestBeforeDoubleClick
SheetBeforeRightCick
SheelCalculate E=]
=[= 4 l ._|’ A
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Now try writing code for a Worksheet object event.

1. In Project Explorer, double-click Sheetl under the current VBA project.
Sheet1’s code editor opens.

2. In the top-left list of the code window, choose Worksheet.

hd

In the top-right list, choose the BeforeDoubleC11ick event.

4. Type in this code to display a running total of the number of times
that the sheet has been double-clicked:

Private Sub Worksheet_BeforeDoubleClick(ByVal Target As
Range, Cancel As Boolean)

Static ¢ As Integer
c=c¢+1

Application.StatusBar = Caption & "Sheet 1 has been
double-clicked " & c & " times."

End Sub

5. Try double-clicking Sheet1 to see the message in the lower-left corner
of the Excel window.

Notice that a report appears in the status bar each time you double-click.

Also notice how event programming differs from ordinary programming:
Ordinary procedures are executed when the program itself decides that they
should be triggered. However, events execute when an outside agent (another
program, an object, or the user) decides to trigger them. Think of it this way:
An ordinary procedure in your day is when you, yourself, decide to make a
sandwich. An event is when someone else asks you to make one.

\\J

Events in the Worksheet Object

As you can read in the preceding section, you can access the list of Workbook
events by opening a workbook programming editor. Likewise, you can get to
the events of a worksheet by opening its editor. To write code that triggers
when a selection in a worksheet changes, for example, follow these steps:
1. Choose Viewr>Project Explorer in the VBA editor.
Project Explorer appears.
2. Double-click Sheetl in Project Explorer.

The editor window for the worksheet is displayed.

Book IV
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3. From the drop-down list in the upper left of the worksheet’s editor,
choose Worksheet.

The Worksheet_SelectionChange event appears with its basic struc-
ture typed in for you.

4. Open the drop-down list in the upper right.
You see a list of all the events that can be programmed for a worksheet.

To write a Worksheet object event, just type this into the SelectionChange
event:

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
MsgBox Target.Address
End Sub

Now each time you click a different cell in the worksheet, a message box
displays its address.

Notice that some events include a parameter, such as Target here. You
sometimes want to use this information. For example, if you plan to take
some action on the newly selected range, you need that Target argument.

Writing Chart Events

To write event procedures for a chart, you must first add a chart to your
workbook. Select some cells with some data in them: These cells provide the
basis for the chart. Then press F11 to add a new chart to your workbook.

Now, go to the VBA editor and choose View=>Project Explorer. Double-click
Chartl1 in Project Explorer to open its code editor window. Now you can
open the drop-down list in the upper right to see (or choose) the various
events available to the Chart object.

Writing Application Events

Application events are used for more generic behaviors than worksheet or
workbook events.
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Here are the events available to the App1ication object: NewWorkbook,
SheetActivate, SheetBeforeDoubleClick, SheetBeforeRightClick,
SheetCalculate, SheetChange, SheetPivotTableUpdate,
SheetDeactivate, SheetSelectionChange, WindowActivate,
WindowDeactivate, WindowResize, WorkbookActivate,
WorkbookAddinInstall, WorkbookAddinUninstall,
WorkbookBeforeClose, WorkbookBeforePrint, WorkbookBeforeSave,
WorkbookDeactivate, WorkbookNewSheet, WorkbookOpen,
WorkbookPivotTableCloseConnection,
WorkbookPivotTableOpenConnection.

SheetBeforeDoubleC11ick and SheetBeforeRightClick events can be
useful if you want to respond via your code differently than the default
responses built into Excel when these actions take place.

Defining an Application event requires some extra steps. Because there

is no code window for the Application object, you have to add a class
module to the VBA editor, defining a global application variable by using the
WithEvents command. Suppose that you want to respond whenever the
user adds a new worksheet to a workbook, but instead of using the
WorkBook_NewSheet event, you decide to use the Application object’s
WorkbookNewSheet event. To respond in this way when the user chooses
Insert>Worksheet, follow these steps:

1. In the VBA editor’s Project Explorer, right-click the project’s name.
It’s the one in boldface, not PERSONAL.XLS.
2. Choose Insert>Class Module from the context menu that appears.

A new class module appears.

3. In the General Declarations section of the class module (in other
words, not inside any procedure), type this (as shown in Figure 2-2):

Public WithEvents objApp As Application

As soon as you create this object variable, the list boxes at the top now
contain additional information.

. Open the upper-left, drop-down list in the same code window
4. O h left, drop-d list in th de wind
(the class module window).

You see your new 0b jApp listed there.
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5. Click it.

6. Open the upper-right, drop-down list.

You see all the AppT1ication objects available to you, as shown in

Figure 2-3.
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Type this into the NewWorkbook event:
Private Sub objApp_NewWorkbook(ByVal Wb As Workbook)

MsgBox ("A new workbook has been created.")

End Sub

You’re not done yet, though. You've still got to connect your declared
object variable with the application in actual code. (The class module
doesn’t automatically run itself.)

Isn’t object-oriented programming (OOP) fun when it forces you into
these meaningless clerical contortions? You now have to put some acti-
vation code into one of the events that automatically triggers when Excel
opens.

In Project Explorer, double-click ThisWorkbook in the Project
Explorer, and then type this into its General Declarations section:

Dim X As New Classl

You've now created a reference (the variable X) to the class module,
which you can use to access any of the members of this class (in other
words, the procedures in this module, to avoid OOP-speak).

Type this into this workbook’s Workbook_Open event:
Private Sub Workbook Open()

Set X.objApp = Application
MsgBox "Application Object Active."

End Sub
Save this project as TestAppObj.x1s and then close Excel.

Now you can try out this twisted sister. Run Excel and open
TestAppObj.x1s.

Because you inserted a macro that runs automatically (as opposed to
writing new macros and testing them), a security warning message might
appear (depending on your Excel macro security settings). If this hap-
pens, choose Tools=>Options, click the Security tab, and then click the
Macro Security button. Change the setting to Medium so you can test
your code. If you wish, restore your setting to High after testing.

Your message box appears, telling you that the AppTication object has
been activated. From here on, any application events that you've coded
will execute.
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12. Now test the application event by choosing Filer>New.
A task pane appears.
13. In the task pane, click Blank Workbook.

A message box displays, informing you that a new workbook has been
created.



Chapter 3: Advanced Worksheet
Editing

In This Chapter

v Importing data

v+ Importing XML

1 Creating datasets programmatically
v Understanding the Shape object

1+ Augmenting Find and Replace

A Ithough this mini-book is about Excel, it’s important to realize that of
all the Office 2003 applications, Access is closest to Excel in many
ways — not least in that both are frequently used to store tabular data. In
this chapter, you go deeper into Excel programming, importing both tradi-
tional data structures, and XML-based data. Then you see how to build
datasets, work with the Shape object, and improve on the built-in Find and
Replace utility.

Importing Data into Excel

One easy way to programmatically import data into Excel is to first start
recording a macro and then use the Data=>Import External Data=>Import
Data feature. Then you can modify the code created by the macro recorder
to import other data from other source. Here’s the raw, unmodified code
that you get when you record the importation of an Access database. In this
case, [ imported the Products table from the Northwind sample database:

Sub GetData()
' Macro recorded 4/9/2004 by Richard

With ActiveSheet.QueryTables.Add(Connection:=Array( _

"OLEDB;Provider=Microsoft.Jet.OLEDB.4.0;Password=""
"":User ID=Admin;Data
Source=C:\Northwind.mdb;Mode=Share Deny
Write;Extended Propertie" _

"'s:" """.Jet OLEDB:System database="""";Jet
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OLEDB:Registry Path="""";Jet OLEDB:Database
Password="""";Jet OLEDB:Engine Type=5;Jdet
OLEDB:Da" _

"'tgbase Locking Mode=0;Jet OLEDB:Global Partial Bulk
Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet
OLEDB:New Database Password=""" _

""".Jet OLEDB:Create System Database=False;Jet
OLEDB:Encrypt Database=False;Jet OLEDB:Don't Copy
Locale on Compact=False;Jet OLEDB" _

, ":Compact Without Replica Repair=False;det
OLEDB:SFP=False"), Destination:= _

Range("A1"))

.CommandType = x1CmdTable

.CommandText Array("Products")

.Name = "Northwind Products"

.FieldNames = True

.RowNumbers = False

.Fi11AdjacentFormulas = False

.PreserveFormatting = True

.RefreshOnFileOpen = False

.BackgroundQuery = True

.RefreshStyle = xlInsertDeleteCells

.SavePassword = False

.SaveData = True

.AdjustColumnWidth = True

.RefreshPeriod = 0

.PreserveColumnInfo = True

.SourceConnectionFile = _

"C:\Documents and Settings\Richard Mansfield\My

Documents\My Data Sources\Northwind Products.odc"

.SourceDataFile = "C:\Northwind.mdb"

.Refresh BackgroundQuery:=False

End With
End Sub

In this recording, I imported a connection file (an ODC file) from the Northwind
sample database. In the next section, I modify this recorded code to allow
the user to both choose the data source and choose a table from a full MDB
database file.

The Northwind sample database is supplied with Office 2003 to allow you to
experiment using a realistic MDB (Jet/Access-style) database. Northwind.
mdb should be found on your hard drive in C: \Program files\Microsoft
0ffice\0fficell\Samples. However, you might not have it installed or
know where to look for it. Choose Help=>Sample Databases in Access, and
then select Northwind Sample Database. If it’s not there, go to the Windows
Control Panel, choose Add/Remove Programs, find and click Microsoft
Office, click the Change button, and follow the instructions to install the
Northwind sample database.
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Importing an Access Database

The following macro asks the user to choose an Access database (MDB), dis-
plays a dialog box asking the user which of that database’s tables to import,
and then displays the results in an Excel worksheet.

Run Excel and press Alt+F11 to open the Visual Basic editor. Choose View=>
Project Explorer and then double-click the ThisWorkbook entry in Project

Explorer to open its programming window.

Type the macro in Listing 3-1 into the editor:

Listing 3-1: Import an Access Database into a Worksheet Macro
Sub importdata()

On Error Resume Next
r = Application.Dialogs(x1DialogOpen).Show
With ActiveSheet.QueryTables.Add(Connection:=Array( _

"OLEDB;Provider=Microsoft.Jet.0LEDB.4.0;Password="""";User ID=Admin;Data
Source=C:\Documents and Settings\Richard Mansfield\My Documents\" _

Eo?der Entryl.mdb;Mode=Share Deny Write;Extended Properties="""";Jet
OLEDB:System database="""";Jet OLEDB:Registry Path="""";Jet
OLEDB:" _

"Database Password="""";Jet OLEDB:Engine Type=5;Jet

OLEDB:Database Locking Mode=0;Jet OLEDB:Global Partial Bulk
Ops=2;Jet OLEDB:Glo" _

3b§} Bulk Transactions=1;Jet OLEDB:New Database Password="""";Jet
OLEDB:Create System Database=False;Jet OLEDB:Encrypt
Database=Fal" _

"se;Jet OLEDB:Don't Copy Locale on Compact=False;Jet OLEDB:Compact
Without Replica Repair=False;Jet OLEDB:SFP=False" _

), Destination:=Range("Al"))

.CommandType = x1CmdTable

.CommandText = Array("Employees") Book IV

.Name = "Order Entryl" Chapter 3

.FieldNames = True

.RowNumbers = False

.FillAdjacentFormulas = False

.PreserveFormatting = True

.RefreshOnFileOpen = False

.BackgroundQuery = True

.RefreshStyle = xlInsertDeleteCells

.SavePassword = False

.SaveData = True

.AdjustColumnWidth = True

.RefreshPeriod = 0

.PreserveColumnInfo = True

.SourceDataFile = r

.Refresh BackgroundQuery:=False

End With

Bunip3 19aysxiop
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s

Figure 3-1:
Choose the
table you
want to
import from
this dialog
box.

If Err Then MsgBox (Error)
End Sub

All the code from this book is available on the book’s companion Web site.
(Please see the Introduction for the specific URL.) You certainly don’t want
to type in lengthy code examples, so just copy and paste it from this Internet
site.

The preceding code is quite similar to the code produced by recording a
macro as when you use the Excel Data=>Import External Data=>Import Data
feature. The modifications are these:

4+ Adding a couple of error trapping lines (On Error and If Err)
4+ Adding this line to allow the user to choose which database file to
import:
r = Application.Dialogs(x1DialogOpen).Show

4+ Using the variable r to specify the SourceConnectionFile or
SourceDataFile argument

.SourceDataFile = r

To test this data-import programming, click somewhere within the code that
you just typed and press F5 to execute the code. When the Excel Open dialog
box displays, use it to locate and open the Access Northwind.mdb sample
database on your hard drive. Close the Open dialog box.

After you select the Northwind.mdb database from the Open dialog box, the
Select Table dialog box opens, asking you to choose the table you want to
see, as shown in Figure 3-1.

Select Table %]
Harme Description i
Bl jlpheb | Underlying query For Alchabstical List of Products repert.
Categary Sales for 1997 Takals product sales by cabegory based on values reburned by the Product |
@ Current Produck Lisk Fikers records n Products table; query returns only products that are not
B invoices (Criteria) Record source For Invoice report. Based on six tables, Inchudes e
) Crder Detaiks Extended Record source For several forms and reports, Uses CCur function bo compy
@ Crder Subtotalks Record source For other queries. Uses Sum and CCur Functions to compute
B orders qry Underlying query For the Orders fioem. w|
12| >
E==n

4

Double-click the table you want, and you see the data imported into Excel’s
current sheet, as shown in Figure 3-2.
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=] Booi S)
Al 8 | ¢ | o | E | E 5
_1_|ProiProductName Supplierld CategorylD QuantityPerUnit UnitPrice |
[ 2 | 1 Chai 1 1]10 boxes » 20 bags 18
3| 2 Chang 1 124-12 oz boitles 13
4 | 3 Aniseed Synp 1 2112 - 550 ml boitles 10
-2} 4 Chef Anton's Cajun Seasoning 2 248 - b oz jars el
& | B Grandma's Boysenberry Spread 3 2112-8 oz jars s}
| 7 | 7 Uncle Bob's Crganic Dried Pears 3 712-11b pkgs a0
| 8 | 8 Morthwoods Cranberry Sauce k| 2/12-12 oz jars 40|
9 | 10 lkura 4 212 - 200 ml jars |-
10| 11 Queso Cabrales a 41 kg pkg, 21
(11| 12 Quesn Manchego La Pastora ) 4110 - 500 g pkgs 38
12| 13 Konbu 4 812 kg box B
13| 14 Tofu 4 740 - 100 g pkys. 2325
14 | 15 Genen Shouyu B 224 - 280 ml hottles 165
(15| 16 Paova 7 3/32-500 g boxes 17.45
16| 18 Camarvon Tigers 7 816 kg pka. B2.5
17| 19 Teatime Chocolate Biscuits g 310 boxes x 12 pieces 9.2
18 | 20 Sir Rodney's Marmalade g 3|20 gift boxes 81
| 18| 21 Sir Rodney's Scones g 324 pkgs. x 4 pieces 10
— || 20| 22 Gustafs Knackebrid a 524 - 500 g pkgs 21
) 21| 23 Tunnbrid 9 512 - 250 g pkos. 9
Figure 3-2: 22| 25 NuNuCa Nuf-Nougat-Creme 11 3/20- 450 g glasses 14
Behold' 23| 26 Gumbar Gummibarchen 11 3100 - 250 g bags 3.3
: | 24 | 27 Schoggi Schokolade 11 31100 - 100 g pieces 439
Data 25| 30 Mord-Ost Matjeshenng 13 810 - 200 g glasses 2589
. 26 | 31 Gorgonzola Teling 14 4112-100 g pkygs 125
automati- 37 | 32 Mascarpone Fabioli 14 4124-200 g pkgs 32
caIIy 28| 33 Geitost 15 4500 g 25
289 | 34 Sasquatch Ale 16 124 -12 oz bottles 14
dumped 30| 35 Stesleye Stout 16 1|24 - 12 oz bottles 1
. 31| 36 Inlagd Sil 17 924 -250q jars 19
Into your (32| 37 Gravad lax 17 5 12- 500 g pkys =
worksheet. 1 33| 38 Cdte de Blaye 18 112- 75 cl bottles 2635 [y
M 4 ¢ niNorthwind / 1< (2]
P If you want to import data from text files with low-level programmatic con-

trol over delimiters (such as data separated by # characters or whatever),
you can use the file input/output (I/0) commands available in VBA. For
details, see Book II, Chapter 4.

Importing Data from an XML Dataset

Disconnected datasets (tables detached from their host database) represent a
valuable technology, providing a highly scalable solution when large num-
bers of users simultaneously need to access a database. They get in and out,
without needing to maintain an active connection to the database.

You can find out more about datasets in the following mini-book (Book V) on
Access, but here’s an example of how you can import an XML dataset into
Excel. You'll import fields from the same Products table of the Northwind
database (see the preceding example in this chapter). Here, however, you
don’t connect to the database directly; instead, you get your data from a
dataset.

Book IV
Chapter 3
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To create an XML dataset by hand, follow these steps:

1.

=W

\\J

10.
11.

12.
13.

14.

S =

Double-click the Northwind.mdb file.
The database is loaded into Access.

In Access, double-click the Products table in the main database
window.

The table opens.
Choose File->Export.

In the Save as Type drop-down list of the Export dialog box,
choose XML.

Click the Export All button.

Clear the Schema of the Data check box.

You want to let Excel format this data, not Access.
Click OK.

The dialog box closes, and your XML dataset is saved.
Close Access.

Run Excel.

Choose File~>Open in Excel.

In the Open dialog box, locate on your hard drive the Products.xml
dataset that you just created. Double-click it to open it.

The Open XML dialog box is displayed.
Choose As an XML List.
Click OK.

You're notified that no schema exists for this data (no XSD or other asso-
ciated formatting file). But you knew that.

Click OK.

Your worksheet fills with the Products table.

Programmatically Creating a Dataset

To create a dataset from an Access-style database (MBD) programmatically,
you can type in and then execute the following code (Listing 3-2) in Visual
Basic .NET.
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Listing 3-2:

Programmatically Creating a Dataset 3 01

Creating a Dataset from an Access-style Database

PubTic s As

String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & _

"C:\Program Files\Microsoft 0ffice\Officell\Samples\Northwind.mdb;"

Private

Dim

Try

Sub Forml_Load(ByVal sender As System.Object, ByVal e As
System.EventArgs) Handles MyBase.load

connect As New System.Data.0leDb.0leDbConnection(s)

connect.Open()
Dim SQ, fname As String, dset As New DataSet
Dim adap As New System.Data.0leDb.0TeDbDataAdapter

SQ = "Select ProductName, CategoryID, QuantityPerUnit, UnitPrice from
Products”

adap.SelectCommand = New System.Data.0leDb.0TeDbCommand(SQ, connect)
adap.Fill(dset)

fname = "C:\Products.xml"

Dim fs As New System.IO.FileStream(fname, System.IO.FileMode.Create)

Dim t As New System.Xml.XmlTextWriter(fs,
System.Text.Encoding.Unicode)

'this is a necessary first element for Excel to recognize the dataset
as XML:
t.WriteProcessingInstruction("xml", "version="'1.0"")

dset.WriteXml(t)
t.Close()

MsgBox ("EXPORT SUCCEEDED")

Catch ex As Exception

MsgBox(ex.Message)

End Try

End Sub

Remember that all this book’s code is available at this book’s companion
Web site. (Please see the Introduction for the specific URL.)

Press F5 to execute this and then follow Steps 9-14 in the preceding example
to load your dataset into Excel.

In Listing 3-2, first the variable s is defined to hold the connection string to
the database. This is done in the General Declarations section, in case you
want to access this connection elsewhere in your project. In this code,

Book IV
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though, you use it only in the Form_Load event. You first create a connection
object named connect. Then within an error-trapping Try block, you open
the connection to the database, create a string variable to hold an SQL Query
string, and also declare a couple of variables to hold a filepath and a dataset.
The dataset, being a particular kind of object (it has no special name, but it
does behave differently than built-in objects like strings) requires that you
use the New keyword when declaring it.

SQL (Structured Query Language) is the most widely used language for get-
ting information from a database. You often don’t want an entire chunk of
data, such as a whole table, so you can write an SQL query, like this: Show
me all customers whose accounts are more than three months overdue. This
provides you with a useful subset of the data. SQL can also be used to
modify a database, such as updating information.

A data adaptor object is created. Also, an SQL query is specified, asking
that the dataset to be built from four fields in the Products table of the
database. The specify query connection (a command, as it’s called) is now
made, and the dataset object is filled. Now the New .NET FileStream and
TextWriter objects are used to save the XML data to a file on the hard
drive.

Database management in the .NET world involves several objects that inter-
act. Dividing the task of accessing data into these several objects is perhaps
more of interest to the programmers at Microsoft who created this division
than to the rest of us. But if you’re curious, here are the four primary objects
that are collectively known as the data provider:

4 The data connection makes contact with a data store, such as a database.
4+ The data adapter makes a connection between a dataset and a data store.

4+ The data command allows you to specify how you want data retrieved or
modified (similar to the idea that SQL can frame specific requests for
subsets of data, or to modify the database).

4+ A data reader object provides a read-only, forward-only stream of data
from a data store. (A reader executes very quickly.)

A dataset is a table, for example, that’s been separated from its original data-
base so you can work with it “offline,” so to speak, without having to main-
tain an active connection to the original database.

Note that Access starts to buckle under the pressure of more than ten simul-
taneous connections; its performance seriously degrades. Disconnecting or
“checking out” tables solves this problem. For more details about .NET data-
base management, see my book Visual Basic .NET Database Programming
For Dummies (Wiley).
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O0OP and the degeneration of languages

Object-oriented programming (00P) theorists
have offered convoluted explanations for the
false “distinction” between objects that require
New during instantiation and those that don't.
But they (the explanations, not the professors)
are too tedious to endure. Just note that some
variable declarations in VB.NET require the
New keyword, others don't, and there's no
rule nor pattern that you can learn to differen-
tiate them. It's the usual thing with OOP
programming — you just have to try something.
And if that doesn’t work, insert a New command
or some other fiddling until the compiler agrees
with your grammar.

You've probably heard that the classic Chinese
language cannot be typewritten because
(being pictographic) the keyboard would have
to be an acre wide and contain hundreds of
thousands of keys. Chinese words aren’t made
up of 26 rearrangeable characters; instead,
each word is a unique drawing, a little picture
resembling the meaning (the word for duck
looks like a duck).

Many of these words are quite lovely, and a
language like this is easier to learn, but it
certainly has drawbacks when you try to
design a computer keyboard for it. Likewise, the
many unique behaviors and interrelationships

between objects and members in 0OP lan-
guages increasingly baffle programmers. Even
the people responsible for designing 00P lan-
guages themselves are often at a loss to
explain the classifications systems, internal
illogic, and absence of useful taxonomic rules.
The Visual Basic language started off in 1990
with around 300 words. There are now hun-
dreds of thousands of phrases — massive
assemblies crammed with objects, each
object’s many members, and the many argu-
ments and overloaded argument lists available
to each member.

Computer programming is the second time in
history (after Esperanto) that a human language
was deliberately designed rather than simply
evolving from grunts or accreting blindly over
centuries of use. Programming offered a spe-
cial opportunity to specify a logical grammar: a
consistent set of rules. It's truly a shame that
computer programming has now become the
plaything of raging academics. To put the situ-
ation bluntly, confusion is triumphing over
common sense. Qur only hope is that sooner
rather than later, the computer itself will design
a programming language that is — like BASIC
used to be — easy for humans to read and
write.

Book IV
Chapter 3

Adding Shapes and Pictures

Now for a little recreation. Whether you’'ve been naughty or nice, there’s no
use perma-sticking your nose to a grindstone. The following example shows
you how to goose up your worksheets and presentations with some fun clip
art. Also, graphics can have practical uses as well, such as drawing attention
to important points.
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You can use both the AddShape method of the Shapes collection and the
Insert method of the Picture collection to liven up your work. The follow-
ing code adds an explosion graphic, followed by a dropshadowed cloud
drawing, and then a second explosion superimposed on the cloud.

\\J
The order in which you add these objects to a sheet defines the z-axis
format — that is, which is superimposed on which.
Sub AutoShapes()
"insert explosions
ActiveSheet.Shapes.AddShape(msoShapeExplosion2, 425.25, 145.5, 86.25,
101.25).Select
'get a shape from the collection on the hard drive:
ActiveSheet.Pictures.Insert("C:\Program Files\Microsoft
0ffice\MEDIA\OFFICE11\AutoShap\BD18185_.wmf").Select
"superimpose second explosion:
ActiveSheet.Shapes.AddShape(msoShapeExplosion2, 465.75, 324.75, 724,
72#) .Select
End Sub
Execute this Sub, and you see the graphics added to your worksheet, similar
to the sheet shown in Figure 3-3.
618 - 500 g pkgs Ed
812 - 200 ml jars i
41 kg phog. 21
410 - 500 g pkygs =
— |82 kg bO 6
740 - 100 g pkys 235
Figure 3-3: 224 - 250 ml bottles 15.5
. 332 - 500 g boxes 17.45
Surprise 20 1 kg tins 9|
- 815 kg pk 625
yourco 310 bgr.pesgx 12 pieces 9.2
workers 3.30 gitt boxes 81
: 3 24 pkgs. x 4 pieces 10
with 5 24 - 500 g pkygs 2
sudden, 512- 250 g pkys 9
112 - 355 ml cans 45
program- 320 - 450 g glasses 14
; 3100 - 250 g bags 3123
matlca”y 3100 - 100 g pieces 439
added 725 - {125 g cans 455
: £ 50 bags x 20 : 123.79
graphics. 510-200 g glssses. | 2589
412 - 100 1 ok 12 5

The AddShape method takes the following arguments:

AddShape(Type, Left, Top, Width, Height)
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Figure 3-4:
Tasteless or
fun, adding
clip art

is your
judgment
call.

Augmenting Find and Replace 3 05

In the preceding code, note that the AddShape method specifies the absolute
position in the sheet as well as absolute size of the graphic. However, when
you insert a picture, its upper-left corner appears at the current selection
point.

A collection of clip art .wmf (Windows Metafile) files can be found in the
AutoShap folder in the path specified in the earlier code. Figure 3-4 shows
some of the available drawings.
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Augmenting Find and Replace

As in Word — or indeed many situations including programming itself — you
sometimes need to locate a particular item or even mass-replace one item
with another in Excel. It could be text, formulae, captions, values, or what-
ever else needs to be located or cleaned up.

Automating a find-and-replace isn’t a difficult challenge; often you can record
a macro that shows you the ropes by providing the necessary code. But do
be aware of the limitations of recorded code. Sometimes it’s too specific: It

Book IV
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specifies the current selection, for instance, rather than using a relative pro-
gramming command. Sometimes it’s hard-wired rather than free-form. Other
times it includes lots of extraneous code, such as line after line of default set-
tings in Word.

In any case, you do want to be aware of your options for programmatic find-
ing and replacing.

The Find method of the Range or WorkSheetFunction objects returns
either nothing if no match is found or the single-cell range where the match
was found. If you want to do a global find-and-replace, therefore, you must
use a loop to iterate through the target cells.

Read more about loops in Book II, Chapter 3.

Understanding Find methods

The Range object offers Find, FindNext, and FindPrevious methods.
Listing 3-3 illustrates how to use the Find and FindNext methods. It asks
users what they want to search for, turns each hit (find) gray, and then dis-
plays how many hits occurred:

Listing 3-3: Using Find and FindNext
Sub Count()

ActiveSheet.UsedRange.Style = "normal"
s = InputBox("Type in the search term.")
With ActiveSheet.UsedRange
Set ¢ = .Find(s, LookIn:=x1Values)
If Not ¢ Is Nothing Then
firstAddress = c.Address
Do
counter = counter + 1
ActiveSheet.Range(c.Address).Interior.Pattern = x1PatternGrayl6
Set ¢ = .FindNext(c)
Loop While Not ¢ Is Nothing And c.Address <> firstAddress
End If
End With
If counter = 0 Then counter = "no"
MsgBox ("We found " & counter & " instances of " & s)

End Sub
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Getting user input

You first blank (delete the contents of) any cells that have shading in the
UsedRange (the entire group of used cells on the active sheet.) Next, you dis-
play an input box to get the user’s target; it can be a number or text. Then
you amend the ActiveSheet.UsedRange in a With block. You define c as
the result of the search (via the Find method of the UsedRange object) —

in other words, the first instance of the target that the user requested be
searched for. If ¢ is not nothing (meaning that something was found as a
match for the requested target), you enter a Do loop, raising the counter
variable each time through the loop and also turning the hit cell gray. You
continue to loop as long as there’s a hit (¢ has something in it) and the
address of c isn’t the same as the first hit. When finished looping, the results
are displayed to the user.

The Find Format

Here is the argument list for the Find method:

Range.Find(What, [After], [LookIn], [LookAt], [SearchOrder],
[SearchDirection], [MatchCase], [MatchByte],
[SearchFormat])

4+ What: This is the target value you're looking for, such as bottles or 200. It
can be any type of data permitted in Excel. What is the only required
argument; brackets mean optional arguments.

4+ After: This is the address of a single cell in the range where you want
the search to begin. It’s an offset; if omitted, your search begins in the
top-left cell of your Range object’s cells.

4 LookIn: This can be one of three constants:
e x1Values (the default)
e x1Formula
e x1Comments

4+ LookAt: This can be one of two constants. (Note: The entire value must
be matched. For example, Boy will not be a match for cowboy.)

e x1Part (the default)
e xlWhole

4 SearchOrder: This can be either x1ByCoTumns or x1ByRows.

Book IV
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WING/

4+ SearchDirection: This argument specifies the search direction.
Choose from

e xINext (the default)

e xIPrevious

+

MatchCase: This is False by default. If True, the search is case-sensitive.

4+ MatchByte:If this is True, Unicode (characters represented by a two-
byte code) matches only other Unicode characters. If False, Unicode
characters can match ASCII code (single-byte) characters. This defaults
to False, so just ignore it.

4+ SearchFormat: This argument is puzzling. If I were you, I wouldn’t
worry about it. It can be True or False and appears to interact with
the FindFormat method, toggling it on or off. This code, for example,
changes italicized cells to boldface but only because the Replace
method’s SearchFormat argument is True:

With Application.FindFormat
.Clear
.Font.Bold = True

End With

With Application.ReplaceFormat
.Clear
.Font.Italic = True

End With

Cells.Replace SearchFormat:=True, ReplaceFormat:=True

Some of the arguments for the Find method persist! In other words, the next
time that you use the Find method in the same session, any values that
you’ve previously assigned to LookIn, LookAt, SearchOrder, or MatchByte
will be used again unless you change them in your new code. This strange
persistence can certainly be expected to cause some confusing bugs.

The Replace method

A typical recorded version of Find and Replace looks like this:

Sub Macrol()
Cells.Replace What:="10", Replacement:="4000", LookAt:=xIPart, _
SearchOrder:=x1ByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False

End Sub
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Fortunately, Replace is a pretty straightforward method, and it doesn’t
require that you build a loop or anything as in the previous Find examples
in this chapter. The arguments are also the same as those for Find except
for Replacement (what you want to replace the targeted value with) and
ReplaceFormat, which allows you to change the formatting of a cell, after
this fashion:

With Application.ReplaceFormat.Font
.Size = 12
.Name = "Optima"
.FontStyle = "Italic"

End With

Book IV
Chapter 3
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Chapter 4: Data Diving
with Pivot Tables

In This Chapter

v~ Building pivot tables

v+~ Using the PivotTable Wizard

+ Revealing hidden data

v Creating pivot charts

+ Modifying the data in pivot tables
v+~ Updating pivot tables

pivot means to turn, yet remain in the same place, like a ballerina revolv-
ing en pointe, so you see her from all sides.

An Excel pivot table allows you to see data in new ways. Maybe you’ve heard
about expensive, complex data mining technology: Sophisticated software
explores a database and then presents users with ideas they never expected,
predictions they never could have made themselves, and answers to ques-
tions they never thought to ask. (Check out Excel Data Analysis For Dummies,
by Stephen L. Nelson, Wiley, for Excel data mining ins and outs.)

As you'll discover in this chapter, you can look at a set of data in several dif-
ferent ways and still miss something of importance. The first few figures in
this chapter contain an interesting anomaly, but you’re unlikely to spot it
until I — with the help of a pivoting table — reveal it to you. Then you’ll go
back and say, “Why didn’t [ see that?” (Answer: You did see it, Bunky, but it
was camouflaged by the data surrounding it. Only after some pivoting was it
revealed to us all.)

This chapter also covers pivot charts and ways to modify or update the
data in pivot tables.

What Is a PivotTable?

Data mining technology is becoming increasingly important in proportion to
the increasing size and complexity of databases. No human has the ability
to sort through millions of data and spot oddities, notable variants, and inter-
esting trends.
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Pivot tables aren’t as advanced as data mining, but they’re in the same ball-
park. With them, you get to twist data around — to pivot it, as it were — to
see it in new ways. I call it data diving because it’s less extreme than mining
although pivoting tables can (in their own way) yield valuable results in
much the same way panning for gold by hand sometimes yields nuggets.

When you drag and drop fields to various locations within a pivot table,
you're pivoting it. The pivot table re-sorts and recalculates the data, adjusting
the subtotals and grand total(s) as necessary. You don’t type in any formulae.
You simply choose from a drop-down list in the PivotTable Field dialog box
(double-click a field title button, the gray buttons, in the PivotTable) whether
you want a COUNT, SUM, AVERAGE, MAX, MIN, PRODUCT, COUNT NUMS,
STANDARD DEVIATION, or other options. If you need to perform calculations
not available on this drop-down list, it’s possible (see Excel’s Help).

Here’s an example of data too complex to be useful unless it’s been pivoted
or mined. Everyone entering the Super Bowl is watched by a video camera,
and their face patterns are compared to stored photos. Tied to the photos is
personal data, such as young, male, pilot lessons, one-way tickets. The visual
and other patterns are automatically and rapidly transformed in various
ways. This kind of analysis, although somewhat chilling for those of us who
value liberty and privacy, might end up saving many lives.

Pivot tables are especially useful in a variety of situations:
4+ Performing simple data-mining by hand, noticing significant facts other-

wise hidden within the data.

4+ Generating budgets and business plans, complete with easy ways to
generate charts and reports.

Tracking expenses.
Discovering hidden patterns and relationships.
Improving inventory control.

Boosting productivity.

¢+ e

Spotting problems or trends early. (Which division wastes the most
money on bad ads or sells the most widgets?)

<+

Summarizing lengthy data in a compact format (see upcoming Figure 4-10).
4+ Deciding what data to selectively hide.

4+ Arranging data in ways that are easily charted (see Figure 4-10, which
results in the chart shown in Figure 4-12).
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Creating a Pivot Table

Like swimming, a pivot table is difficult to describe. The result is obvious in
both cases, but the activity itself needs to be experienced, dear readers, so
jump in here and experience it.

Start by creating a pivot table. Pivot it and twirl it around. Fool with it. Get a
feel for it. To see how a pivot table works, follow these steps:

1. Create a spreadsheet with four columns of fake data: Company, Year,
Expense, and Amount.

You're pretending to be a wild greed engine, a mogul named Varla Vepp,
who wants to examine the costs of three of her companies. She plans to
decide which one to shut down during next year’s New Year’s celebra-
tion, just after many of her employees have maxed out their credit cards.
Watch out for Varla’s bad self; she’s extremely scary when in high spirits.

2. Fill in the data for 20 to 30 rows. Use three different company names,
three different years, three expense categories (transportation,
salaries, and utilities), and various different amounts of money, as

A\ shown in Figure 4-1.

Copying and pasting helps you quickly add this data.

] Book1.xls ===
. A B [ ¢ b [ E E
il COMPANY YEAR EXPENSE AMOUNT
2 |MidState Sealant 2001 Transportation 24000
| 3 |Murrey's Fishfood 2002 Salaries 12500
4 |Murrey's Fishfood 2003 Salaries 45000
5 [MidState Sealant 2001 Transportation 17000
| B |MidState Sealant 2002 Urilties 4000
| 7 |o-Yo Clothing 2003 Transporation 33000
8 [Yo-Yo Clothing 2001 Transportation 5200
9 |MidState Sealant 2002 Salaries 17400
10 [Yo-Yo Clothing 2003 Utities 23000
| 11 [Yo-Yo Clothing 2001 Transportation 4200
12 |MidState Sealant 2002 Lkilties 4440
13 |Murrey's Fishfood 2003 Salaries 56500
14 |¥o-Yo Clothing 2001 Transportation 32000
15 |Murrey's Fishiood 2002 Transportation 42993
16 |MidState Sealant 2003 Lkilties 25909
17 |Murrey's Fishfood 2001 Salaries 13000
18 |¥o-Yo Clothing 2002 Salaries 44400
19 |MidState Sealant 2003 Transporiation 23660
2
21
22
]
24 ]
%
26
e[| 27
28
Figure 4-1: g%
Create a 3
sample set ||
of data. 3 v
i« v w\sheet (sheetz [ sheets / I<] ! [0
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s

Figure 4-2:
Here's

where you
design the
pivot table.

10.

11.

Click any cell in the data.
Choose Data=>PivotTable and PivotChart Report.
The PivotTable and PivotChart Wizard opens.

Leave the Microsoft Office Excel List or Database radio button
selected as the data that you want to analyze.

Leave the PivotTable radio button selected.
Click Next.

In the second page of the wizard, specify A1:D300 as your range (in
the Range text field).

You want to specify a range larger than the actual current data because
you might add data in the future.

Click Next.

In the final wizard page, select the New Worksheet radio button to set
the location of your new pivot table.

Click Finish.

You now see a new worksheet containing a template for your pivot table,
as shown in Figure 4-2.

] Bookl_xls == ]

PivolTable 7
PivatTable - | "1 i | EEE
[Prvot table Fiedd List - x
Nro + 25| Draa bems ko e FrvckTable repert

|u:£<: ¥ W] sheetd {Bheetl J Sheste / Sheetd /. 1< ' tall

Ll [Pk eeo it
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Figure 4-3:
This Pivot
Table is
almost
ready to
pivot.
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Now you're ready to build the actual pivot table. You begin by dragging
and dropping items from the Pivot Table Field List dialog box, as shown in
Figure 4-2. Follow these steps:

1.

Drag the AMOUNT header and drop it into the data field (Drop Data
Items Here) in the template.

The template unhelpfully collapses. The template actually disappears
at this point, and you're left looking at the usual Excel cells. (There’s
a solution to this, which I describe later in the tip in the section, “A
sudden surprise.” The upcoming Figure 4-11 illustrates the dialog box
that solves the problem.)

The item that you drop into the data field is the one that gets summarized
by the pivot table.

Click Company to select it in the PivotTable Field List dialog box.

Click the Add To button (with Row Area visible in the drop-down list)
in the dialog box.

Your company field is added to the worksheet.
Repeat Steps 2 and 3 to add the Year and Expense fields to the worksheet.

See the results in Figure 4-3.

A | B c | D

1
2
3

[Caunt of AMOUNT 1

4 COMPARNY | = [YEAR |~ |EXPENSE | |Total

5 Mid-State Sealant 2001 {Transpariation

(X108}

Lltilities
2002 Total
2003|Transportation
Lltilities
2003 Total

3 Mid-State Sealant Total

15
16
17
18

19

20

14 Murrey's Fish Food 2001 |Salaries

2001 Tatal
2002

Salaries
Transportation
2002 Total
__2003[Safaries

2003 Total

21 hurrey's Fish Food Total

2B

22 Yo-Yo Clothing 2001 |Transpariation

2001 Total
02| Salaries
2002 Total

2003 Transporiation
Litilities

2003 Tatal

29 Yoo Clathing Total

mfro|— —|——lfwm{ralrafrs]— |~ —]~afral— —Joifrs —

31

| 30 (blank) (blank) J(blank)
{blank) Total

32 (blank) Total

34

33 Grand Total 16
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Figure 4-4:
The Pivot-
Table Field
dialog box
offers you
avariety
of ways
to pivot
the data.

Creating a Pivot Table

5. Close the PivotTable Field List dialog box.
6. Double-lick Count of AMOUNT at the top of the data in this worksheet.
Refer to Figure 4-3.
The PivotTable Field dialog box opens. (See Figure 4-4.)

PivotTable Field &
Source fisld:  AMOUNT E
LEITE ount of AnOLIN

Cancel
Summarize bry:
Sum ~ Hide
Count.
Average | bmber...
W PELloifianl
M tions >
Product ptions
Count Nums i

By default, Count of AMOUNT is displayed, which is rather odd. That’s
not very useful information when you’re looking at expenses or, indeed,
many other kinds of summaries. In this example, you want to see the
sum — the total cost — not simply a count of the number of expense
entries. (However, if you're summarizing non-numeric data, such as

company names, Count is the only possible choice — you can’t perform
math on words.)

7. Click Sum in the dialog box (in the Summarize By list) to choose
Summarize by Sum.

8. Click OK.

The dialog box closes, and you see that the Total column has been recal-

culated to show various subtotals and totals. At this point, your work-
sheet should look like Figure 4-5.

Notice in Figure 4-5 that you're seeing expenses for each company, broken
down by yearly subtotals, company subtotals, and a final grand total. Now
drag the Expense button (in cell 4) and drop it on top of the Company
button. At this point, the pivoting takes place. Read on.



Figure 4-5:
Now you're
seeing
some
interesting
information.

The Table Pivots

The Table Pivots

Now the information is recalculated — the table pivots — and you see the
subtotals for each category of expense, rather than by company subtotals.
This is an interesting way to quickly reorient the view on the data, wouldn’t
you agree? You actually have a differently arranged, newly sorted, new table.

Figure 4-6:
Use this
dialog box
to change
the format
of a Pivot-
Table to suit
yourself.

] Book1.xls =@ [x)
A i B A E T 6
1 1
2
3 |Sum of AMOLUNT
4 JCOMPANY ~I¥YEAR ~ |[EXPENSE |~ |Tatal
5 [MidState Sealant 2001 |Trarzspnnat;un 41000
B | 2001 Total 21000
| 7 2002 | Salaries 17400
| 8 Utilties 8440
& 2002 Tatal 25840
0 2003 | Transportation | 23880
| 11 | Utilties 25999
12 2003 Total 49879
13 |MidState Sealant Total 116719
14 |Murrey’s Fishiood 2001 |SaEaries 13000
| 15 | 2001 Total 13000
16 | 2002 |Salaries 12500
17 Transportation | 42999
18 2002 Tatal 55455
(19| 2003 [Salaries 101600
20 2003 Total 101800
21 |Murrey's Fishfood Total 170289
22 |Yo-To Clothing 2001 |Transp0rtatmn 41400
23 | 2001 Total 41400
| 24 | 2002 [Salaries 44400
25 2002 Total 44400
26 2003 | Transportation | 33000
27 Utilties 23000
28 2003 Total SE000
29 [Yo-Yao Clothing Total 141800
30 |(blank) blank) [blank)
31 (blank) Total
32 |(blank) Total
33 |Grand Total 426818
34 v
W o4 v Wb Sheetd  sheetl fshestz f sheets / <] 2
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Try double-clicking the Expense button. You see the PivotTable Field dialog
box from which you can select various options, such as hiding subtotals. Try
clicking the Layout button in the dialog box to see the PivotTable Field

Layout dialog box, as shown in Figure 4-6.

PivotTable Field Layout %]
Dasplay Options

() Shiow ibems In babedar Form

(5 show tbems In autiine Form

Disply subtobaks at top of group

[
Print Opbion

[ | Insert page break after cach Rem
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Figure 4-7:
You can
adjust the
layout to
clarify what
you're
seeing.

Use the PivotTable Field Layout dialog box to change the way your pivot
table looks to perhaps make the information clearer: Select Show Items in
Outline Form, Display Subtotals at Top of Group, and Insert Blank Line after
Each Item. Click OK twice to close both dialog boxes.

You now see a slightly different — and I think more readable — summary of
the costs of each expense item, as shown in Figure 4-7.

=] Book1.xls =0
} A { B G i] O E L =L e
4 |EXPENSE > ICOMPANY [ [¥EAR [~ Taral
| 5 [Salares 182100
| 6 | MidState Sealant
i 2002} 17400
8 MidState Sealant Total 17400
B Murrey's Fishfood
10 2001| 12000
11 2002 12500
12 2003} 101800
| 13 | burrey's Fishfood Total 127300
14 | o-Yo Clothing
15 2002] 44400
16 ‘oo Clothing Total 44400
17
18 | Transportation 182279
19 MidState Sealant
20 2001 41000
21 2003] 23380
| 22 | idState Sealant Total 54880
23 Murrey's Fishfood
24 2002] 42989
25 | Murrey's Fishfood Total 42998
| 26 | o-Yo Clothing
27 2001] 41400
28 2003] 33000
29 | Yo-Yo Clothing Total 74400
30
31 |Utilties 57439
32 MidState Sealant
33 2002| 8440
34 | 2003] 25993
35 | MidState Sealant Total 34439
3B Yo-Yo Clothing
m03] 2=000 =
1< 21l

Just so we're all on the same page, for the next example, reverse your recent
actions, again open the PivotTable Field dialog box, click the Layout button,
and then deselect all three options: Show Items in Outline Form, Display
Subtotals at Top of Group, and Insert Blank Line after Each Item.

Collapsing the pivot table

Try collapsing the entire report to see just the essentials. On the PivotTable
toolbar, click the Hide Detail button (see Figure 4-8). If this toolbar isn’t visi-
ble, right-click the Excel menu bar and mark the PivotTable check box. If the
buttons on the PivotTable are disabled, click a cell within the worksheet’s
data to enable them.



Figure 4-8:
The Pivot
Table
toolbar and
its various
buttons.

Figure 4-9:
The table
organized by
expenses
(top) can be
pivoted to
reorganize
the data into
a table
organized by
companies
(bottom).

The Table Pivots 3 79

Hide Detail Always Display ltems

Format Report | Refresh Data Hide Field List

| | |
i RivotTable~ | Z1 4| = =] ¢ | 14[9] 23]
| |
Show Detail Field Settings

Chart Wizard Include Hidden Items in Total

Now you see only the essentials. To see the fundamental difference between
the two tables you’ve been looking at (broken down by expenses versus by
company), drag the Expense button and drop it on the Company button.
Now it’s easy to see how different a table is when pivoted. This is still the
same basic data (the grand total doesn’t change), but when rearranged and
recalculated, it tells you quite different things about your empire — and
where the money goes — as shown in Figure 4-9.

4 |EXPENSE | = [COMPANY [=YEAR |~ | Total

5 Salaries 189100
B Transportation 182279
7 Unilties 57439
8 {blank)

9 Grand Total 428818
4 [COMPANY | ~[EXFENSE [=IYEAR [~ |Total

5 MidState Sealant 116719
B Murrey's Fishfood 170293
7 Yo-Yo Clothing 141800
8 (blank)

9 |Grand Total 428618

Now try pivoting again, working again with the wizard. Because in the earlier
example, | originally asked the wizard to make a new worksheet when it
created the first pivot table in this chapter, the original data still exists on
Sheetl. That’s what I use. Click Sheet1’s tab on the bottom of the workbook
(which should look like Figure 4-1, earlier in this chapter).

Click to select any cell in the table of data in Sheetl; then choose Data~>
PivotTable and PivotChart Report to open the wizard. Drag Company to
the Row field, Expense to the Column field, and Amount to the Data field.
Double-click Amount and choose Sum. You've deliberately left out the year
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Figure 4-10:
This pivot
simplifies
seeing the
overall
picture by
eliminating
the time
factor (the
year-by-year
breakdown).

field, which simplifies your view of the table because there’s less data to
view and less to summarize.

Notice how different this view is from earlier pivots. The table has rotated
again into a new view, as shown in Figure 4-10.

3 [Sum of AMOUNT |EXPENSE [~ |
4 COMPANY ~ Salaries Transportation Utilties (blank) Grand Total
5 MidState Sealant 17400 54880 34435 116719

B Murrey's Fishfood
7 Yo-Yo Clothing
8 (blank)

127300
44400

429939
74400

23000

170288
141800

9 Grand Total

189100

182279

57439

428816

Calendar data such as year, month, and so on can add needless complexity
to a pivot table’s data. You can either leave this field out of the pivot table
entirely as I did in this example, or you can drop the Year (or other calendar
field) into the Page section of the pivot table layout (see the upcoming
Figure 4-11). Do this, and you can selectively view each unit of time — or all
of them together — via a drop-down list. And if you're working with large
amounts of data (such as comparing 200 companies), you can try the group-
ing continuous variables (see Excel Help).

A sudden surprise

One thing pops out in this new view of the data shown in Figure 4-10:
Murrey’s Fishfood never pays utilities! | wonder whom they know.

Take a look again at Figures 4-1 and 4-5. If you were looking particularly care-
fully at these tables of data, you might have noticed that Murrey’s wasn’t
paying a utility bill. But many people would have missed this detail in the
larger mass of data. That’s precisely the value of pivoting data: You might
see information that was previously hidden. By rotating the table in different
ways, you can often get a deeper understanding of what the data means and
how to perhaps make wiser decisions. I'm sure that Varla will want to know
more about this Fishfood deal.

The sample table of data that I pivot in this chapter is actually rather small.
Real tables can be quite a bit larger and, thus, quite a bit more likely to need
pivoting to reveal their secrets.



Creating Instant Pivot Charts 321

You can rearrange the rows, columns, and data fields quickly in an existing

\\J
pivot table (as opposed to using the original table’s data as I did in the
previous example). Right-click any cell in the pivot table, and then choose
PivotTable Wizard from the context menu. Click the Layout button of the
wizard. In the Layout dialog box that appears (as shown in Figure 4-11), you
can freely rearrange the various field buttons by dragging and dropping
them into the various zones in the diagram.
PivotTable and PivoiChart Wizard - Layout %]
1 I'—‘: s = onstruct your al

.

Figure 4-11: [eace | ExperisE | counn

Use the —

Layout Riow siATA AMOUNT

dialog box

to quickly

pivot your

tables. [ beo JE ok | canced |
Double-click any of the field buttons shown in Figure 4-11 to change that
field’s summary behavior from count to sum, or select from many other
options. Between the wizards, context menus, dialog boxes, and drop-down
lists, you have many ways to pivot, reformat, and manipulate pivot tables.

\\3

Try pivoting this table in various ways. Use the Layout dialog box (refer to
Figure 4-11) to rearrange the field buttons and then close the dialog box to
see your newly pivoted table. And don’t forget these pointers:

4+ You don’t have to include all the available fields in the pivot table.

4 You can insert fields more than once.

4+ You can insert fields in more than one of the three layout locations
(Data, Row, and Column).

Creating Instant Pivot Charts

Nothing could be simpler than seeing a chart of a pivot table — a pivot chart.
Here is yet another view of your data, although this one is graphical. Pivot
tables automatically generate subtotals for you, scaling the subtotals so that
summary data can be easily displayed graphically.
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Figure 4-12:
Pivot charts
are justa

click away.

Right-click any cell in the pivot table shown in Figure 4-10. Choose PivotChart
from the context menu that appears. Et voila, your data is charted. Here’s
another view where you might notice that the fishbait guy isn’t paying his
electric bill, as shown in Figure 4-12.

53] Bicrosoft Excel - Bookinew.xls P
{%] File Edit Miews Insert Format Iools Chart Window Help Type a questenfornse v o @0X
- A

Sum of LMOLUNT]

180000

TR0

anmn

120000
e
EFENSE [+

00 ablank]
alkilties

BOon B Transporaticn
D Zalanias

60200

Anen

0w

1}

tlidZiate Sealant tumey's Fishinad o-¥o Clathag (blank)

COMPARY |- |

1€ 4% Wil Chart? {Sheets | shest: | neet2 { hests / I< 12
Ready

Modifying the Data in a PivotTable

You cannot directly edit the data in a pivot table. It’s like a report — not a
data source. But you can edit the source data and then choose Datar>Refresh
Data. The data that populates a pivot table need not be a loaded, active work-
sheet like the examples that I explore in this chapter. It can be a set of ranges,
another pivot table, or various kinds of external data sources.

Refreshing pivot table data

If the data source is modified — for example, if you make changes to the
values in the sheet shown in Figure 4-1 in this chapter — you can turn back
to the pivot table and click the Refresh Data button on the PivotTable tool-
bar or choose the same option from Data menu. The pivot table is updated
because it remembers the source of its data.
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Pivot charts revert to their default formatting when refreshed. Pivot tables,
however, stay formatted after being refreshed.

Automatically updating pivot table data

Perhaps you want to make the updating process automatic. Every time a pivot
table’s workbook is opened, any pivot tables in it are updated automatically.
To do this, put your updating code in the workbook’s special Open macro that
executes automatically each time the workbook is opened. To do this, press
Alt+F11 to open the Visual Basic editor (VBE) and choose View=>Project
Explorer. In Project Explorer, double-click ThisWorkbook to open its macro
window. Now type this:

Private Sub Workbook_Open()

For i = 1 To ActiveSheet.PivotTables.Count
ActiveSheet.PivotTables(i).RefreshTable

Next

End Sub
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Chapter 5: Business
Analysis with Excel

In This Chapter

v Forecasting with Goal Seek
v+ Creating scenarios
v Using summary reports

v~ Exploring problems with Solver

E(cel includes a variety of tools that you can employ to assist your busi-
ness with forecasting, planning, and general analysis. When it comes
time to run your company stats through Excel, you might as well take advan-
tage of some of these tools. In the preceding chapter of this mini-book, I
cover in depth one of the most important data-analysis tools — the pivot
table. In this chapter, you explore several additional tools useful for people
whose job it is to combine computer expertise with business savvy.

Seeking Goals with Goal Seek

Excel’s Goal Seek feature allows you to specify a particular goal value (such
as profit = $12,000 monthly), and Excel will adjust the value in a second cell
until the goal is achieved. Goal Seek has been called what-if in reverse because
instead of adjusting the income cell to see the effect on the profit cell — the
usual what-if behavior — you do the reverse: Specify what profit you want,
and Excel adjusts income to achieve that goal. It’s rather a simple tool, but it
can be useful. And when you understand how it works, you’ll have an easier
time finding out how to use the more advanced tools such as scenarios and
Solver, which I explore later in this chapter.

To see how the Goal Seek feature works, open a new worksheet and type in
these three labels describing the cash flow of your cheese business: Monthly
Income, Monthly Expenses, and Profit. Then type in these figures: 11000 for
Monthly Income, and 4000 for Monthly Expenses.

The formula that you use to calculate Profit is B1 — B2. Click cell B4 to select
it; in the formula (fx) line at the top, type =B1 — B2, as shown in Figure 5-1. As
soon as you enter the formula, the result of the calculation, 7000, displays in
the Profit cell, as shown in Figure 5-1.
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B4 - £ =B1-B2
=1 Book1 2|=]
A | B | € [
1 |Monthly Income 11000
2 |Monthly Expenses 4000
3
4 |Profit [ ?ooo_l
6
7
8 |
Figure 5-1: | 9 |
Here's some 10
simple L]
cheese —12—
factory BV
cash-flow 15
analysis. W T b\ Sheet1 { Shest / Shesta / | £ — Bl
Now to seek your goal. Click cell B4 to select it. Choose Tools>Goal Seek.
The Goal Seek dialog box opens (as shown in Figure 5-2), and cell B4 is dis-
played as the cell that you want to change. For this example, you want to
see how you can increase Profit, which is cell B4. You also need to enter the
value that you want cell B4 to have (11000) as well as the cell that you want
to adjust to reach this goal. Remember that when using Goal Seek, the goal
cell itself must contain a formula, not merely data.
Figure 5-2: Goal Seek (%]
Specify your | o
goal and To valug: 11000
how you By changingcell: |
want to
achieve it.

To reach your goal in this example, you either have to increase your income
(B1) or decrease your expenses (B2). Assume that you want to see what
your monthly income must be to achieve the desired profit. Into the By
Changing Cell field, enter B1. Click OK. You see the correct answer — 15000,
in the Monthly Income cell — as displayed in Figure 5-3. The Goal Seek dialog
box is replaced by the Goal Seek Status dialog box.
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] Book1 [==]x]
A B c =]
| 1_|Monthly Income [ 150001
2 |Monthly Expenses 4000
3
4 |Profit 11000
: ‘Goal Seek Status
. 7 {Goal Seeking with Cell B4 i T
Flgure 5'3: 8 | found a sclution,
Your 906| iS ] Target value: 11000 @
achieved 10 | Current walue: 11000
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reaches 13|
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15
month. == e
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In the Goal Seek Status dialog box, click OK to leave the changed cell as is;
then click Cancel to restore the original value.

To see how much you’d have to cut down on expenses to achieve your goal,
follow the same steps as above, but instead type B2 in the By Changing Cell
field of the Goal Seek dialog box.

Using Scenarios

A step up from goal seeking, scenarios allow you to collapse what would
require several worksheets into a single, easily viewed set of scenarios for a
single worksheet. A scenario is a set of values that you offer to your formu-
lae and that are displayable from within the Scenario Manager.

Try it by using the same sheet that [ use in this chapter’s earlier example for

the cheese factory. Assume that you want to see the effect of various differ- ci‘;ol:‘:rvs
ent expense levels on profits. One way to do this would be to create several g

sheets, each with a different value in the Monthly Expenses cell, but why do —

that when you can build a set of scenarios? Follow these steps: s

£5

= ®

1. Use the cheese factory sheet shown in Figure 5-1. - a

x >

2. Choose Tools->Scenarios. ]

=

The Scenario Manager dialog box opens. 2.

3. Click the Add button.
The Add Scenario dialog box opens.
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4. Type Expenses @ 1000 as the name for the scenario.
5. Click the Changing Cells field.
The blinking cursor appears, indicating that a cell is selected.
< 6. Click B2 in the worksheet, the Monthly Expenses cell.
This is the cell you want to see adjusted to various values so you get to
see the impact this item has on profits.
7. Click OK.
The Scenario Values dialog box opens.
8. Type 1000 into the dialog box.
9. Click OK.
The Scenario Values dialog box closes, and the Scenario Manager lists
your new scenario.
10. Repeat Steps 3-9 to add Expenses @ 2000 and Expenses @ 3000,
respectively.
You now have three scenarios from which to choose any time you open
the Scenario Manager and click its Show button. At this point, your
dialog box should look like the one in Figure 5-4.
Scenario Manager ]
SCENAH0s:
T
J e | Clse
Figure 5-4:
This dialog T,
box now Bl
contains Sorgrg
three e ETT.
defined Craated by Richard on 41572004
scenarios.
11. Click the Close button to close the Scenario Manager.
\\J

If you want to see additional cells’ values change in Step 6 in the preceding

example, hold down Ctrl while clicking the additional cells to add them to
the scenario.
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Figure 5-5:
Here's a
summary
report,
created out
of three
scenarios.

Exploiting Solver
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Can you display the results of several scenarios on a single worksheet? Sure.

It’s called a summary report. Follow these steps:

1. Open the workbook from the preceding section’s example.

It should contain the three scenarios that you built (Expenses @ 1000,

Expenses @ 2000, and Expenses @ 3000).

2. Choose Tools=>Scenarios.

The Scenario Manager opens, as shown in Figure 5-4.

3. Click the Summary button.

The Scenario Summary dialog box opens. Scenario Summary is selected

by default.

4. 1f B4 isn’t selected, type that into the Result Cells field.

You want the results to be the Profit cell.

5. Click OK.

The summary worksheet is displayed, as shown in Figure 5-5.

=] Baoki
i

Pl Scenario Sum mary

- & |Changing Cells: o
-8 B2 1000 1600 3000

7 |Result Cells:

—_—

- $B%4 10000 10000 9000

9 |Notes: Current Values column represents values of changing cells at
10 [time Scenario Summary Report was created. Changing cells for each
11 |scenario are highlighted in gray.

i2 |
W 4 v wi] Scenatio Summary £ Shests [Sheeta {shests 1=

Exploiting Solver

Solver, which was purchased by Microsoft and integrated into Excel, is simi-
lar to (but more advanced than) the Goal Seek feature. Goal Seek allows you
to only directly specify a single cell as the variable (expenses, for example)
to reach the goal that you specify (such as profit). Many real-world business
problems, though, are more complex and involve multiple variables. With
Solver, you can specify the goal (target cell) as well as constraints and multi-

ple variables (changing cells).
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Figure 5-6:
Use Solver
to analyze
complicated
situations.

For reasons known only to the privileged few, some features of Microsoft
applications are not part of the menu system and must be added to the
application. Solver is one of these mystery sisters that you have to invite
explicitly to come down and join the party. Choose Tools>Add-ins, mark
the Solver check box, and then click OK. Excel shudders a little, and Solver
becomes a member of the family: The Tools menu now displays Solver.
(You might have to insert your Office 2003 CD.)

Solver works with a relatively complex worksheet. (Read more about this in
Excel Data Analysis For Dummies, Stephen L. Nelson, Wiley.) Because of that,
rather than creating a new worksheet to explore, take a look at the sample
workbook of Solver examples that ships with Office 2003. Locate the file
SolvSamp.XLS in this path: C: \Program Files\Microsoft Office\
OFFICEI1\SAMPLES. If it’s not there, find it on your Office 2003 CD. Load it
into Excel by double-clicking its name. Click the Staff Scheduling tab at the
bottom of the SolvSamp worksheet. It should look like Figure 5-6.
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The problem to be solved by the Staff Scheduling Solver example is actually
deceptive. It seems simple, but like the famous math puzzle involving the
shortest route for a traveling salesman, it’s actually rather complicated.
This Solver model has three rules that must be followed (constraints). You
can see these in the Problem Specifications area of the SolvSamp example in
Figure 5-6:
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1. The number of employees must be >= 0 (in other words, not negative).

2. The number of employees for each day must be a whole number and not
a fraction.

3. The total number of employees must equal or exceed the number
required to run the amusement park.

There’s also a constraint not expressed in the sheet itself (but understood by
the person filling in the sheet) that each employee must have two consecutive
days off per week.

P Check out the color-coded borders around the cells, showing which cells are
constrained, which can be changed, and which is the target cell (the goal).
By default, target cells are indicated by cyan (a rather bland color, similar to
turquoise), changing cells indicated by green, and constraints by red.

The profit cell is the target, and you want to maximize profits by minimizing
the number of employees on any given day while still remaining within the
constraints.

Now solve the problem by asking Solver to take a look at it. Choose Tools=>
Solver. The Solver Parameters dialog box opens, where you can specify Solver
parameters and options. See Figure 5-7.

Solver Parameters 1%
St Target Cell; EE 5 Salve
| equalter  OMax @Mo Ovaled: |0 E—
Figure 5-7: B Chanaing Cclls:max i foan [ cose |
Use this $D47:40613 Bl Gusss |
dia|0 bOX Sufjeck ba the Constraints;
i ot o (e
to adqut the e st T
behavior of = [ esatad |
[ Detete |
the Solver. Holp
Book IV
Chapter 5
The Guess button in this dialog box asks Solver to list all cells without for-
mulae in them that are referred to by the formula in the target cell. These g
are likely to be, or at least contain, the cells that should be specified as the s 5
. = ®
changing cells. = 3
3%
P To avoid possibly slowing up your computer for hours, click the Options oD
button. Notice that in this Solver Options dialog box, you can limit the 3,
("]

amount of time that Solver will spend finding the solution. Some problems
with many variables can take enormous computing power, so you might
want to specify a limit.
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Close this dialog box and then click the Solve button (in the Solver Parameters
dialog box). This solution comes quickly, as shown in Figure 5-8.
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compa ny ﬁmﬁa Al constrants and optimalby e
over $10,000 Anser
in annual T
payroll
costs. | [k ] [ concel [ savesceraio.. | [ _Hep |
Compare Figure 5-6 with Figure 5-8. The schedule itself didn’t change (the
Is and 0s) remain fixed — they’re not changing cells. But the changing cells
(employees who have days off on any particular day), and consequently the
schedule totals and profits, do change.
P The various scenarios in this SolvSamp sample workbook make good tem-

plates for problems that many businesses must solve. Microsoft suggests
that you see whether they might apply to problems you’re facing. If so,
adjust the data in the cells to reflect conditions that apply to your business,
and then solve away to see various outcomes.

If you need to do advanced statistical analysis, choose Tools~>Add-ins and
then select Analysis ToolPak or Analysis ToolPak - VBA. You’ll then have all
the co-variance, exponential smoothing, random number generating, reverse
transforms, and other fabulous (to statisticians anyway) tools at your finger-
tips. (You can find out more about this in Excel 2003 Power Programming with
VBA, John Walkenbach, Wiley.)



Chapter 6: Ten Excellent Excel
Macro Techniques

In This Chapter

v Accessing other Office applications from within Excel
v+~ Using UserForms to communicate with the user

1+ Adding macros to worksheet controls

v Automating formatting

v Trapping keypresses

v+ Selecting from a list box

1+ Sending workbooks via e-mail

v~ Differentiating between the Activate and Select methods

If you’ve read the earlier chapters in this book, you know what macros are
and how to press Alt+F11 to open the macro editor in Word, Excel, and
Access. In this chapter, you explore some useful macros that make working
with Excel easier. Perhaps you haven’t thought of some of these shortcuts
or techniques.

P If you want a macro to be available every time you run Excel (and from all
worksheets), put it into Personal . x1s. Do this by choosing Tools>Macroc>
Record New Macro. In the Record Macro dialog box, open the Store Macro
In drop-down list and choose Personal Workbook. This is similar to the
Normal.dot template in Word that’s always available to any Word document.

Accessing Other Office Applications

Contacting another application programmatically isn’t difficult after you know
the code. Obviously, being able to send data automatically between Office
2003 applications has uses. The different applications specialize in different
jobs. For instance, if you want to run some scenarios, you might want to send
data from Access to Excel because Excel excels in math. Word, of course, has
the best facilities for creating reports and formatting documents. So sending
information from Excel to Word is sometimes useful, too.
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In this example, you send the Excel value in cell Al to Word and then save
the Word document. Follow these steps:
1. Run Excel.
2. Type Mrs. Murphy into cell Al.
3. Press Alt+F11.
The Excel VB editor opens.
4. Press Ctrl+R.
Project Explorer opens.
5. Double-click ThisWorkbook and type in this procedure:
Sub SendToWord()

s = Worksheets("Sheetl").Range("A1").Value

Dim objWord As Object
Set objWord = CreateObject("Word.Document")

With objWord.Application
.Selection.TypeText s & " is from Excel to you."
.ActiveDocument.SaveAs "Word Test.doc"

End With

Set objWord = Nothing 'destroy the object

End Sub

6. Press F5 to execute this macro, and then you find that Mrs. Murphy
is from Excel to you is typed into a new Word document.

Understanding Scope

Notice the separate code windows for each of the three default worksheets,
as well as one for ThisWorkbook. If you enter a macro (or module-level vari-
able) into a worksheet VBA code module, its scope is limited to that work-
sheet unless you declare it Pub11ic (making it available to the entire project).
If you create a standard or class module, using Pub11ic makes the procedure
available not only to the entire project but also to any outside project that
references the current project.
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UserForms for User Interaction

You can simplify interacting with users by displaying a graphic form to
accept and validate their input. In this example, | walk you through doing
just that. Additionally, in this UserForm, you also want users to periodically
change their password. For more on UserForms, see Book II, Chapter 4.

1. Press Alt+F11 to open the Excel Visual Basic editor and then choose
Insert>UserForm.

An empty UserForm and a Toolbox appear, as shown in Figure 6-1.

22 5] i

B 3 VEAPruject (Boukl)

Figure 6-1:
Interact with
usersvia
this form.

Some people insist on calling this a UserForm object, but I just call it a
UserForm in the interest of brevity and common sense. Because nearly
everything is nowadays called an object — text boxes and even integers —
it seems to add little to the communication to add the essentially meaning-
less term object. You might as well say, “Please fill the birdfeeder thing,
using the scoop thing.” Leaving out thing in this case doesn’t decrease the
information content one bit.

Book IV
2. Press F4. Chapter 6
The Properties window opens, where you can modify the various prop-
erties of any controls that you place on the form or the form’s properties S E
themselves. I added a compelling (some would say cunning) gradient em
background to the UserForm by importing a graphic into its Picture ;, 3
property. % g
P Sometimes the Toolbox disappears for no apparent reason. (There actu- S'm
ally isn’t any good reason why it should; it’s just one of those funny little 28

things.) If it disappears, click the background of the UserForm to make it
reappear.
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Figure 6-2:
Users often
respond
better to
custom
dialog
boxes.

3. Click the UserForm to select it, click Caption in the Properties
window, and then change the default Caption (title bar) property
from UserForm1 to Type in your new password, please ....

You want users to periodically change their password, so you automate
the process by creating a macro under a UserForm that requests this infor-
mation on a regular basis. You can use this technique to get any informa-
tion from the user.

4. Click the TextBox icon in the Toolbox to select it, and then drag your
mouse in the UserForm to place the text box where you want it.

5. Add two command buttons to the UserForm and change their Caption
properties to OK and Cancel, respectively.

6. (Optional) Add a graphic to the background of this form by clicking
the form to select it. Then in the Properties window, click Picture and
then click the ellipsis button (...) to browse your hard drive for a suit-
able background texture, like the cunning gradient I added.

Drag your mouse around the text box and both control buttons to select
all three. Then the Property window displays only those properties that
they have in common. This is a quick way to increase the size of the font
for these objects. (This is usually necessary, given that the default font
size is 8 pt, which is pretty tiny.)

7. Double-click the Font property in the Properties window and change
the size from 8 to 11.

8. Press F5 to see your form.

It should look something like the one in Figure 6-2, but perhaps without
the gorgeous gradient graphic that | added using the Picture property.

| Type in your new password, please ... %]

x|
Cancel |

9. Close your UserForm to return to editor mode.

10. Complete the design of your form by clicking the text box and then
double-clicking PasswordChar in the Properties window.
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11. (Optional) Enter * if you wish to use asterisks as the characters that
are displayed when a password is entered.

I've never quite understood this feature. Is anyone really dumb enough
to type in their password while some office snoop is standing behind
them, watching them type it in? If the snoop is that close, he can just
watch your fingers as your typing reveals which keys on the keyboard
make up your password.

12. Put the code into the buttons’ events and double-click the OK button.
Its C11ick event procedure opens, ready for you to insert code.
13. Enter this:
Private Sub CommandButtonl Click()

'write code here to send password to administrator

MsgBox ("Your password has been entered")
End

End Sub

14. In the Cancel button’s event, type this:
Private Sub CommandButton2_Click()

End

End Sub

You can add lots of additional controls to the Toolbox by right-clicking it and
then choosing Additional Controls.

Adding Macros to Worksheet Controls

\\J

In the preceding example, you display a UserForm with controls to the user.
You can also add controls directly to worksheets if a UserForm seems overkill.
If you need only one or two user-interaction controls, they can just be dropped
right into a worksheet without cluttering it up.

Display a worksheet in Excel and then choose Viewr>Toolbars=>Control
Toolbox. A set of controls similar to the ones in the VB editor Toolbox appears,
as shown in Figure 6-3. (For more on controls, see Book II, Chapter 4.)

In the lower-left corner of the worksheet is Control Toolbox, a special icon
(see Figure 6-3). Click it to add additional controls to the Toolbox.

Book IV
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to Excel _ﬂ
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Click the CommandButton icon in the Toolbox and then drag your mouse on

your worksheet where you want to display the command button. Right-click

the new button on the worksheet and then choose CommandButton Objectw>
Edit. Change the caption on the button to Click Me to Fill.

Click the worksheet to get out of editing mode. Then double-click the button
to get to its code window. Enter the code in Listing 6-1 into the button’s
C1ick event. It will fill this worksheet with data when the user clicks the
CommandButton that you added to the worksheet:

Listing 6-1: Filling a Worksheet by Clicking a Button
Private Sub CommandButtonl_Click()

With ActiveSheet.QueryTables.Add(Connection:=Array( _
"OLEDB;Provider=Microsoft.Jet.0LEDB.4.0;Password="""";User ID=Admin;Data
Source=C:\Northwind.mdb;Mode=Share Deny Write;Extended Propertie" _

ss;"""";Jet OLEDB:System database="""";Jet OLEDB:Registry Path="""";Jet
OLEDB:Database Password="""";Jet OLEDB:Engine Type=5;dJet
OLEDB:Da" _

;tgbase Locking Mode=0;Jet OLEDB:Global Partial Bulk Ops=2;Jet
OLEDB:Global Bulk Transactions=1;Jet OLEDB:New Database
Password=""" _

""".Jet OLEDB:Create System Database=False;Jet OLEDB:Encrypt
Database=False;Jet OLEDB:Don't Copy Locale on Compact=False;Jet
OLEDB"

, ":Compact Without Replica Repair=False;Jet OLEDB:SFP=False"),
Destination:= _

Range("A1"))

.CommandType = x1CmdTable

.CommandText = Array("Products")

.Name = "Northwind Products"
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.FieldNames = True
.RowNumbers False
.FillAdjacentFormulas = False
.PreserveFormatting = True
.RefreshOnFileOpen = False
.BackgroundQuery = True
.RefreshStyle = xIInsertDeleteCells
.SavePassword = False
.SaveData = True
.AdjustColumnWidth = True
.RefreshPeriod = 0
.PreserveColumnInfo = True
.SourceConnectionFile = _
"C:\Documents and Settings\Richard Mansfield\My Documents\My Data
Sources\Northwind Products.odc"
.SourceDataFile = "C:\Northwind.mdb"
.Refresh BackgroundQuery:=False

End With

End Sub

In Listing 6-1, replace the bold line with a path to a Northwind ODC file on
your hard drive:

"C:\Documents and Settings\Richard Mansfield\
My Documents\My Data Sources\Northwind Products.odc"

® The Northwind sample database is supplied with Office 2003 to allow you to
experiment using a realistic MDB (Jet/Access-style) database. Northwind.mdb
should be found on your hard drive in C:\Program files\Microsoft
0ffice\Officell\Samples. However, you might not have it installed or
know where to look for it. Choose Helpr>Sample Databases in Access and then
select Northwind Sample Database. If it’s not there, go to the Windows Control
Panel, choose Add/Remove Programs, find and click Microsoft Office, click the
Change button, and follow the instructions to install the Northwind sample
database.

Now return to the worksheet where your button resides. Click the Exit

Design Mode button on the top of the Toolbox. The Toolbox disappears. Book IV
Now click the button on the sheet, and your sheet should fill with data from
the database.
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Applying Formatting

If you have a favorite formatting scheme — a favorite way of presenting Excel
data using certain fonts, colors, and so on — you can easily write it (or record
it) into a macro and then assign it to a keyboard shortcut, toolbar, or menu.
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Here’s a macro that applies an AutoFormat to all the data in the current
sheet instantly:

Sub FormatIt()
ActiveSheet.UsedRange.Select

Selection.AutoFormat Format:=x1RangeAutoFormatColorl,
Number:=True, Font _
:=True, Alignment:=True, Border:=True, Pattern:=True,
Width:=True

End Sub

Format:=xT1RangeAutoFormatColorl gives you a black/cyan color scheme.
Replace that with Format:=xTRangeAutoFormatColor? for a brown/tan
effect, or otherwise adjust the constants and parameters to get whatever
formatting you prefer.

Adding Controls Programmatically

You can add controls to worksheets via programming. This example adds a
command button to the active sheet and then adjusts its Caption property:

Sub AddButton()

ActiveSheet.0LEObjects.Add ClassType:="Forms.CommandButton.1", _
Left:=120, Top:=100, Height:=20, Width:=100

ActiveSheet.CommandButtonl.Object.Caption = "Click To Fill"

End Sub

If you want to add other controls, use this format to describe their class:
Frame, Forms.Frame.1, Image, Forms.Image.1, Label, Forms.Label.1,
ListBox, Forms.ListBox.1, and so on.

For more on controls, see Book I, Chapter 4.

Trapping Keypresses

In UserForms, you can use the KeyDown event to trap (react to with your own
programming) user keyboard input. This event is available to any control
that’s sensitive to keypresses, such as check boxes, command buttons, forms,
option buttons, and text boxes.
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One use for this technique is to imitate the keyboard shortcuts in Excel that
you can specify when you choose Toolsw>Macro>Record New Macro and then
specify a shortcut key in the Record Macro dialog box. The same kind of key-
press trapping is also available for your UserForms via the KeyDown event, and
KeyDown is more flexible than the technique available in Excel itself.

In addition to creating custom keyboard shortcut “macros” within your
UserForms, you can also use this technique to redefine the keyboard layout
itself. For example, you could trap all Ctrl+C keypresses and then respond by
clearing the text box (TextBox.Text = "").

Another relatively uncommon use for trapping keypresses is to repeat some
behavior based on how long the user holds down a key. For example, in order
for a user to draw a line or border, you allow the user to hold down a key that
repeats a character (like an underline) until the KeyUp event detects that the
user has released the key.

To try this keypress capture technique, first add a TextBox control and then
a UserForm. Then, from the drop-down lists at the top of the UserForm code
window (double-click the TextBox control), locate and click the KeyDown
event for the text box:

Private Sub TextBoxl_KeyDown(ByVal KeyCode As
MSForms.ReturnInteger, ByVal Shift As Integer)

End Sub

The KeyDown and KeyUp events provide you with two variables: KeyCode and
Shift. KeyCode provides a unique number for every key on the keyboard —
even distinguishing between the 3 on the numeric keypad and the 3 in the row
above the alphabetic keys. In this way, you can have your program react to
anything — the arrow keys, the Num Lock key, and so on.

The numeric codes can be located in the VBA Help. Search for keycode con-
stants. You'll also notice a list of constant names (such as VBKeyBack and
VBKeyTab). You should use these descriptive constants in place of the
numeric codes if you wish — the constants are built into VBA.

For example, VBKeyTab is defined as 0x9 (this is an archaic numbering
system known as octal, so you probably want to stick with the named con-
stants), so you can then use the word VBKeyTab in place of 9 when you are
testing for that KeyDown:

If KeyCode = VBKeyTab

or

I
O

If KeyCode

Book IV
Chapter 6
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P The KeyCodes for uppercase and lowercase letters of the alphabet — A and
a, for example — are the same. Also, the normal and shifted digits, such as 3
and #, are the same. To detect a shifted key, use the Shift parameter pro-
vided by the KeyDown events.

The KeyCodes

Table 6-1 shows the KeyCodes used by the KeyDown event.

Table 6-1 KeyCodes Used by the KeyDown Event
Constant Code Key
vbKeyLButton 1 Left mouse button
vbKeyRButton 2 Right mouse button
vbKeyCancel 3 Cancel
vbKeyMButton 4 Middle mouse button
vbKeyBack 8 Backspace
vbKeyTab 9 Tab

vbKeyClear 12 5 on the keypad
vbKeyReturn 13 Enter (both keyboard and keypad)
vbKeyShift 16 Shift
vbKeyControl 17 Ctrl

vbKeyMenu 18 Menu
vbKeyPause 19 Pause
vbKeyCapital 20 Caps Lock
vbKeyEscape 27 Esc
vbKeySpace 32 Spacebar
vbKeyPageUp 33 Pg Up
vbKeyPageDown 34 Pg Dn

vbKeyEnd 35 End

vbKeyHome 36 Home
vbKeylLeft 37 Left arrow (<)
vbKeyUp 38 Up arrow (T)
vbKeyRight 39 Right arrow (—)
vbKeyDown 40 Down arrow ({)
vbKeySelect 4 Select
vbKeyPrint 42 PrintScreen

vbKeyExecute 43 Execute
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Constant Code Key
vbKeySnapshot 44 Snapshot
vbKeyInsert 45 Insert
vbKeyDelete 46 Delete
vbKeyHelp 47 Help
vbKeyNumlock 144 Num Lock
vbKey0 48 0and)
vbKeyl 49 Tand!
vbKey? 50 2and @
vbKey3 51 3and #
vbKey4 52 4and$
vbKey5b 53 5and %
vbKey6 54 6and A
vbKey7 55 7and &
vbKey8 56 8 and * (not keypad *)
vbKey9 57 9and (
vbKeyA 65 A
vbKeyB 66 B
vbKeyC 67 C
vbKeyD 68 D
vbKeyE 69 E
vbKeyF 70 F
vbKeyG 7 G
vbKeyH 72 H
vbKeyl 73 I
vbKeydJ 74 J
vbKeyK 75 K
Book IV
vb Key L 76 L Chapter 6
vbKeyM 77 M
vbKeyN 78 N 55
vbKeyO 79 0 3T
vbKeyP 80 P gz
vbKeyQ 81 Q ga
vbKeyR 8 R &3
vbKeyS 83 S B
vbKeyT 84 T

(continued)
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Table 6-1 (continued)

Constant Code Key
vbKeyU 85 U
vbKeyV 86 v
vbKeyW 87 w
vbKeyX 88 X
vbKeyY 89 Y
vbKeyZ 90 z

The following codes in Table 6-2 for the ten digits occur when the Num Lock

key is on.

Table 6-2 KeyCodes When the Num Lock Key Is On
Constant Code Key
vbKeyNumpadO 96 0
vbKeyNumpadl 97 1
vbKeyNumpad? 98 2
vbKeyNumpad3 99 3
vbKeyNumpad4 100 4
vbKeyNumpad5 101 5
vbKeyNumpad6 102 6
vbKeyNumpad7 103 7
vbKeyNumpad8 104 8
vbKeyNumpad9 105 9
vbKeyMultiply 106 Multiplication sign (¥)
vbKeyAdd 107 Plus sign (+)
vbKeySeparator 108 Enter
vbKeySubtract 109 Minus sign (=)
vbKeyDecimal 110 Decimal point (.)
vbKeyDivide m Division sign (/)
vbKeyF1 112 F1

vbKeyF? 13 F2

vbKeyF3 114 F3

vbKeyF4 115 F4

vbKeyF5 116 F5
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Constant Code Key
vbKeyF6 17 F6
vbKeyF7 118 F7
vbKeyF8 19 F8
vbKeyF9 120 F9
vbKeyF10 121 F10
vbKeyF11 122 F11
vbKeyF12 123 F12
vbKeyF13 124 F13
vbKeyF14 125 F14
vbKeyF15 126 F15
vbKeyF16 127 F16
vbKeyNumlock 144 Num Lock
none 145 Scroll Lock
186 ;and :
187 =and + (same as keypad =)
187 = (keypad)
188 ,and <
189 -and _ (not keypad —)
190 .and >
191 / and ? (not keypad /)
192 “and ~
219 [and{
220 \and =
221 land}
222 "and"
Book IV
Detecting Shift, Alt, and Cerl L
The KeyDown event also lets you determine whether a key is being pressed o
at the same time as the Shift, Alt, or Ctrl key — in other words, a key combi- 3 :,
nation. A typical macro might allow the user to press Ctrl+F, for example, as i 5
an alternative to accessing a menu or pressing a command button to start a 8=
text search within a text box. ERE
25
The parameter name Shift that’s passed to your programming by the 28

KeyDown event tells you the status of the Shift, Alt, and Ctrl keys as follows:
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Shift =1

Shift + Ctrl = 3
Shift + A1t =5

Shift + Ctrl1 + A1t =7
Ctri= 2

Ctr1+ Alt = 6

Alt = 4

So, to determine whether the user is pressing Alt+Shift+F3, use this program-
ming, press F5 to display the UserForm, type some text into the TextBox,
and then press Alt+Shift+F3 to see the trapping work:

Private Sub TextBoxl_KeyDown(ByVal KeyCode As
MSForms.ReturnInteger, ByVal Shift As Integer)

If Shift = 5 And KeyCode = 114 Then
MsgBox ("Trapped")
End If

End Sub

Selecting from a ListBox

If you frequently apply custom formatting styles to your worksheets —
suppose you have four styles that you always seem to use — it’s helpful to
create a personal list box from which you can simply click any of the styles
to apply. This same technique can be used whenever you find yourself fre-
quently choosing between a set of behaviors.

In the VBA editor, choose Insertz>UserForm, put a list box on the form, and
then resize the form so it’s only a bit larger than the list box. Double-click the
ListBox to get to its C11ick event, and then enter this (Listing 6-2).

Listing 6-2: Choosing Custom Formats
Private Sub ListBox1_CTick()

Select Case ListBoxl.ListIndex
Case O

MsgBox ("Case 1")
Case 1

ActiveSheet.UsedRange.Select
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Selection.AutoFormat Format:=x1RangeAutoFormatColor?,
Number:=True, Font _
:=True, Alignment:=True, Border:=True, Pattern:=True,
Width:=True

Case 2

MsgBox ("Case 3")
Case 3

MsgBox ("Case 4")
End Select

End Sub
Replace the message boxes with the formatting you want to apply.

The Case numbers in the preceding example are off by one; for example, the
second case in the code is Case 1. This results from the fact that the first
ListIndex number is 0 (zero), so you have a Case 0. Sure, it’s daft, but you
have to live with it. The first Case should of course be 1, but long ago some-
one decided that programmers will continually create bugs and trip them-
selves up when using indexes because, “Hey! Wouldn't it be weird to call the
firstborn child Boy Zero, and the kid’s third birthday Birthday Number 27"
Programming languages are unnecessarily difficult in this way. By now, so
much legacy programming code exists that contains this wacky numbering
system that it’s probably impossible to rectify this moronic way of counting
in computer programming. Bitter? Moi?

Put code to create the list in your UserForm’s Activate event:

Private Sub UserForm_Activate()
ListBoxl.AddItem ("Red Border")
ListBox1l.AddItem ("Casual Style")
ListBox1.AddItem ("Color {#2")
ListBoxl.AddItem ("Formal Style")

End Sub

Now execute your UserForm by pressing F5 and click an item in the list to see
it work. You can activate the UserForm in any of the usual ways: via a menu
item, a toolbar, or a keyboard shortcut. You could alternatively add a ListBox
control to your worksheet. If you want the UserForm to disappear after you've
finished using it, add this line of code to the ListBox C11ick event:

Me.Hide

Book IV
Chapter 6
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Sending a Workbook via E-mail

To send someone a whole workbook, type this code into a macro:
Sub sendit()
ThisWorkbook.SendMail "richrdmb2@hotmail.com”, "WorkBook for

Rita"
End Sub

The format is
ThisWorkbook.SendMail "EmailAddress", "Subject Line in email"

To send the active workbook, replace ThisWorkbook with

ActiveWorkbook.SendMail

Differentiating Select from Activate

Figure 6-4:
The active
cellisin
the upper
left of the
selection.

You might recall the difference between a selection and a range. (See Book IV,
Chapter 1 for the full discussion if you don’t.) But many people have difficulty
understanding the difference between the Activate and Select methods —
and indeed they appear similar. (Confusingly, you use the Range object’s
Select method to specify and create a selection.)

A range or selection can be, but isn’t necessarily, a single cell. For example
Range("C6").Select

creates a selection comprising this single cell, but
Range("C6:D8").Select

creates a selection of six cells. Thus, a selection6 can be, but isn’t neces-
sarily, a single cell. Specifying a selection that spans multiple cells, results,
however, in a single cell in the upper-left corner of the selection being some-
what different from the others (in this case it’s white, not shaded), as shown
in Figure 6-4.

k2] 14000 boxes x 20 bags 18
3 1124 - 12 oz bottles 19
4 2112 - 550 ml bottles 4000

5| 243 - B oz Jars 22

| 6| 2§36 boxes 21.35

| 2012-8 oz jars 25
g | 721 1b pkys. )|

=L 212-12 oz jars 40
10 £18 - 500 g pkas a7
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Notice the active cell in the upper left. In Word, this is the insertion point —
the location in the document where whatever the user types will appear. Cell
C6 in Figure 6-4, is the active cell. Note: Only one cell can be the active cell at
any given time.

If you want to move the location of the active cell from its default in the
upper left of a newly created selection, you can do it with this code:

Range("C12:D14").Select
Range("D13").Activate

When this code is executed, it results in the selection and active cell shown
in Figure 6-5.

B | C I ] |

| 1 CategoryIC GuantityPernit UnitPrice
2 14000 boxes » 20 bags 13
- . 3 124 - 12 oz bottles 19
Figure 6-5: (4] 2112 - 550 m bottles 4000
Programm- |5 248-6 0z jars 2.
. b | 2 36 boxes 21.35
atlca”y 7 2/12- 8 oz jars 25
3 7121 1b pkgs. =0
mO\_Ie the 9 212-12 02 jars 40
active cell 0] B 16 - 500 g pkgs 57
H (11 812 - 200 mi jars il
by using the 2 F 5
Activate |12 af4000 - 500 g phge. E
4] B2 ky box 8l
method. 15| 7140 - 40000 § pkas .25
16 2/24 - 250 ml bottles 155

\\J

If you use the Activate method to move the active cell beyond the current
selection, the selection itself becomes the same cell as the active cell. The
previous selection is lost.

Unfortunately, the Activate method can be used to specify more than a
single cell. You should avoid using it in this way, though, because it can
cause mystery bugs. Take this example:

Range("B2:D4").Select
Range("C7:D13").Activate

After the first line with the Select command executes, its effects are ignored
when the Activate method obliterates the selection and moves it down to
C7:D13. Always use the Select method when creating a selection involving
multiple cells.

Book IV
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Chapter 1: Access Today

In This Chapter

1~ Discovering Access’s strengths and weaknesses

v Using the new Access 2003 Developer Extensions

v Exploring the Package Wizard and Custom Startup Wizard
v Discovering the Property Scanner add-in

v+ Introducing Smart Tags

Wth Office 2003, Access has reached a new level of sophistication and
efficiency. In this chapter, you see what Access does well and less
well, and also discover some new tools that can make a developer’s life
easier.

Access has been improved in a variety of ways:

4 The ListBox and ComboBox controls can now display four fields in
ascending or descending order for reports and forms.

4+ You can adjust fonts in Query Design, and its Help system has been
upgraded.

<+

Smart Tags can link fields.

4 The Microsoft Data Engine (MSDE) — used for client-server and Internet
program testing on a single machine — has been upgraded to a newer
version, the SQL Server 2000 Desktop Engine.

4+ Improvements have been made to data access pages.
4+ Forms and reports have new methods, properties, and events.
4+ XML features have been either added or improved.

All in all, Microsoft continues to vigorously support Access with each new
version of Office.

Understanding Access’s Limitations

Access cannot do everything. There, | said it. Access, good for home or
small office use, can also be used as a data store for large enterprise solu-
tions (big companies that want to coordinate all their data and program-
ming needs into a single, harmonious system). However, Access cannot be
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the database management tool for enterprise solutions because it’s not scal-
able enough: It can effectively handle only ten simultaneous connections.

A popular Web site — not to mention a large-scale, corporate intranet —
simply grinds Access to a halt by the demands of the traffic that are brought
to bear on Access.

Although you can use MDB files as databases, you cannot use Access as a
database management system if your company wants to handle high traffic.
And most companies at least hope to. (Don’t they?)

For small business users, Access can build quick solutions via its many rapid
application development (RAD) tools, such as wizards that walk you through
various tasks. But if your business requires specialized coding — and many
businesses do — you might find yourself spending quite a bit of time cus-
tomizing via VBA or other programming tools such as VB.NET.

For large businesses, though, you quickly see performance degradation to
unacceptable levels after you have more than 10 concurrent users or more
than around 100,000 records. You can significantly reduce the network load
that a heavily trafficked Access installation can cause by moving query pro-
cessing to the back end (onto a server). When using this approach, Access
itself merely acts as a front end (a user interface, essentially) for a client/server
system; on the server, a more robust application such as Oracle or Microsoft’s
SQL Server handles the heavy duty processing. To the user, it appears that
Access itself is managing the data, performing updates, sending back query
results, and so on. In fact, another database management system (DBMS) is
doing the heavy lifting. The net result of dividing the workload in this way is to
take advantage of Access’s RAD tools and many experienced Access program-
mers while simultaneously scaling up to handle heavy traffic.

If you plan to set up a large-scale client/server system with Access as the
front end (and primary programming environment, via Access Data Project
tools), you can benefit from the Access SQL Server 2000 Desktop Engine. It
comes with Access and allows a developer to build the client/server applica-
tion on a single machine — simulating a client/server installation on one
computer. Then, after the system is built, it can be installed on SQL Server.

Adding Access 2003 Developer Extensions

If you're determined to go beyond Access’s usual capabilities, you’ll be inter-
ested in exploring a couple of new utilities in the Access 2003 Developer
Extensions. You can give this suite of utilities, part of the Visual Studio Tools
for the Microsoft Office System, a test run at this location: http://msdn.
microsoft.com/vstudio/tryit.
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Alas, there’s a delicate interaction between Office 2003, Internet Information Book V
Server (IIS), Visual Studio, and other components used by developers. I use Chapter 1
the term delicate because you have to install these various items in a spe-
cific order or suffer the consequences: That is, things won’t work or won'’t
work as expected.

In case you're interested in these utilities, here is a summary of the Access-
specific tools in the Visual Studios Tools package. I cover the Package Wizard,
the Custom Startup Wizard, and the Property Scanner.

Aepoj ssaosay

The Package Wizard and the Custom Startup Wizard

The Package Wizard assists with deployment of Access systems, offering an
easy way to build a setup installation utility, including automatic inclusion of
dependencies such as the runtime files. Like the other utilities in this pack-
age, you get the source code for the Package Wizard so you can customize it
to your heart’s content. A related tool, the Custom Startup Wizard, allows you
to easily create several different custom MDE files (MDB files stripped of your
proprietary source code) — individualized MDE files for various customers.

The Property Scanner

This utility is like an industrial-strength search-and-replace. You can search
an entire Access database solution globally (all the files) and replace a string
semiautomatically via a list of links where the string appears. Anyone who’s
worked with a large distributed group of interrelated software projects (what
Microsoft calls a solution) will understand how valuable a global search-and-
replace tool could be.

Adding Smart Tags

Access can now link and export data from Windows SharePoint Services via
Smart Tags, which are those small, context-sensitive icons that can be used
in a variety of ways. (See Book VII, Chapter 5 for in-depth coverage of Smart
Tags.) In Access 2003, you can add Smart Tags to any field in any query,
table, form, report, or data access page in your databases. To see how to add
a Smart Tag to a field, follow these steps:

1. Open an Access database and select a table from the list of tables.

2. Choose Viewr>Design View.

3. Click Smart Tags in the General tab of the property box (similar to the
Properties window in other Microsoft applications), as shown in
Figure 1-1.
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4. Click the ellipsis button in the Smart Tags field of the property box.
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5. (Optional) Click the More Smart Tags button to see third-party Smart
Tags that you can purchase.

Your browser opens with a list of various tags. At the time of this writ-
ing, they included utilities allowing you to quickly create labels from
Outlook Contact lists, build custom Smart Tags, and translate text into

various languages.

6. Select the Person Name check box in the list of available Smart Tags.

This tag style is selected. You now see a list of actions that this Smart
Tag is capable of. For a person’s name, the actions are Send Mail, Schedule
a Meeting, Open Contact, and Add to Contacts. These are useful tasks
that a user might well want to have available while working with your
database table.
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7. Click OK. Book V

Chapter 1
The dialog box closes, and a Person Name Smart Tag is now available apter

in the field you assigned it to. In the property box, this specification is
added to the Smart Tag property:

"urn:schemas-microsoft-com:office:smarttagsfPersonName"”
8. Choose Viewr>Datasheet View.

Aepoj ssaosay

Your table is displayed with small, dark-purple triangles added to each
item in the field where Smart Tags are available. In addition, when you
pause your mouse pointer on an item or select an item, an encircled i
appears, symbolizing (perhaps) information — who knows? You can see
this effect in Figure 1-3.

_] Customers : Table =[=[%]
‘Company Name | Cortact First Name | Contact Last Name | Compafiy| @

|| Snedly Bobby Sanders ,

L\Fersa\fisa Fleming DoubleDown r

| Vepp Varla Vepp i

| |MeepeBeepe Saundra Les Butts 4C8T
Figure 1-3:
Smart Tags
always
display a
small /
symbol. Record: (144 ][ 2 [ J[ri]rH] oF 4

9. Click the Smart Tag icon.

The available options for this Smart Tag open in a drop-down list for the
user to select from, as shown in Figure 1-4.
—— Flarning
. Vara 1" Person Hame: DoubleDown
Flglll’e 1-4: Saundra | es :.:nu M:il L
The user Sched;Ie a Masting
can select Dpei Contact
| Add fo Contacts

Smart Tag
options from
this list.
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Exploiting XML support

Of course, XML has invaded Access 2003 just as it has most other areas of
contemporary computing. You can import or export XML schemas (struc-
tures) and data — in other words, both form and content. You can also use
your own custom XSL transforms when bringing data in or out of Access,
manipulating the XML prior to import or export.

Also, the old Access-specific schema that was obligatory in Access 2003 has
been replaced by the newest XSD (schema) standard. This standard is now
accepted as the preferred way to message data between data stores and data
management systems.

It’s generally quite simple to import or export XML-based data in Access
2003. You don’t even need to use an XSD file to import data. If an XSD file is
present, Access uses the structure defined within that file for importing the
data. If no XSD file is present, Access 2003 deduces the incoming data’s
structure automatically and builds the structure for you.

Here’s a simple example. Assume you have an old set of data in a comma-
delimited list. It’s just a long list of names separated by commas and car-
riage returns. You want to transform that list (stored in a Notepad TXT file)
into a new XML file and also have Access generate an associated schema file
(describing the structure of the XML file). You can import the original TXT
file into Access as a table and then export the table as an XML/XSD file pair.

Importing text data
Here is how this works.

1. Open Notepad and create a simple TXT file. Type this data into the file
and save it as c:\data.txt:

Jones, Dottie
Smith, Stan

2. Open an Access database.
You cannot import unless a database is already open in Access.
3. Choose Filer>Get External Data->Import.

4. In the Import dialog box, choose Text Files in the Files of Type list box
and load your data. txt file.

The Import Text Wizard appears, as shown in Figure 1-5. Notice in
Figure 1-5 that this wizard is smart enough to assume that commas
delimit fields and that carriage returns delimit records.

5. Click Next and leave the default Fields Are Separated by Commas
radio button selected.
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6. Click Next and leave the default New Table option selected.
7. Click Next and then click Advanced.

8. Rename the default Field1 to something more meaningful (use
LastName) and rename Field2 to FirstName.

9. Click OK.
10. Click Next and choose No Primary Key (keep this simple).
11. Click Next and type MyTable in the Import to Table text box.

12. Deselect the check box that requests the wizard to analyze your table
(again, keep this simple).
13. Click Finish.

A rather redundant message box appears, telling you that the importing
has been accomplished.

14. Click OK to close that message box.

15. Look in the main database window and double-click your new table
named data.

You can see that a proper Access table has been created out of your
original TXT file’s data.

Exporting XML and XSD files
Take the data from the preceding section and transform it into XML and an
associated schema (XSD) file.

1. Click Tables, and then click to select the table named data in the
main database window.

Book V
Chapter 1

Aepoj ssaosay
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Choose File>Export.
In the Export dialog box, choose XML in the Files of Type list box.
Click the Export button.

In the Export XML dialog box that appears, leave both the XML and
XSD check boxes marked and then click OK.

NI B S

The job is done! You've taken a simple (perhaps a legacy) list of data, trans-
formed it first into an Access database table, and then further transformed it
into the newest XSD (schema) file and an associated XML file. These files can
now be used to communicate with any other XML-aware database manage-
ment system or other software that can understand XML.

The XSD file that you created specifies your table’s structure and looks like
this:

<?xml version="1.0" encoding="UTF-8"7?>

<xsd:schema xmlns:xsd="http://www.w3.0rg/2001/XMLSchema"
xmlns:od="urn:schemas-microsoft-com:officedata">

<{xsd:element name="dataroot">

{xsd:complexType>

<xsd:sequence>

<xsd:element ref="Data" minOccurs="0" maxOccurs="unbounded"/>

<{/xsd:sequence>

{xsd:attribute name="generated" type="xsd:dateTime"/>

</xsd:complexType>

</xsd:element>

{xsd:element name="Data">

{xsd:annotation>

<xsd:appinfo/>

<{/xsd:annotation>

<xsd:complexType>

{xsd:sequence>

{xsd:element name="LastName" minOccurs="0" od:jetType="text"
od:sql1SType="nvarchar">

{xsd:simpleType>

{xsd:restriction base="xsd:string">

{xsd:maxLength value="255"/>

</xsd:restriction>

</xsd:simpleType>

</xsd:element>

{xsd:element name="FirstName" minOccurs="0" od:jetType="text"
0od:sqlSType="nvarchar">

<xsd:simpleType>

{xsd:restriction base="xsd:string">

{xsd:maxLength value="255"/>

</xsd:restriction>

{/xsd:simpleType>

{/xsd:element>

</xsd:sequence>
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</xsd:complexType>
</xsd:element>
</xsd:schema>

By default, if you double-click an XSD file and you have Visual Studio installed,
the XML structure is loaded into a handy schema designer, as you can see in
Figure 1-6.
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LastName
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The actual XML data that you exported from your table looks like this:

<?xml version="1.0" encoding="UTF-8"7?>

<dataroot xmIns:od="urn:schemas-microsoft-com:officedata"
xmins:xsi="http://www.w3.0rg/2001/XMLSchema-
instance"
xsi:noNamespaceSchemalocation="Data.xsd"
generated="2004-04-12T03:07:23">

<Data>

<LastName>Jones</LastName>

<FirstName>Dottie</FirstName>

</Data>

<Data>

<LastName>Smith</LastName>

<FirstName>Stan</FirstName>

</Data>

<{/dataroot>

Using the new desktop server

The venerable testing server — Microsoft Data Engine (MSDE) — has now
been replaced with a new, improved version: SQL Server 2000 Desktop Engine.
Added features include updatable views, linked servers, custom functions,
additional properties supporting such Access capabilities as input masks and
lookup fields, and copy and transfer database features.

Book V
Chapter 1
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MSDE isn’t automatically removed when you install Office 2003, and you can
continue to use it with Access. However, if you want to explore the newest
features available in Access and also keep your prototyping system current,
you likely want to replace MSDE with SQL Server 2000 Desktop Engine.

You can remove MSDE and then install the SQL Server 2000 Desktop Engine
fresh (Microsoft suggests this), but you might want to instead choose the
upgrade option if you’ve done considerable customization work on your
existing system. Perhaps you’ve spent a lot of time customizing permissions
or logon authentication for lots of users or you’ve worked hard to customize
database roles for SQL Server. If so, you will likely want to choose the upgrade
rather than clean install option when moving from MSDE to SQL Server 2000
Desktop Engine.

Using improved data access pages

Data access pages are Access’s way of presenting its data in Web pages.
Although they were introduced in Access 2000, they’ve only now come into
their own in Access 2003. Data access pages are a way for you to efficiently
build Internet or intranet pages that users can interact with easily. They’re effi-
cient for the programmer because the process of creating these pages is now
assisted by a powerful and automated wizard and Page Designer. The resulting
front end is highly scalable, and you can create Web pages that are highly
sophisticated while letting Access do the dirty work of building the HTML.

Major improvements to data access pages include improved deployment,
formatting, and updates to the Page Designer. Multiple Undo and Redo has
been added, along with other features that bring data access pages from
their relatively lame beginnings to what can now be fairly described as a
full-featured form designer.

To see how easily scrollable tables can be dropped into a Web page, follow
these steps:

1. Load the Northwind sample database into Access.

2. Click the Pages icon in the main database window.

You see the first three options relate to data access pages — different
approaches to the same goal:

e Using design view
e Using a wizard
e Editing an existing Web page, as shown in Figure 1-7

3. Double-click Create Data Access Page in Design View, as shown in
Figure 1-7.

Depending on your version of the Northwind sample database, you
might see a warning message. Just ignore it.
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You now see the data access page, a Toolbox, and a list box containing Book V
the tables and queries in your database (ready to be simply dragged and Chapter 1
dropped into the new Web page.)
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4. Click the title section of the data access page and rename it
Northwind Orders, as shown in Figure 1-8.
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5. Drag the Orders table from the Field List dialog box and drop it into
the Web page, stretching the table to make it a bit larger and dragging
it wherever you want to position it in the page.

Your new Web page now looks like the one in Figure 1-8.
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6. To complete the job, just save this Web page as an HTM file by choos-
ing File>Save.

You see the Save as Data Access Page dialog box.

7. Choose a location on the hard drive to save this file and click the Save
button.

You might see a warning message describing how to deal with network
addressing. Ignore it for now.

When you double-click this HMT file that you just saved, it opens in
Internet Explorer (as shown in Figure 1-9), and the user can freely

browse.
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The user can also make modifications to the data displayed in this Web page,
but to accept such modifications — that is, to permit updating of your data-
base by users — you must handle such requests programmatically.

Using augmented forms and reports

Forms and reports both now include a Move method and a Moveable prop-
erty with which you can change the position of forms or controls. New form
events include OnDirty (is it being edited?) for controls and OnUndo for
forms and controls. Reports now have the following properties previously
only available to forms: AutoCenter, AutoResize, BorderStyle,
CloseButton, ControlBox, MinMaxButtons, Modal, and PopUp.
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Also note that the pivot table and pivot chart functionality in Excel was
added to Access 2002. With these features, you can conduct sophisticated
analysis on data in any query, form, table, ADP (Access Data Project) table,
ADP view, ADP stored procedure, or ADP function. Pivot tables are described
in depth in Book IV, Chapter 4.

Although introduced in Access 2000, ADP technology wasn’t quite ready for
prime time. However, now, most agree that ADP is quite a useful set of tools for
creating client/server solutions. ADP files can contain the front-end objects
(Access macros, data access pages, reports, forms, and so on) and then you
connect to a back-end data store that holds the actual data (tables, views, pro-
cedures, and so on). After making this connection, you can use Access’s effi-
cient user interface to manage the tables and other objects stored on the back
end. Build your client-server application on your personal machine using the
SQL Server 2000 Desktop Engine described earlier in this chapter in the sec-
tion, “Using the new desktop server.” Then after building and testing is com-
plete, port your finished client-server project to the SQL Server database.

Book V
Chapter 1
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Chapter 2: Programming Access

In This Chapter

v+ Introducing Access objects

1~ Sorting out database technologies

v+~ Using ODBC

+ Abandoning VBA

v+ Abandoning DAO

v Understanding ActiveX Data Objects (ADO)
1 Managing the concurrency problem

+ Understanding RAD efficiencies

Fis chapter is for those who want to move their database programming
forward, and, moving forward sometimes means leaving something famil-
iar behind. In this case, your experience with DAO (Data Access Objects)
technology — a well-loved, stable system — must be eventually abandoned
in favor of ADO (ActiveX Data Objects). You also need to look past VBA to
VB.NET. This chapter is something of a launching pad, then: sorting out

the current Access object model but also looking forward to other, more
advanced programming technology.

Access differs in many ways from other Office applications, both in its user
interface and its programming technologies and tools. For one thing, Access
programming relies relatively less than other applications on VBA. In Word, for
example, you build solutions largely by using VBA to manipulate the objects
built into Word. With Access, however, two additional technologies — and
their object models and features — become significantly important in your
programming. These technologies are SQL (for creating queries to extract sub-
sets of data from a data store, or sometimes for modifying the data) and ADO
(for database management, scalability, interoperability, and other efficiencies).
Nonetheless, VBA can be the glue that ties the Jet engine’s features, record-
sets, SQL, and other elements together, so I cannot ignore the Access object
model.

Introducing Access Objects

Like other Office 2003 applications, Access’s highest object is the
Application object, which embraces several essential secondary objects:
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Table, Query, Form, Report, and DataAccessPage. In turn, these objects
themselves contain sets of objects.

Because the Application object is generally understood, in many situations,
it doesn’t need to be explicitly named in code when working with other Access
objects. Access also includes the usual collections: Forms, for example, is a
collection containing all currently active forms.

Start Access, choose FilecoNew, and then choose Blank Database from the
task pane. Click the Create button to close the dialog box and accept the
default name for the MDB file.

Press Alt+F11. Choose Insert=>Module. A nearly empty module appears.
Folks from MS (who enjoy enforcing rules on other people) have forced each
new Access module to include a line of code at the top of the module that
they think we should all use. They’'re wrong, but how fun! This line of code
can introduce some bugs into your programming, but, well . . . so what?

Option Compare Database means that when strings are compared, they’re
not compared as you would expect on the binary level (case-sensitive, which
is the normal Visual Basic default) nor on the text level (case-insensitive).
Instead, the comparison is based on the locale (the language used by the
culture) of the database itself.

Because few of us need this type of comparison — and because most pro-
grammers who do work in some cross-cultural, multidatabase environment
surely know by now that they need to insert this line into their code — you
can just erase it. This way, your string comparisons will work as they nor-
mally do in all other versions of BASIC — namely, case-insensitive and based
on the cultural language of the computer system.

Now to ease into the world of ActiveX Data Objects (ADO), Data Access
objects (DAO), Access objects, alphabet soup, and the lovely, busy world of
object-oriented programming (OOP). Here’s an example of OOP in Access:

Set db = CurrentDb

CurrentDb doesn’t sound like the name of a typical method, but it is indeed
a method of the Access App1ication object. It delivers an object variable
of the database type, as techies like to say. In the code above, db is an object
variable containing a reference to the currently open database in Access —
the sample database Northwind, in the upcoming example.

Technically, this object variable contains a hidden reference to the Microsoft
DAO Object Library, but I won’t delve too deeply into useless OOP jargon.
You can use it without knowing all the gory details about its taxonomy, which
are usually only of interest to the people who classified all these things in
the first place.
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The structure of a database can be modified in many ways in your program-
ming. Try this example. It opens the Northwind sample database, adds a new
table to it (complete with four fields), and then closes it.

The Northwind sample database is supplied with Office 2003 to allow you to
experiment using a realistic MDB (Jet/Access-style) database. Northwind.
mdb should be found on your hard drive in C: \Program files\Microsoft
0ffice\0fficell\Samples. However, you might not have it installed or
know where to look for it. Choose Helpr>Sample Databases in Access, and
then select Northwind Sample Database. If it’s not there, go to the Windows
Control Panel, choose Add/Remove Programs, find and click Microsoft Office,
click the Change button, and follow the instructions to install the Northwind
sample database.

Before taking the drastic step of modifying the sample database, make a copy
of Northwind.mdb so that you can restore it to its pristine state after you're
through adding this table. Of course, you could also always get it off the
Office 2003 CD.

Type the contents of Listing 2-1 into the Access VBA code window.

Listing 2-1: Adding a Table and Fields

Sub BuildTable()

Dim dbNorthwind As Database
Dim td As TableDef

Set db = OpenDatabase("C:\Program files\Microsoft
0ffice\0Officell\Samples\Northwind.mdb")
Set td = db.CreateTableDef("Arrests")

With td
" Build the fields:
.Fields.Append .CreateField("Alibi", dbMemo)
.Fields.Append .CreateField("Name", dbText)
.Fields.Append .CreateField("Alias", dbText)
.Fields.Append .CreateField("PrisonerNumber", dbText)

" Append the new table to the database
db.TableDefs.Append td
End With
db.Close

End Sub
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Press F5 to execute this code. Now you've done it! Take a look at what hap-
pened to Northwind. Run Access, locate the Northwind sample database,
and open it.

Look at the tables in Northwind and then double-click the new one: Arrests,
created from the code in Listing 2-1. You see the fields that you created. By
using this same technique, you can add, remove, or otherwise modify tables
and their internal structures.

Understanding Microsoft Database Technologies
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Before continuing with programming examples, draw back a bit to get a
handle on Microsoft’s various database-related initiatives.

Try to get a sense of the meaning of the many database programming terms
and how they’re related. Oh, yes: You must also always consider XML (the
technology that, theoretically, will someday permit universal data access and
messaging), the buried treasure toward which all the other roads — DAO,
Open Database Connectivity (ODBC), and ADO — supposedly lead. XML pack-
ages are supposed to be self-describing, which means that they contain both an
explanation of their structure as well as the data that fills that structure. For
example, when DataSets are translated into XML, they are divided into two
files: the schema (structure) and a separate file that holds the actual data.

Don’t run for the exits just because the subject of contemporary database
programming has some contradictions and is littered with acronyms.
Understanding these variations and acronyms is important. They represent
the yesterday, today, and tomorrow of database management . . . that is, if
Microsoft has anything to say about it. And for the foreseeable future at
least, Microsoft will have something to say about it.

The great Babel

You can store data in databases in thousands of ways. Most useful computer
applications store data, but rarely do they store it the same way as other
applications. They usually do it in peculiar, proprietary ways. For example,
can you use Access to search the e-mail messages in your Microsoft Outlook
Express Inbox database? Not directly.

One problem is the proliferation of structures. Some files are plain text
delimited by commas; others are delimited in other ways. Some files are in
proprietary binary formats; others are encrypted. And on it goes. To give
you an idea of this problem, Outlook 2003 uses the following 36 file exten-
sions: .cfg, .chm, .csv, .dat, .dic, .d11, .ecf, .eco, .exe, .fav, .fdm,
.htm, .html, .dics, .inf, .mdb, .msg, .nk2, .ocx, .oft, .0ss, .ost, .pab,
.pag, .pst, .rhc, .rtf, .srs, .stf, .txt, .vcf, .vcs, .vfb, .wab, .x1s,
.xnk. Think about it.



Understanding Microsoft Database Technologies 3 71

You should (ahem, should) be able to search those files and extract useful
data that can be stored and managed by Access — or indeed, any other data-
base management system. True, you can search some of them; for example,
MDB, TXT, XLS, and some other formats are readily accessible to Access. But
all data files should be understandable, readable, and accessible unless they
need to be encrypted for security reasons. (And even then, encryption isn’t
designed to destroy data but just to temporarily disguise it until it can safely
be decrypted.)

More shoulds. You should be able to add a subset of your e-mail messages to
your company’s customer-service database if you want. You should be able
to store or copy e-mail anywhere, but you can’t. (Access saves data in files
with an . mbd extension, Outlook Express stores e-mail in files with a . dbx
extension, and the twain do not meet. Even Outlook Express itself has differ-
ent database styles — a few years ago it stored your e-mail in MBX files!)

And how about plain TXT files produced by Notepad or other simple (but
often useful) text editors? Why can’t many database applications retrieve
data from these kinds of files? Or from any and all kinds of files?

Data universality is hampered by various current trends, including the
increasing importance of distributed computing and client/server computing.
A primary trend today involves working harmoniously with applications and
data that’s spread across two or more machines. In other words, the Internet
and intranets sometimes extract tables (sometimes as DataSets) from their
database application or fracture an application into several parts running on
several different computers and cause other divisions.

Increasingly, businesspeople are realizing that lots of important information
remains unused or unintegrated because it’s not in the proper format.
Companies establish sites on the Internet and ask visitors for feedback on
their products. More and more, that feedback comes in the form of e-mail.
How many companies can make wide use of the information in that e-mail?
Can they sort it, search it, and otherwise exploit it in an organized fashion?
In other words, can they manage the data and store it for efficient integration
into other data? Very few companies could do these things until ADO.NET
technology arrived. And even fewer could make efficient use of HTML-based
data such as the Web-based catalogs of their competitors. (Companies do like
to check out competitors’ catalogs, you know.)

Understanding Open Database Connectivity

Open Database Connectivity (ODBC) is a Microsoft database standard that is
still widely used. ODBC takes on the burden of translating some proprietary
database formats into formats that database applications can understand.

Simply put, ODBC sits on your machine or a user’s computer (the client) and
translates remote (server) relational databases into data packages that your
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client application can handle. On a fundamental level, your application can
use Structured Query Language (SQL) to query or modify data held in a
remote database without worrying about the details of the remote data-
base’s methods of storing that data (such as punctuation, organization,
delimiting, and labeling).

One useful feature of ODBC is that you can specify ODBC connections.
(Technically, they’re Data Source Names, or DSNs.) You give these connec-
tions a name; then the next time you want to connect to that database, all
the necessary information (password, log-on information, type of database,
and so on) is already filled in, and you can just employ the DSN itself.

However, like many other acronyms you’ve gotten used to over the years,
ODBC is now in the twilight of its useful life. Microsoft has announced its
successors: OLE DB and, finally, ADO.NET. ODBC enables you to get rela-
tional data into a client computer. ADO.NET enables you to get any data
source’s data into a client computer — at least, that’s the promise.

These days, a source of data is increasingly called a data store rather than a
database. This new term is designed to help us broaden our sense of where
useful data can be stored. It need not be in a proper database file; instead,
you can now get data from simple TXT files, e-mail files, streams of data, and
more. In what other job are new terms so rapidly invented and then killed off
by newer jargon? Fashion? Advertising? Hair dressing?

ADO.NET can access data from many kinds of sources. Potential ADO.NET
data stores cover the waterfront, including structured, semistructured, and
unstructured data; relational and nonrelational data; and SQL-based and
non-SQL data. Examples include desktop databases, flat files, mail stores,
directory services, personal information managers (PIMs), multidimensional
stores, and even those elusive OLAP cubes (don’t ask).

Access and the Future of Database Management

Office 2003 developers might need to move beyond the programming capa-
bilities built into the Office suite — namely VBA. VBA served for years as the
best available programming technology for small businesses using Office.
Now, though, with the demands of the Internet, larger intranets, security
issues, and bandwidth conservation, creating robust solutions requires
moving to VB.NET and Visual Studio (the editor and set of programming
tools used by most serious developers).

With Access, you have a tested, effective system for small offices and home
use. Access’s many rapid application development (RAD) tools, such as its
property pages, wizards, and other helpful utilities, are well known and quite
functional on the small office/home level.
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But as your view expands to Internet sales, distributed programming solu-
tions, larger numbers of employees, and more complex Access programming,
you need to expand your programming skills and move to .NET.

Access itself cannot support your needs with its efficient (although limited)
built-in tools. You can still work with the actual Access database files (MDBs),
and perhaps data entry can still be serviceable by using the Access facilities.
Put another way, existing MDB files can sit on the back end, and you can
employ Access to build a user interface on the front end. But other activities —
such as multiple simultaneous Internet connections — can place too great a
burden on Access’s tools.

Access’s performance degrades as you increase the scale of interaction
(ramp up the number of users). In addition, Jet’s (Access’s engine) record-
locking behaviors don’t offer the necessary scalability for modern, enterprise-
large applications. You can relieve this scalability pressure in some ways by
using VBA to buffer user loads and manage security issues. But if you really
want to prepare yourself, your co-workers, and your company for future
needs, my advice is to move on from VBA to VB.NET.

You can download a 60-day trial version of Visual Studio .NET from this site:

http://msdn.microsoft.com/vstudio/productinfo/trial/default.
aspx

That said, take a look at the several technologies relating to database
management.

The recent legacy: Data Access Objects (DAO)

Only a few years ago, the most popular database technology was Microsoft’s
Data Access Objects (DAO). Robust and well-tested, DAO was used by most

database programmers until recently. They understood its object model (its

syntax and how to program its methods and properties).

However, DAO had several weaknesses. It is best at single, desktop computer
database management rather than distributed client/server, Internet, or
intranet database management. In addition, DAO doesn’t like old database
formats — and lots of businesses have stuff stored in legacy formats.

Nor does DAO like new data formats all that much either, such as HTML,
DHTML, e-mail, and plain text. DAO wants relational data — data organized
into tables, fields, indices, and relations. You can’t blame DAO for all this
because it was never designed to do anything other than what it does (and
does splendidly). Nevertheless, the time has come to phase out DAO and
raise the curtain on the new stars of the database world. If your company is
still using DAO, you’re not preparing for the future.
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What solution does Microsoft propose for addressing the shortcomings in
DAO and other schemes? Universal data access through XML. This plan
doesn’t require that you massage data in any extreme ways. You don’t have
to pour e-mail files, a bunch of old DBF dBASE files, and Notepad TXT files
through filters until they end up in a new, all-purpose file type.

Tools that support the XML strategy are designed to package data from its
current format; provide self-describing, plain-text packages; and then send
those packages freely (no firewall blockage) over an intranet or the Internet.
When received, the XML data packages can be absorbed into whatever data
store the receiving party uses. In theory, this approach will let you (the pro-
grammer) send or receive data without worrying about its native format. It
doesn’t matter whether the data comes from or goes into TXT, MDB, DBF, or
DBX files. Microsoft supports XML, of course, and has built the .NET data
storage and messaging systems on XML.

Now, you might be asking, “Isn’t this universal access the same promise that
we’ve been offered so many times before?” What about all the previous
attempts to resolve the Babylon problem, such as the Symphony application
suite offered in the mid-80s as the solution to the confusion of file types and
data storage schemes? And Symphony’s many successors?

Sure, for more than two decades, developers have been playing the universal
data-access tune. XML is simply the latest attempt to offer everything to
everyone in the Web-development crowd.

So, do I believe that XML is a step in the right direction? Yes. And to move
toward XML and the .NET technology, you must begin to explore ADO.NET. If
you work with databases, you should learn how to program ADO.NET. In all
likelihood, it will become the technology of choice for database programming
in the future.

Understanding ActiveX Data Objects

With ActiveX Data Objects (ADO), database programming became somewhat
simpler to write, and new capabilities pointed the way to true distributed
computing.

Consider just a couple of intriguing features of ADO: building recordsets from
scratch (without any database connection) and disconnecting recordsets from
the server. When disconnected, recordsets continue to work fine in your work-
station (client) computer. Just like a worm chopped in half, each part behaves
normally. And later, you can rejoin these recordsets to their original database
or merge them into other databases. This can greatly improve the scalability of
an application because lots of people need not maintain ongoing connections
to the same database, thereby jamming the traffic on a server and taxing the
abilities of aging applications like Access that were never designed to leap and
twirl within the sudden-scaling world of the Internet.
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Instead, users all work independently with disconnected recordsets sitting in
their own personal machines. Recall that Access can effectively handle only
ten simultaneous connections.

Also, when you know how to use ADO, you can use it with virtually any kind
of data: HTML, e-mail, and plain text, as well as traditional relational data
and even legacy data sources.

ADO offers all the features of its ancestors (DAO and RDO), but it requires
some changes in programming techniques. For example, ADO is said to flatten
the object model of DAO and RDO. Flattening means streamlining the model
by reducing the number of objects but increasing the number of properties
and methods of the objects that remain. Flattening also generally lessens the
emphasis on the object hierarchy. Put simply, you can create objects without
having to create other, higher objects. You can create a recordset without
first having to create a Connection object for it, for example.

DataSets replace recordsets

Go deeper into the ADO.NET framework, and you discover various ways to
manipulate and benefit from the new DataSet concept. You'll find many
improvements, including ways to map aliases (make one-to-one substitu-
tions) when, for example, you're using a DataSet from Greece and prefer to
program using English words to name the various columns in the data store.

Note that with the move from ADO to ADO.NET, the ADO recordset has been
replaced by the ADO.NET DataSet.

Some advantages of ADO.NET

The ADO.NET technology has been designed to provide you with as much
flexibility as you might need — and database programming can require flexi-
bility. Above all, remember that ADO.NET supports disconnected DataSets.
The reason is that maintaining a continuously open connection between
client and server is not only wasteful of system resources, it’s often simply
not possible in the world of Internet programming. So many people, so little
power and memory in your server.

What’s more, the typical database can handle only a few concurrent open
connections. That pretty much eliminates old-style connected programming
for any but the least popular Web sites. When you program for the Web, you
must face the fact that 4 visitors to your site can suddenly swell to 400 —
and many of these visitors might want to view your catalog or place an order
at the same time. You hope, anyway.
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Web programming is always essentially disconnected programming. For exam-
ple, when a server sends an ASPNET HTML page to a user’s browser, it dis-
cards its copy of that page. It pays no more attention to the user’s browser
until another request arrives from the user. It’s like the relationship between
the president and hundreds of clamoring reporters.

ADO.NET and ASP.NET (its Internet-programming counterpart) are based on
the premise that you'll often be programming for a disconnected architec-
ture. You permit your application to connect to a database only while fetch-
ing data or saving changed data back to the database. Otherwise, you're not
connected, and the database can therefore service some other request for
data. If your application is designed to work on a single-user, standalone
computer — therefore requiring a continual connection — use ADO instead
of ADO.NET.

Microsoft sometimes now uses the term column to mean what used to be
called a field in a database table. Likewise, MS now uses the term row for
what used to be called a record. This seemingly endless shifting of terminol-
ogy ... well, it’s the way things are. Keeps us all on our toes. IBM is using
this terminology, too. I don’t think it’s going to catch on.

With ADO.NET, after data has been extracted from its data store, the result-
ing set of data (DataSet) is then translated into XML. If you need to store
the DataSet as afile, it’s stored in XML format. If you send the DataSet to
another application, it is transmitted as an XML file. The translation to and
from XML is handled for you automatically by ADO.NET.

In ADO, you were forced to use what is called COM when transmitting a
disconnected recordset, but in ADO.NET, you use the simpler, cleaner XML
stream. Among the benefits of XML is that no data-type conversions are
required. With COM, ADO data types must be converted to COM data types,
slowing things down.

Another advantage is that firewalls generally have no problem permitting
the transmission of XML. (Ordinary HTML, from which XML is derived and
which it resembles, is considered harmless by firewalls.) XML is seen as
text — probably formatting or simple data — with no capability to spread
viruses, inject worms, or otherwise threaten security. A COM transmission,
on the other hand, makes a firewall slam shut because the transmission is
fundamentally a binary — possibly an executable — form of information.
Finally, the XML technology places no restrictions on the data types, unlike
the limited set offered by the older COM technology.

Of course, there is no perfect technology. XML has its critics, too. The number-
one defect is that platform independence — a frequently sought goal — has so
far proved elusive. Already there are thousands of proprietary flavors of the
supposedly universal XML data structure. Also, XML’s claims that it is self-
documenting are doubtful. Because artificial intelligence doesn’t yet exist, the
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notion that a file could arrive at a server and explain itself to a receiving Book V
application — without any human intervention — seems more than a little Chapter 2
far-fetched. There are other criticisms, too, including XML’s famous
verbosity.

g
Nonetheless, here are some reasons for you to consider switching from ADO gé
to ADO.NET, particularly for distributed applications. Although ADO did 85
introduce the concept of the disconnected recordset, ADO is nonetheless 42
optimized for connected programming. ADO fundamentally assumes a a

continuous connection between the database and the application using it.
ADO.NET, on the other hand, is optimized for the opposite: connect-on-
demand programming.

Think of an ADO recordset as essentially a single table. If you want data from
more than one database table, you have to use a JOIN query. The ADO.NET
DataSet is a collection of one or more tables (DataTab1e objects). Therefore,
data extracted from more than one table in a database is represented in the
DataSet as more than one DataTab]le object. This is easier to visualize
because there is essentially a one-to-one relationship between the structures
in the database and the DataTab1e objects in the DataSet.

Working with the DataSet Object

Like objects everywhere, the DataSet class offers collections and proper-
ties. You need to understand the structure of the DataSet object to work
with ADO.

Collections within collections

The DataSet has two primary collections: TabTes and Relations. Lower

in the hierarchy are several collections within the DataTab1e object: rows,
columns, keys, childrelations, and parentrelations. The DataRow class
includes a RowState property indicating whether and how the row (record)
has been modified since its DataTab1e was first loaded from the database.
The RowState property can be set to modified, new, deleted, and unchanged.

Substituting names (mapping)

When you first load the data from a database into a DataSet, the names of
the tables and columns in the DataSet are the same as those used in the
database or data store. If you prefer to use different names while working
with the DataSet, just create your new names in the DataSet command and
then map your names to the ones used in the original database. Both the
0TeDbCommand and Sq1Command use their TableMappings collections to
map custom names to database names. When you return the data to the
database, all will be well: Any edited data will flow into the correct columns
and tables as named originally in their database.
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Why would you want to map or rename tables and columns? Perhaps the
database is written in a foreign language, and you find it easier to work with
mapped aliases rather than foreign words. Or maybe you have an in-house
naming scheme for your databases but are working with DataSets from
some other organization. You want to maintain the custom naming scheme
in your programming. So map.

What If Someone Else Modifies
the Database in the Meantime?

While your DataSet is been disconnected from its database, someone might
have also been working with some or all of that data in his or her separate
DataSet. Maybe the person modified some of that same data and updated
the database by restoring the contents of the DataSet to the database. What
if the person edited a record that you also edited? Should you overwrite the
other person’s changes with your changes? Or vice versa?

Unfortunately, the ADO.NET DataSet commands cannot handle this prob-
lem automatically, but what technology can? The DataSet — like all other
contemporary computing — is not artificially intelligent, after all. ADO.NET
will not automatically lock a record in the database and then warn others
that the record is being edited and that they must wait . . . and then solve
the version problem that arises when multiple, duplicate DataSets compete
for inclusion in the database update process.

It’s up to you to write programming to solve a potential problem when new
versions of a record conflict. If this is a possible problem for the database
you’re working with, you have to find a solution and write the source code
for that solution yourself. What’s more, if the database you’re working with
could have a problem with conflicting records, you have to find a solution
and write the source code for that solution yourself.

The problem of two or more users in conflict during their attempts to flush
back disconnected data into a database is the problem of concurrency or
the version problem. When two or more users try to update a given record,
should the changes made by the last person to update that record win?

Optimism versus pessimism

You can approach the concurrency problem in two fundamental ways: opti-
mistic concurrency and pessimistic concurrency.

4+ Optimistic concurrency: This prevents outsiders from changing a
record (row) only while another person is updating that record. The
updating usually takes very little time, so the lockout is brief.
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4+ Pessimistic concurrency: By contrast, this locks out others for a longer
time. The lock starts when one user accesses a record (which that user
might potentially edit or delete) and is in effect until the original user
sends the record back to the database. (This is similar to the older style
of database programming that maintained an open connection between
an application and a database.)

Optimism

Optimistic concurrency locks a record only briefly, during the save to a hard
drive. This prevents a nasty collision if two different records are simultane-
ously sent to the same record location in a database.

When a user attempts to update a record under optimistic concurrency, the
updated data is compared with the existing record in the database. If there is
any difference between them, the update is rejected. An exception is raised:
An error message is generated. You (the programmer) must handle such
errors in ADO.NET. You must write programming that responds to this type
of error (using the Try-Catch error handling system in VB.NET) and decide
what to do about the changed record. Do you accept it? Or do you have
some criteria that can reconcile a data clash?

One version of optimistic concurrency is last-in wins. This version doesn’t
compare the updated record with the original record. It merely lets each new
update replace the previous version of the record. The last-in wins approach
is the most scalable approach that you can employ.

Pessimism

Pessimistic concurrency is useful if you need to freeze a record while making
arrangements for a customer. For example, if an Amtrak agent is talking to
someone about booking a sleeping car room on the train for a popular holi-
day, pessimistic locking will prevent two agents in two different stations
from contending for the same room, thereby angering a customer. In that
type of situation, you want to lock the record for that room until the first
customer makes up his mind and either reserves that room or not.

The problem is that when you’re using a DataSet, you can’t use pessimistic
concurrency. It’s not practical in a disconnected architecture, and it’s not
scalable for the same reason that maintaining an open connection between
an application and a DataSet isn’t scalable.

Comparing versions with optimistic concurrency

When deciding which record gets saved, classic optimistic concurrency
compares versions by checking their version number (or, in some cases,
their time and date stamps) or by saving all the values (all the data in the
DataSet is saved when the data is initially read).
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If the version number approach is used, each record must have a version
number (or datestamp) column. This special column is saved on the client
computer when the record is first read. Then if that client has modified a
record, the database is checked to see whether the stored version number
matches the version number currently in the database. If they match, it
proves that no other person has modified that record since it was “checked
out” for use by the client. Therefore, it is safe to update the record with the
client’s edited version. You can use an SQL statement like the following to
conduct this test:

UPDATE myTable SET Fieldl = ChangedValuel, Field2 =
ChangedValue?2
WHERE ClientStoredStamp = OriginalStampInDatabase

If this SQL is attempted but the C1ientStoredStamp doesn’t equal the
OriginalStampInDatabase, an error is returned, and you can write program-
ming to make a decision about what to do. (You could store the client’s editing
and thereby replace the current record, extract the current record to compare
it with the client’s edited record, or save both versions and ask a human to
make the decision.) It’s also your responsibility to write the programming that
updates the version or datetime column whenever a record is modified.

The other approach to managing optimistic concurrency is to save a copy of
arecord when it is first read. This means that your DataSet will have two
copies of any record that is read: the one from the database and the one that
the user modified. By using this approach, when the user attempts to update
arecord, the original version that came from the database is compared with
whatever is now in that database. If they match, there’s no problem. It proves
that no one messed with the record while it’s been “checked out” of your
DataSet, so you can go ahead and save the updated version (containing the
user’s modifications) to the database without worrying about overwriting
someone else’s work.

Every DataSet command includes four parameter collections, one for each
of the four commands: Select, Update, Insert, and Delete. Each param-
eter corresponds to a placeholder (? in an SQL statement) in the command
text. The properties of a parameter specify both the column that the param-
eter is associated with and whether the parameter represents the edited ver-
sion or the original version. These parameter collections make it possible for
the DataSet command to generate dynamic SQL (or provide parameters to a
stored procedure).

Getting Results in Seven Easy Steps

(Drum roll, please) I now conclude this chapter with a demonstration of
some of the RAD features available to VB.NET. By progressing beyond VBA to
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manage database-related programming with .NET, you're not giving up wizards,
add-ons, or other features that can assist you in quickly moving from need to
solution.

This next example demonstrates how quickly you can connect to a server data-
base (Northwind, to be precise) with VB.NET’s RAD tools. No human hands will
write any programming! Yet, in seven quick steps, you’ll watch as a big Access

table of data travels from its server database and is displayed in a client grid
before your very eyes. You'll be slap speechless! Just seven quick steps!

I end this chapter by showing you how much VB.NET can do to help you
with your Access database programming. In the following example, you see
VB.NET make a connection, define a query, access the data, and preview the
DataSet it created:

1. After starting a new VB.NET Windows-style project, open Server
Explorer in Visual Studio, as shown in Figure 2-1.
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You can do lots of things with Server Explorer, including adding, editing,
and deleting tables and columns. You can even create a new database!

2. Drag a table (Orders for this example) and just drop it onto the
VB.NET form, as shown in Figure 2-2.

As soon as the Orders table is dropped onto the form, a Connection
control and a DataAdapter control are automatically added to the proj-
ect. They are placed in the tray below the form.

3. To create a DataSet that contains the Orders table, right-click the
SqlDataAdapterl icon in the tray and then choose Generate Dataset
from the context menu that appears, as shown in Figure 2-3.
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Figure 2-2:
Adding
tables from
an SQL
database is
as easy as
dragging
and
dropping.

Figure 2-3:
AData-
Adapter
can
generate

as many
DataSets
as you want.

Configure Data Adapter...

Generate Dataset...

Preview Data...

& Cut
25 Copy

Pasta
Delete

Properties




Figure 2-4:
Use this
dialog to
name a new
DataSet
(or modify
an existing
one).
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The Generate Dataset dialog box appears.

4. Your only job is to give this new DataSet a name.

Name it Maxie, as shown in Figure 2-4.

Generate Dataset %

Geperate a dataset that includes the specified tables,
Choose a dataset:

" Existing | =

% New: lMaxi@l

Choose which table(s) to add to the dataset:

[ Orders (Salbatatdzpter])

[ fdd this dataset ba the designer.

(=74 I Carcel Help

5. Click OK.

The new DataSet appears in the tray, as you can see in Figure 2-5.Your
new DataSet was created courtesy of the DataAdapter control.

6. Right-click the SqlDataAdapter1 icon again, but this time, choose
Preview Data from its context menu.

The Data Adapter Preview utility opens.

7. Click the Fill DataSet button.
All the data in the Orders table rolls into view, as you can see in Fig-
ure 2-6. That didn’t take long, did it?

[ believe that after you've used them a little, you’ll come to consider the
VB.NET DataSet your friend.

Book V
Chapter 2

$S399Yy
fulwweiboid



3 8 4 Getting Results in Seven Easy Steps

Figure 2-5:
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Maxie1
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the tray.
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Chapter 3: Manipulating Datasets

In This Chapter

+ Loading an Access database into .NET
v~ Filtering queries with Select

+* Working with the DataView object

v Creating relations

v+ Communicating with a database

v Using the XML Designer

v Saving an XML dataset

+ Loading XML into Access

A fter tables get liberated from the usual restraints and proprietary restric-
tions within databases — after they’re flying free as datasets — the sky’s
the limit. In this chapter, you see how to import a table or tables from an
Access database into a VB.NET dataset, how to manipulate datasets every
which way, and then how to send a dataset back into Access. The aging VBA
language still built into Office applications comes nowhere close to VB.NET
when free data management is concerned.

The techniques that I describe in this chapter, however, show you a way to
retain your investment in Access. You can use it as a front end for user-
interaction with a data store or even add Access databases to other back-
end data. And of course, XML will often be the technology of choice when
communicating between front ends, back ends, or any other ends.

Loading Access Tables into UB.NET Projects

Many offices use Access to both store data as well as to provide a way for
users to view or update that data. However, Access isn’t scalable enough by
itself to manage data for large, enterprise systems. One approach to bring-
ing Access into the world of distributed systems and Internet programming
is to integrate Access databases and the Access user interface with .NET
technologies. .NET is designed to be used with XML, to be Internet-ready,
and to permit highly scalable solutions. For these reasons, you want to con-
sider preparing for your company’s future by finding out how to tie Access
into .NET — how to send data stored in Access, for example, to a VB.NET
project. To see how to import data from an Access (MDB) database into a
VB.NET project, follow these steps:
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o=

10.

11.

12.

13.

14.
15.

16.
17.

Start a new VB.NET Windows project.

Add a DataGrid control from the Toolbox (Windows Forms tab) to
Forml.

Choose Viewr>Server Explorer.

Server Explorer appears, with a list of all your data connections. (Read
more about Server Explorer in Book V, Chapter 1.)

Right-click Data Connections in the Explorer.
Choose Add Connection from the context menu that opens.

In the Data Link Properties dialog box that opens, click the
Provider tab.

Choose Microsoft Jet 4.0 OLE DB Provider.

Click Next.

Click the ellipsis button next to Select or Enter a Database Name.
The Select Access Database dialog box opens.

Locate the Northwind.mdb sample database on your hard drive.

If it wasn’t installed when you installed Office 2003, use Control Panel’s
Add/Remove Programs utility to install the samples from the Office CDs.

Double-click Northwind.mdb.

The Select Access Database dialog box closes.

Click Test Connection.

You should have no trouble passing this test.

Click OK to close the Data Link Properties dialog box.

Your new connection is displayed within Server Explorer, ready to
be dropped into any form that you want to connect to this Access
database.

Drag and drop this new ACCESS connection onto Form]1.
Click the Don’t Include Password button.

The Do You Want to Include the Password in the Connection String
dialog box closes, and a new OleDbConnectionl icon appears in your
tray.

Close Server Explorer.

Double-click the OleDbDataAdapter icon in the Toolbox (Data tab) to
add it to the form.

The Data Adapter Configuration Wizard appears, ready for you to define
which tables — and which fields — should be used to build your new
disconnected dataset from the original Access database.



Figure 3-1:
Building
SQL queries
was never
this easy.

18.

19.

20.
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Click Next.

Your connection is automatically listed.

Click Next again.

SQL statements are selected (that, too, is what you want to use).
Click Next and then click the Query Builder button.

This opens the automated SQL Query utility, which is similar to Access’s
various query tools, such as the Simple Query Wizard or Expression
Builder. You might find the .NET Query Builder easier to use, though,
because there’s no need to switch between design view and SQL view
like there is in Access.

21. Double-click Customers to add that table to the new dataset.
22. Click Close.
Your Query Builder should now look like the one in Figure 3-1.
Query Builder
B Orders =] e
L_I* (all Columns) o G Calumes) be
| |address || CustomerI
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[ty [ |Freight
| Icountry w| |_|orderDate v
™
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|ne
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SELECT
FROM {Employees INNER, 301N
Orders ON Employees, EmployeelD = Orders. EmployesID}
| | [ a
| |%
< |i»
|

23.

Select the fields from this table that you want to include in the
dataset. For the heck of it, select All Columns.

Columns is the latest fad term for fields. Sure, it’s been used by IBM and
some others for years, but only recently has Microsoft been trying it on
for size. Time will tell whether it sticks.

Notice that the SQL statement is automatically adjusted from this:

SELECT
FROM Customers
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To this:
SELECT Customers.*
FROM Customers

24. Click OK to close the Query Builder.
25. Click Next and then click Finish.

Generating a Dataset for an Imported Database

After you define a connection and specify the database contents that you
want to import (in the preceding steps), you can generate a dataset for your
VB project. In the preceding section, you can read how to specify a connec-
tion to the Access database, including an SQL statement that requests the
Customers table from that database. Now that things are set up, you can do
the actual work. You pull the data from the database and store it in a brand
new dataset. The dataset is a detached table of data that can now be manip-
ulated by the VB.NET application you're writing. It can be transmitted via
XML, stored in other formats, filtered, or whatever your heart desires.
Follow these steps:

1.

Right-click the OleDbDataAdapter] icon in the tray.
A context menu appears.

Choose Generate Dataset.

The Generate Dataset dialog box opens.

Name your new dataset dsCustomers.

Click OK.

The dialog box closes, and the new dataset’s icon is added to the tray.
Now you want to bind the DataGrid control to this dataset so that data
will fill it when the VB.NET project executes.

Click the DataGrid to select it.

. Press F4 to display the Properties window.

Click the DataSource property in the Properties window.
A down-arrow button appears.

Click the button to drop the list down — it’s like a list box.
Click dsCustomers1.Customers to select the dataset.

The dataset is now bound to the grid control. Notice that the fields are
displayed along the top of the grid control in the form.



Figure 3-2:
There itis,
your Access
database
moved into
a VB.NET
project,
displayed
and ready to
be manipu-
lated.
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The wizard’s work is now over. You have to do a bit of programming (very
little, calm down) to actually fill the dataset when your project executes.
Double-click the form and type this into your Form_Load event:

Private Sub Forml_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Lload

0leDbDataAdapterl.Fill1(DsCustomersl)

End Sub

Press F5 to see the results displayed in Figure 3-2.
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Case Study: Maintaining Alphabetical Order

\\J

So far, so good. Now for some manipulation — demonstrations illustrating
the ways you can manage datasets — starting with figuring out how to alpha-
betize them.

Purists insist that relational data should not be maintained in alphabetical
order. Well, those of us who design database solutions for actual living
people here on planet Earth know that although data might not need to be
maintained that way inside the database, it often has to be displayed in
alphabetical order to users.
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.NET Arrays, ArraylLists, DataViews, and DataTables are all objects that
have a built-in sorting method. Oddly, DataSet object does not. You can, of
course, specify that a particular column be indexed (and if it’s a primary key
column, its values are forced to be unique). However, although indexing a
column makes searching more efficient, it does not maintain the rows in
alphabetical order.

Precisely how indexing works varies among the different database types.
Typically, databases include a primary key (also known as a primary key
index). Some databases also feature a clustered index in which the rows are
maintained in the same order as the index. In other words, when you add a
new record, it is inserted into its alphabetical location within the set of exist-
ing rows rather than simply appended to the set. This kind of indexing is not
available, however, to DataSets.

When you first create an SQL query to extract a DataSet from a database,
you can specify that the result be ordered (alphabetized) in a particular

way (ascending or, more rarely, descending). You can also specify that the
DataSet be ordered by whatever column you want. Imagine a database table
that works like a cookbook, filled with recipe titles in one field and recipe
instructions in a second field. You could order this table alphabetically by
recipe title column in a recipe database, for example.

This is all well and good, but what happens after the DataSet gets into the
user’s computer, and the user starts adding new rows of information? There’s
the problem. Each new row is not inserted alphabetically. If you permit the
user to go to the next or previous row by clicking buttons to maneuver
through the DataSet, or if you display the entire list of titles (for example,

in a list box), some of the rows (at the bottom of the list box) will be out of
alphabetical order. That’s bad. You have to figure out a way around that prob-
lem. You want your DataSet to always be in alphabetical order, even when
the user adds a new record or changes a title so that the recipe must now be
listed elsewhere in the alphabetized list.

Providing an ordered list is such a common user-interface issue that it’s sur-
prising that the DataSet doesn’t have a sort method.

Your first thought might be to just set a list box’s Sorted property to True.
That way, when you display all the titles, they are displayed in alphabetical
order. True, but it doesn’t solve the following two problems:

4+ When users add some recipes to the recipe database and then click the
Next button to move up to the end of the rows, they go past recipes
titled X, Y, and Z and find a mixture of S, R, A, Q, N, or whatever. (The
added recipes are just sitting at the end, appended in no particular
order.) The list box’s Sorted property does not alphabetize items as
they are browsed by the Next button.
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4+ The order of the titles displayed in the list box gets out of sync with the Book V
recipes column. For example, if the user clicks the third title in the list Chapter 3
box, it might or might not represent the third record in the DataSet. Why?
Because perhaps the user has added a new row, and its title begins with A.
That record shows up at the beginning (top) of the list box and bumps all
lower titles down one in the list box (but not in the DataSet table). When
users click in the list box, they expect to see the recipe for that title dis-
played in a text box. How do you, the programmer, figure out which row
in the DataSet to display? You can’t use the SelectedIndex property of
the list box: It tells you which title the user clicked but not which row in
the DataSet to display. The SelectedIndex number doesn’t necessarily
sync with the DataSet item number (Tables(0).Rows(i).Item(1)).
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Of the several ways to deal with this, you could search the DataSet for the
title that matches the one the user clicked and then display the recipe. As long
as the title column contains unique entries (is a primary key), this works.

You can choose from two approaches to query and sort the records in a
DataSet: the Select method and the DataView object. These two tech-
niques are worth knowing about because sorting and searching are quite
common database-related jobs. However, as you see, they don’t solve the
problem outlined in the preceding paragraphs. They do not permit you a
way of sorting the DataSet itself.

I suspect that in the drive toward scalability (another word for one-size-fits-all),
some features that are useful to small- or medium-size applications have been
left out. Clearly, a huge database with 10,000 records isn’t going to be inter-
acted with by clicking Next and Previous buttons. Nor is it practical to display
a huge list box with 10,000 titles. There are other, better ways to interact with
monster databases. However, many of us work with smaller projects, such as a
small office’s inventory or personnel file. Creating utilities on this scale with a
DataSet becomes problematic when you attempt to use a DataSet and find
you can’t sort it. However, probably the best solution is to simply search on
your primary key field for a match to the string that the user clicked in the list
box. This doesn’t solve the Next and Previous button navigation method,
though.

Filtering with Select

When you use the Select method of the DataTable object to get a list of
data, the process is filtering. This is essentially the same process as query-
ing, when you use SQL to extract a subset of the data in a database. In effect,
you say something like, “Give me a list, ordered by age, of all the kids on the
swim team who are still in the Minnows class.” This process involves both
searching and sorting simultaneously. Explaining SQL is beyond the scope of
this book, but there are lots of other lovely books that just spend all their
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time on it. | recommend SQL For Dummies, 5th Edition by Allen G. Taylor
(Wiley).

To experiment with the Select method, start a new VB.NET Windows-style
project and add a ListBox to the form. In this example, I build a dataset
from scratch rather than importing one from an Access database or some
other outside source.

Type these Imports statements at the very top of the code window:

Imports System.Data

Imports System.Data.01eDb
Imports System.Data.SqlClient
Imports System.Data.SqlTypes
Imports System.Data.SqlDbType

You don’t need them all, but what the heck. Why fiddle around? Just dump
them in. Now type these declarations just above the Private Sub
Form_Load line:

Dim ds As New DataSet(), dr As DataRow, dt As DataTable

Used to create a new table, and an array of DataRow objects
Dim newRows() As DataRow
Dim newTable As DataTable

The newRows and newTab1e objects are used in later examples in this chapter.

In the Form_Load event, you define the schema of a DataSet and populate it
with some rows of names. For simplicity, in this example, you use the same
schema as in the example in the previous chapter. However, you let the com-
puter generate a list of 30 rows that you can experiment with. Type the fol-
lowing code (Listing 3-1) into the Form_Load event:

Listing 3-1: Filling a Dataset

Private Sub Forml_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Lload

'"define the dataset:

dt = New DataTable("Recipes")
dt.Columns.Add("title", GetType(String))
dt.Columns.Add("desc", GetType(String))

Dim colArray(1l) As DataColumn
colArray(0) = dt.Columns("title")
dt.PrimaryKey = colArray
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ds.Tables.Add(dt)

'create 30 random titles and descriptions, and add
them to the DataSet:
makeupnames ()

"display the random title and description columns in
the Tistbox
Dim i As Integer, n As String
For i = 0 To dt.Rows.Count - 1
n = ds.Tables(0).Rows(i).Item(0) & "..." &
ds.Tables(0).Rows(i).Item(1)
ListBoxl.Items.Add(n)
Next i

End Sub

Just below the End Sub that ends the Form_Load event, add this next sub-
routine, which makes up 30 fake, random titles and recipes and adds them to
the DataSet. They are out of alphabetical order. (They’re just random non-
sense until you later alphabetize them by using the Select method.) Type in
this Sub (Listing 3-2) below the Form_Load procedure’s End Sub, just above
the End Class:

Listing 3-2: Making Up Fake Names

Sub makeupnames ()
'create fake names
Dim rndGenerator As New System.Random(1)
Dim i, j, x As Integer
Dim word As String

For i =1 To 30

For j 1 To 12
X rndGenerator.Next(97, 123) 'limit it to
lowercase letters
word += Chr(x) 'add a character (from the
ASCII code value) to the word
Next

dr = dt.NewRow()
dr!title = Microsoft.VisualBasic.lLeft
(word.ToUpper, 6) 'make the titles uppercase to
distinguish them
dr!desc = Microsoft.VisualBasic.Right(word, 6)
dt.Rows.Add(dr)
word = ""
Next

End Sub

Book V
Chapter 3

sjasejeq
Bunendiuepy



3 94 Filtering with Select

Notice that by seeding the random number generator with an integer in the
first line of code — (1) in this example — you force it to provide the same list
of random names each time the program runs. I chose this approach so that
you can repeatedly test various aspects of these examples and tell at a glance
how the records have been selected or ordered. Don’t seed the generator if
you want varying lists of random names. Now press F5 to see your DataSet
titles column displayed. Notice that they are not in alphabetical order.

Alphabetizing with Select

In this next example, you alphabetize the list by creating a new array (of
DataRow objects) and by specifying that the Select method should order
them alphabetically (which is the default behavior of the Select method).

Add a button control to the form and change its Text property to Order by

Select. Double-click the button and type this (Listing 3-3) into its C11ick
event:

Listing 3-3: Alphabetizing

Private Sub Buttonl_Click(ByVal sender As System.Object,
ByVal e As System.EventArgs) Handles Buttonl.Click

Dim i As Integer
ListBoxl.Items.Clear()
' Create a new table, and an array of DataRow objects

Dim newRows() As DataRow

Dim newTable As DataTable

Dim n As String

' Get the DataTable of a DataSet.
newTable = ds.Tables("Recipes")

newRows = newTable.Select()

Display the values in both columns of each DataRow.
For i = 0 To newRows.GetUpperBound(0)
n = newRows(i)("Title") & "..." &
newRows (i) ("Desc")
ListBoxl.Items.Add(n)
Next i

End Sub

Press F5 and click the button. The titles are now alphabetized within the list
box, as shown in Figure 3-3.



Figure 3-3:
A sorted list
created by
the Select
method.
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Interestingly, in this array of DataRows (newRows), the Titles and Desc
columns remain synchronized. This is what you wanted to happen to your
DataSet, but you had to create a new array and use the Select method of
the DataTable to accomplish it. The DataSet doesn’t have a Select
method nor any other way of sorting itself.

One is sorted, the other isn’t

Even after creating this new array, notice that the DataSet itself isn’t
alphabetized — just the new array. As you see in a moment, to alphabetize
the DataSet, you can try to replace the rows in the DataSet by deleting the
current DataSet’s rows and then dumping this newRows array into the
DataSet. That sorts the DataSet, albeit in a rather roundabout way.

However, if you do try to replace the existing DataRows with the new array,
you run into all kinds of permissions problems: The primary key row already
exists and can’t be duplicated, Row doesn’t exist, and Column Title doesn’t
allow nulls. Here is a way (Listing 3-4) to replace the rows in the DataSet
with the rows in the array without offending the security squad:
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Listing 3-4: Replacing DataSet Rows

Private Sub ButtonZ2_Click(ByVal sender As System.0Object,
ByVal e As System.EventArgs) Handles Button2.Click
Dim i As Integer
Dim newRows() As DataRow
Dim newTable As DataTable
Dim n As String

ListBoxl.Items.Clear()
newTable = ds.Tables(0).Copy()
ds.Tables(0).Rows.Clear()
newRows = newTable.Select()

For i = 0 To newRows.GetUpperBound(0)
ds.Tables(0).ImportRow(newRows(i))
Next

For i 0 To dt.Rows.Count - 1
n ds.Tables(0).Rows(i).Item(0) & "..." &
ds.Tables(0).Rows(i).Item(1)
ListBoxl.Items.Add(n)
Next i
End Sub

The overloaded Select method

When you use the Select method with no parameters (just empty parenthe-
ses), it automatically puts the result in alphabetical order by the primary key
field. In this example, you specify that the Titles column is the primary key
field. So you can simply use the no-parameter form to get the results you
want:

newRows = newTable.Select()

However, three other forms of this method can be used, which means that it
is overloaded. The arguments that you provide to this method determine
how it behaves. You can specify a Criterion, which is an SQL-like string
that defines how you want the rows to be filtered (queried). Here’s an exam-
ple that doesn’t display any titles starting with A through E:

"find all rows matching the filter: (greater than F
in the alphabet)

Dim Criterion = "Title > '"F""

newRows = newTable.Select(Criterion)

This result is still sorted because the Title column is the primary key, but no
rows beginning with letters lower than F in the alphabet are placed into the
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newRows array. The list of possible expressions (filters or criteria) is exten-
sive and involves various special characters and punctuation rules. To see
how to define a criterion to use with the Select method, open VB.NET’s
Help feature (choose Help=>Index). Type DataColumn.Expression into the
Look For text box, and then double-click the DataColumn.Expression prop-
erty in the left pane of the Help window.

Yet another variation of the Select method permits sorting in descending
order (backward from Z to A). The final Select method enables you to spec-
ify that only rows matching a particular DataViewRowState property are to
be placed into the array. DataViewRowState includes Added, Modified,
Deleted, Unchanged, and so on.

Which version is it?

To see the current version of the DataTable — as opposed to the original
version that was loaded into the DataSet at the start — use code like this:

dv.RowStateFilter=DataViewRowState.Deleted

You can also test the status of individual rows in a DataTable by querying
the RowState property. The following results are returned on these various
rows when you run this code: Detached, Added, Unchanged, Modified,
Deleted.

Dim dTable As New DataTable("dTable")

Dim dCol As New DataColumn("Title",
Type.GetType("System.String"))

dTable.Columns.Add(dCol)

Dim dRow As DataRow

' Make a new DataRow.
dRow = dTable.NewRow()
Console.WritelLine(dRow.RowState.ToString())

dTable.Rows.Add(dRow)
Console.WritelLine(dRow.RowState.ToString())

dRow("Title") = "Moby Dick" 'edit the row
Console.WritelLine(dRow.RowState.ToString())

dTable.AcceptChanges() "this makes the rowstate
"unchanged"
Console.WritelLine(dRow.RowState.ToString())

dRow.Delete()
Console.WritelLine(dRow.RowState.ToString())
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S

In VB.NET, Console.Writeline is a common way of testing code when you
want to print out and see some results. It prints to the Output window,
which you can view by choosing Viewr>Other Windows=>Output, and then
selecting the Debug variation in the drop-down list in the Output window.

When using the Select method, you can set the third parameter to specify
which version of the rows you want to see, as in this pseudocode example.
(Pseudocode uses descriptive names to illustrate the elements of source
code, but the code isn’t actually runnable.)

newRows = newTable.Select(filter expression, sort mode,
DatalViewRowState)

You have to replace the italicized parameters in the preceding sample line
of code with actual VB.NET expressions or enumerations (various built-in
constants). For example, before you could run this line, you must replace
DataViewRowState with one of the enumerations shown when you type in
the line of code. Enumerations are lists of constants. There are sets of con-
stants built-into .NET, or you can create your own with the Enum statement.

If you are using a DataView object, set its RowStateFilter property to
specify which version of the rows you want to see:

Dim drView As DataRowView

dv.RowFilter = "Title LIKE '*g*'"

dv.Sort = "Title"

dv.RowStateFilter = DataViewRowState.Deleted

Using the Dataliew Object

Datasets are disconnected from the database from which they drew their
data. But what if you want to view the data in a dataset in a different way?
For example, if you want to see only customers in Montana, should you go to
the trouble of reconnecting to the original database and build a new dataset?
That’s not efficient. It’s easier to use a data view, which provides you with a
filtered and sorted view of the dataset’s contents. A data view is not a copy
of the data; it’s just a different view of the dataset.

Using the DataView feature isn’t too hard. You have to create a few objects
and use For Each to iterate through them to display them. Add a button to
the form used in the earlier example (“Filtering with Select”) and change its
Text property toDisplay Dataview Q. Then double-click that button and
type this (Listing 3-5) into its C11ick event:
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Listing 3-5: Building a Data View Book V

Private Sub Button2_Click(ByVal sender As System.Object, B
ByVal e As System.EventArgs) Handles Button2.Click
'"Create a DataView and display it

' Get a reference to the Recipes table.

Dim dtNew As DataTable = ds.Tables("Recipes")

' Create a dataview

Dim dv As New DataView(dtNew)

Dim drView As DataRowView

' Set the criterion filter and sort on title.

" This criterion says: list all records with a Q in
the title field

dv.RowFilter = "Title LIKE '"*g*""

dv.Sort = "Title"

sjasejeq
Bunendiuepy

"display the DataSet

Dim i As Integer, s As String
ListBoxl.Items.Clear()
Me.Text = "From DataView"

For Each drView In dv
s = drView(i)
ListBoxl.Items.Add(s)
Next

End Sub

Close Relations

One of the prime virtues of a DataSet is that it permits you to create rela-
tions, just like a real database. After all, the kind of database that’s most
popular these days — and that includes SQL Server and DataSets —is a
relational database. So, just what are relations, and why are they so popular?

A relation is a connection between two tables that both share a common, pri-
mary key (a column in which each row contains unique data). The fact that
they identify their rows uniquely, and both do it the same way, permits you
to access data simultaneously from both rows but in sync. This can be useful
when one table contains details not available in the other table. Recall that
you sometimes use two tables to prevent redundancy.

Master-detail, parent-child

Data coming from multiple yet related tables is often referred to as master-
detail. For example, a master table (the parenf) could contain a list of pub-
lishers and their addresses, phone numbers, and other information.
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However, because each publisher puts out many books, you don’t want to
have to repeat the publisher’s address, phone number, and so on for each
book. That’s the redundancy that multiple tables solves. You simply put the
main information about each publisher in one table, and you link (make a
relation, or join) that table to a different detail (the child) table that lists all
the books for each publisher. The child table doesn’t contain the publisher’s
address, phone number, and so on; rather, it contains details about each book.

This master-detail relationship between tables is quite common. In a dentist’s
office, they put your name, phone number, and so on in one table; then they
link it to a second table containing, for example, details about your payment
history.

In the following sections, you first see how to create a relation between two
tables programmatically, and then you see how to use wizards and the excel-
lent, graphic XML Designer, which shows you a visual diagram of tables and
any relations between them.

Programmatic relations

Start a new VB.NET Windows-style project. Double-click the form to get to
the Forml_Load event in the code window. Type the following code above
the Private Sub Forml_Load line:

Dim ds As New DataSet(), dr As DataRow, dt, dtl As DataTable
Also add the usual Imports statements at the very top of the code window:

Imports System.Data

Imports System.Data.0leDb
Imports System.Data.SqglClient
Imports System.Data.SqlTypes
Imports System.Data.SqlDbType

You now want to create two tables, dt and dt1, and then define a relation-
ship between them. Type this code (Listing 3-6) into the Forml_Load event.
(In this example, the explanation of the various parts of the source code is
provided by comments within the code itself.)

Listing 3-6: Generating Relations Programmatically

Private Sub Forml_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Lload

"define two new datasets:

dt = New DataTable("Recipes")
dt.Columns.Add("title", GetType(String))
dt.Columns.Add("desc", GetType(String))
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Dim colArray(l) As DataColumn 'make title primary key Book V
(unique) ] Chapter 3

colArray(0) = dt.Columns("title")

dt.PrimaryKey = colArray

dtl = New DataTable("Calories")
dtl.Columns.Add("title", GetType(String))
dtl.Columns.Add("CalorieCount", GetType(Integer))
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'make title primary key (unique) for this table, too.
colArray(0) = dtl.Columns("title")
dtl.PrimaryKey = colArray

"add both tables to the dataset
ds.Tables.Add(dt)
ds.Tables.Add(dtl)

"add three rows to the two tables:

dr = dt.NewRow()

dr!ititle = "First Title"

drldesc = "Description of first title"
dt.Rows.Add(dr)

dr = dt.NewRow()

dr!title = "Second Title"

drldesc = "Description of second title
dt.Rows.Add(dr)

dr = dt.NewRow()

drititle = "Third Title"

dr!ldesc = "Description of third title"
dt.Rows.Add(dr)

"second table:

dr = dtl.NewRow()
dr!title = "First Title"
dr!CalorieCount = 130
dtl.Rows.Add(dr)

dr = dtl.NewRow()
dr!ititle = "Second Title"
dr!CalorieCount = 220
dtl.Rows.Add(dr)

dr = dtl.NewRow()
dr!title = "Third Title"
dr!CalorieCount = 30
dtl.Rows.Add(dr)

'now create a relation between these two tables
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'"This next 1ine of code creates a new relation object
named

"CalRel" and specifies that the first column
(Recipes.Title) is the parent and the second column
" (Calories.Title) is the child (the parent/child
relation is

based on the order that you specify the two columns
in the

parameter list).

ds.Relations.Add("CalRel", ds.Tables("Recipes").
Columns("Title"), _
ds.Tables("Calories™).Columns
("Title™))

Now, Toop through each row in the parent table's
rows collection

(it has three rows), and then Toop through each row
in the relation

object (there is only one row), displaying the
"count"

(the parent table's row number), and both columns
in the child.

Note that you are not accessing dtl directly (the
child table)

instead, you are accessing the relation object

Dim da As DataRow
Dim count As Integer

For Each dr In dt.Rows
For Each da In dr.GetChildRows("CalRel")
count += 1
Console.WritelLine(count & "." & da("Title") &
" " & da("CalorieCount"))
Next
Next

End Sub
Press F5 and look in the Output window for the results. You should see this:
1.First Title 130

2.Second Title 220
3.Third Title 30

Creating a Dataset with Relations

As you doubtless suspected, VB.NET offers you many interesting auto-
coding features — wizards, designers, parsers, add-ins, and other helpers
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that let you drag-and-drop or answer a series of questions before they write
source code for you. Sometimes you can get hundreds of lines of source
code based on a three-minute little quiz from a wizard.

In the next example, you see how to connect to two different tables in the
Northwind sample database and how to create a relation between the ID
column that they have in common. You use both a wizard and a designer.
You also see how to bind a DataGrid and a ListBox to the database connec-
tion. This example requires that you have SQL Server installed.

Relations via Wizards and Designers

You need to know how to summon wizards and designers to make your life
as a programmer easier than you thought possible. To create a connection
between a database and a DataSet, follow these steps:

1.
2.

S NS NS

11.
12,

Start a new Windows-style VB.NET project.

On the form, place a ListBox and a DataGrid from the Windows
Forms tab of the Toolbox.

Double-click the OleDbDataAdapter icon in the data tab of the Toolbox.

An OleDbDataAdapter is added to your form, and the Data Adapter
Configuration Wizard opens. Recall that you can use either this
OleDbDataAdapter (which is slower but more versatile because it con-
nects to more databases) or the SqlDataAdapter used in most examples
in this book. For variety, you use the OleDbDataAdapter in this example.

Click Next.

Choose the Northwind database in the drop-down list.
Click Next.

Leave the Use SQL Statements radio button selected.
Click Next.

Click the Query Builder button.

. Double-click Orders in the Add Table dialog box.

The Orders table is added to the Query Builder dialog box.
Click Close to close the Add Table dialog box.

Click order_id and customer_id in the top pane.

This SQL query is constructed for you:

SELECT OrderID, CustomerID
FROM Orders

Book V
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The order_id column is the one on which a relation will be created to
link this table with another table in the Northwind database.

13. Click OK and then click Finish. Choose not to add a password if the
security patrol queries you.

An OleDataAdapterl and an OleDbConnectionl are added to your tray.
You need only this one connection to the database, but to add a new
table, you can add a second OleDataAdapter to your form. This new
adapter also employs the existing OleDbConnection.

14. Double-click the OleDbDataAdapter icon in the Toolbox.

The Data Adapter Configuration Wizard dialog box opens again.
15. Select the Northwind database and click Next.
16. Leave the Use SQL Statements radio button selected. Click Next.
17. Click the Query Builder button.
18. Double-click Order Details in the Add Table dialog box.

The Order Details table is added to the Query Builder dialog box.
19. Click Close to close the Add Table dialog box.

20. Click orderID, quantity, and unit price in the top pane to specify that
you want to access the data from these fields (columns).

This SQL query is constructed:

SELECT OrderID, Quantity, UnitPrice
FROM [Order Details]

\J . . .
) Some databases refuse to permit spaces in table names. To avoid prob-

lems, you can enclose the name in brackets, as illustrated in the preced-
ing SQL statement.

21. Click OK and then click Finish. Click Yes to permit the primary keys to
be added.

22. Now you need to build a DataSet that includes both of these tables.

a. Right-click either of the OleDbDataAdapter icons in the tray beneath
your form.

b. Choose Generate DataSet from the context menu.

c. Mark the check boxes next to both Order Details and Orders.

d. Name this DataSet dsOrders in the New text box on the dialog box.
e. Click OK.

You now see a new DataSet icon in your tray.
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Using the XML Designer Chapter3

At this point, you can open the XML Designer to create your relation. This
illustrates the intimate relationship between tables, datasets, and XML ver-
sions of either. Follow these steps:

1. Double-click the dsOrders . xsd file in Solution Explorer (VB.NET’s
equivalent of VBA’s Project Explorer).
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The XML Designer opens, as shown in Figure 3-4. Notice the little key
symbols next to the key fields in both tables. OrderID is a unique field,
and you create your relation based on it.

w WindowsApplicationd . Microsoft Visual Basic .NET [desiyn] . deOrder... =/0E
Eile Edit View Project Build Debug Schema Tools Window
Help
e = & | Debug - (3 addresses - B3 2
mor oo FELE | Hex @~
B RL S oo =
"o J '_;rt' P_age_i Forml,vb [Design]* Mrders.lcsdl 1 b x|
=) S w
5_ _____ Order Detslls  (Order Detals) | I__ Orders (Grders) g‘
= B OrderIn it T OrderD int =
e Cuaniity shart CustomerID  string i
Untprice decimal i
B ProductID int =
3
Flg_ure 3-4: |
This )
. -]
designer H
helps you g
graphically —
study and
edit
relations
between O DataSet | E EML |
tables. ||Z =) El Output
Ready [ | 4
P If you don’t see dsOrders.xsd file displayed in Solution Explorer, click

the name of your project (which is in boldface in Solution Explorer) to
highlight it, and then click the icon — it looks like three sheets of paper,
one yellow — in the Solution Explorer title bar named Show All Files.

2. Open the Toolbox.

Notice that when the XML Designer is open, you see a number of XML
schema icons that you can use to create a structure.
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3

The Order Details table is your child (details) table in this relation-
ship, so drag a relation icon from the Toolbox and drop it on the
Order Details table in the designer.

The Edit Relation dialog box opens, as shown in Figure 3-5.

Edit Relation %]
Mame:  |Order_x0020_DebailsOrder_x0020_Detais|

To define 2 relationship (keyref), select the parerk element and key, select the chid element,
and then select the chid Field corresponding be each parent field,

Barent element: Chid element;
JOrdcr Details L] IGrd:r Detals :I
L
JCDnstra’r'J:I _1‘ Negy,.. I

Fields:

Key Fields Foraign key Fiekds

CrderIl CrderlD

Product 1D PraductlD

Figure 3-5: Dakaset Properties
Use this [~ Create foreign key constraint only
d|alog box Updabe nie: Delete rule: diceepkfReject ruke:
to specify [iDeFauity =] [ipefauty | [iDefauy =
the details
of a relation. o | el | e |
. In the Name field, the designer has provided a name for your relation:
4. In the Name field, the designer has provided fory lati
Order_x0020_DetailsOrder_x0020_Details, at this point.
. Ensure that the parent element is Orders and the child element is
5. E hat th 1 is Ord d the child el i
OrderDetails.
Now change the name to rel0rders. You want to remember this name
so that you can use it in a minute when you bind the ListBox and
DataGrid to the relation.
Note the use of the term element here for what you normally call a table.
Element is a term used in XML to refer to an item enclosed by <> </>
symbols — tags — as in the following line:
<H1>This is a headline</H1>
® The reason for using element here is that VB.NET has actually translated

your DataSet (the tables, their schema, their relation, and eventually
even their data) into XML. This way, they can be communicated over
firewalls on the Internet. To see the XML source code that VB.NET has
so thoughtfully generated for you, right-click either table in the designer
and choose View XML Source.



Figure 3-6:
This
necklace
symbolizes
the relation
established
between
these two
tables.
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6. Ensure that Key Fields and Foreign Key Fields both read OrderID.
7. Click OK.

The Edit Relation dialog box closes, and you see something that looks
like a necklace appear in the XML Designer, connecting the two tables
graphically and symbolizing their relation, as shown in Figure 3-6.

o WindowsApplicationd . Microsoft Visual Basic .NET [design] . dsOrders.xsd™ == x]
File Edit View Project Build Debug Schema Tools Window Help
Wtm-2HE@ B o v | [ addresses Hlmle

m > o * FELE= Hex [~
# FL o By o v

18] <ot page | Formi ub [Desion]” dsOrdersassd® | 4 b x |[G3l
g 2
E= ¢ Order Detals  (Order Details) | =
B O odes (o | |8

ety e = b T OrderlD int m
UnitPrice decimal Cush R =

T Productls  ink Hsemetios siing E
2

g

RE |

¢
| sapadolg |

O Dataset |Gl |

|I2§|Z]-E| Output |
Ready I

Ld|

8. Right-click the dsOrders.xsd* tab at the top of the designer and
choose Save dsOrders.xsd.

9. Click the Form1.vb[Design] tab at the top of the designer.

You see your form, almost ready to display this relation.

Binding the controls

You now need to bind the ListBox to the Orders master (parent) table and
bind the DataGrid to the details (child) table, Order Details. To do that,
follow these steps:

1. Click the ListBox to select it.

2. Press F4.

The Properties window opens.

Book
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A\

3. Select the DataSource property and click the down-arrow icon next
to that property.

You see a list of possible data sources.

Click dsOrdersl, your DataSet.

=

5. Select the DisplayMember property and click the down-arrow icon
next to that property.

You see a list of columns (fields) within the table you chose as your data
source.

6. Choose ProductID, under the relOrders node.

A node is an entry with a — or + symbol next to it in a list, indicating that
other items are listed underneath it and subordinate to it.

7. Click the + to open this node and select UnitPrice.
The property should now read rel0Orders.ProductID.
8. Click the DataGrid to select it.

9. Click the DataSource property in the Properties window and then
click the down-arrow icon next to that property.

You see a list of possible data sources.
10. Click dsOrders1.Orders.

11. Click the DataMember property in the Properties window and then
click the down-arrow icon next to that property.

12. Click relOrders.

You see the relation, and the DataGrid control displays the four fields
(the schema) of the child table in the DataSet.

At this point, your DataGrid is now able to point to all child rows in the
child table whenever the user clicks on a product ID in the parent table (dis-
played in the list box). By selecting the relation object as the DataMember
for the DataGrid, you make it possible to see the Details (child) fields.

Many people assume that with the DataSet created and the controls bound,
you can just press F5 and see the data in the controls. Well, as you might
remember from the first example in this chapter, you do have to write just a
little source code to complete the process. Double-click the form to get to
the code window and then type this into the Form_Load event:

Private Sub Forml_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Lload
DsOrdersl.Clear()
OleDbDataAdapterl.Fil1(DsOrdersl)
0leDbDataAdapter2.Fill1(DsOrdersl)
End Sub
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Using Clear

Using the C1ear method isn’t strictly necessary here because this is the first
time that this DataSet is being used in this application. Nonetheless, it’s a
good habit to empty a DataSet of all its contents prior to filling it with new
data. The Fi11 method of a DataAdapater object dumps the data from the
database connection into the DataSet.

Saving an XML Dataset

As a final exercise, send this dataset via XML to Access. Change the
Form_Load event code in the previous example to this:

Private Sub Forml_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Lload
DsOrdersl.Clear()
OleDbDataAdapterl.Fil11(DsOrdersl)
OleDbDataAdapter2.Fil1(DsOrdersl)

"SAVE
Try

DsOrdersl.WriteXmISchema("c:\test.xsd")
DsOrdersl.WriteXml("c:\test.xml")

Catch ex As Exception
MsgBox(ex.ToString)
End Try

Me.Text = "Saved..."
End Sub

The new XML file Test and its associated schema file (XSD) are now avail-
able to Access.

Importing XML by hand

You can also use the manual import approach within Access:

1. Choose Filec>Get External Data-=>Import.
The Import dialog box opens.

2. Open the drop-down list next to Files of Type in the dialog box and
select XML (*.xml; *.xsd).

3. Locate the Test.xm] file you created in the preceding section and
double-click its name in the dialog box.

Book V
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The Import XML dialog box opens.
4. Click the Options button in the Import XML dialog box.

The dialog box grows a bit larger. Notice that Structure and Data is
selected by default. That’s indeed what you want — both the schema
(from the XSD file) and the data (from the XML file).

5. Click OK.

You're informed that the importing has taken place, and you also notice
that both tables — Orders and Order Details — have been added to
your database.

6. Click OK.
The message box and the dialog box both disappear.

7. Double-click Order Details and Orders to see that indeed both tables
from your original dataset have now been transferred to Access.

Importing XML programmatically

If you prefer, you can import an XML file and its schema file by using the fol-
lowing VBA code in Access. Press Alt+F11 to get to the code window. Choose
Inserte>Module. Then type this code into the code window:

Sub GetXML()
Application.ImportXML _
DataSource:="c:\test.xml",

ImportOpti ons:=acStructureAndData
End Sub



Chapter 4: Automating Access

In This Chapter

v~ Using automation to connect to Access
1 Working with SendKeys
v Automating the Access runtime

v Displaying a report

M anaging Access from the outside is essential if you want to go beyond
the built-in capabilities that VBA macros — much less old-style Access
macros — offer.

For example, Access has limited Internet programming capabilities, relative

to the splendid and efficient ASP.NET programming facilities built into .NET.
Or, if you want to create a really rich front end for Access Windows projects,
Access’s VBA UserForm is not nearly as full of features — nor as well-tested —
as the Windows Form in VB.NET. Beyond that, the security features, com-
munication classes, and many other elements of the .NET framework are more
advanced and far more plentiful than those built into Access (or any Office
2003 product, for that matter). Serious Office 2003 developers facing projects
of any significance should become familiar with Visual Studio .NET program-
ming. .NET is the future of Microsoft programming, and a programmer’s future
might well depend on his or her ability to make good use of it.

Automating How to Access a Form

Follow this example to see how to use automation to connect to Access.
Here’s the flow: Start Access, display a form from the Northwind sample
database, move to the second record on the form, copy the data, and send
the data back to the .NET application for further processing.

Before you can do all that, you have to get some DLLs in place — object col-
lections, code libraries, communication tubes, and other such under-the-
hood necessities. Go to this location and download the Office XP Primary
Interop Assemblies (PIAs). (They're the same for Office 2003.)

http://msdn.microsoft.com/library/default.asp?url=/
downloads/list/office.asp
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S

This set of assemblies (code libraries, in this case) isn’t always absolutely nec-
essary to control Office 2003 applications from within .NET. Other assemblies
can do the trick. But the PIA is primary — it’s the official set of libraries — so
you can expect it to be supported and to cause the fewest side effects.

After you download the PIA, read the README . HTM file and follow its instruc-
tions to take a trip back in time to the command line. (That would be DOS,
not much used for the past decade, except in cases like this.) Use the batch
file to install the assemblies and update the Global Assembly Cache (GAC).

The README . HTM file doesn’t mention this, but you probably need to restart
Windows before Visual Studio .NET (which contains Visual Basic .NET) will
work properly.

Read the section in the README . HTM file titled “Distributing solutions that
rely on the Office XP PIAs” if you intend to deploy projects relying on the PIA
to other computers. Creating a custom setup utility is likely the simplest
solution to provide these other machines with the proper assemblies.

Now run VB.NET, choose FileoNew=>Project, name the new project
AutomateAccess (in the New Project dialog box), and then double-click the
Windows Application icon. You must create a reference to your newly down-
loaded PIA, which is done indirectly by following these steps:

1. To add a reference to the Access 11.0 object library, choose
Project=>Add Reference.

2. In the Add Reference dialog box that appears, click the COM tab.

3. Locate and double-click the Microsoft Access 11.0 Object Library.
It appears in the Selected Components pane.

4. Click OK.

The Add Reference dialog box closes, and the reference (the assembly,
actually) is added to your current project.

5. Add a TextBox control to Form1; then double-click Form1 to get to the
code window. At the very top of the code window, add this reference
to Access’s objects:

Imports Access

6. Type Listing 4-1 into the Form_Load event.

Listing 4-1: Moving Data from Access to .NET

Private Sub Forml_Load(ByVal sender As System.Object,
ByVal e As System.EventArgs) Handles MyBase.load

Dim s As String = "Customer Orders"”
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Dim oAccess As Access.Application " "o" for object Book V
Dim pathNorth As String = "C:\Program Files\Microsoft Chapter 4
0ffice\Officell\Samples\Northwind.mdb"

" instantiate Access

oAccess = New Access.ApplicationClass
' show it

oAccess.Visible = True

$s399y bunewony

' open Northwind
oAccess.OpenCurrentDatabase(filepath:=pathNorth)

"select the customer orders form
oAccess.DoCmd.SelectObject(ObjectName:=s, _
InDatabaseWindow:=True,
ObjectType:=Access.AcObjectType.acForm)

" display the form
oAccess.DoCmd.OpenForm(FormName:=s, _
View:=Access.AcFormView.acNormal)

' send two Ctrl+Tabs to move to the second record
SendKeys.SendWait("~{TAB}")
SendKeys.SendWait("~{TAB}")

'select, then copy, the record
SendKeys.SendWait(""a") 'select all
SendKeys.SendWait("~c") 'copy

'get the copied data back to .NET from clipboard
Dim c1 As IDataObject = Clipboard.GetDataObject()
If (cl.GetDataPresent(DataFormats.Text)) Then
TextBoxl.Text =
cl.GetData(DataFormats.Text).ToString()
End If

' destroy the app object
oAccess = Nothing

End Sub

The InDatabaseWindow argument of the SelectObject method selects the
object in the database window, but it defaults to False, so you set it to True
here to carry out the selection process. In effect, this argument sets the
focus to the database window.
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Press F5 to execute this code, and you see Access fire up and display the
form. The data from the form is sent back to your VB.NET project and dis-
played in the text box.

This example illustrates a combination of techniques. Object instantiation is
one technique. The Access application is instantiated by using today’s fash-
ionable object-oriented programming (OOP) approach:

New Access.ApplicationClass

A second technique is older — it used to be called OLE Automation — but it
has its uses. You can use AppActivate or Shell commands to set the focus
to another currently running application or start a new instance of an appli-
cation, respectively. However, you then have to use SendKeys extensively to
maneuver — macro-like — around the windows and other elements of the
application. It’s usually easier to first get an object variable (0Access in
Listing 4-1) referring to an instance of Access, and then use that and a form
object variable to do the heavy lifting (that is, the main manipulations).
SendKeys can then be used for other, smaller maneuvers. (For more on
SendKeys, see the next section.)

Here’s an example showing how Shel1 instantiates the Windows Character
Map utility and then switches it to display the Times New Roman font:

Shel1("CHARMAP.EXE", 1)
SendKeys.SendWait("Times New Roman")

Understanding SendKeys

SendKeys is worth spending a little time exploring because it can be helpful
when you don’t have the time to try to figure out all the ins and outs of a
class library to know how to do a job that some simple keystrokes can
accomplish.

When you import the Access namespace, as in Listing 4-1, you can then use
the VBA commands available within the Access object model, including
SendKeys. Alternatively, you can import a VisualBasic namespace (a refer-
ence to a code library, or class library, or object model — three ways of fun-
damentally saying the same thing) and get to use the Visual Basic 6 classic
commands, of which SendKeys is one:

Imports Microsoft.VisualBasic
However you get to it — and whether you call it a function (as it was called

traditionally) or a method (as it’s now described) — SendKeys is nonethe-
less worth knowing about.
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SendKeys allows your VB program to send keystrokes to another Windows
program, just as if the user were typing those keys into the other program.
In other words, SendKeys slips data — fake keystrokes — into the pipeline
between the keyboard and a Windows program. SendKeys makes it seem
that the user is typing something, and the program with the focus cannot tell
that a user isn’t simply typing away.

This technique allows applications to communicate with each other. (You
cannot use SendKeys on the DOS command line.)

SendKeys and SendWait

The target program must be running and have the focus when SendKeys
attempts to “type” something into it.

Normally, you’ll want to use the SendWa it method with SendKeys to

cause your VB program to pause until the outside program has digested —
processed — whatever keystrokes you have sent. Otherwise, keystrokes
can get lost in the ether if focus is shifting or other events are interfering
with a quick cascade of keystrokes. For example, here’s how to send Ctrl+A:

SendKeys.SendWait("”a")
To directly send the following 12 text characters, use the following:
SendKeys.SendWait("MESSAGE SENT")

Or to repeat an individual key — in other words, to specify the number of
repeats — put both items in braces. For example, to print seven z’s, use

{z 7))

Sending nonprinting keys

You can also send the nonprinting keys: the keys that cause actions to take
place rather than text to be printed, such as F1, Alt, Enter, PgDn, and so on.
Many programs recognize and respond to special keys, like the Function
keys and Alt+key combinations, for example. To “press” those keys by using
SendKeys, you provide the name of the special nonprinting key and put it
inside braces ({ }) using the following list. Note: The key names themselves
are case-insensitive: It doesn’t matter how you capitalize them. Enter is the
same as enter or ENTER.

{Backspace} or {Bksp} or {Bs}
{Break}
{Capslock}

Book V

[x]
=
(Y]
=
=3
@
=
s

$s399y bunewony



4 76 Understanding SendKeys
q U}

{Clear}
{Delete} or {Del}
{Down}
{End}
{Enter} or ~
{Esc} or {Escape}
{Help)
{Home}
{Insert)
{Left}
{Numlock}
{Pgdn}
{Pgup}
{Prtsc} (for Print Screen)
{Right}
{Scrolllockt!
{Tab}
{Up}
{F1} through {F16}
Or, you can simulate the Ctrl, Alt, or Shift keypresses in combination with

other characters. For Shift, put the + (plus) symbol before the character you
want shifted: +E, for example.

Many commercial programs save to disk by pressing the Alt+F, S — activating
the File menu and selecting the Save option.

For Alt, put the % (percent) symbol before the character you want pressed
simultaneously with Alt: 2F S, for example.

For Ctrl, use the * (caret) symbol before the character you want pressed
simultaneously with Ctrl: *F, for example.

To hold down the Shift, Alt, or Ctrl key while several other keys are pressed,
put the other keys in parentheses. For example, to send shifted ABC, use
SendKeys "+(abc)".
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Book V
Using "+abc" would shift only the A, resulting in Abc. Chapter 4
Because the braces characters are used in a special way, if you need to send =
one of them, enclose the brace itself in braces: { { }, for example. g
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Because the +, %, and * characters are used to indicate Shift, Alt, and Ctrl, g
respectively, enclose them in braces if you want to send one of them as a char- =
acter or as printable text. For example, to print the percent symbol, use {%}. e
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If the program to which SendKeys is instructed to send keystrokes is not
running or hasn’t been given the focus (with the AppActivate command, for
example), the keystrokes are sent back to your Visual Basic .NET program as
if the keys were being typed into your program. This permits you to simulate
keystrokes that the user might have typed while the VB program is running.

Automating the Runtime

The Developer Edition of Access allows you to deploy your Access 2003 appli-
cations to computers where no retail version of Access is installed. Instead, a
runtime (code library) version of Access (named msaccess.exe) is installed
on these machines. Your code will work, but the users themselves cannot
write code nor customize your code unless they install their own copy of
commercial — not runtime — Access, in which case they can go ahead and
freely manipulate the objects and data that you gave them.

If you want to contact the runtime so you can automate this type of Access
installation, you should start msaccess.exe and also load a database into it
before attempting automation. You must revert to the command line style of
programming to do this (DOS), and you must supply a database as an argu-
ment. Then use the GetObject command to get the App1ication object. You
cannot use CreateObject or New to instantiate Access’s runtime.

For valuable additional information about using the Package Wizard and
deploying Access using the runtime, see the article, “Packaging Access 2003
Solutions” at this Web page on MSDN:

http://msdn.microsoft.com/library/default.asp?url=/Tibrary/
en-us/dnsmart03/html/sa03j8.asp

Displaying a Report

For a final example of automation, you see how to display an Access report.
It’s similar to displaying an Access form; see Listing 4-2:
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Listing 4-2: Displaying an Access Report

Private Sub Forml_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Lload

End Sub

Dim s As String = "Sales Totals by Amount"

Dim oAccess As Access.Application ' "o" for object

Dim pathNorth As String = "C:\Program Files\Microsoft
0ffice\Officell\Samples\Northwind.mdb"

" instantiate Access

0Access = New Access.ApplicationClass

" show it

oAccess.Visible = True

" open Northwind

oAccess.OpenCurrentDatabase(filepath:=pathNorth)

' select the report

oAccess.DoCmd.SelectObject(ObjectName:=s,
InDatabaseWindow:=True, _

ObjectType:=Access.AcObjectType.acReport)

' display the report
oAccess.DoCmd.OpenReport(ReportName:=s, _
View:=Access.AcView.acViewPreview)

' destroy app object
oAccess = Nothing
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In This Chapter

v~ Using the Error event

v+ Understanding Option Explicit and Option Strict
v Adjusting macro security

v Using the new sandbox mode

1+ Backing up Access 2003

v Error-checking for forms and reports

Error Management in Access

A ccess contains several built-in error-management (and avoidance!) fea-
tures. A primary one is the Error event that’s triggered in a form or
report when something isn’t right.

This Error event is not fired when any VBA errors occur in your programming
code. For those errors, you must use the On Error trapping code, which I
describe in detail in Book II, Chapter 6. The Access form and report Error
event is fired when the Jet database engine or another outside source reports
a problem. To see where this error trapping happens, follow these steps:

1. Open the Northwind sample database.

2. Choose HelpoSample Databases and then select Northwind Sample
Database.

If it’s not there, go to Control Panel, choose Add/Remove Programs, find
and click Microsoft Office, click the Change button, and follow the
instructions to install the Northwind sample database.

3. With the sample database open, press Alt+F11 to open the VB editor
and then press Ctrl+R to see Project Explorer.

4. Open the Access class objects node in Project Explorer (click the +)
and then double-click Form Employees to open its code window.
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Each object has its own private code window. Notice that the Program-
ming Police have been busy in this code window. They’'ve already turned
off two options that they don’t believe should be options:

Option Compare Database
Option Explicit

Hold everything. Why did the Programming Police turn off these options? Take
a look at the next section for the answer, and then I'll resume this step list.

Understanding Option Explicit and Option Strict

Option Compare Database means that when strings are compared, the com-
parison is based on the locale (the language used by the culture) of the data-
base itself. For more details on this dubious feature, see Book V, Chapter 1.

When Option Explicit isincluded in code, you cannot use implicit vari-
ables. You must declare every variable name formally (by using Dim, PubTic,
or one of the other declaration/scoping/lifetime commands). In VBA and
VB6, you are not required to explicitly declare variables. You can simply
assign a value to a variable, which causes the variable to come into exis-
tence, like this:

MyVariablesName = 12

Also, you are permitted to forget about variable types and let VB decide for
you which type was required at any given place in the code, based on the
context. This is a variant variable. For example, if MyVariablesName contains
numeric 12 yet you want to display this number in a text box, VB automati-
cally transforms this numeric Integer data type into a text String type:

Textl = MyVariablesName

This line causes Text1 to display the digit characters 12. However, many pro-
grammers and professors of computer “science” (as they prefer to call it —
some of them are quite certain that their style of programming should be Zee
Only Style of Programming!) insist that all variables must be explicitly declared.
It’s not enough to simply assign some value to a variable; you should declare it
and declare its type as well:

Dim MyVariablesName As Integer
MyVariablesName = 12

Not only that, if you want to transform (cast, or coerce) a variable of one type
into another type — such as changing an Integer type intoa String type —
you must specifically do that transforming in your source code:

TextBoxl.Text = CStr(MyVariablesName)
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The CStr command is one of several commands that begin with C (CInt,
CByte, and so on) that cast one variable type into another. In VB.NET, if you
attempt to use a variable before explicitly declaring it, VB.NET informs you
that you’ve made an error — that the variable name has not been declared.
If you want to turn off this error message and use undeclared variables, type
this line at the very top, on the first line, in your code window:

Option Explicit Off

However, you can avoid some kinds of bugs by explicitly declaring all your
variables, and it doesn’t take too much extra time to declare them.

Although VB.NET enforces Option Explicit by default, it does not enforce
Option Strict by default. Option Strict governs whether an error mes-
sage will be generated if you don’t cast variables. You can use this line of
code even though the text box displays a string and MyVariablesName was
declared as an Integer variable type:

TextBox1l.Text = MyVariablesName

This is perfectly legal in VB.NET. No error message will be displayed when
you execute this code. However, some programmers insist that casting is
important. If you are one of those, you can enforce casting by typing this line
at the top of your code window:

Option Strict On
Now, try to execute the following line:
TextBox1.Text = MyVariablesName

The VB.NET compiler does not like that line and displays the following error
message:

Option strict disallows implicit conversions from
System.Integer to System.String.

Option Strict, in spite of its charming name, does permit VB.NET to handle
a few “safe” data type conversions itself. For instance, changing a 16-bit integer
to a 32-bit integer cannot result in any loss of data, so it is permitted to take
place automatically within VB.NET — there is no need for the programmer to
explicitly do this conversion with special source code. The reverse, though
(changing a 32-bit integer into a 16-bit version) is not permitted to take place
automatically. You, the programmer, must use one of the data-conversion com-
mands (see the “Searchable VBA/VB.NET Dictionary” in the online appendix.
For more on this appendix, refer to this book’s Introduction). Likewise, a float-
ing-point data type (which might hold a value such as 12.335) is not permitted
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Figure 5-1:
Add any
database
error
handling
here.

to automatically convert to an integer (which would strip off the .335 fractional
portion of the number because integers have no decimal point). Is converting
from an integer to a floating-point type permitted? Yes, because that is safe.

The point is that the Programming Police want Option Explicit to be
embedded in every programming language — underneath, where you cannot
choose to turn it off. They really don’t want it to be an option at all. Like
autocrats in any context, it’s their way or the highway. Fortunately, some
people enjoy the freedom of options, preferring to decide for themselves
what’s safe and what’s an acceptable risk. That’s why, in BASIC at least,
these options still survive. But programming options — like any freedoms —
are always under attack, and the newest version of BASIC (.NET) has now
made explicit declaration the default.

Locating the Ervor event, part 11

After recovering from the shock of seeing someone else turning off some of
your options by writing code for you in your code window, you can now
locate the Error event. Let me restart my step list where I left off:

5. Open the list box in the top left of the code window.

6. In this list box, click Form.

7. In the other list box (top right of code window), locate and click Error.

You now see the event where you can insert programming to deal with
Jet or other outside errors, as shown in Figure 5-1.

& Northwind - Form_Employees (Code) =&
[funn 3 lErrul 3
Option Compare Dacabsse =

Cption Explicit
Dim path A= Scring

Private Sub AddPicture_ Click()
! Use the Office File Open dislog to get & Tile hame To use -
! as an employee picture.
getFileNams

End Sub

Private Sub Form Error (DataErr A= Inceger, Hesponse js Integer)

End Sub

Private Suo Form RecordExit (Cancel A= Integer)
! Hide the errormsg label to reduce flashing when navigating
! hetween records.
errormzg.Vigible = False

End Sub

Private Sub RemovePicture Click()

! Clear the file name for the employee record and display t]u:J_I
-

== | v
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Recall that you cannot put VBA macro code error handling here. This
event doesn'’t fire for those errors. Use On Error within your VBA code
for that kind of problem.

Adding a custom error message

Most of the time, you employ the Error event shown in Figure 5-1 to keep your
users calm. If they see the standard default Access error message, they might
panic. You want to offer a gentler, kinder message — one that they can under-
stand. Insert your custom error messages in this event, like in Listing 5-1:

Listing 5-1: Custom Error Message

Private Sub Form_Error(DataErr As Integer, Response As
Integer)

If DataErr = 2757 Then 'SQL Server error returned
"don't display error message
Response = acDatakrrContinue

Else 'deal with non-SQL Server errors here:

MsgBox "An error unrelated to SQL Server occurred. Please
contact your IT professional."”
End If

End Sub

Unfortunately, SQL Server cannot return specific error codes to your Form_
Error event. DataErr 2757 includes all possible errors that could occur via
SQL Server. Often, you want to handle errors in your programming rather
than simply displaying an error message to your user and shutting down the
application. To deal with SQL Server problems programmatically, you can
add code like the following to get the error description returned from the
SQL Server to a Recordset object. First create the object, like this:

Private WithEvents recSet As ADODB.Recordset

Private Sub Form_Open(Cancel As Integer)
Set recSet = Me.Recordset
End Sub

Then use the acDataErrContinue command (illustrated in Listing 5-1) to
cause an SQL Server error to be ignored by the Error event and handled
instead within the RecordChangeComplete event, like Listing 5-2.
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Listing 5-2: Dealing with SQL Server Errors

Private Sub recSet_RecordChangeComplete(ByVal adReason As
ADODB.EventReasonEnum, ByVal cRecords As Long,
ByVal pError As ADODB.Error, adStatus As
ADODB.EventStatusEnum, ByVal pRecordset As
ADODB.Recordset)

I[f adStatus = adStatusErrorsOccurred Then
s = pError.Description

If InStr(s, "UPDATE statement conflicted with column
check constraint") > 0 Then

MsgBox ("You violated a check constraint.™")

Elself InStr(s, "Cannot insert the value NULL into
column") > 0 Then

MsgBox ("You cannot use a null value in this

column.")
Else
MsgBox (s & " ... This error occurred in the SQL
Server. Contact your administrator.")
End If
End If

P End Sub

You can use E1self to trap as many error messages as you wish.

Sandbox Mode: Adjusting Macro Security

If you choose Medium or High macro security, you enter sandbox mode. This
disables the usual problem commands (disk formatting and so on) of which
virus writers are so fond. Authorization is used to see who can and cannot
access these features. However, this mode protects you only from attacks
originating in SQL statements or expressions in default values or control
sources. VBA itself is not sandboxed.

Changing macro security levels should be easy, but it’s not. In other Office
applications, you can generally manage macro security easily. Just choose
Tools=>Macro=>Security and adjust the settings. Alas, though Access Help
says to do this, there’s no Security option on the Macros menu at all. To get
to the Security dialog box, you have to go through the following steps:

1. Choose Tools~>Customize.

2. In the Customize dialog box that opens, click the Commands tab.
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3. Click the Rearrange Commands button. Book V

Chapter 5
4. In the Rearrange Commands dialog box that opens, select the Menu aper

Bar option button.
From this drop-down list, choose Tools=>Macro.
5. Click Add.

6. In the Add Command dialog box that opens, choose Tools from the
Categories list.

$S999Yy Ul
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® 7. Choose Security from the Commands list.

This list isn’t in alphabetical order, but don’t lose heart; Security is at
the very bottom of the list.

8. Click OK to close the dialog box.
The Security option appears in the Controls list for the Macros entry.
9. Click both Close buttons.

The dialog boxes close, and the Security option — with sandboxing — is
now available to you.

Backing Up for Safety

The single most important thing you can do to avoid virus and other data-
loss problems is to frequently back up your work. Access 2003 has a new
backup feature that you should become familiar with.

Choose Tools>Database Utilitiess>Back Up Database. The Save Backup As
dialog box appears, like the one shown in Figure 5-2.

Save Backup As =
f
| Save £ SAMPLES v & A X [ Took ~
| A L INFORATH
‘5 2 racethwing. ok
My Recent  Fncrthwindbsk,mdb

Documents

B

——— Deshtop

Figure 5-2:

Use this e

dialog box

to save ﬂ

backups of ety

ZZ::J; bcau; ;e nt My:;-“bl& 5 File pame:  porthwind_2004-01-26.mdb vl [T]

Places Save 85 WDE | Microsoft Office Access Databass (*.mdb) v Cancel )
= |
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A new MBD file is specified, with a default filename incorporating the date in
a strange year-first format, like this: Northwind_2004-01-26.mdb. I suppose
the idea is that if you have huge numbers of otherwise identical backup file-
names, it’s most useful to sort them by year for display in Windows Explorer.
The backup file is saved to the same path as the original MBD file.

Automatic Form and Report Error Checking

Access 2003 has an automatic form and report error-checking feature that
does more than simply flag problems: It tries to offer ways to fix the problems.

Double-click the Products form in the Northwind sample database, choose
Tools=>Options, and click the Error Checking tab on the Options dialog box,
as shown in Figure 5-3.

Options %]
View | Genersl | EdkfFind | Keyboard | Datachest | Foems{Reports || Pages
Advarced International Error Checking Speling Tables/Queries

Settings
[#]Enable errar checking
Error indicator color: | I Green w
FormjReport Design Rules -
[¥]Unassociated label and control

Figure 5-3:
Specify
which error-
checking
features
you want
activated.

[#]tlew unassociated labels
[¥]keyboard shorteut errors
[#] 1rwslid control properties
[¥] Common report esrors

Error checking is turned on by default, as are all the design rules displayed
in Figure 5-3. To see what happens if an error is on your form, click OK to
close the Options dialog box. Then choose View=>Design View so you can
fiddle with the Products form.

Right-click the Product Name TextBox control on the form (not the label by
the same name) and then choose Properties. The text box’s properties dialog
box appears, as shown in Figure 5-4. Click the Data tab and change the Control
Source to a non-existent data source by typing in x (yup, one solitary x).

Close the dialog box and take a look at the form. A small, green triangle
appears in the upper-left corner of the offending text box, and an exclama-
tion point icon also appears, as shown in Figure 5-5.
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LT Text Box: ProductName &
|Productiiame v
| Format | Dta | Event | other | Al |
Contral Sourse . ... 2 [ Lol |
Inpuk Mask . . . |

Default Yalue . . .
. Validation Rule ,
Figure 5-4: validacion Test ..
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Fiker Lookup ... ... atabase Default
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Figure 5-5:
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and R
exclamation |
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error in this UnitP
form.
Click the exclamation point and notice that some very useful information is
displayed, as shown in Figure 5-6.
=] Products : Form 'Q'@
u‘--|---|---l---z--ln---s---ln--4-----“5---|---__‘§
P i §iol =
) Invalid Control Property: Control Source :%
;Iglll‘e 5-6: No Such Field in the Field List
ome error Edit the Control’s Control Source Property
messages Edit the Form’s Record Source Property
are quite Help on This Eror
USEfUl, like lgnore Error
these_ Error Checking Options...

As Figure 5-6 illustrates, this error feature is quite helpful. You're not only told
that the control source (the data field bound to this control) doesn’t exist but
also how to fix it: Edit the form’s or the control’s data source property. This is
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considerably more helpful than the usual computer language error message,
although the new .NET languages do enjoy improved error messages and a
continually improving Help system.

Specificity in error messages is a novel (and quite welcome) development.
And information telling you exactly how to fix the problem is even more rare
and more welcome. Too often, a single computer language error message

is triggered by dozens of different causes. Also, error messages and Help
entries are too often written by a raging propeller-head who knows the tech-
nical details brilliantly and cannot communicate his ideas to ordinary pro-
grammers to save his life. Here’s an example of what I'm talking about, from
an actual VB Help entry:

Changing the value of a field or property associated with any one instance
does not affect the value of fields or properties of other instances of the
class. On the other hand, when you change the value of a shared field and
property associated with an instance of a class, you change the value associ-
ated with all instances of the class.

If you understand the previous paragraph, reach up and give the propeller
on your beanie a spin for me.

Hint: The paragraph would be less confusing were the author, or editor, to
make this change: “. . . a shared field or property . ..” Also, the words associ-
ated and field are used incorrectly here, but don’t get me started. If The
Powers That Be ever do manage to create comprehensible documentation,
many of us computer book authors will be out of work. However, I take com-
fort in the fact that Japanese electronics manuals haven’t improved much
since the first transistor radios appeared in the 1950s, with their lively advice
to Replace the blue pull with the battery plastic, under the battery while shipped
to you, before turning unit off. Or upward.
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In This Chapter

+* Managing without a macro recorder
1+~ Exploring the Object Browser

v+ Understanding DoCmd

v Using built-in functions

+» Employing classic error trapping

v+ Adding keyboard shortcuts

In this chapter, you see how macros work in Access. They're treated a bit
differently from how other Office 2003 applications manage macros. You
find out how to use the important DoCmd object, how to employ built-in func-
tions, and how to trap errors. Access often goes its own way, using different
dialog boxes and approaches than are found in other Office applications.
Keyboard shortcuts are no exception; you see how they’re created in Access.

Understanding the Languages of Access

Access’s built-in programming languages (macro languages) have accreted
over time, like barnacles on a ship. And unlike any other application known
to man, Access currently includes three different built-in languages: BASIC,
VBA, and VBScript, described as follows:

4+ BASIC: Access includes the ancient, limited, and essentially unsupported
Access BASIC language, with its outdated — and relatively distinctive —
point-and-click interface.

4 VBA: VBA is actually a complete programming language, not merely a
macro language. Although lacking inheritance and a few other object-
oriented programming (OOP) features (that many programmers simply
don’t need or want anyway), VBA is a powerful, mature, and efficient
language.

4 VBScript: Finally, a subset of VBA’'s command set is found in the VBScript
language, which is Microsoft’s answer to JavaScript. VBScript is useful for
Internet applications, where executables must be lite (not contain any
commands that could do damage to a user’s system) to pass through
users’ virus defenses. VBScript is a subset of VBA because it’s missing
certain potentially dangerous capabilities, such as hard drive access.



43 0 Creating Macros without a Recorder

WordBasic

Truth be told, Word also had its aging WordBasic  based on one of these older templates, or simply
for a while, but remnants dont remain in Word open a template or attach it to a Word 2003
2003. Word 2003 automatically converts any document. Macros in Word versions 97, 2000, or
WordBasic macros (which can be found embed- 2002 are already in VBA, not WordBasic, so no
ded in Word 6 and Word 95 templates) to VBA. translation is necessary.

This happens if you create a new document

Creating Macros without a Recorder

Unlike Excel and Word, Access doesn’t have a macro recorder, so you cannot
use that helpful shortcut to generate sample programming that you can
modify while creating your own macros.

Often, if you want to know the code to do a particular job (such as opening
a file), the easiest way to get this code up and running is simply to record
it, look at the code automatically generated, and adjust it as necessary. This
approach can even be used with Access if you hit a brick wall. You could
record something in Word, for example, and then see whether that code
works in an Access macro. But this approach isn’t that reliable because the
Access object model has too many unique aspects.

A\
One shortcut is to go back in time to the older Access macro creator and
convert the result into VBA. To see how this works, follow these steps:

Open the Northwind database in Access.

In the Objects list of the main database window, click Macros.
Click New on the window’s icon bar.

In the Macro dialog box that opens, click the top line.

Open the list box from the top line.

Choose Quit from the list.

S, s ®»WDN =

Quit appears in the list of macro actions, along with a SaveAll option.
You can click SaveAll to see another drop-down list of options. (Aargh.
Why don’t they just display the list instead of showing a drop-down
arrow icon and making you click it? After all, if you clicked it, you want
to see the list, right?)

7. Choose Prompt as your option.
8. Close the Macro dialog box.
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A dialog box appears, asking whether you want to save changes.
Click Yes.

A Save As dialog box appears, allowing you to rename the macro.
Rename it Quitting.

Click OK.

The dialog box closes, and your macro is now officially a real macro. It
appears in the list of macros in the main window.

Click Quitting in the main database window.
Choose Tools=>Macro->Convert Macro to Visual Basic.
The Convert Macro: Quitting dialog box appears.

Leave the default check boxes selected because you do want the
error trapping and the comments so cunningly offered to you. (Who
wouldn’t?)

15. Click Convert.

The Convert Macros to Visual Basic dialog box appears telling you that
the conversion is finished.

16. Click OK.

This odd dialog box closes.

17. Locate your new macro. Press Alt+11 to open the VBA editor and then

press Ctrl+R to open Project Explorer.

Its code window does not automatically open for you to view it.

18. Under the Modules node in Project Explorer, double-click the

Converted Macro-Quitting macro.

The special module window devoted just to this particular macro opens,
and you see Listing 6-1.

Listing 6-1: Converted Access Quitting Macro

Fu
On

Qu

nction Quitting()
Error GoTo Quitting_Err

DoCmd.Quit acPrompt

itting_Exit:

Book V
Chapter 6
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Exit Function

Quitting_Err:
MsgBox Error$
Resume Quitting_Exit

End Function

Well, maybe you didn’t need this commenting after all. It’s not too useful, but
the error trapping is good. And what’s most useful is the translation that
Access has — albeit, reluctantly, compared with the recording feature in
other applications — now provided you. You know how to write code that
quits with a prompt: DoCmd.Quit acPrompt.

[ talk more about DoCmd and the error-trapping features shortly. However, |
won’t have anything to say about this line of code:

Resume Quitting_Exit

[ have no idea why this line of code exists. The End Function does the
same thing without redirecting execution.

Using the Object Browser

To help you figure out the object model in Access, you can press Alt+F11 to
get to the VBA code window; then press F2 to open the Object Browser, as
shown in Figure 6-1.

*% Object Browser =aE

Inccegs - _!IJ B@i}i ﬂ

I -] #fx

-~ Search Results

Libra | Class | Member |

Classes Members of AccessDhject!

@ sglobals> |A[E8 Curenfiew

B AccessObject | = | |E® DateCrested

B AccessObjectProperties 75 DateModified
Figure 6_1 B AccessObjeciProperty =5 Fullarne

&P AcCloseSave =& GetDependencyinfo
Use the 27 AcColorindex “# |sDependentUpon
Ob-ect = MxCommand 175 IsLoaded

) P AcConfrolType 28 Mame

Browserto [ sccurentview <8 Parent

2F AcDatadccessPaneliew == Properties
see what 2 AcDataObjectTyoe == Type
ObiECtS are =P pcDataTranstarType

. &P AcDeliew
available &P AcExport{MLEncoding vl
and their Class AccessObject
Member of Access

members.
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The object’s members are symbolized by little icons next to their names. Book V
Properties are symbolized by a hand holding a VCR tape (collections add a Chapter 6
small, cyan, floating ball to this icon), methods by a flying green eraser, enu-

merations by an equal sign, and events by a yellow lightning bolt.

Click a method in the Members pane, and you see the proper syntax for
employing that method in the lowest pane of the browser. The method

is called a function (the older name for method). For example, the
CompactRepair method of the Access Application object looks like this:

sanbiuyaa)
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Function CompactRepair(SourceFile As String, DestinationFile
As String, [LogFile As Boolean = False]) As Boolean

This can be helpful, although the Access VBA editor includes IntelliSense
features such as statement autocompletion and argument lists.

Using DoCmd

DoCmd is a class in the Access library. DoCmd contains many useful, commonly
used methods such as ShowToolbar, GoToPage, FindRecord, Maximize, and
so on. Indeed, by using the DoCmd . RunCommand method, you can trigger all
the Access menu features programmatically, thus taking control over Access’s
behavior.

As you might expect, DoCmd has many methods. Press Alt+F11 to go to

the Access VBA editor, and then press F2 to see the Object Browser. Click
DoCmd in the Classes list in the Object Browser to see all the methods. The
RunCommand method is especially full of variations and possibilities: It’s your
gateway to many Access behaviors. Although any custom menu and toolbar
commands cannot be manipulated via RunCommand, all the built-in Access
menus and toolbars are available. The menu and toolbar items are invoked
by using a built-in constant starting with ac, such as acCmdOptions. For
example, the following displays the Tools=>Options dialog box:

Sub ShowOptions()
DoCmd.RunCommand acCmdOptions

End Sub

Notice that the argument for the RunCommand, acCmdOptions here, is oddly
not enclosed in parentheses. Also, to see all the built-in constants (enums, as C
programmers call them) that can be used with this method, choose Help in the
VBA editor, choose Microsoft Visual Basic Reference in the Table of Contents,
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Figure 6-2:
Here are the
constants
that you can
use to
trigger
Access
menu items.

choose Enumerations, and then click the Microsoft Access Constants hyper-
link. (Simply searching for Microsoft Access Constants won’t do it — that would
be too easy.) In the list of enums, click AcCommand, as shown in Figure 6-2, to
see all the constants that you can employ with the RunCommand method.

|’ty Microsoft Visual Basic Help =) ﬁ@
D¢ =5
~Show &l [#
Microsoft Access Constants 3
This topic Iists all the constants in the Microsoft Access object model,
b AcCloseSave
b AcColorIndex
» AcCommand
Constant Value
scCmdAboutMicrosofthcoess s
acCrmdAddInManager 526
acCmdAddTolewSGroup 434
acCmdAddWatch 201
acCmdAdvancedilterSort =]
acCmdAlgrBottom 46
acCmdAlgnCentsr 477
acCmdhlgrieft 42
acCmdAlgnmentindsizing 478
zcCmdAigrividde 476
acCmdAlgrRight 44
acCmdAlgn ToGrid 47
acCmdAlgnTop 45
2cCmdAlignToshortest 152
acCmdilgnToTalest 154
acCmdAnalyzePerformance 283
acCmdAnalyzeTable 284 b

Seeing Built-in UBA Language Features

The Object Browser can provide you with a shortcut view — quicker than
Help — of the commands that you can use to manage your macros. In the
upper-left corner of the Object Browser, open the list and choose VBA. You
see a list in the left pane showing all the various groups of functions, catego-
rized by purpose such as FileSystem, Math, and so on. Click Strings, and you
see all the classic Visual Basic functions. Click InStr, for example, and you
can see the syntax, like this:

Function InStr([Start], [Stringl]l, [String2], [Compare As
VbCompareMethod = vbBinaryComparel)
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Using Classic Error Trapping Chantors

The On Error command helps you to avoid user panic. It also allows you to
gracefully deal with the unexpected. In this example, what if the user has
deleted a form that you expected to be left in the database?

Sub OpenForm()
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DoCmd.OpenForm FormName:="Suppliers"

End Sub

This works fine in the Northwind database (opening the Suppliers form)
unless that form doesn’t exist or has been renamed. To deal with these pos-
sibilities, use this error structure:

Sub OpenForm()
On Error GoTo handler
Dim fn, s As String

fn = "xx"
DoCmd.OpenForm FormName:=fn

Exit Sub
handler:

If Err = 2102 Then 'handle wrong form name:
s = InputBox("There is no form by the name of " & fn & ".
Please enter the name of a form in this database.™")

DoCmd.OpenForm FormName:=s
End If
End Sub

The handler is a labeled location to which execution is transferred if an error
occurs. (Otherwise, the Exit Sub executes following a successful form
opening.) If an error exists, the code following hand1er executes. Some (not
all) error codes can be found by searching Help for Trappable Errors. Others
can be discovered by inserting this line into your code and then deliberately
triggering an error (such as supplying a bad filename or form name, as in the
previous example):

MsgBox Err
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Using Keyboard Shortcuts

The usual Microsoft keyboard redefinition feature accessible via the Keyboard
button of the Customize dialog box (Toolsw>Customize) is available in Excel
and Word, from which you can easily assign and reassign keyboard short-
cuts. Access (sigh) lacks this feature. Instead, you have to assign keyboard
shortcuts to macros somewhat less directly in Access. To assign a keyboard
shortcut to a macro in Access, follow these steps:

1. Open the Northwind database.

2. In the Objects list of the main database window, click Macros.

3. Click New on the window’s icon bar.

The Macro dialog box opens, and a Macro Design toolbar appears.

4. Click the Macro Names icon on the Macro Design toolbar, as shown in

Figure 6-3.
Figure 6-3:
Create 5 N ED 4o .| § &=
keyboard : | 8]&f | o= S —
shortcuts in I
Access. w
The Macro dialog box divides into three zones: Macro Name, Action, and
Comment.
5. In the Macro Name column, type the key combination that you want to
s use to execute your macro.

The syntax for key combinations involves braces:

Enter This To Get This
NA Ctrl+A

{F1} F1

F1} Ctrl+F1
+{F1} Shift+F1
{INSERT} Insert

{DEL} Delete
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Click the Action column.
From the Action column list, choose RunMacro.
The Action Arguments changes to include a Macro Name field.

Click the Macro Name field in the Action Arguments section of the
dialog box.

Another drop-down list appears, containing all the macros in the current
database.

Click the name of the macro you want to assign this keyboard short-
cut to.

Close the macro window. In the Save As dialog box that appears,
name it AutoKeys.

Book V
Chapter 6
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Chapter 1: Outlook Power Tools

In This Chapter

v+ Discovering the new reading pane
v~ Fixing a filter

v Blocking spam

v Using encryption

v~ Flagging e-mail

1~ Using special folders

v Seeing double Calendars

0utlook 2003 is considerably changed from previous versions. This chap-
ter covers the changes of most interest to developers, including the
new reading pane, how to find “missing” e-mail, and the new spam-blocking
feature. Also of interest are the double Calendars, how folders are employed,
using flags to categorize e-mail, and how to manage encryption.

Using Outlook’s New Reading Pane

Probably the first thing that you notice in Outlook 2003 is the reading pane
on the right side. Many people find it easier to open their e-mail this way,
although you can still use the older Mail view. To avoid opening multiple
windows (one for each e-mail you double-click) or reduce the amount of
scrolling, this pane might be the way for you to go. Figure 1-1 illustrates how
efficient the reading pane can be.

Defaulting to Outlook

To make Outlook your default e-mail, Contacts, here.) Under the General section, select the
and Calendar application, choose Tools=> Make Outlook the Default Program blah blah
Options=>0ther. (See the Options dialog box check box, click OK, and you're good to go.
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Figure 1-1:
Use this
reading
pane to see
more of an
e-mail than
you could in
the older
style. Often,
scrolling
isn't even
necessary.
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Adjusting the Nasty Read Filter

Newcomers to Outlook 2003 are sometimes startled to find that as soon as

they read an Inbox e-mail message, then do something else, or close Outlook,
that particular message disappears! It cannot be found in Inbox or indeed in
any of the mail folders. In fact, another frightening moment occurs when you
realize that there are various categories of folders — personal, favorites,
searches, archives — that aren’t individual folders but rather groups of folders.
And when you look in the three Deleted Items folders (yes, there are three of
these, although they’re different listings for the same folder) or look in the two
For Follow Up folders, you won't find your e-mail anywhere. (This behavior is
quite different from how Outlook Express works. It leaves all your Inbox e-mail
alone unless you specifically delete it or move it.)

The problem is that a default filter is applied to the Inbox folder that auto-
matically hides e-mail that you've read (or even just glanced at). You might
find this a convenience, but if you don’t (and I certainly don’t), follow these

steps to make Outlook straighten up and fly right: that is, unhide already

read Inbox e-mail.

1. Select the Inbox (in the Mail column).
2. Choose Viewr>Arrange By=>Custom.

3. In the Customize View dialog box, click the Filter button.
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4. In the Filter dialog box, click the More Choices tab.
At long last (sheesh), you see the culprit, displayed in Figure 1-2.

Filter &

Messages | Mare Choices | Advanced | SQL

P|O{||V items that are: unresd "
méﬁ]'{ilms with: one of more attachments

—— [Clvwhose impartance s: normal
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Clear this [C]ttatch case

default filter e (Klobytes)

tO see yOUr doesn't matter E¥ () and 1

Inbox mail. ) Tere— s

N\

The check box next to Only Items That Are is selected by default, and
the filter is unread. This has the effect of showing you only those e-mails
that you've never seen before; all the other e-mails are not displayed.

5. Clear this check box to restore all your e-mail in the Inbox.

Why this is the default, and why you must maneuver through so many
twisted paths down into submenus and dialog boxes to finally rectify
this default behavior . . . well, it’s beyond me.

Outlook 2003 is in many ways a marvel of efficiency and ergonomics. In this
case, though, it seems both wrong-headed and poorly designed.

Managing Multiple Accounts

If you're savvy about e-mail, you likely have a very private e-mail address
known only to a few friends and business associates, whom you ask to please
never give out this e-mail address to anyone. Then you create a public e-mail
address (the one you provide when you buy things online, enter contests, or
otherwise risk having the address published or sold, thereby attracting the
usual hailstorm of spam).

Online services such as Hotmail (www.hotmail.com) are useful for setting
up a public e-mail account. But then you have to look for your e-mail in two
locations: your private e-mail program (such as Outlook) and your public
address (your browser where you log on to Hotmail or another Web-based
e-mail service.) No more. Now you can add public accounts like Hotmail to
Outlook so you can see all your e-mail in one application. Outlook will auto-
matically suck all your public account e-mail into a special Inbox.

Book VI
Chapter 1
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Figure 1-3:
Adding a
Hotmail
accountto
Outlook is
easy and
convenient.

To add a Hotmail e-mail account to Outlook, follow these steps:

1. Choose Toolsc>E-mail Accounts.

The E-mail Accounts wizard opens.

Select the Add a New E-mail Account radio button.
Click Next.

You see a list of server options.

Click the HTTP option button.

Click Next.

You see the wizard’s settings page.

used as your User Name), and then type in your Hotmail password.
7. Click Next and then click Finish.

After a little background work, Outlook adds a new folder category
named Hotmail to your All Mail Folders pane, as shown in Figure 1-3.
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Strangely, the Deleted Items folder appears at the top of the Hotmail category
(and other folders as well). I would prefer to have the Inbox located at the
top. After all, Inbox is by far the most often used of the categories of mail, and
the deleted mail folder is probably least used. And although you cannot drag
these folders to reposition them (arrrg; perhaps in the next version of
Outlook), you can rearrange the Favorite Folders.

To complete rerouting Hotmail to Outlook, follow the steps in Book VI,
Chapter 4.

Blocking Spam and Uirii

Figure 1-4:
Specify
here how
you want
Outlook
junk mail
handled.

A relatively sophisticated spam-blocking system has replaced the old rules-
based, anti-spam scheme that Outlook used to rely on (and that Outlook
Express still does). Various telltale cues — you know, the ubiquitous You've
Won! e-mail sent at 4 a.m. — are used to divide the good e-mail from the junk.
However, these filters aren’t perfect by a long shot, so you'll still get spam —
and virus-writers are even more clever than spammers.

Outlook 2003 offers several layers of protection. You can modify the file
types (executables like BAT, EXE, and so on) that are automatically blocked.
You can also force HTML messages to display as text. The new Junk E-mail
Filter can be modified by following these steps:

1. Choose Tools=>Options.

2. In the Options dialog box that opens, click the Junk E-mail button.

The Junk E-mail Options dialog box opens, as shown in Figure 1-4.
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() Safe Lists Orly: Only mal From peogle or domains on your Sefe
Senders List or Safe Recipients Lisk wil be debvered to your Inbox,

|| Permanently delets suspected junk e-mail instead of moving it bo the
Junk E-mai Folder
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By default, the level of blocking is set to Low, which probably makes sense for
most people. It blocks obvious junk but does let some through. An alternative
setting, High, seems rather pointless because it blocks so much that some
authentic messages get blocked along with the junk. So, you have to read
through the Junk E-mail folder to find which real messages got blocked by mis-
take. Given that this is what you have to do with no filtering selected, what'’s
the point of even trying to redirect some e-mail? You have to check it, anyway.

Also, you can specify that particular senders should always be blocked

from the settings available on the Blocked Senders tab (of the Junk E-mail
Options dialog box; refer to Figure 1-4). However, this isn’t much use unless
you have a stalker sending you messages. Spammers constantly change their
addresses, and virii writers often use your friends’ address books to harvest
your address, sending trouble your way by attaching a virus to e-mail that
appears to come from this friend. You'll find more on Outlook security meas-
ures in Chapter 4 of this mini-book.

You can update the Junk E-mail Filter detector software as Microsoft continues
to improve it. Go to this address:

http://www.microsoft.com/downloads/details.aspx?FamilyID=a
d3699f7-5cc3-4604-a768-32c4d044b630&displaylang=en

Using Encryption

Avoiding virii is only half of the e-mail security battle. The other half is pro-
tecting your privacy, including such things as confidential business details
or even certain kinds of monkey business. Encryption provides protection
against prying eyes, and digital signing authenticates that the person who
appears to have sent the e-mail actually did. Signing can also ensure that a
communication hasn’t been tampered with.

To see the level of encryption currently in effect for your company’s Office
2003 installation, follow these steps:
1. Run Word.
2. Choose FilebSave As.
The Save As dialog box opens.

3. Click the Tools drop-down list in the upper-right corner of the Save As
dialog box.

=

Choose Security Options from the drop-down list.
5. In the Security dialog box that opens, click the Advanced button.

The Encryption Type dialog box opens, as shown in Figure 1-5.



Figure 1-5:
Specify
more
advanced
encryption
from here.
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Encryption Type %]
Choose an encrypkion bype:

RiC4, Microsoft DH SChannel Cryptographic Provider

RC#, Microsoft Enhanced Crypographic Provider v1.0

RC4, Microsoft Enhanced D55 and Diffie-Hefrman Cryptographic Provider

R.C4, Microsaft Enhanced RSA and AES Cryptographic Provides (Protatype) |

Choose a key length:

As you can see in Figure 1-5, unless you've changed it, the default encryption
scheme employed by your company is Office 97/2000 Compatible. Although
not as laughably simple-minded as the XOR encryption system, the older
Office version of encryption was not a massively complex problem to solve.

It took me about four hours to crack it and to write a utility that decodes any
documents encrypted using the older versions of Word. I don’t need to know
the password; I just run my utility, and the document decrypts.

So, unless you absolutely require backward compatibility with earlier versions
of Office applications, I suggest that you select one of the DSS (symmetrical
encryption) options in the dialog box shown in Figure 1-5. DSS is quicker than
RSA (public key), but RSA is stronger. Unless you have relatively small docu-
ments, you might find RSA too slow. And DSS is plenty powerful. These encryp-
tion systems are explored in depth in Book VIII, Chapter 8.

You can also specify various key (password) lengths. Most modern encryp-
tion schemes permit several key lengths: the longer the key, the greater the
protection. Note, too, that the encryption schemes in the Encryption Type
dialog box are listed roughly in order of security. DSS should be good enough
for you; after all, it’s good enough for banks.

Logged on at Administrator level access, you can modify your users’ registries
to beef up the security level for each machine. Employ a configuration mainte-
nance file, a transform, an OPS file (Office profile settings), or distribute a Reg

file (having used File=>Export in Regedit).

To encrypt an individual e-mail message, follow these steps:

1. While viewing the message, click the Options button on the toolbar.

2. In the Message Options dialog box that opens, click the Security
Settings button.

The Securities Property dialog box opens.
3. Select the Encrypt Message Contents and Attachments check box.
4. Click OK.

Book VI
Chapter 1
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If you don’t already have a digital ID (used for both digital signatures and
encryption), you'll have to choose Tools=>Options, click the Security tab, and
click the Get a Digital ID button. You’ll be shown a Web site at Microsoft with
some third-party companies offering digital signing. This same Options dialog
box allows you to select the Encrypt Contents and Attachments for Outgoing
Messages check box. This option automatically encrypts all messages that
you send.

Flagging E-mail

Figure 1-6:
Easily tag
your e-mail
with these
flags.

\\J

The new Quick Flag feature allows you to rapidly categorize e-mail for later
handling. With one click next to an e-mail message, a red flag replaces the
pale gray flag, and the message is also automatically put into the For Follow
Up folder. Click the red flag, and it turns into a check mark, meaning that the
follow-up is finished and the message has been dealt with.

Right-click the flag, and a list of various additional flags appears, as shown in
Figure 1-6.

Arranged By: Flag |Red on kap

| Cublock 2003 Team 112472003 @,
Welcome ba Microsoft Offics Gutlook 2003 @_de Flag

Blue Flag

Yellow Flag
Green Flag
Orange Flag
Purple Flag

§ % € c g

Flag Complete
fdd Reminder...
Clear Flag

Set Default Flag »

All these different colored flags have no built-in meaning (other than the red
one and the check icon); Microsoft hasn’t labeled them. You decide what a
green or purple flag means. (I assume that purple represents royalty, so use
it for messages you get from the queen.) Also, others who send e-mail to you
can flag it; if their sense of its importance or category differs from yours, you
can easily reflag the message.

Messages flagged by senders are displayed at the top of the Unflagged Group
if you choose to arrange your messages by flag, as shown in Figure 1-7.
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The Add Reminder option (refer to Figure 1-6) allows you to specify a date
and time to be reminded about this message.

Using Special Folders

\\3

Messages that don’t belong in the built-in folders — Notes, Large Mail, and
For Follow Up — can be put into new folders that you create and name. For
example, right-click Personal Folders in the All Mail Folders list and then
choose New Folder. The Create New Folder dialog box appears, as shown in
Figure 1-8. Here, name the new folder, define what you want it to contain, and
give it a home; click OK.

Search folders are a special category of Personal Folders: For one thing, two
or more of these folders can contain the same message. Microsoft calls them
virtual folders, which should cue you that they’re not quite as real as the
other, more traditional, folders. You can group and view messages in these
search folders without having to actually copy or move them there. The For
Follow Up, Unread Mail, and Large Mail folders are provided as the set of
default search folders, but you can add new ones.

Large Mail is where e-mail with big attachments or huge messages are displayed.

The trick involved with search folders is that messages are automatically
included in these folders based on specified criteria. For example, when you
click the red flag on a message, it is automatically then available in the For
Follow Up folder although it also remains in the Inbox or whatever other
folder you placed it.

Book VI
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To create a custom search folder, follow these steps:
1. Right-click Search Folders in the navigation pane (the pane on the left
in Figure 1-8).
2. From the context menu that opens, choose New Search Folder.
3. In the New Search Folder dialog box that opens, scroll down to
Organizing Mail and then click Mail with Specific Words.
4. Near Show Messages That Contain These Words, click Choose.
5. Type Richard (or whatever other key term you want to use).
6. Click Add.
7. Click OK.

The new folder, named Containing Richard, appears under the Search
Folders group. When you click this new folder, you see a list of all mes-
sages containing your keyword. Remember, this is a virtual folder — that
is, a view of select e-mail — so the actual, real e-mails still reside within
whatever folders they are really contained, such as Inbox.
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Figure 1-9:
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In Step 3 of the preceding step list, if you choose Create a Custom Search
Folder rather than Mail with Specific Words, click Choose, and then click
Criteria, Advanced, and Field, you can go hog-wild in the Search Folder
Criteria dialog box, specifying nearly any kind of criteria you can imagine, as
shown in Figure 1-9.
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Using Twin Calendars

Also new in Outlook 2003, you can now view two or more Calendars side-by-
side, as shown in Figure 1-10. Comparing your schedule to a co-worker’s cal-
endar can be quite useful for setting up meetings and otherwise coordinating
joint projects. Likewise, you might want to compare your personal and busi-
ness calendars, or this year’s calendar with last year’s.

Book VI
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To create a new Calendar, follow these steps:

1. Choose Go=Folder List.
The Folder List appears.

2. Right-click the Calendar folder (not the colored, shaded Calendar
bar button).

3. Choose New Folder from the context menu that appears.
The Create New Folder dialog box appears.

4. In the Name box, type whatever name you want to give to your new
Calendar.

5. Click OK.

The dialog box closes, and your new Calendar is added to your list of
calendars.



Chapter 2: Programming Outlook

In This Chapter

v+ Understanding the Outlook object model
v Discovering namespaces

v Using MAPI objects

v Using practical VBA

+~ Handling events

In this chapter, you see how to take control of Outlook, programming it to
do your bidding. You see how the object model works and how to deal
with the special Windows Messaging API (MAPI) objects. And, of course,
you want to know how to trap events and respond to them programmati-
cally. As always, I try to provide examples that are simultaneously illustra-
tive and potentially useful in your efforts to improve Office efficiency and
increase productivity.

Discovering the Outlook Object Model

The Outlook object model is similar to the other Office 2003 application’s
class hierarchies, but there are some differences. For one thing, in the other
major Office applications, you can open multiple documents, workbooks,
tables, and other objects. In Outlook, there’s only one primary “document” —
the current contents of your Calendar, Contacts, Inbox, and so on. In other
words, there aren’t alternative repositories of data that you can save from
or load into Outlook the way you can open several documents in Word. For
this reason, Outlook’s library of objects contains no methods to save or
load files and otherwise manipulate multiple primary documents.

Outlook also employs special objects named explorer and inspector. The
former stands for each pane (zone onscreen) in which a folder’s contents
are displayed. The inspector is a pane in which a lone object is displayed.
For example, the window displaying a list of all your Inbox folder’s mail is an
explorer. Double-click an e-mail listed in that explorer, and that individ-
ual e-mail is then displayed in an inspector pane or window. To see the
Outlook object model, follow these steps:
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Figure 2-1:
Here's the
Outlook
object
model in all
its splendor.

1. Press Alt+F11 to open the Outlook VBA editor.
Choose Insert->Module in the VBA editor.

A new module window opens.

Choose Help-~>Microsoft Visual Basic Help.

The Help window opens.

in the Help window.

A list of subcategories is displayed.

Click Microsoft Outlook Object Model.

You see the diagram shown in Figure 2-1.

Click the book icon next to Microsoft Outlook Visual Basic Reference
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Using the Outlook Object Model

Try using the Outlook object model. Follow along to see how to automate
sending an e-mail with an attachment from Outlook. Type Listing 2-1 into the
module created in the preceding section:

Listing 2-1: Automating Sending an Outlook E-Mail with an Attachment
Sub SendEmail()

'create the object variables
Dim o As Outlook.Application Book VI
Dim oMail As Outlook.Mailltem Chapter 2

"Instantiate the new objects:
Set o = New Outlook.Application
Set oMail = o.Createltem(oIMailltem)

"Fill in fields and mail the message:
With oMail

JoopnQ
funwweiboid

.Importance = olImportanceHigh

.To = "richardm52@hotmail.com"

.Body = "Get this new message."

.Subject = "For YOU a new Message about our next Meeting!"
.Attachments.Add "c:\test.txt"

.Display

.Send

End With

"kill the objects
Set 0o = Nothing
Set oMail = Nothing

End Sub

This code creates a new e-mail message, specifies the target address, the
message (Body in the object model), types in the subject line, sets the
importance flag to High, attaches a file, and then displays and sends the
e-mail.

Outlook’s VBA has IntelliSense, so while you're typing lines of code, you’ll
usually see a list of options when you type a period (.) to signify a new ele-
ment in a chain of objects or a left parenthesis to signify that you're begin-
ning an argument list.
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Regrettably, the usual classification problems and inconsistencies associ-
ated with object models plague Outlook VBA. Whereas you can access a
Mail object via the Outlook Application object (as illustrated in the previ-
ous example), you cannot use the same technique to access a folder object.
Instead, you must use a namespace object.

Namespaces are a relatively new category: They first appeared in BASIC with
.NET. They’re intended to prevent one of the less-charming aspects of object-
oriented programming (OOP): name collision. In other words, you often pro-
gram with more than a single code library at the same time — for example, a
library of math functions and also a library of string functions. What hap-
pens, though, if both libraries include a function named Add? How is the
compiler to know which of the two functions you intend to use? That’s
where namespaces come in.

Why namespaces?

Why are they using namespaces? It’s a clerical thing, as is so often the case
with OOP. Namespaces can help prevent name collisions, although not
always. They’re enigmas, really, but you have to deal with them just as mar-
itime navigators must deal with sand bars. They're here and there, they're
sometimes in the way, they shift around unpredictably from one Application
Programmers Interface (API) to another — but can hang you up if you ignore
them.

Import or qualify

In .NET, you can add Imports namespaceName statements at the top of
the code window. Alternatively, you can qualify a function name each
time it appears within the source code, like this: namespaceName.
FunctionName. In effect, you're telling the compiler: “Use the function in
this namespace — not the other one if there’s one with the same name in
some other namespace.”

Confusingly, new terminology is constantly being introduced, often for no
good reason. The latest term for code library (or Dynamic Link Library, DLL)
is assembly. An assembly is a file containing a group of related functions,
such as the Microsoft Office Web Components Function Library. Assemblies,
when being added to a project, are called references. Now, one more point.
Don’t be upset, but I have to tell you that there can even be multiple name-
spaces within a single assembly — a single code library, a single DLL. So, you
must think of namespaces as virtual libraries of functions because a name-
space can refer to an entire physical library like a DLL, or it can refer merely
to a subset of functions in a library containing several namespaces.



Figure 2-2:
These
checked
code
libraries are
available by
defaultin
Outlook's
version of
VBA. Just
select new
libraries to
add them.

\\s

Using the Outlook Object Model 45 7

Sometimes, you might find that you need to actually add a library of code to
a VB project. In other words, a function or functions that you want to use
aren’t part of the default set of libraries available to VBA or VB.NET. VBA and
VB.NET both include a huge set of functions, so to write some programs, you
don’t need to import additional libraries. In other cases, though, you must
specifically choose Project>Add Reference in VB.NET — or in VBA, choose
Tools=>References, as shown in Figure 2-2.
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[

I+ Herosaft Office ik b FROVES]
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|l ACShelExk 1.0 Type Library +
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[ ArtPri Fxtensihii:

£ 1

Microsoft Cffice 11,0 Object Libeary
Locakion:  C:\Program Fles\Comman BlesiMicroscft SharedOFFICEL LM
Language:  Standard

To see which code libraries are added by default in VB.NET, right-click the
name of your project in Solution Explorer (it’s the boldface line), choose
Properties, and then select Imports in the Properties dialog box.

What happens, you might say, if you use the Imports command to specify
two namespaces that have a pair of identically named objects? Now you will
have a name collision — no doubt about it. Imports doesn’t help you distin-
guish between these objects because you've used Imports for both name-
spaces. The classification system has a kink or two, as you can see.

You can also create your own namespaces when programming. For example,
assume that you write code for a custom cursor class and put this class into
a namespace called NewCursors within your library MyObjects. Then you
reference it with the Imports command:

Imports MyObjects.NewCursors
And at the same time, you need to also reference the standard Windows
objects namespace (which includes controls such as the TextBox, as well as

other items such as default cursors):

Imports System.Windows.Forms

Book VI
Chapter 2
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You don’t need to actually use Imports System.Windows.Forms;it’s
already imported as one of the default libraries in VB.NET. I'm just showing
you an example here.

Now you have two namespaces in your project, each containing a (different)
cursor class. The only way you can distinguish them is to forget about the
Imports trick and just use the long form (fully qualify the object) whenever
you use the Cursor object. Here’s how you specify that you intend to use
the cursor in the System.Windows.Forms namespace:

Dim n As New System.Windows.Forms.Cursor("nac.ico")
Or, to use your personal custom cursor, fully qualify it like this:

Dim n As New MyObjects.NewCursors.Cursor("nac.ico")

Practical advice about namespaces

For VBA programmers: You can pretty much ignore namespaces because
they’re very rarely used in VBA. But do be aware of the concept of assem-
blies and namespaces because they’re coming down the river toward you
from the future. Eventually, .NET will replace the VBA languages built into
Office applications, so it doesn’t hurt to get used to these classification sys-
tems. True, they might be half-baked, not completely thought-through, and
too often inconsistent and clumsy — but you just have to live with things
like this as programming evolves through its current airy, academic phase
into something more practical (I hope). After all, this isn’t the first time that
programming has suffered from the introduction of ill-conceived new ideas
that upon later reflection had to be yanked from the languages because they
caused so much trouble. Two examples of now-disgraced — although once-
highly touted — concepts are dynamic link libraries (which resulted in the
phrase DLL Hell) and the Variant variable type (which still exists in VBA
but has been banished from VB.NET).

For NET programmers: Don’t worry about adding extra Imports statements
that you actually use in your program: Namespaces neither increase the size
of your executable (EXE) program nor slow execution. VB.NET is a huge lan-
guage. It includes more than 60 .NET assemblies (code libraries), containing
the hundreds of .NET namespaces. Each namespace contains many classes.
In turn, these classes have multiple members (methods you can employ;
properties you can read or change). Also, many of the methods are over-
loaded: They often permit you to provide a variety of arguments to make
them behave in different ways. As you can see, hundreds of thousands of
commands and variations of those commands are in this language.
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What to do if you're a VB.NET programmer? You’ll master the important
tools fairly quickly — file input/output (I/O), printing, useful constants, inter-
acting with the user, debugging, and so on. Most of these major programming
techniques are different in .NET from their VBA counterparts but are not
unrecognizably different. Also, you can use VB.NET Help’s Search and Index
features as well as the Object Browser when needed. To see the format,
syntax, punctuation, and (sometimes) code examples of the many classes, try
this approach. Run the Help Index and then type the following into the Look
For field. (Cutting and pasting doesn’t work; you must type this in.)

system.drawing.

You then see the massive number of classes listed in the left pane. Click any Book VI
of these classes to see its members and other information about how to use Chapter 2
it. Each page contains hyperlinks that take you to more specific information
about particular members. -
(=]
The more practice you get using VB.NET, the more you’ll learn about which gﬁ
namespaces you need to import. The most common namespaces are auto- S g
matically imported by VB.NET when you create a new project. These seven = é

are imported by default: Microsoft.VisualBasic (a compatibility name-
space, permitting you to use most VB6 and VBA constants and functions,
such as InStr rather than the new .NET equivalent, Index0f, System,
System.Collections, System.Data, System.Diagnostics,
System.Drawing, and System.Windows.Forms.

Using the MAP] Namespace

To manage folder objects in Outlook, you must refer to the Windows
Messaging API (MAPI) namespace. This is the only namespace within the
Outlook application object, but for some reason, when working with folders,
you cannot simply use the App1ication object by itself as you do with most
other Outlook objects. Perhaps more namespaces will be added later.
(Search folders, though, are not included in the MAPI namespace, so you
have to use different techniques with them.) MAPI itself puts you in touch
with stored mail messages, among other things.

The following example illustrates how to use the MAPI object (yes, name-
spaces, like nearly everything else, are objects) to switch to the Tasks view
in Outlook:

Sub SwitchToTasks()

Dim o As Outlook.Application
Dim n As Outlook.NameSpace
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Set o
Set n

CreateObject("OQutlook.Application")
0.GetNamespace("MAPI")

Set o.ActiveExplorer.CurrentFolder =
n.GetDefaultFolder(olFolderTasks)
End Sub

The first four lines of this code merely get you the handle (the address of)

to the MAPI namespace inside the App1ication object. You can then employ
the GetDefaultFolder method of the MAPI namespace to change the
CurrentFolder property. The other possible arguments for the GetDefault
Folder method are o1FolderCalendar, olFolderContacts, olFolder
DeletedItems,olFolderDrafts, olFolderInbox, olFolderdournal,
olFolderNotes, olFolderOutbox, ol1FolderSentMail, olFolderTasks,
olPublicFoldersAlT1PublicFolders,and ol Folderdunk.

The Explorer object contains the contents of the currently viewed folder. In
other words, when you look at your Inbox or view a list of Tasks, you're look-
ing at an Explorer. There’s also an Inspector object that displays more
specific data, such as a single e-mail when you double-click in an Explorer
view of your e-mail. These terms have no particular use nor pattern across
different applications, so the only reason to pay any attention to them is that
they’re your passport to accessing this particular object model’s behaviors
and elements.

Using Practical UBA in Outlook

Suppose that a new wind of political change again sweeps the nation, and
now you’re supposed to refer to people as Ms or Miss rather than either
single title. Whatever. But you, clever you, decide that you can automate this
process. Instead of laboriously opening each name in your Contacts folder,
and modifying some of them as required by the latest cultural shift, you
whip up a little VBA code to do the job for you. Here’s how.

You first want to change any name that begins with Miss to Ms or Miss. Use
the code in Listing 2-2 to rifle through your contacts and make the changes:

Listing 2-2: Search-and-Replace Example in Qutlook

Sub MissToMs ()

Dim n As OQutlook.NameSpace
Set n = Application.GetNamespace("MAPI")
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Dim f As Outlook.MAPIFolder
Set f = n.GetDefaultFolder(olFolderContacts)

Dim o As Object
Set o = f.Items.GetFirst

For Each o In f.Items

If Left(o.FullName, 4) = "Miss" Then

o.FulTName = "Ms or " & o.FullName
0.Save
End If
Next
Set o = Nothing
Set f = Nothing
Set n = Nothing
End Sub

First, you do the usual drill of creating object variables and then instantiat-
ing objects for them to refer to. You end up with a generic object, a MAPI
namespace, and a Contacts folder object. Your object uses the GetFirst
method to point to the first item in the Contacts folder — the first Contact,
in other words. Then you go through each item (each Contact) and see
whether its Ful 1Name property begins with Miss. If so, you make the change
by prepending Ms or; then you save the item back into the collection with
the change. Then you go through the usual drill of destroying the objects
you created. Setting things to Nothing causes some confusion. Some
experts insist you always must do this to save memory, to free up resources,
or to prevent problems. Others say that the garbage collection truck will be
along in due time to automatically destroy unused objects. (It knows they're
unused because they’re only local in scope, having been instantiated within
a procedure, and no other references to them exist.) So you can leave off the
three lines ending in Nothing ... and nothing is going to happen. That is,
unless the other experts are correct in their warnings and memory or
resources get all clogged up from pointers pointing to nothing. I've never
noticed a problem.

The Contacts Items collection can contain distribution items as well as
Contacts items. If this is the case, you might try to access properties that
distribution items don’t have. If this problem applies to you, add this test to
the loop in the previous example to filter out the distribution items:

If o.MessageClass = "IPM.Contact" Then

Book VI
Chapter 2
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Handling Events

You might want to insert some VBA code into one of Outlook’s built-in
events to customize Outlook’s behavior. To see the available events for the
Application object, choose View=>Project Explorer, and then double-click
ThisOutlookSession in the Project Explorer. Open the list box on the left
top of the code window and choose Application. Then open the other list
(right side), and you see all the events for the AppTication. Choose Quit
(the event that fires when you close Outlook). In this event, type this code:

Private Sub Application_Quit()
MsgBox ("Tell Mary to go home.")
End Sub

Now close Outlook, and you see the reminder to tell workaholic Mary it’s
time to pack it in.

Open the Outlook VBA editor Help window. In the Table of Contents,

choose Microsoft Outlook Visual Basic Reference; under that, click Events.
You'll find a large number of events for various objects within Outlook.
Unfortunately, creating code for most of these events is rather indirect and
complex — you have to insert Wi thEvents commands, initialize the handler
in the Application_Startup event, and such twists and turns. Fortunately,
the Help system contains quite a generous number of code examples.

Advanced Searching

If simple searches aren’t enough, Outlook also includes an object modestly
named AdvancedSearch. Use this object to really take the bull by the horns.
Interestingly, AdvancedSearch requires that you split your code into two
procedures. You start the search in a procedure of your own. Then, when the
search is finished, it triggers the AdvancedSearchComplete event where
you write code to handle the results.

To see how it works, press Alt+F11 to open the Outlook VBA editor. Choose
Inserte>Module if no Modulel is listed in Project Explorer. Type this public
variable at the very top of Modulel:

Public r As results

Making a Pub1i ¢ variable allows you to easily pass the results object
between procedures. This object will contain the — you guessed it — results
of the search, and you want to display in a text box the body of any e-mail
message the user clicks in the list box.
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Choose Insert>UserForm and put a small text box on the top left, a list box
underneath it, a button on the top right, and a text box under the button. It
should all look like Figure 2-3.
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Double-click the button on the UserForm and type this code into its C11ck
event:

Private Sub CommandButtonl_Click()

Dim s As Search

where = "'Inbox
n = "urn:schemas:mailheader:subject LIKE '%" & TextBoxl.Text & "%'"
Set s = Application.AdvancedSearch(where, n, True)

End Sub

When the user clicks this button, the search is initiated in the Outlook Inbox
(although you can change the where variable here to point to any target you
want to search — perhaps put a group of radio buttons on the form, and let
the user click the target).

Whatever the user has typed into the small text box will be the search term,
and by surrounding it with % symbols, you're saying, Include any additional
text on either side. In this way, searching for bob will also provide hits for
bobby, joe-bob, and so on. This search looks through the subject headers

of each e-mail — not the body text, although you can change that. (See
AdvancedSearch in Outlook VBA Help for additional ways you can specify
the search fields and the search term.) The final argument True in the pre-
ceding code means to search all subfolders.
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In this same UserForm, double-click the list box so you can provide a way for
the user to click an e-mail subject header and thereby cause that e-mail’s
text (the actual message) to be displayed in the text box to the right of the
list box:

Private Sub ListBox1_Click()

Dim rr As results
Set rr = Modulel.r

TextBox2.Text = rr(ListBoxl.ListIndex + 1).Body

End Sub

Notice that you create an object variable rr to hold the results and point it
to the public variable r that you previously declared in Modulel.

Now all that’s left to do is to write some programming in the
AdvanceSearchComplete event. Double-click ThisOutlookSession in Project
Explorer to open the module where Application events are located. Use
the list boxes at the top of this module’s code window to open the
Application_AdvancedSearchComplete event and type this into it:

Private Sub Application_AdvancedSearchComplete(ByVal
SearchObject As Search)

Set r = SearchObject.results
If r.Count = 0 Then
UserForm3.ListBox1l.AddItem ("NOTHING FOUND MATCHING " &
UserForm3.TextBox1l.Text)
Else

For i = 1 To r.Count

UserForm3.ListBox1.AddItem (r(i).Subject & " " &
r(i).SenderName)
Next i
End If

End Sub
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Here you point Modulel’s public variable r to the results returned by the
SearchObject. If the count property of this object is 0, no hit was found, so
you tell the user. Otherwise (E1se), you display the Subject property for
each hit that was found in the list box.

[ suspect that you might prefer to use the above example code to construct
your own custom search utilities for Outlook messages. Also note that you
can conduct as many as 100 multiple simultaneous searches (for example,
searching through several folders at the same time). To run multiple searches,
just call the AdvancedSearch method in successive lines of source code.

Book VI
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Chapter 3: Managing Work
and Life

In This Chapter

+~ Handling Contacts

v+~ Sending Access data into Outlook
1 Creating and displaying folders

+* Modifying collections

v Searching Tasks

»* Managing the Calendar

+»* Moving data from Outlook to Word

v Using the new Business Contact Manager

In this chapter, I explore how to program several of Outlook’s primary
features: Contacts, Tasks, scheduling, and the Calendar. You begin by
solving a common programming problem: how to transfer data from one
application to another. Fortunately, the rich object model available in most
Office 2003 applications makes the process of automating data transfer rela-
tively painless. As usual, the only real pain is figuring out the necessary
syntax. The objects are there; you just have to know how to reference them
and punctuate correctly.

Do This First

For the example code in this chapter to work, you must first set the follow-
ing references:
1. Press Alt+F11 to open the Outlook VBA editor.

2. Choose Tools=>References in the editor and ensure that you have
selected the following three libraries:

e Microsoft Office 11.0 Object Library
e Microsoft Outlook 11.0 Object Library
e Microsoft DAO 3.6 Object Library



468 Sending Access Data into Qutlook

Each of these libraries should have a check mark next to its name in the
References dialog box.

3. Close the References dialog box.

Sending Access Data into OQutlook

WING/
g‘?‘

For this example, suppose that you have a table in Access containing a list of
employees for a particular company — in this case, the Northwind sample
database. You want to import this data into Outlook’s Contacts folder.

If you execute this example code, you’ll want to later delete the nine new
Contacts that the example adds to your current list of Contacts. You don’t
want to clutter up your Contacts list with the fakes added during this example.

Choose Insert>Module in the Outlook VBA editor. A new module appears for
you to type in the following subroutine (Listing 3-1):

Listing 3-1: Importing Access Data into Your Outlook Contacts List

Sub ImportAccessData()

Dim DAOdb As DAO.Database
Dim r As DAO.Recordset

Set DAOdb = OpenDatabase _
("c:\Program Files\Microsoft Office\Officell\Samples\
Northwind.mdb")
Set r = DAOdb.OpenRecordset("Employees™)

'create outlook object variables
Dim o As New Outlook.Application

Dim ¢ As Qutlook.ContactItem
Dim upr As Outlook.UserProperty

With r
.MoveFirst
" Loop through the Access records
Do While Not .EOF

' Create a new Contact object
Set ¢ = o.Createltem(olContactlitem)

' Transfer data to existing Outlook contact
categories:

"If I[ACCESS FIELD NAME] <> "" Then
OUTLOOK.FIELDNAME = !'[ACCESS FIELD NAME]
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If ![LastName] <> "" Then c.FullName = ![LastName] &
I[FirstName]

If I[Titlel <> "" Then c.JobTitle = I[Titlel]

If I[BirthDate] <> "" Then c.Birthday = ![BirthDate]

If ![HomePhone] <> "" Then c.HomeTelephoneNumber =
I[HomePhone]

If I[Notes] <> "" Then c.Body = "Personality defects
or positives: " & ![Notes]

" Create an Outlook user property for any missing
fields.

Set upr = c.UserProperties.Add("Hire date at
Northwind", olText)

' send the data from the appropriate Access field:

If ![HireDate]l <> "" Then upr = ![HireDate]

' Save then destroy the contact object
c.Save
c.Close olDiscard

.MoveNext
Loop
End With

End Sub

P Some Outlook fields are not named the same way that they are labeled in the
Outlook Contact dialog box. For example, the Phone Numbers area in the
Contact dialog box contains four possible entries, so PhoneNumber alone
won’t work. (One of these fields must be referred to as
BusinessTelephoneNumber in programming code but is labeled Business
in the dialog box.) To see the list of field names that you should use in your
code, type c. in the code below this line of code:
Set ¢ = o.Createltem(olContactItem)
Typing c. (with the dot) opens the IntelliSense list with all the different field
names for a contact object, as shown in Figure 3-1.
A VhaProject.0TH - Modulel {Code) 9|E1%]
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In this example, you declare DAO database and recordset objects, open the
sample database, and then open the Employees table. Then you declare
outlook application,contact, and userproperty objects. Next,aWith
block defines what you’re going to do with r, which is the recordset contain-
ing the Access data from the Employees table. You move to the first record
with the .MoveFirst method, and then begin a loop that iterates through
the entire recordset via the .MoveNext method. The loop terminates when
an EOF (end of file) is located.

You create a new Contact object each time through the loop and then stuff
that object’s fields with the data found in the various fields in the EmpToyee
table. The names of the fields don’t always match. Indeed, in the first field
(what Outlook calls Ful1Name), you have to concatenate two fields from the
Access table: LastName and FirstName. Likewise, Access’s Tit1e field
becomes JobTitle in Outlook, and Birthdate becomes Birthday. So it
goes.

Notice that what Access accurately calls Notes, Outlook (for some reason)
calls Body. (Calendar notes are also in a field named Body.) Also, this line of
code illustrates how you can add your own comments to incoming data. This
line prepends your comment "Personality defects or positives:"to
each incoming notes field value from Access:

If I[Notes] <> "" Then c.Body = "Personality defects
or positives: " & ![Notes]

Why do this? Because field values (data) are raw data that, in some cases,
you might want to prepend a description to (for the same reason that you
might stamp Personnel on each resume sent to you). Prepending descrip-
tions can help categorize and identify data.

Finally, for data that you want to transfer but which has no prebuilt field
already defined in the Outlook Contact dialog box, you can define a user-
defined field, displayed in the All Fields tab of the dialog box, as shown in
Figure 3-2.

You create a user field by first using the Add method of the UserProperties
object, defining the name of the new field:

Create an Qutlook user property for any missing
fields.

Set upr = c.UserProperties.Add("Hire date at
Northwind", olText)

Then you transfer the data from Access to your new field in the Contact
object:

If I[HireDate] <> "" Then upr = ![HireDate]



Figure 3-2:
Create your
own custom
fields from
this tab of
the Contact
dialog box.

Displaying a Folder Item 471
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Displaying a Folder Item

Sometimes you want to programmatically display a folder to the user. In this
next example, you see how that’s done. In this case, you display the New
Contact form to the user. Type this procedure (Listing 3-2) into your code
window.

Listing 3-2: Displaying a Folder for User Interaction

Sub ShowNewContact()

Dim o As New Outlook.Application
Dim ns As Qutlook.NameSpace
Dim f As Outlook.MAPIFolder
Dim ¢ As Qutlook.ContactItem

Set ns = o.GetNamespace("MAPI")
Set f = ns.GetDefaultFolder(olFolderContacts)

Set ¢ = f.Items.Add("IPM.Contact")
c.Display

End Sub

This task requires that you create the usual Outlook objects, and then use
the GetDefaultFolder method of the Application object to access the
Contacts folder (via the enum in the method’s argument). Then you use the
Add method to create a new Contact and display the dialog box for that
Contact.

Book VI
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S

For more information on the unfathomable, enigmatic world of namespaces
and object-oriented programming (OOP) nomenclature schemes, see Chap-
ter 2 of this mini-book. As an example, the Windows Messaging API (MAPI)
namespace in Outlook is a strange requirement in many programming
instances. You’'ll find that for much programming written in Outlook VBA,
instantiating a MAPI namespace is required, although for other types of
programming, it’s not needed. Efforts on the part of this author to find any
pattern or rule defining when this namespace must be included in your
Outlook programming have failed. Undoubtedly, there’s some arcane techie
explanation, but I've never come across it. The only rule I know of is that
you must instantiate a MAPI namespace whenever your program won't exe-
cute without it.

MAPI is the only namespace in Outlook, so including it is pointless: Having to
declare it is rather like adding Planet Earth to every letter that you address.
It’s assumed because (as yet) there are no post offices in outer space . . . but
never mind. Just follow the rules and, as Little Richard likes to say, “Shut up!”

You might think that MAPI would be needed for any programming that
accesses the Outlook Mail folder’s methods or sends e-mail via Send meth-
ods. Not so. You can leave MAPI out of your code when you use the Send
method of the AppointmentItem object, as illustrated later in the section
“Using Calendar Automation.” So, do what’s needed, don’t try to figure out
the taxonomy for heaven’s sake, and just shut up!

Creating a New Contacts Folder

How about creating an entirely new folder? Declare the usual variables,
instantiate the usual objects, and provide a name for the new folder
(see Listing 3-3). It’s now part of your Outlook, as shown in Figure 3-3.

Listing 3-3: Creating a New Outlook Folder
Sub AddNewFolder()

Dim o As New Outlook.Application
Set o0 = CreateObject("Outlook.Application")

Dim ns As Outlook.NameSpace
Set ns = o.GetNamespace("MAPI")

Dim fo As Outlook.MAPIFolder
Set fo = ns.GetDefaultFolder(olFolderContacts)

Dim fn As Outlook.MAPIFolder
Set fn = fo.Folders.Add("NewContacts")

End Sub



Figure 3-3:
Add new
folders
easily with
the
Folders.
Add
method.

Making Mass Modifications

Your new Contacts folder now appears in Outlook.
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Making Mass Modifications

Sometimes you need to loop through a set of data, gathering certain values
and building the data into a list. In the following example, you use the Items
collection — also very common in .NET programming — to access the data
in a Contacts folder. Specifically, you want to build a list of names and birth-

days of all the Contacts.

Type this procedure (Listing 3-4) into your Outlook VBA editor.

Listing 3-4: Building a List of Data

473

Sub Iterating()

0.GetNamespace("MAPI")

Dim o As Outlook.Application
Set o = New Outlook.Application
Dim ns As Qutlook.NameSpace

Set ns =

Dim ¢ As Qutlook.Items

Set ¢ =

For Each i In c

ns.GetDefaultFolder(olFolderContacts)

.Items
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If i.Birthday <> "" Then a = a & i.FullName & "," &
i.Birthday & ","

i.Close olDiscard
Next

MsgBox a

Set ¢ = Nothing

Set ns = Nothing

Set o = Nothing
End Sub

Notice that in this code, you don’t create an o1ContactItem object during
each iteration through this loop, as you did in the ImportAccessData
example earlier in this chapter (Listing 3-1) using Set ¢ = o.Createltem
(olContactlItem). Instead, you get an Items collection holding the items
from the Contacts folder (in other words, all the individual contact records).
Then you use a For Each loop, which doesn’t care what variable you use

(i in this example) to iterate through the collection, any more than a For
Next loop cares whether you use i or j or whatever. This same technique
can be used to write data to the fields instead of reading it as is done here.
To write, simply use the syntax i.birthday =.

You inspect each record, reading the birthday field to see whether it has any
data. If so, you add the name and birthday values to your list, delimiting
them with commas. A list like this can be imported into other applications,
such as Access.

Searching Tasks

You can search any of the Outlook collections by using a variation of the
techniques described in previous examples, along with a Find method. This
code (Listing 3-5) searches through a Tasks folder to see whether a Task is
specified as high priority.

Listing 3-5: Searching the Tasks Folder

Sub searchTasks()

Dim o As Qutlook.Application
Set 0o = CreateObject("OQutlook.Application")

Dim ns As Qutlook.NameSpace
Set ns = o.GetNamespace("MAPI")

Dim ts As OQutlook.MAPIFolder
Set ts = ns.GetDefaultFolder(olFolderTasks)
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Dim t As Qutlook.TaskItem
Set t = ts.Items.Find("[Importance] = ""High""")

If t Is Nothing Then 'no high priority items
MsgBox "No High Priorities"
Exit Sub 'quit

Else
MsgBox "The following high importance item was found:
" & t.Subject
End If
End Sub

The Find method of the Items collection can be used to locate the first
match. If you want to find more matches, use the FindNext method. This is
an alternative way to search through a collection than techniques employing
For Eachor For Next.

Using Calendar Automation

In this chapter and the preceding one, I cover a variety of programming tech-
niques involving Outlook Tasks, Mail, and Contacts. [ don’t want to ignore
the important Calendar folder, though, and its scheduling capabilities. You
can create new Calendar entries, send meeting notices, and, in fact, pretty
much do anything you want with the Calendar features via VBA.

This example illustrates how to set up a meeting, require that some employ-
ees attend, and then send them e-mail notification of the compulsory meet-
ing. Their Outlook calendars will be updated to include this meeting and its
details. This example doesn’t require that you instantiate the MAPI name-
space, even though it sends messages. There’s no accounting for OOP classi-
fication schemes, so there’s often no predicting what objects are needed and
what aren’t in any given instance. Do you object to this kind of arbitrariness?
Well, shut up!

Type this (Listing 3-6) into the VBA code window.

Listing 3-6: Setting up an Outlook Meeting

Sub SetMeeting()

Dim o As Outlook.Application
Set o = CreateObject("Outlook.Application™)

Dim a As Outlook.AppointmentItem
Set a = o.Createltem(olAppointmentItem)
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Dim required, required2 As Qutlook.Recipient

"force these two to attend:

Set required = a.Recipients.Add("Janice Loez")
required.Type = olRequired

Set required2 = a.Recipients.Add("Richard Mansfield")
required.Type = olRequired

With a

.Subject = "Bob's Wife's Party"

.Body = "Everyone's invited to see their great new house and
to provide presents.”

.Al1DayEvent = True

.MeetingStatus = olMeeting

.Start = #8/18/2004 8:30:00 AM#

.Duration = 600 "ten hours!

.Save

.Send

End With

Set 0o = Nothing
Set a = Nothing

End Sub

You want to send e-mail notices to two recipients in this code, so you define
two recipient objects:

Dim required, required2 As Outlook.Recipient

Then you instantiate them and add them to your Recipients collection,
specifying that their attendance is mandatory.

Set required = a.Recipients.Add("Janice Loez")
required.Type = olRequired

Set required?2 = a.Recipients.Add("Richard Mansfield")
Required2.Type = olRequired

Then you enter a Wi th block, where (no particular order is required) you
define various properties of this new meeting:

With a

.Subject = "Bob's Wife's Party"

.Body = "Everyone's invited to see their great new house and
to provide presents.”

.MeetingStatus = olMeeting
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.Start = #/8/18/2004 8:30:00 AM#
.Duration = 600 'ten hours!
.Save

.Send

End With

Typing a period (.) anywhere within this block brings up an IntelliSense list
of all the members of the AppointmentItem object.

In this example, you're only setting a few of the 68 total AppointmentItem
object’s properties. For one thing, the End property isn’t necessary if you
provide a Duration property. Outlook calculates the ending time for you,
as illustrated in the End Time field displayed in Figure 3-4.

[l Bob's Wife's Party - Meeting = %]

i File Edit Wiew Insert Format Tools Actions Help
|l Save and Close | =4 {] | 43 8 | 2 Recurrence... | ! & | X | @ 2

Appaintment | Scheduling Tracking |

Figure 3-4:
The recipi-
ents of your
meeting
notice will
find that this
Appointment
item has
been
automati-
cally added
to their
Calendar.
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End time: Wed B/18/2004 w| oM [w

[Creminder: 15 minutes Bz Show time as: | Il Busy bl

Mesting Workspace,., | [ This is an online meeting using: | Misrnscls Mekti==ting
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Contacts... f Caregoties... privats [ |

Then, after the property fields have been filled in, you save this new item to
your Calendar folder and send it to the previously instantiated Recipients
objects. They will get e-mail notices, and their Calendars will automatically
be updated.

Using non-Outlook e-mail programs

If the recipient gets e-mail in a program other than Outlook — such as in
their browser via Hotmail while on the road — he simply finds an attach-
ment to your message. If he opens this attachment in Notepad or some other
text editor, he sees this:

Book

Vi

Chapter 3

ajI7 pue
yiop Buibeuepy



4 78 Using Calendar Automation

Figure 3-5:
Even people
who don't
get their
mail directly
in Outlook
can import
Appoint-
mentItem
attachments
into OQutlook,
like this.

BEGIN:VCALENDAR

PRODID:-//Microsoft Corporation//Outlook 11.0 MIMEDIR//EN

VERSION:2.0

METHOD: REQUEST

BEGIN:VEVENT

ATTENDEE ; ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:richardm52@hotmail.com

ATTENDEE ; ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:richardm52@hotmail.com

ORGANIZER:MAILTO:earth@triad.rr.com

DTSTART:20040818T133000Z

DTEND:20040818T233000Z

TRANSP: OPAQUE

SEQUENCE: 0

UID:040000008200E00074C5B7101A82E00800000000703049E897E9C3010000000000000000100
0000034EF463C8AC0644D90F5284190214507

DTSTAMP:20040202T1921547

DESCRIPTION:When: Wednesday\, August 18\, 2004 8:30 AM-6:30 PM (GMT-05:00)
Eastern Time (US & Canada).\n\n*~*~*~*~k~k~k~k~*~*\n\nEveryone's invited
to see their great new house and to provide presents.\n

SUMMARY :Bob's Wife's Party

PRIORITY:5

X-MICROSOFT-CDO-IMPORTANCE:1

CLASS:PUBLIC

END:VEVENT

END:VCALENDAR

Of course, some details will differ (such as UID and DTSTAMP), but this illus-
trates the interior structure of a Calendar appointment item as Microsoft
transmits it between Outlook instances. You can think up a special code for
the Subject property, such as this:

.Subject = "APPT: Bob's Wife's Party"

Then when one of your associates receives a message where the Subject line
begins with APPT:, he knows to open it in Outlook. Opening this attachment
in Outlook integrates the message into his appointments, as shown in

Figure 3-5.

7 Bob's Wife's Party . Meeting /et
i File Edit View Insert Format Tools Actions Help
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Location:
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E'.-’eryone's invited to see thair great new house and to provide prasents.
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Appointmentltem members

The AppointmentItem object offers quite a few properties and methods.

Here are the 68 AppointmentItem properties: Actions, Al1DayEvent,

Application, Attachments, AutoResolvedWinner,BillingInformation,

Body, BusyStatus, Categories, Class, Companies,
ConferenceServerAllowExternal, ConferenceServerPassword,

Conflicts, ConversationIndex, ConversationTopic, CreationTime,
DownloadState, Duration, End, EntryID, FormDescription

GetInspector, Importance, InternetCodepage, IsConflict,

IsOnlineMeeting, IsRecurring, ItemProperties,
LastModificationTime, Links, Location,MarkForDownload

MeetingStatus, MeetingWorkspaceURL, MessageClass, Mileage, Book VI
NetMeetingAutoStart, NetMeetingDocPathName, Chapter 3
NetMeetingOrganizerAlias, NetMeetingServer, NetMeetingType,
NetShowURL, NoAging, OptionalAttendees, Organizer,
OQutlookInternalVersion, QutlookVersion, Parent, Recipients,
RecurrenceState, ReminderMinutesBeforeStart,
ReminderOverrideDefault, ReminderPlaySound, ReminderSet,
ReminderSoundFile, ReplyTime, RequiredAttendees, Resources,
ResponseRequested, ResponseStatus, Saved, Sensitivity, Session
Size, Start, Subject, UnRead, and UserProperties.
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Here are the 14 AppointmentItem methods: ClearRecurrencePattern,
Close, Copy, Delete, Display, ForwardAsVcal, GetRecurrencePattern,
Move, PrintQOut, Respond, Save, SaveAs, Send, ShowCategoriesDialog.

Outside Outlook: Extracting
Data from Outlook to Word

Because Office applications each specialize in different tasks, you often find
that you want to send data from one application to another. For example,
Word is clearly the best place to format documents, so if you have a list of
data in Outlook that you want to edit in a document, send the Outlook data
to Word. If this transfer of data is something you do often, automating the
process is quite a bit faster than copying and pasting individual data from
one application to another.

In this example, you write code that extracts a subset of AppointmentItems
from your Outlook Calendar and then sends the list to Word for distribution

to others or for printing as hard copy. It would be pretty slow and boring to

have to locate each item in this subset by hand, and then copy it to Word.
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This code is designed to execute from within Word. So start Word up and put
the code into Word’s VBA editor. In Word, press Alt+F11 to open the VBA
editor. Then (in the editor) choose Tools>References and select Microsoft
Outlook 11.0 Object Library to add these functions to your project. Finally,
type this macro (Listing 3-7) into the Word VBA editor.

Listing 3-7: Sending Outlook Data to Word

PubTic Sub MonthsAppointments()

Dim o As Outlook.Application
Set o = New Outlook.Application

Dim ns As Outlook.Namespace
Set ns = o.GetNamespace("MAPI")

Dim m As Qutlook.MAPIFolder
Set m = ns.GetDefaultFolder(olFolderCalendar)

Dim a As Outlook.AppointmentItem
' create a date one month from today:

mo = DateAdd("d", 30, Date)

Selection.TypeText "This Month's Appointments"
‘move down two Tines

Selection.TypeText vbCrLf

Selection.TypeText vbCrLf

For Each a In m.Items
d = a.Start

If d >= Date And d <= mo Then

X=X+1
s=X&". " &a.Start & ": " & a.Subject & vbCrLf
s =35 &" Start: " & Format(a.Start, "Long Time") & vbCrLf
s =s&" End: " & Format(a.End, "Medium Time") & vbCrLf
s =s&" Location: " & a.location

Selection.TypeText s
Selection.TypeText vbCrLf & vbCrLf

End If

Next

End Sub
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When you press F5 to execute this, all the appointments in your Outlook
Calendar for the next 30 days are listed in a Word document, starting wher-
ever the blinking insertion cursor is currently located.

After the usual object instantiations, as described throughout this chapter,
you create a date variable containing whatever date is 30 days from today:

mo = DateAdd("d", 30, Date)
Then you use the Word Selection object to type a title for the list and move

down two lines with the vbCrLf enum (built-in constant). Then you move
through the entire collection of appointments, checking whether any fall

ey s Book VI
. 130
within the specified dates: today to today +30: Chapter 3
d = a.Start
If d >= Date And d <= mo Then =
[
Y -
If so, data about the appointment is printed in the document, along with an 3_@,
incrementing number X at the start of each entry. o8
(1]
s
=

Using the New Business Contact Manager

A new add-in available for Outlook 2003 called Business Contact Manager
(BCM) allows business people to record, track, and organize their profes-
sional activities from within Outlook (where their Contacts, schedules,
Tasks, Calendar, and other utilities also reside). BCM becomes a new folder
in Outlook. BCM is essentially a specialized database where you can enter
and manage the following:

4+ Leads: Info about how to contact the potential human targets of your
sales pitch (also know as opportunities)

+

Products: What you want to sell to leads

+

Existing customers: Former leads

4+ Prospects: Same as leads but perhaps closer to conversion into
customers

4+ Narratives: Describing your various schemes and plots, and lessons
learned from previously unsuccessful schemes and plots
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Chapter 4: Expert E-Mail
Administration

In This Chapter

v~ Effective routing during vacation
1 Managing multiple accounts

v Using Send/Receive Groups

v Blocking virii

Fis chapter focuses on e-mail and the most significant, e-mail-related fea-
tures that Outlook offers users, administrators, and others working with
Office 2003. You see how to automate routing, handle multiple e-mail accounts
from disparate sources, manage groups, and block virii.

Exploring Messaging Management

E-mail management and general messaging within Outlook 2003 is extremely
flexible. Indeed, messaging throughout Office 2003 applications allows you
to pretty much call the shots any way you want them.

For example, you can use Exchange to send a Word document to a folder in
someone’s Outlook application. In Word, choose Filec>Send To, and a con-
text menu pops up with a nice choice of targets, as shown in Figure 4-1.

Choose Exchange Folder from the context menu (if Exchange Server is avail-
able to your office). You see a list of possible targets, including your own
Outlook application, as shown in Figure 4-2.
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Choose Mail Recipient (as Attachment) to employ the more conventional
approach: ordinary e-mail. The familiar Outlook e-mail form appears, with
your file attached, as shown in Figure 4-3.
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Routing: Out of Office Assistant
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P If you right-click a filename in Windows Explorer, you’ll find a Send To con-

text menu. It’s not as full-featured as the Office 2003 applications’ Send To
option, but you can choose Mail Recipient. If you do, an Outlook Mail dialog
box opens with the file attached to the message. Unfortunately, the message
is filled in for you, with the following sentence, which is sure to confuse the
recipient of this e-mail. Who thought this default message was a good idea?

Your files are attached and ready to send with this
message.

If you try to send a BMP file, you're offered the option of letting Outlook
“make all my pictures smaller.” (The picture isn’t actually made smaller, per
se, but its file size shrinks because it’'s compressed. This is an admission that
JPG graphics files are superior — less bloated — than BMP files.) If you
select this option, your BMP is converted to a JPG.

Routing: Out of Office Assistant

Using the routing feature requires an Exchange Server e-mail account. If
you’re going to be gone for a while from your desk, you can use the Out of
Office Assistant to follow various rules about how to handle incoming e-mail.

E-mail can be automatically deleted (you know, those useless notes and gossip
from that pest, Anthony, in R&D), route other e-mail to particular folders,
respond with individualized replies, and so on.
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You must leave Outlook running the whole time you’re gone on vacation for

To see how to automatically respond to incoming e-mail, follow these steps:

cannot be used to autoreply because it must be turned off when you

abbreviated because you have a more limited menu and toolbar features

=

i

\\3
this autoresponse technique to work.
1. Choose Toolsc>Options in Outlook 2003.
2. Click the Mail Format tab of the Options dialog box.
3. Deselect Use Microsoft Word 2003 to Edit F-mail Messages.
\3
P This can be restored after you get back from vacation. This option
save a message as a template.
4. Click OK.
The dialog box closes.
5. Click the Mail folder; then click New on the toolbar.
A new e-mail message dialog box opens (see Figure 4-4), somewhat
than you do in Word 2003.
When | return - Message (HTML)
i Eila Edit View Insert Format Tools Actions Help
iagend | 6 ;éh--:l |1 | A B F D E=ZiciziEE
[ Tou. | |rehacmighotme com
Figure 4-4: l%l e Lretum
Thisisn'tthe | . Nitsy,
full-featured |
message Isrgor:—n in the office either! fm on a fact-finding trip to Las Vegas. See you
box that Besl. Harold
borrows
from Word
2003.

6. Type the message you want automatically sent to your boss if she
should e-mail you from her “study retreat” in Monte Carlo.

7. Choose Filer>Save As.

8. In the Save As dialog box that opens, name this file AutoNitsy.

9. Open the Save as Type drop-down list.

You see a list of various kinds of file options.

10. Choose Outlook Template.
11. Click Save.
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Figure 4-5:
Specify the
target
person in
your
Contacts
list.

Routing: Out of Office Assistant 48 7

12. Close the message dialog box and don’t save a draft.
13. Choose Tools->Rules and Alerts.

If the Rules and Alerts option isn’t visible, you haven’t closed the mes-
sage dialog box. Repeat Step 11.

14. In the Rules and Alerts dialog box that opens, click the New Rule link
in the dialog box.

The Rules Wizard opens. You've created and saved a message that can
automatically be sent to the intended recipient, Nitsy, your boss, in this
example.

In the following steps, you use the Rules Wizard to specify behaviors that
result in an automatic response on Outlook’s part.

. Select Start from a Blank Rule.

. Select Check Messages When They Arrive.

. Click Next.

. Under Select Conditions, select the From People or Distribution List
check box.

N W N~

Select Received in a Specific Date Span in this list if you want to reply
with an out-of-office message to all incoming e-mail.

5. In the Edit the Rule Description list, click the people or distribution
list link.

The Rule Address dialog box opens, as shown in Figure 4-5.

Rule Address %]
Type Name or Select from List: Show Names From the:
Contacts »
| Hame Display Mame E-mail Address
Janice Logz richardmSzhotmail. ... fchardmS2@hotmal .,
{7 iksy BallingerHirihi richardms2@hatmail.... richardms2@hctmal. |
Richard Mansfisid richardmS2@hatmail..... richardmS2@botmal.,
% | >
o ) Lo

Book VI
Chapter 4

uonensiuwpy
|ieN-3 wadxg



48 8 Using Multiple E-Mail Accounts

\\J

6. Click the From button in the dialog box.

Your target person’s e-mail is entered into the dialog box.
7. Click OK, and then click Next.

You see a new page in the wizard.

8. In the What Do You Want to Do with the Message list, choose Reply
Using a Specific Template.

9. Click the a specific template link.

10. In the Look In list, choose User Templates in File System.

You should now see the template that you named AutoNitsy in Step 7 of

the preceding step list.
11. Click AutoNitsy, click Open, and then click Next.

You see a list of exceptions, such as (apply this rule) if sent only to me.
For example, you might want to respond at once — not automatically,
but personally — if the boss sends you a personal e-mail.

12. Click Next.
13. Type AutoNitsy for the rule’s name.

You gave the template underlying this rule this descriptive name, and it

works just as well for the rule itself.
14. Click Finish and then click OK.

The dialog box closes, and your rule is in effect as long as someone

doesn’t turn off your computer or close Outlook. (You can, of course,
turn off your monitor while you're in Vegas. What happens there, stays
there.)

Using Multiple E-Mail Accounts

\\J

You can set up more than a single e-mail account, just as you can have a
home, business, and PO box address for regular mail. With Outlook 2003,
you can also redirect Web-based accounts, such as Hotmail, to Outlook.

An advantage of adding Internet-based accounts to Outlook is that your local
machine has lots of storage for keeping Inbox and Sent Items e-mail. This can

be important if you need to search your e-mail for addresses, discussions,
and so on. Internet-based e-mail accounts are notorious for deleting e-mail
that you don’t want to discard. These accounts have limited storage, but

when you dump your online folders into Outlook folders, you preserve these

potentially important e-mail records.
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Also, if you maintain several accounts within Outlook, you can use rules like
those described in the preceding section to route incoming e-mail to the
proper folder, set flags on it, adjusting priorities, sending automated replies,
and so on. You often set up Send/Receive Groups for different connection
settings. When using this technique, you can segregate e-mail accounts to
prioritize your response, based on the different Groups.

Here’s the difference between creating new folders and new Send/Receive
Groups.

Folder: Create a folder if you're currently working on a project with sev-
eral colleagues. You can set up this special folder just for communica-
tions about that project. This simplifies reading your e-mail because you
would look in this account only when you were interested in working on
that particular project.

Send/Receive Group: Create a separate Send/Receive Group for differ-
ent kinds of e-mail connections. If you're a road warrior, you know that
many hotels don’t yet have broadband. To get around this limitation,
you might want to set up a Send/Receive Group that initially downloads
only message subjects rather than the entire body of the message. Slow
Internet connections can make this technique a real timesaver. (Obviously,
at home or the office where you’ve got a cable/modem connection, you
wouldn’t benefit from this approach.)

Using Exchange Server

Exchange Server has been around for about eight years in one guise or
another. Although Exchange Server makes possible some of the more
advanced features of Outlook, studies say that only about 50 percent of
people using Outlook also employ Exchange Server. With Exchange Server,
you get some offline features, allowing mail management while not con-
nected to the Internet. These days, though, with always-on connections and
high-speed, broadband throughput, the advantages of working offline are
rapidly diminishing.

Also, when you maintain two folders — one on a server and one in a

laptop or desktop — you face the old bugaboo of version control issues.
That is, how can you reconcile two different versions of file collections? The
process of reconciling files — either duplicated, edited responses, or two
collections — cannot be successfully automated because no current pro-
gramming language taps into the necessary artificial intelligence. Humans
must step in and decide which collection, or file, is the current one. Simple
rules that can be programmed, such as the which comes last rule based on
deleted earlier versions, are not sufficient. Sometimes date/timestamps do
not reveal which version should survive.
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Figure 4-6:
Specify
new Send/
Receive
Groups
here.

Some office situations, however, make server-based e-mail stores practical:
for example, if you travel around the office and need to access e-mail from
different computers, or if you're on the road. Also, some offices ask people
to share accounts for one reason or another.

Working with Send/Receive Groups

To set up a Send/Receive Group, follow these steps:

1. Start Outlook.

2. Choose Tools=>Send/Receiver>Send/Receive Settings->Define Send/
Receive Groups.

You see the Send/Receive Groups dialog box, as shown in Figure 4-6.

Send/Recelve Groups 6%
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[ ]5chedule an automatic sendrecsive every | % minubes.

You see that all your current accounts are in a single Send/Receive
Group and any new account you might add will be automatically saved
into this same Group.

3. Click New.
A new Group can now be added.

4. Type Hotmail or Priority or whatever other name describes this new
group.

5. Click OK.

You see the Send/Receive Settings dialog box. You can specify qualities
of your new Send/Receive Group in this dialog box. The left pane lists
your e-mail accounts.



Figure 4-7:
This dialog
box displays
the options
for your
account.
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6. To add an account, select Include the Selected Account in This Group.

You see the options for routing mail incoming from this account, as
shown in Figure 4-7.

Send/Receive Settings - Priority %]
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5 i (3) () Download complete Eem including
W[ ) Inbox (14) stachments
[CIC3 Inbox ARCHIVES
VL Junk E-Mai
WL =) Sent Ibems

7. Click OK after specifying which folders you want included in this
Group’s Send/Receive.

The dialog box closes, and you're returned to main Send/Receive Groups
dialog box where you can now see the new Group that’s been added to
your default Group.

8. Click Close to complete the process.

Avoiding Virii

The simplest and most effective advice on avoiding virii is to not open e-mail
attachments and to maintain frequent backups. These two steps should pre-
vent nearly all problems unless you have someone in your organization who
deliberately introduces problems.

If you’re an administrator, [ suggest that you prevent most of your co-workers
from opening attachments at all. Where transferring files is necessary, take
steps to institute digital signatures, certificates, IDs, or whatever other
secret code or authentication process makes sense for you. In a small office,
where everyone inside can be trusted, your authentication process can be as
simple as adding a line to the e-mail message, such as “This is from Betty. It’s
OK, as we agreed.” Personalized or previously agreed-upon statements like

Book
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this — or phone calls verifying the attachment — are unique to your organi-
zation and cannot easily be replicated by the bad guys.

Outlook automatically blocks executable attachments (.exe, .scr, .bat,
and . js), but virii authors are becoming increasingly clever. Users simply
cannot open these files at all.

To adjust Internet security settings, follow these steps:

1. Choose Tools->Options.
2. In the Options dialog box that opens, click the Security tab.

You see available security options. Explore the Zone Settings and other
buttons on this dialog box to see which levels of restriction should be
enforced for your employees.



Chapter 5: Group Management
in Qutlook

In This Chapter

+* Working with profiles
v+~ Sharing schedules

v+ Planning meetings

People, of course, work together in groups in most businesses. Outlook
can help you avoid stepping on each other’s toes in various ways. In
this chapter, you see how to establish profiles so that different users work
with their own, custom virtual Outlook. You also explore the new shared
Calendars feature — introduced in the first chapter of this mini-book — in
greater depth. You see how to use the feature to make collaborative work
more efficient by setting up a Web site to store calendar information.
Another topic covered is Microsoft’s Free/Busy Service, allowing you to
automate the process of organizing meetings. The chapter concludes with
various other utilities that assist with meetings, including reserving that
slide projector.

Using Profiles

Profiles are yet another way to organize Outlook and its contents. Just as
you might have various Windows profiles for each person who uses your
home computer, you can also establish multiple Outlook profiles at work if
more than one person uses a single machine. (You can also use a new profile
to clean up a messy Outlook setup; read on.)

P With profiles, it’s as if there were several different Outlooks, each with its
own customizations for different purposes or for different people. When you
turn on Windows and choose a Windows profile, the desktop and many
other aspects of Windows can look different from different profiles on that
same computer. Similarly, different Outlook profiles might have different
default folders. For example, one profile might display the Mail folder first,
and another the Calendar folder.

A profile includes toolbar settings, accounts, connection settings,
AutoComplete files, views, navigation pane settings, security preferences,
color and design choices, and others.
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Figure 5-1:
Use this
wizard to
create a
new profile.

Creating a new profile can also be useful if you’ve really messed up your
Outlook. Suppose you've created too many different folders, imported too
many Contacts or Appointments, or otherwise have gotten confused. If

you want to start over, create a new profile and make it the default folder

(as shown in the upcoming Figure 5-3). You'll lose whatever data you've
entered, but perhaps this is an easier path to follow than uninstalling/rein-
stalling if Outlook gets hopelessly mucked up. To create a new profile, follow
these steps:

1.
2.

Close Outlook.

In Windows XP, choose Start=>Control Panel. In Windows 2000,
Start=>Settings~> Control Panel.

The Control Panel opens.
Double-click the Mail icon.

In the Mail Setup dialog box that opens, click the Show Profiles
button.

You see the Mail dialog box.
Click Add.

You see the New Profile dialog box.

6. Type in a name for your new profile, perhaps Private.

Click OK.

The E-mail Accounts Wizard (sometimes oddly referred to as the Custom
Installation Wizard) opens, as shown in Figure 5-1.

E-mail Accounts (%]

This wizard will allow you to change the e-mail
accounts and directories that Outlook uses.

E-mail
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(2 Vizw or change exdsting directories or address books
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8. Following the successive wizard pages, create as many e-mail
accounts as you wish for this new profile.

9. Click OK to close the wizard.

You see the Mail dialog box again, as shown in Figure 5-2, but now it
includes your new profile.

Mail B
Genaral
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; Book VI
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10. Decide which of your profiles should be the default when you open
Outlook, or whether you want to see a dialog box each time and make
a selection, as shown in Figure 5-3.

Figure 5-3: Choose Profile %]
To selecta
. Frofile ame:  Privat M, .

profile, have T v [ v ]
this dialog
box open

(Lo J
whenever

Cpthrs

Outlook ] 5ek as clofault profile
opens.

The option you choose, as well as any new profiles you've added, aren’t
available until you restart your computer.
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Just as with your default Outlook profile, you can create multiple e-mail
accounts. If you copy a profile, this resets its views and toolbar settings to
their original default state yet retains any personalization done to e-mail
accounts, connections, security settings, and folders. Bizarrely, there is some
leakage between profiles. Most custom settings are correctly preserved for the
different profiles, but some are not. For example, if you change the back-
ground color of the Calendar in one profile, all other profiles also reflect this
new color.

If you get tired of always having to choose between profiles every time you
start Outlook, it’s not enough to click the Remove key in the Mail dialog box
(as described in Step 4 of the preceding example). In fact, you need not
remove a profile at all; just select the Always Use This Profile radio button in
the Mail dialog box.

Sharing Calendars

You can use Exchange Server as a way of sharing schedules with your co-
workers. This is fine if you're in an office that uses Exchange Server, but fewer
than half of today’s offices do. Also, if you have traveling salesmen, or other
people who aren’t always connected to your LAN, it’s easiest to rely on Micro-
soft’s Free/Busy Service. It’s on the Web, so you can use it anywhere.

Why share Calendars? Meetings can be easily set up when you can see
whether everyone is free at a particular time. Also, travel can be more easily
planned, projects can be more efficiently organized, and so on. Collaborative
work often requires that people take a look at each other’s Calendar. In Office
2003, you can view two Outlook Calendars at the same time, but many times,
you need to look at more than just two.

Setting up your own site

If you don’t use Exchange Server, you can still employ any Internet site

or intranet server that you control as a store for iCalendar information.
(iCalendar is the format used to compare schedules.) Just publish your data
and ask others to publish theirs — then everyone can see what times are
free and what times are busy. Exactly why they’re busy doesn’t show up. To
use an ordinary server, follow these steps:

1. In Outlook choose Tools=>Options.

2. In the Options dialog box that opens, select the Calendar Options
button on the Preferences tab.

You see the Calendar Options dialog box.



Figure 5-4:
This is your
gateway to
Internet-
based
scheduling.
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3. Click the Free/Busy Options button.
You see the Free/Busy Options dialog box.
4. Select the Publish at My Location option.

5. Fill in your server’s URL address, or LAN address, in the text box.

Using Microsoft’s Free/Busy Service

With the Free/Busy Service, you can share schedules with anyone who uses
Microsoft Passport. This schedule sharing can be accomplished no matter
where you might be located, thanks to the Internet. This is a good way to
automatically remove scheduling conflicts when planning group activities,
such as meetings. Everyone publishes his or her Calendar (free and busy
times) and then Outlook’s meeting request feature uses this Free/Busy
Service to help you pick a good time for everyone to get together.

To use Microsoft’s Free/Busy Service, everyone you want to schedule with
must have a Microsoft Passport account. If you invite nonmembers to join in,
they’ll first be asked to get a Passport account. To use the Microsoft Free/
Busy Service, follow these steps:

1. Choose Tools->Options.

2. In the Options dialog box that opens, click the Calendar Options
button on the Preferences tab.

You see the Calendar Options dialog box, as shown in Figure 5-4.
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3. Click the Free/Busy Options button.
You see the Free/Busy Options dialog box.

4. Select the Publish and Search Using Microsoft Office Internet Free/

Busy Service check box.
5. Click the Manage button.

Your browser opens displaying the Web site where this service is

located.

If you already have a Passport account and are currently signed in, click the
Sign Out button on the Web page (at the preceding URL), and then click the
Sign In button. Things should work smoothly from there on.

After your Passport account has been reconciled with Outlook, you can
permit Outlook to communicate automatically with the online service and
display available meeting times when you or others request a meeting.

Planning Meetings

Figure 5-5:
Specify start
and end
times,
attendees,
and other
information
for a new
meeting
here.

If you want to schedule a meeting, select the Calendar view and then choose
Actions>New Meeting Request. You see the Plan a Meeting dialog box, as

shown in Figure 5-5.

Z__i?_'_Plan a Meeting
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Make Meating Close

Note that you can visualize the start and end time of your meeting by the
green (go) line symbolizing start and the red (stop) line for the end. These
lines can be dragged with your mouse to adjust the meeting span.
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You're essentially creating an e-mail in the dialog box shown in Figure 5-5,
albeit a specialized one. Note: You can add graphics, files, or other attach-
ments if you wish.

If you prefer, wait to add attendees until you click the Make Meeting button
and go to the next dialog box where you can quickly add names by clicking
the To button, as shown in the upcoming Figure 5-6. However, skipping this
Planning dialog box doesn’t allow you to check the free/busy status of your
attendees (as I describe in the preceding section).

Notice in Figure 5-5 that a key to various colors appears in the lower left.
People without published schedules (you don’t have access to their free/
busy information because they’ve refused to grant this permission, or they
don’t have an Exchange server or Free/Busy account) are indicated by
slashed lines.

A solid block of color (under 9:00 in the Figure 5-5) shows that person is
busy from 9:00 to 9:30.

If someone has slashed lines indicating that her schedule is unavailable to
Outlook and she is on Exchange server, it’s possible that somehow her Free/
Busy data is corrupt. Try starting her Outlook by using the /cleanfreebusy
command line switch. This will both clear up and regenerate her Free/Busy
data.

Click the AutoPick Next button (refer to Figure 5-5) to have Outlook auto-
matically find the next available time during work hours when all required
attendees and resources are simultaneously available. You can refine how
AutoPick Next works by clicking the Options button and then moving your
mouse pointer down to AutoPick in the context menu.

If you click the Add Others button, you see a list from Exchange’s global
address list or from your Address Book or other source. Three buttons
appear at the bottom of the Select Attendees and Resources dialog box. You
can assign Required or Optional categories to each attendee or click the
Resources button to specify resources. Note: Resources are things (not
people), like PowerPoint projectors, models, videoconference setups, and so
on. These resources must have previously been defined as recipients on the
Exchange Server, but I must report that people are referred to as resources
(and worse) by certain hard management types.

When you’re satisfied with the details of the meeting, click the Make Meeting
button. You then fill in an e-mail form that is automatically sent to anyone
you specified as an attendee in the previous dialog box. Figure 5-6 illustrates
how you prepare to send invitations to a meeting.
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Figure 5-6:
Fill in the
meeting title
(Subject),
location,
and other
details here.
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i=1Send | Accounts~ | 4 [ |42 & | T} Recurrence... | 1 B} | X | @

(3
@

= B

Appointment

| 1nve

| Schedding |

Hater Beebe {Blater@timer Jocy; Mamby Jones {mambylones@arco.com)

Subject:

Plarring Group
Location: | My Office a | Labed: ([ Mane v
Starktime;  Wed 2/11/2004 [a] 1m:zoam (v Clandag event
End time: Wed 2/11/2004 v 1nooam [
[Creminder: 15 minutes Bz Show time as: | Il Busy |

Mesting Worekspace,., | [1Thisis an online mesting using: | Misrosais Nebie=ting

Conkacts... .Categnries...

privats [ |

If you want to further specify the nature of the meeting, click the Categories
button or type in a message in the text box beneath the Meeting Workspace
button. When you're finished, click the Send button on the toolbar, and
e-mail is automatically sent to your attendee list, as well as notices and
reminders (if any) entered into their Outlook Calendars.

Click the Scheduling tab shown in Figure 5-6 to get to the same free/busy
view illustrated in Figure 5-5. You can check others’ schedules either first
(as described earlier) or after you've filled in the invitation e-mail, as shown
in Figure 5-6.

Responding to invitations

After your invites have been sent out, the startled targets see a special e-mail
in their Inbox, complete with several filled-in responses: Accept, Tentative,
Decline, and Propose New Time. (Too bad The Heck With You! isn’t on the
list.) A user can click any of these responses to reply to the sender, as shown
in Figure 5-7.

Tracking responses

Nothing is sadder than sending out birthday party invitations to your child’s
“friends” and then watching the clock tick-tock as the party start-time passes
and nobody shows up. (It’s no good telling the little person that popularity
fades and surges throughout life: Sometimes you’re nobody, and then a few
years later, you might be elected prom queen!)
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o Accept | P Terrative | 3¢ Decine , Proposs New Time 5 Calendar. ..
Figure 5-7: Our Meeting
Simplify A Richard Mansfield [ear@tid cor]
your rep|y ived For this 0.
by ClICkIng L::;Ei::\:fz?::‘:::r;oz, 2004 2:00 AM-F:30 &M,
any of the
links at the
top of the
meeting
invitation
e-mail.
To see how people are responding to your meeting invitations — and risk a
possible personality collapse if nobody replies — right-click a meeting that
you scheduled in your Calendar. Choose Open from the context menu. You
see the same dialog box shown in Figure 5-6, but now it has a Tracking tab
added to it. Click that tab, and you see the dialog box shown in Figure 5-8.
1 Our Meeting - Mesting 3|=2[x]
: File Edit View Insert Format Tools Actions Help
; | Save and Close | = | 1 &, | 2 ¥Recurrence... | ¥ I | X | @ 4
Appointrient Schediding Tracking | |
The fallwing responses to this meeting have been received:
Naire [attendance Resporss
=l|Richard Marwsfield cearth@tria) Meeting Orgarizer None
{=Arichar dmS2@hotmail.com Foquired Attendes Maone
Click bere ko add a name |
Figure 5-8:
Nobody has
accepted
your
invitation.
Could it be
unpopu-
larity?!

Setting up resource responses

Whoever manages company resources — meeting rooms, laser light shows,

expensive catered hors d’oeuvres, company apartments, whatever —

can work with administrators or developers to automate the process of
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allocating time at the apartment for visiting bigwigs or arranging a real nice
spread for the next fancy meeting. (I suggest lobster-asparagus salad, a pile
of giant shrimp mounded on crushed ice, rumaki, mushrooms stuffed with
crab . .. things like that. Martha would know what to order.)

To make such arrangements do this, choose Tools=>Options and then click
the Calendar Options button. Click the Resource Scheduling button to open
the dialog box shown in Figure 5-9.

Resource Scheduling %]

Processing meeting requests

o Use these options if you are responsible for coordinating resources,
i such as conference rooms,

[#]dutematically accept meeting requests and process cancelabons

Figure 5_9: [ Automatically dedling pecurring mesting requests

Automate You must give users permission to view and edit this calendar iF you
wark: these options ba work offiine.

resource

allocation

here. Co ]

Select the check boxes shown in Figure 5-9 to specify the options you want.
Then click OK to close the Resource Scheduling dialog box and begin the
automatic process of coordinating and scheduling resources.
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Chapter 6: Advanced Qutlook
Macros

In This Chapter

1 Accessing other Office applications from within Outlook
v Trapping events
1 Searching e-mail

v Paying attention to macro-ergonomics for the user

T) run the programming code in this chapter, you must first ensure
that the necessary code libraries are referenced in the Outlook VBA
editor. As grammars go, few world languages — either historical or
contemporary — are as mangled and senseless as the mishmash grammar
underlying computer languages.

Most features of computer languages have multiple names, often with no
distinctions in meaning — not even subtle distinctions. For example, the
term function has lately been less popular than the term method, although
they mean the same thing.

Likewise, when you add a reference to a VBA project, you find many, many
synonyms for what is probably best described simply as a code library: that
is, a collection of code into a library that adds functionality (adds new func-
tions, usually) to a programming language such as VBA. Synonyms for code
library include

Assembly Host object model
Control library Proxylib

Control type library Type library

Class library Plug-in

Object library Plug-in type library
Namespace Services

Project model Services library

Object model Development environment
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Core type library Kernel
Extensibility Helper (17 This one must have been
named by a seven-year-old just before

Runtime library .
nap time.)
Runtime execution DLL (for dynamic link library)

library

Runtime execution
engine

Some will argue that distinctions are here. Indeed, in some cases, adjectives
such as core, control, or plug-in do shade the meaning a bit. But nearly all the
terms in this list are mere synonyms without even a delicate distinction
between them.

Some of the terms are simply bizarre. One popular usage, object library, just
makes no sense. The distinction between classes and objects is that the
latter exist only during runtime, during execution of a program. The proper
term is class library, for the same reason that you don’t confuse a cookbook
with a cafeteria.

So, take a deep breath, kiddo, try to ignore the mess and confusion, and run
Outlook. Press Alt+F11 to open the VBA editor, and then choose Tools=>
References to open the References dialog box. Ensure that the check boxes
next to following code libraries are marked:

4+ Visual Basic for Applications
4 Microsoft Outlook 11.0 Object Library

4+ OLE Automation
4+ Microsoft Office 11.0 Object Library

Interacting with Other Office Applications

You can use the CreateObject command to instantiate an instance of an
outside application and then send data to it. Here’s an example that creates
a Word document, sends an e-mail from the Outlook Inbox, and then prints it
in the Word document.

Open Outlook and press Alt+F11 to get to the VBA editor. Type in this macro
(Listing 6-1).
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Listing 6-1: Sending Inbox E-mail to Word and Then Printing It

Sub SendEmailToWord()
Dim o As Qutlook.Application
Set 0 = CreateObject("Outlook.Application")

Dim ns As Qutlook.NameSpace
Set ns = o.GetNamespace("MAPI")

Dim f As Outlook.MAPIFolder
Set f = ns.GetDefaultFolder(olFolderInbox)

On Error GoTo ErrorHandler

Title = f.Items(2)
Body = f.Items(2).Body

"Title: " & Title & vbCrLf & vbCrLf
s & "Bo