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Why

Introduction

’ve been writing about Macromedia Dreamweaver since the first version
came out in the mid 1990s, and I'm pleased to say that this latest (and
long-awaited) version 8 makes this program better than ever. If you've never
used Dreamweaver before, don’t worry; this book shows you everything you
need to know about the old features, as well as the new ones. If you have
used earlier versions of Dreamweaver, it’s definitely time to upgrade and
make sure you have all the tools available to create a fabulous Web site.

If you're like most of the Web designers | know, you don’t have time to wade
through a thick book before you start working on your Web site. That’s why I
wrote Dreamweaver 8 For Dummies in a way that makes it easy for you to find
the answers you need quickly. You don’t have to read this book cover to
cover. If you're in a hurry, just go right to the information you need most and
get back to work. If you're new to Web design, or you want to really get to
know the intricacies of Dreamweaver, skim through the chapters to get an
overview and then go back and read what’s most relevant to your project in
greater detail. Whether you are building a simple site for the first time or
working to redesign a complex site for the umpteenth time, you find every-
thing you need in these pages.

Choose Dreamweaver?

With each new version of Dreamweaver, this award-winning program
becomes more efficient and powerful. Yet somehow, Macromedia continues
to make Dreamweaver intuitive and easy to use, even as its programmers
work long hours to keep up with the latest innovations in Web design and
release a new version of this program nearly every year since its creation.

The high-end features and ease of use of Dreamweaver make it an ideal
choice for professional Web designers, as well as for those new to working on
the Internet. And the new features in version 8 make Dreamweaver better
than ever!

I've been reviewing Web design programs since the first ones hit the market
in 1994, and I can assure you that Dreamweaver is the best one I've ever
worked with. But don’t take my word for it — Dreamweaver has already won
a slew of awards over the years, including Best of Show at Internet World, the
prestigious five-mouse rating from MacWorld, and Best Web Authoring Tool in
the Readers Choice Awards by PC Magazine.
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Among all the Dreamweaver features, these are some of the best:

v Dreamweaver has clean HTML code and sophisticated support for the
latest HTML options (such as Dynamic HTML).

v Cascading Style Sheets, better known as CSS, have become popular
among professional Web designers. It’s no wonder; this powerful part of
the HTML code can save considerable time and give you greater design
control than ever before. As you’'d expect, Dreamweaver 8 offers more
sophisticated support for CSS and better rendering within the design
environment.

v Dreamweaver 8 even makes adding high-end features for creating database-
driven Web sites easier. These features used to be sold separately in
Dreamweaver UltraDev, but since Dreamweaver MX 2004, they’ve been
integrated into this one powerful program. Now, in version 8, these fea-
tures have been further refined and enhanced to work better than ever.

v As in previous versions, you find a state-of-the-art integrated text editor
that makes switching back and forth between Dreamweaver and a text
editor easier (if you prefer to look at the code, behind your pages you
find some great enhancements to the text editor in this version).

If you've never written HTML before, don’t be intimidated by these fancy
features. The Dreamweaver graphical design environment uses carefully
designed palettes and windows to make it easy for you to create high-end
Web sites that include such features as animations, interactive forms, and
e-commerce systems, even if you don’t know HTML.

Foolish Assumptions

Although Dreamweaver is designed for professional developers, [ don’t assume
you’re a pro — at least not yet. In keeping with the philosophy behind the For
Dummies series, this book is an easy-to-use guide designed for readers with a
wide range of experience. Being interested in Web design and wanting to
create a Web site is key, but that desire is all that I expect from you.

If you're an experienced Web designer, Dreamweaver 8 For Dummies is an ideal
reference for you because it gets you working quickly with this program, start-
ing with basic Web page design features and progressing to the more advanced
options for DHTML and database-driven sites. If you’re new to Web design,
this book walks you through all you need to know to create a Web site.
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About This Book

[ designed Dreamweaver 8 For Dummies to help you find the answers you
need when you need them. You don’t have to read this book cover to cover
and memorize it (and [ don’t really recommend this as beach reading). Con-
sider this a quick study guide and a reference when you need it. Each section
of the book stands alone, giving you easy answers to particular questions and
step-by-step instructions for specific tasks.

Want to find out how to change the background color on a page, create a
nested table, build HTML frames, or get into the really cool stuff such as style
sheets and layers? Then jump right in and go directly to the section that most
interests you. Oh, and don’t worry about keeping all those new HTML tags in
your head. You don’t have to memorize anything. The next time you need to
do one of these tasks, just go back and review that section. And don’t worry
about getting sand on this book if you do take it to the beach — I promise it
won’t complain!

Conventions Used in This Book

Keeping things consistent makes them easier to understand. In this book,
those consistent elements are conventions. Notice how the word conventions
is in italics? That’s a convention I use frequently. [ put new terms in italics
and then define them so that you know what they mean.

When I type URLs (Web addresses) or e-mail addresses within regular para-
graph text, they look like this: www. jcwarner . com. Sometimes, however, I set
URLs off on their own lines, like this:

wWww . jCcwarner .com

That’s so you can easily spot them on a page if you want to type them into
your browser to visit a site. I also assume that your Web browser doesn’t
require the introductory http: // for Web addresses. If you use an older
browser, remember to type this before the address (also make sure you
include that part of the address when you're creating links in Dreamweaver).

Even though Dreamweaver makes knowing HTML code unnecessary, you may
want to wade into HTML waters occasionally. I include HTML code in this
book when I think it can help you better understand how HTML works. When
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[ do provide examples, such as this code which links a URL to a Web page, |
set off HTML in the same monospaced type as URLs:

<A HREF="http://www.jcwarner.com">Janine's Web Site</A>

When I introduce you to a new set of features, such as options in a dialog
box, I set these items apart with bullets so that you can see that they’re all
related. When [ want you to follow instructions, | use numbered steps to walk
you through the process.

How This Book Is Organized

To ease you through the learning curve associated with any new program,
[ organized Dreamweaver 8 For Dummies to be a complete reference. The
following sections provide a breakdown of the parts of the book and what
you can find in each one. Each chapter walks you through the features of
Dreamweaver step by step, providing tips and helping you understand the
vocabulary of Web design.

Part I: Fulfilling Your Dreams

This part introduces you to Dreamweaver and covers getting started with the
basics. In Chapter 1, I give you a handy reference to toolbars and menu
options. I also describe the new features in version 8. You may prefer to skim
this chapter as it’s designed to give you an overview of the program, and you
don’t have to memorize the contents of each menu and toolbar. In Chapter 2,
[ start you on the road to creating your first Web site, including setting up
your site, importing an existing site, creating new Web pages, applying basic
formatting to text, and even placing images and setting links on your pages.
To make this chapter more interesting and help you see how all these fea-
tures come together, [ walk you through creating a real Web page in this chap-
ter as [ show you how each features works.

Part I1I: Looking Like a Million
(Even on a Budget)

Planning the design of your Web site is perhaps the most important part of
Web site development — you’ll save plenty of reorganizing time later. In
Chapter 3, I start you out on the right foot with tips on Web site management,
the principles of good design, and strategies that can save you countless
hours. I also introduce you to the Dreamweaver site-management features,
which can help you keep track of all the elements in your site and make sure
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you don’t have any broken links. In Chapter 4, I introduce you to some of my
favorite Dreamweaver features, including sophisticated template capabilities,
that enable you to create more consistent designs and even lock sections of a
page to protect them. I also love Dreamweaver’s Library items, which can be
used to place and update commonly used elements on your pages, such as
navigation bars or copyright tags. If you work with a team of designers, you
may be especially interested in the check in and check out features covered
in this chapter for version control and integrated e-mail for communicating
with other team members. Chapter 4 also covers tracing images, the Quick
Tag Editor, Design Notes, and the History palette.

Chapter 5 introduces you to the basics of creating, converting, and optimiz-
ing graphics for the Web and shows you how to add graphic elements to your
pages. You can find tools and strategies for creating the best images for your
Web site, as well as tips for finding free images online and buying graphics
that are specially designed for the Web.

Part I1I: Advancing Your Site

In Part III, I show you how to use Dreamweaver with some of the more
advanced HTML features. In Chapter 6, you discover how to use HTML tables
to create page layouts that work in the most common Web browsers. A high-
light of this chapter is Layout mode, which makes creating complex Web
designs easier than ever. In Chapter 7, you find all you need to know about
designing a site with HTML frames. (This chapter helps you decide when you
should and shouldn’t use frames and gives you plenty of step-by-step instruc-
tions for creating HTML frames in Dreamweaver.)

Chapter 8 provides an overview of how Cascading Style Sheets work and how
they can save you time. CSS has become a popular way to create designs and
manage formatting on Web pages, and these features have been nicely
improved in Dreamweaver 8. In this chapter, you find descriptions of the style
definition options available in Dreamweaver as well as instructions for creat-
ing and applying styles.

Part JU: Making It Cool

The most important thing in Web design is looking cool, and this section of
the book is designed to make sure you're part of the “cool club.” In Chapter 9,
[ take you further into CSS and include Dynamic HTML features, such as
layers and behaviors, which allow precise design control and new levels of
interactivity. Chapter 10 introduces Fireworks, the Macromedia image pro-
gram for the Web, and shows you how to take advantage of Dreamweaver’s
integration with Fireworks to more easily edit images.

5
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In Chapter 11, you find out how easily you can add multimedia to your Web
pages, including how to link a variety of file types — from Flash to Java to
RealAudio — to your Web pages. Then in Chapter 12, [ cover HTML forms and
how to use Dreamweaver to add interactive elements, such as surveys, search
engines, online discussion areas, and e-commerce systems to your pages.

Part U: Working with Dynamic Content

Part V features three chapters that cover the most advanced features in
Dreamweaver 8. Chapter 13 is designed to help you understand how database-
driven Web sites work and why they have become so important on the Web.

In Chapter 14, you discover how to add dynamic content to your pages,

define data sources, and display record sets. And in Chapter 15, you pull

it all together and find out how to build master pages, create pages to search
databases, and test your work with a live connection.

Part UI: The Part of Tens

In The Part of Tens, you get three quick references to help you get the most
out of Dreamweaver and avoid some of the common design mistakes on the
Web. In Chapter 16, you find descriptions and images of ten Web sites created
with Dreamweaver to give you an idea of what’s possible. In Chapter 17, you
find ten great Web design ideas; and in Chapter 18, you get ten tips to save
you time and make your sites work better.

Icons Used in This Book

) FlLEg

When I want to point you toward something you can download for your use, I
use this icon.

This icon points you toward valuable resources on the World Wide Web.

This icon reminds you of an important concept or procedure that you’ll want
to store away in your memory banks for future use.
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This icon signals technical stuff that you may find informative and interesting
but isn’t essential for using Dreamweaver. Feel free to skip over this stuff.

This icon indicates a tip or technique that can save you time and money —
and a headache — later.

This icon warns you of any potential pitfalls — and gives you the all-important
information on how to avoid them.

Where to Go from Here

If you want to get familiar with what’s new in Dreamweaver 8 and get an
overview of the program, turn to Chapter 1. If you're ready to dive in and build
your first Web site with Dreamweaver right away, jump ahead to Chapter 2. If
you want to find out about a specific trick or technique, consult the Table of
Contents or the Index and jump right to the section you need; you won’t miss
a beat as you work to make those impossible Web design deadlines. And
most of all have fun!
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In this part . . .

n Part I, you discover that you're not dreaming and all
the wonderful advances in this powerful Web design
program are real and at your fingertips. The new features
of Dreamweaver 8 make Web design easier, more intuitive,

and more powerful than ever. And don’t worry, if you're
new to Dreamweaver or need a little refresher, this part
includes an introduction to this award-winning Web design
program. Chapter 1 provides an overview, with highlights
on what’s new in version 8, as well as descriptions of the
toolbars, menus, and panels that make up Dreamweaver’s
interface. In Chapter 2, you dive right into setting up your
Web site, creating your first Web page, and adding text,
images, and links.




Chapter 1
Introducing Your New Best Friend

In This Chapter

Introducing the new features of Dreamweaver 8

Examining your Web site objectives

Finding your way around in Dreamweaver

Welcome to the wonderful world of Dreamweaver 8. If you're an experi-
enced Web designer, you're going to love the power and sophistica-
tion of this Web editor. If you're new to building Web sites, you’ll appreciate
its simplicity and intuitive interface. Either way, this chapter starts you on
your way to making the most of Dreamweaver by introducing you to the
menus and panels that make this program so useful.

Dreamweaver can help you with every aspect of Web development, from
designing simple pages, to fixing links, to publishing your pages on the World
Wide Web. Dreamweaver can handle the simplest HTML, as well as some of
the most complex and advanced features possible on the Web, including
Cascading Style Sheets and Dynamic HTML (see Chapters 8 and 9 for more
information on these features). Dreamweaver also integrates a powerful
HTML text editor into its easy-to-use graphical design environment so you
can work in the HTML code if you prefer.

If you already work in another Web design program or you're updating a site
that was created in another program, don’t worry — you can use Dreamweaver
to modify existing Web pages and continue to develop your Web site without
losing all the time you’ve already invested. For example, if you’ve been working
in a program such as Microsoft FrontPage or Adobe GoLive, you can change to
Dreamweaver to edit and develop your site further. All Web design programs
create HTML pages, and those pages can be opened in any other Web design
program. At the end of this chapter, in the “Working on Web Pages Created in
Another Web Design Program” section, you find a few warnings about the chal-
lenges you may encounter because the code can vary slightly from program to
program, but once you clean up those differences, you should be fine.

In this chapter, you find an introduction to the new features in Dreamweaver 8,
get a tour of the desktop, and gain an overview of what makes Dreamweaver
such a powerful Web design program.
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So What's New in Dreamweaver 8?

Now the good stuff. All those requests you make to Macromedia, all that
wishful thinking . . . believe it or not, they heard you and many of the little —
and not so little — things we all have been wanting in this program are finally
here, as well as a few extras you might expect!

The following list provides you a quick overview of some of the new features
you find in version 8:

v When you first launch Dreamweaver 8, you’ll notice a few changes to the
Workspace. Although it has no dramatic changes, the programmers at
Macromedia have added some clever new features, including a magnify-
ing glass feature complete with a little icon in the status bar just below
the work area. Much like the magnifiers common in image-editing pro-
grams, this new feature enables you to zoom in to view page elements in
greater detail or zoom out to see the full layout of a larger page.

v You'll find some of the most extensive changes in the way Dreamweaver
handles CSS — important upgrades as Cascading Style Sheets become
increasingly popular among professional designers. Among other things,
you'll find improved CSS rendering, better support for positioning, and a
more unified CSS panel that includes the Rule Tracker, Property Grid,
and a new Composite view.

v You can find one of my favorite new feature sets on the Edit menu. Paste
Special enables you to paste formatted text (and even tables) from other
programs, such as Microsoft Word or Excel, with options about what for-
matting is kept. You can choose to paste text with structural formatting,
such as tables and paragraph marks; with or without basic formatting,
such as bold and italics; and you can even opt to clean up the often
problematic paragraph formatting from Word as you paste in the text.

If you specify your choices in Dreamweaver’s Preferences, anytime
you use the paste feature your text is inserted based on your favorite
options.

v Going beyond the predesigned templates included in previous versions,
Dreamweaver now includes Starter Pages, which not only include topic-
based designs. They actually include text. Of course, you can edit the
text; but if you're creating a calendar of events or a product catalog, for
example, the general text already in place on these pages gives you a
head start.

v If you prefer working in Code view, where you can see all the HTML tags,
you'll find a few enhancements to that interface, including a new toolbar
that provides quick access to common commands and the capability to
selectively expand and collapse code so you can focus on the area you
are working on.
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v | always recommend that you design your pages for the broadest audi-
ence, and that definitely includes designing for the disabled, such as the
blind who use special browsers that read Web pages aloud. Macromedia
has always been good about including accessibility features, and I'm
pleased to see those features support the Priority 2 Web Content
Accessibility Guidelines.

Introducing the Many Components
of Dreamweaver

Dreamweaver can seem a bit overwhelming at first. It has so many features,
and they are spread out in so many panels, toolbars, and dialog boxes that
you can easily get lost. If you prefer to learn by poking around, have at it (and
feel free to skip ahead to the next chapter where you start building your first
Web page). If you want a tour before you get started, the next few sections
introduce you to the interface and provide an overview of the basics of
Dreamweaver. You also discover where to find common features and func-
tions, which the rest of the book covers in more detail.

The Workspace

When you launch Dreamweaver, the Start Screen appears in the main area of
the program (and it reappears anytime you don’t have a file open). From the
Start Screen, you can choose to create a new page from one of the many
Dreamweaver pre-made templates, or you can create a new blank page by
selecting HTML from the Create New options in the middle column. When
you select HTML, Dreamweaver creates a new blank HTML page in the main
Workspace, as shown in Figure 1-1. You can type text directly into any page in
the Workspace and apply basic formatting with the many formatting options
described later in this chapter.

You build HTML pages, templates, style sheets, and so on in the Workspace,
which consists of a main window that shows the page you’re working on sur-
rounded by a number of panels and menus that provide tools you can use to
design and develop your pages (shown in Figure 1-1). The Dreamweaver
Workspace consists of the following basic components: the menu bar (at the
very top), the Insert bar (just below it), the Document window (the main area
of the screen, just below the Insert bar), the Properties inspector (at the
bottom of the screen), and the Vertical Docking panels (to the right of the
Document window) that expand and collapse as needed. More detailed
descriptions of each of these follows.
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The Document window

The big, open area in the main area of the Workspace is the Document window,
which is where you work on new and existing pages. If you use the Designer
interface in Design view, you see your page as it would display in a Web
browser. If you want to see the HTML code behind your page, click the Code
button at the top of the work area. Choose the Split button to see the HTML
code and Design view simultaneously (which you can see in Figure 1-2).

Pages viewed on the World Wide Web may not always look exactly the way
they do in the Document window in Dreamweaver because not all browsers
support the same HTML features or display them identically. For best results,
always test your work in a variety of Web browsers, and design your pages to
work best in the browsers that your audience are most likely to use. Fortu-
nately, Dreamweaver includes features that help you target your page designs
to specific browsers, such as the Check Target Browsers feature covered in
Chapter 3.)
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Customizing the interface

The docking panels, palettes, and bars in Dreamweaver provide easy access
to most of the program’s features. The default settings put the Properties
inspector at the bottom of the page, the Insert bar at the top, and the panels
on the right, but you can move these elements around the screen by selecting
them and use drag and drop to move them to another part of the screen. You
can also close any or all the panels on the right by clicking the tiny Options
icon in the top right of each panel and selecting Close Panel from the drop-
down list (it looks like three bullet points with lines next to them and a little
arrow underneath, and it’s really, really small). You can close them all at once
by choosing Window>Hide Panels (or by clicking the arrow in the middle of
the row of panels), and you can access any or all the panels through the vari-
ous options on the Window menu. If you want to open a particular panel —
the CSS Styles panel, for example — choose Window=>CSS Styles and it
expands to become visible on your screen. The Properties inspector, Insert
bar, and panels are integral parts of this program, and you find a lot more
information about them throughout the book. Check out the Cheat Sheet at
the front of this book for a handy reference to the Properties inspector
options. In Chapter 2, you discover how to use some of the most common
features, such as the icon for inserting an image on the Insert bar at the top
of the screen.
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The Insert bar

The Insert bar, located at the top of the screen, comes with eight subcate-
gories, each with a different set of icons representing common features. Click
the small arrow to the right of the name to access the drop-down list to
switch from displaying the buttons on one subcategory to showing the but-
tons for another. The options are

v Common bar: Displays icons for many of the most common features,
including links, tables, and images.

v Layout bar: Displays layer and table options essential for creating com-
plex layouts.

v Forms bar: Surprise! This one features all the most common form ele-
ments, such as radio buttons and boxes.

v Text bar: Displays common text-formatting features, including para-
graphs, breaks, and lists.

v HTML bar: Offers a mishmash of raw HTML, such as rules, tables,
frames and, scripts.

v~ Application: Use these options when building dynamic Web pages pow-
ered by database material.

v+~ Flash elements: A single icon allows you to place a Flash file on your
Web page.

v Favorites: Right-click (Windows) or Control+click (Mac) to customize
your most-used HTML elements.

At the very end of the drop-down list, you find the Show as Tabs option,
which enables you to display the names of the Insert bars as tabs across the
top of the screen, as shown in Figure 1-3.

The Favorites Insert bar is blank by default, and you can customize it to hold
your own collection of options. Simply right-click (Windows) or Control+click
(Mac) in the bar and you can easily customize this bar.

Throughout the book, I refer to these Insert bars by their full names, such as
the Forms Insert bar or the Layout Insert bar. You find more information on
each of these in their relevant chapters. For example, Chapter 12 covers the
Forms Insert bar in detail; and Chapters 13, 14, and 15 cover the Application
Insert bar.

Figure 1-3 shows the Insert bar with the Common options visible and each
name displayed in a tab across the top of the screen.
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The Properties inspector

The Properties inspector is docked at the bottom of the page in Dreamweaver.
If you prefer it at the top of the screen, you can drag it up there, and it locks
into place; but I rather like that it’s handy, yet out of the way, at the bottom of
the screen.

The Properties inspector displays the properties of a selected element on the
page. A property is a characteristic of HTML — such as the alignment of an
image or the size of a cell in a table — that you can assign to an element on
your Web page. If you know HTML, you recognize these as HTML attributes.

When you select any element on a page (such as an image), the inspector
changes to display the relevant properties for that element, such as the
height and width of an image. You can alter these properties by changing the
fields in the Properties inspector. You can also set links and create image
maps using the options in the Properties inspector.

Figure 1-4 shows the image options displayed in the Properties inspector,
including height and width, alignment, and the URL (Uniform Resource
Locator or, more simply, Web address) to which the image links.

At the bottom-right corner of the Properties inspector, you see a small arrow.
Click this arrow (or double-click in any open inspector space) to reveal addi-
tional attributes that let you control more advanced features, such as the
image map options when a graphic is selected.
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Figure 1-5 shows the Properties inspector when you select a table. Notice
that the fields in the inspector reflect the attributes of an HTML table, such
as the number of columns and rows. (See Chapter 6 to find out more about
HTML tables.)
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The Docking panels

The Docking panels, shown in Figure 1-6, are located to the right of the work
area (although you can easily move them anywhere on the screen). The Docking
panels display a variety of important features in Dreamweaver, including all the
files and folders in a site (in the Files panel), Cascading Style Sheets (in the CSS
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panel) and more. You can open and close panels by clicking the small arrow to
the left of the panel’s name. To display more panels, select the panel name from
the Window menu. To hide all the visible panels at once, click the tab with the
small arrow in the middle, left of the row of panels.
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The following list offers a description of some of the elements that you
access through the Docking panels (the others are described in greater detail
in their respective sections of the book).

v~ Files panel: Shown in Figure 1-6, the Files panel lists all the folders and
files in a Web site and helps you manage the structure and organization
of the site. You can move files in and out of folders and even create new
folders in this panel, and Dreamweaver automatically adjusts any related
links. The Files panel is also where you access FTP (file transfer protocol)
capabilities to upload or download files from a server. You can use the
Connect button at the top of this panel to dial quickly into your server
and use the Get Files and Put Files arrows to transfer pages. (See
Chapter 2 for more about the Files panel and built-in FTP features.)
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v Assets panel: The Assets panel, shown in Figure 1-7, automatically lists

all the images, colors, external links, multimedia files, scripts, templates,
and Library items in a Web site. You can add a stored item, such as a
graphic, to a Web page simply by dragging the element into the work
area. You find more on templates and Library items in Chapter 4.

These features work only if you define your site using the Site Definition
dialog box (by choosing Sitec>"Manage Sites) and then identifying the
main folder of your Web site. If you find that the Library or other options
aren’t available, follow the steps in Chapter 2 to define your site (a setup
process you should go through for all your sites).

v CSS panel: The Cascading Style Sheets panel includes Layers and CSS

Styles panels. CSS styles are similar to style sheets used in word pro-
cessing and desktop publishing programs, such as Microsoft Word and
QuarkXPress. You define a style and name it, and the style is then
included in the CSS Styles panel (see Figure 1-8). The Layers panel pro-
vides access to layers options, which enable you to precisely position
elements on a page. (For more information about CSS and layers, see
Chapters 8 and 9.)

¥ Files s

fosE|

Eweé O

a9l Il i Rl el e el e el el e el el el el )

Assels
Images: (#) Sike () Favorite: [

BIOGRLAPHY

me
bio_button, g
bio_button . gif
bio_jcon.gif
bio_jcon1.gif
bio_icon2.gif
cafepress_clock.jpg
cafepress_mug.jpg
cafeprass_tshirt.jpg
color_paink_printico...
color_paink_printico...
contack_button,gif
conkack_button1.gif
conkack_jcon.gif
conkack_jcont . gif
conkack_icon. gif
feral_archivestxt.gif
feral_logo.gif
fFeral_mavis.gif
Feral_mavis_color, gif
Feral_mavistxt, gf
feral_mermaids  gif

Frwal e bt

¥

C 7+l




21

Chapter 1: Introducing Your New Best Friend

|
Figure 1-8:
The CSS
panel

makes it
easy to
manage
styles and
layers.

|
|
Figure 1-9:
The
Attributes
panel
displays

all the
attributes of
a selected

element.
|

v~ Tag panel: The Tag panel provides access to attributes and behaviors. In

Dreamweaver,

behaviors are scripts (usually written in JavaScript) that

you can apply to objects to add interactivity to your Web page.

Essentially, a b

ehavior is made up of a specified event that, when trig-

gered, causes an action. For example, an event may be a visitor clicking
an image, and the resulting action may be that a sound file plays.

Figure 1-9 shows the Tag panel’s Attributes tab, which displays all the

attributes of a

selected element. You can change attributes in the

Attributes tab as well as in the Properties inspector. (Chapter 9 provides
more information on creating and applying behaviors.)
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v~ History panel: The History panel, shown in Figure 1-10, keeps track of
every action you take in Dreamweaver. You can use the History panel to
undo multiple steps at once, to replay steps you performed, and to auto-
mate tasks. Dreamweaver automatically records the last 50 steps, but you
can increase or decrease that number by choosing Edit>Preferences>
General (Windows) or Dreamweaver=>Preferences>General (Mac), and
changing the maximum number of history steps.

v~ Application panel: This panel includes the Database, Bindings, Server
Behaviors, and Components panels. These features are used only if you
work with a database-driven site (the most technically complex of the
features covered in this book). You find more on database options in

Chapters 13, 14, and 15.

v Frames panel: If you create a site design that uses frames, a set of HTML
tags that enable you to divide a screen into sections made up of sepa-
rate pages, you use the Frames panel to manage the different pages on
the screen, such as the three frames shown in Figure 1-11.
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The menu bar

At the top of the screen, the Dreamweaver menu bar provides easy access

to all the features that you find in the Insert bar, Properties inspector, and
panels, as well as a few others that are available only from the menu. The fol-
lowing sections provide a general description of each of the menu options.

The File menu

You find many familiar options, such as New, Open, and Save, on the File
menu, shown in Figure 1-12. You also find a Revert option, which is similar to
the Revert feature in Adobe Photoshop. This sophisticated undo feature
enables you to return your page quickly to its last-saved version if you don’t
like the changes you made.

The File menu also includes access to Design Notes, a unique feature that
associates private notes with HTML and other files. Take a look at Chapter 4
for more information about Design Notes and other Dreamweaver features
that make collaboration easier.

You can also find features useful for checking your work in Web browsers on
the File menu. Most Web design programs include some way of previewing
your work in a browser. Dreamweaver takes this feature two steps further by
enabling you to check your work in a number of browsers and even test the
compatibility of your pages in different versions of different browsers.

Figure 1-12 shows the Check Page options, which includes Check Accessibility,
Check Links, and Check Target Browsers — all great tools for testing your
work. The Check Target Browsers option enables you to specify a browser
and version, such as Safari 2.0, Netscape 6, or Internet Explorer 6.0. When
you do a browser check, Dreamweaver generates a report listing any HTML
features you use that the chosen browser doesn’t support.

The Check Links feature verifies all the links in a site and produces a report

with all broken and unresolved links. The Check Accessibility feature checks
to make sure the page displays properly in browsers for the blind and other
systems for the disabled.

The Edit menu

The Edit menu contains many features that you may find familiar, such as
Cut, Copy, and Paste. One feature that may be new to you is the Edit with
External Editor option, which enables you to open an element in another pro-
gram, such as an image editor, and make changes without ever closing
Dreamweaver.
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You also find the Preferences settings on the Edit menu (Windows) or on the
Dreamweaver (Mac). Before you start working with a new program, go
through all the Preferences options to ensure that the program is set up the
best way for you.

The View menu

The View menu provides access to some helpful design features, such as
grids and rulers, as well as the new zoom features. The Visual Aides option
on the View menu gives you the option of turning on or off the borders of
your HTML tables, frames, and layers, as well as controlling visibility of
image maps and other invisible elements. This option is useful because you
often want to set the border attribute of these HTML tags to zero so that
they’re not visible when the page displays in a browser. However, while you
work on the design of your page in Dreamweaver, seeing where elements,
such as tables and layers, start and stop is very useful. Checking the frame
options on the View menu lets you see the borders in Dreamweaver even if
you don’t want them visible to your site’s visitors.

The Insert menu

As shown in Figure 1-13, the Insert menu offers access to a number of fea-
tures unique to Web design. From this menu, you can insert elements such as
a horizontal rule, a Java applet, a form, or a plug-in file.
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Dreamweaver offers extra support for inserting Flash and Shockwave
Director files, both of which are products from Macromedia. (You can find
out more about using multimedia files in Chapter 11.)

The Modify menu

The Modify menu is another place where you can view and change object
properties, such as the table attributes shown in Figure 1-14. The properties
(usually called attributes in HTML) let you define elements on a page by set-
ting alignment, height, width, and other specifications.

Page Properties

To alter properties for an entire page, such as text and link colors, use the
Page Properties dialog box shown in Figure 1-15. Available from the Modify
menu or by clicking the Page Properties button at the bottom of the
Properties inspector, the Page Properties panel also enables you to specify
the background color or to use an image as a page background.
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The Text menu

You can easily format text with the Text menu by using simple options, such
as bold and italic, as well as more complex features, such as font styles and
custom style sheets. Text formatting options have evolved dramatically on
the Web. Just a few years ago, you didn’t even have the option of specifying a
particular font style or controlling leading and spacing. Today you have more
control than ever over the look of your Web pages, although these options
aren’t yet universally supported. The Text menu also features options that
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Figure 1-16:
The
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enable you to quickly create headers and subheads, check spelling, and
create lists.

The Commands menu

The Commands menu, shown in Figure 1-16, provides access to a host of
options in Dreamweaver. These options include the Start and Play Recording
features, which let you quickly save a series of steps and then repeat them.
To use this feature, choose Commands=Start Recording, perform whatever
actions you want to record — for example, copying and pasting some text —
and then choose Stop Recording. To perform any action again, choose
Commands=>Play Recorded Command. You can download an action by
choosing Commands=>Get More Commands, which automatically launches a
browser and takes you to the Macromedia Web site. You can download new
commands from the Web site that add functionality to Dreamweaver.

The Clean Up XHTML and Clean up Word HTML options on the Commands
menu help you correct incorrect or redundant HTML code, and the Clean Up
Word HTML feature is designed especially to correct the common problems
caused by the Save As HTML feature in Microsoft Word.

The Add/Remove Netscape Resize Fix option on this menu inserts or removes
a JavaScript script designed to help correct an old Netscape bug by automati-
cally reloading the page when users resize their browser windows.
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The Create Web Photo Album option launches Macromedia Fireworks and
uses it to automate the creation of a photo album with a series of images. If
you choose Optimize Image in Fireworks, a selected image automatically
opens in the optimization area in Fireworks. (Both these commands require
that you have Fireworks installed.)

The Site menu

The Site menu provides access to the options you need to set up your site, a
process required before many of the other Dreamweaver features work prop-
erly. (Chapter 2 covers this process.) The Site menu also gives you easy
access to the Check In and Check Out features, which are options that can
help you keep a team of designers from overwriting each other’s work.
(Chapter 4 talks about this feature.)

The Window menu

The Window menu lets you control the display of panels and dialog boxes,
such as Insert, Properties, and Behaviors. To make these panels visible,
select the panel name so that a check mark appears next to the feature you
want to display; to hide them, select again to remove the check mark. Other
panels and dialog boxes, such as CSS Styles and HTML Code Inspector, are
also listed on the Window menu for easy access.

The Help menu

The Help menu provides easy access to help options that can assist you in
figuring out many features of Dreamweaver. You also find access to the
Dreamweaver template and example files on the Help menu.

Templates and examples provide visual samples of common HTML designs,
such as tables and frames, and provide design ideas and great shortcuts for
creating complex layouts.

The status bar

The status bar appears at the bottom left of any open Dreamweaver docu-
ment. On the right end of the status bar, you can see tool icons that control
the on-screen display of your document. On the left end, you find a row of
HTML codes that indicate how elements on your page are tagged. If you place
your cursor in bold text that is centered, for example, the status bar might
display <BODY><CENTER><B>. This feature makes double-checking the kind of
formatting applied to any element on your page easy.

You can also use the status bar to quickly make a selection on your page. For
example, if you click the name of a tag in the status bar, the section of your
page where that tag is applied is highlighted. This makes selecting a certain
section of a page, such as a page, easier.
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Working on Web Pages Created in
Another Web Design Program
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In theory, all Web design programs should be compatible because HTML files
are, at their heart, just ordinary text files. You can open an HTML file in any
text editor, including Macintosh TextEdit and Windows Notepad. However,
HTML has evolved dramatically over the years and different Web programs
follow different standards, which can cause serious conflicts when a page cre-
ated in one program opens in another.

One of the reasons Dreamweaver is so popular is because it creates very
clean code and is considered more accurate and more respectful of HTML
standards than other programs. Dreamweaver is also better at creating pages
that work in different browsers and on different platforms, but importing files
created in another Web program can be challenging, even in Dreamweaver.

To help with the transition, Dreamweaver includes some special features,
such as the Clean Up Word HTML option, designed to fix some of the
common problems with Microsoft Word’s HTML code.

Before you start working on a site that was developed in another program,
you need to import the site into Dreamweaver. | recommend you make a
backup of the site first so you have a copy of all the original pages (strange
things can happen when you open a site created in another program). You
find step-by-step instructions for importing an existing Web site in Chapter 2.

The following sections describe the most popular HTML editors and what
you need to know if you’re moving files from one of these programs to
Dreamweaver.

Microsoft FrontPage

Microsoft FrontPage is one of the most popular HTML editors on the market,
in large part because it’s a part of the immensely popular Microsoft Office.
FrontPage offers some powerful features as well as an attractive bundle of
programs for Web developers, including Image Composer, a graphics pro-
gram designed for creating images for the Web. FrontPage also includes Web
components that you can use to add interactive features, such as a simple
search engine or a discussion area, to your Web site. Web components work
only if their corresponding programs reside on the Web server that you use,
but many commercial service providers now offer FrontPage Web components.

If you are migrating a site from FrontPage to Dreamweaver, first make note of
any FrontPage Web components that you use, such as search engines or forms.
Dreamweaver doesn’t offer these same built-in features, and you won'’t be able
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to continue editing them in Dreamweaver the way you did in FrontPage.
Although you don’t need to alter the code for these components, thanks to the
Dreamweaver respect for unique code, you can’t edit FrontPage’s built-in com-
ponents in Dreamweaver.

If you use CSS or layers in FrontPage, you need to pay special attention to
those features as you convert your site to Dreamweaver. Microsoft FrontPage
isn’t as good as Dreamweaver at creating high-end features that work in both
Netscape Navigator and Microsoft Internet Explorer, so you probably want to
improve your code if you expect viewers to use any browser other than
Internet Explorer. Because CSS and layers are more complex than HTML to
code, you probably don’t want to edit this code manually — converting from
other editors to Dreamweaver can get pretty tricky. Tables can also get messy
when you switch from one program to another. In some cases, you may find
that the simplest solution is to delete the elements that you created in
FrontPage and re-create them in Dreamweaver. (For more on CSS and layers,
check out Chapters 8 and 9.)

Microsoft Word

Although Microsoft Word is a word processor and is not considered an HTML
editor per se, it does have HTML output capabilities. As a result, you will
likely encounter pages that have been created and saved in Microsoft Word
at some point. The problems you find in HTML code generated from Word are
similar to the problems generated from FrontPage: They both tend to create
unusual and sometimes redundant code that deviates from HTML standards.
Because Word-generated HTML is so common, Dreamweaver includes a spe-
cial Clean Up Word HTML command. To use this feature, choose Commands=>
Clean Up Word HTML and then specify the code you want altered in the Clean
Up Word HTML dialog box. When you use this feature, Dreamweaver removes
excess code, which can help your pages load faster and work better in differ-
ent browsers.

After you use Dreamweaver to clean up Word HTML, you should not expect
to edit the file in Word again. The code may be cleaner, but depending on the
formatting options you’ve used, Word may no longer be able to read it.

Adobe GoLive

Adobe GolLive offers some great features for easy page design and a lot of
similarities to Dreamweaver, so you should have little if any trouble migrating
a site from GoLive to Dreamweaver.
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If you have included any JavaScript actions in your pages using GoLive, you
may not be able to edit them in Dreamweaver, but the actions should still
work when the page displays in a browser. Likewise, CSS and other Dynamic
HTML features created in GoLive do not always work well in Dreamweaver
unless you know how to edit the code manually. If your page contains any
actions or DTHML features, you may find re-creating the page in
Dreamweaver your best option.

Not long before the writing of this book, Adobe purchased Macromedia and
although, to date, no announcement has been made about changes to GoLive,
[ imagine that both GoLive and Dreamweaver are likely to see changes in the
future that will either make them more compatible or make one of them obso-
lete. 'm betting on Dreamweaver, not only because I'm the author of this
book, but because it has the largest market share; but it’s hard to predict
what will happen to GoLive, which is also a strong Web design program.

Other HTML editors

In the early days of the Web, lots of different visual HTML editors were being
used. Today only a few major ones are left. The few that [ discuss here seem
to capture most of the market. Still, you may find yourself inheriting sites
built in really old editors such as Claris HomePage, or Symantec VisualPage.
Each of these programs present fewer problems than either Frontpage or
GolLive because they aren’t capable of creating the complex, high-end fea-
tures that are hardest to migrate from one program to another.

For the most part, you can open any HTML page with Dreamweaver and con-
tinue developing it with little concern. If you run into problems, remember
that you always have the option of re-creating the page from scratch in
Dreamweaver — a sure way to get rid of any unwanted code. You may also
want to use the Dreamweaver Clean Up XHTML feature to identify poten-
tially problematic code. To use this feature, choose Commands=>Clean Up
XHTML and then select the elements you want to alter in the Clean Up
HTML dialog box.

No matter what program your site is originally created in, as you consider

how best to convert your work into Dreamweaver, pay special attention to

unusual code output, nonstandard rules about HTML tags and syntax, and

sophisticated features such as CSS, Dynamic HTML, and sophisticated pro-
gramming, such as ASP, Java, or CGI scripts. These Web page elements are

most likely to cause problems when you import them into Dreamweaver.
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Chapter 2

Setting Up a Web Site
with Dreamweaver

In This Chapter

Building a new site

Making new pages

Creating links

Getting your Web site online

\\J

f you're ready to dive in and start building your Web site, you’ve come to

the right place. In this chapter, you find what you to need to start building
a Web site whether you are working on an existing Web site or creating a new
one. First you discover an important preliminary step — site setup, which
enables Dreamweaver to keep track of the images, links, and other elements
in your site. Then, you get into the fun stuff, creating your first page and
adding images and text.

Before you start creating or editing individual pages, setting up your site
using the site-management features in Dreamweaver is really important.
Whether you're creating a new site or working on an existing site, follow the
steps in the next section to get Dreamweaver ready to manage the site for
you. The site-management features enable Dreamweaver to keep track of the
elements in your site, automatically create links, update your server, and
even manage a team of developers. With the enhancements in this latest ver-
sion, all these features are even more powerful and easy to use.

You can use Dreamweaver without doing this initial site setup, but many of
the features — such as automated link checking and the capability to store
commonly used elements in the Library — won’t work.
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Setting Up a New or Existing Site

The site-management features in Dreamweaver are designed to ensure that
everything works properly in your Web site by making certain that links con-
nect and files and folders are placed correctly on your hard drive. If you don’t
do site setup, you risk breaking links between pages. The site setup process
also gets you ready to use Dreamweaver'’s file transferring tools, including FTP
capabilities (File Transfer Protocol). These tools facilitate the transfer of your
pages to and from your local computer to your Web server. Dreamweaver also
includes special features that help track and manage updates to your server
anytime you make changes to your site.

As you go through the site setup process, you start by telling Dreamweaver
which folder on your hard drive is the one that you use to store all the files
and folders for your Web site. You need to keep all the files and folders for
your site in one main folder because when you finish building your site and
upload it to your Web server, the individual pages, images, and other ele-
ments must remain in the same relative location on the Web server as they
are on your hard drive, and that’s most easily accomplished by storing them
all in one main folder.

If this setup seems a little confusing to you, don’t worry; it’s a quick easy
process and as long as you keep all the files of your Web site in one main
folder, you'll be fine. Just trust me; don’t skip this first step.

When you use site setup for a new Web site, Dreamweaver by default creates
a new folder on your hard drive to ensure that you save all the pages and
other elements of your site in one place. If you prefer, you can change the
location of that folder or create a new one yourself.

If you're working on an existing site, you follow the same steps for site setup,
but instead of creating a new folder, you direct Dreamweaver to the folder
that contains the existing site.

If you're an experienced Web designer and just want to make quick changes
to a site or use the FTP features to access files on a server without doing the
site setup steps, Dreamweaver does enable you to use these features without
completing site setup. To access FTP features and set them up quickly, choose
Sitec>Manage Sites and then choose New=FTP & RDS Server from the Manage
Sites dialog box. This shortcut enables you to work directly on your server
using FTP & RDS Server; but Dreamweaver does not manage link checking,
and none of the other site-management features work.

FTP (File Transfer Protocol) is used for copying files to and from computers
connected across a network, such as the Internet. FTP is the protocol you use
to send your Web pages to your Web server when you’re ready to publish
your site on the Web.
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Defining a site

The following steps walk you through the process of using the Site Definition
dialog box to define your site. Whether you create a new site or work on an
existing Web site, this first step is important to your Web design work because
you identify your site structure, which enables Dreamweaver to set links and
effectively handle many of the site-management features explained in later
chapters.

If you want to work on an existing site that is on a remote Web server, follow
the steps in the sidebar, “Downloading an existing Web site,” later in this
chapter.

To define a site using the Site Definition dialog box, follow these steps.

1. Choose Sitem>Manage Sites.

The Manage Sites dialog box appears, as shown in Figure 2-1.

Manage Sites
David LaFontzine ~ [T
Digital Famity, com I =
Gadensi
Graden site Edt...
Hard News Inc,

ICWarner,cam [ Duglicate
karate ske

Mariym Pitkman
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Ted Parkins site [ _ﬂmmt' I

2. Click the New button and then select Site.
The Site Definition dialog box appears, as shown in Figure 2-2.
3. Click the Advanced tab.

The Advanced window appears. If you prefer, you can use the Basic
wizard that steps you through the setup process, but I find it easier to
understand what’s happening when [ can view all the options at once on
the Advanced tab.

4. Make sure that the Local Info category is selected in the Category box.
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5. In the Site Name text box, type a name for your site.

You can call your site whatever you like; this name is only used for you
to keep track of your sites. Many people work on more than one site in
Dreamweaver so the program includes a way to name and keep track of
them. After you name it here, the name appears as an option on the
drop-down list in the Files panel. You use this list to select the site you
want to work on when you open Dreamweaver. In the example shown in
Figure 2-2, I named the new site I created “Your Dream Site.”

. Click the Browse button (it resembles a file folder) next to the Local

Root Folder text box to locate the folder on your hard drive that con-
tains your Web site.

If you're working on a new site, create a new folder and designate that as
the location of your site in Dreamweaver. If you're working an existing
site, select the folder that contains the files for that site.

. If Refresh Local File List Automatically isn’t already selected, click to

place a check mark in the box next to this option if you want
Dreamweaver to automatically update the list of all the new pages you
add to your site.

This feature helps Dreamweaver work more efficiently by speeding the
process of tracking and identifying files in your site.
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8. Specify the Default Images folder by entering the location or using the
Browse button to locate it.

You do not have to identify an images folder, but it’s another way
Dreamweaver helps keep track of things for you. If you store images in
more than one folder, you can leave this box blank. If you're setting up a
new site, you can create a new folder inside your site folder and identify
that as your images folder, even if it is empty. (You find more information
about images in Chapter 5.)

9. Type the URL of your Web site in the HTTP Address text box.

The HTTP Address is the URL, or Web address, that your site will have
when published on a Web server. If you do not yet know the Web
address for your site or you do not plan to publish it on a Web server,
you can leave this box blank. Include the http:// at the beginning, and
a / at the end.

10. Check the Use Case-Sensitive Link Checking box.

Unless you know for sure that you don’t have to worry about the case of
your filenames, have Dreamweaver help you enforce the case sensitivity
of your site’s links. (See Chapter 3 for more on file naming.)

11. Check the Enable Cache option.

Dreamweaver creates a local cache of your site to quickly reference the
location of files in your site. The local cache speeds up many of the site-
management features of the program and takes only a few seconds to
create.

12. Click OK to close the Site Definition dialog box.

If you haven’t checked the Enable Cache option, a message box appears
asking whether you want to create a cache for the site. Figure 2-2 shows
what the Site Definition dialog box looks like when all the areas in the
Local Info section are filled in.

Setting up Web server access for FTP

To make your life simpler, Dreamweaver incorporates FTP capability so that
you can easily upload your pages to a Web server. This feature also enables
Dreamweaver to help you keep track of changes you make to files on your
hard drive and to ensure that they match the files on your Web server.

You enter information about the Web server where your site will be published
on the Remote Info page of the Site Definition dialog box. You access this page
by selecting Remote Info in the Category box on the left side of the Site Defini-
tion dialog box. The Remote Info page opens on the right side of the box, as
shown in Figure 2-3.
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You can find several options in the Remote Info section on the Access drop-
down list. In the following section, you find instructions on how to set up FTP
access, which is the second choice on the drop-down list. If you aren’t going
to publish your site on a server, choose None from the drop-down list and go
on to the next section. If you're going to send your site to a server located on
your local network, choose Local/Network; then use the Browse button to
specify that server’s location on your network. The other options — WebDAV,
RDS, and Microsoft Visual SourceSafe — are advanced options that you don’t
need to worry about if you're working on a site you’ll host on a commercial
service provider. (You can find more about working with these advanced
options in Chapters 13, 14, and 15.)

The most common way to publish a Web site after you develop it is to use
FTP to send the site to a remote server, such as those offered by commercial
Internet service providers. If that is how you’re going to publish your site,
follow the upcoming steps, and you’ll be all set when you’re ready to publish
your Web site.

If you don’t have your server information, or you're anxious to start building
your site on your own hard drive first, you can skip this part of the setup
process and come back to it when you're ready to publish your site.



Chapter 2: Setting Up a Web Site with Dreamweaver

a\\S

You need the following information to set up the FTP option in Dreamweaver.
If you're using a remote server, such as an Internet service provider, ask your
provider for the following information:

v FTP host name

v Path for the Web directory
v FTP login

v FTP password

Choose FTP from the Access drop-down list in the Remote Info page of the
Site Definition dialog box (refer to Figure 2-3), and follow these steps:

1. In the FTP Host text box, type the hostname of your Web server.

It should look something like ftp.host.com or shell.host.com or
ftp.domain.com, depending on your server. (In my example, [ used
ftp.yourdreamsite.com.)

2. In the Host Directory text box, type the directory on the remote site
in which documents visible to the public are stored (also known as
the site root).

It should look something like public/html/ or www/public/docs/.
Again, this depends on your server.

3. In the Login and Password text boxes, type the login name and pass-
word required to gain access to your Web server. If you check the
Save box, Dreamweaver stores the information and automatically sup-
plies it to the server when you connect to the remote site.

This is your unique login and password information that provides you
access to your server.

Click the Test button to make sure that you've entered everything cor-
rectly. If there are no problems, Dreamweaver responds with a box saying
Dreamweaver connected to your Web server successfully.

4. Put a check mark in the Use Passive FTP or Use Firewall options only
if your service provider or site administrator instructs you to do so.

If you aren’t on a network but you do use a commercial service provider,
you should not need to check either option.

5. Click OK to save your Web Server Info settings and close the Site
Definition dialog box.

If you want to continue reviewing the settings in other categories, choose
Testing Server, Design Notes, Site Map Layout, File View Columns, or Con-
tribute from the Category box on the left side of the screen. (You can find
more information on these categories in Chapter 4.)
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Downloading an existing Web site

If you want to work on an existing Web site and
you don't already have a copy of it on your local
computer’s hard drive, you can use Dream-
weaver to download any or all the files in the
site so that you can edit the existing pages, add
new pages, or use any of Dreamweaver's other
features to check links and manage the site's
further development. The first step is to get a
copy of the site onto your computer by down-
loading it from the server.

To download an existing Web site, follow these
steps:

1. Create a new folder on your computer to
store the existing site.

2. Specify this folder as the local root folder
for the site with the Dreamweaver site
setup features.

Check out the section “Defining a site,” ear-
lier in this chapter, if you're not sure how to
do this.

3. Set up the Remote Info dialog box.

| explain how to do this in the “Setting up
Web server access for FTP” section, earlier
in this chapter.

4. Connect to the remote site by clicking the
Connects to Remote Host button, which
looks like the ends of two cables, in the
Files panel.

5. Click the Get Files button, which looks like
a down arrow, to download the entire site
to your local drive.

Sometimes your Web host has files on the
remote server that you don't need to down-
load. If you want to download only specific

files or folders from the site, select those files
or folders in the Remote Site pane of the Files
panel, and click the Get Files button. Dream-
weaver automatically duplicates some or all
the remote site’s structure, meaning the fold-
ers in the site but not all the files within them,
and places the downloaded files in the cor-
rect part of the site hierarchy. Re-creating
the folder structure on your local computer
is important because Dreamweaver needs
to know the location of the files as they
relate to other parts of the site in order to set
links properly. The safest option is to down-
load the entire site; but if you are working on
a really large Web project, downloading a
part and duplicating the structure enables
you to work on a section of the site without
downloading all of it.

If you are working on only one page or sec-
tion of a site, you should generally choose
to include dependent files, meaning any
files linked from those pages, to ensure that
links set properly when you make changes.

. After you download the site or specific

files orfolders, you can edit them as you do
any other file in Dreamweaver.
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Creating New Pages
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|
Figure 2-4:
The Start
Screen
provides

a list of
shortcuts to
create new
files or open
existing
pagesin
Dream-
weaver.
|

Every Web site begins with a single page. Visitors are first greeted by the
front page — or home page — of your site, and that’s usually a good place to
start building. Dreamweaver makes building a home page easy: When the pro-
gram opens, you see a Start Screen with shortcuts to many handy features for
creating new pages.

If you want to create a simple, blank Web page, choose HTML from the Create
New list in the middle row (see Figure 2-4). If you are creating a dynamic site,
you may choose ColdFusion, PHP, or one of the ASP options. (If you don’t
even know what those options mean, you probably won’t need to use them,
but you can find some information about these advanced options in Chapters
13, 14, and 15.)

Get in the habit of saving new Web pages into your main Web site folder as
soon as you create them, even though they are still blank. As you create links
or add images to your pages, Dreamweaver needs to be able to identify the
location of your page, and it can’t do that until you save the page.
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If the Start Screen is not visible because you have an existing page already
open or you've opted not to show it, follow these steps to create a new page:

1. Choose Filec>New.

2. Select Basic Page from the Category list.
3. Select HTML from the Basic Page list.

4. Choose Filer>Save to save your page.

You find many other options in the Dreamweaver New Document window,
including a wide range of predesigned templates. For now, don’t worry
about all those. In this chapter, you start off by creating a simple blank
page. You find instructions for working with templates in Chapter 4.

Make sure you add a page title to each of your pages. You can add a page title
by changing the text in the Title box on the Document toolbar. By default,
Dreamweaver inserts the words untitled Page into the Title box, but you
can put any text you want in this box. The page title doesn’t appear in the
body of your Web page, but it’s important because this text appears at the
top of the browser window, usually just to the right of the name of the
browser. This text also appears in a user’s list of Favorites or Bookmarks
when that user bookmarks your site.

Naming Web Pages

When you save Web pages, images, and other files in your site, you need to
be careful what you name them and you need to include an extension at the
end to identify the file type (such as .html for HTML files or .gi £ for GIF
images). Dreamweaver automatically adds the extension to the end of HTML
files, but you can change preferences to use either .html or .htm. In theory,
these extensions are interchangeable, but some servers read only .html so
that’s the safer bet.

Filenames in Web sites get incorporated into links and links are easier to
manage when they don’t include spaces or special characters. For example you
shouldn’t name a Web page with an apostrophe, such as cat's page.html. If
you want to separate words, use the underscore (_) or the hyphen (-). For
example, cat-page.html is a fine filename. Numbers are fine and capital let-
ters don’t really matter, as long as the filename and the link match, which
Dreamweaver takes care of for you when you create links (just be careful if you
ever create a link in the HTML code).

One of the most confusing and important filename rules in Web design is that
the main page (or the front page) of your Web site must be called index.html.
That’s because most servers are set up to serve the index.html page first.
(Although some servers also serve other filenames, such as home.html, or
default.asp on dynamic sites, most prioritize and serve index.html before
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Creating multiple pages to set links

Creating a new page to start a Web site may
seem obvious, but consider this: You may want
to create a bunch of new pages before you get
too far in your development, and you may even
want to start organizing the new pages in sub-
directories before you have anything on them.
Doing so enables you to organize the structure
of your site before you start setting links. After
all, you can't link to a page that doesn't exist. If
you plan to have five links on your front page to
other pages in your site, go ahead and create
those other pages, even if you don’t put any-
thing on them yet.

For example, say you're creating a site for your
department at a big company. You're likely to
want a few main pages, such as a page about
your staff, another about what you do, and a
third with general information and resources. At
this initial stage, you could create four pages —
one for the front page of the site and three
others for each of the subsections. With these
initial pages in place, you benefit from having an
early plan for organizing the site, and you can
start setting links among the main pages right
away. See Chapter 3 for more tips about Web
site planning and organization.

all others.) If you want to ensure that your visitors see the right page when
their browsers arrive at your Web site, make sure the front page of your site
is named index.html. After that, you can name your files anything you like,
as long as they don’t include special characters or spaces.

Designing your first page

Many people are pleasantly surprised by how easily you can create a basic
Web page in Dreamweaver.

If you're ready to plunge right in, create a page and click to insert your cursor
at the top of the blank page (see the earlier section “Creating New Pages” if
you need to start from the beginning). Type some text on the page, anything
you like; you just need something to get started. If you're having trouble
being creative today, try typing My husband David is so cool. (Okay, so
I'm guilty of trying to win cheap points with my husband; but trust me, this is
a great trick if you want your spouse, partner, or other significant person in
your life to be interested when you show off your first Web page. Simply
enter your special person’s name in place of mine and you’re on your way to
creating a site he or she is sure to appreciate.)

N Although you may be tempted to use the basic formatting options I cover in
this chapter, if you're doing a lot of formatting on a site, you can save consid-
erable time using Cascading Style Sheets instead. With CSS you can define
styles for things such as headlines, and apply multiple formatting options all
at once. You can also change styles and alter the formatting everywhere it’s
applied. Chapter 8 covers CSS in detail.
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Inserting text from another program

If you have text in another program, such as
Microsoft Word or Excel, you can copy and
paste that text into your Dreamweaver page and
even keep the formatting. The Edit menu has
two paste options: Paste and Paste Special. If
you use the simple Paste option, the content you
paste loses any formatting and appears on your
page as plain text. If you choose Paste Special,

you have several options that enable you to
maintain some or all the formatting applied to
the text in the program you copied it from. Just
click to select the radio button that corresponds
to the formatting you want to preserve, and
Dreamweaver automatically applies that for-
matting to the text as it is inserted into your
page.

Creating a headline

Most Web pages have some kind of headline at the top of the page. To make
your headline bold, centered, and a large font size, follow these steps:

1. Highlight the text you want to format.

2. In the Properties inspector at the bottom of the page, select the B icon
to make the selected text bold.

The heading becomes bold.

3. In the Properties inspector at the bottom of the page, select the
center icon.

The text automatically centers.
4. In the Properties inspector, use the Size drop-down list and select 36.

The text changes to font size 36, and you have a headline at the top of
your page that looks something like the headline shown in Figure 2-5.

In general, I find the Properties inspector the easiest way to apply basic format-
ting, but some people prefer using the drop-down lists from the Text menu bar.
Both achieve the same results with the exception that Dreamweaver features
font sizes in the Properties inspector (listed as sizes 9 through 36 and xx-small
through xx-large) but offers only the capability to increase or decrease font size
from the Text menu.

\\J

You can collapse the panels on the right side of the work area by clicking the
small tab on the side of the panel set. In the following figures, I collapsed the
panels in the figures in the rest of this chapter to create more room in the
Workspace.
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Figure 2-5:
The
Properties
inspector
provides
easy access
to common
formatting
features,
such as
bold, center,
and font
sizes.
|
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Indenting text

Type a little more text after your headline text. (I added a few nice things
about meeting and marrying my husband — call me sentimental if you must.)
A single sentence is all you need, but you can add as much as text as you like.
To indent that text, follow these steps:

1. Highlight the text you want to indent.
2. Choose Text=>Indent.

The text automatically indents. Alternatively, you can use the Text
Indent and Text Outdent icons in the Properties inspector.

If you want to continue adding text and you don’t want to indent it, choose
Texte>Outdent to transition back to plain text mode without the indent. You
can also use the small Indent and Outdent icons located at the bottom of the
Properties inspector, just to the left of the Target field.

If you just want to indent a short paragraph or two, the Indent option is ideal.
If, however, you want to create the effect of a narrower column of text on a
page, you may find that putting your text in an HTML table is a better option
because you can better control the width of the column. You can find infor-
mation about creating HTML tables in Chapter 6. You can also achieve similar
results using layers, which Chapter 9 covers.
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Changing fonts and text sizes

You can change font and text sizes for the entire page or for selections of
text. You find instructions on making global changes in the following section
“Changing Page Properties.” To change the font face and font size for a
selected section of text, follow these steps:

1. Highlight the text you want to change.

2. In the Properties inspector at the bottom of the work area, select a
collection of fonts from the Font drop-down list.

The selected text changes to the font you selected.

You can also choose the Edit Font list option and use any font, but beware
that the font you apply displays on your visitor’s computer only if that
font is on the hard drive. (See sidebar, “Why so many fonts?” for more
about how this works.

3. In the Properties inspector at the bottom of the work area, specify the
size you want your text from the Size drop-down list.

Font sizes in HTML are different from the font sizes you may be used to
using in a word processing or image program. Your size options are
more limited, and you have the added choices of small, x-small, and so
on. The numbered font sizes work much like those you may be used to,
but the options specified by words like small, medium, or large display
according to the settings of a user’s browser. In general, using the num-
bered sizes gives you more predictable results.

You find many more text formatting options in the Properties inspector,

Text menu, and Text Insert bar. Go ahead, experiment a little; you can always
undo your formatting choices or change them again if you don’t like the way
they look.

Adding images

Now for the fun part. Adding an image to your Web page may seem almost
magical at first because it is so simple with Dreamweaver. The challenge with
Web graphics is not adding them to your pages, but creating good-looking
images that load quickly in your viewer’s browser. You need another pro-
gram, such as Photoshop or Fireworks, to create, convert, and edit images.
Dreamweaver just lets you place the images on your page.

For more information on finding and creating images, as well as keeping file
sizes small, see Chapter 5. For now, [ assume that you have a GIF or JPEG
image file ready, and that you want to insert your image into your page. The
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Why so many fonts?

Although you can specify any font you want for
text on your Web pages, you don't have com-
plete control over how that font appears on your
visitor's computer. That's because the font can
only display if your visitor has the font on his or
her hard drive. To help ensure your text appears
as you intend, Dreamweaver offers collections
of similar fonts, such as Arial, Helvetica, sans-
serif, or Georgia, Times New Roman, Times, serif.

Here's how it works. When you apply a collec-
tion of fonts like these, the browser displays the
formatted text in the first font available on that
list. For example, if you choose the font collec-
tion that starts with Georgia and your visitors
don't have Georgia, the text displays in Times
New Roman; if they don’t have that font, it dis-
plays in Times; and if they don't even have
Times, then the browser looks for another serif
font. (In case you're not familiar with font terms,

serif is used to describe fonts such as Times
that have those little curly things on the edges of
letters; sans serifmeans no curly things, which
is what you get with a font such as Arial.)

You can create your own font collections by
selecting the Edit Font List option. The collection
of fonts included in Dreamweaver represents
some of the most common fonts and thus the ones
most likely to appear on any user’s computer.

The only way to ensure that text appears in the
font you want is to create the text as a graphic
in a program such as Photoshop or Fireworks
and then insert the graphic with the text into
your page. That's not a bad option for special
text, such as banners or logos; but it's usually
not a good option for all your text because
graphics take longer to download than text and
harder to update later.

b7

two most common image formats you can use on your Web page are GIF and
JPEG (which is often shortened to JPG). You can use any image on your Web
site, as long as it’s in GIF or JPEG format.

If you don’t have an image handy and want one to practice the following exer-
cise with, you can download a free JPEG from my Web site at www.Digital
Family.com/free (you find instructions for downloading images in Chapter 5).

Most browsers also support BMP, but most designers never use it because
BMP files don’t optimize as well. PNG is also an accepted image format on the
Web, but Web designers rarely use it because Internet Explorer for Windows
has not supported PNG fully. Unless you have a compelling reason to use one
of these formats, you’'ll do well to stick with JPEG and GIF.

You need to do two important things before inserting an image on a Web
page: Save the page and ensure the image is in the proper folder. Saving your
page in your Web site’s folder on your hard drive is important because
Dreamweaver can’t properly set the link to your image until it identifies the
relative locations of the page and the image.
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For this same reason, you need to make sure that the image file is in your
main Web site folder (the folder you identified in the site setup process at the
beginning of this chapter). Many designers create a folder called images so
they can keep all their image files in one place. If you are working on a very
large site, you may want an images folder within each of the main folders of
the site. An important thing to remember is that if you move the page or
image to another folder after you place the image on your page, you risk
breaking the link between the page and the image, and an ugly broken image
icon appears when you view your page in a browser.

If you move files or folders in the Dreamweaver Files panel, it keeps the links
up to date, but if you move them outside of Dreamweaver, the links break. If
for some reason you do end up breaking an image link, simply click the
broken image icon that appears in its place, and use the Browse button in the
Properties inspector to find the image and replace it on your page.

Okay, assuming you've saved your page and the image you want to link is
saved within your main Web site folder, you're ready to follow these steps to
place an image on your Web page:

1. Click the Image icon located on the Common Insert bar at the top of
the work area and choose Image from the drop-down list. (Hint: The
icon looks like a small tree.)

The Image dialog box opens.
2. Click the Select button.

The Select Image Source dialog box opens, displaying files and folders
on your hard drive.

3. Navigate to the folder that has the image you want to insert.
4. Double-click to select the image you want.
The image automatically appears on your Web page.

If you haven’t already saved your page, a warning box appears to tell
you that Dreamweaver cannot properly set the link to the image until
you save the page. You see this message because Dreamweaver needs to
know the location of the HTML page relative to the image to create the
link. If you see this box, you have two options. You can click Cancel, save
your page by choosing Filer>Save, and then repeat the preceding steps.
Or, you can go ahead and choose the image, and after you save your file,
Dreamweaver tries to automatically update the image link.

If you've already saved your page, another common problem is that the
image is not located within your main Web site folder. Dreamweaver
offers you the option of creating a copy of the image in your main site
folder. Click the Yes button if you want Dreamweaver to copy the image
to your root folder (this helps ensure the image transfers to your server
correctly when you upload your site to your server).
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5. Click the image on your Web page to display the image options in the
Properties inspector at the bottom of the page.

Use the Properties inspector to specify image attributes, such as align-
ment, horizontal, and vertical spacing, and alternative text. (The image
properties are visible in the Properties inspector in Figure 2-6.)

With an image selected, the Properties inspector enables you to specify
many attributes for an image. Table 2-1 describes those attributes. If you
don’t see all the attributes listed in the table on your screen, click the
triangle in the bottom-right corner of the Properties inspector to reveal
all the image options.

Although you can resize an image in Dreamweaver by clicking and dragging
on the edge of the image or by changing the Height and Width values in the
Properties inspector, I don’t recommend you change an image size this way:.
Changing the height and width in the Properties inspector won'’t actually
change the size of the image, just the way it displays on the page. That’s a
problem for two reasons. First, using this option to make an image look
bigger often leads to the image looking distorted; second, using this option to
make an image look smaller requires your visitor to download a larger file
than necessary.
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You're almost always better off using Dreamweaver’s new auto resizing and
cropping functions or using an image editor to change the physical size of an
image. Because this is such a common thing to do, Dreamweaver includes a
few shortcuts that incorporate Fireworks image-editing capabilities and
enable you to edit an image in tandem with Dreamweaver. To edit an image in
Fireworks from within Dreamweaver, click to select the image and then click
the Fireworks icon (the yellow circle labeled FW in the Properties inspector)
to open the image in Fireworks. Edit the image in Fireworks and when you
save it, your changes are reflected in Dreamweaver.

See Chapter 5 for more on working with images in Dreamweaver, such as the
built-in cropping tool and image map features. You can find instructions for
working with Fireworks in Chapter 10.

Table 2-1 Image Attributes in the Properties Inspector
Abbreviation Attribute Function

Image N/A Specifies the file size.

Image Name Name Identifies image uniquely on the

page — an important detail if you
use behaviors or other scripts that
are triggered by the image.

Map Map Name Assign a name to an image map.
Allimage maps require a name.

Hotspot tools Image Map Coordinates Use the Rectangle, Oval, and
Polygon icons to create image map
hotspots for links. (See Chapter 5
to find out how to create an
image map.)

w Width Dreamweaver automatically speci-
fies the width of the image based
on the actual size of the image
dimensions.

H Height Dreamweaver automatically speci-
fies the height of the image based
on the actual size of the image
dimensions.
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Abbreviation

Attribute

Function

Src

Source

Required. The source is the file-
name and path from the current
document to the desired image.
Dreamweaver automatically sets
this when you insert the image.

Link

Hyperlink

This field shows the address or
path if the image links to another
page. (For more about linking,
see “Setting Links” later in this
chapter.)

Alt

Alternate Text

The words you enter display if the
image doesn't appear on your
viewer's screen because images
are turned off in the user’s
browser. Alt text is especially
important for search engines and
browsers used by the blind to read
Web pages.

Edit

Icons for Fireworks,
Optimize, Crop,
Resample, Brightness
and Contrast, and
Sharpen

Click the Fireworks icons to launch
Fireworks. Use any of the other
icons to make other minor alter-
ations to an image within
Dreamweaver.

V Space

Vertical Space

Measured in pixels, this setting
inserts blank space above and
below the image.

H Space

Horizontal Space

Measured in pixels, this setting
inserts blank space to the left and
right of the image.

Target

Link Target

Use this option when the image
appears in a page where you want
to control the target, such as when
a page is part of an HTML frameset
or when you want a link to open a
new window. The Target specifies
the frame into which the linked
page opens. | cover creating
frames and how to set links in
frames in Chapter 7.

(continued)

51



52  Partl:Fulfilling Your Dreams

Table 2-1 (continued)

Abbreviation Attribute

Function

Low Src Low Source

This option enables you to link two
images to the same place on a
page. The Low Source image loads
first and, after the rest of the page
loads, is replaced by the primary
image. You may find this option
especially useful when you have a
large image size because you can
set a smaller image (such as a
stretched black-and-white version)
as the Low Source, which displays
while the main image downloads.
The combination of two images in
this way creates the illusion of a
simple animation.

Border Image Border

Measured in pixels, this attribute
enables you to put a border around
an image. | nearly always set the
image border to 0 (zero).
Dreamweaver makes that the
default setting when linking an
image because, otherwise, the
viewer sees a colored border
around a linked image.

Align Alignment

This option enables you to align
the image. Text automatically
wraps around images aligned to
the right or left. The other options,
including Baseline, Top, and
Middle, control how text or other
elements align next to the image.
The alignment icons control the
entire paragraph containing the
image, and align the text left, right,
or center.
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Setting relative versus absolute links

Ifthe page you want to link to is within your Web
site, you want to create a relative, or internal
link, thatincludes the path that describes how to
get from the current page to the linked page. A
relative link doesn’t need to include the domain
name of the server. Here's an example of what
the code would look like if | created a relative
link to the books page on my own Web site:

<A HREF="books/index.html">Janine's

address of the other site. Here's an example of
what the code would look like behind an
absolute link if you created a link from your site
to the books page on my site:
<A
HREF="http://www.jcwarner.com/b

ooks/index.html">Janine's
Books</A>

If all that HREF code stuff looks like Greek to
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sk you, don’t worry. The following section shows

you how Dreamweaver allows you to set links

If you link to a page on a different Web site, you ! t
without even knowing what the code means.

want to create an absolute, or external, link. An
absolute link does include the full Internet

Setting Links

Dreamweaver is truly a dream when setting links. The most important thing
to keep in mind is that a link is essentially an address (URL) that tells a
viewer’s browser what page to go to when the viewer clicks the text or image
containing the link.

Linking pages within your Web site

Linking from one page to another page in your Web site — known as a relative
or internal link — is easy. The most important thing to remember is to save
your pages in the folders that you want to keep them in before you start set-
ting links. Make sure that all your files are in the root folder, as described in
the section “Defining a site,” earlier in this chapter. Here’s how you create an
internal link:

1. In Dreamweaver, open the page on which you want to create a link.

2. Select the text or image that you want to serve as the link (meaning
the text or image that opens the new page when a user clicks it).

Click and drag to highlight text or click once to select an image.
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3. Click the Browse button to the right of the Link text box in the
Properties inspector.

The Select File dialog box opens.

4. Click the filename to select the page that you want your image or text to
link to, and then click the OK button (Windows) or Choose button (Mac).

The link is automatically set and the dialog box closes. If you haven’t
already saved your page, a message box opens, explaining that you can
create a relative link only after you save the page. Always save the page
you’re working on before you set links. Note that to test your links, you
have to view your page in a browser, covered in the “Previewing Your
Page in a Browser,” section later in this chapter.

If the page is part of a frameset, use the Target field in the Properties
inspector to specify which frame the linked page opens into. (You find
out more about setting links in frames in Chapter 7.)

Setting links to named
anchors within a page

If you like to create really long pages, using anchor links to break up naviga-
tion within the page is a good idea. A named anchor link, often called a jump
link, enables you to set a link to a specific part of a Web page. You can use a
named anchor to link from an image or text string on one page to another
place on the same page, or to link from one page to a specific part of a differ-
ent page. To create a named anchor link, you first insert a named anchor in
the place that you want to link to, and then use that anchor to direct the
browser to that specific part of the page when a viewer follows the link.

Suppose that you want to set a link from the word Convertible at the top of a
page to a section lower on the page that starts with the headline Convertible
Sports Cars. You first insert a named anchor at the Convertible Sports Cars head-
line. Then you link the word Convertible from the top of the page to that anchor.

To insert a named anchor and set a link to it, follow these steps:

1. Open the page on which you want to insert the named anchor.

2. Place your cursor next to the word or image that you want to link to
on the page.

You don’t need to select the word or image; you just need a reference
point that displays when the link is selected. For this example, [ placed
the cursor to the left of the headline Convertible Sports Cars.
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3. Choose Insert=>Named Anchor.
The Insert Named Anchor dialog box appears.
4. Enter a name for the anchor.

You can name anchors anything you want (as long as you don’t use
spaces or special characters). Just make sure that you use a different
name for each anchor on the same page. Then be sure that you remem-
ber what you called the anchor, because you have to type the anchor
name to set the link. (Unlike other Web design programs, Dreamweaver
doesn’t automatically enter the anchor name.) In this example, I chose
convertible as the anchor name because it’s easy for me to remember.

5. Click OK.

The dialog box closes, and a small anchor icon appears on the page
where you inserted the anchor name. You can move an anchor name by
clicking the anchor icon and dragging it to another location on the page.

If you're curious about what this named anchor looks like in HTML,
here’s the code that appears before the headline in my example:

<A NAME="convertible"></A>

6. To set a link to the named anchor location, select the text or image
that you want to link from.

You can link to a named anchor from anywhere else on the same page or
from another page. In my example, I linked from the word Convertible
that appears at the top of the page to the anchor | made next to the
headline.

7. In the Properties inspector, type the pound sign (#) followed by the
anchor name.

You can also select the text and drag a line from the Point to File icon
(next to the Link text box) to the anchor icon. The anchor name automat-
ically appears in the Link box, saving you from typing the name again.

In my example, I typed #convertible in the Link text box. The HTML
code for this line looks like this:

<A HREF="#convertible">Convertible</A>

If you want to link to an anchor named convertible on another page with
the filename coolcars.html, you type coolcars.html#convertible in
the Link text box.

When you create a text link, Dreamweaver includes a handy little drop-down
list beside the Link box, listing the most recent links you've created. To set a
link to the same page or Web site, just select it from the drop-down list.
Unfortunately, if you're creating a link from an image, that handy drop-down
list is not available and you have to set the link by entering the URL manually
or using the Browser button to locate the page you want to link to.
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|
Figure 2-7:
Link text or
animage to
another
Web site.

Linking to pages outside your Web site

Linking to a page on another Web site — called an external link — is even
easier than linking to an internal link. All you need is the URL of the page to
which you want to link, and you’re most of the way there.

To create an external link, follow these steps:

1. In Dreamweaver, open the page from which you want to link.
2. Select the text or image that you want to act as a link.

3. In the Link text box in the Properties inspector, type the URL of the
page you want your text or image to link to.

The link is automatically set. (In the example in Figure 2-7, I created a link
to my site about family-oriented Web sites at www.digitalfamily.com.)

Although in most browsers, you don’t have to type the http:// at the begin-
ning of a Web site address to get to a site, you must always use the full URL,
including the http://, when you create an external link in HTML. Otherwise,
the browser can’t find the correct external site address and the visitor proba-
bly end ups on an error page.
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Eormat o mRENES v|BD @
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Setting a link to an e-mail address

Another common link option goes to an e-mail address. Visitors can send you
messages easily with e-mail links. I always recommend that you invite visitors
to contact you because they can point out mistakes in your site and give you

valuable feedback about how you can further develop your site.

Setting a link to an e-mail address is just as easy as setting a link to another
Web page. Before you start, you need to know the e-mail address to which
you want to link. The only other thing you need to know is that e-mail links
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must begin with the codemailto: (no //). Here’s an example of the full line
of code behind an e-mail link:

<A HREF="mailto:janine@jcwarner.com">Send a message to
Janine</A>

When visitors to your Web site click an e-mail link, their browsers automati-
cally launch their associated e-mail programs and create a blank e-mail mes-
sage to the specified e-mail address. This is a cool trick, but it can be discon-
certing to your users if they don’t expect it to happen. That’s why [ always
try to notify users when I use e-mail links by labeling them so that link clearly
goes to an e-mail address and not to another Web page.

To create an e-mail link in Dreamweaver, follow these steps:

1. In Dreamweaver, open the page on which you want to create an e-mail
link and insert your cursor where you want the link.

2. If you want to link a text block, highlight the text that you want to act
as the link.

3. Click the Email Link icon on the Common Insert bar at the top of the
screen. (It looks like a small envelope).

The Email Link dialog box opens. If you selected text before choosing
the Email Link icon, that text is automatically entered into the Text box
in the Email Link dialog box.

4. Enter or edit the text you want to represent the link on the page in the
Text box, and then enter the e-mail address (without mailto:) in the
Email box.

The e-mail link is automatically set, and any text you added or edited
appears on the page.

If you want to create a mailto link using a graphic, you can use the Properties
inspector. Click to select the image you want to link, and then type mailto:
followed by the e-mail address in the Link text area. Make sure you don’t add
any spaces between mailto: and the address. It should look like this:
mailto:name@domain.com.

Changing Page Properties

You can change many individual elements on a page in the Properties inspec-
tor, but if you want to make changes that affect the entire page, such as alter-
ing link or text colors, you need the Page Properties dialog box. Notice in
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Figure 2-8 that the Page Properties dialog box also has a Category list and
that each of these sections reveals different page options. Some of these
options are covered in other parts of the book, such as the Tracing Image fea-
ture (Chapter 4), and the Background Image feature (Chapter 5). For now, to
keep things simple, this section focuses only on changing the background
and text colors available from the Appearance category, shown in Figure 2-8,
and the options in the Links category shown in Figure 2-9.

Q&N\BER You can make global changes in the Page Properties dialog box, but you can
& override those options using the individual formatting options within
Dreamweaver, which take precedence. For example, you could make all your
text purple in the Page Properties dialog box and then change the color of
some of your text to red using the Text Color swatch box in the Properties
dialog box.
To change the background and text colors on a page, follow these steps:
1. Choose Modify-~>Page Properties.
The Appearance category of the Page Properties dialog box appears, as
shown in Figure 2-8.
|
Figure 2-8: Page Properties
The
Appearance Category Appearance
category in Erm Page fonit: | Arial, Hebeetica, sans-serif v B I
250INgs
the Page ﬁrt;?;':”ci?“:m: Size: | 10 w | |pixels
PrOpertlgS Tracing fmag Text colar: !l #EEII66
dlalog bOX Background calar: 3 HCCCCFF
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to change Repeati ®
text colors, _ _ _
font face Left margin: Right margin:
fO nt SiZe, Top margn: Bakttom margin:
background,
and
margins. ok [ concel Apply | [ hep
|

2. Specify the fonts you want for the text on your page from the Page
Font drop-down list.

If you don’t specify a font, your text appears in the font specified in your
user’s browser, which is usually Times.
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. Click the B or I to the right of the Page Font drop-down list if you want

all the text on your page to appear bold or italic.

If you select one of these options, all your text appears bold or italic
unless you specify other formatting options using the individual text
formatting options in Dreamweaver.

. Specify the font size you want for the text on your page with the Size

drop-down list.

Again, you can override these settings by changing the text size using
the individual formatting options in Dreamweaver.

. Click the Text Color swatch box to reveal the color palette. Choose

any color you like.

The color you select fills the color swatch box, but will not change the
text color on your page until you click the Apply or OK button.

. Click the Background Color swatch box to reveal the color palette.

Choose any color you like.

The color you selected fills the color swatch box. The color does not fill
the background until you click the Apply or OK button.

. Click the Browse button next to Background Image box if you want to

insert a graphic or photograph into the background of your page.

When you insert a background image it automatically repeats or tiles
across and down the page unless you choose the no-repeat option from
the Repeat drop-down list.

. Use the margin options at the bottom of the dialog box to change the

left, right, top, or bottom margins of your page.

. Click the Apply button to see how the colors look on your page. Click

OK to finish and close the Page Properties dialog box.

When you change the background, text, or link colors make sure the colors
look good together and that your text is still readable. As a general rule, a
light background color works best with a dark text color and vice versa.
To change the link color and underline options, follow these steps:

1. Choose Modify->Page Properties.

The Page Properties dialog box appears.

2. Select the Links option from the Category list.

The Links page opens, as shown in Figure 2-9.
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|
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. Specify the fonts you want for the links on your page from the Link

Font drop-down list.

If you don’t specify a font, your links appear in the font specified for the
general text of your document, or if that’s not set, the font specified in
your user’s browser, which is usually Times.

. Click the B or I to the right of the Links Font drop-down list if you

want all the links on your page to appear bold or italic.

If you select one of these options, all your links appear bold or italic
unless you specify other formatting options using the individual format-
ting options in Dreamweaver.

. Specify the font size you want for the links on your page from the Size

drop-down list.

Again, you can override these settings by changing the text size using
the individual formatting options in Dreamweaver.

. Click the Link Color swatch box to reveal the color palette. Choose

any color you like.

The color you selected is applied to links on your page. Notice that there
are four link color options:

Link: Specify the color a link appears if a user hasn’t visited its
destination page.

Visited Links: This color is used for links pointing to pages that a
visitor has already visited.

Rollover Links: A link changes to this color when a user rolls a
cursor over the link (also known as hovering).

Active Link: A link changes to this color briefly while a user is
clicking it.
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7. Specify if you want your links underlined from the Underline drop-
down list.

By default, all links on a Web page appear underlined in a browser, but
many designers find that distracting and opt to turn off underlining by
selecting Never Underline. You can also choose Show Underline Only on
Rollover to make the underline appear when users moves their cursors
over the link, or Hide Underline on Rollover to make the underline disap-
pear when users moves their cursors over a link.

8. Click the Apply button to see how the colors look on your page. Click
OK to finish and close the Page Properties dialog box.

Adding Meta Tags for Search Engines

If you've heard of Meta tags, you probably associate them with search engines,
and you’d be right. Meta tags are used for a variety of things, but the most
common is to provide special text that doesn’t appear on your page, but does
get read by crawlers, bots, and other programs that scour the Web cataloging
and ranking Web pages for sites such as Yahoo!, Google, and AltaVista.

Search engines read two common Meta tags — keyword tags and description
tags. The first enables site designers to include a list of keywords they would
like to be matched to in a search engine. Unfortunately, Meta keywords have
been so abused and used to mislead visitors that most search engines no
longer give them any weight when ranking pages. At least one search engine,
Inktomi, is still using Meta keywords at the time of this writing, and you cer-
tainly won’t hurt your ranking by using them, but they don’t offer the benefits
they once did.

The Meta description tag, however, is still widely used and is definitely worth
your time. This tag is designed to let you include a written description of your
Web site and is often used by search engines as the brief description that
appears in search results pages. If you don’t include your own text in a Meta
description tag, most search engines use the first several words that appear
on your front page; but depending on your design, the first few words may not
be the best description of your site — they’re just as likely to be your site’s
top navigation. Indeed, if you've ever wondered why the descriptions of some
Web sites seem so random or disjointed in search engines, that’s why.

To make sure your site looks good in search engine results, follow these steps
to use the Meta description tag:
1. Open the page on which you want to add your Meta description.

You can use Meta descriptions on any or all the pages on your Web site
(some search engines link directly to internal pages on your site if they
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match a search), but the most important thing is to add a description to
the main page of your site.

2. Switch to the HTML Insert bar by selecting HTML from the Insert Bar
drop-down list, as shown in Figure 2-10.

If you have set the Insert bar to display as tabs, click the HTML tab to
open it.

3. Click the small arrow next to the Head icon and choose Description.
The Description dialog box opens.

4. Enter the text you want for your page description in the Description
field in the Description dialog box.

Don’t use any HTML in this box.
5. Click OK.
The description text you entered is inserted into the HTML code.

If you want to add keywords, repeat Steps 1 through 5, selecting the
Keywords option from the Head icon drop-down list in Step 3.
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Previewing Vour Page in a Browser

Although Dreamweaver displays Web pages much like a Web browser, not all
of the interactive features you can add to a Web page function from
Dreamweaver’s work area. For example, links won’t work in Dreamweaver. To
test your links and verify that your page is displaying the way you intended,
you need to preview your work in a Web browser.
¥ The simplest way to preview your work is to save the page you are working
on and then click the Preview/Debug in Browser icon located at the top right
of the Workspace (it looks like a small globe).

When you install Dreamweaver, it automatically finds a browser on your com-
puter and sets it up so that when you click this button, you launch the browser.
If you want to test your work in more than one browser, you can add more
options to the list by choosing Edit~>Preferences and then choosing Preview

in Browser from the Category list (on a Mac, you choose Dreamweaver=
Preferences). Use the plus sign at the top of the screen to add any browsers on
your hard drive to the Browser list.

Putting Your Web Site Online

In the section “Setting Up a New or Existing Site,” earlier in this chapter, I show
you how to set up a site and enter the address, login name, and password for
your server. In this section, I show you how to put pages on your server and
retrieve them by using the built-in FTP capabilities of Dreamweaver.

To transfer files between your hard drive and a remote server, follow these
steps:

1. Make sure you defined your site, as described in the “Setting Up a
New or Existing Site” section in the beginning of this chapter and
make sure that that the site you set up is open and displayed in the
Files panel. You can open an existing site by choosing Windowr>Files
and then selecting the site.

If you do this properly, the files and folders of your site become visible
on the Files tab of the Files panel on the right side of the work area. (See
Figure 2-11.)
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2. Click the Connects to Remote Host button in the top left of the Files
panel (it looks like a small, blue electrical plug).
If you're not already connected to the Internet, the Connects to Remote
Host button starts your dialup connection. If you have trouble connecting
this way, try establishing your Internet connection as you usually do to
check e-mail or surf the Web; then return to Dreamweaver and click the
Connects to Remote Host button after establishing your Internet connec-
tion. When your computer is online, Dreamweaver should have no trouble
establishing an FTP connection with your host server automatically.
P If you still have trouble establishing a connection to your Web server,

refer to the section, “Setting up Web server access for FTP,” earlier in
this chapter and make sure that you specified the server information
correctly. If you still have trouble, contact your service provider or site
administrator to ensure you have all the correct information for con-
necting to your server. Getting all this information set up correctly the
first time can be tricky, and each service provider is different. The good
news is that, once you get this right, Dreamweaver saves your settings
so it connects automatically the next time.

After you establish the connection, the directories on your server
appear in the Files panel. You can move between views in this panel by
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choosing from the drop-down list at the top right (refer to Figure 2-11).
The main options are Local View, which displays files on your local hard
drive, and Remote View, which displays files on the server.

3. To upload a file (transfer a file from your hard drive to your Web
server), select the file from the Local View panel (which shows the
files on your hard drive) and click the Put Files icon (the up arrow) in
the Files panel.

The files automatically copy to your server when you transfer them. You
can select multiple files or folders to be transferred simultaneously.

\3
P After you upload files to you server, test your work by using a Web

browser to view them online. Sometimes things that look and work fine
on your computer (such as links) won’t work on the server.

4. To download files or folders (transfer files or folders from your Web
server to your hard drive), select the files or folders from the Remote
View panel, (which shows the files on your server) and click the Get
Files button (the down arrow) in the Files panel.

The files automatically copy to your hard drive when you transfer them.
Beware that when you copy files to or from your server, the file you're
transferring overwrites the files that are already at the destination.
Dreamweaver notifies you about the overwriting if it notices you're
replacing a new file with an old one, but it isn’t always able to correctly
assess the proper time differences. When the transfer is complete, you
can open the files on your hard drive.

\\3

You can see both the remote and local views simultaneously by clicking the
Expand/Collapse button on the far right side of the top of the Files panel. To col-
lapse this Site dialog box, click the same Expand/Collapse button a second time.

The arrows with the check mark and the little lock at the top of the Files
panel are for the Check In/Check Out feature, which enables you to keep
track of who is working on a site and prevent more than one person making
changes to the same page. Chapter 4 explains this feature.

P If you're not happy with the FTP capabilities in Dreamweaver, you can use a
dedicated FTP program, such as Fetch for the Macintosh or WS_FTP for
Windows. You can download these shareware programs from www . shareware.
com Of www . download. com.

Synchronizing Local and Remote Sites

One of the most valuable features in Dreamweaver’s FTP options is the capa-
bility to automatically synchronize the files on your hard drive with the files
on your server. This is cool because it helps you keep track of which pages
you've edited and ensure that they have been updated on the server. This



66

|
Figure 2-12:
The
expanded
Site dialog
box lets

you view
both remote
and local
files at the
same time.
|

Part I: Fulfilling Your Dreams

may not matter much to you the first time you upload your site, or if you only
have a few pages in your site, but if you have a large site and you make fre-
quent updates, this feature is a wonderful way to make sure all the changes
that you make get to your server. Dreamweaver also confirms which files are
updated after you complete the synchronization.

Follow these steps to synchronize your Web site:
1. Select the name of the site you want to work on in the Files panel

drop-down list.

If you haven’t already defined your site, you first need to follow the step-
by-step instructions in the “Defining a site” section earlier in this chapter.

2. Click the Connects to Remote Host button to log on to your remote site.

3. Click the Expand/Collapse button at the top on the far-right side of the
Files panel.

The Site dialog box displays both the remote and local views of the site,
as shown in Figure 2-12. (To collapse this dialog box, click the same
Expand/Collapse button a second time.)
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4. From the menu bar, choose Site~>Synchronize Sitewide.

The Synchronize Files dialog box appears, as shown in Figure 2-13.

Synchromze Files
‘Gynchronize: | Selected Remote Fies Only v

Direction:  Puk resver Files bo remate v/

5. Choose whether to synchronize the Entire Site or Selected Files Only

from the Synchronize drop-down list.

. From the Direction drop-down list, choose which option you want to

use to copy the files:

¢ Put Newer Files to Remote: This option copies the most recently
modified files from your local site to the remote site. Click the
Delete Remote Files Not On Local Drive box if you want those files
removed from your Web site.

¢ Get Newer Files from Remote: This option copies the most
recently modified files from your remote site to the local site. Click
the Delete Local Files Not On Remote Server box if you want to
remove those files from your local copy.

e Get and Put Newer Files: This option updates both the local and
remote sites with the most recent versions of all the files.

. Make sure the Delete Remote files Not On Local Drive box is

unchecked.

Be careful of this feature. As a general rule, | recommend you leave it
unchecked because you may have folders and files on the server, such
as log files, that do not exist on your hard drive, and you don’t want to
delete them inadvertently.

. Click the Preview button.

The Site FTP dialog box displays the files that are about to be changed.

Now you have the option to verify the files you want to delete, put, and
get. If you don’t want Dreamweaver to alter a file, deselect it from the
Site FTP dialog box now or forever live with the consequences.
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9. Click OK.

All approved changes are automatically made, and Dreamweaver
updates the Site FTP dialog box with the status.

10. When the synchronization finishes, you can choose to save or not
save the verification information to a local file.

[ recommend you choose to save the verification information as it can
be handy if you want to review your changes after synchronization is
complete.

Be very careful of the Delete Remote Files Not on Local Drive option, espe-
cially if you have special administrative pages, such as stats files, which are
often added to your server space by your service provider to track traffic on
your site.

Cloaking Options

The Dreamweaver Cloaking option enables you to exclude folders or files from
all site operations, meaning they won’t be uploaded to the live site when you're
synchronizing or batching files back and forth. This feature is handy if you
have sections of a site that you want to save but don’t want visible to your
viewers. For example, if you have a special holiday folder that you don’t want
visible during the rest of the year, you can use the Cloaking feature to save it
locally, with the assurance that no one can accidentally publish the files with
Dreamweaver until you uncloak them and publish them in December.

To use the Cloaking feature, follow these steps:

1. On the Cloaking page of the Site Definition dialog box, select the
Enable Cloaking box as shown in Figure 2-14.

2. If you want to cloak files of a certain type, select the Cloak Files
Ending With box and enter the extension(s) in the text field.

For example, if you want to cloak all your original Photoshop files so
they don’t upload and take up space on your server, enter the extension
.psd. If you want to cloak more than one file type, separate each file
extension with a space. Do not use a comma or other delimiter.

3. Click OK to close the Site Definition dialog box and then click the
Done button in the Define Sites dialog box to close it.

Files matching the extensions specified, if any, are now cloaked. If you
want to manually cloak specific folders, continue to Step 4.
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4. On the Files tab of the Files panel, select the folders you want to cloak.

You can’t cloak individual files, for reasons known only to the
Dreamweaver programmers.

5. Right-click (Windows) or Control+click (Mac) and select Cloaking=>
Cloak from the shortcut menu.

To uncloak files or folders, repeat Steps 4 and 5 and select Uncloak from the
shortcut menu. You can also use these steps to uncloak all the files in your
current site, disable cloaking in the site, and change the cloaking settings.

If you disable cloaking for all files, any manual cloaking choices you've made
are lost, even if you enable cloaking again later.
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In this part . . .

N o matter how great the content on your Web site is, it
seems viewers always pay most attention to the
design and the images. This part starts by explaining how
to design a well-planned site, an important part of creating
a well-designed site. Then, you find out how to add graph-
ics, create image maps, and bring your pages to life with
images. And you discover how to save time and ensure con-
sistency with Dreamweaver’s templates and Library items.




Chapter 3

Planning and Maintaining
a Web Site

In This Chapter

Planning a new site

Setting the tone for your site

Changing and fixing links

Testing your site with the Dreamweaver Site Report feature
Checking your site in different Web browsers

One of the most common mistakes new Web designers make is plunging
into developing a site without thinking through all their goals, priorities,
budget, and design options. The instinct is to simply start creating pages,
throw them all into one big directory, and then string stuff together with
links. Then, when designers finally test the site out on an audience, they’re
often surprised when users say the site is hard to navigate and they can’t find
what they want.

Do yourself a favor and save yourself some grief by planning ahead. By
having a plan, you also stand a much better chance of creating an attractive
Web site that’s easy to maintain and update. In this chapter, you discover
many of the common planning issues of Web design. You also find out how
Dreamweaver is designed to help manage a team of developers with features
such as Design Notes and integrated e-mail. You also discover Dreamweaver’s
file management features, which make it easy to move files and folders
around within the structure of your Web site without breaking links. If you do
find yourself in the unfortunate predicament of trying to fix broken links,
Dreamweaver makes that task easier, too. And, if you like knowing all the
details, you may appreciate Dreamweaver’s many report features, which
automatically analyze and evaluate many aspects of your Web site.
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Visualizing Vour Site

Before you get too far into building Web pages, take some time to plan your
site and think about its structure and organization. Begin thinking about the
following questions:

v What do you want to accomplish with your Web site? (What are your
goals and objectives?)

v Who is your target audience?

v Who will be working on your site? How many developers do you have to
manage?

v How will you create or collect the text and images you need for your site?

v+ How will you organize the files in your site?

v Will you include multimedia files, such as Flash or RealAudio?

v Will you want interactive features, such as a feedback form or chat room?

v What other software will you need for specialized features (for example,
Macromedia Flash for animations)?

v What kind of navigation system will you have for your site (that is, how
can you make navigating through your Web site easy for visitors)?

v How will you accommodate growth and further development of the site?

With at least a basic plan for your site, you're in a better position to take
advantage of the site-management features discussed in this chapter. Taking
the time to get clear on your goals and objectives is time well spent and can
save you lots of grief later. Set the tone for successful Web development from
the beginning and make sure you spend your precious time, money, and
energy on the elements and features that best serve your audience and help
you reach your goals.

Preparing for Development

One of the first things I like to do when I'm working on a new site with a
group or company is hold a brainstorming session with a few people who
understand the goals for the Web site. The purpose of this session is to come
up with proposed sections and features for the site. A good brainstorming
session is a nonjudgmental free-for-all — a chance for everyone involved to
make all the suggestions that they can think of, whether realistic or not.

Not discrediting ideas at the brainstorming stage is important. Often an unre-
alistic idea leads to a great idea that no one may have thought of otherwise.
And if you stifle one person’s creative ideas too quickly, that person may feel
less inclined to voice other ideas in the future.
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After the brainstorming session, you have a long list of possible features to
develop into your site. Your challenge is to edit that list down to the best and
most realistic ideas and then plan your course of development to ensure that
these ideas all work well together when you’re done.

Developing a New Site

In a nutshell, building a Web site involves creating individual pages and linking
them to other pages. You need to have a home page (often called the front page)
that links to pages representing different sections of the site. Those pages, in
turn, can link to subsections that can then lead to additional subsections. A big
part of Web site planning is determining how to divide your site into sections
and deciding how pages link to one another. Dreamweaver makes creating pages
and setting links easy, but how you organize the pages is up to you.

P If you're new to this, you may think you don’t need to worry much about how
your Web site will grow and develop. Think again. All good Web sites grow,
and the bigger they get, the harder they are to manage. Planning the path of
growth for your Web site before you begin can make a tremendous difference
later. Neglecting to think about growth is probably one of the most common
mistakes among new designers. This becomes even more serious when more
than one person is working on the same site. Without a clearly established
site organization and some common conventions for tasks such as naming
files, confusion reigns.

Managing your site’s structure

Managing the structure of a Web site has two sides: the side that users see,
which depends on how you set up links, and the behind-the-scenes side, which
depends on how you organize files and folders.

What the user sees

The side that the user sees is all about navigation. When users arrive at your
home page, where do you direct them from there? How do they move from
one page to another in your site? A good Web site is designed so that users
navigate easily and intuitively and can make a beeline to the information
most relevant to them. As you plan, make sure that users can

v Access key information easily from more than one place in the site.
v Move back and forth between pages and sections.
v Return to main pages and subsections in one step.

Setting links is easy in Dreamweaver; the challenge is to make sure that
they’re easy for visitors to follow.

75
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What you see

The second side to managing your Web site structure happens behind the
scenes (where your users can’t see the information, but you want some kind
of organizational system to remember what’s what). Before you get too far
into building your site with Dreamweaver, spend some time thinking about
the management issues involved in keeping track of all the files you create for
your site. Files are all the images, HTML pages, animations, sound files, and
anything else you put in your Web site. Once your Web site grows past a
handful of pages, organizing them in separate folders or directories is best.

Many Web developers get 20 or 30 pages into a growing Web site and then real-
ize that having all their files in one folder is confusing. To make matters worse, if
you start moving things into new folders, you have to change all the links. Not
realizing this, some people start organizing files outside of Dreamweaver, only to
discover that they have broken links. Fortunately, Dreamweaver includes site-
management tools that automatically adjust links when you move pages or
create new folders from within the Files panel. Still, starting out with a good plan
is better than having to clean up the structure later.

Before you build those first few pages, think about where you’re likely to add
content in the future (you always will!). For example, you may start with one
page that lists all your staff; but after they see how cool it is, staff members may
want to develop their own pages. In that case, you may want a separate folder
dedicated to staff pages. Similarly, if you provide information for a sales team or
create an online catalog, you may want a separate folder for each product.

As you add new sections, such as the staff or product pages I mention here,
it’s a good practice to create new subfolders to store their respective files.
Creating subfolders also makes managing a site that’s built by multiple
people easier. If each subsection has a separate folder, then each developer
can better manage his or her own files.

Naming your site’s files

As you create files and folders, you have to name them; and the more consis-
tent you are about those names, the easier it is for you and anyone else work-
ing on your site to keep track of what’s in them as the site grows.

For example, say your Web site is a newsletter that includes articles about
the happenings in your town. Simple names like fire.html and truck.html
may make sense to you this week because you're familiar with the top sto-
ries. But six months from now, if you look for that article on the six-car-pileup
that happened on Main Street, you may not remember that you called it
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truck.html. Adding dates to the end of filenames can help you identify the
files that you may need months — or even years — down the road. Remember
that you can’t use spaces, but you can use the underscore. A good filename
may be fire2006_08_12.html or truck2006_08_19.html; using dates
helps you remember that you added these articles in August of 2006.

Another option is to create a folder for each new update and name it with a
date. For example, a folder named stories2006_08 can contain all the stories
from the August 2006 issue. Then you can put truck.html and any other sto-
ries from that issue in the stories2006_08 folder, and you can find them by
date as well as by filename.

As you develop a filenaming system, talk to other people who may work on
the site and make sure you create a system that makes sense to everyone and
is easy to explain if a new person joins the team. Don’t be afraid to give files a
slightly longer, more descriptive name. Whatever you do, don’t name files
randomly and throw them all in one directory. You should also consider doc-
umenting your naming system. Printing a list of all the filenames in your site
can also provide a handy reference if you're looking for a particular file.
sMBER Make sure your files work on your Web server. Dreamweaver lets you call
your files any name that works on your operating system, even something
like don't forget this is the photo the boss likes.htm, but your
Web server may use a different operating system that’s more restrictive.
Many servers on the Web are run on UNIX machines that are case-sensitive —
so stick to lowercase for filenames and extensions. Also, keep your URLs
simple and easy to type by avoiding using spaces, apostrophes, or other spe-
cial characters, except for the underscore (_) or hyphen (-). If you use file-
names that your Web server can’t read, then your site won’t work until you
rename all those files.

Under construction? No hard hats here!

All good Web sites are under construction —
always. It's the nature of the Web. But build your
site in such a way that you can add pages when
they're ready instead of putting up placehold-
ers. Don't greet your viewers with a guy in a
yellow hat who seems to say, “You clicked this
link for no good reason. Come back another day,
and maybe we'll have something for you to
see.” Instead of creating “Under Construction”

placeholders, create directory structures that
make adding new pages later easy. You can let
readers know that new things are coming
by putting notices on pages that already have
content — a message like “Come here next
Thursday for a link to something even cooler” is
a great idea. But never make users click a link
and wait for a page to load, only to find that noth-
ing but a guy with a hard hat is waiting for them.




/8

Part II: Looking Like a Million (Even on a Budget)

A few examples of good filenames are mugshot_jim. jpg, logo_128_x_240.
gif, or deckchair.html. Bad filenames would include spaces and special
characters. These filenames would not work well on a Web site: Jim' sMugShot .
jpg, Logo.gif, or deck chair.HTML. Although coming up with names that
work and that everyone else on your site development team will remember

can take a little more time, it’s worth the effort in the long run. Now where
did I save that file about organizing images. . . .

Finding files by their addresses

If you're not sure where you saved a file or what
you called it, but you can get to it with your
browser, you can determine the filename and
location by looking at the URL in the browser’s
address bar. Each folderin a Web site is included
inthe address to a page within that folder. Folder

names are separated by the forward slash/, and
each filename can be distinguished because it
includes an extension. For example, the address
to the page displayed in the figure tells me that
the file is named dwfd.html and that it is
located in a folder called books.
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Similarly, you can identify the name and location
of any image you are viewing on a Web page. If
you're using Internet Explorer, place your cursor
over the image and right-click (Windows) and
then choose Properties from the drop-down list.
The Properties dialog box includes the specific
URL of the image, which has the name and folder
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Organizing images

Many HTML teachers and consultants suggest that you place all your images
in a single folder at the top level of the directory structure and name it images.
You may also find that other HTML authoring tools place all your images in
one folder by default. Dreamweaver doesn’t require an images folder, but it
does encourage you to identify a main images folder when you set up your
site (for more on site setup, see Chapter 2).

The advantage of keeping all your images in one folder is that you only have
one place to look for them. However, if all your images are in one place, you’ll
likely end up with a long list of image files, making it harder to keep track of
which image is which. When you want to change an image later, sorting
through this list can be arduous work.

A good alternative is to store your images in multiple images folders and keep
them within subfolders with related HTML files. For example, keep all your staff
photos for your staff pages in an images folder within a staff subfolder. If you
have images that link throughout the site — a logo, for example — you may
want to keep those images in an images folder at the top level of your directory
structure. This way, the images are easy to find from any folder in the site.

Dreamweaver makes no distinction between a folder called images and a
folder called hot-stuff, or any other name for that matter. You can name your
folders whatever you like, even goofy_pictures, just make sure you remember
what you called them so you can find them again later.
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Handling links

As you develop your site, the links only become more complicated to manage
and easier to break. Fortunately, Dreamweaver includes a variety of tools that
help you keep links in good working order.

Changing and moving files without breaking links

You can use the Files panel to rename and rearrange files and folders, as well
as create new folders, all with drag-and-drop ease. You need to define your
site for this to work (see Chapter 2).

To rename or rearrange files, follow these steps:

1. Select the site name from the drop-down list at the top of the Files
panel and choose the site you want to work on from the list.

When you select a site, the folders and files of that site display in the
Files panel on the right side of the Dreamweaver work area.

2. Use the plus (+) and minus (-) signs to open and close folders in the
Files panel.

3. In the Files panel, select the file or folder that you want to change
(move and/or rename):

To move the selected file: Drag that file or folder anywhere in the panel.
For example, you can move a file into a folder, and Dreamweaver auto-
matically changes all the related links.

This panel works just like the Explorer window on a PC or the Finder on
a Mac, except that Dreamweaver tracks and fixes links when you move
files through the Files panel. By contrast, if you move or rename site files
or folders in the Finder or Explorer, you break the links in existing Web
pages. In Dreamweaver, when you move a linked file into a new folder,
the Update Files dialog box appears with a list of links that need to be
updated, as shown in Figure 3-1. To adjust the links, choose Update. If
you choose Don’t Update, any links to or from that file are left as they
are, and likely won’t work any more.

To rename a selected file: Click the selected file, and after the cursor
appears at the end of the filename, type your new filename or edit the
existing name. When you finish, press Enter (Return on a Mac). Again
you’re prompted to update any links affected by the filename change.
Choose Update to adjust the links.
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Matking global changes to links

If you want to globally change a link to point at a new URL or to some other
page on your site, you can use the Change Link Sitewide option to enter the
new URL and change every reference automatically. You can use this option
to change any kind of link, including mailto, ftp, and script links. For example,
if the e-mail address that you list at the bottom of every page on your site
changes, you can use this feature to fix it automatically — a real timesaver.
You can also use this feature when you want a string of text to link to a differ-
ent file than it currently does. For example, you can change every instance of
the words Enter this month’s contest to link to /contest/january.htm
instead of /contest/december.htm throughout your Web site.

To change all links from one page on your site to another using the Change
Link Sitewide feature, follow these steps:

1. Make sure the site you want to work on is displayed in the Files panel.
(See Chapter 2 for more on this).

2. From the menu, choose Siter>Change Link Sitewide.
The Change Link Sitewide dialog box appears (see Figure 3-2).

3. Enter the old address and the new address you want to change it to,
or click the Browse buttons to identify files where you want to change
the links.

4. Click OK.
Dreamweaver updates any documents that include the specified links.
These changes occur only on the local version of your site on your hard drive
and are reflected on your live site until you upload them to your server. To

automatically reconcile these changes, use the Dreamweaver Synchronize
Files option described in Chapter 2.
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Finding and Fixing Broken Links

If you're trying to rein in a chaotic Web site, or if you just want to check a site
for broken links, you’ll be pleased to discover the Check Links feature. You
can use Check Links to verify the links in a single file or an entire Web site,
and you can use it to automatically fix all the referring links at once.

Here’s an example of what Check Links can do. Assume that someone on your
team (because you would never do such a thing yourself) changed the name
of a file from new.htm to o1d.htm without using the Dreamweaver automatic
link update features to fix the corresponding links. Maybe this person changed
the name using another program or simply renamed it in the Finder on the
Mac or in Explorer in Windows. Changing the filename was easy, but what
this person may not have realized is that if he or she didn’t change the links
to the file when the file was renamed, the links are now broken.

If only one page links to the file that your clueless teammate changed, fixing
the broken link isn’t such a big deal. As long as you remember what file the
page links from, you can simply open that page and use the Properties
inspector to reset the link the same way you created the link in the first
place. (You can find out all the basics of link creation in Chapter 2.)

But many times, a single page in a Web site is linked to many other pages.
When that’s the case, fixing all the link references can be time-consuming,
and forgetting some of them is all too easy. That’s why the Check Links fea-
ture is so helpful. First, it serves as a diagnostic tool that identifies broken
links throughout the site (so you don’t have to second-guess where someone
may have changed a filename or moved a file). Then it serves as a global fix-it
tool. You can use the Check Links dialog box to identify the page a broken
link should go to, and Dreamweaver automatically fixes all links referring to
that page. The following section walks you through this very cool process.

If you are working on a dynamic, database-driven site or if your site was
altered with programming that was done outside of Dreamweaver, the Check
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Links feature may not work properly. This feature works best for sites with
static HTML pages.

Checking for broken links

To check a site for broken links, follow these steps:

1. Select the site name from the drop-down list at the top of the Files
panel and choose the site you want to work on from the list.

Link checking works only for sites listed in the Dreamweaver Site dialog
box. For more information about the Site dialog box and how to set up a
new site or import an existing one, see Chapter 2.

2. From the menu, choose Site->Check Links Sitewide.

The Link Checker tab opens in the Results panel at the bottom of the
page, just under the Properties inspector, as shown in Figure 3-3. The
tab displays a list of internal and external links. The tab also lists any
pages, images, or other items not linked from any other page in the site
(Dreamweaver calls these orphans). Unused images can waste space on
your server so this list is handy if you want to clean up old images or
other elements you no longer use on the site.

Most service providers limit the amount of space on your server and
charge extra if you exceed that limit. Deleting unused files helps you
save valuable server space, especially if they are image or multimedia
files. But remember, just because you delete them from your hard drive
doesn’t mean they are deleted off the server. Make sure you remove
them from the Remote Site window in the Files panel as well as the Local
Site panel. (For more on using FTP and synchronization to update or
delete files on your server, see Chapter 2.)

If you find broken links, the next section, “Fixing broken links,” shows you
how Dreamweaver automatically updates multiple link references to make
fixing them fast and easy.

Fiving broken links

Broken links are one of the most problematic errors a Web designer can
make. After you identify a broken link in your site, you should fix it immedi-
ately. Nothing turns off visitors faster than clicking a link and getting a File
Not Found error page (also known as a 404 error because that’s the official
Web error code associated with the message viewers usually see if they click
a broken link). Fortunately, Dreamweaver makes fixing broken links simple by
providing quick access to files with broken links and automating the process
of fixing multiple links to the same file.
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After using the Link Checker feature described in the preceding section to
identify broken links, follow these steps to use the Results panel to fix them:

1. With the Results panel open at the bottom of the page, double-click a
filename that Dreamweaver identified as a broken link.

The page and its corresponding Properties inspector opens. The Results
panel remains visible.

2. Select the broken link or image on the open page.

In Figure 3-4, a broken image was selected and is being fixed by using the
Properties inspector to find the correct image name.

3. In the Properties inspector, click the folder icon to the right of the Src
text box to identify the correct image file.

The Select Image Source dialog box appears. You can type the correct
filename and path in the text box or browse to find the image.

You fix links to pages just as you fix links to images, except you type the
name of the correct file into the Link text box or click the folder icon
next to it to find the file in your site folder.

4. Click the filename and the Select button; then click OK.

The link automatically changes to reflect the new filename and location.
If you replace an image, the image file reappears on the page.
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If the link that you correct appears in multiple pages, Dreamweaver prompts
you with a dialog box asking whether you want to fix the remaining broken
link references to the file. Click the Yes button to automatically correct all
other references. Click the No button to leave other files unchanged.

Testing Vour Work with the
Site Reporting Feature

Before you put your site online for the world to see, checking your work using
the Dreamweaver Site Reporting feature is a good idea. You can create a vari-
ety of reports, and even customize them, to identify problems with external
links, redundant and empty tags, untitled documents, and missing Alt text.
You can easily miss things — especially when you work on a tight deadline —
and what you miss can cause real problems for your viewers if you leave mis-
takes unfixed.

Before Dreamweaver added this great new feature, finding these kinds of mis-
takes was a tedious and time-consuming task. Now you can run a report that
identifies these errors for you and use Dreamweaver to fix mistakes across
your entire site automatically.

85



86 Part II: Looking Like a Million (Even on a Budget)

\\J

|
Figure 3-5:
You can
select any
or all the
options in
the Reports
dialog box
to run simul-
taneously,
and you can
run reports
on a single
page or

on your
entire site.
|

Follow these steps to produce a Site Report of your entire Web site:

1. Select the site name from the drop-down list at the top of the Files
panel and choose the site you want to work on from the list.

See Chapter 2 for step-by-step instructions for defining your site if you
haven’t done so already.

2. Make sure all your open documents are saved by choosing File=>
Save All.

3. From the Site menu, choose Site>Reports.
The Reports dialog box appears (see Figure 3-5).
4. From the Report On drop-down list, choose Entire Current Local Site.

You can also choose to check only a single page by opening the page in
Dreamweaver and then choosing Current Document from the Report On
drop-down list. You can also run a report on selected files or on a partic-
ular folder. If you choose Selected Files, you must have already selected
the pages you want to check in the Files panel.

5. Select the type of report you want by putting check marks next to the
report names in the Select Reports section.

Table 3-1 describes the kind of report you get with each option. You can
select as many reports as you want.

The Workflow options in the Select Reports section are available only if
you already enabled Check In/Out in the Remote Info section of the Site
Definition dialog box and selected Maintain Design Notes in the Design
Notes section of the Site Definition dialog box’s Advanced tab. You can
read more about the Site Definition dialog box in Chapter 2 and more
about Design Notes and the Check in/Check Out feature in Chapter 4.

Reports
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Enitire Curvent Local Site .
Selected Files in Site %
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6. Click the Run button to create the report(s).

If you haven’t already done so, you may be prompted to save your file,
define your site, or select a folder (see Chapter 2 for more information
on defining a site in Dreamweaver).

The Results panel opens (see Figure 3-6 displaying a list of problems
found on a site). You can sort the list by different categories (filename,
line number, or description) by clicking the corresponding column head-
ings. If you run several reports at the same time, you can keep all the
results tabs open at the same time.
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7. Double-click any item in the Results panel to open the corresponding
file in the Document window.

You can also right-click (Windows) or Control+click (Mac) on any line of
the report and choose More Info from the drop-down list to find addi-
tional details about the specific error or condition.

8. Use the Properties inspector or other Dreamweaver feature to fix the
identified problem and then save the file.

Your changes aren’t applied to your live site until you update your
server. Use the Synchronize feature, described in Chapter 2, to update
all your changes at once.

Table 3-1

Site Report Options

Report Name

Results

Checked Out By

Produces a list of files checked out of the site and
identifies the person who checked them out.

Design Notes

Produces a list of Design Notes (see Chapter 4 for
more on how to use Design Notes).

Recently Modified

Produces a list of files recently changed. You can set
the time period for the report by clicking the Report
Settings button.

(continued)
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Table 3-1 (continued)

Report Name Results
Combinable Nested Produces a list of all instances where you can
Font Tags combine nested tags. For example, <font color=

"#000000"><font size="2">Great Web
Sites You Should Visit</font></font>
is listed because you can simplify the code by com-
bining the two font tags into <font color=
"#000000" size="2">Great Web Sites
You Should Visit</font>

Accessibility Produces a list of possible accessibility issues in a
wide variety of categories. To set the report cate-
gories, click the Report Settings button.

Missing Alt Text Produces a list of all the image tags that do not
include Alt text. Alt textis a short alternative text
description for an image tag. If the image isn't dis-
played for some reason (many people choose to surf
with images turned off), the Alt text appears in place
of the image. Alt text is also important to the blind
because special browsers that read pages to site
visitors can't interpret text that is part of an image,
but can read the Alt text included in the image tag.

Redundant Nested Tags Produces a list of all places where you have redun-
dant nested tags. For example, <center>Good
headlines <center>are harder to write
</center> than you might think
</center> is listed because you can simplify the
code by removing the second center tag to make the
code look like this: <center>Good headlines
are harder to write than you might
think</center>.

Removable Empty Tags Produces a list of the empty tags on your site. Empty
tags often occur if you delete an image or text sec-
tion without deleting all the tags associated with it.

Untitled Documents Produces a list of filenames that don't have a title.
The title tag is easy to forget because it does not dis-
play in the body of the page. The title tag specifies
the text that appears at the very top of the browser
window and is also the text that appears in the
Favorites list when someone saves your page in his
or her browser. And if that's not enough reason to
have a descriptive title, a good title tag is one key to
getting good placement in many search engines as
well.




Chapter 4
Coordinating Your Design Work

In This Chapter

Using advanced template features to speed development

Saving elements in the Dreamweaver Library for easy access
Designing a Web page with the Dreamweaver Tracing Image feature
Introducing Design Notes

Collaborating with integrated e-mail and Check In/Out

Using the History panel and the Quick Tag Editor

Srive for consistency in all your designs — except when you're trying

to be unpredictable. A little surprise here and there can keep your Web
site lively. But, generally, most Web sites work best and are easiest to navigate
when they follow a consistent design theme. Case in point: Most readers take
for granted that books don’t change their design from page to page, and
newspapers don’t change headline fonts and logos every day. Books and
newspapers want to make life easier for their readers, and consistency is
one of the primary tools for making sure readers find publications familiar.
Dreamweaver offers several features to help you develop and maintain a
consistent look and feel across your site, whether you’re working on a Web
site by yourself or you're coordinating a team of developers.

In this chapter, you discover three of my favorite Dreamweaver features —
templates, Library items, and the Tracing Image feature. Find out how they
combine to make your design work faster and easier to manage. This chapter
also introduces you to Design Notes, the Check In/Out feature, the History
panel, and the Quick Tag Editor — tools that you can use for managing a
team of designers, retracing your steps in Dreamweaver, and tweaking HTML
tags respectively.

Templating Vour Type

Many Web design programs boast about their HTML templates. Often what
they really mean is the program includes some ready-made page designs.
Dreamweaver takes this concept a few leaps further by providing template
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design features that enable you to create a predesigned page and specify
which sections can and can’t be altered. This is a valuable feature if you work
with a team of people with varying skill levels, or if you have to create dozens
of pages with the same basic layout. For example, if you're building a site for
a real-estate company and you want to let the employees update the sales
listings without messing up the page design, a template with locked regions
can be an ideal way to allow sales staff to add new information without acci-
dentally breaking anything.

Templates are best used when you’re creating a number of pages that share
the same characteristics, such as the same background color, column design,
or image arrangement. For example, if you're creating a Web site for a bed-
and-breakfast inn, such as the Inn on Tomales Bay featured in the examples in
this chapter, you might create a template for all the pages where you want to
show off the rooms in the Inn. In that case, you might create a room template
design with a spot for a photo, descriptive text, and forward and back arrows
so that visitors could easily move through the pages for all the rooms. As you
create each new page, you would start with the template, changing only the
photo, descriptive text, and links. Templates can save tons of time and help
ensure that page designs are more consistent.

Dreamweaver’s template feature has an additional functionality that enables
you to make global changes to your site by changing just the template file.
Here’s how it works. If you create a series of pages with the same template,
and then decide you want to alter the template design, the changes you make
to the original template can automatically be applied to any or all the files
created from the template. For example, if you need to change the logo for
your bed-and-breakfast on all your pages, you can simply replace the logo

on the original template and, using the automated update feature, apply that
change to all the pages created with that template. This feature can be a huge
timesaver when you need to make changes to several pages at once.

Dreamweaver 8 includes a wealth of ready-to-use templates; with this ver-
sion, you even find Starter Pages, which include prewritten text to help you
get started with common sites features, such as calendars and product
pages. Templates, starter pages, and many other predesigned components in
Dreamweaver give you a choice of many page layouts, cascading style sheet
designs, framesets, and table-based layouts that can help you create a Web
site quickly.

Creating Predesigned Pages with
Dreamweaver’s Design Files

Dreamweaver comes with a great collection of predesigned pages you can
use to create Web sites with Cascading Style Sheets, frames, and complex
page designs. Macromedia calls these design files, but they are essentially
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templates — predesigned pages you can customize with your own content.
Using a template, or design file, to create a new page is similar to creating any
other page in Dreamweaver with the added advantage that much of the work
is already done for you.

Dreamweaver’s design files do not include all the most advanced features
of Dreamweaver templates, such as the capability to make global changes,
unless you first save the files as custom templates (instructions for that
are in the following section).

Among Dreamweaver’s design files, you can find the following:

v Framesets: These page designs are specific to HTML frames, which
enable you to display multiple pages on the screen at once. Chapter 7
has instructions for working with frames and frame templates.

1 Page Designs (CSS): These files use Cascading Style Sheets to control
layout and design.

v~ Starter Pages: These page designs include written content to give you a
head start as you create common sections in a Web site, such as a calen-
dar or product page.

1 Page Designs: These are most useful as inner page designs around
which you can place your standard header, footer, or navigation, and
they use standard CSS formatting and tables to control layout and
design.

In addition to the design files included in Dreamweaver, you can create
custom templates. Step-by-step instructions are in the “Creating Your Own
Templates” section later in this chapter.

To use one of Dreamweaver’s design files to create a page, follow these steps:

1. Choose Filec>New.

Alternatively, you can choose any of the options from the Create From
Samples section on the Dreamweaver Start page.

2. Choose a design file from any of the four collections available on the
General tab: Framesets, Page Designs (CSS), Starter Pages, or Page
Designs.

Dreamweaver’s design files for the selected collection display in the New
Document window. In the example shown in Figure 4-1, I chose the Page
Designs from the Category list and then selected the Image: Slide Show
from the Page Designs list.

3. From the list of page designs in the middle of the New Document
window, click to display a preview of a template.
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. Choose whether you’re creating a document or a template, and click

the corresponding radio button from the bottom right of the New
Document window.

. With the design file selected, click Create to create a new page.

A new page is created from the design file and opens in the main work
area.

. Choose File=>Save to save the page before you make any changes.

Saving your pages before adding images or setting links is important.
Make sure you save the new page within the main folder of the Web site
you are creating.

If you have not already completed the setup process for this site, see
Chapter 2 to take care of this important preliminary step.

. Click to select any text area, image, link, or other element on the page

and replace it with your own images or text to customize the design.

In the example shown in Figure 4-2, I've replaced the blank image in
the middle of the page with an image from the Inn on Tomales Bay and
replaced the title and caption text. Creating additional pages with this
same design file would allow me to easily create a slide show of images
from this bed-and-breakfast inn.

. Continue to edit the page, replacing images and filler text (Dream-

weaver uses Latin as filler text), setting links, and making any other
alterations or additions to the page.

. When you are done, use File~>Save to save your changes.
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& You can edit or replace anything in a Dreamweaver design file, and even alter

the design to better fit your site.

Creating Your Own Templates

Creating a template is as easy as creating any other file in Dreamweaver. You
can start by creating an HTML page as you would any other page (or modify-
ing an existing page as you would edit any other page). The main difference
is that when you save the file you save it as a template and the file is stored
in a special Templates folder, which Dreamweaver automatically creates in
the main folder for your Web site. Templates must be kept in this common
folder for the automated features in Dreamweaver to work properly.

¥ The template features work only if you define your Web site in Dreamweaver.

If you haven’t gone through the setup process to define your site yet, refer to

Chapter 2.

Custom templates created in Dreamweaver have locked (noneditable) regions
and unlocked (editable) regions. Use editable regions for content that changes,
such as product descriptions or events in a calendar. Use locked regions for
static, unchanging content, such as a logo or site navigation elements.
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For example, if you're publishing an online magazine, the navigation options
may not change from page to page, but the titles and stories do. To indicate
the style and location of an article or headline, you can define placeholder
text (an editable region, with all the size and font attributes already speci-
fied). When you're ready to add a new feature, you simply select the place-
holder text and either paste in a story or type over the selected area. You do
the same thing to create a placeholder for an image.

While you’re editing the template itself, you can make changes to any part of
the file, be it the editable or locked regions. While editing a document made
from a template, however, you can make changes only to the editable regions
of the document. If you go back and change a template after creating it,
Dreamweaver gives you the option of having those changes updated in all the
pages you created with that template.

You can create both editable regions and editable attributes in a Dreamweaver
template. An editable region can be changed in files created from the tem-
plate — you alter text, replace images, and even add tables, images, text, and
so on. Editable attributes relate only to specific elements in a template. For
example, you may want to make the attributes of an image editable to allow
the alignment to be changed from left to right.

In a new template, all elements are locked by default except for two parts of
the document head section, which is indicated by the <HEAD> </HEAD> tags.
These tags enable you to change the title in any page created from a tem-
plate, or to insert JavaScript if you use behaviors on the page. For the tem-
plate to be of much use for building new pages, you must make areas in the
body of the page editable as well. Remember that you can always go back to
the template later to alter the design, make more areas editable, or lock areas
so they can’t be changed.

Creating a new custom template

To create a template that you can use to create new pages, follow these steps:

1. In the Files panel on the right side of the work area, click the Assets
tab and then click the Templates icon (see Figure 4-3).

The Templates panel opens. You don’t have to have the Templates panel
open to create a new template, but having it handy when you’re working
on templates is good because it provides a list of available templates as
well as easy access to template editing and organizational functions.
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2. Choose File=>New.

The New Document window opens (see Figure 4-4).
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. From the Category list in the of the New Document window, choose

Template Page.

The template options become visible in the Template Page list in the
middle of the New Document window.

. Choose HTML Template.

You can choose from a variety of template options, including templates
for ASP (Active Server Pages), ColdFusion, and PHP, all of which are
used for creating dynamic sites, like those shown in Chapters 13, 14,
and 15.

. Click the Create button.

A new blank template is created and opens in the main work area, and
the New Document dialog box closes.

. Choose File~>Save and name the template.

The new template is added to the Assets panel (refer to Figure 4-3).

. You can now edit this page as you edit any other HTML page, inserting

images, text, tables, and so on.

8. Choose Modify->Page Properties to specify background, text, link

CMBER
@&
9
10.
11.
12.
CMBER
&é

colors, and other options that apply to the entire page.

This works just like any other Dreamweaver document.

. To create an editable region, select the content you want to affect,

right-click (Windows) or Control+click (Mac), and choose Templates>
New Editable Region (as shown in Figure 4-5).

The New Editable Region dialog box opens.

Give the new region a name. I recommend something that identifies
the kind of content it is, such as headline or photo_caption.

The region you define as editable becomes an area that can be changed
in any page created with the template. You can have multiple editable
regions in one template, such as a photo that is an editable region and a
photo caption that is a separate editable region. Areas that you don’t
mark as editable become locked and can be changed only if you modify
the template itself.

Click OK.

The editable region is enclosed in a highlighted area with a tab at the
top left, indicating the name of the region.

When you finish designing the page, choose Filer>Save to save your
template.

You can make an entire table or an individual table cell editable, and you can

make entire rows editable. (For more about creating HTML tables, see
Chapter 6.)
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Saving any page as a template

Sometimes you get partway through creating a page before you realize you're
likely to want more pages like it and you should create a template so you don’t
have to re-create the same page design multiple times. Similarly, you may have
a page that someone else created that you want to turn into a template. No
matter where the original page comes from, creating a template from an exist-
ing page is even easier than creating a new template from scratch.

To save a page as a template, follow these steps:

1. Open the page that you want to turn into a template.

Choose File=>Open and browse to find your file. Or, open the site in the
Files panel and double-click the file to open it.

2. Choose Filem>Save As Template.
The Save As Template dialog box appears (see Figure 4-6).
3. Select a site from the Site drop-down list.

The menu lists all the sites that you have defined in Dreamweaver. If
you’re working on a new site or haven'’t yet defined your site, Chapter 2
shows you how to define your site.
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) You can use the Save As Template option to save a page as a template
into any defined site, which makes it easy to save a page design from
one site as a template for another site.

4. In the Save As text box, type a name for the template.
In the example shown in Figure 4-6, | named the template guests.
|
Figure 4-6: [Save he Template
. YOU can Site: |Inn on Tomakes Bay w E
view a” the Existing templates: [; : E
templates in roams =
any defined
site in the
Save As Description: | Guest Pages
Template Save as! | guests Help
dialog box.
|

5. Click the Save button.

Notice that the file now has the . dwt extension, indicating that it’s a
template. You can now make changes to this template the same way
you edit any other template.

6. Decide if you want to update links or not.

Because your original file was probably saved in a different directory
from the templates, Dreamweaver offers to update all your links and
keep them pointing to the correct destination. Unless you have a spe-
cific reason not to allow Dreamweaver to take care of the links for you,
click Yes.

7. Make any changes that you want and choose File~>Save to save the
page.
Follow the steps in the earlier section, “Creating a new custom template,’

to create editable regions. Follow the steps in the next exercise to create
editable attributes.

9

Making attributes editable

To create editable attributes in a template, follow these steps:
1. In any Dreamweaver template, select an item you want to have an
editable attribute.

In the example shown in Figure 4-7, [ selected a section of text, and [ am
in the process of making text attributes editable.
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Figure 4-7:
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|
Figure 4-8:
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the Editable
Tag
Attributes
dialog box.
|
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2. Choose Modify~>Templates->Make Attribute Editable, as shown in

Figure 4-7.

The Editable Tag Attributes dialog box appears, shown in Figure 4-8.

Editable Tag Attributes

Choose which atkribubes of this FONT kag
should be editable.

sise:

[ Make attribute edtable
Label: |

Type:

Default: | |

To change the value of this sttrbute in a page
based on this template, choose Modfy =
Template Properties.

To change whether & is editable, use the Maks
Attribute Editable”’ command again.

il

Cancel

3. From the Attribute drop-down list, choose the attribute you want to be

editable.

If the attribute doesn’t exist yet, click the Add button.
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4. Click to place a check mark in the Make Attribute Editable box and fill

in the Label, Type, and Default options.

The attribute options vary depending on whether you select an image,
text, or other element on the page. With these options, you can control
whether or not an image can be changed and what specific attributes of
the image tag may be altered when the template is used.

5. Click OK.

Using custom templates

After you create your own custom templates, you’ll want to put them to use.
You can use templates to create or modify all the pages in your Web site or
use templates for specific sections. For example, in a site such as the Inn on
Tomales Bay site, you could create one template for the pages that feature
each of the rooms and another template for a slide show of photos from
guests. Using a template to create a new page is similar to creating any other
HTML page.

To use a template to create a page, follow these steps:

1.

Choose Filec>oNew.

The New Document window opens.

. Select the Templates tab at the top of the New Document window.

The New from Template dialog box opens, as shown in Figure 4-9, display-
ing all the templates from the sites you have defined in Dreamweaver.

. From the Templates For list on the left, choose the site that contains a

template you want to use.

The templates in the selected site appear in the middle of the dialog box.

. Select the template you want to use from the Site list in the middle of

the dialog box.

A preview of the selected template displays in the right side of the dialog
box. In the example shown in Figure 4-9, | selected the Rooms template
from the Inn on Tomales Bay Web site.

. Click the Create button.

A new page is created from the template and displays in the main work
area.

. Edit any of the regions of the page that are editable using

Dreamweaver’s regular editing features.
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Making Global Changes with Templates

One of the greatest advantages of using templates is that you can automati-
cally apply changes to all the pages created with a template by altering the
original template. For example, suppose you want to make a change to the
layout of all your slide show pages after you’ve created a slide show using
Dreamweaver’s slide show template. First, you would open the slide show
template, make the edits you want to the overall page design, and when you
save the template, you can opt to automatically update all the pages created
with that template. If you're making changes to many pages at once this can
be a real timesaver. You can also choose to leave all the pages previously cre-
ated with the template unchanged and to have only new pages created with
the template reflect the changes.

To change a template and automatically update all the files in your site that
use that template, follow these steps:
1. Open an existing template.

2. Use Dreamweaver’s editing features to make any changes you want to
the template.

3. Choose File=>Save.

The Update Template Files dialog box appears, shown in Figure 4-10.
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4.

Figure 4-10:
You can

Click the Update button to modify all the pages listed in the Update
Template Files dialog box.

Dreamweaver automatically changes all the pages listed in the Update
Template Files dialog box to reflect the changes you made to the template.

Choose the Don’t Update button to leave these pages unchanged.

update all |Update Template Files

the files

from the
Update
Template

Update all Fles based on this bemplate?

i trips. el
created with s Dont Lpdate

atemplate | | packeges.timi

Files dialog ~
box.
|

If you're not sure what template was used to create a page, you can open the
template while you have the page open, make changes to the template, and
update all the pages created with it by following these steps:

1.
2.

Open a document that uses the template that you want to change.

Choose Modify=>Templates=>Open Attached Template as shown in
Figure 4-11.

The template opens.

. Use Dreamweaver’s regular editing functions to modify the template

as you would edit any page or template.

For example, to modify the template’s page properties, choose Modify=>
Page Properties.

. Choose File=>Save.

The Update Template Files dialog box appears (refer to Figure 4-10).

. Click the Update button to modify all the pages listed in the Update

Template Files dialog box. Click the Don’t Update button to leave
these pages unchanged.

If you chose Update, Dreamweaver automatically changes all the pages
listed in the Update Template Files dialog box.
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You can also apply changes to a template using the Update Pages option.

To do so, you have to first open the template, and then make and save your
changes without applying those changes to pages created with the template.
Then anytime later, you can choose Modify=>Templates=>Update Pages to
apply the update.

Attaching and Detaching Templates

You can apply a template to an existing page by attaching it, and you can
remove a template from a page by detaching it. When you apply a template
to an existing document, the content in the template is added to the content
already in the document. If a template is already applied to the page, Dream-
weaver attempts to match editable areas that have the same name in both
templates and to insert the contents from the editable regions of the page
into the editable regions in the new template. This happens automatically if
all region names are the same.

Remove or detach a template from a page if you want to ensure that changes
to the original template don’t affect the page created with the template.
Detaching a template also unlocks all regions of a page, making it completely
editable.
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You can apply a template to an existing page by using any one of the follow-
ing techniques:

v Choose Modify=>Templates=>Apply Template to Page and then double-
click the name of a template to apply it to the page.

v Drag the template from the Template panel into the Document window.

If the editable regions don’t match up, Dreamweaver asks you to match up
inconsistent region names in a dialog box. After the region conflicts are
resolved, click OK.

You can detach a template, or remove the template association from a file, by
selecting Modify=>Templatest>oDetach from Template. This action makes the
file fully editable again, but any future changes you make to the template will
not be reflected on the detached page.

Reusing Elements with
the Library Feature

The Library feature is not a common feature in other Web design programs,
so the concept may be new to you even if you’ve been developing Web sites
for a while. The more experience you have with this feature, however, the
more likely you are to appreciate its value and the time you can save using
library items.

The Dreamweaver Library feature automates the process of inserting and
updating elements that appear on multiple pages in a Web site. You can save
any element as a Library item — for example, a logo or a row of images that
serve as a site’s navigation, or even a table with images and links. After you
save it in the library, you can insert any item or collection of items into any
page from the Library with drag-and-drop ease. And, if you ever need to
change a Library item (by adding or changing a link, for example), you simply
edit the stored Library item and Dreamweaver automatically updates the
Library item on any or all the pages where it appears throughout the site.

A Library item is a snippet of code that can contain image references and
links. Like templates, Library items are a great way to share the work of your
best designers with less experienced ones. For example, one designer can
create a logo and another the navigation elements, and then these can be
placed in the Library and made available to the entire team. You have more
flexibility with Library items than templates because they are elements you
can place anywhere on any page, even multiple times. Libraries are not
shared among sites, however, so each site you define must have its own col-
lection of elements in its Library:.
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You can save any element from the body of a document as a Library item.
That includes text, tables, forms, images, Java applets, and even multimedia
files. Library items can also contain behaviors, but special requirements exist
for editing the behaviors in Library items. (For more on behaviors, see
Chapter 9.)

Library items cannot contain their own style sheets because the code for
styles can only appear as part of the Head area of an HTML file. (For more
on style sheets, see Chapter 8.)

Creating and using Library items

The following sections show you the steps for creating a Library item, adding
one to a page, and editing and updating a Library item across multiple pages.
For these steps to work properly, you must do them in sequential order. Before
creating or using Library items, you must first define a site or open an existing
site. If you're not sure how to do this, see Chapter 2.

Creating your Library item within an existing page works well because you
can see how the item looks before you add it to the Library. You can, of
course, edit an item after it’s in the Library, but it may not look just as it will
on a Web page. For example, Library items don’t include <BoDY> tags when
they are saved in the Library, so link colors display as default blue when
viewed in the library, even if the link colors have been changed to purple in
all the pages in a site.

Creating a Library item

To create a Library item that you can use on multiple pages on your site,
follow these steps:

1. Open any existing file that has images, text, or other elements on the
page that you want to save as a Library item.

Alternatively, you can create a new page and insert only the element you
want to save to the library.

2. From this page, select an element or collection of elements that you
want to save as a Library item, such as the row of images used for
your site navigation.

3. Choose Modify~Library-~Add Object to Library.

The Assets tab of the Files panel opens and displays the Library. Your
new Library item displays as “Untitled.”
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|
Figure 4-12:
The Assets
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displays all
Library
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drag and
drop to save
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Library
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|

4. Name the element as you would name any file in the Finder on a Mac
or in Explorer on a PC.

When you name a Library item, you automatically save it to the Library.
You can then easily apply the item to any new or existing page in your
site. The Library section of the Assets panel lists all Library items, as
shown in Figure 4-12.

Adding a Library item to a page

You can easily add elements from the Library to your pages by simply drag-
ging them from the Assets panel to the page. When you add a Library item to
a page, the content is inserted into the document and a relationship is estab-
lished between the content on the page and the item in the library. This is
important as it enables you to edit the Library item later and apply the
changes to all pages where the item appears, but it also means that you can
not edit the item on the page where it is inserted. You must edit Library items
from within the Library, as you see in the following section.

To add a Library item to a page, follow these steps:

1. Create a new document in Dreamweaver or open any existing file.

2. From the Files panel, choose the Assets tab and then select the
Library icon.
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The Library opens in the Assets panel (refer to Figure 4-12).
3. Drag an item from the Library to the Document window.

Alternatively, you can select an item in the Library and click the Insert
button.

The item automatically appears on the page. After you insert a Library
item on a page, you can use any of Dreamweaver’s formatting features to
position it on the page.

Highlighting Library items
Library items are highlighted to distinguish them from other elements on a

page. You can customize the highlight color for Library items and show or
hide the highlight color in the Preferences dialog box.

To change or hide Library highlighting, follow these steps:

1. Choose Edit~>Preferences (Windows) or Dreamweaver~ Preferences
Mac).
The Preferences dialog box appears.

2. Select Highlighting from the Category section on the left.

3. Click the color box to select a color for Library items. Check the Show
box to display the Library highlight color on your pages.

Leave the box blank if you don’t want to display the highlight color.
4. Click OK to close the Preferences dialog box.

Making global changes with Library items

One of the biggest timesaving advantages of the Dreamweaver Library feature
is that you can make changes to Library items and automatically apply those
changes to any or all the pages where the Library item appears.

To edit a Library item, follow these steps:
1. From the Files panel, choose the Assets tab and then select the Library
icon.
The Library opens in the Assets panel (refer to Figure 4-12).
2. Double-click any item listed in the Library to open it.
Dreamweaver opens a new window where you can edit the Library item.

Because the Library item is just a snippet of code, it won’t have a
<BODY> tag in which to specify background, link, or text colors. Don’t
worry over this — the Library item acquires the right settings from the
tags on the page where you insert it.
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3. Make any changes you want to the Library item as you would edit any
element in Dreamweaver.

For example, you can change a link, edit the wording of text, change the
font or size, and even add images, text, or other elements.

4. Choose Filew>Save to save changes to the original item.

The Update Library Items dialog box opens, displaying a list of all pages
where the Library item appears.

5. Click the Update button to apply the changes you made to the Library
item on all the listed pages. If you don’t wish to apply the changes to
the pages where the Library item appears, choose the Don’t Update
button.

The Update Pages dialog box appears and shows the progress of the
updating. You can stop the update from this dialog box, if necessary.

If you want to create a new Library item based on an existing one without
altering the original, follow Steps 1 through 3, and in place of Step 4, choose
Filer>Save As and give the item a new name.

Editing one instance of a Library item

If you want to alter a Library item on a specific page where you have inserted
it, or if you want to make changes to just a couple of pages, you can override
the automated Library feature by detaching it, or breaking the link between

\BE the original in the Library and the item inserted into the page.
gMBER

< After you break a connection, you can no longer update that page’s Library
item automatically.

To make a Library item editable, follow these steps:

1. Open any file that contains a Library item and select the Library item.

The Properties inspector displays the Library item options shown in
Figure 4-13.

2. Click the Detach from Original button.

A warning message appears, letting you know that if you proceed with
detaching the Library item from the original, you can no longer update
this occurrence of it when the original is edited.

3. Click OK to detach the Library item.
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The Macromedia Tracing Image feature is unique in the world of Web design
tools, although the concept dates back to the earliest days of design. The
Tracing Image feature enables you to use a graphic as a guide to your page
design, much like an artist who creates a sketch and then paints the final pic-
ture over the sketch.

The Tracing Image feature is ideal for people who like to first create a design
in a program such as Photoshop or Fireworks and then model their Web page
after it. By using the Tracing Image feature, you can insert an image into the
background of your page for the purpose of tracing over it. Then you can
position layers or create table cells on top of the tracing image, which makes
exactly re-creating your design in HTML easier. You can use JPG, GIF, or PNG
images as tracing images, and you can create them in any graphics applica-
tion that supports these formats.

Although the tracing image appears in the background of a page, it doesn’t
take the place of a background image and will not display in a browser.
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To add a tracing image to your page, follow these steps:

1.
2.

Create a new page or open any existing page in Dreamweaver.
Choose Modify->Page Properties.

The Page Properties dialog box opens, as shown in Figure 4-14.

. Select Tracing Image from the Category list on the left of the dialog box.

The Tracing Image options display on the right.

. Click the Browse button to locate the image you want to use as a trac-

ing image.

The Select Image Source dialog box appears.

5. Click the image you want to trace from.
6. Click OK.

7. Set the opacity for the tracing image with the Transparency slider.

Lowering the transparency level causes the tracing image to appear
faded, which makes distinguishing between the tracing image and con-
tent on the page easy. You can set the transparency level to suit your
preferences, but somewhere around 50 percent seems to work well with
most images.

. Click OK.

A tracing image appears in the Document window, as shown in
Figure 4-15.

Page Properties

Figure 4_14. Category Tracing Image

AppEarance R P M
The Page Titke(Encoding Tracing image: | imgftraces-image.gf Browse, ..

Tracing Image

Properties
dialog box
lets you set
a tracing
image to
use when
laying out
your HTML
page.
|

Transparency: I 4%,

Transparent Opaqus

[ i ]l Cancel H Apphy | | Help




Figure 4-15:
When you
place a
tracing
image
behind a
pagein
Dream-
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more
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|
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You have a few other options with the Tracing Image feature. Choose View>
Tracing Image to reveal the following options:

v Show: Hides the tracing image if you want to check your work without it
being visible but don’t want to remove it.

v~ Align with Selection: Enables you to automatically line up the tracing
image with a selected element on a page.

v Adjust Position: Enables you to use the arrow keys or enter X, Y coordi-
nates to control the position of the tracing image behind the page.

+” Reset Position: Resets the tracing image to 0, 0 on the X, Y coordinates.

v Load: Enables you to add or replace a tracing image.

Making the Most of Dreamweaver’s
Site-Management Features

In Chapter 2, I introduce you to Dreamweaver’s Manage Sites dialog box and
some of the options in the Site Definition dialog box, such as the Local Info
dialog box where you do the initial site setup for any Web site. In the following

111
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A\

sections, [ explain the rest of the options available from the Site Definition
dialog box. If you're the only person working on a Web site, you don’t need the
features described in the next three sections.

Using a Testing Server

The Testing Server option enables you to specify a development server, a
necessary step if you are creating a Web site using the Dreamweaver features
with a database. You find more information about how to do this in Chapters
13, 14, and 15. If you're not creating a site using a database or a programming
language (for example PHP or ASP), you don’t need to make any changes to
this dialog box.

Using Check In/Out

The Check In/Out feature is designed to keep people from overwriting each
other’s work when more than one person contributes to the same Web site

(a valuable feature if you want to keep peace on your Web design team). When
a person working on the Web site checks out a file, other developers working
on the site are unable to make changes to that page. When you check out a
file, you see a green check mark next to the filename in the Files panel. If some-
one else checks out a file, you see a red check mark next to the file name.

To use the Check In/Out feature, check the Enable File Check In and Check Out
option at the bottom of the Remote Info dialog box. The dialog box expands to
expose other options. If you want files checked out whenever they are opened,
check the Check Out Files When Opening option (see Figure 4-16).

Keeping the peace with version control

Version control systems enable you to better
manage changes and prevent different team
members from overwriting each other’s work. If
you already use these programs, you'll be glad
to know that you can integrate both Visual
SourceSafe and systems that use the Web
DAV protocol with Dreamweaver. This way, you

can take advantage of the Dreamweaver site-
management features and still protect your
code-development process. If you don’t know
about these programs, visit the Microsoft site
(http://msdn.microsoft.com/ssafe/)
to find out more about Visual SourceSafe.




Figure 4-16:
The Check
In/Out
feature
helps you
keep track
of who is
working on
a page
when more
than one
person is
contributing
to a site.
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Ok ” Cancel |[ Help.

Using this feature, you can track which files a particular person is working
on. But if you want to use this tracking mechanism, check the Check Out Files
When Opening option and then fill in the name you want associated with the
files (presumably your name or nickname if you prefer) in the Check Out
Name field and then include your e-mail address in the Email Address field.
(The Email Address field is needed for Dreamweaver’s integration with e-mail,
which facilitates communication among developers on a site. See the next
section for more information about integrated e-mail.)

Staying in touch with integrated e-mail

Dreamweaver features integrated e-mail as another handy tool for collabora-
tive Web design when you use the Dreamweaver Check In/Out tool (described
in the previous section). In conjunction with the e-mail program you already
use, integrated e-mail gives you easy access to the e-mail addresses of other
members of your team when you need them.

When you work on a site with a team of people, finding that someone else
has already checked out the page you want to work on is common. Until that

Chapter 4: Coordinating Your Design Work ’ ’3
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person checks the file back in, doing the work you need to do to the page is
impossible. In the Dreamweaver Site Definition dialog box, each developer
types his or her e-mail address with the Check In/Check Out feature. Then,
when you find that someone else has the page you need, you can easily fire
off an e-mail telling that person to check it back in so you can work on it,
just by clicking that person’s name in the Files window. (Bribes can be more
effective than threats, especially when you offer chocolate.)

Developers on your team can use the following steps to associate their e-mail
addresses with their version of Dreamweaver as part of the Check In/Check
Out setup:
1. Choose Site=>Manage Sites.
The Manage Sites dialog box opens.
2. Select the site you want to work on and then click the Edit button.
The Site Definition dialog box opens.
3. Click the Advanced tab.
4. In the Category list at the left, choose Remote Info.
The Remote Info page appears (refer to Figure 4-16).
5. Select the Enable File Check In and Check Out check box.
6. Select the Check Out Files When Opening check box.
7. Enter your name in the Check Out Name text box.

Nicknames are okay as long as everyone on the team knows your silly
name.

8. Enter your e-mail address in the Email Address text box.

9. Click OK to save your changes. Click the Done button in the Manage
Sites dialog box.

The Manage Sites dialog box closes.

Using Design Notes

If you sometimes forget the details of your work or neglect to tell your
colleagues important things about the Web site you're all working on,
the Dreamweaver Design Notes feature may save you some grief.

Design Notes are ideal if you want to hide sensitive information from visitors,
such as pricing structures or creative strategies, but make it available to
members of your development team. Information saved as a Design Note in
Dreamweaver can travel with any HTML file or image, even if the file transfers
from one Web site to another or from Fireworks to Dreamweaver.
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Essentially, Design Notes enable you to record information (such as a mes-
sage to another designer on your team) and associate it with a file or folder.
Design Notes work a lot like the comment tag (HTML code that enables you to
embed text in a page that won’t display in a browser) but with a bit more pri-
vacy. Unlike the comment tag, which is embedded directly in the HTML code
of a page (and can be seen if someone views the source code behind a page
on the Web), Design Notes are never visible to your visitors. The only way for
a visitor to view Design Notes is to deliberately type the path to your notes
subdirectory and view the notes files directly. You can even explicitly block
this from being allowed, but only if you have administrative access to your
server. To be even more secure, you can keep the notes on your hard drive
and prevent them from ever being uploaded to your server — though, of
course, your team members won'’t see your witty remarks.

To access the Design Notes page, choose Design Notes in the Category list in
the Site Definition dialog box (see Figure 4-17). The settings on this page
enable you to control how Dreamweaver uses Design Notes:

v+ Maintain Design Notes: Select this option to ensure that the Design Note
remains attached to the file when you upload, copy, or move it.

v~ Upload Design Notes for Sharing: Choose this option to include Design
Notes when you send files to the server via FTP.

v Clean Up: This button enables you to delete Design Notes no longer
associated with files or folders in your site.

When you create graphics in Macromedia Fireworks, you can save a Design
Note for each image file that is also available in Dreamweaver. To use this
integrated feature, create a Design Note in Fireworks and associate it with the
image. Then when you save the Fireworks image to your local Web site folder,
the Design Note goes with it. When you open the file in Dreamweaver, the
Design Note displays when you right-click the image (Control+click on the
Mac). This feature is a great way for graphic designers to communicate with
other members of the Web development team.

To activate the Design Notes feature, follow these steps:

1. Choose Siter>Manage Sites.
The Manage Sites dialog box opens.

2. Select the site you want to work on and then click the Edit button.
The Site Definition dialog box opens.

3. Select the Advanced tab.

4. In the Category list at the left, choose Design Notes.
The Design Notes page appears (refer to Figure 4-17).
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Figure 4-17:
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5. Select the Maintain Design Notes option.

1.

With this option selected, whenever you copy, move, rename, or delete a
file, the associated Design Notes file is also copied, moved, renamed, or
deleted with it.

. If you want your Design Notes to be sent with your files when they are

uploaded to your server, select the Upload Design Notes for Sharing
option.

If you're making notes only to yourself and don’t want them to be associ-
ated with the page when you upload it to the server, deselect this option
and Design Notes is maintained locally but not uploaded with your file.

. Click OK in the Site Definition dialog box; then click the Done button

in the Manage Sites dialog box.

The Manage Sites dialog box closes.

To add Design Notes to a document, follow these steps:

Open the file you want to add a Design Note to and choose File~>
Design Notes.

The Design Notes dialog box opens (see Figure 4-18). You need to have a
file checked out to add or modify a Design Note, but not to read a note.
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Figure 4-18:
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2. Choose the status of the document from the Status drop-down list box.

Your options are Draft, Revision 1, Revision 2, Revision 3, Alpha, Beta,
Final, and Needs Attention. You can choose any status, and you should
set a policy with your design team about what each status means and
how you use these options to manage your development.

3. Type your comments in the Notes text box.

4. Click the Insert Date icon (icon of a calendar page just above the
Notes text box) if you want to insert the current local date.

The current date is inserted automatically.

You can also select the Show When File Is Open check box. If this box is
selected, the Design Notes displays whenever the file is opened so that it
can’t be missed.

5. Click the All Info tab in the Design Notes dialog box.

On the All Info tab, you can add other information that may be useful to
developers of your site. For example, you can name a key designer (in
the Name field) and define the value as the name of that person or the
priority of the project (in the Value field). You also may define a field for
a client or type of file that you commonly use.

6. Click the plus (+) button to add a new information item; click the
minus (-) button to remove a selected item.

7. Click OK to save the notes.

The notes you entered are saved to a subfolder named notes in the same
location as the current file. The filename is the document’s filename, plus
the extension .mno. For example, if the filename is art . htm, the associ-
ated Design Notes file is named art .htm.mno. Design Notes are indicated
in Site View by a small yellow icon that looks like a cartoon bubble.
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Activating Site Map Layout

If you have trouble keeping track of all the files in your Web site and how they
link to one another, you're not alone. As Web sites get larger and larger, this
task becomes increasingly daunting. That’s why Dreamweaver includes a Site
Map Layout feature — to help you keep track of the structure and hierarchy
of your site. This is not a Site Map like those you often see on Web sites that
links to the main pages of a site. The Dreamweaver Site Map Layout is never
visible to your visitors; it’s a site-management feature designed to help you
visually manage the files and folders in your site.

To create a site map from the Site Map Layout page, follow these steps:

1.

Choose Sitec>Manage Sites.
The Manage Sites dialog box opens.

2. Select the name of the site you want to work on.

. Click the Edit button.

The Site Definition box opens.

. Make sure the Advanced tab at the top of the Site Definition dialog

box is selected and the Advanced options are visible.

. Select the Site Map Layout option from the Category list at the left of

the Site Definition dialog box.

The Site Map Layout options display in the right side of the Site
Definition dialog box, as shown in Figure 4-19.

. Click the Browse button (the icon that resembles a file folder) next to

the Home Page text box and browse to find the main folder of your
Web site. Note, if you already filled out the Local Info page for your
site, this field is already filled in.

This text box specifies the location of the home page of the Web site and
the main site folder. This information is essential because it shows
Dreamweaver where the Web site begins and ends.

. Specify the number of columns you want to display per row in the

site map.

If you're not sure what you want for these settings, start with the default
value of 200. You can always come back and change these settings later
if you don’t like the spacing of the icons in your site map.

. In the Column Width text box, set the width of the site map’s columns

in pixels.

Again, start with the default 125 if you're not sure how wide you want
this to display.
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|
Figure 4-19:
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9. In the Icon Labels section, click to put a check mark in the box next to
File Names or Page Titles to specify if you want the filename or the
page title as the label for each page in the site map.

You can manually edit the displayed filename or page title after you gen-
erate the site map.

10. In the Options section, you can choose to hide certain files, meaning
that they won’t be visible in the Site Map window.

If you select the Display Files Marked as Hidden option, files you have
marked as hidden display in italic in the site map.

If you select the Display Dependent Files option, all dependent files in
the site’s hierarchy display. A dependent file is an image or other non-
HTML content that the browser loads when loading the main page.

11. Click OK.
The Site Map is automatically generated.

12. To view the Site Map, open the Files panel on the right side of the
screen and select Map View from the drop-down list in the top-right
corner (see Figure 4-20).

The Site Map displays in the Files panel using icons to represent each
file and link in the site.
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Using the File Uiew Columns option

You can use the File View Columns category in the Site Definition dialog box
(see Figure 4-21) to customize how file and folder options display in the
expanded Files panel. This can be useful for sorting or grouping files in novel
ways, for example, by adding a section, department, season, or version
column. You can customize File View Columns in the following ways:

»* You can add up to 10 new columns by clicking the small plus sign at the
top of the dialog box and entering the name, association, and alignment
of each new column.

v You can reorder or realign the order that columns display in by selecting
the name of the column and then clicking the up or down arrows in the
top right of the dialog to move it up or down the list.

v You can hide any columns except the filename column by selecting the
column name and clicking to remove the check mark in the Show box.
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v You can designate which (if any) columns are shared with other develop-
ers who have access to the site by selecting the column name and click-
ing to remove the check mark in the Enable Column Sharing box.

v You can delete any of the custom columns (you can not delete default
columns) by selecting the column name and clicking on the minus sign
at the top of the dialog box.

v You can rename custom columns as you would edit a filename.

v You can associate Design Notes with custom columns by selecting the
column name and using the drop-down list next to Design Notes.

Enabling Contribute features

Macromedia Contribute is a program that was created so that people who
don’t know much about Web design can easily contribute to a Web site. Think
of Contribute as sort of a Dreamweaver Light, except that it doesn’t work
very well as a stand-alone program. Contribute was designed to work on sites
designed in Dreamweaver, and a number of features have been carefully inte-
grated to make that collaboration work smoothly. If you’re working with other
developers of a site who use Contribute, make sure you check the box next to
Enable Contribute Compatibility in the Contribute category of the Site
Definition dialog box.

Site Definition for Inn on Tomales Bay
Basic | Advanced
Category File: Views Cabumns
Local Info
?::l‘;::; é::@ = [¥] Enable colurn sharing ==
I E:::';:QNMES Mame Typa Show
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F'9ure 4-21: File: v?v Columns Motes Built In Hide
Cortribute Slze Built In Show
YOU can Type Built In Shiowe
MaodiFied Built In Shiowe
Change the Checked Out By Built In Showe
d |Sp|ay inew column Personal Showe
options for
. Column namre:
the Files -
pa nel in th e Assaciake with design nobe:
File View — -
Columns Options: [v] Show
category
available
from
the Site
Definition
dialog box.

Ok ” Cancel |[ Help
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Remembering VYour History

You can keep track of what you're doing and even replay your steps with the
History panel. The History panel also lets you undo one or more steps and
create commands to automate repetitive tasks.

To open the History panel, shown in Figure 4-22, choose Windowr>History. As
soon as you open a file, the History panel starts automatically recording your
actions as you do work in Dreamweaver. You can’t rearrange the order of
steps in the History panel, but you can copy them, replay them, and undo
them. Don’t think of the History panel as an arbitrary collection of com-
mands; think of it as a way to view the steps you've performed, in the order
in which you performed them. This is a great way to let Dreamweaver do
your work for you if you have to repeat the same steps over and over again.
It’s also a lifesaver if you make a major mistake and want to go back one or
more steps in your development work.

Here’s a rundown of how you can put the History panel to use:

v To copy steps you already executed: Use the Copy Steps option as a
quick way to automate steps you want to repeat. You can even select
steps individually, in case you want to replay some (but not all) your
actions exactly as you did them.

v To replay any or all the steps displayed in the History panel: Highlight
the steps you want to replay and click the Replay button in the bottom
of the History panel.

v To undo the results of the replayed steps: Choose Edite>Undo Replay
Steps.

v To apply steps to a specific element on a page: Highlight that element
in the Document window before selecting and replaying the steps. For
example, if you want to apply bold and italic formatting to just a few
words on a page, you can replay the steps that applied bold and italics
to selected text.

|
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Repeating your steps with Recorded Commands

You can automate repeat tasks using Dream-
weaver's Recorded Commands feature, avail-
able from the Commands menu. Simply start the
record option, execute any series of actions in
Dreamweaver, stop, and save them. Then you
just replay the recording to repeat the actions

execute a series of steps that you want to be
able to repeat. When you complete the steps
you want to record, choose Commands=>Stop
Recording and name the command to save it. To
play the actions back, choose Commands=>Play
Recorded Command and select your new com-

mand. Then kick back and watch the action, or
better yet, take a break and get out of your
office for a change.

automatically.

To use the Recorded Commands option, choose
Commands=>Start Recording and then carefully

You can also set the number of steps displayed in the History panel by choos-
ing Edit=>Preferences (Windows) or Dreamweaver=Preferences (Mac) and
selecting General from the Category list on the left. The default is 50 steps,
more than enough for most users. The higher the number, the more memory
the History panel uses.

Using the Quick Tag Editor

If you're one of those developers who likes to work in the Dreamweaver
WYSIWYG editing environment but still wants to look at the HTML tags
once in a while, you’ll love the Quick Tag Editor.

The Quick Tag Editor, as the name implies, lets you quickly access HTML tags
and enables you to modify, add, or remove an HTML tag without opening the
HTML Source window. That means that while you're in the middle of working
on a page in Design view, you can view the HTML tag you are working on
without switching over to Code view. You can use the Quick Tag Editor to
insert HTML, edit an existing tag, or wrap new tags around a selected text
block or other element.

The Quick Tag Editor opens in one of three modes — Edit, Insert, or Wrap —
depending on what you selected on the page before you launched the editor.
Use the keyboard shortcut Ctrl+T (Windows) or 38+T (Macintosh) to change
modes while the Quick Tag Editor is open.

You can enter or edit tags in the Quick Tag Editor just as you would in
Code view, without having to switch back and forth between Code view
and Design view.
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To enter or edit tags in the Quick Tag Editor, follow these steps:

1. With the document you want to edit open, select an element or text
block.

If you want to add new code, simply click anywhere in the file without
selecting text or an element.

&t““’f" 2. Choose Modify=>Quick Tag Editor.

&
You can also press Ctrl+T (Windows) or 8+T (Macintosh).
The Quick Tag Editor opens in the mode that is most appropriate for
your selection, as shown in Figure 4-23. For example, if you click an
image or formatted text, it displays the current tag so that you can edit
it. If you don’t select anything, or if you select unformatted text, the
Quick Tag Editor opens with nothing in it, and you can enter the code
you want to add. Press Ctrl+T (38+T) to switch to another mode.
If you want to edit an existing tag, go to Step 3. If you want to add a new
tag, skip to Step 4.

3. If you selected an element formatted with multiple HTML tags or a tag
with multiple attributes, press Tab to move from one tag, attribute
name, or attribute value to the next. Press Shift+Tab to move back to
the previous one.
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If you aren’t sure about a tag or attribute, pause for a couple of seconds
and a drop-down list appears automatically, offering you a list of all the
tags or attributes available for the element you are editing. If this Hints
list doesn’t appear, choose Edit=>Preferences=>Code Hints (Windows) or
Dreamweaver~Preferences=>Code Hints (Mac) and make sure that the
Enable Code Hints option is selected.

. To add a new tag or attribute, simply type the code into the Quick Tag
Editor.

You can use the Tab and arrow keys to move the cursor where you want
to add code. You can keep the Quick Tag Editor open and continue to
edit and add attribute names and values as long as you like.

. To close the Quick Tag Editor and apply all your changes, press Enter
(Windows) or Return (Mac).
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Chapter 5
Adding Graphics

In This Chapter
Creating images
Using royalty-free images
Choosing a graphics program
Keeping file sizes small
Image editing in Dreamweaver

Using image maps

No matter how great the writing may be on your Web site, the graphics
always get people’s attention first. And the key to making a good first
impression is to use images that look great, download quickly, and are appro-
priate to your Web site.

If you're familiar with using a graphics-editing program to create graphics,
you'’re a step ahead. If not, you find pointers throughout this chapter, and you
discover how to find preexisting graphics to use on your Web site. You also
find out how to bring graphics into Dreamweaver and how to edit them with-
out leaving the Web design environment. To help you get the most out of the
images for your site, you find information about choosing an image-editing
program and keeping image file sizes small.

If your images are ready and you want to dive into placing them on your
pages, jump ahead to the “Inserting Images on Your Pages” section and find
out how to place and align images, create image maps, and set a background
image in Dreamweaver. You also discover some of Dreamweaver’s newest fea-
tures, which enable you to crop images and even adjust contrast and bright-
ness without ever launching an external image-editing program.

Getting Great Graphics

You want your Web graphics to look good, but where do you get them? If you
have some design talent, you can create your own images with Photoshop,
Fireworks, or any other image program (you find descriptions of the most



] 28 Partii: Looking Like a Million (Even on a Budget)

\\3

popular programs in the section “Creating your own images,” later in this
chapter). If you're not an artist, you may be better off gathering images from
clip art collections (libraries of ready-to-use image files) and using royalty-free
or stock photography, as described in this section. If you have a scanner, you
can also scan in existing photographs or logos.

To create textures for backgrounds and buttons on your site, try scanning
fabrics, handmade papers, and other textured objects. You can scan anything
you can put against the glass of your scanner, even medals, coins, and other
things you may have around the house or office. (Just be careful not to
scratch the delicate glass on the scanner.)

Dreamweaver doesn’t have any image-creation capabilities of its own, and
only limited editing tools, so you need to use an image-editing program such
as Photoshop to create or edit images. If you bought Macromedia Studio,
you’re in luck because it includes Fireworks (a great image editor for Web
graphics). No matter what program you use to create and edit your images,
you can set Dreamweaver’s preferences to launch that program when you
choose to edit an image from within Dreamweaver. If you have Macromedia
Studio, the association is automatically set when you install the program. If
you want to use a different image editor, choose Filer>Preferences, choose
the Category File Types/Editors, and use the Browse button to add your soft-
ware program.

Buying royalty-free clip
art and photographs

If you don’t want the hassle of creating your own images (or if you lack the
artistic talent), you may be happy to find many sources of clip art available.
Royalty-free images, which include clip art and photographs, are generally
sold for a one-time fee that grants you all or most of the rights to use the
image. (Read the agreement that comes with any art you purchase to make
sure that you don’t miss any exclusions or exceptions. For example, you may
have to pay extra to use an image for commercial purposes.) You can find a
wide range of CD-ROMs and Web sites full of clip art, photographs, and even
animations that you can use on your Web site. (Speaking of animations, nowa-
days, you can even find Web sites that sell Flash files, animations, buttons,
and other artistic elements that you can edit and integrate into your Web site.
For more info on how to add multimedia to your Web site, see Chapter 12.)
Many professional designers buy clip art images and then alter them in an
image program — such as Macromedia Fireworks, Adobe Illustrator, or Adobe
Photoshop — to tailor them for a specific project or to make the image more
distinct.
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Here are some clip art suppliers:

v Getty Images, Inc. (www.gettyimages.com): Getty Images is the largest
supplier of royalty-free digital imagery on the Web, specializing in pho-
tographs and illustrations of a wide variety of subjects, including film
footage. Pay for images and footage as you go.

1 Stockbyte (www.stockbyte.com): Stockbyte is a great source for inter-
national royalty-free photos. You can purchase photographs in a variety
of qualities, as you need them.

+ Photos.com (www.photos.com): Photos.com is a subscription-based
service for royalty-free stock photography and photo objects. A 1- to
12-month subscription gives you unlimited access and use of its
collection.

v iStockphoto.com (www. istockphoto.com): An innovative variation of
the fee-for-use model, iStockphoto lets you trade your own photographs
for stock images.

v Web Promotion (www.webpromotion.com): A great source for animated
GIFs and other Web graphics. Artwork on this site is free provided you
create a link back to Web Promotion on your Web site, or you can buy
the artwork for a small fee.

+ Fonts.com (www. fonts.com): If you're looking to enhance your font col-
lection, which is a good idea if you want to create distinctive Web graph-
ics with text, you can preview and purchase a huge number of fonts at
Fonts.com. You can search this site by font name or using descriptive
keywords. Keywords help if you need a specific font but don’t know its
name.

Creating your own images

The best way to get original images is to create your own. If you're not graphi-
cally talented or inclined, consider hiring someone who can create images for
you. If you want to create your own images for use in Dreamweaver, Fireworks
is a good program to start with because it’s tightly integrated with Dream-
weaver and has a similar interface.

The last few years have seen a tremendous advancement in the features and
capabilities of specialized Web graphics programs as well as increased compe-
tition between application vendors. In the future, expect even more changes
because two of the biggest competitors — Adobe and Macromedia — are
working on merging into one company and both Fireworks and Photoshop
may change as a result). Most professional designers strongly prefer Adobe
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Photoshop, although [ have to say I've been quite impressed with Photoshop
Elements, which is a “light” version, but offers many of the same features for a
fraction of the cost. (If you're designing images for print, you need Photoshop;
but for the Web, Elements is a surprisingly complete, low-cost alternative.) For
vector-based graphics (a good choice for illustrations), Adobe Illustrator is
the favorite.

The following is a list of the most popular image-editing programs on the
market today. Unless otherwise indicated, all the following image programs
are available for both Mac and Windows:

v Macromedia Fireworks (www.macromedia.com/software/fireworks):
Fireworks was one of the very first image-editing programs designed
specifically to create and edit Web graphics. Fireworks gives you every-
thing you need to create, edit, and output the best-looking Web graphics,
all in one well-designed product. Besides sharing a common interface with
Dreamweaver, Fireworks also integrates extremely well with Dreamweaver
to speed up and simplify the process of building a Web site. In Chapter 11,
you discover some of the special features of Fireworks and Dreamweaver
that help you to work with these two programs.

v Adobe Photoshop (www.adobe .com/products): Adobe calls Photoshop
the “camera of the mind.” This is unquestionably the most popular
image-editing program on the market and a widely used standard among
graphics professionals. With Photoshop, you can create original artwork,
correct color in photographs, retouch photographs, scan images, and do
much more. Photoshop has a wealth of powerful painting and selection
tools in addition to special effects and filters to create images that go
beyond what you can capture on film or create with other illustration
programs. And Photoshop includes everything you need for creating and
editing Web graphics.

v Adobe Photoshop Elements (www.adobe.com/products): If you're not
designing images for print use, and you don’t need all the bells and whis-
tles offered in the full-blown version of Photoshop, Photoshop Elements
is a remarkably powerful program — for about a sixth of the cost of
Photoshop. Elements is especially well suited for Web graphics output
and is easier to learn than Photoshop.

v Adobe Illustrator (www.adobe.com/products): lllustrator is one of the
industry standards for creating vector-based graphics, ideally suited for
illustrations. Adobe integrates all its design programs so you can drag
and drop illustrations that you create in Illustrator right into other Adobe
programs, such as Photoshop or InDesign. lllustrator also comes with an
export feature that enables you to export your illustrations in GIF or JPEG
format with a browser-friendly palette of colors so that your illustrations
look great on the Web.
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v CorelDRAW Essentials (www.corel.com): Another competitor in the
graphics market, CorelDRAW offers features and capabilities similar to
those of Adobe Photoshop for a fraction of the price. The Essentials pack-
age comes with CoreDRAW and Corel PHOTO-PAINT and includes a gener-
ous clip art and royalty-free photography collection. For less than the cost
of Photoshop, you can get the complete Core]DRAW Graphics Suite.

v~ Paint Shop Pro (www.corel.com): Also by Corel, Paint Shop Pro is a full-
featured painting and image-manipulation program available only for
Windows. Paint Shop Pro is similar to Photoshop, but on a more limited
scale because it doesn’t offer the same range of effects, tools, and filters.
However, it costs less than Photoshop and may be a good starter pro-
gram for novice image-makers.

v Macromedia Freehand (www.macromedia.com/software/£freehand):
Macromedia Freehand is an illustration program used widely both on
the Web and in print. Freehand has many excellent Web features, includ-
ing support for Web file formats such as GIF, PNG, and JPEG, as well as
vector formats such as Flash (.SWF) and Shockwave FreeHand (.FHC).
Thirty-day trial versions are available for free on the Macromedia Web
site.

v MicroFrontier Color It! (www.microfrontier.com): This low-cost, easy-
to-use graphics program is available only for the Macintosh and is a
great tool for beginners, as well as those on a tight budget. Although it’s
much more limited than many of the other programs in this list, it pro-
vides enough features to create basic banners and buttons for a small
business Web site. A demo version is available for free from the
MicroFrontier Web site.

Understanding the Basics

of Web Graphics

WMBER
‘Q‘
&

Because having a basic understanding of graphics formats and how they
work on the Web is so important, the following sections give you an overview
of what you need to know about graphics as you create them or place them
on your pages.

The most important thing to keep in mind when placing images on a Web
page is that you want to optimize your images to keep your file sizes as
small as possible. You may ask, “How small is small?” In fact, this is one of
the most common questions people ask about Web graphics. The answer is
largely subjective — remember that the larger your graphics files are, the
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longer people have to wait for them to download before they can see them.
You may have the most beautiful picture of Mount Fuji on the front page of
your Web site, but if it takes forever to download, most people aren’t going
to be patient enough to wait to see it. Also remember that when you build
pages with multiple graphics, you have to consider the cumulative download
time of all the graphics on the page. So smaller is definitely better.

Most Web pros consider anything from about 75K to 150K a good maximum
cumulative size for all the elements on a given page. With the increasing pop-
ularity of DSL and cable modems, many Web sites are starting to become a
bit more graphics-heavy. However, anything over 150K is pushing the limits,
especially if you expect people with dialup modems (56K and under) to stick
around long enough to view your pages.

To make determining the total file size of the images on your page easy,
Dreamweaver includes this information in the status bar of the current
Document window, as shown in Figure 5-1. This number indicates the total
file size of all the images and HTML on your page as well as the expected
download time at a given connection speed. (You can set your own connec-
tion speed by choosing Edit>Preferences=Status Bar~>Connection Speed. On
a Mac, choose Dreamweaver=>Preferencest>Status Bar=>Connection Speed).

Achieving small file sizes requires using compression techniques and color
reduction — tasks that you can achieve using any of the graphics programs
mentioned in the preceding section. Whatever program you use, you should
understand that you can reduce image sizes to varying degrees and that the
challenge is to find the best balance between small file size and good image
quality. If you really want to find out the best ways to create graphics for the
Web, read Web Design For Dummies by Lisa Lopuck (Wiley Publishing, Inc.).
It has a fantastic section on designing Web graphics.

Use GIFs for animations and transparency

GIF is the most widely accepted Web file format
that can have transparent pixels to create a
transparency effect. (The PNG format does
also, but its support is spotty.) GIFs can also
have multiple frames, so you can create small,
animated loops with this format. Animated ads
on the Web, generally referred to as banners,
are sometimes made in GIF.

Designers frequently create a GIF that just con-
sists of words because it allows them to use
nonstandard fonts with perfect anti-aliasing and
whatever colors and effects they want without
worrying about whether the end user has the
font installed. GIF is the ideal format for this
because it offers more control over color com-
pression, whereas JPEG compression can
make the small lines and curves in text fuzzy.
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One of the most common questions about images for the Web concerns when
you use GIF and when you use JPEG. The simple answer:

Use
GIF

JPEG

For

Line art (such as one- or two-color logos), simple drawings,
animations, images with a transparent background, and basi-
cally any image that has no gradients or blends

Colorful, complex images (such as photographs), images con-
taining gradients or color blends, and so on

That said, sometimes the best thing to do is just experiment with both for-
mats and see which yields the best results. In time, you’ll get a knack for
which is the best format to use, depending on the type of image you're
working with.
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Inserting Images on Your Pages

Dreamweaver makes placing images on your Web pages easy.

\\J
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Figure 5-2:
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Before inserting any images into your page, saving your page is important.
After you save, Dreamweaver knows the directory location of the page and
can then properly create the image links.

To place an image on a Web page, follow these steps:

1.

Open an existing page or choose File->New to create a new page.

You can create a basic HTML page or any of the template or other options
available in the New Document dialog box. With the exception of the
dynamic page options (covered in Chapters 13, 14, and 15), the insert
image options work the same no matter what kind of page you create.

. Make sure you save your page before inserting an image by choosing

File->Save and saving it to your main site folder.

. Click the Insert Image icon on the Common Insert bar at the top of the

work area (the icon looks like a small tree) and choose Image from the
drop-down list.

The Select Image Source dialog box appears, as shown in Figure 5-2.
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4. In the Select Image Source dialog box, browse to locate the image you

want to insert.

Alternatively, you can insert images simply by choosing Insert=>Image,
which also brings up the Select Image Source dialog box, or by dragging
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and dropping image files from the Files panel right onto your

BE Dreamweaver document.
QQ,N\ R
& Dreamweaver only lets you insert images in valid Web graphics file for-
mats, such as GIF or JPEG.
5. Double-click the image to insert it or click once and then click OK.
The image automatically appears on your page.
vQ‘\\\NG! When you insert an image file onto a page, you create a link from the page to
& the image, much as you do when you create a link from one page to another.

As a result, if your images and the pages they are linked to are not in the
same relative location on your hard drive as they are on your server, you
break the links and your images do not appear on your pages (instead you
get that ugly broken GIF image). The best way to make sure your images and
files stay where they’'re supposed to in relation to one another is to save
them all in one main site folder and identify that folder using Dreamweaver’s
Site Setup features covered in Chapter 2.

How an image appears on a Web page

The HTML tag that you use to place images on a
Web page is similar to the link tag that you use to
create hyperlinks between pages. Both tags
instruct the browser where to find something. In
the case of the link tag, the path to the linked
page instructs the browser where to find another
URL. In the case of an image tag, the path in the
tag instructs the browser to find a GIF or JPEG
image file. The path describes the location of the
image in relation to the page on which it appears.
For example, images /baby .gif is a path that
instructs a browser to look for an image file
called baby.gif inthe images directory. This
path also implies that the images directory is in
the same directory as the HTML file containing
the link. Whenever you see a forward slash in
HTML, it signifies a directory (or folder) that con-
tains other files or folders.

Trying to determine the path can get a little com-
plicated. Fortunately, Dreamweaver sets the
path for you, but you need to take care of two
important steps before Dreamweaver can do
this properly:

1. Save your page.

When you save a page, Dreamweaver auto-
matically remembers the exact location of
the page in relation to the image. Saving the
file is essential because the path always
indicates the location of an image relative to
the page containing the link (this is called a
relative link). If you forget to save your file
beforehand, Dreamweaver always prompts
you to save the file before completing the
link. If you don't save the file, Dreamweaver
inserts an absolute link that references the
image’s location on your hard drive, but this
linkisn't valid on any other machine or when
you upload your Web site. An absolute link
to your hard drive works on your machine,
but not on your Web server — or any other
machine, for that matter.

2. Define your site and identify your main

Web site folder using the Site Setup fea-
tures covered in Chapter 2.
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Aligning Images on a Page

After you place an image on your Web page, you may want to center or align
it so that text can wrap around it. In the following two sections — “Centering
an image” and “Aligning an image with text wrapping” — you find out the
steps to accomplish both these goals.

Centering an image

To center an image on a page, follow these steps:

1. Click to select the image that you want to center.
The Properties inspector changes to display the image properties.

2. From the icons for alignment options in the Properties inspector,
shown in Figure 5-3, click the Align Center icon.

The image automatically moves to the center of the page.
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Aligning an image with text wrapping

To align an image to the right of a page and wrap text around it on the left,
follow these steps:

1. Insert the image immediately to the left of the first line of the text (see
Figure 5-4).

The easiest way to do this is to place the cursor just before the first
letter of text; then choose Insert=>Image.

Don’t put spaces or line breaks between the image and the text.



|
Figure 5-4:
To wrap text
around an
image, first
place the
image
immediately
to the left of
the text with
no spaces
between the
text and
image.
|

\\3

Chapter 5: Adding Graphics ’3 7

Conwmon ¥

Bl Edt Yiss Irswb Modiy Text Commands

Ste Windos Help

REREEEE-4-BHEEH-@

P Css
it I Bonhcetion

sprS_somerin, ™

|s2] code | <50k | 3] pesgn Thia: |Seudbern Marin. Mar Beesh | [0 g2 I @),

= &

=

ik Tag Inspactor
i % Flles i

Fies

.

LT TN LV TV I L o TP o I

|G

I

a | D Comtal Travdsr % Locd view v

Ferries Cross San Francisco Bay

= Larkspur Lending, Tiburen and Sausalito can be reached by Fequent
Eerryaat service from Fan Francisco. Thers is probably ne more dramabic — yet inexpensie — way of sesing
Zan Francizce and the Golden Gate Brdge then by ferry. & one-way top bebwsen San Francisce and either
Sausalite or Larkspur Landing, for exampls, costs 86,15, Children ages s2c to 12 pay only $4.50 Children
9 five and wndder are fee when accompanied by 2n achilt The fare te Tiburon iz 37.25 for achlis and children
ages Gve to 11 pay 84.00.
<bodys chiccioucte s <p imgs L35+

Q[0

v |775 x 459« ZK /G sec

G|

oG

]

w

¥ Properties
A Imags, I3 W
c
! H 7R4
Man |
k| DD

src | goben-gam-bedgeng £ Ak

i 1)

Gokden Gate Bidge w

@ONEBO A

Cles | Hone ~

Eci:
Border
Sy Men

| Tereet
| Lo 5ic |

¥ Space

Hipace G Defauk

(;s;
£

SRS ESREULSELSEEYRELEeLEOEE Y

et _bne htel
srlH jrerress hisl
spete_matindist bem
et _marshall bt
w4 _ewie bl
SpeTH_miema. il
el peyes il
sorld_strsan him|
et _binbo el
sprlfs irerress. hiwl
sprlS_marinlst bt
et _marshll kel
srlf5_alema,himl
SpriE_pirees. Al
LTS _scomarin. vl
w0 _sbrsan him|
sz bl
P irerress htsl
rdd_rarinlEl.bml
seon_marstomd L bim
e alema.himl
s _poinkrayes.him
e _seman vl
e _strsan.him|
S _boba, il
AUmLL_inverness. hm
sumC0_marrkst himl
aumin_marshal fbel
sumi_mur b=l
sunC0_ricasiou bl
amen_plema, b

-

W

2. Click to select the image.

The Properties inspector changes to display the image attribute options.

3. In the Properties inspector, choose Right from the Align drop-down

list.

The image aligns to the right and the text automatically wraps around it,

as shown in Figure 5-5.

To align the image to the left of the page with text wrapping around on the
left, follow Steps 1 and 2, and then in Step 3, choose Left from the Align drop-

down list instead of Right.

To prevent text from running up against an image, click the image, find V and H
spacing on the Properties inspector, and enter the amount of space you want
(the space is measured in pixels). Five to ten pixels is usually enough to add

space around the image and prevent the text from bumping up against its edge.
If you want to add space to only one side of an image, it’s a bit more work, but
you can more precisely control spacing with CSS (covered in Chapter 8). You
can also use an image-editing program to add a transparent border to the edge
of a GIF or add a few pixels that match the background to a JPEG.
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Creating complex designs with images

The alignment options available in HTML enable you to align your images
vertically or horizontally, but you can’t do both at once. Also, the alignment
options don’t really enable you to position images in relation to one another
or in relation to text with much precision. For example, if you try to center an
image that is positioned up against a text block, the text gets centered, too.
One way to get around this limitation is to create HTML tables and then com-
bine and merge cells in the table to control positioning. See Chapter 6 to find
out how you can make table borders invisible and use them to create com-
plex layouts. You can also use layers (Chapter 9) and Cascading Style Sheets
to position elements on a page (Chapter 8).

Image Editing in Dreamweaver

New features in Dreamweaver enable you to do minor image editing inside
Dreamweaver without opening Fireworks or any other graphics-editing pro-
gram. These tools are available from the Properties inspector when an image
is selected (see Figure 5-6).
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You also find two buttons that enable you to use Macromedia Fireworks to
edit images. The Edit button launches Fireworks and opens the selected image
in the main window of the program, which makes using all the Fireworks edit-
ing features easy. Macromedia’s careful integration of these programs means
that when you save changes to the image in Fireworks, they are reflected in
the page in Dreamweaver. A new button, just to the right of the Edit button, is
designed to make optimizing an image fast and easy, which makes download-
ing faster. Chapter 10 covers both the Edit and Optimize in Fireworks features
in greater detail.

|
Figure 5-6: Brightness and Contrast
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Before you get carried away editing your images, remember that Dreamweaver
is primarily a Web-page creation application and not really designed to edit
graphics. Although these tools can be useful, they shouldn’t take the place of
doing serious work on your graphics in an actual graphics application, such as
Fireworks or Photoshop.

“&N\BER When you do use the tools for cropping, adjusting brightness and contrast,

> and sharpening an image, beware that you are changing the actual image (not
just a copy of it). Make sure you're happy with these changes before you save
the page you're working on. You can use the undo feature in Dreamweaver to
revert back several steps, but after you save the page, you can’t undo changes
to an image. To protect your original image, considering saving a copy before
editing it.

Cropping an image

Essentially, cropping an image is trimming it. To crop a graphic or photo,
follow these steps:

1. In the Document window, select the image you’d like to crop by click-
ing it.

The Properties inspector changes to display the image’s properties.
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2.

From the Edit icons, click the Crop tool.
A dialog box appears warning you that cropping changes the original
image.

Don’t make the change if you’re concerned about needing to keep the
entire image available. If you're concerned, the best thing to do may be
to make a copy of the image and apply your cropping to the copy.

. Click OK.

A dotted line with handlebars appears in the image.

. Outline the area of the image you want to keep with the handlebars.

Any part of the image that is darkened, as shown in Figure 5-7, is deleted
when the crop completes.

. Double-click inside the box, or press Enter (Return on a Mac).

The image is cropped.

You can undo cropping by choosing Edit=>Undo, but remember that, after you

save

e
B Edt

Conwmon ¥

the page, changes permanently apply to the image and cannot be undone.
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Adjusting brightness and contrast

Adjusting an image’s brightness allows you to change the overall amount of
light in an image. Contrast controls the difference between the light and dark
areas of an image. To adjust brightness and contrast, follow these steps:

1.

In the Document window, select the image you want to alter.

The Properties inspector shows the image properties.

. From the Edit tools, click the Brightness and Contrast icon (a circle

with light and dark halves).

A dialog box appears, indicating that changes you make are made to the
original file.

. Click OK.

The Brightness/Contrast dialog box appears.

. Adjust the brightness and contrast settings of the image with the

sliders.

Make sure to select the Preview check box if you want to see how the
changes affect the image as you move the sliders around.

. Click OK.

The settings take effect permanently when you save the page.

Sharpening an image

When you apply sharpening to an image, you increase the distinction
between areas of color. The effect can be one of increased definition to the
shapes and lines in an image. To sharpen an image, follow these steps:

1.

In the Document window, select the image you want to sharpen.

The Properties inspector shows the image properties.

. From the Edit tools, click the Sharpen icon (a blue cone).

A dialog box appears, indicating that your change is made to the original
file.

. Click OK.

The Sharpen dialog box appears.

. Adjust the sharpness of the image with the slider.

Make sure you select the Preview check box if you want to see how the
changes affect the image as you move the slider.
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5. Click OK.

The image is sharpened and changes are made permanently when you
save changes to the page.

Using the Transparent GIF Trick

\\J

You may find it strange that I suggest you place an invisible image on a Web
page, but that’s exactly what [ show you how to do in this section. A small,
transparent GIF is a powerful element in Web page design because you can
use it to control the exact position of other elements on a page. You'll notice
that some other programs, such as Fireworks, also utilize transparent GIFs to
force page elements into place more precisely. In Fireworks, transparent GIFs
are automatically generated, and you can often recognize them because they
use names such as transparent.gif, clear.gif, or spacer.gif.
Regardless of the name, they all perform the same function.

To create your own transparent GIF, simply create a new document in any
image editor with the background set to Transparent. Then don’t add any-
thing to the image before saving it as a GIF with the Transparent option
selected. The result is an image that is invisible, but very useful for spacing
purposes.

If you don’t want to create your own transparent GIF or you just want to prac-
tice the following steps, you can download a free transparent GIF from my
Web site at www.DigitalFamily.com/free (just look at the bottom of the
page for the image that doesn’t appear to be there, but is displayed under
the Transparent GIFs headline and outlined so you can find it).

Some Web designers recommend that you create a single-pixel graphic for this
purpose, but I find that a 10 x 10-pixel image works best because it’s easier to
select after you place it on your page in Dreamweaver. Remember, even if the
clear GIF is 10 x 10 pixels, you change the height and width to any size because
HTML enables you to specify any height and width for an image regardless of
its actual size. Thus, you can alter the image attributes for height and width to
adjust your transparent GIF to be larger or smaller depending on how much
space you want between other visible elements on your page.

Dreamweaver makes using the transparent GIF trick easy because you have
easy access to the height and width attributes in the Properties inspector.
You may also need to specify the alignment of the image to achieve the
desired effect.
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To use a transparent GIF between images, text, or other elements on a page,
follow these steps:

1. Click to insert your cursor wherever you want the transparent GIF
on your page — between two images or within a block of text, for
example.

2. Choose File~Insert and browse to select your transparent GIF.
3. Click OK.
The transparent GIF is inserted on your page and automatically selected.

4. With your transparent GIF still selected, alter the height and width
(the H and W fields in the Properties inspector) until it is the size of
the space you want to create.

The transparent GIF automatically adjusts to the height and width
specified.

When you select a transparent GIF you can see the outline of the image while
it’s selected. Notice that as soon as you deselect the image, it becomes invisi-
ble in Dreamweaver. You can always reselect it by clicking in the area until the
cursor highlights it. Just beware that selecting it can be tricky because it’s not
visible, especially if you make it very small. For this reason, [ recommend
resizing the GIF as soon as you place it on the page while it’s still highlighted.

Creating a Background

\\3
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Background images can bring life to a Web page by adding color and fullness.
Used cleverly, a background image helps create the illusion that the entire
page is one large image while still downloading quickly and efficiently. The
trick is to use a small background image that creates a dramatic effect when
it tiles (repeats) across and down the page (see Figure 5-8).

Background images are often called files, because they repeat like tiles across
a kitchen floor. However, if you use a long, narrow image as a background or a
large image that’s small in file size, you can create many effects beyond a
repeating tile.

Beware that certain backgrounds (such as the one shown in Figure 5-9) can
make reading text that’s placed on top of them hard. Choose your back-
ground images carefully and make sure your background and your text has
plenty of contrast — reading on a computer screen is hard enough.
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As you work with backgrounds, you may find another use for a transparent
GIF. If you place a graphic on top of a patterned background, you end up with
a rectangular area around the graphic that obscures the patterned back-
ground, as shown in Figure 5-10. To allow the background to be visible
around, say, a headline, you can create your headline graphic on top of a
color similar to the dominant color used in the background. When you save
the GIF, set that color to be transparent. Placed on the page, the headline
looks as if it’s floating on top of the pattern (see Figure 5-11).

You may find that you need to change the color of text to make it stand out
better against a background. Notice that in Figure 5-10 the black text looks
good against the white background of the GIF, but after | made the GIF trans-
parent, [ saw that white text was easier to read against the dark green back-
ground pattern and changed the text color accordingly.

To insert a background image on a Web page, follow these steps:

1. Choose Modify-~>Page Properties.
The Page Properties dialog box appears, as shown in Figure 5-12.

2. Click Appearance from the Category list on the left.
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3. Click the Browse button to the right of the Background Image
text box.

The Select Image Source dialog box opens.

4. Browse to find the image that you want to use as your background
image.



Chapter 5: Adding Graphics ’4 7

When you insert an image in your Web site, you want to make sure that
the image is in the same relative location on your hard drive as it is on
your server. If you plan to use your background tile throughout your
site, you may want to store it in a common images folder where you can
easily link to the image from any page in your site. See Chapter 3 for
details on organizing image files.

5. Double-click the filename of your background image to select it.
The Select Image Source dialog box disappears.
6. Click OK in the Page Properties dialog box to finish.

Note that if you click the Apply button, you see the effect of the back-
ground tile being applied to the page, but the Page Properties dialog box
stays open.
P If you don’t want a background image to tile, choose the No-Repeat option
from the Repeat drop-down list in the Page Properties dialog box and the
image appears only in the top-right of the document.

Creating Image Maps

Image maps are popular on the Web because they enable you to create hot
spots in an image and link them to different URLs. A common use of an image
map is a geographic map, such as a map of the United States, that links to dif-
ferent locations, depending on the section of the map selected. For example,
if you have a national bank and want customers to find a local branch or ATM
machine easily, you can create hot spots on an image map of the United
States and then link each hot spot to a page listing banks in that geographic
location. Dreamweaver makes creating image maps easy by providing a set of
simple drawing tools that enable you to create hot spots and set their corre-
sponding links.

To create an image map, follow these steps:

1. Place the image you want to use as an image map on your page.
2. Select the image.
The image properties display in the Properties inspector.

3. To draw your hot spot, choose a shape tool from the Image Map tools
in the lower-left of the Properties inspector (see Figure 5-13).
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The shape tools include a rectangle, a circle, and an irregular polygon
that allow you to draw regions on your images, called hot spots, each

with a specific link.

4. With the shape tool selected, click and drag over an area of the image
that you want to make hot (link to another page). Here’s how the dif-

ferent hot spot tools work:

¢ Rectangle: As you click and drag, a light blue highlight appears
around the region that you’re making hot; this highlighted area
indicates the active region. If you need to reposition the hot area,
select the Pointer Hotspot Tool (black arrow) from the lower-left
corner of the Properties inspector and then select and move the
region to the location you want. You can also resize it by clicking

and dragging any of the corners.

¢ Circle: The circle tool works much like the rectangle tool — just
click and drag. To resize a circle hot spot, select the Pointer
Hotspot Tool, and click and drag one of the small square boxes

on its edges.

¢ Polygon: The polygon tool functions a little bit differently; to make
a polygon selection (such as one of the state of California in a U.S.
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map), you click the tool once for each point of the polygon shape
you want to draw. The shape automatically connects the points as
you click. When you’re done, switch to another map tool or click
outside the image. You can change the size of the polygon or move
any of its points by using the Pointer Hotspot Tool.

5. To link a selected hot area, click the Folder icon next to the Link text
box (at the top of the Properties inspector).

The Select File dialog box opens.

6. Browse to find the HTML file that you want to link to the hot spot on
your image.

7. Double-click the file to which you want to link.

The hot spot links to the selected page and the Select File dialog box
automatically closes. You can also type the path directly in the Link text
box if you know it, so you don’t have to find it on your hard drive.

8. To add more hot spots, choose an image and a shape tool, and repeat
Steps 4 through 7.

9. To give your image map a name, type a name in the Map text field,
just above the shape tools.

Giving your map (and all the hot spots it includes) a name helps to dis-
tinguish it in the event that you have multiple image maps on the same
page. You can call the map anything you want, with the exception that
you can’t include spaces or special punctuation.

When you finish, you see all your image map hot spots indicated by a
light blue highlight.

At any time, you can go back and edit the image map by clicking and high-
lighting the blue region on your image and dragging the edges to resize the
hot spot or by entering a new URL to change the link.
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In this part . . .

T) create the most advanced designs in HTML, you
need to use tables, frames, Cascading Style Sheets
(CSS), or layers. This part introduces you to all of these
design options and helps you decide which features offer
the best options for your Web site. If you choose tables,
Chapter 6 walks you through the steps to create tables for
data and design. It also covers nested tables, merged
cells, and so much more. Chapter 7 covers how to divide a
page with frames, when this option is warranted, and how
to target links so your pages work as you intend. In
Chapter 8, you discover the power and design control that
can only be achieved with CSS. As CSS becomes increas-
ingly well supported on the Web, designers are taking the
leap and enjoying the rewards. In version Dreamweaver 8,
Macromedia has worked hard to give you the best tools to
use these advanced design features.




Chapter 6
Coming to the HTML Table

In This Chapter
Introducing HTML tables
Going beyond spreadsheets

Customizing table structure

Creating complex designs

M any people find the limitations of basic HTML frustrating. Professional
designers get especially annoyed when they discover that they don’t

have the design control they’re used to in print — they can’t align elements

as precisely as they want, can’t layer images so they overlap, or can’t adjust

the line spacing in text.

Although more recent developments in CSS and layers provide far better
design control than the early days of HTML, you still can’t do everything you
can do in print. Worse yet, you risk losing some of your audience when you
use the latest CSS and layer options because, as you discover in the sidebar
“Choosing between tables and layers,” not everyone on the Internet uses the
latest browser.

For this reason, HTML tables have long been the most common way to work
around these limitations because using tables make it possible to create com-
plex designs without sacrificing audience. That’s changing as more and more
people are equipped with browsers that can handle CSS and layers, but today
many people still use tables to do Web-page design.

This chapter helps you appreciate how tables work for layout and what you
can do with them that you can’t do with basic HTML formatting. If you have
ever used a desktop publishing program, such as QuarkXPress or Adobe
InDesign, you have probably used text and image boxes to lay out pages.
Layers work almost exactly like text boxes in a page-design program — tables
achieve a similar effect, but with a little more effort. With tables, you place
images and text in table cells and, by merging and splitting cells, you can
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create almost any page design you could want. For example, you can use a
table to align two columns of text side by side with a headline across the top
like the format you might see in a newspaper. Because you can make the bor-
ders of a table invisible, you can prevent the table itself from displaying. You
still don’t get the design control you're used to in a desktop publishing pro-
gram, but with a little ingenuity, you can create complex page designs despite
the limitations.

This chapter is designed to show you how to create HTML tables for every-
thing from columnar data to complex page designs. Tables are a bit compli-
cated to create and not as precise as you might like them to be, but Dream-
weaver has a number of tools that make creating tables easier.

Creating Tables in Layout Mode

Tables are made up of three basic elements: rows, columns, and cells. If you
have ever worked with a spreadsheet program, you're probably familiar with
what tables are all about. Tables in HTML differ from spreadsheet tables mainly
in that they’re used for more complex alignment of data, which requires lots of
merging and splitting cells. Back in the days when you had to design Web pages
in raw HTML code by hand, even simple tables were difficult to create. The
code behind an HTML table is a complex series of <TR> and <TD> tags that
indicate table rows and table data cells. Figuring out how to type those tags
so that they create a series of little boxes on a Web page was never an intu-
itive process. If you wanted to merge or split cells to create rows or columns
with varying amount of cells, you faced a truly complex challenge.

Thank the cybergods that you have Dreamweaver to make this process easy.
Using Dreamweaver, you can modify both the appearance and the structure
of a table by simply clicking and dragging its edges. You can add any type of
content to a cell, such as images, text, and multimedia files — even a smaller
table. Using the Properties inspector, you can easily merge and split cells,
add color to the background or border, and change the vertical and horizon-
tal alignment of elements within a cell. And, you can easily alter your table if
you change your mind about how you want the table to look after you have
built it.

The easiest way to work with tables in Dreamweaver is to switch to Layout
mode and use the special Layout Cell and Layout Table tools described in the
following steps. With these tools, available only in Layout mode, Dreamweaver
makes table creation much more intuitive. You can even switch between the
two modes, Standard and Layout, to take advantage of all Dreamweaver’s
table features.
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Layout mode provides a special view of your page elements designed to
assist in the construction and editing of tables. In this mode, you can draw
cells anywhere on a page and then drag the edges of a table to change its
size. Figures 6-1 and 6-2 show the same table in Layout mode and Standard
mode. You can tell the difference in modes by the way the table displays in
Dreamweaver or by checking the Layout Mode and Standard Mode icons on
the Layout Insert bar at the top of the work area.

Choosing between tables and layers

More and more pages on the Web are designed
with layers, and you can expect to see that
trend continue. As Internet users upgrade their
browsers and newer browsers support layers
better and better, their advantages are quickly
outweighing the limitations.

Layers are much easier to control than tables,
especially in Dreamweaver where you can
simply click and drag to place them wherever you
want on a page. You can put any element in a
layer, including images, text, and multimedia files.
You can even stack layers on top of each other,
and you get down-to-the-pixel design control,
which is far better than what you get with tables.

So why doesn’t everyone use layers? Because
if your visitors use older browsers (Netscape or
Internet Explorer 4.0 and earlier) layers won't
display in their browsers, meaning any text or
images you place in a layer do not appear as
you intended. Even newer browsers aren't
always consistent about how they display
layers, so some of your visitors may have unpre-
dictable results, such as elements where you
didn’t intend them or misalignment of text and
images. Thus, what you gain in design control
with layers, you may lose twice over for some-
one using an old browser. For this reason, some
designers still prefer tables, and they continue
to be an important design tool on the Web.

Ultimately, you have to base your decision on
whether to use layers or tables on what you know
about your audience. Depending on your server,
you may be able to check the log statistics and

see what versions of browsers your visitors use
(your service provider or system administrator
may be able to give you this information). On
many major sites, less than 3 percent of visitors
are still using browser versions older than 4.0; but
your audience may be different, and you have to
decide what percentage of visitors you're willing
to give up to gain the advantage of using layers.

If your goal is to have decent design control and
the most universally recognized Web pages,
tables are your safest option. If your goal is to
design the most advanced site possible, then
you should move on to CSS and layers, covered
in Chapters 8 and 9. If you want the best of both
worlds, design a page that uses both layers and
tables to achieve the greatest design control yet
still have a page that degrades gracefully for
older browsers.

You have one other option in Dreamweaver. You
can create your page design using layers and
then use Dreamweaver's automated Layers to
Tables conversion option to create a second set
of pages with tables. Then you can add a behav-
ior (also covered in Chapter 9) to your site that
determines what browser version each of your
visitors is using and directs each one to the
appropriate page. This is a pretty cool trick, but
you should know that the conversion process is
not a perfect science (because you can do
things with layers that you can’t do with tables),
and you add a lot more work to your site devel-
opment and maintenance.
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These steps show how to create a table in Layout mode with a long cell
across the top and two smaller cells below it (like the table shown in Figures
6-1 and 6-2):

1. Create a new HTML page (or open an existing page).

To create a new page, choose Filem>New and then select Blank Page from
the Category list and HTML from the Basic Page list.

. Switch to Layout mode by choosing Viewr>Table Mode~>Layout Mode.

The Table layout options become visible on the Layout Insert bar at the
top of the screen, as shown in Figures 6-1 and 6-2.

You can also switch to Layout mode using the Layout Insert bar, avail-
able from the Insert bar drop-down list at the top of the screen.

When you switch to Layout mode, you may see a message describing
how to use the Layout Table and Layout Cell buttons when you first
select this option. The message has some useful tips, but if you click the
Don’t Show Me This Message Again check box, you can avoid seeing it
the next time. Click OK to close it.

. Click the Draw Layout Cell button, located on the Layout Insert bar.

The cursor changes to a crosshair when you move the mouse over the
document area, indicating that you're ready to draw a table cell.

. With the mouse pointer on the document, click and drag to draw a

rectangular shape anywhere on the page for your first table cell (see
Figure 6-3).

The cell is drawn, and its surrounding table structure is automatically
generated. A grid representing the table structure and other table cells
appears.

. Draw another cell anywhere on the page by clicking the same Draw

Layout Cell button again and then clicking and dragging to create the
new cell.

Again, other cells are automatically generated to position the new cell
where you have drawn it. You can draw as many new cells as you want.

To continue drawing cells without having to go back each time and re-
select the Draw Layout Cell tool, press the Ctrl key (88 on Mac) while
you draw cells to retain the tool.

. Click to select any of the cells on the page and enter text, an image, or

any other element.

You can enter anything in a table cell that you can enter on a Web page.

157



158

Part lll: Advancing Your Site

|
Figure 6-3:
When you
use Layout
mode to
draw a table
cell, such as
the cell
highlighted
in this
figure, the
table
structure
and
additional
cells are
auto-
matically
generated
around it.
|

WMBER
\Q—
&

2 Macromadia Dreanweaver B - [Untithed-4 (XHTMLY*] ﬂ[ﬂ]ﬁl
B Edt Yiew Irsrt Modiy Text Commands Ste Widow Heb
e B | Sendwd | Exparded | Lapr 5] | = 5 o oar [@- E
Uniitlec-4* - 9%
|12 code | sk 5] Design | T [Untived Dogamen, e MG o E 3
Layout mode [exit]
L PO T N O Y TV VO T O O O N N - O < O 1 O - P
I
e
|
& i, i
: IIG1Y
I
[bod;r. chable> <bra [<hd W |79 O [100% v 995 ddlv 1K {1e
¥ Properties Y
B Lagaut cel width (SFied 149 | echt 120 Horz oot [w| Mamrsp ] Clss Hane v @
O Autostratch ag [ wart | Top |
o

7. Click to select the border of any cell and drag to move it to a new
location. To resize a cell, click one of the small boxes at the corners or
middle of each table side and drag to enlarge or reduce the cell.

Depending on where you started drawing table cells, Dreamweaver may
create table cells around the cells you created to maintain their posi-
tions on the page. For example, in the table shown in Figure 6-3,
although I have one new cell, Dreamweaver fills in the gaps by automati-
cally creating more cells.

A table’s default position is the upper-left corner of a page, so in order to
maintain the position of the cell I drew, Dreamweaver had to create addi-
tional cells to the top and left of the cell.

HTML doesn’t allow you to place things anywhere on a page unless you
use table cells (or layers) to control their placement. Empty cells that
Dreamweaver creates to fill space in a table merely act as spacer cells
and don’t display in the browser as long as the table border is set to 0.
In this way, a table creates the illusion that page elements can be posi-
tioned independently on any part of the page.
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P Designers often wonder how wide to make a table. My best advice is to
design your pages for an 800 x 600 screen resolution because that’s the most
common size in use on the Web (believe it or not, a lot of people still have
only 15-inch monitors). If you're creating a table that you want to cover the
entire display area, a safe bet is to make your table 740 to 760 pixels wide and
center it in the middle of the page. That leaves a little room on each side to
prevent sideways scrollbars from appearing.

Editing Tables in Layout Mode

One wonderful advantage of working with tables in Layout mode is that you
can use the layout grid to edit, move, and resize any of the rows, columns,
and cells in the table. This capability enables you to use the grid as a true
design guide for creating any kind of layout you want.

Tables are much easier to edit in Layout mode because you can click and
drag to create cells wherever you want on the page and Dreamweaver auto-
matically fills in the rest of the table needed to position the cells for you. That
means you don’t have to manually create spacer cells or do lots of merging or
splitting to get cells where you want them on a page. This feature is still not
as precise as layers, but it comes close.

You also have the flexibility to create nested tables (tables drawn within
tables) for even more control over your layout. To create a nested table,
simply click the Draw Layout Table button (available on the Layout Insert bar
at the top of the work area) and begin drawing a new table inside an existing
table cell. For more information on nested tables, see the section “Using
nested tables: Tables within tables,” later in this chapter.

A third option for table editing is Expanded Table
mode. To access this view, choose Viewr>Table
Mode=>Expanded Tables Mode. This view makes
selecting inside and around tables easier (with-
out this option, it can be tricky to select specific

Using Expanded Table mode to select sells

cells within a table, especially if you're not really
adept with your mouse). If you're in a hurry or
working on lots of cells, this view makes it a lot
easier to select and adjust table elements.
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Layout mode works best for creating and editing the overall structure of your
table. When you're ready to start editing the contents of the table and its indi-
vidual cells, you may prefer Standard mode because the Properties inspector
provides more editing options in this mode. Using Layout mode, you can
change some table attributes, but by using Standard mode, you can change
all HTML table attributes, including the number of rows and columns as well
as height, width, border size, and spacing.

When you select a table or cell, the attributes display in the Properties inspec-
tor, at the bottom of the work area. Click the border of any table to select it,
and the Properties inspector displays the table options shown in Figure 6-4.
To view all the options, click the expander arrow in the lower-right corner of
the Properties inspector.

If you're having trouble selecting the table (sometimes selecting the entire
table and not just an individual cell is tricky), simply place your cursor any-
where inside the table and choose Modify~>Tabler>Select Table.
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The Properties inspector gives you access to the following table options for
customizing the appearance of your table:

v~ Table Id: Provides a text area where you can enter a name or table.

v Rows: Displays the number of rows in the table. You can alter the size
of the table by changing the number. Be careful, though: If you enter a
smaller number, Dreamweaver deletes the bottom rows — contents
and all.
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v Columns: Displays the number of columns in the table. You can alter
the size of the table by changing the number. Again, if you enter a
smaller number, Dreamweaver deletes the columns on the right side
of the table — contents and all.

v W (Width): Displays the width of the table. You can alter the width by
changing the number. You can specify the width as a percentage or a
value in pixels. Values expressed as a percentage increase or decrease
the table’s size relative to the size of the user’s browser window.

v H (Height): Displays the height of the table. You can alter the height by
changing the number. You can specify the height as a percentage or a
value in pixels. Values expressed as a percentage increase or decrease
the table’s size relative to the size of the user’s browser window. This
table attribute is recognized only by version 4.0 browsers and above.

Table dimensions expressed as a percentage enable you to create a table
that changes in size as the browser window is resized. For example, if
you want a table to always take up 75 percent of the browser window, no
matter how big the user’s monitor or display area, set the size as a per-
centage. If you want a table to always be the same size — that is, to
remain the same size regardless of the browser window size — choose
pixels rather than percentages for your table dimensions.

v CellPad: Specifies the space between the contents of a cell and its
border.

v CellSpace: Specifies the space between table cells.

v~ Align: Controls the alignment of the table. Options are left, right, and
center.

1 Border: Controls the size of the border around the table. The larger the
number, the thicker the border. If you want the border to be invisible,
set the border to 0.

v Class: Provides easy access to style sheet options. (See Chapter 9 for
more on CSS.)

v Clear and Convert: The icons in the lower-left area of the Properties
inspector (click the expander arrow in the lower-right corner to view
them) provide these formatting options:

¢ Clear Row Heights and Clear Column Widths enable you to
remove all height and width values at one time.

¢ Convert Table Heights to Pixels and Convert Table Heights to
Percents, and Convert Table Widths to Pixels and Convert Table
Widths to Percents enable you to automatically change Height and
Width settings from percentages to pixels. Pixels specify a fixed
width; a percent setting means the browser automatically adjusts
the specified percentage of the browser display area.
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+~ Bg Color: Controls the background color. Click the color square next to
this label to open the color palette. Click to select a color from the box
or click the color wheel at the top-right corner to choose any color. Also
note that when you click the color square, the cursor changes to an eye-
dropper, enabling you to pick up a color by clicking anywhere on the
page. You can apply this option to a single cell by placing your cursor in
a particular cell before specifying the color or to the entire table by
selecting the table.

v Bg Image: Enables you to select a background image. Specify the file-
name or click the folder icon to locate the image. You can apply this
option to a single cell or to the entire table. Note that because many
older browsers don’t support background images in single cells, the
image may not display for all viewers.

v Brdr Color: Controls the border color of the entire table. Click the color
square next to this label and select a color from the box that appears, or
use the color wheel at the top-right corner to choose any color. Also
note that when you click the color square, the cursor changes to an eye-
dropper, enabling you to pick up a color by clicking anywhere on the

page.
“\Q,N\BER You can also apply formatting options and change the attributes of any ele-
& ments, such as text, images, and multimedia files, that you have placed

within a table cell. To do so, click to select the element and then use the
options in the Properties inspector to make any desired changes, just as you
would if the element were not in a table cell.

Merging and splitting table cells

Sometimes, the easiest way to modify the number of cells in a table is to
merge cells (combine two or more cells into one) or split cells (split one cell
into two or more rows or columns). Using this technique, you can vary the
space in table sections and customize their structures. For example, you may
want a long cell space across the top of your table for a banner and then mul-
tiple cells underneath it so that you can control the spacing between columns
of text or images. The following two sets of steps show you how to merge and
CMBER split cells in a table.

You can merge and split cells only in Standard mode.
To merge cells, create a new HTML page and follow these steps:

1. Choose Insert->Table and create a table with four rows and four
columns, a 75 percent width, and a border of 1. Skip header and
accessibility. Click OK, and the table appears on the page.

2. Highlight two or more adjacent cells by clicking and dragging the
mouse from the first cell to the last.
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You can merge only cells that are adjacent to one another and in the
same row or column.

3. Click the Merge Selected Cells icon in the lower-left region of the
Properties inspector to merge the selected cells into a single cell.

The cells are merged into a single cell by using the Colspan or Rowspan
attributes. These HTML attributes make a single cell merge with adja-
cent cells by spanning extra rows or columns in the table.

To split a cell, follow these steps:

1. Click to place the cursor inside the cell you want to split.

2. Click the Split Selected Cell icon in the lower-left region of the
Properties inspector.

The Split Cell dialog box appears.

3. Select Rows or Columns in the dialog box, depending on how you
want to divide the cell.

You can split a cell into however many new rows or columns you want.
4. Type the number of rows or columns you want to create.

The selected cell is split into the number of rows or columns you entered.

Controlling cell options

In addition to changing table options, you can control options for individual
cells within a table. When you select a cell, which you do by clicking the
cursor anywhere inside the cell area, the Properties inspector changes to dis-
play the individual properties for that cell (see Figure 6-5). The Properties
inspector is where you find the controls to merge and split cells, as well as to
change the alignment of the contents of a particular cell.

Make sure the table fits the contents

Be aware that table cells automatically adjust
to accommodate whatever you insert into them.
For example, if you create a cell that is 100
pixels wide and then insert a 300-pixel-wide
image, the table cell has to adjust to fit the
image. This can cause problems if the overall
size of the table is not set large enough to
accommodate all the objects within the table

cells. As you build your tables, be aware of the
size of the images and multimedia files you are
inserting into cells or you may have unpre-
dictable results. For example, if you set a table
to a total width of 400 pixels and then insert 600
pixels worth of images, the table may not dis-
play the same in all browsers.
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You can also change multiple cells at the same time. For example, suppose
that you want to have some, but not all, the cells in your table take on a cer-
tain color background and style of text. You can apply the same properties to
multiple cells by selecting more than one cell at a time. To select adjacent
cells, press the Shift key while clicking to select cells. To select multiple cells
that are not adjacent, press the Ctrl key (the 8 key on the Mac) and click
each cell you want to select. Any properties you change in the Properties
inspector apply to all selected cells.

If you're having trouble selecting an individual cell because it contains an
image, click the image and then use either the « or — key on your keyboard
to move the cursor and deselect the image, which activates the Properties
inspector and displays the options for that cell.

When one or more cells are selected (they have to be adjacent for this to
work), the top half of the Properties inspector controls the formatting of text
and URLs within the table cells. The lower half of the Properties inspector
provides these table cell attribute options (refer to Figure 6-5):

v Merge Cells: Merges two or more cells. To merge cells, you must first
select two or more cells by clicking and dragging or by pressing either
the Shift or Ctrl key while selecting multiple cells.

v~ Split Cells: Splits one cell into two. When you select this option, a dialog
box lets you specify whether you want to split the row (you split the cell
horizontally) or the column (you split the cell vertically). You can then
specify the number of columns or rows, which controls how many times
the cell divides. Note that you can apply the Split Cell option to only one
cell at a time.
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v Horz: Controls the horizontal alignment of the cell contents.
v Vert: Controls the vertical alignment of the cell contents.

1 W: Controls the width of the cell.

v H: Controls the height of the cell.

v No Wrap: Prevents word wrapping within the cell. The cell widens to
accommodate all text as you type or paste it into a cell. (Normally, the
excess text just moves down to the next line and increases the height
of the cell.)

1 Header: Formats a cell’s contents by using a Header style, which makes
the text bold and centered by default.

+ Bg (Image): Allows you to specify a background image for the cell.
+* Bg (Color): Allows you to specify a background color for the cell.
v Brdr (Color): Allows you to change the border color of the cell.

Formatting tables with color schemes

One of the best reasons for using tables is to present lots of data in a clear
and structured way. Tables accomplish this task because the use of rows and
columns allows the reader to follow along easily when lots of data is repre-
sented. One way to make your data even more presentable and attractive is
to colorize the rows and columns in the table. In the preceding section, you
find out how to change the attributes of individual cells. This section explains
how to use the Format Table feature to select predefined table formats with
color schemes designed to enhance your presentation. Professional design-
ers created these color schemes, so you can be sure that they look good on
your Web page.

To use the Format Table feature, open an existing document or create a new
HTML page, insert a simple table of any size, and follow these steps:
1. Select an existing table in the document.

2. Make sure that you’re in Standard mode. (Choose View~ Table Moder>
Standard Mode.)

3. Choose Commands=>Format Table.
The Format Table dialog box appears, as shown in Figure 6-6.

4. Select one of the schemes by scrolling the list or modify any of the
parameters to create your own scheme.

5. Click OK.

The color scheme applies to the table.
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You can also modify any of the attributes in the Format Table dialog box to
create your own color schemes.

Using low-contrast color schemes in tables is considered the most effective
way to present content. (Just look at the Intuit Quicken software, E-Trade,
and Amazon for examples of real-life illustrations.) High-contrast colors in
tables are usually reserved for site menus and submenus or other elements
you want to call more attention to.

Formatting multiple columans in a table

When you’re working with lots of cells in a table, you may want to format
multiple cells in the same way. Dreamweaver makes that task easy, whether
you want to align numbers, make the headings bold, or change the color
scheme. But before you start planning how to line up all your numbers per-
fectly, be aware that you don’t have as much control in HTML as you have in
a program such as Excel, where you can align numbers to the decimal point.
You can, however, align the content of columns to the left, right, or center.
Thus, if you use the same number of digits after the decimal point in all your
numbers, you can get them to line up. For example, if one price is $12.99 and
another is $14, express it as $14.00; then, when you right-align, the numbers
line up properly. (If your columns are still not lining up the way you want
them to, consider using a monospace font, which lines up better.)
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The steps in this section explain how to create a table in Standard mode and
align all the data cells to the right so that the numbers or other content align
consistently. You can also use these steps to align the contents of table cells
to the left or center and to apply other formatting options, such as bold or
italic. In these steps, I insert the data into the table after I create the table in
Dreamweaver.

If you want to import data from a table you have created in a program

such as Word or Excel, see the section, “Importing Table Data from Other
Programs,” later in this chapter. If you're working with a table that already
has data in it and just want to format or align the cells, go directly to Step 7.

If you're starting from scratch, create a new, blank HTML page and follow
these steps from the beginning:

1. Make sure that you’re in Standard mode. (Choose Viewr>Table Moder>
Standard Mode.)
2. Click to place the cursor where you want to create a table.

In Standard mode, tables are automatically created in the top, left area
of the page, unless you insert them after other content. If you want a
columnar table somewhere else on the page, consider creating a table
in Layout mode as described earlier in the chapter and then inserting
a nested table inside a cell for your columnar data.

3. Click the Insert Table icon on the Insert bar.

Alternatively, you can choose Insert>Table. The Insert Table dialog box
appears.

4. In the appropriate boxes, type the number of columns and rows you
want to include in your table.

Remember you can always add or remove cells later using the Properties
inspector.

5. Specify the width, border, cell padding, and cell spacing; then click OK.
The table automatically appears on the page.

6. Click to place the cursor in a cell, and then type the data you want in
that cell. Repeat for each cell.

Alternatively, you can use Editz>Paste Special to insert columnar data
from another program, such as Excel.

7. Select the column or row for which you want to change the alignment.

Place the cursor in the first cell in the column or row you want to align;
then click and drag your mouse to highlight the other columns or rows
that you want to change.
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Figure 6-7:
You can
access
many
formatting
options by
selecting an
element,
suchasa
table, and
then right-
clicking
(Windows)
or Ctrl+
clicking
(Mac).

8. Right-click (Windows) or Ctrl+click (Mac) in any cell in the highlighted
column or row.

A pop-up menu appears, as shown in Figure 6-7. Alternatively, you can
use the Properties inspector to change selected items.

9. From the pop-up menu, choose Align and then choose Left, Center,
Right, or Justify from the submenu.

This option enables you to change the alignment of all highlighted cells
in the column or row at one time. If you’re working with financial data,
choose Align>Right, which produces the best alignment for numbers.
You can also apply other formatting options, such as bold or italic, to
selected cells and their contents by choosing the option from the pop-
up menu or the Properties inspector.

If you want to format one cell in a column or row differently from the others,
click to place the cursor in just that cell and then click one of the formatting
options in the Properties inspector. You can also choose to align multiple
cells that aren’t contiguous (they don’t touch each other) by pressing and
holding the Ctrl key in Windows while you click the cells you want to select.
On the Mac, you press and hold the Command key (38) while you click to
select particular cells. Any options you change on the pop-up menu or in the
Table Properties inspector apply to all selected cells.
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Sorting Table Data

When you’re working with lots of columnar data, you want to be able to sort
that data, just as you do in a spreadsheet program, such as Excel. In this
newest version of Dreamweaver, you can now sort data even after it’s format-
ted in HTML (something you couldn’t easily do before). You still don’t have
as many options as you do in Excel. For example, you can’t sort different
rows individually, but you can sort an entire table based on any row you
specify.

To use the Sort Table Data feature, create a new, blank HTML page, add a
table with several rows and columns, and add some content (I explain how
in the preceding section). You may also open an existing page with a table
of columnar data. Then, follow these steps:
1. Select the table you want to sort.
Place the cursor in any cell of the table you want to sort.

2. Make sure that you're in Standard mode. (Choose View=>Table Mode~>
Standard Mode.)

3. Choose Commands=>Sort Table.

The Sort Table dialog box appears, as shown in Figure 6-8.

|
Figure 6-8:
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4. Specify which column you want to sort by; then, choose Alphabetically
or Numerically, and Ascending or Descending.

You can set up one or two sorts to happen simultaneously and opt
whether to include the first row and whether to keep the TR (Table Row)
attributes with a sorted row.

5. Click OK.

The selected cells are sorted, just like they are in a program such as
Microsoft Excel. (Pretty cool, huh?)

Importing Table Data from
Other Programs

Manually converting financial data or other spreadsheet information can be
tedious. Fortunately, Dreamweaver includes a special feature that enables you
to insert table data created in other applications, such as Microsoft Word or
Excel. To use this feature, the table data must be saved from the other program
in a delimited format, which means that the columns of data are separated by
either tabs, commas, colons, semicolons, or another type of delimiter. Most
spreadsheet and database applications, as well as Microsoft Word, enable you
to save data in a delimited format, often called CSV because that’s the file
extension they’re given. Consult the documentation for the application you're
using to find out how. After the data is saved in a delimited format, you can
import it into Dreamweaver.

To import table data into Dreamweaver after it has been saved in a delimited
format in its native application, create a new, blank HTML page and follow
these steps:

1. Choose Filez>Import-=>Tabular Data or choose Insert>Table Objects~>
Import Tabular Data.

The Import Tabular Data dialog box appears (see Figure 6-9).

2. In the Import Tabular Data text box, type the name of the file you
want to import or use the Browse button to locate the file.

3. From the Delimiter drop-down list, select the delimiter format you
used when you saved your file in the other application.

The delimiter options are Tab, Comma, Semicolon, Colon, and Other. You
should have made this choice when you exported the data from the orig-
inal program in which you created it, such as Excel. If you don’t remem-
ber what you chose, you can always go back and do it again. You must
select the correct option in order for your data to import correctly.
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Figure 6-9:
You can
import
tabular data
into Dream-
weaver
from other
programs,
such as
Excel.
|

Import Tabular Data
Data file: | expenses.ds Browse. .. III
Deimiter: | Tab [

Table width: ) Fit to data [ ter |
O setea

Cell padding: 5 Format bop row: | [Mo Formatting] “

Cel spacing: | 5 Border: 1

. Select the table width.

If you choose Fit to Data, Dreamweaver automatically creates the table
to fit the data being imported. If you choose Set, you must specify a per-
cent or pixel size.

. Specify the cell padding and cell spacing only if you want extra space

around the data in the table to be created.

. Choose an option from the Format Top Row option only if you want to

format the data in the top row of the table.

Your options are bold, italic, or bold italic.

. Specify the border size.

The default is 1, which puts a small border around the table. Choose 0 if
you don’t want the border to be visible. Choose a larger number if you
want a thicker border.

8. Click OK to automatically create a table with the imported data.

Dreamweaver also enables you to export data from a table into a delimited
format. This capability is useful if you want to export data from a Web page
so that you can import it into another program, such as Word or Excel, or
into a database program, such as FileMaker or Access. To export data from
Dreamweaver, place the cursor anywhere in the table and choose Filew>
Exporte>Table. In the Export Table dialog box, choose from the options on
the Delimiter drop-down list (you can choose Tab, Space, Comma, Semicolon,
or Colon). From the Line Breaks drop-down list, specify the operating system
(you can choose Windows, Mac, or Unix).

Using Tables for Spacing and Alignment

As you get more adept at creating Web pages, you may find that HTML tables
are a crucial part of creating almost any design that requires more than basic
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alignment of elements on a page. Using tables, you can get around many of
the limitations of basic HTML and accomplish some of these design feats:

v Evenly spaced graphical bullets (little GIF files that can take the place of
bullets) next to text

v~ Text boxes and fields properly aligned in a form

v Images placed wherever you want them on a page

v Columns of text that don’t span an entire page

v Myriad intricate layouts that are impossible to accomplish without using

tables or layers (for more on layers, see Chapter 9)

In the rest of this chapter, [ show you how to use tables to create a variety of
page designs, including a few of the ones I just listed.

When you use a table for design control, turn off the border so that it’s not
visible in the design. You do that by typing 0 (zero) in the Border text box in
the Properties inspector with the table selected.

Using tables to design forms

Creating text boxes and drop-down lists for HTML forms is easy in Dream-
weaver, but if you want all the fields to line up well, you may want to use
tables to help with the formatting. In Chapter 12, you find step-by-step
instructions for creating a variety of forms; for now, [ assume that you have
already created a form and want to align the text boxes evenly. | use a simple
form with just a few questions as an example, but you can use this technique
to align any form elements.

To use a table to align form elements, such as text boxes, evenly on your
page, follow these steps:

1. Open a page that has an HTML form on it (or create a new HTML
form).
See Chapter 13 to find out how to create HTML forms.

2. Click to place the cursor where you want to start formatting your
form.

3. Choose Insert>Table.
The Insert Table dialog box appears.
4. Type the number of columns and rows you want in your table.

I set the table to three rows and two columns.
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Figure 6-10:
When the
form fields
in the table
display in
the browser,
they line up
evenly; with
the border
setto 0 you
can't even
tell it's
there.
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5. Set the width to whatever is most appropriate for your design and

click OK.

Remember, up to 760 pixels is a good width if you are designing for an
800 by 600 screen resolution, which many designers consider the best

size to reach the most users.
6. Enter 0 for the border.

When you set the border to 0, the edges of your table change from solid
lines to dotted lines so that you can still see where the borders are while
you’re working in Dreamweaver. When you view the page in a browser,

as shown in Figure 6-10, the border of the table is invisible.

7. Click OK.

The table automatically appears on the page.

8. You need to copy the data from your form into the table. Using the Cut
and Paste commands from the Edit menu, cut the text preceding the
form’s first text field and paste it into the cell in the upper-left corner

of the table.

Alternatively, you can select the text and then click and drag it into each

table cell.

In my example in Figure 6-11, I cut the words Who are you? and pasted

them into the first table cell.

27 Wha are you? - Microsoft Internet Explorer
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9. Select the first text field (the empty box where users type their
responses) and copy and paste (or click and drag) the field into the
desired cell of the table.

10. Repeat Steps 8 and 9 until you have moved all form elements into
table cells.

11. Click the vertical column divider line between the first and second
columns and drag it to the left or right to create the alignment you
want for your form.

Aligning a navigation bar

A common element on Web pages is a navigation bar, a row of images or text
with links to the main sections of a Web site. Navigation bars are usually
placed at the top, bottom, or side of a page, where users can easily access
them but where they’re out of the way of the main content of the page.
Designers sometimes use HTML frames (see Chapter 7) to insert a navigation
bar, but most prefer using tables or layers (covered in Chapter 9).
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Vertical alignment solves common problem

If you're having trouble getting the contents of
adjacent cells to line up with each other, setting
Vertical alignment to Top may solve your prob-
lem. A common frustration when you're building
tables is that you have two or more rows side by
side with text in one and images in the another
and you want the top of the image and the top of
the text to line up. Often they don‘t because they
are different lengths, and the table is trying to

adjust the contents to best use the space within
their respective cells. The solution is simple:
Select all the cells you want to align, and in the
Properties inspector, change Vertical alignment
to Top. Seemingly like magic, all the content
jumps right to the top of the cells and lines up
perfectly. This is such a common problem, | rou-
tinely set the Vertical alignment of table cells to
Top.

In the last example in the preceding section, you see how to create a table in
Standard mode by using the regular table tools. In this section, you discover
how to use Layout mode to build a table, similar to the way you do at the
beginning of this chapter. You can use either mode for creating the table fea-
tured in this section, but I find Layout mode is easier to use because you can
simply drag cells into place instead of having to calculate where to merge and
split cells to create such a complex design. To use Layout mode to create a
table that positions a navigation bar across the top of a Web page, like the
one featured in Figure 6-12, follow these steps:

1. Switch to Layout mode by choosing Layout from the drop-down list on
the Insert bar and clicking the Layout icon, or choose Viewr>Table
Mode~>Layout Mode.

The table layout options become visible on the Layout Insert bar.

2. Select the Draw Layout Table button from the Layout Insert bar, and
create a table by clicking in the upper-left region of the display area
and dragging to fill the entire page.

3. Click the Draw Layout Cell button on the Layout Insert bar to select
the tool for drawing table cells.

Visualizing how you want your table to look is helpful before you start
drawing cells in the next step. The structure is dictated by the shape
and size of your navigation bar and other elements that need to be on
the page. (Figure 6-12 shows an example of a common design with the
navigation bar across the top of the page, just below a banner with the
site’s logo.)

4. Click and drag your mouse on the page to draw the size and shape of
each of the cells you need to contain your navigation bar and other
page elements.

Figure 6-12 shows a page that was created using multiple tables. Notice
that the table that holds the navigation elements includes a separate cell
for each graphic in the navigation row.

175



176

Part lll: Advancing Your Site

A\

Figure 6-12:
Layout
mode
makes it
easy to build
a table that
you can use
to create
almost any
page
design.
|

To continue drawing cells without having to go back each time and re-
select the Draw Layout Cell tool, press the Ctrl key (88 on Mac) to retain
the tool while you draw cells.

5. When you’re done creating all the cells you want in the table, click

the Standard Mode icon on the Layout Insert bar to return to
Standard mode.

6. Click to place the cursor in the table cell in which you want to insert

a navigation bar image and choose Insert=>Image. Use the Browse
button to locate the image you want to insert into the table cell.

7. Double-click the filename of the image.

The image automatically appears in the table cell. Repeat this step to
insert multiple images.

As you can see in Figure 6-12, you can insert a series of images to create
a row of buttons that runs across the top of the page. Similarly, you can
create a table to hold images that run down the right or left side of a
page. You can also use text in place of images by simply entering the text
you want in each of the table cells.

8. Select the table and make sure that the Border option is set to 0 in the

Properties inspector.

This step makes your table invisible so that the border doesn’t display
in a browser.
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Using nested tables: Tables within tables

Placing tables within tables, called nested tables, can help you create extremely
complex designs. You create nested tables by inserting a table within a cell of
another table. In the days when you had to write your own code, this task was
daunting. Dreamweaver now makes nesting tables easy, enabling you to create
complex designs without ever looking at the HTML code.

The best Web designs communicate the information to your audience in the
most elegant and understandable way and are easy to download. To make
sure that your designs don’t get too messy, remember these guidelines:

v~ A table within a table within a table is nested three levels deep. Anything
more than that gets hairy.

v Pages that use nested tables take longer to download because browsers
have to interpret each table individually before rendering the page. For
some designs, the slightly longer download time is worth it, but in most
cases you're better off adding or merging cells in one table, as [ explain
in the section “Merging and splitting table cells,” earlier in this chapter.
One situation that makes a nested table worth the added download time
is when you want to place a table of financial or other data in the midst
of a complex page design.

To place a table inside another table, follow these steps:

1. Click to place the cursor where you want to create the first table.
2. Choose Insert=>Table.

The Insert Table dialog box appears.
3. Type the number of columns and rows you need for your design.

4. Set the Width option to whatever is appropriate for your design and
click OK.

The table is automatically sized to the width you set.

5. Click to place the cursor in the cell in which you want to place the
second table.

6. Repeat Steps 2 through 4, specifying the number of columns and rows
you want and the width of the table.

The new table appears inside the cell of the first table.

7. Type the information that you want in the nested table cells as you
would enter content in any other table.
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Chapter 7
Framing Your Pages

In This Chapter
Introducing HTML frames
Creating frame pages
Knowing when not to use frames
Setting targets and links

No one wants to be “framed,” whether that means being falsely accused
of something you didn’t do or trapped in the HTML frameset of a Web
site with no escape. Appreciating not only the best way to create frames, but
also the best way to use them to enhance site navigation is important if you
don’t want to leave your visitors feeling stuck in your pages.

Many experienced Web designers say you should never use frames. I take a
more open approach — [ don’t recommend frames, but I think you should
decide for yourself. Besides, I can think of a few instances when frames come
in quite handy, such as when you want to bring in content from another Web
site and still maintain your own navigation and logo. Of course, you should
do this only with permission from the other site (see the sidebar later in this
chapter, “Resist using frames when you link to other people’s Web sites”).

To help you make the most of this HTML design feature, this chapter not only
covers how to build HTML framesets in Dreamweaver, but also discusses
when frames are most useful and when you should avoid them. Frames add a
wide range of design possibilities, but they can also create confusing naviga-
tion systems and can be very frustrating to viewers. As you go through this
chapter, consider not only how to create frames, but also whether they are
really the best solution for your Web site project.

Appreciating HTML Frames

Frames add innovative navigation control because they enable you to display
multiple HTML pages in one browser window and control the contents of
each framed area individually. Web developers commonly use frames to
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Figure 7-1:
This
Southwest
Scenes
Web site
uses frames
to keep
navigation
buttons on
the left and
the banner
at the

top, while
changing
the content
in the main
part of the
page.

create a design with two or more sections within one browser window. Each
section consists of a different HTML page, and you can place links in one sec-
tion that, when selected, display information in another page in a different
section within the same browser window.

Web pages that use frames, such as the one shown in Figure 7-1, are split into
separate sections — or individual frames. All the frames together make up a
frameset. Behind the scenes, each frame of the frameset is a separate HTML
file, which makes a page with frames a little complicated to create, even with
Dreamweaver. If you choose to create your frame files in a text editor, you
have to juggle multiple pages, working on each frame one at a time, and you
can see what you create only when you preview your work in a browser. The
visual editor in Dreamweaver makes creating frames a lot easier because you
can view all the HTML files that make up the frameset at the same time and
can edit them while they display in the way in which they appear in a
browser.

As a navigational feature, frames enable you to keep some information
constant, while changing other information in the same browser window.
For example, you can keep a list of links visible in one frame and display
the information each link brings up in another frame, as the site shown in
Figure 7-1 does.
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You can create as many frames as you want within a browser window.
Unfortunately, some people overuse them and create designs that are so
complex and broken up that they’re neither aesthetically appealing nor easily
navigable. Putting too many frames on one page can also make a site hard to
read because the individual windows are too small. This has led many Web
surfers to passionately hate frames. And some sites that rushed to implement
frames when they were first introduced have since either abandoned frames
or minimized their use.

Here’s a list of guidelines to follow when using frames:

v Don’t use frames just for the sake of using frames. If you have a com-
pelling reason to use frames, then create an elegant and easy-to-follow
frameset. But don’t do it just because Dreamweaver makes creating
them relatively easy.

v~ Limit the use of frames and keep files small. Remember that each
frame you create represents another HTML file. Thus, a frameset with
three frames requires a browser to fetch and display four Web pages,
and that may dramatically increase download time.

v Turn off frame borders. Browsers that support frames also support the
capability to turn off the border that divides frames in a frameset. If you
turn the borders off, your pages look cleaner. Frame borders, shown in
Figure 7-1, are thick and an ugly gray in color, and they can break up a
nice design. You can change the color in the Properties inspector, but
[ still recommend that you only use them when you feel that they're
absolutely necessary. [ show you how to turn off frame borders in the
“Changing Frame Properties” section toward the end of this chapter.

v Don’t use frames when you can use CSS or tables instead. Tables are
easier to create than frames and provide a more elegant solution to your
design needs because they’re less intrusive to the design. I include lots
of information on creating tables in Chapter 6, and you find coverage of
CSS — an increasingly popular design option — in Chapter 8.

v Don’t place frames within frames. The windows get too darned small
to be useful for much of anything, and the screen looks horribly compli-
cated. You can also run into problems when your framed site links to
another site that’s displayed in your frameset. The sidebar “Resist using
frames when you link to other people’s Web sites” later in this chapter
provides many more reasons to limit using frames inside of frames.

v~ Put in alternate <NOFRAMES> content. The number of users surfing the
Web with browsers that don’t support frames becomes smaller every
day. Still, showing them something other than a blank page is a good
idea. I usually put in a line that says, “This site uses frames and requires
a frames-capable browser to view.” <NOFRAMES> content can also be
read by search engines, which may otherwise fail to catalog the content
within framed pages.
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Understanding How Frames Work

Frames are a bit complicated, but Dreamweaver helps make the whole process
somewhat easier. When you create a Web page with frames in Dreamweaver,
you need to remember that each frame area is a separate HTML file, and
Dreamweaver saves each frame area as a separate page. You also want to keep
track of which file displays in which of the frames so that you can aim links

properly.

Figure 7-2 shows a simple frameset example with three frames, each contain-
ing a different HTML page and different text (Page 1, Page 2, and Page 3) so
that I can clearly refer to them in the following numbered steps.

In addition to the files that display in each frame, you need to create a separate
HTML file to generate the frameset. This page doesn’t have a <BODY> tag, but

it describes the frames and instructs the browser how and where to display
them. This gets a little complicated, but don’t worry: Dreamweaver creates the
frameset HTML file for you. I just want to give you a general understanding of
all the files that you're creating so that the following steps make more sense.

To help you understand how this works, take a look at the example in Figure
7-2. In this document, you see three frames, each displaying a different HTML
page. The fourth HTML file that makes up the frame page contains the other
frames but doesn’t show up in the browser. This file is the frameset file, and it
describes how the frames display, whether they are on the left or the right
side of the page, the top or bottom, and how large they are. The frameset file
also contains other information, such as the name of each frame, which is
used to specify which frame a link opens into or targets. You find out more
about linking frames in the “Setting Targets and Links in Frames” section later
in this chapter.

Creating a frame in Dreamweaver

When you create a frame page in Dreamweaver, realizing that the file you are
starting with is the frameset file is important — the file doesn’t show up in
the browser but merely instructs the browser how to display the rest of the
frames and which pages to use as content for each frame. When you edit

the content of any of the frames in the frameset, you do not actually edit the
frameset file, but the files that populate the framed regions within the frame-
set. Normally you have to edit the files separately, but Dreamweaver makes
designing with frames easier by letting you edit the content of each frame in
the context of the frameset as it looks in a browser. If you can grasp this con-
cept, you've come a long way toward understanding how frames work and
how to use Dreamweaver to create and edit them. If it hasn’t sunk in yet,
read on and it will.
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Creating a frame by using the Split Frame command

You can create frames in two ways in Dreamweaver. The first way is achieved
by splitting a single HTML file into two sections, which then become individ-
ual frames. When you do that, Dreamweaver automatically generates an unti-
tled page with the <FRAMESET> tag and then additional untitled pages display
in each of the frames within the frameset. Suddenly, you're managing several
pages, not just one. This concept is important to understand because you
have to save and name each of these pages as a separate file, even though
Dreamweaver makes you think you’re working on only one page that’s broken
into sections.

‘x&N\BER Always save your HTML files first before inserting anything into them; how-
& ever, the opposite is true when you work with frame files in Dreamweaver.
Wait until after you create all the frames in your frameset and then save them
one at a time; otherwise, tracking your files gets a bit too complicated and
confusing. [ explain more in the section, “Saving files in a frameset,” later in
this chapter; but first, you create a simple framed page.

To create a simple frameset in Dreamweaver, such as the one shown in
Figure 7-2, follow these steps:

1. Choose Filec>New.

The New Document window opens, as shown in Figure 7-3.
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2. Choose Framesets from the Category list, and then select the Fixed
Top, Nested Left option from the Framesets list.

3. Click the Create button.
The frameset automatically appears.

4. Click and drag any of the bars dividing the frames to adjust the size of
the frame area.

5. To edit each section of the frameset, click inside the frame that you
want to work on and edit it like any other HTML page.

Remember, always save your files before setting links or inserting
images and other files.

You can type text, insert images, create tables, and add any other fea-
tures just as you do to any other page.

To save your files, continue with the instructions in the section “Saving
files in a frameset,” later in this chapter.

Creating a frame by using the Frames icon on the Layout Insert bar

Another way to create frames is with the Frames icon (which has a drop-down
list), shown at the top of Figure 7-4. The Layout Insert bar (available by select-
ing Layout Bar from the drop-down list at the top of the work area) includes
the Frames icon, which displays several predefined frames sets from a drop-
down list. You can create a frameset in Dreamweaver simply by selecting any
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of these options from the Frames drop-down list. Figure 7-4 shows the Layout
Insert bar with the Frames icon selected and an option applied to a new docu-
ment from the drop-down list.

To create a framed page using the Frames icon on the Layout Insert bar,
follow these steps:
1. Choose File=>Newr>Basic Page to create a new page.

2. From the Layout Insert bar, click the Frames icon and select the
design that most closely approximates the type of frameset you want
to build from the drop-down list (refer to Figure 7-4).

Don’t worry if it isn’t exactly the design you want; you can alter it later.
3. Modify the frameset as needed.

You can further modify your frameset by clicking and dragging the bor-
ders of the frames to resize them.

You can also split frames by choosing Modify=>Frameset and then choos-
ing to split the frame left, right, up, or down.

To save your files, continue with the instructions in the next section “Saving
files in a frameset.”
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Saving files in a frameset

As I mention earlier, you shouldn’t save your frameset file until after you add
all your frames; otherwise, keeping track of your files gets very complicated.
Remember, frames in HTML consist of at least two HTML files, even if it
appears as if you are only working on one file.

When you are ready to save, Dreamweaver gives you multiple save options
for saving all the files. You can either save everything all at once, or you can
save each frame and frameset individually. The example in the previous sec-
tion, “Creating a frame in Dreamweaver,” is composed of four separate HTML
files, and each needs to be named and saved to your hard drive. To save all
the files in the frames document you create, follow these steps:

1. Choose File~>Save All.

The Save As dialog box appears, asking you to name the file and
designate a folder to save it in. This is the first of several Save As dialog
boxes you see (how many depends on how many frames your document
contains).

2. Enter a name for the file.

Dreamweaver suggests a name, but you can choose your own. The first
file you save represents the frameset file (the file that holds all the other
frames in place). You can tell this by looking at the Dreamweaver Docu-
ment window behind the Save As dialog box: The entire document has a
thick dotted highlight around it representing the frameset.

3. Browse your hard drive to locate the desired folder for the HTML files
and click the Save button.

The first frameset file saves, and a new Save As dialog box appears for the
next one. For each frameset file, you need a distinct name. I like names
such as framel.html, frame2.html, or leftframe.html, rightframe.
html. It doesn’t matter too much, but such names can help you distin-
guish the frame files later. After you save all the frames, the Save As dialog
box disappears.

Carefully name the files that you save in a way that helps you keep them
in order and know which is which. Notice that as you are prompted to
save each file, Dreamweaver indicates which frame area it is by high-
lighting it with a dark border on-screen behind the dialog box. You may
find your task easier by choosing filenames that make sense and that
help you to identify which area they represent.

After you save and name your documents the first time, choosing Save All
saves any and all the files in your frameset without prompting you separately
for each frame. Choosing Save All is a good way to make sure that all the
pages in your frameset save whenever you edit a frames-based document.
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Resist using frames when you link
to other people’'s Web sites

| understand that most people don‘t want to lose
viewers to another site when they create a link,
but that's the nature of the Web. If your site is
designed well, you shouldn’t have to worry
about losing people. Instead, you should show
them around your informative site and then
politely help guide them to other resources they
may find of interest — and let them go. If you
link to another site and target that link within
your frames, you keep users captive and usu-
ally leave them annoyed with you for taking up
valuable browser space and making it harder to
navigate the site they've followed your link to
visit. By displaying content from other sites
within one or more of the frames in your site,
you risk doing yourself far more harm than good.

If you insist on using frames when you link to
another site, do so discretely by placing a small,
narrow frame across the bottom of the screen or

the left sidle — not a wide band across the top,
and certainly not more than one frame that still
contains information from your site. Not only is
this rude and ugly, but some people have been
sued by sites who charged that using frames
when they linked misled visitors into thinking the
content belonged to them when it didn't.

Another reason not to use frames when you link
to someone else’s site is that other sites use
frames, too. If you link a site that uses frames
into a site that uses frames, you quickly create
a mess of frames within frames that makes nav-
igation confusing at best. Not everyone knows
you can get out of frames by right-clicking a link
in Windows or clicking and holding a link on a
Mac and choosing Open Frame in Separate
Window. Now that you know this trick, at least
you can get out of a framed situation if you ever
find yourself trapped in one.

A\

Sometimes, you may not want to save all the files at once. To save an individ-

ual frame displayed in a frameset without saving all the other frames, place
your cursor in any of the frames and choose File=>Save Frame just as you

save any other individual page. Dreamweaver saves only the file for the frame

in which your cursor is located.

To save only the page that defines the frameset, make sure the entire frame-

set is selected (you can do this by clicking in the upper-most left corner
of the Workspace), and then choose Filer>Save Frameset. If you have not
selected the entire frameset, the Save Frameset option doesn’t appear on
the File menu. Remember: This page doesn’t display in any of the frames;

it simply defines the entire display area, specifying which of the other pages

displays in each frame, as well as the position and size of the frames.

As you continue to work on your frame page, remember that whenever you

187

make a change in one of the content frames, you edit content in a different file
from the one you started with (the frameset file). You may get confused as to
which file you need to save when working in this manner. Don’t worry — this
is what confuses a lot of people about using frames in Dreamweaver. When
you edit the content in one of the frames, make sure that your cursor is still
in that frame when you choose File>Save Frame so that you save the page
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that corresponds to the frame you are working on. To be safe, you can always
choose File>Save All Frames in order to save all changes to all files in the
frameset, including the frameset file itself. The Save All command is also
useful when you make changes to several of the frames and want to save all
the changes with just one command.

Setting Targets and Links in Frames

One of the best features of frames is that you can change the contents of
each frame separately within the Web browser. This feature opens a wide
range of design possibilities that improves navigation for your site. One very
common way to use a frameset is to create a frame that displays a list of links
to various pages of your site and then opens those links into another frame
on the same page. This technique makes keeping a list of links constantly vis-
ible possible and makes navigation a lot simpler and more intuitive.

Setting links from a file in one frame so that the pages they link to open in
another frame is like linking from one page to another, and that’s essentially
what you’re doing. What makes linking within a frameset distinctive is that,
in addition to indicating which page you want to open with the link, you
have to specify which frame section it fargets (opens into).

But before you can set those links, you need to do a few things: First, you
need to create some other pages that you can link to (if you haven’t done so
already). Creating new pages is easy. Choose Filew>’New >)HTML Page to create
additional pages and then save them individually. If your pages already exist,
you’re more than halfway there; it’s just a matter of linking to those pages.

The other thing you have to do before you can set links is to name each
frame so that you can specify where the linked file loads. If you don’t, the
page just replaces the frameset altogether when someone clicks the link,
and this defeats the purpose of using frames in the first place.

Naming frames

Naming a frame is different from naming the file that the frame represents.
You find out how to name the files in the previous section “Saving files in a
frameset;” you do that just as you name any other file you save. The frame
name is like a nickname that allows you to distinguish your frames from one
another on a page and refer to them individually — this becomes important
when you set links and want to target a link to open in a particular area of
the frameset. The filename is the actual name of the HTML file for the frame.
The frame name is the nickname that you refer to when you want to set links.
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You can see the names of your frames in the Frames panel, shown in Figure
7-5. If you're happy with the names that Dreamweaver automatically assigned
to your frames, you can skip the following steps. If you want to change the
names of the frames in your frameset or assign your own name as you create
a new frame, follow these steps:

1.

Open an existing frameset or create a new one.

See the “Creating a frame in Dreamweaver” section, earlier in this chap-
ter, if you don’t know how to create a frameset.

. Choose Window=>Frames to open the Frames panel at the right of the

work area.
The Frames panel opens, as shown in Figure 7-5.

The Frames panel is a miniature representation of the frames on your
page that enables you to select different frames by clicking within the
panel.

. Click to place your cursor in the area of the Frames panel that corre-

sponds to the frame that you want to name.

As displayed in Figure 7-5, you can see that I selected the top frame. You
can click to select any of the frames in the panel.
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The Properties inspector displays the properties for that particular
frame. You can make any changes to the frame’s properties by altering
the properties in the Properties inspector after selecting the frame. You
can also select the entire frameset by clicking the border around all the
frames in the Frames panel. The Frames panel allows you to select only
one frame or frameset at a time.

4. In the Frame Name text box on the left side of the Properties inspec-
tor, type a name for the frame.

Dreamweaver assigns names automatically when you save the files in

a frameset. In the example shown in Figure 7-5, Dreamweaver assigned
the names topFrame, mainFrame, and leftFrame. You can leave these
names as is or change them to anything else in the Properties inspector
(just don’t use spaces or special characters in the names).

In the example, | changed the topFrame to bannerFrame. You should
name your frames in a way that makes sense to you and helps you
remember what they are so you can better target them (which you can
find info on in the “Setting links to a target frame” section that follows).

5. Choose File=>Save Frameset to save the frameset page after changing
any of the names.

The frameset is the file you don’t see in the display area that describes
the other frames and contains information such as frame names.

Remember, you can save any individual frame by placing your cursor
in the frame and choosing File>Save, or you can save all the files in
your frameset (including the frameset page) by choosing Filem>Save
All Frames. Refer to the “Saving files in a frameset” section, earlier in
this chapter, for more information on saving frames.

Now that you identified or changed the names of your frames, you’re ready to
start setting links that target frames. Don’t close these files yet — you want to
use them to follow the steps in the next section to set links.

I like to save my work on a regular basis so that I never lose more than a few
minutes of work if my system crashes or the power goes out. Beware, how-
ever, that when you work with frames, you need to save all your pages to
save your work. You can save each page separately by choosing Filem>Save
Frame to save only the frame that the cursor is currently located in. To save
all your pages at once, simply choose Filem>Save All to save all the pages in
the frameset.

Setting links to a target frame

Setting links in a frameset requires some preliminary work. If you jumped to
this section without creating a frameset or naming your frames, you may
want to refer to the sections earlier in this chapter. If you already have a
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Figure 7-6:
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frameset, have named the frames, and just want to find out how to set links,
this section is where you want to be.

Setting links in a frameset is like setting any other links between pages,
except that you need to specify the target frame, meaning the frame where
the linked page will display when a user clicks on the link. For example, if you
want a link in the left frame to control what’s in the main frame, you need to
specify the main frame as the target in the link. If you don’t specify a target,
the link opens in the same frame the link is in. Because the most common
reason to use frames is to keep navigation links in one frame and open their
corresponding pages in another, you probably want to target a frame when
you set a link.

If this seems confusing, don’t fret. After you try the following steps, it should
become clear how targets work in framesets:
1. Open an existing frame set or create a new frameset.

In Figure 7-6, you see that I am using the Scenes from the Southwest Web
site, which I created to use as an example in this chapter.

2. Highlight the text or click to select the image you want to serve as the
link.

In my example, [ selected Sedona Sights. Note that this works the same
whether you are creating a link with text or an image.
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3. In the Properties inspector, enter any URL in the Link text box or use
the Browse button to select the page you want to link to.

In my example, [ used the Browse button to set a link to the file named
Sedona-sights.html.

4. From the Target drop-down list in the Properties inspector, choose the
name of the frame that you want the link to open into.

In my example, I selected the mainFrame frame as the target. You should
choose the name that corresponds to the frame where you want your
linked page to open. Notice that Dreamweaver conveniently lists all the
frames you named in your document in the Target drop-down list, which
[ have open in Figure 7-6.

The result, as shown in Figure 7-7, is that when the frameset displays in
a browser and a user clicks the graphic that says Sedona Sights in the
left frame, the page named sedona-sights.html displays in the main
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Comparing target options

You have many options when you target links in a frameset. As shown in the
preceding section, “Setting links to a target frame,” you can specify that a
linked page open in another frame within your frameset. But in addition, you
can set linked pages to open in the same frame as the page with the link, to
open a completely new page with no frames, and even to open a second
browser window and display the page without affecting the original framed
design. Table 7-1 provides a list of target options and what they mean. You
can find all these options in the Target drop-down list of the Properties
inspector.

The Target drop-down list in the Properties inspector is activated only when
you select a linked image or section of text. There must be a link in the Link
field of the Properties inspector before you can set a target.

Table 7-1 Understanding Frame Target Options

Target Name Action

_blank Opens the linked document into a fresh new browser
window.

_parent Opens the linked document into the parent frameset of the

page that has the link. (The parentis the frameset or
frame that contains the frame with the link.)

_self Opens the linked document in the same frame as the origi-
nal link, replacing the current content of the frame. This is
the default option and usually does not need to be specified.

_top Opens the linked document into the outermost frameset,
replacing the entire contents of the browser window.

Changing Frame Properties

As you get more sophisticated in using frames, you may want to further
refine your frames by changing properties, which enables you to turn off
frame borders, change the frame or border colors, limit scrolling, and so on.
To access these options in Dreamweaver, choose Window=>Frames, click
inside the Frames panel in the area that corresponds to the frame that you
want to change, and then use the Properties inspector to access the options
I describe in the following four sections. Figure 7-8 shows the Properties
inspector as it appears when you select a frameset in the Frames panel.
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Figure 7-8:
The
selected
frames or
framesets
and their
properties
are visible
in the
Properties
inspector.
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If you don’t see the margin height and width options, make sure that you
click the expander arrow in the bottom-right corner of the Properties inspec-
tor. Clicking this arrow causes all available properties to display for the
selected item.

Changing frame borders

I think the