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Introduction

Fe Web is long past novelty, if-you’ve-heard-about-it-you-must-be-a-geek
status. (I know this because a long-distance friend of mine — a friend so
technology-phobic she bakes bread by hand, not trusting those newfangled
grocery store bakeries — recently told me she’d found inexpensive plane
tickets on a travel Web site, and would I be so kind as to make up the bed in
my spare bedroom?) Everyone, it seems, either has a Web site or is putting
one together.

The trouble is, if you want to join in the fun (and profit) and don’t happen to
be a Web developer by trade, you may have trouble deciding exactly where
to start. HTML! HTTP! XML! Java! JavaScript! Just trying to figure out what
all these strange-sounding acronyms mean can give you a headache — let
alone trying to figure out which acronyms you really need to understand
and which you don’t.

If any of this sounds familiar, you've come to the right place. This book
begins with a minibook (called, appropriately enough, Creating Web Pages)
that introduces you to the wonderful world of the Web, helps you decide
what kind of Web site you want to focus on creating, and outlines the steps
you need to take to go from your great idea to a live Web site.

The rest of the book is organized into concise minibooks, each of which
tackles a specific aspect of Web development — everything from adding
graphic images and sounds to your Web pages to turning a simple home
page into a full-fledged e-commerce site. You don’t need to read through all
of them all at once; just pick the one that corresponds to the feature you
most want to add to your site and go from there.

This book isn’t useful just for folks new to the Web, though. Even if you're
an old hand at creating Web pages, chances are you may need a reference
that covers one or more Web-related topics you may be unfamiliar with —
topics such as the powerful meta language called XML (eXtensible Markup
Language), for example. Here, too, you've come to the right place: The book
you’re holding contains reference minibooks on XML as well as the popular
JavaScript scripting language.
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About This Book

Because you (like me) may learn best when you perform tasks as you read
along, the CD that comes with this book contains a handful of the most pop-
ular Web-development tools on the market. To cement your understanding
of the concepts I present in this book, all you need to do is pop in the CD,
install one or more of the development tools you find there, and try out the
examples [ provide in each minibook.

Creating a Web site is one of the most creative, communicative endeavors in
which you can engage. Whether you're interested in creating a personal home
page for your own enjoyment, or developing a multimedia-rich e-commerce
site for your boss, you can use the tips and examples in this book to create an
interactive work of art that folks all over the planet can access and enjoy.

About This Book

The Creating Web Pages All-in-One Desk Reference For Dummies is intended to
be a reference for all the great things (and maybe a few not-so-great things)
that you may need to know when you're creating or expanding a Web site —
from designing a cool-looking page to creating multimedia effects and
e-commerce capability. Of course, you could go out and buy a book on each
of these Web-development-related topics, but why would you want to when
they’re all conveniently packaged for you in this handy reference? Creating
Web Pages All-in-One Desk Reference For Dummies doesn’t pretend to be a
comprehensive reference for every last detail of all things Web. Instead, this
book shows you how to get up and running fast so that you have more time to
do the things that you really want to do. Designed using the easy-to-follow For
Dummies format, this book helps you get the information you need without
laboring to find it.

How to Use This Book

This book acts like a reference so that you can locate what you want to
know, get in, and get something done as quickly as possible. In this book,
you can find concise descriptions introducing important concepts, task-
oriented topics to help you realize what you need, and step-by-step instruc-
tions, where necessary, to show you the way.

At times, this book presents you with specific ways of performing certain
actions. For example, when you must use a menu command, you see a com-
mand sequence that looks like this:

Filec>Print

This simply means that you use the mouse to click open the File menu and
then click the Print command.
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Sometimes, we tell you about keyboard shortcuts. These shortcuts are key
combinations such as

Ctrl+C

When you see this shortcut, it means to press and hold down the Ctrl key as
you press the C key. Then release both keys together. (Don’t attempt to type
the plus sign!)

Names of dialog boxes, menu commands, and options are spelled with the
first letter of each main word capitalized, even though those letters may not
be capitalized on your screen. This format makes sentences filled with long
option names easier for you to read. (Hey, I think of everything!)

Just one more thing: When you're asked to click or double-click something,
this book assumes that your mouse settings have not been changed from
the default. So, when you're told to click, use the left mouse button. When
you need to use the right mouse button (to display a shortcut menu, for
example), you’ll be specifically told to right-click. Be sure to make the mental
adjustments to these instructions if, for example, you're left-handed and
have reversed your mouse buttons.

Who Are Vou?

Although making too many assumptions about readers (or anything else, for
that matter!) can be a dangerous thing, you probably fit into one or more of
the following categories:

4+ You've surfed the Web for a while and are now contemplating creating
your very own home page — but don’t know where to start.

4+ You've already put up a home page and are interested in expanding it to
create a full-fledged personal Web site.

4+ You're a small-business owner who wants to hop on the e-commerce
bandwagon.

4+ You're studying Web design, Web marketing, or e-commerce at school
and could use a practical, hands-on reference book like this one.

4+ You work for a company that has its own Web site, and part of your job
is (or soon will be) helping to create, improve, or expand your com-
pany’s site.

4+ You're interested in landing a job working as a Web site developer.
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How This Book Is Organized

4+ You're already a crackerjack Web developer, but you could use a good,
solid reference book to consult when you know what you want to do —
but can’t remember the specific details for how to go about doing it.

What this book doesn’t assume (despite the title) is that you are a dummy.
Unfortunately, Web development tools and technologies — most of which
seem to be created for geeks in the first place — change faster than the
scenes in a music video. Creating Web pages can be downright confusing
and intimidating, even for software professionals, and you probably don’t
have time to devote to learning every single aspect of Web design from the
ground up. If you want to help yourself — to get started creating Web pages
as quickly and easily as possible — this is the book for you.

How This Book Is Organized

Each of the minibooks contained in Creating Web Pages All-in-One Desk
Reference For Dummies can practically stand alone. The first minibook pro-
vides a quick-and-dirty overview of the Web site creation process, covering
the basics you should know to help you get the most out of the rest of the
stuff in the book. The remaining minibooks cover just about everything you
ever wanted to know about creating pages. Here’s a brief description of
what you find in each minibook.

Book I: Web Page Basics

This minibook presents an overview of the Web page creation process: why
you might want to create Web pages, how to go about designing top-notch
pages, what steps you need to take to publish your site so that everyone
connected to the Web can view it. Here you also find a list of the elements
common to all attractive, professional-looking sites — elements you can
easily incorporate into your own efforts using the information you find in
the rest of the book.

Book 11: HTML

All Web pages are written in a special markup language called HTML.
Although you may find yourself using a graphical HTML editor — such as
FrontPage or Dreamweaver — that shields you from the nitty-gritty details
of HTML, you may prefer to create your pages from scratch using a simple
text editor and the HTML knowledge you find in this minibook. (The HTML
details you find in this minibook may also come in handy if you decide to
tweak the HTML code generated by your graphical HTML editor.)
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Book 111: FrontPage 2003

FrontPage 2003, from Microsoft, is several Web-creation tools all rolled into
one: It’s an HTML editor you can use to create Web pages, an image editor you
can use to create Web-friendly graphic images, and a Web site publisher you
can use to publish your pages on the Web (in other words, make your pages
accessible to everyone hooked up to the Internet running a Web browser).
This minibook walks you through the process of creating and publishing a
Web site using FrontPage 2003.

Book 1UV: Dreamweaver

Macromedia Dreamweaver is another popular Web creation tool. Like
FrontPage 2003, Dreamweaver allows you to create and publish Web pages
with point-and-click ease.

Book U: Multimedia: Pulling Together Graphics,
Sound, Uideo, Animations, and Applets

For those who want to add a bit of visual or aural interest to their Web pages,
this minibook has the answers. Here you find how to create your own graphic
images, sound files, Java applets, and animated effects from scratch (or find
ones that you can use, if you're not the creative type). You also find out how
to make sure your multimedia additions are optimized for viewing and listen-
ing over the Web — as well as a frank discussion of when multimedia isn’t a
good choice for your Web site.

Book VI: JavaScript

This minibook introduces you to the JavaScript scripting language, a special
programming language that allows you to access and work with the compo-
nents of a Web page to make your Web pages interactive. Here you find out
how to create popular JavaScript effects such as mouse rollovers (push but-
tons that change their appearance in response to a user’s mouse move-
ment) and intelligent forms (input forms that alert users when incorrect
information is entered).

Book VII: Flash

If you're interested in creating animated effects for the Web, you’ll want to
know more about Flash. From Macromedia, Flash is a popular, powerful tool
for creating graphic images and turning those images into animations. In
this minibook, you find out how to use Flash to create animations, slide
shows, and more — all optimized for the Web.
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Book VIII: Adding E-Commerce Capability

E-commerce, or electronic commerce, is one of the fastest-growing uses of
the Web. Whether you want to sell your homemade cookies to cookie afi-
cionados across town or your company’s product line to customers all over
the world, this minibook presents your e-commerce options. And, because
e-commerce is much more than just software, this minibook also lists the
latest approaches to Web marketing and fulfillment.

Book 1X: XML

XML (short for eXtensible Markup Language) has an awful lot of developers
excited because it defines a way to exchange data over the Web without
falling prey to the limitations HTML (and browsers) impose. In this mini-
book, you find out what XML is and how you use it; you also find out what
tools are available to help you create your very own XML applications.

What’s on the CD?

The CD that comes with this book is packed with useful software applica-
tions you can use to begin creating your own Web pages right away. Here
you find HTML editors, programs that help you create multimedia files
(such as graphics, animations, and sound files), and much more. For details
on exactly what’s included, refer to the “About the CD” Appendix.

Icon Alert!

As you flip through this book, little pictures — called icons — in the margins
draw your attention to important information. You’ll discover the following
icons in this book:

This icon points out tidbits of information that save you time and help you
perform a task more easily.

Just a reminder . . . This information may be worth keeping in mind.

Watch out! This icon warns you of things likely to go wrong — the glitches
that most often occur when you create Web pages — and helps you sidestep
those annoying glitches.
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This icon appears beside in-depth, nerdy, technical guru-type stuff you may
want to skip over or read later.

This icon alerts you to where the applications on the companion CD are
mentioned in the book.

You see this icon when we reference another fine book you might want to
check out — one that provides additional details on the topic at hand.
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Chapter 1: Creating a
Successful Web Site

In This Chapter

v Understanding the different kinds of Web sites

+ Determining what to include on your Web site
1 Creating a Web site step by step

v~ Finding space for your Web site

LVeb sites are many things to many people. To some, a Web site is an
electronic business card; to others, an online storefront; to still

others, a classified advertisement or a family photo album. The trick to cre-
ating a successful Web site is to figure out what a Web site is to you — and
then to build your site and make it available on the Web by following a few
simple steps.

Web Site Basics

a\\S

Although the steps you take to create and publish (make it available on the
Web) a Web site are pretty straightforward, the geeky terminology surround-
ing the Web can make the whole process seem downright confusing. The fol-
lowing sections give you an overview of the different kinds of sites you can
create, followed by a description of the “big picture” — in other words, a
description of what you need to do to turn your great idea into a live Web
site that people all over the world can view and enjoy.

Different kinds of Web sites

The following sections describe three very broad categories of Web sites.
The Web site that you intend to publish probably falls into one of these
three categories.

Personal home pages

Just about anyone with access to the Internet can create a personal home
page. The simplest personal home pages contain basic information, such as
your name, information about your family, your occupation, your hobbies,
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and any special interests you may have. You can also throw in a picture. Oh,
and links to your favorite pages on the Web are also commonly included in
personal home pages.

More elaborate personal home pages can include pictures from your last
family vacation, the first chapter of your soon-to-be-published novel, or any-
thing else you think others may be interested in.

If you're looking for a job, you should also include your résumé on your per-
sonal home page.

Company Web sites

More and more companies are joining the Web bandwagon. Even mom-and-
pop pizza parlors are putting up Web pages. The simplest corporate Web
pages provide basic information about a company, such as a description of
the company’s products or services, phone numbers, and so on.

A more elaborate corporate Web site can include any or all of the following:

4 An online catalog that enables Internet users to see detailed information
about products and services. The catalog may include pictures and, if
you want, prices.

4 Online ordering, which enables Internet users to actually place orders
over the Internet.

4 A customer survey.

4+ Lists of frequently asked questions (FAQs) about the company’s prod-
ucts or services.

4 Online support, where a customer can leave a question about a problem
he or she is having with a product and receive an answer within a day
or two.

4 Articles and reviews of the company’s products.
4 Press releases.

4+ Biographies of company employees.

Special-interest Web sites

Many of the most interesting Web sites are devoted to special interests. For
example, if you're involved with a youth soccer league, you may want to
create a Web page that includes team rosters, schedules, and standings.

Or, if you're one of those festive neighbors who decorates your house

with 100,000 lights at Christmas, create a Web page that focuses on
Christmas decorating. The list of possible topics for a special interest

Web site is limitless.
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Creating a Web site: An overview Book|

Chapter 1
Although you don’t have to be obsessively methodical about creating a Web
site, following these three basic steps helps ensure that you end up with a
site you're proud to call your own (in the least possible amount of time).

1. Plan your Web site.
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Taking a bit of time up front to decide exactly how you want your site
to look and behave can save you loads of time, as you see in the follow-
ing section, “Planning Your Web Site.”

2. Create your Web pages.

A Web site is a collection of Web pages. And although all Web pages
must be created in a special language called HTML (which stands for
HyperText Markup Language), you have several options besides becom-
ing an HTML guru and typing all your HTML code into a text editor by
hand. The section “Creating Your Web Pages,” later in this chapter,
describes some of those options.

3. Publish your Web pages.

Before anyone hooked up to the Web can view your Web site, you must
first publish it — that is, you must first copy your Web pages to a Web
server. In the section “Publishing Your Web Pages,” later in this chapter,
you find out how to do that.

Planning Your Web Site

Start by making a plan for your Web site. If all you want to do is create a
simple, one-page “Here I Am” type of personal Web site, you may not need a
plan. However, if this Web site is your first one, a little planning can help you
avoid some frustration as you figure out the nuts and bolts of creating a Web
page. Your plan may be a simple sketch (you can even do it on a napkin) of
what information your site will contain and how that info will look. For a
more elaborate Web site, the planning is more complicated and even more
necessary, but the principle remains the same.

One good way to plan a more complex Web site is to sketch a simple dia-
gram on paper showing the various pages you want to create, complete with
pictures and arrows showing the links between the pages. Or, you can create
an outline that represents your entire site. You can be as detailed or as
vague as you want — but in general, the more detailed your plan, the less
time you spend later when you actually begin building your site.
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Creating Your Web Pages

Creating Your Web Pages

You can take a couple of different approaches to creating the pages that will
make up your Web site: You can hand-code the site from scratch, using a
text editor, or you can use a point-and-click graphical editor that generates
HTML code for you. Either approach works just fine. You can always choose
one approach, work with it awhile, and then switch to the other approach
later if you change your mind.

From scratch, using a text editor

If you dream in Boolean, feel free to fire up Notepad and start banging away
HTML code from scratch. You have to figure out the intricacies of using
HTML code to format your Web pages, but you gain satisfaction from know-
ing you did it the hard way! (You also have complete control over every
aspect of your Web pages — something you don’t always have when you
use a graphical Web page editor.) Book Il introduces you to the HTML basics
you need to get started creating HTML code from scratch.

Using a graphical Web page editor

If the mere thought of programming gives you hives, you can use a simple
Web page editor to create your Web pages. (Book I, Chapter 2, shows you a
free Web-page-creation tool in action.) Or, you can purchase inexpensive
programs for creating complete Web sites. Two of the best known Web site
development programs are Microsoft FrontPage 2003 and Dreamweaver.
(Dreamweaver is included on the CD that comes with this book.) For more
information on these programs, Book IIl covers FrontPage, and Book IV
covers Dreamweaver.

Beyond HTML: Adding nifty features

After you have your basic site up and running, you may want to get fancy
and add some cool extras — features such as:
4+ Images, sound, animations, and Java applets (see Book V)

4 Interactive images and forms that automatically check user input for
errors (see Book VI, which covers JavaScript)

4+ Movie clips (see Book VII, which covers Flash)
4 Credit-card handling (see Book VIII, which covers e-commerce)
For those of you who like to keep up on the cutting edge of things, Book IX is

all about XML (or Extensible Markup Language). XML is one of the latest
Web-related “meta” languages, and Book IX shows you how to use it to
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create your very own specialized markup language, complete with semantic Book |
definitions called vocabularies. Using a combination of XML and a few other Chapter 1
tools, you can create your own HTML-like markup tags and your own lan-
guage processor — in effect, creating a means for extending HTML or
exchanging non-HTML data over the Web in a standard, civilized way. For
example, some folks in the automobile industry are using XML to enable
automobile parts producers and buyers to exchange automobile-related
data quickly and easily over the Web.

9IS qapA
|njssaaang
e funeaiy

Publishing Your Web Pages

After your Web pages are complete, it’s time to publish them on the
Internet. First, you have to find a Web server to host your Web pages. The
next section gives you ideas for finding a Web server. Next, you copy your
Web pages to the Web server. Finally, you can publicize your Web site by
cataloging it in the major search services.

Finding space for your Web site

Before Web surfers can see your Web pages, you must transfer the pages to
a Web server. A Web server is a computer hooked up to the Internet running
special Web server software. The following sections give you some ideas
about where to find a Web server to host your Web pages.

Internet Service Providers

If you access the Internet through an Internet Service Provider (ISP), you
probably already have space set aside on its server to set up a home page.
Most ISPs include a small amount of disk space for Web pages with their
monthly service. The space may be limited to a few megabytes (for example,
AOL offers up to 20MB), but that should be enough to set up several pages.
You can probably get additional disk space if you need it for a modest charge.

Your ISP should be able to give you step-by-step instructions for copying
your Web pages to the ISP’s Web server.

If you're interested in creating a business Web site, you may want to go
shopping for an ISP. Some places to start: reviews.cnet.com (click Web
hosting), webhostinginspector.com, and www.webhostingratings.com.
As you research ISPs, you may find keeping these criteria in mind useful:

4+ Price: Some ISPs charge by the month; others give you discounts for
paying a year or more in advance.

4+ Downtime: You may not care if your personal home page is inaccessible
for a couple of hours a day, but if you're doing business over the Web,
you may care very much indeed. Downtime can occur due to power
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outages, scheduled equipment maintenance, and so on. Because some
ISPs have backup servers that minimize (or even eliminate) downtime
and others don’t, be sure to ask any ISP you’re considering what you
can expect in terms of average site.

4+ Services: Knowing up front which additional services (in addition to
plain vanilla Web hosting) you want makes deciding on an ISP easier.
Some common services an ISP may offer include:

¢ The ability to assign a unique URL of your own choosing (for example,
www.RalphsWidgets.com) to your Web site

e The ability to stream special multimedia formats, such as RealAudio
files

¢ Built-in management and e-commerce tools, such as shopping carts
and usage monitors

e The ability to create and run server-side applications (such as
server-side JavaScript)

Free Web hosts

If you can’t find a home for your Web page at your Internet Service Provider,
consider using a free Web host to host your Web site.

The best known, free home page service is Yahoo! GeoCities, which hosts
well more than 1 million home pages. Each free Web site can use up to 15MB
of disk space. The only limitation is that you must include a banner adver-
tisement at the top of your Web page and a link to the GeoCities home page
at the bottom of your page. (For a $10 one-time fee and $4.95 per month, you
can eliminate the advertising and increase your space allotment to 25MB.)
You can find Yahoo! GeoCities at geocities.yahoo.com.

Many other free home page services are available, although most cater to
specific types of home pages, such as artist pages, churches, chambers of
commerce, and so on. You can find a good directory of free home page serv-
ices by going to Yahoo! (www.yahoo.com) and searching for free Web pages.

If your idea of the perfect Web site is a simple online diary, or Web log (blog
for short), check out Blogger (www.blogger.com) for free hosting.

Publicizing your Web site

Just publishing a Web site doesn’t ensure that any visitors will find it.

To make your presence on the Web known, you must publicize your site.
Book [, Chapter 7, describes the ins and outs of getting the word out about
your site. Depending on the type of site you're creating, your online public-
ity plan may include registering your site with search engines, advertising
your site (both online and off), and getting other people to link to your site
from theirs.
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Elements of a Successful Web Site Chamor

A successful Web site doesn’t just happen by accident. To create a Web site
that people will visit over and over again, keep the following time-tested
guidelines in mind.

4+ Offer something useful on every page. Too many Web sites are filled
with fluff — pages that don’t have any useful content. Avoid creating
pages that are just steps along the way to truly useful information.
Instead, strive to include something useful on every page of your Web
site.
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4 Check the competition. Find out what other Web sites similar to yours
have to offer. Don’t create a “me, too” Web site that offers nothing but
information that is already available elsewhere. Instead, strive for
unique information that people can find only on your Web site.

4+ Make it look good. No matter how good the information at your Web
site is, people will stay away if the layout is disorganized or the design
is too busy or looks thrown together. Yes, substance is more important
than style. But an ugly Web site turns people away, whereas an attrac-
tive Web site draws people in.

4+ Proofread it carefully. Misspelled words and typos make visitors think
that the information on your Web site is unreliable. If your HTML editor
has a spell-check feature, use it — and always proof your work carefully
before you post it to the Web.

4+ Provide links to other sites. Some of the best pages on the Internet are
links to other Web sites that have information about a particular topic.
In fact, many of the pages | have bookmarked for my own use are pages
of links to topics as diverse as hobby electronics, softball, and back-
packing. The time you spend creating a directory of links to other sites
with information similar or complementary to your own is time well
spent.

4+ Keep it current. Out-of-date information turns away visitors. Make sure
that you frequently update your Web pages with current information.
Obviously, some Web pages need to be changed more than others. For
example, if you maintain a Web page that lists the team standings for a
soccer league, you have to update the page after every game. On the
other hand, a page that features medieval verse romances doesn’t need
to be updated very often, unless someone discovers a previously
unpublished Chaucer text hidden in a trunk.

4+ Don’t tie it to a certain browser. Exploiting the cool new features of the
latest and greatest Web browser, whether it’s Microsoft Internet
Explorer or Netscape Navigator, is a good idea. But don’t do so at the
expense of users who may be using the other browser, or at the expense
of users who are still working with an earlier version. Some people are
still using browsers that don’t even support frames. Make sure that any
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pages in which you incorporate advanced features of the newer
browsers work well with older browsers as well by testing your pages in
as many different browsers as possible. (For more information on creat-
ing Web pages that look great in different browsers, check out Book VI,
Chapter 8.)

4+ Don’t make hardware assumptions. Remember that not everyone has
a 21-inch monitor and a high-speed cable-modem connection to the
Internet — folks in other countries, for example. Design your Web site
so that the poor sap who is stuck with a 14-inch monitor and — gasp —
a 28.8 Kbps modem connection to the Internet can use it.

4+ Publicize it. Few people will stumble across your Web site by accident.
If you want people to visit your Web site, you have to publicize it. Make
sure that your site is listed in the major search engines, such as Yahoo!
and Google. Also, you can promote your site by putting its address on
all your advertisements, correspondences, business cards, e-mails,
and so on. For more information about publicizing your site, check out
Book I, Chapter 7.

Organizing Site Content

Figure 1-1:
Sequential
organization.

Organizing your site’s content can mean the difference between creating a
great site and a site that visitors click away from screaming in frustration.
The following sections describe several popular ways to organize the infor-
mation on your Web site.

Sequential organization

In sequential organization, you simply organize your pages so that they
follow one after another, like the pages in a book, as shown in Figure 1-1.

Page 1 Page 2 Page 3 Page 4

On each page, provide navigation links that enable the user to go to the next
page, go to the previous page, or return directly to the first page. You imple-
ment navigation links using HTML links and anchors (both of which I describe
in Book II, Chapter 3), but you can also make them more descriptive than a
plain underlined text link. For example, you can create navigation links that
look like right and left arrows (for “next” and “previous” pages, respectively).
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One of the most popular ways to arrange navigation links is the navigation
bar. A navigation bar is a strip of navigation links that runs either across the
top or bottom of a page, or vertically, along the left-hand side of a Web page.
You find more information about navigation bars in Book I, Chapter 3.

A\

Hierarchical organization

In hierarchical organization, you organize your Web pages into a hierarchy,
categorizing the pages according to subject matter. The topmost page
serves as a menu that enables users to access other pages directly (see
Figure 1-2).

Menu

_— |

Figure 1-2: Y Y ) '
Hierarchical
organization
with one
menu level.

Page 1 Page 2 Page 3 Page 4

On each page, provide a navigation link that returns the user to the menu.

If you want, you can include more than one level of menu pages, as shown in
Figure 1-3.

Menu

Menu Menu

Figure 1-3: ¢ ¢ ¢ ¢

Hierarchical
organization
with multiple
menu levels.

Page 1 Page 2 Page 3 Page 4 Page 5 Page 6

Book |
Chapter 1
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Figure 1-4:
Combination
sequential
and
hierarchical
organization.

However, don’t overdo the menus. Most users are frustrated by Web sites
that have unnecessary menus, each containing only two or three choices.
When a menu has more than a dozen choices, however, consider splitting
the menu into two or more separate menus.

Combination sequential and
hierarchical organization

Many Web sites use a combination of sequential and hierarchical organiza-
tion, in which a menu enables users to access content pages that contain
sequential links to one another, as shown in Figure 1-4.

Menu

Page 1-1 - Page 1-2 > Page 1-3 > Page 2-1 > Page 2-2 > Page 2-3

In a combination style of organization, each content page includes a link to
the next page in sequence in addition to a link back to the menu. The menu
page contains links to the pages that mark the start of each section of con-
tent pages.

Web organization

Some Web sites have pages that are connected with links that defy a strict
sequential or hierarchical pattern. In extreme cases, every page in the site is
linked to every other page, creating a structure that resembles a web, as
shown in Figure 1-5.

Web organization — where every Web page links to every other page in

a Web site — is a good style of organization if the total number of pages in
the web is limited and you can’t predict the sequence in which a user may
want to view the pages.
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Page 1 Page 6
Ve ™~
Page 2 Page 5
~ 7
Figure 1-5:
Web Page 3 Page 4
organization.

What to Include on Every Page

Although every Web page should contain unique and useful information, all
Web pages must contain the following three elements:

4+ Title: At the top of every page, place a descriptive title that identifies
the specific contents of the page and the Web site itself. A descriptive
title is important because some users may not enter your site through
your home page. Instead, they may go directly to one of the content
pages in your site. In addition, many users bookmark pages for quick
access at a later date, and a good title, such as, “Sarah Bellum’s
Definitive Guide to Lemurs,” helps users remember why they book-
marked your page in the first place.

4+ Navigation links: All the pages of your Web site should have a consis-
tent set of navigation links. At a minimum, provide a link to your home
page on every page in your site. In addition, you may want to include
links to the next and previous pages if your pages have a logical sequen-
tial organization. Figure 1-6 shows examples of navigational links at
www.dummies.com.

4 Author and copyright information: Every page should also include
author credits and a copyright notice. Because users can enter your site
by going directly to any page, placing the authorship and copyright
notices on only the home page isn’t sufficient.

Book |
Chapter 1
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Figure 1-6:
The navi-
gational
links at
WWW .
dummies.
cominclude
Everyday
Computing,
Advanced
Computing,
and The
Internet.
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What to Include on Every Web Site

Although every Web site is different, you can find certain common elements
on most Web sites. The following sections describe the items you should
consider including on your Web site.

Home page

Every Web site should include a home page that serves as an entry point
into the site. The home page is the first page that most users see when they
visit your site (unless you include a cover page, as described in the next
section). As a result, devote considerable time and energy to making sure
that your home page makes a good first impression.

Place an attractive title element at the top of the page. Remember that most
users have to scroll down to see all of your home page. They see just the
top of the page first, so you want to make sure that the title is immediately
visible.

After the title, include a site menu that enables users to access the content
available on your Web site. You can create a simple text menu, or you can
opt for a fancy graphics-based menu in which the user can click different
parts of the image to go to different pages. However, if you use this type of
menu, called an image map, be sure to provide a text menu as an alternative
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for users who don’t want to wait for the image map to download or who
have turned off graphic downloads altogether. For more information about
image maps, see Book I, Chapter 4.

Here are a few other goodies you may want to include on your home page:

4 An indication of new content that is available on your Web site: Users
who return to your site often want to know right away when new infor-
mation is available.

4+ The date your site was last updated: Adding a so-called “freshness
date” lets visitors know that you're actively maintaining your site, which
inspires confidence in your content and encourages users to return.

4 A copyright notice: You can include a link to a separate copyright page
where you spell out whether others can copy the information you have
placed on your site. In addition, you might want to add a sentence or
two at the bottom of each page informing visitors that your site content
is copyrighted, and that you're the copyright owner: for example,
Copyright 2003-2004, Sue Smith. (This is true if you create the
content yourself.)

4+ A reminder to bookmark the page so users can get back to the page
easily: Reminding your visitors to bookmark your page is a win-win situ-
ation: They find your site the next time more easily, and you get their
repeat business without having to do a lot of extra work.

4+ A hit counter: If users see that 4 million people have visited your site
since last Tuesday, they automatically assume that yours must be a hot
site. On the other hand, if they see that only three people have visited
since Truman was president, they’ll yawn and leave quickly. If your site
isn’t very popular, or if you're going for a strictly professional look, you
may want to skip the hit counter.

Avoid placing a huge amount of graphics on your home page. Your home
page is the first page on your Web site most users are likely to see. If it takes
more than 15 seconds for your page to load, users may lose patience and
skip your page altogether. As a simple test, try holding your breath while
your home page downloads. If you turn blue before the page finishes down-
loading, the page is too big.

Cover page

A cover page (sometimes called a splash page) is a page that displays tem-
porarily before your home page displays. Cover pages usually feature a
flashy graphic logo or an animation. In most cover pages, the user must click
the logo or some other element on the page to enter the site’s home page.
Or, the page can be programmed so that it automatically jumps to the home
page after a certain amount of time — say 10 or 15 seconds — elapses.

Book |
Chapter 1
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Many users are annoyed by cover pages, especially those that take more
than a few seconds to download and display. Think carefully about whether
the splashy cover page actually enhances your site or is more of an
annoyance.

Site map

If your site has a lot of pages, you may want to include a site map. A site map
is a detailed menu that provides links to every page on the site. By using the
site map, a user can bypass intermediate menus and go directly to the pages
that interest him or her.

Contact information

Be sure your site includes information about how to contact you or your
company. You can easily include your e-mail address as a link right on the
home page. When the user clicks this link, most Web browsers fire up the
user’s e-mail program, ready to compose a message with your e-mail
address already filled in.

This should go without saying, but just in case, if you decide to include con-
tact information, make sure that you're diligent in reading and responding to
the comments your visitors e-mail you. (This advice goes double for those
of you contemplating a commercial Web site.)

If you want to include complete contact information, such as your address
and phone number, or if you want to list contact information for several
individuals, you may want to place the contact information on a separate
page that can be accessed from the home page.

Help page

If your Web site contains more than just a few pages, consider providing a
help page that provides information about how to use the site. The help
page can include information about how to navigate the site, as well as
information such as how you obtained the information for the site, how
often the site is updated, how someone would go about contributing to the
site, and so on.

FAQ

FAQ pages are among the most popular sources of information on the
Internet. You can organize your own FAQ page on any topic you want. Just
come up with a list of questions and provide the answers. Or solicit answers
from readers of your page.
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Troubleshooting Web publishing

The following points summarize the most trou-
blesome aspects of creating high-quality Web
pages.

v Too many Web browsers: Different Web

browsers display Web pages differently.
Each new version of the two most popular
Web browsers — Netscape Navigator and
Microsoft Internet Explorer — adds new
HTML features. Unfortunately, in their
efforts to get ahead of one another, both
Netscape and Microsoft put the notion of
compatibility in the back seat. Whenever
you use a new HTML feature, you have to
make sure that your page looks good no
matter which browser the user views your
page with.

Different screen sizes and resolutions:
Some users have computers with puny 14-
inch monitors that are set to 640 x 480 res-
olution. Others have giant 19-inch monitors

thatrun at 1,280 x 1,024. Your pages look dif-
ferent depending on the display resolution
of the user’s computer. A good middle-of-
the-road approach is to design your pages
for 800 x 600.

Different connection speeds: Some users
are connected to the Internet over high-
speed T3 lines or cable modems, which can
send megabytes of data in seconds. Others
are connected over a phone line at 56 Kbps
(common inthe U.S.) or even 28.8 Kbps (still
common in other countries), both of which
download large graphic files at a snail’s
pace. To compensate for lack of speed,
some users set up their browsers so that
graphics are not automatically down-
loaded. That means that if you want to
reach the widest possible audience, your
pages should not be overly dependent on
graphics.

Related links

At some sites, the most popular page is the links page, which provides a list
of links to related sites. As the compiler of your own links page, you can do

something that search engines such as Yahoo! cannot: You can pick and
choose the links you want to include, and you can provide your own com-
mentary about the information contained on each site.

Discussion group

A discussion group adds interactivity to your Web site by allowing visitors
to post articles that other people who visit your site can read and respond to.

Book |
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Chapter 2: Building
VYour First Web Site

In This Chapter

1+~ Registering with a free Web host

+ Creating and publishing your first Web page
v Using a free Web site creation tool

v Viewing your first Web page

Nothing helps give you a feel for how a process works better than walk-
ing through each of the steps yourself. In this chapter, you see how to
create, publish, and view your first Web page using the free graphical Web
editor available from Yahoo! GeoCities, a free Web host.

Registering with a Free Web Host

A\

You have many options when it comes to finding space for your Web site.
(Book I, Chapter 1 describes several of these options.) In this chapter, |
show you how to register and create a site with Yahoo! GeoCities, one of the
most popular free Web hosting services.

Other free Web hosting services at the time of this writing are Angelfire
(angelfire.lycos.com)and Tripod (www.tripod.lycos.com).

If you already have a Yahoo! GeoCities account, go ahead and skip to “Using
a Free Web Site Creation Tool,” later in this chapter. Otherwise, to register
with Yahoo! GeoCities, follow these steps:

1. Type geocities.yahoo.com/home/ into your browser’s address field
and press Enter.
The Yahoo! GeoCities home page appears, as shown in Figure 2-1.

2. Click the Free link on the Yahoo! GeoCities home page, as shown in
Figure 2-1.

The Free: Highlights window appears.

3. Click the Sign Up link you see on the Free: Highlights window. When
the Welcome to Yahoo! GeoCities page appears, click the Sign Up Now
link.
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Registering with a Free Web Host

"€ Yahoo! GeoCities - Microsoft | Explorer
File Edit Help

@Eack - e - I_x‘] Ej : /._ Search

address (] hitp:fjgeocities. yahoo camihome]

View Favorites Tools i
Lo Faveritss emedin @ I__‘v _¢ - [ ﬁ ﬁ
ﬂ =

o
o _—
- Yahoo! - Help
YAHOO! GeoCities %
Welcome, Guest [Signin] |_
Yahoo! GeoCities
Sign in to Yahoo! The Way to Build a Better Web Site
Yahoo! ID: |
Password
[ remember my 15 & Pazancrd
Figure 2-1:
Yahoo!
GeoCities is || Get Started
Don't mind ads on your site?
one of many ! g . ’
Then you can gel starled
free Web e e ainre | GeoCities Pro ~ Business Web Hosting
X page. Or, get full-featured Evendhing you need to craate a p Estabiish your : anling with
hOStIng capabilities and an ad-free web site securs, reliabiz fosting from Yahoo! L |
services site with: « ‘four own domain name: WwwLyeur- e e S i ¥
& Ireemst
A Sign Up for Your Yahoo! ID window similar to the one you see in
Figure 2-2 appears.
&1 Welcome to Yahoo! - Microsoft Internet Explorer LEE
File Edit View Favorites Tools Help .?'
@ Back = () I_x‘] Ej : : /._ Search 7 Feveritss emedin &) .-‘ hé _ﬁ = - g ﬂ B
Address ,@jw=|.&.done=httn°fo:3a.lf.fueocltles.y’ahoo.cu'rt.l’f_80%3‘-9:ate=u&.9c=ue0&.v=Ela:.u=4saﬁeccvoenIs_apartner=a..p_=apru'no=&.last= ﬂ = =
o
N -~ oo P &
Yahoo! - Hel
YaHoO! GeoCities # Yahoo - telp
Sign up for your Yahoo! ID Already have an 10?7 )
Gala Yahoo! 1D and password for access 1o Yanoo! GeoClties and all other personalized Yahoo! senices
. . Choosing your ID
¥ahoot|0): lknitiand2004 *fou wil use this information to sccess |
Examples: “dakymanss” of “reelriyme" “fahoo! esch time, Capitsization matters for
— - paszw
Fassword: sssess i o
Flgure 2-2: Musst ks six chavactsrs or mors
You use this Re-type Password. sesess
sign-up form e ——
. . . . Tee Yahoo! Mai
to reg iStel' Activate Yahoo! Mail: ] hCrta gle vTurf\r‘ei Yamo:le mail address for this ID and YoUr Smal atress will b8 The Yehool
f f W b eintzng:an00lMal. youve chosen foliwed by @yahoo.com
oriree Ve
hosti Ifyou farget your password o need help with your account, you'll need 1o confirm e Recalling your password
ostn g following information: This information is aur only way to verify
. : ; - T your identty. To protect your account,
services Security Question: | What was your high school mascot? :ﬂ make sure *Your Answer* i memorable
with Yahoo! OUF ANSWEr cougar for you but hard for others to guess! |
GeOC|t|es Oicthdonr [ FO 1o Aot L] L e i

B Irtemet
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Using a Free Web Site Creation Tool

4. Fill out each field following the instructions provided on the form
and then click the Submit This Form button.

V?‘“\NG! If you forget the ID or password you choose, you won’t be able to access
S your account (or the Web page creation tools). Chances are your memory,
like mine, isn’t infallible — so make sure you write this information on a
slip of paper and tuck it in a safe place next to your computer.
The Registration Completed window you see in Figure 2-3 appears.
£]Welcome 10 Yahoo! - Microsoft Internet Explorer BEx]
File Edit View Fawvorites Tools Help o
@ Back = () Iﬂ |§ ; /.- Search Favorites G‘Meda @’. s ?_ 3 L ﬁ ﬁa
s 6] st crumbe<EaySe 2 crul=YsEally St er=geokdone=hit el gecctesyshoo comireg i state=tipartner=| v | [ o
e o]
YasoO! GeoCities # Yahool - Hilo
Registration Completed: Welcome to Yahoo! knitfiend2004
‘We recornmend that you write down your password and the information below for future reference.
Figure 2.3: Your Yahoo! ID: knitfiend2004
When you. Your new Yahoo! Mail address: knitfiend2004@yahoo.com
see this
Click here to edit your Marketing Preferences. You can select and customize the categories of communications you
message, receive about Yahoo! products and senices, or choose to opt-out of each.
you know
your ' ; )
. . [ Tes, personalize my browser with Yahoo! Companion toolbar.
registration
has been
successfully .
completed. | L)
€l & Internet

5. Click the Continue to Yahoo! button you see on the Registration
Completed window.

You're done!

Using a Free Web Site Creation Tool

Most free Web services provide their own graphical Web site creation tools

to make creating your first Web pages quick and easy.
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Using a Free Web Site Creation Tool

No such thing as a free lunch?

As you may suspect, “free” Web services aren’t
completely free. Most free Web services don't
charge you setup or hosting fees, but they do
require you to display advertising messages on
your site. Although you may be able to restrict
the types of advertising the Web services dis-
play on your site (for example, you may request
family- or environmentally friendly messages),
the Web service always has the last word.

One more thing to consider when choosing a
service: Free providers such as Yahoo! GeoCities

typically reserve the right to pull the plug at any
time. In other words, you may wake up one
morning to find out that the free provider you
were relying on has decided to stop offering its
services. For that reason, you may want to
choose a for-pay provider if you're creating a
business-related or other gotta-be-available-
24/7 Web site. (Hey, you get what you pay for,
right?)

Most free Web services don’t restrict you to using their Web site creation
tools; instead, they allow you to create Web pages using any tool you like. If
you choose not to use their built-in tools, however, you need to take an
extra step to transfer your Web pages to your free site host — typically by
using a transfer utility based on ftp (File Transfer Protocol).

As you become more and more skilled at creating Web pages, you may want
to switch to a more sophisticated tool, such as Dreamweaver. You can find a
trial version of Dreamweaver on the CD that comes with this book.

In the following steps, you see how to use the Yahoo! PageWizards Web tool
available free when you register with Yahoo! GeoCities to create a simple
Web page. First, [ show you how to choose a look, or theme, for your Web

page; then I show you how to add content, such as text, links, and a picture.

To use Yahoo! PageWizards to create a simple Web page, follow these steps:

1. Type geocities.yahoo.com/home/ into your browser’s address field
and press Enter.

A Welcome page appears (refer to Figure 2-1).

2. Click the Free link on the Yahoo! GeoCities home page, as shown in
Figure 2-1.

The Free: Highlights window appears.
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Figure 2-4:
The first
step in
creating a
free Yahoo!
GeoCities
site is
selecting
which type
of ad you
want to
display on
your site.

Using a Free Web Site Creation Tool 3 1

3. Click the Sign Up link you see on the Free: Highlights window. When
the Welcome to Yahoo! GeoCities page appears, type your previously
registered ID and password into the Yahoo! ID and Password fields,
respectively, and then click Sign In.

The previous section describes how to register an ID and password with
Yahoo! GeoCities.

A Yahoo! GeoCities page personalized with your ID, similar to the one
you see in Figure 2-4, appears.

4. Select an ad topic and then click the Continue button.
A page containing your Web site URL appears.
Be sure to write down your Web site URL so you don’t forget it.
5. Click the Build Your Web Site Now! link.
A page similar to the one you see in Figure 2-5 appears.
6. Click the Yahoo! PageWizards link.

A Yahoo! GeoCities PageWizards window appears, offering a selection of
page themes (see Figure 2-6).

] Welcome to Yahoo! GeoCities - Microsoft Intemet Explorer BE=]

File Edit View Fawvorites Tools Help o

@Back L > | Iﬂ |§ ; /.- Search -\'_:'_'._-'Favnrltes G‘Meda &) Vb ?_ 3 L ﬁ ﬁa

dcress @] e yah coinjfeg? stitent ¥ B
s
geocilies.com/knitfiend2004 GeoCities Free &
Sign up now for a premium package and your set up fee is WAIVED! Premium Packages
GeoCities Free geaties Pro
A T [ Your own personalized

; £ : : | web site.
Choose a topic to determine the type of ads that will appear on your site. (Can be changed later) | St
if you do not want ads on your web site, please check out our premium packages = Ag-free web site

- Easy to set up

O Altemnative Lifestyle O Friends © Religion & Beliefs = Free domain
O Arts & Literature O Games O Romance ée.g. vwnv.ryu:r-narn.le.com) :
O Autos O Health © Schools & Education Rersonelicec: eimall.ascouns
O Busi L Fi o os & Os = FTF and Remate Loading
,_' usiness Inance .} Hobbies & Crafts cience + §8.95/manth
) Celebrities C Home ) Saniors « $45 setupfes WANVED
Cj Computers & Intamet © lIssues & Causes © Sports Learn More... Sign Up
O Family O Military O Teens
O Fashion & Beauty O Movies O Travel [iEOEI‘hES Plus
{_:1 Fitness O Music © Television | AN pony need your own
) Food ) Pets ) Women b dornain name yet?

= Ad-fres web site

» Share photos, post & resume %]

&] Dore 4 Internet
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Using a Free Web Site Creation Tool

Welcome, knitfiend2004 http: fwww ge ocities,com/ knitfiend2004

Yahoo! GeoCities

Limited time offer
Advanced Toolbox
File Manager

Upgrade to an Ad-fiee Site - Get a free, personalized domain (like www.your-name.com),

armail add to match, customizable designs, more storage space, password protection, and more!

Build My Web Site

B geocitizs.combaitiiend2004 Creating web pages is easy with these popular tools..

&7 Yahoo! GeoCities - Microsoft Internet Explorer =oE
File Edit View Favorites Tools Help o
@Back L > | Iﬂ |§ ; j-'search "f'_'."FavanLes G‘Meda €‘_3 > ;; % | ﬁ a

Az 8] tpjgecctes.yshon conf ¥8<
[

Figure 2-5; Add New Serice %E}}? Yahoo! PageWizards - fooy! Subditectories, HTML 2diting...
i 13 Build a personal home page quickly with this simple, Easy Upload
The easiest My Service step-by-step method. Try it! Transtar files fram yaur computer
way to View My Site - 7 Yahoo! PageBuilder HTHL Editor
beqi wasan 08 0 citi 62 combmitfian 42004 /.7 Design and customize pages easily with this powerful  Wite, or cut & paste HTML code,
egin ] and full-featured editor, Try itl ; e
Creating Senice Announcements f“?s'iam‘_';shﬁ L
nalyze your site's traffic 1eports.
our Web Getting Started Enhance My Web Site
V. . To begin creating your site, - Web Site Add-Ons . ; Submitnet Special Offer
site Is to choose one of the tools tathe  Spice up your web pages with Headlines, Maps, Counters, Sibmit your sile 10 gver
click the night. If you're new to building Stock Quotes, Weather, and more. h
web pages, try Yahoo!
Yahoo! PageWizards. : 90 day free trial >>
PageWizards Member Pages Directory
Resources Find interesting member sites, or list your own. e — (]
link. i OMOTE YOUR WEBSITE! L)
&l & Internet
] Yahoo! GeoCities - Microsoft Internet Exploter BE=]
File Edit View Favorites Tools Help o
@ Back * () Iﬂ |§ ; /- ' Search r. Favarites eMeda e? L~ ;; = |J ﬂ a
peiress 8] btligente.yshoo camivin ' B
Welcome, knitflend2004 http:/ www.qe e cities.com/knitfiend2004 ||
geocities.com/knitfiend2004 GeoCities Free
Home > PageWizards
" Yahoo! PageWizards
Pagevizards are a fun and fast way to make cool web pages. Just angwer a few Build a multi-page site in minutes -
questions and build a professional-looking web paga in minutas. no coding required! hMove up to a
; ! ing plan.
Quick Start - Eight designs to choose from and just four easy steps. b W
Setup Fee Waived!
Linited time offer |
— Featured Themes
. ' Photo Page
Flglll'e 2-6: Include a message
The Yahoo! Might “isi Disk Dri :Egt:g Ia?rtiight
. i ision isk Drive
PageWIZards captions. Choose
from eight designs,
tool offers e
a selection :
of page Tribute Page -
themes e leveliisla = winkiive loctl]

& Internet
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7. Click any of the theme links shown in Figure 2-6 (for example, you
can click Fun D’Mental).

A theme is a named set of characteristics — color, layout, and so on.
A window titled Yahoo! Quick Start Web Page Wizard appears (see
Figure 2-7).

&1 Yahoo! Quick Stant Page Wizard [knitfiend2004@hnp: 'www.geocities.com/knitfiend200... =/ 2B

¥ Build your Quick Start Page Help  Send Feedback

Welcome to Yahoo! Wizards

Yahoo! Wizards will walk you through 4 simple steps to build
your own Guick Start Page. This should only take you about & to
10 minutes

If you choose to skip & step, the section will be removed from

your page

Figure 27 Click the "Begin” buttan below to start building your page

The Yahool [ gm u n undin ur 3

Quick Start

Web Page

Wizard is Copyright @ 2003 Yahoo! Inc.

ready for All Rights Resened.

you to begin

building Cancel ((Begin |

your Web

page.
Themes are sometimes referred to as styles or templates.

\

P To see what your Web page looks like at any stage of the building
process, click the Preview button located near the bottom of the Yahoo!
Quick Start Web Page Wizard window.

8. Click the Begin button located at the bottom of the screen.
The screen shown in Figure 2-8 appears.
9. Click one of the radio buttons shown in Figure 2-8 to choose a theme

(style) and click Next.
For example, you can choose Fun D’Mental, Techie, or Night Vision.
(If you wait a few seconds after clicking a style button, a preview of that
style appears on the left-hand side of the screen.)

<P Does this step sound familiar? It should. You chose a theme, or style, for

your Web page in Step 7. Unfortunately, Yahoo! Quick Start Web Page
Wizard requires you to specify the style you want for your Web page
again! If you want, you can use this opportunity to change your mind
and select a different style.
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&]Yahoo! Quick Start Page Wizard [knitfiend2004@http:/'www.geocities.com/knitfiend200... =) 2/E

¥ Build your Quick Start Page Help  Send Fesdback

Mo Choose alook for your page

Click on a button below to choose a style for your page.

2 SEEEERT e & Fun D''Mental C Classic Tan
mmimtaa . —
SR O Techie O Classic Blue
(' Lt

e O Night Vision O Countryside
SEees KR e
Sl (O Disk Drive O Great Outdoors
oo
Figure 2-8:
ChOOSing a Copyright @ 2003 Yahoo! Inc.
|00kf0r your All Rights Resened.
Web page is
as easy as Preniew ][ Cancel ] l < Back “ IMext > ]
clicking a
button.
10. In the next screen, type the text you want to appear at the top of your
Web page into the Enter Page Title field (see Figure 2-9). Type the text
you want to appear in the middle of your Web page into the Enter
Text field. When you’re ready, click Next.
)
2] Yahoo! Quick Start Page Wizard [knitfiend2004@htip:/'www.geocities.com/knitfiend200... EI
E Build your Quick Start Page Help  Send Feedhack
Abgit e o Enter your page title and text
B ¥ Withat do you want to say? Type a title for your page and the text
et you want people to read,
2 e e
= Enter page title:
0| ArApouAmadiios
S o : .
)
o Enter teut:
M CONCESEY To popular opinion,
armadillos are actually
quite gentle creatures.
pyright @ 2003 vahoo! Ing.
Figure 2-9: All Rights Resened.
Adding a
page title Preniew ][ Cancel ] l < Back “ IMext > ]
and content
(text).
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11. In the next screen (Figure 2-10), add a picture to your Web site by

choosing the Use Your Own Image radio button and then clicking the
Upload New Image button. When the Upload Image dialog box
appears, type the fully qualified name of an image file in the field
next to the Browse button and click the Upload button.

A fully qualified filename includes both the filename and the directory in
which that file resides on your computer: for example, c: \photos\
ralph.gif is the fully qualified filename of a file (ralph.gif) located
in the photos directory, which is located in turn on the c: drive.

If you're not sure whether you have image files or where those files
might be, you can click the Browse button shown in Figure 2-10.

&1 Yahoo! Quick Stant Page Wizard [knitfiend2004@hnp: 'www.geocities.com/knitfiend200... =/ 2B

¥ Build your Quick Start Page Help  Send Feedback

@) Pick your picture

@ Use your own image
IP_'C_k fram your account
[sketchgit [ preview image
OR
| Uplosd new image...

O Use the template’s default image - preview image

Figure 2-10: C Don't use an image
Adding a _ _
. Picture caphion:

picture to conyzjglnéznz‘zn":i;:u::! Inc. Emecilla-diavn skeich

your Web

site,

COIT]p'ete Preview “ Cancel ] l < Back “ INext > I

with a

caption.

¥ The kinds of image file formats that work best in Web pages are JPEG,
GIF, and PNG files. (For the skinny on using images in Web pages, check
out Book I, Chapter 4.)

® You can choose not to include a picture on your page by choosing the

Don’t Use an Image radio button. To use a picture ready-made by
GeoCities, choose the Use The Template’s Default Image radio button.
(The ready-made picture is the goofy-looking cartoon face you see next
to the big 2 in Figure 2-10, but hey — if you don’t happen to have a pic-
ture file of your own on hand, a goofy-looking cartoon face may be
better than nothing!)
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3 7 Using a Free Web Site Creation Tool

12.

Type a few words of descriptive text in the Picture Caption field and
click Next.

The screen shown in Figure 2-11 appears.

&1 Yahoo! Quick Stant Page Wizard [knitfiend2004@hnp: 'www.geocities.com knitfiend200... =/ 2B

¥ Build your Quick Start Page Help  Send Feedback

€ Enter your favorite links

Type in your favorite links, Visitors to your page will then be able
to go to these pages. Below are some suggested links, You can
change or delete these.

Marne your favorte links section:
All-Star Armadillo Links

Figure 21 Link Mame Web Address

Addlng links (ex. My favorite page)  (ex. www. yahoo.com)
from your 1. Armnadillo recipes wnw, armadillorecipe:
Web page Convzjglh;znz;?i;:w:! Ine. 2, Ammadillo gear W, BIMEEEE COm

to Other 3. Greatphotos weivw.armadillopiecor
Web pages i

makes the

Web gO Freniew H Cancel ] |_ < Back “ lexdt » ;
‘round.

13. Add links from your Web site to others by typing a descriptive name
for the link in the Link Name field and the URL of the link in the cor-
responding field marked Web Address (refer to Figure 2-11). If you
want, you can also type a heading for your link section in the field
called Name Your Favorite Links section.

14. Click Next.

The screen in Figure 2-12 appears.

15. Add contact information to your site by typing your name and e-mail
address into the Your Name and Your Email Address fields. Click
Next.

Adding contact information to your Web site is a good idea, especially if
you're creating a business or community-oriented site.
P Even if you're setting up a personal Web site, you’ll want to create a spe-

16.

cial e-mail address just for your e-mail from your Web site. If you put
your personal e-mail address on the Web for all to see, you’ll be deluged
with junk e-mail.

In the next screen, name your page by typing a short, descriptive
name into the Page Name field (see Figure 2-13).
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@ Yahoo! Quick Stant Page Wizard [iulIlﬂeudzom@hup:.-'l‘www.geocltles,com&nﬂﬂend!ul}.-. =oE

E1 Build your Quick Start Page Help  Send Fesdback
Abgye @) Enter your information
Mame your persanal info saction
All About el
Y our name:
R Madillo

our email address:
armadillo@emilyw.com
(ex, youmarme@yzhoo, com)

Let peaple know when you are online. If you have Yahoo!

Flgu_re 212 Co"”xﬂ"&,ﬁfﬂi;ﬂﬁ! e Messenger, this indicator will let visitors send you an instant
Addlng message,

contact -

; : [CIPut this on my page
|nf0rmat|0n Send fie 0 nEssege

to yourWeb l Preview ][ Cancel ] [ < Back “ Iext > !
site.

17. Click Next.

Don’t bother adding an .htmor . htm1 suffix; Yahoo! GeoCities Quick
Start Page Wizard adds the appropriate extension for you.

The congratulations screen appears (see Figure 2-14), complete with the
URL of your brand-spanking-new Web page. As the wizard suggests, take a

second to jot down the URL on a piece of scratch paper. (You need this URL
to view your new Web page, which [ show you how to do in the next section.)

37

Online Web creation tools like the one demon-
strated in this chapter save your Web page files
directly to their Web server. What this means is
that your Web page is available on the Web as
soon as you create it. But this also means that
you don't have a copy of the file saved on your
own computer, which, depending on how para-
noid you are, may be a problem — or maybe not.

Web creation tools that you install on your own
machine work differently. In the case of a Web

Keeping copies of your files

editor such as FrontPage, for example, you save
your Web pages files to your own computer
and then transfer, or upload, those files to a
Web server in a separate step. Although this
approach requires a bit more work on your part,
you can be sure you have a copy of your file
saved on your own machine in case you need it.
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38 Viewing Your First Web Page — Live

€] Yahoo! Quick Start Page Wizard [knitflend2004@http: 'www.geocities.com/knitfiend200... =2/ &

¥ Build your Quick Start Page Help  Send Fesdback

Name your page

Type in a name for your page or use the one suggested below.
This name will be part of your page’s web addrass, which will be
used when your fiends view your page

FPage name: q_rmud_i[!_\:_l

(example: My_page or mypage)

Copyright @ 2003 Yahoo! Inc.
All Rights Resenved.

Figure 2-13:
Naming Preview ][ Cancel ] l < Back H INext >
your Web
page.

€] Yahoo! Quick Start Page Wizard [knitflend2004@http: 'www.geocities.com/knitfiend200... =2/ &

¥ Build your Quick Start Page Help  Send Fesdback

Congratulations!

“fou have finished creating your own Quick Start Page. You and
your fiiends can now view your page at the web address below!

Please write down your web address for future reference.

Figure 2-14:
Yee-haw!
The Web
page is Copyright @ 2003 Yahoo! Inc.
Completed All Rights Resened.
and ready to
view at the
URL listed
on screen.

Viewing Your First Web Page — Live

To view your newly created Web page, type the URL (Uniform Resource
Locator) of your Web page into your browser’s address field and click
Return.
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Figure 2-15 shows a newly created Web page as it looks loaded into Book |
Microsoft Internet Explorer. Chapter 2
w
=l Al r A A i W soft Inte - "'.u | E
- File Edit View Favorites Tools Help gé
O © MR G P frraoes @ @3- H L) EHEH @ S
: fddrese | 8] hktp:ffwinw.geocities, comhitFiend2004]armadilo. bkl v/ B @ -=-|‘-|
b 2

All About Armadillos

All-Star Armadillo
Links

Figure 2-15:
Loading
your first
Web page
into a Web
browser.

All About Me!

5| Done, but with errars on page.
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Chapter 3: Exploring the Essential
Elements of Web Page Design

In This Chapter

v~ Starting an HTML page

v+ Adding headings and titles

v+ Formatting text

v~ Creating lists and tables

v Specifying page and background settings

+» Adding navigation tools and links

ou can think of HTML as a kind of primitive word-processing language

for Web pages. HTML defines a bunch of directives, or tags, that you
use to surround individual Web page elements to tell the browser how to
display those elements. For example, if you want to display a paragraph in
italics, you surround that paragraph with the beginning and ending HTML
italic tags <I> and </ I>. Book Il describes what you can do with HTML in
detail; this chapter gives you a quick overview of the most essential, most
popular features to get you up and running in record time.

HTML Basics

HTML defines two types of tags: beginning tags and ending tags.

4+ Beginning tags, as you may guess, tell a Web browser to begin some
kind of formatting process. For example, <B> tells a Web browser to
begin displaying text in bold font.

4+ Ending tags tell a Web browser to stop a particular formatting process.
Ending tags are identical to beginning tags except for one tiny detail:
Ending tags sport a backslash just after the opening angle bracket, like
this: </B>

The following HTML code snippet shows you how the beginning and ending
tags look in a typical HTML file:

This text will appear in regular font.
<B>This text will appear in bold font.</B>
This text will appear in regular font.
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Adding Text

Most HTML tags come in the beginning-ending pair, but not all.

Now that you’re familiar with beginning and ending tags, you're ready to take
a look at the bare-bones tags that virtually all HTML documents contain.

<HTML>
<HEAD>
<TITLE>Your title goes here</TITLE>
</HEAD>
<BODY>
The body of your document goes here.
</BODY>
</HTML>

Here’s an explanation of each of these tags:

4+ The <HTML> tag always appears as the very first thing in an HTML docu-
ment. It tells the browser that the file is an HTML file.

4 The <HEAD> and </HEAD> tags mark the section of the document
called the header, which contains information that applies to the
entire document.

4 The <TITLE> and </TITLE> tags mark the document title. Any text that
appears within the <TITLE> and </TITLE> tags is used as the title for
your HTML document.

4+ The <BODY> and </B0DY> tags mark the beginning and ending portions
of your document that is displayed by the browser when the page is
viewed. In most HTML documents, a lot of stuff falls between the
<BODY> and </BODY> tags.

4 The </HTML> ending tag is always the last tag in your document.

Adding Text

WING/

To add text to an HTML document, you place the text you want to add
between the beginning <BODY> and ending </B0ODY> tags:

<BODY>

A1l the text for this Web page goes right here. You can
surround this text with many different HTML tags to
format it attractively.

</BODY>

You typically include many HTML tags in a Web page — not just the
required tags, which [ describe in the preceding “HTML Basics” section, but
also a handful of formatting tags to make your Web page look attractive.
With all those angle brackets (<. . .>) lying around, you may find yourself
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accidentally slipping text inside an HTML tag. If that happens, you may be
surprised when you try to load your Web page and the text doesn’t display!
So, for example, the following text does not appear on the screen when the
HTML snippet loads:

<BODY Text inside tag declarations is NOT displayed
onscreen.></B0ODY>

Instead, make sure that text falls between tags:

<BODY>Text placed properly between tag pairs IS displayed
onscreen.</B0ODY>

Aligning text

HTML doesn’t give you many options for aligning text. By default, text is left
aligned on the page. But you can use the <CENTER> tag to specify text to be
centered, as in the following example:

CCENTER>This text is centered.</CENTER>

For more precise control of text alignment, use the text-align style property.
It gives you four text-alignment options: left, right, center, and justify. The
following example creates a right-aligned heading using the <H1> tag:

<H1 STYLE="text-align: right">This heading is right
aligned.</H1>

In the preceding HTML code, double quotes (") surround the value
assigned to the STYLE attribute of the <H1> tag. You can assign values

to tag attributes — a process some folks refer to as defining an attribute
inline — for many HTML tags. Just remember that when you do, you need
to include the double quotes.

For more information about using the STYLE attribute to create different
display styles, see Book II, Chapter 8.

Specifying headings

Don't fill your Web pages with a constant stream of uninterrupted text.
Instead, use headings and paragraphs to organize the content on each page.
The HTML heading tags make creating headings that break your text into
manageable chunks easy.

You can include up to six levels of headings on your Web pages by using the
HTML tags <H1>, <H2>, and so on through <H6>. The following snippet of
HTML shows all six heading styles in use. It also shows the basic paragraph
tag, <P>. Adding a paragraph causes a browser to display a vertical double-
space directly after the text, as you see in Figure 3-1.
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Figure 3-1:
Six levels of
headings
plus one
normal text
paragraph.

<H1>This is
<HZ2>This s
<H3>This is
<H4>This is

heading 1</HI1>
heading 2</H2>
heading 3</H3>
heading 4</H4>
<H5>This is heading 5</H5>
<H6>This is heading 6</H6>
<P>This is a normal text paragraph.</P>

[eSiNel N el N e N e} i @})

Figure 3-1 shows how this HTML appears when displayed in Internet
Explorer 6.

N
&7 Clewpeode bkifig31.him - Microsoft Internet Explorer =oE
File Edit View Faverites Tools Help o
p " - n »
@Back L > | Iﬂ |§ 4l Search 7 Favorites & |
Aciress @) Cilempeodelpkifs3t b v Be

This is a heading 1
This is a heading 2

This is a heading 3

This is a heading 4

“This is 2 heading 5

i is s heading 6

This 1z a normal text paragraph.

A\

Each Web browser uses its own point sizes for displaying the various heading
levels, and most browsers use huge type for the highest heading levels —
<H1> and <H2>. Fortunately, you can override the browser’s type size by
using styles as described in Creating Web Pages For Dummies, 6th Edition, by
Bud Smith and Arthur Bebak (published by Wiley Publishing, Inc.).

Changing text appearance

In addition to changing font face, size, and color (see “Changing fonts,” later
in this section, for details), you can make text appear bold or italicized.
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Bold

You can use the <B> tag to format your text in boldface type. Add a <B> tag
immediately before the text you want to appear in boldface. Then, turn the
boldface off by adding a </B> end tag. For example:

This is <B>bold</B>.

Italic

You can use the <I> tag to format your text in italic type. Add an <I> tag
immediately before the text you want to appear in italic. Then, turn the italic
typeface off by adding an </ 1> end tag. For example:

This is <I>italic</I>.

Changing fonts

HTML has two tags that let you control font settings: <FONT> and
<BASEFONT>. The <FONT> tag lets you control font settings for an individual
block of text, whereas the <BASEFONT> tag sets the default font used for a
document. Attributes are description-value pairs joined by an equal sign
(for example, FACE=Arial), and you can use attributes to fine-tune HTML
tags. The following list explains the most important attributes of the <FONT>
and <BASEFONT> tags.

Many HTML tags come in pairs, but not all. <BASEFONT>, for example, con-
tains only the beginning tag; no corresponding </BASEFONT> tag exists.

4 FACE: Sets the typeface.

4 SIZE: Gives the type size on a scale of 1 to 7, where 7 is the largest and
1 is the smallest. The default size is 3.

4 COLOR: Sets the color of the text. (For more information about using this
attribute, see the section “Adding Color,” later in this chapter.)

Here is a snippet of HTML that sets the typeface used for text on a Web page:

<BODY>

<BASEFONT SIZE=4 COLOR=BLACK FACE="Times New Roman">

<P>This is normal body text using the font set by the
BASEFONT tag.</P>

<HI><FONT FACE="Arial">This is a heading</FONT></H1>

<{P>After the heading, the text reverts to the BASEFONT
setting.

/P>

</BODY>

Figure 3-2 shows how this HTML appears when displayed in a Web browser.
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Figure 3-2:
Using the
<FONT>
and <BASE
FONT>
tags to
modify the
appearance
of text.

N
&1 Clewpeode bk1fig32.him - Microsoft Internet Explorer =oE
File Edit View Faverites Tools Help o
p " - n »
@Back - ) Iﬂ |,‘:I' g - search 5[ Favarites &i
Acdiress &) Cilempeodolekifisx v Be

Tlus 12 normal body text g the font set by the BASEFONT tag.

This is a heading

After the headmg, the text reverts to the BASEFONT setting.

A\

Because the stock fonts that ship with operating systems vary, good pro-
gramming practice dictates that you include at least a couple of font choices
every time you specify a font face. For example, the following HTML snippet
tells a Web browser to look first for the Helvetica typeface (which comes
installed with Macintosh computers) and, if Helvetica can’t be found, to look
for the Arial typeface (which comes installed with Windows computers).
Make sure that you separate typefaces with commas, as shown in the follow-
ing line of code; you can specify as many typefaces as you like.

<FONT SIZE="2" FACE="helvetica, arial, sans-serif">

Both the <FONT> and <BASEFONT> tags are superseded by an even better
method of setting fonts and other typographical options: style sheets. For
more information about how to use styles, check out Book II, Chapter 8.

Creating line breaks

HTML ignores line endings in an HTML document. As a result, you can’t
insert line breaks just by pressing the Enter key when you create an HTML
document. For example, the following lines of text in an HTML document
produce just one line of text rather than two:

HTML ignores
line endings.
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To force a line break, use a <BR> tag where you want the line break to occur,
as in this example:

HTML pays attention<BR>
to the Tine break tag.

Many HTML tags come in pairs, but not all. <BR>, for example, contains only
the beginning tag; no corresponding </BR> tag exists.

Adding Color

You can specify colors in various HTML tags. For example, <BODY> has a
BGCOLOR attribute that lets you specify the background color for your page.
You can also use the COLOR attribute in a <FONT> tag to set the text color.

Standard HTML defines 14 color names that you can use to set a predefined
color. The easiest way to set color is to use one of these color names. For
example, to create yellow text, you can use a <FONT> tag this way:

<FONT COLOR=YELLOW>This text is yellow.</FONT>

For more precise color control, you can specify a color by using a six-digit
hexadecimal number to indicate the exact mixture of red, green, and blue
you want to use — kind of like mixing paint from a palette containing globs
of red, green, and blue. The first two hexadecimal digits represent the
amount of red, the next two represent the amount of green, and the last two
are for blue. A value of 00 means that the color is completely absent, and FF
means the color is completely saturated. A pound sign (#) must precede the
entire six-digit color string. For example, you can replace the HTML tag
<FONT COLOR=YELLOW> shown in the previous example with <FONT
COLOR="#FFFF00">. The result is the same: nice, bright, yellow text.

Hexadecimal numbers are made up of the digits 0 through 9 and the letters
A through F. For example, 14, 3F, B9, and AC are valid hexadecimal numbers.

Here are the 14 standard HTML color names along with their corresponding
hexadecimal color strings:

Black #000000 Green #008000
Silver #C0COCO Lime #00FF00
Gray #808080 Olive #808000
White #FFFFFF Yellow #FFFFO0
Maroon #800000 Navy #000080
Purple #800080 Teal #008080

Fuchsia #FFOOFF Aqua #00FFFF

Book |
Chapter 3

ufisaq afied qap jo
sjuawa|j |enuassy
ay) buuojdxg



48

WMBER
‘x&
&

Changing the Background

These standard colors, sometimes referred to as Web-safe colors, appear the
same in all browsers. (Thanks to hardware and software differences, other,
non-Web-safe colors do not always appear the same when loaded into two dif-
ferent browsers.) So to be compatible with as many browser versions as pos-
sible, stick to these 14 standard Web-safe colors. (Both Internet Explorer 6
and Navigator 6 support additional color names.)

Watch out for color combinations that result in illegible text. For example,
avoid maroon text on a purple background or green text on an olive
background.

Changing the Background

When creating Web pages, you don’t have to settle for white: You can use
colors and images to create an interesting, attractive background.

One caveat, though: Keep readability in mind when you choose a back-
ground. If you use a background image for your pages, choose an image that
doesn’t interfere with the text and other elements on the page. By the same
token, if you'd rather use a background color, select a neutral color such as
white, light gray, or one of those infamous earth tones: These colors help
your visitors read your text without eye strain.

Setting the background color

To set the background color of your Web page, follow these steps:

1. Create the following <BODY> tag at the start of your document:
<BODY BGCOLOR=>

2. Type a color name or a hexadecimal color value for the BGCOLOR
attribute into the tag you created, insert the text for your Web page,
and then add a closing </B0DY> tag.

For example:

<BODY BGCOLOR="white">
The body of your Web page goes here
</BODY>

This tag sets the background color to white.

For more information about using color, see the “Adding Color” section,
earlier in this chapter.
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Using a background image

To use a background image for your Web page, follow these steps:

1. Create the following <BODY> tag at the start of your document:
<BODY BACKGROUND=>

2. Type the name of the image file you want to use for the background
as the BACKGROUND attribute value:

<BODY BACKGROUND="bgpic.gif">

This tag uses the file bgpic.gif as a background picture. Note that GIF
images are the preferred type for background images, because they
keep the file size small, which in turn helps pages load faster.

The background image repeats as many times as necessary to completely
fill the page. Avoid background images that use loud colors or bold designs;
such images can overpower the text on your page, rendering your page next
to unreadable.

For more information about creating and using images, check out Book I,
Chapter 4.

Creating Visual Interest with Horizontal Rules

SMBER
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Horizontal rules are horizontal lines you can add to create visual breaks on
your Web pages. To add a rule to a page, you use the <HR> tag. You can con-
trol the height, width, and alignment of the rule by using the SIZE, WIDTH,
and ALIGN attributes. For example:

<HR WIDTH="50%" SIZE=6 ALIGN=CENTER>

Many HTML tags come in pairs, but not all. <HR>, for example, contains only
the beginning tag; no corresponding </HR> tag exists.

In this example, the rule is half the width of the page, six pixels in height,
and is centered on the page.

Many Web designers prefer to use graphic images rather than the <HR> tag
to create horizontal rules. Because different Web browsers display the <HR>
tag differently, using an image for a rule enables you to precisely control
how your rule appears on-screen. To use an image rule, follow these steps:
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Organizing Information into Lists

1. Type an <IMG> tag where you would normally use an <HR> tag to
create a horizontal rule:

<IMG>

2. Type the name of the graphic file that contains the image rule in the
<IMG> tag’s SRC (shorthand for source) attribute:

<IMG SRC="grulel.gif">

3. Add a WIDTH attribute that specifies the number of pixels you want
the rule to span or a percentage of the screen width:

<IMG SRC="grulel.gif" WIDTH="100%">
4. Follow up with a <BR> tag to force a line break:
<IMG SRC="grulel.gif" WIDTH="100%"><BR>

Organizing Information into Lists

Using HTML, you can create two basic types of lists for your Web page.
4+ Bulleted lists: In a bulleted list, each item in the list is marked by a
bullet character (typically a dot).

4 Numbered lists: Each item in a numbered list is marked by a number.
The Web browser takes care of figuring out which number to use for
each item in the list.

HTML also lets you create several other types of lists, known as menu lists,
directory lists, and definition lists. Because these types of lists aren’t as
commonly used as bulleted and numbered lists, they aren’t described here.

Bulleted lists

A bulleted list (more properly called an unordered list) requires you to use
three tags:
4 <UL> marks the beginning of the unordered list.

4 <LI> marks the start of each item in the list. No corresponding </L1>
tag is needed.

4+ </UL> marks the end of the entire list.

Here is a snippet of HTML that sets up a bulleted list:
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<H3>The Inhabitants of 0z</H3>

<UL>

<LI>The Scarecrow

<LI>The Tin Man

<LI>The Cowardly Lion

<LI>Munchkins

<LI>The Wizard

<LI>The Wicked Witch of the West (WWW)
<LI>GTenda

</UL>

Figure 3-3 shows how this list appears when displayed in a browser.

&1 Clewpeode bk1fig33.him - Microsoft Internet Explorer BEx]
File Edit View Fawvorites Tools Help o
@ Back = () Iﬂ |§ ; /- ! search :. Favorites = & fifs b
diess &) Cenpendsipkifigss i v Be
The Inhabitants of Oz
» The Scarecrow
o The Tin Man
« The Cowardly Lion
+ Munchlens
o The Wizard
o The Wicked Witch of the West (AW
« Glenda
Figure 3-3:
You use
<UL>
</UL> to
create a
bulleted list.
Numbered lists

A numbered list (more properly called an ordered list) requires you to use
three tags:
4 <0L> marks the beginning of the ordered list.

4 <LI> marks the start of each item in the list. No corresponding </LI1>
tag is needed.

4 </0L> marks the end of the entire list.
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Here is an HTML snippet that creates a numbered list:

<H3>The Inhabitants of 0z</H3>

<OL>

<LI>The Scarecrow

<LI>The Tin Man

<LI>The Cowardly Lion

<LI>Munchkins

<LI>The Wizard

<LI>The Wicked Witch of the West (WWW)
<LI>GTenda

</0L>

Figure 3-4 shows how the numbered list appears when displayed in a

browser.

&1 Clewpeode bkifig34.him - Microsoft Internet Explorer BEx]
File Edit View Favorites Tools Help o
@Back L > | Iﬂ |§ ; j_'search :. Favorites * &I. e
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The Inhabitants of Oz

The Scarecrow

The Tin Man

The Cowardly Lion

Munchlons

The Wizard

. The Wicked Witch of the West (WWW)
. Glenda

HNow bW

Figure 3-4:
You use
<O0L>
</0L>to
create a
numbered
list.

Creating Links

Links are an integral part of any Web page. Links let your reader travel to a
different location, which can be a part of the same HTML document, a differ-
ent page located on your Web site, or a page from a different Web site
located elsewhere on the Internet. All the user has to do to be transported
to a different page is click the link.
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Using text links
A text link is a portion of text that someone viewing your page can click to
jump to another location. To create a text link, follow these steps:

1. Determine the address of the page you want the link to jump to.

2. Type an <A> tag at the point on the page where you want the link to
appear.

In the <A> tag, use an HREF attribute (http reference URL) to indicate the
address of the page you want to link to. For example:
<A HREF="http://www.dummies.com">

3. After the <A> tag, type the text that you want to appear in your docu-
ment as a link:

<A HREF="http://www.dummies.com">The Official For
Dummies Web Page

4. Add a closing </A> tag:

<A HREF="http://www.dummies.com">The Official For
Dummies Web Page</A>

The text that appears between the <A> and </A> links is called the anchor.
The Web address that appears in the HREF attribute is called the target.

The anchor text displays on the Web page in a special color (usually blue)
and is underlined so that the person viewing the page knows the text is a
link.

If the target refers to another page at the same Web site as the page the link
appears on, you can use just the filename as the target. For example:

<A HREF="emerald7.html">See the Wizard</A>

When a user clicks the See the Wizard link, the HTML file named emerald7.
html appears on-screen.

Using graphic links

A graphic link is a graphic image that a user can click to jump to another
page or a different location on the current page. To create a graphic link,
follow the procedure described in the previous section. But in Step 3,
instead of typing text for the link, type an <IMG> tag that identifies the image
file to use for the link in its SRC attribute. For example:

<A HREF="emerald7.html"><IMG SRC="emerald.gif"></A>

In this example, the graphic image file named emerald.gif appears on-
screen. If a user clicks it, the browser displays the emerald7.html page.
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Linking within the same page
To create a link that simply moves the user to another location on the same
page, follow these steps:

1. Create the following <A> tag at the start of your document:
<A NAME="namehere">, replacing namehere with the name of
the section you want to link to.

In this example, the section name is “Top.”
<A NAME="Top">
2. Immediately follow the <A> tag with an </A> end tag.
The finished product looks like this: <A NAME="Top"><A/>

3. Create a text or graphic link to that section by typing the section
name, preceded by the # symbol, in the HREF attribute of a link.

Here is a snippet of HTML that creates a link that jumps to the location
named “Top.”

<A HREF="#Top">Go back to the top of the page<A>

Using Tables

Tables are a basic HTML feature frequently used for two distinct purposes.
The first is presenting information in a tabular format, in which it is obvious
to the user that a table is being used. The second is controlling a Web docu-
ment’s page layout, in which the user is (or at least should be) unaware that
a table is being used.

Creating a table requires you to use some very complicated HTML tags. For
that reason, setting up a table using an HTML editor such as FrontPage or
Dreamweaver is often easier. (FrontPage is covered in Book III, and
Dreamweaver in Book IV.)

Creating a basic table

The following steps explain how to set up a basic table in which the first row
contains headings and subsequent rows contain data:

1. Type a set of <TABLE> and </TABLE> tags in the Web document where
you want the table to appear:

<TABLE>
</TABLE>

2. Add a BORDER attribute to the <TABLE> tag to create a border and
establish its width in pixels.
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For example:

<TABLE BORDER=6>
</TABLE>

3. Create the first table row by typing a set of <TR> and </TR> tags
between the <TABLE> and </TABLE> tags:

<TABLE BORDER=6>
<TR>

</TR>

</TABLE>

This first row will hold the headings for the table.

4. For each column in the table, type a <TH> tag, followed by the text
you want to display for the heading, followed by a </TH> tag. Place
each of these heading columns between the <TR> and </TR> tags:

<TR>
{TH>Web Feature</TH>
{TH>Love It</TH>
{TH>Hate It</TH>
</TR>

5. Create additional rows for the table by typing a <TR> and </TR> pairs
of tags. Between these tags, type a <TD> tag followed by the text you
want to appear in each column in the row and then a </TD> tag.

For example, here are the tags and text you'd type to add a row to show
that 62 percent of Web users love tables and 38 percent hate them:

<TR>
<TD>Tables</TD>
<TD>62%</TD>
<TD>38%</TD>
</TR>

Putting all this together, here is the HTML for a table with four rows including
the heading row:

<TABLE BORDER=6>

<TR>
<TH>Web Feature</TH>
<TH>Love It</TH>
<{TH>Hate It</TH>

</TR>

<TR>
<TD>Tables</TD>
<TD>62%</TD>
<TD>38%</TD>

</TR>
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Figure 3-5:
Athree-
column,
four-row
table.

<TR>
<TD>Frames</TD>
<TD>18%</TD>
<TD>72%</TD>

</TR>

<TR>
<TD>Style Sheets</TD>
<TD>55%</TD>
<TD>45%</TD>

</TRY

</TABLE>

Figure 3-5 shows how this table appears when displayed in a Web browser.

&1 Cewpeode bk1fig35.htm - Microsoft Internet Explorer BEx]
File Edit View Favorites Tools Help i
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Web Feature Love Tt Hate Tt
Tables 6206 |38%
Frames [1s2s  [72%
Style Sheets [55% 45V

Using a table for page layout

You can use tables to set up a neat layout for the text and other elements
that appear on your Web pages. The following procedure shows you how to
set up a simple layout that provides for a page header area at the top of the
page, a sidebar area on the left side of the page, and a main text area in the
central portion of the page.



Figure 3-6:
Table layout
including
page
header,
sidebar
area, and
main text
area.

Using Tables 57

. Determine the dimensions of the layout you want to use.

Be sure to allow for empty “gutter” areas in your layout.

Figure 3-6 shows the layout used for this example.

Overall width: 780

Page Header Area height: 50

| | | |
1 1 1 1
1 1 1 1
1 1 1 1
1 1 1 1
1 1 1 1
1 1 1 1
. i i i
ETSK:eAbar i i Main Text Area width: 590 i
1 EX r.eal 1 1
width: 150 ! !
i i | |
1 1 1 1
1 1 1 1
1 1 1 1
Ii EI —i Gutter: 20 Gutter: 10—i
Gutter: 5 J

. Type a set of <TABLE> and </TABLE> tags to begin the table that will

establish your page layout. In the <TABLE> tag, use the WIDTH attrib-
ute to set the overall width of your page layout in pixels and include
the attributes BORDER=0, CELLSPACING=0, and CELLPADDING=0.

You set these attributes to 0 so that the table will not have borders or
extra space between the cells. CELLSPACING specifies the width of the
border between cells; CELLPADDING defines the space between the con-
tents of cells and those cells’ borders.

The <TABLE> tag should look like this:
<TABLE BORDER=0 CELLSPACING=0 CELLPADDING=0 WIDTH=780>

. Create a row for the page header area by adding the following tags

between the <TABLE> and </TABLE> tags:

<TR>

<TD BGCOLOR=YELLOW HEIGHT=50 COLSPAN=6>
<H1>Page Header Area</HI1>

</TD>

</TR>
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Using Tables

Use whatever color you want for the background color (BGCOLOR) and
set the HEIGHT attribute value to the height of the page header area you
want to provide for your layout. COLSPAN, which is short for columns to
span, specifies how many columns you want the page header to run
across.

. Add a set of <TR> and </TR> tags to use for the second table row,

which will contain the six columns required to set up the gutter and
text areas for the sidebar and main text portions of the page layout.

. Between the second set of <TR> and </TR> tags, add a set of <TD> and

</TD> tags for each of the three columns used for the sidebar area,
similar to these:

<TD BGCOLOR=SILVER WIDTH=5 HEIGHT=600
VALIGN=TOP>&nbsp</TD>

<TD BGCOLOR=SILVER WIDTH=150 VALIGN=TOP>Sidebar
Area</TD>

<TD BGCOLOR=STLVER WIDTH=5 VALIGN=TOP>&nbsp</TD>

Set the background color (BGCOLOR) to the color you want to use for the
sidebar background and set the WIDTH value to the width your layout
calls for. Also, use VALIGN=TOP so that any text you place in the
columns is aligned with the top of the cell rather than the middle. And,
for the first column only, use a HEIGHT attribute in the <TD> tag to set
the overall height of the page.

The text for the first and third columns uses a &nbsp (nonbreaking
space) character as a placeholder for the gutters. For the second
column, Sidebar Area is used as a placeholder.

. Add three more pairs of <TD> and </TR> tags to create the columns

for the main text area and its two gutter areas, similar to these:

<TD BGCOLOR=WHITE WIDTH=20 VALIGN=TOP>&nbsp</TD>

<TD BGCOLOR=WHITE WIDTH=590 VALIGN=TOP>Main Text
Area</TD>

<TD BGCOLOR=WHITE WIDTH=10 VALIGN=TOP>&nbsp</TD>

The HTML for the entire layout should look something like the following:

<TABLE BORDER=0 CELLSPACING=0 CELLPADDING=0 WIDTH=780>

<TR>

<TD BGCOLOR=YELLOW HEIGHT=50 COLSPAN=6>

<{H1>Page Header Area</H1>

</TD>

</TR>

<TR>

<TD BGCOLOR=SILVER WIDTH=5 HEIGHT=600
VALIGN=TOP>&nbsp</TD>

<TD BGCOLOR=SILVER WIDTH=150 VALIGN=TOP>Sidebar
Area</TD>

<TD BGCOLOR=STLVER WIDTH=5 VALIGN=TOP>&nbsp</TD>
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<TD BGCOLOR=WHITE WIDTH=20 VALIGN=TOP>&nbsp</TD>

<TD BGCOLOR=WHITE WIDTH=590 VALIGN=TOP>Main Text
Area</TD>

<TD BGCOLOR=WHITE WIDTH=10 VALIGN=TOP>&nbsp</TD>

</TR>

</TABLE>

7. Save the file and test the layout it creates using your Web browser;
adjust the settings if necessary until the layout looks just the way you
want it to.

Figure 3-7 shows how the layout appears in Internet Explorer 6.

8. To create a document based on the layout, open the file and save it
under a new name. Then, replace the Page Header Area, Sidebar
Area, and Main Text Area placeholders with the text and other page
elements you want to appear in these areas.
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Creating Navigation Bars

A navigation bar is a collection of text or graphic links that enables users to
work their way through a series of pages on your Web site easily. The navi-
gation bar appears in the same place on every page in the site so that the
user can easily find it.
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Creating Navigation Bars

You can create a navigation bar in several ways. The most common is to
create a table, placing a link in each cell of the table. An alternative is to create
a single GIF image for the entire navigation bar and then use that image in an
image map. For more information about how to do this, take a peek at Book I,
Chapter 4.

Deciding what to include in a navigation bar

Depending on the site, a navigation bar can include some or all of the follow-
ing links:

4+ Home: Takes the user to the site’s home page.

4+ Next: Takes the user to the next page in sequence when viewing a series
of Web pages.

4+ Previous: Takes the user to the page that precedes the current page
when viewing a series of pages.

4+ Up: Takes the user to the page at the next level up in the hierarchy of
pages.
4+ Help: Takes the user to a help page.

4+ Site map: Takes the user to a page that includes links to all the pages on
the site.

A navigation bar can also contain links to major sections of your Web site,
such as a Product Information section or an Online Catalog section.

Creating a text-based navigation bar

The easiest way to create a navigation bar is to use text links in a table. Each
cell in the table contains a link. The following bit of HTML shows how to
create a navigation bar with links to four pages (home, help, previous, and
next). (For more information about the <TABLE>, <TR>, and <TD> tags, see
the section, “Using Tables,” earlier in this chapter.)

<TABLE BORDER="0" CELLSPACING="0" CELLPADDING="0" WIDTH=800>
<TR>

<TD BGCOLOR="SILVER" HEIGHT="25" WIDTH="160" VALIGN="TOP">
<IMG SRC="bTank.gif">
</TD>

<TD BGCOLOR="SILVER"™ HEIGHT="25" WIDTH="100" VALIGN="TOP">
<A HREF="home.html">Home</A>
</TD>

<TD BGCOLOR="SILVER" HEIGHT="25" WIDTH="100" VALIGN="TOP">
<A HREF="help.html">Help</A>
</TD>



Figure 3-8:
A text
navigation
bar created
using an
HTML table.

Creating Navigation Bars o1

<TD BGCOLOR="STLVER"™ HEIGHT="25" WIDTH="100" VALIGN="TOP">
<A HREF="page3.html">Next</A>
</TD>

<TD BGCOLOR="SILVER"™ HEIGHT="25" WIDTH="100" VALIGN="TOP">
<A HREF="pagel.html">Previous</A>
</TD>

<TD BGCOLOR="SILVER" HEIGHT="25" WIDTH="240" VALIGN="TOP">
<IMG SRC="bTank.gif">
</TD>

</TR>
</TABLE>

This HTML table is set up so that the entire table is 800 pixels wide. The
table has a single row, which has six cells. The first and last cells contain the
image file blank.gif, which displays a blank cell; they provide the spacing
necessary to precisely position the four middle cells, which contain the text
links for the home, help, previous, and next pages.

Figure 3-8 shows how this navigation bar appears when positioned at the
bottom of a blank page.
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Introducing Frames

You have to modify the HREF attributes in the text links used for the Next
and Previous links on each page.

Using images in a navigation bar

You can create a navigation bar using images of the buttons that the user
clicks to move from page to page. Here is the HTML for a simple navigation
bar that uses two images of arrows, one facing left, the other right, to link to
the next and previous pages, with a simple two-cell table to position the but-
tons. (The images in this navigation bar are created as links within the cells
of a table. For more information about the <TABLE>, <TR>, and <TD> tags,
see the section, “Using Tables,” earlier in this chapter.)

{TABLE BORDER="0" CELLSPACING="0" CELLPADDING="0" WIDTH=50>
<TR>

<TD HEIGHT="25" WIDTH="25">

<A HREF="pagel.html"><IMG SRC="larrow.gif" BORDER="0"
HEIGHT="25" WIDTH="25"></A>

</TD>

<TD HEIGHT="25" WIDTH="25">

<A HREF="page3.html"><IMG SRC="rarrow.gif" BORDER="0"
HEIGHT="25" WIDTH="25"></A>

</TD>

</TR>
</TABLE>

In this example, both Tarrow.gif and rarrow.gif are GIF images 25 pixels
tall by 25 pixels wide that show a left and right arrow.

Introducing Frames

Frames enable you to divide a page into separate areas that each display the
contents of a separate HTML file. The advantage of using frames is that the
user can interact with each frame independently. For example, a frame that
contains a long text document can have its own scrollbars so that the user
can scroll through the document, and other elements of the page — such as
a navigation bar — remain on the screen.

The use of frames is an advanced HTML technique that enables you to
create several HTML files for each page. The first HTML file replaces the
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beginning and ending <BODY > tags with the beginning and ending <FRAMESET>
tags that indicate the arrangement of frames on the page. Between the
<FRAMESET> and </FRAMESET> tags, you use one or more <FRAME> tags to
create the actual frames. Each <FRAME> tag includes an SRC attribute that
names a separate HTML file that contains the contents of the frame. The
<FRAME> tag can also include additional attributes that indicate such things
as whether the frame has a visible border, scrollbars, and so on.

A <FRAMESET> tag can include a ROWS attribute to create frames stacked one
atop the other, or it can include a COLS attribute to create side-by-side
frames. In the ROWS or COLS attribute, you list the pixel size of each frame
you want to create. For the last frame, use an asterisk to indicate that the
frame should fill the remainder of the page. For example, the following
<FRAMESET> tag creates three frames side by side: The first is 150 pixels
wide, the second is 20, and the third fills the remainder of the page:

<FRAMESET ROWS="150,20,*">

In the <FRAME> tags, use the SRC attribute to indicate the name of the HTML
file that should appear in the frame.

The following examples show how you can use frames to set up a grid page
layout that has four layout areas: a page header area, a page footer area, a
left margin area, and a main text window that can be scrolled. Five HTML
files are required. The main HTML file contains the following lines:

<HTML>
<FRAMESET ROWS="75, *, 50" FRAMEBORDER=0 FRAMESPACING=0>
{FRAME SRC="frtop.html">
<FRAMESET COLS="150, *">
<FRAME SRC="frleft.html">
{FRAME SRC="frright.html" SCROLLING="YES">
</FRAMESET>
<FRAME SRC="frbottom.html" SCROLLING="NO">
</FRAMESET>
</HTML>

In the preceding code snippet, you see that FRAMEBORDER is set to 0, which
turns off visible borders between frames in the frameset. (A value of 1 turns
on visible borders.) FRAMESPACING is set to 0, too, which tells the browser
to insert no additional space between frames. The frtop.html, frbottom.
html, frieft.html,and frright.html files contain the HTML used to dis-
play the content of each frame. Figure 3-9 shows how these frames appear
in Internet Explorer 6 when each of the HTML files are empty except for a
<BODY> tag that specifies a background color to be used for the frame.
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Figure 3-9:
Aframe
containing
four layout
areas: page
header,
page footer,
left margin,
and scroll-
able main
text area.
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Frames are a troublesome HTML feature where browser compatibility is
concerned. The current versions of both Navigator and Internet Explorer
both support the <FRAME> and <FRAMESET> tags, but each has several
attributes that aren’t supported by the other. In addition, Internet Explorer
has a simpler method of creating inline frames by using an <IFRAME> tag.
Inline frames are floating frames that you can place inside a Web page, simi-
lar to the way you can place images inside a Web page. Although the
<IFRAME> tag is easier to deal with than the <FRAMESET> and <FRAME> tags,
Navigator doesn’t support the <IFRAME> tag.



Chapter 4: Working with Graphics,
Sounds, and Uideo

In This Chapter

v Understanding formats for image, sound, and video files
v Working with images

v Using image maps

1 Adding sounds and video clips to a Web page

v Creating transparent GIF images

A dding images, sounds, and movie clips to your Web pages can make

your pages come alive. Book V describes how you create multimedia
files. However, if you already have a few multimedia files and want to incor-
porate them into your pages, this is the chapter for you. Here you find the
guidelines and specific steps you need to add multimedia files to your Web
pages like a pro.

Getting Familiar with File Formats
for Image, Sound, and Video

You can choose from many different file formats for images, sounds, and
videos. Fortunately, you can construct almost all Web pages by using just
the formats that I describe in the following sections.

Image file
Although dozens of different image file formats exist, only two are widely
used for Web page images: GIF and JPEG.

GIF images

GIF, which stands for Graphic Interchange Format, was originally used on
the CompuServe online network and is now widely used throughout the
Internet. GIF image files have the following characteristics:
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+

GIF images can have a maximum of 256 different colors.

4+ GIF files are compressed to reduce their size. The compression method
GIF uses doesn’t reduce the image quality.

4+ A GIF image can include a transparent color, which, when displayed in a
Web browser, allows the background of the Web page to show through.

4+ GIF images can be interlaced, which allows the Web browser to quickly
display a crude version of the image and then display progressively
better versions of the image.

4+ GIF supports a simple animation technique that enables you to store
several distinct images in the same file. The Web browser displays the
animation by displaying the images one after the other in sequence.

4 GIF files usually have the .gif filename extension.

The GIF format is the best choice for most Web graphics that are created
with drawing or paint programs and that do not contain a large number of
different colors. It’s ideal for icons, buttons, background textures, bullets,
rules, and line art.

A format called PNG (Portable Network Graphics) was developed in 1995 as
a successor to the GIF format. PNG (pronounced Ping) supports all the fea-
tures of GIF and then some, including support for more colors than GIF. PNG
hasn’t really caught on, though, so GIF remains the most widely used image
format.

JPEG images
JPEG, a format developed by the Joint Photographic Experts Group, is
designed for photographic quality images. It has the following characteristics:

4+ JPEG images can have either 16.7 million or 2 billion colors. Most JPEG
images use 16.7 million colors, which provides excellent representation
of photographic images.

4+ To reduce image size, JPEG uses a special compression technique that
slightly reduces the quality of the image while greatly reducing its size.
In most cases, you have to carefully compare the original uncompressed
image with the compressed image to see the difference.

4+ JPEG supports progressive images that are similar to GIF interlaced
images.

4+ JPEG doesn’t support transparent background colors as GIF does.

+

JPEG doesn’t support animation.

4+ JPEG files usually have the . jpg filename extension.
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Other image file formats

Many other image file formats exist that don’t work on the Web. (To use a
graphic file saved in one of these non-Web-friendly formats, you must con-
vert the file to JPEG or GIF using a graphics program such as Jasc Software’s
Paint Shop Pro.) Here are just a few non-Web-friendly graphics formats:

4+ BMP: Windows bitmap

4+ PCX: Another bitmap format
4 TIF: Tagged Image File

4+ PIC: Macintosh picture file

You can find a trial version of Paint Shop Pro on the CD that comes with this
book.

Sound file formats
The following paragraphs describe the most commonly used sound file
formats.

4+ WAV: The Windows standard for sound recordings. WAV is short for
Wave.

4 SND: The Macintosh standard for sound recordings. SND is short for
Sound.

4 AU: The UNIX standard for sound recordings. AU is short for Audio.

4+ MID: MIDI files, which are not actually sound recordings but are instead
music stored in a form that a sound card’s synthesizer can play. MIDI
stands for Musical Instrument Digital Interface.

Don’t confuse sound files with sound you can listen to in real time over the
Internet, known as streaming audio. The most popular format for streaming
audio is RealAudio. RealAudio enables you to listen to a sound as it is being
downloaded to your computer, so you don’t have to wait for the entire file
to be downloaded before you can listen to it. To listen to RealAudio sound,
you must first install a RealAudio player (available at www.real.com) in
your Web browser. We explain how to play and record sound using
RealAudio in Book V.

Video file formats

Three popular formats for video clips are used on the Web:
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4 AVI: The Windows video standard. AVI stands for Audio Video
Interleaved.

4 QuickTime: The Macintosh video standard. QuickTime files usually
have the .mov extension.

4+ MPEG: An independent standard. MPEG stands for Motion Picture
Experts Group.

Although AVl is known as a Windows video format and QuickTime is a
Macintosh format, both formats — as well as MPEG — have become cross-
platform standards. Both Netscape Navigator and Microsoft Internet
Explorer can play AVI, QuickTime, and MPEG videos.

We explain how to play and create video files for the Web in Book V.

Inserting a Graphic Image

To insert a graphic image on a Web page, follow these steps:

1. Obtain an image file you want to include on your page, and store the
image file in the same directory as the HTML document that displays
the image.

If necessary, use a graphics program to convert the file to the format

W you want to use (GIF or JPEG).

To find out how to create images you can add to your Web pages, check
out Book V.

2. In the HTML file, add the <IMG> tag at the point in the document
where you want the image to appear and use the SRC attribute to
provide the name of the image file.

For example:
<IMG SRC="1imagel.gif">

Working with Graphic Images

Here are some guidelines for using graphic images wisely on your Web
pages:

4+ Don’t add so many images or such large images that your page takes too
long to download. As a general rule, try holding your breath while your
page downloads with a 28.8 Kbps modem. If you turn blue, the down-
load takes too long.



WING/
&

Carving Up Graphics with Image Maps 69

4 Use the ALT attribute with the <IMG> tag to provide text for users who
view your page with images turned off. For example:

<IMG SRC="chicken.gif" ALT="Picture of a chicken">

4 Use the HEIGHT and WIDTH attributes with the <IMG> tag to preformat
your pages for the correct image dimensions.

<IMG SRC="chicken.gif" HEIGHT=100 WIDTH=50>

4 Use the GIF format for most images created with drawing or painting
programs. Use the JPEG format for photographic images.

4 Use BORDER=0 in the <IMG> tag to eliminate the border that appears
around your images (unless you want the borders to appear):

<IMG SRC="chicken.gif" BORDER=0>

4+ Use transparent GIFs to create images that blend seamlessly with your
page background.

For more information about transparent GIFs, skip ahead to the “Using
Transparent GIF Images” section, later in this chapter.

4+ If you want to make large image files available for download on your
Web site, provide smaller, thumbnail versions of the images that people
can preview before deciding whether to download the full-size image.
Many graphics editing programs, including Paint Shop Pro, enable you
to create thumbnail versions of graphics files quickly and easily.

Keep in mind that many of the images you see displayed on the Web are
copyrighted materials that you cannot simply copy and use on your own
Web site without permission from the copyright holder. Similarly, photo-
graphs, artwork, and other images that appear in magazines and books are
copyrighted. (In other words, if you didn’t create the materials yourself or
purchase them, someone else owns them.) You cannot legally scan copy-
righted images and post them on your Web site without the copyright
owner’s permission. For the skinny on U.S. copyright law, check out www .
loc.gov/copyright.If you're not based in the United States, you may want
to check out The Canadian Intellectual Property Office at cipo.gc.ca, the
U.K. Patent Office at www.patent.gov.uk/copy/index.htm, or the
Australian Copyright Council Home Page at www.copyright.org.au.

Carving Up Graphics with Image Maps

An image map is a graphic image in which specific regions of the image
serve as links to other Web pages. For example, if you're creating a Web site
about The Wizard of Oz, you can use an image map showing the Scarecrow,
Tin Man, and Cowardly Lion to link to pages about these characters.
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Figure 4-1:
Use an
image with
at least two
distinct
regions as
an image
map.

To create an image map, you must use several HTML tags: <MAP> and its
companion </MAP>, <AREA>, and <IMG>. Here are the steps to follow to
create an image map:

1.

Find or create a graphic image that can serve as an image map.

The image should have distinct regions that will serve as the map’s
links.

For example, you can use the image you see in Figure 4-1 as an image
map that will provide two links: one for the dog, the other for the
woman.

Using your favorite graphic drawing program to display the image,
determine the rectangular boundaries of each area of the image that
will serve as a link. Write down the pixel coordinates of the top, left,
bottom, and right edges of these rectangles.

The example shown in Figure 4-2 shows these coordinates: 32, 367
(width) and 161, 554 (height). For suggestions on graphics programs
you can use, check out Book V.
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a graphic
program
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Most graphics programs display these coordinates in the program’s
status bar as you move the mouse around or when you use the selec-
tion tool to select an area. For example, Figure 4-2 shows an area
selected (using the crop tool) in Paint Shop Pro.

For the dog-and-woman image, the following coordinates define the
rectangular areas for the links:

Top Left Bottom Right
Dog 32 367 161 554
Woman 168 99 350 568

3. Type a set of <MAP> and </MAP> tags. In the <MAP> tag, use the NAME
attribute to provide a name for the image map:

<MAP NAME="IMGMAP1">
</MAP>

4. Between the <MAP> and </MAP> tags, type an <AREA> tag for each rec-
tangular area of the image that will serve as a link. In the <AREA> tag,
include the following attributes:

e SHAPE=RECT

e COORDS="top,
e HREF="url"

left,

bottom,

right"
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For example:

<{MAP NAME=IMGMAP1>
<AREA SHAPE=RECT COORDS="32,367, 161, 554"
HREF="dog.html">
<AREA SHAPE=RECT COORDS="168,99,350,568"
HREF="woman.html">
</MAP>

5. Type an <IMG> tag. Use the SRC attribute to name the image file and
the USEMAP attribute to provide the name of the image map listed in
the <MAP> attribute:

<IMG SRC="dog_and_woman.jpg" USEMAP="{#imgmapl">

Be sure to type a pound sign (#) before the image map name in the
<IMG> tag’s USEMAP attribute. But don’t use the # symbol when you
create the name in the <MAP> tag’s NAME attribute.

Putting it all together, here is a complete HTML document to set up an
image map:

<BODY>

<MAP NAME=IMGMAP1>

<AREA SHAPE=RECT COORDS="32,367, 161, 554" HREF="dog.html">
<AREA SHAPE=RECT COORDS="168,99,350,568"
HREF="woman.html">

</MAP>

<IMG SRC="dog_and_woman.jpg" USEMAP="{imgmapl">

</BODY>

Figure 4-3 shows how this page appears when displayed. Notice the border
around the image? That border lets you know that parts of the image are
clickable. Clicking the dog in Figure 4-3 loads the file dog.htm1; clicking the
woman loads woman.html. The in-between parts of the image — for exam-
ple, the trees over the dog’s head— are not clickable; in other words, click-
ing the in-between areas of the image doesn’t cause a new file to load.

Use the <TITLE> attribute in the <AREA> tags to create ToolTips that display
when the user pauses the mouse pointer briefly over an image map area.
For example:

<AREA SHAPE=RECT COORDS="32,367, 161, 554" HREF="dog.html"
TITLE="Panda the Wonder Dog">

<AREA SHAPE=RECT COORDS="168,99,350,568" HREF="woman.html"
TITLE="Panda's Human Companion">

Some people configure their settings so that their browsers do not download
and display images. Whenever you use an image map, be sure to provide
text links as an alternative to the image map. Otherwise, users who visit
your page with images turned off can’t navigate your site.



Figure 4-3:
A clickable
image map
displayed in
a browser.
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Using Transparent GIF Images
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Most graphics programs can create transparent GIF images, in which one
color is designated as transparent. When the image displays on your page,
the background color of the page shows through the transparent area. You
can also create sophisticated designs by stacking images of different trans-
parency levels on top of each other. (Imagine a stack of plastic overhead
transparencies, each containing a different image.)

Stackable images — whether transparent or opaque — are referred to as
layers in most graphics programs.

The procedures for setting the transparent color are similar in most graph-
ics programs. Follow these steps to set transparent color in Paint Shop Pro,
a trial version of which is included on the companion CD:

1. Open the image you want to make transparent.

2. Choose Layers->Properties.

The Layers Properties dialog box appears, as shown in Figure 4-4.
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3. Click the Opacity Selector in the Layers Properties dialog box and
choose an opacity setting from 0 (fully transparent, or invisible) to
100 (fully opaque).
The preview image changes based on your selection. For example,
Figure 4-5 shows the effects of choosing an opacity setting of 64.
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4. When you’re happy with the transparency of your image, click OK.

5. Choose Filer>Save to save the file with the transparent color
information.

To use a transparent background color, make sure that the image’s back-

\\3
ground consists of a single color and that the background color doesn’t
appear elsewhere in the image. You may need to fiddle with your paint pro-
gram’s painting tools to adjust the background of the image accordingly.
Incorporating Sounds

You can insert a sound file on a Web page in one of two ways: as a link or as
an embedded sound. The following sections show you how to use the HTML
tags necessary for each method.

You can also insert a sound as a part of the page’s background so that the
sound plays automatically whenever the page displays. Flip to the section
“Creating a background sound,” later in this chapter, for more
information.

To find out how to create sound files to include in your Web pages, check
out Book V.

Inserting a link to a sound file

Not everyone likes sound to play automatically. The advantage of linking to
a sound file is that it gives your visitors a choice. The sound file isn’t down-
loaded to the user’s computer until the user clicks the sound file link. To
insert a link to a sound file, follow these steps:

1. Obtain a sound file you want linked to your Web site.

2. Place the sound file in the same directory as the HTML document that
will contain the link.

3. Add an <A> tag, some descriptive text, and an </A> tag to the HTML
file as follows:

<A HREF="sound.wav">Click here to play the
sound.</A>

Be sure to type the name of your sound file in the HREF attribute.
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Embedding a sound file

Embedding a sound file displays sound controls (stop, play, and start) on a
Web page, allowing visitors to control when and how the sound file plays.
You can embed a sound on a Web page by using an <EMBED> tag as follows:

<EMBED SRC="sound.wav">

The SRC attribute specifies the name of the sound file.
égmmm
& Be sure to specify a fully qualified filename (one that includes the full path
to the file) if your sound file is located in a different directory than your
HTML file. For example: SRC="d:\mysite\mysounds\sound.wav"

Creating a background sound

A background sound plays automatically whenever a user displays your
Web page. To add a background sound to a page, follow these steps:

1. Obtain a sound file you want to use as a background sound.
2. Place the sound file in the same directory as the HTML file.

3. Add a <BGSOUND> tag following the document’s <BODY> tag. Use the
SRC attribute to name the sound file you want to be played:

<BODY>
<BGSOUND SRC="music.mid">

4. If you want the sound to repeat several times, add the LOOP attribute:
<BGSOUND SRC="music.mid" LOOP=3>

You can type any number you want in the LOOP attribute to indicate
how many times the sound should be repeated. You can use
LOOP=INFINITE to repeat the sound repeatedly as long as the page is
displayed.

@“\NG! Some people would rather listen to fingernails dragged across a chalkboard
8 than annoying background sounds that play over and over again. If you want
people like me to visit your site more than once, avoid LOOP=INFINITE like
the plague.

Incorporating Video Clips

You can insert a video file on a Web page in one of two ways: as a link or as
an embedded object. To find out how to create a video clip to add to your
Web page, see Book V.
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Inserting a link to a video

Inserting a link to a video clip enables your visitors to decide whether and
when to view your visual masterpiece. All your visitors need to do to view a
linked video is click the link. (To view an embedded video, on the other
hand, visitors need to click the embedded playback controls. Check out the
next section, “Embedding a video,” for details.)

Follow these steps to insert a link to a video file:

1. Locate a video file that you want to link to from your Web page.

2. Add an <A> tag, some descriptive text, and an </A> tag to the HTML
file as follows:

<A HREF="movie.avi">Click here to download a movie.</A>

Provide the name of the video file in the <A> tag’s HREF attribute.

When the user clicks the link, the Web browser downloads the file and plays
the video.

Embedding a video

Embedding a video differs from inserting a link to a video — which I describe
in the preceding section — in one very important respect: Embedding a
video automatically displays a video control panel your visitors can use to
stop, start, and pause video playback.

Use the <EMBED> tag to embed a video on a Web page. Follow these steps:

1. Locate a video file you want to embed on a Web page.

2. In the HTML document for the Web page, add an <EMBED> tag specify-
ing the name of the video file in the SRC attribute:

<EMBED SRC="movie.avi">

3. If you want to change the size of the area used to display the video,
add the HEIGHT and WIDTH attributes:

<EMBED SRC="movie.avi" HEIGHT=200 WIDTH=200>

4. If you want the video to play automatically as soon as it finishes
downloading, add AUTOSTART=TRUE to the <EMBED> tag:

<EMBED SRC="movie.avi" AUTOSTART=TRUE>

5. If you want the video to repeat, add a LOOP attribute to the
<EMBED> tag.

You can set the LO0P value to a number to cause the video to repeat a
specific number of times, or you can specify LOOP=INFINITE to cause
the video to replay over and over again as long as the page is displayed.
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Chapter 5: Building
Your Web Workshop

In This Chapter

+ Examining Web browsers

v~ Selecting an HTML editor
v Perusing Java, JavaScript, and multimedia tools
v Opting for office suites

v Choosing a graphics program

Wmther you're cooking, building furniture, or creating Web pages, the
right tool for the job can be a big help. Fortunately, an enormous

selection of Web tools is on the market today, ranging from free to pricey,
from general, all-purpose tools to unbelievably specialized wizards. For
every Web developer and every project, you can find the perfect tool.

In this chapter, we introduce you to some popular, useful tools you may
want to consider adding to your Web toolbox. Some of these tools are com-
mercial programs you must buy, and others are programs you can download
free from the Internet.

<WNECD

N The CD that comes with this book contains trial versions of several popular
commercial programs. I flag these with an icon so that you can find them
easily as you skim through this chapter.

Web Browsers

Two Web browsers are in widespread usage on the Internet. If you're a seri-
ous Web developer, you should have both of them so that you can make
sure that your Web pages work with both browsers.

Netscape 7.0

Netscape 7.0 is the complete package of Internet access tools from
Netscape, including the following components:

4+ Navigator, for Web browsing

4 Mail, for e-mail
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4+ Instant Messenger, for instant messaging
4+ Composer, for creating Web pages
You can download Netscape free, or you can purchase one of several

Netscape editions that includes additional software. You can also order
Netscape on CD-ROM for $2.95.

Price: Free

Web site: http://channels.netscape.com/ns/browsers/default.jsp

Internet Explorer 6

Internet Explorer 6 features the latest Web technologies from Microsoft:
Dynamic HTML (a combination of HTML, style sheets, and scripting tools
that enables you to create Web pages that respond to user interaction),
Visual Basic Scripting Edition (VBScript), channels, ActiveX (a language for
creating and plugging self-contained programs — similar to Java applets —
into Web pages), and more.

The complete Internet Explorer 6 suite includes the following components:

4+ Internet Explorer 6, for Web browsing
4 Outlook Express, for e-mail and newsgroups
4+ MSN Messenger Service, for instant messaging
4+ NetMeeting, for online conferencing
All these components are available to download from the Microsoft Web

site. (If you prefer, you can order Internet Explorer on a CD-ROM for about
$5 shipping and handling.)

Price: Free

Web site: www.microsoft.com/windows/ie/default.htm

Graphics Programs

Graphics programs are an essential part of your Web toolkit. You need a
graphics drawing program that can create images in either GIF or JPEG
format, and the program should be able to handle advanced features, such
as GIF transparent backgrounds, interlaced images, and animations.

The following sections describe several graphics programs you can use for
creating Web pages.
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Photoshop Lol

Chapter 5
Photoshop, from Adobe, is one of the oldest, best known, and most consis-
tently top-rated graphics programs around. As you might guess from the

name, Adobe Photoshop originally focused on helping professional photog- g o
raphers (and graphic designers) retouch and manipulate photos. These ; =
days, Photoshop offers much more: a full range of professional-strength s&
tools for graphic design and video as well as photography. E =

SE

Price: $649

Web site: www.adobe.com

CorelDRAW

CorelDRAW 11 Graphics Suite is one of the best suites of graphics programs
available. The relatively stiff price makes sense when you realize that the
comprehensive CorelDRAW 11 Graphics Suite package includes not just the
CorelDRAW drawing program, but Corel PHOTO-PAINT 2, Corel R.A.V.E. (Real
Animated Vector Effects 2), and a bunch of photos, fonts, and graphics util-
ity programs, as well.

Price: $529

Web site: www.corel.com

Paint Shop Pro

Paint Shop Pro 8, from JASC, Inc., is a powerful yet inexpensive painting pro-
gram you can download from the Internet to use free for a 30-day evaluation
period. If you like it, you can purchase it after the trial period. Paint Shop
Pro 8 has just about everything you could possibly want in an image draw-
ing program. It supports more than 30 graphic image formats, including, of
course, GIF and JPEG, and it includes sophisticated features, such as gradi-
ent fills, blur effects, and textured brush effects for creating stunning
images. Paint Shop Pro 8 also comes with Animation Shop for creating GIF
<MECD animations.

N
You can find an evaluation copy of Paint Shop Pro on the companion CD.

Price: $99 download or $109 on CD-ROM

0,

Web site: www. jasc.com
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Windows Paint

Paint is the free image drawing program that comes with Windows.
Beginning with Windows 98, Microsoft has beefed up Paint to make it suit-
able for working with Web images by supporting the GIF and JPEG file for-
mats. Paint can handle transparent background colors for GIF images, but it
cannot create interlaced GIF images or GIF animations.

Price: Included with Windows 98, 2000, and XP

Web site: www.microsoft.com

HTML Editors

9,

<ME CD

You can create HTML documents with a simple text editor, such as Notepad,
but for serious HTML work, you should invest in a more sophisticated HTML
editor, such as one of the programs described in the following sections. Most
HTML editors let you work in two modes:

4 Graphical WYSIWYG (What You See Is What You Get) mode lets you
create Web pages by dragging and dropping, like a cross between a
word processor and a drawing program.

4+ HTML mode lets you work directly with HTML tags and attributes. In
addition, many HTML editors generate not just HTML code, but also
simple JavaScript code, Java code, and more.

Dreamweaver

Dreamweaver MX 2004, from Macromedia, Inc., combines a text editor with
a visual development environment so that you can choose the Web page
creation style you're most comfortable with. A bonus for developers inter-
ested in creating animations for their Web sites: Dreamweaver is compatible
with Flash (Macromedia’s animation creation tool).

You can find an evaluation copy of Dreamweaver MX 2004 on the
companion CD.

Price: $399

Web site: www.macromedia.com/software/dreamweaver
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Composer

Composer is a free HTML editor that comes bundled with the Netscape Web
browser. Nifty toolbar buttons let you quickly add lists, tables, images, links,
colors, and font styles to your pages.

Price: Free download or $2.95 on CD-ROM

Web site: http://channels.netscape.com/ns/browsers/default.jsp

FrontPage 2003

FrontPage 2003 is the Microsoft full-featured Web site development tool. The
FrontPage 2003 WYSIWYG HTML editor enables you to use advanced HTML
features, such as layers and Cascading Style Sheets, and it enables you to
edit HTML tags and attributes directly. In addition, FrontPage 2003 includes
tools that let you manage and coordinate all the pages that make up your
Web site, including a feature that maintains your hyperlinks automatically.

Price: $199

Web site: www.microsoft.com/frontpage

HotDog Professional

HotDog Professional 7.0, made by a company called Sausage Software, is a
sophisticated code-based HTML editor that uses wizards to create HTML
tags for your documents. Unlike most HTML editors, HotDog Professional
7.0 lets you utilize advanced features such as style sheets, Java, and push
channels using Microsoft, PointCast, or Netscape channel technologies.
(Push channels work much like radio and television channels: They push, or
broadcast, content to users, rather than waiting for users to request content.
In contrast, traditional Web sites are considered pull channels, because users
must take a specific action, such as clicking a link, to download content.)

You can find an evaluation copy of HotDog Professional on the companion CD.
Price: $99.95 download or $129.95 on CD-ROM

Web site: www.Ssausage.com

Java and Animation Tools

If you're interested in creating Java applets (self-contained programs written
in the Java programming language) or flashy animations to add to your Web
pages, you want to invest in a top-notch development tool such as one of
the following.

Book |
Chapter 5

doysyaopp g3
anop Buipjing



84

Q

@

Office Suites

JBuilder

JBuilder 9, from Borland Software Corporation, is a popular visual Java
development environment for creating Java-based Web sites. It is available
in three editions: Personal, Developer, and Enterprise. A free trial version of
JBuilder is available for download at the Borland Web site.

Price: $9.95 (Personal Edition), $999 (Developer Edition), $3,500 (Enterprise
Edition)

Web site: www.borland.com/jbuilder/index.htm]

Flash

Macromedia Flash MX 2004 has become the standard for any Web designer
wanting to produce high-quality, high-impact animations for Web sites. This
tool offers advanced drawing tools and interactive support that you can use
to create navigation bars (those cool rows of clickable buttons that enable
users to visit other sections of a site) and presentations complete with
synchronized sound.

You can find an evaluation copy of Flash MX 2004 on the companion CD.
Price: $499

Web site: www.macromedia.com/software/flash

Office Suites

All three of the popular Office suites — Microsoft Office, Corel WordPerfect
Suite, and Lotus SmartSuite — include Web authoring features. These fea-
tures enable you to use a word processor, spreadsheet, or desktop presenta-
tion program to create Web pages. One of the useful features is the ability to
quickly convert an existing document, spreadsheet, or presentation to a
Web page.

Corel WordPerfect Office 11

The Corel basic office suite features these programs:

4+ Word processing: Corel WordPerfect 11
4+ Spreadsheet: Corel Quattro Pro 11

4+ Desktop presentations: Corel Presentations 11
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You can use all these programs to create new Web pages using HTML, PDF,
and XML. The Professional Edition also includes the database program
Paradox, which can also publish database data to a Web page.

Price: $299.99 (Standard Edition). The Professional Edition is available
through a licensing program; total cost depends on a number of criteria.
Contact Corel for details.

Web site: www.corel.com

Lotus SmartSuite Millennium Edition

SmartSuite Millennium Edition 9.8 includes the following programs:

4+ Word processing: Lotus Word Pro

4+ Spreadsheet: Lotus 1-2-3

4+ Desktop presentations: Lotus Freelance Graphics

4+ Database: Lotus Approach
You can use all the SmartSuite programs for Web publishing. SmartSuite pro-
grams can automatically convert documents, presentations, and spread-
sheets to HTML format and publish them on the Web. SmartSuite is especially
adept at collaborative work by enabling you to electronically distribute

documents to other Internet users and automatically consolidate multiple
versions of a document to create a final, edited document.

Price: $202

Web site: www. Totus.com/products/smrtsuite.nsf

Microsoft Office

Microsoft Office 2003 comes in several versions; the most popular are the
Standard Edition and the Professional Edition. Office 2003 Standard Edition
includes the following programs:

4+ Word processing: Word 2003

4+ Spreadsheet: Excel 2003

4 Desktop presentations: PowerPoint 2003

4+ E-mail/organizer: Outlook 2003

The Professional Edition also includes the database program Access 2003,
as well as Publisher 2003 and FrontPage 2003.
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All the Office 2003 programs include features for creating Web pages. You
can use Word 2003 as a simple WYSIWYG HTML editor, or you can convert
existing documents to HTML pages. You can also use Access 2003 and Excel
2003 to publish database or spreadsheet data to the Web.

Best of all, the Professional Edition of Office 2003 comes with FrontPage
2003.

Price: At the time of this writing, Microsoft had not yet released a price for
Microsoft Office 2003.

Web site: www.microsoft.com/office
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Chapter 6: Publishing
Your Web Site

In This Chapter

v Using FTP to publish your Web pages

v+~ Using Microsoft’s Web Publishing Wizard to publish your Web pages
1+~ Rating your site using the ICRA rating service

v~ Figuring out how to submit your site to search services

n Web parlance, publishing your Web site means taking the steps neces-
sary to move your Web pages from your computer to a Web server —
whether that Web server is maintained by an Internet Service Provider or a
Web hosting company. After your pages are on a Web server, anyone with

a Web browser and a working Internet connection can see them.

Because visitors won’t exactly flock to your site just because it exists on a
Web server, though, this chapter shows you not only how to transfer your
files to a Web server but also how to rate it (an optional step you can take to
announce to the world that your Web pages contain, for example, no sexually
explicit content) and submit it to search engines. (Discovering more in-depth
ways to get the word out about your site is the focus of Book I, Chapter 7.)

Always make sure you test your Web pages — in other words, load them up
in a Web browser and double-check they look and behave the way you want
them to — before you publish them to the Web for the whole world to see.
Many Web page creation tools, such as Dreamweaver, make the testing
process easy by including a Preview/Debug in Browser button on the main
toolbar. (See Book IV, Chapter 1 for more information on the Dreamweaver
Preview/Debug in Browser button.)

Publishing Your Web Pages

Before anyone on the Web can see your Web pages, you must first upload,
or transfer, them from your computer to a Web server. You have a couple of
options for making this transfer:
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4 File Transfer Protocol (FTP): If your computer is running Windows 98,
Windows 2000, or Windows XP, you can use the command-line program
called ftp.exe to upload your pages to any Web server. You can also
purchase and use one of the popular graphical FTP programs on the
market, such as WS_FTP Pro (www. ipswitch.com) for Windows users;
Fetch (www. fetchsoftworks.com) for Mac users; or CuteFTP (www .
globalscape.com),available for both Windows and Mac users.

4+ Web Publishing Wizard: If your computer is running Windows 98,
Windows 2000, or Windows XP, or if you have Internet Explorer Version 4
or higher installed, you can use the Web Publishing Wizard to walk you
through the process of uploading your files to a Web server on the free
Microsoft Web hosting service, MSN Groups.

Most Web page creation tools, such as FrontPage and Dreamweaver, come
with their own built-in utilities to help you publish your Web pages.

FrP

FTP, or File Transfer Protocol, is a commonly used method of uploading, or
transferring, your Web files to a Web server.

What you need to know to use FTP

To use FTP to transfer your Web files to a Web server, you need to obtain
the following information from your Internet Service Provider:

4 The host name for the FTP server: This name usually, but not always,
starts with ftp, asin ftp.yourwebserver.com.

4 The user ID and password you must use to sign on to the FTP server:
Your user ID is probably the same user ID and password you use to sign
on to your service provider’s Web, e-mail, and news servers.

4 The name of the directory into which you can copy your Web files:
On the server I use, the directory is named PUBLIC_HTML. (A directory
on an FTP server is similar to a folder in Windows 98 or Windows XP.)

The Windows FTP client

If you use Windows 98, Windows 2000, or Windows XP, you already have the
software you need to access an FTP server. The following steps describe
how to transfer files to a Web server using the FTP program that comes with
Windows:

1. Collect all the files required for your Web site in one folder.

If you have a lot of files — for example, 50 or more — you may want to
consider using several subfolders to organize the files. But if you do,
keep the folder structure as simple as possible.
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. Make sure that you have the information you need to access the FTP

server.

To find out what you need, refer to the previous section, “What you
need to know to use FTP.”

. Open an MS-DOS command window by choosing Start~>All Programs->

Accessoriesm>Command Prompt.

. Use the CD (Change Directory) command to change to the folder that

contains the Web files you want to transfer to the Web server.

For example, if your Web files are stored in a folder named \Webfiles,
type the following command into the MS-DOS command window:

cd \Webfiles

. Type ftp followed by the name of your FTP host:

ftp ftp.yourwebserver.com

A line similar to User (ftp.yourwebserver.com) appears in the
MS-DOS command window, followed by a colon.

. Type your user ID.

The Password: prompt appears.

. Type your password.

After you successfully log in to the FTP server, you see an FTP prompt
that looks like this:
ftp>

This prompt indicates that you're connected to the FTP server, and any
commands you type are processed by the FTP server, not by the DOS
command prompt on your own computer.

. Use the CD command to change to the directory to which you want to

copy your files.
For example:

cd public_html
You can verify your current directory at any time by typing the com-
mand PWD (short for print working directory) at the FTP command
prompt.
Remember that the FTP server processes this command, so it changes
the current directory on the FTP server, not on your own computer. The

current directory for your own computer is still set to the directory you
specified in Step 4.

. Use the ascii or binary command to set the appropriate file transfer

mode.
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If you plan to upload nontext files such as GIF files, JPG files, or sound
files — or a mix of both text and nontext files — type binary at the FTP
command prompt and press Return. If, on the other hand, you plan to
upload only plain text (HTML) files, type ascii (short for ASCII text) at
the FTP command prompt and press Return.

Setting the file transfer mode to ascii and uploading nontext files
causes your nontext files to arrive at the Web server in a horribly man-
gled form. When in doubt, always set the file transfer mode to binary.

10. Use the following MPUT command to copy all the files from the cur-
rent directory on your computer (which you set in Step 4) to the
current directory on the FTP server (which you set in Step 8):

mput *.*
You’re prompted to copy each file in the directory:
mput yourfile.html?

11. Type Y and then press Enter to copy the file to the FTP server. Type N
and then press Enter if you want to skip the file.

After you copy all the files, the FTP> prompt displays again.
12. Type bye to disconnect from the FTP server.

Windows and Macintosh use the terms folders and subfolders. FTP uses the
terms directories and subdirectories to refer to the same concept. Throughout
the following discussion, keep in mind that the terms subdirectory and sub-
folder mean essentially the same thing, except that folders and subfolders
exist on Windows or Macintosh computers, whereas directories and subdi-
rectories exist on the FTP server.

If you have files stored in subfolders on your computer, you must copy those
files to the FTP server separately. First, though, you must create the subdirec-
tories on the FTP server. Use the MKDIR command to do that. For example, to
create a subdirectory named IMAGES, type a command at the FTP prompt:

mkdir images

Now you can copy files to the new directory. First, use the CD command to
change to the new directory:

cd images

Then, use the MPUT command to copy the files. You must specify the name
of the subfolder that contains the files on your computer in the MPUT
command:

mput images\*.*

You are prompted to copy the files in the IMAGES folder one at a time.



A
gg‘

NG/

Publishing Your Web Pages 91

Partial FTP command summary

Table 6-1 lists the FTP commands you’re most likely to use when you store
your Web files on an FTP server.

Table 6-1 Common FTP Commands

Command Description

ascii Sets the transfer mode to ASCII text (for plain text files).

binary Sets the transfer mode to binary (for nontext files).

bye Disconnects from the FTP server and exits the FTP program.

cd Changes the current FTP server directory.

delete Deletes a file on the FTP server.

dir Displays the names of the files in the current FTP server directory.

get Copies a single file from the FTP server to your computer.

help Displays a list of commands (he1p command displays instructions
for command).

mget Copies multiple files from the FTP server to your computer.

mkdir Creates a new directory on the FTP server.

mput Copies multiple files from your computer to the FTP server.

put Copies a single file from your computer to the FTP server.

rename Renames a file on the FTP server.

rmdir Removes (deletes) a directory on the FTP server.

Web Publishing Wizard

The Microsoft Web Publishing Wizard simplifies the task of publishing your
Web site. Web Publishing Wizard comes with Internet Explorer Versions 4
and higher; it also comes with Windows XP (and Windows 98, if you're still
using an older computer). If you don’t have the Web Publishing Wizard,
you can download it from www.microsoft.com/downloads/release.
asp?ReleaselD=22658.

The Web Publishing Wizard doesn’t allow you to upload your Web files to
any Web server you want. Instead, the Web Publishing Wizard allows you to
upload your Web files to MSN Groups — Microsoft’s own free Web hosting
service — and your photos to HP Photo, a free Web hosting service devoted
to personal photo albums. If you want to upload your files to another Web
host, see the FTP section earlier in this chapter. For more information about
MSN Groups, visit http://groups.msn.com. For the skinny on HP Photo,
point your Web browser to www.hpphoto.com.
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Figure 6-1:
You can
publish your
Web files
quickly and
easily in
Windows
XP using the
File and
Folder Tasks
menu.

Follow these steps to set up the Web Publishing Wizard for your Web site
and copy the Web files to your Web server for the first time if you're running
Windows XP:

1. Choose Start>My Documents and then open the folder that contains
the files you want to upload.
The File and Folder Tasks menu appears, as shown in Figure 6-1.

2. If you don’t want to upload the entire folder, select the file or files
you want to upload.

The publishing options in the File and Folder Tasks menu change to
reflect your selections.

3. Click Publish This File to the Web.

(If you didn’t select specific files in Step 2, click the Publish This Folder
to the Web link; if you selected multiple files, click the Publish Selected
[tems to the Web.)

The Web Publishing Wizard springs to life.
4. Click Next.

A Change Your File Selection dialog box similar to the one shown in
Figure 6-2 appears.
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Publishing Your Web Pages

(Web Publishing Wizard
Change Your File Selection
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upload [ okt b "
selections é] i bl
Wl e B
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5. Click the check box next to each file icon to uncheck any files you
don’t want to upload (or, conversely, check any additional files you
want to upload) and then click Next.
A Where Do You Want To Publish These Files? dialog box similar to the
one shown in Figure 6-3 appears.
(Web Publishing Wizard
Where do pou want to publish these files?
gﬁ:;oe*:]?:gf praowider bo bast your \Webs site. IF you do not have a membership accours, oo wil be
— Service providers:
Figure 6-3: MSN Groups
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your Web
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Microsoft
MSN
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Figure 6-4:
You need to
create an
account at
WWW .
msnusers
.comto
upload your
files to MSN
Groups.

Rating Your Site

The service providers (Web hosts) listed may vary from the ones shown

in Figure 6-3, depending on the type of file you select to publish. For
example, if you select an image file, HP Photo appears in the Service
Providers list.

Choose a service provider from the list and click Next.

A welcome screen appears. In the example you see in Figure 6-4, the
Connect to www.msnusers.com screen appears.

Connect to Wwww.msnusers.com

‘welcome to MSM Communities!
Fleaze sign-in with pour Passport
account.

E-mail address: ﬁ HitgcdEna it vomm lvi
Pazsward: [TITITY]
[ Sign me in automatically
[ Ok ] [ Cancel ]
Geta MET Passport Help

7. Follow the service provider instructions that appear and click Next
when you’re finished.

The Completing the Web Publishing Wizard dialog box appears.

Check the Open This Site When I Click Finish check box and then
click Finish.

Whee! Your successfully uploaded files appear.
Note: Accessing the wizard works differently in Windows 98 than in

Windows XP. If you're working in Windows 98, choose Start=>Programsr>
Internet Explorer=>Web Publishing Wizard.

Rating Your Site

Many Web users activate their Web browsers content filtering features

(or purchase third-party filtering software packages, such as Net Nanny

or CyberSitter) to ban access to sites that contain offensive material. For
example, Internet Explorer includes a Content Advisor feature that enables
users to prevent access to offensive Web sites.
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Content Advisor (as well as most third-party filtering software) limits the
kind of content it allows based on a system of ratings similar to — but more
detailed — than the ratings used for movies.

Here’s how Web rating works. Web publishers voluntarily assign ratings to
their Web pages for four categories: violence, nudity, sex, and language. The
ratings are stored in special HTML tags that appear in the <HEAD> section of
Web pages.

If you fail to provide a rating for your Web site, your site may be banned
even if it doesn’t contain offensive material. So providing ratings for your
site is a good idea, even if your site is G-rated.

An organization called the Internet Content Rating Association, or ICRA,
oversees Internet ratings. ICRA has an online service that simplifies the task
of rating your site, and best of all, it’s free. Just follow these steps to rate
your site:

1. Go to the ICRA home page at www.icra.org.
2. Follow the links to register your site.

3. Type the site information requested by ICRA (your Web page URL,
contact name, phone number, and so on).

This information is kept private, so you don’t have to worry about your
address being sold to junk mailers.

4. Answer the questions about the content level of your Web site for
language, sex, nudity, and violence.

Answer truthfully so that you can give your site an accurate rating.

After you finish, the ICRA Web page displays a snippet of HTML that
contains the appropriate tags to add to your Web page.

5. Use the mouse to highlight these HTML lines and then press Ctrl+C to
copy them onto the clipboard.

6. Open your home page in your favorite HTML editor, switch to HTML
view so that you can see the actual HTML code, and paste the ICRA
tags into the <HEAD> section of your home page.

If you want to let people know that you rated your site, flip back to the ICRA
page that contains the HTML tags you copied in Step 5. On that page is a
“Labeled With ICRA” graphic. Save this graphic to your hard disk and then
insert it into your Web page.

Because rating Web sites is a voluntary process, most filtering software uses
the ICRA ratings as a first line of defense only and adds extra measures to
keep unwanted content from loading into a filter-protected browser.

Book |
Chapter 6
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Submitting Your Site to Search Services

Submitting your site to the major search services (also known as search
engines) is like taking out a Yellow Pages ad: Doing so helps Web surfers find
your site. You should try to get your page listed in as many search services
as possible.

Table 6-2 describes how to add your site to several of the popular Web
search services. To list your Web site in the search service, go to the URL
and click the link indicated in the last column of the table.

Table 6-2 Adding Your Site to Popular Web Search Services

Search Service URL Click This Link

AltaVista www.altavista.com  Submita Site

Excite www.excite.com Submit Your Site

Open Directory dmoz.org Add URL

Lycos www.lycos.com Add Your Site to Lycos

MSN Web Search search.msn.com Submit a Site

Yahoo! www.yahoo.com Suggest Your Site

Google www.google.com gpbs, Press, & Help=>Submitting your
ite

\\s

Submitting your site to search services isn’t something you can do once and
then forget about. To avoid having your site dropped from a search service’s
database, you need to resubmit your site every six months or so.

For more information about getting your Web site noticed, see Creating
Web Pages For Dummies, 6th Edition, by Bud Smith and Arthur Bebak.




Chapter 7: Publicizing
Your Web Site

In This Chapter

+* Coming up with a domain name

»* Maximizing your search services

1 Using advertising and site statistics to get other sites to link to your site

S)me folks mistakenly think that as soon as they publish a Web site, the
world will beat a path to their cyberdoor. Unfortunately, getting Web
surfers to visit your site isn’t quite that easy! Registering your Web site with
a bunch of search engines (as I describe in Book [, Chapter 6) makes it
easier for people actively hunting for your site to find you on the Web. But
to attract visitors to your site who don’t already know who you are and
what your site is all about, you must do more than just submit your site to
search engines: You must publicize your site. This chapter shows you how.

Springing For a Domain Name

\\J

The single most effective thing you can do to promote your own Web site is
splash out for your own domain name — for example, janedoe. com (if your
name happens to be Jane Doe, and you're creating a personal Web site) or
mnsoccer.org (if you happen to be creating a Web site for a Minnesota-
based soccer association).

Why spend extra money on a domain name? Because typing your domain
name into a browser or search engine is the way most visitors will find your
site. If you don’t register your own domain name, you take potluck: Web
hosts assign you a domain name, which may be long and tricky to spell, like
www.someFreeWebHost.com/~community/janedoe23423.html. As you
may expect, remembering (or guessing) and typing www. janedoe.comis
much easier for prospective visitors.

If you're planning to use your Web site for business-related reasons, spring-
ing for your own domain name helps demonstrate your commitment to a
professional image, much the same as investing in nice letterhead or a well-
written resume.
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Springing For a Domain Name

Choosing a domain name

Registering a domain name is like getting a driver’s license: It’s good for a
couple of years before you have to renew. To select a domain name you’ll be
happy with for a while, consider the following suggestions:

4 Make it meaningful. Popular choices include your name (or a short
variation, if your name happens to be really long) and the name of your
business or organization.

4+ Keep it simple. With domain names, the shorter and easier the name is
to spell, the better. And try to resist the temptation to use cute spellings.
FatTuesday.com, for example, is a lot easier for Web surfers to remem-
ber and spell than phattuzeday.com.

4+ Think ahead. If you select joesDonuts.com as your domain name and
decide a few months from now to sell your donut shop and take up goat
ranching, your domain name will be obsolete.

Domain names are going fast! To find out whether the domain name you’re
considering is still available, visit www.register.comand type your
selection.

Registering a domain name

The cost of registering and hosting a domain name has dropped like a stone
in the last couple of years. (Yeah!) The good news is that registration serv-
ices and Internet Service Providers are currently engaged in a price war to
get your business. The bad news is that you may find it difficult to figure out
who offers the best deal because many companies bundle the price of
domain name registration with other services. Here are a few options for
you to explore:

4+ Internet Service Providers: These days, many Internet Service
Providers register your domain name for you for a small additional
charge. Fees vary widely, so if you haven’t already found space for your
Web site, make sure to compare prices carefully. (See Book I, Chapter 1,
for tips on finding a company to host your Web site.)

4+ Registration services: If you're the type of person who enjoys doing
things yourself (especially if doing so means saving a buck or two), you
may want to look into a do-it-yourself registration service, such as
www.register.comor www.dotster.com.

Because some Web hosts charge a domain name transfer fee, registering
your domain name yourself and then selecting a Web host may turn out to
be more expensive in the long run than paying for a package deal.
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Understanding Search Services
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Registering your site with search services such as Yahoo! and AltaVista, as

[ explain in Book I, Chapter 6, is the first step of any successful site publicity
campaign. To make the most of your search service listing, however, you
need to make sure that you code your HTML properly — before you submit
your site.

As the Internet has become more popular, the number of Web sites has
mushroomed to titanic proportions, and search services have reacted by
merging with one another and by tweaking the way they examine site sub-
missions. The result? These days, submitting to search services has become
both art and science — especially for those hoping to win a coveted high
ranking.

Despite all these changes, the following are still the three most important
things you can do to help search services classify your site properly, in
order of importance:

1. Specify a descriptive page title.

Search services first examine the title of your Web page. (By title, | mean
the text you place between the beginning and ending HTML <TITLE>
tags, and which appears in the browser window’s title bar when your
page loads.)

To help you determine if your page title is descriptive, bookmark your
Web page. (To do this in Internet Explorer 6, load your page and then
select Favoritese>Add To Favorites.) Then examine that bookmark. (In
Internet Explorer 6, select Favorites, and then the title of your book-
marked page.) Is the title closer to newpage4, or The History of
Stuffed Animals from the 1700s to Present Day?

2. Include appropriate page content.

After the title, search services look at the text that appears on your
Web page.

3. Add meaningful HTML <META> tags.
Finally, search services scan special HTML tags, called meta tags, to
decide how to classify your site.

Although submitting your site to some search services is still free, more and
more search services are beginning to charge a fee for listing your Web site.

Book |
Chapter 7

as g\
Inoy, buizianqng



100 Understanding Search Services

WING/

Specifying a descriptive HTML title

A good Web page title lets readers know precisely what they can expect to
find on that Web page. A good Web page title also helps prospective readers
find that Web page because search services use the words in the title to
classify that page.

Consider this example. If you're creating a Web site that describes your
book, you may want to place a title of “When Computers Kill: A Technical
Thriller by Novelist Jane Doe” in the browser window title bar, rather than
“My Book.”

You create a title for your Web page by placing text inside the beginning and
ending <TITLE> tags:

<HEAD>

KTITLE>When Computers Kill: A Technical Thriller by
Novelist Jane Doe</TITLE>

</HEAD>

Optimizing Web page text

To help ensure that search services classify your Web site properly, you

need to make sure that the text of your Web page includes your keywords
(the words you expect prospective viewers would use to search for your
site).

You include text in your Web page using the beginning and ending <BODY>
tags.

The following example shows you the keywords you might include in your
Web page if you're a novelist who'’s just written a technical thriller:

<BODY>

In the tradition of Michael Crichton and Tom Clancy, novelist
Jane Doe's latest critically acclaimed technical
thriller, When Computers Kill, confronts the specter of
total annihilation as the world's computers turn on their
owners and

</BODY>

If you think that repeating keywords in the body of your Web page may help
you achieve a higher search engine ranking, you're right — sort of. Most
search services count the repetitions of keywords. If they count more than a
few repetitions, they may assume that the creator of the Web page is trying
to pull a fast one and refuse to list the site at all! The best advice: Don’t
intentionally overdo keywords. Just make sure that you sprinkle keywords
naturally throughout the text of your Web page.
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Using HTML meta tags Book|

Chapter 7
HTML defines a special tag (the <META> tag) for search services and Web
directories to scan for hints on what your site is all about. You can define a

<{META> tag in dozens of different ways, but the following two, which define g
the description and keywords you want to associate with your site, are g =
far and away the most useful. A §:

9 él‘i
Here’s an example: =)

<META NAME="description" CONTENT="When Computers Kill is the
latest novel from award-winning author and novelist Jane
Doe. Read an excerpt and order your own copy at www.
janedoe.com.">

<META NAME="keywords" CONTENT="Jane Doe When Computers Kill
technical thriller novel">

Adding the preceding code snippet to an HTML file (and then submitting the
HTML page to search services, as I describe in Book I, Chapter 6) enables
readers to search for Jane Doe’s novel by typing technical, thriller, novel,
and so on into a search engine or directory. Then, when a link to Jane’s Web
page appears in the result list of a search service, it appears next to the
description “When Computers Kill is the latest novel from award-winning
novelist. . ..”

3
By convention, you place HTML <META> tags at the beginning of an HTML
file, inside the beginning <HEAD> and ending </HEAD> tags.

Exploring automated submission tools

Submitting your site to search services and Web directories can be time-
consuming. Not only do some of these services change their submission cri-
teria every two seconds (okay, maybe it just feels that often!), but after your
site is listed, you need to resubmit occasionally to make sure that your site
doesn’t drop off of the search services’ gigantic (and growing) databases.

You can save yourself some time by submitting your Web site to a submis-
sion service such as Submit It (www.submit-it.com). This service can
submit your Web site to more than 400 search engines for a modest fee.
(As I write this book, the fee is $79 for one URL for one year.)

\\J

Going Beyond Search Services

Getting your site listed with search services is a great first step in any site
publicity plan. If you really want to pull in the visitors, though, you have to
do more than that. Two of the best ways to publicize your site are
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4 Getting other people to link to your site from theirs.

4 Advertising your site.

After you get a few links and start advertising your site, you can use site sta-
tistics to examine and fine-tune your online publicity efforts.

Getting links

Unfortunately, one of the most effective means of promoting your site
online — getting related, high-traffic sites link to yours — is also one of
the most time-intensive.

Here are steps you can take to get other sites to link to yours:

4+ Research the Web and come up with a list of sites that are similar in
content to yours. For example, if your site is devoted to Australian
shepherds, you may include the American Kennel Club and a couple of
dog-training sites on your list. The more compatible sites you can find,
the better.

4+ Send a note to each site requesting a link. Some folks swear by formal
press releases, but a brief, personalized e-mail request to the
Webmaster should do the trick. For best results, word your request cor-
dially and be sure to point out precisely what makes your site worth
linking to. (After all, you're asking someone to do you a favor!)

Advertising your site

Online or off, if you want somebody to know about something, what do you
do? You advertise!

Many for-profit Web sites sell advertising much like newspapers and maga-
zines do — by the inch. Beyond paid advertising, though, you can take the
following free steps to get the word out about your site.

4 Add your domain name to your e-mail signature. One of the easiest
and most effective ways to advertise your site is to include your domain
name, along with a short description, in your e-mail signature. Virtually
all e-mail programs let you create and modify a personalized signature,
or sig, file. For the precise steps for changing your signature, check the
documentation for your particular e-mail program.

4+ Participate in newsgroups, lists, and chats. Newsgroups, lists, and
chat rooms are electronic gathering places where folks with a common
interest get together to share opinions and information. By participat-
ing and sharing your expertise on a particular topic — for example,
cheese-making — you can become acquainted with other cheese lovers
who, chances are, will be delighted to know about your newly created
Web site, All About Cheese.
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Just because your Web site is online doesnt letterhead, and resume. Some folks get really
mean your publicity efforts have to be restricted  creative with their site publicity, slapping their
to cyberspace. Some obvious choices for meat-  domain names on everything from t-shirts to
space (real-world) publicity include adding cars!

your domain name to your business cards,

Publicizing your site offline
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Visit groups.yahoo.comor groups.google.com/ to find newsgroups, lists,
and chat rooms on virtually every topic you can think of.

Don’t hesitate to mention your site to an appropriate audience, but never,
ever spam. Spam means sending unsolicited messages to inappropriate
audiences; you can think of it as the electronic equivalent of junk mail. For
example, posting a message containing news of your latest cheese creation
tothealt.collecting.hockey-pucks or to a chat room devoted to single
parents, would be considered spam. If you're not sure whether your mes-
sage is appropriate for a particular newsgroup, list, or chat room, lurk (read
others’ messages without contributing) for a while to get the feel for the
community — and then, if it seems appropriate, jump in.

Using site statistics
If you're serious about reaching readers with a Web site, you need to know
what site statistics are — and how to use them.

Understanding site statistics

Site statistic software sits on the same Web server your Web site files sit on.
(For help in finding a Web server, check out Book I, Chapter 1.) Every time a
reader loads or interacts with your Web page, statistic software logs the
interaction. The kinds of statistics typically logged include

4+ How many hits each page of your site gets, and when. Each hit corre-
sponds to a person loading one of your Web pages into his or her
browser. This statistic is useful because it lets you know which page of
your site is the most popular — and, therefore, a good candidate for fre-
quent updates. You can also use this statistic to figure out whether your
publicity campaign is working. For example, if you spent all weekend
telling everyone you know about your Web site, you can verify whether
your time was well spent by checking this statistic to see whether your
site logged more hits after your whirlwind campaign than before.

Book |
Chapter 7
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4+ Which site referred the visitor to your site. This statistic lets you know
which links your visitors follow to find you on the Web. You can use this
information to concentrate your link-getting efforts on the types of sites
that are leading the most visitors to yours. (For tips on getting links, see
the section “Getting links,” earlier in this chapter.)

4+ How many times surfers tried to view your site, but couldn’t (and
why). After you publish a site, you may think that your site is always
available for viewing. Theoretically, consistently available Web sites
exist — but in the real world, power goes out, computer hardware
crashes, and Internet Service Provider staff occasionally make mistakes.
This statistic gives you insight into just how often your Web host is
unavailable. (You may find that free services tend to be unavailable just
a tad more often than for-pay services.)

4+ What country your site visitors are from. You can use this statistic to
find out whether readers in Germany are visiting your site heavily, for
example. If that’s the case, you may want to consider translating your
site copy into German.

4 Which make and model of browser surfers are using to view your
site. Internet Explorer and Netscape aren’t the only browsers in town,
although they are the two most popular. Each browser offers goodies
that the other doesn’t. (Internet Explorer, for example, supports a
slightly different scripting language than Netscape supports.) You can
use this statistic to determine whether the majority of your viewers are
using one particular browser to view your Web pages. If one browser is
most popular, you can take full advantage of the extra goodies that it
provides.

Accessing site statistics

Site statistic software must be installed on a Web server; it doesn’t work if
it’s installed on your computer. The company that hosts your Web site con-
trols which statistics package you have access to and how you access it. All
you have to do is contact the company and ask for instructions.

Different software programs report statistics differently, so be sure to ask
your Web host for an interpretation guide if you have any difficulty figuring
out what all the different numbers and charts mean.
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Chapter 1: Creating an HTML Page

In This Chapter

v~ Figuring out HTML text and tags
v Working with structure tags

+ Recognizing common HTML tags

thher you choose to create HTML pages by hand or by using one
of the many fine HTML editors on the market, you should become

familiar with the HTML basics I present in this chapter. Why? Because
understanding the basics — such as which HTML tags are necessary to
create a bona fide HTML file, which tags are the most common and why,
and how tags work in general — helps you create your pages in record time.
Being familiar with the tags you see in this chapter even helps you catch
errors that your HTML editing program may make.

If you haven’t already, go ahead and open your favorite text editor and
browser so that you can try out the examples in this chapter. The examples
help you insert tags and set up your first HTML document.

Understanding HTML Basics: Text and Tags

HTML documents basically contain the following three elements:

4+ Text that you're working with

4+ Tags that determine document elements, such as headings, lists, and
paragraphs

4+ Tags that insert effects, such as bolding or italics, or that insert other
objects, such as images, style sheets, sounds, little programs called
applets, and movies (although a description of many of these is outside
the scope of this book)

You use most of the HTML tags described in this chapter in pairs — one tag
goes before the text, and the other tag goes after the text, as in the following
example:

{TAG>whatever your text is</TAG>
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4 The first tag (the opening tag) indicates the beginning of a tag that
you're applying to some of the text in your document.

4+ The second tag (the closing tag) indicates the end of a tag that you're
applying to some text in your document.

Not all HTML tags require a closing tag, although many do. An example of an
effect that doesn’t require a closing tag is <HR>, which displays on a Web
page an attractive separator called a horizontal rule. No closing </HR> tag is
required in order to display a horizontal rule.

The tags affect everything between the opening and closing tags.

Opening and closing tags are generally identical, except that the closing tag
has a forward slash (/) in front of the tag name. The tag name is always
exactly the same in the opening and closing tags.

Sometimes, opening tags also include an attribute, which is just an additional
bit of information that further specifies information such as color, align-
ment, or the text that should appear in order to describe an image. So, in
such a case, an attribute appears in the initial tag:

<TAG ATTRIBUTE="More Info">whatever your text is</TAG>

HTML tags are case-insensitive, which means that you can type the tags by
using either UPPERCASE or lowercase letters, or BoTh. Typing the tags in all
caps is a good idea because it helps you differentiate between the tags and
text, particularly after your HTML document becomes pages and pages long.

Formatting text

Browsers disregard all formatting that doesn’t appear between tags. For
example, browsers ignore extra spaces in the HTML document or blank lines
that you use to move things down the page. As a result, the extra spaces,
lines, or tabs that you insert don’t affect your document’s appearance.

You can type your line this way, for example:
<TAG>hi11 of beans information</TAG>
or even like the following example:

<TAG>
hill

of beans information
</TAG>
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The next generation of HTML: XHTML

Recently released as a recommendation by the by Web browsers — which may be soon — you
World Wide Web Consortium (www.w3.0rg), will notice the following changes in how you
XHTML 2.0 is the reformulation of HTML4 as an  code your Web pages:

XML application. XHTML tags and attributes are
almost identical to those in HTML; the differ-
ence is that XHTML is a stricter, tidier version of 1~ All XHTML tags must be closed.

HTMI." (In other words, sloppy -programmln;q Note: For more information on XML, check out
practices you can get away with in HTML don’t Book IX

fly in XHTML.) When XHTML is fully supported Book II
Chapter 1

v XHTML tags are all lowercase.

Nesting tags

In many cases, you may want to nest tags inside other tags. Nesting tags
simply means enclosing tags within tags. By nesting tags, you apply multiple
tags to the same bit of text.

abed TNLH
ue Buneaiy

Suppose that you want to make text both bold and italic. You can’t achieve
this effect by using only one tag — no BOLD-n-ITALICS HERE tag exists.
Instead, you nest one tag inside the other, as the following example shows:

<B><I>more hill of beans information</I></B>

Notice that the tag that appears first (in this case, the bold tag) also appears
last. If a tag starts first, it ends last. If a tag is right beside the text on the
front end, it’s right beside the text on the back end.

Using HTML Structure Tags

This section introduces you to a group of HTML tags that you use in every
HTML document you create. The first tags in this group are structure tags (so
named because they define and describe a document’s structure). Although
most structure tags don’t generally affect the appearance of the document
or the information contained within it, they do help some browsers and
HTML-editing programs identify document characteristics.

For most HTML documents, you use the structure tags listed in Table 1-1
and described in the following sections.
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Table 1-1 HTML Structure Tags
HTML Tag Purpose Use in Pairs?

<!DOCTYPE HTML PUBLIC"-// Identifies a document as an No
W3C//DTD HTML4.01 Frameset// HTML documentand specifies
EN" "http://www.w3.0rg/TR/ the HTML version; mandatory

html4/frameset.dtd" in all HTML documents
<HTML>. . . </HTML> Defines a document as an Yes
HTML document
<HEAD>. . .</HEAD> Includes introductory Yes
information about the
document
KTITLE>. . .</TITLE> Indicates the document title; Yes
mandatory in all HTML
documents
<META NAME="KEYWORDS" Indicates keywords that No
CONTENT=". . ."> describe the document
<META NAME="DESCRIPTION" Provides a short summary No
CONTENT=". . ."> or description of a document
<BODY>. . .</BODY> Encloses all elements within Yes

the main portion of a document

The !DOCTYPE tag

The DOCTYPE tag identifies the document as an HTML document. It
appears at the top of HTML documents and notes that the document con-
forms to specific HTML standards — in this example, to the final HTML
Version 4.01 standards. If you use HTML editing programs, they probably
insert the ! DOCTYPE tag automatically. If they don’t, however, make sure
that you type the !DOCTYPE tag at the top of all your documents.

Suppose that you want to create an HTML document about making a water
balloon. Enter the !DOCTYPE tag:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/html4/frameset.dtd">

The <HTML> tag

The <HTML> tag encloses everything except the ! DOCTYPE tag in every docu-
ment. This tag, as its name suggests, indicates that the document is HTML. If
you don’t specify HTML, the browser may conceivably not read the tags as
tags. Instead, the browser may read the tags as text, in which case the docu-
ment looks pretty much as it does in the text editor. Yuck!
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You enter the <HTML> tags at the beginning and end of the document (but
after the ! DOCTYPE tag), as shown in the following example:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML>

...all the stuff about making water
balloons will go here eventually...

</HTML>

The <HEAD> and <TITLE> tags

The <HEAD> tag is part of what many browsers use to identify or reference
the document. For many HTML developers, the <HEAD> tag seems useless.
Keep in mind that although this tag doesn’t have a visible application for
creating an HTML document, it does have a technical application — it con-
tains information about the document that doesn’t appear within the
browser window.

The <TITLE> tag, one of those about-this-document bits, goes within the
<HEAD> tags. This tag is required by the HTML specification to apply a title
of your choice to the document. Titles appear on the title bar of a browser
window. Make your title as descriptive as you can so that people can find or
identify your documents more easily on the Internet.

You add the <HEAD> and <TITLE> tags, as shown in the following example:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML>

<HEAD>XTITLE>Making Effective Water Balloons

</TITLE></HEAD>

.all the stuff about making water balloons
will go here eventually.

</HTML>

Notice that the <HEAD> and <TITLE> tags appear immediately after the ini-
tial <HTML> tag.

The <META> tag

The <META> tag appears in dozens of permutations and combinations, only
a couple of which have any significant effect on most HTML developers.
These tags, cleverly positioned right alongside the <TITLE> tag between the
{HEAD> tags, provide more about-this-document information. This meta-
information fuels Internet directories (such as Lycos, at www. Tycos.com)

Book I
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and search services (such as AltaVista, at www.altavista.com) because
providing the information makes categorizing and finding your documents
easier. Although you don’t have to include these tags, you greatly improve
your chances of being found by people “out there” if you do.

You add the <META NAME="KEYWORDS" CONTENT="..."> and <META
NAME="DESCRIPTION" CONTENT="..."> tags, as shown in the following
example:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML>

<HEAD><TITLE>Making Effective Water Balloons

</TITLE>

<META NAME="KEYWORDS" CONTENT="water balloon
surprise splash splat cat oops sorry
ouch cold wet">

<META NAME="DESCRIPTION" CONTENT="This document
provides basic instructions for developing and
using water balloons.">

</HEAD>

.all the stuff about making water balloons
will go here eventually.

</HTML>

The <BODY> tag

The <BODY> tag surrounds all the information that’s supposed to be visible
to your readers — the real heart of the document. Everything you want
people to see must be contained between the <BODY> and </BODY> tags.

Place the <BODY> tag just before the information that you want to put into
your HTML document and then just before the closing </HTML> tag.
Technically, all other tags you use are nested between the <BODY> and
</BODY> tags.

You begin the water balloon project by adding the <BODY> tags:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01

Frameset//EN"
"http://www.w3.0rg/TR/html4/frameset.dtd">
<HTML>
<HEAD>XTITLE>Making Effective Water Balloons
</TITLE>

<META NAME="KEYWORDS" CONTENT="water balloon
surprise splash splat cat oops sorry
ouch cold wet">
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<META NAME="DESCRIPTION" CONTENT="This document
provides basic instructions for developing and
using water balloons.">

</HEAD>

<BODY>

. . .all the stuff about making water balloons.

</BODY>

</HTML>

Getting Familiar with Basic HTML Tags

Basic HTML tags are the ones that enable you to create simple, functional Book Il
effects in your HTML documents. This section describes the tags necessary Chapter 1
for making headings, paragraphs, and lists and for emphasizing and setting

off text.

Making headings

HTML offers you six choices in headings, labeled <H1> through <H6>. <H1>
is the largest and boldest of the headings, and <H6> is the smallest and least
bold (most timid?). You can use these headings, as shown in Table 1-2, to
show a hierarchy of information (such as the headings in this book).

abed TNLH
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Table 1-2 Your HTML Heading Options

HTML Tag Effect Use in Pairs?
<HI>. . L</HD> Heading 1 Yes

<H2>. . .</H2> Heading 2 Yes

<H6>. . .</H6> Heading 6 Yes

As with all other paired tags, the text that you want to include goes between
the tags; for example: <H1>Here is my heading</H1>.

Making paragraphs

By using HTML, you can separate information into paragraphs. The HTML
paragraph tag, <P>, indicates the beginning and the end of a paragraph of
text. Although using the end </P> tag is optional, including it is good pro-
gramming practice. When you add this tag around a paragraph of text, the
text appears in a block with a line of space at the end.

Emphasizing text
After you write something, you may want to make some of the words within
the text stand out. HTML offers several options for doing this, including
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emphasizing text and adding bold and italics to text. Table 1-3 describes
some of these options.

Table 1-3 Tags to Create Standout Text
HTML Tag Effect Use in Pairs?
<EM>. L L<K/EMD Adds emphasis Yes
(usually appears
as italics)
<STRONG>. . .</STRONG> Adds strong emphasis Yes
(usually appears as bold)
<B>. . /B> Adds boldface Yes
<I>. . /D> Adds italics Yes

Making lists

Often, you may want to provide information in lists rather than in para-
graphs. Providing information in lists is especially valuable in HTML docu-
ments because lists enable the reader to skim through information quickly
without needing to wade through paragraphs of text. For you, the writer,
making lists is an easy way to help organize your information and provide
easy links to other pages.

Making lists is a two-part process. First, you must add a pair of tags to spec-
ify that the information appears in a list. You can specify, for example, an
ordered (or numbered) list, <OL>. . .</0L>; or an unordered (or bulleted)
list, <UL>. . .</UL>.

Then, you must specify each line of the list, called line items. Just insert the
<LI> tag at the beginning of each line, where you want the number or bullet

to be. No closing tag is required.

Table 1-4 shows the tags you use to create lists.

Table 1-4 Tags to Create Numbered and Bulleted Lists
HTML Tag Effect Use in Pairs?
<LI> Identifies each item No
in a list
OL>. . .</0L> Specifies ordered Yes
(numbered) lists
AUL>. . .</u> Specifies unordered Yes

(bulleted) lists




Figure 1-1:
You use the
<UL> and
</UL> tags
to create an
unordered
(bullet) list.
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To add an unordered (bulleted) list of materials to a page, place the follow-
ing HTML code between the <BODY> and </B0ODY > tags:

<BODY>

<UL>

<LI>Water

<LI>Big, big balloon
<LI>Balloon ties (optional)
<LI>Second-story window
<LI>Target below window
</UL>

</BODY>

The bulleted list shown in Figure 1-1 shows the results of adding these tags
and text.

[T Waking Effective Water Balloons - Microsoft Internet Explorer = ) |
. File Edit View Favorites Tools Help ;,'
Do © A @G P Frrvorn @ @ 2+ 1% B - L HE @

: piddress [@7 c\bke_t_thm | & e

Making Effective Water Balloons

Mlaking water balloons 15 eagy... but makmng effective water balloons takes time and pafience. The result 1 a water balloon
that does not break in your hand, offers maximum splashing power, and resquires wiually no post-splat cleanp.

Materials Needed

o Water

« Big, big balloon

« Balloon ties (optional)
» Second-story window
o Target below window

@J Done 'j My Computer

Notice that the list tags don’t have <P> tags around them. If you have a list,
you don’t need a <P>.

To add an ordered list of instructions, you simply use the <0L> tags:

1. Add opening and closing <OL> tags where the list appears.

For example, if you are creating a page about making effective water bal-
loons, you add the following:

Book I
Chapter 1
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\\3

<HZ2>Instructions</H2>
<OL>
</0L>

2. Add <LI> tags and text for each item.

<H2>Instructions</H2>

<0L>

<LI>Fi11 balloon with water.

<LI>Tie balloon using a tie or by making a knot.
<LI>Go to second-story window.

<LI>Aim at spot below window.

<LI>Drop balloon.

</0L>

The result is a numbered list containing five items.

You can add attributes (extra information) to your list tags to control what
the bullets look like, what kind of numbers (Roman, capital letters, or regu-
lar Arabic numbers, for example) appear, and what the starting number is
for sequential lists.



Chapter 2: Setting Background
and Text Characteristics

In This Chapter

v~ Spicing up your background with color and images
v Locating your perfect image
+» Working with text colors and text alignment

v~ Specifying the font type

In this chapter, you discover how to set background and text characteris-
tics, which can help you liven up your pages with various color and align-
ment options.

This chapter assumes that you have a basic understanding of how HTML
tags work. If you don’t, check out Book II, Chapter 1, and then flip back here
to continue. Before beginning to work through the examples in this chapter,
make sure that you have your browser and text editor open and ready to
create a new document.

QMNG/ Because the formatting attributes and tags in this chapter work with nearly
N all current browsers but aren’t recommended in HTML 4.01, consider using
style sheets for all your formatting needs. (For a more in-depth look at style

sheets, see Book I, Chapter 8.)

Applying a Color Background

To include a background color, all you need to do is insert the BGCOLOR
attribute in the opening <BODY > tag.

Here’s an example of how specifying sky blue as the background color might
look:

<HEAD><TITLE>Fleabag Kitty</TITLE></HEAD>

<BODY BGCOLOR="4#3399CC">With a scratcha scratcha here and a
scratcha scratcha there...

</BODY>

#3399CC is an RGB value that translates to “sky blue,” but you can substi-
tute any RGB value (which all follow the RRGGBB format). To get a black
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background, for example, you use #000000. (If you do specify a black back-
ground, look at the section “Setting Document Text Colors,” later in this
chapter, to find out how to set the text to a nonblack color.)

Alternatively, you can specify some colors by name. The following colors
work in most browsers: aqua, black, blue, fuchsia, gray, green, lime, maroon,
navy, olive, purple, red, silver, teal, white, and yellow. The code would look
something like BGCOLOR="purple".

So just where do you come up with the RGB values? Try one of the following
two ways:

4+ Find a list of RGB numbers on the Web. If you browse enough on the
Web, you're likely to find general sources of information that provide
you with lists of commonly used Web page features, including RGB num-
bers, complete with samples. One useful reference is the Web Source
color chart at www.web-source.net/216_color_chart.htm.

4 Look for RGB values in your image-editing or paint software. Many
packages offer the option of altering the colors with which you’re work-
ing and provide the RGB value for the colors you choose. Look in the
color-related screens for RGB values.

RGB stands for red, green, blue. RGB values string together three hexadeci-
mal numbers representing a color’s red, green, and blue components,
respectively.

Applying an Image Background

In addition to using simple colors for backgrounds, you can use images as
backgrounds. To do so, you specify a URL pointing to an image for the
BACKGROUND attribute of the <BODY> tag. You can specify either a relative
URL or an absolute URL:

4 A relative URL points to a file located in or below the same directory as
the Web page: for example, picture.gif.

4 An absolute URL points to a file located anywhere on your computer: for
example, /mypictures/picture.qgif.

Here’s an example of specifying an image for the background (see Book II,
Chapter 1, for more information on the <BODY> tag):

<HTML>

<HEAD><TITLE>Adding a background to your Web
page</TITLE></HEAD>

<BODY BACKGROUND="star.gif">

<HI1>Backgrounds can make text hard to read!</HI1>



Figure 2-1:
Using the
BACK-
GROUND
attribute of
the <BODY>
tagto
specify a
background
image.
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</BODY>
</HTML>

Figure 2-1 shows the star.gif image (one star) tiled throughout the page.
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Background images, such as the star.gif image, that don’t fill the entire
background are tiled to cover all available space — that is, copies of the
image are automatically placed together, like a tile floor. The background
image in the example is really only one star — the browser makes the copies
automatically.

Finding Images to Use

Coming up with images to use for a background is about as easy as using
simple colors. The only difference is that you use an image file rather than
just a color number. Here are two ways to find background images:

4+ Design your own. You may want to use a background image that’s spe-
cific to the Web site you're creating. [ strongly suggest doing so if you
have any graphics talent. (If you do what I do and make fleas that look
like roaches, check out the other options.)
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4+ Look for image or background CDs or disks in your local software
store. Many CDs chock-full of cool stock images are available, at varying
prices. Make sure that the images you choose are, indeed, stock images,
which are images you can freely use without obtaining additional copy-
right permission. Putting nonstock, copyrighted images on your Web
site, by contrast, is immoral and illegal and has been proven to cause
hair to grow on your palms.

Make sure that you choose simple backgrounds — ones with no more than a
few subtle colors or with only a few elements. Busy backgrounds make read-
ing difficult for your users.

Setting Document Text Colors
In addition to changing the background of Web pages, you can also change
the color of the text. This technique is particularly handy if you use a back-

ground on which the default colors of text and links do not show up well.

Table 2-1 shows the attributes used to color text in an HTML document:

Table 2-1 Attributes That Set Text Color
HTML Attribute Effect

TEXT="#RRGGBB" Changes the color of the body text
LINK="#RRGGBB" Changes the color of the link
ALINK="#RRGGBB" Changes the color of the active link
VLINK="#fRRGGBB" Changes the color of the visited link

You fill in a color number where "#RRGGBB" is indicated, as shown in the
example in the following section.

Changing text colors

To change text colors on your Web page, you specify an RGB value for the
TEXT attribute of the <BODY> tag:

<BODY BGCOLOR="43399CC" TEXT="{#FFFFFF">With a scratcha
scratcha here and a scratcha scratcha there...
</BODY>

Changing link colors

To change link colors on your Web page, you specify an RGB color value
for the ALINK (active, or normal) attribute of the <BODY> tag and the VLINK
(visited) attribute of the <BODY> tag, as the following code shows:
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<BODY BGCOLOR="4#3399CC" TEXT="4FFFFFF"
LINK="#FF0000" ALINK="#FFFFO0"
VLINK="48C1717">With a scratcha scratcha here and a
scratcha scratcha there...

</BODY>

Specifying Text Alignment

In addition to recoloring text and links, you can move text around so that it’s
not all aligned on the left. You can align headings, paragraphs, other text,

and images by using the attributes in Table 2-2. il
Chapter 2
Table 2-2 Text-Alignment Attributes 7
D

. Q =
HTML Attribute Effect Example §- N
ALIGN="CENTER"  Centers text within the left <H1 ALIGN="CENTER">Text 2Edw
and right margins goes here</H1> E;%;

ALIGN="RIGHT" Aligns text on the right <P ALIGN="RIGHT">Text %ﬁﬁ
margin goes here</P> » £
o

Keep in mind that although most browsers support these attributes, not all
do, so your text may not align correctly in some browsers. Always try
designs in more than one browser to make sure that your design works the
way you think it should.

A\
You don’t need to add an attribute if you want the element aligned on the
left. Browsers align text on the left unless you tell them to do otherwise.

If you want to use center and right alignment for headings, paragraphs, and
images, follow these steps:

1. Start your HTML page, which should look similar to the following
example:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">
<HTML>

<HEAD><TITLE>Birthday</TITLE></HEAD>

<BODY>

</BODY>

</HTML>

2. Type a heading:

<BODY>
<H1>Happy Birthday, Winchester</H1>
</BODY>
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Figure 2-2:
Aligning
headings,
text, and
images with
the ALIGN
attribute.

Add the ALIGN="right" attribute to the heading, as shown in the fol-
lowing example:

<H1 ALIGN="right">Happy Birthday,
Winchester</H1>

Insert a graphical image on the left side of the heading:

<H1 ALIGN="right"><IMG SRC="winch.jpg">Happy
Birthday, Winchester</H1>

Type some paragraph information, as shown in this example:

<H1 ALIGN="right"><IMG SRC="winch.jpg">Happy
Birthday, Winchester</HI1>

<P>0On March 3, Deb and Eric snuck up on their cat,
Winchester, and surprised him with a water balloon
for his birthday. It was lucky #13 for
Winchester.</P>

</BODY>

Add the ALIGN="center" attribute to the paragraph, as shown here:

<P ALIGN="center">0n March 3, Deb and Eric
snuck up on their cat, Winchester, and
surprised him with a water balloon for his
birthday. It was lucky #13 for
Winchester.</P>

Figure 2-2 shows the result.

[e.». 0 B A @ @ IB F
|| Back Fonsecd Stop  Refiesh  Home Search Favoites  Histony Mail Print
| Address ]@ W apcomin books\idghhinlgnS ample Files\yI-Salign Him :_J @ Go
[~
Happy Birthday,
Winchester
On March 3rd, Deb and Enc snuck up on their cat, Winchester, and surprised hum with a water
balloon for his birthday, It was lucky #13 for Winchester,
— _ =
@] Done | |25 Local intranet 7
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Using Font Type Specifications
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HTML wasn’t designed to support specific formatting. HTML was conceived
with the idea that authors would specify headings and lists, and readers (or
the readers’ browsers) would take care of applying fonts and sizes.

A generation of designers accustomed to desktop publishing and to being
able to control every aspect of document design, however, sought out ways
to control HTML design as well. In response, newer browsers and the most
widely supported HTML specification provide some tags specifically to
format text precisely.

The combination of “pure” HTML, without the formatting tags in this section,
and style sheets (covered in Book II, Chapter 8) provides the best of both
worlds: HTML coding simplicity and complete layout and design control.

If you choose to use the formatting commands in this section, remember
that not all browsers support them. In particular, remember that a font you
specify isn’t necessarily installed on your readers’ machines!

Table 2-3 shows the tags and attributes used to format type:

Table 2-3 Formatting Type
HTML Tag or Attribute  Effect Example
<FONT>...</FONT>  Changes the font {FONT COLOR="red">Text

goes here</FONT>

COLOR="#RRGGBB" Colors the text based <FONT COLOR="{#FFHHAA">Text

on the RRGGBB goes here</FONT>
number
FACE="..." Sets the typeface <FONT FACE="Helvetica">

NAME ; a list of font Text goes; here</FONT>
names can be specified

SIZE="n" Changes the font <FONT SIZE="3">Text goes
size non a scale here</FONT>
from1to7

To change the characteristics of a specific block of text, follow these steps:

1. Start your HTML document, which should look something like the fol-
lowing example:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN"
"http://www.w3.0rg/TR/html14/
transitional.dtd"> <HTML>

Book Il
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<HEAD><TITLE>Making Effective Water
Balloons</TITLE>

</HEAD>

<BODY>

<HI1>Making Effective Water Balloons</HI1>

<P>

Making water balloons is <EM>easy</EM>...
but making <B>effective</B> water balloons takes
time and patience. The result is a water balloon
that does not break in your hand, offers <I>maximum
splashing power</I>, and requires virtually no
post-splat clean up.

<P

</BODY>

</HTML>

2. Add the <FONT> tags around the text you want to change:

<H1>Making Effective Water Balloons</H1>

<P>

<FONT>

Making water balloons is <EM>easy</EM>...
but making <B>effective</B> water balloons takes
time and patience. The result is a water balloon
that does not break in your hand, offers <I>maximum
splashing power</I>, and requires virtually no
post-splat clean up.

</FONT>

/P>

3. To change the size, add the appropriate SIZE attribute to the font tag.

By default, the size is 4. (The number doesn’t represent anything — it
just is.) You can specify a size relative to the default (+1 for one size
larger or -2 for two sizes smaller) or in absolute numbers, such as 1 or 7:

<FONT SIZE=+2>

Making water balloons is <EM>easy</EM>...
but making <B>effective</B> water balloons takes
time and patience. The result is a water balloon
that does not break in your hand, offers <I>maximum
splashing power </I>, and requires virtually no
post-splat clean up.

</FONT>
4. To change the typeface, add the FACE attribute, as the following exam-
ple shows:
<FONT FACE="Gil11 Sans, Arial, Courier”
SIZE=+2>

Making water balloons is <EM>easy</EM>...
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but making <B>effective</B> water balloons takes
time and patience. The result is a water balloon
that does not break in your hand, offers <I>maximum
splashing power </I>, and requires virtually no
post-splat clean up.

</FONT>

You can name any font on your system (bear in mind that, in order to
appear correctly, the font must be available on the reader’s system

also). You can also list fonts in descending order of preference. If the
first one isn’t available, the reader’s browser moves along to the next

and then the next.
Book Il

Figure 2-3 shows the new typeface in a Web browser.
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P Reliable fonts for Windows include Arial, Times New Roman, and »
Courier New. Helvetica and Times are similar to Arial and Times New o 2
Roman and also are frequently available. :_?: -l
Q=
5. To change the color, add the COLOR attribute, as shown in the follow- 22 g
ing example: FRE
4 " r . er F NONS - 15! :.‘ n
File Edll L{'ew Go C i Help
j ,J Bookmatks A Locaiion:[fie:/77MI/raycom books/idg/hmiar/S arple Files A Sloris him ] @5 wrarsRewed I
Makmg Effective Water Balloons
Making water balloons is easy . . . but making effective water
balloons takes time and patience. The result is a water balloon
that does not break in your hand, offers maximum splashing
power, and requires virtually no post-splat clean up.
Figure 2-3:
Using the
<FONT> tag
to change
the font size
and
typeface. _—
= == |Document: Done = R S e ) B )
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As with other text color settings (described earlier in this chapter), you
use a #fRRGGBB number to specify the color:

<FONT FACE="Gil1l1 Sans, Courier, Arial"
COLOR="4#000000" SIZE=+2>

Making water balloons is <EM>easy</EM>...
but making <B>effective</B> water balloons takes
time and patience. The result is a water balloon
that does not break in your hand, offers <I>maximum
splashing power </I>, and requires virtually no
post-splat clean up.

</FONT>



Chapter 3: Adding Internal
and External Links

In This Chapter

v+ Understanding links and anchors
v~ Linking your documents to URLs on the Web
+» Making links between and within documents

v Taking advantage of a link-checker utility

In this chapter, you see how to add anchors and links to your HTML
documents. Anchors and links enable readers to jump from place to
place within your document or to other documents and files. Put another
way, anchors and links are the sticky strands that connect your site to the
rest of the Web.

You apply lots of tags in this section, so if initial tags, closing tags, and phrases
such as “apply markup tags to your document” are unfamiliar, you may want
to flip to Book II, Chapter 1, for more information about HTML basics.

Understanding Links

When you create HTML documents, you create documents that users can
read by linking from topic to topic — that is, by jumping from page to page
and from topic to topic rather than reading linearly, as in a novel. Links (or
hyperlinks or hot spots) are places that users can select to access other
topics, documents, or Web sites (collections of HTML documents).

As you build your HTML documents, think about how you want your docu-
ments to link. As a rule, you should create several short HTML documents
rather than one long document. Short documents are easier for readers to
follow and are, therefore, more likely to be read. You can then link these
shorter documents into a single cohesive set of documents (that is, a Web
site).

To create a link, you need the following two elements:

4+ A URL (or Uniform Resource Locator): This is just an address on the Web.

4 An anchor tag: This marks the link in a Web page. (You read more about
anchor tags later in this chapter, in the section “Understanding Anchors.”)
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About URLs

A URL (pronounced “you-are-ell”), or Uniform Resource Locator, is a fancy
way of saying an address for information on the Internet. If you hear “URL,”
just think “address” or “location.” URLs differ based on how specific you
need to be.

All HTML documents can use URLs to link to other information. URLs, in
turn, can point to many different things, such as HTML documents, other
sites on the Internet, or even images and sound files. Depending on what the
URL points to, it can be absolute (full) or relative (partial), as explained in
more detail later in this chapter.

URLs are case-sensitive. On some computers, typing a filename such as
Kitten.html is quite different from typing kitten.html. If you create a
filename that uses special capitalization (rather than, for example, all lower-
case characters), you must use this same capitalization the same way every
time you link to the document. (Frankly, just using lowercase is easier for
you and your readers.)

Anatomy of URLs

If you're not used to them, URLs can be pretty odd-looking. Each part of a
URL has a built-in specific meaning, however, much like each part of your
home address. The street address, 12 Fritter Lane, Apartment G, Santa
Clara, CA 95051, for example, provides a postal carrier with essential and
complete information — the specific apartment in a specific building on a
specific street in a specific town in a specific state in a specific zip code.
Specifically, URLs work the same way by providing a browser with all the
parts it needs to locate information. A URL consists of the protocol indicator,
the hostname, and the directory name or filename. The following (fictitious)
URL is an example of an absolute URL:

http://cat.feline.org/fur/fuzzy.html
Here’s a description of each URL part:

4+ http:// portion (protocol indicator): Tells the server how to send the
information. The http:// protocol indicator is the standard used by
Web servers and browsers that lets them talk to each other. The
http:// protocol indicator often is omitted by publications (like this
one), because of space issues and because most URLs (at least those
published in the media) tend to be http://-type URLs.

Note: Even though you can leave the http:// off the URL in casual
usage, you must include it when linking to another Web site.
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Another common protocol indicator you see on the Web is https://.

Different from http://, https:// means that the transmission of data
between the Web server and the browser occurs using a special trans-
mission protocol called secure sockets layer, or SSL.

4+ cat.feline.org portion (hostname): Specifies a computer on the
Internet. If you publish an HTML document, you’re placing it on a com-
puter that “serves” the document to anyone who knows the correct
URL. The server thus “hosts” all these documents and makes them
accessible to users.

To obtain the hostname of the server on which you place your files,
check with your system administrator.

4+ fur portion (directory name): You may not need to show a directory
name, or you may have several that represent directories inside direc-
tories (or folders inside folders).

4+ fuzzy.html portion (name of file located on the host computer):
Sometimes, you don’t need to provide a filename — the server simply
gives out the default file in the directory. The default filenames are usu-
ally one of three: index.html, default.html, or homepage.html,
depending on which kind of Web server the files are located. The file-
name is like many other files; it contains a name (fuzzy) and an exten-
sion (. htm1).

Sometimes, URLs have a hostname with a port number at the end (for exam-
ple, cat.feline.org:80). This number gives the server more precise infor-
mation about the URL. If you see a URL with a number, just leave the
number on the URL. If you don’t see a number, don’t worry about it.

Try to avoid creating directory names or filenames with spaces or other
unusual characters. Stay with letters (lowercase is best), numbers, under-
scores (_), periods (.), or plus signs (+). Why? Because some servers have
problems with odd characters and spaces. (In addition, most humans have
trouble remembering odd characters and spaces in URLs — so keeping your
filenames simple helps visitors find your site more easily.)

Absolute and relative URLs

Links in Web pages use two different types of URLs: absolute URLs and rela-
tive URLs. Each of these types of URLs has a specific purpose and uses spe-
cific components:

4 Absolute URLs: These URLs give the full address of something on the
Internet. They include the protocol indicator, hostname, and directory
name or filenames. You use absolute URLs to indicate any location on
the Internet.
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Figure 3-1:
Absolute
versus
relative
URLs.

Keep in mind that pointing people to Internet locations requires as
much information as you can provide, just as you would provide
detailed information to an out-of-town friend who’s driving to your
apartment. You would provide, for example, the state, city, building
number, and apartment number (unless, of course, you want that
friend to get lost). Similarly, you need to provide as complete a URL as
possible — including the protocol indicator — so that people around
the world can find your Web site.

Relative URLs: These URLs don’t contain a complete address, but they
can still provide all the information you need in order to link to other
documents. A relative URL usually contains only the last part of the
absolute URL — the directory name (possibly) and the filename. You
use relative URLs to link to locations within the same folder or same
group of folders.

To go back to the postal address analogy, if you're giving a local friend
directions to your apartment, you’d probably provide just the street
address, building, and apartment. The city and state are implicit. In the
same way, a relative URL implies the missing information based on

the location of the file containing the relative URL. The browser infers the
missing information from the location of the document containing the
link.

Check out Figure 3-1, which shows you how absolute URLs and relative
URLSs work.

HTML http://cat.feline.org/
+ ||Document| = funny.html
Absolute URL pointing to
funny.html.

cat.feline.org funny.html

http://cat.feline.org/
HTML fur/fuzzy.html

Document Absolute URL pointing
to fuzzy.html, in the fur
T folder, on the
fuzzy.html cat.feline.org server.

i + Dolgjl\n%nt - /furffuzzy.html
Relative URL pointing
; to fuzzy.html, in the fur
fur fuzzy.html folder, on whatever

server the link is on.




Making Links '3 ]

Understanding Anchors

The linking process begins with anchors; this term is just a fancy way of
saying links. (Folks call them anchors because the tag is <A>.)

Anchor tags are generally used with one of the following two attributes:

4+ HREF: Enables users to jump from one bit of information to another —
either to material within the same Web site or to other material out on
the Internet. These tags create the hyperlinks.

4+ NAME: Labels a spot within a document. That spot can then be part of

a URL so that readers can jump directly to it. The NAME anchor is useful c::":zlrls
in long documents that users must otherwise scroll through. If NAME v
anchors and links to them are present, users can jump to specific infor- -
mation and don’t need to wade through pages of material. 2z
45
8
Table 3-1 Common Anchor Tags and Attributes 52
HTML Tag or Attribute  Effect Example g g
SA> LKA Marks anchor <A HREF="http://www. ¢

dummies.com">Click to
visit the Dummies site</A>

HREF="..." Indicates where <A HREF="#middle">C1ick
to jump tojump to the middle of
my Web page</A>
NAME="..." Identifies an <A NAME="middle"></A>
internal label

Making Links

Links are the connections to other material within or among HTML docu-
ments. Links are visible as (often blue) text that you select as you're surfing
the Web. (After you link to a document, the link often appears in a different
color to indicate that you've already been there.)

The next three sections show you how to link to other documents within your
site, link to HTML documents “out there” on the Web, and link to other infor-
mation on the Internet. For now, you work with the <A> tag’s HREF attribute.

Linking to documents within your site

Start with plain text and build your first hypertext link. To make things easy
on yourself, work with two (preferably small) HTML documents at first so
that you can link from one to the other and back again. Practicing linking is
much more difficult if you work with just one document.
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Note: Before you begin the example in this section, open your text editor
and browser. While you follow these examples, you should also have avail-
able a basic HTML document, such as the following:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

CHTML><HEAD><TITLE>Cats</TITLE></HEAD>

<BODY>

</BODY>

</HTML>

Follow these steps to build your first hypertext link:

1. Enter the text you want to appear on the page between the <BODY>
tags, as the following example shows:

<BODY>
Cats are funny.
</BODY>

2. Apply the anchor tags to the text that you want to be the anchor (the
part your visitors click to link to something else):

Cats are <A>funny</A>.
3. Add an attribute (HREF, in this case) to link to another document:
Cats are <A HREF="funny.html">funny</A>.

The HREF attribute specifies which document appears after your readers
click the anchor. And funny.html is the name of the document to which
you're linking.

In this case, funny.html is a file in the same directory or folder as the docu-
ment you're building.

Linking to pages out on the Web

To create links to other documents on the Internet, follow the same proce-
dure as with other links and include the complete URL in the HREF attribute.

To make a link from the word cats to a completely different address on the
Web, use the following example, starting with the following basic HTML
document.

Note: Before you begin, open your text editor and browser.
<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01

Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">
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<HTML><HEAD>KTITLE>Cats</TITLE></HEAD>
<BODY>

</BODY>

</HTML>

Use the following steps to add a link to a document at another location:

1. Type Cats are funny. between the <BODY> tags:

<BODY>
Cats are funny.
</BODY>

2. Add the following anchor tags:
<A>Cats</A> are funny.

3. Add the HREF attribute to link to a sample (fictitious) Web site about
cats:

<A HREF="http://cats.com/home.html">Cats</A>
are funny.

You can also link to non-HTML files from a regular http:// type of address.
If, for example, you have a Word document that you want people to be able
to download from your Web site, you can add a link such as the following:

<A HREF="catjokes.doc">Download original cat
stories hered/A>.

Or, you can use an absolute URL, like this one:

<A HREF="http://cat.feline.org/furry/catpix.jpg">
Download a picture of the cutest cat in history</A>.

Then all you need to do is upload the catjokes.doc and catpix. jpg files
to the server at the same time as you upload your HTML document to the
server.

Linking to other stuff on the Internet

Just as you can link to HTML documents or images or files on the Internet
by including the right URL, you can also link to other types of information
(such as discussion groups or file archives) on the Internet. All kinds of
other protocols (the language that computers use to transfer information)
are in use.

For example, if you see or hear of neat material on the Internet that’s avail-
able through an FTP (File Transfer Protocol) site, you can link that material
into your document.
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Suppose that your best friend found a collection of cat jokes at an FTP site
on the Internet. You can simply copy the URL from your friend. The URL
may look something like ftp://humor.central.org/jokes/animals/
cats.zip. You can put that URL into your document, as shown here:

A collection of <A HREF="ftp://humor.central.org/jokes/
animals/cats.zip"> cat jokes</A> is good to have.

To create a hyperlink to an e-mail address, type this line:

<A HREF="mailto:me@mycompany.com">E-mail me</A>

Making Links within Documents

Making links to places within an HTML document requires a little more work
than creating links to other documents. On regular links to other documents
or to documents on other servers, you just point to a computer and a file. If
you’re going to point to a place within a document that you’re creating, how-
ever, you must also identify the targets to which you intend to link.

Matking internal links

An internal link points to a specific location within a document. Internal
links work well if you have a long HTML document that really doesn’t lend
itself to being split into different files. If you're dealing with one of these long
documents, you can use internal links to point from one place to another
within the same document. As a result, readers don’t need to scroll through
pages of information; they can just link to a place (defined by a special
anchor) within the document.

Within the kitten.html file, you may have a long list of favorite kitten
names along with a description of the names’ origins. You can enable read-
ers to jump right to the W names without needing to scroll through the A
through V names. The following URL points directly to the w anchor within
the kitten.html file. (I show you how to create the named w anchor in the
next section.)

kitten.htmltw

You can also write the relative URL this way:
fur/kitten.htmlifw

or

/fur/kitten.html{fw
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Or, you can write the address as the following absolute URL:

http://cat.feline.org/fur/kitten.htmlffw

Matrking internal targets

Developing anchors to permit links to points within a document is quite sim-
ilar to creating the links themselves. You use the NAME attribute to create
internal targets (also called named anchors).

(In the preceding section’s hypothetical example, the author of kitten.htm]
inserted name anchors for all 26 A-Z headings, just so that you can link to
them.)

For the following example, imagine that you have within your document the
heading “Funny Cats I've Known,” as shown here:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML><HEAD>KTITLE>Cats</TITLE></HEAD>

<BODY>

<H2>Funny Cats I've Known</H2>

General information about the cats would be here.

</BODY>

</HTML>

Follow these steps to add an anchor to your page:

1. Include an anchor:
<H2><KA>Funny</A> Cats I've Known</H2>
2. Insert the NAME attribute:

<H2><A NAME="funny">Funny</A> Cats I've
Known</H2>

This anchor doesn’t show up in the browser view of your document, but
you know that it’s there.

If you want to link directly to the funny cats section of your document
from within the same document, you include a link to funny by using the
hash (#) sign:

<A HREF="#funny">Funny cats</A> are here.
The ##funny anchor to which you want to link, for example, may be in the

cats.html file on the server named cat.feline.org. You just create a
URL that looks like this:
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http://cat.feline.org/cats.html#funny

Your friends and admirers can then set up links to your funny cats section:

Boy, you know, those <A HREF="http://
cat.feline.org/cats.html#funny">funny cats
</A> are something else.

Using a Link-Checker Utility

As you no doubt noticed if you spend much time surfing the Web, Web sites
come and go with lightning speed. Unfortunately, this volatility means that
the links you create to other peoples’ Web pages can break at any time.
Although broken links may not be a problem if you're creating a personal
home page, it reflects poorly on a professional or business-related site.

The only way to prevent broken links is to check them periodically.
Checking links yourself — by loading your own Web page into a browser,
clicking each link, and noting whether the linked site appears — can be
awfully time-consuming, depending on how many links you've created. To
automate the process, you can use a link-checker utility. A link-checker util-
ity follows all the links in your Web page and then issues a report telling you
which ones are broken. (You then decide whether to delete or change any
links reported as broken.)

<MECD

Not surprisingly, most HTML editing tools (including Dreamweaver — check

out the trial version on the CD that comes with this book) include a link-

checker utility.

S

If you haven’t decided on an HTML tool, however, you can still check your
links by visiting an online link-checking utility, such as the World Wide Web
Consortium’s link checker: http://validator.w3.org/checklink.



Chapter b: Working with Images

In This Chapter

v+ Adding images to your Web page
1 Making downloads go quicker

v Adjusting image alignment

» Maximizing blank space

1 Creating clickable images

If you’re interested in incorporating images into your Web pages (and
who isn’t?), you’re in luck: This chapter shows you everything you need
to know. In it, you find out how to add images, position them on the page
attractively, and even make them clickable. (As you may be able to guess,
clickable images are images that do something — for example, load another
Web page — when someone viewing your page clicks them.)

Note: If you want to create images that respond differently based on where
users click them — in other words, if you want to create image maps —
check out Book V.
¥ Before working through the examples in this chapter, make sure that your
browser and text editor are open and ready to create a new document. You
should also have an image available to use in the document.

Adding Images

Adding images to your HTML documents is just as straightforward as the
basic link and text tags are. (An image can be a picture, drawing, diagram, or
what-have-you.)

You can include images with either GIF (usually pronounced “jiff”), JPG (pro-
nounced “jay-peg”), or PNG (pronounced “ping”) file formats. These formats
are compressed, so they take up minimal disk space and downloading time.
You choose which format to use based on the image itself.

4+ Choose GIF images for line drawings, images with only a few colors,
images that blend into the background, or animated images. GIF remains
a popular file format because all graphical browsers can interpret and
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display them and because transparent images are far spiffier than the
regular kind. (Transparent images contain see-through portions, so they
can be any shape — unlike regular images, which are always square.)

4+ Choose JPG images for photographic images or images with fancy shad-
ing. JPG files are considerably smaller than GIF files in terms of disk
space and, therefore, don’t take f-o-r-e-v-e-r to download to your read-
ers’ browsers.

4+ Choose PNG images if you have photographic or complex images and
you know that your readers will be using newer browsers: Microsoft
Internet Explorer 6 and Netscape Navigator 7.1 or newer.

Adding images isn’t too complicated: Just include an <IMG> tag and the SRC
attribute, pointing to a valid URL (either absolute or relative) for your
image.

Table 4-1 shows some common image-related tags and attributes:

Table 4-1 Common Image Tags and Attributes
HTML Tag or Attribute Effect Example
<IMG SRC="..."> Inserts an image <IMG SRC="myPicture.
gif">
ALT="..." Specifies the text to <IMG
display if the image SRC="myPicture.
isn't displayed gif" ALT="Photo of
Australian shepherd">
BORDER=n Controls the thickness <IMG SRC="myPicture.
of the border around an gif" ALT="Photo of
image in pixels Australian shepherd"
BORDER=5>

The following example shows you how to add an image to your document.
To include an image in your document, follow these steps:

1. Start your HTML page:
Start with the following sample of HTML code:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/html4/frameset.dtd">

<HTML>

<HEAD>XTITLE>My Family Photo Album</TITLE></HEAD>

<BODY>

<H1>Photos circa 1940</H1>



Figure 4-1:
Using the
<IMG> tag
to add an
image to
your Web
page.
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</BODY>
</HTML>

2. Add the <IMG> tag wherever you want your image to appear, as
shown in the following example:

<H1>Photos circa 1940</H1>
<IMG>

3. Add the SRC attribute to provide the address of the image, as the fol-
lowing example shows:

The image I'm using is named winchest. jpg, and it’s in the same folder
as my HTML document:

<IMG SRC="uncleNeil.jpg">

4. Add the ALT attribute to describe the image, just in case viewers can’t
view (or choose not to view) the image:

<IMG SRC="uncleNeil.jpg" ALT="Photo of Uncle Neil taken
at Clear Lake">

The resulting Web page looks like what you see in Figure 4-1.

. File Edit View Favorites Tools Help i
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Photos circa 1940
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Figure 4-2:
Using the
ALT
attribute of
the <IMG>
tag displays
alternative
text to
viewers
who can't
see the
image.

Technically, you don’t have to provide the ALT text (which stands for alter-
native text) with the image; however, doing so is a good idea. Sometimes,
people use browsers — including read-aloud browsers for the visually
impaired — that can’t display images.

Section 508 of the U.S. Rehabilitation Act requires all U.S. government (and
government vendor) Web sites to include ALT attributes where appropriate.
You can find out more about accessibility by checking out the WebSite Tips
Accessibility page (www.websitetips.com/accessibility), the World Wide
Web Consortium’s Web Content Accessibility Guidelines, (www.w3.0rg/TR/
WAT-WEBCONTENT), or the U.S. government site devoted to Section 508
(/www.section508.gov).

Many people also commonly stop their browsers from showing images so
that they don’t need to wait for the images to copy to their computers over
slow modem connections.

By using alternative text, you tell people what they’re missing rather than
make them guess. As a bonus, many browsers use the alternative text for
those cute little pop-up blurbs that appear when you hover your mouse
over images.

Figure 4-2 shows you an example of how the alternative text may look to
readers viewing the same page without the images.

[ET Wy Family Pliota Album - Microsoft litarnet Explorer §=[C)% |
- File Edit View Favorites Tools Help w
Dt @ X [B] @ Pwen Srraates @ede )] (2 5 LU EE®
Cacbess | flespicioie_3_t bl v Ee

Photos circa 1940

[] Photo of Uncle Mal taken 2 Clear Lake

&] Done My Computer
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Finding images to use in your Web pages

Unless clearly stated otherwise, all images are Internet that offer clip art or Web art that's free
copyrighted. Don't even think about copying for noncommercial use. Check out Yahoo! (www .
images from other peoples’ Web sites and using  yahoo. com) by typing and searching for clip art.
the images in your own pages. Instead, check  You should be able to find all you could ever use.
out one of the hundreds of good sites on the

Optimizing Images for Quick Download

\\3

Images take quite a while to download (particularly over a slow Internet
connection), and readers are likely to give up on your Web site and move on
if the images take too long to appear on-screen. If you're on a fast Internet
connection or if you're testing your HTML documents directly from your
hard drive (as most people do), you probably don’t notice how long some
images take to load; 28.8 Kbps or 56.6 Kbps modems (which are still
common) take a long time to transfer images — sometimes up to several
minutes.

You can shorten the time images take to download in either of the following
two ways:

4 Reduce the image’s file size. You do this when you create an image, as
described in Book V.

4 Indicate image dimensions in the HTML document by using the WIDTH
and HEIGHT attributes associated with the <IMG> tag.

Thumbnail images, covered later in this chapter in the section “Making
Clickable Images,” can also be helpful in managing the “World Wide Wait”
when you want to use large images.

You specify the dimensions of an image (generally displayed on the title bar
or status bar of image-editing programs) by including height and width
attributes in the <IMG> tag. When you do so, browsers leave space for the
image, finish loading the text (at which point your readers can start read-
ing), and then continue loading the images. The images don’t really load
faster, but specifying the image size can help readers think that the images
are loading faster, which is almost as good. The numbers you specify for
height and width specify the size in pixels, which are those itty-bitty dots
on-screen that make up the image.
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Controlling Image Alignment

Table 4-2 shows the attributes used to specify image height and width:

Table 4-2 Image Height and Width Attributes

HTML Attribute Effect Example

HEIGHT=n Specifies the height of the <IMG SRC="picture.gif"
image in pixels HEIGHT="200">

WIDTH=n Specifies the width of the <IMG SRC="picture.gif"
image in pixels WIDTH="150">

The code for specifying HEIGHT and WIDTH attributes looks something like
this:

<IMG SRC="auntEliza.gif" ALT="Aunt Eliza on her wedding day"
WIDTH=300 HEIGHT="300">

Controlling Image Alignment

A\\S

By default, browsers align images on the left side of the page. If you want,
you can realign the images so that they appear aligned at the right or
aligned vertically.

HTML 4.0 (and 4.01) recommends that you use style sheets to control image
alignment rather than use the attributes given in this section. However,
using the attributes you find in Table 4-3 can be useful if the folks visiting
your site are using old browsers — for example, versions of Internet
Explorer before version 6 and versions of Netscape before 7.1. See Book II,
Chapter 8, for the lowdown on style sheets.

Table 4-3 shows the attributes used to control image alignment:

Table 4-3 Image Alignment Attributes
HTML Attribute Effect
ALIGN="bottom" Aligns the bottom of the image with the baseline of

the current line

ALIGN="Teft" Allows an image to float down and over to the left margin
(into the next available space); subsequent text wraps to
the right of that image
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HTML Attribute Effect
ALIGN="middle" Aligns the baseline of the current line with the middle of
the image
ALIGN="right" Aligns the image with the right margin and wraps the text
around the left
ALIGN="top" Aligns the text with the top of the tallest item in the line
HSPACE=n Controls the horizontal space (white space) around the
image in pixels
VSPACE=n Controls the vertical space (white space) around the image
in pixels
Book |
L. . . . Chapter 4
All you need to do is include these attributes in the <IMG> tag in your HTML
document. The order of the attributes within the <IMG> tag isn’t important.
You can put them in the order that you find most convenient. The following s
HTML code shows you how to align an image to appear on the right side of 5 -‘:-_
the page: &5
85
«
<IMG SRC="auntEliza.jpg" ALT="Aunt Eliza on her wedding day" =

ALIGN="RIGHT">

Surrounding Images with Blank Space

You can include these alignment effects by adding vertical and horizontal
space around the images.

Just add the HSPACE or VSPACE attributes (or both). The n is the number of
pixels wide that the space should be on each side of the image; thus, the
total width that is added is two times n. Here’s an example:

<IMG SRC="cousins.jpg" ALT="Girl cousins" ALIGN="Tleft"
HSPACE=50>

<IMG SRC="cousins2.jpg" ALT="Girl cousins - second take"
ALIGN="right" HSPACE=50>

Figure 4-3 shows you the results of the extra space around the images.

Note: If most of your readers will be using HTML 4.0-compliant browsers,
such as Internet Explorer 6 (and higher) and Netscape 7 (and higher), con-
sider achieving the same effects with style sheets, covered in Book II,
Chapter 8.
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Figure 4-3:
Using the
HSPACE
attribute of
the <IMG>
tagto
surround
images with
blank space.
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Making Clickable Images

You can use images as your anchors for making links. Using images as
anchors isn’t any more complicated than creating a link and then adding an
image.

Note: If you want to create images that respond differently based on where
users click them — in other words, if you want to create image maps —
check out Book V.

To use an image as the anchor to link to another document, follow these
steps:

1. Start your HTML document:

Your document may look similar to the following example:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML>

<HEAD><TITLE>My Family Photo Album</TITLE></HEAD>

<BODY>
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<H1>Click a picture for more information</H1>
</BODY>
</HTML>

2. Add alink, as shown in the following example:

<H1> Click a picture for more information </H1>
<A HREF="cousinInfo.html"><A>

For more information about links, take a look at Book II, Chapter 3.

3. Add the <IMG> tag between the opening and closing link tags
(between <A> and </A>):

<A HREF="cousinInfo.html"><IMG><A> Book Il
4. Add the SRC attribute to the <IMG> tag: Chapter 4
(Remember: This attribute tells which graphical image you’re including
in your HTML document.) =
)
<A HREF="cousinInfo.html"><IMG SRC="cousins.jpg"><A> g =
=
5. Add the ALT attribute to the <IMG> tag, as shown in the following ‘e ";
example: =

(Remember: This attribute tells what text to display if the image isn’t
displayed.)
<A HREF="cousinInfo.html"><IMG SRC="cousins.jpg"
ALT="Gir1l cousins"></A>

The Web page looks something like what you see in Figure 4-4.

Notice that the image shown in Figure 4-4 contains a border. It’s the same
color as other links in the document, which indicates to readers that the
image links to other information or files.

You can remove the border from around the linked image. To do so, just
add the BORDER attribute to the <IMG> tag with the value BORDER=0. For
example:

<A HREF="cousinInfo.html"><{IMG SRC="cousins.jpg"
ALT="Girl cousins" BORDER=0></A>

Making an image into a link is useful when you want to link a small thumbnail
image file to a large, full-size version. (Using thumbnail images is a good idea
if you have many images or very large images on your Web page because
visitors get the idea of what the pictures look like but don’t need to wait all
day for the bigger image files to download.) To link a thumbnail image to a
full-size version, follow the steps described in the preceding example, placing
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Figure 4-4:
This image
isalsoa
link,
courtesy of
the <A> and
<IMG> tags.

the name of the full-size image in the link and the name of the thumbnail
image in the SRC attribute. For example:

<A HREF="big_img.Jjpg"><IMG SRC="thumb_img.jpg" ALT="Thumbnail
image"></A>
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Chapter 5: Controlling Page Layout

In This Chapter

v Creating tables
v~ Using horizontal rules

v Causing line breaks

' his chapter introduces you to some nifty things you can do with HTML
to format your pages attractively.

You need to be familiar with the basic HTML tags before diving into this
chapter. Most examples in this chapter include only the tags and attributes
discussed under a particular heading and don’t include structure or body
tags. | assume that you know where structure and body tags are placed. If
you don’t, you may want to refer to Book II, Chapter 1.

Although not as widely supported as tables, layers are another way to
create slick-looking layouts for your Web site. You can use an HTML editor,
such as Dreamweaver, to work with layers easily. See Book IV, Chapter 7, for
details.

Developing Tables

Tables are not just for dinner any more. In the context of HTML, tables are
quite handy for the following purposes:

4+ Lining up material vertically and horizontally
4+ Making creative layouts

4 Placing text next to graphics

Table 5-1 shows the tags and attributes used to create tables.
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Table 5-1 Creating Tables
HTML Tag or Attribute Effect Use in Pairs?
<TABLE>...</TABLE> Indicates table format Yes
BORDER=n Controls table border No

width in pixels; 0 specifies

no border
<TD>...</TD> Indicates table data cell Yes
<TH>. . .</TH> Indicates table headings Yes
<TR>...K/TR> Indicates table row items Yes

These steps describe how to create a table, such as the one that follows,
with two rows and two columns. Note: Before you begin, make sure that
your browser and text editor are open and ready to create a new document.
Or, you can apply this information to an existing document.

Culprit Water Balloon Skills
Deborah Fair
Eric Excellent

Follow these steps to create a simple table:

1. Type text, row by row, using a space or two between row elements:
Culprit Water Balloon Skills

Deborah Fair
Eric Excellent

2. Insert <TABLE> tags before and after the text to indicate the <TABLE>
information to be inserted into the table:

<TABLE>

Culprit Water Balloon Skills
Deborah Fair

Eric Excellent

</TABLE>

3. Add <TR> tags to show where the table rows should be placed.

(Remember: TR stands for table rows, and rows go across the page.)

<TABLE>

<TR>Culprit Water Balloon Skills</TR>
<TR>Deborah Fair</TR>

<TR>Eric Excellent</TR>

</TABLE>
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4. Add pairs of <TH> tags to show where the table heading cells go (in
the top row).

At this point, adding some spacing may help you more easily see what’s
going on:

<TABLE>

<TR><TH>Culprit</TH>

<TH>Water Balloon Skills</TH>

</TR>

<TR>Deborah Fair</TR>

<TR>Eric Excellent</TR>

</TABLE>

5. Add pairs of <TD> tags to indicate the individual data cells of a table:

<TABLE>

<TRO>KTH>Culprit</TH>

{TH>Water Balloon Skills</TH>

</TR>

{TR>KTD>Deborah</TD> <TD>Fair</TD></TR>
<TRO>KTDY>Eric</TD> <TD>Excellent</TD></TR>
</TABLE>

6. Add the BORDER attribute to the <TABLE> tag to create lines around
each table cell:

{TABLE BORDER=1>

<TRO>KTH>Culprit</TH>

{TH>Water Balloon Skills</TH>

/TR

{TR><TD>Deborah </TD> <TD>Fair</TD></TR>
{TR><TD>Eric </TD> <TD>Excellent</TD></TR>
</TABLE>

Figure 5-1 shows the result of all this work.

Experiment with tables. You can come up with many creative layouts and
page designs. Here are some ideas:

4+ Embed images in tables (to align graphics and text the way you want).

4+ Place text in table cells to make columns — like a newspaper.

4+ Place headings to the left (or right) of a paragraph of text.
If you find that your tables have problems — or don’t seem to work — make
sure that your tags are paired correctly and that you haven’t omitted any
tags. Printing a copy of your HTML code and marking pairs of tags are some-

times necessary for troubleshooting tables. As you can see from the very
small example in the text, getting confused is easy because of all the different
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Figure 5-1:
Use the
<TABLE>
tagto
create nice,
even rows
and
columns.

tags necessary for tables. Additionally, save yourself some trouble by liber-
ally using white space and blank lines as you create the table. The extra
white space can help you see what’s going on.
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Embedding Horizontal Rules

HTML allows you to break up Web pages by applying a horizontal rule:
<HR>. This horizontal rule can serve as not only a visual break for long
pages but also an informational break. Table 5-2 illustrates the tag used to
create horizontal rules and the attributes that let you format them.

Table 5-2 Adding Horizontal Rules

HTML Tag or Attribute Effect

<HR> Applies a horizontal rule.

SIZE="number" Indicates how thick the rule is.
WIDTH="number" Specifies an exact width in pixels or percentage

(%) of document width. A percentage value must appear in
quotes, like WIDTH="50%".

ALIGN="LEFT", Specifies the alignment; works only in combination
"CENTER",or "RIGHT"  with WIDTH.




Figure 5-2:
Using the
<HR> tag to
create
horizontal
rules helps
you divide
page
content for
easy
reading.

Embedding Horizontal Rules

To use horizontal rules, apply the following tags and attributes:

<P><EM><H1 ALIGN=CENTER>Lost
Cat!</HI>/EM>L/P>

<HR WIDTH=80% ALIGN=CENTER>

<HR WIDTH=60% ALIGN=CENTER>

<HR WIDTH=40% ALIGN=CENTER>

<P>Fuzzy tortoise shell Persian--lost in Big
Lake area. Probably Tooks confused.</P>

<HR>

<P>Answers to:

<UL>

<LI>Winchester

<LI>Hairheimer

KLI>Fritter

<LI>Sound of can opener

<JUL>L/ P>

<{P>Please call if you find him: 555-9999</P>

<HR WIDTH=200>

<HR WIDTH=400>

<HR WIDTH=200>

Figure 5-2 shows the effects of these tags.

A Lost Cat! - Microsoft Internet Explorer
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Getting carried away with horizontal rules is easy. Figure 5-2 shows horizon-
tal rules used to excess. You should use these rules only where they help
readers find information more easily or help them wade through long pas-
sages of information.

You can also use style sheets (covered in Book II, Chapter 8) to format hori-
zontal rules.

Forcing Line Breaks

HTML allows you to break lines of text so that you can determine exactly (or
as much as possible) how they appear on the users’ end.

Table 5-3 shows the tag used to force line breaks.

Table 5-3 Inserting Line Breaks
HTML Tag or Attribute Effect Use in Pairs?
<BR> Breaks line; new line No
begins after tag
CLEAR="..." Requiresthat LEFT, RIGHT, No

NONE, or ALL margins are
clear before new line starts

To break lines of text so that each line appears the way you want (for exam-
ple, in a poem), use the <BR> tag as in the following block of code.

<BODY>

<P

I'm Hungry, I'm Hungry! I said with a
sigh,<BR>

I want to cancel dinner and go straight to my
pie.<BR>

I want cake and ice cream and toast with
jelly,<BR>

And I don't care if I grow a big belly.<BR>

</P>

</BODY>

If you include a line break and want to make sure that the new line starts
after an image, for example, add the CLEAR=ALL attribute to the <BR> tag.
That forces the new line below all other objects on the line.
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Figure 5-3 shows the effects of these line breaks.

<3 Ode to Food - Microsoft Internet Explorer
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Chapter 6: Creating Forms

In This Chapter

v+ Adding a basic form
v Working with buttons, check boxes, and radio buttons

v Adding pizzazz with selection lists, text fields, and more

Flis chapter introduces forms, which you may think of as online versions
of hard-copy forms that have check boxes and blanks to fill in, among
other possible features. These online forms can help you get feedback and
information from the folks who visit your Web site.

To develop a fully functional form, you need the help of your server admin-
istrator. In this chapter, I tell you where you need to ask for help and what
information to request.

Creating a Basic Form

In HTML, forms are just what they are in real life — a fairly impersonal and
effective means of getting standardized information from other people. You
may use forms to

4 Conduct a survey.

4+ Collect addresses or information about visitors to your site.

4+ Enable people to register for something.

Table 6-1 shows you the basic <FORM> tags and attributes you can use.
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Table 6-1 Creating Forms

HTML Tag or Attribute Effect Example

<FORM...> ... </FORM> Enclosesthe <FORM METHOD ="POST"
entire form. ACTION="http://www.

yourServer.yourScript">
form components</FORM>

ACTION="..." Identifies what <FORM METHOD ="POST"
should happen to ACTION="http://www.
the data after the yourServer.yourScript">
form is submitted. form components</FORM>

METHOD="..." Identifies methods; <FORM METHOD="POST"
valid options are ACTION="http://www.
GET or POST — yourServer.yourScript">
one is required. form components</FORM>

When you create forms, you need to make sure that the information gets
back to you after readers fill out the form and click Submit. Although form
results can be processed and returned in various ways, your server adminis-
trator most likely has the server set up to e-mail form results directly to
you.

The basic <FORM> tag is a two-parter, having both an initial tag and a closing
tag. You can use the <FORM> tag to have information sent back to you
directly or to a program that compiles the information for you.

The <FORM> tag has two primary (essential) attributes:

4 ACTION: Tells the server what to do with the information after the
server receives it.

4 METHOD: Tells the server how to get the processed information back to
you.

Exactly what you fill in as values for these two attributes depends on what
your server administrator tells you. So, before you get started creating your
form, go ahead and contact your server administrator and tell her that you
want to create a form that can be e-mailed to your personal address and ask
what you should fill in for the ACTION and METHOD attributes.

For example, my administrator told me to use the following elements:
ACTION="http://www.raycomm.com/

cgi-bin/email?raycomm"”
Method=POST
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Notice that the rest of the examples in this chapter are constructed based
on this information. Just ask your server administrator exactly what to use
(or where to look for instructions).

Before I outline how to create a form, [ assume that the following informa-
tion is true:

4 You have already contacted your server administrator and have the
ACTION and METHOD information.

4 You have your HTML document open in an editing program.

4 You have opened the HTML document in your browser so that you can
view and test the document.

To include a form in your Web page, follow these basic steps:

1. Start with a basic HTML document, similar to this one:
<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01

Frameset//EN"
"http://www.w3.0rg/TR/html14/frameset.dtd">

<HTML>

<HEAD>XTITLE>Survey: How to Get the
Cats</TITLE></HEAD>

<BODY>

<H1>Survey: How to Get the Cats</HI1>

<P>We've decided to take a survey about the best pranks
to play on the cats. Please complete the survey and
click the Submit button.</P>

</BODY>

</HTML>

2. Add the <FORM> and </FORM> tags to show where the form goes:

Please complete the survey and click the Submit
button.</P>

<FORM>

</FORM>

</BODY>

</HTML>

3. Add the information that your server administrator gave you for the
ACTION and METHOD attributes.

Remember that this information is what my administrator told me to
fill in.
<FORM METHOD="POST"
ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">
</FORM>
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At this point, you can’t see anything different about your page. Nor can you
test the page to find out whether it works. Just forge ahead, finish up the
form, and satisfy your curiosity:.

Using Form Components to Collect Information

After you have the basics of the form under control, you should include
some <INPUT> fields so that you can start collecting information. The basic
form-input tags (see Table 6-2), in many permutations, should carry you
through the next several sections.

Table 6-2 Form-Input Tags

HTML Tag Effect Example

or Attribute

CINPUT...> Identifies some type <INPUT TYPE="SUBMIT">
of input field.

CHECKED Shows which item is selected <INPUT TYPE="CHECKBOX"

by default (used with check box CHECKED>
and radio button).

MAXLENGTH=n Indicates the maximum number of <INPUT TYPE="TEXT"

characters in the field width. MAXLENGTH=25>
NAME="..." Indicates the name of the field. <INPUT TYPE="TEXT"
NAME="HomeAddress">
SIZE=n Displays field n characters wide. <INPUT TYPE="SELECT"
SIZE=4>
TYPE="..." Indicates the type of field. Valid <INPUT TYPE="RADIO">

types are TEXT, PASSWORD,
CHECKBOX, RADIO, SUBMIT,
RESET, FILE, IMAGE, BUTTON,

and HIDDEN.

VALUE="..." Indicates the value of the button <INPUT TYPE="BUTTON"
(and the label for Submit and VALUE="CTick this
Reset). button">

Including Submit and Reset buttons

After you create a form, you need to add Submit and Reset buttons that
readers click to submit the form (or start over again if they goof up). The
Submit button sends the information after your readers click it, whereas the
Reset button just clears the input from the form.

To include Submit and Reset buttons, enter the following text and tags in
your HTML document.
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Remember: You need a functional form before you start adding Submit and
Reset buttons.

<FORM METHOD="POST" ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">

<INPUT TYPE="SUBMIT" VALUE="Submit">

<INPUT TYPE="RESET" VALUE="Reset">

</FORM>

To change the text that appears on the Submit and Reset buttons, change
the values associated with the VALUE attributes of the Submit and Reset but-
tons, respectively. Here’s an example:

<INPUT TYPE="RESET" VALUE="Forget it!">

Including check boxes, radio buttons, and more

Check boxes and radio buttons are the objects that users can click to select
choices from a list. Check boxes allow you to select multiple options. Radio
buttons are designed so that you can choose only one from a list — just like
with pushing buttons on a car radio. Both check boxes and radio buttons
are variations on the <INPUT> field. You see examples of both in the follow-
ing sections.

Making check boxes

Making check boxes isn’t complicated: You use several tags, but the process
is the same as creating anything else with HTML.

Note: You need to have a functional form, including Submit and Reset but-
tons, before you add check boxes. Start with the following example — just a
section of a complete document — and build on it:

<FORM METHOD="POST"
ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">

<INPUT TYPE="SUBMIT" VALUE="Submit">

<INPUT TYPE="RESET" VALUE="Reset">

</FORM>

To use check boxes in your document, follow these steps:

1. Enter <INPUT TYPE="CHECKBOX"> on the blank line after the begin-
ning of the form:
<FORM METHOD="PQOST"

ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">
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<INPUT TYPE="CHECKBOX">

<INPUT TYPE="SUBMIT" VALUE="Submit">
CINPUT TYPE="RESET"VALUE="Reset">
</FORM>

2. Insert the text that you want people to see behind that check box.

Until you do so, they see a check box with no description.

<FORM METHOD="POST"
ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">

<INPUT TYPE="CHECKBOX">Throw a balloon!

<INPUT TYPE="SUBMIT" VALUE="Submit">

<INPUT TYPE="RESET" VALUE="Reset">

</FORM>

3. Identify the name of the <INPUT> field.

You see this field as you're reading the input from your form. Make the
name something short and logical.

<FORM METHOD="POST"
ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">

<INPUT TYPE="CHECKBOX" NAME="Throw">
Throw a balloon!

<INPUT TYPE="SUBMIT" VALUE="Submit">

<INPUT TYPE="RESET" VALUE="Reset">

</FORM>

4. Enter the text you want to see if someone selects this option, as
shown in the following example:

<FORM METHOD="POST"
ACTION="http://www.raycomm.com/
cgi-bin/email?raycomm">

<INPUT TYPE="CHECKBOX" NAME="Throw"
VALUE="ThrowBalloon"> Throw a balloon!

<INPUT TYPE="SUBMIT" VALUE="Submit">

<INPUT TYPE="RESET" VALUE="Reset">

</FORM>

5. Enter a couple more lines to complete the list because, of course, you
don’t want a check box list with only one item to check.

<INPUT TYPE="CHECKBOX" NAME="Throw"
VALUE="ThrowBalloon"> Throw a balloon!

<INPUT TYPE="CHECKBOX" NAME="Hurl" VALUE="HurlBalloon">
Hurl a balloon!

<INPUT TYPE="CHECKBOX" NAME="Lob"™ VALUE="LobBalloon">
Lob a balloon!
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6. Enter a CHECKED attribute in the check box that you want to have
selected by default, as shown in the following example.

Do so if you want to select a check box in advance to give a recommen-
dation or to make sure that something gets checked.

<INPUT CHECKED TYPE="CHECKBOX" NAME="Hurl"
VALUE="Hur1Balloon"> Hurl a balloon!

Making radio buttons

Making radio buttons is similar to making check boxes — you use several
tags, and the process is the same as that for using other HTML tags.

Note: Before you start making radio buttons, make sure that you already
completed your functional form.

To include radio buttons in your form, follow these steps:

1. Enter <INPUT TYPE="RADIO"> and insert the text that people
should see:
<INPUT>Do it--it'11 be funny!
<INPUT TYPE="SUBMIT" VALUE="Submit">
<INPUT TYPE="RESET" VALUE="Reset">
</FORM>

2. Add the NAME and VALUE indicators.

The NAME field applies to the whole set of radio buttons, so I have
chosen a less-specific name:

<INPUT TYPE="RADIO" NAME="Prank" VALUE="Do" >Do it--
it'11 be funny!

3. Add the CHECKED attribute because this selection is the recommended
choice:

<INPUT TYPE="RADIO"™ NAME="Prank" VALUE="Do"
CHECKED>Do it--it'11 be funny!

4. Add as many more radio buttons to this set as you want, along with
line breaks (<BR> or <P>) between them, just to make them look nice.

Remember: Radio buttons are designed to accept only one selection
from the group, so make sure that they all share the same NAME field.
This way, the computer knows that they belong together:

<INPUT TYPE="RADIO" NAME="Prank" VALUE="Do" CHECKED>Do

it--it'11 be funny!<BR>
<INPUT TYPE="RADIO" NAME="Prank" VALUE="DoNot">
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Don't play a prank, meanie!<BR>

<INPUT TYPE="RADIO" NAME="Prank"
VALUE="DoNotCare">I couldn't care less.
They're your cats, and you'll have to live with
yourself.<P>

Using other input types

Other input types, such as TEXT, can be quite useful. The TEXT type allows
visitors to insert a small amount of information (such as a name or an
address) into your form.

Note: Before you start adding other input attributes, make sure that you
already completed your functional form.

To include text input areas in your form, follow these steps:

1. Insert the <INPUT> tag and the text that people should see, plus a tag
(XBR> or <P>) to force a new line:

<INPUT>Your Name<P>
<INPUT TYPE="SUBMIT" VALUE="Submit">
<INPUT TYPE="RESET" VALUE="Reset">
</FORM>
2. Add the TYPE indicator to show that it’s a text input area:

CINPUT TYPE="TEXT">Your Name<P>

3. Add the NAME indicator:
<INPUT TYPE="TEXT" NAME="name">Your Name<P>

4. Add the SIZE indicator to tell the field how many characters wide it
should be:

CINPUT SIZE=35 TYPE="TEXT" NAME="name">Your Name<P>

Including select lists

Select lists are lists from which readers can choose one or more items.
The lists are similar to the font selection drop-down lists in your word-
processing program.

Table 6-3 shows you the tags and attributes used to include select lists in
your HTML documents.
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Table 6-3 Adding Lists

HTML Tag or Attribute Effect Use in Pairs?

<SELECT...> ...</SELECT> Provides a list of Yes
items to select

MULTIPLE Indicates that multiple No
selections are allowed

NAME="..." Indicates the name No
of the field

SIZE=n Determines the size of No
the scrollable list by
showing noptions

<OPTION...> Precedes each itemin Yes, optionally
an option list

SELECTED Identifies which option No by default
is selected

VALUE="..." Indicates the value No

of the field

The following steps describe how to add a select list to your form. (Note:
Before you include select lists, make sure that you already have a functional
form completed.)

1. Insert the <SELECT> tags into your document and a tag (<BR> or <P>)
to force a new line:

<SELECT>
</SELECT><P>
<INPUT TYPE="SUBMIT" VALUE="Submit">
<INPUT TYPE="RESET" VALUE="Reset">
</FORM>

2. Add the NAME attribute to the <SELECT> tag.

The NAME should be appropriately broad to cover the spectrum of

choices:

<SELECT NAME="Method">
</SELECT><P>

3. Add an <OPTION> tag defining an option that your readers can select:
{SELECT NAME="Method">

<OPTION VALUE="single">Single Balloon

</SELECT><P>

Book Il
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4. Complete your <SELECT> section by adding the other possible
choices:

{SELECT NAME="Method">

<OPTION VALUE="single">Single Balloon
<OPTION VALUE="multiple">Multiple Balloons
<OPTION VALUE="hose">Just Use the Hose
</SELECT><P>

Figure 6-1 demonstrates the addition of the select list to your form.

Including text areas

Text areas are open spaces in your form in which readers can type com-
ments or enter other information.

Table 6-4 lists the tags and attributes used to add text areas to your form.

Table 6-4 Adding Text Areas
HTML Tag or Attribute  Effect Use in Pairs?
{TEXTAREA ...> Encloses a multiline text field. Yes
. /TEXTAREAS The enclosed text is the value
displayed in the field.
COLS=n Indicates the number of No
columns in the field.
NAME="..." Indicates the name of the field. No
ROWS=n Indicates the number of rows No
in the field.

To add a text area to your form, you include the opening and closing
<TEXTAREA> tags, along with values for the NAME, ROWS, and COLS attributes:

<TEXTAREA NAME="comments" ROWS=3 COLS=40>Enter your comments
here.

{/TEXTAREAD<P>

<INPUT TYPE="SUBMIT" VALUE="Submit">

<INPUT TYPE="RESET" VALUE="Reset">

</FORM>

Check out Figure 6-2 to see the text area the preceding HTML code produces.
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Chapter 7: Working with Frames

In This Chapter

v+~ Finding out about frames

v Coming up with content

v Providing alternative content

v Creating the frameset document

+» Working with frames, links, and targets

v Trying out your framed site

F rames let you place several different HTML documents within a single
browser window, providing at least the possibility for visually interest-
ing or easy-to-navigate sites.

The bad news: Frames can get a little confusing at times, and the trouble-
shooting process isn’t always easy. If you have gotten this far with HTML,
however, nothing in this chapter should be a real problem. Just take things
one step at a time.

In this chapter, [ don’t address tag basics — I just tell you to apply them.
Check out Book II, Chapter 1, for information about tags if you need a quick
brush-up on using tags.

About Frames

Frames divide a browser window into several parts, just as a window (the
glass kind) can be divided into several panes. Each frame (or pane) consists
of an individual HTML document. In effect, using frames lets you put multi-
ple separate HTML documents on a single page, each in an individual box.

You can use frames to create a variety of layouts. For example, you may
have seen frames used as a navigational aid, such as a frame with links on
the left side of the browser window, as shown in Figure 7-1.

After readers click a link from the left frame, the linked document appears in
the right frame — thus, the navigational features stay visible at all times.
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Or, you may have seen frames used to help promote a corporate name or
image. For example, the same logo and navigation bar you find in Figure 7-1
stay in the top frame of Figure 7-2; the content in the left and lower frames
changes according to the navigation button a user selects.
Think of these frames as being a two-column or two-row table. In these
examples, the smaller of the two frames stays constant on the Web page (I
refer to the smaller frame as the navigation, or banner, page), whereas the
larger frame changes to display various HTML documents (called the con-
tent pages) in the site. The effect is that you can develop the navigation page
only one time and throw it in a frame and then be done with it — not to
mention that the frame can stay visible and fixed while other text within the
same overall browser window moves.

A\\S

You can provide a bunch of frames in a browser window, but that technique
quickly becomes complex for you (the author) and your readers. Two or
three frames are plenty.

Frames do have a few disadvantages. Whereas most browsers these days
can display frames, not all readers like them. One reason is that readers
can’t easily bookmark framed content. If you do frames well, however, most
of your readers can at least tolerate them, and frames are quite widespread.
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Creating a framed site requires planning above all else. First, sit down and
sketch out where you want frames to be placed, and give them descriptive
names, such as “banner,” “body,” “index,” and “text.” You should also note
on your sketch which frame provides the navigation page (and therefore
stays constant) and which frame provides the content pages (and therefore
changes). Planning this information now helps you develop content, set up
the frames, and set up navigation between the frames.

The sample site you see in Figure 7-2 puts the corporate logo and some navi-
gational links in the top frame, which should take only about 20 percent
(about 100 pixels) of the total area of the window. The top frame acts prima-
rily as a navigational tool; the bottom frame contains the new (changing)
content of each link.

The following steps outline the process of creating frames after you finish
planning and sketching; I discuss each step in more detail in the following
sections:

1. Develop content for each frame.

2. Develop alternative content for browsers that cannot accommodate
frames.

Book I
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Establish the frameset document.
Set up the frames.

Target the frames.

S s W

Test the frames extensively — in as many different browser/computer
combinations as possible.

Developing Content

WMBER
@%
&

\\J

Developing content for your framed Web site doesn’t really pose unique
challenges because the content is just a bunch of HTML documents, just like
the ones you see in all the other chapters in this book.

You start by developing an HTML document that includes text and images
you want to appear on the navigation page. For example, in Figure 7-2 (in the
preceding section), I start with the content for the top frame, which con-
tains the company logo and some navigational links.

When you develop the content for the content pages, remember a couple of
suggestions about the remaining content pages of your framed site:

4 On content pages, don’t duplicate too much information that appears
on the navigation page. If, for example, your navigation page includes
the corporate logo, omit that item from individual pages.

4+ On content pages, include some contact and identification informa-
tion. Readers may be able to access content pages directly, without
going through the frames (because the pages are just HTML documents,
after all), and if you have no contact or identification information,
nobody knows where the pages came from.

Remember the names you give your content pages — you need them as you
fill in your frames.

Developing Alternative Content

Most browsers support frames; however, a relatively small percentage of
people who are online can’t easily view Web pages containing frames. Why?
Because some people surf the Web using small-screen Web devices, like
pocket PCs. Some sight-impaired folks use screen readers that don’t handle
frames. For whatever reasons, a few people are still using ancient browsers
that don’t recognize frames. And, finally, some search engine spiders can’t
read framed pages. (A search engine spider is software that prowls the Web,
cataloguing every Web site it comes across for inclusion in a search engine
listing.)
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The upshot? If you want to use frames and want everyone on the Web to be
able to see your site, consider providing alternative content. Alternative
content is similar to alternative text you include with images; this text
appears in place of images in case your readers cannot or choose not to
view your images. (See Book I, Chapter 4, for information about alternative
image text.)

In an ideal world, you could take the time to have two complete Web sites —
one optimized for nonframed browsers and the other for framed browsers.
Realistically, however, you're not likely to have the time for this luxury
because having two sites doubles the time required to create and maintain

them. Book Il

Chapter 7
Instead, just make a single HTML document that includes all the corporate P

logos and links that your navigation and content documents contain.

Establishing the Frameset Document

After you develop the content — for both the frames and the alternative
content — you're ready to set up your frameset document. The frameset docu—
ment tells the browser which frames are available and where they go, in
addition to containing some content that only nonframed browsers can see.

sawel
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You use the tags listed in Table 7-1 to start developing a frameset document:

Table 7-1 Developing a Frameset Document

HTML Tag or Attribute Description

<FRAMESET>...</FRAMESET> Establishes frame layout

BORDER=n Specifies width of border in pixels for all
contained frames

BORDERCOLOR=# Specifies color (RRGGBB or name) for contained
frames

COLS="n,n" Specifies column dimensions in pixels,

percentage, or in terms of remaining space
(COLS="25%,100,*")
FRAMEBORDER=n Specifies border (1) or no border (0)
ROWS="n,n" Specifies row dimensions in pixels or percentage

or in terms of remaining space
(ROWS=25%,100,*)

<NOFRAMES>. .. </NOFRAMES> Specifies area of frameset document that is
visible to frame-incapable browsers
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‘x‘gN\BEIi Follow these steps to set up your frameset document:
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1. Create a new HTML document.
Don’t use <BODY> tags; use <FRAMESET> tags instead:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/html4/frameset.dtd">

<HTML>

<HEAD><TITLE>My Framed Site</TITLE></HEAD>

</HTMLD

2. Add a <FRAMESET> tag pair:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML>

<HEAD><TITLE>My Framed Site</TITLE></HEAD>

<FRAMESET>

</FRAMESET>

</HTML>

This example sets up two rows — and no columns — so you need to
add a ROWS attribute to the <FRAMESET> tag. The first (top) row is 100
pixels high, and the remaining row fills the remaining available space, so
the complete attribute is ROWS="100,*".

In more complex documents, you can have multiple <FRAMESET> tags to
add frames within frames (such as a set of columns within a set of
rows), but that’s not necessary in this example.

3. Add the ROWS attribute:

<FRAMESET ROWS="100,*">
</FRAMESET>

You can also specify something such as ROWS="25%,*" to make the first
row occupy 25 percent of the window and the second row occupy the
rest.

4. If you want to remove the frame borders (which is kind of a neat
effect), add the BORDER=0 and FRAMEBORDER=0 attributes to the tag:

<FRAMESET ROWS="100,*" BORDER=0 FRAMEBORDER=0>
</FRAMESET>

Why do you need both BORDER and FRAMEBORDER? Well, you need one
for most versions of Netscape Navigator, and the other for Microsoft
Internet Explorer and other HTML 4.01-compliant browsers — dueling
browsers require special accommodations.
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5. Add a <NOFRAMES> tag pair under the <FRAMESET> tag to accommo-

date browsers that cannot display frames:

<FRAMESET ROWS="100,*" BORDER=0 FRAMEBORDER=0>

</FRAMESET>
<NOFRAMES>
</NOFRAMES>

6. Provide regular HTML code within the <NOFRAMES> tags for readers
with frame-incapable browsers to see.

A brief identification and link to the extra content are plenty:
<FRAMESET ROWS="100,*" BORDER=0 FRAMEBORDER=0>

</FRAMESET>
<NOFRAMES>

<H1>Welcome to my framed site!</HI>
<A HREF="noframes.html">Please join us.</A>

</NOFRAMES>

Setting Up the Frames

Placed between the <FRAMESET> tags are the <FRAME> tags, which build the
frames; one frame tag per column or row is called for in the <FRAMESET> tag.
So, to set up frames, you need two <FRAME> tags plus their associated attrib-
utes. Table 7-2 shows the tags and attributes necessary to create frames:

Table 7-2 Creating Frames

HTML Tag Description Example

or Attribute

<FRAME> Establishes frame. <FRAME>

BORDER=nN Specifies width of border <FRAME BORDER=4>

in pixels.

FRAMEBORDER=n

Specifies border (1)
or no border (0).

<FRAME FRAMEBORDER=0>

NAME="..." Provides frame name. <FRAME NAME="
myBanner">

NORESIZE Prevents reader from <FRAME NORESIZE>
resizing frame.

SCROLLING="..." Specifies whether the frame <FRAME SCROLLING=
can scroll in terms of YES, NO, "NO">
or AUTO(matic). Yes requires
scrollbars; No prohibits them.

SRC="URL" Identifies source file that <FRAME SRC="banner.

flows into frame.

htm">

Book Il
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Note: At this point, I assume that you have a complete frameset document
and need to add only the <FRAME> tags. The following block of code builds
on the preceding one:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/htm14/frameset.dtd">

<HTML>

<HEAD>KTITLE>My Framed SiteTITLE></HEAD>

<FRAMESET ROWS="100,*" BORDER=0 FRAMEBORDER=0>

</FRAMESET>

<NOFRAMES>

<H1>Welcome to my framed site!</H1>

<A HREF="noframes.html">Please join us.</A>

</NOFRAMES>

</HTML>

Follow these steps to add frame tags:

1. Add the first <FRAME> tag, corresponding to the top (navigation) page.

To see an example of a navigation page, take a peek at Figure 7-2, earlier
in this chapter.

<FRAMESET ROWS="100,*" BORDER=0 FRAMEBORDER=0>
<FRAME>
</FRAMESET>

2. Add the SRC attribute, which uses a standard URL (absolute or rela-
tive) to point to the document that will fill this frame:

<FRAME SRC="banner.htm">

3. Add the NAME attribute to name the frame so that you can refer to it
later within HTML documents:

I call this one “banner” because it acts as a banner at the top of the
page:
<FRAME SRC="banner.htm" NAME="banner">

4. Add other attributes, if you want — for example, NORESIZE and
SCROLLING.

The <FRAMESET> tag turned off the borders, but that can also be done
(optionally) in each individual frame. Because the banner.htm docu-
ment is primarily an image of a known size, turning off the scroll bars
and preventing readers from resizing the frame is a good idea. This type
of setup gives you a little extra layout control, but it can cause real
problems for readers if you accidentally put more content in banner.htm
than fits in the available space:
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<FRAME SRC="banner.htm" NAME="banner" NORESIZE
SCROLLING=NO>

5. Add the remaining <FRAME> tags and attributes:

<FRAME SRC="banner.htm" NAME="banner" NORESIZE
SCROLLING=NO>

<FRAME SRC="main.htm" NAME="content"
SCROLLING=AUTO>

3
Don'’t restrict either scrolling or resizing for the content frame; readers
may need to scroll to see all the text.
After your frames are complete, open the frameset document in your browser Book II
and check out the frames. Figure 7-3 shows you the frame I created. Chapter 7
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Setting Up Links and Targets

When you set up links in framed documents, you can make some links
appear in a completely new window, some appear in the same frame, and
some appear in different frames.
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To control where links appear, you use an additional TARGET attribute. Each
of your links from a framed page should have the additional TARGET attrib-
ute to name the frame in which the link should appear. The previous blocks
of code named the top frame “banner” and the lower frame “content” so
that links are targeted accordingly.

To establish a link from the banner.htm document (contained in the banner
frame) to the document named mission.htm (which appears within the con-
tent frame), add the following TARGET attribute to the existing link:

<A HREF="mission.htm" TARGET="content">Mission
Statement</A>

This link opens in the content frame the file named mission.htm (as you may
recall, the content frame in this example is the larger frame at the bottom of
the browser window). If you omit the target, the link opens in the same
frame as the anchor — the navigation frame, in this example.

Additionally, you can use a couple of “magic” target names: _top and
_window are the most common and useful. If you target _top, the link
replaces your frames in the same window and returns you to a nonframed
environment. If you target _window, the link appears in a completely new
window. Targeting _window is handy if you're linking to another site — your
pages remain open while the others are also easily accessible.

Suppose that within your Web site you suggest that readers access the For
Dummies home page, at www.dummies.com. You probably don’t want the For
Dummies page to appear within one of your frames; that would look silly.
Therefore, you need to break out of the frames by using the _window magic
target. Your framed site remains open, and a new browser window appears
with the For Dummies home page in it. Just use code similar to the following:

<A HREF="http://www.dummies.com/"
TARGET="_window">Dummies Home Page</A>

In addition to working in the <A> tag, the TARGET attribute works in any
other link, such as an image map or a form. (The form results appear in the
targeted frame.)

Testing Your Framed Site

After you completely set up your framed site, you want to test the site
extensively to make sure that all its pages and links work as you expect.
Beyond the obvious step of opening your frameset document in several dif-
ferent browsers and clicking all the links, you may find that a couple of tips
make the process a little easier:
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4+ If you're sure that you have made and saved frameset document
changes, but they don’t seem to be appearing in the browser, exit from
the browser and open it again.

4+ If you edited one of the documents within a frame and want to reload
just that document, click inside the frame and then click the Reload or
Refresh buttons in your browser.

Book I
Chapter 7
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Chapter 8: Developing Style Sheets

In This Chapter

v Understanding style sheets
v Tying style sheets into HTML documents

v~ Creating style sheets from scratch

Syle sheets, another standard from the World Wide Web Consortium,
provide all the formatting capabilities you could ever want for your Web

pages.

The bad news is that even though both Microsoft Internet Explorer and
Netscape support style sheets, that support isn’t identical: Each browser
displays style sheet code just a bit differently from the other. Readers who
aren’t using an HTML 4.0-capable browser cannot see the nifty formatting
effects you add by using style sheets. This chapter gives you suggestions for
accommodating those wood-burning browsers.

Throughout this chapter, [ assume that you're familiar with how HTML tags
work. If you’re not, brush up on Book II, Chapter 1, before diving into this
chapter.

About Style Sheets

Style sheets provide formatting commands for Web pages in a more conven-
ient and efficient manner than regular HTML offers.

Using style sheets, you can format practically any element of your HTML
document and have that formatting applied to the same elements through-
out your entire Web site. So, rather than manually change all those pesky
headings, you can simply change the heading style and change the appear-
ance of all of them in one fell swoop.

Accommodating browser differences

At the time this book was written, browser support for style sheets was still
fairly unpredictable.
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If you know that your readers are in the roughly 95 percent of the Internet
population that uses style-sheet-capable browsers, by all means use style
sheets, albeit with some care. If, as is more likely, some of your readers have
style-sheet-capable browsers and some have older browsers, you have three
choices:

4+ Use style sheets exclusively and let readers with older browsers see the
plain, mostly unformatted text.

4 Use only regular HTML formatting commands and pretend that style
sheets don’t exist.

4+ Use both style sheets and regular HTML formatting options. You spend
twice as much effort using this approach (and it’s redundant and repeti-
tive and formats the same thing over and over again), but it accommo-
dates a larger percentage of your readers more effectively than the
other options do.

A good compromise for using style sheets and accommodating browsers
that don’t reliably handle them is to do the following:

4+ Format the background and basic text colors (as defined in the <BODY>
tag of regular HTML documents) with HTML commands.

4+ Format the background and basic text colors with style sheets. (If nec-
essary, these style sheet commands override the analogous commands
from the regular HTML document.)

4 Provide any additional formatting commands through style sheets and,
optionally, HTML markup tags.

Understanding inheritance

Inheritance means that a document takes on global basic characteristics,
and each more specific formatting command that you define overrides the
last (for most elements). For example, if you define the background of the
whole page as red, the background of a table as blue, and the background of
a table cell as green, the most specific formatting (green for the cell) takes
precedence.

Here’s the general order of precedence:
4 Document-wide formatting from an HTML document (as defined in the

<BODY> tag) is the most basic level of formatting.

4+ Document-wide formatting from a style sheet overrides document-wide
formatting from an HTML document.

4 Specific formatting in HTML overrides document-wide formatting.
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4+ Specific formatting from a style sheet overrides specific formatting in
HTML.

4+ Specific formatting from a style sheet overrides general formatting.

If specific formatting is defined in the HTML document and the format for
the same element is also defined in a style sheet, the style sheet formatting
generally wins. If a more specific element (such as a table cell rather than
the whole table) is specified in either the style sheet or HTML document,
the specific element wins.

Before you get started using style sheets, remember that the style sheet

isn’t necessarily part of the HTML document. In fact, depending on how you Book Il
do it (see the options in the next section), the style sheet can be a com- Chapter 8
pletely different document. So, your first step is to decide how you want to

connect the style sheet to the HTML document. Then you can develop the 4
style sheet, which specifies all the bells and whistles you want to include. 3
4
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The first step in using style sheets is to decide how you want to connect
them to your HTML documents. After you get the hang of using style sheets
and know how you want to connect them, you can just dive in and start cre-
ating them. (You find the exact process later in this chapter, in the section
“Understanding Style Rules.”) For now, however, you need to get an idea of
how style sheets and HTML documents can relate.

Basically, style sheets can connect to HTML documents in four ways. You
can do any one of the following:

4+ Embed the style sheet in the HTML document.

4+ Link the style sheet to the HTML document.

4 Import the style sheet into the HTML document.

4 Add style sheet rules as attributes to regular HTML tags.
This chapter covers only the first two options — mainly because they are
the most widely supported and the most practical to use. (Also, the latter

two are somewhat more complicated and convoluted, and describing them
is beyond the scope of this book.)

If you're interested in knowing how to use the latter two options, check out
HTML 4 For Dummies, 4th Edition, written by Ed Tittel, Natanya Pitts, and
Chelsea Valentine and published by Wiley Publishing, Inc.
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Embedding style sheets

The easiest way to handle style sheets is to embed them within the <HEAD>
tag (technically, within <STYLE> tags within the <HEAD>) of the HTML docu-
ment. Embedding them is easy because you don’t have to create a com-
pletely different document for the style sheet. You can simply work with an
HTML document you already have.

To embed a style sheet, use the tags and attributes listed in Table 8-1.

Table 8-1 Embedding a Style Sheet

HTML Tag Description Example

or Attribute

{STYLE>...</STYLE>  Specifies the <STYLE TYPE="text/
style block csS"><STYLE>

TYPE="text/css" Specifies the type (STYLE TYPE="text/
of style sheet css"><STYLE>

<= => Hides style sheet <STYLE TYPE="text/
commands from older css"><I—= —=>LSTYLE>
browsers

The following steps show you how to add the <STYLE> tag and its attributes:

1. Start with a functional HTML document.

The top of the document should look something like the following block
of code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/html4/frameset.dtd">

<HTMLY

<HEAD>

KTITLE>Cats Galore</TITLE>

</HEAD>

<BODY>

</BODY>

</HTML>

2. Add <STYLE> tags:

<TITLE>Cats Galore</TITLE>
<STYLE>

</STYLE>

</HEAD>

3. Add comment tags within the <STYLE> tags to hide the styles from
older browsers:
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<STYLE>
<1L--

-->
</STYLE>

4. Add the TYPE="text/css" attribute to specify that you’re using a
Cascading Style Sheet:

<STYLE TYPE="text/css">
<L--

>

</STYLE>

Other style sheet formats exist (most notably, JavaScript Style Sheets)
but they are less common and nonstandard, so this chapter doesn’t
address them.

That’s it! You don’t see anything different in the document, but you have
found a home for your styles. When you develop the style sheet and specify
cool formatting, you add it between the <STYLE> tags, as shown in the sec-
tion “Understanding Style Rules,” later in this chapter.

Linking style sheets

Linking style sheets can be a little more confusing than embedding them,
mostly because the formatting information is in one location and the HTML
code is in a completely separate document. That arrangement, however,
also provides the biggest advantage of style sheets.

Here’s why. Suppose that you have 17 documents in your Web site. You
decide that you want to add a background image to them all. If you're using
embedded style sheets or traditional HTML coding, you have to open and
edit every one of those 17 documents to add the appropriate code. If, how-
ever, you have linked a single style sheet to each of those 17 documents,
you need to make only a single change in that style sheet, and (voila!) the
change happens in each linked document.

You can use the tags and attributes in Table 8-2 to link your style sheets.

Table 8-2 Linking Style Sheets

HTML Tag or Attribute Description Use in Pairs?
<LINK> Connects a document to other information No
REL="StyleSheet" Specifies that the link is to a style sheet No
TYPE="text/css" Specifies the type of style sheet No

HREF="..." Indicates the URL of the linked style sheet No
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3

In linking style sheets, you need to create the style sheet file (so that you
have a filename to link f0). Only then can you include a link to the style
sheet file within your HTML document.

Creating the style sheet file

If you choose to link to a style sheet, you need to create a file that contains
the style sheet. The file must be a plain-text file, just like regular HTML docu-
ments, and have the extension . css (rather than .htmor .htm1). The file
contains the same style sheet rules you use in an embedded style sheet.
Check out the section “Understanding Style Rules,” later in this chapter, for
help in creating a style sheet file.

Putting in the link

To link a style sheet to an HTML document, you use the <L INK> tag, includ-
ing the REL, TYPE, and HREF attributes, as shown in the following block of
code:

<LINK REL="StyleSheet" TYPE="text/css"
HREF="newstyle.css">

You must specify the values for the REL and TYPE attributes as shown; for
the HREF attribute, simply fill in the name (or address) of the style sheet file
to which you want to link.

You can link and embed a style sheet in the same document. For example,
you may have a generic style sheet that applies to most of your HTML docu-
ments — that one, you would link. Then, just below the <LINK> tag, you
could embed another style sheet with exceptions or additions to the generic
style sheet. Both style sheets affect your document, and the style definitions
embedded in the document override the linked ones.

This capability of using multiple style sheets is the cascading part of the
term Cascading Style Sheet. You could use a generic style sheet that applies
to all your documents and then a second (or third or fourth) style sheet
with formatting specific to the particular document.

Understanding Style Rules

Style sheets are made up of rules that simply tell browsers how to format
HTML elements. Just as HTML tags identify parts of a document — such as a
paragraph, heading, table, or list — style rules specify formatting for those
elements.
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Style rules look a bit different from HTML. For example, rather than use
angle brackets as you do with HTML code, you use curly braces ({ }). And,
rather than use HTML-like abbreviations, you get to use some spelled-out
words and descriptions. After you get used to the differences, you may even
find style sheets easier to read and work with than HTML code.

Style rules have two basic parts:

4+ The part (called the selector) that identifies which element the style
applies to

4 The part (called the declaration) that tells browsers how to display that
element
Take a look at the following:

P { color: blue }

In this example, the P (the selector) identifies which HTML element the
style applies to, and the information within the curly braces (the property
and the value, respectively) tells browsers how to display the element. In
this case, the style rule specifies that all paragraphs (P) in the document
should be blue.

Also, note that you can string together style rules, if you find doing so
easier. For example, rather than have two separate rules on two lines, like
this:

P ( color: red }
P { background-color: white }

you can put the rules together within the same set of braces by using a
semicolon, like this:

P { color: red ; background-color: white }

And, just as you can add multiple declarations and values within the braces,
you can specify multiple elements, like this:

H1, H2, H3, H4, H5, H6 { color: green }

Notice that when you string together elements, you separate them with
commas (not semicolons, as you do between multiple declarations).

Book I
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With these basic concepts of style rule construction in mind, find out in the
following sections how to bring them all together.

Applying style rules
Table 8-3 summarizes the various declarations and values you see in the
next several sections.

Table 8-3 Declarations and Their Values

Property Selected Possible Values

font-family Font names from readers’ systems, plus generic
choicesof serif,sans-serif,ormonospace

font-size xx-small,x-small,small, medium, Targe,
x-large,xx-large,smaller, larger

font-style normal,italic,oblique

font-variant normal,small-caps

font-weight normal,bold,bolder, Tighter

color #FRRGGBB hexadecimal number

background-color J#RRGGBB hexadecimal number or color name

background-image urlC. . )

background-attachment fixed,scroll

background-repeat repeat, repeat-x, repeat-y,no-repeat

background-position %, %

float left, right

As you can see from this limited sample of declarations and values, the
number of style combinations is endless.

Setting a font for an entire document

With just a few commands, you can apply formatting to an entire document.
To set the font for the entire body (everything within the <BODY> and
</BODY> parts of the HTML document), follow these steps:

1. In the style sheet, add the BODY element to specify what the style rule
applies to:

<STYLE>
<h--
BODY

-2
</STYLE>
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. Add { and } to contain the style declaration:

<STYLE>
<L--
BODY { )
-->
</STYLE>

. Add the font-size property, followed by a colon (:), a font size, and
a semicolon (}):

BODY { font-size: 32pt; }

. Add the font-family property, followed by a colon (3):
BODY { font-size: 32pt;
font-family: }
. Add your first-choice font:
BODY { font-size: 32pt;
font-family: Arial }
. Add other font choices if you want, separated by commas (,):

BODY { font-family: Arial, Helvetica,
Swiss }

. Add the closest generic choice from the preceding table:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif }

When this style sheet is applied to the document shown in Figure 8-1, the
result is the niftily styled page you see in Figure 8-2.

Specifying text and background colors

Another popular use of style sheets is to specify text and background
colors. The following steps describe how to do both within the same rule:

1. Add a color style declaration to color the text in the body of the docu-

ment dark blue:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif ;
color: 000066 }

Book I
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2. Add a background-color style declaration to set the entire document
background to pale yellow:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif ;
color: 000066 ;
background-color: #ffffcc }

Note that you can more easily read the styles if each one is on a separate
line, as shown in the preceding code. You’re welcome to use spaces or tabs
because you need to make the style rule easy to read by humans as well as
by computers.

To add other style rules, you need only put more rules on additional lines.
Follow these steps:

1. To color firstlevel headings, you can add an H1 element:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif ;
color: 000066 ;
background-color: ffffcc }
H1 { color: #ff0000 }

2. If you want the background of (only) the firstlevel headings to be
white, you can set that, too:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif ;
color: 000066 ;
background-color: #ffffcc }
H1 { color: #ff0000 ;
background-color: #ffffff }

Specifying background images

You can specify background images for the document as a whole, as you do
in HTML, and for individual elements (which you cannot do in HTML). You
can also control many aspects of the background image’s appearance.
Here’s how:

1. Add a style declaration to set a background image:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif ;
color: #000066 ;
background-color: {#ffffcc ;
background-image:
url(winchesterback.jpg) }
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to get you started:

of new ones.

v~ Take care of document-wide formatting
first—that is, specify the background image,
background color, and font before you start
specifying the nitpicky individual formatting.

v Add one or two styles at a time and test
them. Troubleshooting just a few new styles
is easier than troubleshooting a whole blob

Using style sheets effectively

Although no “right way” to develop and format
style sheets exists, some techniques prove
more effective than others. Here are a few tips

v~ Stay as simple as possible and expand

gradually, as you need to. Adding new
styles one at a time is easier than back-
tracking and removing styles.

Remember not to get caught up in the appar-
ent WYSIWYG-ness of style sheets. You still
don’t have absolute control of the final
appearance of the document because your
readers may not have style-sheet-capable
browsers, may have their browsers set not
to use style sheets, or may override your for-
matting with their own, preferred formatting.

2. Add another style declaration to keep the image from scrolling so
that it looks like a watermark on the screen:

BODY { font-family: Arial, Helvetica,

Swiss,

sans-serif ;
color: #000066 ;

background-color: {ffffcc ;
background-image:
url(winchesterback.jpg)
background-attachment: fixed }

3. Specify the location of the image on the background:

The following code specifies background-position values of 50% and 0%
to move the image horizontally halfway across the screen and position

it at the top, respectively:

BODY { font-family: Arial, Helvetica,

Swiss,

sans-serif ;
color: 000066 ;

background-color: #ffffcc ;
background-image:
url(winchesterback.jpg)
background-attachment: fixed ;
background-position: 50% 0% }
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4. Set background images to repeat only horizontally, only vertically,
both, or not at all.

To preserve the watermark effect, this case specifies “not at all”:

BODY { font-family: Arial, Helvetica,
Swiss, sans-serif ;
color: #000066 ;
background-color: #ffffcc ;
background-image:
url(winchesterback.jpg)
background-attachment: fixed ;
background-position: 50% 0% ;
background-repeat: no-repeat} Book II
Chapter 8
The result of the code in Steps 1 through 4 is a background image that remains
in a specific location on a Web page — even when users scroll that Web
page. | encourage you to experiment with specifying different values for the
background-attachment, background-position, and background-repeat
attributes until you create the perfect background effect for your site.
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Chapter 1: Getting to Know
FrontPage

In This Chapter

v Discovering the power of FrontPage
v Looking at the FrontPage interface
v+ Viewing your Web site in FrontPage

v Using the FrontPage Editor

ou don’t need to be a whiz kid to churn out a quality Web page. By

using FrontPage, you can join the ranks of Web page designers. The
powerful FrontPage program enables you to create almost any type of Web
page. This chapter covers the FrontPage basics and introduces you to some
of the program’s essential tools.

“What Is FrontPage, and What Can | Do with It?”

FrontPage is an all-in-one Web publishing tool for big-time Web companies
(such as Yahoo! or ESPN), small companies, and personal users. By using
FrontPage, you can create individual Web pages and publish them to the
Internet, generate tracking reports about those Web pages, and effectively
administer the Web site after it’s on the Net . . . all from within the same
program.

Of course, you may never want to administer an entire Web site and use all
that functionality, and that’s okay. If you just want to build ordinary HTML
pages and put them up on the Internet or the company intranet, that’s fine,
too. FrontPage is exceptionally flexible and scalable; it can grow with you as
your Web site needs grow.

How FrontPage Is Organized

FrontPage contains a multitude of features, mini-applications, and menus, all
wrapped up in one tidy little package. Still, maneuvering around FrontPage
can baffle anyone. So to better orient you, Figure 1-1 shows you a typical
FrontPage interface. You also see figure callouts for a number of features.
Pay particular attention to the callouts, because you use those features the
most.
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Viewing Your Web Site

FrontPage allows you to work with six different aspects, or views, of your
Web site. I devote the rest of this section to describing these views.

Before you can work with a Web site, you must first load into FrontPage one
or more Web pages that make up that site.

To open a Web page in FrontPage:

1. Choose Filec>Open Site from the main menu.
The Open Site dialog box appears.
2. Enter the name of a Web page in the Site Name field.

You can either type the name of the Web page or navigate to the page by
clicking the icons you see in the Open Site window.

3. Click the Open button.
The Web page you chose in Step 2 appears.
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Figure 1-2:
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FrontPage
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Viewing Your Web Site

You can view your Web page in any of several different views:

4+ Page view: Where you build all your Web pages (refer to Figure 1-1).
The page view is the default view: When you open a Web page in
FrontPage, you automatically see a page view similar to the one shown
in Figure 1-1. To redisplay your page in Page view, choose Viewr>Page.

You can preview your Web site in Internet Explorer at any time by
choosing Filec>Preview In Browser.

4+ Folders view: Displays a typical Windows Explorer menu, making all
your Web project’s files and folders easily accessible within FrontPage
(see Figure 1-2). From this view, you can also drag and drop files, which
makes adding and deleting content easy.

You display your site in Folders view by choosing View=>Folders or by
clicking the Folders icon you see on the Views bar (see Figure 1-2).

If you look at Figure 1-2, you see several icons on the Views bar at the
bottom of the page. Clicking these icons allows you to switch instantly
to the six views available in FrontPage (without having to use the Views
menu).
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Figure 1-3:
Reports
view
enables you
to trouble-
shoot your
site ata
glance.

4+ Remote Web Site view: Allows you to synchronize the Web pages on
your local computer with the Web pages on a Web server — in other
words, Remote Web Site view allows you to publish your Web site. For
the complete skinny on publishing your site with FrontPage, check out
Book IIl, Chapter 8.

You access Remote Web Site view by choosing View=>Remote Web
Site or by clicking the Remote Web Site icon you see on the Views bar
(refer to Figure 1-2).

Reports view: Gives you a Site Summary (see Figure 1-3), which pro-
vides a bird’s-eye view of what’s working within your Web site (or not
working, if, for example, your site contains some broken hyperlinks).
From the Reports view, you can also run a more detailed series of
reports that give you immediate information on the status of various
aspects of your Web site, such as load times or hyperlink status.

You display your site in Reports view by choosing Viewr>Reports or by
clicking the Reports icon you see on the Views bar (see Figure 1-3).
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4+ Navigation view: Provides a visual representation of all the pages on
your Web site and the pages’ hierarchical order. By dragging around the
pages, you can change the relationships of those pages to one another
and organize the pages of your site more effectively. Clicking the
Navigation icons you see in the upper-right corner of Navigation view
allows you to add pages and links to your site instantly.

You display your site in Navigation view by choosing Viewr>Navigation
or by clicking the Navigation icon you see on the Views bar (refer to
Figure 1-3).

4+ Hyperlinks view: Gives you a graphical representation of how every
Web page connects to every other page within your Web site (see
Figure 1-4). In addition, the Hyperlinks view provides a quick way to
see which pages link to other sites outside your own.

To display your site in Hyperlinks view:
1. In Page, Folders, Reports, or Navigation view, click to select a
page.

2. Choose Viewr>Navigation or click the Navigation icon you see on
the Views bar (see Figure 1-4).
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FrontPage shows you every page in your site linked to the page you
selected in Step 1.

4+ Tasks view: Enables you to assign tasks to individuals on your team,
check the status of tasks that are already underway, and manage the
workflow and the publishing of new elements to the site. You can also
use this view to stay on top of tasks that you have to do yourself. Tasks
view makes a very good to-do list. If you're going to use FrontPage in a
multiuser environment, the Tasks view (which you display by clicking
the Tasks View icon, as shown in Figure 1-4, or by choosing Viewr>Tasks
from the main menu) no doubt becomes a common sight.

Introducing the FrontPage Editor

The FrontPage Editor is the program’s built-in tool for creating and viewing
Web pages. You can switch to Page view and then click a button (Design,
Split, Code, or Preview) at the bottom of the window, as shown earlier in
this chapter, in Figure 1-1 to switch among the following modes:

4+ Design mode: FrontPage’s visual, what-you-see-is-what-you-get (WYSI-
WYG) editor for Web development. In Normal mode, you can place
elements — text, graphics, applets, or whatever — on-screen in any
location, and FrontPage automatically generates the behind-the-scenes
HTML code to account for the location of every object on-screen.

4+ Split mode: Allows you to view your Web page in design mode on one
half of the screen and the corresponding HTML code on the other half.

4 Code mode: Enables you to edit raw HTML by hand, just as you did in
the good old days. (This mode is for purists.)

4+ Preview mode: Enables you to see what your pages look like in a Web
browser window before you put them up on the Internet. The FrontPage
default browser, not surprisingly, is Microsoft’s own Internet Explorer.

As you become familiar with FrontPage, you may find yourself switching
back and forth between modes when you create your Web pages. For exam-
ple, many folks begin creating their pages in Normal mode and then switch
to Preview mode to check their work and back again to Normal to adjust
their layout and design, repeating as necessary. When they want to incorpo-
rate a bit of hand-coded HTML (for example, the HTML code necessary to
incorporate a custom JavaScript script, which I cover in Book VII), they
simply switch to HTML mode — and then back again to Preview mode to
view the finished product.



Chapter 2: Getting Started with
FrontPage: Your First Web Site

In This Chapter

v Creating a new Web site yourself or with a template
+ Creating a Web page yourself or with a template

v+ Naming (and renaming) your Web page

v Saving your Web page

v+ Opening files in odd formats with FrontPage

0 h, what a tangled Web you can weave — but FrontPage makes starting
out and keeping track of what you’re doing easy. Whether you plan to
create a Web page on your own or use one of the Web templates that the
program provides, this chapter shows you the basics. If you can figure out
how to open, save, and close your Web pages, you're well on the road to
Webmastery.

Creating a New Web Site

A Web site is a collection of Web pages and related content, such as pictures,
movies, and sound clips.

You want to create and name a Web site in FrontPage before you create your
first Web page. Doing so helps you organize your content — much like creat-
ing and labeling a manila folder called Tax Receipts in the real world helps
you organize the dozens of receipts you accumulate by giving you a single
place to store them.

In this section, [ show you how to create a quick-and-dirty, one-page Web
site. To do so, follow these steps:

1. Choose FileroNew to open the New task pane, as shown in the right
side of Figure 2-1.
2. Under New Web Site in the task pane, click One Page Web Site.

The Web Site Templates dialog box appears (see Figure 2-1).
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3. Make sure that the General tab is selected and then select One Page

Web Site from the list of available templates.

The templates appear in icon form in the Web Site Templates dialog
box. Each has a descriptive name (refer to Figure 2-1), and when you
click a template, FrontPage displays even more information about that
template in the Description section you see in the lower-right area of
the Web Site Templates dialog box.

FrontPage comes with several Web templates that enable you to design
a Web site that you can tailor to your business or personal needs.
Choose the Personal Web template, for example, to create a Web site
that describes your family and its adventures. Table 2-1 describes these
Web templates.

4. Enter a directory name in the field labeled Specify the location

of the new Web site: to specify where on your computer you
want FrontPage to store the Web pages associated with this Web site.

To select a directory on your computer, you can either type the name of
a directory or click the Browse button and use the New Web Site
Location dialog box that appears.
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This part is confusing, but what you enter in Step 4 determines both the
location and the name of your new Web site. For example, entering
c:\myDocuments\myWebSites\Knitting tells FrontPage to name your
Web site Knitting; it also tells FrontPage to create a directory (or folder)
named c:\myDocuments\myWebSites\Knitting and to store all the
content associated with the Knitting site in the c: \myDocuments\
myWebSites\Knitting directory.

“&N\BEB FrontPage, if you let it have its way, names the directory mysite.

& Although this name may seem nice and homey, it isn’t particularly effec-
tive in helping you remember what your Web site contains. And, after
you create your Web site (and a bunch of content), changing the name
can prove to be a hassle if you decide that you don’t like the current
name. Naming your Web site, therefore, is one of the more important
decisions you can make.

5. Click OK to create your new Web site.

Note: As you create a Web site, you’ll notice that FrontPage creates a few
extra items, including an Images folder and a Private folder. The Images
folder is the default location for housing images in your Web site. The
Private folder (it’s actually called _Private) is where FrontPage puts the
majority of the code it generates automatically to create your Web site.

Book Il
Table 2-1 Web Site Templates in FrontPage Chapter 2
Template What It Includes
One Page Web Site Just a single Web page

Corporate Presence Wizard ~ Pages for products and services, feedback, and a search
page, as well as pages for mission statements and contact
information

Customer Support Weh The tools necessary for building a compelling customer
support site, including pages for discussion groups, FAQs,
bug-list reports, a searchable database, and bulletin-board
postings

aIS qap\ Isaiq
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Database Interface Wizard Tools for interfacing with a database so that you can view,
add, and update records in the database

Discussion Web Site Wizard  Search forms, a discussion area, and user registration

Empty Web Site Only the empty default folders

Import Web Site Wizard A walk-through of the process of importing an existing Web
site into a new FrontPage Web site

Personal Web Site A home page, plus pages for a photo album, your personal
interests, and your favorite sites on the World Wide Web

(continued)
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Table 2-1 (continued)
Template What It Includes

Project Web Site Project-related elements, such as schedules, task status,
discussion pages, and team-member information

Share-Point Team Site A calendar, a library for documents that you share with
others, and a task list so that you can build a Web site with
your colleagues

Creating Web Pages

Creating new Web pages is perhaps the most common task that you perform
in FrontPage, especially if you have a good-size Web site. Not surprisingly,
then, FrontPage offers you a plethora of options for generating new Web
pages, whether you want to create a simple text page or something as
sophisticated as a page involving frames.

Creating an empty Web page
You can create a new, empty HTML page to add to your Web page in several
ways, but the following methods may prove the easiest:

4+ From the New task pane: To create a Web page by using the task pane,
choose FileroNew. Then choose Blank Page from the New task pane that
appears.

4 From the toolbar: Just below the File menu lies the New Page button.
Click it (or press Ctrl+N) to create a new Web page.

4+ From the Folders view: Whenever Folders view is active, you can gener-
ate a new, blank Web page by right-clicking a blank part of the Folders
view and choosing Newr>Blank Page from the shortcut menu that
appears.

After you create a new page, a tab appears along the top of the window in
Page view. Click a tab to go from page to page.

Creating a Web page from a template

FrontPage gives you many more options for creating Web pages than just
making an empty page. In fact, FrontPage includes 36 different Web page
templates that make choosing a Web page for almost any of your needs
easy. Table 2-2 lists some of these templates. To create a Web page from a
template, choose File=>New, click More Page Templates in the New task pane
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Saving an HTML file as a template

Suppose that you're working on a Web page
and you suddenly realize, “Zoinks! All my other
Web pages should have these same basic ele-
ments!” FrontPage enables you to save an
HTML page as a template, which you can then
load the same as other HTML templates. To
save an HTML page as a template, follow these
steps:

1. Switch to Page view and make the pane
active by clicking in it.

2. Choose File->Save As.
The Save As dialog box appears.

3. Select FrontPage Template (*.tem) from the
Save As Type drop-down list.

The dialog box opens to the C:\
Documents and Settings\Owner\
Application Data\ Microsoft\
FrontPage\Pages folder, the folder

where FrontPage keeps its templates.
(Depending on which version of Windows
you're running, the templates may be in a
different folder.)

4. Click the Save button.
The Save As Template dialog box appears.

5. Enter a title, name, and description for your
template and click OK.

The title, name, and description that you
enter appear in the Page Templates dialog
box along with the titles, names, and
descriptions of other templates.

After you save your file, you can see and
choose your new template on the My Templates
tab of the Page Templates dialog box, which is
the one that you see after you click More Page
Templates in the New task pane.

that appears, and double-click a template in the Page Templates dialog box
that opens. The Preview box in the dialog box shows you what kind of Web
page you get with each selection.

The fastest way to open the Page Templates dialog box is to open the New
Page button drop-down list from the toolbar and choose Page.

Table 2-2
Web Page Template

Web Page Templates
What Is Created
A page with entries in the correct form for a bibliography

Bibliography

Confirmation Form A customer-service reply page for users to submit a query

Feedback Form A form for submitting and receiving feedback

Form Page Wizard A customized page containing a form that Web surfers can

submit
Frequently Asked A blank table of contents and links to major sections. (You get
Questions to fill them in, however.)

(continued)
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Table 2-2 (continued)
Web Page Template What Is Created

Guesthook A form that visitors can use to post comments to your Web site

Photo Gallery A page laid out for presenting photographs

Search Page A search form with instructions

Table of Contents A set of topics and built-in links for your Web pages

User Registration A page that users can use to register for a restricted access
Web site

Creating framed Web pages

Ever see a Web page where you can scroll down the page, but the menu at
the top never moves and the scrolling page seems to disappear underneath
the menu? A feature known as frames controls these nifty tricks — and it’s
one of the great secrets of HTML. Frames aren’t as popular as they once
were, but you can still create frame pages with FrontPage by following these
steps:

1. In Page view, choose Filec>)New to open the New task pane.
2. Click More Page Templates.
The Page Templates dialog box appears.
3. Click the Frames Pages tab.
4. Select the frame style you want.

Be sure to glance at the Description section in the Page Templates
dialog box, along with the Preview window — it shows you precisely
what your choice is.

5. Click OK to generate the framed pages.

After you select your framed page, you don’t automatically see the page the
way that it’s eventually going to look. After you choose a frame page style,
FrontPage creates a control page for the frame style, leaving to you the
selection of the pages in the frame. On-screen, you see borders breaking up
the page according to the frame style that you select. Within each framed
area on-screen, you find two buttons. You use these buttons to select the
pages for each framed area in the style that you select. Figure 2-2 shows you
how these buttons look on-screen after you create a framed page.
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Click to create a new Web page on-the-spot

Click to specify an existing Web page

The following list describes when to use each button:

4+ Set Initial Page: If you want to insert a page you've already made, click
this button.

4+ New Page: If you want to make up a new page on the spot, click this
button.
\\3
Click the Preview button along the bottom of the screen in Page view to see
how a page with frames looks in real terms.

Changing a Filename

Sometimes you find that you want to change the name of a FrontPage file.
For example, you may create a file named pagel.html and later decide to
give that file a more meaningful, easy-to-remember name, such as ufo_
sightings.html.
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Keep those filenames short

Although you live in the wonderful world of
Windows, where you can have long filenames
that even include spaces between words, not

(not including the three characters allowed
after the dot). So, to ensure that your files work
fine on all types of servers, make sure that you

all Web servers run Windows. Some non-
Windows servers on the Internet can handle
only filenames that are eight characters long

give your files names that contain eight char-
acters or fewer.

If you're familiar with the way Windows enables you to rename files,
FrontPage is sure to seem awfully familiar, because it works almost identi-
cally. To change the name of a file, follow these steps:

1. If you don’t already have Folders view displayed, choose
Viewr>Folders.
Folders view appears.

2. In Folders view, right-click the name of the file that you want to
change.

3. Choose Rename from the shortcut menu that appears.

The file whose name you want to change is highlighted.
4. Type the new name for the file.
5. Press Enter.
If you change the name of a Web page, you break the links that connect the
page to any other pages in your Web site. Fortunately, FrontPage knows
exactly how all your Web pages link, so after you change the name of a file,

FrontPage asks whether you want to automatically update your other pages
as well.

Saving Your Web Pages

An old saying in software-development circles goes a little something like
this: Save and save often. Well, saving and saving often is a great idea in
FrontPage, too. The number of times that you save a file is directly propor-
tional to how mad you get if you lose all the work you just finished. Keeping
that in mind, use one of the following three easy ways to save a file in
FrontPage:



Opening Files from Other Programs with FrontPage 209

4+ Choose Filem>Save.

4 Click the Save button on the Standard toolbar.

4 Press Ctrl+S.
If you haven’t yet saved the file, the Save As dialog box appears. From the
Save As dialog box, you can give your file a name and choose where to save

it. After you save the file the first time, you no longer see the Save As dialog
box if you use any of the preceding three methods of saving.

Opening Files from Other Programs with FrontPage

Figure 2-3:
You can
open non-
FrontPage
filesin
FrontPage
using the
Open File
dialog box.

Because FrontPage is part of Microsoft Office, the program can read and edit
a large number of different file formats in addition to HTML. To open a non-
FrontPage file in FrontPage, follow these steps:

1. Choose Filec>Open to access the Open File dialog box (see Figure 2-3).

You can also press Ctrl+O to access the Open File dialog box.

2. Select from the Files of Type drop-down list the file type you want to
open.

3. Use the Look In drop-down list to find the file that you need.

4. Click the name of the file that you want from the list and then click
the Open button.
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Chapter 3: Customizing FrontPage
to Your Liking

In This Chapter

1+ Getting to know the FrontPage Editor
v~ Setting up your toolbars

v Dealing with your folders

v Importing Web elements

Before you get too far along into churning out Web pages like a well-
oiled machine, take a step back and set things up in FrontPage to your
liking. Get your toolbars just right because you may end up clicking lots of
buttons when you create your Web pages. Organize your file folders so that
you can at least remember where you're putting your masterpieces. And
don’t forget to use some of the Web stuff that you may have already lying
around. With a little thought, your future efforts don’t seem so hard.

A Quick Guide to the Three Modes
of the FrontPage Editor

As with most things in FrontPage, you can make the Editor as simple or as
complex as you want. The Editor is designed to appeal to HTML editing new-
bies as well as to HTML masters. It achieves this delicate balance between
the new kids on the block and the veterans by enabling users either to use
drag-and-drop tools for composing pages or to edit the HTML directly.

The FrontPage Editor is split into three basic modes, which you can access
by clicking one of the following three tabs in the bottom-left corner of the
editing window:

4 Design mode: This mode is the default for the Editor and undoubtedly
the way Microsoft prefers that you create your Web pages.

In the Design mode, shown in Figure 3-1, you can create Web page ele-
ments on-screen and position them anywhere you want. As you do so,
FrontPage autogenerates the necessary HTML to make the page that
you’re creating.
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The idea is that FrontPage takes HTML editing out of the HTML creation
process and replaces it with menus, toolbars, wizards, and other ele-
ments that Office users are accustomed to seeing.

4 Code mode: Prefer to do your own HTML editing? You can use HTML
mode, as shown in Figure 3-2, to edit your HTML directly and bypass all
the automated features that the Design mode offers. This mode works
the same as a more traditional HTML editor, but it also offers a number
of handy features to make editing a little more user-friendly, such as
HTML coloring and tag viewing.

4+ Split mode: Split mode offers the best of both worlds: drag-and-drop
design mode on the top of the display area, code mode on the bottom.
When you make a change in one mode, you see that change reflected
immediately in the other.

4 Preview mode: Preview mode eliminates the need to open up a browser
to see what your pages look like. This mode gives you an immediate
idea of whether a page that you're creating is working correctly,
because Preview mode shows what your Web page looks like in the
Internet Explorer browser.

Preview mode is a good idea . . . almost. The downside is that it emu-
lates Internet Explorer, which means that, if you use the Preview mode
as the only method of previewing your work, you're neglecting the large
number of Web users who use other browsers, such as Netscape
Navigator.




Figure 3-2:
The same
Web page
as shown in
Figure 3-1 —
in Code
mode this
time.
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Using FrontPage Toolbars

FrontPage comes with the requisite Office toolbars, including the Standard
and Formatting toolbars. In addition to these two toolbars, FrontPage sup-
ports seven other toolbars that you can display and customize. If you get to
know these toolbars, your life may become much easier later. Table 3-1 high-
lights the functions of each toolbar.

Table 3-1 FrontPage Toolbars

Toolbar What It Does

Standard Includes such general Office functions as Open, Save, and Print

Formatting Provides font-style and formatting functions

Code View Offers coding shortcuts, such as function lookup, code snippets,
tag and brace matching, and more

DHTML Effects Assigns Dynamic HTML events, allowing your Web page to
respond to mouse clicks, mouse movement, and text input

Drawing Offers tools and buttons for drawing and formatting shapes and
lines

Drawing Canvas Presents tools for expanding, collapsing, and cropping the

drawing canvas

(continued)
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Table 3-1 (continued)

Toolbar What It Does

Dynamic Web Template Provides you with an easy way to add editable regions to
dynamic Web templates (templates which mix “locked” layout
with editable sections)

Pictures Gives you point-and-click access to all the image-editing tools
builtinto FrontPage

Positioning Enables you to set locations and move the position of objects
on a page

Style Launches the Cascading Style Sheet dialog box

Tables Generates quick and easy HTML tables

Task Pane Opens the task pane. Click the down arrow in the task pane and
select which pane you want from the drop-down list

WordArt Offers buttons and tools for creating and editing WordArt
images

XML View Provides you with a way to verify the well-formedness of XML
code (well-formedness means “grammatically correct” in
XML-speak)

To display a toolbar, choose Viewr>Toolbars=>Name Of The Toolbar or right-
click a toolbar and choose a name from the shortcut menu that appears.
After you choose the toolbar that you want, a check mark appears in the
menu next to the name of the toolbar, and the toolbar that you choose
either floats on-screen or sits next to the Standard and Formatting toolbars.

If a toolbar appears to be floating randomly on-screen, you can drag it up to
the location of the other toolbars. After you get the toolbar up there, the
toolbar area grows to accommodate the new toolbar. You can also double-
click the title bar of a floating toolbar to mount it with the other nonfloating
toolbars.

Creating Folders

Folders help you organize the files that make up your Web site. The larger
your site — in other words, the more Web pages you create — the more
important organizing your files becomes. (Just as in everyday life, hunting
through a stack of disorganized files for that one single file you're looking
for can be frustrating and time-consuming.)
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Collapsing and expanding folders

If you use Windows, seeing your folders After you click the plus sign, it changesto a
arranged in a hierarchy that you can collapse minus sign.

and expand may already be familiar to you.
Such an arrangement makes grasping the over-
all structure of your folders easy. FrontPage You can also copy and move files by using the
also offers the capability to view data through  Folder List, just as you can in the Windows
collapsing and expanding folders. To expand  Explorer. Simply right-click the file, drag it into
and collapse folders, follow these steps: the desired folder, and choose either Copy Here

or Move Here from the shortcut menu.

3. To collapse the folder, click the minus sign.

1. Activate the Folder List by choosing View=>
Folder List.

2. Click any folder with a plus sign next to its
name to expand the folder and view the
contents of that folder.

To create new folders for a Web project, follow these steps:
1. If the Folder List isn’t already open, choose Viewr>Folder List to Book Il
activate it. Chapter 3

Don’t confuse the Viewr>oFolder List command with the Viewr>oFolders
command. They perform different fuctions.

2. Right-click the folder in which you want to place your new folder and
then choose Newr>Folder from the shortcut menu that appears.

Bunji] anop
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FrontPage creates the new folder and prompts you to enter a name for it.

3. Enter a name for your new folder in the active text box next to your
new folder.

The text box appears as a black box with a blinking white cursor at the
end of the box.

4. Press Enter to set the name of your new folder.

Deleting Files and Folders

FrontPage offers a number of ways for you to delete files and folders. To
delete any file or folder from your project, choose any of the following
methods:
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4 Deleting from the Folder List: Click an item and press the Delete key.
The Confirm Delete dialog box appears to make sure that you're really
serious about wanting to delete the file or folder (see Figure 3-3).

Figure 3-3:
FrontPage
always
checks to
make sure
that you
really want
to delete an
item.

Confirm Delete

Are you sure you wank to delete "index. htm", the
! hame page of your web sike?

‘ou are deleting the home page For your web site, This could
cause broken links, broken link bars and errars when
publishing.

[ Don't show me again,

\NG/
S

4 Deleting from the Folders view: This procedure works just the same as
the Folder List option that [ describe in the preceding paragraph.

4 Deleting from the Reports view: You can also delete various HTML
pages on which you generate reports. Just click the HTML page in a
report and press Delete. Again, the Confirm Delete dialog box appears
to confirm that you want to delete the HTML page. You can’t, however,
delete a page from the Site Summary report.

4 Deleting from the Navigation view: Deleting from this view is slightly
different. Select the page that you want to delete and then press Delete.
The Delete Link dialog box appears. Select the Remove This Link Bar
from All Pages in the Web Site option to keep the page in the Web but
delete all links to the file or select the Delete This Page from the Web
Site option to eliminate the page entirely.

4 Deleting from the Hyperlinks view: Select the page that you want to
delete and press the Delete key. The Confirm Delete dialog box appears
to make sure that you want to delete your selection.

After you delete a page from your Web, you can’t undo the action. You're
always better off eliminating the page from the active Web by stripping the
page out of the Navigation view first and then removing the page. This
method eliminates the file from use but keeps it in the Web. That way, you
can check to see whether deleting it causes any unintended repercussions.
The same rule applies for other kinds of files.

Importing Webs and Web Pages

If you're working with a number of different Web sites, you may want to
import important Web pages, graphics, and even other Web sites into your
current Web site. FrontPage enables you to import such accessories easily.
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Figure 3-4:
You can
import a

file into
FrontPage
by using this
dialog box.
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You always need to specify first the destination into which you want to
import files! To do so, first activate the Folder List by choosing Viewr>Folder
List. Then select the folder into which you want to import the data.

By the way, before you can use material that someone else created, you must
get the creator’s permission. Presenting other’s work without permission is
a violation of copyright laws — and the repercussions for violating those
laws can be stiff.

Importing files that you created elsewhere

To import a file into FrontPage, follow these steps:

1. Choose FilecoImport.

The Import dialog box appears, as shown in Figure 3-4.

Import %]
Fie [ eL | addrie...
C:\Documerks and Settings\C...  music. BMP
Ciyny_audio_flesivideo_cip.avi  video_clip.avi Acd Folder.,.
Cimy _audio_Flesisong_clip.rm song_diprm

Froen Site. ..
Remove
Ok Close

2. Click the Add File button.
The Add File to Import List dialog box appears.

3. Use the Look In drop-down list to tell FrontPage where you want to
get the file(s) and then select the file(s) that you want to import from
either your local drive or the network.

4. Click the Open button to add the file(s) to your Import List.
You return to the Import dialog box.

5. Click OK to import the files into your Web.

Importing folders that you created elsewhere
After you select a folder in the Folder List, follow these steps to import a
folder into the folder you selected:

Book Il
Chapter 3

Bunjry anop
0) abediuo.y

Buiziwo)sny



218 Importing Webs and Web Pages

\\J

1. Choose FileZ> Import.
The Import dialog box appears.
2. Click the Add Folder button.
The File Open dialog box appears.

3. Select the folder that you want to import by searching through the
available local and network drives.

4. Click the Open button to add that folder and its contents to the
Import List.

You return to the Import dialog box.
5. Click OK in the Import dialog box to import the folder into your Web
site.

You don’t need to import files and then import folders separately. You can
make a collection of files and folders by adding them to the Import List first.
After you collect all the items that you want to import, click OK in the
Import dialog box to import the whole collection.

Importing a Web site that you created elsewhere

To import an entire Web site into your existing FrontPage Web site, follow
these steps:
1. Choose Filec>Import.
The Import dialog box appears.
2. Click the From Site button.
The Import Web Wizard opens.
3. Choose how you want to import the Web site.
The wizard provides the following five import options:

¢ FrontPage Server Extensions Or SharePointServices: Files stored
on a remote computer, transferred via Microsoft’s own transfer
protocols.

e WebDAV: Files stored on a remote computer, transferred via Web
Distributed Authoring and Versioning.

e FTP: Files stored on a remote computer, transferred via the file
transfer protocol.

¢ File System: Files stored on your local computer.

e HTTP: Files stored on a remote computer, transferred via hypertext
transfer protocol.
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. Enter the name of a directory (or URL) in the Web Site Location field.

You can use the Browse button to surf to the local directory (if you
choose File System) or URL (if you choose any of the other options) you
want, or you can type the name of the directory or URL directly into the
field.

. Specify additional transfer information.

Depending on your selection, you may also want to specify one of the
following:

¢ Include subsites: This option is available when you choose
FrontPage Server Extensions Or SharePointServices or File System.
Checking this option tells FrontPage to automatically transfer sub-
sites (subdirectories) located beneath the directory or URL you
selected in Step 4.

e Use Passive FTP: Available when you select FTP; checking this
option alerts FrontPage that you want to transfer files from a server
that uses a different port for each FTP connection.

¢ Encrypted connection required (SSL): Available when you select
FrontPage Server Extensions Or SharePointServices, WebDAV, or
HTTP, checking this option tells FrontPage to transfer files via a
secure connection.

. Click Next.

Depending on the transfer option you choose in Step 3, FrontPage may
ask you for a name and password. For example, if you choose FTP in
Step 3, FrontPage asks you to enter the name and password required by
your FTP server. Enter the requested information and click Next.

. Set the download options for the Web site that you want to import.

You can limit the size of the Web site you want to download by choosing
from a series of check boxes. These check boxes enable you to specify
the number of layers of the Web that you want to import, the size (in
kilobytes) that you want to import, and the kinds of files that you want
to import.

. Click Next.
The Finish dialog box appears.
. Click the Finish button to import the Web site.

Book Il
Chapter 3
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Chapter 4: Laying the Groundwork
for Vour Web Pages

In This Chapter

v Giving your Web site a theme

v Editing your theme
1~ Setting up page properties

If you thought you could just jump right in and make a Web page, you've
probably figured out that it’s not that easy. To do a thorough job, you
need to consider the elements that may seem secondary to you but that
make a big difference — especially as you try to apply them later and realize
that you should have done these things first! Before getting too far along,
you need to consider whether you need a theme for your page, additional
background images and colors, and page margins. To save yourself grief
later, establish your Web groundwork today.

Applying a Theme to a Web Page
(Or an Entire Web Site)

Themes are compelling graphics and varying text styles that help provide a
common look and feel for your Web site. FrontPage comes with more than
60 different themes that you can apply to individual pages, as well as to an
entire Web site. To add a theme to a Web page or Web site, follow these steps:
1. Choose Format>Theme.
A Theme task pane, similar to the one shown in Figure 4-1, appears.
2. Select the theme that you want from the list that appears.

The three check boxes in the bottom-right corner of the Theme task
pane give you the following additional options:

¢ Vivid Colors: Displays themes with nice, bright colors.

e Active Graphics: Displays themes with interesting and dynamic-
looking graphics for such elements as a banner, the large heading
that sometimes appears along the top of Web pages.

¢ Background Picture: Displays themes containing background images.
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Rolling your cursor

over the right side of a theme
displays options

for applying that theme

ETgn‘_le v X
®|®| A

[# Current theme: No theme (...

Select a theme

avalable :]
S |
— T
Figure 4-1: ——
Selecting a S
theme for MR
your Web Ficie
site gives e
each page T
in your site &
a consistent .v" Yivid colors
look and v| Active graphics
feel — Iwl Background picture
instantly. Create new theme. ..
3. Choose any of the options described in Step 2 by clicking the check
box next to the text that describes the option that you want.
4. Move your cursor over the right side of any theme that’s displayed
and click the arrow that appears.
A pop-up menu appears.
5. From the pop-up menu, choose Apply As Default Theme to apply the
theme to all the pages in your Web site or choose Apply to Selected
Page(s) to apply the theme to only those pages that are open in
FrontPage.
FrontPage applies the theme.
\\3

If you don’t like the way the newly applied theme makes your pages look,
don’t despair: choosing Edit=>Undo Theme Change removes all theme
formatting.
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Editing a Theme

Figure 4-2:
You can
modify any
of dozens of
prebuilt
themes to
create your
own
customized
theme.

What if you like the look of a theme, but the color just doesn’t quite work for
you? FrontPage enables you to modify any of the more than 60 themes in
FrontPage, providing hours of fun for the entire family! To edit a theme,
follow these steps:

1. Choose Format->Theme.

The Theme task pane appears.

2. In the list of theme names, select the theme that you want.
3. Click Create New Theme.

The Customize Theme dialog box that appears enables you to change
the colors, graphics, and/or text display of your selected theme.

4. Click the Colors, Graphics, or Text buttons to edit the color, graphic,

or text properties of the selected theme.

You can click one, two, or all three of these buttons, so go hog wild!

5. Click the Save button to save any changes to the theme or click the

Save As button to save your theme under a new name.

If you click the Save As button, the Save Theme dialog box appears (see
Figure 4-2). Type a new name for your theme and then click OK to save

223

the new theme.

13 Customize Theme
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Editing Page Properties

Every Web page offers a number of options that you can modify to fit the
needs of the site that you're building. These options range from choosing
Web page background images to specifying the color of hyperlinks. FrontPage
organizes these options in one convenient place so that accessing them is

a snap.

In Page view with Design mode selected, you can right-click a Web page and
choose Page Properties from the shortcut menu. The Page Properties dialog

box appears,

as shown in Figure 4-3. (You can also choose File=>Properties

to access the same dialog box.)

Page Properties 2] %]
General |F0rmat{|nu | Mvanced[ Custom! Language | Workurt‘m]
_— Location: File: 1 fC:{Documents and Settings/Owner My Documentsii:
Figure 4-3: Title: mewiters.oeg - Minnesota Writers
Choose your Page descrption: gl;sv;rci‘t;r:;sgsanurbprdk association of Minnesoka-
page Keywords: Minnesota, minnesota, writers
?ptlons - Base location:
rom Default targat frame: Vi
background 2
S.OUndS to Background sound -
link colors Lacation: B
USIng Loop: j ¥ Forever
the Page
Properties
dialog box. —
You can perform a number of detailed tasks in the Page Properties dialog
box, most of which I describe in the following sections. Some of the simpler
options that you can easily change include the following:
4+ Change a page title: You can change a page title by typing a new name
in the Title text box on the General tab.
4 Specify a default page sound: Also on the General tab, you can click the
Browse button to place a sound in your Web page. Unless you deselect
the Forever check box and insert a value in the Loop text box, the
sound loops continuously after the page loads. In other words, it keeps
\NG/ right on playing.
§g~“

Sounds are platform-dependent, so if you specify a PC sound file (for
example, a WAV file), Macintosh and Unix Web users can’t hear it.



Figure 4-4:
You can
add a
background
image to
your Web
page using
the Page
Properties
dialog box.
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4+ Specify the page language: On the Language tab, you can choose the
(human) language for both the page text and the HTML coding.

4 Assign categories to the page: You use categories to track a page as
someone’s working on it in a multiuser environment. On the Workgroup
tab, you can specify the categories that a page falls under, as well as the
current review status of the page and who'’s assigned to work on it.

Setting a background image

Click the Formatting tab of the Page Properties dialog box, as shown in
Figure 4-4, to set a background image for a page. (You can access the dialog
box by choosing Filem>Properties.)

Page Properties
Genersl Fomatting | advanced | Custom | Language | Workgroup |
EBackoround
I¥ Backgrourd pickure
I~ Make Ik 3 watermark.
Browss. ., Properties
Coors —
Background; | [ | Select Background Picture [E3]x]
sy Lockin: () old_emiyy x| @-31Q X [y = Tools
3 Name = »|
L-J | :ﬂsnple_lugo.gif
My Recent © sivple_logo. b0
Documents 7 .
:anple_[m;a_small.glf
= gshﬂc_lugc_small.j:.tlg
= @) smal_tright.ipa
Daskkop @ splash.ipa
splash_nav_dumny jog Sez
]stargit s
=] testk.prg
My Documents @tunnel.ipg
. @ runnel_black.jpg
& @ tunnel_blus.pg
@ tunnel_coker jpg
AL | @ tunnel_purple jpg . ]
T 3 T 2
Fie name: - -
My Metwork. | J S 1
Places Fies of bypet [all Pictures (*.0F;*. jog;*  png;*.brp; *wmf;* db) = Cancel

After you click the tab, follow these steps:

1. Click the Background Picture check box.

2. Click the Browse button to locate and select the background image
that you want to use.

The Select Background Picture dialog box appears (refer to Figure 4-4).
As does every other dialog box in FrontPage that requires you to find a

Book I
Chapter 4
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Figure 4-5:
Click to
specify a
background
color for
your Web
page.

file, the Select Background Picture dialog box defaults to enabling you to
choose files from only your Web site. By rooting around and going to dif-
ferent folders on your computer or a network, however, you can look for
background images until you find the right one. When you do, click Open.

3. Click OK.

After you click OK to close the Page Properties dialog box, the image

that you choose is added to your page.

Setting background colors

On the Formatting tab in the Page Properties dialog box (right-click the page
and choose Page Properties to see the dialog box), you can set the back-
ground colors and the various hyperlink colors for a Web page. For each
option, a drop-down list (see Figure 4-5) enables you to choose from a series
of default colors, as well as specify your own Web-safe color by clicking the
More Colors button and choosing a color in the More Colors dialog box.

Page Properties

Genersl Formatting |Mvanced[ Custom | Language |

Background
I~ Background picture
B ey

Browss, ., ! Properties
Colors
Background: | NS | Hyperink: [ astomatie |
ezt Automatic hyperivis [ ] Automabc =]

N ERERRE | Automatic ¥

EEEIEEN
I poee Coboes..

oK Cancel

Click the Formatting tab of the Page Properties dialog box and choose from
among the following options in the Colors area to set the colors of various

parts of a Web page:

4+ Background: If you didn’t select a background image, the color that
appears in the Background tab of the Page Properties dialog box appears
on the page. You can click to open the drop-down list that appears next

to this option and choose a new color.




Editing Page Properties 227

4+ Text: This menu sets the default color for text on your Web page, but
you can open the drop-down list and choose a new color.

4+ Hyperlink: The hyperlink color is the color that appears for either text
that represents a link or the border around an image that’s a link. This
color appears only if no one has yet visited the link. Choose a new color
from the drop-down list if you want.

4+ Visited Hyperlink: Identical to the Hyperlink option, except that this
color appears if the person who is visiting your Web page has previously
clicked the link. You can choose a new color from the drop-down list.

4 Active Hyperlink: This color appears on a link if a visitor selects but
doesn’t visit the link. You can choose a new color from the drop-down
list.

Setting page margins

Suppose that you want to indent an entire Web page, either from the top
or from the left. What may otherwise prove a bear of an HTML problem,
FrontPage makes an exceptionally trivial task. Here’s how you do it:

1. Choose File>Properties to access the Page Properties dialog box.
The Page Properties dialog box appears. Book i
2. Click the Advanced tab. Chapter 4
3. Click the check box of the margin that you want to indent.
FrontPage enables you to indent only the top and left margins.
4. In the Pixels text boxes, type the desired margin sizes.

All images on computer screens are constructed of pixels, the tiny dots
that, taken together, form images. On a 640 x 480 screen — the one for
which Web site designers typically plan their work — indenting by ten
pixels on the right margin moves the page about a sixth of the way
across the screen.
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5. Click OK to see how your new margins look.
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Chapter 5: Getting the Basics on
Vour Page: Text, Tables, and Links

In This Chapter

v Getting your text just right
+» Making and modifying tables
1+ Creating and updating hyperlinks

During the infancy of the World Wide Web, its pages offered only a few
common elements. One constant was text on the page — nothing too
fancy, but with a little bit of variety (maybe some color and a nice bulleted
list, for example). Some designers chose to present their text in columns
and rows, so tables, which are a great way to arrange text on a page, became
the rage. Finally, the Web would never have become the Web without its
capability of enabling you to use hyperlinks — you click here and go there.

These concepts are still the fundamentals of the Web today and the focus of
this chapter.

Changing Text Attributes

FrontPage, by and large, looks and feels like Microsoft Word if you’re changing
text attributes. In the Page view with the Design button selected, creating
text is as simple as placing the cursor where you want it on-screen and then
typing away. Editing your newly typed text is merely a matter of selecting
the text and then choosing the appropriate text-editing feature.

\3
P You can change most of the basic attributes of a piece of text by highlighting
it and then clicking the appropriate button on the Formatting toolbar, shown
in Figure 5-1.
Figure 5-1:
The : a i " = === X A= e L . ~
Formatting [rormal 4 o B rul=S===|x . | EiF=E Y A-J

toolbar.




230 Changing Text Attributes

Changing font properties
To change the text attributes for text that you create in the Page view with
the Normal button clicked, follow these steps:

1. Highlight the text that you want to change.
2. Choose Format—>Font.
The Font dialog box appears, as shown in Figure 5-2. (You can also open
the Font dialog box by pressing Alt+Enter or by right-clicking the
selected text and choosing Font from the shortcut menu.)
Font =]
Font | Character Spacing |
Fank: Fonk style: Size:
il Reqular 5 (18 pt)
vl -~ [Reoder 2 (10pt) [~
Webdings Tralic 3 (lzpt)
Wingdings Bold 4 (14pt) | =|
‘Wingdings 2 Bcld Ttalc S{lEpty —
Winadings 3 b 6 (2dpt) (¥
color: | — |
—
1 -2 ™ Underk ™ smal o pl
Figure 5-2: o e I~ befonkn
The Font [~ overline I Capialize [~ Citakion
H ™ Blirk ™ Hidden r iable
d|a|0g bOX | :uperscr'pt I™ strong r ::y{:mard
gives you _I— Subscripk I™ Emphasis [~ Code
complete e
freedom to AP
Change (R -, N -
your text
attributes. o | conce T
3. Choose the new attributes for the selected text.
On the Font and Character Spacing tabs, you can change the font type,
style, color, and size, as well as modify things such as character posi-
tioning and spacing. You can also choose from a number of effects,
which enable you to modify such respects as the text’s visibility and
its emphasis.
‘?q‘“\NG! One of the biggest problems with Web site development involves fonts.
S If you change fonts by using the Font dialog box, you’re changing to

fonts that reside on your machine. Those fonts may not be installed
on someone else’s machine. As a result, what the user sees may look
entirely different from what you see as you're creating the page. The
two safest fonts to use, therefore, are Arial and Times New Roman,
because those fonts are installed on everyone’s computer.
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WING/
§g~ Many of the items in the Effects category don’t work with the older 3.0
browsers (Microsoft Internet Explorer 3.0 and Netscape Navigator 3.0),
WebTV, or newer handheld devices.
4. Click OK to activate your text changes.
Changing paragraph settings
You change paragraph settings in the same manner that you change font
attributes, so if these steps seem familiar, that’s because they are the same!
(Well, almost.) To change the paragraph setting for a chunk of text, follow
these steps:
1. Highlight the text that you want to change.
2. Choose Format->Paragraph.
The Paragraph dialog box, shown in Figure 5-3, appears.
Patagraph =]
Indents and Spacing
Alignment: Center line
Indenkation
Bsfore text: |10 ﬁ Indent first e
After test: |10 = s =
Figure 5-3: | " owe: e
You can after: L isines v
change your word [ =
paragraph Praview
settings
with a few
deft clicks in
this dialog
box. o] con
3. Enter the new paragraph settings in the Paragraph dialog box.
You can change the alignment, line spacing, and indentation of the
paragraph.
v?‘“\NG" As do font attributes, paragraph settings use Cascading Style Sheets
S and newer versions of HTML to set property values, making many of

these settings nonfunctional for the 3.0 and earlier versions of Netscape
Navigator and Internet Explorer, as well as WebTV and newer handheld
devices.

4. Click OK to save the paragraph settings.
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Creating bulleted and numbered lists

Bulleted and numbered lists are simple, yet effective, ways to communicate
an idea or concept with emphasis. And yes, FrontPage handles them just the
same as the rest of the Microsoft Office programs. To turn a series of text
items into a bulleted or numbered list, follow these steps:

1. Highlight the text that you want to change.

2. Choose Format->Bullets and Numbering.

The Bullets and Numbering dialog box appears.
3. Click the appropriate tab for the kind of list that you want.

FrontPage provides three basic kinds of lists: picture bulleted, plain bul-
leted, and numbered.

4. Select the bullet or number style that you want by clicking it in the
dialog box.

5. Click OK to save the text to a bulleted or numbered list.

You can click the Numbering or Bullets button on the Formatting toolbar
to create a numbered or bulleted list. By going this route, however, you get
plain numbers or bullets unless you chose a theme for your Web pages.

Changing borders and shading properties

FrontPage provides a number of text border and shading options. The value
in changing these settings is that you can place more emphasis on a particu-
lar piece of text by contrasting it with other text elements. Putting emphasis
on particular pieces of text is especially useful for important elements that
you want visitors to your site to see, such as navigation menus, sidebars,
and forms. To change borders and shading, follow these steps:

1. Highlight the text that you want to change.
2. Choose Format=>Borders and Shading.

The Borders and Shading dialog box appears (see Figure 5-4).

3. On the Borders tab, specify the border style that you want for the
text box.

You can choose from the following options:

e Setting: You can select one of three options: no border (the default),
a complete border around the text, or a custom border.

e Style: This box lists all the border styles that you can choose,
including solid lines, dashed lines, and grooved lines (my favorite),
just to name a few.



Figure 5-4:
Go wild with
the various
borders and
shading
options.
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e Color: You can select a color for your border from the many Web-
safe colors that this option offers.

e Width: In this text box, you can specify how wide (in pixels) you
want the border.

¢ Padding: You can set how much padding (in pixels) you want between
all sides of the border and the text inside it by entering a value in
these four text boxes.

e Preview: In this area, you can see what your borders look like, as well
as add or remove individual sides of the border. To add or remove
sides, click one of the four buttons that surrounds the sample page.

4. Choose your shading options.

On the Shading tab, you can set the foreground and background colors,
as well as select an image as the background for the text box. To choose
a background image, click the Browse button to find an image on your
local drive, a network drive, or the World Wide Web. With each color
selection, you get several default choices, but you can also specify any
color from the Web palette.

5. Click OK to set your border and shading options.
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Working with Tables

When it comes to laying out a Web page, tables are the backbone of nearly
all Web-page development. The notion of a table with rows and columns was
one of the first concepts introduced in the first version of HTML. Tables still
offer the most effective method of presenting data within a Web browser.
Instead of carefully laying out everything, you just plop each item in a table.
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Figure 5-5:
You can use
this dialog
box to insert
tables into
your Web
page the
easy way!

Not surprisingly, FrontPage offers a host of utilities that make generating and
maintaining tables a reasonably easy task. The syntax and methodology for
creating tables are, in fact, very similar to that of the other Office programs.

Creating a new table

To create a table in FrontPage, follow these steps:

1. Choose Tabler>Insert~>Table.

The Insert Table dialog box appears (see Figure 5-5).

Insert Table &
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2. Select one of the following layout tool options:

¢ Enable Layout Tools: Clicking the border of a table created with this
option automatically activates the FrontPage table layout tools.

¢ Disable Layout Tools: Clicking the border of a table created with this
option doesn’t automatically activate the FrontPage table layout tools.

e Automatically Enable Layout Tools Based on Table Content:
Clicking the border of a table created with this option automatically
activates the FrontPage table layout tools (or not) based on the con-

tent you place in your table cells.
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Another way to view table layout tools is to choose Tabler>Layout
Tables And Cells from the FrontPage main menu to display the
Layout Tables and Cells task panel and then select Show Layout Tool
from the Layout Tables and Cells task panel.

. Type a number in the Rows and Columns text boxes to choose the

number of rows and columns that you want for your table.

Remember: If you need more rows and columns after you create your
table, you can just right-click a cell and choose Insert Row or Insert
Column from the shortcut menu.

. Set your layout options from the Layout area of the Insert Table

dialog box:

e Alignment: Determines how you want the table to be aligned on the
page. Your choices are left, right, and center. Choosing Left, for
example, places the table against the left margin.

¢ Float: Determines how you want the table to be aligned on the page.
Your choices are left and right.

e Cell Padding: Sets the distance, in pixels, between the borders of a
cell and the text within the cell. Enter a number in this text box.

¢ Cell Spacing: Sets the distance, in pixels, between cells. Enter a
number in this text box.

¢ Specify Width and Specify Height: Sets the width and height, respec-
tively, of the table. You can specify both width and height as a per-
centage of the page or as a set pixel width by choosing the In Pixels
or In Percent option button.

5. Set your table border options from the Borders area of the Insert

Table dialog box:

¢ Size: Establishes the thickness of the line border around both the
cells and the outside of the table. Enter a number in this text box. If
you don’t want a border, set the value to 0.

¢ Color: Sets the color of the border around both the cells and the out-
side of the table. Click the drop-down list to choose a color for the
border.

e Light Border: Sets the color of the portion of the border that appears
around the top and left sides of the table and around the bottom and
right sides of the cells. Click the drop-down list to choose a color.

¢ Dark Border: Sets the color of the portion of the border that appears
around the top and left sides of the cells and around the bottom and
right sides of the table. Click the drop-down list to choose a color.
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Figure 5-6:
The Table

Properties
dialog box.

¢ Collapse Table Border: Checking this option tells FrontPage to leave
no space between row and cell borders. (Unchecking it tells FrontPage
to display row and cell borders detached.) This option isn’t available
if you choose Enable Layout Tools (see Step 2).

6. Set your background options from the Background area of the Insert

Table dialog box:

¢ Color: Click the drop-down box to choose a color for the background

of your table.

e Use Background Picture: Checking this option allows you to enter the
fully qualified name of a picture file (for example, .gif or .jpg) in the
text box you see below the check box. You can type directly into the
text box the name of the picture file you want to appear in the back-
ground of your table, or you can click the Browse button to display
the Select Background Picture dialog box. In the Select Background
Picture dialog box, select the file you want and click Open.

7. Click OK to insert the new table.

After you create a table, you can go back and change the properties you just
set by placing your cursor anywhere in the table and choosing Tablem>Table
Properties>Table to open the Table Properties dialog box (see Figure 5-6).
You can also right-click the table and choose Table Properties on the short-

cut menu.
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Figure 5-7:
Insert a new
row or
column
wherever
you want.
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You can also choose Tabler>Table Propertiest>Cell to change the properties
you just set for individual cells. Make your changes in the Cell Properties
dialog box that appears.

Modifying tables

In addition to generating tables, FrontPage offers a host of tools for modify-
ing tables after you create them. The following list describes the ways in
which you can modify a table:

4 Adding cells: You can add individual cells, rows, or columns. In all cases,
first place the cursor where you want to create the new cells, rows, or
columns.

e To insert new cells, choose Tabler>Insert=>Cell. FrontPage places
a new cell directly to the right of the cell in which you placed the
Cursor.

¢ To insert new rows or columns, choose Table=>Insertz>Rows or
Columns. The Insert Rows or Columns dialog box appears (see
Figure 5-7). Choose the number of rows or columns that you want to
insert, as well as their location, and then click OK to insert them.

Insert Rows or Columns
(" Rows (* Columns
Mumber of columins: |3 ﬂ

Location: -
" Left of selection

* Right of seleckion

aK | Cancel ‘

4 Deleting cells: Select a cell (or group of cells) and then choose Tabler>
Delete Cells to eliminate the cell and its contents from the table.

4 Merging cells: Select the cells that you want to merge and then choose
Table=>Merge Cells to collapse the two cells and combine their contents.

4+ Splitting cells: Select the cells that you want to split and then choose
Table=>Split Cells. In the Split Cells dialog box that appears, choose
whether you want to split the cells into rows or columns and how many
rows or columns you want to split the cell(s) into and then click OK.

4+ Distributing cells: Select rows or columns of uneven size and then
choose either Tablem>Distribute Rows Evenly or Table=>Distribute
Columns Evenly to make the rows or columns equal sizes.
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Checking spelling on a Web page

Don't wait to check the spelling on your pages
until they're up on the Weh! Check your spelling
before others find your mistakes. You can run a
spell-check on a page to make sure that it
doesn't contain spelling errors. You can also tell
FrontPage to fix those spelling errors and track
them so that you can see them in the Tasks
view. To track spelling errors in FrontPage,

2. Click the correct spelling in the Sugges-
tions list box or type it in the Change To
box.

3. Click the Change button.

4. Continue correcting errors until you see
the Spelling Check Is Complete
message.

@ ATEsE Sy You also find Ignore buttons for ignoring what

FrontPage thinks are spelling errors and an Add
button for entering words in the dictionary and
preventing the spell-checker from stopping on
them in the future.

1. Choose Tools=>Spelling.

The Spelling dialog box appears if FrontPage
detects a spelling error. (As in other Office
products, you can also press F7 to open the
Spelling dialog bhox.)

4 AutoFit to Contents: The AutoFit to Contents command tries to find the
optimal size for the cells in the table based on their contents. This way,
the table contains no wasted space. AutoFit to Contents is a good tool
to use if you replace text or a graphic of a different size within a table
cell. Select the cells and choose Tabler>AutoFit to Contents to set the
optimal table.

Creating and Using Hyperlinks

Hyperlinks sounds like such an impressive word . . . very futuristic . . . the
kind of thing you would expect Captain Kirk or Captain Picard to burst out
with on any given episode of Star Trek. Truthfully, however, hyperlinks —
referred to as plain old links by most people — are just a way of jumping
from location to location on the Web.

Hyperlinks are the navigational building blocks of any Web site. Without
hyperlinks, you would never get off the home page of a Web site. So, not sur-
prisingly, FrontPage offers a vast array of tools for generating and maintain-
ing hyperlinks. To create a hyperlink in a Web page, follow these steps:

1. Highlight the text or image that you want to turn into a hyperlink.

You can also create a link to a page without highlighting anything at all.
In this case, the link uses the title of the page that you're linking to for a
text description.



Figure 5-8:
Hyperlinking
has never
been so
easy.

2.
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Choose Insert~>Hyperlink or press Ctrl+K.
The Insert Hyperlink dialog box appears (see Figure 5-8).

If you're trying to cut down on using menus, you can click the Hyperlink
button on the Standard toolbar to access the dialog box.

Insert Hyperlink
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Interret Explorer version 4.0 or laker,
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3.

Click the ScreenTip button.
The Set Hyperlink ScreenTip dialog box (refer to Figure 5-8) appears.
Type a description of the hyperlink and then click OK.

When visitors to your Web site move their mouse pointers over the link,
they see the description that you enter in a pop-up box.

Create the link by choosing from the following options in the Insert
Hyperlink dialog box:

A link to a Web page on the Internet: Under Link To, click the Existing
File or Web Page button. Then type the address of the Web page by
doing one of the following:

e Type it in the Address text box.
e Open the Address drop-down list and select it.

e (Click the Browse the Web button. Your Web browser opens. Go to
the Web page that you want to link to. After you return to the Insert
Hyperlink dialog box, the address of the page appears in the Address
text box.

¢ (Click the Browsed Pages button, look for the address of the page,
and select it.

= W
o O
= S
- =
[1-
= =
o1 =

syuI pue ‘sajqey
1xa] :afieq 1noj uo
saiseg ay) buyen



2 40 Creating and Using Hyperlinks

A link to another page in your Web: Click the Existing File or Web Page
button. Then click the Current Folder button. The dialog box lists the
files that make up your Web. Find the Web page that you want to link to
and select it.

A link to another place in the same Web page you are on: Click the
Place in This Document button. Then click the plus sign next to the
Bookmarks label, if necessary, to see the bookmarks on the page; find
the one that you want to link to and click it. To link to a place in the
same document, you must have bookmarks in your document. To place
a bookmark, click where you want the bookmark to go, choose Insertm>
Bookmark, enter a name for the bookmark in the Bookmark dialog box
that appears, and click OK.

A link to an e-mail address: Click the E-mail Address button. Then enter
your e-mail address, suggest a subject for the messages that others
send you, and click the OK button.

After you create a hyperlink, make sure that you test it by switching to
Preview mode and clicking it. If the hyperlink doesn’t work, right-click it,
choose Hyperlink Properties from the shortcut menu, and fix the link by
typing the correct URL for the link in the Edit Hyperlink dialog box that
appears. This dialog box works exactly like the Insert Hyperlink dialog box
(refer to Figure 5-8). Click the Remove Link button to remove a hyperlink.

So, what's your page looking like?

You probably don’t like the idea of working on FrontPage supports three viewing ranges:
something that you can’t see. Well, FrontPage Internet Explorer in the browser Default
doesn't keep you in the dark. To preview a Web size, 640 x 480, and 800 x 600.

page from any browser on your desktop, follow

these steps: To preview your page in another browser,

select Edit Browser List to display the Edit

1. Switch to the Folders view by clicking the Browser List dialog box and then click Add
Folders icon in the Views bar or choose to display the Add Browser dialog box. In
View=>Folder List to open the Folder List the Add Browser dialog box, enter the name
from your current view. and command (location) of another Web

browser located on your machine. When

2. Click the page that you want to preview in you finish, click OK.

an external Web browser.
3. Choose File->Preview in Browser. G (i _the Prewev_v_button to view your Web
page in the specified browser.
The Preview in Browser dialog box appears.

4. Select the browser in which you want to
preview the page.




Figure 5-9:
Hyperlinks
view
displays all
your links.
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Working with the Hyperlinks view

One of the nice things about the Hyperlinks view is that you can choose any
object in your Web site — including HTML pages and graphics — and see
exactly what pages or other objects link into that object. You can also see
where the object links. With the Folder List open, all you need to do is click
an object, and the Hyperlinks view displays all the links to and from that
page, as shown in Figure 5-9.

FrontPage comes with a Web browser built into its editor, but sometimes
you just can’t beat the real thing. Check out the sidebar titled “So, what’s
your page looking like?”, in this chapter, for hints on viewing your page live.

Recalculating a project’s hyperlinks

Through the process of building pages, moving folders around, and gener-
ally doing the work that maintaining a Web site requires, some things are
liable to get broken. Hyperlinks are usually the first things to go. To combat
this problem, FrontPage depends on Hyperlinks view, which enables you to
see the links to and from every page and graphic on your site.
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2 42 Creating and Using Hyperlinks

Ah, but if a link’s broken and you can’t see it amid the links, how do you
know that it’s broken? That’s where the FrontPage Recalculate Hyperlinks
feature comes in handy.

To recalculate hyperlinks, choose Toolsm>Recalculate Hyperlinks. FrontPage
warns you that recalculating may take a while and asks whether you really
want to do it. Click Yes after you see the prompt, and you're off. Although a
progress indicator doesn’t appear, the bottom-left corner shows you that
FrontPage is recalculating your hyperlinks. When the recalculation is com-
plete, your pages are updated, and broken hyperlinks are repaired.



Chapter 6: Perking Up Vour Pages
with Interactive Buttons,
Counters, and Move

In This Chapter

v Adding interactive buttons (rollovers), counters, and marquees

v Adding clip art and other graphics

If people want to see black text on a white background, they can read a
book. On the Web, people like to push things, watch things move, and see
neat pictures. If you want to make your Web page a success, you need to
make it visually pleasing. In this chapter, you find out how to add exciting
graphics and navigation aids to your Web site.

Inserting Some Extra Effects

QNG

You may have admired some Web pages that feature moving messages, ani-
mated buttons, hit counters, and the like. These effects are easily within
your reach, and this section shows you the way.

Some special effects don’t work with the older 3.0 browsers (Microsoft
Internet Explorer 3.0 and Netscape Navigator 3.0), WebTV, or newer hand-
held devices.

Adding a hit counter

A hit counter tracks the number of times people access a page and displays
the number of “hits” on the Web page itself. It’s a nice way of saying, “Hey,
look how popular my Web page is!” (That is, unless nobody’s visiting your
Web site, in which case you probably don’t want to include a hit counter.)
To add a hit counter, follow these steps:
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1. Choose Insert->Web Component.
The Insert Web Component dialog box, as shown in Figure 6-1, appears.
2. In the Component Type area, click to select Hit Counter.

The right side of the dialog box offers different counters that you may
choose for your Web page.
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pages us'ng Insert a counter that kalies and displays the number of times the page has been visited,
the Insert
Web
Component |
dialog box, || Semmenznis e : = ([ |
3. Click to select the style and number of digits that you want in your hit
counter.
4. Click the Finish button.
The Hit Counter Properties dialog box appears (see Figure 6-2).
5. Make any, all, or none of the following changes:
e Change the counter style you set in Step 3 by clicking next to any of
the styles you find in the Counter Style section.
¢ Reset the counter to any number you want by checking the Reset
Counter To check box and specifying a corresponding number.
e Specify a fixed number of digits other than the default, which is five,
by checking the Fixed Number of Digits check box.
6. Click OK to finish.
A\\S

If you're editing an existing hit counter and you want to reset the counter,
click the Reset Counter To check box and, in the text box next to it, type the
number to which you want the counter to be reset.



Figure 6-2:
The Hit
Counter
Properties
dialog box.
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Adding an interactive button (rollover)

Buttons that animate or highlight as you roll your mouse cursor over them
are very popular. A number of methods exist for adding this kind of graphi-
cal quality to a Web page, including using JavaScript and Dynamic HTML.
Not to be outdone, FrontPage offers you a way to use Java to create the
same effect! To add an interactive button (often called a rollover), follow
these steps:

1.

Choose Insert=>Web Component.

The Insert Web Component dialog box appears.

In the Component Type area, select Dynamic Effects.

In the Choose an Effect area, double-click Interactive Button.
The Interactive Buttons dialog box appears (see Figure 6-3).
Specify the properties for the button.

By clicking the Button, Font, and Image tabs you see in Figure 6-3, you
can set a number of different options for the button, including the size
and color of the button, button text, and the page to which the button
links after you click it.

Click OK to insert the interactive button into your Web page.
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Adding a marquee
Have you ever seen the stock listings whoosh by on a digital board or at the
bottom of your television screen? Those are two examples of a marquee,
which you can easily embed in your Web page. To add a marquee to a Web
page in FrontPage, follow these steps:
1. Choose Insert->Web Component.
The Insert Web Component dialog box appears.
2. In the Component Type area, select Dynamic Effects.
3. In the Choose an Effect area, double-click Marquee.
The Marquee Properties dialog box appears (see Figure 6-4).
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4. Specify the properties for your marquee.

Table 6-1 explains your options. In addition to these options, you can
change the text style associated with the banner. To do so, click the
Style button and then either select from the available styles or select
Format to create a new style.

5. Click OK to insert the marquee into your Web page.

Table 6-1 Marquee Settings
Setting What It Does
Direction Specifies the direction in which you want the text to move across the

screen by selecting the Left or Right option.

Speed Indicates the speed at which you want the text to move. In the Delay
text box, enter the amount of time in milliseconds that the marquee
pauses before it starts moving. In the Amount text box, enter the
distance in pixels that the marquee should move.

Behavior Indicates how you want the text to move on-screen when you choose
the Scroll, Slide, or Alternate option. If you choose Alternate, the
marquee alternates between scrolling and sliding.

Size Specifies the size of the banner when you enter its dimensions in the
Width and Height text boxes. By choosing an option, you can specify
whether the dimension measurement you're entering is in pixels or a
percentage. Percentage is the better option because, by choosing it,
you can take into account a visitor's Web browser.

Repeat Determines whether the banner repeats continuously or appears
only once. Deselect the Continuously check box if you want it to
appear once. To make it repeat, enter in the Times text box the
number of times that you want it to repeat.

Background Color Indicates the background color for the marquee when you choose a
color on this drop-down list.

Graphics to Web Pages

Now that FrontPage looks more like Word than anything else, the similarities
between adding graphics to a Web page in FrontPage and adding graphics to
a document in Word aren’t surprising. In fact, adding graphics in FrontPage
is very similar to adding graphics in Word. If, however, you don’t choose to
use the Word-like interface in FrontPage, you can still use the FrontPage
HTML capabilities.

Although FrontPage supports a host of file formats for graphics, older
browsers (3.0 and earlier) don’t support many of the file formats that
FrontPage supports. As a result, you're better off making sure that the graphic
that you want to import is in either GIF or JPG format before you import it
into FrontPage. (Besides, those graphics load faster than the others.)

Book Il
Chapter 6

safied 1nop
dn Bunpagd



2 48 Adding Graphics to Web Pages

If you're looking for graphics for your Web page, you can either get one from
your computer or use one from the Microsoft Clip Organizer.

Adding a graphic on your own

To add a graphic that you're storing on your computer, follow these steps:

1. Click the location on the active Web page where you want to put your
graphic.
If your page is blank, your only choice is to place your cursor in the top-
left corner.

2. Choose Insert>Picture~From File.

The Picture dialog box appears (see Figure 6-5).
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3. Select the graphic that you want to insert.

From the Picture dialog box, you can browse your Web, the rest of your
computer, or the Internet to find the graphic that you want to insert.
FrontPage also provides thumbnail previews for each graphic that you
click, so you can see what you’re adding before you add it.

4. Click the Insert button to add the graphic to your Web page.

You can also add graphics to a Web page via the traditional Windows
drag-and-drop interface. To do so, go to the folder on your desktop that
houses the graphic that you want to insert. Click and drag the graphic
onto the active Web page and voila! There it is . . . good to go!
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V?‘“\NG! If the graphic you're adding to your page was created by someone else, you
need to ask permission to use that graphic — in other words, you need to
secure copyright permissions. For more information on U.S. copyright and
how it applies to the Web, check out www.1oc.gov/copyright.

Adding clip art from the Clip
Organizer to a Web page

FrontPage comes with an extensive Clip Art gallery that helps you create
buttons and banners, as well as communicate all kinds of different themes
and emotions. To add clip art to your Web page, follow these steps:

1. Click the Web page where you want the clip art to appear.

2. Choose InsertoPicturer>Clip Art.

The Clip Art task pane appears on the right of your screen, as shown in

Figure 6-6.
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3. Tell FrontPage how and where to search for clip-art images.

You use the Search For field to search for clip-art images; you use the
optional Search In and Results Should Be fields to limit (speed up) your
search.



250 Adding Graphics to Web Pages

e Search For: Type in this text box a word that describes what kind of
clip art you want to look for. For example, to find images containing
cars, you might type in the word car.

¢ Search In: You can limit the search by clicking the drop-down list
next to this option and selecting which directories you want
FrontPage to search.

¢ Results Should Be: You can further limit the search by clicking the
drop-down list next to this option and making choices to tell
FrontPage what kind of files to look for. If you select All Media Types,
for example, FrontPage searches for photographs, movies, and
sounds as well as clip art. To limit your search to clip art only, click
the plus sign (+) beside the All Media Types folder and then deselect
Photographs, Movies, and Sounds.

4. Click the Go button.

If FrontPage can find clip-art images, they appear in thumbnail form in
the Insert Clip Art task pane. If necessary, scroll down the list to exam-
ine all the images or click the small icon under the word Results to see
the images in a box.

5. Click an image to insert it in your document.

The image is probably too large, and you may need to make it smaller.
To do so, drag a corner handle on the image toward the image’s center.
(Book I, Chapter 7, explains many techniques for changing the size of
images.)



Chapter 7: Image Editing
for Everyone

In This Chapter

v~ Using the Pictures toolbar
+* Manipulating and editing your images
v~ Inserting hyperlinks

v Making an image map

Smply grabbing or creating an image and then plopping it as-is into your
Web page doesn’t enable you to take full advantage of the FrontPage
editing capabilities. You may find a great image to use, but think about what
else you can do to it. You can scale it, flip it, move it, bevel it, brighten it,
and more! You may want to place some text over it or turn the image itself
into a hyperlink. You can even turn different parts of the image into hyper-
links and make a clickable image map. This chapter walks you through the
process of editing your images in FrontPage.

Activating the Pictures Toolbar

In FrontPage, you can’t edit a graphics image without first activating the
Pictures toolbar. Unlike a number of the other toolbars in FrontPage, the
Pictures toolbar doesn’t have any corresponding keyboard or menu options.
To activate the Pictures toolbar, choose View=>Toolbarsw>Pictures or right-
click a toolbar and choose Pictures from the shortcut menu.

Working with Auto Thumbnails

An Auto Thumbnailis a handy tool that enables
you to create a miniversion of a picture. This
tool is particularly useful if you want to use an
image as a button that then links to a larger ver-
sion of the picture. To create an Auto Thumbnail,
select an image and click the Auto Thumbnail
button on the Pictures toolbar.

After you create a thumbnail and go to save the
page, FrontPage prompts you to save the new
thumbnail image. After you load the page in a
browser, you see the thumbnail rather than the
original image. Then, after you click the thumb-
nail, the larger version appears in the Web
browser by itself.
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Figure 7-1:
Clicking the
icons on the
Pictures
toolbar
allows you
to add and
manipulate
images
quickly and
easily.

Figure 7-1 briefly acquaints you with the buttons on the Pictures toolbar; the
remaining sections in this chapter describe in greater detail the buttons
you're likely to use most.
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Image Manipulation Made Easy

If FrontPage doesn’t make image manipulation easy, it at least makes image
manipulation easier than ever before. Although image editing in FrontPage
isn’t as powerful as in Photoshop or some of the other popular graphics
software, you can’t beat the convenience of getting this editing capability
already built into your Web-creation application.

Scaling an image

Scaling is the process of making an entire image either larger or smaller.
(No cutting away of the image is involved here.) You can scale an image
just by clicking it.

After you click an image, you see anchor points appear around the border of
the image. To scale the image, click and drag one of these anchor points.
The image resizes itself according to where you release the anchor point.
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To scale an image and keep its proportions intact, choose one of the corner
anchor points and then scale the image. Scaling in this manner keeps the
aspect ratio (the height-to-width ratio of an image) consistent as the image
gets bigger or smaller.

After you scale your image, you can resample it by clicking the Resample
button on the Pictures toolbar. The Resample tool analyzes the image that
you just scaled. If, for example, the image became bigger, the pixels that
make up the image are stretched. The Resample tool then breaks up the
stretched pixels into smaller pixels to create a crisper, cleaner image.
Similarly, if you shrink the image, you end up with more pixels than are
really necessary for a smaller image. In this case, using the Resample tool
eliminates any unnecessary pixels without sacrificing image quality — a
bonus for any image included in a Web page. (Small image files download to
users’ browsers faster than large image files.)

If you don’t like how your newly scaled image looks, you can click the
Restore button to reset the image to its original size.

You can use the Restore button on a number of other Pictures toolbar fea-
tures as well, including the Color, Brightness, Contrast, Rotate, and Flip
tools.

Changing brightness and contrast

Changing a graphic’s brightness makes the graphic appear lighter or darker.
Changing a graphic’s contrast makes the graphic’s individual pixels either
stand out more or become more muted. Usually, setting a graphic’s contrast
goes hand in hand with changing the graphic’s brightness. So, for example,
the brighter a graphic becomes, the more contrast you need to avoid it
becoming washed out. To change an image’s brightness and contrast, follow
these steps:

1. In the Page view, click the image that you want to modify.

2. Click any of the following four Contrast or Brightness options on the
Pictures toolbar:

e More Contrast: This option increases the color distinctions between
pixels.

¢ Less Contrast: This option makes the colors blend together.
¢ More Brightness: This option washes out the image.
¢ Less Brightness: This option darkens the image.

Every time that you click a button, the brightness or contrast either
increases or decreases incrementally. The more times that you click the
brightness button, for example, the brighter the image gets.
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You can undo your work by pressing Ctrl+Z or clicking the Undo button on
the Standard toolbar. In fact, FrontPage supports multiple undos, so if you're
fiddling with an image and you want to return it to its previous condition,
open the Undo button drop-down list and choose how many actions you
want to undo. (To restore an “undone” action, press Ctrl+Y or click the
Restore button.)

Setting an image’s transparent color

GIF images support transparency, which means that you can choose to
make a particular color on your image invisible. This feature is helpful if you
have a square graphic and you want to display only the logo in the middle of
the image. In FrontPage, setting the transparent color is a cinch! Here’s what
you do:

1. In Page view, click the graphic that contains the color that you want
to make transparent.

2. Click the Set Transparent Color button on the Pictures toolbar.
3. Click the color on the image that you want to make transparent.

All instances of that color in the image become invisible, and you can
see the Web page background through it.

Only GIF images can be made transparent, but all is not lost if you're using
other image types in your Web page — a JPEG image, for example — because
FrontPage turns images into GIF files after you click the Set Transparent Color
button on the Pictures toolbar. In addition, you can set only one transparent
color by using this tool. If you select the tool again and click another color,
that color becomes the transparent color, and the preceding transparent
color is no longer transparent.

Beveling an image

Beveling adds both a border and three-dimensional depth to a graphic. The
most frequent reason to bevel an image is to create a button effect. To bevel
an image in FrontPage, follow these steps:

1. In Page view, click the image that you want to bevel.
2. Click the Bevel button on the Pictures toolbar.

A bevel appears on the graphic, as shown in Figure 7-2.

3. If you want to make the bevel darker and add more emphasis to it,
click the Bevel button again.

Click the Undo button on the Standard toolbar if you regret clicking the
Bevel button too many times. (Click the Restore button to restore
“undone” actions.)



Figure 7-2:
Animage
can have a
beveled
(button-like)
edge.
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Cropping an image

Cropping reduces an image in size by lopping off portions of an image.
Cropping images comes in handy if, for example, you have a picture of you
and your mother-in-law and you want to eliminate your mother-in-law from
the picture. To be honest, the FrontPage cropping features are limited in
that you can crop only rectangular areas. To crop an image, follow these
steps:

1. In Page view, click the image that you want to crop.
2. Click the Crop button on the Pictures toolbar.

A rectangular box appears inside the image’s border.

3. Click and drag a selection handle to form a rectangle around the part
of the graphic that you want to keep (see Figure 7-3).

You see eight selection handles, one at each corner and one in the
middle of each side of the image. You can drag more than one selection
handle in succession and in so doing form the rectangle around only the
part of the image that you want.

4. Press Enter to crop the image to the size of the rectangle.
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If you decide that you don’t want to crop an image, press the Esc key or
click outside the image to disengage the cropping tool.

Flipping and rotating images
FrontPage makes flipping and rotating images easy. To do so, follow these
steps:

1. In Page view, click the graphic that you want to flip or rotate.

2. Click the Rotate Left, Rotate Right, Flip Horizontal, or Flip Vertical
button on the Pictures toolbar, depending on the action that you want
to initiate.

You get the following options with each button:
¢ Rotate Left: This option rotates the image 90 degrees to the left.
¢ Rotate Right: This option rotates the image 90 degrees to the right.



Figure 7-4:
You place
text over an
image by
using the
Text button.
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¢ Flip Horizontal: This option mirrors the image left to right.

e Flip Vertical: This option mirrors the image top to bottom.

Placing text over an image
FrontPage supports a clever little way of placing text in images to achieve a
nice effect. To do so, follow these steps:

1. In Page view, click the graphic over which you want to place text.

2. Click the Text button on the Pictures toolbar.

A text box appears in the middle of your graphic (see Figure 7-4). To
resize the text box, drag the box’s anchor points by using your pointer.

3. Type the text that you want in the text box.

You can change the font or font size of text by selecting the text and
choosing options from the Font and Font Size drop-down lists on the
Formatting toolbar.

4. Press Esc.
Text button
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To generate another text box on that image, click the image and then click
the Text button again. If you want to move a text box around on the image,
click and hold the mouse button while the cursor’s in the middle of the text
box and then move the text box to its new location.

Because this graphic is essentially an image map with text, you can also
turn these text boxes into hyperlinks. Just choose Insert=>Hyperlink from
the main menu (or, alternatively, press Ctrl+K) to open the Edit Hyperlink
dialog box after you create a text box in a selected image. Then enter the
link location and click OK to add the link to the text on the image.

If you're using other image types in your Web page — a JPEG image, for
example — FrontPage tries to turn the image into a GIF file after you click
the Text button on the Pictures toolbar. In most cases, this change compro-
mises the graphical quality of the image you're adding text to, because con-
verting from a JPEG to a GIF reduces the number of colors in the image.

Adding a hyperlink to an image

Using images as hyperlinks can add pizzazz and flair to a Web site. To add a
hyperlink to an image, follow these steps:

1. With the Design button selected in Page view, click the image that
you want to make a hyperlink.
2. Choose Insert->Hyperlink or press Ctrl+K.

The Insert Hyperlink dialog box that appears may look familiar; it’s
the same dialog box that FrontPage uses to create text hyperlinks
(see Figure 7-5).
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See Book III, Chapter 5, for more information about creating text
hyperlinks.

3. Click OK.

You can now use the image as a hyperlink on your Web page.

Creating Image Maps

Image maps are great navigation tools that you see in many Web sites. You
load a Web page, and a big graphic appears smack dab in the middle of the
page. On the graphic are a host of hot links to various locations. How did
the Web designers create such a helpful tool, you ask? The answer lies in
image maps.

You create image maps by specifying regions of a graphic and then setting
links for those regions. In the past, you needed to create image maps in a
separate program and then load the map into your Web page. Times change.
The following steps show you how to create an image map in FrontPage:

1. In Page view, click the graphic for which you want to create an
image map.

2. Select one of the Image Map shapes tools from the Pictures toolbar.
FrontPage provides the following shape tools for creating image maps:

¢ Rectangular Hotspot: This button creates squares and rectangles.
To create a square or rectangular link, click the image and then drag
the mouse while holding the mouse button. FrontPage creates a
square image from the point where you first click the mouse.

¢ Circular Hotspot: This button creates circles and ovals. You create a
circular link precisely the same as you do a rectangular hot spot.

¢ Polygonal Hotspot: This button enables you to create multisided
polygon areas. Click the image first to create a path and then click it
again to specify each point for the linked area. You finish creating
the polygon by selecting the first path point. Doing so encloses the
polygonal image.

3. Create the shape that you want.
The Insert Hyperlink dialog box appears.
4. Create the hyperlink.
Book IIl, Chapter 5, explains in detail how to create a hyperlink.

5. Click OK to set the hyperlink.
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You may want to move your link around on the graphic after you create it.
To do so, click the Select button (the arrow) on the Pictures toolbar and
then click and hold the mouse button on the link. As long as you continue to
hold the mouse button, you can drag the link around on the graphic.

To change the size of the link, click and hold any of the link’s anchor points —
the square dots along the outline of the link area. Then drag the anchor to
the desired location, and the link automatically scales according to where
you move the anchor point. Releasing the mouse button changes the link’s
size.



Chapter 8: Publishing
Your Web Pages

In This Chapter
v Publishing via HTTP
» Publishing via FTP

E/entually, you need to put your hard work on the World Wide Web for
everyone to see. The process of publishing on the Web may seem diffi-
cult, but it’s probably one of the easiest steps in creating a Web page (which
may explain why so much junk is already out there! Ahem). This chapter
shows you how to join the fray.

Publishing a Web by Using HTTP

\NG/
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HTTP sounds new and nifty, but if you’'ve ever loaded a Web page, you
already know what HTTP does. HTTP, which stands for HyperText Transfer
Protocol, is simply a way of transferring data from a server to your Web
browser (and vice versa). In fact, HTTP is the preferred way of transferring
files in FrontPage.

To use this method of file transfer, your Internet service provider (ISP) must
support the FrontPage server extensions. Use the FTP method of uploading
files if your ISP doesn’t support the server extensions. (To find out whether
your ISP supports FrontPage server extension, you need to ask.)

To publish a Web by using HTTP, follow these steps:

1. Choose File~>Publish Site.

The Remote Web Site Properties dialog box you see in Figure 8-1
appears.

2. Make sure the Remote Web Site tab is selected.

3. Choose one of the following two options from the Remote Web Server
Type area:

¢ FrontPage or SharePoint Services: Choose this option if your Web
server doesn’t support Web Distributed Authoring and Versioning
(ask your ISP).
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Figure 8-1:
Use the
Remote
Web Site
Properties
dialog box
to tell
FrontPage
where and
how to
publish your
Web site.

4.

e WebDAV: Choose this option if your Web server does support Web
Distributed Authoring and Versioning (ask your ISP).

Note: You use the other two options, FTP and File System, if you
want to publish your site using FTP or publish your site to a direc-
tory on your local computer network, respectively. Because FTP is
popular publishing protocol, I cover FTP in the section “Publishing a
Web by Using FTP” later in this chapter.

In the Remote Web Site Location text box, type the URL where you
want to publish your Web content.

If you're not sure of the location to which you want to publish your Web
content, click the Browse button to search for FrontPage servers from
the New Publish Location dialog box.

Click the hyperlink in the dialog box if you're not sure whether your ISP
provides the appropriate server extensions to support the FrontPage
publishing features. Clicking the hyperlink sends you to the Microsoft
Web site for the most current list of ISPs that support the extensions.

Check the Encrypted Connection Required (SSL) check box if your
Web server requires a password-protected secure connection.

Your Internet service provider can tell you whether a secure connection
is required in order to upload files to your Web site.

Click OK to submit the new Web content.

FrontPage tracks the progress of the upload and shows you which pages
are transferring. After the upload is complete, an alert box appears,
telling you so.
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Web servers are typically password-protected, so the first time you see the
Publish Web dialog box, you always see another dialog box prompting you
for your user name and password. (Contact your ISP or Web host to find out
your user name and password.) This safeguard is intended to prevent
people from coming along and posting content on any Web site they want.

You can customize the way FrontPage publishes your Web pages. By clicking
the Optimize HTML and Publishing tabs you see in the Remote Web Site
Properties dialog box, you can strip out the comments and white space in
your uploaded HTML files (choosing this option makes understanding your
code difficult for would-be thieves), tell FrontPage to upload only those Web
pages that have changed since you last published your site, and more.

Publishing a Web by Using FTP

People were publishing Web sites long before Microsoft came along and
tried to make the whole process transparent to the user. Now, by using
FrontPage, you can finally connect to any server and publish your content
on the Internet by using FTP. FTP (short for File Transfer Protocol) is a soft-
ware interface that enables you to send (and also receive) files to a remote
computer over the Internet. Thanks to the protocol, you don’t have to enter
detailed commands about which files you want to send. All you have to do
is designate a folder on your computer.

If you're familiar with how the Web works, you may know that Web pages
are transferred from Web servers to Web browsers using HTTP (HyperText
Transfer Protocol). Why, then, the need for an additional protocol — FTP —
to publish your Web pages? Simply this: FTP was designed to let you trans-
fer all kinds of files (even large ones) quickly, with no browser involved.

Publishing by using FTP consists of two parts. The first is to set up your FTP
connection, and the second is to publish the content.

Setting up an FTP connection

To set up an FTP connection, follow these steps:

1. Choose File=>Open Site to access the Open Site dialog box.

Or, if you prefer, you can perform these same steps from the Open File
dialog box, which you open by choosing Filec>Open.

2. Open the Look In drop-down list and select Add/Modify FTP
Locations.

The Add/Modify FTP Locations dialog box appears, as shown in
Figure 8-2.
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3. In the Name of FTP Site text box, type the name of the FTP site.
If you don’t know the name of the FTP site you want to place your files
on, ask your ISP. To visit the FTP site, for example, you might type
ftp.examplesite.com.
4. In the Log on As area, choose how you want to log on to the FTP site.
If you want to log on anonymously, select the Anonymous option. If
you're a registered user, select the User option and then type your name
in the text box to the right of that button.
< 5. Type your password in the Password text box.
If you log on anonymously, most FTP sites either request or require that
you use your e-mail address as your logon password.
6. Click the Add button to add your FTP location to the FTP Sites area in
the dialog box.
You can also change the particulars of a location by clicking in the FTP
Sites area and then clicking the Modify button. Similarly, you can delete
a location by selecting it and clicking the Remove button.
7. Click OK in the Add/Modify FTP Locations dialog box to activate the
connection and return to the Open Site dialog box.
8. Click Cancel to return to FrontPage.

Publishing your Web

After you set up the FTP connection, you can publish your Web content by
following these simple steps:
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1. Choose Filec>Publish Site.

The Remote Web Site Properties dialog box appears.
2. Check the FTP option.

FrontPage prefills the Remote Web Site Location text box with ftp://.
3. Click the Browse button to access the New Publish Location dialog box.

The following steps explain how to enter the publish destination by
clicking the Browse button. But if you happen to know the location, you
can type it in the Site Name text box.

4. Open the Look In drop-down list and select an FTP location.

You find FTP locations at the bottom of the drop-down list, below
Add/Modify FTP Locations.

If you see the Name and Password Required dialog box, type your user
name and password there (contact your ISP or Web host if you can’t
remember your username and password) and click OK.

If you connect to the Internet through a firewall or proxy server (special
computers whose job it is to intercept messages between your computer
and the rest of the Internet as a security measure), you may run into a glitch
or two when publishing your Web site using FrontPage. If this is the case,
contact your system administrator for instructions on how to proceed.
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Chapter 1: Getting to Know
Dreamweaver

In This Chapter

1+~ Discovering the power of Dreamweaver

v Getting familiar with the Document window

» Examining a site with the Site window

v Choosing between Standard, Layout, and Expanded Tables modes
+ Exploring toolbar buttons

v+~ Using panels and Properties inspectors

v+ Finding out how to get help

If you’re looking for a Web design tool that’s easy enough for beginners to
use and sophisticated enough for Web design gurus, you have come to
the right place. The powerful Dreamweaver MX 2004, from Macromedia,
enables you to create almost any type of Web page. This chapter covers the
Dreamweaver basics and introduces you to some of the program’s essential
tools.

What Is Dreamweaver, and What Can 1 Do with It?

Dreamweaver MX 2004 is the industry standard for professional Web site
design, production, and maintenance. Whether you’re interested in creating
a site for fun (such as an online photo album or a site devoted to one of
your hobbies) or for business — an online store, for example — the flexible
Dreamweaver interface provides simultaneous graphical and HTML editing.
In other words, using Dreamweaver, you can lay out pages like an artist

and also fine-tune the associated code like a programmer. The built-in
Dreamweaver FTP features let you upload your site to the Web in a snap

so that you can share your masterpieces with the world. And using built-in
support for server-side features, such as ColdFusion (for integrating Web
pages with databases) and PHP (a server-side scripting language for creating
dynamic Web pages), you can go beyond simple Web sites to create robust,
full-fledged Web applications.
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Introducing the Document Window

Your primary workspace in Dreamweaver MX 2004 is the Document window.
The Document window appears automatically when you start Dreamweaver.
You have two choices:

4+ To work with an existing Web page: Select a Web page from the option
list that appears on the left side of the start-up page.

4+ To create a new Web page: Click Create New HTML from the option list
that appears in the middle of the screen.

Figure 1-1 shows you the option list that appears when you start
Dreamweaver. Figure 1-2 shows you an example of the Document window.

By default, the start-up page you see in Figure 1-1 appears when you start
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The Document toolbar
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The Document window

In the Document window, you construct your individual Web pages using
panels, inspectors, and dialog boxes to format your work. You can view the
Document window in Design view to work in a completely graphical environ-
ment, as shown in Figure 1-2, or you can choose Split view, where you can
view both the design layout and the HTML source code for your page at the
same time. (To display the Split view, choose Viewr>Code and Design from
the main menu.)

Examining Your Site with the Site Window

After you define a site in Dreamweaver (which [ show you how to do in
Book IV, Chapter 2), you can view that site in outline form by clicking the
Site Map button that appears in the expanded Files panel.

In Figure 1-3, you see the Expand/Collapse button you use to expand the
Files panel and display the Site Map button; Figure 1-4 shows you an example
of a site map.
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As you can see in Figure 1-4, the Site window shows you a list of all the files
in your site and a map of how those files connect. The Site window is also
where you connect to the host server so that you can transfer, or publish,
your site from your local computer to the Web. (You can find details in
Book IV, Chapter 9, about publishing your site.)

The Site window is just one built-in tool you can use in Dreamweaver. To see
more tools, check out the next section.

Choosing between Standard, Layout,
and Expanded Tables Modes

You can work with content in your Document window using any of the fol-
lowing three modes. The first mode is good for general, all-purpose Web
page design; the other two are useful for creating and editing HTML tables.

4+ Standard mode: Standard mode is the familiar — and only — WYSIWYG
(“what you see is what you get”) graphical view through which you lay
out pages in the Document window.

To work in Standard mode, choose View=Table Moder>Standard Mode
from the Dreamweaver main menu.

4+ Layout mode: Layout mode is specifically geared toward helping you use
tables to design your Web page. The advantage of Layout mode is that it
provides a simpler interface for drawing and editing tables and table
cells. Using Layout mode, you can draw tables and individual table cells
by choosing Insert=>Layout Objects>Layout Table and Insert=>Layout
Objects>Layout Cell, respectively.

To work in Layout mode, choose Viewr>Table Moder>Layout Mode from
the Dreamweaver main menu.

4+ Expanded Tables mode: When you select Expanded Tables mode,
Dreamweaver displays your tables surrounded by nice crisp borders
that make selecting, moving, and resizing your tables easier.

To work in Expanded Tables mode, choose View=>Table Moder>
Expanded Tables Mode from the Dreamweaver main menu.

If you don’t see the Layout mode or Expanded Tables mode buttons, choose
Views>Toolbarse>Document from the Dreamweaver main menu to display
the Document toolbar.

Book IV
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Exploring Toolbar Buttons

Dreamweaver provides you with two toolbars, the Standard toolbar and the
Document toolbar, both of which are packed with useful buttons you can
use to create and edit your Web pages quickly.

4 The Standard toolbar: You can view the Standard toolbar by choosing
Viewr>Toolbarse>Standard from the Dreamweaver main menu. This
toolbar displays buttons you can use to create new Web pages, open
existing Web pages, cut and paste text, and perform other common
word-processing operations. Figure 1-2, earlier in this chapter, shows
you what the Standard toolbar looks like.

4 The Document toolbar: You can view the Document toolbar by choos-
ing View=>Toolbars>Document from the Dreamweaver main menu. (You
can see an example of the Document toolbar in Figure 1-2.) You use the
buttons in the Document toolbar to work with Dreamweaver Web docu-
ments. Table 1-1 gives you a rundown of the Document toolbar buttons.

Table 1-1 Documented-Related View Buttons

Button or Tool Name What You Can Do

Show Code View button View full-screen HTML page code

Show Code and Design View button ~ View HTML page code and

= Document window at the same

time

Show Design View button View full-screen Document

window

No Browser Check Errors button Click and select Check Browser

Support and Show All Errors to
specify target browser and view
errors, respectively

File Management button Click and then select Get to
retrieve files from the Web site
host or select Put to send files to

=
End

the host

Preview/Debug in Browser button Click and select to preview or
debug in Internet Explorer or
Navigator

Refresh button Click to refresh (redisplay) the

contents of the Document window

View Options button Click and select to view visual
drawing aids, such as rulers,
grids, and more

]
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Using Panels, Bars, and Properties Inspectors

Figure 1-5:
The Forms
bar lets you
click to add
text fields,
list boxes,
and other
form
elements to
your Web

page.

You can use Dreamweaver panels, bars, and Properties inspectors to enter
details about all aspects of your Web site. These interfaces offer areas where
you can add and format page features, set up navigation and behaviors, and
manage your workflow.

Panels and bars

Panels and bars typically provide information about all instances of a partic-
ular page feature.

For example, you can use the Insert bar to add elements to your Web page
quickly and easily. Using the Insert bar named Forms, you can click to add
an HTML form to your Web page and then build your form by clicking to add
elements such as text fields, check boxes, and radio buttons until your form
looks just the way you want it. In Figure 1-5, you see an example of the
Forms bar.

Press arrow to see additional panels Forms panel
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Figure 1-6:
Properties
inspectors
can cus-
tomize the
charac-
teristics

of each
document
object.

You can choose Insert from the Dreamweaver main menu to insert any ele-
ment you see displayed on the Insert bar. For example, you can choose
InsertoForms to insert form elements.

Dreamweaver offers several Insert bars, including the Common, Layout,
Forms, HTML, and Application panels. In addition, Dreamweaver offers sev-
eral additional panels. For example, in Figure 1-5, you see the Assets panel
on the right side of the screen.

You can open panels and bars by choosing Window from the Dreamweaver
main menu and then checking the desired panel name (such as Insert, CSS
Styles, Behaviors, Frames, or Layers) from the drop-down list.

To close a panel, you can right-click the panel and choose Close Panel
Group from the pop-up list that appears. To close all panels and bars,
choose Windowr>Hide Panels from the main menu.

Properties inspectors

A Properties inspector is unique to the individual document object it
represents and contains details on attributes of the object. For example,
selecting text on a page opens the Text Properties inspector where you can
format the text size, font, color, link, and other information. To make certain
that the Properties inspectors are shown in the Document window, choose
Window=Properties from the main menu. You see an example of a Text
Properties inspector in Figure 1-6.
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Getting Help

Dreamweaver offers a variety of tools to help you find the answer to virtu-
ally any question you have about the program. The Help tools provide basic
information for beginners as well as advanced references detailing features
such as support for ColdFusion and extending the Dreamweaver application
itself (really!).

You can access help by using the Help menu on the main menu. Just choose
Help and then one of the following options:

+*

+

Getting Started and Tutorials: Uses steps to walk you through the
process of creating a simple Web document.

Using Dreamweaver: Provides definitions and itemized steps in per-
forming routine Dreamweaver tasks. This option opens the Microsoft
Internet Explorer browser and displays Help Contents, Index, and
Search categories.

Using ColdFusion: Provides assistance in installing, configuring, and
administering ColdFusion, the Macromedia server-side language for
integrating databases with Web pages. This option also offers reference
material for developing Web-based ColdFusion applications.

Reference: Opens a panel offering a dictionary-style reference on CSS,
HTML, and JavaScript.

Extensions: Provides tips for creating extensions to the Dreamweaver
application itself (including an Application Programming Interface, or
API, reference) as well as instructions for submitting those extensions
for distribution to other Dreamweaver developers and installing third-
party extensions.

Dreamweaver Support Center: Connects you to the Web, where you
can find continually updated information on working with Dreamweaver,
answers to Frequently Asked Questions, and program extensions.

Macromedia Online Forums: Connects you to an online developers’
forum where you can chat with other Dreamweaver users to get (and
give) help.

Activation: Allows you to activate and register your copy of Dreamweaver.
Also allows you to transfer your Dreamweaver license — helpful if you
upgrade your computer and want to reinstall your copy of
Dreamweaver on your new computer.

About Dreamweaver: Displays the version number of Dreamweaver.
(Click the Escape key to make the version display disappear.)

Book IV
Chapter 1

laneamuwiealq
mouy 0} Buyan



278  Book 1V: Dreamweaver



Chapter 2: Creating Vour First
Web Site with Dreamweaver

In This Chapter

v~ Starting Dreamweaver
+ Creating a new site or document
v Adding content to your document

v Saving and previewing your document in a Web browser

D eveloping a Web page from scratch is an easy task with Dreamweaver.
In this chapter, you see a five-minute procedure for creating a simple
Web page.

Starting Dreamweaver

Each time you start Dreamweaver, a list of options appears in the Document
window — options you can click to open existing documents or create new
documents. To start Dreamweaver, you do the following:

In Windows: Choose Start=>All Programsc>Macromedia->Macromedia
Dreamweaver MX 2004 from the Status bar at the bottom of the screen.

In Macintosh: Click the Application button on the Launcher and click the
Dreamweaver program icon.

Creating a New Site

In Dreamweaver, creating a new site means specifying a location where you
want your documents (Web pages) and dependent files, called assets (such
as images and audio files), to be stored. After you create a new site, you can
use the powerful Dreamweaver site-related features, such as viewing a
graphical site map and automatically checking site links.
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Figure 2-1:
Clicking the
Basic tab in
the Site
Definition
dialog box
walks you
through the
process of
creating a
new Web
site.

To create a new site, follow these steps:
1. Start Dreamweaver and choose Siter>Manage Sites from the main
menu.
The Manage Sites window appears.

2. Click the New button in the Manage Sites window and then choose
Site from the menu that appears.

A Site Definition dialog box, similar to the one you see in Figure 2-1,
appears. Note that the Advanced tab is displayed by default.

Clicking the Basic tab in the Site Definition dialog box walks you
through the process of defining your site step by step.

‘Site Definition for My First Site %]

Bas | Advanced

Site Definition

Editing Files Tesst

A site, In Macromedia Dreanwesver MX 2004, is a colection of files and Folders that corresponds
Lo & website on a server,

‘wihat would you like to name your site?
My Firsk Site
Example: mySite

IF you weark ko werk directly on the server using FTP or RDS, you shoud create an FTP or RDS
server connechion instead. Server connections do nok Alow you to perform sitewide operations
Irik checking or site reports,

I Hest = H Cancel “ Help |

3. In the Site Definition dialog box, enter a name for your site in the
What Would You Like To Name Your Site? text box.

The name can contain spaces. For example, My First Siteis avalid
site name.

4. Click Next.
The Editing Files, Part 2 screen appears.



A\

5.

10.

11.

12.

13.
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Choose Yes if you plan to add a server-side program (such as a
database-accessing script written in PHP) to your Web site; otherwise,
choose No.

If you choose Yes, a drop-down list appears. Choose the server-side
technology you want to include in your Web site.

. Click Next.

The Editing Files, Part 3 screen appears.

. Choose whether you want to work with your files locally (on your

computer) or remotely (on the Web server). After you choose, specify
the location where you want to store your site files.

You can either type the fully qualified name of a folder in the text field
provided or click the folder button and browse to locate an existing
folder.

. Click Next.

The Sharing Files screen appears.

. Select a remote connection option, such as FTP, from the drop-down

list.

Depending on the option you choose, additional options appear. For
example, if you choose FTP, additional options for that FTP address,
remote folder, login, and password appear. Follow the instructions you
see on the Sharing Files screen to make selections for all additional
options that appear.

Click Next.
The Sharing Files, Part 2 screen appears.
Choose whether you want to enable file check-in.

Checking files in and out “locks” those files, preventing two people from
making changes to the same file at the same time.

Click Next.

A summary of the site definition details you specified in Steps 3 through
11 appears for your review.

If you want to make changes to the site definition details you see, you
can either click the Back button or the Advanced tab.

Click Done.

The Manage Sites dialog box reappears.

Book IV
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Figure 2-2:
After you
define a
site in
Dream-
weaver,
site-related
operations,
such as
getting and
putting files,
become
available.

14. Click the Done button in the Manage Sites dialog box.

The folder (and existing files, if any) you specified in Step 4 appear in
the Files panel, as shown in Figure 2-2.

15. Click OK.
The Manage Sites dialog box reappears.
16. Click the Done button in the Manage Sites dialog box.

The folder you specified in Step 7 appears in the Files panel, as shown
in Figure 2-2.

If you specified existing files in Step 7, you can view them in the Files panel
by choosing Local View from the drop-down menu in the Files panel.

You can specify much more information about your Dreamweaver site than
the site’s name and location. To specify additional information, such as the
location of your Web server, choose SiteroManage Sites from the main menu,
select the site name you specified in Step 3, and then click the Edit button.
In the Site Definition dialog box that appears, choose any of the categories
you see on the left side of the screen (check out Figure 2-1 to see the cate-
gories) to specify additional site-related information.

Click to perform site-related operations
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Creating a New Document

Figure 2-3:
You can
create many
different
types of
Web
documents
by using the
New
Document
dialog box.

Creating a new document means creating a new Web page or dependent

file to save in your site folder. (Dreamweaver refers to Web pages and other
separate files, such as scripts you include in your Web pages, as documents.)
To create a new document:

1. Choose FilecoNew from the main menu.

The New Document dialog box, as shown in Figure 2-3, appears.

New Document
General | Templates
Category: Basic page: Preview:
PBasicpage 0 4 HIML
Dryniamic page @ HTMLtemplate
Template page @ Library item
Cther 4 ActionScript
255 Style Sheets @ G35
Framesats @ JavaScript <Mao previews
Page Desiors {C55) @ XML

Page Desigre
Page Designs (Accessible)

Diezcription:
[HTML document

[ Make document ¥HTML compliant

l Help | lPrchrentcs... Gek mare contenk,,.

2. Select the type of document you want to create.

To create an HTML page, select Basic Page from the Category list and
HTML from the Basic Page list.

3. Click the Create button.

A new, untitled HTML document appears in the Document window.

Adding Content to a Document

After you start Dreamweaver, create a new site, and create a new document,
you're ready to add content (such as text, links, or images) to that docu-
ment, as shown in Figure 2-4.
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Figure 2-4:
Inserting
images
and defining
linksin a
Dream-
weaver
document
is point-
and-click
easy.

A\

Click the Preview button to test your work
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Insert link (and other) info using the Properties inspector

Book IV, Chapters 2 through 7, show you how to add many different kinds of
cool content (including tables, frames, and animations) to your pages.

To add content, follow these steps:

1. Switch to the untitled document.

To switch in Windows, click the Untitled Document tab in the Document
window. On a Macintosh, click the Untitled Document window.

2. Add content and color to your page by doing as many (or as few) of
the following procedures as you want:

¢ Choose a background color: Choose Modify->Page Properties from
the main menu. Click the Appearance category and then select a
color from the Background color swatch palette. Click OK.

¢ Specify a title: Enter a title for your page in the Title text box at the
top of the Document window. This title appears in the title bar of the

browser window when your page is loaded.
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e Enter text: Click your cursor in the Document window and enter
something compelling, riveting, or insightful. Include the sentence “I
just bought this great book from John Wiley & Sons, Inc.”

¢ Create a link: Select the text “John Wiley & Sons, Inc.” A Text
Properties inspector appears at the bottom of the screen. (If it
doesn’t, choose Windowr>Properties from the main menu.) In the
Link text box, type http://www.wiley.com.

¢ Add an image: Click the Images button you find in the Insert
Common panel and then select Image from the drop-down list
that appears. Browse to find a GIF or JPEG image on your computer
and click OK. (If the Insert Common panel isn’t visible, choose
Window=>Insert from the main menu to display the Insert bar and
then select Common from the Insert bar’s drop-down box.)

Saving a Document

After opening a new document or editing an existing document, you must
save your work. A document must be saved in your site folder before you
can transfer it from your computer to a host computer for display on the
Web. To save an open document, follow these steps:

1. Choose File>Save from the main menu.

2. At the Save As dialog box, browse to your site folder in the Save In
drop-down list.
This folder may already be selected.

3. In the File Name area, enter a name for your document followed by
the extension .html.

4. Click Save.

\\3
To save a site, you simply save each document contained in the site. Also

save all dependent files, such as images, that you use in your documents.

Previewing a Document in a Web Browser

After you create or modify a document, preview it in a Web browser to see
how it appears after you publish it. (For the steps on publishing your docu-
ment, check out Book IV, Chapter 8.)

Book IV
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To preview a document:

1. Click the Preview in Browser button in the Document window.

Alternatively, you can choose File>Preview in Browser from the main
menu.

A list of installed browsers appears.

2. From the list that appears, select the browser in which you want to
preview the page.

Dreamweaver launches the selected browser preloaded with your page.

3. If you go online, you can click any links you may have inserted to
ensure that they open the appropriate Web site; click the Back button
in your browser to return to your page.

P If the browser installed on your machine doesn’t appear in the Preview in
Browser list, choose Filew>Preview in Browser=Edit Browser List to display
the Preferences dialog box. Then click the + you see next to Browsers and
type the name and fully qualified name of a browser-executable file in the
Name and Application fields, respectively. Check either Primary Browser
(if you want Dreamweaver to open the browser by default) or Secondary
Browser (if the browser is just one of many browsers you want Dreamweaver
to work with). When you finish, click OK to add the specified browser to the
Preview in Browser list.



Chapter 3: Creating
Basic Web Pages

In This Chapter

v Adapting the Document window to your personal preferences
+~ Changing page properties

v~ Adding text and line breaks

v Working with images

v Using links and anchors

+ Working with tables

Fle most significant (and, fortunately, the easiest) process in building a
Web site is creating the individual pages that convey the site’s content.
Even if you plan to create an ultrahip site chock-full of animation and inter-
active forms, the vast majority of your site-building efforts are spent con-
structing basic Web pages composed of words and images. This chapter
shows you how to set up, color, and name individual Web pages. You also
discover how to add basic elements, such as text, graphics, and tables, to
your pages.

Customizing What Vou See in the Document Window

\\3

Dreamweaver offers you complete control over how you work in the
Document window by providing two guide tools — rulers and a grid — to
help you accurately lay out your work. You can customize a variety of guide
tool attributes, such as ruler increments and grid snapping, to suit your per-
sonal preferences and speed Web page development.

You can customize almost all aspects of the Dreamweaver environment by
specifying default settings in the Preferences dialog box. To open the
Preferences dialog box, choose Edit>Preferences from the main menu.

Turning rulers on and off

Using rulers in the Document window can help you measure and numeri-
cally position page elements. Toggle the Ruler on and off by choosing View>
Rulerse>Show from the main menu.
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Adjusting page size

When you design Web pages, you must con-
sider how your target audiences will view them.
People looking at your page may view it at any
number of screen resolutions from 640 x 480
(the standard factory-set resolution for many
computers) all the way up to 1024 x 768. Your
audience may even view your pages using
WebTV or a handheld appliance. Because
pages appear differently at different resolu-
tions, Dreamweaver offers you the ability

the workspace appears in your Document
window.

To size your pages, click the Window Size
Indicator in the middle of the Status bar (which,
in turn, is located along the bottom of the Docu-
ment window) and select a standard size — for
example, 640 x 480 — from the pop-up menu.
(Choosing the Edit Sizes option from the pop-up
menu allows you to specify any height and

to build your pages for a variety of monitor res- il izl ey )

olutions. The higher the resolution, the larger

Moving and resetting the origin

By default, the origin, or (0,0) coordinate, of a Dreamweaver ruler is set to
the upper-left corner of the Document window. Reposition it to any coordi-
nate in the Document window by clicking the origin cross hairs and drag-
ging them to new coordinates. Reset the origin to its default position by
choosing Viewr>Rulersr>Reset Origin from the main menu.

Changing ruler measurement units

You can change the ruler’s measuring increment by choosing Viewr>Rulers
from the main menu and then choosing Pixels, Inches, or Centimeters from
the pop-up menu.

Viewing the grid

Dreamweaver provides a Document window grid that can assist you in visu-
ally positioning and aligning page elements. You can toggle the grid on and
off by choosing View=>Grid=>Show Grid from the main menu.

Activating and deactivating grid snapping

The Document window grid offers a snapping feature that causes a page ele-
ment to automatically align precisely with the snap-to points you define. You
can toggle grid snapping on and off by choosing Viewr>Grid=>Snap to Grid
from the main menu.
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You can adjust how the grid appears in the Document window through the
Grid Settings dialog box. To do so, open the Grid Settings dialog box by
choosing View=>Grid=>Grid Settings from the main menu and changing any
(or all) of the attributes that appear. When you finish, click Apply to view
the effect of your changes. Click OK to accept the changes and close the
dialog box.

Establishing Page Properties

Figure 3-1:
Use the
Page
Properties
dialog box
to specify
settings that
affect your
entire
document,
such as
background
and font
size.

The Page Properties dialog box provides you with control over several key
page properties, grouped into five categories:

4 Appearance

4 Links

4 Headings

4+ Title/Encoding

4 Tracing Image
The kinds of page properties you can set by using the Page Properties
dialog box include the title of the page, page background color, link colors,

page margins, and much more. Selections apply only to the current page,
not the entire site.

Open a Page Properties dialog box similar to the one you see in Figure 3-1 by
choosing Modify=>Page Properties from the main menu or by clicking the
Page Properties button that appears in the Properties inspector.

Page Properties =

Categaory
|Appearance FeT— = =

m& Page fonk: | Asial, Helvetica, sans-seri || B I
|Headings e —

| ThlefEncoding Sze: | 12 + | | pixels :]

| Tracng Image
Text color: || #o00000

Appearance

Backqround colar: [ || #E0DFE3

Background imane: | |
Left margin: Right margin:
Top margin: Boktom mangn;
Loc J[ comet J( ooy J[ teo ]
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If you're working with a document containing frames, not all five categories
may appear in the Page Properties dialog box.

As you see in Figure 3-1, the Appearance properties appear by default. Click
the Links, Headings, Title/Encoding, or Tracing Image category to display
(and edit) additional properties related to your Web site’s appearance or to
trace an existing image onto a Web page.

Using the Page Properties dialog box, you can make changes to any of the
following:

4 Appearance: Click the Appearance tab in the Page Properties dialog box
(shown in Figure 3-1) to change font size and color, specify a back-
ground color and image, and define margins.

Page Font: Click the drop-down box to select a page font. Clicking
the Bold or Italics icon that appears to the right of the drop-down
font menu applies bold or italics formatting, respectively, to the
selected font.

Size: Click the Size drop-down box to select a font size; then click the
drop-down box you find next to Size to specify a measurement, such
as pixels or centimeters (cm).

Text Color: You can either click the color chart to select a text color
by pointing and clicking, or you can specify a hexadecimal RGB
value in the text field you find next to the color chart.

Background Color: You can either click the color chart to select a
background color by pointing and clicking, or you can specify an
RGB value in the text field you find next to the color chart.

Background Image: Click Browse (Windows) or Choose (Macintosh)
to locate the image file that you want to appear as the Document
window background. If the image is smaller than the available back-
ground area, it tiles (repeats in checkerboard fashion, like floor tiles)
to fill the background.

Left Margin, Top Margin, Right Margin, Bottom Margin: These

Property boxes set up margins that affect how your page appears in
Microsoft Internet Explorer. Enter a whole number for the number of
pixels of space you want on the left and top sides of your document.

4+ Links: Click the Links category in the Page Properties dialog box
(shown in Figure 3-2) to define the way your links appear.

Link Font: Click the drop-down box to select a link font. Clicking the
Bold or Italics icon that appears to the right of the drop-down font
menu applies bold or italics formatting, respectively, to the selected
font.
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e Size: Click the Size drop-down box to select a font size for the link;

then click the drop-down box you find next to Size to specify a meas-
urement, such as pixels or inches (in).

Link Color, Visited Links, Rollover Links, and Active Links: Click
the color chart next to each property and select a color from the
color palette that appears. Alternatively, you may enter a hexadeci-
mal RGB color code directly into any Color Code box.

Underline Style: Click the drop-down box to select an underline
style (such as Always Underline or Never Underline) from the style
menu that appears.

Figure 3-2:
Use the
Links
category of
the Page
Properties
dialog box
to customize
the way
links appear
in your
pages.

| Tracing Image

Page Properties =
I:H&s
Lirk Fonk: .@:a}weaspagsi’;nij" 'L| B I
| TlejEncoding Seet[36 (v -p;e.i.s_m:]
Link color: W8] #290000  mtoverinks: [ |
Visited links: )| #3300FF activefnks: [
Underling style: | Abways underine I"

ok J[ comel J[ oot J[ oo |

4+ Headings: Click the Headings category in the Page Properties dialog
box (shown in Figure 3-3) to define the way headings appear in your
Web pages.

¢ Heading Font: Click the drop-down box to select a font for your

headings. Clicking the Bold or Italics icon that appears to the right of
the drop-down font menu applies bold or italics formatting, respec-
tively, to the selected font.

Heading 1-6: For each individual heading level, from 1 to 6, you can
select a different size and color. Click the Size drop-down box to
select a font size for the heading; then click the drop-down box you
find next to Size to specify a measurement, such as pixels or inches
(in). To specify a color, you can either click the color chart or spec-
ify a hexadecimal RGB value.

4+ Title/Encoding: Click the Title/Encoding category in the Page
Properties dialog box to specify a title for your Web page and to select a
language for character encoding.
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e Title: Enter a page title in the box. This title appears in the Title Bar
area of the window both during construction in Dreamweaver and
when the page is viewed through a Web browser.

¢ Encoding: From the drop-down list, select a language for character
encoding of text on your page. For example, if you want to create
Web pages capable of displaying text in Korean, you can choose
Korean (EUC-KR); if you want to display text in English, choose
Western (Latinl). Click Reload to display the page with the changed

encoding.
“Page Properties =
Figure 3-3: S o
Use the ﬁf:"'a"“’ Heading Fant: | Arial, Helvetica, sans-serf v B 1
Headings !ngzding Hesdimgi:| (v oia W #oosees
category of |Tracng Image :
the Page Heading 2: vl )| #eoores
i Heading 3: ~| =
Properties
dialog box reaina ] o
to customize Hesdnas :E] |:_.|
the way teeat |l .
headings
appearin
your pages. o oo J Cooomr ) [rew)
4+ Tracing Image: Click the Tracing Image category in the Page Properties
dialog box to specify a helpful tracing image.
¢ Tracing Image: Click Browse (Windows) or Choose (Macintosh) to
locate the image file you want to use as a guide for laying out your
Web page in the Document window. This feature is handy for devel-
opers who prefer to “mock up” a portion of their Web page design in
a graphics program and then re-create that design in their Web
pages. Tracing images appear only in Dreamweaver, as a pattern to
help guide you in creating a Web page design; tracing images never
appear on the finished Web page.
¢ Image Transparency: Drag the slider to adjust the visibility level of
the tracing image. At 0 percent, the tracing image is invisible; at 100
percent, the image is opaque.
Click Apply to view the effect of any property you change. Click OK to
accept your changes and close the Page Properties dialog box.
\\J

Even if you choose to use a background image, select a complementary back-
ground color — the color shows while the background image is downloading.
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Entering Text

Figure 3-4:
The Insert
HTML panel
allows you
to add line
breaks (and
much more)
to your
documents
with point-
and-click
ease.

You can enter and manipulate text on a Web page in Dreamweaver by using
similar procedures to those you use when working with a word-processing
document.

Inserting text

To enter text on a page, click your mouse in the Document window and
begin typing. Your mouse pointer appears as a blinking cursor that moves
along with the text you enter. When you reach the end of a line, the text
automatically wraps to the next line. Dreamweaver automatically adds the
associated code for your new text to the HTML for the page.

Inserting a line break

When you want to start a new line in a word-processing program, you hit the
Return key. In Dreamweaver, you create a line break by pressing Shift+Return
or by choosing Insert> HTML=>Special Characterst>Line Break from the
main menu. Alternatively, you may click the Characters button you find on
the Insert HTML panel. Dreamweaver places the cursor at the start of the
next line and creates the line break HTML code for the page.

If you want to view the Insert HTML panel, as shown in Figure 3-4, choose
Window=Insert->HTML.

Head button

Insert HTML panel Script button

o I
\\—HTML - = - talbl - hm v ST

Horizontal Rule button
Tables button

Deleting text and line breaks

To delete text and line breaks from a page, select in the Document window
the item that you want to delete and press Backspace or Delete on your
keyboard.
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Modifying text
You can modify how text appears on a page by editing its font, size, color,
alignment, and other attributes.

To modify text in the Document window, drag your mouse to select the text
you want to modify. The Text Properties inspector appears, as you see in
Figure 3-5. (If the Properties inspector doesn’t show up, choose Windowr>
Properties from the main menu to open it.) On the Text Properties inspec-
tor, modify any of the following properties:

+

<+

Format: From the first drop-down list, select a default text style. These
styles are relative, not absolute. Heading 1 is the largest style and
Heading 6 is the smallest, but none of the headings correlates with a
specific pixel size.

Font: Select a font face from the drop-down list. Choosing Edit Font List
from the font drop-down list allows you to add to the font face drop-
down list any other fonts you may have installed on your computer.

Style: Select a style sheet from the drop-down list (None is the default).
You can create, edit, rename, or attach an existing style sheet to any
portion of text by clicking the New, Edit, Rename, and Attach Style Sheet
options, which appear at the bottom of the drop-down list.

Size: Select a font size from the drop-down list. The options include spe-
cific font sizes (from 9 through 36), as well as descriptions ranging from
xx-small (xx-small corresponds to 1 in previous versions of
Dreamweaver) to xx-large (xx-large corresponds to 7 in previous ver-
sions of Dreamweaver). Choosing the Smaller font size setting displays
text one font size smaller than the previously specified font size.
Alternatively, choosing the Larger setting displays text one font size
larger than the previously specified font size.

Color: Click the color box you find next to the Size drop-down box and
select a text color from the Web-safe color palette that appears.
Alternatively, you may enter a hexadecimal color code directly in any
color code box. (To set the default text color for a page, check out the
section “Establishing Page Properties,” earlier in this chapter.)

Bold or Italic: Click the Bold button to bold your selected text. Click the
[talic button to italicize your selected text. You can click either button
or both.

Alignment: Click an alignment button to align your text. Choices are
Left, Center, Right, and Justify.

Link: Type a URL in this field to transform text into a hypertext link.

Target: From the drop-down list, choose one of the following: _blank
(opens link in a new window), _parent (opens link in the parent of the
currently opened window), _self (opens link in the opened window),
and _top (opens link in the top-level window, replacing frames, if any).



Figure 3-5:
You can
change the
format,
color, and
alignment of
any text on
your page
using the
Text
Properties
inspector.
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Manipulating Images
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4+ List: Click the Unordered List icon next to the Target field to transform
text into an unordered (bulleted) list; click the Ordered List icon to
transform text into an ordered (numbered) list.

4+ Placement: Click the Text Outdent icon you find next to the Ordered
List icon to outdent selected text; click the Text Indent icon to indent
selected text.

4+ List Item: Click this button (which becomes active after you select a bul-
leted or numbered list item) to edit list properties (such as the auto-
matic starting number of a numbered list).

Manipulating Images

\\3

Next to entering text, manipulating images on a Web page is probably the
most common Dreamweaver function you perform. You can add or delete an
image and modify its properties to create an aesthetically pleasing layout
that effectively conveys the information you want to deliver to the user.

To see how to place an image on the background of your page, check out the
section, “Establishing Page Properties,” earlier in this chapter.
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296 Manipulating Images

Inserting an image

To insert an image on a page, follow these steps:

1. Choose Insert>Image from the main menu.

Alternatively, you can click the Insert Image button from the Insert
Common panel. (If the panel doesn’t appear, display it by choosing
Window=Insert and then selecting the Common tab.)

2. In the Select Image Source dialog box (shown in Figure 3-6), click the
image you want to insert.

If the image is outside the current folder, click the arrow tab beside the
Look In box and browse to select the file you want.

Select Image Source 2]
Select file name ftom:  (5) File system
() Data sourcas
Lok in: | £ myfrstSiee :‘ 3 o - Image preview

—_— | &bt s
%] mythig. gif
Figure 3-6: ) tumnel_black.jog e Ty
You can use
the Select
Image -
Source File niame: | banner pg 688 91 JPEG. 10K / 2 sec
dia |0g box Files of typec | Image Files [*.af"jpa;" jpea”. pg] il Cancel
to insert the = = 5
. f URL: file: /¢ ATl Ay FirstSite/banres. pg
Image o . Relative to: | Document | v | Unitleg:2
your ChOICE. Document should be saved to use this option [] Preview images

3. Click the OK button to insert the image.

Note: Every image you want to include on a Web page must reside
within the folder of the current site. If you attempt to insert an image
from another location, Dreamweaver asks whether you want to copy the
image to the current site root. Click Yes. In the Copy File As dialog box,
you can enter a new name for the image in the File Name box or accept
the current name and click Save.

Put a check in the Preview Images check box at the bottom of the Select
Image Source dialog box, as shown in Figure 3-6, to view a thumbnail image
before you select it for insertion. The preview area also tells you the size of
the image and the expected download time.

\\J
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Deleting an image
To delete an image from a page, click the image in the Document window
and press the Delete key on your keyboard.

Modifying an image
You can modify how an image appears on a page by editing its size and
alignment, adding a border, and changing other attributes.

To modify an image, click the image in the Document window to select it. If
the Image Properties inspector doesn’t appear, choose Window=>Properties
from the main menu to open it.

To see all the options the Image Properties inspector offers, click the
expand/contract arrow in the lower-right corner of the Image Properties
inspector. (Clicking the arrow a second time displays fewer options.)
Alternatively, you can double-click anywhere on the inspector to display
more or fewer options.

As shown in Figure 3-7, you can modify any of the following properties:

4 Name the image: On the Image Properties inspector, enter a name in the
box next to the thumbnail image. (Naming an image is important if you
want to refer to that image using a scripting language, such as
JavaScript. You can find out more about JavaScript in Book VI.)

4 Resize the image: Click and drag a sizing handle to change the dimen-
sions of the image. To resize the image and maintain the same propor-
tions, hold down the Shift key as you drag a sizing handle. Alternatively,
you can change the numbers (representing pixels) you see in the W
(width) and H (height) fields to change the image’s size.

4 Change the image file: On the Image Properties inspector, enter a
different filename in the Src box (or click the file icon to browse for
image files).

4 Make the image a link: On the Image Properties inspector, enter a URL
in the Link box. If you like, you can specify a target for the link by select-
ing an option from the Target drop-down list.

4+ Specify alternative text for the image: On the Image Properties inspec-
tor, enter alternative text in the Alt box. (Specifying alternative text
ensures that when viewers’ browsers don’t — or can’t — display the
image, some meaningful text appears instead.)

4+ Edit the image: On the Image Properties inspector, click the buttons
you see next to Edit (check out Figure 3-7) to perform the following
functions:
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e Edit: Click the Edit button to edit the image by using an external
image-editing program.
P Dreamweaver doesn’t enable you to edit images directly. Instead,

clicking the Edit button opens the image-editing program that’s
installed on your computer. To specify a new image-editing program,
choose Edite>Edit with External Editor. In the Preferences dialog box
that appears, choose File Types/Editors from the Category menu.
Choose an image extension (.gif, . jpg, or .png) from the Extensions
menu. Then choose a program from the Editors menu and click the
Make Primary button. You can add a new editor by clicking the add
(+) button. Click OK to apply your changes and close the dialog box.

Optimize with Fireworks: Click this button to reduce the image size
using Fireworks, an image-editing program from Macromedia. You
must have Fireworks installed on your machine to use this feature.

Crop: To crop a selected image, click this button; then move and
drag the dashed handles that appear over the image to specify
which section of the image you want to crop. When you finish, click
the Crop button again to crop the image to the specified dimensions.
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¢ Brightness and contrast: Clicking this button allows you to adjust
both the brightness and contrast of the image.

Create a hot spot: A hot spot is a portion of an image that responds to a
user’s mouse click. To create a hot spot, click one of the hot spot tools
(Rectangular, Oval, or Polygon). To create a hot spot on the image, click
and drag the cross hair cursor that appears. In the Hotspot Properties
inspector that appears, specify a link and a target.

Clicking the Pointer Hotspot Tool returns the cross hair pointer to a
normal pointer, allowing you to move the hot spot around on the image.

Pad an image with spaces: In the Image Properties inspector, enter a
number in pixels in the V Space (V for vertical) box for the space you
want to appear at the top and bottom of the image; then enter a number
in pixels in the H Space (H for horizontal) box for the space you want to
appear on either side of the image.

Specify a “low source” image. Some Web designers like to specify a
quick-loading, black-and-white “low source” version of each large image
they work with. Doing so gives users a taste of what’s to come while
they wait for the real (large) image to download. To specify a low source
image in the Image Properties inspector, enter in the Low Src box the
fully qualified name of an image file.

Add a border to the image: On the Image Properties inspector, enter a
number in the Border box to add a border of that thickness to the
image. Border thickness is measured in pixels.

Align the image: On the Image Properties inspector, click an Alignment
button to position the image on the page (or within a cell if the image is
located in a table cell). Alignment button choices consist of Left, Center,
and Right. To align an image with special word wrapping, select the
image and choose one of the alignment options from the Align drop-
down list, as shown in Table 3-1.

Table 3-1

Aligning an Image in Relation to Text

Alignment Option

Effect on Image and Text Wrapping

Browser Default

Same as Bottom alignment

Baseline Same as Bottom alignment

Top Aligns the image top with the highest other inline element
Middle Aligns the image middle with the text baseline

Bottom Aligns the image bottom with the text baseline

Text Top Aligns the image top with the text top

Absolute Middle Aligns the image middle with the text middle

Absolute Bottom

Aligns the image bottom with the bottom of the text descenders

Left

Aligns the image flush left

Right

Aligns the image flush right
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Dreamweaver doesn’t offer image-editing functions, such as recoloring or
adding drop shadows; you have to use a separate program, such as
Macromedia Fireworks or Adobe Photoshop, to accomplish these tasks.

Working with Links

A\

Linking your page to other Web pages enables you to direct visitors to
related content on the Web. To insert a link, you must specify an image or
some text to serve as the link; you must also specify the link location to
which you want to send your visitors. The link can go to a page within your
site or to a page elsewhere on the Web.

Inserting a link

To insert a link on a page, follow these steps:

1. Select the text or image you want to make a link.

Doing so opens the Properties inspector for your text or image. If the
Properties inspector doesn’t appear, choose Window=>Properties from
the main menu to open it.

2. In the Link area of the Properties inspector, enter the target of the
link (text or image) you created in Step 1.

The URL you specify can be any valid URL — for example, a Web page
on your computer (somePage.html), on the Web (www.someSite.com/
somePage.html), or even an e-mail address (mailto:somebody@
somewhere.com).

Alternatively, you may click the File Folder icon you see in the
Properties inspector to display the Select File dialog box.

3. Using the Select File dialog box, browse your computer to find a file.
Then click Select to make that file the target of a link.

To create an e-mail link quickly, click anywhere in your document and
choose Insert>Email Link from the main menu. Specifying the same value
for the Text and E-mail fields that appear allows folks who haven’t config-
ured their Web browsers to handle e-mail automatically to see the e-mail
address on the page. Then, they can cut and paste the e-mail address infor-
mation into their e-mail program of choice.

Deleting a link

To delete a link from a page, follow these steps:
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1. Select the text or image you want to remove the link from.

The Properties inspector for your text or image opens. If the Properties
inspector doesn’t appear, choose Window=>Properties from the main
menu to open it.

2. In the Properties inspector, delete the name of the link from the
Link box.

Using named anchors

When you want to create a navigational link that connects users to not only
a page but also a specific location on the page, you need to create a named
anchor. Named anchors are frequently used for jumping to exact positions
within a large block of text so that users don’t have to scroll through sen-
tence after sentence to find the information they need. Setting up named
anchors is especially useful when creating links from a directory or a table
of contents to the content it presents.

Inserting a named anchor
Place an anchor anywhere on your Web page:

1. In the Document window, click your mouse cursor at the position you
want to insert the named anchor.

2. Click the Named Anchor button on the Insert Common bar or choose
Insert->Named Anchor from the main menu.

If the Insert Common bar doesn’t appear, open it by choosing
Window=>Insert>Common.

The Insert Named Anchor dialog box appears.
3. Type a name in the Anchor Name box.
4. Click OK.

You should insert the named anchor tag slightly above the actual position
where you want the link to target. Doing so gives your targeted content a
little padding on top. Otherwise, the top of your image or your first line of
text appears flush with the top of the browser window.

Linking to a named anchor

To link to a named anchor, follow the procedure outlined in the section
“Inserting a Link,” earlier in this chapter, with the following modifications:

4+ Linking to a named anchor on the current page: In the Link box of the
Properties inspector, type a pound sign (#) followed by the anchor
name.
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4+ Linking to a named anchor on a different page: In the Link box of the
Properties inspector, type the HTML page name followed by a pound

sign and then the anchor name.
&\\NG!
s As of this writing, the latest version of Netscape Navigator (Version 6.0) sup-
ports linking to named anchors on the current page — not on other pages.

Working with Tables

Adding a table to a Web page can help you lay out page elements more
easily in the Document window. Tables consist of as many holding areas, or
cells, if you like, and you can place virtually any Web element — such as text
or an image — into a cell. Cells are organized horizontally into rows and ver-
tically into columns. Dreamweaver provides you with complete control over
the size, position, color, and other attributes of your table. And you can edit
these attributes at any time via the Table Properties inspector.

Inserting a table

To add a table, choose Insert>Table from the main menu to open the Insert
Table dialog box, shown in Figure 3-8. Alternatively, you may click the Insert
Table button from the Insert Common panel. (If the panel doesn’t appear,
open it by choosing Window=Insert=>Common.) Enter the following infor-
mation in the Insert Table dialog box:

4 Rows: Enter a number in the box for the number of rows in the table.

4 Columns: Enter a number in the box for the number of columns in the
table.

4 Table width: Select Percent from the drop-down list and then enter a
number (0-100) in the box for the percentage of page width you want
the entire table to occupy. Or select Pixels from the drop-down list and
enter a number of pixels for the width of the entire table.

4 Border thickness: Enter a number in the box for the width of the table
borders in pixels. Entering 0 causes the borders to disappear.

4 Cell padding: Enter a number in the box to specify how many pixels of
padding you want between the inside edge of a cell and its contents.

4 Cell spacing: Enter a number in the box to specify how many pixels of
separation you want between cells.

4+ Header: Click to enable row headings (Left), column headings (Top),
both row and column headings (Both), or no headings (None).

4 Caption: Enter text for a table caption.



Figure 3-8:
Use the
Insert Table
dialog box
to specify
which kind
of table you
want to add
to your
document.
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Table

Table size

Rows: 6 Columns: | 3

Table vidth: 200 -ma,; v
Border thickness: 0 pizels

Cell padding: S

Cell spacing: [EE}

Header

Accessility
Captiors:
Align caption: i:op |
Summary:
s

4+ Align caption: Select from the drop-down box to choose how you want
your table caption aligned with respect to your table: top, bottom, left,
right, or default (top).

4+ Summary: Enter text for an optional table summary. (Some devices,
such as screen readers designed to help visually impaired folks surf the
Web, don’t display HTML tables; instead, they read and interpret sum-
mary information.)

Deleting a table

To delete a table from a page, click the border of the table to select it and
then press the Backspace or Delete key. Dreamweaver removes the table
from your page and deletes the associated code in the HTML for the page.

Storing Information in Table Cells

After you insert a table on a page, you can add or delete elements, such as
text and images, in the table cells.

Adding an image to a cell

To add an image to a table cell, click to position the cursor in a table cell and
choose Insertr>Image from the main menu. Browse and select an image you
want to add to the cell and then click OK. (For more information on inserting
images, flip to the section “Inserting an image,” earlier in this chapter.)
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Adding text to a cell

To add text to a table cell, click to position the cursor in a table cell and
type the text you want placed inside the cell.

Deleting an image from a cell

To delete an image from a table cell, select the image and press Backspace
or Delete.

Deleting text from a cell

To delete text from a table cell, select the text and press Backspace or
Delete.



Chapter 4: Incorporating
Interactive Images

In This Chapter

v+ Adding a link to an image

v Working with hot spots

v Adding color with Flash text

v Changing appearances with button rollovers (Flash buttons)
v+ Adding graphic rollovers

v Creating a navigation bar

Images are great — but if you really want to add pizzazz to your Web site,
consider adding interactive images to your pages. Interactive images are
more than just pretty pictures: They change their appearance when users
mouse over them. The most popular types of interactive images, called
rollovers and hot spots, serve as navigation buttons that enable users to
move through the site.

Creating a Link from an Image

You can make an image interactive by simply making it a link. Clicking an
image that’s set up as a link causes the user to jump somewhere else in the
site or on the Web. To create a link from an image, follow these steps:

1. Select the image in the Document window.

The Image Properties inspector appears. (If the inspector doesn’t
appear, open it by choosing Window=>Properties from the main menu.)

2. In the Image Properties inspector, click the Link folder to open the
Select File dialog box.

3. Browse to select the page you want to link to.

If the link is outside the current folder, click the arrow tab beside the
Look In box and browse to select the file you want. Alternatively, you
can enter a Web address in the URL box at the bottom of the Select File
dialog box.
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4. Click OK.

The dialog box closes, and the link is activated.

Creating Clickable Hot Spots

Figure 4-1:
You can
create hot
spots
anywhere
on your
image using
the circle,
rectangle,
and polygon
drawing
tools.

You can designate certain areas of an image as hot spots — active areas that
a user can click to open a link to another Web page or activate some other
behavior. Hot spots can be shaped like rectangles, circles, or polygons
(irregular objects).

Creating a hot spot

Use the following procedure to create a hot spot:

1. Select the image to which you want to add a hot spot.

The Image Properties inspector you see in Figure 4-1 appears. If the

inspector doesn’t appear, open it by choosing Window=>Properties from
the main menu.

If the bottom half of the Image Properties inspector isn’t visible, click

the expand/contract button (the arrow you see in the lower-right corner
of Figure 4-1).
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2. In the Map area of the Image Properties inspector, click a Hotspot
button for the shape you want to draw.

You can choose from among a rectangle, circle, or polygon. Your mouse
pointer becomes a cross hair cursor when you move it over the image.

3. Draw the hot spot according to the shape you select.

¢ Circle or rectangle: Click your cross hair cursor on the image and
drag to create a hot spot. Release the mouse button when your hot
spot reaches your desired dimensions. The area you draw is high-
lighted light blue, and the Hotspot Properties inspector appears.

e Polygon: Click your cross hair cursor on the image once for each
point. Click the Arrow tool in the Image Properties inspector, if nec-
essary, to close the shape. The area you draw is highlighted light
blue, and the Hotspot Properties inspector appears.

4. In the Hotspot Properties inspector, supply the following information:
e Map: Enter a unique name for the hot spot.

e Link: Enter a URL or the name of an HTML file you want to open
when the user clicks the hot spot. Alternatively, you can click the
folder and browse to select the link from your files.

Completing this box is optional. Instead, you may choose to attach a
different kind of behavior to the hot spot.

To attach a behavior other than link to the hot spot, open the
Behaviors panel by choosing Window=>Behaviors from the main
menu. Then click the add (+) button in the Behaviors panel, which
opens a pop-up menu of available behaviors, including Check Plug-
in, Play Sound, Popup Message, Preload Images, and many others.
Choose a behavior from the pop-up menu, complete the information
in the dialog box that appears for your selected behavior, and

click OK.

e Target: Complete this box if you entered a link in the Link box. Click
the tab and select from the drop-down list a target window where
your selected link will appear. You can select from the following
choices: _blank (opens link in a new window), _parent (opens link in
the parent of the opened window), _self (opens link in the opened
window), and _top (opens link in the top-level window, replacing
frames, if any). If you have created frames, you can also select a
frame name from this list. (See Book IV, Chapter 6, for more informa-
tion about frames.)

e Alt: Enter the text you want to appear when the user moves the
mouse pointer over the hot spot.
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Modifying a hot spot

Use the following procedure to edit a hot spot:

1.

On an image in the Document window or table cell, click the hot spot
you want to modify.

The Hotspot Properties inspector appears. If the inspector doesn’t
appear, open it by choosing Window=>Properties from the main menu.

. Edit any information you want to change in the Hotspot Properties

inspector.

. Reshape any hot spot by clicking the Arrow tool in the Hotspot

Properties inspector and dragging your mouse.

. Delete a hot spot by clicking it and pressing the Delete key on your

keyboard.

Adding Text Rollovers (Flash Text)

A text rollover is text that changes colors when a user moves the mouse
pointer over it. (One color appears to “roll over” to the next color.) One way
to create text rollovers in Dreamweaver is by adding Flash text to your pages.

Flash text (and Flash buttons) are so called because Dreamweaver imple-
ments these features using the same code that Flash — an animation pro-
gram developed by Macromedia — uses.

Adding Flash text

To add Flash text, follow these steps:

1.

2.

Click in the Document window or table cell where you want to add
Flash text.

Click the Media button you find on the Insert Common panel and
then select Flash Text from the drop-down list that appears (or choose
Insert->Media~>Flash Text).

The Insert Flash Text dialog box, shown in Figure 4-2, appears.

If the Insert Common panel doesn’t appear, open it by choosing
Properties=>Insert from the main menu and then selecting Common
from the Insert bar drop-down list.

Alternatively, you can choose InsertroMediar>Flash Text from the main
menu.

. In the Insert Flash Text dialog box, select a text font from the Font

drop-down list.
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Figure 4-2: Named Anchor button Date button
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. Enter a point size for your text in the Size box.
5. If you want, format the text.

You can click the Bold button and/or Italics button. You can also click
an alignment button. Alignment choices are Left, Center, Right, and
Justify.

6. Select a color (initial color) and a rollover color (a color that
responds to mouse movement) by clicking the color swatch in each
area and selecting a color from the color palette that appears.

7. Enter your text in the Text box. Click to select the Show Font check
box if you want to view the Text box in your selected font.

8. In the Link box, enter a URL or the name of the page you want to
appear when the user clicks the Flash text.

Alternatively, you can click the Browse button to select a page from
your files.

9. In the Target area, click the tab and select from the drop-down list a
target window where the link will appear.

If you have created frames, you can select a frame name from this list,
or you can select from the following choices: _blank (opens link in a
new window), _parent (opens link in the parent of the currently opened
window), _self (opens link in the currently opened window), and _top
(opens link in the top-level window, replacing frames, if any).

10. Select a background color by clicking the Bg Color swatch and select-
ing a color from the color palette that appears.

Your Flash text appears over the background color you choose.

11. Enter a name for your Flash text component in the Save As box or
click the Browse button to select a name from your files.

Note: You must save Flash text with an .swf extension.

12. Click OK to create your Flash text and close the dialog box.
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Changing Flash text

You can change a Flash text object you already created by simply double-
clicking the object in the Document window. Doing so opens the Insert Flash
Text dialog box where you can change your text as [ describe in the section
“Adding Flash text,” a little earlier in this chapter. After you make changes to
the Flash text object, you must resave the object.

Playing (previewing) Flash text

To play Flash text, select the text in the Document window to open the Flash
Text Properties inspector. In the Properties inspector, click the Play button
to view your Flash text as it appears in the browser window. Click the Stop
button when you finish.

Adding Button Rollovers (Flash Buttons)

Buttons that change appearance when a user moves the mouse pointer over
them — called button rollovers — are so popular that Dreamweaver gives
you a way to create them quickly and easily.

Adding a Flash button

To add a Flash button, follow these steps:

1.

2.

Click in the Document window or table cell in which you want to add
a Flash Button.

Click the Media button you find on the Insert Common panel (refer to
Figure 4-2) and then select Flash Button from the drop-down list that
appears.

An Insert Flash Button dialog box, similar to the one shown in Figure 4-3,
appears.

If the Insert Common panel doesn’t appear, open it by choosing
Properties=Insert from the main menu and then selecting Common
from the Insert bar drop-down list.

Alternatively, you can choose Insert->Media=>Flash Button from the
main menu.

. In the Insert Flash Button dialog box, scroll through the button selec-

tions in the Style list and click to select a style.

You can preview the style in the Sample area of the dialog box — just
point to the sample with your mouse to see the Flash button play.

. If your selected button has a placeholder for text, enter in the Button

Text area the text that you want to appear on the button.



311

Adding Button Rollovers (Flash Buttons)

Insert Flash Button
Sangles
\Bulumaled)
Stvfe: |eCommerce-Add Il Get More Sbyes. .
o eCommerce-Cart
eCommerce-Cash
eCommerce-Checkout
eCommerce-Generic -
sCommerce-Remove 1)

Butbon bexk:

Chech out

Figure 4-3: < T Tl .

You can add L et

more than a Link: | selections.Heml Browse. .,

dozen Target: _:eIF :]

prebuilt Bgcolor; )| #00FF99

rollover Saveas: | cart_button,swf Erowsa,.,

(Flash)

buttons to

your pages.
5. Select a font for your Flash button text from the Font drop-down list.
6. Enter in the Size box a point size for your text.
7. In the Link box, enter a URL or the name for the page that you want

to appear when the user clicks the Flash button.

Alternatively, you can click the Browse button to select a page from
your files.

In the Target area, click the tab and select from the drop-down list a
target window where the URL will appear.

You can select from the following choices: _blank (opens link in a new
window), _parent (opens link in the parent of the currently opened
window), _self (opens link in the currently opened window), and _top
(opens link in the top-level window, replacing frames, if any). If you have
created frames, you can also select a frame name from this list.

Select a background color by clicking the Bg Color swatch and select-
ing a color from the color palette that appears.

Your Flash button appears on top of the background color you select.

Alternatively, you can enter a hexadecimal color code in the Bg Color box.

10. Enter a name for your Flash button in the Save As box or click the

Browse button to select a name from your files.

You must save the Flash button with an .swf extension.

11. Click OK to create your Flash button and then close the dialog box.
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Get new Flash buttons from the Macromedia Dreamweaver Web site by
clicking the Get More Styles button in the Insert Flash Button dialog box.

Changing a Flash button

To change a Flash button object you have already created, simply double-
click the object in the Document window. Doing so opens the Insert Flash
Button dialog box where you can change your button as I describe in the
section “Adding a Flash button,” earlier in this chapter. After you make
changes to the Flash button object, you must resave the object.

Modifying Flash button features

You can add additional features to a Flash button:

1. In the Document window, click to select the Flash button object you
want to enhance.

The Flash Text Properties inspector appears. If the inspector doesn’t
appear, open it by choosing Window=>Properties from the main menu.

2. At the Flash Button Properties inspector, modify any of the available
Flash button attributes.

For more information about Flash button attributes, check out the sec-
tion “Adding a Flash Button,” earlier in this chapter.

Playing (previewing) a Flash button

To see what a Flash button looks like in action, select the button in the
Document window to open the Flash Button Properties inspector. In the
Properties inspector, click the Play button to view your Flash button as it
appears in the browser window. Click the Stop button after you finish.

Inserting Image Rollovers

An image rollover (often just referred to as rollover) is an image that appears
to change whenever the user rolls the mouse pointer over it. Rollovers add
interactivity to a Web page by helping users know what parts of the page
link to other Web pages.

A rollover is actually two images — one for normal display on a page (the
original image) and one that is slightly modified for display when the image
is rolled over (the rollover image). You can modify an image by changing the
color or position, adding a glow or a shadow, or adding another graphic —
such as a dog changing from sleeping to wide awake.



Figure 4-4:
You can use
the Insert
Rollover
Image
dialog box
to insert an
image
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Insert a rollover by following these steps:
1. Click either inside the Document window or inside a table cell in
which you want to insert the rollover.
2. Choose Insert->Image Objects->Rollover Image from the main menu.

The Insert Rollover Image dialog box, as shown in Figure 4-4, appears.

Insert Rollover Image %]
Image name: | MyRollover III
Original image: | normal.gif

Freload rollover image
Alternate text: | Click to purchase

Rolover imags: | rolover gf

wihen clicked, Gobo URL: | hktp: ] emilyv, com|

3. In the Insert Rollover Image dialog box, enter a name for the rollover
in the Image Name box.

The rollover is referred to by this name in the HTML page code. Keep in
mind that this rollover name refers to the combined original
image/rollover image pair.

4. Enter the name of the original image file in the Original Image box or
click the Browse button to select an image from your files.

The original image appears on the page when the user’s mouse pointer
is not over the rollover.

5. Enter the name of the Rollover Image file in the Rollover Image box
or click the Browse button to select an image from your files.

The rollover image appears on the page when the user’s mouse pointer
is over the rollover.

6. Check the Preload Rollover Image check box.

This feature makes the rollover action appear without delay to users as
they move the mouse pointer over the original image.

7. In the When Clicked, Go to URL text box, enter a URL or the name of
the page you want to appear when the user clicks the rollover.

Alternatively, you can click the Browse button to select a page from
your files.

8. Click OK to accept your choices and close the dialog box.
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To check the rollover, preview your page in a browser by choosing Filew>
Preview in Browser from the main menu or by clicking the Preview/Debug in
Browser button that appears on the Document toolbar and using your
mouse to point to the original image.

As with all images, you can’t create the original image or the rollover image
directly in Dreamweaver; you must use an image-editing program, such as
Macromedia Fireworks.

Setting Up a Navigation Bar

A navigation bar is a group of buttons that users can access to move
throughout your Web site. Buttons within a navigation bar may present
users with options, such as moving backward, moving forward, returning to
the home page, or jumping to specific pages within the site.

Each button in a navigation bar possesses properties similar to a rollover in
that the button changes state — or appears differently — based on where
the user is positioning the mouse pointer. However, a navigation bar button
can possess as many as four different states:

4+ Up: The original state of the button.

4+ Over: How the button appears when a user hovers the mouse pointer
over it.

4 Down: How the button appears when a user clicks it.
4+ Over While Down: How the button appears when the user moves the
mouse pointer over it after clicking it.

A navigation bar differs from individual rollovers in that clicking a naviga-
tion bar button in the Down state causes all other buttons in the bar to
revert to the Up state.

Creating a new navigation bar

To create a navigation bar, follow these steps:
1. Select the Image button from the Insert Common panel and select
Navigation Bar from the drop-down list that appears.

If the panel doesn’t appear, open it by choosing Properties=>Insert from
the main menu and then selecting Common from the Insert bar drop-
down box.

Alternatively, you may choose Insert>Image Objects>Navigation Bar
from the main menu.

The Insert Navigation Bar dialog box appears, shown in Figure 4-5.
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2. Enter a name for the first button in the Element Name box.
The new button appears in the Nav Bar Elements box.

3. For each state of the button — Up Image, Over Image, Down Image,
and Over While Down Image — enter the name of the image file that
you want to use in the associated field.

Alternatively, you can click the Browse button for each field and select
an image from your files. You must supply the Up Image. All other states
< are optional and can be left blank.

You don’t need to use all four navigation bar button states — creating
only Up and Down works just fine.

4. In the When Clicked, Go to URL box, enter a URL or the name for the

page you want to appear when the user clicks the navigation bar
button.

Alternatively, you can click the Browse button to select a page from
your files.

5. Click the drop-down list tab and select a target window where you

want the URL to appear.

If you aren’t using frames, the only option is to use the Main window.

6. Click the (+) button to add another navigation bar button.

Repeat Steps 2 through 5 to format the new button.

Note: You can remove any button already created by clicking its name in
the Nav Bar Elements box and clicking the Remove (-) button. Reorder
the sequence of the buttons by clicking a button name in the Nav Bar
Elements box and clicking the up or down arrow.
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7. In the Options area, select the Preload Images check box if you want
the rollover effects to appear without delay as soon as the page loads.

8. To set the current button to appear in the Down state when the user
first sees the navigation bar, select the Show “Down Image” Initially
check box in the Options area.

9. In the Insert list box, click the tab and select from the drop-down list
to position the navigation bar either horizontally or vertically.

10. To set up the button images in a table format, select the Use Tables
check box.

11. Click OK to accept your choices and close the dialog box.

To check the navigation bar, you must preview your page in a browser.
Choose Filer>Preview in Browser from the main menu or click the Preview/
Debug in Browser button and use your mouse to point to the buttons.

Modifying a navigation bar

To change elements of a navigation bar you already created, choose
Modify=>Navigation Bar from the main menu, which opens the Modify
Navigation Bar dialog box where you can make edits.

The Modify Navigation Bar dialog box is nearly identical to the Insert
Navigation Bar dialog box shown earlier in this chapter, in Figure 4-5, except
that you can no longer change the orientation of the bar or access the Use
Tables check box.



Chapter 5: Adding Multimedia
Objects

In This Chapter

v+ Adding audio and video
+ Embedding and linking video

+~ Incorporating other media (ActiveX controls, Java applets, and Flash
movies)

If you want to understand and appreciate the power of adding video —
streaming or downloadable — to your Web site, just take a peek at sites
such as CNN (www.cnn.com). And for the talk-radio and music lovers among
you, sites such as National Public Radio (www.npr.org) demonstrate how
you can effectively use audio on your pages.

This chapter shows you how to incorporate both video and audio — as well
as other multimedia objects, such as Java applets, Flash movies, and
ActiveX controls — into your sites using Dreamweaver. Keep in mind that
Dreamweaver can’t help you build the multimedia elements themselves; it
can only make existing multimedia objects accessible to users who view
your page.

P Many different Web-friendly media formats exist. For a list of the most popu-

lar (along with tips for creating your own audio, video, and animation files),

check out Book V.

Adding Audio and Video to Vour Pages

You have two basic options for adding downloadable audio and video to
your Web pages.

4+ Embedding: You embed an audio or video file to display a playback con-
sole on a Web page that users can use to play, rewind, and fast-forward
the media file. (You can also embed an audio file and make it invisible to
create a background audio effect.) Users must have an appropriate plug-
in installed on their machines to play the embedded audio or video file.

4+ Linking: You link to an audio or video file to allow users the option of
linking to that media file.
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Figure 5-1:
Embedding
a media file
using the
Select File
dialog box.

The following sections describe the two options.

Keep in mind that most audio and video files are large — large enough that
many folks impatiently click the Stop button on their browsers before a Web
page chock-full of audio or video effects has a chance to finish loading. Two
basic rules help you use audio and video effectively in your Web pages:

4+ Use audio and video only when plain text just doesn’t do the trick.

4+ Keep your audio and video clips as short (and corresponding file sizes
as small) as possible.

Embedding an audio or video clip

You embed an audio file by following these steps:
1. In the Document window, click your page in the location where you
want to add an embedded audio file.
2. Choose Insert->Media->Plugin from the main menu.

Alternatively, you can click the Media button you find on the Insert
Common panel. To display the panel, choose WindowrInsert from the
main menu and then select Common from the Insert bar drop-down box.

The Select File dialog box you see in Figure 5-1 appears.

Select File B
Select fle name from: (%) File spstem
() Data zources
Lok in: -_}my_ma;o_h_les ] :.i. 3% @

ﬁ sorg_clip2.way
_@]scﬂg_:lps.mld
@ i

File name: song_clip.war
Files of type: iﬂIIFiIes ) V]

URL: fikr 4/ Cl¢my_audio_tles/sang_clip.wav

Relative to: | Document v1 navbar kil
Chasen file is not under site roat C:myFirstSite’.

3. In the File Name field, enter the name of the audio file you want to
embed and click the OK button.

The Plugin Properties inspector appears.
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If the file you enter is outside your Web site’s root directory,
Dreamweaver asks whether you want to copy the file to your site root.
Click Yes.

In the Plugin Properties inspector, size the Audio Plugin placeholder
to any dimensions you prefer.

You can either enter a width and height in the W and H text boxes in the
Plugin Properties inspector or drag a handle on the placeholder to man-
ually resize.

A width of 144 pixels and a height of 60 pixels ensure that users can
view all the audio playback controls in both Netscape Navigator and
Internet Explorer.

Click the Play button in the Plugin Properties inspector to play your media
file without previewing your page in a browser.

To play an embedded media file, you must first install the appropriate plug-
in media player.

To embed background music (music that plays automatically after the user
opens a page):

1.

2.

In the Document window, click your page in the location where you
want to add an embedded audio file.

Choose Insert>Media~>Plugin from the main menu.
The Select File dialog box appears.

In the File Name field, enter the name of the audio file you want to
embed and click the OK button.

Enter 2 for the width and height in the W and H text boxes in the
Plugin Properties inspector.

Click the Parameters button to open the Parameters dialog box.

In the Parameters dialog box, click the Add (+) button to add a new
parameter.

Click in the Parameter column and type hidden.

Press Tab to move to the Value column and type true.
Steps 7 and 8 hide the audio playback controls.

Click OK to complete the process and close the dialog box.
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Streaming audio and video

RealPlayer, from RealNetworks, Inc., offers you
the capability to stream audio and video files for
user playback. Streamingfiles begin playing as
soon as a browser transfers sufficient informa-
tion to the user's computer to stay ahead of the
remaining portion of the file as it downloads.
Streaming enables the user to experience your
audio or video clip much sooner than with a

downloadable file. This option is especially
useful for large audio files and all but the
shortest video files. Book V shows you how to
create streaming audio and video files with
RealPlayer. For helpful details on including
streaming media files in your Web site, refer to
Dreamweaver 4 Bible, by Joseph W. Lowery
(Wiley Publishing, Inc.).

Linking to an audio or video clip

A simple and relatively trouble-free way to include audio and video clips on
a Web page is to link the page to an audio or video file. Users can select the
link if they want to hear the clip. This selection opens a player outside the
browser where the user can control playback.

You follow the same steps to create a link to an audio or video file as you do
to create a link to a Web page; the only difference is the file format you
choose as the link target. For help in creating a link, see Book IV, Chapter 3.

Adding Other Media

Dreamweaver enables you to easily insert a number of other multimedia for-
mats into your Web pages, including ActiveX, Java Applets, Flash, and
Shockwave. After inserting any of the following media, you can set the con-
trol and playback features of the media in the Parameters dialog box.
Additionally, you can fine-tune the media action on your page by using the
Behaviors panel to create triggering actions that cause the media to play,
stop, and execute other functions.

Follow these directions to insert other media:
1. In the Document window, click your page in the location where you

want to add a multimedia file.

2. Choose Insert-oMedia from the main menu and choose from the drop-
down list the media type that you want to use.

Or, alternatively, display the Insert Common panel by choosing
Windowr>Insert from the main menu and selecting Common from the
Insert bar drop-down list.
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Media Type Button
ActiveX
Java Applet
Flash
Shockwave

3. Enter the name of the media file you want to insert.

For Applet, Flash, and Shockwave files: In the Select File dialog box,
enter the path to the media and click the Select button. Your file is
attached, and the associated Properties inspector appears. You can
change the selected file in the Plugin Properties inspector by typing a
new name in the Src text box or by browsing in the Src folder to select

a file.

For ActiveX: An ActiveX placeholder is inserted, and the ActiveX
Properties inspector appears. Enter in the Class ID text box the name of
the ActiveX file you want to play.

4. In the Properties inspector for your selected media, enter dimensions
in the W and H text boxes to size the Media placeholder to any
dimensions you choose.

5. In the Properties inspector for your selected media, click the
Parameters button to open the Parameters dialog box, where you can
format the playback of your media file.

See the reference materials for Flash and other multimedia programs for
details on formatting and playing files on your Web pages that you create

with these programs.
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Chapter 6: Punching Up Your
Pages with Forms and Frames

In This Chapter

v Incorporating forms
1 Adding text fields, buttons, and other form elements

v~ Structuring your pages with frames

' wo of the more popular Web page features, forms and frames, are also
two of the most advanced. You use them for these purposes:

4+ Forms: To gather information and feedback from users who visit your
Web pages.

4+ Frames: To construct sophisticated navigational schemes for your
Web site.

In this chapter, you see how to work with these powerful features in
Dreamweaver.

Incorporating Forms

Forms on the Web serve the same purpose as the paper-based forms

you fill out — they provide a structured format for gathering specific
information. The difference is that Web-based forms usually require less
time for keyboard-savvy users to fill out (and using Web-based forms also
saves a few trees otherwise destined for a paper mill).

Dreamweaver offers you a number of handy tools for creating Web-based
forms that you can easily include on your Web pages. You can incorporate
everything from text boxes to radio buttons, and you can create surveys,
gather user data, and conduct e-commerce.

Creating Web-based forms requires two steps:

1. Create the form that users see and interact with, which I demonstrate
how to do using Dreamweaver in this chapter.

2. Create the processing program that accepts and processes form
input. These processing programs — typically written in Perl or C and
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connected to Web-based forms through a protocol called CGI (Common
Gateway Interface) — must be installed on a Web server and are beyond
the scope of this book. For more information, check with your ISP (some
allow you to use the simple form-processing programs on their Web
servers for no extra charge) or check out a good book, such as Perl For
Dummies, 4th Edition, by Paul E. Hoffman (Wiley Publishing, Inc.).

Adding a form
Before you can insert specific form objects, such as check boxes, on your

Web page, you must first add a form to the page. You can add a form directly
to the Document window or in a table cell.

To add a form to a page, click in the Document window where you want to
add the form and choose Insert>Form=>Form from the main menu or click
the Form button on the Insert Forms panel. (If the Insert Forms panel isn’t
open, choose Windowr>Insert from the main menu to open the panel and
then select Forms from the Insert bar drop-down list.)

Dreamweaver adds the form to the page as indicated by the red dashed
lines and also adds the associated form tag to your HTML page code.

You can now insert form objects between the red dashed lines of the form.

If you attempt to add a form element (such as a radio button) without first
adding a form, a dialog box appears, asking whether you want to add a form
tag. Click Yes to add both the form tag and the element to your page.

Specifying form properties

A form has several properties that you can set using the Form Properties
inspector: Form Name, Action, Method, Target, and Enctype (short for MIME
encoded type). Click the form to open the Form Properties inspector. (If the
Properties inspector doesn’t appear, open it by choosing Window=>Properties
from the main menu.) Then specify the following properties:

4+ Form Name: Enter an alphanumeric name in the empty text box. The
advantage of naming your form is that you can use the name to refer-
ence the form in a scripting language that you use to retrieve, store, and
manipulate the form data.

4+ Action: Enter the address of the location that processes the form data.
Alternatively, you can browse to the location by clicking the folder and
making a selection at the Select File dialog box.

You can select the following three common actions:
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e Enter the URL of a Common Gateway Interface (CGI) program that
runs after the user submits the form. The action resembles the
following:

www.server.com/cgi-bin/formhandler.pl

e Enter the JavaScript program that runs after the user submits the
form. The action appears as follows:

www.server.com/javascript:function()
Here, function is your form handling function.

e Enter a mailto: address where the form data goes after the user
clicks Submit. A mailto: address appears similar to the following:

mailto:gruntworker@formhandling.com

Data received at the specified mailto: address isn’t formatted for easy
reading: It appears as strings of code with the form data embedded
within lots of ampersands and plus signs.

Method: Select from the drop-down list a method for how the form data
passes to the processing entity that you specified in the Action field.
Choices are Default, GET, and POST. (Default and GET are the same.)
GET sends the form data by appending it to the URL that the Action
specifies. POST sends the form data as a separate entity. GET limits the
amount of data that can pass along, but POST does not.

Target: You can specify a target window where your returned form data
will appear. Click the tab to select from the following choices: _blank
(displays returned data in a new window), _parent (displays returned
data in the parent of the currently opened window), _self (displays
returned data in the currently opened window), and _top (displays
returned data in the top-level window, replacing frames, if any). If you
have created frames, you can also select a frame name from this list.
(See the section “Structuring Pages with Frames,” later in this chapter,
for more information about frames.)

Enctype: You use the Enctype pop-up menu to specify the MIME encod-
ing type of the form data you submit to the server for processing.
(MIME, which stands for Multipurpose Internet Mail Extension, is simply
a standard way to send non-ASCII data across the Internet.) You use the
default setting of application/x-www-form-urlencode if you specify
the POST method. If your form includes a file-upload field, however, you
want to specifymultipart/form-data.

Labeling form objects
Dreamweaver enables you to provide labels for form elements (such as text
fields) and provide the user with directions about how to complete the
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information requested for each option. To label form elements, simply posi-
tion your cursor in the form and begin typing. Then insert the form element
you want.

Using text fields

Text fields are blank text boxes that you can insert in your form to hold
alphanumeric information that the user types. You can set up a text field to
hold a single line of text, multiple lines of text, or a password.

4 Single line: Provides space for the user to enter a single word or short
phrase of text.

4+ Multiline: Provides space for the user to enter a longer string of text.
Appropriate for a comment box.

4+ Password: Provides space for the user to enter a password. An asterisk
(Windows) or dot (Macintosh) appears on-screen for each character
that the user types.

To add a text field, do the following:

1. In the Document window, click where you want to add the text and
choose Insert>Formr>Text Field from the main menu or click the Text
Field button on the Inset Form panel.

If the panel isn’t open, choose Windowr>Insert from the main menu
to open the panel and then select Forms from the Insert bar drop-
down list.

Dreamweaver adds a text field to your form, and a Text Field Properties
inspector appears. If the Text Field Properties inspector doesn’t appear,
choose Window=>Properties from the main menu to open the inspector.

2. Fill in the following fields of the Text Field Properties inspector to
format the text field:

e TextField name: Enter a name in the empty box. The field is refer-
enced by this name in the HTML page code.

e Char Width: Enter a whole number for the approximate visible width
of the field. (The width is approximate because text characters in
your form display differently according to users’ browser settings.)

e Max Chars: (Applies to Single line and Password only.) Enter a whole
number to indicate the maximum number of characters that the user
can enter in the field. Max Chars can be equal to or greater than
Char Width.
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e Num Lines: (Applies to Multiline only.) Enter a whole number for the
maximum number of lines that the user can enter in the field.

e Type: Click a radio button for Single line, Multiline, or Password.

¢ Init Val: (Optional) Enter an alphanumeric word or phrase that occu-
pies the text field when the user first encounters the field. The user
can enter his or her own information over the Init Val.

Setting up buttons

After a user enters data into a form, the user must then perform some sort
of task to transmit the data from his or her computer to another computer
that can process the information. Dreamweaver offers you three buttons to
use to activate your form: Reset, Submit, and Command:

<+

+*

Reset: Clicking this button erases all data entered into the form, allow-
ing the user to reenter data into a fresh, clean form.

Submit: After the user clicks this button, the form data scoots off to
another computer based on the specified Action. (You see how to set
the Action of a form in the section, “Specifying form properties,” earlier
in this chapter.)

Command: After the user clicks this button, it executes the program-
ming function that the Web designer assigned to it.

To insert a button, follow these steps:

1.

Click where you want to add the button in the Document window and
choose Insert~>Form=>Button from the main menu or click the Button
button on the Insert Forms panel.

If the panel isn’t open, choose Windowr>Insert from the main menu and
then choose Forms from the Insert bar drop-down list.

Dreamweaver adds a button to your form, and a Button Properties
inspector similar to the one in Figure 6-1 appears. If the Button
Properties inspector doesn’t appear, choose Window=>Properties from
the main menu to open the inspector.

Fill in the following fields of the Button Properties inspector to
format the button:

¢ Button name: Enter a name in the empty text box. This name identi-
fies the button in the HTML code.

e Label: Enter a name for the button to appear on-screen.

e Action: Click a radio button to indicate the function of the button.
Choices consist of Reset form, Submit form, and None (Command).

Book IV
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Figure 6-1:
You use the
Button
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for a form.
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You can create a graphical Submit button — a button created from a small
image — by choosing Inserte>Form=>Image Field from the main menu or by
clicking the Image Field button on the Insert Forms panel. Then either
browse to the image file on your hard drive or type the name of the image
file directly into the File Name field. When you finish, click OK to create the
graphical Submit button.

Adding form elements

In addition to the text fields and buttons I describe in the sections, “Using
text fields” and “Setting up buttons,” earlier in this chapter, you can add a
variety of form elements that help your users give you information. Table 6-1
shows you some of the useful form elements you can add to your forms. To
insert any of the elements you see in Table 6-1, follow these steps:

1. Position your cursor in the area of the Document window where you
want to add the element.
2. Click the appropriate button on the Insert Forms panel.

See Table 6-1 for details. If the panel isn’t open, choose Window=Insert
from the main menu to open the panel and then select Forms from the
Insert bar drop-down list.

Dreamweaver adds the element to your form, and the appropriate
inspector appears. (If the appropriate inspector doesn’t appear, open it
by choosing Windowr>Properties from the main menu.)

3. Fill in the fields of the inspector.
4. Click OK to apply your selections and close the dialog box.
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Table 6-1 Form Elements

Element Button on the Insert Forms Panel
Check box

Radio button

List menu =

Jump menu (scrolling list of links) Ei

Structuring Pages with Frames

Frames are divisions of a Web page that enable you to load information inde-
pendently into distinct regions of your page. Frames are useful if you want
to display certain information on-screen while changing other information.
You frequently see three-frame pages on the Web — the top frame shows the
site’s title graphic; the left frame shows the navigation bar; and the large
body frame changes to show the content that you select.

A special HTML page called a frameset defines the structure and formatting
of frames on your Web page. As you work with frames, be aware that you
must always save the frameset page to lay out the size, position, and bor-
ders of your frames, along with the content that you want to display in each
frame.

Adding frames

You can add a frame to a frameless Document window or to an existing
frame within the Document window. Adding a frame to an existing frame
divides the existing frame into two or more regions. The page describing the
collective grouping of your frames is called a frameset.

To add a frame, click the Document window or existing frame in the area
where you want to add the frame. Choose Insert>HTML=Frames and select Book IV
an option from the drop-down list (see Table 6-2).
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Table 6-2 Options for Creating Frames ® :-f -§u
Frame Option What It Creates ; Eg
Left A vertical frame down the left side E 2-:::
Right A vertical frame down the right side 3 % 5
Top A horizontal frame across the top ® =
Bottom A horizontal frame across the bottom

(continued)
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Table 6-2 (continued)

Frame Option What It Creates

Bottom Nested Left A horizontal frame across the bottom and a

vertical frame down the left side

Bottom Nested Right A horizontal frame across the bottom and a vertical

frame down the right side

Left Nested Top A vertical frame down the left side and a horizontal

frame across the top

Left Nested Bottom A vertical frame down the left side and a horizontal

frame across the bottom

Right Nested Bottom A vertical frame down the right side and a horizontal frame

across the bottom

Right Nested Top A vertical frame down the right side and a horizontal frame

across the top

Top and Bottom Two horizontal frames of equal size and shape, one across

the top and the other across the bottom

Top Nested Left A horizontal frame across the top and a vertical frame

down the left side

Top Nested Right A horizontal frame across the top and a vertical frame

down the right side

Modifying frames

You use the Frame Properties inspector to select the source page that
appears in a frame. You also use the Frame Properties inspector to format the
appearance of an individual frame. To modify a frame, follow these steps:

1.

Open the Frames panel by choosing Windowr>Frames from the main
menu.

The Frames panel appears and displays a miniature version of the
frameset for your entire page. (See the right side of Figure 6-2.)

Note: You can’t simply click a frame to open its associated Frame
Properties inspector. If you click a frame, you’re actually clicking the
source page that resides in the frame — a process identical to clicking
in the Document window for that page.

In the Frames panel, click the frame whose attributes you want to
modify.

A Frame Properties inspector similar to the one at the bottom of
Figure 6-2 appears for the selected frame. If the inspector doesn’t
appear, open it by choosing Window=>Properties from the main menu.
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3. In the Frame Properties inspector, enter a name for your frame in the

Frame Name text box.

This name is the name by which the frame is referenced in the Frames
panel, the Target drop-down lists, and the HTML page code. The frame
name must start with a letter, and you cannot use hyphens, spaces, or
periods. You must also avoid using JavaScript-reserved names, such

as top.

4. In the Src text box, enter the name of the source page whose content

you intend to display in the frame.

Alternatively, you can click the Src folder and browse to select the

source page.

5. Select a scrolling option for your selected frame from the Scroll drop-

down menu.

Your options are

e Yes: Adds a scroll bar to the frame, whether it’s needed or not.

e No: Doesn’t add a scroll bar to the frame, even if needed.

Book IV
Chapter 6

sawel4 pue
suo4 yym sabed
1no), dn Buiyaung



332 Structuring Pages with Frames

e Auto: Places a scroll bar in the frame if the frame contents exceed
the frame boundaries.

e Default: Places a scroll bar in the frame depending on the user’s
browser settings.

6. Click the No Resize check box if you don’t want the user to be able to
resize the frame.

If you do want the user to be able to resize the frame, leave the check
box unchecked.

7. Format the frame border appearance by selecting a choice from the
Borders drop-down list box.

You have three choices:
¢ Yes: Creates a three-dimensional look for the borders.
¢ No: Creates a single-color flat look for the borders.
e Default: Enables the user’s browser to set how borders appear.

8. Select a border color for the frame by clicking the Border Color
swatch and selecting a color from the Color palette that appears.

Alternatively, you can enter a hexadecimal color code in the Border
Color text box.

9. Enter a number in pixels in the Margin Width and the Margin Height
text boxes.

Margin Width specifies the horizontal standoff space between the frame
content and the frame border. Margin Height specifies the vertical
standoff space between the frame content and the frame border.

Deleting frames

To delete a frame, select the frame border and drag it to the edge of the
parent frame or to the edge of the Document window — whichever is closer.

To view frame borders, choose Viewr>Visual Aids=>Frame Borders from the
main menu.

Saving frames

Saving a frame means that you're saving the HTML page from which the
source content of the frame originates. To save a frame, follow these steps:

1. Select the frame by clicking it.

2. Choose File>Save Frame from the main menu.
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3. On the first save, enter a name in the File Name text box of the Save
As dialog box that appears and click Save.

Future saves require that you complete only Steps 1 and 2.

Saving framesets

Saving a frameset means saving the layout of frame positions, frame names,
and border formatting on a page. Keep in mind that you must also save indi-
vidual frames (see the preceding section, “Saving frames”) to save the con-
tent contained in those frames. To save a frameset, follow these steps:

1. Select the frameset by clicking one of its borders.

To view frame borders, choose Viewr>Visual Aids=>Frame Borders from
the main menu.

2. Choose File>Save Frameset from the main menu.

3. On the first save, enter a name in the File Name text box of the Save
As dialog box that appears and click Save.

Future saves require that you complete only Steps 1 and 2.

If you also make changes to individual frames — not just the frameset —
since your last save, Dreamweaver asks whether you want to save individual
frames. Make sure that you do so.

Setting no-frames content

Text-based browsers and many older browsers frequently don’t support
frames and can’t correctly display pages that you create by using frames.

To help ensure that the maximum number of users can view your page cor-
rectly, Dreamweaver offers you a method for building no-frames pages as
companions to your frame-enabled pages. To create a no-frames page for
your current frameset, follow these steps:

1. Choose Modify=>Frameset=>Edit NoFrames Content from the main
menu.

A blank, NoFrames Content page appears in the Document window and
replaces your frame-enabled page.

2. On the NoFrames Content page, insert the information that you want
to appear in No Frames browsers.

3. Return to your frame-enabled page by choosing Modify->Frameset=>
Edit NoFrames Content from the main menu.
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Figure 6-3:
You use the
Properties
inspector
associated
with a link
to choose

a target for
your framed
content.

Targeting content

You

can set up a two-frame frameset in which you use the left frame for navi-

gation and the main frame to display any link that the user clicks in the navi-
gation frame. You need to set up only the link to target the main frame as the
location where you want the selected HTML page to open.

Set up a target by following these steps:

1. Select the text or image that you want to act as a link.

Doing so opens the associated Properties inspector, as shown in Figure
6-3. If the inspector doesn’t appear, open it by choosing Windowr>
Properties from the main menu.
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2. In the Link box, enter the name of the HTML source page whose con-

tent will appear in the frame.

Alternatively, you can click the Link folder and browse to select the
source page.

From the Target drop-down menu, select the target frame where the
link is to appear.

All available targets are listed in the menu. These targets include the
names of all frames that you set up (in this case, content, which is the
main frame, and nav, the navigational frame) and also the following
system-wide targets:

e _blank: Opens a new browser window and reveals the link in that
window. The current window remains open.

e _parent: Opens the link in a window that replaces the frameset con-
taining the current page.
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e _self: Opens the link in the current frame. The linked page replaces
the page in the current frame.

e _top: Opens the link in a window that replaces the outermost frame-
set of the current page. (Same as _parent, unless you're using nested
framesets.)
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Chapter 7: Laying Out
Pages with Layers

In This Chapter

v Adding, selecting, and deleting a layer

v+ Placing objects in a layer

v+ Including a background image or color in a layer
v+ Naming a layer

1+ Nesting and aligning layers

+ Changing the visibility of a layer

+* Moving and resizing a layer or multiple layers

T) precisely lay out the content of your Web page, you can use tables
(see Book IV, Chapter 6), or you can use the latest and greatest layout
aid: layers. Think of layers in Dreamweaver as separate pieces of paper that
you fill with content (images and text, for example) and shulffle, stack, posi-
tion, and overlap until your page looks exactly the way you want.

Adding a Layer

You can add a layer to the workspace of your Document window by using
one of the following two methods:

4 Choose InsertrvLayout Objects=Layer from the main menu. A new layer
appears in the upper-left corner of your Document window.

4 Click the Draw Layer button you see in the Insert Layout panel. (If the
panel doesn’t appear, open it by choosing Windowr>Insert from the
main menu and then selecting Layout from the Insert bar’s drop-down
list.) Position the cross hair cursor anywhere in your Document window
and click and drag until the layer obtains the dimensions you want.
Release the mouse button.
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After you add a layer, the Layers panel appears. If the Layers panel isn’t dis-
played after you add a layer, choose Windowr>Layers from the main menu.

Selecting a Layer

Selecting a layer enables you to identify which layer you want to affect when
executing a layer operation, such as moving or naming the layer.

Use any of the following methods to select a layer:

4 In the Document window, click the boundary of the layer.

4 In the Document window, click the layer handle — the square enclosing
a small grid located at the top-left corner of the layer.

4 In the Document window, press the Shift key and click anywhere inside
the layer.

+

In the Layers panel, click the name of the layer.

4+ Click the layer’s HTML tag in the tag selector of the Document window
Status bar.

Selection handles appear on the boundary of the layer to indicate that you
selected it.

Deleting a Layer

Deleting a layer removes the layer, the layer’s contents, and the layer
marker from the Document window. To delete a layer, select the layer and
then press Delete or Backspace.

V?‘“\NG" Don’t delete a layer if you want to remove it from one page and add it to
another. Instead, cut the layer by selecting it (see the preceding section,
“Selecting a Layer™) and choosing Edit=>Cut from the main menu. Open the
page where you want to add the layer and choose Edit=>Paste.

Placing Objects in a Layer

To add an object to a layer, click inside the layer and follow the normal pro-
cedure for adding the object. For example, add text to a layer by clicking
inside the layer and typing text or add other objects to a layer by clicking
inside the layer and choosing Insert from the main menu.
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Including a Background Image or Color in a Layer

By default, an unnested layer has the same color or background image as
the Document window in which it’s drawn. (A nested child layer has the
same color or background image as its parent. For more about nested layers,
see the section “Nesting Layers,” later in this chapter.)

You can change the background of any layer by including a background
image or color in the layer by following these steps:

1. Select the layer where you want to change the background.

If the Layer Properties inspector doesn’t appear, open it by choosing
Window=>Properties from the main menu.

2. In the Layer Properties inspector, change one of the following:

¢ Bg Image: Click the folder to the right of the box and browse to
select a background image from the Select Image Source dialog box
that appears. Click OK to accept your image choice and close the
dialog box. The name of the background image appears in the Bg
Image box, and the image is added to the background of the layer.

e Bg Color: Click the color swatch and select a color from the color
palette that appears. Alternatively, you can enter a color in the Bg
Color box. The new color appears in the background of the selected
layer.

Naming a Layer

The first layer you add to a page is automatically named Layer 1; the second
layer you add is named Layer 2; and so on. You can change these default
names to other names that help you more easily distinguish layers when
working with HTML and examining layers with the Layer Properties inspec-
tor or Layers panel.

To name a layer using the Layers panel, follow these steps:
1. If the Layers panel doesn’t appear, open it by choosing

Windowr>Layers from the main menu.

2. In the Layers panel, double-click the name of the layer whose name
you want to change.

The current name is selected.

3. Enter a new name for the layer.
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\\3

Get in the habit of appropriately naming your layers as soon as you create
them. The name blueprint image map helps you remember a layer’s content
much better than Layerl5.

Nesting Layers

Figure 7-1:
A nested
layer can be
(but doesn't
have to be)
drawn
inside its
parent layer.

A nested layer has a dependent relationship with another layer. The nested
layer is often referred to as a child layer, whereas the layer on which it
depends is called the parent layer. A child layer can be drawn completely
inside its parent (as shown in Figure 7-1) in an intersecting arrangement
with its parent or completely unattached to its parent, depending on the
effect you want to achieve. A nested layer has or inherits the same visibility
of its parent and moves with the parent when the parent layer is reposi-
tioned in the Document window.

This 15 the parent layer
[E

s i the nested layer
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Enabling nesting

To create nested layers in the Document window, you must first enable nest-
ing. To do so, follow these steps:

Choose Edit=>Preferences to open the Preferences dialog box.

In the Preferences dialog box, choose Layers in the category area.
Check the Nesting check box.

Click OK to banish the Preferences dialog box.

s WN =

In the Document window, choose Windowr>Layers to open the Layers
panel.

6. In the Layers panel, make sure that the Prevent Overlap box is
unchecked.
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Creating a new nested layer

Use either of these methods to draw a nested layer:

4+ Click inside an existing layer and choose Insert=>Layout Objectst>Layer

from the main menu. A child layer of default size appears inside the
parent layer. If the dimensions of the parent layer are smaller than the
dimensions of the child layer, the child layer exceeds the boundaries of
the parent.

Click the Draw Layer button from the Insert Common panel and drag it
into the parent layer. A child layer of default size appears inside the
parent layer. If the dimensions of the parent layer are smaller than the
dimensions of the child layer, the child layer exceeds the boundaries of
the parent.

Changing the nesting of an existing layer

To change the nesting of an existing layer, follow these steps:

1.

2.

Open the Layers panel by choosing Windowr>Layers from the
main menu.

In the Layers panel, press and hold the Ctrl key (Windows) or 38 key
(Macintosh) while using the mouse to click and drag the intended
child layer on top of its new parent.

The child is in the correct position when you see a box appear around
its intended parent layer.

Release the mouse button.

The new child-parent relationship is shown in the Layers panel.

Dreamweaver draws the new child layer and updates the associated code
for changed layer-nesting in the HTML source code for your page.

Collapsing or expanding your
view in the Layers panel

You can change how you view the names of nested layers in the Layers
panel by collapsing or expanding your view, as shown in Figure 7-2.

4+ To collapse your view: Click the minus sign () in front of a parent layer.

Names of nested child layers for that parent are hidden.

4+ To expand your view: Click the plus sign (+) in front of a parent layer.

Names of nested child layers for that parent appear.
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Aligning Layers

Aligning layers can help you precisely lay out visual content in the Document
window. You can align layers with the top, left side, right side, or bottom.

To align layers, select the layers you want to align by pressing and holding

the Shift key and then clicking each layer in the Document window. Choose
Modify=>Align from the main menu and choose one of the following options
from the menu that appears:

4+ Left: Assigns the x-coordinate of the leftmost selected layer to all
selected layers.

4+ Right: Aligns the right side of all selected layers with the right side of
the rightmost selected layer.

4+ Top: Assigns the y-coordinate of the topmost selected layer to all
selected layers.

4 Bottom: Aligns the bottom of all selected layers with the bottom of the
bottommost selected layer.
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4+ Make Same Width: Resizes layers to match the width of the layer
selected last.

4 Make Same Height: Resizes layers to match the height of the layer
selected last.

Changing the Ulisibility of a Layer

You can specify whether a layer is visible or hidden when a Web page
loads — first appears — and as a result of specific actions by the user.
Visibility can change as many times as you want. Visibility options consist of

4 Default: The layer’s initial visibility is the default setting. (To edit layer
default settings, choose Edit=>Preferences from the main menu and
then, to display the layer default settings you can change, click Layers
in the Preferences dialog box that appears.)

4+ Inherit: For a nested layer, the layer’s initial visibility is the same visibil-
ity of its parent. For an unnested layer, selecting the Inherit option
causes the layer to appear as visible.

4 Visible: The layer’s initial visibility is visible.
4+ Hidden: The layer’s initial visibility is hidden.

You can also set layer visibility by using either the Layer Properties inspec-
tor or the Layers panel. By setting layer visibility, you can create images
that appear (or disappear) in response to user interaction. For example, you
can create an image of a widget that appears on a Web page after a user
clicks a link marked “Click here to see our top-of-the-line widget!”

To set the initial visibility of a layer via the Layer Properties inspector,
select the layer in the Document window to open the Layer Properties
inspector. If the inspector doesn’t appear, open it by choosing Window=>
Properties from the main menu. Click the down arrow tab at the Vis box
and choose a visibility option from the drop-down list.

To set the initial visibility of a layer via the Layers panel, click in the
Visibility column (shown a little earlier in this chapter, in Figure 7-2) next to
a layer’s name to display an open eye (visible), closed eye (hidden), or no
eye (inherited).

Layering Layers: Setting the Z-index

The z-index of a layer indicates the layer’s position in a stack of multiple
layers. Z-indices are useful when you have a handful of layers — some
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containing transparent portions; some of different sizes — stacked one on
top of the other. Changing the z-index of your layers lets you “shuffle” the
layers — much as you shuffle a deck of cards — to create interesting visual
effects.

Z-indices are measured in whole numbers and don’t have to be consecutive —
for example, you can have three layers with z-indices of 1, 3, and 7, respec-
tively. The layer with the largest z-index sits on top of the layer stack, and the
layer with the smallest z-index sits on the bottom of the layer stack. Layers
with larger z-indices obscure those with smaller z-indices. You can change the
z-index of a layer in either the Layer Properties inspector or the Layers panel.

To assign the z-index of a layer by using the Layer Properties inspector,
first select the layer to open the Layer Properties inspector. If the Layer
Properties inspector doesn’t appear, open it by choosing Window=>
Properties from the main menu. Then enter a new number in the Z-Index
box of the Layer Properties inspector.

To assign the z-index of a layer using the Layers panel (as shown in
Figure 7-3), follow these steps:
1. Select the layer to open the Layers panel.

If the Layers panel doesn’t appear, open it by choosing Windowr>Layers
from the main menu.

2. Click the Z column for the layer whose z-index you want to change.
The current z-index is selected.

3. Enter a new z-index for the layer.
The new number appears in the Z column for the selected layer.

To assign relative z-indices to layers by reordering layers in the Layers
panel, follow these steps:

1. Open the Layers panel by choosing Windowr>Layers from the main
menu.
The Layers panel lists layers in order of descending z-index.

2. Click the name of a layer for which you want to change the z-index.

3. Drag the layer name into a new list position and release the mouse
button.

As you drag, the selected layer is indicated by a thick line.
Dreamweaver reorders the list in the Layers panel and renumbers layer

z-indices to reflect your change. Also, Dreamweaver updates, in the HTML
source code for your page, the associated code for the layers’ z-indices.
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P Because you don’t have to number the z-index of layers consecutively,

consider leaving gaps between indices in case you want to add new layers
into the middle of the stack. For example, use only even numbers for your
indices so that you can easily sandwich a layer with an odd-numbered
z-index in-between.

Moving a Layer

You may choose to move a layer to a place in another location in the
Document window or to a position relative to the grid or to other objects.

To move a layer, select the layer in the Document window and then reposi-
tion your selection by using one of the following three methods:
4 Click and drag the layer to a new location and release the mouse button.

4 Press the arrow keys you find on the numeric keypad on your keyboard
to nudge the layer up, down, left, or right one pixel at a time.

4+ In the Layer Properties inspector, enter a new value in the T and L
boxes to indicate the pixel coordinates of the layer’s top-left corner.
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\J .
) When moving layers, you can choose to enable or prevent layer overlap,

depending on how you want the final image montage to appear. You enable
or prevent layer overlap as described in the following list:

4+ To prevent layer overlap: Open the Layers panel by choosing Window=>
Layers from the main menu and checking the Prevent Overlap check box.

4+ To enable layer overlap: Open the Layers panel by choosing
Windowr=>Layers from the main menu and making sure that the Prevent
Overlap check box is unchecked.

Resizing a Layer

Resizing a layer means changing its height and width dimensions. To resize
a layer, select the layer and perform one of the following tasks:

4+ Click and drag a selection handle — one of the large dots on the layer
boundary — until the layer obtains the dimensions you desire.

4+ In the Layer Properties inspector, enter a new width in pixels at the W
box and a new height in pixels at the H box. If the Layer Properties
inspector doesn’t appear, open it by choosing Windowr>Properties from
the main menu.

Resizing Multiple Layers at the Same Time

You can change the height and width dimensions of multiple layers at the
same time as follows:

1. Press and hold the Shift key while selecting each layer you want to
resize.

2. If the Multiple Layers Properties inspector doesn’t appear, open it by
choosing Window=>Properties from the main menu.

3. In the Multiple Layers Properties inspector, enter a new width in
pixels in the W box and a new height in pixels in the H box.



Chapter 8: Using Templates
for a Consistent Look

In This Chapter

v About templates
v~ Creating a template
v~ Adding an editable field to a template

v~ Using a template to create a Web page

Creating one or two Web pages by hand is easy to do. If you want to
create a large site containing dozens (or even hundreds) of pages con-
taining similar elements, however, such as your company logo or a nifty
columnar layout, you quickly find that hand-crafting each page takes a great
deal of time. And, because we humans tend to make mistakes from time to
time, the more pages you create by hand, the more mistakes you may find
you make.

Fortunately, Dreamweaver helps solve this problem by providing a tech-
nique for creating templates. A template is a special kind of document you
can create that you can use to construct multiple Web pages, changing the
content slightly with each Web page while keeping a specified portion (for
example, your company logo and the navigation layout) static from page to
page. Using templates saves you time (and frustration) as you create multi-
ple Web pages with a consistent “look and feel.”

Some Web development teams like to distinguish between Web designers,
the folks who design the way Web pages look, and Web content specialists,
the folks who keep the textual content of a Web site updated. Because using
templates allows you to lock the design portion of your Web pages and
specify text as editable, Web designers can create a great-looking Web site
and then hand it over to Web content specialists to update — without fear!
(Any updates the Web content specialists make don’t affect the locked
design elements.)

\\J

About Templates

In Dreamweaver, a template is a special type of file you can use to create
multiple Web pages that share certain design elements, such as navigation
bars, images, colors, and links.
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Although templates resemble Web pages (as you see a little later in this
chapter, in Figure 8-1), they have two important differences:

4+ You can “lock” content on a template to create both fixed (non-
editable) and editable regions. Other developers using your template
to create Web pages can change the editable regions of your template,
but not the fixed regions. Locking content ensures that all Web pages
created from a particular template contain at least some fixed, identical
content. (The kinds of content that you typically want to appear identi-
cal from page to page include page layout, logos, copyright notices, and
other “look and feel” design elements.)

4+ You save templates with a special file extension. You save Web pages
by using the .html or . htm extension; you save templates by using the
.dwt (Dreamweaver template) file extension.

Creating and Using Templates

Figure 8-1:
You
designate
the fixed
portion of
atemplate
in the
Document
window.

The steps you take to create a template are similar to those you use to
create a Web page. In this section, I demonstrate how to save fixed content
as a template; then I show you how to add editable regions to a template.
Finally, you see how to use a template — one you create or one that already
exists — to create a Web page.
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Figure 8-2:
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Creating a template

Many prebuilt templates are available (for a price!). If you prefer to
purchase a template rather than to create one from scratch, you may
want to point your browser to a site that reviews third-party Dreamweaver
templates, such as Dreamweaver-Templates.org (www.dreamweaver-
templates.org).

Follow these steps to create a template:

1.
2.

Create a new Web document or open an existing document.

Add any design elements you want to designate as fixed (non-
editable) regions.

In Figure 8-1, you see a graphical logo across the top of the template,
navigation links across the left side of the template, and an animation
element at the bottom of the template.

Choose Filer>Save as Template.

The warning dialog box you see in Figure 8-2 appears.

Dieamweaver MX 2004 =]

This template doesnt have amy edtable regions. Are
! 0L SURE You wank to continue?

[ |Der't warn me again,

Click OK.

The Save as Template dialog box appears.

Type a descriptive name for your template in the Save As field.
Click Save.

Dreamweaver saves the template using the .dwt file extension.

Adding an editable region

An editable region is the portion of a template you want to change from Web
page to Web page. You can specify as many editable regions in a template as
you want.
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In addition to editable regions, you can add other types of regions, such as
repeating regions and optional regions, to your template. For more informa-
tion about the regions you can add to your template, choose Help=>Using
Dreamweaver~Search to display the Search dialog box, type templates in
the keyword field you find in the Search dialog box, and click Search.

To add an editable region to a template, follow these steps:

1. Open an existing template.

2. Select the area that you want to be editable and choose
Insert~>Template Objects~>Editable Region.

The New Editable Region dialog box appears, as shown in Figure 8-3.

.
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3. Enter a name for the editable region in the Name field and click OK.
A border appears around the editable region, as shown in Figure 8-4.
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4. Choose Filer>Save to save your changes.

Using a Template to Create a Web Page

To create a Web page using an existing template, follow these steps:

Figure 8-5:
Creating a
Web page
from an
existing
template.

1. Choose File>New.

The New Document dialog box appears.

2. Click the Templates tab you see in the New Document dialog box.

A New from Template dialog box appears, similar to the one shown in

Figure 8-5.
New from Templ
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3. Select your site from the Templates For area; then select the template
you want to use. When you finish, click Create.

A new, untitled Web page based on the template you select appears in
the Document window. Figure 8-6 shows you an example.

4. Update the editable portion of the Web page.

Notice that Dreamweaver doesn’t allow you to update the fixed portion
of the Web page.

5. Choose Filer>Save to save the Web page.
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Chapter 9: Publishing and
Maintaining Your Site

In This Chapter

1+~ Defining remote host settings
v+~ Connecting to a Web server

v~ Transferring files

v Collaborating on site revisions

v Measuring download time, monitoring links, and updating meta tags

T) make your site available on the World Wide Web, you must sign up
with a Web hosting service or have another method of accessing a Web
server. You can then transfer a copy of your entire local site root to a folder
on the Web server that hosts your site. You must transfer not only every
HTML code page in your local site but also every image, video, and sound
(and all other files you use in your site) to the remote host.

After your site is transferred, you and other collaborators can retrieve site
pages, work on them locally, and upload the pages back to the host to keep
the site updated. You can also fine-tune your site by setting up meta tags,
measuring the download time your site requires, and monitoring all the links
on your site — quickly and easily — to ensure that users don’t access any
dead-end pages from your site.

Defining Remote Host Settings

Dreamweaver makes an easy task of transferring Web files from your local site
to the remote host. But prior to transferring, or uploading, your first site to
the host, you must tell Dreamweaver some basic information about the host,
such as where it is located on the Web and what the access password is.

You define remote host attributes in the same dialog box that you use to
define your local site — namely, the Site Definition dialog box — by follow-
ing these steps:
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Figure 9-1:
You must
define the
settings for
your remote
host before
you can
transfer, or
upload, your
files using
Dream-
weaver.

1. In Dreamweaver, choose Siter>Manage Sites from the main menu to
open the Manage Sites dialog box.

2. From the Manage Sites dialog box, select the site you want to work
with and click the Edit button.

The Site Definition dialog box for your site opens, as shown in Figure 9-1.
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3. Select the Remote Info category.

4. At the Access drop-down menu, select a Web server access method
from these options:

e None: Applicable only if you don’t plan to upload your site to a
remote server.

e FTP: Select this option to transfer files to and from your server via
File Transfer Protocol. Supply the requested information at the
dialog box based on the information in Table 9-1.

Table 9-1 FTP-Related Settings in Dreamweaver
Item Description
FTP Host Enter the name of the FTP connection for your server,

such as www.domainname.com.

Host Directory Enter the name from which users will access your site,
such aswww/public/yourlD.
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Item Description

Login Enter your login identification for accessing the server and click
the Test button if you want to test your FTP connection.

Password Enter your password for accessing the server and click the
Save check box if you want Dreamweaver to remember your
password.

Use Passive FTP Check this box if your firewall requires that your local software
establish the server connection instead of the remote host (if
you're not sure whether your computer configuration includes a
firewall, ask your system administrator).

Use Firewall Check this box if you connect to the host from behind a firewall;

then click the Firewall Settings button to define a firewall host.

Use Secure FTP (SFTP) Check this box if your FTP host supports secure FTP.

Automatically Upload Check this box to upload files automatically every time you save
Files to Server on Save your site in Dreamweaver.

Enable File Check Check this box to enable file check in and check out via
In and Check Out the Files panel.

e Local/Network: Select this option if your local computer is also your

Web server or if you connect to the Web server via a local area net-
work. At the Remote Folder box, enter a folder name or browse to
select the folder on the remote host where you store your site files.
Click to check the Refresh Remote File List Automatically box if you
want to see the Remote Files pane of the Site window updated auto-
matically as you transfer files to the remote server. Click to check
the Automatically Upload Files to Server on Save box to upload files
automatically every time you save your site in Dreamweaver; click
Enable File Check In and Check Out box to enable file check in/check
out (useful if many folks will be updating and maintaining your Web
site pages).

RDS: Select this option if you want to access ColdFusion Remote
Development Services. Click the Settings button to display the
Configure RDS Server dialog box and specify the host name, port,
full host directory, username, and password. Click OK to close the
Configure RDS Server dialog box. Click to check the Automatically
Upload Files to Server on Save box to upload files automatically
every time you save your site in Dreamweaver; click the Enable File
Check In and Check Out box to enable file check in/check out (useful
if many folks will be updating and maintaining your Web site pages).
If you want to check out the files when you open the RDS server con-
nection, click the Check Out Files When Opening box and then spec-
ify a check out name and e-mail address.
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¢ SourceSafe Database: Select this option if you want to access a
SourceSafe database. Click the Settings button and complete the
Open SourceSafe Database dialog box by typing (or browsing for)

a database path, typing a project name, and providing your user-
name and password. When you finish, click OK to close the Open
SourceSafe Database dialog box. Click to check the Automatically
Upload Files to Server on Save box if you want to upload files auto-
matically every time you save your site in Dreamweaver. Click the
Check Out Files When Opening box if you want to check out the files
when you open the SourceSafe database connection.

e WebDAV: Select this option if you want to make a WebDAV connec-
tion. (WebDAV, which is short for Web-based Distributed Authoring and
Versioning, allows you to edit and manage files on remote Web servers
collaboratively — in other words, to share files with other developers.
For more information, visit www.webdav . org). Click the Settings
button and complete the WebDAV Connection dialog box by entering
the server URL and providing your username, password, and e-mail
address; click OK to finish. Click to check the Automatically Upload
Files to Server on Save box to upload files automatically every time
you save your site in Dreamweaver. Click the Enable File Check In and
Check Out box to enable file check in/check out (useful if many folks
will be updating and maintaining your Web site pages).

5. Click OK to close the Site Definition dialog box.
6. Click Done to close the Manage Sites dialog box.

If you're confused about information regarding your Web server (and who
isn’t, at least at first?), contact your hosting service or your system adminis-
trator to find out the server name, directory, username, password, and
other details you need to complete the Remote Info area of the Site
Definition dialog box.

If you change hosting services or other remote server information, such as
your password, you can edit your Remote Host attributes by returning to
the Site Definition dialog box.

Connecting to a Web Server

To connect to your Web server, simply click the Connects to Remote Host
button you see in the Files panel (and in Figure 9-2).

(If the Files panel doesn’t appear, choose Window=Files from the main
menu. If the Connects to Remote Host button doesn’t appear in the Files
panel, select a Dreamweaver site file from the Files panel and then choose
Siter>Manage Sites from the main menu. Then, in the Manage Sites dialog
box that appears, select the site that you want to upload and click Done.
The Site Management toolbar, including the Connects to Remote Host
button, appears in the Files panel. )
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To expand the Files panel and view the Site window, click the Expand/
Collapse button you find on the right side of the Files panel.

After you connect, as shown in Figure 9-3, your site files on the remote host
appear in the Remote Site pane — the left pane of the Site window. Files in
your local site root still appear in the right pane of the Site window.
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When you’re done working with your Web server, simply click the
Disconnects from Remote Host button in the Site window.

Transferring Files

When you connect to the remote host, you can transfer files to and from the
server. Just follow these steps:

1. If you're not already at the Site window, switch to it by opening a
Dreamweaver site file, choosing Window=>Files from the main menu,
and clicking the Expand/Contract button.

If the Site Management toolbar doesn’t appear in the Files panel,
choose Siter?Manage Sites from the main menu. Then, in the Manage
Sites dialog box that appears, select the site that you want to upload
and click Done. When the Site Management toolbar appears, click the
Expand/Contract button to display the Site window.

2. Select the files you want to transfer.

To select files you want to send to the remote site: Click on one or
more files in the Local Files pane.

To select files you want to retrieve from the remote site: Click on one
or more files in the Remote Files pane.

3. Transfer the files.

To send local files to the remote site: Click the Put button in the Site
window or choose Siter>Put from the Site window menu. Dreamweaver
presents a dialog box that asks whether you want to include dependent
files in the transfer. Dependent files are files, such as images, that are
included in your HTML code pages. Click Yes to include these files or No
to transfer only your selected files.

To bring remote files to the local site: Click the Get button in the Site
window or choose Site=>Get from the Site window menu.

Your transferred files appear in the destination window pane. You can move
files in and out of folders in their new location using standard Windows
procedures.

At any time, you can refresh your file lists to reread a directory of files. To
refresh the selected file directory, just click the Refresh button in the Site
window.

Collaborating on Site Revisions

Site maintenance can be an enormous task that you can accomplish best
by giving multiple designers revision privileges for files on the site host. To
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simplify the maintenance task, Dreamweaver provides a check in/check out
system that enables you to work collaboratively with others in revising site
files. This system helps you and your team keep track of who has which file
currently checked out so that revisers don’t inadvertently duplicate editing
efforts.

Enabling file check in/check out

Follow these steps to set up file check in/check out for a site:

1. In Dreamweaver, choose Sitec>Manage Sites from the main menu to
open the Manage Sites dialog box.

2. From the Site list, select the site that you want to work on and click
the Edit button.

A Site Definition dialog box for your site appears. (Refer to Figure 9-1 to
see a similar dialog box.)

3. Select the Remote Info category.
4. The options you choose in this step depend on your access method.

If you select FTP or Local/Network for your Access method: Click the
Enable File Check In and Check Out check box. After you do so, the
additional options you see at the bottom of the Site Definition dialog
box appear (refer to Figure 9-1).

If you select SourceSafe Database or WebDAV for your Access
method: Click the Settings button and complete the dialog box that
appears.

5. For all Access methods, click the Check Out Files When Opening
check box.

The file is marked as checked out to you whenever you open it from the
remote server.

6. If you select FTP or Local/Network for your access method, enter a
check out name and e-mail address.

Any file you check out shows this name and address listed in the Check
Out column of the Remote Files pane of the Site window.

Checking files in and out
Follow these procedures to check files in and out for collaborative site
editing:

To check files out: In the Remote Files pane of the Site window, select the
files you want to check out. Then click the Check Out button at the top of
the Site window or choose Site=>Check Out from the Site window menu. The
Checked Out By column in the remote pane of the Site window identifies the
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person checking out the file. A check mark appears in front of the filename
to indicate that it’s checked out.

To check files in: In the remote pane, select the files you want to check in.
Then click the Check In button at the top of the Site window or choose
Siter>Check In from the Site window menu. The Checked Out By column in
the remote pane of the Site window removes the name of the person who
had previously checked out the file. Also, the check mark in front of the file-
name indicates that its checked-out status is removed.

Maintaining Your Site

Figure 9-4:
File size and
estimated
download
time appear
at the
bottom

of the
Document
window as
you work
with a page
in Dream-
weaver.

After you publish your site, you want to maintain and fine-tune it so that it
always looks (and behaves) its very best. The maintenance tasks you per-
form most often (other than updating content) include measuring download
time, monitoring links, and updating meta tags.

Measuring download time

Download time is an important measurement for you as a Web designer
because it tells you how long users must wait to view your entire page on
their computers. Download time depends on the connection speed, or bits
per second (bps), of a user’s modem.

You can keep tabs on the expected download time for a page under con-
struction by looking at the File Size/Download Time indicator in the Status
bar at the bottom of the Document window, as shown in Figure 9-4.
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Dreamweaver computes the estimated download time based on the connec-
tion speed specified in the Preferences dialog box. To change the default
connection speed, choose Edit>Preferences from the main menu to open
the Preferences dialog box. At the Preferences dialog box, select the Status
bar category and then choose a connection speed from the Connection
Speed drop-down menu. Choices consist of 14.4, 28.8, 33.6, 56, 64, 128, and
1,500 kilobits per second.

Try minimizing download time for a page — by optimizing or reducing the
images on your page, for example — to the greatest degree possible prior to
uploading the page to the server. Then check the actual download time after
the page goes online to determine whether additional file size reduction is
needed.

Monitoring links

After constructing your site and putting it on the Web, you can monitor its
currency by frequently ensuring that any external address links you set up
still work as intended. URLs change frequently, and you don’t want users to
click links that don’t open their intended destinations.

Setting your HTTP address

To assist Dreamweaver in checking link accuracy, you must provide the
actual URL for your site on the Web. Dreamweaver uses this information to
check whether links in your site refer to other pages in your site root or to
absolute addresses external to your site. Follow these steps to set your
HTTP address:

1. In Dreamweaver, choose Siter>Manage Sites from the main menu to
open the Manage Sites dialog box.

2. From the Site list, select the site you want to work on and click the
Edit button.

The Site Definition dialog box for your site opens.
3. Select the Local Info category.
4. In the HTTP Address box, enter the URL for your site.

This URL is the actual Web address for your site — for example,
http://www.yoursite.com.

5. Click OK to close the Site Definition dialog box.
6. Click Done to close the Manage Sites dialog box.
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Figure 9-5:
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Click to check the Enable Cache check box in the Local Info category of the
Site Definition dialog box. Enabling the cache causes file and assets informa-
tion to be maintained in the site, which helps speed up site management
tasks as you construct your site. You can rebuild the cache at any time by
choosing Siter>Advancedr>Recreate Site Cache from the main menu.

Updating links sitewide
The Dreamweaver Link Checker can tell you whether links in your site are

functioning properly. If you do find an incorrect link, you can update the link

throughout your site, whether it’s a URL or a link to one of your own pages.
To identify and update broken links, just follow this procedure:

1. If you're not already at the Site window, switch to it by opening a
Dreamweaver site file and choosing Window=>Files from the main
menu and clicking the Expand/Contract button.

If the Site Management toolbar doesn’t appear in the Files panel, choose
Siter>Manage Sites from the main menu. Then, in the Manage Sites
dialog box that appears, select the site whose links you want to check
and click Done. When the Site Management toolbar appears, click the
Expand/Contract button to display the Site window.

2. Choose Site>Check Links Sitewide from the Site window main menu.

A Results window similar to the one in Figure 9-5 appears, displaying

broken links in your site. If you don’t see the Results window, choose
Window=>Results from the Dreamweaver main menu and then choose
Siter>Check Links Sitewide from the Site window menu bar.
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3. Choose Siter>Change Link Sitewide from the Site window menu bar.

The Change Link Sitewide dialog box opens, where you can replace the
name of an old (broken) link with its new name.

4. In the Change All Links To box, enter the current URL or internal
page name or address you want to change.

5. In the Into Links To box, enter the URL or internal page of what you
want the links to change to.

6. Click OK.

Setting up meta tags

Your goal in putting a Web site online is probably to make a certain body of
information accessible to the public. Search engines can help users track
down your site, but you can improve the likelihood of search engines listing
your site by including special HTML code on your pages. This special code
is contained in metfa tags (tags defined using the <meta> keyword) and con-
sists of keywords and descriptions that you create to help search engines
match user queries with your Web pages. (For more information about meta
tags, see Book II, Chapter 1.)

Adding keyword <meta> tags
To set up keyword <meta> tags for a page, follow these steps:

1. In the Document window, choose Insert-> HTML->Head Tags->
Keywords from the main menu.
The Keywords dialog box appears.

2. In the Insert Keywords dialog box, enter individual words or phrases
that describe the content of your page, and separate the entries with
commas.

Search engines use these keywords to index the page.
3. Click OK.

The dialog box closes and inserts your entries into the <meta> keyword
tag in the HTML page code.

Adding a description <meta> tag
To set up a description <meta> tag for a page, follow these steps:

1. In the Document window, choose Insert->"HTML=>Head Tags->
Description from the main menu.

The Insert Description dialog box appears.
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2. At the Insert Description dialog box, enter a sentence or paragraph
that describes the content of your page.

Search engines use this description to index the page.
3. Click OK.

The dialog box closes and inserts your entry into the <meta> descrip-
tion tag and the HTML page code.
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Chapter 1: Adding Visual Appeal
with Graphics and Photos

In This Chapter

v Acquiring Web-friendly graphics and photos
v+ Optimizing your images for the Web
1+ Creating transparent images

v Using hotspots to create clickable images

LVell-chosen images can really make your Web site come alive. You can
use big images as background art, little images as buttons, complex
images as clickable splash pages — you get the idea.

Creating images for your Web pages isn’t really any more difficult than creat-
ing other images. You can draw, format, and tweak an image by using an
editing program, such as Paint Shop Pro (a copy of which you find on the
companion CD).

Not an artist, you say? All your attempts to create original images turn out
looking like squiggly lines? Not a problem! Using a combination of an editing
program and high-tech toys such as digital cameras and scanners, you can
transfer photos and existing artwork to your Web site. You can purchase art-
work for use in your Web endeavors, and if you're willing to spend a little
time hunting, you can even find Web-ready artwork for free.

This chapter gives you the lowdown on acquiring images for your Web site;
it also gives you some tips for optimizing those images so they load fast and
work well with other Web page elements.

Acquiring Web-Friendly Graphics and Photos

When finding images for your Web pages, you have three basic options:

4 Creating images from scratch: If you enjoy drawing, this is the option
for you! Using an image-editing program such as Flash (a copy of which
you find on the companion CD) or Photoshop, you can draw shapes and
images, color them, spice them up with text, and add special effects
(such as transparency and beveled borders) to your heart’s content.
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4+ Purchasing images: You can purchase images for the Web much as you

can purchase stock photos for offline purposes. Prices vary greatly, from
free (my favorite!) to hundreds of dollars and up. Some vendors sell
individual images; others offer packages containing thousands of
images. Some places to begin your image shopping: Barry’s ClipArt
Server (www.barrysclipart.com), Webspice (www.webspice.com),
and ClipArt (www.clipart.com).

According to copyright law (and just plain good sense), unless you
create an image, you don’t own that image — the creator does. The cre-
ator of an image may require you to pay a usage fee, ask you to use the
image in certain prescribed ways (for example, only on a personal site
and not on a commercial site), or both. Always make sure you under-
stand and agree to the image owner’s terms and conditions before using
any image.

Transforming existing art or photos into Web-ready images:
Depending on the type of existing images you have at your disposal,
you may be interested in one or both of the following options:

e Scanning line art and photos: Using a piece of hardware called a
scanner allows you to scan hard-copy photos, drawings, and images
and load them into an image-editing program, such as Paint Shop
Pro. After you scan and load an image into an image editing program,
you can modify it and save it in a Web-friendly format. Although
scanners and image-editing programs vary, the following basic steps
apply: Hook up a scanner to your computer and install a scanner
driver (a piece of software that comes with your scanner). Installing a
scanner driver tells your computer how to communicate with the
scanner. Then you load, or import, the scanned image into your
image-editing program. Most image-editing programs treat loading a
scanned image slightly differently than they treat loading an image
file located on your computer. For example, in Paint Shop Pro, you
choose Filer>Open to load an image file. To import a scanned image,
however, you choose FilecImport=>From Scanner or Camera.

¢ Importing digital photos: Most digital cameras come with software
and instructions for transferring digital photos to your computer. In
addition, many image-editing programs allow you (after your digital
camera is connected to your computer) to import a digital photo
directly. To import a digital photo into Paint Shop Pro, for example,
you choose Filer>Import=>From Scanner or Camera.

Optimizing Your Images for the Web

Whether you scan images from paper copies, import digital photos, or
create images from scratch using a drawing or image-editing program (such
as Adobe Photoshop, JASC Paint Shop Pro, or Microsoft Paint), you need to
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make sure you optimize images for the Web before you include them in your
Web pages. In the following sections, I present the three most important ways
to optimize images: saving your images in a Web-friendly format, reducing
image file size, and making sure your images contain Web-friendly colors.

Saving your images in a Web-friendly format

You can’t just put an image created in any old graphics file format on your
Web page — not if you want folks to see that image. To be seen in Web
browsers, your image files must be saved in one of the following three Web
formats: GIF, JPG, or PNG. Virtually all Web browsers support these formats.

To create images in GIF, JPG, or PNG formats, follow these steps:

1. Create an image (or load an existing image) into an image-editing pro-
gram, such as Paint Shop Pro.

2. In the program you use to work with the image, choose File=>Save As
(or File=Export or something similar) to save the image as a GIF, JPG,
or PNG image.

The Save As dialog box appears.

The GIF format is best suited for images that you created in an image
editor. Use the JPEG format for a digital photo than you’ve taken with a
digital camera or scanned into your computer.

3. Type a name and a location.

Make sure that the image type you select is GIF, JPG, or PNG and that
the location is the same as your HTML documents (for ease of linking).

4. Click Save.

The image-editing program saves your image file to your computer
using the format you chose in Step 3.

Reducing image file size

On the Web, file size is important. If your image files are massive, users

may not wait for them to download; in fact, users may get so tired of waiting
for your images to download that they surf off to some other site, never to
return. Keeping image file sizes as small as possible is one of the best ways
to ensure that users see your Web pages as you intend for your pages to be
seen.

The following techniques can help reduce image file size and make an
incredible difference in how fast your images load:

4+ Reduce color depth: Check your image-editing software for options,
such as Reduce Color Depth. For fairly simple graphics, reducing the
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Figure 1-1:
Image-
editing
programs,
such as
Paint Shop
Pro, offer a
color palette
tool you can
use to
choose the
colors of
your
images.

color depth to 16 colors, instead of 256 colors or millions of colors, can
make the image’s file size much smaller with little or no visible differ-
ence in the image quality.

4+ Use the JPG or PNG formats for photographs: These formats compress
photographs and complex images more effectively than the GIF format
does.

4+ Try compression: Programs that allow you to save files in GIF, JPG,
and PNG formats also usually offer a way for you to set compression
options. Experiment with the compression and increase compression
until you start to see a loss of quality; then back off a little.

Choosing Web-friendly image colors

When you create an image or when you modify an existing image to include
in your Web page, you need to be aware of how color works on the Web.

Good color choices are ones that look good in practically any browser and
operating system and display resolution configuration — that is, they show
up clearly, not splotchy or mottled. Unfortunately, color involves more than
meets the eye.

As you create or edit an image, you use a color palette tool, similar to the
one you see in Figure 1-1, to choose colors.
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As you’re choosing colors, keep in mind that not all colors are created equal.
Some colors don’t show up at all in readers’ browsers. If you choose a color
from the 16.7-million-color palette, for example, and your readers’ browsers
are set to only 256 colors, the color you choose may not show up crisp and
clear (unless it’s one of the 256). For that matter, even if you choose a color
from the 256-color palette, the color can show up splotchy (a condition tech-
nically called dithered) on many readers’ screens.

To figure out which colors to use, you should first know how colors are
described. For the Web, you specify colors with an RGB (Red-Green-Blue)
number. By using three numbers (either three decimal numbers or three
two-digit hexadecimal numbers), you can specify the amounts of red, green,
and blue to create any one of about 16.7 million colors. By mixing the levels
of RGB, you can create any color you want.

So which colors are best to use in HTML documents? Colors that are standard
across all platforms and that look good even at lower color resolutions. How
do you know which ones? Choose colors with the values from the tables in
the following sections. By using these values to choose colors (pick one
number from each column to create the RGB number), you stand the best
chance of having the colors show up clearly in just about any browser.

If your image-editing software uses hexadecimal numbers: The hexadeci-
mal numbering system (hex) provides you with the same values as the decimal
system does, but hex uses 16 digits instead of 10. The digits for hex are 0-9
and the letters A-F in place of the numbers 10-15. By using two hex digits
(##), you can specify a number between 0 (or 00 in hex) and 255 (FF in hex).

Table 1-1 shows values you can use if your image-editing software uses hexa-
decimal numbers. Use the following table as you would a Chinese restaurant
menu (one from column Red, one from column Green, and one from column
Blue) to choose six-digit color numbers.

You also use the hexadecimal numbers for specifying colors within your
HTML documents (for example, you’d specify the background color). For
more information on specifying background colors for a Web page, see Book I.

Table 1-1 Hexadecimal RGB Values for Web-Safe Colors
Red Green Blue

00 00 00

33 33 33

66 66 66

99 99 99

cC cC CC

FF FF FF
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If your image-editing software uses decimal numbers: Table 1-2 shows
values you can use if your image-editing software uses decimal RGB num-
bers to set colors. Again, think Chinese restaurant menu — take a number
from the Red column, then a number from the Green column, and the final
number from the Blue column.

Table 1-2 Decimal RGB Values for Web-Safe Colors
Red Green Blue

0 0 0

51 51 51

102 102 102

153 153 153

204 204 204

255 255 255

Creating Transparent Images

“NG‘
Q \! H

A transparent image is one in which the image’s background color doesn’t
show up — it’s replaced by the background color that’s visible in the
browser. Consider making your images transparent if the background is
likely to be a distraction or if the important part of your image is not rectan-
gular. Take a look at Figure 1-2, which shows an image with a regular back-
ground (at top) and the same image with a transparent background
(bottom).

Transparency is a cool technique — but it doesn’t work on most photos.
Why? Because most photos don’t contain clearly delineated blocks of color
and you need clearly designated blocks of color to create a transparent
image.

Many graphics or photo-editing software packages allow you to easily make
a background color transparent. If you don’t have image-editing software
and don’t want to invest in it, you can check out freeware and shareware
programs available on the Internet. Many of these programs offer menu
options for choosing the background color (that is, the color that disap-
pears in the browser).

To create transparent images, use a procedure similar to the following steps.
I demonstrate how to create a transparent image using Paint Shop Pro (a
copy of which you can find on the companion CD), but other image-editing
programs offer similar techniques.



Figure 1-2:
The
difference
between
regular and
transparent
images is
easy to see.
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Note: Before beginning, be sure that you have your image-editing software
open and ready to use.

Follow these steps:

1. Open an image in your graphics software program.
The image must have a uniform background color.
2. Choose FilecoExport=>GIF Optimizer from the main menu.

The GIF Optimizer window shown in Figure 1-3 appears. (Many pro-
grams have a similar option under one of the menus, but this option
varies from program to program.)

3. Click the Transparency tab.

Transparency options appear, along with a “before and after” preview of
your image.

4. Click the Areas That Match This Color radio button and select the
existing background color (the color you want to be transparent).

Using the color picker you find next to the radio button allows you to
find the color that matches the one you want to be transparent.

5. Click OK.
The Save As dialog box appears.
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Figure 1-3:
Most image-
editing
programs
offer options
you can

use to
designate a
transparent
background
color.

6. Type a name and a location and click Save.

At this point, you don’t see a change in the image background; you must
open the image in your browser to see the results of your hard work.

7. View the image in your browser just to make sure that the image
looks how you want it to look.

In your browser, choose Filer>Open or File>Open Page; select Show All
Files at the bottom of the dialog box that appears; find the image file
you want to view; and then click Open.
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An image map is a linked image, so visitors click an image or parts of an
image to go somewhere else online. The image map can provide a menu of
selections for your reader, just as a set of regular links can provide a menu.

Image maps are good for making spiffy-looking menus — that is, menus
arranged so that readers can click various parts of an image to link to differ-
ent information. Image maps are also good for making geographic-related
links (by letting people click the state or country of their choice) or for all
kinds of orientation or training applications (by allowing people to click to
get more information about whatever is pictured).
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Keep in mind that some people choose not to (or cannot) view images, so
image maps alone won’t always work for navigation. Be sure to include text-
based links to supplement your image map.

Including image maps in your HTML document is fairly easy. In the following
sections, I describe in detail the process for including image maps:
1. Adding an image to your HTML document.
2. Defining clickable areas (a process called mapping).
3. Defining the map — that is, specifying which image map areas link to

what information.

Table 1-3 shows the tags used to add an image map to an HTML document.

Table 1-3 Image Map Tags
HTML Tag or Attribute Effect Use in Pairs?
<IMG SRC="..."> Inserts an image. No
ISMAP Specifies that the image is No
a server-side clickable
image map.
USEMAP="fmapname" Identifies the picture as a No

client-side image map and
specifies a MAP to use for
acting on the readers’ clicks.

Note: Server-side image maps exist, but are not covered in this book. If you
must delve into server-side image maps, consult your system administrator.

The SRC="..." attribute still points to a valid URL (relative or absolute) for
your image. The remaining information points to an addition to the HTML
document. Remember that all the other valid <IMG> attributes also apply to
your image map.

Adding the image

The image you find or create to use in the image map should be as clear and
small as you can make it. Stick to a few colors and think simple. Although
your readers may be impressed with a graphical masterpiece the first time
they see it, they quickly tire of waiting for it to load each time they view
your page.

The image you see in Figure 1-4 illustrates some of the possibilities of image
maps. Clicking any of the shapes in Figure 1-4 — including the scanned
photo on the left-hand side of the page and all of the crossword-style menu
options on the right — opens a different link.
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To include an image in your Web page, follow these steps:

1. Include the image in your document, along with the descriptive text
you want to appear in non-image-supporting browsers, by adding the
following tags and text to your HTML document:

<HI1>Making Image Maps Can Be Fun!</H1>

<IMG ALT="This is a clickable map."
SRC="1imagemap.jpg">

The image above is an image map.<P>

2. Include the USEMAP attribute to tell the browser which map to apply
to the image.

The USEMAP attribute points to a map by name — demomap, as you see
in this example:

<H1>Making Image Maps Can Be Fun!</H1>

<IMG ALT="This is a clickable map."
SRC="imagemap.jpg" USEMAP="4{demomap">

The image above is an image map.<P>

Note: The i before demomap indicates that you're using a map within the
same document, just as the # in a <A> tag indicates a within-document link.

You just added the image into your document and indicated that it’s an
image map. You can’t see much of a difference through your browser — the




Figure 1-5:
At the
bottom
right-hand
side of the
screen,
you see
the
coordinates
(in this
case, 0,0)
displayed.
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image looks like any other image that’s a link in your document. You must
define the map before the hot spots work, as [ describe in the next section.

Mapping clickable areas

In mapping clickable areas, you divide the image into parts that eventually
link to other information and pages. Mapping is sort of like taking a picture
and carving it into individual pieces (like puzzle pieces) — each piece repre-
sents an individual area that you can then link to something else.

Many Web design programs allow you to map clickable areas on images with
point-and-click ease. To see how to map clickable areas using Dreamweaver,
take a peek at Book IV, Chapter 4 (you can find a trial version of this nifty
Web design program on the CD). If you prefer mapping clickable areas by
hand, as [ describe in this chapter, you can use an image-editing program,
such as Paint Shop Pro (also available on the companion CD).

Mapping your image isn’t too complicated. You basically just need to iden-
tify the coordinates of certain points in the image. All points or coordinates
are measured from the upper-left corner of the image, in x,y coordinates.
The point at the upper-left corner is 0,0 — zero pixels across by zero pixels
down. Figure 1-5 shows the cursor pointing at that spot. Notice that you can
see the coordinates (0,0) displayed at the lower right of the window.
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If you know how to map coordinates for three simple shapes — a circle, a rec-
tangle, and a triangle — you can map any shape in any image you want to use:

4+ Rectangular shapes require the upper-left and lower-right corners. The
computer figures out the rest.

4+ Circles require the center and the radius length. (Yes, you must do the
math to figure out the radius.)

4+ Polygons, such as the triangle, just require each corner. The computer
connects the dots to finish the figure.

You can represent any other shape by using some combination of the rec-
tangle, circle, and polygon. A sleeping cat, for example, can have a long rec-
tangle for the tail, a fatter one for the body, a circle for the head, and a
couple of triangles for the ears. Alternatively, you can just go point to point
to point on the cat and call it a fancy polygon.

Mapping a rectangle

To determine the coordinates that define a rectangle for use in an image
map, follow these steps:

1. Point the cursor at the upper-left corner of the rectangle and write the
x,y coordinates on a piece of paper — (38,65), as shown in Figure 1-6.

2. Point at the lower-right corner and write the x,y coordinates
(207,218), as shown in Figure 1-7.

To see how to use the coordinates you gathered to define a map for the
square, flip to the section “Defining the map,” later in this chapter.

Mapping a circle
To determine the coordinates of a circle for use in image maps, follow these
steps:

1. Point the cursor at the center of the circle and write down the x,y
coordinates that appear.

2. Move the cursor horizontally to the edge of the circle and note those
x,y coordinates.

3. Subtract the first x coordinate from the second one to get the radius
of the circle.

To see how to use the coordinates that you gathered to define a map for the
circle, check out the section “Defining the map,” later in this chapter.



Figure 1-6:
Begin by
writing
down

the x,y
coordinates
of the
upper-left
corner

of the
square —
in this case
(38,65).

Figure 1-7:
Next, write
down the
le
coordinates
of the
lower-right
corner
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square —
(207,218)

in this
example.
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Mapping a polygon
To determine the coordinates that define the triangle (or any other polygon)
for use in image maps, follow these steps:

1. Pick a corner, point the cursor at it, and note the x,y coordinates.

2. Move to the next corner and note those x,y coordinates.

3. Continue moving around the edge of the shape, noting the coordi-
nates of each corner.

Make sure that you mark the corners in order — the computer connects
the dots in the same order that you follow to figure out what the shape is.

To make mapping a polygon easier, you might try turning grids on in your
image-editing program. You turn on grids by choosing Viewr>Grid (or some-
thing similar, depending on the image-editing program you use).

Don’t lose the piece of paper with your notes. You need it to define your
map, which [ describe in the next section.

Defining the map

Defining the map simply tells the computer which areas readers may click and
what link to follow after they click. The process looks more complex than it
really is. Table 1-4 shows the tags and attributes used to define the map.

Table 1-4 Tags and Attributes for Defining an Image Map
HTML Tag or Attribute Effect Use in Pairs?
<MAP>...</MAP> Specifies a collection of Yes
hot spots for a client-side
image map.
NAME="..." Gives the MAP a name so No
that it can be referred to later.
<AREA> Specifies the shape of a hot No
spotin a client-side image
map.
COORDS="x1,y1,xZ2, Specifies coordinates that No
yZ, " define the hot spot's shape.
HREF="URL" Specifies the destination of No
the hot spot.
NOHREF Indicates that clicks in No

this region should cause
no action.
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HTML Tag or Attribute Effect Use in Pairs? Book V
Chapter 1
SHAPE="..." Specifies type of shape as No
RECT (for rectangle), 0
CIRC (for circle), or = >
POLY (for polygon). Zs =
1
Qe
2s=
The <MAP> beginning and end tags tell the browser which areas in your = i @
image link to which URLs. The following block of code shows you how to g =
include a map definition in your document along with the image map. You a

start with an HTML file similar to the following:

<IDOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Frameset//EN"
"http://www.w3.0rg/TR/html14/frameset.dtd">

<HTML>

<HEAD>

<TITLE>Making Image Maps</TITLE>

</HEAD>

<BODY>

<HI>Making Image Maps Can Be Fun!</H1>

<IMG ALT="This is a clickable map."
SRC="imagemap.jpg" USEMAP="4{demomap"><P>

The image above is an image map.<P>

</BODY>

</HTML>

To include a map definition in your document along with the image map,
follow these steps:

1. Include the <MAP> tags in your document, as shown in the following
block of code:

<IMG ALT="This is a clickable map."
SRC="imagemap.jpg" USEMAP="{demomap"><P>

The image above is an image map.<P>

<MAP>

</MAP>

</BODY>

</HTML>

2. Add the NAME attribute to the <MAP> tag, as the following block of
code shows.

Note: The map is called demomap.

<IMG ALT="This is a clickable map."
SRC="1imagemap.jpg" USEMAP="Jfdemomap"><P>

The image above is an image map.<P>

<MAP NAME="demomap">
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</MAP>
</BODY>
</HTML>

3. Add an <AREA> tag between the <MAP> tags, as follows.

You eventually have one <AREA> tag for each clickable area in your map,
but the following examples build them one at a time.

<IMG ALT="This is a clickable map."
SRC="imagemap.jpg" USEMAP="{demomap"><P>

The image above is an image map.<P>

<MAP NAME="demomap">

<AREA>

</MAP>

4. Add a SHAPE attribute to the <AREA> tag, as follows.

I'm starting with SHAPE="RECT" because the square (rectangle) is the
easiest one to do. Other valid SHAPE values include CIRCLE and POLY.

<IMG ALT="This is a clickable map."
SRC="1imagemap.jpg" USEMAP="jfdemomap"><P>

The image above is an image map.<P>

<MAP NAME="demomap">

<AREA SHAPE="RECT">

</MAP>

5. Add the COORDS attribute to the <AREA> tag, as shown in the following
block of code.

The coordinates for this square are 208,75 for the upper-left corner and
345,197 for the lower-right corner.

<IMG ALT="This is a clickable map."
SRC="1imagemap.jpg" USEMAP="Jfdemomap"><P>

The image above is an image map.<P>

<MAP NAME="demomap">

<AREA SHAPE="RECT" COORDS="208,75,345,197">

</MAP>

Note: Don’t include spaces between the coordinates.
6. Add the HREF attribute to the <AREA> tag, as follows.

You can use any valid URL for your client-side image map.

<IMG ALT="This is a clickable map."
SRC="imagemap.jpg" USEMAP="{demomap"><P>

The image above is an image map.<P>

<MAP NAME="demomap">

<AREA SHAPE="RECT" COORDS="208,75,345,197"
HREF="/shapes/square.htm">

</MAP>
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7. Add more <AREA> tags as necessary.

Make sure that you include the correct SHAPE and COORDS attributes for
each tag.
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Chapter 2: Creating Media Files
and Putting Them on Vour Site

In This Chapter

v+ Understanding the difference between downloadable and
streaming media

1 Creating streaming and downloadable (MP3) audio files
v Adding video files to your site
v Creating animated effects

+* Adding media files to your Web pages

ereas text and images can convey an amazing amount of informa-
tion, well-chosen multimedia effects — such as audio, video, and

animations — can entertain and inform your visitors in a way that plain-
vanilla text and images can’t. This chapter introduces you to the two main
options you have when creating multimedia files — namely, streaming and
downloadable — and shows you how to create both types. You also find tips
for creating animated effects, as well as for adding audio, video, and anima-
tion files to your Web pages.

The Difference between Downloadable
and Streaming Media

You can create two types of audio and video files:

4 Streaming media files: A streaming media file, such as an audio file cre-
ated using the RealAudio file format, begins to play immediately. The
good news is that users don’t have to wait for the entire streaming
media file to download before they can begin listening. The bad news is
that a slow modem connection can interrupt the streaming file transfer
and make the listening experience less than perfect.

4+ Downloadable media files: Downloadable media files, such as MP3
audio files, sound just as their producers intend because playback isn’t
affected by modem connection speed. Unfortunately, users must down-
load a downloadable media file in its entirety before they can begin
playing it — and if the file is very large, users may have to wait awhile
for the download to complete.
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No matter which option you choose — streaming or downloadable — users
must install special software players on their computers to enjoy your multi-
media masterpieces.

Take a look at Tables 2-1 and 2-2 for an explanation of the most popular
streaming and downloadable audio and video file formats, as well as their
associated players.

® Most media players are free, and many “plug in” to Web browsers easily, so
installing media players isn’t difficult for most folks. To make viewing your
multimedia files even easier for your visitors, however, consider adding a
link from your multimedia-laden Web page to a site on the Internet where
users can download and install the appropriate player.

Table 2-1 Popular Web Audio Formats

Audio File Extensions Common Use Streaming/
Format Downloadable
AIFF .aif, .aiff Uncompressed files can Downloadable

be played in browsers
but are slow to download.

Flash audio .swf Audio-only files can stream  Streaming
PCM or MP3-compressed
audio.
MIDI .mid, .midi, Music files saved in the Downloadable
.smf MIDI format. Plays in MIDI

players (which aren’t well-
standardized on the Web).

MP3 .mp3, .mp2 High-quality, compressed Downloadable
files with relatively speedy
download times. Plays in
numerous players, including
QuickTime Player, RealOne
Player, Windows Media
Player, and others that
act as browser helper
applications.

QuickTime .mov Soundtrack-only Downloadable
QuickTime movies.
Plays in the QuickTime
Player.

RealAudio .ra, .ram Audio-only files in the Streaming
streaming RealMedia
format. Plays in RealOne
Player.

Rich Music .rmf Hybrid audio/music format. Downloadable
Format Plays in the Beatnik player.
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Audio File Extensions Common Use Streaming/
Format Downloadable
Shockwave .swa Audio-only Shockwave Downloadable
Audio files that can be played
by any MP3 player.
WAV wav Uncompressed files can Downloadable
be played in browsers
but are slow to download.
Windows .asf, .asx The Microsoft streaming Downloadable
Media media format. Plays in the

Windows Media Player.

As you skim through Tables 2-1 and 2-2, notice that the file extension indi-
cates the format in which you save the clip. For example, song. ra indicates

a RealAudio clip; video.mov indicates a QuickTime clip.

Table 2-2

Popular Web Video Formats

Video File
Format

Extensions

Streaming/
Downloadable

Common Use

MPEG

-mpg,
.mpe

.mpeg,

High-quality, compressed Downloadable
files that play in Windows
Media Player and on

Macintosh via QuickTime.

QuickTime

.mov

QuickTime movies that Downloadable
play in the QuickTime

Player on both Windows

and Macintosh systems.

Can include video and

audio or just video.

RealVideo

.ra,

.ram

Files in the RealMedia
format. Plays in RealOne
Player. Can include video
and audio or just video.

Streaming

Video for
Windows

.avi

Once-popular format is Downloadable
becoming less prevalent

but still plays in most players.

Creating Streaming Audio Files

RealNetworks’ RealAudio file format is the most popular choice for creating
streaming audio files. In this section, I show you how to create audio files in

RealAudio format using Helix Producer Basic 9.

Book V
Chapter 2

8)IS INOA Uo way|
Buming pue sajiy
eipajy buneary



388 Creating Streaming Audio Files

\\3

Figure 2-1:
You can
create
streaming
audio files
using Helix
Producer
Basic.

You can download and install your own (free) copy of Helix Producer Basic
from RealNetworks at www.realnetworks.com/products/producer/
basic.html.

To create a streaming audio file, follow these steps:

1. Start Helix Producer Basic 9, either by clicking the Helix Producer
Basic 9 icon on your desktop or by choosing Start~>All Programs~
Helix Producer Basic 9.

The Helix Producer Basic window, shown in Figure 2-1, appears.
2. Choose the Input File option on the left.

The Input File option enables you to create a streaming audio file from
another type of audio file — for example, a .wav file — you already have
stored on your computer.

You can choose the Devices option instead if you want to record a
streaming audio file by speaking or singing into a microphone, or by
recording an audio CD. (Before you choose this option, make sure that
your microphone or CD player is already hooked up to your computer.)
This option is rarely used, however, and beyond the scope of this book.
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You use

a fully
qualified
filename to
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format.

Creating Streaming Audio Files

Select Help from the main menu at any time when using Helix Producer
Basic to access commonly asked questions, product documentation,
and online technical help.

hd

Clicking the Browse button on the left-hand side of the screen in Figure
2-1 displays a Select Input File screen that you can use to locate audio
files stored on your computer.

Figure 2-2 shows you an example of a fully qualified audio filename (a
fully qualified name is one that shows the full path to the file).

Notice that when you specify an input filename, Helix Producer Basic
automatically generates the name for the soon-to-be-converted stream-
ing audio file based on the name of the file you select. (For example, on
the right in Figure 2-2, you can find the automatically generated name
song_clip.rmunder the Destination heading.)

4. If you want to change the automatically generated name for the
streaming audio file, right-click the generated name and select Edit
Destination from the pop-up menu that appears.

389

Specify the audio file you want to convert to streaming audio format.
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390 Creating Streaming Audio Files

5. Click the Clip Information button.
The Clip Information window, shown in Figure 2-3, appears.

6. Enter the values you want to associate with this media file’s Title,
Author, Copyright, Keywords, Description, and Rating designations.

When you finish entering clip information, close the Clip Information
window by clicking the Close (X) button in the upper right.

7. Click the Encode button at the bottom of the Helix Producer Basic
window.

This prompts Helix Producer Basic to covert the existing audio file to
streaming audio format. When the conversion is done, you see a status
of Complete on the right side of the Helix Producer Basic main panel, as
shown in Figure 2-4.

P If Helix Producer Basic encounters any problems during the conversion
process, an error message appears at the bottom of the Helix Producer
Basic window. You can view a detailed description of the errors encoun-
tered by choosing View=>Show Log Viewer from the main menu.

8. To listen to your newly recorded streaming audio clip, click the Play
button on the right (under the Destination and Status info).
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To play RealAudio files, you must first download and install a player that
supports RealAudio, such as RealOne Free Player 2.0. You can download a
free copy of RealOne Free Player 2.0 at www.real.com.

Creating Downloadable Audio Files

A\

Downloadable audio files are audio files that listeners must download com-
pletely (from your Web site to their computers) before playing. Although
many different types of downloadable audio files exist (refer to Table 2-1),
by far the most popular format of downloadable audio file on the Web is a
format called MP3. This section describes how to create MP3 audio files for
your Web pages.

Many software programs exist that you can use to create downloadable
audio files. In this section, | demonstrate using Audio Catalyst 2.1, from
RealNetworks, to create an MP3 file from an audio CD. You can download
your own free copy of Audio Catalyst 2.1 from www.xingtech.com/mp3/
audiocatalyst/index.html?src=xingtech-home.

To create an MP3 file by using Audio Catalyst 2.1, follow these steps.
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392 Creating Downloadable Audio Files

1. Load the audio CD from which you want to create an MP3 file into the

CD drive attached to your computer.

QUING/ Virtually all commercial audio media, such as CDs, record albums,
y . . .

8 tapes, and encoded files, are copyrighted, meaning that unless you ask
for permission, you can legally copy them only for your own personal
use. Of course, putting a song on your personal Web site for all to down-
load does not fall under personal use. For more information on U.S.
copyright law (including guidelines for incorporating multimedia into
your Web pages), visit www.1oc.gov/copyright.

2. Start Audio Catalyst, either by clicking the Audio Catalyst icon on
your desktop or by choosing Start->All Programs->Audio Catalyst.
The Audio Catalyst interface, shown in Figure 2-5, appears. Audio
Catalyst automatically displays artist, album, and track information for
the CD you inserted into your CD drive in Step 1.
@@ AudioCatalyst [=]=] =]
_File cD Seuings He_lp
SO e b AP XL
Refissh Giabl I MNom W MP3 CDDE  Flayer Kingweb Abum [ToaTee
Track name | Time Filzsize | Infamation ]
M TokTes 0610 E226Mb
Eighty Ore 0543 G783 Mb
People Make The Ward .. 0722 7449 Mb
Figure 2-5: Besams Mucha 11:06 112_-10 b
a, | S, m= um
album. and y 0622 B432Mb
track
information
appear
when you
put an audio
CD inyour — —
CD drive. 73 : : RS —1
7 Tiacks. Plaptime: 4326 Totaltime lef: OO0S:30 = 11 W ¥ &« b [ 0 P \B /
3. Select the CD audio track you want to convert to MP3 format.
In the example you see in Figure 2-5, the first track, To A Tee, is selected.
Vg‘“\NG" The free version of Audio Catalyst 2.1 that I demonstrate in this section

only allows you to select some — not all — of the tracks on an audio
CD. To purchase a full-featured version, visit www.xingtech.com/mp3/
audiocatalyst/index.html?src=xingtech-home.

4. Click the Grab! button.
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Audio Catalyst automatically begins converting (also referred to as rip-
ping), the track you selected in Step 3 to MP3 file format. In addition, a
Sampling window similar to the one you see in Figure 2-6 appears.

A\\S
Choose Settings=>General from the Audio Catalyst main menu to change
where Audio Catalyst stores your newly created MP3 files.
When the grabbing process is complete, you see a Copied 0K message in
the Information column of the AudioCatalyst window (refer to Figure 2-5).

Fi 2.6 @s pling Clay Moore -To A Tee =[S ]

igure 2-5: Disc vite: 516 Mbytes Used CPU fime [Anslca Copy)

The e 52,26 Mgtes = Encg;gllﬂg

Sampling g st S ot 0 ) v (

window A N

presents Lo Current €D red speed: 1.00x xing

conversion Tirne laft 53 8%

statistics Mormaization is not selected.

U85 | sk otons T =

e apse Time elapzed: (00

time) as it Tineleft 000 o

converts the MP3 C jon: 128 Khbit, Stesen [loint steren)

file to MP3 | fine sapued cu0

format. Time left.  00:20 LE Abart al

“&N\BEB To listen to an MP3 file, you must have an MP3 player installed on your

& computer. If you installed the MP3 player that comes bundled with Audio

Catalyst, you can listen to your newly created MP3 file by choosing
Settings->MP3 Playback from the Audio Catalyst main menu.

Creating Uideo Files for Your Web Pages

Video clips can add interest to your page by providing a television-like feel
for the user. Because creating effective video is both art and science (heck,
universities offer degrees in creating video), [ don’t discuss the soup-to-nuts
video creation process in detail here. Instead, [ cover how to convert an
existing video clip into a streaming, Web-friendly video clip using the
RealVideo format developed by RealNetworks.

Keep in mind that you can choose from many other options when creating
video for your Web pages. For example, you can choose another video format,
such as Microsoft’s Windows Media Encoder 9 Series (www.microsoft.com/
windows/windowsmedia/create/video.aspx) or Apple’s QuickTime
(developer.apple.com/quicktime). Or you can choose a video
creation/editing tool, such as Adobe Premiere Pro, that enables you to save
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3 94 Creating Video Files for Your Web Pages

your video file in any format you like. Whichever approach you take, the
guidelines that follow help you figure out how to incorporate video clips
into your Web pages quickly and easily.

Gathering the hardware and software you need

To create a video clip for your Web page, you must have all of the following:

4+ A video capture card: Most PCs come with a video card, but that’s not
the same as a video capture card. A video capture card is a piece of hard-
ware that fits into your computer, acting as a kind of adapter you use to
hook up your computer to a video input device such as a video cassette
recorder (VCR) or digital camera.

Chances are, you have to purchase a video capture card. Mac owners
rejoice: Many Mac computers do come complete with a video capture
card. To find out whether you already have a video capture card, turn
your computer around and look for a little round hole next to the words
Video In. If you find this Video In port, you're in luck! If not, you must
purchase and install a video capture card.

4+ A video source device: If you want to shoot your own video, you need
avideo camera. (You can create video for the Web by using any video
camera, from a modest consumer model to a high-end professional digi-
tal video camera.) Alternatively, you can create video clips for your Web
pages by converting prerecorded videotapes into Web-friendly
formats — in which case, you need a VCR.

4+ Cables: You need to use video and audio cables to connect the video
and audio ports of your source device (for example, a digital camera or
a VCR) to the corresponding video and audio ports on your computer.

4+ A powerful computer: Creating and editing video files requires a power-
ful processor, as well as lots of memory and disk space. Although the
exact requirements depend on the video capture card and video cre-
ation and editing software you choose, at a minimum you want to invest
in a Pentium Il 800 MHz with at least 256MB RAM running Windows XP,
or a PowerMac G4.

4 Video capturing and editing software: If you plan to create sophisti-
cated video clips from scratch, you may want to invest in a full-featured
video capturing and editing tool such as Adobe Premiere Pro (www .
adobe.com/products/premiere) or Apple’s Final Cut Express (www .
apple.com/finalcutexpress/). Most video capturing and editing
tools — including the two I mention — let you choose among several
Web-friendly formats when it comes time to save your video file.

On the other hand, if all you want to do is convert a few seconds of that
videotape of your daughter’s first birthday party into digital format for
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presentation on your personal Web site, you may be able to get by with
a free tool, such as Helix Producer Basic or the Apple iMovie.

Virtually all commercial videotapes are copyrighted, which means that if
you convert them to digital format and make them available from your Web
site, you may be running afoul of the law. When in doubt, check with the
copyright owner of the videotape you want to convert.

Converting a video file to ReallVideo format

To create a streaming video file from an existing digital video file, follow
these steps:

1. With Helix Producer Basic 9 open, select the Input File option (refer
to Figure 2-1).

When you select the Input File option, the Browse button you see on the
right-hand side of the Input panel is enabled.

2. Specify the video file you want to convert to RealVideo format.

You can either type in a fully qualified filename in the text field next to
Input File or click the Browse button to locate audio files stored on your
computer.

Helix Producer Basic automatically generates a name for the streaming
file in the Destination area.

3. To change the automatically generated name, right-click it and select
Edit Destination from the pop-up menu that appears.

4. Click the Encode button at the bottom of the main window.

When Helix Producer Basic finishes converting the existing audio file to
streaming audio format, you see a status of Complete on the right-hand
side of the Helix Producer Basic main panel.

If Helix Producer Basic encounters any problems converting your exist-
ing video file, an error message appears at the bottom of the Helix
Producer Basic window. You can view a detailed description of the
errors encountered by choosing Viewr>Show Log Viewer from the main
menu.

5. To view the successfully encoded video clip, click the Play button
(refer to Figure 2-4).

To play RealVideo files, you must first download and install a RealMedia
player, such as RealOne Free Player 2.0. You can download a free copy
of RealOne Free Player 2.0 at www.real.com.
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396 Creating an Animated Effect

Shooting video for the Web

For the best results, keep the following tips in
mind when shooting video for the Web:

tiny video clip you end up putting on the
Web. If the time and date are important,

s~ Minimize camera movement Panning, tilt- consider adding this information to the Web

ing, and dollying (moving the camera side-
ways, up and down, and walking around
with the camera) all add color and motion
to the background, which makes the fin-
ished clip appear jerky when viewed on the
Web. If you absolutely must move the
camera, do so slowly and smoothly.

page where you link to the video clip.

Invest in an external microphone: Video
experts know that good video depends
on good audio — and good-quality audio
is especially important when creating video
for the Web, because converting the audio
portion of a video to a Web-friendly format

compresses and degrades audio. External
microphones usually produce better quality
sound than the microphones built into
cameras.

v~ Zoom in close: Because your finished video
clip will appear in a relatively small frame
on your Web site, close-ups work better
than long shots.

v+~ Don't include a time/date stamp: A time/
date stamp will be unreadable in the teeny-

Creating an Animated Effect

You create animated effects, or animations, by displaying a series of pictures
(sometimes called frames) one after another to simulate movement. Two of
the most popular forms of animated effects for Web pages are banner ads
(animated advertisements you see on commercial Web sites) and slide
shows.

On a technical level, the process for creating animated effects is the oppo-
site of creating video. To create animated effects, you take discrete images
and put them together to create the illusion of continuous motion; to create
video, you begin with continuous motion and then break it up into discrete
images.

You can use any of a variety of animation tools to create animated effects for
your Web pages. Flash (the focus of Book VII) is one of the most popular.
Some image editors, such as Paint Shop Pro and Photoshop, include the
ability to create GIF animations as well. Some developers even create anima-
tions using a made-for-the-Web programming language such as JavaScript
(Book VI) or Java (introduced in Book V).




Figure 2-7:
The Jasc
Animation
Shop main
window.
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You can find trial copies of Flash, Dreamweaver, and Paint Shop Pro on the
companion CD.

In the following steps, I demonstrate how to use Jasc Animation Shop, which
is included with Paint Shop Pro 8, to create a simple animated GIF file that is
as easy to incorporate into your Web pages as a regular image:

1. Create or find the images you want to string together to create your
animated effect.

To create a simple on/off animation, you need two images; to create a
slide show or more complex animated effect, you may use two, three, or
even dozens more.

Two sample images, neutral.gif and surprised.gif, are located on
the companion CD. For more information on creating (and finding)
images for use in your animated effects, check out Book V, Chapter 1.

2. Start Animation Shop by choosing Start=>Programst>Jasc Softwarer>
Animation Shop 3.

The Jasc Animation Shop main window appears, as shown in Figure 2-7.

Animation Wizard icon
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398 Creating an Animated Effect

3. Choose File=>Animation Wizard from the Jasc Animation Shop main
menu or, alternatively, click the animation wizard icon on the far left
of the toolbar.

The Animation Wizard dialog box, shown in Figure 2-8, appears.

‘wihat do pou want the tatal dimensions of
the: new animation bo be?

Figure 2-8:
Set the size
for your

animation. gt [ Hews | Cancel Hel

4. To create an animated effect the same size as your first image, click
Same Size As the First Image Frame; to create a custom-size anima-
tion, click As Defined Here and then specify values for Width and
Height describing the dimensions of your custom-size animation.
When you finish, click Next.

In the example [ use throughout these steps, | demonstrate selecting the
first option.

5. In the next window that appears (see Figure 2-9), select a default
canvas color for your animated effect and then click Next.

‘wihat do pou want lo 521 as the defaull
canvas coloe for the animalion?

1~ Transpaient
Figure 2-9:
Selecta
background
for your
animated

eﬁ:ect < Back I Heut > |:I Cancel Heb
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The options are Transparent (for a see-through background) and Book V
Opaque (for a colored background). If you choose Opaque, you can Chapter 2
click the color swatch you see next to the Opaque radio button to select
the color background you want. Choosing Transparent creates a trans-
parent (see-through) background.

6. In the next window (see Figure 2-10), specify where you want your
images to appear in the finished animated effect by selecting either
Upper Left Corner of the Frame or Centered in the Frame.
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7. In the same window, specify how you want to fill blank portions of
the animation frames to appear and then click Next.

You can choose either With the Canvas Color or With the Preceding
Frame’s Contents. If you want to scale the animation frames to fit your
images (rather than crop the images), select Scale Frames to Fit.

8. In the next window (Figure 2-11), specify how many times you want
the animated effect to repeat, or loop; then specify how long you
want each image to appear onscreen before being replaced by the
next. When you finish, click Next.

5 ource images which have an aspact ratio
different from that of the anmation will need
. I be positioned wathin the frame duting
F|gu|'e 2-10: construction. \where wilkin the animation
. frame should such images be located?
Specify
where (and Eer
‘wihen the image occupies only & pait of the:
_hOW) your. Irame, how should the rest be filed?
images will & Wihihe canvas colr
appear in " \th the preceding rame's contents
the finished I~ Seale fames tofi
animated
effect. ¢ Back | ﬂent),: I Cancel Help
a1

9. In the next window (Figure 2-12), click the Add Image button to add
as many images as you want to the animated effect. Then click Next.

The final Animation Wizard screen appears.
10. Click the Finish button.
The Animation Wizard creates your animated effect.

11. Choose View=>Animation or click the View button (which looks like a
strip of film and is on the Animation Shop main toolbar) to view the
animated effect.
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Figure 2-11:

Specify
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Figure 2-12:

Add images adinson 1 hiniye In

to your Remove Imags Move Down

animated

effect. <Back [ Mews | Cancel Hep

12. Choose Filer>Save to save the animated effect.
The Save As dialog box appears.

13. Enter a filename, select a file format from the Save As Type drop-
down box, and click Save.

The Animation Quality Versus Output Size window, shown in Figure 2-13,
appears.

14. Drag the bar shown in Figure 2-13 according to whether you want the
best quality animation possible (the top of the bar) or the smallest
possible file size (the bottom of the bar). Then click Next.

The Optimization Progress dialog box appears.
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15. Click Next to continue.
The Optimization Preview dialog box appears.
16. Click Next to continue.
The Optimization Results dialog box appears.
17. Click Finish.
Animation Shop saves the animation to the filename and directory you
specified in Step 13.
A\

To create a banner ad quickly and easily in Jasc Animation Shop, choose
FilecoBanner Wizard. (A banner ad is a standard-sized animated effect that
typically incorporates text with motion.)

Editing your animated effect

You can add any of several visual effects to your animated effect. In this sec-
tion, I demonstrate using Jasc Animation Shop to add visual effects to your
animations, but most animation software offers these same three basic
types of effects:

4 Stretching or rotating individual images in your animation: Choose
Effects=>Insert Image Effect and select any of the effects you see in the
Effect drop-down box that appears in the Insert Image Effect dialog box.
You see a preview of the effect in the Effect section of the Insert Image
Effect dialog box.

Click OK after you finish. Then choose Effects>Apply Image Effect to
apply the effect to your animation file. To view your handiwork, choose
Viewr>Animation.
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4+ Wiping or dissolving the transitions between individual images:
Choose EffectseoInsert Image Transition to display the Insert Image
Transition window. Select a transition effect from the Effect drop-down
box to preview the effect in the Transition area of the Insert Image
Transition window.

Click OK after you finish. Then choose Effects>Apply Image Effect to
apply the effect to your animation file. To view your handiwork, choose
Viewr>Animation.

4 Putting text in your animation: Choose Effectse>Insert Text Effect. Type
the text you want to add to your animation in the Define Text field and
select any of the effects you see in the Effect drop-down box that
appears in the Insert Text Effect dialog box. You see a preview of the
effect in the Effect section of the Insert Text Effect dialog box.

Click OK after you finish. Then choose Effects>Apply Text Effect to
apply the effect to your animation file. To view your handiwork, choose
Viewr>Animation.

Optimizing your animated effect

Depending on the number of images and effects you add to your animation,
you may end up with a very large file. Because keeping file size to a minimum
is important on the Web, you may want to optimize your animation file — that
is, choose to tweak the quality of the effect in order to reduce the file size.

Saving an animation file in Animation Shop automatically optimizes the
saved file. To optimize an existing file (one you created with another pro-
gram, perhaps, or got from a friend), choose File>Optimization Wizard and
follow the steps in the wizard.

Finding Media Files

If you want to add audio, video, or animated effects to your Web pages but
don’t want to create them yourself, you may find what you want online.
Many sources of stock media files exist on the Web. Most charge a fee,
although some offer free samples. Here are a few places to begin your online
search for the perfect media file:

4+ Eyewire (www.eyewire.com): Illustrations, photos, clip art audio, and
video

4 Media Builder’s Animation Factory (www.animfactory.com): Free and
fee graphics and animations

<+

ArtBeats (www.artbeats.com): Video clips and still images

4+ Yahoo! Multimedia Guide (dir.yahoo.com/Computers_and_
Internet/multimedia): Directory listing includes links to graphics,
audio, video, animations, and more
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Adding Media Files to Vour Web Page

SMBER
>

When it comes to adding media files to your Web pages, you have two
options. You can add a link to your media file, or you can embed your media
file directly into your Web pages.

As you may know if you've had a chance to peruse Book I, Chapter 6, you
must upload any file you want to make available for download over the Web
to a special kind of computer called a Web server. To make audio and video
clips available for download, you must upload your audio and video files to
a Web server that supports audio and video. For example, if you want to
include an audio file formatted in RealAudio format to your Web page, you
must upload all your Web pages — including your RealAudio file — to a Web
server that supports RealAudio. For more information on storing your Web
site files on a Web server, take a look at Book I, Chapter 6.

Adding a link to a media file

A simple and relatively trouble-free way to include audio, video, and anima-
tions on a Web page is to link the page to the media file. Users can select the
link if they want to hear or view the clip (and not be forced to endure the
clip if they’re not in the mood). This selection opens a player outside the
browser where the user can control the playback of the file.

To create a link to a media file, you use the HTML <A> beginning and end
tags as follows:

<A HREF="http://www.mySite.com/mySong.ram">Click here to
lTisten to my song</A>

The preceding HTML code creates a link to the streaming audio RealAudio
file mySong. ram file located on a RealAudio-supporting Web server at
www.mySite.com.

As you may know if you’ve read through the section “Creating Streaming
Audio Files,” earlier in this chapter, RealAudio audio filenames contain the

. rm extension. However, to create a link to a RealAudio file, you must link to
a . ram file. Files with . ram extensions are simple text files, containing the
fully qualified name of a streaming presentation on a Web server, which pass
the . rm file to the RealAudio player when a user clicks the link. For more
information on Real file formats, take a look at the sidebar, “RealMedia file
formats,” later in this chapter.

For more information on linking in HTML, check out Book II, Chapter 3.

Book V
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RealMedia file formats

In this chapter, you see examples of creating they span audio, video, audio-plus-video, and
audio and video files using tools from animation, they can be confusing. Here's a
RealNetworks. The file formats created by quick rundown of the formats you work with in
RealNetworks are very popular; but because  RealMedia:

RealMedia File Format Extensions Function
Audio, video, animation files .rm, .ra, .rp, Media file saved in the format required
.rt, .swf for RealOne Player playback
Metafile for linked media .ram The file that launches the independent
RealOne Player
Metafile for embedded media .rpm The file that launches the RealOne
Player plugin

a\\S

Embedding a media file

Another option for adding a media file to your Web page is to embed the
playback controls directly into the page. (You can also embed invisible play-
back controls into a Web page. Doing so lets you create a Web page with
background sound or movement that plays automatically.)

You use either the HTML <OBJECT> or <EMBED> tags to embed a media file
into a Web page. Because the attributes you must specify for the <OBJECT>
and <EMBED> tags are fairly lengthy, complex, and closely tied to the specific
media player you expect your site visitors to use, the best way to embed a
streaming media file into your Web page is to let the media file creation tool
you use generate the HTML code for you. For details on embedding media
files into your Web pages using Dreamweaver, for example, see Book IV,
Chapter 5.

Animated GIFs (such as the one I demonstrate how to create in the section
“Creating an Animated Effect,” earlier in this chapter) are exceptions to the
rule when it comes to embedding. Instead of using the <OBJECT> or
<EMBED> tags, you use the <IMG> tag to embed an animated GIF in your Web
page. For more information on using the <IMG> tag, see Book I, Chapter 4.




Chapter 3: Spicing Up Vour
Site with Java Applets

In This Chapter

v Using Java-related HTML syntax
+» Understanding applet security

ava applets are special, self-contained applications that you embed
inside Web pages. Some popular applets display fancy pop-up menus;
others add interactive games and animated effects.

When users download a Web page that contains a Java applet, that applet is
loaded onto their machines right along with the HTML code for the Web
page. Java applets execute locally, right inside users’ Web browsers. (Both
Internet Explorer and Netscape Navigator provide support for running Java

applets.)

Although you can create your own Java applications using a Java develop-
ment toolkit, applet development is both challenging and outside the scope
of this book. (If you're interested in creating your own Java applets, you may
want to check out Java 2 For Dummies or Beginning Programming with Java
For Dummies, both by Barry Burd.) More likely, however, you want to pur-
chase a Java applet — or find a free applet on one of the many Web sites
devoted to Java applet exchange — and add that applet to your Web site
using the HTML code snippets you find in this chapter.

In this chapter, | introduce you to the basic stuff you need to know to work
with applets: specifically, how to find Java applets to put on your site and
how to incorporate those applets into your Web pages using HTML tags.
Because security is an important part of any Web-based development effort
(including working with Java applets), I also give you the lowdown on Java
security. Although creating your own applets is beyond the scope of this
book, this chapter does whet your appetite with some bare-bones informa-
tion that can help you start taking your applet skills to the next level.
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Finding Applets

You can find a variety of Java applets on the Web. Some are free; others, you
must pay for. To start you off on your hunt for the perfect applet, here are a
handful of popular sites that offer Java applets:

4+ JPowered (Wwww. jpowered. com): Navigation and menu components,
graph and charting applets, and more.

4+ Java Boutique (http://javaboutique.internet.com): This devel-
oper community offers free applets appropriate for personal Web sites,
such as banners, text animators, calculators, and games.

4+ Applet Collection (www.appletcollection.com): This site offers a
collection of text-related applets as vertical scrolling, typewriter, and
dissolving effects.

Inserting Applets into HTML: An Overview

After you have the applet you want to use, all you have to do is insert it into
your Web page. You do this using one of two HTML tags: the <APPLET> or
the <OBJECT> tag.

The World Wide Web Consortium — the good folks who define the HTML
specifications — have deprecated the <APPLET> tag, which means they’ve
suggested that browsers begin providing support for embedded applets
(and other types of multimedia, such as plug-ins) through the <OBJECT> tag
instead of the <APPLET> tag. However, support for the <OBJECT> tag has
been slow to come. As I write this book, only Internet Explorer versions 5
and 6 support embedding applets with the <OBJECT> tag (which means that
using the <OBJECT> tag to embed applets prevents users running any
browser but Internet Explorer 5 or 6 from seeing that applet). So in the
future, you may use the <OBJECT> tag to embed applets in Web pages, but
for now, you can keep using the <APPLET> tag. For detailed information on
the <OBJECT> tag, visit www.w3.0rg/TR/REC-htm140/struct/objects.
htm1#h-13.

Inserting Applets with the <APPLET> Tag

You use the HTML <APPLET> tag to embed Java applets in Web pages.

In this section, I show you the syntax for the <APPLET> tag, including an
explanation of each tag element. I've indicated which elements are required
and which elements are optional.
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Java on the run

As | write this book, support for Java in one of
the most popular Web browsers — Internet
Explorer — is in transition. Microsoft recently
announced that it will no longer support or dis-
tribute its own Java virtual machine (software
that allows a Web browser to run Java pro-
grams). However, Java developers and users
can still download third-party Java software
development toolkits and virtual machines,
respectively, like the ones offered by Sun

Microsystems (java.sun.com),to create and
enjoy Java applets and applications. Microsoft
is encouraging developers to switch to Micro-
soft's own .NET development languages instead.
The upshot? Although Internet Explorer 6 sup-
ports Java, time will tell whether future versions
of Internet Explorer will continue to do so. For
more information about Java support in Internet
Explorer, check out www.microsoft.com/
mscorp/java.

As a reminder, tags are HTML elements that appear after a less-than (<)
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character. Attributes are other elements that reside inside the less-than and
greater-than characters (<>). Some attributes are mandatory. You’ll under-
stand why they are mandatory when you see them.

Looking at the <APPLET> tag syntax

To use the <APPLET> tag to embed applets in your pages, you need to
understand its syntax. Here is the complete syntax for the <APPLET> tag,
followed by an in-depth look at each of the <APPLET> tag’s attributes and a
bare-bones example of the <APPLET> tag in action:

<APPLET
CODEBASE = "codebaseURL"
ARCHIVES = "archivesList"

CODE = "appletFile" ...or...
"serializedApplet”

ALT = "alternateText"

NAME = "appletInstanceName'

WIDTH = "pixels”

HEIGHT = "pixels”

0BJECT =

ALIGN = "alignment"

VSPACE = "pixels"”

HSPACE = "pixels"
>
<PARAM NAME = "appletAttributel” VALUE = "value">
<PARAM NAME = "appletAttribute2" VALUE = "value">

Defaul tHTMLText
</APPLET>
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The only required attributes associated with the <APPLET> tag are CODE,
WIDTH, and HEIGHT. Read the following sections for details about these and
all the other optional attributes.

CODEBASE = “codebaseURL”

This optional attribute specifies the base URL of the applet — the directory
on the server that contains the applet’s code. If you don’t specify the
CODEBASE attribute, the Web page’s URL is used. You use CODEBASE =
codebaseURL only when the applet doesn’t reside in the same directory

as the HTML file.

ARCHIVES = “archivesList”

ARCHIVES = archivesList is an optional attribute that describes one or
more archives containing classes and other resources (images and sound,
for example) that will be “preloaded.” Archives provide a way of reducing
download time.

CODE = “appletFile”

CODE = appletFile specifies the name of the compiled applet file you
want to embed (the . class file). This file is relative to the CODEBASE base
URL of the applet. Either CODE or 0BJECT (see the next section) must be
defined for every <APPLET> tag.

OBJECT = “serializedApplet”

This attribute specifies the name of a file containing a serialized representa-
tion of an applet. (Serialized files are non-executable files that have been
“flattened” — in other words, reformatted and optimized for storing on disk
and transferring across networks.) You must specify a value for either the
CODE attribute (see the preceding section) or the OBJECT attribute. The seri-
alized applet will be deserialized when it is downloaded. The applet’s
init() method will not be invoked, but its start () method will. This sce-
nario differs from the CODE attribute, in which the applet’s init () method
is called before the start () method. Attributes valid when the original
object was serialized are not restored.

ALT = “alternateText”

This optional attribute specifies any text that should be displayed if the
browser understands the <APPLET> tag but can’t run Java applets. It’s like
the ALT attribute associated with an <IMG> tag, which you may be familiar
with if you work with HTML.
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NAME = “appletlnstanceName”

This optional attribute specifies a name for the applet instance, which
makes it possible for scripting code and other applets on the page to find
(and communicate with) each other. You don’t need to use this attribute
unless you plan to communicate with an applet.

WIDTH = “pixels” and HEIGHT = “pixels”

These required attributes determine the width and height (in pixels) of the
applet display area, not counting any windows or dialog boxes that the
applet may create.

ALIGN = “alignment”

This optional attribute specifies the alignment of the applet. The possible
values of this attribute are the same as those for the <IMG> tag: Teft,
right, top, texttop, middle, absmiddle, baseline, bottom,
absbottom. You can experiment with these values to see which combination
works best with your applets.

USPACE = “pixels” and HSPACE = “pixels”

These attributes are optional. You can use VSPACE to specify the number
of pixels above and below the applet, and HSPACE specifies the number of
pixels on either side of the applet. You treat these attributes the same way
as you do the <IMG> tag’s VSPACE and HSPACE attributes.

The Applet parameter tag

You use the following syntax to specify one or more (optional) applet-
specific parameters:

"value">
"value">

<PARAM NAME
<PARAM NAME

"appletAttributel" VALUE
"appletAttribute2" VALUE

Applets can retrieve their parameters with the getParameter () method.
Remember that <PARAM> tags can appear only in between <APPLET> and
</APPLET> tags. Also note a <PARAM> tag’s NAME attribute should be unique.

How do you know if you need to specify a parameter (or two or three) for
any given applet? Simple: The creator of the applet tells you. Whether you
download a free applet or purchase a commercial applet, the developer who
created the applet describes the applet’s specifications, or specs — how
many parameters and what their names are; what methods the applet sup-
ports and how to call those methods; and so on.
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DefaultHTMLtext

You can insert text between the opening and closing <APPLET> tags to be
displayed as the default message if the object can’t be displayed by the
browser.

Placing an applet on a page
using the <APPLET> tag

The following HTML code places an applet on a Web page using the <APPLET>
tag. The applet lists phone numbers, which are stored in a file on the server.
The width and height of this applet are 400 and 500 pixels, respectively. An
applet parameter specifies the name of a file on the server containing the tele-
phone numbers so that an HTML author can easily change the filename with-
out bothering a Java programmer. Users who aren’t running a Java-enabled
browser (or who have Java support turned off in their Java-enabled browsers)
see a helpful message in place of the Java applet.

<APPLET CODE = "PhoneBook.class" WIDTH = "400" HEIGHT =
"500">

<PARAM NAME = "index" VALUE = "personal.dat">

CCENTER><HI>NOTICE</H1></CENTER>

<B>This page contains a Java applet. Your browser is either
not capable of executing Java applets or you have that
option turned off. Please obtain a Java enabled browser
or turn on execution of Java.</B>

</APPLET>

Adding additional HTML statements that non-Java-enabled browsers can
display is good programming practice. You do this by inserting the text in
HTML tags within the <APPLET> tags as shown in the preceding code. If a
visitor has a Java-enabled browser, his or her browser ignores all HTML tags
that appear between the <APPLET> and </APPLET> tags and thus doesn’t
display the alternate text. Non-Java-enabled browsers, however, ignore all
the Java-related tags such as <APPLET> and its attributes (because they
don’t understand the tags) and display any additional HTML tags.

You can download free example HTML files and utility applets from Sun
Microsystems by pointing your browser to java.sun.com/openstudio/
index.html.

Inserting Applets with the <OBJECT> Tag

You can use the HTML <0BJECT> tag to embed Java applets in Web pages.

In this section, I show you the syntax for the <OBJECT> tag, including an
explanation of each tag element. The optional elements appear in regular
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typeface, and element values you must supply appear in italics. Mandatory
elements appear in bold.

Tags are HTML elements that appear after a less-than (<) character.
Attributes are other elements that reside inside the less-than and greater-
than characters (<>). Some attributes are mandatory. You’ll understand why
they are mandatory when you see them.

Looking at the <OBJECT> tag syntax

To use the <OBJECT> tag to embed applets in your pages, you need to
understand the syntax of the <OBJECT> tag. Here is the complete syntax for
the <OBJECT> tag, followed by an in-depth look at each of the <OBJECT>
tag’s attributes:

<OBJECT
ALIGN = "alignment"
ARCHIVE = "archiveslList"
CLASSID = "URL"
CODEBASE = "codebaseURL"

CODETYPE = "codetype"
DATA = "dataURL"
DECLARE

HEIGHT = "pixels"
HSPACE = "pixels"
NAME = "objectInstanceName"
STANDBY = "message"
TYPE = "datatype"
USEMAP = "URL"

VSPACE = "pixels"
WIDTH = "pixels"

>
<PARAM NAME = "objectAttributel" VALUE = "value">
<PARAM NAME = "objectAttribute2" VALUE = "value">

DefaultHTMLText
</OBJECT>

The only required attributes associated with the <OBJECT> tag are CLASSID,
WIDTH, and HEIGHT. Read the following sections for details about these and
all the other optional attributes.

ALIGN = “alignment”

This optional attribute specifies the alignment of the object. The possible
values of this attribute are Teft, center, right, texttop, middle,
textmiddle, baseline, and textbottom.
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ARCHIVE = “archivesList”

ARCHIVE = archiveslist is an optional attribute that describes one or

more URLs pointing to classes and other resources (images and sound, for
example) that must be preloaded before the object can be displayed. If the
URL is relative, you must provide a base URL using the CODEBASE attribute.

CLASSID = “URL”

CLASSID = "URL" specifies the name of the compiled object file you want
to embed. If the URL is relative, you must provide a base URL using the
CODEBASE attribute.

CODEBASE = “codebaseURL”

This optional attribute specifies the base URL of the object — the directory
on the server that contains the object code. If you don’t specify the
CODEBASE attribute, the Web page’s URL is used. (In other words, you use
CODEBASE = codebaseURL when the object doesn’t reside in the same
directory as the HTML file.)

CODETYPE = “codetype”

CODETYPE = "codetype" specifies the data format, or MIME (short for Multi-
Purpose Internet Mail Extension) type of the object. If you don’t specify a
value for CODETYPE, the browser determines the object’s type at runtime.

DATA = “datalRL”

DATA = "dataURL" specifies the URL of the data file associated with the
object, if any. If the URL is relative, you must provide a base URL using the
CODEBASE attribute.

DECLARE

The DECLARE attribute is a Boolean value that, if present, declares an object
without instantiating it.

NAME = “objectlnstanceName”

This optional attribute specifies a name for the object instance. Specifying a
value for the NAME attribute makes scripting code and other objects on the
page to find (and communicate with) the object possible.

STANDBY = “message”

STANDBY = "message" specifies an optional message to display while the
object is loading.
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TYPE = “datatype”

TYPE = "datatype" specifies the data format, or MIME (short for Multi-
Purpose Internet Mail Extension) type, of the data associated with an object.
(You associate data with an object by specifying a value for the DATA attrib-
ute.) If you don’t specify a value for TYPE, the browser determines the
object’s data type at runtime.

USEMAP = “URL”

USEMAP = "URL" specifies an image map to be used with the object.

WIDTH = “pixels” and HEIGHT = “pixels”

These required attributes determine the width and height (in pixels) of the
applet display area, not counting any windows or dialog boxes that the
applet may create.

USPACE = “pixels” and HSPACE = “pixels”

These attributes are optional. You can use VSPACE to specify the number of
pixels above and below the applet, and HSPACE specifies the number of
pixels on either side of the applet. You treat these attributes the same way
as you do the <IMG> tag’s VSPACE and HSPACE attributes.

DefaultHTML Text

You can insert text between the opening and closing <OBJECT> tags to be
displayed as the default message if the object can’t be displayed by the
browser.

The parameter tag

You use the following syntax to specify one or more (optional) object-
specific parameters:

"value">
"value">

<PARAM NAME
<PARAM NAME

"objectAttributel" VALUE
"objectAttribute2" VALUE

<PARAM> tags can appear only in between the <OBJECT> and </0BJECT>
tags. Also note a <PARAM> tag’s NAME attribute should be unique.

Placing an applet on a page
using the <OBJECT> tag

The following HTML code places an animation applet on a Web page using
the <OBJECT> tag. The width and height of this applet are 372 and 200 pixels,
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respectively. Users whose browsers can’t, for whatever reason, display this
applet see a helpful message in place of the Java applet.

<OBJECT CLASSID="clsid:8E27C92B-1264-101C-8A2F-040224009C02"
WIDTH="372" HEIGHT="200>

This page contains a Java applet. Your browser is either not
capable of executing Java applets or you have that option
turned off. Please obtain a Java enabled browser, turn on
execution of Java, or contact our Webmaster.

</0BJECT>

Understanding Applet Security

Some of Java’s critics have called applets a laboratory for viruses. Think of
some of the obvious hacks that an unscrupulous Java programmer could
perpetrate, these critics say: retrieving password files, deleting files, filling
an unsuspecting surfer’s hard drive with useless data, compromising a fire-
wall. Yikes!

Fortunately, none of these security breaches (including other, more subtle
hacks) is possible because applet security restricts untrusted applets —
applets that aren’t digitally signed by a trusted source. If applet security
were not as tight as it is, Java would have died before it ever saw its first
Web server.

Basically, this is how digital certificates work: Imagine that Company X
applies for, receives, and installs a digital certificate from a digital certificate
authority, such as VeriSign, Inc. (www.verisign.com). This certificate —
software that uses a public key obtained separately at runtime from the
granting certificate authority — identifies Company X’s applets as originat-
ing from Company X’s Web server. When users begin to download an applet,
they’re automatically informed (via their browsers) that Company X is on
file with the digital certificate authority; then they’re given the option of
downloading the applet or banning it outright from their browsers.

An applet must overcome several hurdles before it can be executed on a
remote machine. The class loader, the security manager, and the virtual
machine itself (all of which are implemented in a Java-supporting Web
browser) are what allow good to triumph over evil, order over chaos, the
very survival of humanity! Well, maybe not the survival of humanity, but you
get the picture.

The following list details operations that untrusted applets can’t perform:

4 Access the local file system, including reading, writing, deleting, renam-
ing, or obtaining file information.
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4 Execute native code on the local machine.

4+ Create a network connection to any computer other than the machine
from which the applet was loaded.

4+ Listen for or accept socket connections from any port (in other words,
transmit or accept data from some other computer).

4+ Create a frame or dialog box without a visible warning indicating the
untrusted nature of the applet that created the frame or dialog box.

4+ Define system properties.

4+ Invoke System.exit () (in other words, shut down the user’s
machine).

4 Load dynamic Java class libraries using 1oad() or 1ToadLibrary ()
(in other words, load and run other malicious applets under the covers).

4+ Create or manipulate any thread that is not part of the same thread-
group as the applet itself.

4+ CreateaClassloader or SecurityManager object (objects responsi-
ble for maintaining Java-related security).

4+ Define any of the “Factories,” such as ContentHandlerFactory,
SockImplFactory, or URLStreamFactory, responsible for creating
data transmission mechanisms and thus bypass built-insecurity.

Creating Your Own Java Applets

Can’t find a Java applet on the Web that does exactly what you want it to
do? You can create your own Java applet! Creating your own Java applets is
relatively difficult (unless you happen to be a computer programmer), but
it’s not impossible.

Due to space constraints, in this section I give you an overview of how to go
about programming in Java — just enough to whet your appetite. For more
in-depth information, two other books can give you the complete story: See
Beginning Programming with Java For Dummies or Java 2 For Dummies, both
by Barry Burd (published by Wiley Publishing, Inc.).

What you need to create Java applets

If you have a Web browser such as Netscape Navigator or Microsoft Internet
Explorer installed on your computer, you can execute Java applets; that’s
because a Java execution environment called the Java virtual machine, or
JVM, is built into Netscape Navigator, and you can download and add third-
party JVMs, such as the one available from Sun Microsystems, to Internet
Explorer.
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Dispelling the portability myth

One of the characteristics for which Java is
often lauded is its ability to run unchanged on
computers ranging from tiny handhelds to
massive supercomputers — in other words, its
portability. (Portability is often referred to as
cross-platform capability, because portable
code can execute on, or across, many different
hardware/software platforms.)

Although Java does strive to be a portable lan-
guage in theory, it often falls short in practice.
Here's why.

Java compilers and interpreters do their best to
translate Java source code into bytecode, and
bytecode into machine code, respectively. But
how they do this translation is dependent on at
least a couple of variables:

v The target platform: IBM personal comput-
ers, Sun workstations, and Macintosh note-
books are different — period. As in human
languages, some things just don't translate.
So if you're trying to accomplish a task

using Java that the underlying operating
system on one computer just can’t handle,
what language you’re developing in doesn’t
matter; you're out of luck.

v~ The developers creating the compilers and
interpreters: Different companies create
and distribute different Java compilers and
interpreters. Sun established a Java stan-
dard and makes that standard available to
any companies who want to license it.
Human nature being what itis, however, the
end result— intentional or not— is that dif-
ferences exist between Java compilers and
runtime implementations.

The upshot? Whereas creating cross-platform
programs using Java is easier than probably
any other language out there, it's not a given. In
other words, programming in Java doesn't
guarantee portability; it just makes creating
portable programs easier.

Before you can create Java programs of your own, however, you need more
than just a Java-supporting browser. You need to have the following soft-
ware installed on your computer:

4+ A copy of the Java development kit: The Java SDK (which stands for
Software Development Kit) contains all of the following:

e The Java class libraries (prebuilt Java classes, or APIs) and language
support you need to create Java applets

e The compiler (called javac) you need to turn Java source files into
bytecode

e A Java runtime environment (called appletviewer) you use to turn
compiled bytecode into machine language — in other words, to test
the applet
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You can download a free copy of the Java 2 SDK, standard edition (the
latest Java development kit at the time of this writing) from java.sun.
com/j2se.

A text or graphical editor: All Java programs begin as Java source
code, which is plain text you save using the . java file extension. So,
before you can create a Java program, you need to have a text editor
installed on your machine. Depending on your preference, you can use
a plain text editor (such as the Notepad application that comes bundled
with Windows), a text editor designed specifically for programmers
(such as TextPad), or an integrated development environment (IDE)
designed specially for Java programmers. IDEs (such as Borland’s
JBuilder and Sun’s ONE Studio) combine a graphical, drag-and-drop
editor with built-in code snippets, a Java compiler, and a code checker.
Java IDEs help you create Java applets much more quickly than you can
by typing Java code into a text editor and compiling that code into exe-
cutable applet form.

From source to executable code: A look
at the applet development life cycle

Good Java programming practice demands that you create an applet file,

test it, and make changes as necessary until your applet executes error-free.
Specifically, after you have the Java development tools I describe in the pre-

vious section installed on your computer, here’s an outline of the basic
steps you need to follow:

You can find documentation and tips for creating Java applets on the Sun
Web site, at java.sun.com/j2se.

1. Create an applet source file.

You can use the editor of your choice to create a Java applet source file.

Just be sure to save that file using the . java extension. For example,
the name of an applet source file might look like this:

myFirstProgram.java

2. Compile the source file.

You compile a Java source file using the javac compiler. For example,

you type the following at a command line prompt to compile the
myFirstProgram. java file:

javac myFirstProgram.java
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The compiler generates a new (compiled) file bearing the same file-
name, only with a . class file extension instead of the . java extension,
like this:

myFirstProgram.class
3. Execute, or test, the compiled file.

To test a compiled applet, you create an HTML file and include the name
of the applet as part of the <APPLET> (or <OBJECT>) tag. I describe how
to do this in the section, “Inserting Applets into HTML: An Overview,”
earlier in this chapter.
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Chapter 1: JavaScript
Syntax and Keywords

In This Chapter

v Exploring JavaScript’s role in Web development

v Adding JavaScript scripts to HTML files

1+ Understanding JavaScript security issues

v Getting acquainted with the document object model

v+ Unraveling JavaScript syntax and expressions

Fis chapter is a JavaScript grammar book, dictionary, and thesaurus all
rolled into one. In this chapter, you find the nuts-and-bolts mechanics
of writing JavaScript statements — from selecting syntax and keywords

to declaring variables and defining and calling functions. You also find an
overview of all the Web page components, called objects, that you can work
with in JavaScript.

A Quick Overview of the JavaScript
Scripting Language

Using JavaScript, you can create cool interactive features — such as
rollovers, clickable images, and smart forms — and add them to your plain
old static HTML pages.

Like all scripting languages, JavaScript is a special kind, designed to give
folks easy access to prebuilt components. In the case of JavaScript, those
prebuilt components are all the objects that make up a Web page (or, more
accurately, a Web document): links, images, HTML form elements, browser
and configuration details, for example. Together, these objects are referred
to as the document object model. When you create a JavaScript script, you
create lines of JavaScript code that access, change, and perform actions
based on one or more of these objects.
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Support for JavaScript, including the JavaScript interpreter that executes
JavaScript code, is built into two Web browsers: Microsoft Internet Explorer
and Netscape Navigator. If you have some kind of text editor and either of
these two browsers installed on your computer, you have everything you
need to create and run JavaScript scripts.

Web development tools such as Dreamweaver (included on the companion
CD) help you begin creating JavaScript scripts quickly and easily — without
having to learn the nitty-gritty JavaScript programming details.

Technically, the JavaScript language comes in three versions: a client-side
version that runs inside Web browsers, a server-side version that runs
inside Netscape Web servers, and a subset of both versions called the core
version. The client-side version, which is by far the most popular, is the ver-
sion [ describe in this book. If you’re interested in finding out more about
the server-side versions, you can visit devedge.netscape.com/library/
manuals/.

Adding Scripts to HTML Files

You add JavaScript to HTML pages in one of two ways:

4+ Insert JavaScript statements directly into HTML files: Use the HTML
<SCRIPT>...</SCRIPT> tags, as shown in the following code:

<HTML>
<HEAD>

<SCRIPT LANGUAGE="JavaScript">
(Your JavaScript statements go here.)
</SCRIPT>

</HEAD>
</HTMLD
4 Assign JavaScript statements to an event handler: Examples are

onClick and onChange, as shown in the following code. (You find out
all about event handlers in Book VI, Chapter 6.)

<INPUT TYPE="TEXT" NAME="firstName" SIZE="25"
onBlur="if (lexists(this.value)) { alert('Please
enter a first name'); }">

About JavaScript Security

Because JavaScript runs entirely inside a Web browser (both Netscape
Navigator and Microsoft Internet Explorer provide JavaScript support),
JavaScript’s ability to permit security breaches is extremely limited.
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Basically, JavaScript can perform only those functions that a Web browser
allows it to perform.

Specifically, here’s what JavaScript can’t do:

4 Access your computer files. JavaScript can’t write or delete files, other
than cookies, on your computer, which means JavaScript can’t destroy
data and can’t plant viruses. (Cookies are special files that browsers can
place on your computer when you surf the Web. The browser strictly
controls the size of these tiny files — as well as how many and where
they can be placed, for example.)

4 Open its own direct connection. Browsers control the receiving and
sending of data from a client computer to a Web server, and JavaScript
can’t override this control. All JavaScript can do is trigger a few browser
events. For example, you can use a JavaScript statement to load a Web
page or send HTML form data to a Web server — but the actual receiv-
ing and sending is securely controlled by the browser, not by JavaScript.

Security threats surrounding JavaScript have cropped up from time

to time — usually when a brand-spanking-new version of a browser is
released. Technically, these security threats aren’t JavaScript-related;
they’re browser-related. And, fortunately, these security “holes” are usually
patched very quickly.

The only security threat JavaScript can pose is the insecure transfer of pri-
vate data via signed scripts — and all signed scripts are administered and
controlled by the Web browser. Signed scripts, which are supported in
Netscape Navigator, allow a JavaScript developer to request certain privi-
leges from the end user at run time — privileges such as the ability to send
HTML form data without the end user’s knowledge and other questionable
(from a security standpoint) actions. These privileges can be exercised only
with the end user’s explicit permission, however. When Navigator attempts
to run a signed script, a pop-up message appears asking the end user
whether he or she agrees to grant those special privileges.

For more information on script signing and security in Netscape Navigator,
visit devedge.netscape.com/central/security/.

Internet Explorer takes a different approach to JavaScript security than
Navigator. In Internet Explorer, users can turn scripting support on or off for
certain specified “zones,” but they can’t grant specific privileges via signed
scripts the way they can with Navigator. (To turn scripting support on or off
in Internet Explorer, choose Toolst>Internet Options and then click the
Security tab. In the Security panel, select a zone; then click the Custom
Level button to display the security settings for that zone. In the Security
Settings panel, scroll down until you see Active Scripting; then choose the
Disable option, next to Active Scripting, to turn off scripting support.)

Book VI
Chapter 1
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You can work with three main kinds of objects in JavaScript:

4+ Objects that make up a Web page (the document object model)
4 Built-in data types
4 Utility objects

Read the following section for a quick rundown of each object type and the
differences among them.

You can also create your own custom objects by using the new operator,
which you see at work in Book VI, Chapter 5.

Built-in data types and utility objects are sometimes referred to collectively
as core objects. But because you use them in very different ways, I present
them here separately.

The document object model

With the exception of custom objects you create using the JavaScript new
operator (which I discuss in detail in Book VI, Chapter 5), all the document
objects you work with in JavaScript are created by either HTML statements
or the browser itself. After the objects exist, you can use JavaScript to exam-
ine these objects, change them, perform calculations on them — whatever
your heart desires.

The document object model is a hierarchy, which means that some objects
contain other objects. For example, a Web page, or document, can contain
an HTML form, which in turn can contain a text field. So, to access an object
(such as a text field) in JavaScript, you must type the entire hierarchy, from
the top down, separated with periods like this:

document.someForm.someTextField

Table 1-1 describes some of the most common objects you can work with in
JavaScript.

Unfortunately, the Internet Explorer and Navigator object models differ
slightly. (They’re even named differently: Microsoft calls its document
object model DHTML, short for dynamic HTML.) What’s worse, these object
models change a bit (and grow larger!) with each new browser release. The
objects described in Table 1-1 are supported by both browsers at the time
of this writing. To keep up to date with the latest information on the Internet
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Explorer and Navigator complete document object models, respectively,
visit msdn.microsoft.com/workshop/author/dhtml/reference/
objects.asp and devedge.netscape.com/Tibrary/manuals/2000/
javascript/1.5/quide/.

Table 1-1 The Document Object Model
Object Creating HTML Tag JavaScript Syntax
window None (it's a given) window (optional)
document <HTML> .. .</HTML> document
Tink SA> L KTAS document.Tinks[0] Book VI
anchor <A> . KA document.Tinks[0] Chapter 1
applet CAPPLET>...</APPLET>  document.applets[0] o
area <MAP> .. . <AREA>. .. document.someArea - 2
</MAP> 2o
==
form <FORM>...</FORM> document.someForm Eﬁ'
button <INPUT TYPE="button"> document.someForm.someButton sY
[——]
checkbox  <INPUT TYPE= document.someForm.someCheckbox @ g
"checkbox">

fileUpload